TI.ZPI1

Texas Instruments ZPI Library
TI.ZPI1 Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AF_INCOMINGDATA_INDICATION | This command is used by the device to indicate a received packet.
Public class | AF_INIT_REQUEST | This command enables the tester to initialize the target AF.
Public class | AF_INIT_RESPONSE | Response for AF_INIT_REQUEST
Public class | AF_REGISTER_REQUEST | This command enables the tester to register an application's endpoint description
Public class | AF_REGISTER_RESPONSE | Response for AF_REGISTER_REQUEST
Public class | AF_SENDMSG_CONFIRM | This command contains status of a AF_SENDMSG_REQUEST
Public class | AF_SENDMSG_REQUEST | This command is used to build and send a data packet.
Public class | AF_SENDMSG_RESPONSE | Response for AF_SENDMSG_REQUEST
Public class | APSDE_DATA_CONFIRMATION | This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.
Public class | APSME_BIND_RESPONSE | Response for APSME_BIND
Public class | NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
Public class | NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
Public class | NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
Public class | NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
Public class | NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
Public class | NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
Public class | NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
Public class | NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
Public class | NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
Public class | NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
Public class | NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
Public class | NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
Public class | NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
Public class | NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
Public class | NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
Public class | NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
Public class | NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
Public class | NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
Public class | NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
Public class | NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
Public class | NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
Public class | NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
Public class | NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
Public class | NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
Public class | NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
Public class | NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
Public class | NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
Public class | NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
Public class | NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
Public class | NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
Public class | NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
Public class | NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
Public class | NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
Public class | NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
Public class | NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
Public class | NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
Public class | NLME_SYNC_REQUEST | This primitive allows the next higher layer to synchronize or extract data from its ZigBee coordinator or router
Public class | NLME_SYNC_RESPONSE | Response for NLME_SYNC_REQUEST
Public class | NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
Public class | NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
Public class | NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
Public class | NWK_COMM_STATUS_INDICATION | This function reports a comm status error
Public class | NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
Public class | NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
Public class | NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
Public class | NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
Public class | NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
Public class | NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
Public class | NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
Public class | NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
Public class | NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
Public class | NWK_START_CONFIRMATION | This function reports the success of the start request.
Public class | NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon
Public class | SYS_APP_MSG | Use this message to send raw data to an application.
Public class | SYS_APP_MSG_RESPONSE | Response for SYS_APP_MSG
Public class | SYS_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
Public class | SYS_CALLBACK_SUBSCRIBE_RESPONSE | Response for SYS_CALLBACK_SUBSCRIBE
Public class | SYS_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
Public class | SYS_GET_DEVICE_INFO_RESPONSE | Response for SYS_GET_DEVICE_INFO
Public class | SYS_GET_EXTENDED_ADDRESS | Read the extended address from the device.
Public class | SYS_GET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_GET_EXTENDED_ADDRESS
Public class | SYS_GET_NV | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
Public class | SYS_GET_NV_INFO | Use this message to get the NV information.
Public class | SYS_GET_NV_INFO_RESPONSE | Response for SYS_GET_NV_INFO
Public class | SYS_GET_NV_RESPONSE | Response for SYS_GET_NV
Public class | SYS_GET_TIME_ALIVE | Use this message to get board's time alive.
Public class | SYS_GET_TIME_ALIVE_RESPONSE | Response for SYS_GET_TIME_ALIVE
Public class | SYS_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
Public class | SYS_KEY_EVENT_RESPONSE | Response for SYS_KEY_EVENT
Public class | SYS_LED_CONTROL | Use this message to control LEDs on the board.
Public class | SYS_LED_CONTROL_RESPONSE | Response for SYS_LED_CONTROL
Public class | SYS_PING | This command is used to check for a device
Public class | SYS_PING_RESPONSE | Response for SYS_PING
Public class | SYS_RAM_READ | This command is used by the tester to read a single memory location in the target RAM. THe command accepts an address value and returns the memory value present in the target RAM at that address.
Public class | SYS_RAM_READ_RESPONSE | Response for SYS_RAM_READ
Public class | SYS_RAM_WRITE | This command is used by the tester to write to a particular location in the target RAM. The command accepts an address location and a memory value. The memory value is written to the address location in the target RAM
Public class | SYS_RAM_WRITE_RESPONSE | Response for SYS_RAM_WRITE
Public class | SYS_RESET | This command is sent by the tester to the target to reset it
Public class | SYS_RESET_RESPONSE | Response for SYS_RESET. This response is sent from the target device or serial bootloader after the requested reset is complete.
Public class | SYS_SET_CHANNELS | Use this message to set the channels.
Public class | SYS_SET_CHANNELS_RESPONSE | Response for SYS_SET_CHANNELS
Public class | SYS_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
Public class | SYS_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
Public class | SYS_SET_EXTENDED_ADDRESS | Set the 64-bit extended address.
Public class | SYS_SET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_SET_EXTENDED_ADDRESS
Public class | SYS_SET_NV | This command is used by the tester to write to a particular location in non-volatile memory. The command accepts an address location and a memory value. The memory value is written to the address location in the target.
Public class | SYS_SET_NV_RESPONSE | Response for SYS_SET_NV
Public class | SYS_SET_PANID | Use this message to set PANID.
Public class | SYS_SET_PANID_RESPONSE | Response for SYS_SET_PANID
Public class | SYS_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
Public class | SYS_SET_PRECONFIG_KEY_RESPONSE | Response for SYS_SET_PRECONFIG_KEY
Public class | SYS_SET_SECURITY_LEVEL | Use this message to set the security level.
Public class | SYS_SET_SECURITY_LEVEL_RESPONSE | Response for SYS_SET_SECURITY_LEVEL
Public class | SYS_SET_SECURITY_MODE | Use this message to get the NV information.
Public class | SYS_SET_SECURITY_MODE_RESPONSE | Response for SYS_SET_SECURITY_MODE
Public class | SYS_STRING_RESPONSE | Debug message sent by device
Public class | SYS_VERSION | Ask for the device's version string.
Public class | SYS_VERSION_RESPONSE | Response for SYS_VERSION
Public class | USERTEST_REQUEST | This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).
Public class | USERTEST_RESPONSE | Response for USERTEST_REQUEST
Public class | ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
Public class | ZB_ALLOW_BIND_CNF |
Public class | ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
Public class | ZB_BIND_CNF | (zb_BindConfirm)
Public class | ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
Public class | ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
Public class | ZB_FIND_DEV | Search for a device's short address given its IEEE address.
Public class | ZB_FIND_DEV_CNF | (zb_FindDeviceConfirm)
Public class | ZB_FIND_DEV_RSP | Response for ZB_FIND_DEV
Public class | ZB_GET_DEV_INFO | Reads current device infromation.
Public class | ZB_GET_DEV_INFO_RSP | Response for ZB_GET_DEV_INFO
Public class | ZB_PERMIT_JOIN | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
Public class | ZB_PERMIT_JOIN_RSP | Response for SYS_PERMIT_JOIN
Public class | ZB_RCV_DATA_IND | (zb_ReceiveDataIndication)
Public class | ZB_READ_CFG | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
Public class | ZB_READ_CFG_RSP |
Public class | ZB_SEND_DATA | Send a data packet to another device (zb_SendDataRequest).
Public class | ZB_SEND_DATA_CNF | (zb_SendDataConfirm)
Public class | ZB_SEND_DATA_RSP | Response for ZB_SEND_DATA
Public class | ZB_START_CNF | (zb_StartConfirm)
Public class | ZB_START_REQ | Starts the ZigBee stack (zb_StartRequest).
Public class | ZB_START_REQ_RSP | Response for ZB_START_REQ
Public class | ZB_SYS_RESET | Reboot the device (zb_SystemReset)
Public class | ZB_WRITE_CFG | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
Public class | ZB_WRITE_CFG_RSP | Response for ZB_WRITE_CFG
Public class | ZDO_ACTIVEENDPOINT_REQUEST | This command is generated to request a list of active endpoint from the destination device.
Public class | ZDO_ACTIVEENDPOINT_RESPONSE | Response for ZDO_ACTIVEENDPOINT_REQUEST
Public class | ZDO_ACTIVEENDPOINT_RESPONSECB | This callback message is in response to the ZDO Active Endpoint Request.
Public class | ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST | This command will tell the ZDO to request an End Device Bind. The ZDO will send the message to the Zigbee coordinator based on the information found in the AF Endpoint description for the passed in endpoint.
Public class | ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE | Response for ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST
Public class | ZDO_AUTOFINDDESTINATION_REQUEST | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
Public class | ZDO_AUTOFINDDESTINATION_RESPONSE | Response for ZDO_AUTOFINDDESTINATION_REQUEST
Public class | ZDO_BIND_REQUEST | This command is generated to request a Bind
Public class | ZDO_BIND_RESPONSE | Response for ZDO_BIND_REQUEST
Public class | ZDO_BIND_RESPONSECB | This callback message is in response to the ZDO Bind Request
Public class | ZDO_COMPLEXDESCRIPTOR_REQUEST | This command is generated to request for the destination device's complex descriptor
Public class | ZDO_COMPLEXDESCRIPTOR_RESPONSE | Response for ZDO_COMPLEXDESCRIPTOR_REQUEST
Public class | ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
Public class | ZDO_END_DEVICE_ANNCE_RESPONSE | Response for ZDO_END_DEVICE_ANNCE_REQUEST
Public class | ZDO_ENDDEVICEBIND_REQUEST | This command is generated to request an End Device Bind with the destination device
Public class | ZDO_ENDDEVICEBIND_RESPONSE | Response for ZDO_ENDDEVICEBIND_REQUEST
Public class | ZDO_ENDDEVICEBIND_RESPONSECB | This callback message is in response to the ZDO End Device Bind Request
Public class | ZDO_IEEEADDRESS_REQUEST | This command will request a device's IEEE 64-bit address. You must subscribe to "ZDO IEEE Address Response" to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
Public class | ZDO_IEEEADDRESS_RESPONSE | Response for ZDO_IEEEADDRESS_REQUEST
Public class | ZDO_IEEEADDRESS_RESPONSECB | This callback message is in response to the ZDO IEEE Address Request.
Public class | ZDO_MATCHDESCRIPTOR_REQUEST | This command is generated to request a list of active endpoint from the destination device
Public class | ZDO_MATCHDESCRIPTOR_RESPONSE | Response for ZDO_MATCHDESCRIPTOR_REQUEST
Public class | ZDO_MATCHDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Match Description Request
Public class | ZDO_MGMT_BIND_REQUEST | This command is generated to request a Management Binding Table Request.
Public class | ZDO_MGMT_BIND_RESPONSE | Response for ZDO_MGMT_BIND_REQUEST
Public class | ZDO_MGMT_BIND_RESPONSECB | This callback message is in response to the ZDO Management Binding Table Request
Public class | ZDO_MGMT_DIRECT_JOIN_REQUEST | This command is generated to request a Management Direct Join Request
Public class | ZDO_MGMT_DIRECT_JOIN_RESPONSE | Response for ZDO_MGMT_DIRECT_JOIN_REQUEST
Public class | ZDO_MGMT_DIRECT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Direct Join Request.
Public class | ZDO_MGMT_LEAVE_REQUEST | This command is generated to request a Management Leave Request
Public class | ZDO_MGMT_LEAVE_RESPONSE | Response for ZDO_MGMT_LEAVE_REQUEST
Public class | ZDO_MGMT_LEAVE_RESPONSECB | This callback message is in response to the ZDO Management Leave Request.
Public class | ZDO_MGMT_LQI_REQUEST | This command is generated to request a Management LQI Request.
Public class | ZDO_MGMT_LQI_RESPONSE | Response for ZDO_MGMT_LQI_REQUEST
Public class | ZDO_MGMT_LQI_RESPONSECB | This callback message is in response to the ZDO Management LQI Request.
Public class | ZDO_MGMT_NWK_UPDATE_NOTIFYCB | This callback message is in response to the Mgmt NWK Update Request. Upon receiving the request, remote device shall determine from the contents of the ScanDuration parameter whether this request is an update to the apsChannelMask and nwkManagerAddr parameters, a channel change command, or a request to scan channels and report the results
Public class | ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
Public class | ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
Public class | ZDO_MGMT_NWKDISC_REQUEST | This command is generated to request a Management Network Discovery Request
Public class | ZDO_MGMT_NWKDISC_RESPONSE | Response for ZDO_MGMT_NWKDISC_REQUEST
Public class | ZDO_MGMT_NWKDISC_RESPONSECB | This callback message is in response to the ZDO Management Network Discovery Request
Public class | ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
Public class | ZDO_MGMT_PERMIT_JOIN_RESPONSE | Response for ZDO_MGMT_PERMIT_JOIN_REQUEST
Public class | ZDO_MGMT_PERMIT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
Public class | ZDO_MGMT_RTG_REQUEST | This command is generated to request a Management Routing Table Request.
Public class | ZDO_MGMT_RTG_RESPONSE | Response for ZDO_MGMT_RTG_REQUEST
Public class | ZDO_MGMT_RTG_RESPONSECB | This callback message is in response to the ZDO Management Routing Table Request.
Public class | ZDO_NETWORK_START_REQUEST | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
Public class | ZDO_NETWORK_START_RESPONSE | Response for ZDO_NETWORK_START_REQUEST
Public class | ZDO_NETWORKADDRESS_REQUEST | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
Public class | ZDO_NETWORKADDRESS_RESPONSE | Response for ZDO_NETWORKADDRESS_REQUEST
Public class | ZDO_NETWORKADDRESS_RESPONSECB | This callback message is in response to the ZDO Network Address Request.
Public class | ZDO_NODEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Node Descriptor of the destination device
Public class | ZDO_NODEDESCRIPTOR_RESPONSE | Response for ZDO_NODEDESCRIPTOR_REQUEST
Public class | ZDO_NODEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Node Descriptor Request.
Public class | ZDO_POWERDESCRIPTOR_REQUEST | This command is generated to inquire as to the Power Descriptor of the destination
Public class | ZDO_POWERDESCRIPTOR_RESPONSE | Response for ZDO_POWERDESCRIPTOR_REQUEST
Public class | ZDO_POWERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Power Descriptor Request.
Public class | ZDO_SIMPLEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
Public class | ZDO_SIMPLEDESCRIPTOR_RESPONSE | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
Public class | ZDO_SIMPLEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Simple Descriptor Request.
Public class | ZDO_SYSTEM_SERVER_DISC_REQUEST | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
Public class | ZDO_SYSTEM_SERVER_DISC_RESPONSE | Response for ZDO_SYSTEM_SERVER_DISC_REQUEST
Public class | ZDO_SYSTEM_SERVER_DISC_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
Public class | ZDO_UNBIND_REQUEST | This command is generated to request an UnBind
Public class | ZDO_UNBIND_RESPONSE | Response for ZDO_UNBIND_REQUEST
Public class | ZDO_UNBIND_RESPONSECB | This callback message is in response to the ZDO UnBind Request
Public class | ZDO_USERDESCRIPTOR_REQUEST | This command is generated to request for the destination device's user descriptor
Public class | ZDO_USERDESCRIPTOR_RESPONSE | Response for ZDO_USERDESCRIPTOR_REQUEST
Public class | ZDO_USERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO User Description Request.
Public class | ZDO_USERDESCRIPTOR_SET_REQUEST | This command is generated to request a User Descriptor Set Request
Public class | ZDO_USERDESCRIPTOR_SET_RESPONSE | Response for ZDO_USERDESCRIPTOR_SET_REQUEST
Public class | ZDO_USERDESCRIPTOR_SET_RESPONSECB | This callback message is in response to the ZDO User Descriptor Set Request.
Public class | ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
Public class | ZMAC_ASSOCIATE_RESPOND | This command is used to send (on behalf of the next higher layer) an association response message
Public class | ZMAC_ASSOCIATE_RESPOND_RESPONSE | Response for ZMAC_ASSOCIATE_RESPOND
Public class | ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
Public class | ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
Public class | ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
Public class | ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
Public class | ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
Public class | ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
Public class | ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
Public class | ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
Public class | ZMAC_INIT_RESPONSE | Response for ZMAC_INIT_REQUEST
Public class | ZMAC_ORPHAN_RESPOND | This command is used to send a response to the Orphan Indication message.
Public class | ZMAC_ORPHAN_RESPOND_RESPONSE | Response for ZMAC_ORPHAN_RESPOND
Public class | ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
Public class | ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
Public class | ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
Public class | ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
Public class | ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
Public class | ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
Public class | ZMAC_RX_ENABLE_REQUEST | This command contains timing information that tells the device when to enable or disable its receiver, in order to schedule a data transfer between itself and another device. The information is sent from the upper layers directly to the MAC sublayer.
Public class | ZMAC_RX_ENABLE_RESPONSE | Response for ZMAC_RX_ENABLE_REQUEST
Public class | ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
Public class | ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
Public class | ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
Public class | ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
Public class | ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
Public class | ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
Public class | ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon
Public class | ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST

Interfaces

 | Interface | Description
Public interface | IAF |
Public interface | IAPS |
Public interface | ICONFIRMATION |
Public interface | IINDICATION |
Public interface | INETWORK |
Public interface | IREQUEST |
Public interface | IRESPONSE |
Public interface | IRESPONSE_CALLBACK |
Public interface | ISIMPLEAPI |
Public interface | ISYSTEM |
Public interface | IUSERTEST |
Public interface | IZDO |
Public interface | IZMAC |

Structures

 | Structure | Description
NestedPublic structure | NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Pan Information. Used with NLME_NETWORKDISCOVERY_CONFIRMATION
NestedPublic structure | SYS_APP_MSG.BLIND_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST | Send this message to a Blind Node to request its configuration. The response to this request is the Blind Node Configuration (Cluster ID 6) message. This message doesn't have a body to the message (just cluster ID)
NestedPublic structure | SYS_APP_MSG.BLIND_NODE_REQUEST | Send this message to a Blind Node to request its location. The response to this message will be sent by the blind node when the location process is complete (which will take seconds). This message doesn't have a body to the message (just cluster ID)
NestedPublic structure | SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST | Send this message to a Reference Node to request its configuration. The response to this request is the Reference Node Configuration (Cluster ID 5) message. This message doesn't have a body to the message (just cluster ID)
NestedPublic structure | SYS_APP_MSG.REFERENCE_NODE_REQUEST | Send this message to a reference node to request its position information. In this request is the number of responses expected
NestedPublic structure | SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Used by Commissioner to assign Client status to a device and therefore to cause a new image to be downloaded to that device. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | This command causes the target device to enable the downloaded image. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | This command requests the target device to reset. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG.ZLMSGID_RESET_REQUEST | This command requests the target device to terminate all OAD activity and return to the idle state. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Response for ZLMSGID_SEND_DATA_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Response for ZLMSGID_SESSION_START_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Response for ZLMSGID_SESSION_TERM_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST | Used to determine images currently existing on a device. This is part of the Commissioner's enumeration process. Based on need each device may then be either a Client or a Server depending on current images on-board. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE | This message is sent out of the Blind Node in response to the "Bind Node Request" message. The blind node, upon receiving the request message, will send a "Reference Node Request" (radius 1 - broadcast) to its immediate neighbors and wait for responses. Use the Blind Node Configuration message to change the parameters used to generate this response message (ie. number of reference node response, collect time)
NestedPublic structure | SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE | This message is sent by a Reference Node in response to a "Reference Node Request" message. The number of time that this message is sent depends on the number request in the request. When multiple responses are request, the delay between responses are from 2-16 milliseconds
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE | Response for ZLMSGID_CLIENT_CMD_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE | Response for ZLMSGID_CODE_ENABLE_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE | Response for ZLMSGID_RESET_BOARD_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE | Response for ZLMSGID_RESET_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST | This command requests the target device to send a data packet. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST | Used to mark the beginning of a set of data transfer transactions and to establish Server status on the part of the target device. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST | Used to terminate a session and reset the OAD context of the target platform. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE | Response for ZLMSGID_STATUSQ_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | ZDO_MGMT_BIND_RESPONSECB.BindListItemClass | Contains information in a single item of a bind list
NestedPublic structure | ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass | Contains information in a single item of a network list
NestedPublic structure | ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass | Contains information in a single item of a network list

Enumerations

 | Enumeration | Description
NestedPublic enumeration | AF_INIT_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_REGISTER_REQUEST.APP_FLAGS | App flags
NestedPublic enumeration | AF_REGISTER_REQUEST.LATENCY_TYPE | Latency type
NestedPublic enumeration | AF_REGISTER_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_SENDMSG_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | APSDE_DATA_CONFIRMATION.APSDE_STATUS | Status code for APSDE responses
NestedPublic enumeration | APSDE_DATA_CONFIRMATION.BOOLEAN | True or False flag
NestedPublic enumeration | APSME_BIND_RESPONSE.NLME_STATUS | Status code for NLME response
Public enumeration | MESSAGE_ID | Contains SPI message ID's
NestedPublic enumeration | NLDE_DATA_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLDE_DATA_RESPONSE.NLDE_STATUS | Status code for NLDE response
NestedPublic enumeration | NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | NLME_DIRECTJOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_GET_REQUEST.NIB_ATTR | Network layer information base attributes
NestedPublic enumeration | NLME_GET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_JOIN_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_JOIN_INDICATION.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | NLME_JOIN_REQUEST.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | NLME_JOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_LEAVE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_LEAVE_INDICATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_LEAVE_REQUEST.BOOLEAN | True or False flag
NestedPublic enumeration | NLME_LEAVE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS | Status code for NLME response
NestedPublic enumeration | NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NLME_ORPHANJOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_PERMITJOINING_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_RESET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_SET_REQUEST.NIB_ATTR | Network layer information base attributes
NestedPublic enumeration | NLME_SET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_STARTROUTER_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_STARTROUTER_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_SYNC_INDICATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_SYNC_REQUEST.TRACK_BEACONS | Select track beacons or not
NestedPublic enumeration | NLME_SYNC_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_ASSOCIATE_INDICATION.CAPABILITIES | Capabilities bitfield
NestedPublic enumeration | NWK_ASSOCIATE_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.BOOLEAN | True or False flag
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_DATA_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_DATA_INDICATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_DATA_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_DATA_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON | Valid disassociation reason codes
NestedPublic enumeration | NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_ORPHAN_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_ORPHAN_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_POLL_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_PURGE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_SCAN_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_SCAN_CONFIRMATION.SCAN_TYPE | Scan type
NestedPublic enumeration | NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NWK_START_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT |
NestedPublic enumeration | SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE |
NestedPublic enumeration | SYS_APP_MSG.LOC_REQ_MESSAGE_ID | Message id for LOC_REQ_MESSAGE_ID
NestedPublic enumeration | SYS_APP_MSG.OAD_REQ_MESSAGE_ID | Message id for OAD_REQ_MESSAGE_ID
NestedPublic enumeration | SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT |
NestedPublic enumeration | SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID | Message id for LOC_RSP_MESSAGE_ID
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID | Message id for OAD_RSP_MESSAGE_ID
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE |
NestedPublic enumeration | SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION | Subscribe Action
NestedPublic enumeration | SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE | Device state
NestedPublic enumeration | SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE | Device type bitfield
NestedPublic enumeration | SYS_GET_NV_INFO_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | SYS_GET_NV_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_KEY_EVENT.BOOLEAN | True or False flag
NestedPublic enumeration | SYS_KEY_EVENT.KEY_EVENT | Key event
NestedPublic enumeration | SYS_KEY_EVENT_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_LED_CONTROL.LED_MODE | Mode of the LED
NestedPublic enumeration | SYS_LED_CONTROL.LED_NUM | The ID of the LED
NestedPublic enumeration | SYS_LED_CONTROL_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_PING_RESPONSE.CAPABILITIES | Capabilities bitfield
NestedPublic enumeration | SYS_RAM_READ_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_RAM_WRITE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_RESET.RESET_TYPE | Reset type
NestedPublic enumeration | SYS_RESET_RESPONSE.RESET_TYPE | Reset type
NestedPublic enumeration | SYS_SET_CHANNELS.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | SYS_SET_CHANNELS_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD | specifies the threshold value for reporting debug messages by that software component
NestedPublic enumeration | SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_SET_NV_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_SET_PANID_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | USERTEST_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_BIND_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_BIND_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_BIND_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS | Status code for bind response
NestedPublic enumeration | ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | ZDO_END_DEVICE_ANNCE.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS | status code for End Device bind Response
NestedPublic enumeration | ZDO_IEEEADDRESS_REQUEST.REQ_TYPE | Request type
NestedPublic enumeration | ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_IEEEADDRESS_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_BIND_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_LEAVE_REQUEST.BOOLEAN | True or False flag
NestedPublic enumeration | ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_LQI_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_RTG_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS | Status of network start response
NestedPublic enumeration | ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE | Request type
NestedPublic enumeration | ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS | Security status
NestedPublic enumeration | ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE | Type of Node
NestedPublic enumeration | ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY | Capabilities bitfield
NestedPublic enumeration | ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC | Node Available power sources bitfield
NestedPublic enumeration | ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE | Node current power mode bitfield
NestedPublic enumeration | ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER | App dev ver
NestedPublic enumeration | ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS | App flags
NestedPublic enumeration | ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY | Capabilities bitfield
NestedPublic enumeration | ZDO_UNBIND_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_UNBIND_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_UNBIND_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS | Status code for Unbind response
NestedPublic enumeration | ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE | Security suite list
NestedPublic enumeration | ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ASSOCIATE_RESPOND.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_DATA_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_DATA_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_DATA_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_DATA_REQUEST.TX_OPT | Transmission options bitfield
NestedPublic enumeration | ZMAC_DATA_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON | Valid disassociation reason codes
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_GET_REQUEST.MAC_PID_ATTR | MAC PID Attribute
NestedPublic enumeration | ZMAC_GET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_INIT_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ORPHAN_RESPOND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_POLL_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_POLL_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_POLL_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_POLL_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_PURGE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_RESET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SCAN_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_SCAN_REQUEST.SCAN_TYPE | Scan type
NestedPublic enumeration | ZMAC_SCAN_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZMAC_SCAN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SET_REQUEST.MAC_PID_ATTR | MAC PID Attribute
NestedPublic enumeration | ZMAC_SET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_START_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_START_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_START_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS | Status of command

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.


AF_INCOMINGDATA_INDICATION Class

AF_INCOMINGDATA_INDICATION Class
See Also Example Members
[image]

This command is used by the device to indicate a received packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_INCOMINGDATA_INDICATION
Implements IINDICATION, IAF
C#
public class AF_INCOMINGDATA_INDICATION : IINDICATION, IAF
C++
ref class AF_INCOMINGDATA_INDICATION : IINDICATION, IAF
J#
public class AF_INCOMINGDATA_INDICATION implements IINDICATION, IAF
JScript
public class AF_INCOMINGDATA_INDICATION extends IINDICATION, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_INCOMINGDATA_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_INCOMINGDATA_INDICATION Members
TI.ZPI1 Namespace


AF_INCOMINGDATA_INDICATION Members

AF_INCOMINGDATA_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the device to indicate a received packet.

The following tables list the members exposed by AF_INCOMINGDATA_INDICATION.

Public Constructors

Name | Description
AF_INCOMINGDATA_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterId | The cluster ID of the incoming packet.
Public field | DestEndpoint | The destination endpoint of the incoming packet.
Public field | LinkQuality | Indicates the link quality measured during reception.
Public field | PayloadLen | The length of the PayloadValue field
Public field | PayloadValue | Packet payload.
Public field | SrcAddress | The address of the source device that sent the packet.
Public field | SrcEndpoint | The endpoint of the source device that sent the packet.
Public field | WasBroadcast | Was addressed to broadcast address
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_INCOMINGDATA_INDICATION | Overloaded.
Top

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


AF_INCOMINGDATA_INDICATION Constructor

AF_INCOMINGDATA_INDICATION Constructor
See Also Example

Overload List

 | Name | Description
Public method | AF_INCOMINGDATA_INDICATION | Constructor
Public method | AF_INCOMINGDATA_INDICATION (UInt16, Byte, Byte, UInt16, Byte, Byte, Byte, Byte) | Constructor

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


AF_INCOMINGDATA_INDICATION Constructor ()

AF_INCOMINGDATA_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_INCOMINGDATA_INDICATION()
C++
public:
AF_INCOMINGDATA_INDICATION() sealed
J#
public AF_INCOMINGDATA_INDICATION()
JScript
public function AF_INCOMINGDATA_INDICATION()

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace
AF_INCOMINGDATA_INDICATION Constructor Overload List


AF_INCOMINGDATA_INDICATION Constructor (UInt16, Byte, Byte, UInt16, Byte, Byte[], Byte, Byte)

AF_INCOMINGDATA_INDICATION Constructor (UInt16, Byte, Byte, UInt16, Byte, Byte[], Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As Byte _
)
C#
public AF_INCOMINGDATA_INDICATION(
ushort ,
byte ,
byte ,
ushort ,
byte ,
byte[] ,
byte ,
byte
)
C++
public:
AF_INCOMINGDATA_INDICATION(
unsigned short ,
char ,
char ,
unsigned short ,
char ,
array<char>^ ,
char ,
char
) sealed
J#
public AF_INCOMINGDATA_INDICATION(
ushort ,
byte ,
byte ,
ushort ,
byte ,
byte[] ,
byte ,
byte
)
JScript
public function AF_INCOMINGDATA_INDICATION(
: UInt16,
: Byte,
: Byte,
: UInt16,
: Byte,
: Byte[],
: Byte,
: Byte
)

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace
AF_INCOMINGDATA_INDICATION Constructor Overload List


Fields

AF_INCOMINGDATA_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterId | The cluster ID of the incoming packet.
Public field | DestEndpoint | The destination endpoint of the incoming packet.
Public field | LinkQuality | Indicates the link quality measured during reception.
Public field | PayloadLen | The length of the PayloadValue field
Public field | PayloadValue | Packet payload.
Public field | SrcAddress | The address of the source device that sent the packet.
Public field | SrcEndpoint | The endpoint of the source device that sent the packet.
Public field | WasBroadcast | Was addressed to broadcast address
Top

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


ClusterId Field

AF_INCOMINGDATA_INDICATION.ClusterId Field
[image]

The cluster ID of the incoming packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterId As UInt16
C#
public ushort ClusterId;
C++
public:
unsigned short ClusterId sealed ;
J#
public ushort ClusterId
JScript
public ClusterId : UInt16;

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


DestEndpoint Field

AF_INCOMINGDATA_INDICATION.DestEndpoint Field
[image]

The destination endpoint of the incoming packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


LinkQuality Field

AF_INCOMINGDATA_INDICATION.LinkQuality Field
[image]

Indicates the link quality measured during reception.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


PayloadLen Field

AF_INCOMINGDATA_INDICATION.PayloadLen Field
[image]

The length of the PayloadValue field

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadLen As Byte
C#
public byte PayloadLen;
C++
public:
char PayloadLen sealed ;
J#
public byte PayloadLen
JScript
public PayloadLen : Byte;

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


PayloadValue Field

AF_INCOMINGDATA_INDICATION.PayloadValue Field
[image]

Packet payload.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadValue As Byte()
C#
public byte[] PayloadValue;
C++
public:
array<char>^ PayloadValue sealed ;
J#
public byte[] PayloadValue
JScript
public PayloadValue : Byte[];

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


SrcAddress Field

AF_INCOMINGDATA_INDICATION.SrcAddress Field
[image]

The address of the source device that sent the packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


SrcEndpoint Field

AF_INCOMINGDATA_INDICATION.SrcEndpoint Field
[image]

The endpoint of the source device that sent the packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


WasBroadcast Field

AF_INCOMINGDATA_INDICATION.WasBroadcast Field
[image]

Was addressed to broadcast address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public WasBroadcast As Byte
C#
public byte WasBroadcast;
C++
public:
char WasBroadcast sealed ;
J#
public byte WasBroadcast
JScript
public WasBroadcast : Byte;

See Also

AF_INCOMINGDATA_INDICATION Class
TI.ZPI1 Namespace


AF_INIT_REQUEST Class

AF_INIT_REQUEST Class
See Also Example Members
[image]

This command enables the tester to initialize the target AF.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_INIT_REQUEST
Implements IREQUEST, IAF
C#
public class AF_INIT_REQUEST : IREQUEST, IAF
C++
ref class AF_INIT_REQUEST : IREQUEST, IAF
J#
public class AF_INIT_REQUEST implements IREQUEST, IAF
JScript
public class AF_INIT_REQUEST extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_INIT_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_INIT_REQUEST Members
TI.ZPI1 Namespace


AF_INIT_REQUEST Members

AF_INIT_REQUEST Members
See Also Example Constructors Methods
[image]

This command enables the tester to initialize the target AF.

The following tables list the members exposed by AF_INIT_REQUEST.

Public Constructors

 | Name | Description
Public method | AF_INIT_REQUEST | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AF_INIT_REQUEST Class
TI.ZPI1 Namespace


AF_INIT_REQUEST Constructor

AF_INIT_REQUEST Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_INIT_REQUEST()
C++
public:
AF_INIT_REQUEST() sealed
J#
public AF_INIT_REQUEST()
JScript
public function AF_INIT_REQUEST()

See Also

AF_INIT_REQUEST Class
TI.ZPI1 Namespace


AF_INIT_RESPONSE Class

AF_INIT_RESPONSE Class
See Also Example Members
[image]

Response for AF_INIT_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_INIT_RESPONSE
Implements IRESPONSE, IAF
C#
public class AF_INIT_RESPONSE : IRESPONSE, IAF
C++
ref class AF_INIT_RESPONSE : IRESPONSE, IAF
J#
public class AF_INIT_RESPONSE implements IRESPONSE, IAF
JScript
public class AF_INIT_RESPONSE extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_INIT_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_INIT_RESPONSE Members
TI.ZPI1 Namespace


AF_INIT_RESPONSE Members

AF_INIT_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_INIT_REQUEST

The following tables list the members exposed by AF_INIT_RESPONSE.

Public Constructors

Name | Description
AF_INIT_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_INIT_RESPONSE | Overloaded.
Top

See Also

AF_INIT_RESPONSE Class
TI.ZPI1 Namespace


AF_INIT_RESPONSE Constructor

AF_INIT_RESPONSE Constructor

Overload List

 | Name | Description
Public method | AF_INIT_RESPONSE | Constructor
Public method | AF_INIT_RESPONSE (AF_INIT_RESPONSE.AF_STATUS) |

See Also

AF_INIT_RESPONSE Class
TI.ZPI1 Namespace


AF_INIT_RESPONSE Constructor ()

AF_INIT_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_INIT_RESPONSE()
C++
public:
AF_INIT_RESPONSE() sealed
J#
public AF_INIT_RESPONSE()
JScript
public function AF_INIT_RESPONSE()

See Also

AF_INIT_RESPONSE Class
TI.ZPI1 Namespace
AF_INIT_RESPONSE Constructor Overload List


AF_INIT_RESPONSE Constructor (AF_INIT_RESPONSE.AF_STATUS)

AF_INIT_RESPONSE Constructor (AF_INIT_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_INIT_RESPONSE.AF_STATUS _
)
C#
public AF_INIT_RESPONSE(
AF_INIT_RESPONSE.AF_STATUS
)
C++
public:
AF_INIT_RESPONSE(
AF_INIT_RESPONSE.AF_STATUS
) sealed
J#
public AF_INIT_RESPONSE(
AF_INIT_RESPONSE.AF_STATUS
)
JScript
public function AF_INIT_RESPONSE(
: AF_INIT_RESPONSE.AF_STATUS
)

See Also

AF_INIT_RESPONSE Class
TI.ZPI1 Namespace
AF_INIT_RESPONSE Constructor Overload List


Fields

AF_INIT_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_INIT_RESPONSE Class
TI.ZPI1 Namespace


Status Field

AF_INIT_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_INIT_RESPONSE.AF_STATUS
C#
public AF_INIT_RESPONSE.AF_STATUS Status;
C++
public:
AF_INIT_RESPONSE.AF_STATUS Status sealed ;
J#
public AF_INIT_RESPONSE.AF_STATUS Status
JScript
public Status : AF_INIT_RESPONSE.AF_STATUS;

See Also

AF_INIT_RESPONSE Class
TI.ZPI1 Namespace


AF_INIT_RESPONSE.AF_STATUS Enumeration

AF_INIT_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_INIT_RESPONSE.AF_STATUS As Byte
C#
public enum AF_INIT_RESPONSE.AF_STATUS : byte
C++
public enum class AF_INIT_RESPONSE.AF_STATUS : char
J#
public enum AF_INIT_RESPONSE.AF_STATUS byte
JScript
public enum AF_INIT_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


AF_REGISTER_REQUEST Class

AF_REGISTER_REQUEST Class
See Also Example Members
[image]

This command enables the tester to register an application's endpoint description

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_REGISTER_REQUEST
Implements IREQUEST, IAF
C#
public class AF_REGISTER_REQUEST : IREQUEST, IAF
C++
ref class AF_REGISTER_REQUEST : IREQUEST, IAF
J#
public class AF_REGISTER_REQUEST implements IREQUEST, IAF
JScript
public class AF_REGISTER_REQUEST extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_REGISTER_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_REGISTER_REQUEST Members
TI.ZPI1 Namespace


AF_REGISTER_REQUEST Members

AF_REGISTER_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command enables the tester to register an application's endpoint description

The following tables list the members exposed by AF_REGISTER_REQUEST.

Public Constructors

Name | Description
AF_REGISTER_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppDeviceID | specifies the device description id for this endpoint
Public field | AppDeviceVersion | specifies the version of the device description
Public field | AppFlags | specifies if a complex identifier is available
Public field | AppInClusterList | Dynamic array, requires memory allocation. variable length field of size 'AppNumInClusters' and is the list of Input Cluster Ids
Public field | AppNumInClusters | the number of Input cluster Ids following in the AppInClusterList
Public field | AppNumOutClusters | specifies the number of Output cluster Ids following in the AppOutClusterList
Public field | AppOutClusterList | Dynamic array, requires memory allocation. Variable length field of size 'AppNumOutClusters' and is the list of Output Cluster Ids
Public field | AppProfileID | specifies the profile id of the application
Public field | Endpoint | specifies the endpoint of the device
Public field | Latency | Latency
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_REGISTER_REQUEST | Overloaded.
Top

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AF_REGISTER_REQUEST Constructor

AF_REGISTER_REQUEST Constructor

Overload List

 | Name | Description
Public method | AF_REGISTER_REQUEST | Constructor
Public method | AF_REGISTER_REQUEST (Byte, UInt16, UInt16, Byte, AF_REGISTER_REQUEST.APP_FLAGS, Byte, UInt16, Byte, UInt16, AF_REGISTER_REQUEST.LATENCY_TYPE) |

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AF_REGISTER_REQUEST Constructor ()

AF_REGISTER_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_REGISTER_REQUEST()
C++
public:
AF_REGISTER_REQUEST() sealed
J#
public AF_REGISTER_REQUEST()
JScript
public function AF_REGISTER_REQUEST()

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace
AF_REGISTER_REQUEST Constructor Overload List


AF_REGISTER_REQUEST Constructor (Byte, UInt16, UInt16, Byte, AF_REGISTER_REQUEST.APP_FLAGS, Byte, UInt16[], Byte, UInt16[], AF_REGISTER_REQUEST.LATENCY_TYPE)

AF_REGISTER_REQUEST Constructor (Byte, UInt16, UInt16, Byte, AF_REGISTER_REQUEST.APP_FLAGS, Byte, UInt16[], Byte, UInt16[], AF_REGISTER_REQUEST.LATENCY_TYPE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As AF_REGISTER_REQUEST.APP_FLAGS, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As AF_REGISTER_REQUEST.LATENCY_TYPE _
)
C#
public AF_REGISTER_REQUEST(
byte ,
ushort ,
ushort ,
byte ,
AF_REGISTER_REQUEST.APP_FLAGS ,
byte ,
ushort[] ,
byte ,
ushort[] ,
AF_REGISTER_REQUEST.LATENCY_TYPE
)
C++
public:
AF_REGISTER_REQUEST(
char ,
unsigned short ,
unsigned short ,
char ,
AF_REGISTER_REQUEST.APP_FLAGS ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^ ,
AF_REGISTER_REQUEST.LATENCY_TYPE
) sealed
J#
public AF_REGISTER_REQUEST(
byte ,
ushort ,
ushort ,
byte ,
AF_REGISTER_REQUEST.APP_FLAGS ,
byte ,
ushort[] ,
byte ,
ushort[] ,
AF_REGISTER_REQUEST.LATENCY_TYPE
)
JScript
public function AF_REGISTER_REQUEST(
: Byte,
: UInt16,
: UInt16,
: Byte,
: AF_REGISTER_REQUEST.APP_FLAGS,
: Byte,
: UInt16[],
: Byte,
: UInt16[],
: AF_REGISTER_REQUEST.LATENCY_TYPE
)

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace
AF_REGISTER_REQUEST Constructor Overload List


Fields

AF_REGISTER_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | AppDeviceID | specifies the device description id for this endpoint
Public field | AppDeviceVersion | specifies the version of the device description
Public field | AppFlags | specifies if a complex identifier is available
Public field | AppInClusterList | Dynamic array, requires memory allocation. variable length field of size 'AppNumInClusters' and is the list of Input Cluster Ids
Public field | AppNumInClusters | the number of Input cluster Ids following in the AppInClusterList
Public field | AppNumOutClusters | specifies the number of Output cluster Ids following in the AppOutClusterList
Public field | AppOutClusterList | Dynamic array, requires memory allocation. Variable length field of size 'AppNumOutClusters' and is the list of Output Cluster Ids
Public field | AppProfileID | specifies the profile id of the application
Public field | Endpoint | specifies the endpoint of the device
Public field | Latency | Latency
Top

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppDeviceID Field

AF_REGISTER_REQUEST.AppDeviceID Field
[image]

specifies the device description id for this endpoint

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppDeviceID As UInt16
C#
public ushort AppDeviceID;
C++
public:
unsigned short AppDeviceID sealed ;
J#
public ushort AppDeviceID
JScript
public AppDeviceID : UInt16;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppDeviceVersion Field

AF_REGISTER_REQUEST.AppDeviceVersion Field
[image]

specifies the version of the device description

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppDeviceVersion As Byte
C#
public byte AppDeviceVersion;
C++
public:
char AppDeviceVersion sealed ;
J#
public byte AppDeviceVersion
JScript
public AppDeviceVersion : Byte;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppFlags Field

AF_REGISTER_REQUEST.AppFlags Field
[image]

specifies if a complex identifier is available

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppFlags As AF_REGISTER_REQUEST.APP_FLAGS
C#
public AF_REGISTER_REQUEST.APP_FLAGS AppFlags;
C++
public:
AF_REGISTER_REQUEST.APP_FLAGS AppFlags sealed ;
J#
public AF_REGISTER_REQUEST.APP_FLAGS AppFlags
JScript
public AppFlags : AF_REGISTER_REQUEST.APP_FLAGS;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppInClusterList Field

AF_REGISTER_REQUEST.AppInClusterList Field
[image]

Dynamic array, requires memory allocation. variable length field of size 'AppNumInClusters' and is the list of Input Cluster Ids

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppInClusterList As UInt16()
C#
public ushort[] AppInClusterList;
C++
public:
array<unsigned short>^ AppInClusterList sealed ;
J#
public ushort[] AppInClusterList
JScript
public AppInClusterList : UInt16[];

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppNumInClusters Field

AF_REGISTER_REQUEST.AppNumInClusters Field
[image]

the number of Input cluster Ids following in the AppInClusterList

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppNumInClusters As Byte
C#
public byte AppNumInClusters;
C++
public:
char AppNumInClusters sealed ;
J#
public byte AppNumInClusters
JScript
public AppNumInClusters : Byte;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppNumOutClusters Field

AF_REGISTER_REQUEST.AppNumOutClusters Field
[image]

specifies the number of Output cluster Ids following in the AppOutClusterList

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppNumOutClusters As Byte
C#
public byte AppNumOutClusters;
C++
public:
char AppNumOutClusters sealed ;
J#
public byte AppNumOutClusters
JScript
public AppNumOutClusters : Byte;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppOutClusterList Field

AF_REGISTER_REQUEST.AppOutClusterList Field
[image]

Dynamic array, requires memory allocation. Variable length field of size 'AppNumOutClusters' and is the list of Output Cluster Ids

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppOutClusterList As UInt16()
C#
public ushort[] AppOutClusterList;
C++
public:
array<unsigned short>^ AppOutClusterList sealed ;
J#
public ushort[] AppOutClusterList
JScript
public AppOutClusterList : UInt16[];

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AppProfileID Field

AF_REGISTER_REQUEST.AppProfileID Field
[image]

specifies the profile id of the application

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppProfileID As UInt16
C#
public ushort AppProfileID;
C++
public:
unsigned short AppProfileID sealed ;
J#
public ushort AppProfileID
JScript
public AppProfileID : UInt16;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


Endpoint Field

AF_REGISTER_REQUEST.Endpoint Field
[image]

specifies the endpoint of the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


Latency Field

AF_REGISTER_REQUEST.Latency Field
[image]

Latency

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Latency As AF_REGISTER_REQUEST.LATENCY_TYPE
C#
public AF_REGISTER_REQUEST.LATENCY_TYPE Latency;
C++
public:
AF_REGISTER_REQUEST.LATENCY_TYPE Latency sealed ;
J#
public AF_REGISTER_REQUEST.LATENCY_TYPE Latency
JScript
public Latency : AF_REGISTER_REQUEST.LATENCY_TYPE;

See Also

AF_REGISTER_REQUEST Class
TI.ZPI1 Namespace


AF_REGISTER_REQUEST.APP_FLAGS Enumeration

AF_REGISTER_REQUEST.APP_FLAGS Enumeration
[image]

App flags

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_REGISTER_REQUEST.APP_FLAGS As Byte
C#
public enum AF_REGISTER_REQUEST.APP_FLAGS : byte
C++
public enum class AF_REGISTER_REQUEST.APP_FLAGS : char
J#
public enum AF_REGISTER_REQUEST.APP_FLAGS byte
JScript
public enum AF_REGISTER_REQUEST.APP_FLAGS :

Members

Member Name | Description
COMPLEX_DESC_AVAIL | App flags
USER_DESC_AVAIL | App flags

See Also

TI.ZPI1 Namespace


AF_REGISTER_REQUEST.LATENCY_TYPE Enumeration

AF_REGISTER_REQUEST.LATENCY_TYPE Enumeration
[image]

Latency type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_REGISTER_REQUEST.LATENCY_TYPE As Byte
C#
public enum AF_REGISTER_REQUEST.LATENCY_TYPE : byte
C++
public enum class AF_REGISTER_REQUEST.LATENCY_TYPE : char
J#
public enum AF_REGISTER_REQUEST.LATENCY_TYPE byte
JScript
public enum AF_REGISTER_REQUEST.LATENCY_TYPE :

Members

Member Name | Description
NO_LATENCY_REQS | Latency type
FAST_BEACONS | Latency type
SLOW_BEACONS | Latency type

See Also

TI.ZPI1 Namespace


AF_REGISTER_RESPONSE Class

AF_REGISTER_RESPONSE Class
See Also Example Members
[image]

Response for AF_REGISTER_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_REGISTER_RESPONSE
Implements IRESPONSE, IAF
C#
public class AF_REGISTER_RESPONSE : IRESPONSE, IAF
C++
ref class AF_REGISTER_RESPONSE : IRESPONSE, IAF
J#
public class AF_REGISTER_RESPONSE implements IRESPONSE, IAF
JScript
public class AF_REGISTER_RESPONSE extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_REGISTER_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_REGISTER_RESPONSE Members
TI.ZPI1 Namespace


AF_REGISTER_RESPONSE Members

AF_REGISTER_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_REGISTER_REQUEST

The following tables list the members exposed by AF_REGISTER_RESPONSE.

Public Constructors

Name | Description
AF_REGISTER_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_REGISTER_RESPONSE | Overloaded.
Top

See Also

AF_REGISTER_RESPONSE Class
TI.ZPI1 Namespace


AF_REGISTER_RESPONSE Constructor

AF_REGISTER_RESPONSE Constructor

Overload List

 | Name | Description
Public method | AF_REGISTER_RESPONSE | Constructor
Public method | AF_REGISTER_RESPONSE (AF_REGISTER_RESPONSE.AF_STATUS) |

See Also

AF_REGISTER_RESPONSE Class
TI.ZPI1 Namespace


AF_REGISTER_RESPONSE Constructor ()

AF_REGISTER_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_REGISTER_RESPONSE()
C++
public:
AF_REGISTER_RESPONSE() sealed
J#
public AF_REGISTER_RESPONSE()
JScript
public function AF_REGISTER_RESPONSE()

See Also

AF_REGISTER_RESPONSE Class
TI.ZPI1 Namespace
AF_REGISTER_RESPONSE Constructor Overload List


AF_REGISTER_RESPONSE Constructor (AF_REGISTER_RESPONSE.AF_STATUS)

AF_REGISTER_RESPONSE Constructor (AF_REGISTER_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_REGISTER_RESPONSE.AF_STATUS _
)
C#
public AF_REGISTER_RESPONSE(
AF_REGISTER_RESPONSE.AF_STATUS
)
C++
public:
AF_REGISTER_RESPONSE(
AF_REGISTER_RESPONSE.AF_STATUS
) sealed
J#
public AF_REGISTER_RESPONSE(
AF_REGISTER_RESPONSE.AF_STATUS
)
JScript
public function AF_REGISTER_RESPONSE(
: AF_REGISTER_RESPONSE.AF_STATUS
)

See Also

AF_REGISTER_RESPONSE Class
TI.ZPI1 Namespace
AF_REGISTER_RESPONSE Constructor Overload List


Fields

AF_REGISTER_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_REGISTER_RESPONSE Class
TI.ZPI1 Namespace


Status Field

AF_REGISTER_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_REGISTER_RESPONSE.AF_STATUS
C#
public AF_REGISTER_RESPONSE.AF_STATUS Status;
C++
public:
AF_REGISTER_RESPONSE.AF_STATUS Status sealed ;
J#
public AF_REGISTER_RESPONSE.AF_STATUS Status
JScript
public Status : AF_REGISTER_RESPONSE.AF_STATUS;

See Also

AF_REGISTER_RESPONSE Class
TI.ZPI1 Namespace


AF_REGISTER_RESPONSE.AF_STATUS Enumeration

AF_REGISTER_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_REGISTER_RESPONSE.AF_STATUS As Byte
C#
public enum AF_REGISTER_RESPONSE.AF_STATUS : byte
C++
public enum class AF_REGISTER_RESPONSE.AF_STATUS : char
J#
public enum AF_REGISTER_RESPONSE.AF_STATUS byte
JScript
public enum AF_REGISTER_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


AF_SENDMSG_CONFIRM Class

AF_SENDMSG_CONFIRM Class
See Also Example Members
[image]

This command contains status of a AF_SENDMSG_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_SENDMSG_CONFIRM
Implements IREQUEST, IAF
C#
public class AF_SENDMSG_CONFIRM : IREQUEST, IAF
C++
ref class AF_SENDMSG_CONFIRM : IREQUEST, IAF
J#
public class AF_SENDMSG_CONFIRM implements IREQUEST, IAF
JScript
public class AF_SENDMSG_CONFIRM extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_SENDMSG_CONFIRM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_SENDMSG_CONFIRM Members
TI.ZPI1 Namespace


AF_SENDMSG_CONFIRM Members

AF_SENDMSG_CONFIRM Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command contains status of a AF_SENDMSG_REQUEST

The following tables list the members exposed by AF_SENDMSG_CONFIRM.

Public Constructors

Name | Description
AF_SENDMSG_CONFIRM | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Endpoint | Source endpoint for the message
Public field | Status | Status of the SENDMSG request
Public field | TransID | Transaction ID for the message
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_SENDMSG_CONFIRM | Overloaded.
Top

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace


AF_SENDMSG_CONFIRM Constructor

AF_SENDMSG_CONFIRM Constructor

Overload List

 | Name | Description
Public method | AF_SENDMSG_CONFIRM | Constructor
Public method | AF_SENDMSG_CONFIRM (Byte, Byte, Byte) | Constructor

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace


AF_SENDMSG_CONFIRM Constructor ()

AF_SENDMSG_CONFIRM Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_SENDMSG_CONFIRM()
C++
public:
AF_SENDMSG_CONFIRM() sealed
J#
public AF_SENDMSG_CONFIRM()
JScript
public function AF_SENDMSG_CONFIRM()

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace
AF_SENDMSG_CONFIRM Constructor Overload List


AF_SENDMSG_CONFIRM Constructor (Byte, Byte, Byte)

AF_SENDMSG_CONFIRM Constructor (Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public AF_SENDMSG_CONFIRM(
byte ,
byte ,
byte
)
C++
public:
AF_SENDMSG_CONFIRM(
char ,
char ,
char
) sealed
J#
public AF_SENDMSG_CONFIRM(
byte ,
byte ,
byte
)
JScript
public function AF_SENDMSG_CONFIRM(
: Byte,
: Byte,
: Byte
)

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace
AF_SENDMSG_CONFIRM Constructor Overload List


Fields

AF_SENDMSG_CONFIRM Fields
[image]

Public Fields

 | Name | Description
Public field | Endpoint | Source endpoint for the message
Public field | Status | Status of the SENDMSG request
Public field | TransID | Transaction ID for the message
Top

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace


Endpoint Field

AF_SENDMSG_CONFIRM.Endpoint Field
[image]

Source endpoint for the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace


Status Field

AF_SENDMSG_CONFIRM.Status Field
[image]

Status of the SENDMSG request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace


TransID Field

AF_SENDMSG_CONFIRM.TransID Field
[image]

Transaction ID for the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransID As Byte
C#
public byte TransID;
C++
public:
char TransID sealed ;
J#
public byte TransID
JScript
public TransID : Byte;

See Also

AF_SENDMSG_CONFIRM Class
TI.ZPI1 Namespace


AF_SENDMSG_REQUEST Class

AF_SENDMSG_REQUEST Class
See Also Example Members
[image]

This command is used to build and send a data packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_SENDMSG_REQUEST
Implements IREQUEST, IAF
C#
public class AF_SENDMSG_REQUEST : IREQUEST, IAF
C++
ref class AF_SENDMSG_REQUEST : IREQUEST, IAF
J#
public class AF_SENDMSG_REQUEST implements IREQUEST, IAF
JScript
public class AF_SENDMSG_REQUEST extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_SENDMSG_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_SENDMSG_REQUEST Members
TI.ZPI1 Namespace


AF_SENDMSG_REQUEST Members

AF_SENDMSG_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to build and send a data packet.

The following tables list the members exposed by AF_SENDMSG_REQUEST.

Public Constructors

Name | Description
AF_SENDMSG_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | The cluster ID for the message in this packet.
Public field | DestAddress | The address of the destination device
Public field | DestEndpoint | The endpoint on the destination device for this packet.
Public field | PayloadLen | The length of the payload field in this packet.
Public field | PayloadValue | Variable length field of size 'PayloadLen'.
Public field | Radius | The number of hops allowed to deliver the message; set to 0 to use the default value
Public field | SrcEndpoint | The source endpoint in the device that is sending this packet.
Public field | TransID | The transaction Id for this packet.
Public field | TxOptions | Bitmap of the transmission options fields; ( 0x10 enables end-to-end acknowledgement; 0x20 to enable route discovery )
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_SENDMSG_REQUEST | Overloaded.
Top

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


AF_SENDMSG_REQUEST Constructor

AF_SENDMSG_REQUEST Constructor

Overload List

 | Name | Description
Public method | AF_SENDMSG_REQUEST | Constructor
Public method | AF_SENDMSG_REQUEST (Byte, Byte, UInt16, Byte, UInt16, Byte, Byte, Byte, Byte) | Constructor

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


AF_SENDMSG_REQUEST Constructor ()

AF_SENDMSG_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_SENDMSG_REQUEST()
C++
public:
AF_SENDMSG_REQUEST() sealed
J#
public AF_SENDMSG_REQUEST()
JScript
public function AF_SENDMSG_REQUEST()

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace
AF_SENDMSG_REQUEST Constructor Overload List


AF_SENDMSG_REQUEST Constructor (Byte, Byte, UInt16, Byte, UInt16, Byte, Byte[], Byte, Byte)

AF_SENDMSG_REQUEST Constructor (Byte, Byte, UInt16, Byte, UInt16, Byte, Byte[], Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As Byte _
)
C#
public AF_SENDMSG_REQUEST(
byte ,
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte[] ,
byte ,
byte
)
C++
public:
AF_SENDMSG_REQUEST(
char ,
char ,
unsigned short ,
char ,
unsigned short ,
char ,
array<char>^ ,
char ,
char
) sealed
J#
public AF_SENDMSG_REQUEST(
byte ,
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte[] ,
byte ,
byte
)
JScript
public function AF_SENDMSG_REQUEST(
: Byte,
: Byte,
: UInt16,
: Byte,
: UInt16,
: Byte,
: Byte[],
: Byte,
: Byte
)

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace
AF_SENDMSG_REQUEST Constructor Overload List


Fields

AF_SENDMSG_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | The cluster ID for the message in this packet.
Public field | DestAddress | The address of the destination device
Public field | DestEndpoint | The endpoint on the destination device for this packet.
Public field | PayloadLen | The length of the payload field in this packet.
Public field | PayloadValue | Variable length field of size 'PayloadLen'.
Public field | Radius | The number of hops allowed to deliver the message; set to 0 to use the default value
Public field | SrcEndpoint | The source endpoint in the device that is sending this packet.
Public field | TransID | The transaction Id for this packet.
Public field | TxOptions | Bitmap of the transmission options fields; ( 0x10 enables end-to-end acknowledgement; 0x20 to enable route discovery )
Top

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


ClusterID Field

AF_SENDMSG_REQUEST.ClusterID Field
[image]

The cluster ID for the message in this packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


DestAddress Field

AF_SENDMSG_REQUEST.DestAddress Field
[image]

The address of the destination device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt16
C#
public ushort DestAddress;
C++
public:
unsigned short DestAddress sealed ;
J#
public ushort DestAddress
JScript
public DestAddress : UInt16;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


DestEndpoint Field

AF_SENDMSG_REQUEST.DestEndpoint Field
[image]

The endpoint on the destination device for this packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


PayloadLen Field

AF_SENDMSG_REQUEST.PayloadLen Field
[image]

The length of the payload field in this packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadLen As Byte
C#
public byte PayloadLen;
C++
public:
char PayloadLen sealed ;
J#
public byte PayloadLen
JScript
public PayloadLen : Byte;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


PayloadValue Field

AF_SENDMSG_REQUEST.PayloadValue Field
[image]

Variable length field of size 'PayloadLen'.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadValue As Byte()
C#
public byte[] PayloadValue;
C++
public:
array<char>^ PayloadValue sealed ;
J#
public byte[] PayloadValue
JScript
public PayloadValue : Byte[];

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


Radius Field

AF_SENDMSG_REQUEST.Radius Field
[image]

The number of hops allowed to deliver the message; set to 0 to use the default value

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Radius As Byte
C#
public byte Radius;
C++
public:
char Radius sealed ;
J#
public byte Radius
JScript
public Radius : Byte;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


SrcEndpoint Field

AF_SENDMSG_REQUEST.SrcEndpoint Field
[image]

The source endpoint in the device that is sending this packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


TransID Field

AF_SENDMSG_REQUEST.TransID Field
[image]

The transaction Id for this packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransID As Byte
C#
public byte TransID;
C++
public:
char TransID sealed ;
J#
public byte TransID
JScript
public TransID : Byte;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


TxOptions Field

AF_SENDMSG_REQUEST.TxOptions Field
[image]

Bitmap of the transmission options fields; ( 0x10 enables end-to-end acknowledgement; 0x20 to enable route discovery )

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxOptions As Byte
C#
public byte TxOptions;
C++
public:
char TxOptions sealed ;
J#
public byte TxOptions
JScript
public TxOptions : Byte;

See Also

AF_SENDMSG_REQUEST Class
TI.ZPI1 Namespace


AF_SENDMSG_RESPONSE Class

AF_SENDMSG_RESPONSE Class
See Also Example Members
[image]

Response for AF_SENDMSG_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_SENDMSG_RESPONSE
Implements IRESPONSE, IAF
C#
public class AF_SENDMSG_RESPONSE : IRESPONSE, IAF
C++
ref class AF_SENDMSG_RESPONSE : IRESPONSE, IAF
J#
public class AF_SENDMSG_RESPONSE implements IRESPONSE, IAF
JScript
public class AF_SENDMSG_RESPONSE extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI1.AF_SENDMSG_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_SENDMSG_RESPONSE Members
TI.ZPI1 Namespace


AF_SENDMSG_RESPONSE Members

AF_SENDMSG_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_SENDMSG_REQUEST

The following tables list the members exposed by AF_SENDMSG_RESPONSE.

Public Constructors

Name | Description
AF_SENDMSG_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_SENDMSG_RESPONSE | Overloaded.
Top

See Also

AF_SENDMSG_RESPONSE Class
TI.ZPI1 Namespace


AF_SENDMSG_RESPONSE Constructor

AF_SENDMSG_RESPONSE Constructor

Overload List

 | Name | Description
Public method | AF_SENDMSG_RESPONSE | Constructor
Public method | AF_SENDMSG_RESPONSE (AF_SENDMSG_RESPONSE.AF_STATUS) |

See Also

AF_SENDMSG_RESPONSE Class
TI.ZPI1 Namespace


AF_SENDMSG_RESPONSE Constructor ()

AF_SENDMSG_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_SENDMSG_RESPONSE()
C++
public:
AF_SENDMSG_RESPONSE() sealed
J#
public AF_SENDMSG_RESPONSE()
JScript
public function AF_SENDMSG_RESPONSE()

See Also

AF_SENDMSG_RESPONSE Class
TI.ZPI1 Namespace
AF_SENDMSG_RESPONSE Constructor Overload List


AF_SENDMSG_RESPONSE Constructor (AF_SENDMSG_RESPONSE.AF_STATUS)

AF_SENDMSG_RESPONSE Constructor (AF_SENDMSG_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_SENDMSG_RESPONSE.AF_STATUS _
)
C#
public AF_SENDMSG_RESPONSE(
AF_SENDMSG_RESPONSE.AF_STATUS
)
C++
public:
AF_SENDMSG_RESPONSE(
AF_SENDMSG_RESPONSE.AF_STATUS
) sealed
J#
public AF_SENDMSG_RESPONSE(
AF_SENDMSG_RESPONSE.AF_STATUS
)
JScript
public function AF_SENDMSG_RESPONSE(
: AF_SENDMSG_RESPONSE.AF_STATUS
)

See Also

AF_SENDMSG_RESPONSE Class
TI.ZPI1 Namespace
AF_SENDMSG_RESPONSE Constructor Overload List


Fields

AF_SENDMSG_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_SENDMSG_RESPONSE Class
TI.ZPI1 Namespace


Status Field

AF_SENDMSG_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_SENDMSG_RESPONSE.AF_STATUS
C#
public AF_SENDMSG_RESPONSE.AF_STATUS Status;
C++
public:
AF_SENDMSG_RESPONSE.AF_STATUS Status sealed ;
J#
public AF_SENDMSG_RESPONSE.AF_STATUS Status
JScript
public Status : AF_SENDMSG_RESPONSE.AF_STATUS;

See Also

AF_SENDMSG_RESPONSE Class
TI.ZPI1 Namespace


AF_SENDMSG_RESPONSE.AF_STATUS Enumeration

AF_SENDMSG_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_SENDMSG_RESPONSE.AF_STATUS As Byte
C#
public enum AF_SENDMSG_RESPONSE.AF_STATUS : byte
C++
public enum class AF_SENDMSG_RESPONSE.AF_STATUS : char
J#
public enum AF_SENDMSG_RESPONSE.AF_STATUS byte
JScript
public enum AF_SENDMSG_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


APSDE_DATA_CONFIRMATION Class

APSDE_DATA_CONFIRMATION Class
See Also Example Members
[image]

This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APSDE_DATA_CONFIRMATION
Implements ICONFIRMATION, IAPS
C#
public class APSDE_DATA_CONFIRMATION : ICONFIRMATION, IAPS
C++
ref class APSDE_DATA_CONFIRMATION : ICONFIRMATION, IAPS
J#
public class APSDE_DATA_CONFIRMATION implements ICONFIRMATION, IAPS
JScript
public class APSDE_DATA_CONFIRMATION extends ICONFIRMATION, IAPS

Inheritance Hierarchy

System.Object
TI.ZPI1.APSDE_DATA_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APSDE_DATA_CONFIRMATION Members
TI.ZPI1 Namespace


APSDE_DATA_CONFIRMATION Members

APSDE_DATA_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.

The following tables list the members exposed by APSDE_DATA_CONFIRMATION.

Public Constructors

Name | Description
APSDE_DATA_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | indicates the IEEE extended address of the remote device
Public field | DestAddressPresent | indicates if the destination address and endpoint information is present
Public field | DestEndpoint | indicates the endpoint of the destination device
Public field | SrcEndpoint | indicates the endpoint of the destination device
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APSDE_DATA_CONFIRMATION | Overloaded.
Top

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


APSDE_DATA_CONFIRMATION Constructor

APSDE_DATA_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | APSDE_DATA_CONFIRMATION | Constructor
Public method | APSDE_DATA_CONFIRMATION (APSDE_DATA_CONFIRMATION.BOOLEAN, UInt64, Byte, Byte, APSDE_DATA_CONFIRMATION.APSDE_STATUS) |

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


APSDE_DATA_CONFIRMATION Constructor ()

APSDE_DATA_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APSDE_DATA_CONFIRMATION()
C++
public:
APSDE_DATA_CONFIRMATION() sealed
J#
public APSDE_DATA_CONFIRMATION()
JScript
public function APSDE_DATA_CONFIRMATION()

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace
APSDE_DATA_CONFIRMATION Constructor Overload List


APSDE_DATA_CONFIRMATION Constructor (APSDE_DATA_CONFIRMATION.BOOLEAN, UInt64, Byte, Byte, APSDE_DATA_CONFIRMATION.APSDE_STATUS)

APSDE_DATA_CONFIRMATION Constructor (APSDE_DATA_CONFIRMATION.BOOLEAN, UInt64, Byte, Byte, APSDE_DATA_CONFIRMATION.APSDE_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As APSDE_DATA_CONFIRMATION.BOOLEAN, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APSDE_DATA_CONFIRMATION.APSDE_STATUS _
)
C#
public APSDE_DATA_CONFIRMATION(
APSDE_DATA_CONFIRMATION.BOOLEAN ,
ulong ,
byte ,
byte ,
APSDE_DATA_CONFIRMATION.APSDE_STATUS
)
C++
public:
APSDE_DATA_CONFIRMATION(
APSDE_DATA_CONFIRMATION.BOOLEAN ,
unsigned __int64 ,
char ,
char ,
APSDE_DATA_CONFIRMATION.APSDE_STATUS
) sealed
J#
public APSDE_DATA_CONFIRMATION(
APSDE_DATA_CONFIRMATION.BOOLEAN ,
ulong ,
byte ,
byte ,
APSDE_DATA_CONFIRMATION.APSDE_STATUS
)
JScript
public function APSDE_DATA_CONFIRMATION(
: APSDE_DATA_CONFIRMATION.BOOLEAN,
: UInt64,
: Byte,
: Byte,
: APSDE_DATA_CONFIRMATION.APSDE_STATUS
)

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace
APSDE_DATA_CONFIRMATION Constructor Overload List


Fields

APSDE_DATA_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | indicates the IEEE extended address of the remote device
Public field | DestAddressPresent | indicates if the destination address and endpoint information is present
Public field | DestEndpoint | indicates the endpoint of the destination device
Public field | SrcEndpoint | indicates the endpoint of the destination device
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


DestAddress Field

APSDE_DATA_CONFIRMATION.DestAddress Field
[image]

indicates the IEEE extended address of the remote device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


DestAddressPresent Field

APSDE_DATA_CONFIRMATION.DestAddressPresent Field
[image]

indicates if the destination address and endpoint information is present

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressPresent As APSDE_DATA_CONFIRMATION.BOOLEAN
C#
public APSDE_DATA_CONFIRMATION.BOOLEAN DestAddressPresent;
C++
public:
APSDE_DATA_CONFIRMATION.BOOLEAN DestAddressPresent sealed ;
J#
public APSDE_DATA_CONFIRMATION.BOOLEAN DestAddressPresent
JScript
public DestAddressPresent : APSDE_DATA_CONFIRMATION.BOOLEAN;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


DestEndpoint Field

APSDE_DATA_CONFIRMATION.DestEndpoint Field
[image]

indicates the endpoint of the destination device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


SrcEndpoint Field

APSDE_DATA_CONFIRMATION.SrcEndpoint Field
[image]

indicates the endpoint of the destination device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

APSDE_DATA_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As APSDE_DATA_CONFIRMATION.APSDE_STATUS
C#
public APSDE_DATA_CONFIRMATION.APSDE_STATUS Status;
C++
public:
APSDE_DATA_CONFIRMATION.APSDE_STATUS Status sealed ;
J#
public APSDE_DATA_CONFIRMATION.APSDE_STATUS Status
JScript
public Status : APSDE_DATA_CONFIRMATION.APSDE_STATUS;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


APSDE_DATA_CONFIRMATION.APSDE_STATUS Enumeration

APSDE_DATA_CONFIRMATION.APSDE_STATUS Enumeration
[image]

Status code for APSDE responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APSDE_DATA_CONFIRMATION.APSDE_STATUS As Byte
C#
public enum APSDE_DATA_CONFIRMATION.APSDE_STATUS : byte
C++
public enum class APSDE_DATA_CONFIRMATION.APSDE_STATUS : char
J#
public enum APSDE_DATA_CONFIRMATION.APSDE_STATUS byte
JScript
public enum APSDE_DATA_CONFIRMATION.APSDE_STATUS :

Members

Member Name | Description
APSDE_SUCCESS | Status code for APSDE responses
APSDE_INVALID_TARGET | Status code for APSDE responses
APSDE_NO_BOUND_DEVICE | Status code for APSDE responses
APSDE_BUFFER_FULL | Status code for APSDE responses
APSDE_MEMORY_ERROR | Status code for APSDE responses
APSDE_INVALID_NETWORK_STATE | Status code for APSDE responses
APSDE_TX_ERROR | Status code for APSDE responses
APSDE_FAIL | Status code for APSDE responses

See Also

TI.ZPI1 Namespace


APSDE_DATA_CONFIRMATION.BOOLEAN Enumeration

APSDE_DATA_CONFIRMATION.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APSDE_DATA_CONFIRMATION.BOOLEAN As Byte
C#
public enum APSDE_DATA_CONFIRMATION.BOOLEAN : byte
C++
public enum class APSDE_DATA_CONFIRMATION.BOOLEAN : char
J#
public enum APSDE_DATA_CONFIRMATION.BOOLEAN byte
JScript
public enum APSDE_DATA_CONFIRMATION.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI1 Namespace


APSME_BIND_RESPONSE Class

APSME_BIND_RESPONSE Class
See Also Example Members
[image]

Response for APSME_BIND

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APSME_BIND_RESPONSE
Implements IRESPONSE, IAPS
C#
public class APSME_BIND_RESPONSE : IRESPONSE, IAPS
C++
ref class APSME_BIND_RESPONSE : IRESPONSE, IAPS
J#
public class APSME_BIND_RESPONSE implements IRESPONSE, IAPS
JScript
public class APSME_BIND_RESPONSE extends IRESPONSE, IAPS

Inheritance Hierarchy

System.Object
TI.ZPI1.APSME_BIND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APSME_BIND_RESPONSE Members
TI.ZPI1 Namespace


APSME_BIND_RESPONSE Members

APSME_BIND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for APSME_BIND

The following tables list the members exposed by APSME_BIND_RESPONSE.

Public Constructors

Name | Description
APSME_BIND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APSME_BIND_RESPONSE | Overloaded.
Top

See Also

APSME_BIND_RESPONSE Class
TI.ZPI1 Namespace


APSME_BIND_RESPONSE Constructor

APSME_BIND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APSME_BIND_RESPONSE | Constructor
Public method | APSME_BIND_RESPONSE (APSME_BIND_RESPONSE.NLME_STATUS) |

See Also

APSME_BIND_RESPONSE Class
TI.ZPI1 Namespace


APSME_BIND_RESPONSE Constructor ()

APSME_BIND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APSME_BIND_RESPONSE()
C++
public:
APSME_BIND_RESPONSE() sealed
J#
public APSME_BIND_RESPONSE()
JScript
public function APSME_BIND_RESPONSE()

See Also

APSME_BIND_RESPONSE Class
TI.ZPI1 Namespace
APSME_BIND_RESPONSE Constructor Overload List


APSME_BIND_RESPONSE Constructor (APSME_BIND_RESPONSE.NLME_STATUS)

APSME_BIND_RESPONSE Constructor (APSME_BIND_RESPONSE.NLME_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As APSME_BIND_RESPONSE.NLME_STATUS _
)
C#
public APSME_BIND_RESPONSE(
APSME_BIND_RESPONSE.NLME_STATUS
)
C++
public:
APSME_BIND_RESPONSE(
APSME_BIND_RESPONSE.NLME_STATUS
) sealed
J#
public APSME_BIND_RESPONSE(
APSME_BIND_RESPONSE.NLME_STATUS
)
JScript
public function APSME_BIND_RESPONSE(
: APSME_BIND_RESPONSE.NLME_STATUS
)

See Also

APSME_BIND_RESPONSE Class
TI.ZPI1 Namespace
APSME_BIND_RESPONSE Constructor Overload List


Fields

APSME_BIND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

APSME_BIND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

APSME_BIND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As APSME_BIND_RESPONSE.NLME_STATUS
C#
public APSME_BIND_RESPONSE.NLME_STATUS Status;
C++
public:
APSME_BIND_RESPONSE.NLME_STATUS Status sealed ;
J#
public APSME_BIND_RESPONSE.NLME_STATUS Status
JScript
public Status : APSME_BIND_RESPONSE.NLME_STATUS;

See Also

APSME_BIND_RESPONSE Class
TI.ZPI1 Namespace


APSME_BIND_RESPONSE.NLME_STATUS Enumeration

APSME_BIND_RESPONSE.NLME_STATUS Enumeration
[image]

Status code for NLME response

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APSME_BIND_RESPONSE.NLME_STATUS As Byte
C#
public enum APSME_BIND_RESPONSE.NLME_STATUS : byte
C++
public enum class APSME_BIND_RESPONSE.NLME_STATUS : char
J#
public enum APSME_BIND_RESPONSE.NLME_STATUS byte
JScript
public enum APSME_BIND_RESPONSE.NLME_STATUS :

Members

Member Name | Description
NLME_SUCCESS | Status code for NLME response
NLME_FAILURE | Status code for NLME response
NLME_ILLEGAL_REQUEST | Status code for NLME response
NLME_UNKNOWN_DEVICE | Status code for NLME response
NLME_STARTUP_FAILURE | Status code for NLME response
NLME_NO_SHORT_ADDRESS | Status code for NLME response
NLME_UNAVAILABLE_KEY | Status code for NLME response
NLME_FRAME_TOO_LONG | Status code for NLME response
NLME_FAILED_SECURITY_CHECK | Status code for NLME response
NLME_INVALID_PARAMETER | Status code for NLME response
NLME_UNSUPPORTED_ATTRIBUTE | Status code for NLME response
NLME_NOT_JOINED | Status code for NLME response
NLME_ALREADY_JOINED | Status code for NLME response
NLME_NOT_POSSIBLE | Status code for NLME response
NLME_TX_FAIL | Status code for NLME response
NLME_TX_ERROR | Status code for NLME response
NLME_RX_SUCCESS | Status code for NLME response
NLME_RX_FAILURE | Status code for NLME response
NLME_ALREADY_PRESENT | Status code for NLME response
NLME_NO_NETWORKS | Status code for NLME response
NLME_TABLE_FULL | Status code for NLME response

See Also

TI.ZPI1 Namespace


IAF Interface

IAF Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAF
C#
public interface IAF
C++
interface class IAF
J#
public interface IAF
JScript
public interface IAF

Types that implement IAF

Type | Description
TI.ZPI1.AF_INCOMINGDATA_INDICATION | This command is used by the device to indicate a received packet.
TI.ZPI1.AF_INIT_REQUEST | This command enables the tester to initialize the target AF.
TI.ZPI1.AF_INIT_RESPONSE | Response for AF_INIT_REQUEST
TI.ZPI1.AF_REGISTER_REQUEST | This command enables the tester to register an application's endpoint description
TI.ZPI1.AF_REGISTER_RESPONSE | Response for AF_REGISTER_REQUEST
TI.ZPI1.AF_SENDMSG_CONFIRM | This command contains status of a AF_SENDMSG_REQUEST
TI.ZPI1.AF_SENDMSG_REQUEST | This command is used to build and send a data packet.
TI.ZPI1.AF_SENDMSG_RESPONSE | Response for AF_SENDMSG_REQUEST

See Also

IAF Members
TI.ZPI1 Namespace


IAPS Interface

IAPS Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAPS
C#
public interface IAPS
C++
interface class IAPS
J#
public interface IAPS
JScript
public interface IAPS

Types that implement IAPS

Type | Description
TI.ZPI1.APSDE_DATA_CONFIRMATION | This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.
TI.ZPI1.APSME_BIND_RESPONSE | Response for APSME_BIND

See Also

IAPS Members
TI.ZPI1 Namespace


ICONFIRMATION Interface

ICONFIRMATION Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICONFIRMATION
C#
public interface ICONFIRMATION
C++
interface class ICONFIRMATION
J#
public interface ICONFIRMATION
JScript
public interface ICONFIRMATION

Types that implement ICONFIRMATION

Type | Description
TI.ZPI1.APSDE_DATA_CONFIRMATION | This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.
TI.ZPI1.NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
TI.ZPI1.NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
TI.ZPI1.NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
TI.ZPI1.NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
TI.ZPI1.NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
TI.ZPI1.NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
TI.ZPI1.NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
TI.ZPI1.NWK_COMM_STATUS_INDICATION | This function reports a comm status error
TI.ZPI1.NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
TI.ZPI1.NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
TI.ZPI1.NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
TI.ZPI1.NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
TI.ZPI1.NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
TI.ZPI1.NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
TI.ZPI1.NWK_START_CONFIRMATION | This function reports the success of the start request.

See Also

ICONFIRMATION Members
TI.ZPI1 Namespace


IINDICATION Interface

IINDICATION Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IINDICATION
C#
public interface IINDICATION
C++
interface class IINDICATION
J#
public interface IINDICATION
JScript
public interface IINDICATION

Types that implement IINDICATION

Type | Description
TI.ZPI1.AF_INCOMINGDATA_INDICATION | This command is used by the device to indicate a received packet.
TI.ZPI1.NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
TI.ZPI1.NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
TI.ZPI1.NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
TI.ZPI1.NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
TI.ZPI1.NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
TI.ZPI1.NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
TI.ZPI1.NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
TI.ZPI1.NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
TI.ZPI1.NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon

See Also

IINDICATION Members
TI.ZPI1 Namespace


INETWORK Interface

INETWORK Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface INETWORK
C#
public interface INETWORK
C++
interface class INETWORK
J#
public interface INETWORK
JScript
public interface INETWORK

Types that implement INETWORK

Type | Description
TI.ZPI1.NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
TI.ZPI1.NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
TI.ZPI1.NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
TI.ZPI1.NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
TI.ZPI1.NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
TI.ZPI1.NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
TI.ZPI1.NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
TI.ZPI1.NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
TI.ZPI1.NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
TI.ZPI1.NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
TI.ZPI1.NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
TI.ZPI1.NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
TI.ZPI1.NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
TI.ZPI1.NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
TI.ZPI1.NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
TI.ZPI1.NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
TI.ZPI1.NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
TI.ZPI1.NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
TI.ZPI1.NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
TI.ZPI1.NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
TI.ZPI1.NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
TI.ZPI1.NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
TI.ZPI1.NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
TI.ZPI1.NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
TI.ZPI1.NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
TI.ZPI1.NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
TI.ZPI1.NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
TI.ZPI1.NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
TI.ZPI1.NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
TI.ZPI1.NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
TI.ZPI1.NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
TI.ZPI1.NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
TI.ZPI1.NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
TI.ZPI1.NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
TI.ZPI1.NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
TI.ZPI1.NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
TI.ZPI1.NLME_SYNC_REQUEST | This primitive allows the next higher layer to synchronize or extract data from its ZigBee coordinator or router
TI.ZPI1.NLME_SYNC_RESPONSE | Response for NLME_SYNC_REQUEST
TI.ZPI1.NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
TI.ZPI1.NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
TI.ZPI1.NWK_COMM_STATUS_INDICATION | This function reports a comm status error
TI.ZPI1.NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
TI.ZPI1.NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
TI.ZPI1.NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
TI.ZPI1.NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
TI.ZPI1.NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
TI.ZPI1.NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
TI.ZPI1.NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
TI.ZPI1.NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
TI.ZPI1.NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
TI.ZPI1.NWK_START_CONFIRMATION | This function reports the success of the start request.
TI.ZPI1.NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon

See Also

INETWORK Members
TI.ZPI1 Namespace


IREQUEST Interface

IREQUEST Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IREQUEST
C#
public interface IREQUEST
C++
interface class IREQUEST
J#
public interface IREQUEST
JScript
public interface IREQUEST

Types that implement IREQUEST

Type | Description
TI.ZPI1.AF_INIT_REQUEST | This command enables the tester to initialize the target AF.
TI.ZPI1.AF_REGISTER_REQUEST | This command enables the tester to register an application's endpoint description
TI.ZPI1.AF_SENDMSG_CONFIRM | This command contains status of a AF_SENDMSG_REQUEST
TI.ZPI1.AF_SENDMSG_REQUEST | This command is used to build and send a data packet.
TI.ZPI1.NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
TI.ZPI1.NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
TI.ZPI1.NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
TI.ZPI1.NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
TI.ZPI1.NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
TI.ZPI1.NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
TI.ZPI1.NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
TI.ZPI1.NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
TI.ZPI1.NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
TI.ZPI1.NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
TI.ZPI1.NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
TI.ZPI1.NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
TI.ZPI1.NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
TI.ZPI1.NLME_SYNC_REQUEST | This primitive allows the next higher layer to synchronize or extract data from its ZigBee coordinator or router
TI.ZPI1.SYS_APP_MSG | Use this message to send raw data to an application.
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
TI.ZPI1.SYS_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS | Read the extended address from the device.
TI.ZPI1.SYS_GET_NV | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
TI.ZPI1.SYS_GET_NV_INFO | Use this message to get the NV information.
TI.ZPI1.SYS_GET_TIME_ALIVE | Use this message to get board's time alive.
TI.ZPI1.SYS_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
TI.ZPI1.SYS_LED_CONTROL | Use this message to control LEDs on the board.
TI.ZPI1.SYS_PING | This command is used to check for a device
TI.ZPI1.SYS_RAM_READ | This command is used by the tester to read a single memory location in the target RAM. THe command accepts an address value and returns the memory value present in the target RAM at that address.
TI.ZPI1.SYS_RAM_WRITE | This command is used by the tester to write to a particular location in the target RAM. The command accepts an address location and a memory value. The memory value is written to the address location in the target RAM
TI.ZPI1.SYS_RESET | This command is sent by the tester to the target to reset it
TI.ZPI1.SYS_SET_CHANNELS | Use this message to set the channels.
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS | Set the 64-bit extended address.
TI.ZPI1.SYS_SET_NV | This command is used by the tester to write to a particular location in non-volatile memory. The command accepts an address location and a memory value. The memory value is written to the address location in the target.
TI.ZPI1.SYS_SET_PANID | Use this message to set PANID.
TI.ZPI1.SYS_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
TI.ZPI1.SYS_SET_SECURITY_LEVEL | Use this message to set the security level.
TI.ZPI1.SYS_SET_SECURITY_MODE | Use this message to get the NV information.
TI.ZPI1.SYS_VERSION | Ask for the device's version string.
TI.ZPI1.USERTEST_REQUEST | This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).
TI.ZPI1.ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
TI.ZPI1.ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
TI.ZPI1.ZB_FIND_DEV | Search for a device's short address given its IEEE address.
TI.ZPI1.ZB_GET_DEV_INFO | Reads current device infromation.
TI.ZPI1.ZB_PERMIT_JOIN | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
TI.ZPI1.ZB_READ_CFG | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
TI.ZPI1.ZB_SEND_DATA | Send a data packet to another device (zb_SendDataRequest).
TI.ZPI1.ZB_START_REQ | Starts the ZigBee stack (zb_StartRequest).
TI.ZPI1.ZB_SYS_RESET | Reboot the device (zb_SystemReset)
TI.ZPI1.ZB_WRITE_CFG | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
TI.ZPI1.ZDO_ACTIVEENDPOINT_REQUEST | This command is generated to request a list of active endpoint from the destination device.
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST | This command will tell the ZDO to request an End Device Bind. The ZDO will send the message to the Zigbee coordinator based on the information found in the AF Endpoint description for the passed in endpoint.
TI.ZPI1.ZDO_AUTOFINDDESTINATION_REQUEST | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
TI.ZPI1.ZDO_BIND_REQUEST | This command is generated to request a Bind
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_REQUEST | This command is generated to request for the destination device's complex descriptor
TI.ZPI1.ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
TI.ZPI1.ZDO_ENDDEVICEBIND_REQUEST | This command is generated to request an End Device Bind with the destination device
TI.ZPI1.ZDO_IEEEADDRESS_REQUEST | This command will request a device's IEEE 64-bit address. You must subscribe to "ZDO IEEE Address Response" to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI1.ZDO_MATCHDESCRIPTOR_REQUEST | This command is generated to request a list of active endpoint from the destination device
TI.ZPI1.ZDO_MGMT_BIND_REQUEST | This command is generated to request a Management Binding Table Request.
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_REQUEST | This command is generated to request a Management Direct Join Request
TI.ZPI1.ZDO_MGMT_LEAVE_REQUEST | This command is generated to request a Management Leave Request
TI.ZPI1.ZDO_MGMT_LQI_REQUEST | This command is generated to request a Management LQI Request.
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
TI.ZPI1.ZDO_MGMT_NWKDISC_REQUEST | This command is generated to request a Management Network Discovery Request
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
TI.ZPI1.ZDO_MGMT_RTG_REQUEST | This command is generated to request a Management Routing Table Request.
TI.ZPI1.ZDO_NETWORK_START_REQUEST | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
TI.ZPI1.ZDO_NETWORKADDRESS_REQUEST | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI1.ZDO_NODEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Node Descriptor of the destination device
TI.ZPI1.ZDO_POWERDESCRIPTOR_REQUEST | This command is generated to inquire as to the Power Descriptor of the destination
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_REQUEST | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
TI.ZPI1.ZDO_UNBIND_REQUEST | This command is generated to request an UnBind
TI.ZPI1.ZDO_USERDESCRIPTOR_REQUEST | This command is generated to request for the destination device's user descriptor
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_REQUEST | This command is generated to request a User Descriptor Set Request
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND | This command is used to send (on behalf of the next higher layer) an association response message
TI.ZPI1.ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
TI.ZPI1.ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
TI.ZPI1.ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
TI.ZPI1.ZMAC_ORPHAN_RESPOND | This command is used to send a response to the Orphan Indication message.
TI.ZPI1.ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
TI.ZPI1.ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
TI.ZPI1.ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
TI.ZPI1.ZMAC_RX_ENABLE_REQUEST | This command contains timing information that tells the device when to enable or disable its receiver, in order to schedule a data transfer between itself and another device. The information is sent from the upper layers directly to the MAC sublayer.
TI.ZPI1.ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
TI.ZPI1.ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
TI.ZPI1.ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
TI.ZPI1.ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon

See Also

IREQUEST Members
TI.ZPI1 Namespace


IRESPONSE Interface

IRESPONSE Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRESPONSE
C#
public interface IRESPONSE
C++
interface class IRESPONSE
J#
public interface IRESPONSE
JScript
public interface IRESPONSE

Types that implement IRESPONSE

Type | Description
TI.ZPI1.AF_INIT_RESPONSE | Response for AF_INIT_REQUEST
TI.ZPI1.AF_REGISTER_RESPONSE | Response for AF_REGISTER_REQUEST
TI.ZPI1.AF_SENDMSG_RESPONSE | Response for AF_SENDMSG_REQUEST
TI.ZPI1.APSME_BIND_RESPONSE | Response for APSME_BIND
TI.ZPI1.NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
TI.ZPI1.NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
TI.ZPI1.NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
TI.ZPI1.NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
TI.ZPI1.NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
TI.ZPI1.NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
TI.ZPI1.NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
TI.ZPI1.NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
TI.ZPI1.NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
TI.ZPI1.NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
TI.ZPI1.NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
TI.ZPI1.NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
TI.ZPI1.NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
TI.ZPI1.NLME_SYNC_RESPONSE | Response for NLME_SYNC_REQUEST
TI.ZPI1.SYS_APP_MSG_RESPONSE | Response for SYS_APP_MSG
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE_RESPONSE | Response for SYS_CALLBACK_SUBSCRIBE
TI.ZPI1.SYS_GET_DEVICE_INFO_RESPONSE | Response for SYS_GET_DEVICE_INFO
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_GET_EXTENDED_ADDRESS
TI.ZPI1.SYS_GET_NV_INFO_RESPONSE | Response for SYS_GET_NV_INFO
TI.ZPI1.SYS_GET_NV_RESPONSE | Response for SYS_GET_NV
TI.ZPI1.SYS_GET_TIME_ALIVE_RESPONSE | Response for SYS_GET_TIME_ALIVE
TI.ZPI1.SYS_KEY_EVENT_RESPONSE | Response for SYS_KEY_EVENT
TI.ZPI1.SYS_LED_CONTROL_RESPONSE | Response for SYS_LED_CONTROL
TI.ZPI1.SYS_PING_RESPONSE | Response for SYS_PING
TI.ZPI1.SYS_RAM_READ_RESPONSE | Response for SYS_RAM_READ
TI.ZPI1.SYS_RAM_WRITE_RESPONSE | Response for SYS_RAM_WRITE
TI.ZPI1.SYS_RESET_RESPONSE | Response for SYS_RESET. This response is sent from the target device or serial bootloader after the requested reset is complete.
TI.ZPI1.SYS_SET_CHANNELS_RESPONSE | Response for SYS_SET_CHANNELS
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_SET_EXTENDED_ADDRESS
TI.ZPI1.SYS_SET_NV_RESPONSE | Response for SYS_SET_NV
TI.ZPI1.SYS_SET_PANID_RESPONSE | Response for SYS_SET_PANID
TI.ZPI1.SYS_SET_PRECONFIG_KEY_RESPONSE | Response for SYS_SET_PRECONFIG_KEY
TI.ZPI1.SYS_SET_SECURITY_LEVEL_RESPONSE | Response for SYS_SET_SECURITY_LEVEL
TI.ZPI1.SYS_SET_SECURITY_MODE_RESPONSE | Response for SYS_SET_SECURITY_MODE
TI.ZPI1.SYS_STRING_RESPONSE | Debug message sent by device
TI.ZPI1.SYS_VERSION_RESPONSE | Response for SYS_VERSION
TI.ZPI1.USERTEST_RESPONSE | Response for USERTEST_REQUEST
TI.ZPI1.ZB_ALLOW_BIND_CNF |
TI.ZPI1.ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
TI.ZPI1.ZB_BIND_CNF | (zb_BindConfirm)
TI.ZPI1.ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
TI.ZPI1.ZB_FIND_DEV_CNF | (zb_FindDeviceConfirm)
TI.ZPI1.ZB_FIND_DEV_RSP | Response for ZB_FIND_DEV
TI.ZPI1.ZB_GET_DEV_INFO_RSP | Response for ZB_GET_DEV_INFO
TI.ZPI1.ZB_PERMIT_JOIN_RSP | Response for SYS_PERMIT_JOIN
TI.ZPI1.ZB_RCV_DATA_IND | (zb_ReceiveDataIndication)
TI.ZPI1.ZB_READ_CFG_RSP |
TI.ZPI1.ZB_SEND_DATA_CNF | (zb_SendDataConfirm)
TI.ZPI1.ZB_SEND_DATA_RSP | Response for ZB_SEND_DATA
TI.ZPI1.ZB_START_CNF | (zb_StartConfirm)
TI.ZPI1.ZB_START_REQ_RSP | Response for ZB_START_REQ
TI.ZPI1.ZB_WRITE_CFG_RSP | Response for ZB_WRITE_CFG
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSE | Response for ZDO_ACTIVEENDPOINT_REQUEST
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE | Response for ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST
TI.ZPI1.ZDO_AUTOFINDDESTINATION_RESPONSE | Response for ZDO_AUTOFINDDESTINATION_REQUEST
TI.ZPI1.ZDO_BIND_RESPONSE | Response for ZDO_BIND_REQUEST
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_RESPONSE | Response for ZDO_COMPLEXDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_END_DEVICE_ANNCE_RESPONSE | Response for ZDO_END_DEVICE_ANNCE_REQUEST
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSE | Response for ZDO_ENDDEVICEBIND_REQUEST
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSE | Response for ZDO_IEEEADDRESS_REQUEST
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSE | Response for ZDO_MATCHDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_MGMT_BIND_RESPONSE | Response for ZDO_MGMT_BIND_REQUEST
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSE | Response for ZDO_MGMT_DIRECT_JOIN_REQUEST
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSE | Response for ZDO_MGMT_LEAVE_REQUEST
TI.ZPI1.ZDO_MGMT_LQI_RESPONSE | Response for ZDO_MGMT_LQI_REQUEST
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSE | Response for ZDO_MGMT_NWKDISC_REQUEST
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSE | Response for ZDO_MGMT_PERMIT_JOIN_REQUEST
TI.ZPI1.ZDO_MGMT_RTG_RESPONSE | Response for ZDO_MGMT_RTG_REQUEST
TI.ZPI1.ZDO_NETWORK_START_RESPONSE | Response for ZDO_NETWORK_START_REQUEST
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSE | Response for ZDO_NETWORKADDRESS_REQUEST
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSE | Response for ZDO_NODEDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSE | Response for ZDO_POWERDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSE | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSE | Response for ZDO_SYSTEM_SERVER_DISC_REQUEST
TI.ZPI1.ZDO_UNBIND_RESPONSE | Response for ZDO_UNBIND_REQUEST
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSE | Response for ZDO_USERDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSE | Response for ZDO_USERDESCRIPTOR_SET_REQUEST
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND_RESPONSE | Response for ZMAC_ASSOCIATE_RESPOND
TI.ZPI1.ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
TI.ZPI1.ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
TI.ZPI1.ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
TI.ZPI1.ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
TI.ZPI1.ZMAC_INIT_RESPONSE | Response for ZMAC_INIT_REQUEST
TI.ZPI1.ZMAC_ORPHAN_RESPOND_RESPONSE | Response for ZMAC_ORPHAN_RESPOND
TI.ZPI1.ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
TI.ZPI1.ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
TI.ZPI1.ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
TI.ZPI1.ZMAC_RX_ENABLE_RESPONSE | Response for ZMAC_RX_ENABLE_REQUEST
TI.ZPI1.ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
TI.ZPI1.ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
TI.ZPI1.ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
TI.ZPI1.ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST

See Also

IRESPONSE Members
TI.ZPI1 Namespace


IRESPONSE_CALLBACK Interface

IRESPONSE_CALLBACK Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRESPONSE_CALLBACK
C#
public interface IRESPONSE_CALLBACK
C++
interface class IRESPONSE_CALLBACK
J#
public interface IRESPONSE_CALLBACK
JScript
public interface IRESPONSE_CALLBACK

Types that implement IRESPONSE_CALLBACK

Type | Description
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSECB | This callback message is in response to the ZDO Active Endpoint Request.
TI.ZPI1.ZDO_BIND_RESPONSECB | This callback message is in response to the ZDO Bind Request
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSECB | This callback message is in response to the ZDO End Device Bind Request
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSECB | This callback message is in response to the ZDO IEEE Address Request.
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Match Description Request
TI.ZPI1.ZDO_MGMT_BIND_RESPONSECB | This callback message is in response to the ZDO Management Binding Table Request
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Direct Join Request.
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSECB | This callback message is in response to the ZDO Management Leave Request.
TI.ZPI1.ZDO_MGMT_LQI_RESPONSECB | This callback message is in response to the ZDO Management LQI Request.
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_NOTIFYCB | This callback message is in response to the Mgmt NWK Update Request. Upon receiving the request, remote device shall determine from the contents of the ScanDuration parameter whether this request is an update to the apsChannelMask and nwkManagerAddr parameters, a channel change command, or a request to scan channels and report the results
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSECB | This callback message is in response to the ZDO Management Network Discovery Request
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
TI.ZPI1.ZDO_MGMT_RTG_RESPONSECB | This callback message is in response to the ZDO Management Routing Table Request.
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSECB | This callback message is in response to the ZDO Network Address Request.
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Node Descriptor Request.
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Power Descriptor Request.
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Simple Descriptor Request.
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
TI.ZPI1.ZDO_UNBIND_RESPONSECB | This callback message is in response to the ZDO UnBind Request
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO User Description Request.
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSECB | This callback message is in response to the ZDO User Descriptor Set Request.

See Also

IRESPONSE_CALLBACK Members
TI.ZPI1 Namespace


ISIMPLEAPI Interface

ISIMPLEAPI Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISIMPLEAPI
C#
public interface ISIMPLEAPI
C++
interface class ISIMPLEAPI
J#
public interface ISIMPLEAPI
JScript
public interface ISIMPLEAPI

Types that implement ISIMPLEAPI

Type | Description
TI.ZPI1.ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
TI.ZPI1.ZB_ALLOW_BIND_CNF |
TI.ZPI1.ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
TI.ZPI1.ZB_BIND_CNF | (zb_BindConfirm)
TI.ZPI1.ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
TI.ZPI1.ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
TI.ZPI1.ZB_FIND_DEV | Search for a device's short address given its IEEE address.
TI.ZPI1.ZB_FIND_DEV_CNF | (zb_FindDeviceConfirm)
TI.ZPI1.ZB_FIND_DEV_RSP | Response for ZB_FIND_DEV
TI.ZPI1.ZB_GET_DEV_INFO | Reads current device infromation.
TI.ZPI1.ZB_GET_DEV_INFO_RSP | Response for ZB_GET_DEV_INFO
TI.ZPI1.ZB_PERMIT_JOIN | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
TI.ZPI1.ZB_PERMIT_JOIN_RSP | Response for SYS_PERMIT_JOIN
TI.ZPI1.ZB_RCV_DATA_IND | (zb_ReceiveDataIndication)
TI.ZPI1.ZB_READ_CFG | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
TI.ZPI1.ZB_READ_CFG_RSP |
TI.ZPI1.ZB_SEND_DATA | Send a data packet to another device (zb_SendDataRequest).
TI.ZPI1.ZB_SEND_DATA_CNF | (zb_SendDataConfirm)
TI.ZPI1.ZB_SEND_DATA_RSP | Response for ZB_SEND_DATA
TI.ZPI1.ZB_START_CNF | (zb_StartConfirm)
TI.ZPI1.ZB_START_REQ | Starts the ZigBee stack (zb_StartRequest).
TI.ZPI1.ZB_START_REQ_RSP | Response for ZB_START_REQ
TI.ZPI1.ZB_SYS_RESET | Reboot the device (zb_SystemReset)
TI.ZPI1.ZB_WRITE_CFG | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
TI.ZPI1.ZB_WRITE_CFG_RSP | Response for ZB_WRITE_CFG

See Also

ISIMPLEAPI Members
TI.ZPI1 Namespace


ISYSTEM Interface

ISYSTEM Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISYSTEM
C#
public interface ISYSTEM
C++
interface class ISYSTEM
J#
public interface ISYSTEM
JScript
public interface ISYSTEM

Types that implement ISYSTEM

Type | Description
TI.ZPI1.SYS_APP_MSG | Use this message to send raw data to an application.
TI.ZPI1.SYS_APP_MSG_RESPONSE | Response for SYS_APP_MSG
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE_RESPONSE | Response for SYS_CALLBACK_SUBSCRIBE
TI.ZPI1.SYS_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
TI.ZPI1.SYS_GET_DEVICE_INFO_RESPONSE | Response for SYS_GET_DEVICE_INFO
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS | Read the extended address from the device.
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_GET_EXTENDED_ADDRESS
TI.ZPI1.SYS_GET_NV | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
TI.ZPI1.SYS_GET_NV_INFO | Use this message to get the NV information.
TI.ZPI1.SYS_GET_NV_INFO_RESPONSE | Response for SYS_GET_NV_INFO
TI.ZPI1.SYS_GET_NV_RESPONSE | Response for SYS_GET_NV
TI.ZPI1.SYS_GET_TIME_ALIVE | Use this message to get board's time alive.
TI.ZPI1.SYS_GET_TIME_ALIVE_RESPONSE | Response for SYS_GET_TIME_ALIVE
TI.ZPI1.SYS_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
TI.ZPI1.SYS_KEY_EVENT_RESPONSE | Response for SYS_KEY_EVENT
TI.ZPI1.SYS_LED_CONTROL | Use this message to control LEDs on the board.
TI.ZPI1.SYS_LED_CONTROL_RESPONSE | Response for SYS_LED_CONTROL
TI.ZPI1.SYS_PING | This command is used to check for a device
TI.ZPI1.SYS_PING_RESPONSE | Response for SYS_PING
TI.ZPI1.SYS_RAM_READ | This command is used by the tester to read a single memory location in the target RAM. THe command accepts an address value and returns the memory value present in the target RAM at that address.
TI.ZPI1.SYS_RAM_READ_RESPONSE | Response for SYS_RAM_READ
TI.ZPI1.SYS_RAM_WRITE | This command is used by the tester to write to a particular location in the target RAM. The command accepts an address location and a memory value. The memory value is written to the address location in the target RAM
TI.ZPI1.SYS_RAM_WRITE_RESPONSE | Response for SYS_RAM_WRITE
TI.ZPI1.SYS_RESET | This command is sent by the tester to the target to reset it
TI.ZPI1.SYS_RESET_RESPONSE | Response for SYS_RESET. This response is sent from the target device or serial bootloader after the requested reset is complete.
TI.ZPI1.SYS_SET_CHANNELS | Use this message to set the channels.
TI.ZPI1.SYS_SET_CHANNELS_RESPONSE | Response for SYS_SET_CHANNELS
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS | Set the 64-bit extended address.
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_SET_EXTENDED_ADDRESS
TI.ZPI1.SYS_SET_NV | This command is used by the tester to write to a particular location in non-volatile memory. The command accepts an address location and a memory value. The memory value is written to the address location in the target.
TI.ZPI1.SYS_SET_NV_RESPONSE | Response for SYS_SET_NV
TI.ZPI1.SYS_SET_PANID | Use this message to set PANID.
TI.ZPI1.SYS_SET_PANID_RESPONSE | Response for SYS_SET_PANID
TI.ZPI1.SYS_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
TI.ZPI1.SYS_SET_PRECONFIG_KEY_RESPONSE | Response for SYS_SET_PRECONFIG_KEY
TI.ZPI1.SYS_SET_SECURITY_LEVEL | Use this message to set the security level.
TI.ZPI1.SYS_SET_SECURITY_LEVEL_RESPONSE | Response for SYS_SET_SECURITY_LEVEL
TI.ZPI1.SYS_SET_SECURITY_MODE | Use this message to get the NV information.
TI.ZPI1.SYS_SET_SECURITY_MODE_RESPONSE | Response for SYS_SET_SECURITY_MODE
TI.ZPI1.SYS_STRING_RESPONSE | Debug message sent by device
TI.ZPI1.SYS_VERSION | Ask for the device's version string.
TI.ZPI1.SYS_VERSION_RESPONSE | Response for SYS_VERSION

See Also

ISYSTEM Members
TI.ZPI1 Namespace


IUSERTEST Interface

IUSERTEST Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IUSERTEST
C#
public interface IUSERTEST
C++
interface class IUSERTEST
J#
public interface IUSERTEST
JScript
public interface IUSERTEST

Types that implement IUSERTEST

Type | Description
TI.ZPI1.USERTEST_REQUEST | This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).
TI.ZPI1.USERTEST_RESPONSE | Response for USERTEST_REQUEST

See Also

IUSERTEST Members
TI.ZPI1 Namespace


IZDO Interface

IZDO Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IZDO
C#
public interface IZDO
C++
interface class IZDO
J#
public interface IZDO
JScript
public interface IZDO

Types that implement IZDO

Type | Description
TI.ZPI1.ZDO_ACTIVEENDPOINT_REQUEST | This command is generated to request a list of active endpoint from the destination device.
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSE | Response for ZDO_ACTIVEENDPOINT_REQUEST
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSECB | This callback message is in response to the ZDO Active Endpoint Request.
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST | This command will tell the ZDO to request an End Device Bind. The ZDO will send the message to the Zigbee coordinator based on the information found in the AF Endpoint description for the passed in endpoint.
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE | Response for ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST
TI.ZPI1.ZDO_AUTOFINDDESTINATION_REQUEST | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
TI.ZPI1.ZDO_AUTOFINDDESTINATION_RESPONSE | Response for ZDO_AUTOFINDDESTINATION_REQUEST
TI.ZPI1.ZDO_BIND_REQUEST | This command is generated to request a Bind
TI.ZPI1.ZDO_BIND_RESPONSE | Response for ZDO_BIND_REQUEST
TI.ZPI1.ZDO_BIND_RESPONSECB | This callback message is in response to the ZDO Bind Request
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_REQUEST | This command is generated to request for the destination device's complex descriptor
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_RESPONSE | Response for ZDO_COMPLEXDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
TI.ZPI1.ZDO_END_DEVICE_ANNCE_RESPONSE | Response for ZDO_END_DEVICE_ANNCE_REQUEST
TI.ZPI1.ZDO_ENDDEVICEBIND_REQUEST | This command is generated to request an End Device Bind with the destination device
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSE | Response for ZDO_ENDDEVICEBIND_REQUEST
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSECB | This callback message is in response to the ZDO End Device Bind Request
TI.ZPI1.ZDO_IEEEADDRESS_REQUEST | This command will request a device's IEEE 64-bit address. You must subscribe to "ZDO IEEE Address Response" to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSE | Response for ZDO_IEEEADDRESS_REQUEST
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSECB | This callback message is in response to the ZDO IEEE Address Request.
TI.ZPI1.ZDO_MATCHDESCRIPTOR_REQUEST | This command is generated to request a list of active endpoint from the destination device
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSE | Response for ZDO_MATCHDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Match Description Request
TI.ZPI1.ZDO_MGMT_BIND_REQUEST | This command is generated to request a Management Binding Table Request.
TI.ZPI1.ZDO_MGMT_BIND_RESPONSE | Response for ZDO_MGMT_BIND_REQUEST
TI.ZPI1.ZDO_MGMT_BIND_RESPONSECB | This callback message is in response to the ZDO Management Binding Table Request
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_REQUEST | This command is generated to request a Management Direct Join Request
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSE | Response for ZDO_MGMT_DIRECT_JOIN_REQUEST
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Direct Join Request.
TI.ZPI1.ZDO_MGMT_LEAVE_REQUEST | This command is generated to request a Management Leave Request
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSE | Response for ZDO_MGMT_LEAVE_REQUEST
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSECB | This callback message is in response to the ZDO Management Leave Request.
TI.ZPI1.ZDO_MGMT_LQI_REQUEST | This command is generated to request a Management LQI Request.
TI.ZPI1.ZDO_MGMT_LQI_RESPONSE | Response for ZDO_MGMT_LQI_REQUEST
TI.ZPI1.ZDO_MGMT_LQI_RESPONSECB | This callback message is in response to the ZDO Management LQI Request.
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_NOTIFYCB | This callback message is in response to the Mgmt NWK Update Request. Upon receiving the request, remote device shall determine from the contents of the ScanDuration parameter whether this request is an update to the apsChannelMask and nwkManagerAddr parameters, a channel change command, or a request to scan channels and report the results
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
TI.ZPI1.ZDO_MGMT_NWKDISC_REQUEST | This command is generated to request a Management Network Discovery Request
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSE | Response for ZDO_MGMT_NWKDISC_REQUEST
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSECB | This callback message is in response to the ZDO Management Network Discovery Request
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSE | Response for ZDO_MGMT_PERMIT_JOIN_REQUEST
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
TI.ZPI1.ZDO_MGMT_RTG_REQUEST | This command is generated to request a Management Routing Table Request.
TI.ZPI1.ZDO_MGMT_RTG_RESPONSE | Response for ZDO_MGMT_RTG_REQUEST
TI.ZPI1.ZDO_MGMT_RTG_RESPONSECB | This callback message is in response to the ZDO Management Routing Table Request.
TI.ZPI1.ZDO_NETWORK_START_REQUEST | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
TI.ZPI1.ZDO_NETWORK_START_RESPONSE | Response for ZDO_NETWORK_START_REQUEST
TI.ZPI1.ZDO_NETWORKADDRESS_REQUEST | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSE | Response for ZDO_NETWORKADDRESS_REQUEST
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSECB | This callback message is in response to the ZDO Network Address Request.
TI.ZPI1.ZDO_NODEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Node Descriptor of the destination device
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSE | Response for ZDO_NODEDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Node Descriptor Request.
TI.ZPI1.ZDO_POWERDESCRIPTOR_REQUEST | This command is generated to inquire as to the Power Descriptor of the destination
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSE | Response for ZDO_POWERDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Power Descriptor Request.
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSE | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Simple Descriptor Request.
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_REQUEST | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSE | Response for ZDO_SYSTEM_SERVER_DISC_REQUEST
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
TI.ZPI1.ZDO_UNBIND_REQUEST | This command is generated to request an UnBind
TI.ZPI1.ZDO_UNBIND_RESPONSE | Response for ZDO_UNBIND_REQUEST
TI.ZPI1.ZDO_UNBIND_RESPONSECB | This callback message is in response to the ZDO UnBind Request
TI.ZPI1.ZDO_USERDESCRIPTOR_REQUEST | This command is generated to request for the destination device's user descriptor
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSE | Response for ZDO_USERDESCRIPTOR_REQUEST
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO User Description Request.
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_REQUEST | This command is generated to request a User Descriptor Set Request
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSE | Response for ZDO_USERDESCRIPTOR_SET_REQUEST
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSECB | This callback message is in response to the ZDO User Descriptor Set Request.

See Also

IZDO Members
TI.ZPI1 Namespace


IZMAC Interface

IZMAC Interface
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IZMAC
C#
public interface IZMAC
C++
interface class IZMAC
J#
public interface IZMAC
JScript
public interface IZMAC

Types that implement IZMAC

Type | Description
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND | This command is used to send (on behalf of the next higher layer) an association response message
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND_RESPONSE | Response for ZMAC_ASSOCIATE_RESPOND
TI.ZPI1.ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
TI.ZPI1.ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
TI.ZPI1.ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
TI.ZPI1.ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
TI.ZPI1.ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
TI.ZPI1.ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
TI.ZPI1.ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
TI.ZPI1.ZMAC_INIT_RESPONSE | Response for ZMAC_INIT_REQUEST
TI.ZPI1.ZMAC_ORPHAN_RESPOND | This command is used to send a response to the Orphan Indication message.
TI.ZPI1.ZMAC_ORPHAN_RESPOND_RESPONSE | Response for ZMAC_ORPHAN_RESPOND
TI.ZPI1.ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
TI.ZPI1.ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
TI.ZPI1.ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
TI.ZPI1.ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
TI.ZPI1.ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
TI.ZPI1.ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
TI.ZPI1.ZMAC_RX_ENABLE_REQUEST | This command contains timing information that tells the device when to enable or disable its receiver, in order to schedule a data transfer between itself and another device. The information is sent from the upper layers directly to the MAC sublayer.
TI.ZPI1.ZMAC_RX_ENABLE_RESPONSE | Response for ZMAC_RX_ENABLE_REQUEST
TI.ZPI1.ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
TI.ZPI1.ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
TI.ZPI1.ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
TI.ZPI1.ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
TI.ZPI1.ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
TI.ZPI1.ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
TI.ZPI1.ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon
TI.ZPI1.ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST

See Also

IZMAC Members
TI.ZPI1 Namespace


MESSAGE_ID Enumeration

MESSAGE_ID Enumeration
[image]

Contains SPI message ID's

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum MESSAGE_ID
C#
public enum MESSAGE_ID
C++
public enum class MESSAGE_ID
J#
public enum MESSAGE_ID
JScript
public enum MESSAGE_ID

Members

Member Name | Description
SYS_RAM_READ | This command is used by the tester to read a single memory location in the target RAM. THe command accepts an address value and returns the memory value present in the target RAM at that address.
SYS_RAM_WRITE | This command is used by the tester to write to a particular location in the target RAM. The command accepts an address location and a memory value. The memory value is written to the address location in the target RAM
SYS_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
SYS_RESET | This command is sent by the tester to the target to reset it
SYS_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
SYS_PING | This command is used to check for a device
SYS_VERSION | Ask for the device's version string.
SYS_SET_EXTENDED_ADDRESS | Set the 64-bit extended address.
SYS_GET_EXTENDED_ADDRESS | Read the extended address from the device.
SYS_SET_NV | This command is used by the tester to write to a particular location in non-volatile memory. The command accepts an address location and a memory value. The memory value is written to the address location in the target.
SYS_GET_NV | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
SYS_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
SYS_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
SYS_APP_MSG | Use this message to send raw data to an application.
SYS_LED_CONTROL | Use this message to control LEDs on the board.
SYS_GET_TIME_ALIVE | Use this message to get board's time alive.
SYS_SET_PANID | Use this message to set PANID.
SYS_SET_CHANNELS | Use this message to set the channels.
SYS_SET_SECURITY_LEVEL | Use this message to set the security level.
SYS_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
SYS_GET_NV_INFO | Use this message to get the NV information.
SYS_SET_SECURITY_MODE | Use this message to get the NV information.
ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
ZMAC_ASSOCIATE_RESPOND | This command is used to send (on behalf of the next higher layer) an association response message
ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
ZMAC_ORPHAN_RESPOND | This command is used to send a response to the Orphan Indication message.
ZMAC_RX_ENABLE_REQUEST | This command contains timing information that tells the device when to enable or disable its receiver, in order to schedule a data transfer between itself and another device. The information is sent from the upper layers directly to the MAC sublayer.
ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon
ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
NLME_SYNC_REQUEST | This primitive allows the next higher layer to synchronize or extract data from its ZigBee coordinator or router
NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
APSDE_DATA_CONFIRMATION | This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.
AF_INIT_REQUEST | This command enables the tester to initialize the target AF.
AF_REGISTER_REQUEST | This command enables the tester to register an application's endpoint description
AF_SENDMSG_REQUEST | This command is used to build and send a data packet.
AF_INCOMINGDATA_INDICATION | This command is used by the device to indicate a received packet.
AF_SENDMSG_CONFIRM | This command contains status of a AF_SENDMSG_REQUEST
ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST | This command will tell the ZDO to request an End Device Bind. The ZDO will send the message to the Zigbee coordinator based on the information found in the AF Endpoint description for the passed in endpoint.
ZDO_AUTOFINDDESTINATION_REQUEST | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
ZDO_NETWORKADDRESS_REQUEST | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
ZDO_IEEEADDRESS_REQUEST | This command will request a device's IEEE 64-bit address. You must subscribe to "ZDO IEEE Address Response" to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
ZDO_NODEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Node Descriptor of the destination device
ZDO_POWERDESCRIPTOR_REQUEST | This command is generated to inquire as to the Power Descriptor of the destination
ZDO_SIMPLEDESCRIPTOR_REQUEST | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
ZDO_ACTIVEENDPOINT_REQUEST | This command is generated to request a list of active endpoint from the destination device.
ZDO_MATCHDESCRIPTOR_REQUEST | This command is generated to request a list of active endpoint from the destination device
ZDO_COMPLEXDESCRIPTOR_REQUEST | This command is generated to request for the destination device's complex descriptor
ZDO_USERDESCRIPTOR_REQUEST | This command is generated to request for the destination device's user descriptor
ZDO_ENDDEVICEBIND_REQUEST | This command is generated to request an End Device Bind with the destination device
ZDO_BIND_REQUEST | This command is generated to request a Bind
ZDO_UNBIND_REQUEST | This command is generated to request an UnBind
ZDO_MGMT_NWKDISC_REQUEST | This command is generated to request a Management Network Discovery Request
ZDO_MGMT_LQI_REQUEST | This command is generated to request a Management LQI Request.
ZDO_MGMT_RTG_REQUEST | This command is generated to request a Management Routing Table Request.
ZDO_MGMT_BIND_REQUEST | This command is generated to request a Management Binding Table Request.
ZDO_MGMT_DIRECT_JOIN_REQUEST | This command is generated to request a Management Direct Join Request
ZDO_USERDESCRIPTOR_SET_REQUEST | This command is generated to request a User Descriptor Set Request
ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
ZDO_MGMT_LEAVE_REQUEST | This command is generated to request a Management Leave Request
ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
ZDO_SYSTEM_SERVER_DISC_REQUEST | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
ZDO_NETWORK_START_REQUEST | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
ZDO_NETWORKADDRESS_RESPONSECB | This callback message is in response to the ZDO Network Address Request.
ZDO_IEEEADDRESS_RESPONSECB | This callback message is in response to the ZDO IEEE Address Request.
ZDO_NODEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Node Descriptor Request.
ZDO_POWERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Power Descriptor Request.
ZDO_SIMPLEDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Simple Descriptor Request.
ZDO_ACTIVEENDPOINT_RESPONSECB | This callback message is in response to the ZDO Active Endpoint Request.
ZDO_MATCHDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO Match Description Request
ZDO_ENDDEVICEBIND_RESPONSECB | This callback message is in response to the ZDO End Device Bind Request
ZDO_BIND_RESPONSECB | This callback message is in response to the ZDO Bind Request
ZDO_UNBIND_RESPONSECB | This callback message is in response to the ZDO UnBind Request
ZDO_MGMT_NWKDISC_RESPONSECB | This callback message is in response to the ZDO Management Network Discovery Request
ZDO_MGMT_LQI_RESPONSECB | This callback message is in response to the ZDO Management LQI Request.
ZDO_MGMT_RTG_RESPONSECB | This callback message is in response to the ZDO Management Routing Table Request.
ZDO_MGMT_BIND_RESPONSECB | This callback message is in response to the ZDO Management Binding Table Request
ZDO_MGMT_DIRECT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Direct Join Request.
ZDO_USERDESCRIPTOR_RESPONSECB | This callback message is in response to the ZDO User Description Request.
ZDO_USERDESCRIPTOR_SET_RESPONSECB | This callback message is in response to the ZDO User Descriptor Set Request.
ZDO_MGMT_LEAVE_RESPONSECB | This callback message is in response to the ZDO Management Leave Request.
ZDO_MGMT_PERMIT_JOIN_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
ZDO_SYSTEM_SERVER_DISC_RESPONSECB | This callback message is in response to the ZDO Management Permit Join Request
ZDO_MGMT_NWK_UPDATE_NOTIFYCB | This callback message is in response to the Mgmt NWK Update Request. Upon receiving the request, remote device shall determine from the contents of the ScanDuration parameter whether this request is an update to the apsChannelMask and nwkManagerAddr parameters, a channel change command, or a request to scan channels and report the results
USERTEST_REQUEST | This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).
SYS_RAM_READ_RESPONSE | Response for SYS_RAM_READ
SYS_RAM_WRITE_RESPONSE | Response for SYS_RAM_WRITE
SYS_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
SYS_RESET_RESPONSE | Response for SYS_RESET. This response is sent from the target device or serial bootloader after the requested reset is complete.
SYS_CALLBACK_SUBSCRIBE_RESPONSE | Response for SYS_CALLBACK_SUBSCRIBE
SYS_PING_RESPONSE | Response for SYS_PING
SYS_VERSION_RESPONSE | Response for SYS_VERSION
SYS_SET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_SET_EXTENDED_ADDRESS
SYS_GET_EXTENDED_ADDRESS_RESPONSE | Response for SYS_GET_EXTENDED_ADDRESS
SYS_SET_NV_RESPONSE | Response for SYS_SET_NV
SYS_GET_NV_RESPONSE | Response for SYS_GET_NV
SYS_GET_DEVICE_INFO_RESPONSE | Response for SYS_GET_DEVICE_INFO
SYS_STRING_RESPONSE | Debug message sent by device
SYS_KEY_EVENT_RESPONSE | Response for SYS_KEY_EVENT
SYS_APP_MSG_RESPONSE | Response for SYS_APP_MSG
SYS_LED_CONTROL_RESPONSE | Response for SYS_LED_CONTROL
SYS_GET_TIME_ALIVE_RESPONSE | Response for SYS_GET_TIME_ALIVE
SYS_SET_PANID_RESPONSE | Response for SYS_SET_PANID
SYS_SET_CHANNELS_RESPONSE | Response for SYS_SET_CHANNELS
SYS_SET_SECURITY_LEVEL_RESPONSE | Response for SYS_SET_SECURITY_LEVEL
SYS_SET_PRECONFIG_KEY_RESPONSE | Response for SYS_SET_PRECONFIG_KEY
SYS_GET_NV_INFO_RESPONSE | Response for SYS_GET_NV_INFO
SYS_SET_SECURITY_MODE_RESPONSE | Response for SYS_SET_SECURITY_MODE
ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
ZMAC_INIT_RESPONSE | Response for ZMAC_INIT_REQUEST
ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
ZMAC_ASSOCIATE_RESPOND_RESPONSE | Response for ZMAC_ASSOCIATE_RESPOND
ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
ZMAC_ORPHAN_RESPOND_RESPONSE | Response for ZMAC_ORPHAN_RESPOND
ZMAC_RX_ENABLE_RESPONSE | Response for ZMAC_RX_ENABLE_REQUEST
ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST
ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
NLME_SYNC_RESPONSE | Response for NLME_SYNC_REQUEST
NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
APSME_BIND_RESPONSE | Response for APSME_BIND
AF_INIT_RESPONSE | Response for AF_INIT_REQUEST
AF_REGISTER_RESPONSE | Response for AF_REGISTER_REQUEST
AF_SENDMSG_RESPONSE | Response for AF_SENDMSG_REQUEST
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE | Response for ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST
ZDO_AUTOFINDDESTINATION_RESPONSE | Response for ZDO_AUTOFINDDESTINATION_REQUEST
ZDO_NETWORKADDRESS_RESPONSE | Response for ZDO_NETWORKADDRESS_REQUEST
ZDO_IEEEADDRESS_RESPONSE | Response for ZDO_IEEEADDRESS_REQUEST
ZDO_NODEDESCRIPTOR_RESPONSE | Response for ZDO_NODEDESCRIPTOR_REQUEST
ZDO_POWERDESCRIPTOR_RESPONSE | Response for ZDO_POWERDESCRIPTOR_REQUEST
ZDO_SIMPLEDESCRIPTOR_RESPONSE | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
ZDO_ACTIVEENDPOINT_RESPONSE | Response for ZDO_ACTIVEENDPOINT_REQUEST
ZDO_MATCHDESCRIPTOR_RESPONSE | Response for ZDO_MATCHDESCRIPTOR_REQUEST
ZDO_COMPLEXDESCRIPTOR_RESPONSE | Response for ZDO_COMPLEXDESCRIPTOR_REQUEST
ZDO_USERDESCRIPTOR_RESPONSE | Response for ZDO_USERDESCRIPTOR_REQUEST
ZDO_ENDDEVICEBIND_RESPONSE | Response for ZDO_ENDDEVICEBIND_REQUEST
ZDO_BIND_RESPONSE | Response for ZDO_BIND_REQUEST
ZDO_UNBIND_RESPONSE | Response for ZDO_UNBIND_REQUEST
ZDO_MGMT_NWKDISC_RESPONSE | Response for ZDO_MGMT_NWKDISC_REQUEST
ZDO_MGMT_LQI_RESPONSE | Response for ZDO_MGMT_LQI_REQUEST
ZDO_MGMT_RTG_RESPONSE | Response for ZDO_MGMT_RTG_REQUEST
ZDO_MGMT_BIND_RESPONSE | Response for ZDO_MGMT_BIND_REQUEST
ZDO_MGMT_DIRECT_JOIN_RESPONSE | Response for ZDO_MGMT_DIRECT_JOIN_REQUEST
ZDO_USERDESCRIPTOR_SET_RESPONSE | Response for ZDO_USERDESCRIPTOR_SET_REQUEST
ZDO_END_DEVICE_ANNCE_RESPONSE | Response for ZDO_END_DEVICE_ANNCE_REQUEST
ZDO_MGMT_LEAVE_RESPONSE | Response for ZDO_MGMT_LEAVE_REQUEST
ZDO_MGMT_PERMIT_JOIN_RESPONSE | Response for ZDO_MGMT_PERMIT_JOIN_REQUEST
ZDO_SYSTEM_SERVER_DISC_RESPONSE | Response for ZDO_SYSTEM_SERVER_DISC_REQUEST
ZDO_NETWORK_START_RESPONSE | Response for ZDO_NETWORK_START_REQUEST
ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
USERTEST_RESPONSE | Response for USERTEST_REQUEST
NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon
NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
NWK_COMM_STATUS_INDICATION | This function reports a comm status error
NWK_START_CONFIRMATION | This function reports the success of the start request.
NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
ZB_SYS_RESET | Reboot the device (zb_SystemReset)
ZB_START_REQ | Starts the ZigBee stack (zb_StartRequest).
ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
ZB_SEND_DATA | Send a data packet to another device (zb_SendDataRequest).
ZB_READ_CFG | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
ZB_WRITE_CFG | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
ZB_GET_DEV_INFO | Reads current device infromation.
ZB_FIND_DEV | Search for a device's short address given its IEEE address.
ZB_PERMIT_JOIN | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
ZB_START_REQ_RSP | Response for ZB_START_REQ
ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
ZB_SEND_DATA_RSP | Response for ZB_SEND_DATA
ZB_WRITE_CFG_RSP | Response for ZB_WRITE_CFG
ZB_FIND_DEV_RSP | Response for ZB_FIND_DEV
ZB_PERMIT_JOIN_RSP | Response for SYS_PERMIT_JOIN
ZB_START_CNF | (zb_StartConfirm)
ZB_SEND_DATA_CNF | (zb_SendDataConfirm)
ZB_BIND_CNF | (zb_BindConfirm)
ZB_FIND_DEV_CNF | (zb_FindDeviceConfirm)
ZB_RCV_DATA_IND | (zb_ReceiveDataIndication)
ZB_READ_CFG_RSP |
ZB_GET_DEV_INFO_RSP | Response for ZB_GET_DEV_INFO
ZB_ALLOW_BIND_CNF |

See Also

TI.ZPI1 Namespace


NLDE_DATA_CONFIRMATION Class

NLDE_DATA_CONFIRMATION Class
See Also Example Members
[image]

This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLDE_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLDE_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLDE_DATA_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLDE_DATA_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLDE_DATA_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_CONFIRMATION Members
TI.ZPI1 Namespace


NLDE_DATA_CONFIRMATION Members

NLDE_DATA_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.

The following tables list the members exposed by NLDE_DATA_CONFIRMATION.

Public Constructors

Name | Description
NLDE_DATA_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NSDUHandle | indicates the transaction handle (that was created when the data request was issued)
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_CONFIRMATION | Overloaded.
Top

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


NLDE_DATA_CONFIRMATION Constructor

NLDE_DATA_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_CONFIRMATION | Constructor
Public method | NLDE_DATA_CONFIRMATION (Byte, NLDE_DATA_CONFIRMATION.CMD_STATUS) |

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


NLDE_DATA_CONFIRMATION Constructor ()

NLDE_DATA_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_CONFIRMATION()
C++
public:
NLDE_DATA_CONFIRMATION() sealed
J#
public NLDE_DATA_CONFIRMATION()
JScript
public function NLDE_DATA_CONFIRMATION()

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace
NLDE_DATA_CONFIRMATION Constructor Overload List


NLDE_DATA_CONFIRMATION Constructor (Byte, NLDE_DATA_CONFIRMATION.CMD_STATUS)

NLDE_DATA_CONFIRMATION Constructor (Byte, NLDE_DATA_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As NLDE_DATA_CONFIRMATION.CMD_STATUS _
)
C#
public NLDE_DATA_CONFIRMATION(
byte ,
NLDE_DATA_CONFIRMATION.CMD_STATUS
)
C++
public:
NLDE_DATA_CONFIRMATION(
char ,
NLDE_DATA_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLDE_DATA_CONFIRMATION(
byte ,
NLDE_DATA_CONFIRMATION.CMD_STATUS
)
JScript
public function NLDE_DATA_CONFIRMATION(
: Byte,
: NLDE_DATA_CONFIRMATION.CMD_STATUS
)

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace
NLDE_DATA_CONFIRMATION Constructor Overload List


Fields

NLDE_DATA_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | NSDUHandle | indicates the transaction handle (that was created when the data request was issued)
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


NSDUHandle Field

NLDE_DATA_CONFIRMATION.NSDUHandle Field
[image]

indicates the transaction handle (that was created when the data request was issued)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDUHandle As Byte
C#
public byte NSDUHandle;
C++
public:
char NSDUHandle sealed ;
J#
public byte NSDUHandle
JScript
public NSDUHandle : Byte;

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NLDE_DATA_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLDE_DATA_CONFIRMATION.CMD_STATUS
C#
public NLDE_DATA_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLDE_DATA_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLDE_DATA_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLDE_DATA_CONFIRMATION.CMD_STATUS;

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


NLDE_DATA_CONFIRMATION.CMD_STATUS Enumeration

NLDE_DATA_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLDE_DATA_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLDE_DATA_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLDE_DATA_CONFIRMATION.CMD_STATUS : char
J#
public enum NLDE_DATA_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLDE_DATA_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLDE_DATA_INDICATION Class

NLDE_DATA_INDICATION Class
See Also Example Members
[image]

This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLDE_DATA_INDICATION : IINDICATION, INETWORK
C++
ref class NLDE_DATA_INDICATION : IINDICATION, INETWORK
J#
public class NLDE_DATA_INDICATION implements IINDICATION, INETWORK
JScript
public class NLDE_DATA_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLDE_DATA_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_INDICATION Members
TI.ZPI1 Namespace


NLDE_DATA_INDICATION Members

NLDE_DATA_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.

The following tables list the members exposed by NLDE_DATA_INDICATION.

Public Constructors

Name | Description
NLDE_DATA_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | LinkQuality | indicates the link quality measured during reception
Public field | NSDU | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | NSDULength | indicates the length of the NSDU
Public field | SrcAddress | short address of the source device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_INDICATION | Overloaded.
Top

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace


NLDE_DATA_INDICATION Constructor

NLDE_DATA_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_INDICATION | Constructor
Public method | NLDE_DATA_INDICATION (UInt16, Byte, Byte, Byte) | Constructor

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace


NLDE_DATA_INDICATION Constructor ()

NLDE_DATA_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_INDICATION()
C++
public:
NLDE_DATA_INDICATION() sealed
J#
public NLDE_DATA_INDICATION()
JScript
public function NLDE_DATA_INDICATION()

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace
NLDE_DATA_INDICATION Constructor Overload List


NLDE_DATA_INDICATION Constructor (UInt16, Byte, Byte[], Byte)

NLDE_DATA_INDICATION Constructor (UInt16, Byte, Byte[], Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte _
)
C#
public NLDE_DATA_INDICATION(
ushort ,
byte ,
byte[] ,
byte
)
C++
public:
NLDE_DATA_INDICATION(
unsigned short ,
char ,
array<char>^ ,
char
) sealed
J#
public NLDE_DATA_INDICATION(
ushort ,
byte ,
byte[] ,
byte
)
JScript
public function NLDE_DATA_INDICATION(
: UInt16,
: Byte,
: Byte[],
: Byte
)

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace
NLDE_DATA_INDICATION Constructor Overload List


Fields

NLDE_DATA_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | LinkQuality | indicates the link quality measured during reception
Public field | NSDU | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | NSDULength | indicates the length of the NSDU
Public field | SrcAddress | short address of the source device
Top

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace


LinkQuality Field

NLDE_DATA_INDICATION.LinkQuality Field
[image]

indicates the link quality measured during reception

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace


NSDU Field

NLDE_DATA_INDICATION.NSDU Field
[image]

Dynamic array, actual network data packet which is of size indicated by NSDULength

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDU As Byte()
C#
public byte[] NSDU;
C++
public:
array<char>^ NSDU sealed ;
J#
public byte[] NSDU
JScript
public NSDU : Byte[];

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace


NSDULength Field

NLDE_DATA_INDICATION.NSDULength Field
[image]

indicates the length of the NSDU

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDULength As Byte
C#
public byte NSDULength;
C++
public:
char NSDULength sealed ;
J#
public byte NSDULength
JScript
public NSDULength : Byte;

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace


SrcAddress Field

NLDE_DATA_INDICATION.SrcAddress Field
[image]

short address of the source device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

NLDE_DATA_INDICATION Class
TI.ZPI1 Namespace


NLDE_DATA_REQUEST Class

NLDE_DATA_REQUEST Class
See Also Example Members
[image]

This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLDE_DATA_REQUEST : IREQUEST, INETWORK
C++
ref class NLDE_DATA_REQUEST : IREQUEST, INETWORK
J#
public class NLDE_DATA_REQUEST implements IREQUEST, INETWORK
JScript
public class NLDE_DATA_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLDE_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_REQUEST Members
TI.ZPI1 Namespace


NLDE_DATA_REQUEST Members

NLDE_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.

The following tables list the members exposed by NLDE_DATA_REQUEST.

Public Constructors

Name | Description
NLDE_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | short address of the destination device.
Public field | DiscoverRoute | if set to TRUE ( non-zero value ), will attempt a route discovery operation for the destination device if no route already exists.
Public field | NSDU | the actual network data packet which is of size indicated by nsduLength.
Public field | NSDUHandle | the transaction handle (that was created when the data request was issued)
Public field | NSDUHandleOptions | the options applied to the transmission of this packet.
Public field | NSDULength | length of the NSDU.
Public field | RadiusCounter | determines how many hops this packet will travel in the network.
Public field | SecurityEnable | if set to FALSE (0x00), explicitly prohibits this packet from being secured.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_REQUEST | Overloaded.
Top

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


NLDE_DATA_REQUEST Constructor

NLDE_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_REQUEST | Constructor
Public method | NLDE_DATA_REQUEST (UInt16, Byte, Byte, Byte, UInt16, Byte, Byte, Byte) | Constructor

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


NLDE_DATA_REQUEST Constructor ()

NLDE_DATA_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_REQUEST()
C++
public:
NLDE_DATA_REQUEST() sealed
J#
public NLDE_DATA_REQUEST()
JScript
public function NLDE_DATA_REQUEST()

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace
NLDE_DATA_REQUEST Constructor Overload List


NLDE_DATA_REQUEST Constructor (UInt16, Byte, Byte[], Byte, UInt16, Byte, Byte, Byte)

NLDE_DATA_REQUEST Constructor (UInt16, Byte, Byte[], Byte, UInt16, Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLDE_DATA_REQUEST(
ushort ,
byte ,
byte[] ,
byte ,
ushort ,
byte ,
byte ,
byte
)
C++
public:
NLDE_DATA_REQUEST(
unsigned short ,
char ,
array<char>^ ,
char ,
unsigned short ,
char ,
char ,
char
) sealed
J#
public NLDE_DATA_REQUEST(
ushort ,
byte ,
byte[] ,
byte ,
ushort ,
byte ,
byte ,
byte
)
JScript
public function NLDE_DATA_REQUEST(
: UInt16,
: Byte,
: Byte[],
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte
)

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace
NLDE_DATA_REQUEST Constructor Overload List


Fields

NLDE_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | short address of the destination device.
Public field | DiscoverRoute | if set to TRUE ( non-zero value ), will attempt a route discovery operation for the destination device if no route already exists.
Public field | NSDU | the actual network data packet which is of size indicated by nsduLength.
Public field | NSDUHandle | the transaction handle (that was created when the data request was issued)
Public field | NSDUHandleOptions | the options applied to the transmission of this packet.
Public field | NSDULength | length of the NSDU.
Public field | RadiusCounter | determines how many hops this packet will travel in the network.
Public field | SecurityEnable | if set to FALSE (0x00), explicitly prohibits this packet from being secured.
Top

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


DestAddress Field

NLDE_DATA_REQUEST.DestAddress Field
[image]

short address of the destination device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt16
C#
public ushort DestAddress;
C++
public:
unsigned short DestAddress sealed ;
J#
public ushort DestAddress
JScript
public DestAddress : UInt16;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


DiscoverRoute Field

NLDE_DATA_REQUEST.DiscoverRoute Field
[image]

if set to TRUE ( non-zero value ), will attempt a route discovery operation for the destination device if no route already exists.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DiscoverRoute As Byte
C#
public byte DiscoverRoute;
C++
public:
char DiscoverRoute sealed ;
J#
public byte DiscoverRoute
JScript
public DiscoverRoute : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


NSDU Field

NLDE_DATA_REQUEST.NSDU Field
[image]

the actual network data packet which is of size indicated by nsduLength.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDU As Byte()
C#
public byte[] NSDU;
C++
public:
array<char>^ NSDU sealed ;
J#
public byte[] NSDU
JScript
public NSDU : Byte[];

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


NSDUHandle Field

NLDE_DATA_REQUEST.NSDUHandle Field
[image]

the transaction handle (that was created when the data request was issued)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDUHandle As Byte
C#
public byte NSDUHandle;
C++
public:
char NSDUHandle sealed ;
J#
public byte NSDUHandle
JScript
public NSDUHandle : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


NSDUHandleOptions Field

NLDE_DATA_REQUEST.NSDUHandleOptions Field
[image]

the options applied to the transmission of this packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDUHandleOptions As UInt16
C#
public ushort NSDUHandleOptions;
C++
public:
unsigned short NSDUHandleOptions sealed ;
J#
public ushort NSDUHandleOptions
JScript
public NSDUHandleOptions : UInt16;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


NSDULength Field

NLDE_DATA_REQUEST.NSDULength Field
[image]

length of the NSDU.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDULength As Byte
C#
public byte NSDULength;
C++
public:
char NSDULength sealed ;
J#
public byte NSDULength
JScript
public NSDULength : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


RadiusCounter Field

NLDE_DATA_REQUEST.RadiusCounter Field
[image]

determines how many hops this packet will travel in the network.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RadiusCounter As Byte
C#
public byte RadiusCounter;
C++
public:
char RadiusCounter sealed ;
J#
public byte RadiusCounter
JScript
public RadiusCounter : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


SecurityEnable Field

NLDE_DATA_REQUEST.SecurityEnable Field
[image]

if set to FALSE (0x00), explicitly prohibits this packet from being secured.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityEnable As Byte
C#
public byte SecurityEnable;
C++
public:
char SecurityEnable sealed ;
J#
public byte SecurityEnable
JScript
public SecurityEnable : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI1 Namespace


NLDE_DATA_RESPONSE Class

NLDE_DATA_RESPONSE Class
See Also Example Members
[image]

Response for NLDE_DATA_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLDE_DATA_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLDE_DATA_RESPONSE : IRESPONSE, INETWORK
J#
public class NLDE_DATA_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLDE_DATA_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLDE_DATA_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_RESPONSE Members
TI.ZPI1 Namespace


NLDE_DATA_RESPONSE Members

NLDE_DATA_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLDE_DATA_REQUEST

The following tables list the members exposed by NLDE_DATA_RESPONSE.

Public Constructors

Name | Description
NLDE_DATA_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_RESPONSE | Overloaded.
Top

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI1 Namespace


NLDE_DATA_RESPONSE Constructor

NLDE_DATA_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_RESPONSE | Constructor
Public method | NLDE_DATA_RESPONSE (NLDE_DATA_RESPONSE.NLDE_STATUS) |

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI1 Namespace


NLDE_DATA_RESPONSE Constructor ()

NLDE_DATA_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_RESPONSE()
C++
public:
NLDE_DATA_RESPONSE() sealed
J#
public NLDE_DATA_RESPONSE()
JScript
public function NLDE_DATA_RESPONSE()

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI1 Namespace
NLDE_DATA_RESPONSE Constructor Overload List


NLDE_DATA_RESPONSE Constructor (NLDE_DATA_RESPONSE.NLDE_STATUS)

NLDE_DATA_RESPONSE Constructor (NLDE_DATA_RESPONSE.NLDE_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLDE_DATA_RESPONSE.NLDE_STATUS _
)
C#
public NLDE_DATA_RESPONSE(
NLDE_DATA_RESPONSE.NLDE_STATUS
)
C++
public:
NLDE_DATA_RESPONSE(
NLDE_DATA_RESPONSE.NLDE_STATUS
) sealed
J#
public NLDE_DATA_RESPONSE(
NLDE_DATA_RESPONSE.NLDE_STATUS
)
JScript
public function NLDE_DATA_RESPONSE(
: NLDE_DATA_RESPONSE.NLDE_STATUS
)

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI1 Namespace
NLDE_DATA_RESPONSE Constructor Overload List


Fields

NLDE_DATA_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLDE_DATA_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLDE_DATA_RESPONSE.NLDE_STATUS
C#
public NLDE_DATA_RESPONSE.NLDE_STATUS Status;
C++
public:
NLDE_DATA_RESPONSE.NLDE_STATUS Status sealed ;
J#
public NLDE_DATA_RESPONSE.NLDE_STATUS Status
JScript
public Status : NLDE_DATA_RESPONSE.NLDE_STATUS;

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI1 Namespace


NLDE_DATA_RESPONSE.NLDE_STATUS Enumeration

NLDE_DATA_RESPONSE.NLDE_STATUS Enumeration
[image]

Status code for NLDE response

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLDE_DATA_RESPONSE.NLDE_STATUS As Byte
C#
public enum NLDE_DATA_RESPONSE.NLDE_STATUS : byte
C++
public enum class NLDE_DATA_RESPONSE.NLDE_STATUS : char
J#
public enum NLDE_DATA_RESPONSE.NLDE_STATUS byte
JScript
public enum NLDE_DATA_RESPONSE.NLDE_STATUS :

Members

Member Name | Description
NLDE_SUCCESS | Status code for NLDE response
NLDE_INVALID_TARGET | Status code for NLDE response
NLDE_INVALID_PARAMETER | Status code for NLDE response
NLDE_BUFFER_FULL | Status code for NLDE response
NLDE_MEMORY_ERROR | Status code for NLDE response
NLDE_INVALID_NETWORK_STATE | Status code for NLDE response
NLDE_FAILURE | Status code for NLDE response

See Also

TI.ZPI1 Namespace


NLME_DIRECTJOIN_REQUEST Class

NLME_DIRECTJOIN_REQUEST Class
See Also Example Members
[image]

NLME direct join request used by tester

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_DIRECTJOIN_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_DIRECTJOIN_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_DIRECTJOIN_REQUEST : IREQUEST, INETWORK
J#
public class NLME_DIRECTJOIN_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_DIRECTJOIN_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_DIRECTJOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_DIRECTJOIN_REQUEST Members
TI.ZPI1 Namespace


NLME_DIRECTJOIN_REQUEST Members

NLME_DIRECTJOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME direct join request used by tester

The following tables list the members exposed by NLME_DIRECTJOIN_REQUEST.

Public Constructors

Name | Description
NLME_DIRECTJOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | Extended address
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_DIRECTJOIN_REQUEST | Overloaded.
Top

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_DIRECTJOIN_REQUEST Constructor

NLME_DIRECTJOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_DIRECTJOIN_REQUEST | Constructor
Public method | NLME_DIRECTJOIN_REQUEST (UInt64, NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO) |

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_DIRECTJOIN_REQUEST Constructor ()

NLME_DIRECTJOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_DIRECTJOIN_REQUEST()
C++
public:
NLME_DIRECTJOIN_REQUEST() sealed
J#
public NLME_DIRECTJOIN_REQUEST()
JScript
public function NLME_DIRECTJOIN_REQUEST()

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI1 Namespace
NLME_DIRECTJOIN_REQUEST Constructor Overload List


NLME_DIRECTJOIN_REQUEST Constructor (UInt64, NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO)

NLME_DIRECTJOIN_REQUEST Constructor (UInt64, NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO _
)
C#
public NLME_DIRECTJOIN_REQUEST(
ulong ,
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
)
C++
public:
NLME_DIRECTJOIN_REQUEST(
unsigned __int64 ,
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
) sealed
J#
public NLME_DIRECTJOIN_REQUEST(
ulong ,
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
)
JScript
public function NLME_DIRECTJOIN_REQUEST(
: UInt64,
: NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
)

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI1 Namespace
NLME_DIRECTJOIN_REQUEST Constructor Overload List


Fields

NLME_DIRECTJOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | Extended address
Top

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI1 Namespace


CapabilityInfo Field

NLME_DIRECTJOIN_REQUEST.CapabilityInfo Field
[image]

bitmap which specifies the operational capabilities of the joining device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInfo As NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
C#
public NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO CapabilityInfo;
C++
public:
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO CapabilityInfo sealed ;
J#
public NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO CapabilityInfo
JScript
public CapabilityInfo : NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO;

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI1 Namespace


ExtendedAddress Field

NLME_DIRECTJOIN_REQUEST.ExtendedAddress Field
[image]

Extended address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedAddress As UInt64
C#
public ulong ExtendedAddress;
C++
public:
unsigned __int64 ExtendedAddress sealed ;
J#
public ulong ExtendedAddress
JScript
public ExtendedAddress : UInt64;

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO Enumeration

NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO byte
JScript
public enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI1 Namespace


NLME_DIRECTJOIN_RESPONSE Class

NLME_DIRECTJOIN_RESPONSE Class
See Also Example Members
[image]

Response for NLME_DIRECTJOIN_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_DIRECTJOIN_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_DIRECTJOIN_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_DIRECTJOIN_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_DIRECTJOIN_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_DIRECTJOIN_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_DIRECTJOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_DIRECTJOIN_RESPONSE Members
TI.ZPI1 Namespace


NLME_DIRECTJOIN_RESPONSE Members

NLME_DIRECTJOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_DIRECTJOIN_REQUEST

The following tables list the members exposed by NLME_DIRECTJOIN_RESPONSE.

Public Constructors

Name | Description
NLME_DIRECTJOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_DIRECTJOIN_RESPONSE | Overloaded.
Top

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_DIRECTJOIN_RESPONSE Constructor

NLME_DIRECTJOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_DIRECTJOIN_RESPONSE | Constructor
Public method | NLME_DIRECTJOIN_RESPONSE (NLME_DIRECTJOIN_RESPONSE.CMD_STATUS) |

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_DIRECTJOIN_RESPONSE Constructor ()

NLME_DIRECTJOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_DIRECTJOIN_RESPONSE()
C++
public:
NLME_DIRECTJOIN_RESPONSE() sealed
J#
public NLME_DIRECTJOIN_RESPONSE()
JScript
public function NLME_DIRECTJOIN_RESPONSE()

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI1 Namespace
NLME_DIRECTJOIN_RESPONSE Constructor Overload List


NLME_DIRECTJOIN_RESPONSE Constructor (NLME_DIRECTJOIN_RESPONSE.CMD_STATUS)

NLME_DIRECTJOIN_RESPONSE Constructor (NLME_DIRECTJOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_DIRECTJOIN_RESPONSE.CMD_STATUS _
)
C#
public NLME_DIRECTJOIN_RESPONSE(
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
)
C++
public:
NLME_DIRECTJOIN_RESPONSE(
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_DIRECTJOIN_RESPONSE(
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
)
JScript
public function NLME_DIRECTJOIN_RESPONSE(
: NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
)

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI1 Namespace
NLME_DIRECTJOIN_RESPONSE Constructor Overload List


Fields

NLME_DIRECTJOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_DIRECTJOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
C#
public NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_DIRECTJOIN_RESPONSE.CMD_STATUS;

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Enumeration

NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_DIRECTJOIN_RESPONSE.CMD_STATUS : char
J#
public enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_GET_REQUEST Class

NLME_GET_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_GET_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_GET_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_GET_REQUEST : IREQUEST, INETWORK
J#
public class NLME_GET_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_GET_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_GET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_GET_REQUEST Members
TI.ZPI1 Namespace


NLME_GET_REQUEST Members

NLME_GET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).

The following tables list the members exposed by NLME_GET_REQUEST.

Public Constructors

Name | Description
NLME_GET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Index | used to index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | Value | contains the data value
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_GET_REQUEST | Overloaded.
Top

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace


NLME_GET_REQUEST Constructor

NLME_GET_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_GET_REQUEST | Constructor
Public method | NLME_GET_REQUEST (NLME_GET_REQUEST.NIB_ATTR, UInt16, UInt16) |

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace


NLME_GET_REQUEST Constructor ()

NLME_GET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_GET_REQUEST()
C++
public:
NLME_GET_REQUEST() sealed
J#
public NLME_GET_REQUEST()
JScript
public function NLME_GET_REQUEST()

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace
NLME_GET_REQUEST Constructor Overload List


NLME_GET_REQUEST Constructor (NLME_GET_REQUEST.NIB_ATTR, UInt16, UInt16)

NLME_GET_REQUEST Constructor (NLME_GET_REQUEST.NIB_ATTR, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_GET_REQUEST.NIB_ATTR, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public NLME_GET_REQUEST(
NLME_GET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
C++
public:
NLME_GET_REQUEST(
NLME_GET_REQUEST.NIB_ATTR ,
unsigned short ,
unsigned short
) sealed
J#
public NLME_GET_REQUEST(
NLME_GET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
JScript
public function NLME_GET_REQUEST(
: NLME_GET_REQUEST.NIB_ATTR,
: UInt16,
: UInt16
)

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace
NLME_GET_REQUEST Constructor Overload List


Fields

NLME_GET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Index | used to index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | Value | contains the data value
Top

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace


Index Field

NLME_GET_REQUEST.Index Field
[image]

used to index into table NIB items

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index As UInt16
C#
public ushort Index;
C++
public:
unsigned short Index sealed ;
J#
public ushort Index
JScript
public Index : UInt16;

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace


NIBAttribute Field

NLME_GET_REQUEST.NIBAttribute Field
[image]

identifies the intended attribute of the NIB

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NIBAttribute As NLME_GET_REQUEST.NIB_ATTR
C#
public NLME_GET_REQUEST.NIB_ATTR NIBAttribute;
C++
public:
NLME_GET_REQUEST.NIB_ATTR NIBAttribute sealed ;
J#
public NLME_GET_REQUEST.NIB_ATTR NIBAttribute
JScript
public NIBAttribute : NLME_GET_REQUEST.NIB_ATTR;

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace


Value Field

NLME_GET_REQUEST.Value Field
[image]

contains the data value

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As UInt16
C#
public ushort Value;
C++
public:
unsigned short Value sealed ;
J#
public ushort Value
JScript
public Value : UInt16;

See Also

NLME_GET_REQUEST Class
TI.ZPI1 Namespace


NLME_GET_REQUEST.NIB_ATTR Enumeration

NLME_GET_REQUEST.NIB_ATTR Enumeration
[image]

Network layer information base attributes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_GET_REQUEST.NIB_ATTR As Byte
C#
public enum NLME_GET_REQUEST.NIB_ATTR : byte
C++
public enum class NLME_GET_REQUEST.NIB_ATTR : char
J#
public enum NLME_GET_REQUEST.NIB_ATTR byte
JScript
public enum NLME_GET_REQUEST.NIB_ATTR :

Members

Member Name | Description
NWK_BCSN | Network layer information base attributes
NWK_PASSIVE_ACK_TIMEOUT | Network layer information base attributes
NWK_MAX_BROADCAST_RETRIES | Network layer information base attributes
NWK_MAX_CHILDREN | Network layer information base attributes
NWK_MAX_DEPTH | Network layer information base attributes
NWK_MAX_ROUTERS | Network layer information base attributes
NWK_NEIGHBOR_TABLE | Network layer information base attributes
NWK_BROADCAST_DELIVERY_TIME | Network layer information base attributes
NWK_REPORT_CONSTANT_COST | Network layer information base attributes
NWK_ROUTE_DISCOVERY_RETRIES_PERMITTED | Network layer information base attributes
NWK_ROUTE_TABLE | Network layer information base attributes
NWK_SECURE_ALL_FRAMES | Network layer information base attributes
NWK_SECURITY_LEVEL | Network layer information base attributes
NWK_SYM_LINK | Network layer information base attributes
NWK_CAP_INFO | Network layer information base attributes

See Also

TI.ZPI1 Namespace


NLME_GET_RESPONSE Class

NLME_GET_RESPONSE Class
See Also Example Members
[image]

Response for NLME_GET_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_GET_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_GET_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_GET_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_GET_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_GET_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_GET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_GET_RESPONSE Members
TI.ZPI1 Namespace


NLME_GET_RESPONSE Members

NLME_GET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_GET_REQUEST

The following tables list the members exposed by NLME_GET_RESPONSE.

Public Constructors

Name | Description
NLME_GET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_GET_RESPONSE | Overloaded.
Top

See Also

NLME_GET_RESPONSE Class
TI.ZPI1 Namespace


NLME_GET_RESPONSE Constructor

NLME_GET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_GET_RESPONSE | Constructor
Public method | NLME_GET_RESPONSE (NLME_GET_RESPONSE.CMD_STATUS) |

See Also

NLME_GET_RESPONSE Class
TI.ZPI1 Namespace


NLME_GET_RESPONSE Constructor ()

NLME_GET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_GET_RESPONSE()
C++
public:
NLME_GET_RESPONSE() sealed
J#
public NLME_GET_RESPONSE()
JScript
public function NLME_GET_RESPONSE()

See Also

NLME_GET_RESPONSE Class
TI.ZPI1 Namespace
NLME_GET_RESPONSE Constructor Overload List


NLME_GET_RESPONSE Constructor (NLME_GET_RESPONSE.CMD_STATUS)

NLME_GET_RESPONSE Constructor (NLME_GET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_GET_RESPONSE.CMD_STATUS _
)
C#
public NLME_GET_RESPONSE(
NLME_GET_RESPONSE.CMD_STATUS
)
C++
public:
NLME_GET_RESPONSE(
NLME_GET_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_GET_RESPONSE(
NLME_GET_RESPONSE.CMD_STATUS
)
JScript
public function NLME_GET_RESPONSE(
: NLME_GET_RESPONSE.CMD_STATUS
)

See Also

NLME_GET_RESPONSE Class
TI.ZPI1 Namespace
NLME_GET_RESPONSE Constructor Overload List


Fields

NLME_GET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_GET_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_GET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_GET_RESPONSE.CMD_STATUS
C#
public NLME_GET_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_GET_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_GET_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_GET_RESPONSE.CMD_STATUS;

See Also

NLME_GET_RESPONSE Class
TI.ZPI1 Namespace


NLME_GET_RESPONSE.CMD_STATUS Enumeration

NLME_GET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_GET_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_GET_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_GET_RESPONSE.CMD_STATUS : char
J#
public enum NLME_GET_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_GET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_JOIN_CONFIRMATION Class

NLME_JOIN_CONFIRMATION Class
See Also Example Members
[image]

This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_JOIN_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_JOIN_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_JOIN_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_JOIN_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_JOIN_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_CONFIRMATION Members
TI.ZPI1 Namespace


NLME_JOIN_CONFIRMATION Members

NLME_JOIN_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.

The following tables list the members exposed by NLME_JOIN_CONFIRMATION.

Public Constructors

Name | Description
NLME_JOIN_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | PanId | indicates the PAN identifer of the network to which the device has joined
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_CONFIRMATION | Overloaded.
Top

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_JOIN_CONFIRMATION Constructor

NLME_JOIN_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_CONFIRMATION | Constructor
Public method | NLME_JOIN_CONFIRMATION (UInt64, UInt16, NLME_JOIN_CONFIRMATION.CMD_STATUS) |

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_JOIN_CONFIRMATION Constructor ()

NLME_JOIN_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_CONFIRMATION()
C++
public:
NLME_JOIN_CONFIRMATION() sealed
J#
public NLME_JOIN_CONFIRMATION()
JScript
public function NLME_JOIN_CONFIRMATION()

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_JOIN_CONFIRMATION Constructor Overload List


NLME_JOIN_CONFIRMATION Constructor (UInt64, UInt16, NLME_JOIN_CONFIRMATION.CMD_STATUS)

NLME_JOIN_CONFIRMATION Constructor (UInt64, UInt16, NLME_JOIN_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As NLME_JOIN_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_JOIN_CONFIRMATION(
ulong ,
ushort ,
NLME_JOIN_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_JOIN_CONFIRMATION(
unsigned __int64 ,
unsigned short ,
NLME_JOIN_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_JOIN_CONFIRMATION(
ulong ,
ushort ,
NLME_JOIN_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_JOIN_CONFIRMATION(
: UInt64,
: UInt16,
: NLME_JOIN_CONFIRMATION.CMD_STATUS
)

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_JOIN_CONFIRMATION Constructor Overload List


Fields

NLME_JOIN_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | PanId | indicates the PAN identifer of the network to which the device has joined
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace


DeviceAddress Field

NLME_JOIN_CONFIRMATION.DeviceAddress Field
[image]

specifies the IEEE extended address of the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace


PanId Field

NLME_JOIN_CONFIRMATION.PanId Field
[image]

indicates the PAN identifer of the network to which the device has joined

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NLME_JOIN_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_JOIN_CONFIRMATION.CMD_STATUS
C#
public NLME_JOIN_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_JOIN_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_JOIN_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_JOIN_CONFIRMATION.CMD_STATUS;

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_JOIN_CONFIRMATION.CMD_STATUS Enumeration

NLME_JOIN_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_JOIN_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_JOIN_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_JOIN_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_JOIN_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_JOIN_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_JOIN_INDICATION Class

NLME_JOIN_INDICATION Class
See Also Example Members
[image]

This message is sent by the target to notify the next higher layer of a remote join request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLME_JOIN_INDICATION : IINDICATION, INETWORK
C++
ref class NLME_JOIN_INDICATION : IINDICATION, INETWORK
J#
public class NLME_JOIN_INDICATION implements IINDICATION, INETWORK
JScript
public class NLME_JOIN_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_JOIN_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_INDICATION Members
TI.ZPI1 Namespace


NLME_JOIN_INDICATION Members

NLME_JOIN_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to notify the next higher layer of a remote join request.

The following tables list the members exposed by NLME_JOIN_INDICATION.

Public Constructors

Name | Description
NLME_JOIN_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInformation | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | specifies the IEEE extended address of the same entity
Public field | ShortAddress | indicates the network address of an entity that has been added to the network
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_INDICATION | Overloaded.
Top

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace


NLME_JOIN_INDICATION Constructor

NLME_JOIN_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_INDICATION | Constructor
Public method | NLME_JOIN_INDICATION (UInt16, UInt64, NLME_JOIN_INDICATION.CAPABILITY_INFO) |

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace


NLME_JOIN_INDICATION Constructor ()

NLME_JOIN_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_INDICATION()
C++
public:
NLME_JOIN_INDICATION() sealed
J#
public NLME_JOIN_INDICATION()
JScript
public function NLME_JOIN_INDICATION()

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace
NLME_JOIN_INDICATION Constructor Overload List


NLME_JOIN_INDICATION Constructor (UInt16, UInt64, NLME_JOIN_INDICATION.CAPABILITY_INFO)

NLME_JOIN_INDICATION Constructor (UInt16, UInt64, NLME_JOIN_INDICATION.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As NLME_JOIN_INDICATION.CAPABILITY_INFO _
)
C#
public NLME_JOIN_INDICATION(
ushort ,
ulong ,
NLME_JOIN_INDICATION.CAPABILITY_INFO
)
C++
public:
NLME_JOIN_INDICATION(
unsigned short ,
unsigned __int64 ,
NLME_JOIN_INDICATION.CAPABILITY_INFO
) sealed
J#
public NLME_JOIN_INDICATION(
ushort ,
ulong ,
NLME_JOIN_INDICATION.CAPABILITY_INFO
)
JScript
public function NLME_JOIN_INDICATION(
: UInt16,
: UInt64,
: NLME_JOIN_INDICATION.CAPABILITY_INFO
)

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace
NLME_JOIN_INDICATION Constructor Overload List


Fields

NLME_JOIN_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInformation | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | specifies the IEEE extended address of the same entity
Public field | ShortAddress | indicates the network address of an entity that has been added to the network
Top

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace


CapabilityInformation Field

NLME_JOIN_INDICATION.CapabilityInformation Field
[image]

bitmap which specifies the operational capabilities of the joining device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInformation As NLME_JOIN_INDICATION.CAPABILITY_INFO
C#
public NLME_JOIN_INDICATION.CAPABILITY_INFO CapabilityInformation;
C++
public:
NLME_JOIN_INDICATION.CAPABILITY_INFO CapabilityInformation sealed ;
J#
public NLME_JOIN_INDICATION.CAPABILITY_INFO CapabilityInformation
JScript
public CapabilityInformation : NLME_JOIN_INDICATION.CAPABILITY_INFO;

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace


ExtendedAddress Field

NLME_JOIN_INDICATION.ExtendedAddress Field
[image]

specifies the IEEE extended address of the same entity

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedAddress As UInt64
C#
public ulong ExtendedAddress;
C++
public:
unsigned __int64 ExtendedAddress sealed ;
J#
public ulong ExtendedAddress
JScript
public ExtendedAddress : UInt64;

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace


ShortAddress Field

NLME_JOIN_INDICATION.ShortAddress Field
[image]

indicates the network address of an entity that has been added to the network

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ShortAddress As UInt16
C#
public ushort ShortAddress;
C++
public:
unsigned short ShortAddress sealed ;
J#
public ushort ShortAddress
JScript
public ShortAddress : UInt16;

See Also

NLME_JOIN_INDICATION Class
TI.ZPI1 Namespace


NLME_JOIN_INDICATION.CAPABILITY_INFO Enumeration

NLME_JOIN_INDICATION.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_JOIN_INDICATION.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum NLME_JOIN_INDICATION.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class NLME_JOIN_INDICATION.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum NLME_JOIN_INDICATION.CAPABILITY_INFO byte
JScript
public enum NLME_JOIN_INDICATION.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI1 Namespace


NLME_JOIN_REQUEST Class

NLME_JOIN_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_JOIN_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_JOIN_REQUEST : IREQUEST, INETWORK
J#
public class NLME_JOIN_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_JOIN_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_JOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_REQUEST Members
TI.ZPI1 Namespace


NLME_JOIN_REQUEST Members

NLME_JOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.

The following tables list the members exposed by NLME_JOIN_REQUEST.

Public Constructors

Name | Description
NLME_JOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | Channel | specifies the channel of the intended device
Public field | PanId | indicates the short address of the intended device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_REQUEST | Overloaded.
Top

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_JOIN_REQUEST Constructor

NLME_JOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_REQUEST | Constructor
Public method | NLME_JOIN_REQUEST (UInt16, Byte, NLME_JOIN_REQUEST.CAPABILITY_INFO) |

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_JOIN_REQUEST Constructor ()

NLME_JOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_REQUEST()
C++
public:
NLME_JOIN_REQUEST() sealed
J#
public NLME_JOIN_REQUEST()
JScript
public function NLME_JOIN_REQUEST()

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace
NLME_JOIN_REQUEST Constructor Overload List


NLME_JOIN_REQUEST Constructor (UInt16, Byte, NLME_JOIN_REQUEST.CAPABILITY_INFO)

NLME_JOIN_REQUEST Constructor (UInt16, Byte, NLME_JOIN_REQUEST.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As NLME_JOIN_REQUEST.CAPABILITY_INFO _
)
C#
public NLME_JOIN_REQUEST(
ushort ,
byte ,
NLME_JOIN_REQUEST.CAPABILITY_INFO
)
C++
public:
NLME_JOIN_REQUEST(
unsigned short ,
char ,
NLME_JOIN_REQUEST.CAPABILITY_INFO
) sealed
J#
public NLME_JOIN_REQUEST(
ushort ,
byte ,
NLME_JOIN_REQUEST.CAPABILITY_INFO
)
JScript
public function NLME_JOIN_REQUEST(
: UInt16,
: Byte,
: NLME_JOIN_REQUEST.CAPABILITY_INFO
)

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace
NLME_JOIN_REQUEST Constructor Overload List


Fields

NLME_JOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | Channel | specifies the channel of the intended device
Public field | PanId | indicates the short address of the intended device
Top

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace


CapabilityInfo Field

NLME_JOIN_REQUEST.CapabilityInfo Field
[image]

bitmap which specifies the operational capabilities of the joining device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInfo As NLME_JOIN_REQUEST.CAPABILITY_INFO
C#
public NLME_JOIN_REQUEST.CAPABILITY_INFO CapabilityInfo;
C++
public:
NLME_JOIN_REQUEST.CAPABILITY_INFO CapabilityInfo sealed ;
J#
public NLME_JOIN_REQUEST.CAPABILITY_INFO CapabilityInfo
JScript
public CapabilityInfo : NLME_JOIN_REQUEST.CAPABILITY_INFO;

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace


Channel Field

NLME_JOIN_REQUEST.Channel Field
[image]

specifies the channel of the intended device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Channel As Byte
C#
public byte Channel;
C++
public:
char Channel sealed ;
J#
public byte Channel
JScript
public Channel : Byte;

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace


PanId Field

NLME_JOIN_REQUEST.PanId Field
[image]

indicates the short address of the intended device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

NLME_JOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_JOIN_REQUEST.CAPABILITY_INFO Enumeration

NLME_JOIN_REQUEST.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_JOIN_REQUEST.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum NLME_JOIN_REQUEST.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class NLME_JOIN_REQUEST.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum NLME_JOIN_REQUEST.CAPABILITY_INFO byte
JScript
public enum NLME_JOIN_REQUEST.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI1 Namespace


NLME_JOIN_RESPONSE Class

NLME_JOIN_RESPONSE Class
See Also Example Members
[image]

Response for NLME_JOIN_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_JOIN_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_JOIN_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_JOIN_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_JOIN_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_JOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_RESPONSE Members
TI.ZPI1 Namespace


NLME_JOIN_RESPONSE Members

NLME_JOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_JOIN_REQUEST

The following tables list the members exposed by NLME_JOIN_RESPONSE.

Public Constructors

Name | Description
NLME_JOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_RESPONSE | Overloaded.
Top

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_JOIN_RESPONSE Constructor

NLME_JOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_RESPONSE | Constructor
Public method | NLME_JOIN_RESPONSE (NLME_JOIN_RESPONSE.CMD_STATUS) |

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_JOIN_RESPONSE Constructor ()

NLME_JOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_RESPONSE()
C++
public:
NLME_JOIN_RESPONSE() sealed
J#
public NLME_JOIN_RESPONSE()
JScript
public function NLME_JOIN_RESPONSE()

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI1 Namespace
NLME_JOIN_RESPONSE Constructor Overload List


NLME_JOIN_RESPONSE Constructor (NLME_JOIN_RESPONSE.CMD_STATUS)

NLME_JOIN_RESPONSE Constructor (NLME_JOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_JOIN_RESPONSE.CMD_STATUS _
)
C#
public NLME_JOIN_RESPONSE(
NLME_JOIN_RESPONSE.CMD_STATUS
)
C++
public:
NLME_JOIN_RESPONSE(
NLME_JOIN_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_JOIN_RESPONSE(
NLME_JOIN_RESPONSE.CMD_STATUS
)
JScript
public function NLME_JOIN_RESPONSE(
: NLME_JOIN_RESPONSE.CMD_STATUS
)

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI1 Namespace
NLME_JOIN_RESPONSE Constructor Overload List


Fields

NLME_JOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_JOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_JOIN_RESPONSE.CMD_STATUS
C#
public NLME_JOIN_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_JOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_JOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_JOIN_RESPONSE.CMD_STATUS;

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_JOIN_RESPONSE.CMD_STATUS Enumeration

NLME_JOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_JOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_JOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_JOIN_RESPONSE.CMD_STATUS : char
J#
public enum NLME_JOIN_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_JOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_LEAVE_CONFIRMATION Class

NLME_LEAVE_CONFIRMATION Class
See Also Example Members
[image]

This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_LEAVE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_LEAVE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_LEAVE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_LEAVE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_LEAVE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_CONFIRMATION Members
TI.ZPI1 Namespace


NLME_LEAVE_CONFIRMATION Members

NLME_LEAVE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.

The following tables list the members exposed by NLME_LEAVE_CONFIRMATION.

Public Constructors

Name | Description
NLME_LEAVE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_CONFIRMATION | Overloaded.
Top

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_LEAVE_CONFIRMATION Constructor

NLME_LEAVE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_CONFIRMATION | Constructor
Public method | NLME_LEAVE_CONFIRMATION (UInt64, NLME_LEAVE_CONFIRMATION.CMD_STATUS) |

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_LEAVE_CONFIRMATION Constructor ()

NLME_LEAVE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_CONFIRMATION()
C++
public:
NLME_LEAVE_CONFIRMATION() sealed
J#
public NLME_LEAVE_CONFIRMATION()
JScript
public function NLME_LEAVE_CONFIRMATION()

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_LEAVE_CONFIRMATION Constructor Overload List


NLME_LEAVE_CONFIRMATION Constructor (UInt64, NLME_LEAVE_CONFIRMATION.CMD_STATUS)

NLME_LEAVE_CONFIRMATION Constructor (UInt64, NLME_LEAVE_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_LEAVE_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_LEAVE_CONFIRMATION(
ulong ,
NLME_LEAVE_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_LEAVE_CONFIRMATION(
unsigned __int64 ,
NLME_LEAVE_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_LEAVE_CONFIRMATION(
ulong ,
NLME_LEAVE_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_LEAVE_CONFIRMATION(
: UInt64,
: NLME_LEAVE_CONFIRMATION.CMD_STATUS
)

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_LEAVE_CONFIRMATION Constructor Overload List


Fields

NLME_LEAVE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI1 Namespace


DeviceAddress Field

NLME_LEAVE_CONFIRMATION.DeviceAddress Field
[image]

specifies the IEEE extended address of the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NLME_LEAVE_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_LEAVE_CONFIRMATION.CMD_STATUS
C#
public NLME_LEAVE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_LEAVE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_LEAVE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_LEAVE_CONFIRMATION.CMD_STATUS;

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_LEAVE_CONFIRMATION.CMD_STATUS Enumeration

NLME_LEAVE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_LEAVE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_LEAVE_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_LEAVE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_LEAVE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_LEAVE_INDICATION Class

NLME_LEAVE_INDICATION Class
See Also Example Members
[image]

This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLME_LEAVE_INDICATION : IINDICATION, INETWORK
C++
ref class NLME_LEAVE_INDICATION : IINDICATION, INETWORK
J#
public class NLME_LEAVE_INDICATION implements IINDICATION, INETWORK
JScript
public class NLME_LEAVE_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_LEAVE_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_INDICATION Members
TI.ZPI1 Namespace


NLME_LEAVE_INDICATION Members

NLME_LEAVE_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator

The following tables list the members exposed by NLME_LEAVE_INDICATION.

Public Constructors

Name | Description
NLME_LEAVE_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_INDICATION | Overloaded.
Top

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI1 Namespace


NLME_LEAVE_INDICATION Constructor

NLME_LEAVE_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_INDICATION | Constructor
Public method | NLME_LEAVE_INDICATION (UInt64, NLME_LEAVE_INDICATION.CMD_STATUS) |

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI1 Namespace


NLME_LEAVE_INDICATION Constructor ()

NLME_LEAVE_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_INDICATION()
C++
public:
NLME_LEAVE_INDICATION() sealed
J#
public NLME_LEAVE_INDICATION()
JScript
public function NLME_LEAVE_INDICATION()

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI1 Namespace
NLME_LEAVE_INDICATION Constructor Overload List


NLME_LEAVE_INDICATION Constructor (UInt64, NLME_LEAVE_INDICATION.CMD_STATUS)

NLME_LEAVE_INDICATION Constructor (UInt64, NLME_LEAVE_INDICATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_LEAVE_INDICATION.CMD_STATUS _
)
C#
public NLME_LEAVE_INDICATION(
ulong ,
NLME_LEAVE_INDICATION.CMD_STATUS
)
C++
public:
NLME_LEAVE_INDICATION(
unsigned __int64 ,
NLME_LEAVE_INDICATION.CMD_STATUS
) sealed
J#
public NLME_LEAVE_INDICATION(
ulong ,
NLME_LEAVE_INDICATION.CMD_STATUS
)
JScript
public function NLME_LEAVE_INDICATION(
: UInt64,
: NLME_LEAVE_INDICATION.CMD_STATUS
)

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI1 Namespace
NLME_LEAVE_INDICATION Constructor Overload List


Fields

NLME_LEAVE_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI1 Namespace


DeviceAddress Field

NLME_LEAVE_INDICATION.DeviceAddress Field
[image]

specifies the IEEE extended address of the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI1 Namespace


Status Field

NLME_LEAVE_INDICATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_LEAVE_INDICATION.CMD_STATUS
C#
public NLME_LEAVE_INDICATION.CMD_STATUS Status;
C++
public:
NLME_LEAVE_INDICATION.CMD_STATUS Status sealed ;
J#
public NLME_LEAVE_INDICATION.CMD_STATUS Status
JScript
public Status : NLME_LEAVE_INDICATION.CMD_STATUS;

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI1 Namespace


NLME_LEAVE_INDICATION.CMD_STATUS Enumeration

NLME_LEAVE_INDICATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_INDICATION.CMD_STATUS As Byte
C#
public enum NLME_LEAVE_INDICATION.CMD_STATUS : byte
C++
public enum class NLME_LEAVE_INDICATION.CMD_STATUS : char
J#
public enum NLME_LEAVE_INDICATION.CMD_STATUS byte
JScript
public enum NLME_LEAVE_INDICATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_LEAVE_REQUEST Class

NLME_LEAVE_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_LEAVE_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_LEAVE_REQUEST : IREQUEST, INETWORK
J#
public class NLME_LEAVE_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_LEAVE_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_LEAVE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_REQUEST Members
TI.ZPI1 Namespace


NLME_LEAVE_REQUEST Members

NLME_LEAVE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.

The following tables list the members exposed by NLME_LEAVE_REQUEST.

Public Constructors

Name | Description
NLME_LEAVE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | indicates the IEEE extended address of the intended device
Public field | Reassociate | indicates whether the device, specified by the DeviceAddress, should reassociate after it leaves
Public field | RemoveChildren | indicates whether the device, specified by the DeviceAddress, should remove it's children
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_REQUEST | Overloaded.
Top

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace


NLME_LEAVE_REQUEST Constructor

NLME_LEAVE_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_REQUEST | Constructor
Public method | NLME_LEAVE_REQUEST (UInt64, NLME_LEAVE_REQUEST.BOOLEAN, NLME_LEAVE_REQUEST.BOOLEAN) |

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace


NLME_LEAVE_REQUEST Constructor ()

NLME_LEAVE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_REQUEST()
C++
public:
NLME_LEAVE_REQUEST() sealed
J#
public NLME_LEAVE_REQUEST()
JScript
public function NLME_LEAVE_REQUEST()

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace
NLME_LEAVE_REQUEST Constructor Overload List


NLME_LEAVE_REQUEST Constructor (UInt64, NLME_LEAVE_REQUEST.BOOLEAN, NLME_LEAVE_REQUEST.BOOLEAN)

NLME_LEAVE_REQUEST Constructor (UInt64, NLME_LEAVE_REQUEST.BOOLEAN, NLME_LEAVE_REQUEST.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_LEAVE_REQUEST.BOOLEAN, _
ByVal As NLME_LEAVE_REQUEST.BOOLEAN _
)
C#
public NLME_LEAVE_REQUEST(
ulong ,
NLME_LEAVE_REQUEST.BOOLEAN ,
NLME_LEAVE_REQUEST.BOOLEAN
)
C++
public:
NLME_LEAVE_REQUEST(
unsigned __int64 ,
NLME_LEAVE_REQUEST.BOOLEAN ,
NLME_LEAVE_REQUEST.BOOLEAN
) sealed
J#
public NLME_LEAVE_REQUEST(
ulong ,
NLME_LEAVE_REQUEST.BOOLEAN ,
NLME_LEAVE_REQUEST.BOOLEAN
)
JScript
public function NLME_LEAVE_REQUEST(
: UInt64,
: NLME_LEAVE_REQUEST.BOOLEAN,
: NLME_LEAVE_REQUEST.BOOLEAN
)

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace
NLME_LEAVE_REQUEST Constructor Overload List


Fields

NLME_LEAVE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | indicates the IEEE extended address of the intended device
Public field | Reassociate | indicates whether the device, specified by the DeviceAddress, should reassociate after it leaves
Public field | RemoveChildren | indicates whether the device, specified by the DeviceAddress, should remove it's children
Top

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace


DeviceAddress Field

NLME_LEAVE_REQUEST.DeviceAddress Field
[image]

indicates the IEEE extended address of the intended device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace


Reassociate Field

NLME_LEAVE_REQUEST.Reassociate Field
[image]

indicates whether the device, specified by the DeviceAddress, should reassociate after it leaves

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reassociate As NLME_LEAVE_REQUEST.BOOLEAN
C#
public NLME_LEAVE_REQUEST.BOOLEAN Reassociate;
C++
public:
NLME_LEAVE_REQUEST.BOOLEAN Reassociate sealed ;
J#
public NLME_LEAVE_REQUEST.BOOLEAN Reassociate
JScript
public Reassociate : NLME_LEAVE_REQUEST.BOOLEAN;

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace


RemoveChildren Field

NLME_LEAVE_REQUEST.RemoveChildren Field
[image]

indicates whether the device, specified by the DeviceAddress, should remove it's children

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RemoveChildren As NLME_LEAVE_REQUEST.BOOLEAN
C#
public NLME_LEAVE_REQUEST.BOOLEAN RemoveChildren;
C++
public:
NLME_LEAVE_REQUEST.BOOLEAN RemoveChildren sealed ;
J#
public NLME_LEAVE_REQUEST.BOOLEAN RemoveChildren
JScript
public RemoveChildren : NLME_LEAVE_REQUEST.BOOLEAN;

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI1 Namespace


NLME_LEAVE_REQUEST.BOOLEAN Enumeration

NLME_LEAVE_REQUEST.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_REQUEST.BOOLEAN As Byte
C#
public enum NLME_LEAVE_REQUEST.BOOLEAN : byte
C++
public enum class NLME_LEAVE_REQUEST.BOOLEAN : char
J#
public enum NLME_LEAVE_REQUEST.BOOLEAN byte
JScript
public enum NLME_LEAVE_REQUEST.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI1 Namespace


NLME_LEAVE_RESPONSE Class

NLME_LEAVE_RESPONSE Class
See Also Example Members
[image]

Response for NLME_LEAVE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_LEAVE_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_LEAVE_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_LEAVE_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_LEAVE_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_LEAVE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_RESPONSE Members
TI.ZPI1 Namespace


NLME_LEAVE_RESPONSE Members

NLME_LEAVE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_LEAVE_REQUEST

The following tables list the members exposed by NLME_LEAVE_RESPONSE.

Public Constructors

Name | Description
NLME_LEAVE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_RESPONSE | Overloaded.
Top

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


NLME_LEAVE_RESPONSE Constructor

NLME_LEAVE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_RESPONSE | Constructor
Public method | NLME_LEAVE_RESPONSE (NLME_LEAVE_RESPONSE.CMD_STATUS) |

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


NLME_LEAVE_RESPONSE Constructor ()

NLME_LEAVE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_RESPONSE()
C++
public:
NLME_LEAVE_RESPONSE() sealed
J#
public NLME_LEAVE_RESPONSE()
JScript
public function NLME_LEAVE_RESPONSE()

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI1 Namespace
NLME_LEAVE_RESPONSE Constructor Overload List


NLME_LEAVE_RESPONSE Constructor (NLME_LEAVE_RESPONSE.CMD_STATUS)

NLME_LEAVE_RESPONSE Constructor (NLME_LEAVE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_LEAVE_RESPONSE.CMD_STATUS _
)
C#
public NLME_LEAVE_RESPONSE(
NLME_LEAVE_RESPONSE.CMD_STATUS
)
C++
public:
NLME_LEAVE_RESPONSE(
NLME_LEAVE_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_LEAVE_RESPONSE(
NLME_LEAVE_RESPONSE.CMD_STATUS
)
JScript
public function NLME_LEAVE_RESPONSE(
: NLME_LEAVE_RESPONSE.CMD_STATUS
)

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI1 Namespace
NLME_LEAVE_RESPONSE Constructor Overload List


Fields

NLME_LEAVE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_LEAVE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_LEAVE_RESPONSE.CMD_STATUS
C#
public NLME_LEAVE_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_LEAVE_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_LEAVE_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_LEAVE_RESPONSE.CMD_STATUS;

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


NLME_LEAVE_RESPONSE.CMD_STATUS Enumeration

NLME_LEAVE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_LEAVE_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_LEAVE_RESPONSE.CMD_STATUS : char
J#
public enum NLME_LEAVE_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_LEAVE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Class

NLME_NETWORK_FORMATION_CONFIRMATION Class
See Also Example Members
[image]

This message is used by the target NWK to inform the tester of the result of a previous association request command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORK_FORMATION_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_NETWORK_FORMATION_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_NETWORK_FORMATION_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_NETWORK_FORMATION_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_NETWORK_FORMATION_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_NETWORK_FORMATION_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Members
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Members

NLME_NETWORK_FORMATION_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is used by the target NWK to inform the tester of the result of a previous association request command

The following tables list the members exposed by NLME_NETWORK_FORMATION_CONFIRMATION.

Public Constructors

Name | Description
NLME_NETWORK_FORMATION_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORK_FORMATION_CONFIRMATION | Overloaded.
Top

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Constructor

NLME_NETWORK_FORMATION_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORK_FORMATION_CONFIRMATION | Constructor
Public method | NLME_NETWORK_FORMATION_CONFIRMATION (NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS) |

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Constructor ()

NLME_NETWORK_FORMATION_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORK_FORMATION_CONFIRMATION()
C++
public:
NLME_NETWORK_FORMATION_CONFIRMATION() sealed
J#
public NLME_NETWORK_FORMATION_CONFIRMATION()
JScript
public function NLME_NETWORK_FORMATION_CONFIRMATION()

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_NETWORK_FORMATION_CONFIRMATION Constructor Overload List


NLME_NETWORK_FORMATION_CONFIRMATION Constructor (NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS)

NLME_NETWORK_FORMATION_CONFIRMATION Constructor (NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_NETWORK_FORMATION_CONFIRMATION(
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_NETWORK_FORMATION_CONFIRMATION(
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_NETWORK_FORMATION_CONFIRMATION(
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_NETWORK_FORMATION_CONFIRMATION(
: NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
)

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_NETWORK_FORMATION_CONFIRMATION Constructor Overload List


Fields

NLME_NETWORK_FORMATION_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NLME_NETWORK_FORMATION_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
C#
public NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS;

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Enumeration

NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_REQUEST Class

NLME_NETWORK_FORMATION_REQUEST Class
See Also Example Members
[image]

This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORK_FORMATION_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_NETWORK_FORMATION_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_NETWORK_FORMATION_REQUEST : IREQUEST, INETWORK
J#
public class NLME_NETWORK_FORMATION_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_NETWORK_FORMATION_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_NETWORK_FORMATION_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORK_FORMATION_REQUEST Members
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_REQUEST Members

NLME_NETWORK_FORMATION_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.

The following tables list the members exposed by NLME_NETWORK_FORMATION_REQUEST.

Public Constructors

Name | Description
NLME_NETWORK_FORMATION_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | indicates whether NLME will request that the Zigbee coordinator is started supporting battery life extension mode.
Public field | BeaconOrder | represents the beacon order type
Public field | PanId | short address of the intended device.
Public field | ScanChannels | indicates list of channels in bit map format.
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | SuperFrameOrder | specifies the length of the active portion of the superframe
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORK_FORMATION_REQUEST | Overloaded.
Top

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_REQUEST Constructor

NLME_NETWORK_FORMATION_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORK_FORMATION_REQUEST | Constructor
Public method | NLME_NETWORK_FORMATION_REQUEST (UInt16, NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, Byte, Byte) |

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_REQUEST Constructor ()

NLME_NETWORK_FORMATION_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORK_FORMATION_REQUEST()
C++
public:
NLME_NETWORK_FORMATION_REQUEST() sealed
J#
public NLME_NETWORK_FORMATION_REQUEST()
JScript
public function NLME_NETWORK_FORMATION_REQUEST()

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace
NLME_NETWORK_FORMATION_REQUEST Constructor Overload List


NLME_NETWORK_FORMATION_REQUEST Constructor (UInt16, NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, Byte, Byte)

NLME_NETWORK_FORMATION_REQUEST Constructor (UInt16, NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLME_NETWORK_FORMATION_REQUEST(
ushort ,
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
byte ,
byte
)
C++
public:
NLME_NETWORK_FORMATION_REQUEST(
unsigned short ,
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ,
char ,
char ,
char ,
char
) sealed
J#
public NLME_NETWORK_FORMATION_REQUEST(
ushort ,
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
byte ,
byte
)
JScript
public function NLME_NETWORK_FORMATION_REQUEST(
: UInt16,
: NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace
NLME_NETWORK_FORMATION_REQUEST Constructor Overload List


Fields

NLME_NETWORK_FORMATION_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | indicates whether NLME will request that the Zigbee coordinator is started supporting battery life extension mode.
Public field | BeaconOrder | represents the beacon order type
Public field | PanId | short address of the intended device.
Public field | ScanChannels | indicates list of channels in bit map format.
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | SuperFrameOrder | specifies the length of the active portion of the superframe
Top

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


BatteryLifeExtension Field

NLME_NETWORK_FORMATION_REQUEST.BatteryLifeExtension Field
[image]

indicates whether NLME will request that the Zigbee coordinator is started supporting battery life extension mode.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BatteryLifeExtension As Byte
C#
public byte BatteryLifeExtension;
C++
public:
char BatteryLifeExtension sealed ;
J#
public byte BatteryLifeExtension
JScript
public BatteryLifeExtension : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


BeaconOrder Field

NLME_NETWORK_FORMATION_REQUEST.BeaconOrder Field
[image]

represents the beacon order type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


PanId Field

NLME_NETWORK_FORMATION_REQUEST.PanId Field
[image]

short address of the intended device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


ScanChannels Field

NLME_NETWORK_FORMATION_REQUEST.ScanChannels Field
[image]

indicates list of channels in bit map format.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS
C#
public NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


ScanDuration Field

NLME_NETWORK_FORMATION_REQUEST.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


SuperFrameOrder Field

NLME_NETWORK_FORMATION_REQUEST.SuperFrameOrder Field
[image]

specifies the length of the active portion of the superframe

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameOrder As Byte
C#
public byte SuperFrameOrder;
C++
public:
char SuperFrameOrder sealed ;
J#
public byte SuperFrameOrder
JScript
public SuperFrameOrder : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS Enumeration

NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_RESPONSE Class

NLME_NETWORK_FORMATION_RESPONSE Class
See Also Example Members
[image]

Response for NLME_NETWORK_FORMATION_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORK_FORMATION_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_NETWORK_FORMATION_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_NETWORK_FORMATION_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_NETWORK_FORMATION_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_NETWORK_FORMATION_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_NETWORK_FORMATION_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORK_FORMATION_RESPONSE Members
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_RESPONSE Members

NLME_NETWORK_FORMATION_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_NETWORK_FORMATION_REQUEST

The following tables list the members exposed by NLME_NETWORK_FORMATION_RESPONSE.

Public Constructors

Name | Description
NLME_NETWORK_FORMATION_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORK_FORMATION_RESPONSE | Overloaded.
Top

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_RESPONSE Constructor

NLME_NETWORK_FORMATION_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORK_FORMATION_RESPONSE | Constructor
Public method | NLME_NETWORK_FORMATION_RESPONSE (NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS) |

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_RESPONSE Constructor ()

NLME_NETWORK_FORMATION_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORK_FORMATION_RESPONSE()
C++
public:
NLME_NETWORK_FORMATION_RESPONSE() sealed
J#
public NLME_NETWORK_FORMATION_RESPONSE()
JScript
public function NLME_NETWORK_FORMATION_RESPONSE()

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI1 Namespace
NLME_NETWORK_FORMATION_RESPONSE Constructor Overload List


NLME_NETWORK_FORMATION_RESPONSE Constructor (NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS)

NLME_NETWORK_FORMATION_RESPONSE Constructor (NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS _
)
C#
public NLME_NETWORK_FORMATION_RESPONSE(
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
)
C++
public:
NLME_NETWORK_FORMATION_RESPONSE(
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
) sealed
J#
public NLME_NETWORK_FORMATION_RESPONSE(
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
)
JScript
public function NLME_NETWORK_FORMATION_RESPONSE(
: NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
)

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI1 Namespace
NLME_NETWORK_FORMATION_RESPONSE Constructor Overload List


Fields

NLME_NETWORK_FORMATION_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_NETWORK_FORMATION_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
C#
public NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Status;
C++
public:
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Status sealed ;
J#
public NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Status
JScript
public Status : NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS;

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI1 Namespace


NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Enumeration

NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Enumeration
[image]

Status code for NLME response

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS As Byte
C#
public enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS : byte
C++
public enum class NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS : char
J#
public enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS byte
JScript
public enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS :

Members

Member Name | Description
NLME_SUCCESS | Status code for NLME response
NLME_FAILURE | Status code for NLME response
NLME_ILLEGAL_REQUEST | Status code for NLME response
NLME_UNKNOWN_DEVICE | Status code for NLME response
NLME_STARTUP_FAILURE | Status code for NLME response
NLME_NO_SHORT_ADDRESS | Status code for NLME response
NLME_UNAVAILABLE_KEY | Status code for NLME response
NLME_FRAME_TOO_LONG | Status code for NLME response
NLME_FAILED_SECURITY_CHECK | Status code for NLME response
NLME_INVALID_PARAMETER | Status code for NLME response
NLME_UNSUPPORTED_ATTRIBUTE | Status code for NLME response
NLME_NOT_JOINED | Status code for NLME response
NLME_ALREADY_JOINED | Status code for NLME response
NLME_NOT_POSSIBLE | Status code for NLME response
NLME_TX_FAIL | Status code for NLME response
NLME_TX_ERROR | Status code for NLME response
NLME_RX_SUCCESS | Status code for NLME response
NLME_RX_FAILURE | Status code for NLME response
NLME_ALREADY_PRESENT | Status code for NLME response
NLME_NO_NETWORKS | Status code for NLME response
NLME_TABLE_FULL | Status code for NLME response

See Also

TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Class

NLME_NETWORKDISCOVERY_CONFIRMATION Class
See Also Example Members
[image]

This message is sent by the target to indicate network discovery confirmation

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORKDISCOVERY_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_NETWORKDISCOVERY_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_NETWORKDISCOVERY_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_NETWORKDISCOVERY_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_NETWORKDISCOVERY_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_NETWORKDISCOVERY_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Members
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Members

NLME_NETWORKDISCOVERY_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate network discovery confirmation

The following tables list the members exposed by NLME_NETWORKDISCOVERY_CONFIRMATION.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Number | Number of networks found
Public field | PanInfo | Dynamic array, Pan Information
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Constructor

NLME_NETWORKDISCOVERY_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION | Constructor
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION (Byte, Object) | Constructor

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Constructor ()

NLME_NETWORKDISCOVERY_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION()
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION() sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION()
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION()

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION Constructor Overload List


NLME_NETWORKDISCOVERY_CONFIRMATION Constructor (Byte, Object[])

NLME_NETWORKDISCOVERY_CONFIRMATION Constructor (Byte, Object[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Object() _
)
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION(
byte ,
object[]
)
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION(
char ,
array<Object>^
) sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION(
byte ,
object[]
)
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION(
: Byte,
: Object[]
)

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Number | Number of networks found
Public field | PanInfo | Dynamic array, Pan Information
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI1 Namespace


Number Field

NLME_NETWORKDISCOVERY_CONFIRMATION.Number Field
[image]

Number of networks found

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Number As Byte
C#
public byte Number;
C++
public:
char Number sealed ;
J#
public byte Number
JScript
public Number : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI1 Namespace


PanInfo Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfo Field
[image]

Dynamic array, Pan Information

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanInfo As Object()
C#
public object[] PanInfo;
C++
public:
array<Object>^ PanInfo sealed ;
J#
public object[] PanInfo
JScript
public PanInfo : Object[];

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
See Also Example Members
[image]

Pan Information. Used with NLME_NETWORKDISCOVERY_CONFIRMATION

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
C#
public struct NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
C++
value class NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
J#
public final class NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Members
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Members

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Pan Information. Used with NLME_NETWORKDISCOVERY_CONFIRMATION

The following tables list the members exposed by NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BeaconOrder |
Public field | DeviceCapacity |
Public field | LogicalChannel |
Public field | PanID |
Public field | RouterCapacity |
Public field | StackProfile |
Public field | SuperFrameOrder |
Public field | Version |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor
See Also Example

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Initializes a new instance of the NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass class.
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass (UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte) |

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor ()

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass()
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass() sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass()
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass()

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor Overload List


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor (UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte)

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor (UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
unsigned short ,
char ,
char ,
char ,
char ,
char ,
char ,
char
) sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | BeaconOrder |
Public field | DeviceCapacity |
Public field | LogicalChannel |
Public field | PanID |
Public field | RouterCapacity |
Public field | StackProfile |
Public field | SuperFrameOrder |
Public field | Version |
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


BeaconOrder Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.BeaconOrder Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


DeviceCapacity Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.DeviceCapacity Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceCapacity As Byte
C#
public byte DeviceCapacity;
C++
public:
char DeviceCapacity sealed ;
J#
public byte DeviceCapacity
JScript
public DeviceCapacity : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


LogicalChannel Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.LogicalChannel Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


PanID Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.PanID Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


RouterCapacity Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.RouterCapacity Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RouterCapacity As Byte
C#
public byte RouterCapacity;
C++
public:
char RouterCapacity sealed ;
J#
public byte RouterCapacity
JScript
public RouterCapacity : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


StackProfile Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.StackProfile Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StackProfile As Byte
C#
public byte StackProfile;
C++
public:
char StackProfile sealed ;
J#
public byte StackProfile
JScript
public StackProfile : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


SuperFrameOrder Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.SuperFrameOrder Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameOrder As Byte
C#
public byte SuperFrameOrder;
C++
public:
char SuperFrameOrder sealed ;
J#
public byte SuperFrameOrder
JScript
public SuperFrameOrder : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


Version Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.Version Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Version As Byte
C#
public byte Version;
C++
public:
char Version sealed ;
J#
public byte Version
JScript
public Version : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_REQUEST Class

NLME_NETWORKDISCOVERY_REQUEST Class
See Also Example Members
[image]

NLME Network discovery request used by tester

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORKDISCOVERY_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_NETWORKDISCOVERY_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_NETWORKDISCOVERY_REQUEST : IREQUEST, INETWORK
J#
public class NLME_NETWORKDISCOVERY_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_NETWORKDISCOVERY_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_NETWORKDISCOVERY_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_REQUEST Members
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_REQUEST Members

NLME_NETWORKDISCOVERY_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME Network discovery request used by tester

The following tables list the members exposed by NLME_NETWORKDISCOVERY_REQUEST.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_REQUEST | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_REQUEST Constructor

NLME_NETWORKDISCOVERY_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_REQUEST | Constructor
Public method | NLME_NETWORKDISCOVERY_REQUEST (NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, Byte) |

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_REQUEST Constructor ()

NLME_NETWORKDISCOVERY_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_REQUEST()
C++
public:
NLME_NETWORKDISCOVERY_REQUEST() sealed
J#
public NLME_NETWORKDISCOVERY_REQUEST()
JScript
public function NLME_NETWORKDISCOVERY_REQUEST()

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_REQUEST Constructor Overload List


NLME_NETWORKDISCOVERY_REQUEST Constructor (NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, Byte)

NLME_NETWORKDISCOVERY_REQUEST Constructor (NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte _
)
C#
public NLME_NETWORKDISCOVERY_REQUEST(
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ,
byte
)
C++
public:
NLME_NETWORKDISCOVERY_REQUEST(
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ,
char
) sealed
J#
public NLME_NETWORKDISCOVERY_REQUEST(
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ,
byte
)
JScript
public function NLME_NETWORKDISCOVERY_REQUEST(
: NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS,
: Byte
)

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_REQUEST Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


ScanChannels Field

NLME_NETWORKDISCOVERY_REQUEST.ScanChannels Field
[image]

Channels to scan

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS
C#
public NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS;

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


ScanDuration Field

NLME_NETWORKDISCOVERY_REQUEST.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS Enumeration

NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Class

NLME_NETWORKDISCOVERY_RESPONSE Class
See Also Example Members
[image]

Response for NLME_NETWORKDISCOVERY_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORKDISCOVERY_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_NETWORKDISCOVERY_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_NETWORKDISCOVERY_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_NETWORKDISCOVERY_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_NETWORKDISCOVERY_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_NETWORKDISCOVERY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_RESPONSE Members
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Members

NLME_NETWORKDISCOVERY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_NETWORKDISCOVERY_REQUEST

The following tables list the members exposed by NLME_NETWORKDISCOVERY_RESPONSE.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_RESPONSE | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Constructor

NLME_NETWORKDISCOVERY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_RESPONSE | Constructor
Public method | NLME_NETWORKDISCOVERY_RESPONSE (NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS) |

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Constructor ()

NLME_NETWORKDISCOVERY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_RESPONSE()
C++
public:
NLME_NETWORKDISCOVERY_RESPONSE() sealed
J#
public NLME_NETWORKDISCOVERY_RESPONSE()
JScript
public function NLME_NETWORKDISCOVERY_RESPONSE()

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_RESPONSE Constructor Overload List


NLME_NETWORKDISCOVERY_RESPONSE Constructor (NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS)

NLME_NETWORKDISCOVERY_RESPONSE Constructor (NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS _
)
C#
public NLME_NETWORKDISCOVERY_RESPONSE(
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
)
C++
public:
NLME_NETWORKDISCOVERY_RESPONSE(
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_NETWORKDISCOVERY_RESPONSE(
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
)
JScript
public function NLME_NETWORKDISCOVERY_RESPONSE(
: NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
)

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace
NLME_NETWORKDISCOVERY_RESPONSE Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_NETWORKDISCOVERY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
C#
public NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS;

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Enumeration

NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS : char
J#
public enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_ORPHANJOIN_REQUEST Class

NLME_ORPHANJOIN_REQUEST Class
See Also Example Members
[image]

NLME orphan join request used by tester

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ORPHANJOIN_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_ORPHANJOIN_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_ORPHANJOIN_REQUEST : IREQUEST, INETWORK
J#
public class NLME_ORPHANJOIN_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_ORPHANJOIN_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_ORPHANJOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ORPHANJOIN_REQUEST Members
TI.ZPI1 Namespace


NLME_ORPHANJOIN_REQUEST Members

NLME_ORPHANJOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME orphan join request used by tester

The following tables list the members exposed by NLME_ORPHANJOIN_REQUEST.

Public Constructors

Name | Description
NLME_ORPHANJOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ORPHANJOIN_REQUEST | Overloaded.
Top

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_ORPHANJOIN_REQUEST Constructor

NLME_ORPHANJOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_ORPHANJOIN_REQUEST | Constructor
Public method | NLME_ORPHANJOIN_REQUEST (NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, Byte) |

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_ORPHANJOIN_REQUEST Constructor ()

NLME_ORPHANJOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ORPHANJOIN_REQUEST()
C++
public:
NLME_ORPHANJOIN_REQUEST() sealed
J#
public NLME_ORPHANJOIN_REQUEST()
JScript
public function NLME_ORPHANJOIN_REQUEST()

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI1 Namespace
NLME_ORPHANJOIN_REQUEST Constructor Overload List


NLME_ORPHANJOIN_REQUEST Constructor (NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, Byte)

NLME_ORPHANJOIN_REQUEST Constructor (NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte _
)
C#
public NLME_ORPHANJOIN_REQUEST(
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ,
byte
)
C++
public:
NLME_ORPHANJOIN_REQUEST(
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ,
char
) sealed
J#
public NLME_ORPHANJOIN_REQUEST(
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ,
byte
)
JScript
public function NLME_ORPHANJOIN_REQUEST(
: NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS,
: Byte
)

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI1 Namespace
NLME_ORPHANJOIN_REQUEST Constructor Overload List


Fields

NLME_ORPHANJOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI1 Namespace


ScanChannels Field

NLME_ORPHANJOIN_REQUEST.ScanChannels Field
[image]

Channels to scan

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS
C#
public NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS;

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI1 Namespace


ScanDuration Field

NLME_ORPHANJOIN_REQUEST.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI1 Namespace


NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS Enumeration

NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


NLME_ORPHANJOIN_RESPONSE Class

NLME_ORPHANJOIN_RESPONSE Class
See Also Example Members
[image]

Response for NLME_ORPHANJOIN_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ORPHANJOIN_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_ORPHANJOIN_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_ORPHANJOIN_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_ORPHANJOIN_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_ORPHANJOIN_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_ORPHANJOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ORPHANJOIN_RESPONSE Members
TI.ZPI1 Namespace


NLME_ORPHANJOIN_RESPONSE Members

NLME_ORPHANJOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_ORPHANJOIN_REQUEST

The following tables list the members exposed by NLME_ORPHANJOIN_RESPONSE.

Public Constructors

Name | Description
NLME_ORPHANJOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ORPHANJOIN_RESPONSE | Overloaded.
Top

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_ORPHANJOIN_RESPONSE Constructor

NLME_ORPHANJOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_ORPHANJOIN_RESPONSE | Constructor
Public method | NLME_ORPHANJOIN_RESPONSE (NLME_ORPHANJOIN_RESPONSE.CMD_STATUS) |

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_ORPHANJOIN_RESPONSE Constructor ()

NLME_ORPHANJOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ORPHANJOIN_RESPONSE()
C++
public:
NLME_ORPHANJOIN_RESPONSE() sealed
J#
public NLME_ORPHANJOIN_RESPONSE()
JScript
public function NLME_ORPHANJOIN_RESPONSE()

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI1 Namespace
NLME_ORPHANJOIN_RESPONSE Constructor Overload List


NLME_ORPHANJOIN_RESPONSE Constructor (NLME_ORPHANJOIN_RESPONSE.CMD_STATUS)

NLME_ORPHANJOIN_RESPONSE Constructor (NLME_ORPHANJOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_ORPHANJOIN_RESPONSE.CMD_STATUS _
)
C#
public NLME_ORPHANJOIN_RESPONSE(
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
)
C++
public:
NLME_ORPHANJOIN_RESPONSE(
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_ORPHANJOIN_RESPONSE(
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
)
JScript
public function NLME_ORPHANJOIN_RESPONSE(
: NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
)

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI1 Namespace
NLME_ORPHANJOIN_RESPONSE Constructor Overload List


Fields

NLME_ORPHANJOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_ORPHANJOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
C#
public NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_ORPHANJOIN_RESPONSE.CMD_STATUS;

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI1 Namespace


NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Enumeration

NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_ORPHANJOIN_RESPONSE.CMD_STATUS : char
J#
public enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_PERMITJOINING_REQUEST Class

NLME_PERMITJOINING_REQUEST Class
See Also Example Members
[image]

This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_PERMITJOINING_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_PERMITJOINING_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_PERMITJOINING_REQUEST : IREQUEST, INETWORK
J#
public class NLME_PERMITJOINING_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_PERMITJOINING_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_PERMITJOINING_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_PERMITJOINING_REQUEST Members
TI.ZPI1 Namespace


NLME_PERMITJOINING_REQUEST Members

NLME_PERMITJOINING_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.

The following tables list the members exposed by NLME_PERMITJOINING_REQUEST.

Public Constructors

Name | Description
NLME_PERMITJOINING_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | PermitDuration | indicates the length of time during which the Zigbee coordinatior will be allowing associations
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_PERMITJOINING_REQUEST | Overloaded.
Top

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI1 Namespace


NLME_PERMITJOINING_REQUEST Constructor

NLME_PERMITJOINING_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_PERMITJOINING_REQUEST | Constructor
Public method | NLME_PERMITJOINING_REQUEST (Byte) | Constructor

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI1 Namespace


NLME_PERMITJOINING_REQUEST Constructor ()

NLME_PERMITJOINING_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_PERMITJOINING_REQUEST()
C++
public:
NLME_PERMITJOINING_REQUEST() sealed
J#
public NLME_PERMITJOINING_REQUEST()
JScript
public function NLME_PERMITJOINING_REQUEST()

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI1 Namespace
NLME_PERMITJOINING_REQUEST Constructor Overload List


NLME_PERMITJOINING_REQUEST Constructor (Byte)

NLME_PERMITJOINING_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public NLME_PERMITJOINING_REQUEST(
byte
)
C++
public:
NLME_PERMITJOINING_REQUEST(
char
) sealed
J#
public NLME_PERMITJOINING_REQUEST(
byte
)
JScript
public function NLME_PERMITJOINING_REQUEST(
: Byte
)

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI1 Namespace
NLME_PERMITJOINING_REQUEST Constructor Overload List


Fields

NLME_PERMITJOINING_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | PermitDuration | indicates the length of time during which the Zigbee coordinatior will be allowing associations
Top

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI1 Namespace


PermitDuration Field

NLME_PERMITJOINING_REQUEST.PermitDuration Field
[image]

indicates the length of time during which the Zigbee coordinatior will be allowing associations

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PermitDuration As Byte
C#
public byte PermitDuration;
C++
public:
char PermitDuration sealed ;
J#
public byte PermitDuration
JScript
public PermitDuration : Byte;

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI1 Namespace


NLME_PERMITJOINING_RESPONSE Class

NLME_PERMITJOINING_RESPONSE Class
See Also Example Members
[image]

Response for NLME_PERMITJOINING_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_PERMITJOINING_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_PERMITJOINING_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_PERMITJOINING_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_PERMITJOINING_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_PERMITJOINING_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_PERMITJOINING_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_PERMITJOINING_RESPONSE Members
TI.ZPI1 Namespace


NLME_PERMITJOINING_RESPONSE Members

NLME_PERMITJOINING_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_PERMITJOINING_REQUEST

The following tables list the members exposed by NLME_PERMITJOINING_RESPONSE.

Public Constructors

Name | Description
NLME_PERMITJOINING_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_PERMITJOINING_RESPONSE | Overloaded.
Top

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI1 Namespace


NLME_PERMITJOINING_RESPONSE Constructor

NLME_PERMITJOINING_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_PERMITJOINING_RESPONSE | Constructor
Public method | NLME_PERMITJOINING_RESPONSE (NLME_PERMITJOINING_RESPONSE.CMD_STATUS) |

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI1 Namespace


NLME_PERMITJOINING_RESPONSE Constructor ()

NLME_PERMITJOINING_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_PERMITJOINING_RESPONSE()
C++
public:
NLME_PERMITJOINING_RESPONSE() sealed
J#
public NLME_PERMITJOINING_RESPONSE()
JScript
public function NLME_PERMITJOINING_RESPONSE()

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI1 Namespace
NLME_PERMITJOINING_RESPONSE Constructor Overload List


NLME_PERMITJOINING_RESPONSE Constructor (NLME_PERMITJOINING_RESPONSE.CMD_STATUS)

NLME_PERMITJOINING_RESPONSE Constructor (NLME_PERMITJOINING_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_PERMITJOINING_RESPONSE.CMD_STATUS _
)
C#
public NLME_PERMITJOINING_RESPONSE(
NLME_PERMITJOINING_RESPONSE.CMD_STATUS
)
C++
public:
NLME_PERMITJOINING_RESPONSE(
NLME_PERMITJOINING_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_PERMITJOINING_RESPONSE(
NLME_PERMITJOINING_RESPONSE.CMD_STATUS
)
JScript
public function NLME_PERMITJOINING_RESPONSE(
: NLME_PERMITJOINING_RESPONSE.CMD_STATUS
)

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI1 Namespace
NLME_PERMITJOINING_RESPONSE Constructor Overload List


Fields

NLME_PERMITJOINING_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_PERMITJOINING_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_PERMITJOINING_RESPONSE.CMD_STATUS
C#
public NLME_PERMITJOINING_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_PERMITJOINING_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_PERMITJOINING_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_PERMITJOINING_RESPONSE.CMD_STATUS;

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI1 Namespace


NLME_PERMITJOINING_RESPONSE.CMD_STATUS Enumeration

NLME_PERMITJOINING_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_PERMITJOINING_RESPONSE.CMD_STATUS : char
J#
public enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_RESET_REQUEST Class

NLME_RESET_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_RESET_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_RESET_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_RESET_REQUEST : IREQUEST, INETWORK
J#
public class NLME_RESET_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_RESET_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_RESET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_RESET_REQUEST Members
TI.ZPI1 Namespace


NLME_RESET_REQUEST Members

NLME_RESET_REQUEST Members
See Also Example Constructors Methods
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation

The following tables list the members exposed by NLME_RESET_REQUEST.

Public Constructors

 | Name | Description
Public method | NLME_RESET_REQUEST | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NLME_RESET_REQUEST Class
TI.ZPI1 Namespace


NLME_RESET_REQUEST Constructor

NLME_RESET_REQUEST Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_RESET_REQUEST()
C++
public:
NLME_RESET_REQUEST() sealed
J#
public NLME_RESET_REQUEST()
JScript
public function NLME_RESET_REQUEST()

See Also

NLME_RESET_REQUEST Class
TI.ZPI1 Namespace


NLME_RESET_RESPONSE Class

NLME_RESET_RESPONSE Class
See Also Example Members
[image]

Response for NLME_RESET_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_RESET_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_RESET_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_RESET_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_RESET_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_RESET_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_RESET_RESPONSE Members
TI.ZPI1 Namespace


NLME_RESET_RESPONSE Members

NLME_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_RESET_REQUEST

The following tables list the members exposed by NLME_RESET_RESPONSE.

Public Constructors

Name | Description
NLME_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_RESET_RESPONSE | Overloaded.
Top

See Also

NLME_RESET_RESPONSE Class
TI.ZPI1 Namespace


NLME_RESET_RESPONSE Constructor

NLME_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_RESET_RESPONSE | Constructor
Public method | NLME_RESET_RESPONSE (NLME_RESET_RESPONSE.CMD_STATUS) |

See Also

NLME_RESET_RESPONSE Class
TI.ZPI1 Namespace


NLME_RESET_RESPONSE Constructor ()

NLME_RESET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_RESET_RESPONSE()
C++
public:
NLME_RESET_RESPONSE() sealed
J#
public NLME_RESET_RESPONSE()
JScript
public function NLME_RESET_RESPONSE()

See Also

NLME_RESET_RESPONSE Class
TI.ZPI1 Namespace
NLME_RESET_RESPONSE Constructor Overload List


NLME_RESET_RESPONSE Constructor (NLME_RESET_RESPONSE.CMD_STATUS)

NLME_RESET_RESPONSE Constructor (NLME_RESET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_RESET_RESPONSE.CMD_STATUS _
)
C#
public NLME_RESET_RESPONSE(
NLME_RESET_RESPONSE.CMD_STATUS
)
C++
public:
NLME_RESET_RESPONSE(
NLME_RESET_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_RESET_RESPONSE(
NLME_RESET_RESPONSE.CMD_STATUS
)
JScript
public function NLME_RESET_RESPONSE(
: NLME_RESET_RESPONSE.CMD_STATUS
)

See Also

NLME_RESET_RESPONSE Class
TI.ZPI1 Namespace
NLME_RESET_RESPONSE Constructor Overload List


Fields

NLME_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_RESET_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_RESET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_RESET_RESPONSE.CMD_STATUS
C#
public NLME_RESET_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_RESET_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_RESET_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_RESET_RESPONSE.CMD_STATUS;

See Also

NLME_RESET_RESPONSE Class
TI.ZPI1 Namespace


NLME_RESET_RESPONSE.CMD_STATUS Enumeration

NLME_RESET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_RESET_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_RESET_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_RESET_RESPONSE.CMD_STATUS : char
J#
public enum NLME_RESET_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_RESET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_REQUEST Class

NLME_ROUTEDISCOVERY_REQUEST Class
See Also Example Members
[image]

NLME route discovery request used by tester

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ROUTEDISCOVERY_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_ROUTEDISCOVERY_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_ROUTEDISCOVERY_REQUEST : IREQUEST, INETWORK
J#
public class NLME_ROUTEDISCOVERY_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_ROUTEDISCOVERY_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_ROUTEDISCOVERY_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ROUTEDISCOVERY_REQUEST Members
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_REQUEST Members

NLME_ROUTEDISCOVERY_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME route discovery request used by tester

The following tables list the members exposed by NLME_ROUTEDISCOVERY_REQUEST.

Public Constructors

Name | Description
NLME_ROUTEDISCOVERY_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddress | Destination address
Public field | Repair | specifies a route repair operation if set to TRUE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ROUTEDISCOVERY_REQUEST | Overloaded.
Top

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_REQUEST Constructor

NLME_ROUTEDISCOVERY_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_ROUTEDISCOVERY_REQUEST | Constructor
Public method | NLME_ROUTEDISCOVERY_REQUEST (UInt16, Byte) | Constructor

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_REQUEST Constructor ()

NLME_ROUTEDISCOVERY_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ROUTEDISCOVERY_REQUEST()
C++
public:
NLME_ROUTEDISCOVERY_REQUEST() sealed
J#
public NLME_ROUTEDISCOVERY_REQUEST()
JScript
public function NLME_ROUTEDISCOVERY_REQUEST()

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI1 Namespace
NLME_ROUTEDISCOVERY_REQUEST Constructor Overload List


NLME_ROUTEDISCOVERY_REQUEST Constructor (UInt16, Byte)

NLME_ROUTEDISCOVERY_REQUEST Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public NLME_ROUTEDISCOVERY_REQUEST(
ushort ,
byte
)
C++
public:
NLME_ROUTEDISCOVERY_REQUEST(
unsigned short ,
char
) sealed
J#
public NLME_ROUTEDISCOVERY_REQUEST(
ushort ,
byte
)
JScript
public function NLME_ROUTEDISCOVERY_REQUEST(
: UInt16,
: Byte
)

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI1 Namespace
NLME_ROUTEDISCOVERY_REQUEST Constructor Overload List


Fields

NLME_ROUTEDISCOVERY_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddress | Destination address
Public field | Repair | specifies a route repair operation if set to TRUE
Top

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


DstAddress Field

NLME_ROUTEDISCOVERY_REQUEST.DstAddress Field
[image]

Destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddress As UInt16
C#
public ushort DstAddress;
C++
public:
unsigned short DstAddress sealed ;
J#
public ushort DstAddress
JScript
public DstAddress : UInt16;

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


Repair Field

NLME_ROUTEDISCOVERY_REQUEST.Repair Field
[image]

specifies a route repair operation if set to TRUE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Repair As Byte
C#
public byte Repair;
C++
public:
char Repair sealed ;
J#
public byte Repair
JScript
public Repair : Byte;

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Class

NLME_ROUTEDISCOVERY_RESPONSE Class
See Also Example Members
[image]

Response for NLME_ROUTEDISCOVERY_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ROUTEDISCOVERY_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_ROUTEDISCOVERY_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_ROUTEDISCOVERY_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_ROUTEDISCOVERY_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_ROUTEDISCOVERY_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_ROUTEDISCOVERY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ROUTEDISCOVERY_RESPONSE Members
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Members

NLME_ROUTEDISCOVERY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_ROUTEDISCOVERY_REQUEST

The following tables list the members exposed by NLME_ROUTEDISCOVERY_RESPONSE.

Public Constructors

Name | Description
NLME_ROUTEDISCOVERY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ROUTEDISCOVERY_RESPONSE | Overloaded.
Top

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Constructor

NLME_ROUTEDISCOVERY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_ROUTEDISCOVERY_RESPONSE | Constructor
Public method | NLME_ROUTEDISCOVERY_RESPONSE (NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS) |

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Constructor ()

NLME_ROUTEDISCOVERY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ROUTEDISCOVERY_RESPONSE()
C++
public:
NLME_ROUTEDISCOVERY_RESPONSE() sealed
J#
public NLME_ROUTEDISCOVERY_RESPONSE()
JScript
public function NLME_ROUTEDISCOVERY_RESPONSE()

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace
NLME_ROUTEDISCOVERY_RESPONSE Constructor Overload List


NLME_ROUTEDISCOVERY_RESPONSE Constructor (NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS)

NLME_ROUTEDISCOVERY_RESPONSE Constructor (NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS _
)
C#
public NLME_ROUTEDISCOVERY_RESPONSE(
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
)
C++
public:
NLME_ROUTEDISCOVERY_RESPONSE(
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_ROUTEDISCOVERY_RESPONSE(
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
)
JScript
public function NLME_ROUTEDISCOVERY_RESPONSE(
: NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
)

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace
NLME_ROUTEDISCOVERY_RESPONSE Constructor Overload List


Fields

NLME_ROUTEDISCOVERY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_ROUTEDISCOVERY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
C#
public NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS;

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI1 Namespace


NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Enumeration

NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS : char
J#
public enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_SET_REQUEST Class

NLME_SET_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SET_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_SET_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_SET_REQUEST : IREQUEST, INETWORK
J#
public class NLME_SET_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_SET_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_SET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SET_REQUEST Members
TI.ZPI1 Namespace


NLME_SET_REQUEST Members

NLME_SET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).

The following tables list the members exposed by NLME_SET_REQUEST.

Public Constructors

Name | Description
NLME_SET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Index | contains the index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | NIBAttributeValue | specifies the value of the NIBAttribute
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SET_REQUEST | Overloaded.
Top

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace


NLME_SET_REQUEST Constructor

NLME_SET_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_SET_REQUEST | Constructor
Public method | NLME_SET_REQUEST (NLME_SET_REQUEST.NIB_ATTR, UInt16, UInt16) |

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace


NLME_SET_REQUEST Constructor ()

NLME_SET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SET_REQUEST()
C++
public:
NLME_SET_REQUEST() sealed
J#
public NLME_SET_REQUEST()
JScript
public function NLME_SET_REQUEST()

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace
NLME_SET_REQUEST Constructor Overload List


NLME_SET_REQUEST Constructor (NLME_SET_REQUEST.NIB_ATTR, UInt16, UInt16)

NLME_SET_REQUEST Constructor (NLME_SET_REQUEST.NIB_ATTR, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SET_REQUEST.NIB_ATTR, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public NLME_SET_REQUEST(
NLME_SET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
C++
public:
NLME_SET_REQUEST(
NLME_SET_REQUEST.NIB_ATTR ,
unsigned short ,
unsigned short
) sealed
J#
public NLME_SET_REQUEST(
NLME_SET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
JScript
public function NLME_SET_REQUEST(
: NLME_SET_REQUEST.NIB_ATTR,
: UInt16,
: UInt16
)

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace
NLME_SET_REQUEST Constructor Overload List


Fields

NLME_SET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Index | contains the index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | NIBAttributeValue | specifies the value of the NIBAttribute
Top

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace


Index Field

NLME_SET_REQUEST.Index Field
[image]

contains the index into table NIB items

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index As UInt16
C#
public ushort Index;
C++
public:
unsigned short Index sealed ;
J#
public ushort Index
JScript
public Index : UInt16;

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace


NIBAttribute Field

NLME_SET_REQUEST.NIBAttribute Field
[image]

identifies the intended attribute of the NIB

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NIBAttribute As NLME_SET_REQUEST.NIB_ATTR
C#
public NLME_SET_REQUEST.NIB_ATTR NIBAttribute;
C++
public:
NLME_SET_REQUEST.NIB_ATTR NIBAttribute sealed ;
J#
public NLME_SET_REQUEST.NIB_ATTR NIBAttribute
JScript
public NIBAttribute : NLME_SET_REQUEST.NIB_ATTR;

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace


NIBAttributeValue Field

NLME_SET_REQUEST.NIBAttributeValue Field
[image]

specifies the value of the NIBAttribute

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NIBAttributeValue As UInt16
C#
public ushort NIBAttributeValue;
C++
public:
unsigned short NIBAttributeValue sealed ;
J#
public ushort NIBAttributeValue
JScript
public NIBAttributeValue : UInt16;

See Also

NLME_SET_REQUEST Class
TI.ZPI1 Namespace


NLME_SET_REQUEST.NIB_ATTR Enumeration

NLME_SET_REQUEST.NIB_ATTR Enumeration
[image]

Network layer information base attributes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SET_REQUEST.NIB_ATTR As Byte
C#
public enum NLME_SET_REQUEST.NIB_ATTR : byte
C++
public enum class NLME_SET_REQUEST.NIB_ATTR : char
J#
public enum NLME_SET_REQUEST.NIB_ATTR byte
JScript
public enum NLME_SET_REQUEST.NIB_ATTR :

Members

Member Name | Description
NWK_BCSN | Network layer information base attributes
NWK_PASSIVE_ACK_TIMEOUT | Network layer information base attributes
NWK_MAX_BROADCAST_RETRIES | Network layer information base attributes
NWK_MAX_CHILDREN | Network layer information base attributes
NWK_MAX_DEPTH | Network layer information base attributes
NWK_MAX_ROUTERS | Network layer information base attributes
NWK_NEIGHBOR_TABLE | Network layer information base attributes
NWK_BROADCAST_DELIVERY_TIME | Network layer information base attributes
NWK_REPORT_CONSTANT_COST | Network layer information base attributes
NWK_ROUTE_DISCOVERY_RETRIES_PERMITTED | Network layer information base attributes
NWK_ROUTE_TABLE | Network layer information base attributes
NWK_SECURE_ALL_FRAMES | Network layer information base attributes
NWK_SECURITY_LEVEL | Network layer information base attributes
NWK_SYM_LINK | Network layer information base attributes
NWK_CAP_INFO | Network layer information base attributes

See Also

TI.ZPI1 Namespace


NLME_SET_RESPONSE Class

NLME_SET_RESPONSE Class
See Also Example Members
[image]

Response for NLME_SET_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SET_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_SET_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_SET_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_SET_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_SET_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_SET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SET_RESPONSE Members
TI.ZPI1 Namespace


NLME_SET_RESPONSE Members

NLME_SET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_SET_REQUEST

The following tables list the members exposed by NLME_SET_RESPONSE.

Public Constructors

Name | Description
NLME_SET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SET_RESPONSE | Overloaded.
Top

See Also

NLME_SET_RESPONSE Class
TI.ZPI1 Namespace


NLME_SET_RESPONSE Constructor

NLME_SET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_SET_RESPONSE | Constructor
Public method | NLME_SET_RESPONSE (NLME_SET_RESPONSE.CMD_STATUS) |

See Also

NLME_SET_RESPONSE Class
TI.ZPI1 Namespace


NLME_SET_RESPONSE Constructor ()

NLME_SET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SET_RESPONSE()
C++
public:
NLME_SET_RESPONSE() sealed
J#
public NLME_SET_RESPONSE()
JScript
public function NLME_SET_RESPONSE()

See Also

NLME_SET_RESPONSE Class
TI.ZPI1 Namespace
NLME_SET_RESPONSE Constructor Overload List


NLME_SET_RESPONSE Constructor (NLME_SET_RESPONSE.CMD_STATUS)

NLME_SET_RESPONSE Constructor (NLME_SET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SET_RESPONSE.CMD_STATUS _
)
C#
public NLME_SET_RESPONSE(
NLME_SET_RESPONSE.CMD_STATUS
)
C++
public:
NLME_SET_RESPONSE(
NLME_SET_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_SET_RESPONSE(
NLME_SET_RESPONSE.CMD_STATUS
)
JScript
public function NLME_SET_RESPONSE(
: NLME_SET_RESPONSE.CMD_STATUS
)

See Also

NLME_SET_RESPONSE Class
TI.ZPI1 Namespace
NLME_SET_RESPONSE Constructor Overload List


Fields

NLME_SET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_SET_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_SET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_SET_RESPONSE.CMD_STATUS
C#
public NLME_SET_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_SET_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_SET_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_SET_RESPONSE.CMD_STATUS;

See Also

NLME_SET_RESPONSE Class
TI.ZPI1 Namespace


NLME_SET_RESPONSE.CMD_STATUS Enumeration

NLME_SET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SET_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_SET_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_SET_RESPONSE.CMD_STATUS : char
J#
public enum NLME_SET_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_SET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_STARTROUTER_CONFIRMATION Class

NLME_STARTROUTER_CONFIRMATION Class
See Also Example Members
[image]

This message is sent by the target to the next higher layer of the results of its request to start a router

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_STARTROUTER_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_STARTROUTER_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_STARTROUTER_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_STARTROUTER_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_STARTROUTER_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_STARTROUTER_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_STARTROUTER_CONFIRMATION Members
TI.ZPI1 Namespace


NLME_STARTROUTER_CONFIRMATION Members

NLME_STARTROUTER_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to the next higher layer of the results of its request to start a router

The following tables list the members exposed by NLME_STARTROUTER_CONFIRMATION.

Public Constructors

Name | Description
NLME_STARTROUTER_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_STARTROUTER_CONFIRMATION | Overloaded.
Top

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_STARTROUTER_CONFIRMATION Constructor

NLME_STARTROUTER_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_STARTROUTER_CONFIRMATION | Constructor
Public method | NLME_STARTROUTER_CONFIRMATION (NLME_STARTROUTER_CONFIRMATION.CMD_STATUS) |

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_STARTROUTER_CONFIRMATION Constructor ()

NLME_STARTROUTER_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_STARTROUTER_CONFIRMATION()
C++
public:
NLME_STARTROUTER_CONFIRMATION() sealed
J#
public NLME_STARTROUTER_CONFIRMATION()
JScript
public function NLME_STARTROUTER_CONFIRMATION()

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_STARTROUTER_CONFIRMATION Constructor Overload List


NLME_STARTROUTER_CONFIRMATION Constructor (NLME_STARTROUTER_CONFIRMATION.CMD_STATUS)

NLME_STARTROUTER_CONFIRMATION Constructor (NLME_STARTROUTER_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_STARTROUTER_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_STARTROUTER_CONFIRMATION(
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_STARTROUTER_CONFIRMATION(
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_STARTROUTER_CONFIRMATION(
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_STARTROUTER_CONFIRMATION(
: NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
)

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI1 Namespace
NLME_STARTROUTER_CONFIRMATION Constructor Overload List


Fields

NLME_STARTROUTER_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NLME_STARTROUTER_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
C#
public NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_STARTROUTER_CONFIRMATION.CMD_STATUS;

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI1 Namespace


NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Enumeration

NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_STARTROUTER_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_STARTROUTER_REQUEST Class

NLME_STARTROUTER_REQUEST Class
See Also Example Members
[image]

NLME Start router request used by tester

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_STARTROUTER_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_STARTROUTER_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_STARTROUTER_REQUEST : IREQUEST, INETWORK
J#
public class NLME_STARTROUTER_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_STARTROUTER_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_STARTROUTER_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_STARTROUTER_REQUEST Members
TI.ZPI1 Namespace


NLME_STARTROUTER_REQUEST Members

NLME_STARTROUTER_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME Start router request used by tester

The following tables list the members exposed by NLME_STARTROUTER_REQUEST.

Public Constructors

Name | Description
NLME_STARTROUTER_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | Battery Life Extension
Public field | BeaconOrder | Beacon Order
Public field | SuperframeOrder | Super frame Order
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_STARTROUTER_REQUEST | Overloaded.
Top

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace


NLME_STARTROUTER_REQUEST Constructor

NLME_STARTROUTER_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_STARTROUTER_REQUEST | Constructor
Public method | NLME_STARTROUTER_REQUEST (Byte, Byte, Byte) | Constructor

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace


NLME_STARTROUTER_REQUEST Constructor ()

NLME_STARTROUTER_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_STARTROUTER_REQUEST()
C++
public:
NLME_STARTROUTER_REQUEST() sealed
J#
public NLME_STARTROUTER_REQUEST()
JScript
public function NLME_STARTROUTER_REQUEST()

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace
NLME_STARTROUTER_REQUEST Constructor Overload List


NLME_STARTROUTER_REQUEST Constructor (Byte, Byte, Byte)

NLME_STARTROUTER_REQUEST Constructor (Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLME_STARTROUTER_REQUEST(
byte ,
byte ,
byte
)
C++
public:
NLME_STARTROUTER_REQUEST(
char ,
char ,
char
) sealed
J#
public NLME_STARTROUTER_REQUEST(
byte ,
byte ,
byte
)
JScript
public function NLME_STARTROUTER_REQUEST(
: Byte,
: Byte,
: Byte
)

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace
NLME_STARTROUTER_REQUEST Constructor Overload List


Fields

NLME_STARTROUTER_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | Battery Life Extension
Public field | BeaconOrder | Beacon Order
Public field | SuperframeOrder | Super frame Order
Top

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace


BatteryLifeExtension Field

NLME_STARTROUTER_REQUEST.BatteryLifeExtension Field
[image]

Battery Life Extension

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BatteryLifeExtension As Byte
C#
public byte BatteryLifeExtension;
C++
public:
char BatteryLifeExtension sealed ;
J#
public byte BatteryLifeExtension
JScript
public BatteryLifeExtension : Byte;

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace


BeaconOrder Field

NLME_STARTROUTER_REQUEST.BeaconOrder Field
[image]

Beacon Order

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace


SuperframeOrder Field

NLME_STARTROUTER_REQUEST.SuperframeOrder Field
[image]

Super frame Order

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperframeOrder As Byte
C#
public byte SuperframeOrder;
C++
public:
char SuperframeOrder sealed ;
J#
public byte SuperframeOrder
JScript
public SuperframeOrder : Byte;

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI1 Namespace


NLME_STARTROUTER_RESPONSE Class

NLME_STARTROUTER_RESPONSE Class
See Also Example Members
[image]

Response for NLME_STARTROUTER_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_STARTROUTER_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_STARTROUTER_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_STARTROUTER_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_STARTROUTER_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_STARTROUTER_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_STARTROUTER_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_STARTROUTER_RESPONSE Members
TI.ZPI1 Namespace


NLME_STARTROUTER_RESPONSE Members

NLME_STARTROUTER_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_STARTROUTER_REQUEST

The following tables list the members exposed by NLME_STARTROUTER_RESPONSE.

Public Constructors

Name | Description
NLME_STARTROUTER_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_STARTROUTER_RESPONSE | Overloaded.
Top

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI1 Namespace


NLME_STARTROUTER_RESPONSE Constructor

NLME_STARTROUTER_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_STARTROUTER_RESPONSE | Constructor
Public method | NLME_STARTROUTER_RESPONSE (NLME_STARTROUTER_RESPONSE.CMD_STATUS) |

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI1 Namespace


NLME_STARTROUTER_RESPONSE Constructor ()

NLME_STARTROUTER_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_STARTROUTER_RESPONSE()
C++
public:
NLME_STARTROUTER_RESPONSE() sealed
J#
public NLME_STARTROUTER_RESPONSE()
JScript
public function NLME_STARTROUTER_RESPONSE()

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI1 Namespace
NLME_STARTROUTER_RESPONSE Constructor Overload List


NLME_STARTROUTER_RESPONSE Constructor (NLME_STARTROUTER_RESPONSE.CMD_STATUS)

NLME_STARTROUTER_RESPONSE Constructor (NLME_STARTROUTER_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_STARTROUTER_RESPONSE.CMD_STATUS _
)
C#
public NLME_STARTROUTER_RESPONSE(
NLME_STARTROUTER_RESPONSE.CMD_STATUS
)
C++
public:
NLME_STARTROUTER_RESPONSE(
NLME_STARTROUTER_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_STARTROUTER_RESPONSE(
NLME_STARTROUTER_RESPONSE.CMD_STATUS
)
JScript
public function NLME_STARTROUTER_RESPONSE(
: NLME_STARTROUTER_RESPONSE.CMD_STATUS
)

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI1 Namespace
NLME_STARTROUTER_RESPONSE Constructor Overload List


Fields

NLME_STARTROUTER_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_STARTROUTER_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_STARTROUTER_RESPONSE.CMD_STATUS
C#
public NLME_STARTROUTER_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_STARTROUTER_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_STARTROUTER_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_STARTROUTER_RESPONSE.CMD_STATUS;

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI1 Namespace


NLME_STARTROUTER_RESPONSE.CMD_STATUS Enumeration

NLME_STARTROUTER_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_STARTROUTER_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_STARTROUTER_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_STARTROUTER_RESPONSE.CMD_STATUS : char
J#
public enum NLME_STARTROUTER_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_STARTROUTER_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_SYNC_INDICATION Class

NLME_SYNC_INDICATION Class
See Also Example Members
[image]

This message is sent by the target to indicate a sync request to the next higher layer of a coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SYNC_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLME_SYNC_INDICATION : IINDICATION, INETWORK
C++
ref class NLME_SYNC_INDICATION : IINDICATION, INETWORK
J#
public class NLME_SYNC_INDICATION implements IINDICATION, INETWORK
JScript
public class NLME_SYNC_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_SYNC_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SYNC_INDICATION Members
TI.ZPI1 Namespace


NLME_SYNC_INDICATION Members

NLME_SYNC_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate a sync request to the next higher layer of a coordinator

The following tables list the members exposed by NLME_SYNC_INDICATION.

Public Constructors

Name | Description
NLME_SYNC_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SYNC_INDICATION | Overloaded.
Top

See Also

NLME_SYNC_INDICATION Class
TI.ZPI1 Namespace


NLME_SYNC_INDICATION Constructor

NLME_SYNC_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLME_SYNC_INDICATION | Constructor
Public method | NLME_SYNC_INDICATION (NLME_SYNC_INDICATION.CMD_STATUS) |

See Also

NLME_SYNC_INDICATION Class
TI.ZPI1 Namespace


NLME_SYNC_INDICATION Constructor ()

NLME_SYNC_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SYNC_INDICATION()
C++
public:
NLME_SYNC_INDICATION() sealed
J#
public NLME_SYNC_INDICATION()
JScript
public function NLME_SYNC_INDICATION()

See Also

NLME_SYNC_INDICATION Class
TI.ZPI1 Namespace
NLME_SYNC_INDICATION Constructor Overload List


NLME_SYNC_INDICATION Constructor (NLME_SYNC_INDICATION.CMD_STATUS)

NLME_SYNC_INDICATION Constructor (NLME_SYNC_INDICATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SYNC_INDICATION.CMD_STATUS _
)
C#
public NLME_SYNC_INDICATION(
NLME_SYNC_INDICATION.CMD_STATUS
)
C++
public:
NLME_SYNC_INDICATION(
NLME_SYNC_INDICATION.CMD_STATUS
) sealed
J#
public NLME_SYNC_INDICATION(
NLME_SYNC_INDICATION.CMD_STATUS
)
JScript
public function NLME_SYNC_INDICATION(
: NLME_SYNC_INDICATION.CMD_STATUS
)

See Also

NLME_SYNC_INDICATION Class
TI.ZPI1 Namespace
NLME_SYNC_INDICATION Constructor Overload List


Fields

NLME_SYNC_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_SYNC_INDICATION Class
TI.ZPI1 Namespace


Status Field

NLME_SYNC_INDICATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_SYNC_INDICATION.CMD_STATUS
C#
public NLME_SYNC_INDICATION.CMD_STATUS Status;
C++
public:
NLME_SYNC_INDICATION.CMD_STATUS Status sealed ;
J#
public NLME_SYNC_INDICATION.CMD_STATUS Status
JScript
public Status : NLME_SYNC_INDICATION.CMD_STATUS;

See Also

NLME_SYNC_INDICATION Class
TI.ZPI1 Namespace


NLME_SYNC_INDICATION.CMD_STATUS Enumeration

NLME_SYNC_INDICATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SYNC_INDICATION.CMD_STATUS As Byte
C#
public enum NLME_SYNC_INDICATION.CMD_STATUS : byte
C++
public enum class NLME_SYNC_INDICATION.CMD_STATUS : char
J#
public enum NLME_SYNC_INDICATION.CMD_STATUS byte
JScript
public enum NLME_SYNC_INDICATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NLME_SYNC_REQUEST Class

NLME_SYNC_REQUEST Class
See Also Example Members
[image]

This primitive allows the next higher layer to synchronize or extract data from its ZigBee coordinator or router

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SYNC_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_SYNC_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_SYNC_REQUEST : IREQUEST, INETWORK
J#
public class NLME_SYNC_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_SYNC_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_SYNC_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SYNC_REQUEST Members
TI.ZPI1 Namespace


NLME_SYNC_REQUEST Members

NLME_SYNC_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This primitive allows the next higher layer to synchronize or extract data from its ZigBee coordinator or router

The following tables list the members exposed by NLME_SYNC_REQUEST.

Public Constructors

Name | Description
NLME_SYNC_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Track | Specifies whether the synchronization should be maintained for future beacons or not
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SYNC_REQUEST | Overloaded.
Top

See Also

NLME_SYNC_REQUEST Class
TI.ZPI1 Namespace


NLME_SYNC_REQUEST Constructor

NLME_SYNC_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_SYNC_REQUEST | Constructor
Public method | NLME_SYNC_REQUEST (NLME_SYNC_REQUEST.TRACK_BEACONS) |

See Also

NLME_SYNC_REQUEST Class
TI.ZPI1 Namespace


NLME_SYNC_REQUEST Constructor ()

NLME_SYNC_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SYNC_REQUEST()
C++
public:
NLME_SYNC_REQUEST() sealed
J#
public NLME_SYNC_REQUEST()
JScript
public function NLME_SYNC_REQUEST()

See Also

NLME_SYNC_REQUEST Class
TI.ZPI1 Namespace
NLME_SYNC_REQUEST Constructor Overload List


NLME_SYNC_REQUEST Constructor (NLME_SYNC_REQUEST.TRACK_BEACONS)

NLME_SYNC_REQUEST Constructor (NLME_SYNC_REQUEST.TRACK_BEACONS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SYNC_REQUEST.TRACK_BEACONS _
)
C#
public NLME_SYNC_REQUEST(
NLME_SYNC_REQUEST.TRACK_BEACONS
)
C++
public:
NLME_SYNC_REQUEST(
NLME_SYNC_REQUEST.TRACK_BEACONS
) sealed
J#
public NLME_SYNC_REQUEST(
NLME_SYNC_REQUEST.TRACK_BEACONS
)
JScript
public function NLME_SYNC_REQUEST(
: NLME_SYNC_REQUEST.TRACK_BEACONS
)

See Also

NLME_SYNC_REQUEST Class
TI.ZPI1 Namespace
NLME_SYNC_REQUEST Constructor Overload List


Fields

NLME_SYNC_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Track | Specifies whether the synchronization should be maintained for future beacons or not
Top

See Also

NLME_SYNC_REQUEST Class
TI.ZPI1 Namespace


Track Field

NLME_SYNC_REQUEST.Track Field
[image]

Specifies whether the synchronization should be maintained for future beacons or not

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Track As NLME_SYNC_REQUEST.TRACK_BEACONS
C#
public NLME_SYNC_REQUEST.TRACK_BEACONS Track;
C++
public:
NLME_SYNC_REQUEST.TRACK_BEACONS Track sealed ;
J#
public NLME_SYNC_REQUEST.TRACK_BEACONS Track
JScript
public Track : NLME_SYNC_REQUEST.TRACK_BEACONS;

See Also

NLME_SYNC_REQUEST Class
TI.ZPI1 Namespace


NLME_SYNC_REQUEST.TRACK_BEACONS Enumeration

NLME_SYNC_REQUEST.TRACK_BEACONS Enumeration
[image]

Select track beacons or not

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SYNC_REQUEST.TRACK_BEACONS As Byte
C#
public enum NLME_SYNC_REQUEST.TRACK_BEACONS : byte
C++
public enum class NLME_SYNC_REQUEST.TRACK_BEACONS : char
J#
public enum NLME_SYNC_REQUEST.TRACK_BEACONS byte
JScript
public enum NLME_SYNC_REQUEST.TRACK_BEACONS :

Members

Member Name | Description
TRACK | Select track beacons or not
NO_TRACK | Select track beacons or not

See Also

TI.ZPI1 Namespace


NLME_SYNC_RESPONSE Class

NLME_SYNC_RESPONSE Class
See Also Example Members
[image]

Response for NLME_SYNC_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SYNC_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_SYNC_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_SYNC_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_SYNC_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_SYNC_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NLME_SYNC_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SYNC_RESPONSE Members
TI.ZPI1 Namespace


NLME_SYNC_RESPONSE Members

NLME_SYNC_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_SYNC_REQUEST

The following tables list the members exposed by NLME_SYNC_RESPONSE.

Public Constructors

Name | Description
NLME_SYNC_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SYNC_RESPONSE | Overloaded.
Top

See Also

NLME_SYNC_RESPONSE Class
TI.ZPI1 Namespace


NLME_SYNC_RESPONSE Constructor

NLME_SYNC_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_SYNC_RESPONSE | Constructor
Public method | NLME_SYNC_RESPONSE (NLME_SYNC_RESPONSE.CMD_STATUS) |

See Also

NLME_SYNC_RESPONSE Class
TI.ZPI1 Namespace


NLME_SYNC_RESPONSE Constructor ()

NLME_SYNC_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SYNC_RESPONSE()
C++
public:
NLME_SYNC_RESPONSE() sealed
J#
public NLME_SYNC_RESPONSE()
JScript
public function NLME_SYNC_RESPONSE()

See Also

NLME_SYNC_RESPONSE Class
TI.ZPI1 Namespace
NLME_SYNC_RESPONSE Constructor Overload List


NLME_SYNC_RESPONSE Constructor (NLME_SYNC_RESPONSE.CMD_STATUS)

NLME_SYNC_RESPONSE Constructor (NLME_SYNC_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SYNC_RESPONSE.CMD_STATUS _
)
C#
public NLME_SYNC_RESPONSE(
NLME_SYNC_RESPONSE.CMD_STATUS
)
C++
public:
NLME_SYNC_RESPONSE(
NLME_SYNC_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_SYNC_RESPONSE(
NLME_SYNC_RESPONSE.CMD_STATUS
)
JScript
public function NLME_SYNC_RESPONSE(
: NLME_SYNC_RESPONSE.CMD_STATUS
)

See Also

NLME_SYNC_RESPONSE Class
TI.ZPI1 Namespace
NLME_SYNC_RESPONSE Constructor Overload List


Fields

NLME_SYNC_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_SYNC_RESPONSE Class
TI.ZPI1 Namespace


Status Field

NLME_SYNC_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_SYNC_RESPONSE.CMD_STATUS
C#
public NLME_SYNC_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_SYNC_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_SYNC_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_SYNC_RESPONSE.CMD_STATUS;

See Also

NLME_SYNC_RESPONSE Class
TI.ZPI1 Namespace


NLME_SYNC_RESPONSE.CMD_STATUS Enumeration

NLME_SYNC_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SYNC_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_SYNC_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_SYNC_RESPONSE.CMD_STATUS : char
J#
public enum NLME_SYNC_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_SYNC_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_ASSOCIATE_CONFIRMATION Class

NWK_ASSOCIATE_CONFIRMATION Class
See Also Example Members
[image]

This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_ASSOCIATE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_ASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_ASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_ASSOCIATE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_ASSOCIATE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_ASSOCIATE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_ASSOCIATE_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_ASSOCIATE_CONFIRMATION Members

NWK_ASSOCIATE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.

The following tables list the members exposed by NWK_ASSOCIATE_CONFIRMATION.

Public Constructors

Name | Description
NWK_ASSOCIATE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AllocatedAddress | Allocated Address
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_ASSOCIATE_CONFIRMATION | Overloaded.
Top

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_ASSOCIATE_CONFIRMATION Constructor

NWK_ASSOCIATE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_ASSOCIATE_CONFIRMATION | Constructor
Public method | NWK_ASSOCIATE_CONFIRMATION (NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, UInt16, Byte, NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, Byte) |

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_ASSOCIATE_CONFIRMATION Constructor ()

NWK_ASSOCIATE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_ASSOCIATE_CONFIRMATION()
C++
public:
NWK_ASSOCIATE_CONFIRMATION() sealed
J#
public NWK_ASSOCIATE_CONFIRMATION()
JScript
public function NWK_ASSOCIATE_CONFIRMATION()

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_ASSOCIATE_CONFIRMATION Constructor Overload List


NWK_ASSOCIATE_CONFIRMATION Constructor (NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, UInt16, Byte[], NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, Byte)

NWK_ASSOCIATE_CONFIRMATION Constructor (NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, UInt16, Byte[], NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, _
ByVal As UInt16, _
ByVal As Byte(), _
ByVal As NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, _
ByVal As NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_ASSOCIATE_CONFIRMATION(
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS ,
ushort ,
byte[] ,
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_ASSOCIATE_CONFIRMATION(
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS ,
unsigned short ,
array<char>^ ,
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_ASSOCIATE_CONFIRMATION(
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS ,
ushort ,
byte[] ,
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_ASSOCIATE_CONFIRMATION(
: NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS,
: UInt16,
: Byte[],
: NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL,
: NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_ASSOCIATE_CONFIRMATION Constructor Overload List


Fields

NWK_ASSOCIATE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | AllocatedAddress | Allocated Address
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


AllocatedAddress Field

NWK_ASSOCIATE_CONFIRMATION.AllocatedAddress Field
[image]

Allocated Address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AllocatedAddress As UInt16
C#
public ushort AllocatedAddress;
C++
public:
unsigned short AllocatedAddress sealed ;
J#
public ushort AllocatedAddress
JScript
public AllocatedAddress : UInt16;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_ASSOCIATE_CONFIRMATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE
C#
public NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_ASSOCIATE_CONFIRMATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_ASSOCIATE_CONFIRMATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_ASSOCIATE_CONFIRMATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL
C#
public NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_ASSOCIATE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS
C#
public NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration

NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE Enumeration

NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE As Byte
C#
public enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE : byte
C++
public enum class NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE : char
J#
public enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE byte
JScript
public enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL Enumeration

NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL As Byte
C#
public enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL : byte
C++
public enum class NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL : char
J#
public enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL byte
JScript
public enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


NWK_ASSOCIATE_INDICATION Class

NWK_ASSOCIATE_INDICATION Class
See Also Example Members
[image]

This function is used to indicate the reception of an association request command.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_ASSOCIATE_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_ASSOCIATE_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_ASSOCIATE_INDICATION : IINDICATION, INETWORK
J#
public class NWK_ASSOCIATE_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_ASSOCIATE_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_ASSOCIATE_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_ASSOCIATE_INDICATION Members
TI.ZPI1 Namespace


NWK_ASSOCIATE_INDICATION Members

NWK_ASSOCIATE_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to indicate the reception of an association request command.

The following tables list the members exposed by NWK_ASSOCIATE_INDICATION.

Public Constructors

Name | Description
NWK_ASSOCIATE_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInformation | capability of the associated device
Public field | DeviceAddresss | Address of the associated device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_ASSOCIATE_INDICATION | Overloaded.
Top

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


NWK_ASSOCIATE_INDICATION Constructor

NWK_ASSOCIATE_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_ASSOCIATE_INDICATION | Constructor
Public method | NWK_ASSOCIATE_INDICATION (UInt64, NWK_ASSOCIATE_INDICATION.CAPABILITIES, Byte, NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


NWK_ASSOCIATE_INDICATION Constructor ()

NWK_ASSOCIATE_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_ASSOCIATE_INDICATION()
C++
public:
NWK_ASSOCIATE_INDICATION() sealed
J#
public NWK_ASSOCIATE_INDICATION()
JScript
public function NWK_ASSOCIATE_INDICATION()

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace
NWK_ASSOCIATE_INDICATION Constructor Overload List


NWK_ASSOCIATE_INDICATION Constructor (UInt64, NWK_ASSOCIATE_INDICATION.CAPABILITIES, Byte[], NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, Byte)

NWK_ASSOCIATE_INDICATION Constructor (UInt64, NWK_ASSOCIATE_INDICATION.CAPABILITIES, Byte[], NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NWK_ASSOCIATE_INDICATION.CAPABILITIES, _
ByVal As Byte(), _
ByVal As NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_ASSOCIATE_INDICATION(
ulong ,
NWK_ASSOCIATE_INDICATION.CAPABILITIES ,
byte[] ,
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_ASSOCIATE_INDICATION(
unsigned __int64 ,
NWK_ASSOCIATE_INDICATION.CAPABILITIES ,
array<char>^ ,
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_ASSOCIATE_INDICATION(
ulong ,
NWK_ASSOCIATE_INDICATION.CAPABILITIES ,
byte[] ,
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_ASSOCIATE_INDICATION(
: UInt64,
: NWK_ASSOCIATE_INDICATION.CAPABILITIES,
: Byte[],
: NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL,
: NWK_ASSOCIATE_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace
NWK_ASSOCIATE_INDICATION Constructor Overload List


Fields

NWK_ASSOCIATE_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInformation | capability of the associated device
Public field | DeviceAddresss | Address of the associated device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


CapabilityInformation Field

NWK_ASSOCIATE_INDICATION.CapabilityInformation Field
[image]

capability of the associated device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInformation As NWK_ASSOCIATE_INDICATION.CAPABILITIES
C#
public NWK_ASSOCIATE_INDICATION.CAPABILITIES CapabilityInformation;
C++
public:
NWK_ASSOCIATE_INDICATION.CAPABILITIES CapabilityInformation sealed ;
J#
public NWK_ASSOCIATE_INDICATION.CAPABILITIES CapabilityInformation
JScript
public CapabilityInformation : NWK_ASSOCIATE_INDICATION.CAPABILITIES;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


DeviceAddresss Field

NWK_ASSOCIATE_INDICATION.DeviceAddresss Field
[image]

Address of the associated device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddresss As UInt64
C#
public ulong DeviceAddresss;
C++
public:
unsigned __int64 DeviceAddresss sealed ;
J#
public ulong DeviceAddresss
JScript
public DeviceAddresss : UInt64;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_ASSOCIATE_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_ASSOCIATE_INDICATION.KEY_ID_MODE
C#
public NWK_ASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_ASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_ASSOCIATE_INDICATION.KEY_ID_MODE;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_ASSOCIATE_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_ASSOCIATE_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_ASSOCIATE_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL
C#
public NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


NWK_ASSOCIATE_INDICATION.CAPABILITIES Enumeration

NWK_ASSOCIATE_INDICATION.CAPABILITIES Enumeration
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NWK_ASSOCIATE_INDICATION.CAPABILITIES As
C#
[FlagsAttribute]
public enum NWK_ASSOCIATE_INDICATION.CAPABILITIES : ushort
C++
[FlagsAttribute]
public enum class NWK_ASSOCIATE_INDICATION.CAPABILITIES : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum NWK_ASSOCIATE_INDICATION.CAPABILITIES ushort
JScript
public enum NWK_ASSOCIATE_INDICATION.CAPABILITIES :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
MT_CAP_MAC | Capabilities bitfield | 1
MT_CAP_NWK | Capabilities bitfield | 2
MT_CAP_AF | Capabilities bitfield | 4
MT_CAP_ZDO | Capabilities bitfield | 8
MT_CAP_USER_TEST | Capabilities bitfield | 16
MT_CAP_SAPI | Capabilities bitfield | 32
MT_CAP_BOOTLOAD | Capabilities bitfield | 32768

See Also

TI.ZPI1 Namespace


NWK_ASSOCIATE_INDICATION.KEY_ID_MODE Enumeration

NWK_ASSOCIATE_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_ASSOCIATE_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration

NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION Class

NWK_BEACON_NOTIFY_INDICATION Class
See Also Example Members
[image]

This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_BEACON_NOTIFY_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_BEACON_NOTIFY_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_BEACON_NOTIFY_INDICATION : IINDICATION, INETWORK
J#
public class NWK_BEACON_NOTIFY_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_BEACON_NOTIFY_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_BEACON_NOTIFY_INDICATION Members
TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION Members

NWK_BEACON_NOTIFY_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.

The following tables list the members exposed by NWK_BEACON_NOTIFY_INDICATION.

Public Constructors

Name | Description
NWK_BEACON_NOTIFY_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AddressList | The list of device addresses for which the sender of the beacon has data
Public field | BSN | Beacon sequence number
Public field | CoordAddress | Address of the coordinator
Public field | CoordAddressMode | Coordinator Address Mode
Public field | CoordPanID | PAN ID of the coordinator
Public field | GTSPermit | TRUE if coordinator accepts GTS requests
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | The link quality of the received beacon
Public field | LogicalChannel | The logical channel of the network
Public field | PendingAddressSpec | The beacon pending address specification
Public field | SDU | Actual SDU data. Can be 0-32 bytes
Public field | SDULength | Length of the SDU data
Public field | SecurityFailure | Set to TRUE if there was an error in the security processing
Public field | SecurityLevel | Security Level of this data frame
Public field | SuperFrameSpec | The superframe specification of the network
Public field | TimeStamp | Time stamp when the beacon is received
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_BEACON_NOTIFY_INDICATION | Overloaded.
Top

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION Constructor

NWK_BEACON_NOTIFY_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_BEACON_NOTIFY_INDICATION | Constructor
Public method | NWK_BEACON_NOTIFY_INDICATION (Byte, UInt32, NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, UInt64, UInt16, UInt16, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE, Byte, Byte, Byte, Byte, Byte) |

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION Constructor ()

NWK_BEACON_NOTIFY_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_BEACON_NOTIFY_INDICATION()
C++
public:
NWK_BEACON_NOTIFY_INDICATION() sealed
J#
public NWK_BEACON_NOTIFY_INDICATION()
JScript
public function NWK_BEACON_NOTIFY_INDICATION()

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace
NWK_BEACON_NOTIFY_INDICATION Constructor Overload List


NWK_BEACON_NOTIFY_INDICATION Constructor (Byte, UInt32, NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, UInt64, UInt16, UInt16, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte[], NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, NWK_BEACON_NOTIFY_INDICATION.KEY_ID_

NWK_BEACON_NOTIFY_INDICATION Constructor (Byte, UInt32, NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, UInt64, UInt16, UInt16, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte[], NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE, Byte, Byte, Byte[], Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, _
ByVal As Byte, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, _
ByVal As Byte(), _
ByVal As NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public NWK_BEACON_NOTIFY_INDICATION(
byte ,
uint ,
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
ushort ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte[] ,
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL ,
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[] ,
byte ,
byte[]
)
C++
public:
NWK_BEACON_NOTIFY_INDICATION(
char ,
unsigned int ,
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
unsigned short ,
char ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
char ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
array<char>^ ,
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL ,
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE ,
char ,
char ,
array<char>^ ,
char ,
array<char>^
) sealed
J#
public NWK_BEACON_NOTIFY_INDICATION(
byte ,
uint ,
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
ushort ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte[] ,
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL ,
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[] ,
byte ,
byte[]
)
JScript
public function NWK_BEACON_NOTIFY_INDICATION(
: Byte,
: UInt32,
: NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE,
: UInt64,
: UInt16,
: UInt16,
: Byte,
: NWK_BEACON_NOTIFY_INDICATION.BOOLEAN,
: Byte,
: NWK_BEACON_NOTIFY_INDICATION.BOOLEAN,
: Byte[],
: NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL,
: NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[],
: Byte,
: Byte[]
)

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace
NWK_BEACON_NOTIFY_INDICATION Constructor Overload List


Fields

NWK_BEACON_NOTIFY_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | AddressList | The list of device addresses for which the sender of the beacon has data
Public field | BSN | Beacon sequence number
Public field | CoordAddress | Address of the coordinator
Public field | CoordAddressMode | Coordinator Address Mode
Public field | CoordPanID | PAN ID of the coordinator
Public field | GTSPermit | TRUE if coordinator accepts GTS requests
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | The link quality of the received beacon
Public field | LogicalChannel | The logical channel of the network
Public field | PendingAddressSpec | The beacon pending address specification
Public field | SDU | Actual SDU data. Can be 0-32 bytes
Public field | SDULength | Length of the SDU data
Public field | SecurityFailure | Set to TRUE if there was an error in the security processing
Public field | SecurityLevel | Security Level of this data frame
Public field | SuperFrameSpec | The superframe specification of the network
Public field | TimeStamp | Time stamp when the beacon is received
Top

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


AddressList Field

NWK_BEACON_NOTIFY_INDICATION.AddressList Field
[image]

The list of device addresses for which the sender of the beacon has data

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddressList As Byte()
C#
public byte[] AddressList;
C++
public:
array<char>^ AddressList sealed ;
J#
public byte[] AddressList
JScript
public AddressList : Byte[];

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


BSN Field

NWK_BEACON_NOTIFY_INDICATION.BSN Field
[image]

Beacon sequence number

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BSN As Byte
C#
public byte BSN;
C++
public:
char BSN sealed ;
J#
public byte BSN
JScript
public BSN : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


CoordAddress Field

NWK_BEACON_NOTIFY_INDICATION.CoordAddress Field
[image]

Address of the coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddress As UInt64
C#
public ulong CoordAddress;
C++
public:
unsigned __int64 CoordAddress sealed ;
J#
public ulong CoordAddress
JScript
public CoordAddress : UInt64;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


CoordAddressMode Field

NWK_BEACON_NOTIFY_INDICATION.CoordAddressMode Field
[image]

Coordinator Address Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddressMode As NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE
C#
public NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE CoordAddressMode;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE CoordAddressMode sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE CoordAddressMode
JScript
public CoordAddressMode : NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


CoordPanID Field

NWK_BEACON_NOTIFY_INDICATION.CoordPanID Field
[image]

PAN ID of the coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordPanID As UInt16
C#
public ushort CoordPanID;
C++
public:
unsigned short CoordPanID sealed ;
J#
public ushort CoordPanID
JScript
public CoordPanID : UInt16;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


GTSPermit Field

NWK_BEACON_NOTIFY_INDICATION.GTSPermit Field
[image]

TRUE if coordinator accepts GTS requests

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public GTSPermit As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN
C#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN GTSPermit;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN GTSPermit sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN GTSPermit
JScript
public GTSPermit : NWK_BEACON_NOTIFY_INDICATION.BOOLEAN;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_BEACON_NOTIFY_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE
C#
public NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_BEACON_NOTIFY_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_BEACON_NOTIFY_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


LinkQuality Field

NWK_BEACON_NOTIFY_INDICATION.LinkQuality Field
[image]

The link quality of the received beacon

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


LogicalChannel Field

NWK_BEACON_NOTIFY_INDICATION.LogicalChannel Field
[image]

The logical channel of the network

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


PendingAddressSpec Field

NWK_BEACON_NOTIFY_INDICATION.PendingAddressSpec Field
[image]

The beacon pending address specification

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PendingAddressSpec As Byte
C#
public byte PendingAddressSpec;
C++
public:
char PendingAddressSpec sealed ;
J#
public byte PendingAddressSpec
JScript
public PendingAddressSpec : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


SDU Field

NWK_BEACON_NOTIFY_INDICATION.SDU Field
[image]

Actual SDU data. Can be 0-32 bytes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SDU As Byte()
C#
public byte[] SDU;
C++
public:
array<char>^ SDU sealed ;
J#
public byte[] SDU
JScript
public SDU : Byte[];

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


SDULength Field

NWK_BEACON_NOTIFY_INDICATION.SDULength Field
[image]

Length of the SDU data

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SDULength As Byte
C#
public byte SDULength;
C++
public:
char SDULength sealed ;
J#
public byte SDULength
JScript
public SDULength : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


SecurityFailure Field

NWK_BEACON_NOTIFY_INDICATION.SecurityFailure Field
[image]

Set to TRUE if there was an error in the security processing

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityFailure As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN
C#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN SecurityFailure;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN SecurityFailure sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN SecurityFailure
JScript
public SecurityFailure : NWK_BEACON_NOTIFY_INDICATION.BOOLEAN;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_BEACON_NOTIFY_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL
C#
public NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


SuperFrameSpec Field

NWK_BEACON_NOTIFY_INDICATION.SuperFrameSpec Field
[image]

The superframe specification of the network

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameSpec As UInt16
C#
public ushort SuperFrameSpec;
C++
public:
unsigned short SuperFrameSpec sealed ;
J#
public ushort SuperFrameSpec
JScript
public SuperFrameSpec : UInt16;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


TimeStamp Field

NWK_BEACON_NOTIFY_INDICATION.TimeStamp Field
[image]

Time stamp when the beacon is received

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp As UInt32
C#
public uint TimeStamp;
C++
public:
unsigned int TimeStamp sealed ;
J#
public uint TimeStamp
JScript
public TimeStamp : UInt32;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE Enumeration

NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION.BOOLEAN Enumeration

NWK_BEACON_NOTIFY_INDICATION.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.BOOLEAN : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE Enumeration

NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL Enumeration

NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION Class

NWK_COMM_STATUS_INDICATION Class
See Also Example Members
[image]

This function reports a comm status error

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_COMM_STATUS_INDICATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_COMM_STATUS_INDICATION : ICONFIRMATION, INETWORK
C++
ref class NWK_COMM_STATUS_INDICATION : ICONFIRMATION, INETWORK
J#
public class NWK_COMM_STATUS_INDICATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_COMM_STATUS_INDICATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_COMM_STATUS_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_COMM_STATUS_INDICATION Members
TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION Members

NWK_COMM_STATUS_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports a comm status error

The following tables list the members exposed by NWK_COMM_STATUS_INDICATION.

Public Constructors

Name | Description
NWK_COMM_STATUS_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | PanID | Pan Id of the Remote device
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Indicates the format of the source address.
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_COMM_STATUS_INDICATION | Overloaded.
Top

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION Constructor

NWK_COMM_STATUS_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_COMM_STATUS_INDICATION | Constructor
Public method | NWK_COMM_STATUS_INDICATION (NWK_COMM_STATUS_INDICATION.CMD_STATUS, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, UInt16, Byte, Byte, NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION Constructor ()

NWK_COMM_STATUS_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_COMM_STATUS_INDICATION()
C++
public:
NWK_COMM_STATUS_INDICATION() sealed
J#
public NWK_COMM_STATUS_INDICATION()
JScript
public function NWK_COMM_STATUS_INDICATION()

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace
NWK_COMM_STATUS_INDICATION Constructor Overload List


NWK_COMM_STATUS_INDICATION Constructor (NWK_COMM_STATUS_INDICATION.CMD_STATUS, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, UInt16, Byte, Byte[], NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, Byte)

NWK_COMM_STATUS_INDICATION Constructor (NWK_COMM_STATUS_INDICATION.CMD_STATUS, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, UInt16, Byte, Byte[], NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_COMM_STATUS_INDICATION.CMD_STATUS, _
ByVal As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_COMM_STATUS_INDICATION(
NWK_COMM_STATUS_INDICATION.CMD_STATUS ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
byte ,
byte[] ,
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL ,
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_COMM_STATUS_INDICATION(
NWK_COMM_STATUS_INDICATION.CMD_STATUS ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
char ,
array<char>^ ,
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL ,
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_COMM_STATUS_INDICATION(
NWK_COMM_STATUS_INDICATION.CMD_STATUS ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
byte ,
byte[] ,
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL ,
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_COMM_STATUS_INDICATION(
: NWK_COMM_STATUS_INDICATION.CMD_STATUS,
: NWK_COMM_STATUS_INDICATION.ADDRESS_MODE,
: UInt64,
: NWK_COMM_STATUS_INDICATION.ADDRESS_MODE,
: UInt64,
: UInt16,
: Byte,
: Byte[],
: NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL,
: NWK_COMM_STATUS_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace
NWK_COMM_STATUS_INDICATION Constructor Overload List


Fields

NWK_COMM_STATUS_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | PanID | Pan Id of the Remote device
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Indicates the format of the source address.
Public field | Status | Status
Top

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


DestAddress Field

NWK_COMM_STATUS_INDICATION.DestAddress Field
[image]

Address of the Remote device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


DestAddressMode Field

NWK_COMM_STATUS_INDICATION.DestAddressMode Field
[image]

Remote device Address Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressMode As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE
C#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE DestAddressMode;
C++
public:
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE DestAddressMode sealed ;
J#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE DestAddressMode
JScript
public DestAddressMode : NWK_COMM_STATUS_INDICATION.ADDRESS_MODE;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_COMM_STATUS_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_COMM_STATUS_INDICATION.KEY_ID_MODE
C#
public NWK_COMM_STATUS_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_COMM_STATUS_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_COMM_STATUS_INDICATION.KEY_ID_MODE;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_COMM_STATUS_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_COMM_STATUS_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


PanID Field

NWK_COMM_STATUS_INDICATION.PanID Field
[image]

Pan Id of the Remote device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


Reason Field

NWK_COMM_STATUS_INDICATION.Reason Field
[image]

Synchronization lost Reason

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reason As Byte
C#
public byte Reason;
C++
public:
char Reason sealed ;
J#
public byte Reason
JScript
public Reason : Byte;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_COMM_STATUS_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL
C#
public NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


SrcAddress Field

NWK_COMM_STATUS_INDICATION.SrcAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


SrcAddressMode Field

NWK_COMM_STATUS_INDICATION.SrcAddressMode Field
[image]

Indicates the format of the source address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddressMode As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE
C#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE SrcAddressMode;
C++
public:
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE SrcAddressMode sealed ;
J#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE SrcAddressMode
JScript
public SrcAddressMode : NWK_COMM_STATUS_INDICATION.ADDRESS_MODE;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


Status Field

NWK_COMM_STATUS_INDICATION.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_COMM_STATUS_INDICATION.CMD_STATUS
C#
public NWK_COMM_STATUS_INDICATION.CMD_STATUS Status;
C++
public:
NWK_COMM_STATUS_INDICATION.CMD_STATUS Status sealed ;
J#
public NWK_COMM_STATUS_INDICATION.CMD_STATUS Status
JScript
public Status : NWK_COMM_STATUS_INDICATION.CMD_STATUS;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION.ADDRESS_MODE Enumeration

NWK_COMM_STATUS_INDICATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.ADDRESS_MODE : char
J#
public enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE byte
JScript
public enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION.CMD_STATUS Enumeration

NWK_COMM_STATUS_INDICATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.CMD_STATUS As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.CMD_STATUS : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.CMD_STATUS : char
J#
public enum NWK_COMM_STATUS_INDICATION.CMD_STATUS byte
JScript
public enum NWK_COMM_STATUS_INDICATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION.KEY_ID_MODE Enumeration

NWK_COMM_STATUS_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL Enumeration

NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


NWK_DATA_CONFIRMATION Class

NWK_DATA_CONFIRMATION Class
See Also Example Members
[image]

This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DATA_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_DATA_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_DATA_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_DATA_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DATA_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_DATA_CONFIRMATION Members

NWK_DATA_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.

The following tables list the members exposed by NWK_DATA_CONFIRMATION.

Public Constructors

Name | Description
NWK_DATA_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MsduHandle | Handle of the frame
Public field | Status | Status of the frame
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DATA_CONFIRMATION | Overloaded.
Top

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_DATA_CONFIRMATION Constructor

NWK_DATA_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_DATA_CONFIRMATION | Constructor
Public method | NWK_DATA_CONFIRMATION (NWK_DATA_CONFIRMATION.CMD_STATUS, Byte, UInt32, UInt16) |

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_DATA_CONFIRMATION Constructor ()

NWK_DATA_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DATA_CONFIRMATION()
C++
public:
NWK_DATA_CONFIRMATION() sealed
J#
public NWK_DATA_CONFIRMATION()
JScript
public function NWK_DATA_CONFIRMATION()

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_DATA_CONFIRMATION Constructor Overload List


NWK_DATA_CONFIRMATION Constructor (NWK_DATA_CONFIRMATION.CMD_STATUS, Byte, UInt32, UInt16)

NWK_DATA_CONFIRMATION Constructor (NWK_DATA_CONFIRMATION.CMD_STATUS, Byte, UInt32, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_DATA_CONFIRMATION.CMD_STATUS, _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As UInt16 _
)
C#
public NWK_DATA_CONFIRMATION(
NWK_DATA_CONFIRMATION.CMD_STATUS ,
byte ,
uint ,
ushort
)
C++
public:
NWK_DATA_CONFIRMATION(
NWK_DATA_CONFIRMATION.CMD_STATUS ,
char ,
unsigned int ,
unsigned short
) sealed
J#
public NWK_DATA_CONFIRMATION(
NWK_DATA_CONFIRMATION.CMD_STATUS ,
byte ,
uint ,
ushort
)
JScript
public function NWK_DATA_CONFIRMATION(
: NWK_DATA_CONFIRMATION.CMD_STATUS,
: Byte,
: UInt32,
: UInt16
)

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_DATA_CONFIRMATION Constructor Overload List


Fields

NWK_DATA_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | MsduHandle | Handle of the frame
Public field | Status | Status of the frame
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


MsduHandle Field

NWK_DATA_CONFIRMATION.MsduHandle Field
[image]

Handle of the frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsduHandle As Byte
C#
public byte MsduHandle;
C++
public:
char MsduHandle sealed ;
J#
public byte MsduHandle
JScript
public MsduHandle : Byte;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_DATA_CONFIRMATION.Status Field
[image]

Status of the frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_DATA_CONFIRMATION.CMD_STATUS
C#
public NWK_DATA_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_DATA_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_DATA_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_DATA_CONFIRMATION.CMD_STATUS;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


TimeStamp Field

NWK_DATA_CONFIRMATION.TimeStamp Field
[image]

The time, in backoffs, at which the data were received

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp As UInt32
C#
public uint TimeStamp;
C++
public:
unsigned int TimeStamp sealed ;
J#
public uint TimeStamp
JScript
public TimeStamp : UInt32;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


TimeStamp2 Field

NWK_DATA_CONFIRMATION.TimeStamp2 Field
[image]

The time, in internal MAC timer units, at which the data were recieved

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp2 As UInt16
C#
public ushort TimeStamp2;
C++
public:
unsigned short TimeStamp2 sealed ;
J#
public ushort TimeStamp2
JScript
public TimeStamp2 : UInt16;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_DATA_CONFIRMATION.CMD_STATUS Enumeration

NWK_DATA_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_DATA_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_DATA_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_DATA_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_DATA_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_DATA_INDICATION Class

NWK_DATA_INDICATION Class
See Also Example Members
[image]

This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DATA_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_DATA_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_DATA_INDICATION : IINDICATION, INETWORK
J#
public class NWK_DATA_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_DATA_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_DATA_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DATA_INDICATION Members
TI.ZPI1 Namespace


NWK_DATA_INDICATION Members

NWK_DATA_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.

The following tables list the members exposed by NWK_DATA_INDICATION.

Public Constructors

Name | Description
NWK_DATA_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | DestPanID | Pan Id of the Remote device
Public field | Dsn | Dsn
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Lqi | Raw LQI of the received data frame
Public field | mpduLinkQuality | Link Quality
Public field | MSDU | The actual data
Public field | MSDULength | Length of the data
Public field | Rssi | Raw RSSI of the received data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Initiating device Address Mode
Public field | SrcPanID | Pan Id of the initiating device
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DATA_INDICATION | Overloaded.
Top

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


NWK_DATA_INDICATION Constructor

NWK_DATA_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_DATA_INDICATION | Constructor
Public method | NWK_DATA_INDICATION (NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, NWK_DATA_INDICATION.SECURITY_LEVEL, NWK_DATA_INDICATION.KEY_ID_MODE, Byte, Byte, Byte) |

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


NWK_DATA_INDICATION Constructor ()

NWK_DATA_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DATA_INDICATION()
C++
public:
NWK_DATA_INDICATION() sealed
J#
public NWK_DATA_INDICATION()
JScript
public function NWK_DATA_INDICATION()

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace
NWK_DATA_INDICATION Constructor Overload List


NWK_DATA_INDICATION Constructor (NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], NWK_DATA_INDICATION.SECURITY_LEVEL, NWK_DATA_INDICATION.KEY_ID_MODE, Byte, Byte, Byte[])

NWK_DATA_INDICATION Constructor (NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], NWK_DATA_INDICATION.SECURITY_LEVEL, NWK_DATA_INDICATION.KEY_ID_MODE, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_DATA_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As NWK_DATA_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt32, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As NWK_DATA_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_DATA_INDICATION.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public NWK_DATA_INDICATION(
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
uint ,
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
NWK_DATA_INDICATION.SECURITY_LEVEL ,
NWK_DATA_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
C++
public:
NWK_DATA_INDICATION(
NWK_DATA_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
NWK_DATA_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned int ,
unsigned short ,
unsigned short ,
unsigned short ,
char ,
char ,
char ,
char ,
array<char>^ ,
NWK_DATA_INDICATION.SECURITY_LEVEL ,
NWK_DATA_INDICATION.KEY_ID_MODE ,
char ,
char ,
array<char>^
) sealed
J#
public NWK_DATA_INDICATION(
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
uint ,
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
NWK_DATA_INDICATION.SECURITY_LEVEL ,
NWK_DATA_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
JScript
public function NWK_DATA_INDICATION(
: NWK_DATA_INDICATION.ADDRESS_MODE,
: UInt64,
: NWK_DATA_INDICATION.ADDRESS_MODE,
: UInt64,
: UInt32,
: UInt16,
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[],
: NWK_DATA_INDICATION.SECURITY_LEVEL,
: NWK_DATA_INDICATION.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[]
)

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace
NWK_DATA_INDICATION Constructor Overload List


Fields

NWK_DATA_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | DestPanID | Pan Id of the Remote device
Public field | Dsn | Dsn
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Lqi | Raw LQI of the received data frame
Public field | mpduLinkQuality | Link Quality
Public field | MSDU | The actual data
Public field | MSDULength | Length of the data
Public field | Rssi | Raw RSSI of the received data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Initiating device Address Mode
Public field | SrcPanID | Pan Id of the initiating device
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


DestAddress Field

NWK_DATA_INDICATION.DestAddress Field
[image]

Address of the Remote device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


DestAddressMode Field

NWK_DATA_INDICATION.DestAddressMode Field
[image]

Remote device Address Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressMode As NWK_DATA_INDICATION.ADDRESS_MODE
C#
public NWK_DATA_INDICATION.ADDRESS_MODE DestAddressMode;
C++
public:
NWK_DATA_INDICATION.ADDRESS_MODE DestAddressMode sealed ;
J#
public NWK_DATA_INDICATION.ADDRESS_MODE DestAddressMode
JScript
public DestAddressMode : NWK_DATA_INDICATION.ADDRESS_MODE;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


DestPanID Field

NWK_DATA_INDICATION.DestPanID Field
[image]

Pan Id of the Remote device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestPanID As UInt16
C#
public ushort DestPanID;
C++
public:
unsigned short DestPanID sealed ;
J#
public ushort DestPanID
JScript
public DestPanID : UInt16;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


Dsn Field

NWK_DATA_INDICATION.Dsn Field
[image]

Dsn

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Dsn As Byte
C#
public byte Dsn;
C++
public:
char Dsn sealed ;
J#
public byte Dsn
JScript
public Dsn : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_DATA_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_DATA_INDICATION.KEY_ID_MODE
C#
public NWK_DATA_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_DATA_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_DATA_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_DATA_INDICATION.KEY_ID_MODE;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_DATA_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_DATA_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


Lqi Field

NWK_DATA_INDICATION.Lqi Field
[image]

Raw LQI of the received data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Lqi As Byte
C#
public byte Lqi;
C++
public:
char Lqi sealed ;
J#
public byte Lqi
JScript
public Lqi : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


mpduLinkQuality Field

NWK_DATA_INDICATION.mpduLinkQuality Field
[image]

Link Quality

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public mpduLinkQuality As Byte
C#
public byte mpduLinkQuality;
C++
public:
char mpduLinkQuality sealed ;
J#
public byte mpduLinkQuality
JScript
public mpduLinkQuality : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


MSDU Field

NWK_DATA_INDICATION.MSDU Field
[image]

The actual data

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDU As Byte()
C#
public byte[] MSDU;
C++
public:
array<char>^ MSDU sealed ;
J#
public byte[] MSDU
JScript
public MSDU : Byte[];

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


MSDULength Field

NWK_DATA_INDICATION.MSDULength Field
[image]

Length of the data

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDULength As Byte
C#
public byte MSDULength;
C++
public:
char MSDULength sealed ;
J#
public byte MSDULength
JScript
public MSDULength : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


Rssi Field

NWK_DATA_INDICATION.Rssi Field
[image]

Raw RSSI of the received data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Rssi As Byte
C#
public byte Rssi;
C++
public:
char Rssi sealed ;
J#
public byte Rssi
JScript
public Rssi : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_DATA_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_DATA_INDICATION.SECURITY_LEVEL
C#
public NWK_DATA_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_DATA_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_DATA_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_DATA_INDICATION.SECURITY_LEVEL;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


SrcAddress Field

NWK_DATA_INDICATION.SrcAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


SrcAddressMode Field

NWK_DATA_INDICATION.SrcAddressMode Field
[image]

Initiating device Address Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddressMode As NWK_DATA_INDICATION.ADDRESS_MODE
C#
public NWK_DATA_INDICATION.ADDRESS_MODE SrcAddressMode;
C++
public:
NWK_DATA_INDICATION.ADDRESS_MODE SrcAddressMode sealed ;
J#
public NWK_DATA_INDICATION.ADDRESS_MODE SrcAddressMode
JScript
public SrcAddressMode : NWK_DATA_INDICATION.ADDRESS_MODE;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


SrcPanID Field

NWK_DATA_INDICATION.SrcPanID Field
[image]

Pan Id of the initiating device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcPanID As UInt16
C#
public ushort SrcPanID;
C++
public:
unsigned short SrcPanID sealed ;
J#
public ushort SrcPanID
JScript
public SrcPanID : UInt16;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


TimeStamp Field

NWK_DATA_INDICATION.TimeStamp Field
[image]

The time, in backoffs, at which the data were received

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp As UInt32
C#
public uint TimeStamp;
C++
public:
unsigned int TimeStamp sealed ;
J#
public uint TimeStamp
JScript
public TimeStamp : UInt32;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


TimeStamp2 Field

NWK_DATA_INDICATION.TimeStamp2 Field
[image]

The time, in internal MAC timer units, at which the data were recieved

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp2 As UInt16
C#
public ushort TimeStamp2;
C++
public:
unsigned short TimeStamp2 sealed ;
J#
public ushort TimeStamp2
JScript
public TimeStamp2 : UInt16;

See Also

NWK_DATA_INDICATION Class
TI.ZPI1 Namespace


NWK_DATA_INDICATION.ADDRESS_MODE Enumeration

NWK_DATA_INDICATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_INDICATION.ADDRESS_MODE As Byte
C#
public enum NWK_DATA_INDICATION.ADDRESS_MODE : byte
C++
public enum class NWK_DATA_INDICATION.ADDRESS_MODE : char
J#
public enum NWK_DATA_INDICATION.ADDRESS_MODE byte
JScript
public enum NWK_DATA_INDICATION.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


NWK_DATA_INDICATION.KEY_ID_MODE Enumeration

NWK_DATA_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_DATA_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_DATA_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_DATA_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_DATA_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_DATA_INDICATION.SECURITY_LEVEL Enumeration

NWK_DATA_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_DATA_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_DATA_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_DATA_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_DATA_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


NWK_DISASSOCIATE_CONFIRMATION Class

NWK_DISASSOCIATE_CONFIRMATION Class
See Also Example Members
[image]

This function is sent as the result of a disassociation request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DISASSOCIATE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_DISASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_DISASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_DISASSOCIATE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_DISASSOCIATE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_DISASSOCIATE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DISASSOCIATE_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_DISASSOCIATE_CONFIRMATION Members

NWK_DISASSOCIATE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is sent as the result of a disassociation request.

The following tables list the members exposed by NWK_DISASSOCIATE_CONFIRMATION.

Public Constructors

Name | Description
NWK_DISASSOCIATE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DeviceAddressMode | Specifies the format of the device address.
Public field | PanID | PAN ID of the remote device
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DISASSOCIATE_CONFIRMATION | Overloaded.
Top

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_DISASSOCIATE_CONFIRMATION Constructor

NWK_DISASSOCIATE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_DISASSOCIATE_CONFIRMATION | Constructor
Public method | NWK_DISASSOCIATE_CONFIRMATION (NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, UInt64, UInt16) |

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_DISASSOCIATE_CONFIRMATION Constructor ()

NWK_DISASSOCIATE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DISASSOCIATE_CONFIRMATION()
C++
public:
NWK_DISASSOCIATE_CONFIRMATION() sealed
J#
public NWK_DISASSOCIATE_CONFIRMATION()
JScript
public function NWK_DISASSOCIATE_CONFIRMATION()

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_DISASSOCIATE_CONFIRMATION Constructor Overload List


NWK_DISASSOCIATE_CONFIRMATION Constructor (NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, UInt64, UInt16)

NWK_DISASSOCIATE_CONFIRMATION Constructor (NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, UInt64, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, _
ByVal As NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16 _
)
C#
public NWK_DISASSOCIATE_CONFIRMATION(
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS ,
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE ,
ulong ,
ushort
)
C++
public:
NWK_DISASSOCIATE_CONFIRMATION(
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS ,
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short
) sealed
J#
public NWK_DISASSOCIATE_CONFIRMATION(
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS ,
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE ,
ulong ,
ushort
)
JScript
public function NWK_DISASSOCIATE_CONFIRMATION(
: NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS,
: NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE,
: UInt64,
: UInt16
)

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_DISASSOCIATE_CONFIRMATION Constructor Overload List


Fields

NWK_DISASSOCIATE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DeviceAddressMode | Specifies the format of the device address.
Public field | PanID | PAN ID of the remote device
Public field | Status | Status
Top

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


DeviceAddress Field

NWK_DISASSOCIATE_CONFIRMATION.DeviceAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


DeviceAddressMode Field

NWK_DISASSOCIATE_CONFIRMATION.DeviceAddressMode Field
[image]

Specifies the format of the device address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddressMode As NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE
C#
public NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE DeviceAddressMode;
C++
public:
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE DeviceAddressMode sealed ;
J#
public NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE DeviceAddressMode
JScript
public DeviceAddressMode : NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


PanID Field

NWK_DISASSOCIATE_CONFIRMATION.PanID Field
[image]

PAN ID of the remote device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_DISASSOCIATE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS
C#
public NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE Enumeration

NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE As Byte
C#
public enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE : byte
C++
public enum class NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE : char
J#
public enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE byte
JScript
public enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration

NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_DISASSOCIATE_INDICATION Class

NWK_DISASSOCIATE_INDICATION Class
See Also Example Members
[image]

This function is used to indicate the reception of a disassociation notification command.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DISASSOCIATE_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_DISASSOCIATE_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_DISASSOCIATE_INDICATION : IINDICATION, INETWORK
J#
public class NWK_DISASSOCIATE_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_DISASSOCIATE_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_DISASSOCIATE_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DISASSOCIATE_INDICATION Members
TI.ZPI1 Namespace


NWK_DISASSOCIATE_INDICATION Members

NWK_DISASSOCIATE_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to indicate the reception of a disassociation notification command.

The following tables list the members exposed by NWK_DISASSOCIATE_INDICATION.

Public Constructors

Name | Description
NWK_DISASSOCIATE_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DisassociateReason | Reason of the disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DISASSOCIATE_INDICATION | Overloaded.
Top

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


NWK_DISASSOCIATE_INDICATION Constructor

NWK_DISASSOCIATE_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_DISASSOCIATE_INDICATION | Constructor
Public method | NWK_DISASSOCIATE_INDICATION (UInt64, NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, Byte, NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


NWK_DISASSOCIATE_INDICATION Constructor ()

NWK_DISASSOCIATE_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DISASSOCIATE_INDICATION()
C++
public:
NWK_DISASSOCIATE_INDICATION() sealed
J#
public NWK_DISASSOCIATE_INDICATION()
JScript
public function NWK_DISASSOCIATE_INDICATION()

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace
NWK_DISASSOCIATE_INDICATION Constructor Overload List


NWK_DISASSOCIATE_INDICATION Constructor (UInt64, NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, Byte[], NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, Byte)

NWK_DISASSOCIATE_INDICATION Constructor (UInt64, NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, Byte[], NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, _
ByVal As Byte(), _
ByVal As NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_DISASSOCIATE_INDICATION(
ulong ,
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON ,
byte[] ,
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_DISASSOCIATE_INDICATION(
unsigned __int64 ,
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON ,
array<char>^ ,
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_DISASSOCIATE_INDICATION(
ulong ,
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON ,
byte[] ,
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_DISASSOCIATE_INDICATION(
: UInt64,
: NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON,
: Byte[],
: NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL,
: NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace
NWK_DISASSOCIATE_INDICATION Constructor Overload List


Fields

NWK_DISASSOCIATE_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DisassociateReason | Reason of the disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


DeviceAddress Field

NWK_DISASSOCIATE_INDICATION.DeviceAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


DisassociateReason Field

NWK_DISASSOCIATE_INDICATION.DisassociateReason Field
[image]

Reason of the disassociation

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DisassociateReason As NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON
C#
public NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON DisassociateReason;
C++
public:
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON DisassociateReason sealed ;
J#
public NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON DisassociateReason
JScript
public DisassociateReason : NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_DISASSOCIATE_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE
C#
public NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_DISASSOCIATE_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_DISASSOCIATE_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_DISASSOCIATE_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL
C#
public NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI1 Namespace


NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON Enumeration

NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON Enumeration
[image]

Valid disassociation reason codes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON As Byte
C#
public enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON : byte
C++
public enum class NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON : char
J#
public enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON byte
JScript
public enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON :

Members

Member Name | Description
RESERVED | Valid disassociation reason codes
COOR_WISHES_DEV_LEAVE | Valid disassociation reason codes
DEV_WISHES_LEAVE | Valid disassociation reason codes

See Also

TI.ZPI1 Namespace


NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE Enumeration

NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration

NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


NWK_ORPHAN_INDICATION Class

NWK_ORPHAN_INDICATION Class
See Also Example Members
[image]

This function allows the MLME to notify the next higher layer of an orphaned device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_ORPHAN_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_ORPHAN_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_ORPHAN_INDICATION : IINDICATION, INETWORK
J#
public class NWK_ORPHAN_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_ORPHAN_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_ORPHAN_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_ORPHAN_INDICATION Members
TI.ZPI1 Namespace


NWK_ORPHAN_INDICATION Members

NWK_ORPHAN_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function allows the MLME to notify the next higher layer of an orphaned device

The following tables list the members exposed by NWK_ORPHAN_INDICATION.

Public Constructors

Name | Description
NWK_ORPHAN_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | OrphanAddress | Orphan Address
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_ORPHAN_INDICATION | Overloaded.
Top

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


NWK_ORPHAN_INDICATION Constructor

NWK_ORPHAN_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_ORPHAN_INDICATION | Constructor
Public method | NWK_ORPHAN_INDICATION (UInt64, Byte, NWK_ORPHAN_INDICATION.SECURITY_LEVEL, NWK_ORPHAN_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


NWK_ORPHAN_INDICATION Constructor ()

NWK_ORPHAN_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_ORPHAN_INDICATION()
C++
public:
NWK_ORPHAN_INDICATION() sealed
J#
public NWK_ORPHAN_INDICATION()
JScript
public function NWK_ORPHAN_INDICATION()

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace
NWK_ORPHAN_INDICATION Constructor Overload List


NWK_ORPHAN_INDICATION Constructor (UInt64, Byte[], NWK_ORPHAN_INDICATION.SECURITY_LEVEL, NWK_ORPHAN_INDICATION.KEY_ID_MODE, Byte)

NWK_ORPHAN_INDICATION Constructor (UInt64, Byte[], NWK_ORPHAN_INDICATION.SECURITY_LEVEL, NWK_ORPHAN_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte(), _
ByVal As NWK_ORPHAN_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_ORPHAN_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_ORPHAN_INDICATION(
ulong ,
byte[] ,
NWK_ORPHAN_INDICATION.SECURITY_LEVEL ,
NWK_ORPHAN_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_ORPHAN_INDICATION(
unsigned __int64 ,
array<char>^ ,
NWK_ORPHAN_INDICATION.SECURITY_LEVEL ,
NWK_ORPHAN_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_ORPHAN_INDICATION(
ulong ,
byte[] ,
NWK_ORPHAN_INDICATION.SECURITY_LEVEL ,
NWK_ORPHAN_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_ORPHAN_INDICATION(
: UInt64,
: Byte[],
: NWK_ORPHAN_INDICATION.SECURITY_LEVEL,
: NWK_ORPHAN_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace
NWK_ORPHAN_INDICATION Constructor Overload List


Fields

NWK_ORPHAN_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | OrphanAddress | Orphan Address
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_ORPHAN_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_ORPHAN_INDICATION.KEY_ID_MODE
C#
public NWK_ORPHAN_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_ORPHAN_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_ORPHAN_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_ORPHAN_INDICATION.KEY_ID_MODE;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_ORPHAN_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_ORPHAN_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


OrphanAddress Field

NWK_ORPHAN_INDICATION.OrphanAddress Field
[image]

Orphan Address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OrphanAddress As UInt64
C#
public ulong OrphanAddress;
C++
public:
unsigned __int64 OrphanAddress sealed ;
J#
public ulong OrphanAddress
JScript
public OrphanAddress : UInt64;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_ORPHAN_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_ORPHAN_INDICATION.SECURITY_LEVEL
C#
public NWK_ORPHAN_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_ORPHAN_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_ORPHAN_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_ORPHAN_INDICATION.SECURITY_LEVEL;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI1 Namespace


NWK_ORPHAN_INDICATION.KEY_ID_MODE Enumeration

NWK_ORPHAN_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ORPHAN_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_ORPHAN_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_ORPHAN_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_ORPHAN_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_ORPHAN_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_ORPHAN_INDICATION.SECURITY_LEVEL Enumeration

NWK_ORPHAN_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_ORPHAN_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


NWK_POLL_CONFIRMATION Class

NWK_POLL_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of a polling attempt.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_POLL_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_POLL_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_POLL_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_POLL_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_POLL_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_POLL_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_POLL_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_POLL_CONFIRMATION Members

NWK_POLL_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of a polling attempt.

The following tables list the members exposed by NWK_POLL_CONFIRMATION.

Public Constructors

Name | Description
NWK_POLL_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_POLL_CONFIRMATION | Overloaded.
Top

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_POLL_CONFIRMATION Constructor

NWK_POLL_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_POLL_CONFIRMATION | Constructor
Public method | NWK_POLL_CONFIRMATION (NWK_POLL_CONFIRMATION.CMD_STATUS) |

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_POLL_CONFIRMATION Constructor ()

NWK_POLL_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_POLL_CONFIRMATION()
C++
public:
NWK_POLL_CONFIRMATION() sealed
J#
public NWK_POLL_CONFIRMATION()
JScript
public function NWK_POLL_CONFIRMATION()

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_POLL_CONFIRMATION Constructor Overload List


NWK_POLL_CONFIRMATION Constructor (NWK_POLL_CONFIRMATION.CMD_STATUS)

NWK_POLL_CONFIRMATION Constructor (NWK_POLL_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_POLL_CONFIRMATION.CMD_STATUS _
)
C#
public NWK_POLL_CONFIRMATION(
NWK_POLL_CONFIRMATION.CMD_STATUS
)
C++
public:
NWK_POLL_CONFIRMATION(
NWK_POLL_CONFIRMATION.CMD_STATUS
) sealed
J#
public NWK_POLL_CONFIRMATION(
NWK_POLL_CONFIRMATION.CMD_STATUS
)
JScript
public function NWK_POLL_CONFIRMATION(
: NWK_POLL_CONFIRMATION.CMD_STATUS
)

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_POLL_CONFIRMATION Constructor Overload List


Fields

NWK_POLL_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_POLL_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_POLL_CONFIRMATION.CMD_STATUS
C#
public NWK_POLL_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_POLL_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_POLL_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_POLL_CONFIRMATION.CMD_STATUS;

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_POLL_CONFIRMATION.CMD_STATUS Enumeration

NWK_POLL_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_POLL_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_POLL_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_POLL_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_POLL_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_POLL_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_PURGE_CONFIRMATION Class

NWK_PURGE_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of a purge attempt.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_PURGE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_PURGE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_PURGE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_PURGE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_PURGE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_PURGE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_PURGE_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_PURGE_CONFIRMATION Members

NWK_PURGE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of a purge attempt.

The following tables list the members exposed by NWK_PURGE_CONFIRMATION.

Public Constructors

Name | Description
NWK_PURGE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MsduHandle | Application-defined handle value associated with the data request.
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_PURGE_CONFIRMATION | Overloaded.
Top

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_PURGE_CONFIRMATION Constructor

NWK_PURGE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_PURGE_CONFIRMATION | Constructor
Public method | NWK_PURGE_CONFIRMATION (NWK_PURGE_CONFIRMATION.CMD_STATUS, Byte) |

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_PURGE_CONFIRMATION Constructor ()

NWK_PURGE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_PURGE_CONFIRMATION()
C++
public:
NWK_PURGE_CONFIRMATION() sealed
J#
public NWK_PURGE_CONFIRMATION()
JScript
public function NWK_PURGE_CONFIRMATION()

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_PURGE_CONFIRMATION Constructor Overload List


NWK_PURGE_CONFIRMATION Constructor (NWK_PURGE_CONFIRMATION.CMD_STATUS, Byte)

NWK_PURGE_CONFIRMATION Constructor (NWK_PURGE_CONFIRMATION.CMD_STATUS, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_PURGE_CONFIRMATION.CMD_STATUS, _
ByVal As Byte _
)
C#
public NWK_PURGE_CONFIRMATION(
NWK_PURGE_CONFIRMATION.CMD_STATUS ,
byte
)
C++
public:
NWK_PURGE_CONFIRMATION(
NWK_PURGE_CONFIRMATION.CMD_STATUS ,
char
) sealed
J#
public NWK_PURGE_CONFIRMATION(
NWK_PURGE_CONFIRMATION.CMD_STATUS ,
byte
)
JScript
public function NWK_PURGE_CONFIRMATION(
: NWK_PURGE_CONFIRMATION.CMD_STATUS,
: Byte
)

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_PURGE_CONFIRMATION Constructor Overload List


Fields

NWK_PURGE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | MsduHandle | Application-defined handle value associated with the data request.
Public field | Status | Status
Top

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI1 Namespace


MsduHandle Field

NWK_PURGE_CONFIRMATION.MsduHandle Field
[image]

Application-defined handle value associated with the data request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsduHandle As Byte
C#
public byte MsduHandle;
C++
public:
char MsduHandle sealed ;
J#
public byte MsduHandle
JScript
public MsduHandle : Byte;

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_PURGE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_PURGE_CONFIRMATION.CMD_STATUS
C#
public NWK_PURGE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_PURGE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_PURGE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_PURGE_CONFIRMATION.CMD_STATUS;

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_PURGE_CONFIRMATION.CMD_STATUS Enumeration

NWK_PURGE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_PURGE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_PURGE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_PURGE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_PURGE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_PURGE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_RX_ENABLE_CONFIRMATION Class

NWK_RX_ENABLE_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of an RX enable attempt.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_RX_ENABLE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_RX_ENABLE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_RX_ENABLE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_RX_ENABLE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_RX_ENABLE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_RX_ENABLE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_RX_ENABLE_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_RX_ENABLE_CONFIRMATION Members

NWK_RX_ENABLE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of an RX enable attempt.

The following tables list the members exposed by NWK_RX_ENABLE_CONFIRMATION.

Public Constructors

Name | Description
NWK_RX_ENABLE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_RX_ENABLE_CONFIRMATION | Overloaded.
Top

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_RX_ENABLE_CONFIRMATION Constructor

NWK_RX_ENABLE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_RX_ENABLE_CONFIRMATION | Constructor
Public method | NWK_RX_ENABLE_CONFIRMATION (NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS) |

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_RX_ENABLE_CONFIRMATION Constructor ()

NWK_RX_ENABLE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_RX_ENABLE_CONFIRMATION()
C++
public:
NWK_RX_ENABLE_CONFIRMATION() sealed
J#
public NWK_RX_ENABLE_CONFIRMATION()
JScript
public function NWK_RX_ENABLE_CONFIRMATION()

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_RX_ENABLE_CONFIRMATION Constructor Overload List


NWK_RX_ENABLE_CONFIRMATION Constructor (NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS)

NWK_RX_ENABLE_CONFIRMATION Constructor (NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS _
)
C#
public NWK_RX_ENABLE_CONFIRMATION(
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
)
C++
public:
NWK_RX_ENABLE_CONFIRMATION(
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
) sealed
J#
public NWK_RX_ENABLE_CONFIRMATION(
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
)
JScript
public function NWK_RX_ENABLE_CONFIRMATION(
: NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
)

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_RX_ENABLE_CONFIRMATION Constructor Overload List


Fields

NWK_RX_ENABLE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_RX_ENABLE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
C#
public NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS;

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Enumeration

NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_SCAN_CONFIRMATION Class

NWK_SCAN_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of a channel scan request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_SCAN_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_SCAN_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_SCAN_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_SCAN_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_SCAN_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_SCAN_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_SCAN_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_SCAN_CONFIRMATION Members

NWK_SCAN_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of a channel scan request.

The following tables list the members exposed by NWK_SCAN_CONFIRMATION.

Public Constructors

Name | Description
NWK_SCAN_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | EDMaxEnergy | Maximum possible energy detect value
Public field | ResultCount | Result Count
Public field | Results | List of energy measurements or PAN descriptors (depends on the scan type)
Public field | ScanType | ScanType
Public field | Status | Status of the scan request
Public field | UnscannedChannels | Bit mask of channels that were not scanned
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_SCAN_CONFIRMATION | Overloaded.
Top

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_SCAN_CONFIRMATION Constructor

NWK_SCAN_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_SCAN_CONFIRMATION | Constructor
Public method | NWK_SCAN_CONFIRMATION (NWK_SCAN_CONFIRMATION.CMD_STATUS, Byte, NWK_SCAN_CONFIRMATION.SCAN_TYPE, Byte, NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, Byte, Byte) |

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_SCAN_CONFIRMATION Constructor ()

NWK_SCAN_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_SCAN_CONFIRMATION()
C++
public:
NWK_SCAN_CONFIRMATION() sealed
J#
public NWK_SCAN_CONFIRMATION()
JScript
public function NWK_SCAN_CONFIRMATION()

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_SCAN_CONFIRMATION Constructor Overload List


NWK_SCAN_CONFIRMATION Constructor (NWK_SCAN_CONFIRMATION.CMD_STATUS, Byte, NWK_SCAN_CONFIRMATION.SCAN_TYPE, Byte, NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, Byte, Byte[])

NWK_SCAN_CONFIRMATION Constructor (NWK_SCAN_CONFIRMATION.CMD_STATUS, Byte, NWK_SCAN_CONFIRMATION.SCAN_TYPE, Byte, NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_SCAN_CONFIRMATION.CMD_STATUS, _
ByVal As Byte, _
ByVal As NWK_SCAN_CONFIRMATION.SCAN_TYPE, _
ByVal As Byte, _
ByVal As NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public NWK_SCAN_CONFIRMATION(
NWK_SCAN_CONFIRMATION.CMD_STATUS ,
byte ,
NWK_SCAN_CONFIRMATION.SCAN_TYPE ,
byte ,
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS ,
byte ,
byte[]
)
C++
public:
NWK_SCAN_CONFIRMATION(
NWK_SCAN_CONFIRMATION.CMD_STATUS ,
char ,
NWK_SCAN_CONFIRMATION.SCAN_TYPE ,
char ,
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS ,
char ,
array<char>^
) sealed
J#
public NWK_SCAN_CONFIRMATION(
NWK_SCAN_CONFIRMATION.CMD_STATUS ,
byte ,
NWK_SCAN_CONFIRMATION.SCAN_TYPE ,
byte ,
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS ,
byte ,
byte[]
)
JScript
public function NWK_SCAN_CONFIRMATION(
: NWK_SCAN_CONFIRMATION.CMD_STATUS,
: Byte,
: NWK_SCAN_CONFIRMATION.SCAN_TYPE,
: Byte,
: NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS,
: Byte,
: Byte[]
)

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_SCAN_CONFIRMATION Constructor Overload List


Fields

NWK_SCAN_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | EDMaxEnergy | Maximum possible energy detect value
Public field | ResultCount | Result Count
Public field | Results | List of energy measurements or PAN descriptors (depends on the scan type)
Public field | ScanType | ScanType
Public field | Status | Status of the scan request
Public field | UnscannedChannels | Bit mask of channels that were not scanned
Top

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


ChannelPage Field

NWK_SCAN_CONFIRMATION.ChannelPage Field
[image]

The channel page of the scan

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


EDMaxEnergy Field

NWK_SCAN_CONFIRMATION.EDMaxEnergy Field
[image]

Maximum possible energy detect value

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public EDMaxEnergy As Byte
C#
public byte EDMaxEnergy;
C++
public:
char EDMaxEnergy sealed ;
J#
public byte EDMaxEnergy
JScript
public EDMaxEnergy : Byte;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


ResultCount Field

NWK_SCAN_CONFIRMATION.ResultCount Field
[image]

Result Count

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ResultCount As Byte
C#
public byte ResultCount;
C++
public:
char ResultCount sealed ;
J#
public byte ResultCount
JScript
public ResultCount : Byte;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


Results Field

NWK_SCAN_CONFIRMATION.Results Field
[image]

List of energy measurements or PAN descriptors (depends on the scan type)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Results As Byte()
C#
public byte[] Results;
C++
public:
array<char>^ Results sealed ;
J#
public byte[] Results
JScript
public Results : Byte[];

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


ScanType Field

NWK_SCAN_CONFIRMATION.ScanType Field
[image]

ScanType

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanType As NWK_SCAN_CONFIRMATION.SCAN_TYPE
C#
public NWK_SCAN_CONFIRMATION.SCAN_TYPE ScanType;
C++
public:
NWK_SCAN_CONFIRMATION.SCAN_TYPE ScanType sealed ;
J#
public NWK_SCAN_CONFIRMATION.SCAN_TYPE ScanType
JScript
public ScanType : NWK_SCAN_CONFIRMATION.SCAN_TYPE;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_SCAN_CONFIRMATION.Status Field
[image]

Status of the scan request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_SCAN_CONFIRMATION.CMD_STATUS
C#
public NWK_SCAN_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_SCAN_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_SCAN_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_SCAN_CONFIRMATION.CMD_STATUS;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


UnscannedChannels Field

NWK_SCAN_CONFIRMATION.UnscannedChannels Field
[image]

Bit mask of channels that were not scanned

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UnscannedChannels As NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS
C#
public NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS UnscannedChannels;
C++
public:
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS UnscannedChannels sealed ;
J#
public NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS UnscannedChannels
JScript
public UnscannedChannels : NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_SCAN_CONFIRMATION.CMD_STATUS Enumeration

NWK_SCAN_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SCAN_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_SCAN_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_SCAN_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_SCAN_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_SCAN_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_SCAN_CONFIRMATION.SCAN_TYPE Enumeration

NWK_SCAN_CONFIRMATION.SCAN_TYPE Enumeration
[image]

Scan type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SCAN_CONFIRMATION.SCAN_TYPE As Byte
C#
public enum NWK_SCAN_CONFIRMATION.SCAN_TYPE : byte
C++
public enum class NWK_SCAN_CONFIRMATION.SCAN_TYPE : char
J#
public enum NWK_SCAN_CONFIRMATION.SCAN_TYPE byte
JScript
public enum NWK_SCAN_CONFIRMATION.SCAN_TYPE :

Members

Member Name | Description
ENERGY_DETECT | Scan type
ACTIVE | Scan type
PASSIVE | Scan type
ORPHAN | Scan type

See Also

TI.ZPI1 Namespace


NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS Enumeration

NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS uint
JScript
public enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


NWK_START_CONFIRMATION Class

NWK_START_CONFIRMATION Class
See Also Example Members
[image]

This function reports the success of the start request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_START_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_START_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_START_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_START_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_START_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_START_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_START_CONFIRMATION Members
TI.ZPI1 Namespace


NWK_START_CONFIRMATION Members

NWK_START_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the success of the start request.

The following tables list the members exposed by NWK_START_CONFIRMATION.

Public Constructors

Name | Description
NWK_START_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_START_CONFIRMATION | Overloaded.
Top

See Also

NWK_START_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_START_CONFIRMATION Constructor

NWK_START_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_START_CONFIRMATION | Constructor
Public method | NWK_START_CONFIRMATION (NWK_START_CONFIRMATION.CMD_STATUS) |

See Also

NWK_START_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_START_CONFIRMATION Constructor ()

NWK_START_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_START_CONFIRMATION()
C++
public:
NWK_START_CONFIRMATION() sealed
J#
public NWK_START_CONFIRMATION()
JScript
public function NWK_START_CONFIRMATION()

See Also

NWK_START_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_START_CONFIRMATION Constructor Overload List


NWK_START_CONFIRMATION Constructor (NWK_START_CONFIRMATION.CMD_STATUS)

NWK_START_CONFIRMATION Constructor (NWK_START_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_START_CONFIRMATION.CMD_STATUS _
)
C#
public NWK_START_CONFIRMATION(
NWK_START_CONFIRMATION.CMD_STATUS
)
C++
public:
NWK_START_CONFIRMATION(
NWK_START_CONFIRMATION.CMD_STATUS
) sealed
J#
public NWK_START_CONFIRMATION(
NWK_START_CONFIRMATION.CMD_STATUS
)
JScript
public function NWK_START_CONFIRMATION(
: NWK_START_CONFIRMATION.CMD_STATUS
)

See Also

NWK_START_CONFIRMATION Class
TI.ZPI1 Namespace
NWK_START_CONFIRMATION Constructor Overload List


Fields

NWK_START_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NWK_START_CONFIRMATION Class
TI.ZPI1 Namespace


Status Field

NWK_START_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_START_CONFIRMATION.CMD_STATUS
C#
public NWK_START_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_START_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_START_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_START_CONFIRMATION.CMD_STATUS;

See Also

NWK_START_CONFIRMATION Class
TI.ZPI1 Namespace


NWK_START_CONFIRMATION.CMD_STATUS Enumeration

NWK_START_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_START_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_START_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_START_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_START_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_START_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Class

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
See Also Example Members
[image]

This function indicates the loss of synchronization of a network beacon

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_SYNCHRONIZATION_LOSS_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_SYNCHRONIZATION_LOSS_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_SYNCHRONIZATION_LOSS_INDICATION : IINDICATION, INETWORK
J#
public class NWK_SYNCHRONIZATION_LOSS_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_SYNCHRONIZATION_LOSS_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI1.NWK_SYNCHRONIZATION_LOSS_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Members
TI.ZPI1 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Members

NWK_SYNCHRONIZATION_LOSS_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function indicates the loss of synchronization of a network beacon

The following tables list the members exposed by NWK_SYNCHRONIZATION_LOSS_INDICATION.

Public Constructors

Name | Description
NWK_SYNCHRONIZATION_LOSS_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Logical channel for this frame
Public field | PanID | PanID.
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_SYNCHRONIZATION_LOSS_INDICATION | Overloaded.
Top

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor

NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_SYNCHRONIZATION_LOSS_INDICATION | Constructor
Public method | NWK_SYNCHRONIZATION_LOSS_INDICATION (Byte, UInt16, Byte, Byte, Byte, NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor ()

NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION()
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION() sealed
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION()
JScript
public function NWK_SYNCHRONIZATION_LOSS_INDICATION()

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace
NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor Overload List


NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor (Byte, UInt16, Byte, Byte, Byte[], NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, Byte)

NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor (Byte, UInt16, Byte, Byte, Byte[], NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION(
byte ,
ushort ,
byte ,
byte ,
byte[] ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION(
char ,
unsigned short ,
char ,
char ,
array<char>^ ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION(
byte ,
ushort ,
byte ,
byte ,
byte[] ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_SYNCHRONIZATION_LOSS_INDICATION(
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte[],
: NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL,
: NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace
NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor Overload List


Fields

NWK_SYNCHRONIZATION_LOSS_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Logical channel for this frame
Public field | PanID | PanID.
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


ChannelPage Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.ChannelPage Field
[image]

The channel page of the scan

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


KeyIdMode Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


KeyIndex Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


KeySource Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


LogicalChannel Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.LogicalChannel Field
[image]

Logical channel for this frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


PanID Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.PanID Field
[image]

PanID.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


Reason Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.Reason Field
[image]

Synchronization lost Reason

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reason As Byte
C#
public byte Reason;
C++
public:
char Reason sealed ;
J#
public byte Reason
JScript
public Reason : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


SecurityLevel Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI1 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE Enumeration

NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL Enumeration

NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL Enumeration
See Also Example
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


SYS_APP_MSG Class

SYS_APP_MSG Class
See Also Example Members
[image]

Use this message to send raw data to an application.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_APP_MSG
Implements IREQUEST, ISYSTEM
C#
public class SYS_APP_MSG : IREQUEST, ISYSTEM
C++
ref class SYS_APP_MSG : IREQUEST, ISYSTEM
J#
public class SYS_APP_MSG implements IREQUEST, ISYSTEM
JScript
public class SYS_APP_MSG extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG Members
TI.ZPI1 Namespace


SYS_APP_MSG Members

SYS_APP_MSG Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to send raw data to an application.

The following tables list the members exposed by SYS_APP_MSG.

Public Constructors

Name | Description
SYS_APP_MSG | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppEndpoint | Application endpoint of the outgoing message
Public field | ClusterID | Cluster ID of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Public field | DestAddress | Destination address of the outgoing message
Public field | DestEndpoint | Destination endpoint of the outgoing message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG | Overloaded.
Top

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


SYS_APP_MSG Constructor

SYS_APP_MSG Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG | Constructor
Public method | SYS_APP_MSG (Byte, UInt16, Byte, UInt16, Byte, Object) | Constructor

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


SYS_APP_MSG Constructor ()

SYS_APP_MSG Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG()
C++
public:
SYS_APP_MSG() sealed
J#
public SYS_APP_MSG()
JScript
public function SYS_APP_MSG()

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace
SYS_APP_MSG Constructor Overload List


SYS_APP_MSG Constructor (Byte, UInt16, Byte, UInt16, Byte, Object)

SYS_APP_MSG Constructor (Byte, UInt16, Byte, UInt16, Byte, Object)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Object _
)
C#
public SYS_APP_MSG(
byte ,
ushort ,
byte ,
ushort ,
byte ,
object
)
C++
public:
SYS_APP_MSG(
char ,
unsigned short ,
char ,
unsigned short ,
char ,
Object
) sealed
J#
public SYS_APP_MSG(
byte ,
ushort ,
byte ,
ushort ,
byte ,
object
)
JScript
public function SYS_APP_MSG(
: Byte,
: UInt16,
: Byte,
: UInt16,
: Byte,
: Object
)

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace
SYS_APP_MSG Constructor Overload List


Fields

SYS_APP_MSG Fields
[image]

Public Fields

 | Name | Description
Public field | AppEndpoint | Application endpoint of the outgoing message
Public field | ClusterID | Cluster ID of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Public field | DestAddress | Destination address of the outgoing message
Public field | DestEndpoint | Destination endpoint of the outgoing message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Top

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


AppEndpoint Field

SYS_APP_MSG.AppEndpoint Field
[image]

Application endpoint of the outgoing message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppEndpoint As Byte
C#
public byte AppEndpoint;
C++
public:
char AppEndpoint sealed ;
J#
public byte AppEndpoint
JScript
public AppEndpoint : Byte;

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


ClusterID Field

SYS_APP_MSG.ClusterID Field
[image]

Cluster ID of the outgoing message. Can be left blank (filled in automatically by Z-Architect)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


DestAddress Field

SYS_APP_MSG.DestAddress Field
[image]

Destination address of the outgoing message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt16
C#
public ushort DestAddress;
C++
public:
unsigned short DestAddress sealed ;
J#
public ushort DestAddress
JScript
public DestAddress : UInt16;

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


DestEndpoint Field

SYS_APP_MSG.DestEndpoint Field
[image]

Destination endpoint of the outgoing message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


Message Field

SYS_APP_MSG.Message Field
[image]

raw data packet to send to the application

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Message As Object
C#
public object Message;
C++
public:
Object Message sealed ;
J#
public object Message
JScript
public Message : Object;

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


MsgLen Field

SYS_APP_MSG.MsgLen Field
[image]

Length of the outgoing message. Can be left blank (filled in automatically by Z-Architect)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsgLen As Byte
C#
public byte MsgLen;
C++
public:
char MsgLen sealed ;
J#
public byte MsgLen
JScript
public MsgLen : Byte;

See Also

SYS_APP_MSG Class
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.BLIND_NODE_CONFIGURATION
C#
public struct SYS_APP_MSG.BLIND_NODE_CONFIGURATION
C++
value class SYS_APP_MSG.BLIND_NODE_CONFIGURATION
J#
public final class SYS_APP_MSG.BLIND_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Members
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION Members

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by SYS_APP_MSG.BLIND_NODE_CONFIGURATION.

Public Constructors

Name | Description
SYS_APP_MSG.BLIND_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.BLIND_NODE_CONFIGURATION | Overloaded.
Top

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.BLIND_NODE_CONFIGURATION | Initializes a new instance of the SYS_APP_MSG.BLIND_NODE_CONFIGURATION class.
Public method | SYS_APP_MSG.BLIND_NODE_CONFIGURATION (Byte, Byte, SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte) |

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor ()

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.BLIND_NODE_CONFIGURATION class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION()
C++
public:
SYS_APP_MSG.BLIND_NODE_CONFIGURATION() sealed
J#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION()
JScript
public function SYS_APP_MSG.BLIND_NODE_CONFIGURATION()

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor Overload List


SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, _
ByVal As Byte _
)
C#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
C++
public:
SYS_APP_MSG.BLIND_NODE_CONFIGURATION(
char ,
char ,
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
unsigned short ,
unsigned short ,
unsigned short ,
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
char
) sealed
J#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
JScript
public function SYS_APP_MSG.BLIND_NODE_CONFIGURATION(
: Byte,
: Byte,
: SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE,
: UInt16,
: UInt16,
: UInt16,
: SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT,
: Byte
)

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG.BLIND_NODE_CONFIGURATION Constructor Overload List


Fields

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


AParameter Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.AParameter Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AParameter As Byte
C#
public byte AParameter;
C++
public:
char AParameter sealed ;
J#
public byte AParameter
JScript
public AParameter : Byte;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


CollectTime Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.CollectTime Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CollectTime As UInt16
C#
public ushort CollectTime;
C++
public:
unsigned short CollectTime sealed ;
J#
public ushort CollectTime
JScript
public CollectTime : UInt16;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


CycleTime Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.CycleTime Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CycleTime As UInt16
C#
public ushort CycleTime;
C++
public:
unsigned short CycleTime sealed ;
J#
public ushort CycleTime
JScript
public CycleTime : UInt16;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


MinRefNodes Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.MinRefNodes Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MinRefNodes As Byte
C#
public byte MinRefNodes;
C++
public:
char MinRefNodes sealed ;
J#
public byte MinRefNodes
JScript
public MinRefNodes : Byte;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


Mode Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.Mode Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
C#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode;
C++
public:
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode sealed ;
J#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode
JScript
public Mode : SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


nParameter Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.nParameter Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public nParameter As Byte
C#
public byte nParameter;
C++
public:
char nParameter sealed ;
J#
public byte nParameter
JScript
public nParameter : Byte;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


ReportEndpoint Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.ReportEndpoint Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportEndpoint As SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT
C#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint;
C++
public:
SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint sealed ;
J#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint
JScript
public ReportEndpoint : SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


ReportShortAddress Field

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.ReportShortAddress Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportShortAddress As UInt16
C#
public ushort ReportShortAddress;
C++
public:
unsigned short ReportShortAddress sealed ;
J#
public ushort ReportShortAddress
JScript
public ReportShortAddress : UInt16;

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT As Byte
C#
public enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT : byte
C++
public enum class SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT : char
J#
public enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT byte
JScript
public enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT :

Members

Member Name | Description
OAD |
LOCATION |
LOCATION_DONGLE |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration

SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE As Byte
C#
public enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : byte
C++
public enum class SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : char
J#
public enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE byte
JScript
public enum SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE :

Members

Member Name | Description
POLLED |
AUTO |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure

SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure
See Also Example Members
[image]

Send this message to a Blind Node to request its configuration. The response to this request is the Blind Node Configuration (Cluster ID 6) message. This message doesn't have a body to the message (just cluster ID)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
C#
public struct SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
C++
value class SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
J#
public final class SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Members

SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Members
See Also Example Constructors Methods
[image]

Send this message to a Blind Node to request its configuration. The response to this request is the Blind Node Configuration (Cluster ID 6) message. This message doesn't have a body to the message (just cluster ID)

The following tables list the members exposed by SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST.

Public Constructors

 | Name | Description
Public method | SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST | Initializes a new instance of the SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST class.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Constructor

SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Constructor
[image]

Initializes a new instance of the SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST()
C++
public:
SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST() sealed
J#
public SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST()
JScript
public function SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST()

See Also

SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_REQUEST Structure

SYS_APP_MSG.BLIND_NODE_REQUEST Structure
See Also Example Members
[image]

Send this message to a Blind Node to request its location. The response to this message will be sent by the blind node when the location process is complete (which will take seconds). This message doesn't have a body to the message (just cluster ID)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.BLIND_NODE_REQUEST
C#
public struct SYS_APP_MSG.BLIND_NODE_REQUEST
C++
value class SYS_APP_MSG.BLIND_NODE_REQUEST
J#
public final class SYS_APP_MSG.BLIND_NODE_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.BLIND_NODE_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_REQUEST Members

SYS_APP_MSG.BLIND_NODE_REQUEST Members
See Also Example Constructors Methods
[image]

Send this message to a Blind Node to request its location. The response to this message will be sent by the blind node when the location process is complete (which will take seconds). This message doesn't have a body to the message (just cluster ID)

The following tables list the members exposed by SYS_APP_MSG.BLIND_NODE_REQUEST.

Public Constructors

 | Name | Description
Public method | SYS_APP_MSG.BLIND_NODE_REQUEST | Initializes a new instance of the SYS_APP_MSG.BLIND_NODE_REQUEST class.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

SYS_APP_MSG.BLIND_NODE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.BLIND_NODE_REQUEST Constructor

SYS_APP_MSG.BLIND_NODE_REQUEST Constructor
[image]

Initializes a new instance of the SYS_APP_MSG.BLIND_NODE_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.BLIND_NODE_REQUEST()
C++
public:
SYS_APP_MSG.BLIND_NODE_REQUEST() sealed
J#
public SYS_APP_MSG.BLIND_NODE_REQUEST()
JScript
public function SYS_APP_MSG.BLIND_NODE_REQUEST()

See Also

SYS_APP_MSG.BLIND_NODE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.LOC_REQ_MESSAGE_ID Enumeration

SYS_APP_MSG.LOC_REQ_MESSAGE_ID Enumeration
[image]

Message id for LOC_REQ_MESSAGE_ID

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.LOC_REQ_MESSAGE_ID As Short
C#
public enum SYS_APP_MSG.LOC_REQ_MESSAGE_ID : short
C++
public enum class SYS_APP_MSG.LOC_REQ_MESSAGE_ID : short
J#
public enum SYS_APP_MSG.LOC_REQ_MESSAGE_ID short
JScript
public enum SYS_APP_MSG.LOC_REQ_MESSAGE_ID : short

Members

Member Name | Description
REFERENCE_NODE_REQUEST | Message id for LOC_REQ_MESSAGE_ID
BLIND_NODE_REQUEST | Message id for LOC_REQ_MESSAGE_ID
REFERENCE_NODE_CONFIGURATION | Message id for LOC_REQ_MESSAGE_ID
BLIND_NODE_CONFIGURATION | Message id for LOC_REQ_MESSAGE_ID
REFERENCE_NODE_CONFIGURATION_REQUEST | Message id for LOC_REQ_MESSAGE_ID
BLIND_NODE_CONFIGURATION_REQUEST | Message id for LOC_REQ_MESSAGE_ID

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.OAD_REQ_MESSAGE_ID Enumeration

SYS_APP_MSG.OAD_REQ_MESSAGE_ID Enumeration
[image]

Message id for OAD_REQ_MESSAGE_ID

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.OAD_REQ_MESSAGE_ID As Short
C#
public enum SYS_APP_MSG.OAD_REQ_MESSAGE_ID : short
C++
public enum class SYS_APP_MSG.OAD_REQ_MESSAGE_ID : short
J#
public enum SYS_APP_MSG.OAD_REQ_MESSAGE_ID short
JScript
public enum SYS_APP_MSG.OAD_REQ_MESSAGE_ID : short

Members

Member Name | Description
ZLMSGID_STATUSQ_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_SESSION_START_RESPONSE | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_SESSION_TERM_RESPONSE | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_CLIENT_CMD_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_CODE_ENABLE_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_SEND_DATA_RESPONSE | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_RESET_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_RESET_BOARD_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_GET_DONGLE_INFO_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_STATUSQ_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_CLIENT_CMD_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_CODE_ENABLE_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_RESET_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_RESET_BOARD_REQUEST | Message id for OAD_REQ_MESSAGE_ID

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION
C#
public struct SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION
C++
value class SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION
J#
public final class SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Members
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Members

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION.

Public Constructors

Name | Description
SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION | Initializes a new instance of the SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION class.
Public method | SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION (UInt16, UInt16) |

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor ()

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION()
C++
public:
SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION() sealed
J#
public SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION()
JScript
public function SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION()

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor Overload List


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
C++
public:
SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION(
unsigned short ,
unsigned short
) sealed
J#
public SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
JScript
public function SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION(
: UInt16,
: UInt16
)

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor Overload List


Fields

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


XPos Field

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION.XPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


YPos Field

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION.YPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure
See Also Example Members
[image]

Send this message to a Reference Node to request its configuration. The response to this request is the Reference Node Configuration (Cluster ID 5) message. This message doesn't have a body to the message (just cluster ID)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
C#
public struct SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
C++
value class SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
J#
public final class SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Members

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Members
See Also Example Constructors Methods
[image]

Send this message to a Reference Node to request its configuration. The response to this request is the Reference Node Configuration (Cluster ID 5) message. This message doesn't have a body to the message (just cluster ID)

The following tables list the members exposed by SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST.

Public Constructors

 | Name | Description
Public method | SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST | Initializes a new instance of the SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST class.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Constructor

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Constructor
[image]

Initializes a new instance of the SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST()
C++
public:
SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST() sealed
J#
public SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST()
JScript
public function SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST()

See Also

SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure

SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure
See Also Example Members
[image]

Send this message to a reference node to request its position information. In this request is the number of responses expected

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.REFERENCE_NODE_REQUEST
C#
public struct SYS_APP_MSG.REFERENCE_NODE_REQUEST
C++
value class SYS_APP_MSG.REFERENCE_NODE_REQUEST
J#
public final class SYS_APP_MSG.REFERENCE_NODE_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.REFERENCE_NODE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.REFERENCE_NODE_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_REQUEST Members

SYS_APP_MSG.REFERENCE_NODE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to a reference node to request its position information. In this request is the number of responses expected

The following tables list the members exposed by SYS_APP_MSG.REFERENCE_NODE_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG.REFERENCE_NODE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NumberMessages |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.REFERENCE_NODE_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor

SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.REFERENCE_NODE_REQUEST | Initializes a new instance of the SYS_APP_MSG.REFERENCE_NODE_REQUEST class.
Public method | SYS_APP_MSG.REFERENCE_NODE_REQUEST (Byte) |

See Also

SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor ()

SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.REFERENCE_NODE_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.REFERENCE_NODE_REQUEST()
C++
public:
SYS_APP_MSG.REFERENCE_NODE_REQUEST() sealed
J#
public SYS_APP_MSG.REFERENCE_NODE_REQUEST()
JScript
public function SYS_APP_MSG.REFERENCE_NODE_REQUEST()

See Also

SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor Overload List


SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor (Byte)

SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor (Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_APP_MSG.REFERENCE_NODE_REQUEST(
byte
)
C++
public:
SYS_APP_MSG.REFERENCE_NODE_REQUEST(
char
) sealed
J#
public SYS_APP_MSG.REFERENCE_NODE_REQUEST(
byte
)
JScript
public function SYS_APP_MSG.REFERENCE_NODE_REQUEST(
: Byte
)

See Also

SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.REFERENCE_NODE_REQUEST Constructor Overload List


Fields

SYS_APP_MSG.REFERENCE_NODE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | NumberMessages |
Top

See Also

SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI1 Namespace


NumberMessages Field

SYS_APP_MSG.REFERENCE_NODE_REQUEST.NumberMessages Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumberMessages As Byte
C#
public byte NumberMessages;
C++
public:
char NumberMessages sealed ;
J#
public byte NumberMessages
JScript
public NumberMessages : Byte;

See Also

SYS_APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
See Also Example Members
[image]

Used by Commissioner to assign Client status to a device and therefore to cause a new image to be downloaded to that device. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
C#
public struct SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
C++
value class SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
J#
public final class SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Members

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used by Commissioner to assign Client status to a device and therefore to cause a new image to be downloaded to that device. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlclC_endp |
Public field | zlclC_IEEE |
Public field | zlclC_manu |
Public field | zlclC_nwk |
Public field | zlclC_prod |
Public field | zlclC_ver |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST class.
Public method | SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST (Byte, Byte, UInt16, UInt16, UInt16, UInt64, UInt16, SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT) |

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor ()

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST()
C++
public:
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST() sealed
J#
public SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST()
JScript
public function SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST()

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor Overload List


SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, UInt64, UInt16, SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT)

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, UInt64, UInt16, SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT _
)
C#
public SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ulong ,
ushort ,
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
)
C++
public:
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned __int64 ,
unsigned short ,
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
) sealed
J#
public SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ulong ,
ushort ,
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
)
JScript
public function SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: UInt64,
: UInt16,
: SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
)

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlclC_endp |
Public field | zlclC_IEEE |
Public field | zlclC_manu |
Public field | zlclC_nwk |
Public field | zlclC_prod |
Public field | zlclC_ver |
Top

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


zlclC_endp Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_endp Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_endp As SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
C#
public SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT zlclC_endp;
C++
public:
SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT zlclC_endp sealed ;
J#
public SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT zlclC_endp
JScript
public zlclC_endp : SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


zlclC_IEEE Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_IEEE Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_IEEE As UInt64
C#
public ulong zlclC_IEEE;
C++
public:
unsigned __int64 zlclC_IEEE sealed ;
J#
public ulong zlclC_IEEE
JScript
public zlclC_IEEE : UInt64;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


zlclC_manu Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_manu Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_manu As UInt16
C#
public ushort zlclC_manu;
C++
public:
unsigned short zlclC_manu sealed ;
J#
public ushort zlclC_manu
JScript
public zlclC_manu : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


zlclC_nwk Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_nwk Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_nwk As UInt16
C#
public ushort zlclC_nwk;
C++
public:
unsigned short zlclC_nwk sealed ;
J#
public ushort zlclC_nwk
JScript
public zlclC_nwk : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


zlclC_prod Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_prod Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_prod As UInt16
C#
public ushort zlclC_prod;
C++
public:
unsigned short zlclC_prod sealed ;
J#
public ushort zlclC_prod
JScript
public zlclC_prod : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


zlclC_ver Field

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_ver Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_ver As UInt16
C#
public ushort zlclC_ver;
C++
public:
unsigned short zlclC_ver sealed ;
J#
public ushort zlclC_ver
JScript
public zlclC_ver : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT Enumeration

SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT As Byte
C#
public enum SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT : byte
C++
public enum class SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT : char
J#
public enum SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT byte
JScript
public enum SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT :

Members

Member Name | Description
OAD |
LOCATION |
LOCATION_DONGLE |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
See Also Example Members
[image]

This command causes the target device to enable the downloaded image. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
C#
public struct SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
C++
value class SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
J#
public final class SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Members

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command causes the target device to enable the downloaded image. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlceC_manu |
Public field | zlceC_prod |
Public field | zlceC_ver |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST class.
Public method | SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST (Byte, Byte, UInt16, UInt16, UInt16) |

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor ()

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST()
C++
public:
SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST() sealed
J#
public SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST()
JScript
public function SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST()

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor Overload List


SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16)

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort
)
C++
public:
SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short
) sealed
J#
public SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort
)
JScript
public function SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16
)

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlceC_manu |
Public field | zlceC_prod |
Public field | zlceC_ver |
Top

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


zlceC_manu Field

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.zlceC_manu Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlceC_manu As UInt16
C#
public ushort zlceC_manu;
C++
public:
unsigned short zlceC_manu sealed ;
J#
public ushort zlceC_manu
JScript
public zlceC_manu : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


zlceC_prod Field

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.zlceC_prod Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlceC_prod As UInt16
C#
public ushort zlceC_prod;
C++
public:
unsigned short zlceC_prod sealed ;
J#
public ushort zlceC_prod
JScript
public zlceC_prod : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


zlceC_ver Field

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.zlceC_ver Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlceC_ver As UInt16
C#
public ushort zlceC_ver;
C++
public:
unsigned short zlceC_ver sealed ;
J#
public ushort zlceC_ver
JScript
public zlceC_ver : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
See Also Example Members
[image]

This command requests the target device to reset. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
C#
public struct SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
C++
value class SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
J#
public final class SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Members

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command requests the target device to reset. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST class.
Public method | SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST (Byte, Byte) |

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor ()

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST()
C++
public:
SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST() sealed
J#
public SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST()
JScript
public function SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST()

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor Overload List


SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor (Byte, Byte)

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor (Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
byte ,
byte
)
C++
public:
SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
char ,
char
) sealed
J#
public SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
byte ,
byte
)
JScript
public function SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
: Byte,
: Byte
)

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
See Also Example Members
[image]

This command requests the target device to terminate all OAD activity and return to the idle state. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_RESET_REQUEST
C#
public struct SYS_APP_MSG.ZLMSGID_RESET_REQUEST
C++
value class SYS_APP_MSG.ZLMSGID_RESET_REQUEST
J#
public final class SYS_APP_MSG.ZLMSGID_RESET_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_RESET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_REQUEST Members

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command requests the target device to terminate all OAD activity and return to the idle state. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_RESET_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_RESET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_RESET_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_RESET_REQUEST | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_RESET_REQUEST class.
Public method | SYS_APP_MSG.ZLMSGID_RESET_REQUEST (Byte, Byte) |

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor ()

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_RESET_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_RESET_REQUEST()
C++
public:
SYS_APP_MSG.ZLMSGID_RESET_REQUEST() sealed
J#
public SYS_APP_MSG.ZLMSGID_RESET_REQUEST()
JScript
public function SYS_APP_MSG.ZLMSGID_RESET_REQUEST()

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor Overload List


SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor (Byte, Byte)

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor (Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_APP_MSG.ZLMSGID_RESET_REQUEST(
byte ,
byte
)
C++
public:
SYS_APP_MSG.ZLMSGID_RESET_REQUEST(
char ,
char
) sealed
J#
public SYS_APP_MSG.ZLMSGID_RESET_REQUEST(
byte ,
byte
)
JScript
public function SYS_APP_MSG.ZLMSGID_RESET_REQUEST(
: Byte,
: Byte
)

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_RESET_REQUEST Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_RESET_REQUEST.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_RESET_REQUEST.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_SEND_DATA_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
C#
public struct SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
C++
value class SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
J#
public final class SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Members

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_SEND_DATA_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdR_data |
Public field | zlsdR_errorCode |
Public field | zlsdR_pktNum |
Public field | zlsdR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE class.
Public method | SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE (Byte, Byte, SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, UInt16, Byte) |

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor ()

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE()
C++
public:
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE() sealed
J#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE()
JScript
public function SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE()

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor Overload List


SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, UInt16, Byte[])

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, UInt16, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, _
ByVal As UInt16, _
ByVal As Byte() _
)
C#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
byte ,
byte ,
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE ,
ushort ,
byte[]
)
C++
public:
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
char ,
char ,
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE ,
unsigned short ,
array<char>^
) sealed
J#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
byte ,
byte ,
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE ,
ushort ,
byte[]
)
JScript
public function SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE,
: UInt16,
: Byte[]
)

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdR_data |
Public field | zlsdR_errorCode |
Public field | zlsdR_pktNum |
Public field | zlsdR_state |
Top

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


zlsdR_data Field

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_data Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_data As Byte()
C#
public byte[] zlsdR_data;
C++
public:
array<char>^ zlsdR_data sealed ;
J#
public byte[] zlsdR_data
JScript
public zlsdR_data : Byte[];

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


zlsdR_errorCode Field

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_errorCode Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_errorCode As SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE
C#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE zlsdR_errorCode;
C++
public:
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE zlsdR_errorCode sealed ;
J#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE zlsdR_errorCode
JScript
public zlsdR_errorCode : SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE;

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


zlsdR_pktNum Field

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_pktNum Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_pktNum As UInt16
C#
public ushort zlsdR_pktNum;
C++
public:
unsigned short zlsdR_pktNum sealed ;
J#
public ushort zlsdR_pktNum
JScript
public zlsdR_pktNum : UInt16;

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


zlsdR_state Field

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_state Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_state As SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE zlsdR_state;
C++
public:
SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE zlsdR_state sealed ;
J#
public SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE zlsdR_state
JScript
public zlsdR_state : SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE Enumeration

SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE As Byte
C#
public enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE : byte
C++
public enum class SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE : char
J#
public enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE byte
JScript
public enum SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NOT_IN_SVR_ST |
BAD_SESS_ID |
OOR_PKT_NUM |
NO_PRE_START_SESS_CMD |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_SESSION_START_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE
C#
public struct SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE
C++
value class SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE
J#
public final class SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Members

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_SESSION_START_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsR_blkSize |
Public field | zlbsR_errorCode |
Public field | zlbsR_imgLen |
Public field | zlbsR_imgOffset |
Public field | zlbsR_numBlks |
Public field | zlbsR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE class.
Public method | SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE (Byte, Byte, SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, UInt32, Byte, Byte, Byte) |

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor ()

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE()
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE() sealed
J#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE()
JScript
public function SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE()

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor Overload List


SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, UInt32, Byte, Byte, Byte)

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, UInt32, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
byte ,
byte ,
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE ,
uint ,
byte ,
byte ,
byte
)
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
char ,
char ,
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE ,
unsigned int ,
char ,
char ,
char
) sealed
J#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
byte ,
byte ,
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE ,
uint ,
byte ,
byte ,
byte
)
JScript
public function SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE,
: UInt32,
: Byte,
: Byte,
: Byte
)

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsR_blkSize |
Public field | zlbsR_errorCode |
Public field | zlbsR_imgLen |
Public field | zlbsR_imgOffset |
Public field | zlbsR_numBlks |
Public field | zlbsR_state |
Top

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


zlbsR_blkSize Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_blkSize Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_blkSize As Byte
C#
public byte zlbsR_blkSize;
C++
public:
char zlbsR_blkSize sealed ;
J#
public byte zlbsR_blkSize
JScript
public zlbsR_blkSize : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


zlbsR_errorCode Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_errorCode As SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE
C#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE zlbsR_errorCode;
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE zlbsR_errorCode sealed ;
J#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE zlbsR_errorCode
JScript
public zlbsR_errorCode : SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


zlbsR_imgLen Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_imgLen Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_imgLen As UInt32
C#
public uint zlbsR_imgLen;
C++
public:
unsigned int zlbsR_imgLen sealed ;
J#
public uint zlbsR_imgLen
JScript
public zlbsR_imgLen : UInt32;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


zlbsR_imgOffset Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_imgOffset Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_imgOffset As Byte
C#
public byte zlbsR_imgOffset;
C++
public:
char zlbsR_imgOffset sealed ;
J#
public byte zlbsR_imgOffset
JScript
public zlbsR_imgOffset : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


zlbsR_numBlks Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_numBlks Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_numBlks As Byte
C#
public byte zlbsR_numBlks;
C++
public:
char zlbsR_numBlks sealed ;
J#
public byte zlbsR_numBlks
JScript
public zlbsR_numBlks : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


zlbsR_state Field

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_state Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_state As SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE zlbsR_state;
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE zlbsR_state sealed ;
J#
public SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE zlbsR_state
JScript
public zlbsR_state : SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE Enumeration

SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE As Byte
C#
public enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE : byte
C++
public enum class SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE : char
J#
public enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE byte
JScript
public enum SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NOT_IN_IDLE_ST |
NO_IMG_MATCH |
CANT_ALLOC_MEM |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_SESSION_TERM_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
C#
public struct SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
C++
value class SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
J#
public final class SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Members

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_SESSION_TERM_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE class.
Public method | SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE (Byte, Byte, SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE) |

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor ()

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE()
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE() sealed
J#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE()
JScript
public function SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE()

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor Overload List


SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE)

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE _
)
C#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
byte ,
byte ,
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
)
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
char ,
char ,
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
) sealed
J#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
byte ,
byte ,
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
)
JScript
public function SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
)

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_errorCode Field

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
C#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE zlesR_errorCode;
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE zlesR_errorCode sealed ;
J#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_state Field

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.zlesR_state Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE Enumeration

SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE As Byte
C#
public enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE : byte
C++
public enum class SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE : char
J#
public enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE byte
JScript
public enum SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
BAD_SESSION_ID |
NOT_IN_SVR_ST |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
See Also Example Members
[image]

Used to determine images currently existing on a device. This is part of the Commissioner's enumeration process. Based on need each device may then be either a Client or a Server depending on current images on-board. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST
C#
public struct SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST
C++
value class SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST
J#
public final class SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Members

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used to determine images currently existing on a device. This is part of the Commissioner's enumeration process. Based on need each device may then be either a Client or a Server depending on current images on-board. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST | Initializes a new instance of the SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST class.
Public method | SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST (Byte, Byte) |

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor ()

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST()
C++
public:
SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST() sealed
J#
public SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST()
JScript
public function SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST()

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor Overload List


SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor (Byte, Byte)

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor (Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST(
byte ,
byte
)
C++
public:
SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST(
char ,
char
) sealed
J#
public SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST(
byte ,
byte
)
JScript
public function SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST(
: Byte,
: Byte
)

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor Overload List


Fields

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE Class

SYS_APP_MSG_RESPONSE Class
See Also Example Members
[image]

Response for SYS_APP_MSG

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_APP_MSG_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_APP_MSG_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_APP_MSG_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_APP_MSG_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_APP_MSG_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE Members

SYS_APP_MSG_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_APP_MSG

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppEndpoint | this represents the application endpoint to send the data
Public field | ClusterID | Cluster ID of the received message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the received message
Public field | SrcAddress | Source address of the received message
Public field | SrcEndpoint | Source endpoint of the received message
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE Constructor

SYS_APP_MSG_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE | Constructor
Public method | SYS_APP_MSG_RESPONSE (Byte, UInt16, Byte, UInt16, Byte, Object) | Constructor

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE Constructor (Byte, UInt16, Byte, UInt16, Byte, Object)

SYS_APP_MSG_RESPONSE Constructor (Byte, UInt16, Byte, UInt16, Byte, Object)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Object _
)
C#
public SYS_APP_MSG_RESPONSE(
byte ,
ushort ,
byte ,
ushort ,
byte ,
object
)
C++
public:
SYS_APP_MSG_RESPONSE(
char ,
unsigned short ,
char ,
unsigned short ,
char ,
Object
) sealed
J#
public SYS_APP_MSG_RESPONSE(
byte ,
ushort ,
byte ,
ushort ,
byte ,
object
)
JScript
public function SYS_APP_MSG_RESPONSE(
: Byte,
: UInt16,
: Byte,
: UInt16,
: Byte,
: Object
)

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | AppEndpoint | this represents the application endpoint to send the data
Public field | ClusterID | Cluster ID of the received message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the received message
Public field | SrcAddress | Source address of the received message
Public field | SrcEndpoint | Source endpoint of the received message
Top

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


AppEndpoint Field

SYS_APP_MSG_RESPONSE.AppEndpoint Field
[image]

this represents the application endpoint to send the data

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppEndpoint As Byte
C#
public byte AppEndpoint;
C++
public:
char AppEndpoint sealed ;
J#
public byte AppEndpoint
JScript
public AppEndpoint : Byte;

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


ClusterID Field

SYS_APP_MSG_RESPONSE.ClusterID Field
[image]

Cluster ID of the received message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


Message Field

SYS_APP_MSG_RESPONSE.Message Field
[image]

raw data packet to send to the application

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Message As Object
C#
public object Message;
C++
public:
Object Message sealed ;
J#
public object Message
JScript
public Message : Object;

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


MsgLen Field

SYS_APP_MSG_RESPONSE.MsgLen Field
[image]

Length of the received message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsgLen As Byte
C#
public byte MsgLen;
C++
public:
char MsgLen sealed ;
J#
public byte MsgLen
JScript
public MsgLen : Byte;

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


SrcAddress Field

SYS_APP_MSG_RESPONSE.SrcAddress Field
[image]

Source address of the received message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


SrcEndpoint Field

SYS_APP_MSG_RESPONSE.SrcEndpoint Field
[image]

Source endpoint of the received message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

SYS_APP_MSG_RESPONSE Class
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION
C#
public struct SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION
C++
value class SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION
J#
public final class SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Members

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION | Initializes a new instance of the SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION class.
Public method | SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION (Byte, Byte, SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte) |

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor ()

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION()
C++
public:
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION() sealed
J#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION()
JScript
public function SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION()

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor Overload List


SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT, _
ByVal As Byte _
)
C#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
C++
public:
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION(
char ,
char ,
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
unsigned short ,
unsigned short ,
unsigned short ,
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
char
) sealed
J#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
JScript
public function SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION(
: Byte,
: Byte,
: SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE,
: UInt16,
: UInt16,
: UInt16,
: SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT,
: Byte
)

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


AParameter Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.AParameter Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AParameter As Byte
C#
public byte AParameter;
C++
public:
char AParameter sealed ;
J#
public byte AParameter
JScript
public AParameter : Byte;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


CollectTime Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.CollectTime Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CollectTime As UInt16
C#
public ushort CollectTime;
C++
public:
unsigned short CollectTime sealed ;
J#
public ushort CollectTime
JScript
public CollectTime : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


CycleTime Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.CycleTime Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CycleTime As UInt16
C#
public ushort CycleTime;
C++
public:
unsigned short CycleTime sealed ;
J#
public ushort CycleTime
JScript
public CycleTime : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


MinRefNodes Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.MinRefNodes Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MinRefNodes As Byte
C#
public byte MinRefNodes;
C++
public:
char MinRefNodes sealed ;
J#
public byte MinRefNodes
JScript
public MinRefNodes : Byte;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


Mode Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.Mode Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
C#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode;
C++
public:
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode sealed ;
J#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode
JScript
public Mode : SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


nParameter Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.nParameter Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public nParameter As Byte
C#
public byte nParameter;
C++
public:
char nParameter sealed ;
J#
public byte nParameter
JScript
public nParameter : Byte;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


ReportEndpoint Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.ReportEndpoint Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportEndpoint As SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT
C#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint;
C++
public:
SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint sealed ;
J#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint
JScript
public ReportEndpoint : SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


ReportShortAddress Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.ReportShortAddress Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportShortAddress As UInt16
C#
public ushort ReportShortAddress;
C++
public:
unsigned short ReportShortAddress sealed ;
J#
public ushort ReportShortAddress
JScript
public ReportShortAddress : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT As Byte
C#
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT : byte
C++
public enum class SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT : char
J#
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT byte
JScript
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT :

Members

Member Name | Description
OAD |
LOCATION |
LOCATION_DONGLE |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration

SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : char
J#
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE byte
JScript
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE :

Members

Member Name | Description
POLLED |
AUTO |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
See Also Example Members
[image]

This message is sent out of the Blind Node in response to the "Bind Node Request" message. The blind node, upon receiving the request message, will send a "Reference Node Request" (radius 1 - broadcast) to its immediate neighbors and wait for responses. Use the Blind Node Configuration message to change the parameters used to generate this response message (ie. number of reference node response, collect time)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE
C#
public struct SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE
C++
value class SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE
J#
public final class SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Members

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent out of the Blind Node in response to the "Bind Node Request" message. The blind node, upon receiving the request message, will send a "Reference Node Request" (radius 1 - broadcast) to its immediate neighbors and wait for responses. Use the Blind Node Configuration message to change the parameters used to generate this response message (ie. number of reference node response, collect time)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClosestRSSI |
Public field | ClosestShortAddr |
Public field | ClosestXPos |
Public field | ClosestYPos |
Public field | NumOfRef |
Public field | Status |
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE | Initializes a new instance of the SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE class.
Public method | SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE (SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, UInt16, Byte) |

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor (SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, UInt16, Byte)

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor (SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE(
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS ,
ushort ,
ushort ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
C++
public:
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE(
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS ,
unsigned short ,
unsigned short ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
char
) sealed
J#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE(
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS ,
ushort ,
ushort ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
JScript
public function SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE(
: SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS,
: UInt16,
: UInt16,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: Byte
)

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | ClosestRSSI |
Public field | ClosestShortAddr |
Public field | ClosestXPos |
Public field | ClosestYPos |
Public field | NumOfRef |
Public field | Status |
Public field | XPos |
Public field | YPos |
Top

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


ClosestRSSI Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.ClosestRSSI Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestRSSI As Byte
C#
public byte ClosestRSSI;
C++
public:
char ClosestRSSI sealed ;
J#
public byte ClosestRSSI
JScript
public ClosestRSSI : Byte;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


ClosestShortAddr Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.ClosestShortAddr Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestShortAddr As UInt16
C#
public ushort ClosestShortAddr;
C++
public:
unsigned short ClosestShortAddr sealed ;
J#
public ushort ClosestShortAddr
JScript
public ClosestShortAddr : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


ClosestXPos Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.ClosestXPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestXPos As UInt16
C#
public ushort ClosestXPos;
C++
public:
unsigned short ClosestXPos sealed ;
J#
public ushort ClosestXPos
JScript
public ClosestXPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


ClosestYPos Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.ClosestYPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestYPos As UInt16
C#
public ushort ClosestYPos;
C++
public:
unsigned short ClosestYPos sealed ;
J#
public ushort ClosestYPos
JScript
public ClosestYPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


NumOfRef Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.NumOfRef Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOfRef As Byte
C#
public byte NumOfRef;
C++
public:
char NumOfRef sealed ;
J#
public byte NumOfRef
JScript
public NumOfRef : Byte;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


Status Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.Status Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS
C#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Status;
C++
public:
SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Status sealed ;
J#
public SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Status
JScript
public Status : SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


XPos Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.XPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


YPos Field

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.YPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Enumeration

SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS As Byte
C#
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS : byte
C++
public enum class SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS : char
J#
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS byte
JScript
public enum SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS :

Members

Member Name | Description
SUCCESS |
NOT_ENOUGH_REF |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID Enumeration

SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID Enumeration
[image]

Message id for LOC_RSP_MESSAGE_ID

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID As Short
C#
public enum SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID : short
C++
public enum class SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID : short
J#
public enum SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID short
JScript
public enum SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID : short

Members

Member Name | Description
REFERENCE_NODE_RESPONSE | Message id for LOC_RSP_MESSAGE_ID
BLIND_NODE_RESPONSE | Message id for LOC_RSP_MESSAGE_ID
REFERENCE_NODE_CONFIGURATION | Message id for LOC_RSP_MESSAGE_ID
BLIND_NODE_CONFIGURATION | Message id for LOC_RSP_MESSAGE_ID

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID Enumeration

SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID Enumeration
[image]

Message id for OAD_RSP_MESSAGE_ID

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID As Short
C#
public enum SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID : short
C++
public enum class SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID : short
J#
public enum SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID short
JScript
public enum SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID : short

Members

Member Name | Description
ZLMSGID_STATUSQ_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_SESSION_START_REQUEST | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_SESSION_TERM_REQUEST | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_CLIENT_CMD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_CODE_ENABLE_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_SEND_DATA_REQUEST | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_RESET_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_RESET_BOARD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_GET_DONGLE_INFO_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_STATUSQ_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_CLIENT_CMD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_CODE_ENABLE_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_RESET_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_RESET_BOARD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION
C#
public struct SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION
C++
value class SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION
J#
public final class SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Members

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor
See Also Example

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION | Initializes a new instance of the SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION class.
Public method | SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION (UInt16, UInt16) |

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor ()

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION()
C++
public:
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION() sealed
J#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION()
JScript
public function SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION()

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor Overload List


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
C++
public:
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION(
unsigned short ,
unsigned short
) sealed
J#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
JScript
public function SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION(
: UInt16,
: UInt16
)

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


XPos Field

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION.XPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


YPos Field

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION.YPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
See Also Example Members
[image]

This message is sent by a Reference Node in response to a "Reference Node Request" message. The number of time that this message is sent depends on the number request in the request. When multiple responses are request, the delay between responses are from 2-16 milliseconds

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE
C#
public struct SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE
C++
value class SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE
J#
public final class SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Members

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by a Reference Node in response to a "Reference Node Request" message. The number of time that this message is sent depends on the number request in the request. When multiple responses are request, the delay between responses are from 2-16 milliseconds

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ResponseNumber |
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE | Initializes a new instance of the SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE class.
Public method | SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE (UInt16, UInt16, Byte) |

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor (UInt16, UInt16, Byte)

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor (UInt16, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE(
ushort ,
ushort ,
byte
)
C++
public:
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE(
unsigned short ,
unsigned short ,
char
) sealed
J#
public SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE(
ushort ,
ushort ,
byte
)
JScript
public function SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE(
: UInt16,
: UInt16,
: Byte
)

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | ResponseNumber |
Public field | XPos |
Public field | YPos |
Top

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace


ResponseNumber Field

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE.ResponseNumber Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ResponseNumber As Byte
C#
public byte ResponseNumber;
C++
public:
char ResponseNumber sealed ;
J#
public byte ResponseNumber
JScript
public ResponseNumber : Byte;

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace


XPos Field

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE.XPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace


YPos Field

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE.YPos Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_CLIENT_CMD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Members

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_CLIENT_CMD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE)

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE(
char ,
char ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.Length Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.Session Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_errorCode Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE zlesR_errorCode;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE zlesR_errorCode sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_state Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.zlesR_state Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NOT_IN_IDLE_ST |
CANT_ALLOC_MEM |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_CODE_ENABLE_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Members

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_CODE_ENABLE_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor
See Also Example

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE)

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE(
char ,
char ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.Length Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.Session Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_errorCode Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE zlesR_errorCode;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE zlesR_errorCode sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_state Field

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.zlesR_state Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NO_VALID_DL_IMG |
NO_IMG_SPEC_MATCH |
NOT_IN_IDLE_ST |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_RESET_BOARD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Members

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_RESET_BOARD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor
See Also Example

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE)

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE(
char ,
char ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.Length Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.Session Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_errorCode Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE zlesR_errorCode;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE zlesR_errorCode sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_state Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.zlesR_state Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE :

Members

Member Name | Description
NO_ERROR |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_RESET_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Members

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_RESET_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE)

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE(
char ,
char ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_errorCode Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE zlesR_errorCode;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE zlesR_errorCode sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace


zlesR_state Field

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.zlesR_state Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE :

Members

Member Name | Description
NO_ERROR |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
See Also Example Members
[image]

This command requests the target device to send a data packet. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Members

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command requests the target device to send a data packet. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdC_pktNum |
Public field | zlsdC_sessionID |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST (Byte, Byte, UInt16, Byte) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor (Byte, Byte, UInt16, Byte)

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor (Byte, Byte, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST(
byte ,
byte ,
ushort ,
byte
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST(
char ,
char ,
unsigned short ,
char
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST(
byte ,
byte ,
ushort ,
byte
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST(
: Byte,
: Byte,
: UInt16,
: Byte
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdC_pktNum |
Public field | zlsdC_sessionID |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace


zlsdC_pktNum Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST.zlsdC_pktNum Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdC_pktNum As UInt16
C#
public ushort zlsdC_pktNum;
C++
public:
unsigned short zlsdC_pktNum sealed ;
J#
public ushort zlsdC_pktNum
JScript
public zlsdC_pktNum : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace


zlsdC_sessionID Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST.zlsdC_sessionID Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdC_sessionID As Byte
C#
public byte zlsdC_sessionID;
C++
public:
char zlsdC_sessionID sealed ;
J#
public byte zlsdC_sessionID
JScript
public zlsdC_sessionID : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
See Also Example Members
[image]

Used to mark the beginning of a set of data transfer transactions and to establish Server status on the part of the target device. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Members

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used to mark the beginning of a set of data transfer transactions and to establish Server status on the part of the target device. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsC_manu |
Public field | zlbsC_prod |
Public field | zlbsC_sessionID |
Public field | zlbsC_ver |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor
See Also Example

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST (Byte, Byte, UInt16, UInt16, UInt16, Byte) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, Byte)

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST(
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
char
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST(
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: Byte
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsC_manu |
Public field | zlbsC_prod |
Public field | zlbsC_sessionID |
Public field | zlbsC_ver |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST.Length Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST.Session Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


zlbsC_manu Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST.zlbsC_manu Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_manu As UInt16
C#
public ushort zlbsC_manu;
C++
public:
unsigned short zlbsC_manu sealed ;
J#
public ushort zlbsC_manu
JScript
public zlbsC_manu : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


zlbsC_prod Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST.zlbsC_prod Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_prod As UInt16
C#
public ushort zlbsC_prod;
C++
public:
unsigned short zlbsC_prod sealed ;
J#
public ushort zlbsC_prod
JScript
public zlbsC_prod : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


zlbsC_sessionID Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST.zlbsC_sessionID Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_sessionID As Byte
C#
public byte zlbsC_sessionID;
C++
public:
char zlbsC_sessionID sealed ;
J#
public byte zlbsC_sessionID
JScript
public zlbsC_sessionID : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


zlbsC_ver Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST.zlbsC_ver Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_ver As UInt16
C#
public ushort zlbsC_ver;
C++
public:
unsigned short zlbsC_ver sealed ;
J#
public ushort zlbsC_ver
JScript
public zlbsC_ver : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
See Also Example Members
[image]

Used to terminate a session and reset the OAD context of the target platform. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Members

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used to terminate a session and reset the OAD context of the target platform. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesC_sessionID |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor
See Also Example

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST (Byte, Byte, Byte) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor (Byte, Byte, Byte)

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor (Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST(
byte ,
byte ,
byte
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST(
char ,
char ,
char
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST(
byte ,
byte ,
byte
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST(
: Byte,
: Byte,
: Byte
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesC_sessionID |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST.Length Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST.Session Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace


zlesC_sessionID Field

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST.zlesC_sessionID Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesC_sessionID As Byte
C#
public byte zlesC_sessionID;
C++
public:
char zlesC_sessionID sealed ;
J#
public byte zlesC_sessionID
JScript
public zlesC_sessionID : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_STATUSQ_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE
C#
public struct SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE
C++
value class SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE
J#
public final class SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Members
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Members

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_STATUSQ_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.

Public Constructors

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsqR_capabilties |
Public field | zlsqR_curPkt |
Public field | zlsqR_dlManu |
Public field | zlsqR_dlProd |
Public field | zlsqR_dlVer |
Public field | zlsqR_errorCode |
Public field | zlsqR_opManu |
Public field | zlsqR_opProd |
Public field | zlsqR_opVer |
Public field | zlsqR_protocolVer |
Public field | zlsqR_state |
Public field | zlsqR_totPkt |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE | Overloaded.
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE | Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE class.
Public method | SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, Byte, Byte, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16) |

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor ()

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE()
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE() sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE()
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE()

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor Overload List


SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, Byte, Byte, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16)

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor (Byte, Byte, SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, Byte, Byte, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, _
ByVal As SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE ,
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort
)
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE(
char ,
char ,
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE ,
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short
) sealed
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE(
byte ,
byte ,
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE ,
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE ,
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort
)
JScript
public function SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE(
: Byte,
: Byte,
: SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE,
: SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE,
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16
)

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Constructor Overload List


Fields

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsqR_capabilties |
Public field | zlsqR_curPkt |
Public field | zlsqR_dlManu |
Public field | zlsqR_dlProd |
Public field | zlsqR_dlVer |
Public field | zlsqR_errorCode |
Public field | zlsqR_opManu |
Public field | zlsqR_opProd |
Public field | zlsqR_opVer |
Public field | zlsqR_protocolVer |
Public field | zlsqR_state |
Public field | zlsqR_totPkt |
Top

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


Length Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.Length Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


Session Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.Session Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_capabilties Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_capabilties Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_capabilties As Byte
C#
public byte zlsqR_capabilties;
C++
public:
char zlsqR_capabilties sealed ;
J#
public byte zlsqR_capabilties
JScript
public zlsqR_capabilties : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_curPkt Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_curPkt Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_curPkt As UInt16
C#
public ushort zlsqR_curPkt;
C++
public:
unsigned short zlsqR_curPkt sealed ;
J#
public ushort zlsqR_curPkt
JScript
public zlsqR_curPkt : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_dlManu Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_dlManu Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_dlManu As UInt16
C#
public ushort zlsqR_dlManu;
C++
public:
unsigned short zlsqR_dlManu sealed ;
J#
public ushort zlsqR_dlManu
JScript
public zlsqR_dlManu : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_dlProd Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_dlProd Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_dlProd As UInt16
C#
public ushort zlsqR_dlProd;
C++
public:
unsigned short zlsqR_dlProd sealed ;
J#
public ushort zlsqR_dlProd
JScript
public zlsqR_dlProd : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_dlVer Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_dlVer Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_dlVer As UInt16
C#
public ushort zlsqR_dlVer;
C++
public:
unsigned short zlsqR_dlVer sealed ;
J#
public ushort zlsqR_dlVer
JScript
public zlsqR_dlVer : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_errorCode Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_errorCode As SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE zlsqR_errorCode;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE zlsqR_errorCode sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE zlsqR_errorCode
JScript
public zlsqR_errorCode : SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_opManu Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_opManu Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_opManu As UInt16
C#
public ushort zlsqR_opManu;
C++
public:
unsigned short zlsqR_opManu sealed ;
J#
public ushort zlsqR_opManu
JScript
public zlsqR_opManu : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_opProd Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_opProd Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_opProd As UInt16
C#
public ushort zlsqR_opProd;
C++
public:
unsigned short zlsqR_opProd sealed ;
J#
public ushort zlsqR_opProd
JScript
public zlsqR_opProd : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_opVer Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_opVer Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_opVer As UInt16
C#
public ushort zlsqR_opVer;
C++
public:
unsigned short zlsqR_opVer sealed ;
J#
public ushort zlsqR_opVer
JScript
public zlsqR_opVer : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_protocolVer Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_protocolVer Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_protocolVer As Byte
C#
public byte zlsqR_protocolVer;
C++
public:
char zlsqR_protocolVer sealed ;
J#
public byte zlsqR_protocolVer
JScript
public zlsqR_protocolVer : Byte;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_state Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_state Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_state As SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE
C#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE zlsqR_state;
C++
public:
SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE zlsqR_state sealed ;
J#
public SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE zlsqR_state
JScript
public zlsqR_state : SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


zlsqR_totPkt Field

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.zlsqR_totPkt Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_totPkt As UInt16
C#
public ushort zlsqR_totPkt;
C++
public:
unsigned short zlsqR_totPkt sealed ;
J#
public ushort zlsqR_totPkt
JScript
public zlsqR_totPkt : UInt16;

See Also

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE :

Members

Member Name | Description
NO_ERROR |

See Also

TI.ZPI1 Namespace


SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE Enumeration

SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE Class

SYS_CALLBACK_SUBSCRIBE Class
See Also Example Members
[image]

This command subscribes/unsubscribes to layer callbacks.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_CALLBACK_SUBSCRIBE
Implements IREQUEST, ISYSTEM
C#
public class SYS_CALLBACK_SUBSCRIBE : IREQUEST, ISYSTEM
C++
ref class SYS_CALLBACK_SUBSCRIBE : IREQUEST, ISYSTEM
J#
public class SYS_CALLBACK_SUBSCRIBE implements IREQUEST, ISYSTEM
JScript
public class SYS_CALLBACK_SUBSCRIBE extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_CALLBACK_SUBSCRIBE Members
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE Members

SYS_CALLBACK_SUBSCRIBE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command subscribes/unsubscribes to layer callbacks.

The following tables list the members exposed by SYS_CALLBACK_SUBSCRIBE.

Public Constructors

Name | Description
SYS_CALLBACK_SUBSCRIBE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Action | contains the action of the command
Public field | CommandID | contains the Command ID field of the expected callback message
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_CALLBACK_SUBSCRIBE | Overloaded.
Top

See Also

SYS_CALLBACK_SUBSCRIBE Class
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE Constructor

SYS_CALLBACK_SUBSCRIBE Constructor

Overload List

 | Name | Description
Public method | SYS_CALLBACK_SUBSCRIBE | Constructor
Public method | SYS_CALLBACK_SUBSCRIBE (UInt16, SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION) |

See Also

SYS_CALLBACK_SUBSCRIBE Class
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE Constructor ()

SYS_CALLBACK_SUBSCRIBE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_CALLBACK_SUBSCRIBE()
C++
public:
SYS_CALLBACK_SUBSCRIBE() sealed
J#
public SYS_CALLBACK_SUBSCRIBE()
JScript
public function SYS_CALLBACK_SUBSCRIBE()

See Also

SYS_CALLBACK_SUBSCRIBE Class
TI.ZPI1 Namespace
SYS_CALLBACK_SUBSCRIBE Constructor Overload List


SYS_CALLBACK_SUBSCRIBE Constructor (UInt16, SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION)

SYS_CALLBACK_SUBSCRIBE Constructor (UInt16, SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION _
)
C#
public SYS_CALLBACK_SUBSCRIBE(
ushort ,
SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION
)
C++
public:
SYS_CALLBACK_SUBSCRIBE(
unsigned short ,
SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION
) sealed
J#
public SYS_CALLBACK_SUBSCRIBE(
ushort ,
SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION
)
JScript
public function SYS_CALLBACK_SUBSCRIBE(
: UInt16,
: SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION
)

See Also

SYS_CALLBACK_SUBSCRIBE Class
TI.ZPI1 Namespace
SYS_CALLBACK_SUBSCRIBE Constructor Overload List


Fields

SYS_CALLBACK_SUBSCRIBE Fields
[image]

Public Fields

 | Name | Description
Public field | Action | contains the action of the command
Public field | CommandID | contains the Command ID field of the expected callback message
Top

See Also

SYS_CALLBACK_SUBSCRIBE Class
TI.ZPI1 Namespace


Action Field

SYS_CALLBACK_SUBSCRIBE.Action Field
[image]

contains the action of the command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Action As SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION
C#
public SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION Action;
C++
public:
SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION Action sealed ;
J#
public SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION Action
JScript
public Action : SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION;

See Also

SYS_CALLBACK_SUBSCRIBE Class
TI.ZPI1 Namespace


CommandID Field

SYS_CALLBACK_SUBSCRIBE.CommandID Field
[image]

contains the Command ID field of the expected callback message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandID As UInt16
C#
public ushort CommandID;
C++
public:
unsigned short CommandID sealed ;
J#
public ushort CommandID
JScript
public CommandID : UInt16;

See Also

SYS_CALLBACK_SUBSCRIBE Class
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION Enumeration

SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION Enumeration
[image]

Subscribe Action

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION As Byte
C#
public enum SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION : byte
C++
public enum class SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION : char
J#
public enum SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION byte
JScript
public enum SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION :

Members

Member Name | Description
UNSUBSCRIBE | Subscribe Action
SUBSCRIBE | Subscribe Action

See Also

TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE_RESPONSE Class

SYS_CALLBACK_SUBSCRIBE_RESPONSE Class
See Also Example Members
[image]

Response for SYS_CALLBACK_SUBSCRIBE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_CALLBACK_SUBSCRIBE_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_CALLBACK_SUBSCRIBE_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_CALLBACK_SUBSCRIBE_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_CALLBACK_SUBSCRIBE_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_CALLBACK_SUBSCRIBE_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_CALLBACK_SUBSCRIBE_RESPONSE Members
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE_RESPONSE Members

SYS_CALLBACK_SUBSCRIBE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_CALLBACK_SUBSCRIBE

The following tables list the members exposed by SYS_CALLBACK_SUBSCRIBE_RESPONSE.

Public Constructors

Name | Description
SYS_CALLBACK_SUBSCRIBE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_CALLBACK_SUBSCRIBE_RESPONSE | Overloaded.
Top

See Also

SYS_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor

SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_CALLBACK_SUBSCRIBE_RESPONSE | Constructor
Public method | SYS_CALLBACK_SUBSCRIBE_RESPONSE (SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS) |

See Also

SYS_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor ()

SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_CALLBACK_SUBSCRIBE_RESPONSE()
C++
public:
SYS_CALLBACK_SUBSCRIBE_RESPONSE() sealed
J#
public SYS_CALLBACK_SUBSCRIBE_RESPONSE()
JScript
public function SYS_CALLBACK_SUBSCRIBE_RESPONSE()

See Also

SYS_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI1 Namespace
SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor Overload List


SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor (SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS)

SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor (SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS _
)
C#
public SYS_CALLBACK_SUBSCRIBE_RESPONSE(
SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
)
C++
public:
SYS_CALLBACK_SUBSCRIBE_RESPONSE(
SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_CALLBACK_SUBSCRIBE_RESPONSE(
SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
)
JScript
public function SYS_CALLBACK_SUBSCRIBE_RESPONSE(
: SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
)

See Also

SYS_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI1 Namespace
SYS_CALLBACK_SUBSCRIBE_RESPONSE Constructor Overload List


Fields

SYS_CALLBACK_SUBSCRIBE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

SYS_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_CALLBACK_SUBSCRIBE_RESPONSE.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
C#
public SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS;

See Also

SYS_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI1 Namespace


SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Enumeration

SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS : char
J#
public enum SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO Class

SYS_GET_DEVICE_INFO Class
See Also Example Members
[image]

This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_DEVICE_INFO
Implements IREQUEST, ISYSTEM
C#
public class SYS_GET_DEVICE_INFO : IREQUEST, ISYSTEM
C++
ref class SYS_GET_DEVICE_INFO : IREQUEST, ISYSTEM
J#
public class SYS_GET_DEVICE_INFO implements IREQUEST, ISYSTEM
JScript
public class SYS_GET_DEVICE_INFO extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_DEVICE_INFO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_DEVICE_INFO Members
TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO Members

SYS_GET_DEVICE_INFO Members
See Also Example Constructors Methods
[image]

This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.

The following tables list the members exposed by SYS_GET_DEVICE_INFO.

Public Constructors

 | Name | Description
Public method | SYS_GET_DEVICE_INFO | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_GET_DEVICE_INFO Class
TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO Constructor

SYS_GET_DEVICE_INFO Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_DEVICE_INFO()
C++
public:
SYS_GET_DEVICE_INFO() sealed
J#
public SYS_GET_DEVICE_INFO()
JScript
public function SYS_GET_DEVICE_INFO()

See Also

SYS_GET_DEVICE_INFO Class
TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO_RESPONSE Class

SYS_GET_DEVICE_INFO_RESPONSE Class
See Also Example Members
[image]

Response for SYS_GET_DEVICE_INFO

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_DEVICE_INFO_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_GET_DEVICE_INFO_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_GET_DEVICE_INFO_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_GET_DEVICE_INFO_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_GET_DEVICE_INFO_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_DEVICE_INFO_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_DEVICE_INFO_RESPONSE Members
TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO_RESPONSE Members

SYS_GET_DEVICE_INFO_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_GET_DEVICE_INFO

The following tables list the members exposed by SYS_GET_DEVICE_INFO_RESPONSE.

Public Constructors

Name | Description
SYS_GET_DEVICE_INFO_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocDevicesList | Dynamic array, Assoc Devices List
Public field | DeviceState | Device Type
Public field | DeviceType | Bitmap byte field indicating device type, where bits 0 to 2 indicate the capability for the device to operate as a coordinator, router, or end device, respectively
Public field | IEEEAddr | IEEE Address
Public field | NumAssocDevices | Number Assoc Devices
Public field | ShortAddress | Short Address
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GET_DEVICE_INFO_RESPONSE | Overloaded.
Top

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO_RESPONSE Constructor

SYS_GET_DEVICE_INFO_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_GET_DEVICE_INFO_RESPONSE | Constructor
Public method | SYS_GET_DEVICE_INFO_RESPONSE (SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, UInt64, UInt16, SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, Byte, UInt16) |

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO_RESPONSE Constructor ()

SYS_GET_DEVICE_INFO_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_DEVICE_INFO_RESPONSE()
C++
public:
SYS_GET_DEVICE_INFO_RESPONSE() sealed
J#
public SYS_GET_DEVICE_INFO_RESPONSE()
JScript
public function SYS_GET_DEVICE_INFO_RESPONSE()

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_DEVICE_INFO_RESPONSE Constructor Overload List


SYS_GET_DEVICE_INFO_RESPONSE Constructor (SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, UInt64, UInt16, SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, Byte, UInt16[])

SYS_GET_DEVICE_INFO_RESPONSE Constructor (SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, UInt64, UInt16, SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, _
ByVal As SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public SYS_GET_DEVICE_INFO_RESPONSE(
SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS ,
ulong ,
ushort ,
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE ,
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE ,
byte ,
ushort[]
)
C++
public:
SYS_GET_DEVICE_INFO_RESPONSE(
SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS ,
unsigned __int64 ,
unsigned short ,
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE ,
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE ,
char ,
array<unsigned short>^
) sealed
J#
public SYS_GET_DEVICE_INFO_RESPONSE(
SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS ,
ulong ,
ushort ,
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE ,
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE ,
byte ,
ushort[]
)
JScript
public function SYS_GET_DEVICE_INFO_RESPONSE(
: SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS,
: UInt64,
: UInt16,
: SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE,
: SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE,
: Byte,
: UInt16[]
)

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_DEVICE_INFO_RESPONSE Constructor Overload List


Fields

SYS_GET_DEVICE_INFO_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | AssocDevicesList | Dynamic array, Assoc Devices List
Public field | DeviceState | Device Type
Public field | DeviceType | Bitmap byte field indicating device type, where bits 0 to 2 indicate the capability for the device to operate as a coordinator, router, or end device, respectively
Public field | IEEEAddr | IEEE Address
Public field | NumAssocDevices | Number Assoc Devices
Public field | ShortAddress | Short Address
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Top

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


AssocDevicesList Field

SYS_GET_DEVICE_INFO_RESPONSE.AssocDevicesList Field
[image]

Dynamic array, Assoc Devices List

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocDevicesList As UInt16()
C#
public ushort[] AssocDevicesList;
C++
public:
array<unsigned short>^ AssocDevicesList sealed ;
J#
public ushort[] AssocDevicesList
JScript
public AssocDevicesList : UInt16[];

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


DeviceState Field

SYS_GET_DEVICE_INFO_RESPONSE.DeviceState Field
[image]

Device Type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceState As SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE
C#
public SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE DeviceState;
C++
public:
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE DeviceState sealed ;
J#
public SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE DeviceState
JScript
public DeviceState : SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE;

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


DeviceType Field

SYS_GET_DEVICE_INFO_RESPONSE.DeviceType Field
[image]

Bitmap byte field indicating device type, where bits 0 to 2 indicate the capability for the device to operate as a coordinator, router, or end device, respectively

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceType As SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE
C#
public SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE DeviceType;
C++
public:
SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE DeviceType sealed ;
J#
public SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE DeviceType
JScript
public DeviceType : SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE;

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


IEEEAddr Field

SYS_GET_DEVICE_INFO_RESPONSE.IEEEAddr Field
[image]

IEEE Address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


NumAssocDevices Field

SYS_GET_DEVICE_INFO_RESPONSE.NumAssocDevices Field
[image]

Number Assoc Devices

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumAssocDevices As Byte
C#
public byte NumAssocDevices;
C++
public:
char NumAssocDevices sealed ;
J#
public byte NumAssocDevices
JScript
public NumAssocDevices : Byte;

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


ShortAddress Field

SYS_GET_DEVICE_INFO_RESPONSE.ShortAddress Field
[image]

Short Address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ShortAddress As UInt16
C#
public ushort ShortAddress;
C++
public:
unsigned short ShortAddress sealed ;
J#
public ushort ShortAddress
JScript
public ShortAddress : UInt16;

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_GET_DEVICE_INFO_RESPONSE.Status Field
[image]

The fail status is returned if the address value in the command message was not within the valid range.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS
C#
public SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS;

See Also

SYS_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Enumeration

SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS : char
J#
public enum SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE Enumeration

SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE Enumeration
[image]

Device state

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE As Byte
C#
public enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE : byte
C++
public enum class SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE : char
J#
public enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE byte
JScript
public enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE :

Members

Member Name | Description
DEV_HOLD | Device state
DEV_INIT | Device state
DEV_NWK_DISC | Device state
DEV_NWK_JOINING | Device state
DEV_NWK_REJOIN | Device state
DEV_END_DEVICE_UNAUTH | Device state
DEV_END_DEVICE | Device state
DEV_ROUTER | Device state
DEV_COORD_STARTING | Device state
DEV_ZB_COORD | Device state
DEV_NWK_ORPHAN | Device state

See Also

TI.ZPI1 Namespace


SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE Enumeration

SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE Enumeration
[image]

Device type bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE As Byte
C#
[FlagsAttribute]
public enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE : byte
C++
[FlagsAttribute]
public enum class SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE : char
J#
/** @attribute FlagsAttribute() */
public enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE byte
JScript
public enum SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE :

Members

Member Name | Description | Value
NONE | Device type bitfield | 0
COORDINATOR | Device type bitfield | 1
ROUTER | Device type bitfield | 2
END_DEVICE | Device type bitfield | 4

See Also

TI.ZPI1 Namespace


SYS_GET_EXTENDED_ADDRESS Class

SYS_GET_EXTENDED_ADDRESS Class
See Also Example Members
[image]

Read the extended address from the device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_EXTENDED_ADDRESS
Implements IREQUEST, ISYSTEM
C#
public class SYS_GET_EXTENDED_ADDRESS : IREQUEST, ISYSTEM
C++
ref class SYS_GET_EXTENDED_ADDRESS : IREQUEST, ISYSTEM
J#
public class SYS_GET_EXTENDED_ADDRESS implements IREQUEST, ISYSTEM
JScript
public class SYS_GET_EXTENDED_ADDRESS extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_EXTENDED_ADDRESS Members
TI.ZPI1 Namespace


SYS_GET_EXTENDED_ADDRESS Members

SYS_GET_EXTENDED_ADDRESS Members
See Also Example Constructors Methods
[image]

Read the extended address from the device.

The following tables list the members exposed by SYS_GET_EXTENDED_ADDRESS.

Public Constructors

 | Name | Description
Public method | SYS_GET_EXTENDED_ADDRESS | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_GET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace


SYS_GET_EXTENDED_ADDRESS Constructor

SYS_GET_EXTENDED_ADDRESS Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_EXTENDED_ADDRESS()
C++
public:
SYS_GET_EXTENDED_ADDRESS() sealed
J#
public SYS_GET_EXTENDED_ADDRESS()
JScript
public function SYS_GET_EXTENDED_ADDRESS()

See Also

SYS_GET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace


SYS_GET_EXTENDED_ADDRESS_RESPONSE Class

SYS_GET_EXTENDED_ADDRESS_RESPONSE Class
See Also Example Members
[image]

Response for SYS_GET_EXTENDED_ADDRESS

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_EXTENDED_ADDRESS_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_GET_EXTENDED_ADDRESS_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_GET_EXTENDED_ADDRESS_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_GET_EXTENDED_ADDRESS_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_GET_EXTENDED_ADDRESS_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_EXTENDED_ADDRESS_RESPONSE Members
TI.ZPI1 Namespace


SYS_GET_EXTENDED_ADDRESS_RESPONSE Members

SYS_GET_EXTENDED_ADDRESS_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_GET_EXTENDED_ADDRESS

The following tables list the members exposed by SYS_GET_EXTENDED_ADDRESS_RESPONSE.

Public Constructors

Name | Description
SYS_GET_EXTENDED_ADDRESS_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Address | The device's extended address
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GET_EXTENDED_ADDRESS_RESPONSE | Overloaded.
Top

See Also

SYS_GET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor

SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_GET_EXTENDED_ADDRESS_RESPONSE | Constructor
Public method | SYS_GET_EXTENDED_ADDRESS_RESPONSE (UInt64) | Constructor

See Also

SYS_GET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor ()

SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_EXTENDED_ADDRESS_RESPONSE()
C++
public:
SYS_GET_EXTENDED_ADDRESS_RESPONSE() sealed
J#
public SYS_GET_EXTENDED_ADDRESS_RESPONSE()
JScript
public function SYS_GET_EXTENDED_ADDRESS_RESPONSE()

See Also

SYS_GET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor Overload List


SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor (UInt64)

SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public SYS_GET_EXTENDED_ADDRESS_RESPONSE(
ulong
)
C++
public:
SYS_GET_EXTENDED_ADDRESS_RESPONSE(
unsigned __int64
) sealed
J#
public SYS_GET_EXTENDED_ADDRESS_RESPONSE(
ulong
)
JScript
public function SYS_GET_EXTENDED_ADDRESS_RESPONSE(
: UInt64
)

See Also

SYS_GET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_EXTENDED_ADDRESS_RESPONSE Constructor Overload List


Fields

SYS_GET_EXTENDED_ADDRESS_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Address | The device's extended address
Top

See Also

SYS_GET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


Address Field

SYS_GET_EXTENDED_ADDRESS_RESPONSE.Address Field
[image]

The device's extended address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Address As UInt64
C#
public ulong Address;
C++
public:
unsigned __int64 Address sealed ;
J#
public ulong Address
JScript
public Address : UInt64;

See Also

SYS_GET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_NV Class

SYS_GET_NV Class
See Also Example Members
[image]

This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_NV
Implements IREQUEST, ISYSTEM
C#
public class SYS_GET_NV : IREQUEST, ISYSTEM
C++
ref class SYS_GET_NV : IREQUEST, ISYSTEM
J#
public class SYS_GET_NV implements IREQUEST, ISYSTEM
JScript
public class SYS_GET_NV extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_NV

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_NV Members
TI.ZPI1 Namespace


SYS_GET_NV Members

SYS_GET_NV Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.

The following tables list the members exposed by SYS_GET_NV.

Public Constructors

Name | Description
SYS_GET_NV | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | contains the location that needs to be read
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GET_NV | Overloaded.
Top

See Also

SYS_GET_NV Class
TI.ZPI1 Namespace


SYS_GET_NV Constructor

SYS_GET_NV Constructor

Overload List

 | Name | Description
Public method | SYS_GET_NV | Constructor
Public method | SYS_GET_NV (Byte) | Constructor

See Also

SYS_GET_NV Class
TI.ZPI1 Namespace


SYS_GET_NV Constructor ()

SYS_GET_NV Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_NV()
C++
public:
SYS_GET_NV() sealed
J#
public SYS_GET_NV()
JScript
public function SYS_GET_NV()

See Also

SYS_GET_NV Class
TI.ZPI1 Namespace
SYS_GET_NV Constructor Overload List


SYS_GET_NV Constructor (Byte)

SYS_GET_NV Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_GET_NV(
byte
)
C++
public:
SYS_GET_NV(
char
) sealed
J#
public SYS_GET_NV(
byte
)
JScript
public function SYS_GET_NV(
: Byte
)

See Also

SYS_GET_NV Class
TI.ZPI1 Namespace
SYS_GET_NV Constructor Overload List


Fields

SYS_GET_NV Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | contains the location that needs to be read
Top

See Also

SYS_GET_NV Class
TI.ZPI1 Namespace


Attribute Field

SYS_GET_NV.Attribute Field
[image]

contains the location that needs to be read

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As Byte
C#
public byte Attribute;
C++
public:
char Attribute sealed ;
J#
public byte Attribute
JScript
public Attribute : Byte;

See Also

SYS_GET_NV Class
TI.ZPI1 Namespace


SYS_GET_NV_INFO Class

SYS_GET_NV_INFO Class
See Also Example Members
[image]

Use this message to get the NV information.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_NV_INFO
Implements IREQUEST, ISYSTEM
C#
public class SYS_GET_NV_INFO : IREQUEST, ISYSTEM
C++
ref class SYS_GET_NV_INFO : IREQUEST, ISYSTEM
J#
public class SYS_GET_NV_INFO implements IREQUEST, ISYSTEM
JScript
public class SYS_GET_NV_INFO extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_NV_INFO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_NV_INFO Members
TI.ZPI1 Namespace


SYS_GET_NV_INFO Members

SYS_GET_NV_INFO Members
See Also Example Constructors Methods
[image]

Use this message to get the NV information.

The following tables list the members exposed by SYS_GET_NV_INFO.

Public Constructors

 | Name | Description
Public method | SYS_GET_NV_INFO | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_GET_NV_INFO Class
TI.ZPI1 Namespace


SYS_GET_NV_INFO Constructor

SYS_GET_NV_INFO Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_NV_INFO()
C++
public:
SYS_GET_NV_INFO() sealed
J#
public SYS_GET_NV_INFO()
JScript
public function SYS_GET_NV_INFO()

See Also

SYS_GET_NV_INFO Class
TI.ZPI1 Namespace


SYS_GET_NV_INFO_RESPONSE Class

SYS_GET_NV_INFO_RESPONSE Class
See Also Example Members
[image]

Response for SYS_GET_NV_INFO

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_NV_INFO_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_GET_NV_INFO_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_GET_NV_INFO_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_GET_NV_INFO_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_GET_NV_INFO_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_NV_INFO_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_NV_INFO_RESPONSE Members
TI.ZPI1 Namespace


SYS_GET_NV_INFO_RESPONSE Members

SYS_GET_NV_INFO_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_GET_NV_INFO

The following tables list the members exposed by SYS_GET_NV_INFO_RESPONSE.

Public Constructors

Name | Description
SYS_GET_NV_INFO_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEAddress | IEEE Address
Public field | PanID | Pan ID
Public field | PreConfigKey | PreConfigKey
Public field | ScanChannels | Scan Channels
Public field | SecurityMode | This specifies the network messaging security mode, zero disables security
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GET_NV_INFO_RESPONSE | Overloaded.
Top

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_NV_INFO_RESPONSE Constructor

SYS_GET_NV_INFO_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_GET_NV_INFO_RESPONSE | Constructor
Public method | SYS_GET_NV_INFO_RESPONSE (SYS_GET_NV_INFO_RESPONSE.CMD_STATUS, UInt64, SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, UInt16, Byte, Byte) |

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_NV_INFO_RESPONSE Constructor ()

SYS_GET_NV_INFO_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_NV_INFO_RESPONSE()
C++
public:
SYS_GET_NV_INFO_RESPONSE() sealed
J#
public SYS_GET_NV_INFO_RESPONSE()
JScript
public function SYS_GET_NV_INFO_RESPONSE()

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_NV_INFO_RESPONSE Constructor Overload List


SYS_GET_NV_INFO_RESPONSE Constructor (SYS_GET_NV_INFO_RESPONSE.CMD_STATUS, UInt64, SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, UInt16, Byte, Byte[])

SYS_GET_NV_INFO_RESPONSE Constructor (SYS_GET_NV_INFO_RESPONSE.CMD_STATUS, UInt64, SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_GET_NV_INFO_RESPONSE.CMD_STATUS, _
ByVal As UInt64, _
ByVal As SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public SYS_GET_NV_INFO_RESPONSE(
SYS_GET_NV_INFO_RESPONSE.CMD_STATUS ,
ulong ,
SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ,
ushort ,
byte ,
byte[]
)
C++
public:
SYS_GET_NV_INFO_RESPONSE(
SYS_GET_NV_INFO_RESPONSE.CMD_STATUS ,
unsigned __int64 ,
SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public SYS_GET_NV_INFO_RESPONSE(
SYS_GET_NV_INFO_RESPONSE.CMD_STATUS ,
ulong ,
SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ,
ushort ,
byte ,
byte[]
)
JScript
public function SYS_GET_NV_INFO_RESPONSE(
: SYS_GET_NV_INFO_RESPONSE.CMD_STATUS,
: UInt64,
: SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS,
: UInt16,
: Byte,
: Byte[]
)

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_NV_INFO_RESPONSE Constructor Overload List


Fields

SYS_GET_NV_INFO_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEAddress | IEEE Address
Public field | PanID | Pan ID
Public field | PreConfigKey | PreConfigKey
Public field | ScanChannels | Scan Channels
Public field | SecurityMode | This specifies the network messaging security mode, zero disables security
Public field | Status | Status
Top

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


IEEEAddress Field

SYS_GET_NV_INFO_RESPONSE.IEEEAddress Field
[image]

IEEE Address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddress As UInt64
C#
public ulong IEEEAddress;
C++
public:
unsigned __int64 IEEEAddress sealed ;
J#
public ulong IEEEAddress
JScript
public IEEEAddress : UInt64;

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


PanID Field

SYS_GET_NV_INFO_RESPONSE.PanID Field
[image]

Pan ID

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


PreConfigKey Field

SYS_GET_NV_INFO_RESPONSE.PreConfigKey Field
[image]

PreConfigKey

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PreConfigKey As Byte()
C#
public byte[] PreConfigKey;
C++
public:
array<char>^ PreConfigKey sealed ;
J#
public byte[] PreConfigKey
JScript
public PreConfigKey : Byte[];

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


ScanChannels Field

SYS_GET_NV_INFO_RESPONSE.ScanChannels Field
[image]

Scan Channels

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS
C#
public SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ScanChannels;
C++
public:
SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS;

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


SecurityMode Field

SYS_GET_NV_INFO_RESPONSE.SecurityMode Field
[image]

This specifies the network messaging security mode, zero disables security

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityMode As Byte
C#
public byte SecurityMode;
C++
public:
char SecurityMode sealed ;
J#
public byte SecurityMode
JScript
public SecurityMode : Byte;

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_GET_NV_INFO_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_GET_NV_INFO_RESPONSE.CMD_STATUS
C#
public SYS_GET_NV_INFO_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_GET_NV_INFO_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_GET_NV_INFO_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_GET_NV_INFO_RESPONSE.CMD_STATUS;

See Also

SYS_GET_NV_INFO_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_NV_INFO_RESPONSE.CMD_STATUS Enumeration

SYS_GET_NV_INFO_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_GET_NV_INFO_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_GET_NV_INFO_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_GET_NV_INFO_RESPONSE.CMD_STATUS : char
J#
public enum SYS_GET_NV_INFO_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_GET_NV_INFO_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS Enumeration

SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS uint
JScript
public enum SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


SYS_GET_NV_RESPONSE Class

SYS_GET_NV_RESPONSE Class
See Also Example Members
[image]

Response for SYS_GET_NV

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_NV_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_GET_NV_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_GET_NV_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_GET_NV_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_GET_NV_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_NV_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_NV_RESPONSE Members
TI.ZPI1 Namespace


SYS_GET_NV_RESPONSE Members

SYS_GET_NV_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_GET_NV

The following tables list the members exposed by SYS_GET_NV_RESPONSE.

Public Constructors

Name | Description
SYS_GET_NV_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | indicates the location that is to be written.
Public field | Len | The length of the array containing the attribute value.
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Public field | Value | Dynamic array, contains the data read from the target.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GET_NV_RESPONSE | Overloaded.
Top

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_NV_RESPONSE Constructor

SYS_GET_NV_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_GET_NV_RESPONSE | Constructor
Public method | SYS_GET_NV_RESPONSE (SYS_GET_NV_RESPONSE.CMD_STATUS, Byte, Byte, Byte) |

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_NV_RESPONSE Constructor ()

SYS_GET_NV_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_NV_RESPONSE()
C++
public:
SYS_GET_NV_RESPONSE() sealed
J#
public SYS_GET_NV_RESPONSE()
JScript
public function SYS_GET_NV_RESPONSE()

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_NV_RESPONSE Constructor Overload List


SYS_GET_NV_RESPONSE Constructor (SYS_GET_NV_RESPONSE.CMD_STATUS, Byte, Byte, Byte[])

SYS_GET_NV_RESPONSE Constructor (SYS_GET_NV_RESPONSE.CMD_STATUS, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_GET_NV_RESPONSE.CMD_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public SYS_GET_NV_RESPONSE(
SYS_GET_NV_RESPONSE.CMD_STATUS ,
byte ,
byte ,
byte[]
)
C++
public:
SYS_GET_NV_RESPONSE(
SYS_GET_NV_RESPONSE.CMD_STATUS ,
char ,
char ,
array<char>^
) sealed
J#
public SYS_GET_NV_RESPONSE(
SYS_GET_NV_RESPONSE.CMD_STATUS ,
byte ,
byte ,
byte[]
)
JScript
public function SYS_GET_NV_RESPONSE(
: SYS_GET_NV_RESPONSE.CMD_STATUS,
: Byte,
: Byte,
: Byte[]
)

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_NV_RESPONSE Constructor Overload List


Fields

SYS_GET_NV_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | indicates the location that is to be written.
Public field | Len | The length of the array containing the attribute value.
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Public field | Value | Dynamic array, contains the data read from the target.
Top

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace


Attribute Field

SYS_GET_NV_RESPONSE.Attribute Field
[image]

indicates the location that is to be written.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As Byte
C#
public byte Attribute;
C++
public:
char Attribute sealed ;
J#
public byte Attribute
JScript
public Attribute : Byte;

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace


Len Field

SYS_GET_NV_RESPONSE.Len Field
[image]

The length of the array containing the attribute value.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_GET_NV_RESPONSE.Status Field
[image]

The fail status is returned if the address value in the command message was not within the valid range.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_GET_NV_RESPONSE.CMD_STATUS
C#
public SYS_GET_NV_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_GET_NV_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_GET_NV_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_GET_NV_RESPONSE.CMD_STATUS;

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace


Value Field

SYS_GET_NV_RESPONSE.Value Field
[image]

Dynamic array, contains the data read from the target.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

SYS_GET_NV_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_NV_RESPONSE.CMD_STATUS Enumeration

SYS_GET_NV_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_GET_NV_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_GET_NV_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_GET_NV_RESPONSE.CMD_STATUS : char
J#
public enum SYS_GET_NV_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_GET_NV_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_GET_TIME_ALIVE Class

SYS_GET_TIME_ALIVE Class
See Also Example Members
[image]

Use this message to get board's time alive.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_TIME_ALIVE
Implements IREQUEST, ISYSTEM
C#
public class SYS_GET_TIME_ALIVE : IREQUEST, ISYSTEM
C++
ref class SYS_GET_TIME_ALIVE : IREQUEST, ISYSTEM
J#
public class SYS_GET_TIME_ALIVE implements IREQUEST, ISYSTEM
JScript
public class SYS_GET_TIME_ALIVE extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_TIME_ALIVE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_TIME_ALIVE Members
TI.ZPI1 Namespace


SYS_GET_TIME_ALIVE Members

SYS_GET_TIME_ALIVE Members
See Also Example Constructors Methods
[image]

Use this message to get board's time alive.

The following tables list the members exposed by SYS_GET_TIME_ALIVE.

Public Constructors

 | Name | Description
Public method | SYS_GET_TIME_ALIVE | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_GET_TIME_ALIVE Class
TI.ZPI1 Namespace


SYS_GET_TIME_ALIVE Constructor

SYS_GET_TIME_ALIVE Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_TIME_ALIVE()
C++
public:
SYS_GET_TIME_ALIVE() sealed
J#
public SYS_GET_TIME_ALIVE()
JScript
public function SYS_GET_TIME_ALIVE()

See Also

SYS_GET_TIME_ALIVE Class
TI.ZPI1 Namespace


SYS_GET_TIME_ALIVE_RESPONSE Class

SYS_GET_TIME_ALIVE_RESPONSE Class
See Also Example Members
[image]

Response for SYS_GET_TIME_ALIVE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_TIME_ALIVE_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_GET_TIME_ALIVE_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_GET_TIME_ALIVE_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_GET_TIME_ALIVE_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_GET_TIME_ALIVE_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_GET_TIME_ALIVE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_TIME_ALIVE_RESPONSE Members
TI.ZPI1 Namespace


SYS_GET_TIME_ALIVE_RESPONSE Members

SYS_GET_TIME_ALIVE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_GET_TIME_ALIVE

The following tables list the members exposed by SYS_GET_TIME_ALIVE_RESPONSE.

Public Constructors

Name | Description
SYS_GET_TIME_ALIVE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Seconds | Seconds
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GET_TIME_ALIVE_RESPONSE | Overloaded.
Top

See Also

SYS_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_TIME_ALIVE_RESPONSE Constructor

SYS_GET_TIME_ALIVE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_GET_TIME_ALIVE_RESPONSE | Constructor
Public method | SYS_GET_TIME_ALIVE_RESPONSE (UInt32) | Constructor

See Also

SYS_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI1 Namespace


SYS_GET_TIME_ALIVE_RESPONSE Constructor ()

SYS_GET_TIME_ALIVE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_TIME_ALIVE_RESPONSE()
C++
public:
SYS_GET_TIME_ALIVE_RESPONSE() sealed
J#
public SYS_GET_TIME_ALIVE_RESPONSE()
JScript
public function SYS_GET_TIME_ALIVE_RESPONSE()

See Also

SYS_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_TIME_ALIVE_RESPONSE Constructor Overload List


SYS_GET_TIME_ALIVE_RESPONSE Constructor (UInt32)

SYS_GET_TIME_ALIVE_RESPONSE Constructor (UInt32)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt32 _
)
C#
public SYS_GET_TIME_ALIVE_RESPONSE(
uint
)
C++
public:
SYS_GET_TIME_ALIVE_RESPONSE(
unsigned int
) sealed
J#
public SYS_GET_TIME_ALIVE_RESPONSE(
uint
)
JScript
public function SYS_GET_TIME_ALIVE_RESPONSE(
: UInt32
)

See Also

SYS_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI1 Namespace
SYS_GET_TIME_ALIVE_RESPONSE Constructor Overload List


Fields

SYS_GET_TIME_ALIVE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Seconds | Seconds
Top

See Also

SYS_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI1 Namespace


Seconds Field

SYS_GET_TIME_ALIVE_RESPONSE.Seconds Field
[image]

Seconds

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Seconds As UInt32
C#
public uint Seconds;
C++
public:
unsigned int Seconds sealed ;
J#
public uint Seconds
JScript
public Seconds : UInt32;

See Also

SYS_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI1 Namespace


SYS_KEY_EVENT Class

SYS_KEY_EVENT Class
See Also Example Members
[image]

Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_KEY_EVENT
Implements IREQUEST, ISYSTEM
C#
public class SYS_KEY_EVENT : IREQUEST, ISYSTEM
C++
ref class SYS_KEY_EVENT : IREQUEST, ISYSTEM
J#
public class SYS_KEY_EVENT implements IREQUEST, ISYSTEM
JScript
public class SYS_KEY_EVENT extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_KEY_EVENT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_KEY_EVENT Members
TI.ZPI1 Namespace


SYS_KEY_EVENT Members

SYS_KEY_EVENT Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.

The following tables list the members exposed by SYS_KEY_EVENT.

Public Constructors

Name | Description
SYS_KEY_EVENT | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Key | byte field with bit values for the keys
Public field | Shift | True (0x01) means that the shift was enabled
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_KEY_EVENT | Overloaded.
Top

See Also

SYS_KEY_EVENT Class
TI.ZPI1 Namespace


SYS_KEY_EVENT Constructor

SYS_KEY_EVENT Constructor

Overload List

 | Name | Description
Public method | SYS_KEY_EVENT | Constructor
Public method | SYS_KEY_EVENT (SYS_KEY_EVENT.BOOLEAN, SYS_KEY_EVENT.KEY_EVENT) |

See Also

SYS_KEY_EVENT Class
TI.ZPI1 Namespace


SYS_KEY_EVENT Constructor ()

SYS_KEY_EVENT Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_KEY_EVENT()
C++
public:
SYS_KEY_EVENT() sealed
J#
public SYS_KEY_EVENT()
JScript
public function SYS_KEY_EVENT()

See Also

SYS_KEY_EVENT Class
TI.ZPI1 Namespace
SYS_KEY_EVENT Constructor Overload List


SYS_KEY_EVENT Constructor (SYS_KEY_EVENT.BOOLEAN, SYS_KEY_EVENT.KEY_EVENT)

SYS_KEY_EVENT Constructor (SYS_KEY_EVENT.BOOLEAN, SYS_KEY_EVENT.KEY_EVENT)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_KEY_EVENT.BOOLEAN, _
ByVal As SYS_KEY_EVENT.KEY_EVENT _
)
C#
public SYS_KEY_EVENT(
SYS_KEY_EVENT.BOOLEAN ,
SYS_KEY_EVENT.KEY_EVENT
)
C++
public:
SYS_KEY_EVENT(
SYS_KEY_EVENT.BOOLEAN ,
SYS_KEY_EVENT.KEY_EVENT
) sealed
J#
public SYS_KEY_EVENT(
SYS_KEY_EVENT.BOOLEAN ,
SYS_KEY_EVENT.KEY_EVENT
)
JScript
public function SYS_KEY_EVENT(
: SYS_KEY_EVENT.BOOLEAN,
: SYS_KEY_EVENT.KEY_EVENT
)

See Also

SYS_KEY_EVENT Class
TI.ZPI1 Namespace
SYS_KEY_EVENT Constructor Overload List


Fields

SYS_KEY_EVENT Fields
[image]

Public Fields

 | Name | Description
Public field | Key | byte field with bit values for the keys
Public field | Shift | True (0x01) means that the shift was enabled
Top

See Also

SYS_KEY_EVENT Class
TI.ZPI1 Namespace


Key Field

SYS_KEY_EVENT.Key Field
[image]

byte field with bit values for the keys

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Key As SYS_KEY_EVENT.KEY_EVENT
C#
public SYS_KEY_EVENT.KEY_EVENT Key;
C++
public:
SYS_KEY_EVENT.KEY_EVENT Key sealed ;
J#
public SYS_KEY_EVENT.KEY_EVENT Key
JScript
public Key : SYS_KEY_EVENT.KEY_EVENT;

See Also

SYS_KEY_EVENT Class
TI.ZPI1 Namespace


Shift Field

SYS_KEY_EVENT.Shift Field
[image]

True (0x01) means that the shift was enabled

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Shift As SYS_KEY_EVENT.BOOLEAN
C#
public SYS_KEY_EVENT.BOOLEAN Shift;
C++
public:
SYS_KEY_EVENT.BOOLEAN Shift sealed ;
J#
public SYS_KEY_EVENT.BOOLEAN Shift
JScript
public Shift : SYS_KEY_EVENT.BOOLEAN;

See Also

SYS_KEY_EVENT Class
TI.ZPI1 Namespace


SYS_KEY_EVENT.BOOLEAN Enumeration

SYS_KEY_EVENT.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_KEY_EVENT.BOOLEAN As Byte
C#
public enum SYS_KEY_EVENT.BOOLEAN : byte
C++
public enum class SYS_KEY_EVENT.BOOLEAN : char
J#
public enum SYS_KEY_EVENT.BOOLEAN byte
JScript
public enum SYS_KEY_EVENT.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI1 Namespace


SYS_KEY_EVENT.KEY_EVENT Enumeration

SYS_KEY_EVENT.KEY_EVENT Enumeration
[image]

Key event

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_KEY_EVENT.KEY_EVENT As Byte
C#
public enum SYS_KEY_EVENT.KEY_EVENT : byte
C++
public enum class SYS_KEY_EVENT.KEY_EVENT : char
J#
public enum SYS_KEY_EVENT.KEY_EVENT byte
JScript
public enum SYS_KEY_EVENT.KEY_EVENT :

Members

Member Name | Description
KEY_1 | Key event
KEY_2 | Key event
KEY_3 | Key event
KEY_4 | Key event
KEY_5 | Key event
KEY_6 | Key event
KEY_7 | Key event
KEY_8 | Key event

See Also

TI.ZPI1 Namespace


SYS_KEY_EVENT_RESPONSE Class

SYS_KEY_EVENT_RESPONSE Class
See Also Example Members
[image]

Response for SYS_KEY_EVENT

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_KEY_EVENT_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_KEY_EVENT_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_KEY_EVENT_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_KEY_EVENT_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_KEY_EVENT_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_KEY_EVENT_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_KEY_EVENT_RESPONSE Members
TI.ZPI1 Namespace


SYS_KEY_EVENT_RESPONSE Members

SYS_KEY_EVENT_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_KEY_EVENT

The following tables list the members exposed by SYS_KEY_EVENT_RESPONSE.

Public Constructors

Name | Description
SYS_KEY_EVENT_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_KEY_EVENT_RESPONSE | Overloaded.
Top

See Also

SYS_KEY_EVENT_RESPONSE Class
TI.ZPI1 Namespace


SYS_KEY_EVENT_RESPONSE Constructor

SYS_KEY_EVENT_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_KEY_EVENT_RESPONSE | Constructor
Public method | SYS_KEY_EVENT_RESPONSE (SYS_KEY_EVENT_RESPONSE.CMD_STATUS) |

See Also

SYS_KEY_EVENT_RESPONSE Class
TI.ZPI1 Namespace


SYS_KEY_EVENT_RESPONSE Constructor ()

SYS_KEY_EVENT_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_KEY_EVENT_RESPONSE()
C++
public:
SYS_KEY_EVENT_RESPONSE() sealed
J#
public SYS_KEY_EVENT_RESPONSE()
JScript
public function SYS_KEY_EVENT_RESPONSE()

See Also

SYS_KEY_EVENT_RESPONSE Class
TI.ZPI1 Namespace
SYS_KEY_EVENT_RESPONSE Constructor Overload List


SYS_KEY_EVENT_RESPONSE Constructor (SYS_KEY_EVENT_RESPONSE.CMD_STATUS)

SYS_KEY_EVENT_RESPONSE Constructor (SYS_KEY_EVENT_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_KEY_EVENT_RESPONSE.CMD_STATUS _
)
C#
public SYS_KEY_EVENT_RESPONSE(
SYS_KEY_EVENT_RESPONSE.CMD_STATUS
)
C++
public:
SYS_KEY_EVENT_RESPONSE(
SYS_KEY_EVENT_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_KEY_EVENT_RESPONSE(
SYS_KEY_EVENT_RESPONSE.CMD_STATUS
)
JScript
public function SYS_KEY_EVENT_RESPONSE(
: SYS_KEY_EVENT_RESPONSE.CMD_STATUS
)

See Also

SYS_KEY_EVENT_RESPONSE Class
TI.ZPI1 Namespace
SYS_KEY_EVENT_RESPONSE Constructor Overload List


Fields

SYS_KEY_EVENT_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_KEY_EVENT_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_KEY_EVENT_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_KEY_EVENT_RESPONSE.CMD_STATUS
C#
public SYS_KEY_EVENT_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_KEY_EVENT_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_KEY_EVENT_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_KEY_EVENT_RESPONSE.CMD_STATUS;

See Also

SYS_KEY_EVENT_RESPONSE Class
TI.ZPI1 Namespace


SYS_KEY_EVENT_RESPONSE.CMD_STATUS Enumeration

SYS_KEY_EVENT_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_KEY_EVENT_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_KEY_EVENT_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_KEY_EVENT_RESPONSE.CMD_STATUS : char
J#
public enum SYS_KEY_EVENT_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_KEY_EVENT_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_LED_CONTROL Class

SYS_LED_CONTROL Class
See Also Example Members
[image]

Use this message to control LEDs on the board.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_LED_CONTROL
Implements IREQUEST, ISYSTEM
C#
public class SYS_LED_CONTROL : IREQUEST, ISYSTEM
C++
ref class SYS_LED_CONTROL : IREQUEST, ISYSTEM
J#
public class SYS_LED_CONTROL implements IREQUEST, ISYSTEM
JScript
public class SYS_LED_CONTROL extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_LED_CONTROL

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_LED_CONTROL Members
TI.ZPI1 Namespace


SYS_LED_CONTROL Members

SYS_LED_CONTROL Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to control LEDs on the board.

The following tables list the members exposed by SYS_LED_CONTROL.

Public Constructors

Name | Description
SYS_LED_CONTROL | Overloaded.
Top

Public Fields

 | Name | Description
Public field | LedID | The ID of the LED to be controlled
Public field | Mode | Mode to set the LED to
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_LED_CONTROL | Overloaded.
Top

See Also

SYS_LED_CONTROL Class
TI.ZPI1 Namespace


SYS_LED_CONTROL Constructor

SYS_LED_CONTROL Constructor

Overload List

 | Name | Description
Public method | SYS_LED_CONTROL | Constructor
Public method | SYS_LED_CONTROL (SYS_LED_CONTROL.LED_NUM, SYS_LED_CONTROL.LED_MODE) |

See Also

SYS_LED_CONTROL Class
TI.ZPI1 Namespace


SYS_LED_CONTROL Constructor ()

SYS_LED_CONTROL Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_LED_CONTROL()
C++
public:
SYS_LED_CONTROL() sealed
J#
public SYS_LED_CONTROL()
JScript
public function SYS_LED_CONTROL()

See Also

SYS_LED_CONTROL Class
TI.ZPI1 Namespace
SYS_LED_CONTROL Constructor Overload List


SYS_LED_CONTROL Constructor (SYS_LED_CONTROL.LED_NUM, SYS_LED_CONTROL.LED_MODE)

SYS_LED_CONTROL Constructor (SYS_LED_CONTROL.LED_NUM, SYS_LED_CONTROL.LED_MODE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_LED_CONTROL.LED_NUM, _
ByVal As SYS_LED_CONTROL.LED_MODE _
)
C#
public SYS_LED_CONTROL(
SYS_LED_CONTROL.LED_NUM ,
SYS_LED_CONTROL.LED_MODE
)
C++
public:
SYS_LED_CONTROL(
SYS_LED_CONTROL.LED_NUM ,
SYS_LED_CONTROL.LED_MODE
) sealed
J#
public SYS_LED_CONTROL(
SYS_LED_CONTROL.LED_NUM ,
SYS_LED_CONTROL.LED_MODE
)
JScript
public function SYS_LED_CONTROL(
: SYS_LED_CONTROL.LED_NUM,
: SYS_LED_CONTROL.LED_MODE
)

See Also

SYS_LED_CONTROL Class
TI.ZPI1 Namespace
SYS_LED_CONTROL Constructor Overload List


Fields

SYS_LED_CONTROL Fields
[image]

Public Fields

 | Name | Description
Public field | LedID | The ID of the LED to be controlled
Public field | Mode | Mode to set the LED to
Top

See Also

SYS_LED_CONTROL Class
TI.ZPI1 Namespace


LedID Field

SYS_LED_CONTROL.LedID Field
[image]

The ID of the LED to be controlled

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LedID As SYS_LED_CONTROL.LED_NUM
C#
public SYS_LED_CONTROL.LED_NUM LedID;
C++
public:
SYS_LED_CONTROL.LED_NUM LedID sealed ;
J#
public SYS_LED_CONTROL.LED_NUM LedID
JScript
public LedID : SYS_LED_CONTROL.LED_NUM;

See Also

SYS_LED_CONTROL Class
TI.ZPI1 Namespace


Mode Field

SYS_LED_CONTROL.Mode Field
[image]

Mode to set the LED to

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As SYS_LED_CONTROL.LED_MODE
C#
public SYS_LED_CONTROL.LED_MODE Mode;
C++
public:
SYS_LED_CONTROL.LED_MODE Mode sealed ;
J#
public SYS_LED_CONTROL.LED_MODE Mode
JScript
public Mode : SYS_LED_CONTROL.LED_MODE;

See Also

SYS_LED_CONTROL Class
TI.ZPI1 Namespace


SYS_LED_CONTROL.LED_MODE Enumeration

SYS_LED_CONTROL.LED_MODE Enumeration
[image]

Mode of the LED

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_LED_CONTROL.LED_MODE As Byte
C#
public enum SYS_LED_CONTROL.LED_MODE : byte
C++
public enum class SYS_LED_CONTROL.LED_MODE : char
J#
public enum SYS_LED_CONTROL.LED_MODE byte
JScript
public enum SYS_LED_CONTROL.LED_MODE :

Members

Member Name | Description
LED_OFF | Mode of the LED
LED_ON | Mode of the LED
BLINK | Mode of the LED
FLASH | Mode of the LED
TOGGLE | Mode of the LED

See Also

TI.ZPI1 Namespace


SYS_LED_CONTROL.LED_NUM Enumeration

SYS_LED_CONTROL.LED_NUM Enumeration
[image]

The ID of the LED

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_LED_CONTROL.LED_NUM As Byte
C#
public enum SYS_LED_CONTROL.LED_NUM : byte
C++
public enum class SYS_LED_CONTROL.LED_NUM : char
J#
public enum SYS_LED_CONTROL.LED_NUM byte
JScript
public enum SYS_LED_CONTROL.LED_NUM :

Members

Member Name | Description
LED_1 | The ID of the LED
LED_2 | The ID of the LED
LED_3 | The ID of the LED
LED_4 | The ID of the LED
ALL_LEDS | The ID of the LED

See Also

TI.ZPI1 Namespace


SYS_LED_CONTROL_RESPONSE Class

SYS_LED_CONTROL_RESPONSE Class
See Also Example Members
[image]

Response for SYS_LED_CONTROL

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_LED_CONTROL_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_LED_CONTROL_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_LED_CONTROL_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_LED_CONTROL_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_LED_CONTROL_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_LED_CONTROL_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_LED_CONTROL_RESPONSE Members
TI.ZPI1 Namespace


SYS_LED_CONTROL_RESPONSE Members

SYS_LED_CONTROL_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_LED_CONTROL

The following tables list the members exposed by SYS_LED_CONTROL_RESPONSE.

Public Constructors

Name | Description
SYS_LED_CONTROL_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_LED_CONTROL_RESPONSE | Overloaded.
Top

See Also

SYS_LED_CONTROL_RESPONSE Class
TI.ZPI1 Namespace


SYS_LED_CONTROL_RESPONSE Constructor

SYS_LED_CONTROL_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_LED_CONTROL_RESPONSE | Constructor
Public method | SYS_LED_CONTROL_RESPONSE (SYS_LED_CONTROL_RESPONSE.CMD_STATUS) |

See Also

SYS_LED_CONTROL_RESPONSE Class
TI.ZPI1 Namespace


SYS_LED_CONTROL_RESPONSE Constructor ()

SYS_LED_CONTROL_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_LED_CONTROL_RESPONSE()
C++
public:
SYS_LED_CONTROL_RESPONSE() sealed
J#
public SYS_LED_CONTROL_RESPONSE()
JScript
public function SYS_LED_CONTROL_RESPONSE()

See Also

SYS_LED_CONTROL_RESPONSE Class
TI.ZPI1 Namespace
SYS_LED_CONTROL_RESPONSE Constructor Overload List


SYS_LED_CONTROL_RESPONSE Constructor (SYS_LED_CONTROL_RESPONSE.CMD_STATUS)

SYS_LED_CONTROL_RESPONSE Constructor (SYS_LED_CONTROL_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_LED_CONTROL_RESPONSE.CMD_STATUS _
)
C#
public SYS_LED_CONTROL_RESPONSE(
SYS_LED_CONTROL_RESPONSE.CMD_STATUS
)
C++
public:
SYS_LED_CONTROL_RESPONSE(
SYS_LED_CONTROL_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_LED_CONTROL_RESPONSE(
SYS_LED_CONTROL_RESPONSE.CMD_STATUS
)
JScript
public function SYS_LED_CONTROL_RESPONSE(
: SYS_LED_CONTROL_RESPONSE.CMD_STATUS
)

See Also

SYS_LED_CONTROL_RESPONSE Class
TI.ZPI1 Namespace
SYS_LED_CONTROL_RESPONSE Constructor Overload List


Fields

SYS_LED_CONTROL_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_LED_CONTROL_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_LED_CONTROL_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_LED_CONTROL_RESPONSE.CMD_STATUS
C#
public SYS_LED_CONTROL_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_LED_CONTROL_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_LED_CONTROL_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_LED_CONTROL_RESPONSE.CMD_STATUS;

See Also

SYS_LED_CONTROL_RESPONSE Class
TI.ZPI1 Namespace


SYS_LED_CONTROL_RESPONSE.CMD_STATUS Enumeration

SYS_LED_CONTROL_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_LED_CONTROL_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_LED_CONTROL_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_LED_CONTROL_RESPONSE.CMD_STATUS : char
J#
public enum SYS_LED_CONTROL_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_LED_CONTROL_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_PING Class

SYS_PING Class
See Also Example Members
[image]

This command is used to check for a device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_PING
Implements IREQUEST, ISYSTEM
C#
public class SYS_PING : IREQUEST, ISYSTEM
C++
ref class SYS_PING : IREQUEST, ISYSTEM
J#
public class SYS_PING implements IREQUEST, ISYSTEM
JScript
public class SYS_PING extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_PING

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_PING Members
TI.ZPI1 Namespace


SYS_PING Members

SYS_PING Members
See Also Example Constructors Methods
[image]

This command is used to check for a device

The following tables list the members exposed by SYS_PING.

Public Constructors

 | Name | Description
Public method | SYS_PING | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_PING Class
TI.ZPI1 Namespace


SYS_PING Constructor

SYS_PING Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_PING()
C++
public:
SYS_PING() sealed
J#
public SYS_PING()
JScript
public function SYS_PING()

See Also

SYS_PING Class
TI.ZPI1 Namespace


SYS_PING_RESPONSE Class

SYS_PING_RESPONSE Class
See Also Example Members
[image]

Response for SYS_PING

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_PING_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_PING_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_PING_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_PING_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_PING_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_PING_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_PING_RESPONSE Members
TI.ZPI1 Namespace


SYS_PING_RESPONSE Members

SYS_PING_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_PING

The following tables list the members exposed by SYS_PING_RESPONSE.

Public Constructors

Name | Description
SYS_PING_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Capabilities | This field represents the interfaces that this device can handle (compiled into the device).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_PING_RESPONSE | Overloaded.
Top

See Also

SYS_PING_RESPONSE Class
TI.ZPI1 Namespace


SYS_PING_RESPONSE Constructor

SYS_PING_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_PING_RESPONSE | Constructor
Public method | SYS_PING_RESPONSE (SYS_PING_RESPONSE.CAPABILITIES) |

See Also

SYS_PING_RESPONSE Class
TI.ZPI1 Namespace


SYS_PING_RESPONSE Constructor ()

SYS_PING_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_PING_RESPONSE()
C++
public:
SYS_PING_RESPONSE() sealed
J#
public SYS_PING_RESPONSE()
JScript
public function SYS_PING_RESPONSE()

See Also

SYS_PING_RESPONSE Class
TI.ZPI1 Namespace
SYS_PING_RESPONSE Constructor Overload List


SYS_PING_RESPONSE Constructor (SYS_PING_RESPONSE.CAPABILITIES)

SYS_PING_RESPONSE Constructor (SYS_PING_RESPONSE.CAPABILITIES)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_PING_RESPONSE.CAPABILITIES _
)
C#
public SYS_PING_RESPONSE(
SYS_PING_RESPONSE.CAPABILITIES
)
C++
public:
SYS_PING_RESPONSE(
SYS_PING_RESPONSE.CAPABILITIES
) sealed
J#
public SYS_PING_RESPONSE(
SYS_PING_RESPONSE.CAPABILITIES
)
JScript
public function SYS_PING_RESPONSE(
: SYS_PING_RESPONSE.CAPABILITIES
)

See Also

SYS_PING_RESPONSE Class
TI.ZPI1 Namespace
SYS_PING_RESPONSE Constructor Overload List


Fields

SYS_PING_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Capabilities | This field represents the interfaces that this device can handle (compiled into the device).
Top

See Also

SYS_PING_RESPONSE Class
TI.ZPI1 Namespace


Capabilities Field

SYS_PING_RESPONSE.Capabilities Field
[image]

This field represents the interfaces that this device can handle (compiled into the device).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Capabilities As SYS_PING_RESPONSE.CAPABILITIES
C#
public SYS_PING_RESPONSE.CAPABILITIES Capabilities;
C++
public:
SYS_PING_RESPONSE.CAPABILITIES Capabilities sealed ;
J#
public SYS_PING_RESPONSE.CAPABILITIES Capabilities
JScript
public Capabilities : SYS_PING_RESPONSE.CAPABILITIES;

See Also

SYS_PING_RESPONSE Class
TI.ZPI1 Namespace


SYS_PING_RESPONSE.CAPABILITIES Enumeration

SYS_PING_RESPONSE.CAPABILITIES Enumeration
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum SYS_PING_RESPONSE.CAPABILITIES As
C#
[FlagsAttribute]
public enum SYS_PING_RESPONSE.CAPABILITIES : ushort
C++
[FlagsAttribute]
public enum class SYS_PING_RESPONSE.CAPABILITIES : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum SYS_PING_RESPONSE.CAPABILITIES ushort
JScript
public enum SYS_PING_RESPONSE.CAPABILITIES :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
MT_CAP_MAC | Capabilities bitfield | 1
MT_CAP_NWK | Capabilities bitfield | 2
MT_CAP_AF | Capabilities bitfield | 4
MT_CAP_ZDO | Capabilities bitfield | 8
MT_CAP_USER_TEST | Capabilities bitfield | 16
MT_CAP_SAPI | Capabilities bitfield | 32
MT_CAP_BOOTLOAD | Capabilities bitfield | 32768

See Also

TI.ZPI1 Namespace


SYS_RAM_READ Class

SYS_RAM_READ Class
See Also Example Members
[image]

This command is used by the tester to read a single memory location in the target RAM. THe command accepts an address value and returns the memory value present in the target RAM at that address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RAM_READ
Implements IREQUEST, ISYSTEM
C#
public class SYS_RAM_READ : IREQUEST, ISYSTEM
C++
ref class SYS_RAM_READ : IREQUEST, ISYSTEM
J#
public class SYS_RAM_READ implements IREQUEST, ISYSTEM
JScript
public class SYS_RAM_READ extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_RAM_READ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RAM_READ Members
TI.ZPI1 Namespace


SYS_RAM_READ Members

SYS_RAM_READ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to read a single memory location in the target RAM. THe command accepts an address value and returns the memory value present in the target RAM at that address.

The following tables list the members exposed by SYS_RAM_READ.

Public Constructors

Name | Description
SYS_RAM_READ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Address | contains the address of the memory location that needs to be read
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RAM_READ | Overloaded.
Top

See Also

SYS_RAM_READ Class
TI.ZPI1 Namespace


SYS_RAM_READ Constructor

SYS_RAM_READ Constructor

Overload List

 | Name | Description
Public method | SYS_RAM_READ | Constructor
Public method | SYS_RAM_READ (UInt16) | Constructor

See Also

SYS_RAM_READ Class
TI.ZPI1 Namespace


SYS_RAM_READ Constructor ()

SYS_RAM_READ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RAM_READ()
C++
public:
SYS_RAM_READ() sealed
J#
public SYS_RAM_READ()
JScript
public function SYS_RAM_READ()

See Also

SYS_RAM_READ Class
TI.ZPI1 Namespace
SYS_RAM_READ Constructor Overload List


SYS_RAM_READ Constructor (UInt16)

SYS_RAM_READ Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public SYS_RAM_READ(
ushort
)
C++
public:
SYS_RAM_READ(
unsigned short
) sealed
J#
public SYS_RAM_READ(
ushort
)
JScript
public function SYS_RAM_READ(
: UInt16
)

See Also

SYS_RAM_READ Class
TI.ZPI1 Namespace
SYS_RAM_READ Constructor Overload List


Fields

SYS_RAM_READ Fields
[image]

Public Fields

 | Name | Description
Public field | Address | contains the address of the memory location that needs to be read
Top

See Also

SYS_RAM_READ Class
TI.ZPI1 Namespace


Address Field

SYS_RAM_READ.Address Field
[image]

contains the address of the memory location that needs to be read

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Address As UInt16
C#
public ushort Address;
C++
public:
unsigned short Address sealed ;
J#
public ushort Address
JScript
public Address : UInt16;

See Also

SYS_RAM_READ Class
TI.ZPI1 Namespace


SYS_RAM_READ_RESPONSE Class

SYS_RAM_READ_RESPONSE Class
See Also Example Members
[image]

Response for SYS_RAM_READ

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RAM_READ_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_RAM_READ_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_RAM_READ_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_RAM_READ_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_RAM_READ_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_RAM_READ_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RAM_READ_RESPONSE Members
TI.ZPI1 Namespace


SYS_RAM_READ_RESPONSE Members

SYS_RAM_READ_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_RAM_READ

The following tables list the members exposed by SYS_RAM_READ_RESPONSE.

Public Constructors

Name | Description
SYS_RAM_READ_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range
Public field | Value | contains the data read from the target RAM
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RAM_READ_RESPONSE | Overloaded.
Top

See Also

SYS_RAM_READ_RESPONSE Class
TI.ZPI1 Namespace


SYS_RAM_READ_RESPONSE Constructor

SYS_RAM_READ_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_RAM_READ_RESPONSE | Constructor
Public method | SYS_RAM_READ_RESPONSE (SYS_RAM_READ_RESPONSE.CMD_STATUS, Byte) |

See Also

SYS_RAM_READ_RESPONSE Class
TI.ZPI1 Namespace


SYS_RAM_READ_RESPONSE Constructor ()

SYS_RAM_READ_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RAM_READ_RESPONSE()
C++
public:
SYS_RAM_READ_RESPONSE() sealed
J#
public SYS_RAM_READ_RESPONSE()
JScript
public function SYS_RAM_READ_RESPONSE()

See Also

SYS_RAM_READ_RESPONSE Class
TI.ZPI1 Namespace
SYS_RAM_READ_RESPONSE Constructor Overload List


SYS_RAM_READ_RESPONSE Constructor (SYS_RAM_READ_RESPONSE.CMD_STATUS, Byte)

SYS_RAM_READ_RESPONSE Constructor (SYS_RAM_READ_RESPONSE.CMD_STATUS, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_RAM_READ_RESPONSE.CMD_STATUS, _
ByVal As Byte _
)
C#
public SYS_RAM_READ_RESPONSE(
SYS_RAM_READ_RESPONSE.CMD_STATUS ,
byte
)
C++
public:
SYS_RAM_READ_RESPONSE(
SYS_RAM_READ_RESPONSE.CMD_STATUS ,
char
) sealed
J#
public SYS_RAM_READ_RESPONSE(
SYS_RAM_READ_RESPONSE.CMD_STATUS ,
byte
)
JScript
public function SYS_RAM_READ_RESPONSE(
: SYS_RAM_READ_RESPONSE.CMD_STATUS,
: Byte
)

See Also

SYS_RAM_READ_RESPONSE Class
TI.ZPI1 Namespace
SYS_RAM_READ_RESPONSE Constructor Overload List


Fields

SYS_RAM_READ_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range
Public field | Value | contains the data read from the target RAM
Top

See Also

SYS_RAM_READ_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_RAM_READ_RESPONSE.Status Field
[image]

The fail status is returned if the address value in the command message was not within the valid range

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_RAM_READ_RESPONSE.CMD_STATUS
C#
public SYS_RAM_READ_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_RAM_READ_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_RAM_READ_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_RAM_READ_RESPONSE.CMD_STATUS;

See Also

SYS_RAM_READ_RESPONSE Class
TI.ZPI1 Namespace


Value Field

SYS_RAM_READ_RESPONSE.Value Field
[image]

contains the data read from the target RAM

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte
C#
public byte Value;
C++
public:
char Value sealed ;
J#
public byte Value
JScript
public Value : Byte;

See Also

SYS_RAM_READ_RESPONSE Class
TI.ZPI1 Namespace


SYS_RAM_READ_RESPONSE.CMD_STATUS Enumeration

SYS_RAM_READ_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_RAM_READ_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_RAM_READ_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_RAM_READ_RESPONSE.CMD_STATUS : char
J#
public enum SYS_RAM_READ_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_RAM_READ_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_RAM_WRITE Class

SYS_RAM_WRITE Class
See Also Example Members
[image]

This command is used by the tester to write to a particular location in the target RAM. The command accepts an address location and a memory value. The memory value is written to the address location in the target RAM

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RAM_WRITE
Implements IREQUEST, ISYSTEM
C#
public class SYS_RAM_WRITE : IREQUEST, ISYSTEM
C++
ref class SYS_RAM_WRITE : IREQUEST, ISYSTEM
J#
public class SYS_RAM_WRITE implements IREQUEST, ISYSTEM
JScript
public class SYS_RAM_WRITE extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_RAM_WRITE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RAM_WRITE Members
TI.ZPI1 Namespace


SYS_RAM_WRITE Members

SYS_RAM_WRITE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to write to a particular location in the target RAM. The command accepts an address location and a memory value. The memory value is written to the address location in the target RAM

The following tables list the members exposed by SYS_RAM_WRITE.

Public Constructors

Name | Description
SYS_RAM_WRITE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Address | indicates the address of the memory location that is to be written
Public field | Value | contains the data value that is to be written to the memory location
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RAM_WRITE | Overloaded.
Top

See Also

SYS_RAM_WRITE Class
TI.ZPI1 Namespace


SYS_RAM_WRITE Constructor

SYS_RAM_WRITE Constructor

Overload List

 | Name | Description
Public method | SYS_RAM_WRITE | Constructor
Public method | SYS_RAM_WRITE (UInt16, Byte) | Constructor

See Also

SYS_RAM_WRITE Class
TI.ZPI1 Namespace


SYS_RAM_WRITE Constructor ()

SYS_RAM_WRITE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RAM_WRITE()
C++
public:
SYS_RAM_WRITE() sealed
J#
public SYS_RAM_WRITE()
JScript
public function SYS_RAM_WRITE()

See Also

SYS_RAM_WRITE Class
TI.ZPI1 Namespace
SYS_RAM_WRITE Constructor Overload List


SYS_RAM_WRITE Constructor (UInt16, Byte)

SYS_RAM_WRITE Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public SYS_RAM_WRITE(
ushort ,
byte
)
C++
public:
SYS_RAM_WRITE(
unsigned short ,
char
) sealed
J#
public SYS_RAM_WRITE(
ushort ,
byte
)
JScript
public function SYS_RAM_WRITE(
: UInt16,
: Byte
)

See Also

SYS_RAM_WRITE Class
TI.ZPI1 Namespace
SYS_RAM_WRITE Constructor Overload List


Fields

SYS_RAM_WRITE Fields
[image]

Public Fields

 | Name | Description
Public field | Address | indicates the address of the memory location that is to be written
Public field | Value | contains the data value that is to be written to the memory location
Top

See Also

SYS_RAM_WRITE Class
TI.ZPI1 Namespace


Address Field

SYS_RAM_WRITE.Address Field
[image]

indicates the address of the memory location that is to be written

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Address As UInt16
C#
public ushort Address;
C++
public:
unsigned short Address sealed ;
J#
public ushort Address
JScript
public Address : UInt16;

See Also

SYS_RAM_WRITE Class
TI.ZPI1 Namespace


Value Field

SYS_RAM_WRITE.Value Field
[image]

contains the data value that is to be written to the memory location

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte
C#
public byte Value;
C++
public:
char Value sealed ;
J#
public byte Value
JScript
public Value : Byte;

See Also

SYS_RAM_WRITE Class
TI.ZPI1 Namespace


SYS_RAM_WRITE_RESPONSE Class

SYS_RAM_WRITE_RESPONSE Class
See Also Example Members
[image]

Response for SYS_RAM_WRITE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RAM_WRITE_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_RAM_WRITE_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_RAM_WRITE_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_RAM_WRITE_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_RAM_WRITE_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_RAM_WRITE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RAM_WRITE_RESPONSE Members
TI.ZPI1 Namespace


SYS_RAM_WRITE_RESPONSE Members

SYS_RAM_WRITE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_RAM_WRITE

The following tables list the members exposed by SYS_RAM_WRITE_RESPONSE.

Public Constructors

Name | Description
SYS_RAM_WRITE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the address location in the command message was not within the valid range
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RAM_WRITE_RESPONSE | Overloaded.
Top

See Also

SYS_RAM_WRITE_RESPONSE Class
TI.ZPI1 Namespace


SYS_RAM_WRITE_RESPONSE Constructor

SYS_RAM_WRITE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_RAM_WRITE_RESPONSE | Constructor
Public method | SYS_RAM_WRITE_RESPONSE (SYS_RAM_WRITE_RESPONSE.CMD_STATUS) |

See Also

SYS_RAM_WRITE_RESPONSE Class
TI.ZPI1 Namespace


SYS_RAM_WRITE_RESPONSE Constructor ()

SYS_RAM_WRITE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RAM_WRITE_RESPONSE()
C++
public:
SYS_RAM_WRITE_RESPONSE() sealed
J#
public SYS_RAM_WRITE_RESPONSE()
JScript
public function SYS_RAM_WRITE_RESPONSE()

See Also

SYS_RAM_WRITE_RESPONSE Class
TI.ZPI1 Namespace
SYS_RAM_WRITE_RESPONSE Constructor Overload List


SYS_RAM_WRITE_RESPONSE Constructor (SYS_RAM_WRITE_RESPONSE.CMD_STATUS)

SYS_RAM_WRITE_RESPONSE Constructor (SYS_RAM_WRITE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_RAM_WRITE_RESPONSE.CMD_STATUS _
)
C#
public SYS_RAM_WRITE_RESPONSE(
SYS_RAM_WRITE_RESPONSE.CMD_STATUS
)
C++
public:
SYS_RAM_WRITE_RESPONSE(
SYS_RAM_WRITE_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_RAM_WRITE_RESPONSE(
SYS_RAM_WRITE_RESPONSE.CMD_STATUS
)
JScript
public function SYS_RAM_WRITE_RESPONSE(
: SYS_RAM_WRITE_RESPONSE.CMD_STATUS
)

See Also

SYS_RAM_WRITE_RESPONSE Class
TI.ZPI1 Namespace
SYS_RAM_WRITE_RESPONSE Constructor Overload List


Fields

SYS_RAM_WRITE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the address location in the command message was not within the valid range
Top

See Also

SYS_RAM_WRITE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_RAM_WRITE_RESPONSE.Status Field
[image]

The fail status is returned if the address location in the command message was not within the valid range

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_RAM_WRITE_RESPONSE.CMD_STATUS
C#
public SYS_RAM_WRITE_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_RAM_WRITE_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_RAM_WRITE_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_RAM_WRITE_RESPONSE.CMD_STATUS;

See Also

SYS_RAM_WRITE_RESPONSE Class
TI.ZPI1 Namespace


SYS_RAM_WRITE_RESPONSE.CMD_STATUS Enumeration

SYS_RAM_WRITE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_RAM_WRITE_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_RAM_WRITE_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_RAM_WRITE_RESPONSE.CMD_STATUS : char
J#
public enum SYS_RAM_WRITE_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_RAM_WRITE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_RESET Class

SYS_RESET Class
See Also Example Members
[image]

This command is sent by the tester to the target to reset it

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RESET
Implements IREQUEST, ISYSTEM
C#
public class SYS_RESET : IREQUEST, ISYSTEM
C++
ref class SYS_RESET : IREQUEST, ISYSTEM
J#
public class SYS_RESET implements IREQUEST, ISYSTEM
JScript
public class SYS_RESET extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_RESET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RESET Members
TI.ZPI1 Namespace


SYS_RESET Members

SYS_RESET Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is sent by the tester to the target to reset it

The following tables list the members exposed by SYS_RESET.

Public Constructors

Name | Description
SYS_RESET | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Type | requests a target device reset (0) or serial bootloader reset (1). If the target device does not support serial bootloading, bootloader reset commands are ignored and no response is sent from the target.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RESET | Overloaded.
Top

See Also

SYS_RESET Class
TI.ZPI1 Namespace


SYS_RESET Constructor

SYS_RESET Constructor

Overload List

 | Name | Description
Public method | SYS_RESET | Constructor
Public method | SYS_RESET (SYS_RESET.RESET_TYPE) |

See Also

SYS_RESET Class
TI.ZPI1 Namespace


SYS_RESET Constructor ()

SYS_RESET Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RESET()
C++
public:
SYS_RESET() sealed
J#
public SYS_RESET()
JScript
public function SYS_RESET()

See Also

SYS_RESET Class
TI.ZPI1 Namespace
SYS_RESET Constructor Overload List


SYS_RESET Constructor (SYS_RESET.RESET_TYPE)

SYS_RESET Constructor (SYS_RESET.RESET_TYPE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_RESET.RESET_TYPE _
)
C#
public SYS_RESET(
SYS_RESET.RESET_TYPE
)
C++
public:
SYS_RESET(
SYS_RESET.RESET_TYPE
) sealed
J#
public SYS_RESET(
SYS_RESET.RESET_TYPE
)
JScript
public function SYS_RESET(
: SYS_RESET.RESET_TYPE
)

See Also

SYS_RESET Class
TI.ZPI1 Namespace
SYS_RESET Constructor Overload List


Fields

SYS_RESET Fields
[image]

Public Fields

 | Name | Description
Public field | Type | requests a target device reset (0) or serial bootloader reset (1). If the target device does not support serial bootloading, bootloader reset commands are ignored and no response is sent from the target.
Top

See Also

SYS_RESET Class
TI.ZPI1 Namespace


Type Field

SYS_RESET.Type Field
[image]

requests a target device reset (0) or serial bootloader reset (1). If the target device does not support serial bootloading, bootloader reset commands are ignored and no response is sent from the target.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Type As SYS_RESET.RESET_TYPE
C#
public SYS_RESET.RESET_TYPE Type;
C++
public:
SYS_RESET.RESET_TYPE Type sealed ;
J#
public SYS_RESET.RESET_TYPE Type
JScript
public Type : SYS_RESET.RESET_TYPE;

See Also

SYS_RESET Class
TI.ZPI1 Namespace


SYS_RESET.RESET_TYPE Enumeration

SYS_RESET.RESET_TYPE Enumeration
[image]

Reset type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_RESET.RESET_TYPE As Byte
C#
public enum SYS_RESET.RESET_TYPE : byte
C++
public enum class SYS_RESET.RESET_TYPE : char
J#
public enum SYS_RESET.RESET_TYPE byte
JScript
public enum SYS_RESET.RESET_TYPE :

Members

Member Name | Description
TARGET_DEVICE | Reset type
SERIAL_BOOTLOADER | Reset type

See Also

TI.ZPI1 Namespace


SYS_RESET_RESPONSE Class

SYS_RESET_RESPONSE Class
See Also Example Members
[image]

Response for SYS_RESET. This response is sent from the target device or serial bootloader after the requested reset is complete.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RESET_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_RESET_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_RESET_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_RESET_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_RESET_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RESET_RESPONSE Members
TI.ZPI1 Namespace


SYS_RESET_RESPONSE Members

SYS_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_RESET. This response is sent from the target device or serial bootloader after the requested reset is complete.

The following tables list the members exposed by SYS_RESET_RESPONSE.

Public Constructors

Name | Description
SYS_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Type | indicates which reset operation is being reported - target device (0) or serial bootloader (1).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RESET_RESPONSE | Overloaded.
Top

See Also

SYS_RESET_RESPONSE Class
TI.ZPI1 Namespace


SYS_RESET_RESPONSE Constructor

SYS_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_RESET_RESPONSE | Constructor
Public method | SYS_RESET_RESPONSE (SYS_RESET_RESPONSE.RESET_TYPE) |

See Also

SYS_RESET_RESPONSE Class
TI.ZPI1 Namespace


SYS_RESET_RESPONSE Constructor ()

SYS_RESET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RESET_RESPONSE()
C++
public:
SYS_RESET_RESPONSE() sealed
J#
public SYS_RESET_RESPONSE()
JScript
public function SYS_RESET_RESPONSE()

See Also

SYS_RESET_RESPONSE Class
TI.ZPI1 Namespace
SYS_RESET_RESPONSE Constructor Overload List


SYS_RESET_RESPONSE Constructor (SYS_RESET_RESPONSE.RESET_TYPE)

SYS_RESET_RESPONSE Constructor (SYS_RESET_RESPONSE.RESET_TYPE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_RESET_RESPONSE.RESET_TYPE _
)
C#
public SYS_RESET_RESPONSE(
SYS_RESET_RESPONSE.RESET_TYPE
)
C++
public:
SYS_RESET_RESPONSE(
SYS_RESET_RESPONSE.RESET_TYPE
) sealed
J#
public SYS_RESET_RESPONSE(
SYS_RESET_RESPONSE.RESET_TYPE
)
JScript
public function SYS_RESET_RESPONSE(
: SYS_RESET_RESPONSE.RESET_TYPE
)

See Also

SYS_RESET_RESPONSE Class
TI.ZPI1 Namespace
SYS_RESET_RESPONSE Constructor Overload List


Fields

SYS_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Type | indicates which reset operation is being reported - target device (0) or serial bootloader (1).
Top

See Also

SYS_RESET_RESPONSE Class
TI.ZPI1 Namespace


Type Field

SYS_RESET_RESPONSE.Type Field
[image]

indicates which reset operation is being reported - target device (0) or serial bootloader (1).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Type As SYS_RESET_RESPONSE.RESET_TYPE
C#
public SYS_RESET_RESPONSE.RESET_TYPE Type;
C++
public:
SYS_RESET_RESPONSE.RESET_TYPE Type sealed ;
J#
public SYS_RESET_RESPONSE.RESET_TYPE Type
JScript
public Type : SYS_RESET_RESPONSE.RESET_TYPE;

See Also

SYS_RESET_RESPONSE Class
TI.ZPI1 Namespace


SYS_RESET_RESPONSE.RESET_TYPE Enumeration

SYS_RESET_RESPONSE.RESET_TYPE Enumeration
[image]

Reset type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_RESET_RESPONSE.RESET_TYPE As Byte
C#
public enum SYS_RESET_RESPONSE.RESET_TYPE : byte
C++
public enum class SYS_RESET_RESPONSE.RESET_TYPE : char
J#
public enum SYS_RESET_RESPONSE.RESET_TYPE byte
JScript
public enum SYS_RESET_RESPONSE.RESET_TYPE :

Members

Member Name | Description
TARGET_DEVICE | Reset type
SERIAL_BOOTLOADER | Reset type

See Also

TI.ZPI1 Namespace


SYS_SET_CHANNELS Class

SYS_SET_CHANNELS Class
See Also Example Members
[image]

Use this message to set the channels.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_CHANNELS
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_CHANNELS : IREQUEST, ISYSTEM
C++
ref class SYS_SET_CHANNELS : IREQUEST, ISYSTEM
J#
public class SYS_SET_CHANNELS implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_CHANNELS extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_CHANNELS

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_CHANNELS Members
TI.ZPI1 Namespace


SYS_SET_CHANNELS Members

SYS_SET_CHANNELS Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set the channels.

The following tables list the members exposed by SYS_SET_CHANNELS.

Public Constructors

Name | Description
SYS_SET_CHANNELS | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Channels | Channels.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_CHANNELS | Overloaded.
Top

See Also

SYS_SET_CHANNELS Class
TI.ZPI1 Namespace


SYS_SET_CHANNELS Constructor

SYS_SET_CHANNELS Constructor

Overload List

 | Name | Description
Public method | SYS_SET_CHANNELS | Constructor
Public method | SYS_SET_CHANNELS (SYS_SET_CHANNELS.ZIGBEE_CHANNELS) |

See Also

SYS_SET_CHANNELS Class
TI.ZPI1 Namespace


SYS_SET_CHANNELS Constructor ()

SYS_SET_CHANNELS Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_CHANNELS()
C++
public:
SYS_SET_CHANNELS() sealed
J#
public SYS_SET_CHANNELS()
JScript
public function SYS_SET_CHANNELS()

See Also

SYS_SET_CHANNELS Class
TI.ZPI1 Namespace
SYS_SET_CHANNELS Constructor Overload List


SYS_SET_CHANNELS Constructor (SYS_SET_CHANNELS.ZIGBEE_CHANNELS)

SYS_SET_CHANNELS Constructor (SYS_SET_CHANNELS.ZIGBEE_CHANNELS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_CHANNELS.ZIGBEE_CHANNELS _
)
C#
public SYS_SET_CHANNELS(
SYS_SET_CHANNELS.ZIGBEE_CHANNELS
)
C++
public:
SYS_SET_CHANNELS(
SYS_SET_CHANNELS.ZIGBEE_CHANNELS
) sealed
J#
public SYS_SET_CHANNELS(
SYS_SET_CHANNELS.ZIGBEE_CHANNELS
)
JScript
public function SYS_SET_CHANNELS(
: SYS_SET_CHANNELS.ZIGBEE_CHANNELS
)

See Also

SYS_SET_CHANNELS Class
TI.ZPI1 Namespace
SYS_SET_CHANNELS Constructor Overload List


Fields

SYS_SET_CHANNELS Fields
[image]

Public Fields

 | Name | Description
Public field | Channels | Channels.
Top

See Also

SYS_SET_CHANNELS Class
TI.ZPI1 Namespace


Channels Field

SYS_SET_CHANNELS.Channels Field
[image]

Channels.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Channels As SYS_SET_CHANNELS.ZIGBEE_CHANNELS
C#
public SYS_SET_CHANNELS.ZIGBEE_CHANNELS Channels;
C++
public:
SYS_SET_CHANNELS.ZIGBEE_CHANNELS Channels sealed ;
J#
public SYS_SET_CHANNELS.ZIGBEE_CHANNELS Channels
JScript
public Channels : SYS_SET_CHANNELS.ZIGBEE_CHANNELS;

See Also

SYS_SET_CHANNELS Class
TI.ZPI1 Namespace


SYS_SET_CHANNELS.ZIGBEE_CHANNELS Enumeration

SYS_SET_CHANNELS.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum SYS_SET_CHANNELS.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum SYS_SET_CHANNELS.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class SYS_SET_CHANNELS.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum SYS_SET_CHANNELS.ZIGBEE_CHANNELS uint
JScript
public enum SYS_SET_CHANNELS.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


SYS_SET_CHANNELS_RESPONSE Class

SYS_SET_CHANNELS_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_CHANNELS

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_CHANNELS_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_CHANNELS_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_CHANNELS_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_CHANNELS_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_CHANNELS_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_CHANNELS_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_CHANNELS_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_CHANNELS_RESPONSE Members

SYS_SET_CHANNELS_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_CHANNELS

The following tables list the members exposed by SYS_SET_CHANNELS_RESPONSE.

Public Constructors

Name | Description
SYS_SET_CHANNELS_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_CHANNELS_RESPONSE | Overloaded.
Top

See Also

SYS_SET_CHANNELS_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_CHANNELS_RESPONSE Constructor

SYS_SET_CHANNELS_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_CHANNELS_RESPONSE | Constructor
Public method | SYS_SET_CHANNELS_RESPONSE (SYS_SET_CHANNELS_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_CHANNELS_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_CHANNELS_RESPONSE Constructor ()

SYS_SET_CHANNELS_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_CHANNELS_RESPONSE()
C++
public:
SYS_SET_CHANNELS_RESPONSE() sealed
J#
public SYS_SET_CHANNELS_RESPONSE()
JScript
public function SYS_SET_CHANNELS_RESPONSE()

See Also

SYS_SET_CHANNELS_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_CHANNELS_RESPONSE Constructor Overload List


SYS_SET_CHANNELS_RESPONSE Constructor (SYS_SET_CHANNELS_RESPONSE.CMD_STATUS)

SYS_SET_CHANNELS_RESPONSE Constructor (SYS_SET_CHANNELS_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_CHANNELS_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_CHANNELS_RESPONSE(
SYS_SET_CHANNELS_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_CHANNELS_RESPONSE(
SYS_SET_CHANNELS_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_CHANNELS_RESPONSE(
SYS_SET_CHANNELS_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_CHANNELS_RESPONSE(
: SYS_SET_CHANNELS_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_CHANNELS_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_CHANNELS_RESPONSE Constructor Overload List


Fields

SYS_SET_CHANNELS_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_CHANNELS_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_CHANNELS_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_CHANNELS_RESPONSE.CMD_STATUS
C#
public SYS_SET_CHANNELS_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_CHANNELS_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_CHANNELS_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_CHANNELS_RESPONSE.CMD_STATUS;

See Also

SYS_SET_CHANNELS_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_CHANNELS_RESPONSE.CMD_STATUS Enumeration

SYS_SET_CHANNELS_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_CHANNELS_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_CHANNELS_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_CHANNELS_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_CHANNELS_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_CHANNELS_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD Class

SYS_SET_DEBUG_THRESHOLD Class
See Also Example Members
[image]

This command is used by the tester to set the debug threshold level for a particular software component in the target.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_DEBUG_THRESHOLD
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_DEBUG_THRESHOLD : IREQUEST, ISYSTEM
C++
ref class SYS_SET_DEBUG_THRESHOLD : IREQUEST, ISYSTEM
J#
public class SYS_SET_DEBUG_THRESHOLD implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_DEBUG_THRESHOLD extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_DEBUG_THRESHOLD Members
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD Members

SYS_SET_DEBUG_THRESHOLD Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to set the debug threshold level for a particular software component in the target.

The following tables list the members exposed by SYS_SET_DEBUG_THRESHOLD.

Public Constructors

Name | Description
SYS_SET_DEBUG_THRESHOLD | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ComponentID | uniquely identifies a particular software component on the target
Public field | Threshold | specifies the threshold value for reporting debug messages by that software component
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_DEBUG_THRESHOLD | Overloaded.
Top

See Also

SYS_SET_DEBUG_THRESHOLD Class
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD Constructor

SYS_SET_DEBUG_THRESHOLD Constructor

Overload List

 | Name | Description
Public method | SYS_SET_DEBUG_THRESHOLD | Constructor
Public method | SYS_SET_DEBUG_THRESHOLD (Byte, SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD) |

See Also

SYS_SET_DEBUG_THRESHOLD Class
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD Constructor ()

SYS_SET_DEBUG_THRESHOLD Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_DEBUG_THRESHOLD()
C++
public:
SYS_SET_DEBUG_THRESHOLD() sealed
J#
public SYS_SET_DEBUG_THRESHOLD()
JScript
public function SYS_SET_DEBUG_THRESHOLD()

See Also

SYS_SET_DEBUG_THRESHOLD Class
TI.ZPI1 Namespace
SYS_SET_DEBUG_THRESHOLD Constructor Overload List


SYS_SET_DEBUG_THRESHOLD Constructor (Byte, SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD)

SYS_SET_DEBUG_THRESHOLD Constructor (Byte, SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD _
)
C#
public SYS_SET_DEBUG_THRESHOLD(
byte ,
SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
)
C++
public:
SYS_SET_DEBUG_THRESHOLD(
char ,
SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
) sealed
J#
public SYS_SET_DEBUG_THRESHOLD(
byte ,
SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
)
JScript
public function SYS_SET_DEBUG_THRESHOLD(
: Byte,
: SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
)

See Also

SYS_SET_DEBUG_THRESHOLD Class
TI.ZPI1 Namespace
SYS_SET_DEBUG_THRESHOLD Constructor Overload List


Fields

SYS_SET_DEBUG_THRESHOLD Fields
[image]

Public Fields

 | Name | Description
Public field | ComponentID | uniquely identifies a particular software component on the target
Public field | Threshold | specifies the threshold value for reporting debug messages by that software component
Top

See Also

SYS_SET_DEBUG_THRESHOLD Class
TI.ZPI1 Namespace


ComponentID Field

SYS_SET_DEBUG_THRESHOLD.ComponentID Field
[image]

uniquely identifies a particular software component on the target

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ComponentID As Byte
C#
public byte ComponentID;
C++
public:
char ComponentID sealed ;
J#
public byte ComponentID
JScript
public ComponentID : Byte;

See Also

SYS_SET_DEBUG_THRESHOLD Class
TI.ZPI1 Namespace


Threshold Field

SYS_SET_DEBUG_THRESHOLD.Threshold Field
[image]

specifies the threshold value for reporting debug messages by that software component

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Threshold As SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
C#
public SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Threshold;
C++
public:
SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Threshold sealed ;
J#
public SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Threshold
JScript
public Threshold : SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD;

See Also

SYS_SET_DEBUG_THRESHOLD Class
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Enumeration

SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Enumeration
[image]

specifies the threshold value for reporting debug messages by that software component

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD As Byte
C#
public enum SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD : byte
C++
public enum class SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD : char
J#
public enum SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD byte
JScript
public enum SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD :

Members

Member Name | Description
CRITICAL | specifies the threshold value for reporting debug messages by that software component
ERROR | specifies the threshold value for reporting debug messages by that software component
INFORMATION | specifies the threshold value for reporting debug messages by that software component
TRACE | specifies the threshold value for reporting debug messages by that software component

See Also

TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD_RESPONSE Class

SYS_SET_DEBUG_THRESHOLD_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_DEBUG_THRESHOLD

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_DEBUG_THRESHOLD_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_DEBUG_THRESHOLD_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_DEBUG_THRESHOLD_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_DEBUG_THRESHOLD_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_DEBUG_THRESHOLD_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_DEBUG_THRESHOLD_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD_RESPONSE Members

SYS_SET_DEBUG_THRESHOLD_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_DEBUG_THRESHOLD

The following tables list the members exposed by SYS_SET_DEBUG_THRESHOLD_RESPONSE.

Public Constructors

Name | Description
SYS_SET_DEBUG_THRESHOLD_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_DEBUG_THRESHOLD_RESPONSE | Overloaded.
Top

See Also

SYS_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor

SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_DEBUG_THRESHOLD_RESPONSE | Constructor
Public method | SYS_SET_DEBUG_THRESHOLD_RESPONSE (SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor ()

SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_DEBUG_THRESHOLD_RESPONSE()
C++
public:
SYS_SET_DEBUG_THRESHOLD_RESPONSE() sealed
J#
public SYS_SET_DEBUG_THRESHOLD_RESPONSE()
JScript
public function SYS_SET_DEBUG_THRESHOLD_RESPONSE()

See Also

SYS_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor Overload List


SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor (SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS)

SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor (SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_DEBUG_THRESHOLD_RESPONSE(
SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_DEBUG_THRESHOLD_RESPONSE(
SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_DEBUG_THRESHOLD_RESPONSE(
SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_DEBUG_THRESHOLD_RESPONSE(
: SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_DEBUG_THRESHOLD_RESPONSE Constructor Overload List


Fields

SYS_SET_DEBUG_THRESHOLD_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

See Also

SYS_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_DEBUG_THRESHOLD_RESPONSE.Status Field
[image]

The fail status is returned if the component identifier in the comand message was not valid.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
C#
public SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS;

See Also

SYS_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Enumeration

SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS Class

SYS_SET_EXTENDED_ADDRESS Class
See Also Example Members
[image]

Set the 64-bit extended address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_EXTENDED_ADDRESS
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_EXTENDED_ADDRESS : IREQUEST, ISYSTEM
C++
ref class SYS_SET_EXTENDED_ADDRESS : IREQUEST, ISYSTEM
J#
public class SYS_SET_EXTENDED_ADDRESS implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_EXTENDED_ADDRESS extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_EXTENDED_ADDRESS Members
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS Members

SYS_SET_EXTENDED_ADDRESS Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Set the 64-bit extended address.

The following tables list the members exposed by SYS_SET_EXTENDED_ADDRESS.

Public Constructors

Name | Description
SYS_SET_EXTENDED_ADDRESS | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ExtAddress | The device's extended address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_EXTENDED_ADDRESS | Overloaded.
Top

See Also

SYS_SET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS Constructor

SYS_SET_EXTENDED_ADDRESS Constructor

Overload List

 | Name | Description
Public method | SYS_SET_EXTENDED_ADDRESS | Constructor
Public method | SYS_SET_EXTENDED_ADDRESS (UInt64) | Constructor

See Also

SYS_SET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS Constructor ()

SYS_SET_EXTENDED_ADDRESS Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_EXTENDED_ADDRESS()
C++
public:
SYS_SET_EXTENDED_ADDRESS() sealed
J#
public SYS_SET_EXTENDED_ADDRESS()
JScript
public function SYS_SET_EXTENDED_ADDRESS()

See Also

SYS_SET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace
SYS_SET_EXTENDED_ADDRESS Constructor Overload List


SYS_SET_EXTENDED_ADDRESS Constructor (UInt64)

SYS_SET_EXTENDED_ADDRESS Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public SYS_SET_EXTENDED_ADDRESS(
ulong
)
C++
public:
SYS_SET_EXTENDED_ADDRESS(
unsigned __int64
) sealed
J#
public SYS_SET_EXTENDED_ADDRESS(
ulong
)
JScript
public function SYS_SET_EXTENDED_ADDRESS(
: UInt64
)

See Also

SYS_SET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace
SYS_SET_EXTENDED_ADDRESS Constructor Overload List


Fields

SYS_SET_EXTENDED_ADDRESS Fields
[image]

Public Fields

 | Name | Description
Public field | ExtAddress | The device's extended address.
Top

See Also

SYS_SET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace


ExtAddress Field

SYS_SET_EXTENDED_ADDRESS.ExtAddress Field
[image]

The device's extended address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddress As UInt64
C#
public ulong ExtAddress;
C++
public:
unsigned __int64 ExtAddress sealed ;
J#
public ulong ExtAddress
JScript
public ExtAddress : UInt64;

See Also

SYS_SET_EXTENDED_ADDRESS Class
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS_RESPONSE Class

SYS_SET_EXTENDED_ADDRESS_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_EXTENDED_ADDRESS

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_EXTENDED_ADDRESS_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_EXTENDED_ADDRESS_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_EXTENDED_ADDRESS_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_EXTENDED_ADDRESS_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_EXTENDED_ADDRESS_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_EXTENDED_ADDRESS_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS_RESPONSE Members

SYS_SET_EXTENDED_ADDRESS_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_EXTENDED_ADDRESS

The following tables list the members exposed by SYS_SET_EXTENDED_ADDRESS_RESPONSE.

Public Constructors

Name | Description
SYS_SET_EXTENDED_ADDRESS_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_EXTENDED_ADDRESS_RESPONSE | Overloaded.
Top

See Also

SYS_SET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor

SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_EXTENDED_ADDRESS_RESPONSE | Constructor
Public method | SYS_SET_EXTENDED_ADDRESS_RESPONSE (SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor ()

SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_EXTENDED_ADDRESS_RESPONSE()
C++
public:
SYS_SET_EXTENDED_ADDRESS_RESPONSE() sealed
J#
public SYS_SET_EXTENDED_ADDRESS_RESPONSE()
JScript
public function SYS_SET_EXTENDED_ADDRESS_RESPONSE()

See Also

SYS_SET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor Overload List


SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor (SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS)

SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor (SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_EXTENDED_ADDRESS_RESPONSE(
SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_EXTENDED_ADDRESS_RESPONSE(
SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_EXTENDED_ADDRESS_RESPONSE(
SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_EXTENDED_ADDRESS_RESPONSE(
: SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_EXTENDED_ADDRESS_RESPONSE Constructor Overload List


Fields

SYS_SET_EXTENDED_ADDRESS_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_EXTENDED_ADDRESS_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS
C#
public SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS;

See Also

SYS_SET_EXTENDED_ADDRESS_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS Enumeration

SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_SET_NV Class

SYS_SET_NV Class
See Also Example Members
[image]

This command is used by the tester to write to a particular location in non-volatile memory. The command accepts an address location and a memory value. The memory value is written to the address location in the target.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_NV
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_NV : IREQUEST, ISYSTEM
C++
ref class SYS_SET_NV : IREQUEST, ISYSTEM
J#
public class SYS_SET_NV implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_NV extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_NV

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_NV Members
TI.ZPI1 Namespace


SYS_SET_NV Members

SYS_SET_NV Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to write to a particular location in non-volatile memory. The command accepts an address location and a memory value. The memory value is written to the address location in the target.

The following tables list the members exposed by SYS_SET_NV.

Public Constructors

Name | Description
SYS_SET_NV | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | indicates the location that is to be written.
Public field | Length | Length of the value of the property.
Public field | Value | Dynamic array, requires memory allocation. Contains the data value that is to be written to the location.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_NV | Overloaded.
Top

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace


SYS_SET_NV Constructor

SYS_SET_NV Constructor

Overload List

 | Name | Description
Public method | SYS_SET_NV | Constructor
Public method | SYS_SET_NV (Byte, Byte, Byte) | Constructor

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace


SYS_SET_NV Constructor ()

SYS_SET_NV Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_NV()
C++
public:
SYS_SET_NV() sealed
J#
public SYS_SET_NV()
JScript
public function SYS_SET_NV()

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace
SYS_SET_NV Constructor Overload List


SYS_SET_NV Constructor (Byte, Byte, Byte[])

SYS_SET_NV Constructor (Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public SYS_SET_NV(
byte ,
byte ,
byte[]
)
C++
public:
SYS_SET_NV(
char ,
char ,
array<char>^
) sealed
J#
public SYS_SET_NV(
byte ,
byte ,
byte[]
)
JScript
public function SYS_SET_NV(
: Byte,
: Byte,
: Byte[]
)

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace
SYS_SET_NV Constructor Overload List


Fields

SYS_SET_NV Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | indicates the location that is to be written.
Public field | Length | Length of the value of the property.
Public field | Value | Dynamic array, requires memory allocation. Contains the data value that is to be written to the location.
Top

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace


Attribute Field

SYS_SET_NV.Attribute Field
[image]

indicates the location that is to be written.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As Byte
C#
public byte Attribute;
C++
public:
char Attribute sealed ;
J#
public byte Attribute
JScript
public Attribute : Byte;

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace


Length Field

SYS_SET_NV.Length Field
[image]

Length of the value of the property.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace


Value Field

SYS_SET_NV.Value Field
[image]

Dynamic array, requires memory allocation. Contains the data value that is to be written to the location.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

SYS_SET_NV Class
TI.ZPI1 Namespace


SYS_SET_NV_RESPONSE Class

SYS_SET_NV_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_NV

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_NV_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_NV_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_NV_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_NV_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_NV_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_NV_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_NV_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_NV_RESPONSE Members

SYS_SET_NV_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_NV

The following tables list the members exposed by SYS_SET_NV_RESPONSE.

Public Constructors

Name | Description
SYS_SET_NV_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_NV_RESPONSE | Overloaded.
Top

See Also

SYS_SET_NV_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_NV_RESPONSE Constructor

SYS_SET_NV_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_NV_RESPONSE | Constructor
Public method | SYS_SET_NV_RESPONSE (SYS_SET_NV_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_NV_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_NV_RESPONSE Constructor ()

SYS_SET_NV_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_NV_RESPONSE()
C++
public:
SYS_SET_NV_RESPONSE() sealed
J#
public SYS_SET_NV_RESPONSE()
JScript
public function SYS_SET_NV_RESPONSE()

See Also

SYS_SET_NV_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_NV_RESPONSE Constructor Overload List


SYS_SET_NV_RESPONSE Constructor (SYS_SET_NV_RESPONSE.CMD_STATUS)

SYS_SET_NV_RESPONSE Constructor (SYS_SET_NV_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_NV_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_NV_RESPONSE(
SYS_SET_NV_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_NV_RESPONSE(
SYS_SET_NV_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_NV_RESPONSE(
SYS_SET_NV_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_NV_RESPONSE(
: SYS_SET_NV_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_NV_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_NV_RESPONSE Constructor Overload List


Fields

SYS_SET_NV_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_NV_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_NV_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_NV_RESPONSE.CMD_STATUS
C#
public SYS_SET_NV_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_NV_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_NV_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_NV_RESPONSE.CMD_STATUS;

See Also

SYS_SET_NV_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_NV_RESPONSE.CMD_STATUS Enumeration

SYS_SET_NV_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_NV_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_NV_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_NV_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_NV_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_NV_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_SET_PANID Class

SYS_SET_PANID Class
See Also Example Members
[image]

Use this message to set PANID.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_PANID
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_PANID : IREQUEST, ISYSTEM
C++
ref class SYS_SET_PANID : IREQUEST, ISYSTEM
J#
public class SYS_SET_PANID implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_PANID extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_PANID

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_PANID Members
TI.ZPI1 Namespace


SYS_SET_PANID Members

SYS_SET_PANID Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set PANID.

The following tables list the members exposed by SYS_SET_PANID.

Public Constructors

Name | Description
SYS_SET_PANID | Overloaded.
Top

Public Fields

 | Name | Description
Public field | PanID | PanID.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_PANID | Overloaded.
Top

See Also

SYS_SET_PANID Class
TI.ZPI1 Namespace


SYS_SET_PANID Constructor

SYS_SET_PANID Constructor

Overload List

 | Name | Description
Public method | SYS_SET_PANID | Constructor
Public method | SYS_SET_PANID (UInt16) | Constructor

See Also

SYS_SET_PANID Class
TI.ZPI1 Namespace


SYS_SET_PANID Constructor ()

SYS_SET_PANID Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_PANID()
C++
public:
SYS_SET_PANID() sealed
J#
public SYS_SET_PANID()
JScript
public function SYS_SET_PANID()

See Also

SYS_SET_PANID Class
TI.ZPI1 Namespace
SYS_SET_PANID Constructor Overload List


SYS_SET_PANID Constructor (UInt16)

SYS_SET_PANID Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public SYS_SET_PANID(
ushort
)
C++
public:
SYS_SET_PANID(
unsigned short
) sealed
J#
public SYS_SET_PANID(
ushort
)
JScript
public function SYS_SET_PANID(
: UInt16
)

See Also

SYS_SET_PANID Class
TI.ZPI1 Namespace
SYS_SET_PANID Constructor Overload List


Fields

SYS_SET_PANID Fields
[image]

Public Fields

 | Name | Description
Public field | PanID | PanID.
Top

See Also

SYS_SET_PANID Class
TI.ZPI1 Namespace


PanID Field

SYS_SET_PANID.PanID Field
[image]

PanID.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

SYS_SET_PANID Class
TI.ZPI1 Namespace


SYS_SET_PANID_RESPONSE Class

SYS_SET_PANID_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_PANID

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_PANID_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_PANID_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_PANID_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_PANID_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_PANID_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_PANID_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_PANID_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_PANID_RESPONSE Members

SYS_SET_PANID_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_PANID

The following tables list the members exposed by SYS_SET_PANID_RESPONSE.

Public Constructors

Name | Description
SYS_SET_PANID_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_PANID_RESPONSE | Overloaded.
Top

See Also

SYS_SET_PANID_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_PANID_RESPONSE Constructor

SYS_SET_PANID_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_PANID_RESPONSE | Constructor
Public method | SYS_SET_PANID_RESPONSE (SYS_SET_PANID_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_PANID_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_PANID_RESPONSE Constructor ()

SYS_SET_PANID_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_PANID_RESPONSE()
C++
public:
SYS_SET_PANID_RESPONSE() sealed
J#
public SYS_SET_PANID_RESPONSE()
JScript
public function SYS_SET_PANID_RESPONSE()

See Also

SYS_SET_PANID_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_PANID_RESPONSE Constructor Overload List


SYS_SET_PANID_RESPONSE Constructor (SYS_SET_PANID_RESPONSE.CMD_STATUS)

SYS_SET_PANID_RESPONSE Constructor (SYS_SET_PANID_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_PANID_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_PANID_RESPONSE(
SYS_SET_PANID_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_PANID_RESPONSE(
SYS_SET_PANID_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_PANID_RESPONSE(
SYS_SET_PANID_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_PANID_RESPONSE(
: SYS_SET_PANID_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_PANID_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_PANID_RESPONSE Constructor Overload List


Fields

SYS_SET_PANID_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_PANID_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_PANID_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_PANID_RESPONSE.CMD_STATUS
C#
public SYS_SET_PANID_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_PANID_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_PANID_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_PANID_RESPONSE.CMD_STATUS;

See Also

SYS_SET_PANID_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_PANID_RESPONSE.CMD_STATUS Enumeration

SYS_SET_PANID_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_PANID_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_PANID_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_PANID_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_PANID_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_PANID_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY Class

SYS_SET_PRECONFIG_KEY Class
See Also Example Members
[image]

Use this message to set the preconfig key.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_PRECONFIG_KEY
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_PRECONFIG_KEY : IREQUEST, ISYSTEM
C++
ref class SYS_SET_PRECONFIG_KEY : IREQUEST, ISYSTEM
J#
public class SYS_SET_PRECONFIG_KEY implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_PRECONFIG_KEY extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_PRECONFIG_KEY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_PRECONFIG_KEY Members
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY Members

SYS_SET_PRECONFIG_KEY Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set the preconfig key.

The following tables list the members exposed by SYS_SET_PRECONFIG_KEY.

Public Constructors

Name | Description
SYS_SET_PRECONFIG_KEY | Overloaded.
Top

Public Fields

 | Name | Description
Public field | PreConfigKey | PreConfigKey.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_PRECONFIG_KEY | Overloaded.
Top

See Also

SYS_SET_PRECONFIG_KEY Class
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY Constructor

SYS_SET_PRECONFIG_KEY Constructor

Overload List

 | Name | Description
Public method | SYS_SET_PRECONFIG_KEY | Constructor
Public method | SYS_SET_PRECONFIG_KEY (Byte) | Constructor

See Also

SYS_SET_PRECONFIG_KEY Class
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY Constructor ()

SYS_SET_PRECONFIG_KEY Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_PRECONFIG_KEY()
C++
public:
SYS_SET_PRECONFIG_KEY() sealed
J#
public SYS_SET_PRECONFIG_KEY()
JScript
public function SYS_SET_PRECONFIG_KEY()

See Also

SYS_SET_PRECONFIG_KEY Class
TI.ZPI1 Namespace
SYS_SET_PRECONFIG_KEY Constructor Overload List


SYS_SET_PRECONFIG_KEY Constructor (Byte[])

SYS_SET_PRECONFIG_KEY Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public SYS_SET_PRECONFIG_KEY(
byte[]
)
C++
public:
SYS_SET_PRECONFIG_KEY(
array<char>^
) sealed
J#
public SYS_SET_PRECONFIG_KEY(
byte[]
)
JScript
public function SYS_SET_PRECONFIG_KEY(
: Byte[]
)

See Also

SYS_SET_PRECONFIG_KEY Class
TI.ZPI1 Namespace
SYS_SET_PRECONFIG_KEY Constructor Overload List


Fields

SYS_SET_PRECONFIG_KEY Fields
[image]

Public Fields

 | Name | Description
Public field | PreConfigKey | PreConfigKey.
Top

See Also

SYS_SET_PRECONFIG_KEY Class
TI.ZPI1 Namespace


PreConfigKey Field

SYS_SET_PRECONFIG_KEY.PreConfigKey Field
[image]

PreConfigKey.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PreConfigKey As Byte()
C#
public byte[] PreConfigKey;
C++
public:
array<char>^ PreConfigKey sealed ;
J#
public byte[] PreConfigKey
JScript
public PreConfigKey : Byte[];

See Also

SYS_SET_PRECONFIG_KEY Class
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY_RESPONSE Class

SYS_SET_PRECONFIG_KEY_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_PRECONFIG_KEY

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_PRECONFIG_KEY_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_PRECONFIG_KEY_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_PRECONFIG_KEY_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_PRECONFIG_KEY_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_PRECONFIG_KEY_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_PRECONFIG_KEY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_PRECONFIG_KEY_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY_RESPONSE Members

SYS_SET_PRECONFIG_KEY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_PRECONFIG_KEY

The following tables list the members exposed by SYS_SET_PRECONFIG_KEY_RESPONSE.

Public Constructors

Name | Description
SYS_SET_PRECONFIG_KEY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_PRECONFIG_KEY_RESPONSE | Overloaded.
Top

See Also

SYS_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY_RESPONSE Constructor

SYS_SET_PRECONFIG_KEY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_PRECONFIG_KEY_RESPONSE | Constructor
Public method | SYS_SET_PRECONFIG_KEY_RESPONSE (SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY_RESPONSE Constructor ()

SYS_SET_PRECONFIG_KEY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_PRECONFIG_KEY_RESPONSE()
C++
public:
SYS_SET_PRECONFIG_KEY_RESPONSE() sealed
J#
public SYS_SET_PRECONFIG_KEY_RESPONSE()
JScript
public function SYS_SET_PRECONFIG_KEY_RESPONSE()

See Also

SYS_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_PRECONFIG_KEY_RESPONSE Constructor Overload List


SYS_SET_PRECONFIG_KEY_RESPONSE Constructor (SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS)

SYS_SET_PRECONFIG_KEY_RESPONSE Constructor (SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_PRECONFIG_KEY_RESPONSE(
SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_PRECONFIG_KEY_RESPONSE(
SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_PRECONFIG_KEY_RESPONSE(
SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_PRECONFIG_KEY_RESPONSE(
: SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_PRECONFIG_KEY_RESPONSE Constructor Overload List


Fields

SYS_SET_PRECONFIG_KEY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_PRECONFIG_KEY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
C#
public SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS;

See Also

SYS_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Enumeration

SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL Class

SYS_SET_SECURITY_LEVEL Class
See Also Example Members
[image]

Use this message to set the security level.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_SECURITY_LEVEL
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_SECURITY_LEVEL : IREQUEST, ISYSTEM
C++
ref class SYS_SET_SECURITY_LEVEL : IREQUEST, ISYSTEM
J#
public class SYS_SET_SECURITY_LEVEL implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_SECURITY_LEVEL extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_SECURITY_LEVEL

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_SECURITY_LEVEL Members
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL Members

SYS_SET_SECURITY_LEVEL Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set the security level.

The following tables list the members exposed by SYS_SET_SECURITY_LEVEL.

Public Constructors

Name | Description
SYS_SET_SECURITY_LEVEL | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SecurityLevel | Security Level.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_SECURITY_LEVEL | Overloaded.
Top

See Also

SYS_SET_SECURITY_LEVEL Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL Constructor

SYS_SET_SECURITY_LEVEL Constructor

Overload List

 | Name | Description
Public method | SYS_SET_SECURITY_LEVEL | Constructor
Public method | SYS_SET_SECURITY_LEVEL (Byte) | Constructor

See Also

SYS_SET_SECURITY_LEVEL Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL Constructor ()

SYS_SET_SECURITY_LEVEL Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_SECURITY_LEVEL()
C++
public:
SYS_SET_SECURITY_LEVEL() sealed
J#
public SYS_SET_SECURITY_LEVEL()
JScript
public function SYS_SET_SECURITY_LEVEL()

See Also

SYS_SET_SECURITY_LEVEL Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_LEVEL Constructor Overload List


SYS_SET_SECURITY_LEVEL Constructor (Byte)

SYS_SET_SECURITY_LEVEL Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_SET_SECURITY_LEVEL(
byte
)
C++
public:
SYS_SET_SECURITY_LEVEL(
char
) sealed
J#
public SYS_SET_SECURITY_LEVEL(
byte
)
JScript
public function SYS_SET_SECURITY_LEVEL(
: Byte
)

See Also

SYS_SET_SECURITY_LEVEL Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_LEVEL Constructor Overload List


Fields

SYS_SET_SECURITY_LEVEL Fields
[image]

Public Fields

 | Name | Description
Public field | SecurityLevel | Security Level.
Top

See Also

SYS_SET_SECURITY_LEVEL Class
TI.ZPI1 Namespace


SecurityLevel Field

SYS_SET_SECURITY_LEVEL.SecurityLevel Field
[image]

Security Level.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As Byte
C#
public byte SecurityLevel;
C++
public:
char SecurityLevel sealed ;
J#
public byte SecurityLevel
JScript
public SecurityLevel : Byte;

See Also

SYS_SET_SECURITY_LEVEL Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL_RESPONSE Class

SYS_SET_SECURITY_LEVEL_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_SECURITY_LEVEL

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_SECURITY_LEVEL_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_SECURITY_LEVEL_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_SECURITY_LEVEL_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_SECURITY_LEVEL_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_SECURITY_LEVEL_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_SECURITY_LEVEL_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_SECURITY_LEVEL_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL_RESPONSE Members

SYS_SET_SECURITY_LEVEL_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_SECURITY_LEVEL

The following tables list the members exposed by SYS_SET_SECURITY_LEVEL_RESPONSE.

Public Constructors

Name | Description
SYS_SET_SECURITY_LEVEL_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_SECURITY_LEVEL_RESPONSE | Overloaded.
Top

See Also

SYS_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL_RESPONSE Constructor

SYS_SET_SECURITY_LEVEL_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_SECURITY_LEVEL_RESPONSE | Constructor
Public method | SYS_SET_SECURITY_LEVEL_RESPONSE (SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL_RESPONSE Constructor ()

SYS_SET_SECURITY_LEVEL_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_SECURITY_LEVEL_RESPONSE()
C++
public:
SYS_SET_SECURITY_LEVEL_RESPONSE() sealed
J#
public SYS_SET_SECURITY_LEVEL_RESPONSE()
JScript
public function SYS_SET_SECURITY_LEVEL_RESPONSE()

See Also

SYS_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_LEVEL_RESPONSE Constructor Overload List


SYS_SET_SECURITY_LEVEL_RESPONSE Constructor (SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS)

SYS_SET_SECURITY_LEVEL_RESPONSE Constructor (SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_SECURITY_LEVEL_RESPONSE(
SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_SECURITY_LEVEL_RESPONSE(
SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_SECURITY_LEVEL_RESPONSE(
SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_SECURITY_LEVEL_RESPONSE(
: SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_LEVEL_RESPONSE Constructor Overload List


Fields

SYS_SET_SECURITY_LEVEL_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_SECURITY_LEVEL_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
C#
public SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS;

See Also

SYS_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Enumeration

SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE Class

SYS_SET_SECURITY_MODE Class
See Also Example Members
[image]

Use this message to get the NV information.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_SECURITY_MODE
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_SECURITY_MODE : IREQUEST, ISYSTEM
C++
ref class SYS_SET_SECURITY_MODE : IREQUEST, ISYSTEM
J#
public class SYS_SET_SECURITY_MODE implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_SECURITY_MODE extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_SECURITY_MODE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_SECURITY_MODE Members
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE Members

SYS_SET_SECURITY_MODE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to get the NV information.

The following tables list the members exposed by SYS_SET_SECURITY_MODE.

Public Constructors

Name | Description
SYS_SET_SECURITY_MODE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SecurityMode | Security mode to use the next time the target device resets. Zero is used to disable security
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_SECURITY_MODE | Overloaded.
Top

See Also

SYS_SET_SECURITY_MODE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE Constructor

SYS_SET_SECURITY_MODE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_SECURITY_MODE | Constructor
Public method | SYS_SET_SECURITY_MODE (Byte) | Constructor

See Also

SYS_SET_SECURITY_MODE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE Constructor ()

SYS_SET_SECURITY_MODE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_SECURITY_MODE()
C++
public:
SYS_SET_SECURITY_MODE() sealed
J#
public SYS_SET_SECURITY_MODE()
JScript
public function SYS_SET_SECURITY_MODE()

See Also

SYS_SET_SECURITY_MODE Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_MODE Constructor Overload List


SYS_SET_SECURITY_MODE Constructor (Byte)

SYS_SET_SECURITY_MODE Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_SET_SECURITY_MODE(
byte
)
C++
public:
SYS_SET_SECURITY_MODE(
char
) sealed
J#
public SYS_SET_SECURITY_MODE(
byte
)
JScript
public function SYS_SET_SECURITY_MODE(
: Byte
)

See Also

SYS_SET_SECURITY_MODE Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_MODE Constructor Overload List


Fields

SYS_SET_SECURITY_MODE Fields
[image]

Public Fields

 | Name | Description
Public field | SecurityMode | Security mode to use the next time the target device resets. Zero is used to disable security
Top

See Also

SYS_SET_SECURITY_MODE Class
TI.ZPI1 Namespace


SecurityMode Field

SYS_SET_SECURITY_MODE.SecurityMode Field
[image]

Security mode to use the next time the target device resets. Zero is used to disable security

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityMode As Byte
C#
public byte SecurityMode;
C++
public:
char SecurityMode sealed ;
J#
public byte SecurityMode
JScript
public SecurityMode : Byte;

See Also

SYS_SET_SECURITY_MODE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE_RESPONSE Class

SYS_SET_SECURITY_MODE_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_SECURITY_MODE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_SECURITY_MODE_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_SECURITY_MODE_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_SECURITY_MODE_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_SET_SECURITY_MODE_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_SECURITY_MODE_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_SET_SECURITY_MODE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_SECURITY_MODE_RESPONSE Members
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE_RESPONSE Members

SYS_SET_SECURITY_MODE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_SECURITY_MODE

The following tables list the members exposed by SYS_SET_SECURITY_MODE_RESPONSE.

Public Constructors

Name | Description
SYS_SET_SECURITY_MODE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_SECURITY_MODE_RESPONSE | Overloaded.
Top

See Also

SYS_SET_SECURITY_MODE_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE_RESPONSE Constructor

SYS_SET_SECURITY_MODE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_SET_SECURITY_MODE_RESPONSE | Constructor
Public method | SYS_SET_SECURITY_MODE_RESPONSE (SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS) |

See Also

SYS_SET_SECURITY_MODE_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE_RESPONSE Constructor ()

SYS_SET_SECURITY_MODE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_SECURITY_MODE_RESPONSE()
C++
public:
SYS_SET_SECURITY_MODE_RESPONSE() sealed
J#
public SYS_SET_SECURITY_MODE_RESPONSE()
JScript
public function SYS_SET_SECURITY_MODE_RESPONSE()

See Also

SYS_SET_SECURITY_MODE_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_MODE_RESPONSE Constructor Overload List


SYS_SET_SECURITY_MODE_RESPONSE Constructor (SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS)

SYS_SET_SECURITY_MODE_RESPONSE Constructor (SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS _
)
C#
public SYS_SET_SECURITY_MODE_RESPONSE(
SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS
)
C++
public:
SYS_SET_SECURITY_MODE_RESPONSE(
SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS
) sealed
J#
public SYS_SET_SECURITY_MODE_RESPONSE(
SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS
)
JScript
public function SYS_SET_SECURITY_MODE_RESPONSE(
: SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS
)

See Also

SYS_SET_SECURITY_MODE_RESPONSE Class
TI.ZPI1 Namespace
SYS_SET_SECURITY_MODE_RESPONSE Constructor Overload List


Fields

SYS_SET_SECURITY_MODE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_SECURITY_MODE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

SYS_SET_SECURITY_MODE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS
C#
public SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS Status;
C++
public:
SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS Status sealed ;
J#
public SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS Status
JScript
public Status : SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS;

See Also

SYS_SET_SECURITY_MODE_RESPONSE Class
TI.ZPI1 Namespace


SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS Enumeration

SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS As Byte
C#
public enum SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS : byte
C++
public enum class SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS : char
J#
public enum SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS byte
JScript
public enum SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


SYS_STRING_RESPONSE Class

SYS_STRING_RESPONSE Class
See Also Example Members
[image]

Debug message sent by device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_STRING_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_STRING_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_STRING_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_STRING_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_STRING_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_STRING_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_STRING_RESPONSE Members
TI.ZPI1 Namespace


SYS_STRING_RESPONSE Members

SYS_STRING_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Debug message sent by device

The following tables list the members exposed by SYS_STRING_RESPONSE.

Public Constructors

Name | Description
SYS_STRING_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DebugString | Debug string sent by device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_STRING_RESPONSE | Overloaded.
Top

See Also

SYS_STRING_RESPONSE Class
TI.ZPI1 Namespace


SYS_STRING_RESPONSE Constructor

SYS_STRING_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_STRING_RESPONSE | Constructor
Public method | SYS_STRING_RESPONSE (Byte) | Constructor

See Also

SYS_STRING_RESPONSE Class
TI.ZPI1 Namespace


SYS_STRING_RESPONSE Constructor ()

SYS_STRING_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_STRING_RESPONSE()
C++
public:
SYS_STRING_RESPONSE() sealed
J#
public SYS_STRING_RESPONSE()
JScript
public function SYS_STRING_RESPONSE()

See Also

SYS_STRING_RESPONSE Class
TI.ZPI1 Namespace
SYS_STRING_RESPONSE Constructor Overload List


SYS_STRING_RESPONSE Constructor (Byte[])

SYS_STRING_RESPONSE Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public SYS_STRING_RESPONSE(
byte[]
)
C++
public:
SYS_STRING_RESPONSE(
array<char>^
) sealed
J#
public SYS_STRING_RESPONSE(
byte[]
)
JScript
public function SYS_STRING_RESPONSE(
: Byte[]
)

See Also

SYS_STRING_RESPONSE Class
TI.ZPI1 Namespace
SYS_STRING_RESPONSE Constructor Overload List


Fields

SYS_STRING_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | DebugString | Debug string sent by device
Top

See Also

SYS_STRING_RESPONSE Class
TI.ZPI1 Namespace


DebugString Field

SYS_STRING_RESPONSE.DebugString Field
[image]

Debug string sent by device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DebugString As Byte()
C#
public byte[] DebugString;
C++
public:
array<char>^ DebugString sealed ;
J#
public byte[] DebugString
JScript
public DebugString : Byte[];

See Also

SYS_STRING_RESPONSE Class
TI.ZPI1 Namespace


SYS_VERSION Class

SYS_VERSION Class
See Also Example Members
[image]

Ask for the device's version string.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_VERSION
Implements IREQUEST, ISYSTEM
C#
public class SYS_VERSION : IREQUEST, ISYSTEM
C++
ref class SYS_VERSION : IREQUEST, ISYSTEM
J#
public class SYS_VERSION implements IREQUEST, ISYSTEM
JScript
public class SYS_VERSION extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_VERSION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_VERSION Members
TI.ZPI1 Namespace


SYS_VERSION Members

SYS_VERSION Members
See Also Example Constructors Methods
[image]

Ask for the device's version string.

The following tables list the members exposed by SYS_VERSION.

Public Constructors

 | Name | Description
Public method | SYS_VERSION | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_VERSION Class
TI.ZPI1 Namespace


SYS_VERSION Constructor

SYS_VERSION Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_VERSION()
C++
public:
SYS_VERSION() sealed
J#
public SYS_VERSION()
JScript
public function SYS_VERSION()

See Also

SYS_VERSION Class
TI.ZPI1 Namespace


SYS_VERSION_RESPONSE Class

SYS_VERSION_RESPONSE Class
See Also Example Members
[image]

Response for SYS_VERSION

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_VERSION_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_VERSION_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_VERSION_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_VERSION_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_VERSION_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI1.SYS_VERSION_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_VERSION_RESPONSE Members
TI.ZPI1 Namespace


SYS_VERSION_RESPONSE Members

SYS_VERSION_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_VERSION

The following tables list the members exposed by SYS_VERSION_RESPONSE.

Public Constructors

Name | Description
SYS_VERSION_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Version | Dynamic array, device defined ASCII string (NOT null terminated).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_VERSION_RESPONSE | Overloaded.
Top

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI1 Namespace


SYS_VERSION_RESPONSE Constructor

SYS_VERSION_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_VERSION_RESPONSE | Constructor
Public method | SYS_VERSION_RESPONSE (Byte) | Constructor

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI1 Namespace


SYS_VERSION_RESPONSE Constructor ()

SYS_VERSION_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_VERSION_RESPONSE()
C++
public:
SYS_VERSION_RESPONSE() sealed
J#
public SYS_VERSION_RESPONSE()
JScript
public function SYS_VERSION_RESPONSE()

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI1 Namespace
SYS_VERSION_RESPONSE Constructor Overload List


SYS_VERSION_RESPONSE Constructor (Byte[])

SYS_VERSION_RESPONSE Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public SYS_VERSION_RESPONSE(
byte[]
)
C++
public:
SYS_VERSION_RESPONSE(
array<char>^
) sealed
J#
public SYS_VERSION_RESPONSE(
byte[]
)
JScript
public function SYS_VERSION_RESPONSE(
: Byte[]
)

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI1 Namespace
SYS_VERSION_RESPONSE Constructor Overload List


Fields

SYS_VERSION_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Version | Dynamic array, device defined ASCII string (NOT null terminated).
Top

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI1 Namespace


Version Field

SYS_VERSION_RESPONSE.Version Field
[image]

Dynamic array, device defined ASCII string (NOT null terminated).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Version As Byte()
C#
public byte[] Version;
C++
public:
array<char>^ Version sealed ;
J#
public byte[] Version
JScript
public Version : Byte[];

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI1 Namespace


USERTEST_REQUEST Class

USERTEST_REQUEST Class
See Also Example Members
[image]

This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class USERTEST_REQUEST
Implements IREQUEST, IUSERTEST
C#
public class USERTEST_REQUEST : IREQUEST, IUSERTEST
C++
ref class USERTEST_REQUEST : IREQUEST, IUSERTEST
J#
public class USERTEST_REQUEST implements IREQUEST, IUSERTEST
JScript
public class USERTEST_REQUEST extends IREQUEST, IUSERTEST

Inheritance Hierarchy

System.Object
TI.ZPI1.USERTEST_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

USERTEST_REQUEST Members
TI.ZPI1 Namespace


USERTEST_REQUEST Members

USERTEST_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).

The following tables list the members exposed by USERTEST_REQUEST.

Public Constructors

Name | Description
USERTEST_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CommandID | Command ID of the message
Public field | Endpoint | indicates the endpoint of the application
Public field | Param1 | first parameter of the command (usually an On/Off indicator or a level indicating value)
Public field | Param2 | second parameter of the command (usually an On/Off indicator or a level indicating value)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
USERTEST_REQUEST | Overloaded.
Top

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace


USERTEST_REQUEST Constructor

USERTEST_REQUEST Constructor

Overload List

 | Name | Description
Public method | USERTEST_REQUEST | Constructor
Public method | USERTEST_REQUEST (Byte, UInt16, UInt16, UInt16) | Constructor

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace


USERTEST_REQUEST Constructor ()

USERTEST_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public USERTEST_REQUEST()
C++
public:
USERTEST_REQUEST() sealed
J#
public USERTEST_REQUEST()
JScript
public function USERTEST_REQUEST()

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace
USERTEST_REQUEST Constructor Overload List


USERTEST_REQUEST Constructor (Byte, UInt16, UInt16, UInt16)

USERTEST_REQUEST Constructor (Byte, UInt16, UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public USERTEST_REQUEST(
byte ,
ushort ,
ushort ,
ushort
)
C++
public:
USERTEST_REQUEST(
char ,
unsigned short ,
unsigned short ,
unsigned short
) sealed
J#
public USERTEST_REQUEST(
byte ,
ushort ,
ushort ,
ushort
)
JScript
public function USERTEST_REQUEST(
: Byte,
: UInt16,
: UInt16,
: UInt16
)

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace
USERTEST_REQUEST Constructor Overload List


Fields

USERTEST_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CommandID | Command ID of the message
Public field | Endpoint | indicates the endpoint of the application
Public field | Param1 | first parameter of the command (usually an On/Off indicator or a level indicating value)
Public field | Param2 | second parameter of the command (usually an On/Off indicator or a level indicating value)
Top

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace


CommandID Field

USERTEST_REQUEST.CommandID Field
[image]

Command ID of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandID As UInt16
C#
public ushort CommandID;
C++
public:
unsigned short CommandID sealed ;
J#
public ushort CommandID
JScript
public CommandID : UInt16;

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace


Endpoint Field

USERTEST_REQUEST.Endpoint Field
[image]

indicates the endpoint of the application

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace


Param1 Field

USERTEST_REQUEST.Param1 Field
[image]

first parameter of the command (usually an On/Off indicator or a level indicating value)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Param1 As UInt16
C#
public ushort Param1;
C++
public:
unsigned short Param1 sealed ;
J#
public ushort Param1
JScript
public Param1 : UInt16;

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace


Param2 Field

USERTEST_REQUEST.Param2 Field
[image]

second parameter of the command (usually an On/Off indicator or a level indicating value)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Param2 As UInt16
C#
public ushort Param2;
C++
public:
unsigned short Param2 sealed ;
J#
public ushort Param2
JScript
public Param2 : UInt16;

See Also

USERTEST_REQUEST Class
TI.ZPI1 Namespace


USERTEST_RESPONSE Class

USERTEST_RESPONSE Class
See Also Example Members
[image]

Response for USERTEST_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class USERTEST_RESPONSE
Implements IRESPONSE, IUSERTEST
C#
public class USERTEST_RESPONSE : IRESPONSE, IUSERTEST
C++
ref class USERTEST_RESPONSE : IRESPONSE, IUSERTEST
J#
public class USERTEST_RESPONSE implements IRESPONSE, IUSERTEST
JScript
public class USERTEST_RESPONSE extends IRESPONSE, IUSERTEST

Inheritance Hierarchy

System.Object
TI.ZPI1.USERTEST_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

USERTEST_RESPONSE Members
TI.ZPI1 Namespace


USERTEST_RESPONSE Members

USERTEST_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for USERTEST_REQUEST

The following tables list the members exposed by USERTEST_RESPONSE.

Public Constructors

Name | Description
USERTEST_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
USERTEST_RESPONSE | Overloaded.
Top

See Also

USERTEST_RESPONSE Class
TI.ZPI1 Namespace


USERTEST_RESPONSE Constructor

USERTEST_RESPONSE Constructor

Overload List

 | Name | Description
Public method | USERTEST_RESPONSE | Constructor
Public method | USERTEST_RESPONSE (USERTEST_RESPONSE.CMD_STATUS) |

See Also

USERTEST_RESPONSE Class
TI.ZPI1 Namespace


USERTEST_RESPONSE Constructor ()

USERTEST_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public USERTEST_RESPONSE()
C++
public:
USERTEST_RESPONSE() sealed
J#
public USERTEST_RESPONSE()
JScript
public function USERTEST_RESPONSE()

See Also

USERTEST_RESPONSE Class
TI.ZPI1 Namespace
USERTEST_RESPONSE Constructor Overload List


USERTEST_RESPONSE Constructor (USERTEST_RESPONSE.CMD_STATUS)

USERTEST_RESPONSE Constructor (USERTEST_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As USERTEST_RESPONSE.CMD_STATUS _
)
C#
public USERTEST_RESPONSE(
USERTEST_RESPONSE.CMD_STATUS
)
C++
public:
USERTEST_RESPONSE(
USERTEST_RESPONSE.CMD_STATUS
) sealed
J#
public USERTEST_RESPONSE(
USERTEST_RESPONSE.CMD_STATUS
)
JScript
public function USERTEST_RESPONSE(
: USERTEST_RESPONSE.CMD_STATUS
)

See Also

USERTEST_RESPONSE Class
TI.ZPI1 Namespace
USERTEST_RESPONSE Constructor Overload List


Fields

USERTEST_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

USERTEST_RESPONSE Class
TI.ZPI1 Namespace


Status Field

USERTEST_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As USERTEST_RESPONSE.CMD_STATUS
C#
public USERTEST_RESPONSE.CMD_STATUS Status;
C++
public:
USERTEST_RESPONSE.CMD_STATUS Status sealed ;
J#
public USERTEST_RESPONSE.CMD_STATUS Status
JScript
public Status : USERTEST_RESPONSE.CMD_STATUS;

See Also

USERTEST_RESPONSE Class
TI.ZPI1 Namespace


USERTEST_RESPONSE.CMD_STATUS Enumeration

USERTEST_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum USERTEST_RESPONSE.CMD_STATUS As Byte
C#
public enum USERTEST_RESPONSE.CMD_STATUS : byte
C++
public enum class USERTEST_RESPONSE.CMD_STATUS : char
J#
public enum USERTEST_RESPONSE.CMD_STATUS byte
JScript
public enum USERTEST_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZB_ALLOW_BIND Class

ZB_ALLOW_BIND Class
See Also Example Members
[image]

Puts the device into the Allow Bind mode (zb_AllowBind).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_ALLOW_BIND
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_ALLOW_BIND : IREQUEST, ISIMPLEAPI
C++
ref class ZB_ALLOW_BIND : IREQUEST, ISIMPLEAPI
J#
public class ZB_ALLOW_BIND implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_ALLOW_BIND extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_ALLOW_BIND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_ALLOW_BIND Members
TI.ZPI1 Namespace


ZB_ALLOW_BIND Members

ZB_ALLOW_BIND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Puts the device into the Allow Bind mode (zb_AllowBind).

The following tables list the members exposed by ZB_ALLOW_BIND.

Public Constructors

Name | Description
ZB_ALLOW_BIND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Seconds | The number of seconds ( max. 64 ) for which the device will remain in the Allow Bind mode ( If 0, the device will turn off Allow Bind mode immediately. If 0xFF, the device will remain in the mode indefinitely. )
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_ALLOW_BIND | Overloaded.
Top

See Also

ZB_ALLOW_BIND Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND Constructor

ZB_ALLOW_BIND Constructor

Overload List

 | Name | Description
Public method | ZB_ALLOW_BIND | Constructor
Public method | ZB_ALLOW_BIND (Byte) | Constructor

See Also

ZB_ALLOW_BIND Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND Constructor ()

ZB_ALLOW_BIND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_ALLOW_BIND()
C++
public:
ZB_ALLOW_BIND() sealed
J#
public ZB_ALLOW_BIND()
JScript
public function ZB_ALLOW_BIND()

See Also

ZB_ALLOW_BIND Class
TI.ZPI1 Namespace
ZB_ALLOW_BIND Constructor Overload List


ZB_ALLOW_BIND Constructor (Byte)

ZB_ALLOW_BIND Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_ALLOW_BIND(
byte
)
C++
public:
ZB_ALLOW_BIND(
char
) sealed
J#
public ZB_ALLOW_BIND(
byte
)
JScript
public function ZB_ALLOW_BIND(
: Byte
)

See Also

ZB_ALLOW_BIND Class
TI.ZPI1 Namespace
ZB_ALLOW_BIND Constructor Overload List


Fields

ZB_ALLOW_BIND Fields
[image]

Public Fields

 | Name | Description
Public field | Seconds | The number of seconds ( max. 64 ) for which the device will remain in the Allow Bind mode ( If 0, the device will turn off Allow Bind mode immediately. If 0xFF, the device will remain in the mode indefinitely. )
Top

See Also

ZB_ALLOW_BIND Class
TI.ZPI1 Namespace


Seconds Field

ZB_ALLOW_BIND.Seconds Field
[image]

The number of seconds ( max. 64 ) for which the device will remain in the Allow Bind mode ( If 0, the device will turn off Allow Bind mode immediately. If 0xFF, the device will remain in the mode indefinitely. )

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Seconds As Byte
C#
public byte Seconds;
C++
public:
char Seconds sealed ;
J#
public byte Seconds
JScript
public Seconds : Byte;

See Also

ZB_ALLOW_BIND Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND_CNF Class

ZB_ALLOW_BIND_CNF Class
See Also Example Members
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_ALLOW_BIND_CNF
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_ALLOW_BIND_CNF : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_ALLOW_BIND_CNF : IRESPONSE, ISIMPLEAPI
J#
public class ZB_ALLOW_BIND_CNF implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_ALLOW_BIND_CNF extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_ALLOW_BIND_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_ALLOW_BIND_CNF Members
TI.ZPI1 Namespace


ZB_ALLOW_BIND_CNF Members

ZB_ALLOW_BIND_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by ZB_ALLOW_BIND_CNF.

Public Constructors

Name | Description
ZB_ALLOW_BIND_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Source | The 16-bit address of the source device that requested a binding.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_ALLOW_BIND_CNF | Overloaded.
Top

See Also

ZB_ALLOW_BIND_CNF Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND_CNF Constructor

ZB_ALLOW_BIND_CNF Constructor

Overload List

 | Name | Description
Public method | ZB_ALLOW_BIND_CNF | Constructor
Public method | ZB_ALLOW_BIND_CNF (UInt16) | Constructor

See Also

ZB_ALLOW_BIND_CNF Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND_CNF Constructor ()

ZB_ALLOW_BIND_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_ALLOW_BIND_CNF()
C++
public:
ZB_ALLOW_BIND_CNF() sealed
J#
public ZB_ALLOW_BIND_CNF()
JScript
public function ZB_ALLOW_BIND_CNF()

See Also

ZB_ALLOW_BIND_CNF Class
TI.ZPI1 Namespace
ZB_ALLOW_BIND_CNF Constructor Overload List


ZB_ALLOW_BIND_CNF Constructor (UInt16)

ZB_ALLOW_BIND_CNF Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public ZB_ALLOW_BIND_CNF(
ushort
)
C++
public:
ZB_ALLOW_BIND_CNF(
unsigned short
) sealed
J#
public ZB_ALLOW_BIND_CNF(
ushort
)
JScript
public function ZB_ALLOW_BIND_CNF(
: UInt16
)

See Also

ZB_ALLOW_BIND_CNF Class
TI.ZPI1 Namespace
ZB_ALLOW_BIND_CNF Constructor Overload List


Fields

ZB_ALLOW_BIND_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Source | The 16-bit address of the source device that requested a binding.
Top

See Also

ZB_ALLOW_BIND_CNF Class
TI.ZPI1 Namespace


Source Field

ZB_ALLOW_BIND_CNF.Source Field
[image]

The 16-bit address of the source device that requested a binding.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Source As UInt16
C#
public ushort Source;
C++
public:
unsigned short Source sealed ;
J#
public ushort Source
JScript
public Source : UInt16;

See Also

ZB_ALLOW_BIND_CNF Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND_RSP Class

ZB_ALLOW_BIND_RSP Class
See Also Example Members
[image]

Response for ZB_ALLOW_BIND

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_ALLOW_BIND_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_ALLOW_BIND_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_ALLOW_BIND_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_ALLOW_BIND_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_ALLOW_BIND_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_ALLOW_BIND_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_ALLOW_BIND_RSP Members
TI.ZPI1 Namespace


ZB_ALLOW_BIND_RSP Members

ZB_ALLOW_BIND_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_ALLOW_BIND

The following tables list the members exposed by ZB_ALLOW_BIND_RSP.

Public Constructors

Name | Description
ZB_ALLOW_BIND_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_ALLOW_BIND_RSP | Overloaded.
Top

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND_RSP Constructor

ZB_ALLOW_BIND_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_ALLOW_BIND_RSP | Constructor
Public method | ZB_ALLOW_BIND_RSP (Byte) | Constructor

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI1 Namespace


ZB_ALLOW_BIND_RSP Constructor ()

ZB_ALLOW_BIND_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_ALLOW_BIND_RSP()
C++
public:
ZB_ALLOW_BIND_RSP() sealed
J#
public ZB_ALLOW_BIND_RSP()
JScript
public function ZB_ALLOW_BIND_RSP()

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI1 Namespace
ZB_ALLOW_BIND_RSP Constructor Overload List


ZB_ALLOW_BIND_RSP Constructor (Byte)

ZB_ALLOW_BIND_RSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_ALLOW_BIND_RSP(
byte
)
C++
public:
ZB_ALLOW_BIND_RSP(
char
) sealed
J#
public ZB_ALLOW_BIND_RSP(
byte
)
JScript
public function ZB_ALLOW_BIND_RSP(
: Byte
)

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI1 Namespace
ZB_ALLOW_BIND_RSP Constructor Overload List


Fields

ZB_ALLOW_BIND_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_ALLOW_BIND_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI1 Namespace


ZB_BIND_CNF Class

ZB_BIND_CNF Class
See Also Example Members
[image]

(zb_BindConfirm)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_BIND_CNF
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_BIND_CNF : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_BIND_CNF : IRESPONSE, ISIMPLEAPI
J#
public class ZB_BIND_CNF implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_BIND_CNF extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_BIND_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_BIND_CNF Members
TI.ZPI1 Namespace


ZB_BIND_CNF Members

ZB_BIND_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

(zb_BindConfirm)

The following tables list the members exposed by ZB_BIND_CNF.

Public Constructors

Name | Description
ZB_BIND_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CommandId | The command identifier of packets for this binding.
Public field | Status | The status of the bind operation.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_BIND_CNF | Overloaded.
Top

See Also

ZB_BIND_CNF Class
TI.ZPI1 Namespace


ZB_BIND_CNF Constructor

ZB_BIND_CNF Constructor

Overload List

 | Name | Description
Public method | ZB_BIND_CNF | Constructor
Public method | ZB_BIND_CNF (UInt16, Byte) | Constructor

See Also

ZB_BIND_CNF Class
TI.ZPI1 Namespace


ZB_BIND_CNF Constructor ()

ZB_BIND_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_BIND_CNF()
C++
public:
ZB_BIND_CNF() sealed
J#
public ZB_BIND_CNF()
JScript
public function ZB_BIND_CNF()

See Also

ZB_BIND_CNF Class
TI.ZPI1 Namespace
ZB_BIND_CNF Constructor Overload List


ZB_BIND_CNF Constructor (UInt16, Byte)

ZB_BIND_CNF Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZB_BIND_CNF(
ushort ,
byte
)
C++
public:
ZB_BIND_CNF(
unsigned short ,
char
) sealed
J#
public ZB_BIND_CNF(
ushort ,
byte
)
JScript
public function ZB_BIND_CNF(
: UInt16,
: Byte
)

See Also

ZB_BIND_CNF Class
TI.ZPI1 Namespace
ZB_BIND_CNF Constructor Overload List


Fields

ZB_BIND_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | CommandId | The command identifier of packets for this binding.
Public field | Status | The status of the bind operation.
Top

See Also

ZB_BIND_CNF Class
TI.ZPI1 Namespace


CommandId Field

ZB_BIND_CNF.CommandId Field
[image]

The command identifier of packets for this binding.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandId As UInt16
C#
public ushort CommandId;
C++
public:
unsigned short CommandId sealed ;
J#
public ushort CommandId
JScript
public CommandId : UInt16;

See Also

ZB_BIND_CNF Class
TI.ZPI1 Namespace


Status Field

ZB_BIND_CNF.Status Field
[image]

The status of the bind operation.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_BIND_CNF Class
TI.ZPI1 Namespace


ZB_BIND_DEVICE Class

ZB_BIND_DEVICE Class
See Also Example Members
[image]

Create or remove a binding entry (zb_BindDevice).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_BIND_DEVICE
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_BIND_DEVICE : IREQUEST, ISIMPLEAPI
C++
ref class ZB_BIND_DEVICE : IREQUEST, ISIMPLEAPI
J#
public class ZB_BIND_DEVICE implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_BIND_DEVICE extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_BIND_DEVICE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_BIND_DEVICE Members
TI.ZPI1 Namespace


ZB_BIND_DEVICE Members

ZB_BIND_DEVICE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Create or remove a binding entry (zb_BindDevice).

The following tables list the members exposed by ZB_BIND_DEVICE.

Public Constructors

Name | Description
ZB_BIND_DEVICE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CommandID | The Command identifier of packets for this binding.
Public field | Create | TRUE ( non-zero ) to create a binding; FALSE ( zero ) to delete a binding.
Public field | Destination | IEEE address of device to establish the binding with ( all zeros indicate NULL ).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_BIND_DEVICE | Overloaded.
Top

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace


ZB_BIND_DEVICE Constructor

ZB_BIND_DEVICE Constructor

Overload List

 | Name | Description
Public method | ZB_BIND_DEVICE | Constructor
Public method | ZB_BIND_DEVICE (Byte, UInt16, UInt64) | Constructor

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace


ZB_BIND_DEVICE Constructor ()

ZB_BIND_DEVICE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_BIND_DEVICE()
C++
public:
ZB_BIND_DEVICE() sealed
J#
public ZB_BIND_DEVICE()
JScript
public function ZB_BIND_DEVICE()

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace
ZB_BIND_DEVICE Constructor Overload List


ZB_BIND_DEVICE Constructor (Byte, UInt16, UInt64)

ZB_BIND_DEVICE Constructor (Byte, UInt16, UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt64 _
)
C#
public ZB_BIND_DEVICE(
byte ,
ushort ,
ulong
)
C++
public:
ZB_BIND_DEVICE(
char ,
unsigned short ,
unsigned __int64
) sealed
J#
public ZB_BIND_DEVICE(
byte ,
ushort ,
ulong
)
JScript
public function ZB_BIND_DEVICE(
: Byte,
: UInt16,
: UInt64
)

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace
ZB_BIND_DEVICE Constructor Overload List


Fields

ZB_BIND_DEVICE Fields
[image]

Public Fields

 | Name | Description
Public field | CommandID | The Command identifier of packets for this binding.
Public field | Create | TRUE ( non-zero ) to create a binding; FALSE ( zero ) to delete a binding.
Public field | Destination | IEEE address of device to establish the binding with ( all zeros indicate NULL ).
Top

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace


CommandID Field

ZB_BIND_DEVICE.CommandID Field
[image]

The Command identifier of packets for this binding.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandID As UInt16
C#
public ushort CommandID;
C++
public:
unsigned short CommandID sealed ;
J#
public ushort CommandID
JScript
public CommandID : UInt16;

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace


Create Field

ZB_BIND_DEVICE.Create Field
[image]

TRUE ( non-zero ) to create a binding; FALSE ( zero ) to delete a binding.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Create As Byte
C#
public byte Create;
C++
public:
char Create sealed ;
J#
public byte Create
JScript
public Create : Byte;

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace


Destination Field

ZB_BIND_DEVICE.Destination Field
[image]

IEEE address of device to establish the binding with ( all zeros indicate NULL ).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Destination As UInt64
C#
public ulong Destination;
C++
public:
unsigned __int64 Destination sealed ;
J#
public ulong Destination
JScript
public Destination : UInt64;

See Also

ZB_BIND_DEVICE Class
TI.ZPI1 Namespace


ZB_BIND_DEVICE_RSP Class

ZB_BIND_DEVICE_RSP Class
See Also Example Members
[image]

Response for ZB_BIND_DEVICE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_BIND_DEVICE_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_BIND_DEVICE_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_BIND_DEVICE_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_BIND_DEVICE_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_BIND_DEVICE_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_BIND_DEVICE_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_BIND_DEVICE_RSP Members
TI.ZPI1 Namespace


ZB_BIND_DEVICE_RSP Members

ZB_BIND_DEVICE_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_BIND_DEVICE

The following tables list the members exposed by ZB_BIND_DEVICE_RSP.

Public Constructors

Name | Description
ZB_BIND_DEVICE_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_BIND_DEVICE_RSP | Overloaded.
Top

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI1 Namespace


ZB_BIND_DEVICE_RSP Constructor

ZB_BIND_DEVICE_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_BIND_DEVICE_RSP | Constructor
Public method | ZB_BIND_DEVICE_RSP (Byte) | Constructor

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI1 Namespace


ZB_BIND_DEVICE_RSP Constructor ()

ZB_BIND_DEVICE_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_BIND_DEVICE_RSP()
C++
public:
ZB_BIND_DEVICE_RSP() sealed
J#
public ZB_BIND_DEVICE_RSP()
JScript
public function ZB_BIND_DEVICE_RSP()

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI1 Namespace
ZB_BIND_DEVICE_RSP Constructor Overload List


ZB_BIND_DEVICE_RSP Constructor (Byte)

ZB_BIND_DEVICE_RSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_BIND_DEVICE_RSP(
byte
)
C++
public:
ZB_BIND_DEVICE_RSP(
char
) sealed
J#
public ZB_BIND_DEVICE_RSP(
byte
)
JScript
public function ZB_BIND_DEVICE_RSP(
: Byte
)

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI1 Namespace
ZB_BIND_DEVICE_RSP Constructor Overload List


Fields

ZB_BIND_DEVICE_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_BIND_DEVICE_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI1 Namespace


ZB_FIND_DEV Class

ZB_FIND_DEV Class
See Also Example Members
[image]

Search for a device's short address given its IEEE address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_FIND_DEV
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_FIND_DEV : IREQUEST, ISIMPLEAPI
C++
ref class ZB_FIND_DEV : IREQUEST, ISIMPLEAPI
J#
public class ZB_FIND_DEV implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_FIND_DEV extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_FIND_DEV

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_FIND_DEV Members
TI.ZPI1 Namespace


ZB_FIND_DEV Members

ZB_FIND_DEV Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Search for a device's short address given its IEEE address.

The following tables list the members exposed by ZB_FIND_DEV.

Public Constructors

Name | Description
ZB_FIND_DEV | Overloaded.
Top

Public Fields

 | Name | Description
Public field | searchKey | IEEE address of the device to find.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_FIND_DEV | Overloaded.
Top

See Also

ZB_FIND_DEV Class
TI.ZPI1 Namespace


ZB_FIND_DEV Constructor

ZB_FIND_DEV Constructor

Overload List

 | Name | Description
Public method | ZB_FIND_DEV | Constructor
Public method | ZB_FIND_DEV (UInt64) | Constructor

See Also

ZB_FIND_DEV Class
TI.ZPI1 Namespace


ZB_FIND_DEV Constructor ()

ZB_FIND_DEV Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_FIND_DEV()
C++
public:
ZB_FIND_DEV() sealed
J#
public ZB_FIND_DEV()
JScript
public function ZB_FIND_DEV()

See Also

ZB_FIND_DEV Class
TI.ZPI1 Namespace
ZB_FIND_DEV Constructor Overload List


ZB_FIND_DEV Constructor (UInt64)

ZB_FIND_DEV Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public ZB_FIND_DEV(
ulong
)
C++
public:
ZB_FIND_DEV(
unsigned __int64
) sealed
J#
public ZB_FIND_DEV(
ulong
)
JScript
public function ZB_FIND_DEV(
: UInt64
)

See Also

ZB_FIND_DEV Class
TI.ZPI1 Namespace
ZB_FIND_DEV Constructor Overload List


Fields

ZB_FIND_DEV Fields
[image]

Public Fields

 | Name | Description
Public field | searchKey | IEEE address of the device to find.
Top

See Also

ZB_FIND_DEV Class
TI.ZPI1 Namespace


searchKey Field

ZB_FIND_DEV.searchKey Field
[image]

IEEE address of the device to find.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public searchKey As UInt64
C#
public ulong searchKey;
C++
public:
unsigned __int64 searchKey sealed ;
J#
public ulong searchKey
JScript
public searchKey : UInt64;

See Also

ZB_FIND_DEV Class
TI.ZPI1 Namespace


ZB_FIND_DEV_CNF Class

ZB_FIND_DEV_CNF Class
See Also Example Members
[image]

(zb_FindDeviceConfirm)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_FIND_DEV_CNF
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_FIND_DEV_CNF : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_FIND_DEV_CNF : IRESPONSE, ISIMPLEAPI
J#
public class ZB_FIND_DEV_CNF implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_FIND_DEV_CNF extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_FIND_DEV_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_FIND_DEV_CNF Members
TI.ZPI1 Namespace


ZB_FIND_DEV_CNF Members

ZB_FIND_DEV_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

(zb_FindDeviceConfirm)

The following tables list the members exposed by ZB_FIND_DEV_CNF.

Public Constructors

Name | Description
ZB_FIND_DEV_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Result | The 16-bit short address of the device that was found.
Public field | SearchKey | The 64-bit IEEE address of device that was searched for.
Public field | SearchType | The type of search that was performed.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_FIND_DEV_CNF | Overloaded.
Top

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace


ZB_FIND_DEV_CNF Constructor

ZB_FIND_DEV_CNF Constructor

Overload List

 | Name | Description
Public method | ZB_FIND_DEV_CNF | Constructor
Public method | ZB_FIND_DEV_CNF (Byte, UInt16, UInt64) | Constructor

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace


ZB_FIND_DEV_CNF Constructor ()

ZB_FIND_DEV_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_FIND_DEV_CNF()
C++
public:
ZB_FIND_DEV_CNF() sealed
J#
public ZB_FIND_DEV_CNF()
JScript
public function ZB_FIND_DEV_CNF()

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace
ZB_FIND_DEV_CNF Constructor Overload List


ZB_FIND_DEV_CNF Constructor (Byte, UInt16, UInt64)

ZB_FIND_DEV_CNF Constructor (Byte, UInt16, UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt64 _
)
C#
public ZB_FIND_DEV_CNF(
byte ,
ushort ,
ulong
)
C++
public:
ZB_FIND_DEV_CNF(
char ,
unsigned short ,
unsigned __int64
) sealed
J#
public ZB_FIND_DEV_CNF(
byte ,
ushort ,
ulong
)
JScript
public function ZB_FIND_DEV_CNF(
: Byte,
: UInt16,
: UInt64
)

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace
ZB_FIND_DEV_CNF Constructor Overload List


Fields

ZB_FIND_DEV_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Result | The 16-bit short address of the device that was found.
Public field | SearchKey | The 64-bit IEEE address of device that was searched for.
Public field | SearchType | The type of search that was performed.
Top

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace


Result Field

ZB_FIND_DEV_CNF.Result Field
[image]

The 16-bit short address of the device that was found.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Result As UInt16
C#
public ushort Result;
C++
public:
unsigned short Result sealed ;
J#
public ushort Result
JScript
public Result : UInt16;

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace


SearchKey Field

ZB_FIND_DEV_CNF.SearchKey Field
[image]

The 64-bit IEEE address of device that was searched for.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SearchKey As UInt64
C#
public ulong SearchKey;
C++
public:
unsigned __int64 SearchKey sealed ;
J#
public ulong SearchKey
JScript
public SearchKey : UInt64;

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace


SearchType Field

ZB_FIND_DEV_CNF.SearchType Field
[image]

The type of search that was performed.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SearchType As Byte
C#
public byte SearchType;
C++
public:
char SearchType sealed ;
J#
public byte SearchType
JScript
public SearchType : Byte;

See Also

ZB_FIND_DEV_CNF Class
TI.ZPI1 Namespace


ZB_FIND_DEV_RSP Class

ZB_FIND_DEV_RSP Class
See Also Example Members
[image]

Response for ZB_FIND_DEV

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_FIND_DEV_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_FIND_DEV_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_FIND_DEV_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_FIND_DEV_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_FIND_DEV_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_FIND_DEV_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_FIND_DEV_RSP Members
TI.ZPI1 Namespace


ZB_FIND_DEV_RSP Members

ZB_FIND_DEV_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_FIND_DEV

The following tables list the members exposed by ZB_FIND_DEV_RSP.

Public Constructors

Name | Description
ZB_FIND_DEV_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_FIND_DEV_RSP | Overloaded.
Top

See Also

ZB_FIND_DEV_RSP Class
TI.ZPI1 Namespace


ZB_FIND_DEV_RSP Constructor

ZB_FIND_DEV_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_FIND_DEV_RSP | Constructor
Public method | ZB_FIND_DEV_RSP (Byte) | Constructor

See Also

ZB_FIND_DEV_RSP Class
TI.ZPI1 Namespace


ZB_FIND_DEV_RSP Constructor ()

ZB_FIND_DEV_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_FIND_DEV_RSP()
C++
public:
ZB_FIND_DEV_RSP() sealed
J#
public ZB_FIND_DEV_RSP()
JScript
public function ZB_FIND_DEV_RSP()

See Also

ZB_FIND_DEV_RSP Class
TI.ZPI1 Namespace
ZB_FIND_DEV_RSP Constructor Overload List


ZB_FIND_DEV_RSP Constructor (Byte)

ZB_FIND_DEV_RSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_FIND_DEV_RSP(
byte
)
C++
public:
ZB_FIND_DEV_RSP(
char
) sealed
J#
public ZB_FIND_DEV_RSP(
byte
)
JScript
public function ZB_FIND_DEV_RSP(
: Byte
)

See Also

ZB_FIND_DEV_RSP Class
TI.ZPI1 Namespace
ZB_FIND_DEV_RSP Constructor Overload List


Fields

ZB_FIND_DEV_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_FIND_DEV_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_FIND_DEV_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_FIND_DEV_RSP Class
TI.ZPI1 Namespace


ZB_GET_DEV_INFO Class

ZB_GET_DEV_INFO Class
See Also Example Members
[image]

Reads current device infromation.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_GET_DEV_INFO
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_GET_DEV_INFO : IREQUEST, ISIMPLEAPI
C++
ref class ZB_GET_DEV_INFO : IREQUEST, ISIMPLEAPI
J#
public class ZB_GET_DEV_INFO implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_GET_DEV_INFO extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_GET_DEV_INFO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_GET_DEV_INFO Members
TI.ZPI1 Namespace


ZB_GET_DEV_INFO Members

ZB_GET_DEV_INFO Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Reads current device infromation.

The following tables list the members exposed by ZB_GET_DEV_INFO.

Public Constructors

Name | Description
ZB_GET_DEV_INFO | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigID | Identifier of the device info parameter to read.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_GET_DEV_INFO | Overloaded.
Top

See Also

ZB_GET_DEV_INFO Class
TI.ZPI1 Namespace


ZB_GET_DEV_INFO Constructor

ZB_GET_DEV_INFO Constructor

Overload List

 | Name | Description
Public method | ZB_GET_DEV_INFO | Constructor
Public method | ZB_GET_DEV_INFO (Byte) | Constructor

See Also

ZB_GET_DEV_INFO Class
TI.ZPI1 Namespace


ZB_GET_DEV_INFO Constructor ()

ZB_GET_DEV_INFO Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_GET_DEV_INFO()
C++
public:
ZB_GET_DEV_INFO() sealed
J#
public ZB_GET_DEV_INFO()
JScript
public function ZB_GET_DEV_INFO()

See Also

ZB_GET_DEV_INFO Class
TI.ZPI1 Namespace
ZB_GET_DEV_INFO Constructor Overload List


ZB_GET_DEV_INFO Constructor (Byte)

ZB_GET_DEV_INFO Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_GET_DEV_INFO(
byte
)
C++
public:
ZB_GET_DEV_INFO(
char
) sealed
J#
public ZB_GET_DEV_INFO(
byte
)
JScript
public function ZB_GET_DEV_INFO(
: Byte
)

See Also

ZB_GET_DEV_INFO Class
TI.ZPI1 Namespace
ZB_GET_DEV_INFO Constructor Overload List


Fields

ZB_GET_DEV_INFO Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigID | Identifier of the device info parameter to read.
Top

See Also

ZB_GET_DEV_INFO Class
TI.ZPI1 Namespace


ConfigID Field

ZB_GET_DEV_INFO.ConfigID Field
[image]

Identifier of the device info parameter to read.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigID As Byte
C#
public byte ConfigID;
C++
public:
char ConfigID sealed ;
J#
public byte ConfigID
JScript
public ConfigID : Byte;

See Also

ZB_GET_DEV_INFO Class
TI.ZPI1 Namespace


ZB_GET_DEV_INFO_RSP Class

ZB_GET_DEV_INFO_RSP Class
See Also Example Members
[image]

Response for ZB_GET_DEV_INFO

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_GET_DEV_INFO_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_GET_DEV_INFO_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_GET_DEV_INFO_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_GET_DEV_INFO_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_GET_DEV_INFO_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_GET_DEV_INFO_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_GET_DEV_INFO_RSP Members
TI.ZPI1 Namespace


ZB_GET_DEV_INFO_RSP Members

ZB_GET_DEV_INFO_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_GET_DEV_INFO

The following tables list the members exposed by ZB_GET_DEV_INFO_RSP.

Public Constructors

Name | Description
ZB_GET_DEV_INFO_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigId | The identifier of the info parameter that was read.
Public field | Value | The value of the parameter.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_GET_DEV_INFO_RSP | Overloaded.
Top

See Also

ZB_GET_DEV_INFO_RSP Class
TI.ZPI1 Namespace


ZB_GET_DEV_INFO_RSP Constructor

ZB_GET_DEV_INFO_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_GET_DEV_INFO_RSP | Constructor
Public method | ZB_GET_DEV_INFO_RSP (Byte, Byte) | Constructor

See Also

ZB_GET_DEV_INFO_RSP Class
TI.ZPI1 Namespace


ZB_GET_DEV_INFO_RSP Constructor ()

ZB_GET_DEV_INFO_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_GET_DEV_INFO_RSP()
C++
public:
ZB_GET_DEV_INFO_RSP() sealed
J#
public ZB_GET_DEV_INFO_RSP()
JScript
public function ZB_GET_DEV_INFO_RSP()

See Also

ZB_GET_DEV_INFO_RSP Class
TI.ZPI1 Namespace
ZB_GET_DEV_INFO_RSP Constructor Overload List


ZB_GET_DEV_INFO_RSP Constructor (Byte, Byte[])

ZB_GET_DEV_INFO_RSP Constructor (Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_GET_DEV_INFO_RSP(
byte ,
byte[]
)
C++
public:
ZB_GET_DEV_INFO_RSP(
char ,
array<char>^
) sealed
J#
public ZB_GET_DEV_INFO_RSP(
byte ,
byte[]
)
JScript
public function ZB_GET_DEV_INFO_RSP(
: Byte,
: Byte[]
)

See Also

ZB_GET_DEV_INFO_RSP Class
TI.ZPI1 Namespace
ZB_GET_DEV_INFO_RSP Constructor Overload List


Fields

ZB_GET_DEV_INFO_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigId | The identifier of the info parameter that was read.
Public field | Value | The value of the parameter.
Top

See Also

ZB_GET_DEV_INFO_RSP Class
TI.ZPI1 Namespace


ConfigId Field

ZB_GET_DEV_INFO_RSP.ConfigId Field
[image]

The identifier of the info parameter that was read.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigId As Byte
C#
public byte ConfigId;
C++
public:
char ConfigId sealed ;
J#
public byte ConfigId
JScript
public ConfigId : Byte;

See Also

ZB_GET_DEV_INFO_RSP Class
TI.ZPI1 Namespace


Value Field

ZB_GET_DEV_INFO_RSP.Value Field
[image]

The value of the parameter.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZB_GET_DEV_INFO_RSP Class
TI.ZPI1 Namespace


ZB_PERMIT_JOIN Class

ZB_PERMIT_JOIN Class
See Also Example Members
[image]

Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_PERMIT_JOIN
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_PERMIT_JOIN : IREQUEST, ISIMPLEAPI
C++
ref class ZB_PERMIT_JOIN : IREQUEST, ISIMPLEAPI
J#
public class ZB_PERMIT_JOIN implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_PERMIT_JOIN extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_PERMIT_JOIN

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_PERMIT_JOIN Members
TI.ZPI1 Namespace


ZB_PERMIT_JOIN Members

ZB_PERMIT_JOIN Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.

The following tables list the members exposed by ZB_PERMIT_JOIN.

Public Constructors

Name | Description
ZB_PERMIT_JOIN | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Destination | Short adddress of the device on which to control the joining permissions. This is usually the local device address or the special broadcast address that denotes all routers and coordinator ( 0xFFFC ).
Public field | Timeout | The amount of time in seconds for which the joining permissions should be turned on. If set to 0x00, the device will turn off the joining permissions indefinitely. If it is set to 0xFF, the joining permissions will be turned on indefinitely.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_PERMIT_JOIN | Overloaded.
Top

See Also

ZB_PERMIT_JOIN Class
TI.ZPI1 Namespace


ZB_PERMIT_JOIN Constructor

ZB_PERMIT_JOIN Constructor

Overload List

 | Name | Description
Public method | ZB_PERMIT_JOIN | Constructor
Public method | ZB_PERMIT_JOIN (UInt16, Byte) | Constructor

See Also

ZB_PERMIT_JOIN Class
TI.ZPI1 Namespace


ZB_PERMIT_JOIN Constructor ()

ZB_PERMIT_JOIN Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_PERMIT_JOIN()
C++
public:
ZB_PERMIT_JOIN() sealed
J#
public ZB_PERMIT_JOIN()
JScript
public function ZB_PERMIT_JOIN()

See Also

ZB_PERMIT_JOIN Class
TI.ZPI1 Namespace
ZB_PERMIT_JOIN Constructor Overload List


ZB_PERMIT_JOIN Constructor (UInt16, Byte)

ZB_PERMIT_JOIN Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZB_PERMIT_JOIN(
ushort ,
byte
)
C++
public:
ZB_PERMIT_JOIN(
unsigned short ,
char
) sealed
J#
public ZB_PERMIT_JOIN(
ushort ,
byte
)
JScript
public function ZB_PERMIT_JOIN(
: UInt16,
: Byte
)

See Also

ZB_PERMIT_JOIN Class
TI.ZPI1 Namespace
ZB_PERMIT_JOIN Constructor Overload List


Fields

ZB_PERMIT_JOIN Fields
[image]

Public Fields

 | Name | Description
Public field | Destination | Short adddress of the device on which to control the joining permissions. This is usually the local device address or the special broadcast address that denotes all routers and coordinator ( 0xFFFC ).
Public field | Timeout | The amount of time in seconds for which the joining permissions should be turned on. If set to 0x00, the device will turn off the joining permissions indefinitely. If it is set to 0xFF, the joining permissions will be turned on indefinitely.
Top

See Also

ZB_PERMIT_JOIN Class
TI.ZPI1 Namespace


Destination Field

ZB_PERMIT_JOIN.Destination Field
[image]

Short adddress of the device on which to control the joining permissions. This is usually the local device address or the special broadcast address that denotes all routers and coordinator ( 0xFFFC ).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Destination As UInt16
C#
public ushort Destination;
C++
public:
unsigned short Destination sealed ;
J#
public ushort Destination
JScript
public Destination : UInt16;

See Also

ZB_PERMIT_JOIN Class
TI.ZPI1 Namespace


Timeout Field

ZB_PERMIT_JOIN.Timeout Field
[image]

The amount of time in seconds for which the joining permissions should be turned on. If set to 0x00, the device will turn off the joining permissions indefinitely. If it is set to 0xFF, the joining permissions will be turned on indefinitely.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timeout As Byte
C#
public byte Timeout;
C++
public:
char Timeout sealed ;
J#
public byte Timeout
JScript
public Timeout : Byte;

See Also

ZB_PERMIT_JOIN Class
TI.ZPI1 Namespace


ZB_PERMIT_JOIN_RSP Class

ZB_PERMIT_JOIN_RSP Class
See Also Example Members
[image]

Response for SYS_PERMIT_JOIN

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_PERMIT_JOIN_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_PERMIT_JOIN_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_PERMIT_JOIN_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_PERMIT_JOIN_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_PERMIT_JOIN_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_PERMIT_JOIN_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_PERMIT_JOIN_RSP Members
TI.ZPI1 Namespace


ZB_PERMIT_JOIN_RSP Members

ZB_PERMIT_JOIN_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_PERMIT_JOIN

The following tables list the members exposed by ZB_PERMIT_JOIN_RSP.

Public Constructors

Name | Description
ZB_PERMIT_JOIN_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_PERMIT_JOIN_RSP | Overloaded.
Top

See Also

ZB_PERMIT_JOIN_RSP Class
TI.ZPI1 Namespace


ZB_PERMIT_JOIN_RSP Constructor

ZB_PERMIT_JOIN_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_PERMIT_JOIN_RSP | Constructor
Public method | ZB_PERMIT_JOIN_RSP (Byte) | Constructor

See Also

ZB_PERMIT_JOIN_RSP Class
TI.ZPI1 Namespace


ZB_PERMIT_JOIN_RSP Constructor ()

ZB_PERMIT_JOIN_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_PERMIT_JOIN_RSP()
C++
public:
ZB_PERMIT_JOIN_RSP() sealed
J#
public ZB_PERMIT_JOIN_RSP()
JScript
public function ZB_PERMIT_JOIN_RSP()

See Also

ZB_PERMIT_JOIN_RSP Class
TI.ZPI1 Namespace
ZB_PERMIT_JOIN_RSP Constructor Overload List


ZB_PERMIT_JOIN_RSP Constructor (Byte)

ZB_PERMIT_JOIN_RSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_PERMIT_JOIN_RSP(
byte
)
C++
public:
ZB_PERMIT_JOIN_RSP(
char
) sealed
J#
public ZB_PERMIT_JOIN_RSP(
byte
)
JScript
public function ZB_PERMIT_JOIN_RSP(
: Byte
)

See Also

ZB_PERMIT_JOIN_RSP Class
TI.ZPI1 Namespace
ZB_PERMIT_JOIN_RSP Constructor Overload List


Fields

ZB_PERMIT_JOIN_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_PERMIT_JOIN_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_PERMIT_JOIN_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_PERMIT_JOIN_RSP Class
TI.ZPI1 Namespace


ZB_RCV_DATA_IND Class

ZB_RCV_DATA_IND Class
See Also Example Members
[image]

(zb_ReceiveDataIndication)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_RCV_DATA_IND
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_RCV_DATA_IND : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_RCV_DATA_IND : IRESPONSE, ISIMPLEAPI
J#
public class ZB_RCV_DATA_IND implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_RCV_DATA_IND extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_RCV_DATA_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_RCV_DATA_IND Members
TI.ZPI1 Namespace


ZB_RCV_DATA_IND Members

ZB_RCV_DATA_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

(zb_ReceiveDataIndication)

The following tables list the members exposed by ZB_RCV_DATA_IND.

Public Constructors

Name | Description
ZB_RCV_DATA_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Command | The CommandId of the data packet.
Public field | Data | The received data packet payload.
Public field | Len | The length of the data payload.
Public field | Source | The 16-bit address of the device that sent the data packet.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_RCV_DATA_IND | Overloaded.
Top

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace


ZB_RCV_DATA_IND Constructor

ZB_RCV_DATA_IND Constructor

Overload List

 | Name | Description
Public method | ZB_RCV_DATA_IND | Constructor
Public method | ZB_RCV_DATA_IND (UInt16, UInt16, UInt16, Byte) | Constructor

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace


ZB_RCV_DATA_IND Constructor ()

ZB_RCV_DATA_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_RCV_DATA_IND()
C++
public:
ZB_RCV_DATA_IND() sealed
J#
public ZB_RCV_DATA_IND()
JScript
public function ZB_RCV_DATA_IND()

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace
ZB_RCV_DATA_IND Constructor Overload List


ZB_RCV_DATA_IND Constructor (UInt16, UInt16, UInt16, Byte[])

ZB_RCV_DATA_IND Constructor (UInt16, UInt16, UInt16, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte() _
)
C#
public ZB_RCV_DATA_IND(
ushort ,
ushort ,
ushort ,
byte[]
)
C++
public:
ZB_RCV_DATA_IND(
unsigned short ,
unsigned short ,
unsigned short ,
array<char>^
) sealed
J#
public ZB_RCV_DATA_IND(
ushort ,
ushort ,
ushort ,
byte[]
)
JScript
public function ZB_RCV_DATA_IND(
: UInt16,
: UInt16,
: UInt16,
: Byte[]
)

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace
ZB_RCV_DATA_IND Constructor Overload List


Fields

ZB_RCV_DATA_IND Fields
[image]

Public Fields

 | Name | Description
Public field | Command | The CommandId of the data packet.
Public field | Data | The received data packet payload.
Public field | Len | The length of the data payload.
Public field | Source | The 16-bit address of the device that sent the data packet.
Top

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace


Command Field

ZB_RCV_DATA_IND.Command Field
[image]

The CommandId of the data packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Command As UInt16
C#
public ushort Command;
C++
public:
unsigned short Command sealed ;
J#
public ushort Command
JScript
public Command : UInt16;

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace


Data Field

ZB_RCV_DATA_IND.Data Field
[image]

The received data packet payload.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace


Len Field

ZB_RCV_DATA_IND.Len Field
[image]

The length of the data payload.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As UInt16
C#
public ushort Len;
C++
public:
unsigned short Len sealed ;
J#
public ushort Len
JScript
public Len : UInt16;

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace


Source Field

ZB_RCV_DATA_IND.Source Field
[image]

The 16-bit address of the device that sent the data packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Source As UInt16
C#
public ushort Source;
C++
public:
unsigned short Source sealed ;
J#
public ushort Source
JScript
public Source : UInt16;

See Also

ZB_RCV_DATA_IND Class
TI.ZPI1 Namespace


ZB_READ_CFG Class

ZB_READ_CFG Class
See Also Example Members
[image]

Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_READ_CFG
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_READ_CFG : IREQUEST, ISIMPLEAPI
C++
ref class ZB_READ_CFG : IREQUEST, ISIMPLEAPI
J#
public class ZB_READ_CFG implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_READ_CFG extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_READ_CFG

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_READ_CFG Members
TI.ZPI1 Namespace


ZB_READ_CFG Members

ZB_READ_CFG Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).

The following tables list the members exposed by ZB_READ_CFG.

Public Constructors

Name | Description
ZB_READ_CFG | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigID | Identifier of property to read.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_READ_CFG | Overloaded.
Top

See Also

ZB_READ_CFG Class
TI.ZPI1 Namespace


ZB_READ_CFG Constructor

ZB_READ_CFG Constructor

Overload List

 | Name | Description
Public method | ZB_READ_CFG | Constructor
Public method | ZB_READ_CFG (Byte) | Constructor

See Also

ZB_READ_CFG Class
TI.ZPI1 Namespace


ZB_READ_CFG Constructor ()

ZB_READ_CFG Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_READ_CFG()
C++
public:
ZB_READ_CFG() sealed
J#
public ZB_READ_CFG()
JScript
public function ZB_READ_CFG()

See Also

ZB_READ_CFG Class
TI.ZPI1 Namespace
ZB_READ_CFG Constructor Overload List


ZB_READ_CFG Constructor (Byte)

ZB_READ_CFG Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_READ_CFG(
byte
)
C++
public:
ZB_READ_CFG(
char
) sealed
J#
public ZB_READ_CFG(
byte
)
JScript
public function ZB_READ_CFG(
: Byte
)

See Also

ZB_READ_CFG Class
TI.ZPI1 Namespace
ZB_READ_CFG Constructor Overload List


Fields

ZB_READ_CFG Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigID | Identifier of property to read.
Top

See Also

ZB_READ_CFG Class
TI.ZPI1 Namespace


ConfigID Field

ZB_READ_CFG.ConfigID Field
[image]

Identifier of property to read.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigID As Byte
C#
public byte ConfigID;
C++
public:
char ConfigID sealed ;
J#
public byte ConfigID
JScript
public ConfigID : Byte;

See Also

ZB_READ_CFG Class
TI.ZPI1 Namespace


ZB_READ_CFG_RSP Class

ZB_READ_CFG_RSP Class
See Also Example Members
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_READ_CFG_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_READ_CFG_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_READ_CFG_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_READ_CFG_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_READ_CFG_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_READ_CFG_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_READ_CFG_RSP Members
TI.ZPI1 Namespace


ZB_READ_CFG_RSP Members

ZB_READ_CFG_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by ZB_READ_CFG_RSP.

Public Constructors

Name | Description
ZB_READ_CFG_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigId | The identifier of the property that was read.
Public field | Len | The size of the value of the property.
Public field | Status | The result of the read operation.
Public field | Value | The value of the property that was read.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_READ_CFG_RSP | Overloaded.
Top

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace


ZB_READ_CFG_RSP Constructor

ZB_READ_CFG_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_READ_CFG_RSP | Constructor
Public method | ZB_READ_CFG_RSP (Byte, Byte, Byte, Byte) | Constructor

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace


ZB_READ_CFG_RSP Constructor ()

ZB_READ_CFG_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_READ_CFG_RSP()
C++
public:
ZB_READ_CFG_RSP() sealed
J#
public ZB_READ_CFG_RSP()
JScript
public function ZB_READ_CFG_RSP()

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace
ZB_READ_CFG_RSP Constructor Overload List


ZB_READ_CFG_RSP Constructor (Byte, Byte, Byte, Byte[])

ZB_READ_CFG_RSP Constructor (Byte, Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_READ_CFG_RSP(
byte ,
byte ,
byte ,
byte[]
)
C++
public:
ZB_READ_CFG_RSP(
char ,
char ,
char ,
array<char>^
) sealed
J#
public ZB_READ_CFG_RSP(
byte ,
byte ,
byte ,
byte[]
)
JScript
public function ZB_READ_CFG_RSP(
: Byte,
: Byte,
: Byte,
: Byte[]
)

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace
ZB_READ_CFG_RSP Constructor Overload List


Fields

ZB_READ_CFG_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigId | The identifier of the property that was read.
Public field | Len | The size of the value of the property.
Public field | Status | The result of the read operation.
Public field | Value | The value of the property that was read.
Top

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace


ConfigId Field

ZB_READ_CFG_RSP.ConfigId Field
[image]

The identifier of the property that was read.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigId As Byte
C#
public byte ConfigId;
C++
public:
char ConfigId sealed ;
J#
public byte ConfigId
JScript
public ConfigId : Byte;

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace


Len Field

ZB_READ_CFG_RSP.Len Field
[image]

The size of the value of the property.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_READ_CFG_RSP.Status Field
[image]

The result of the read operation.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace


Value Field

ZB_READ_CFG_RSP.Value Field
[image]

The value of the property that was read.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZB_READ_CFG_RSP Class
TI.ZPI1 Namespace


ZB_SEND_DATA Class

ZB_SEND_DATA Class
See Also Example Members
[image]

Send a data packet to another device (zb_SendDataRequest).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SEND_DATA
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_SEND_DATA : IREQUEST, ISIMPLEAPI
C++
ref class ZB_SEND_DATA : IREQUEST, ISIMPLEAPI
J#
public class ZB_SEND_DATA implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_SEND_DATA extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_SEND_DATA

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SEND_DATA Members
TI.ZPI1 Namespace


ZB_SEND_DATA Members

ZB_SEND_DATA Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send a data packet to another device (zb_SendDataRequest).

The following tables list the members exposed by ZB_SEND_DATA.

Public Constructors

Name | Description
ZB_SEND_DATA | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CommandID | Command identifier of the data packet.
Public field | Destination | Short address of destination device ( 0xFFFE indicates NULL address and a binding must have been established previously for this command identifier. Broadcast addresses include 0xFFFF for all devices, 0xFFFC for all routers/coordinator devices and 0xFFFD for all devices with receiver turned ON ).
Public field | Handle | Identifier for this data send operation.
Public field | PayloadLen | Size in bytes of the data packet payload.
Public field | PayloadValue | Packet payload.
Public field | Radius | Max number of hops the data packet can travel ( set to 0 to use default value ).
Public field | TxOptions | Bit mask of transmission options ( 0x10 for end-to-end acknowledgements and retransmissions ).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_SEND_DATA | Overloaded.
Top

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


ZB_SEND_DATA Constructor

ZB_SEND_DATA Constructor

Overload List

 | Name | Description
Public method | ZB_SEND_DATA | Constructor
Public method | ZB_SEND_DATA (UInt16, UInt16, Byte, Byte, Byte, Byte, Byte) | Constructor

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


ZB_SEND_DATA Constructor ()

ZB_SEND_DATA Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SEND_DATA()
C++
public:
ZB_SEND_DATA() sealed
J#
public ZB_SEND_DATA()
JScript
public function ZB_SEND_DATA()

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace
ZB_SEND_DATA Constructor Overload List


ZB_SEND_DATA Constructor (UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[])

ZB_SEND_DATA Constructor (UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_SEND_DATA(
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[]
)
C++
public:
ZB_SEND_DATA(
unsigned short ,
unsigned short ,
char ,
char ,
char ,
char ,
array<char>^
) sealed
J#
public ZB_SEND_DATA(
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[]
)
JScript
public function ZB_SEND_DATA(
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[]
)

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace
ZB_SEND_DATA Constructor Overload List


Fields

ZB_SEND_DATA Fields
[image]

Public Fields

 | Name | Description
Public field | CommandID | Command identifier of the data packet.
Public field | Destination | Short address of destination device ( 0xFFFE indicates NULL address and a binding must have been established previously for this command identifier. Broadcast addresses include 0xFFFF for all devices, 0xFFFC for all routers/coordinator devices and 0xFFFD for all devices with receiver turned ON ).
Public field | Handle | Identifier for this data send operation.
Public field | PayloadLen | Size in bytes of the data packet payload.
Public field | PayloadValue | Packet payload.
Public field | Radius | Max number of hops the data packet can travel ( set to 0 to use default value ).
Public field | TxOptions | Bit mask of transmission options ( 0x10 for end-to-end acknowledgements and retransmissions ).
Top

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


CommandID Field

ZB_SEND_DATA.CommandID Field
[image]

Command identifier of the data packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandID As UInt16
C#
public ushort CommandID;
C++
public:
unsigned short CommandID sealed ;
J#
public ushort CommandID
JScript
public CommandID : UInt16;

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


Destination Field

ZB_SEND_DATA.Destination Field
[image]

Short address of destination device ( 0xFFFE indicates NULL address and a binding must have been established previously for this command identifier. Broadcast addresses include 0xFFFF for all devices, 0xFFFC for all routers/coordinator devices and 0xFFFD for all devices with receiver turned ON ).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Destination As UInt16
C#
public ushort Destination;
C++
public:
unsigned short Destination sealed ;
J#
public ushort Destination
JScript
public Destination : UInt16;

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


Handle Field

ZB_SEND_DATA.Handle Field
[image]

Identifier for this data send operation.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


PayloadLen Field

ZB_SEND_DATA.PayloadLen Field
[image]

Size in bytes of the data packet payload.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadLen As Byte
C#
public byte PayloadLen;
C++
public:
char PayloadLen sealed ;
J#
public byte PayloadLen
JScript
public PayloadLen : Byte;

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


PayloadValue Field

ZB_SEND_DATA.PayloadValue Field
[image]

Packet payload.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadValue As Byte()
C#
public byte[] PayloadValue;
C++
public:
array<char>^ PayloadValue sealed ;
J#
public byte[] PayloadValue
JScript
public PayloadValue : Byte[];

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


Radius Field

ZB_SEND_DATA.Radius Field
[image]

Max number of hops the data packet can travel ( set to 0 to use default value ).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Radius As Byte
C#
public byte Radius;
C++
public:
char Radius sealed ;
J#
public byte Radius
JScript
public Radius : Byte;

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


TxOptions Field

ZB_SEND_DATA.TxOptions Field
[image]

Bit mask of transmission options ( 0x10 for end-to-end acknowledgements and retransmissions ).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxOptions As Byte
C#
public byte TxOptions;
C++
public:
char TxOptions sealed ;
J#
public byte TxOptions
JScript
public TxOptions : Byte;

See Also

ZB_SEND_DATA Class
TI.ZPI1 Namespace


ZB_SEND_DATA_CNF Class

ZB_SEND_DATA_CNF Class
See Also Example Members
[image]

(zb_SendDataConfirm)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SEND_DATA_CNF
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_SEND_DATA_CNF : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_SEND_DATA_CNF : IRESPONSE, ISIMPLEAPI
J#
public class ZB_SEND_DATA_CNF implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_SEND_DATA_CNF extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_SEND_DATA_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SEND_DATA_CNF Members
TI.ZPI1 Namespace


ZB_SEND_DATA_CNF Members

ZB_SEND_DATA_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

(zb_SendDataConfirm)

The following tables list the members exposed by ZB_SEND_DATA_CNF.

Public Constructors

Name | Description
ZB_SEND_DATA_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Handle | The handle identifing the send data operation.
Public field | Status | The results from the data packet send operation.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_SEND_DATA_CNF | Overloaded.
Top

See Also

ZB_SEND_DATA_CNF Class
TI.ZPI1 Namespace


ZB_SEND_DATA_CNF Constructor

ZB_SEND_DATA_CNF Constructor

Overload List

 | Name | Description
Public method | ZB_SEND_DATA_CNF | Constructor
Public method | ZB_SEND_DATA_CNF (Byte, Byte) | Constructor

See Also

ZB_SEND_DATA_CNF Class
TI.ZPI1 Namespace


ZB_SEND_DATA_CNF Constructor ()

ZB_SEND_DATA_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SEND_DATA_CNF()
C++
public:
ZB_SEND_DATA_CNF() sealed
J#
public ZB_SEND_DATA_CNF()
JScript
public function ZB_SEND_DATA_CNF()

See Also

ZB_SEND_DATA_CNF Class
TI.ZPI1 Namespace
ZB_SEND_DATA_CNF Constructor Overload List


ZB_SEND_DATA_CNF Constructor (Byte, Byte)

ZB_SEND_DATA_CNF Constructor (Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZB_SEND_DATA_CNF(
byte ,
byte
)
C++
public:
ZB_SEND_DATA_CNF(
char ,
char
) sealed
J#
public ZB_SEND_DATA_CNF(
byte ,
byte
)
JScript
public function ZB_SEND_DATA_CNF(
: Byte,
: Byte
)

See Also

ZB_SEND_DATA_CNF Class
TI.ZPI1 Namespace
ZB_SEND_DATA_CNF Constructor Overload List


Fields

ZB_SEND_DATA_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Handle | The handle identifing the send data operation.
Public field | Status | The results from the data packet send operation.
Top

See Also

ZB_SEND_DATA_CNF Class
TI.ZPI1 Namespace


Handle Field

ZB_SEND_DATA_CNF.Handle Field
[image]

The handle identifing the send data operation.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZB_SEND_DATA_CNF Class
TI.ZPI1 Namespace


Status Field

ZB_SEND_DATA_CNF.Status Field
[image]

The results from the data packet send operation.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_SEND_DATA_CNF Class
TI.ZPI1 Namespace


ZB_SEND_DATA_RSP Class

ZB_SEND_DATA_RSP Class
See Also Example Members
[image]

Response for ZB_SEND_DATA

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SEND_DATA_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_SEND_DATA_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_SEND_DATA_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_SEND_DATA_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_SEND_DATA_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_SEND_DATA_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SEND_DATA_RSP Members
TI.ZPI1 Namespace


ZB_SEND_DATA_RSP Members

ZB_SEND_DATA_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_SEND_DATA

The following tables list the members exposed by ZB_SEND_DATA_RSP.

Public Constructors

Name | Description
ZB_SEND_DATA_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_SEND_DATA_RSP | Overloaded.
Top

See Also

ZB_SEND_DATA_RSP Class
TI.ZPI1 Namespace


ZB_SEND_DATA_RSP Constructor

ZB_SEND_DATA_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_SEND_DATA_RSP | Constructor
Public method | ZB_SEND_DATA_RSP (Byte) | Constructor

See Also

ZB_SEND_DATA_RSP Class
TI.ZPI1 Namespace


ZB_SEND_DATA_RSP Constructor ()

ZB_SEND_DATA_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SEND_DATA_RSP()
C++
public:
ZB_SEND_DATA_RSP() sealed
J#
public ZB_SEND_DATA_RSP()
JScript
public function ZB_SEND_DATA_RSP()

See Also

ZB_SEND_DATA_RSP Class
TI.ZPI1 Namespace
ZB_SEND_DATA_RSP Constructor Overload List


ZB_SEND_DATA_RSP Constructor (Byte)

ZB_SEND_DATA_RSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_SEND_DATA_RSP(
byte
)
C++
public:
ZB_SEND_DATA_RSP(
char
) sealed
J#
public ZB_SEND_DATA_RSP(
byte
)
JScript
public function ZB_SEND_DATA_RSP(
: Byte
)

See Also

ZB_SEND_DATA_RSP Class
TI.ZPI1 Namespace
ZB_SEND_DATA_RSP Constructor Overload List


Fields

ZB_SEND_DATA_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_SEND_DATA_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_SEND_DATA_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_SEND_DATA_RSP Class
TI.ZPI1 Namespace


ZB_START_CNF Class

ZB_START_CNF Class
See Also Example Members
[image]

(zb_StartConfirm)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_START_CNF
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_START_CNF : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_START_CNF : IRESPONSE, ISIMPLEAPI
J#
public class ZB_START_CNF implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_START_CNF extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_START_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_START_CNF Members
TI.ZPI1 Namespace


ZB_START_CNF Members

ZB_START_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

(zb_StartConfirm)

The following tables list the members exposed by ZB_START_CNF.

Public Constructors

Name | Description
ZB_START_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The results from the start operation.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_START_CNF | Overloaded.
Top

See Also

ZB_START_CNF Class
TI.ZPI1 Namespace


ZB_START_CNF Constructor

ZB_START_CNF Constructor

Overload List

 | Name | Description
Public method | ZB_START_CNF | Constructor
Public method | ZB_START_CNF (Byte) | Constructor

See Also

ZB_START_CNF Class
TI.ZPI1 Namespace


ZB_START_CNF Constructor ()

ZB_START_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_START_CNF()
C++
public:
ZB_START_CNF() sealed
J#
public ZB_START_CNF()
JScript
public function ZB_START_CNF()

See Also

ZB_START_CNF Class
TI.ZPI1 Namespace
ZB_START_CNF Constructor Overload List


ZB_START_CNF Constructor (Byte)

ZB_START_CNF Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_START_CNF(
byte
)
C++
public:
ZB_START_CNF(
char
) sealed
J#
public ZB_START_CNF(
byte
)
JScript
public function ZB_START_CNF(
: Byte
)

See Also

ZB_START_CNF Class
TI.ZPI1 Namespace
ZB_START_CNF Constructor Overload List


Fields

ZB_START_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The results from the start operation.
Top

See Also

ZB_START_CNF Class
TI.ZPI1 Namespace


Status Field

ZB_START_CNF.Status Field
[image]

The results from the start operation.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_START_CNF Class
TI.ZPI1 Namespace


ZB_START_REQ Class

ZB_START_REQ Class
See Also Example Members
[image]

Starts the ZigBee stack (zb_StartRequest).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_START_REQ
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_START_REQ : IREQUEST, ISIMPLEAPI
C++
ref class ZB_START_REQ : IREQUEST, ISIMPLEAPI
J#
public class ZB_START_REQ implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_START_REQ extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_START_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_START_REQ Members
TI.ZPI1 Namespace


ZB_START_REQ Members

ZB_START_REQ Members
See Also Example Constructors Methods
[image]

Starts the ZigBee stack (zb_StartRequest).

The following tables list the members exposed by ZB_START_REQ.

Public Constructors

 | Name | Description
Public method | ZB_START_REQ | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_START_REQ Class
TI.ZPI1 Namespace


ZB_START_REQ Constructor

ZB_START_REQ Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_START_REQ()
C++
public:
ZB_START_REQ() sealed
J#
public ZB_START_REQ()
JScript
public function ZB_START_REQ()

See Also

ZB_START_REQ Class
TI.ZPI1 Namespace


ZB_START_REQ_RSP Class

ZB_START_REQ_RSP Class
See Also Example Members
[image]

Response for ZB_START_REQ

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_START_REQ_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_START_REQ_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_START_REQ_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_START_REQ_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_START_REQ_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_START_REQ_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_START_REQ_RSP Members
TI.ZPI1 Namespace


ZB_START_REQ_RSP Members

ZB_START_REQ_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_START_REQ

The following tables list the members exposed by ZB_START_REQ_RSP.

Public Constructors

Name | Description
ZB_START_REQ_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_START_REQ_RSP | Overloaded.
Top

See Also

ZB_START_REQ_RSP Class
TI.ZPI1 Namespace


ZB_START_REQ_RSP Constructor

ZB_START_REQ_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_START_REQ_RSP | Constructor
Public method | ZB_START_REQ_RSP (Byte) | Constructor

See Also

ZB_START_REQ_RSP Class
TI.ZPI1 Namespace


ZB_START_REQ_RSP Constructor ()

ZB_START_REQ_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_START_REQ_RSP()
C++
public:
ZB_START_REQ_RSP() sealed
J#
public ZB_START_REQ_RSP()
JScript
public function ZB_START_REQ_RSP()

See Also

ZB_START_REQ_RSP Class
TI.ZPI1 Namespace
ZB_START_REQ_RSP Constructor Overload List


ZB_START_REQ_RSP Constructor (Byte)

ZB_START_REQ_RSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_START_REQ_RSP(
byte
)
C++
public:
ZB_START_REQ_RSP(
char
) sealed
J#
public ZB_START_REQ_RSP(
byte
)
JScript
public function ZB_START_REQ_RSP(
: Byte
)

See Also

ZB_START_REQ_RSP Class
TI.ZPI1 Namespace
ZB_START_REQ_RSP Constructor Overload List


Fields

ZB_START_REQ_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_START_REQ_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_START_REQ_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_START_REQ_RSP Class
TI.ZPI1 Namespace


ZB_SYS_RESET Class

ZB_SYS_RESET Class
See Also Example Members
[image]

Reboot the device (zb_SystemReset)

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SYS_RESET
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_SYS_RESET : IREQUEST, ISIMPLEAPI
C++
ref class ZB_SYS_RESET : IREQUEST, ISIMPLEAPI
J#
public class ZB_SYS_RESET implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_SYS_RESET extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_SYS_RESET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SYS_RESET Members
TI.ZPI1 Namespace


ZB_SYS_RESET Members

ZB_SYS_RESET Members
See Also Example Constructors Methods
[image]

Reboot the device (zb_SystemReset)

The following tables list the members exposed by ZB_SYS_RESET.

Public Constructors

 | Name | Description
Public method | ZB_SYS_RESET | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_SYS_RESET Class
TI.ZPI1 Namespace


ZB_SYS_RESET Constructor

ZB_SYS_RESET Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SYS_RESET()
C++
public:
ZB_SYS_RESET() sealed
J#
public ZB_SYS_RESET()
JScript
public function ZB_SYS_RESET()

See Also

ZB_SYS_RESET Class
TI.ZPI1 Namespace


ZB_WRITE_CFG Class

ZB_WRITE_CFG Class
See Also Example Members
[image]

Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_WRITE_CFG
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_WRITE_CFG : IREQUEST, ISIMPLEAPI
C++
ref class ZB_WRITE_CFG : IREQUEST, ISIMPLEAPI
J#
public class ZB_WRITE_CFG implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_WRITE_CFG extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_WRITE_CFG

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_WRITE_CFG Members
TI.ZPI1 Namespace


ZB_WRITE_CFG Members

ZB_WRITE_CFG Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).

The following tables list the members exposed by ZB_WRITE_CFG.

Public Constructors

Name | Description
ZB_WRITE_CFG | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigID | Identifier of property to write.
Public field | Len | Length of the value of the property.
Public field | Value | Array containing value to write to property
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_WRITE_CFG | Overloaded.
Top

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace


ZB_WRITE_CFG Constructor

ZB_WRITE_CFG Constructor

Overload List

 | Name | Description
Public method | ZB_WRITE_CFG | Constructor
Public method | ZB_WRITE_CFG (Byte, Byte, Byte) | Constructor

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace


ZB_WRITE_CFG Constructor ()

ZB_WRITE_CFG Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_WRITE_CFG()
C++
public:
ZB_WRITE_CFG() sealed
J#
public ZB_WRITE_CFG()
JScript
public function ZB_WRITE_CFG()

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace
ZB_WRITE_CFG Constructor Overload List


ZB_WRITE_CFG Constructor (Byte, Byte, Byte[])

ZB_WRITE_CFG Constructor (Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_WRITE_CFG(
byte ,
byte ,
byte[]
)
C++
public:
ZB_WRITE_CFG(
char ,
char ,
array<char>^
) sealed
J#
public ZB_WRITE_CFG(
byte ,
byte ,
byte[]
)
JScript
public function ZB_WRITE_CFG(
: Byte,
: Byte,
: Byte[]
)

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace
ZB_WRITE_CFG Constructor Overload List


Fields

ZB_WRITE_CFG Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigID | Identifier of property to write.
Public field | Len | Length of the value of the property.
Public field | Value | Array containing value to write to property
Top

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace


ConfigID Field

ZB_WRITE_CFG.ConfigID Field
[image]

Identifier of property to write.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigID As Byte
C#
public byte ConfigID;
C++
public:
char ConfigID sealed ;
J#
public byte ConfigID
JScript
public ConfigID : Byte;

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace


Len Field

ZB_WRITE_CFG.Len Field
[image]

Length of the value of the property.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace


Value Field

ZB_WRITE_CFG.Value Field
[image]

Array containing value to write to property

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZB_WRITE_CFG Class
TI.ZPI1 Namespace


ZB_WRITE_CFG_RSP Class

ZB_WRITE_CFG_RSP Class
See Also Example Members
[image]

Response for ZB_WRITE_CFG

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_WRITE_CFG_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_WRITE_CFG_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_WRITE_CFG_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_WRITE_CFG_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_WRITE_CFG_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI1.ZB_WRITE_CFG_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_WRITE_CFG_RSP Members
TI.ZPI1 Namespace


ZB_WRITE_CFG_RSP Members

ZB_WRITE_CFG_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_WRITE_CFG

The following tables list the members exposed by ZB_WRITE_CFG_RSP.

Public Constructors

Name | Description
ZB_WRITE_CFG_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_WRITE_CFG_RSP | Overloaded.
Top

See Also

ZB_WRITE_CFG_RSP Class
TI.ZPI1 Namespace


ZB_WRITE_CFG_RSP Constructor

ZB_WRITE_CFG_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_WRITE_CFG_RSP | Constructor
Public method | ZB_WRITE_CFG_RSP (Byte) | Constructor

See Also

ZB_WRITE_CFG_RSP Class
TI.ZPI1 Namespace


ZB_WRITE_CFG_RSP Constructor ()

ZB_WRITE_CFG_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_WRITE_CFG_RSP()
C++
public:
ZB_WRITE_CFG_RSP() sealed
J#
public ZB_WRITE_CFG_RSP()
JScript
public function ZB_WRITE_CFG_RSP()

See Also

ZB_WRITE_CFG_RSP Class
TI.ZPI1 Namespace
ZB_WRITE_CFG_RSP Constructor Overload List


ZB_WRITE_CFG_RSP Constructor (Byte)

ZB_WRITE_CFG_RSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_WRITE_CFG_RSP(
byte
)
C++
public:
ZB_WRITE_CFG_RSP(
char
) sealed
J#
public ZB_WRITE_CFG_RSP(
byte
)
JScript
public function ZB_WRITE_CFG_RSP(
: Byte
)

See Also

ZB_WRITE_CFG_RSP Class
TI.ZPI1 Namespace
ZB_WRITE_CFG_RSP Constructor Overload List


Fields

ZB_WRITE_CFG_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_WRITE_CFG_RSP Class
TI.ZPI1 Namespace


Status Field

ZB_WRITE_CFG_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

ZB_WRITE_CFG_RSP Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_REQUEST Class

ZDO_ACTIVEENDPOINT_REQUEST Class
See Also Example Members
[image]

This command is generated to request a list of active endpoint from the destination device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ACTIVEENDPOINT_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_ACTIVEENDPOINT_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_ACTIVEENDPOINT_REQUEST : IREQUEST, IZDO
J#
public class ZDO_ACTIVEENDPOINT_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_ACTIVEENDPOINT_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_ACTIVEENDPOINT_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ACTIVEENDPOINT_REQUEST Members
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_REQUEST Members

ZDO_ACTIVEENDPOINT_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a list of active endpoint from the destination device.

The following tables list the members exposed by ZDO_ACTIVEENDPOINT_REQUEST.

Public Constructors

Name | Description
ZDO_ACTIVEENDPOINT_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ACTIVEENDPOINT_REQUEST | Overloaded.
Top

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_REQUEST Constructor

ZDO_ACTIVEENDPOINT_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_ACTIVEENDPOINT_REQUEST | Constructor
Public method | ZDO_ACTIVEENDPOINT_REQUEST (UInt16, UInt16, ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE) |

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_REQUEST Constructor ()

ZDO_ACTIVEENDPOINT_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ACTIVEENDPOINT_REQUEST()
C++
public:
ZDO_ACTIVEENDPOINT_REQUEST() sealed
J#
public ZDO_ACTIVEENDPOINT_REQUEST()
JScript
public function ZDO_ACTIVEENDPOINT_REQUEST()

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace
ZDO_ACTIVEENDPOINT_REQUEST Constructor Overload List


ZDO_ACTIVEENDPOINT_REQUEST Constructor (UInt16, UInt16, ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE)

ZDO_ACTIVEENDPOINT_REQUEST Constructor (UInt16, UInt16, ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_ACTIVEENDPOINT_REQUEST(
ushort ,
ushort ,
ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_ACTIVEENDPOINT_REQUEST(
unsigned short ,
unsigned short ,
ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_ACTIVEENDPOINT_REQUEST(
ushort ,
ushort ,
ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_ACTIVEENDPOINT_REQUEST(
: UInt16,
: UInt16,
: ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE
)

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace
ZDO_ACTIVEENDPOINT_REQUEST Constructor Overload List


Fields

ZDO_ACTIVEENDPOINT_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_ACTIVEENDPOINT_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_ACTIVEENDPOINT_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_ACTIVEENDPOINT_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE
C#
public ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE;

See Also

ZDO_ACTIVEENDPOINT_REQUEST Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE Enumeration

ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSE Class

ZDO_ACTIVEENDPOINT_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_ACTIVEENDPOINT_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ACTIVEENDPOINT_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_ACTIVEENDPOINT_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_ACTIVEENDPOINT_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_ACTIVEENDPOINT_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_ACTIVEENDPOINT_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ACTIVEENDPOINT_RESPONSE Members
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSE Members

ZDO_ACTIVEENDPOINT_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_ACTIVEENDPOINT_REQUEST

The following tables list the members exposed by ZDO_ACTIVEENDPOINT_RESPONSE.

Public Constructors

Name | Description
ZDO_ACTIVEENDPOINT_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ACTIVEENDPOINT_RESPONSE | Overloaded.
Top

See Also

ZDO_ACTIVEENDPOINT_RESPONSE Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSE Constructor

ZDO_ACTIVEENDPOINT_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_ACTIVEENDPOINT_RESPONSE | Constructor
Public method | ZDO_ACTIVEENDPOINT_RESPONSE (ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS) |

See Also

ZDO_ACTIVEENDPOINT_RESPONSE Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSE Constructor ()

ZDO_ACTIVEENDPOINT_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ACTIVEENDPOINT_RESPONSE()
C++
public:
ZDO_ACTIVEENDPOINT_RESPONSE() sealed
J#
public ZDO_ACTIVEENDPOINT_RESPONSE()
JScript
public function ZDO_ACTIVEENDPOINT_RESPONSE()

See Also

ZDO_ACTIVEENDPOINT_RESPONSE Class
TI.ZPI1 Namespace
ZDO_ACTIVEENDPOINT_RESPONSE Constructor Overload List


ZDO_ACTIVEENDPOINT_RESPONSE Constructor (ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS)

ZDO_ACTIVEENDPOINT_RESPONSE Constructor (ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS _
)
C#
public ZDO_ACTIVEENDPOINT_RESPONSE(
ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS
)
C++
public:
ZDO_ACTIVEENDPOINT_RESPONSE(
ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_ACTIVEENDPOINT_RESPONSE(
ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS
)
JScript
public function ZDO_ACTIVEENDPOINT_RESPONSE(
: ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS
)

See Also

ZDO_ACTIVEENDPOINT_RESPONSE Class
TI.ZPI1 Namespace
ZDO_ACTIVEENDPOINT_RESPONSE Constructor Overload List


Fields

ZDO_ACTIVEENDPOINT_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_ACTIVEENDPOINT_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_ACTIVEENDPOINT_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS
C#
public ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS;

See Also

ZDO_ACTIVEENDPOINT_RESPONSE Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS Enumeration

ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS : char
J#
public enum ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSECB Class

ZDO_ACTIVEENDPOINT_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Active Endpoint Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ACTIVEENDPOINT_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_ACTIVEENDPOINT_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_ACTIVEENDPOINT_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_ACTIVEENDPOINT_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_ACTIVEENDPOINT_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSECB Members

ZDO_ACTIVEENDPOINT_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Active Endpoint Request.

The following tables list the members exposed by ZDO_ACTIVEENDPOINT_RESPONSECB.

Public Constructors

Name | Description
ZDO_ACTIVEENDPOINT_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ActiveEndpointCount | Number of active endpoint in the list
Public field | ActiveEndpointList | Array of active endpoints on this device
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ACTIVEENDPOINT_RESPONSECB | Overloaded.
Top

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSECB Constructor

ZDO_ACTIVEENDPOINT_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_ACTIVEENDPOINT_RESPONSECB | Constructor
Public method | ZDO_ACTIVEENDPOINT_RESPONSECB (ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte) |

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSECB Constructor ()

ZDO_ACTIVEENDPOINT_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ACTIVEENDPOINT_RESPONSECB()
C++
public:
ZDO_ACTIVEENDPOINT_RESPONSECB() sealed
J#
public ZDO_ACTIVEENDPOINT_RESPONSECB()
JScript
public function ZDO_ACTIVEENDPOINT_RESPONSECB()

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_ACTIVEENDPOINT_RESPONSECB Constructor Overload List


ZDO_ACTIVEENDPOINT_RESPONSECB Constructor (ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte[])

ZDO_ACTIVEENDPOINT_RESPONSECB Constructor (ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_ACTIVEENDPOINT_RESPONSECB(
ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_ACTIVEENDPOINT_RESPONSECB(
ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS ,
unsigned short ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_ACTIVEENDPOINT_RESPONSECB(
ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_ACTIVEENDPOINT_RESPONSECB(
: ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS,
: UInt16,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_ACTIVEENDPOINT_RESPONSECB Constructor Overload List


Fields

ZDO_ACTIVEENDPOINT_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | ActiveEndpointCount | Number of active endpoint in the list
Public field | ActiveEndpointList | Array of active endpoints on this device
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


ActiveEndpointCount Field

ZDO_ACTIVEENDPOINT_RESPONSECB.ActiveEndpointCount Field
[image]

Number of active endpoint in the list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ActiveEndpointCount As Byte
C#
public byte ActiveEndpointCount;
C++
public:
char ActiveEndpointCount sealed ;
J#
public byte ActiveEndpointCount
JScript
public ActiveEndpointCount : Byte;

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


ActiveEndpointList Field

ZDO_ACTIVEENDPOINT_RESPONSECB.ActiveEndpointList Field
[image]

Array of active endpoints on this device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ActiveEndpointList As Byte()
C#
public byte[] ActiveEndpointList;
C++
public:
array<char>^ ActiveEndpointList sealed ;
J#
public byte[] ActiveEndpointList
JScript
public ActiveEndpointList : Byte[];

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_ACTIVEENDPOINT_RESPONSECB.NWKAddrOfInterest Field
[image]

Device's short address that this response describes.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_ACTIVEENDPOINT_RESPONSECB.SrcAddress Field
[image]

the message's source network address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_ACTIVEENDPOINT_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS
C#
public ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS;

See Also

ZDO_ACTIVEENDPOINT_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS Enumeration

ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class
See Also Example Members
[image]

This command will tell the ZDO to request an End Device Bind. The ZDO will send the message to the Zigbee coordinator based on the information found in the AF Endpoint description for the passed in endpoint.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST : IREQUEST, IZDO
J#
public class ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Members
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Members

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command will tell the ZDO to request an End Device Bind. The ZDO will send the message to the Zigbee coordinator based on the information found in the AF Endpoint description for the passed in endpoint.

The following tables list the members exposed by ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST.

Public Constructors

Name | Description
ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Endpoint | Specifies which endpoint to issue the End Device Bind request for
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST | Overloaded.
Top

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST | Constructor
Public method | ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST (Byte) | Constructor

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor ()

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST()
C++
public:
ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST() sealed
J#
public ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST()
JScript
public function ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST()

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor Overload List


ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor (Byte)

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST(
byte
)
C++
public:
ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST(
char
) sealed
J#
public ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST(
byte
)
JScript
public function ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST(
: Byte
)

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Constructor Overload List


Fields

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Endpoint | Specifies which endpoint to issue the End Device Bind request for
Top

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


Endpoint Field

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST.Endpoint Field
[image]

Specifies which endpoint to issue the End Device Bind request for

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Members
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Members

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST

The following tables list the members exposed by ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.

Public Constructors

Name | Description
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE | Overloaded.
Top

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE | Constructor
Public method | ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE (ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS) |

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor ()

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE()
C++
public:
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE() sealed
J#
public ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE()
JScript
public function ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE()

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor Overload List


ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor (ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS)

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor (ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS _
)
C#
public ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE(
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS
)
C++
public:
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE(
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE(
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS
)
JScript
public function ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE(
: ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS
)

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Constructor Overload List


Fields

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS
C#
public ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS;

See Also

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS Enumeration

ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS : char
J#
public enum ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_REQUEST Class

ZDO_AUTOFINDDESTINATION_REQUEST Class
See Also Example Members
[image]

This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_AUTOFINDDESTINATION_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_AUTOFINDDESTINATION_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_AUTOFINDDESTINATION_REQUEST : IREQUEST, IZDO
J#
public class ZDO_AUTOFINDDESTINATION_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_AUTOFINDDESTINATION_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_AUTOFINDDESTINATION_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_AUTOFINDDESTINATION_REQUEST Members
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_REQUEST Members

ZDO_AUTOFINDDESTINATION_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.

The following tables list the members exposed by ZDO_AUTOFINDDESTINATION_REQUEST.

Public Constructors

Name | Description
ZDO_AUTOFINDDESTINATION_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Endpoint | Specifies which endpoint to issue the End Device Bind request for
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_AUTOFINDDESTINATION_REQUEST | Overloaded.
Top

See Also

ZDO_AUTOFINDDESTINATION_REQUEST Class
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_REQUEST Constructor

ZDO_AUTOFINDDESTINATION_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_AUTOFINDDESTINATION_REQUEST | Constructor
Public method | ZDO_AUTOFINDDESTINATION_REQUEST (Byte) | Constructor

See Also

ZDO_AUTOFINDDESTINATION_REQUEST Class
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_REQUEST Constructor ()

ZDO_AUTOFINDDESTINATION_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_AUTOFINDDESTINATION_REQUEST()
C++
public:
ZDO_AUTOFINDDESTINATION_REQUEST() sealed
J#
public ZDO_AUTOFINDDESTINATION_REQUEST()
JScript
public function ZDO_AUTOFINDDESTINATION_REQUEST()

See Also

ZDO_AUTOFINDDESTINATION_REQUEST Class
TI.ZPI1 Namespace
ZDO_AUTOFINDDESTINATION_REQUEST Constructor Overload List


ZDO_AUTOFINDDESTINATION_REQUEST Constructor (Byte)

ZDO_AUTOFINDDESTINATION_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZDO_AUTOFINDDESTINATION_REQUEST(
byte
)
C++
public:
ZDO_AUTOFINDDESTINATION_REQUEST(
char
) sealed
J#
public ZDO_AUTOFINDDESTINATION_REQUEST(
byte
)
JScript
public function ZDO_AUTOFINDDESTINATION_REQUEST(
: Byte
)

See Also

ZDO_AUTOFINDDESTINATION_REQUEST Class
TI.ZPI1 Namespace
ZDO_AUTOFINDDESTINATION_REQUEST Constructor Overload List


Fields

ZDO_AUTOFINDDESTINATION_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Endpoint | Specifies which endpoint to issue the End Device Bind request for
Top

See Also

ZDO_AUTOFINDDESTINATION_REQUEST Class
TI.ZPI1 Namespace


Endpoint Field

ZDO_AUTOFINDDESTINATION_REQUEST.Endpoint Field
[image]

Specifies which endpoint to issue the End Device Bind request for

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_AUTOFINDDESTINATION_REQUEST Class
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_RESPONSE Class

ZDO_AUTOFINDDESTINATION_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_AUTOFINDDESTINATION_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_AUTOFINDDESTINATION_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_AUTOFINDDESTINATION_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_AUTOFINDDESTINATION_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_AUTOFINDDESTINATION_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_AUTOFINDDESTINATION_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_AUTOFINDDESTINATION_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_AUTOFINDDESTINATION_RESPONSE Members
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_RESPONSE Members

ZDO_AUTOFINDDESTINATION_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_AUTOFINDDESTINATION_REQUEST

The following tables list the members exposed by ZDO_AUTOFINDDESTINATION_RESPONSE.

Public Constructors

Name | Description
ZDO_AUTOFINDDESTINATION_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_AUTOFINDDESTINATION_RESPONSE | Overloaded.
Top

See Also

ZDO_AUTOFINDDESTINATION_RESPONSE Class
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_RESPONSE Constructor

ZDO_AUTOFINDDESTINATION_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_AUTOFINDDESTINATION_RESPONSE | Constructor
Public method | ZDO_AUTOFINDDESTINATION_RESPONSE (ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS) |

See Also

ZDO_AUTOFINDDESTINATION_RESPONSE Class
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_RESPONSE Constructor ()

ZDO_AUTOFINDDESTINATION_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_AUTOFINDDESTINATION_RESPONSE()
C++
public:
ZDO_AUTOFINDDESTINATION_RESPONSE() sealed
J#
public ZDO_AUTOFINDDESTINATION_RESPONSE()
JScript
public function ZDO_AUTOFINDDESTINATION_RESPONSE()

See Also

ZDO_AUTOFINDDESTINATION_RESPONSE Class
TI.ZPI1 Namespace
ZDO_AUTOFINDDESTINATION_RESPONSE Constructor Overload List


ZDO_AUTOFINDDESTINATION_RESPONSE Constructor (ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS)

ZDO_AUTOFINDDESTINATION_RESPONSE Constructor (ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS _
)
C#
public ZDO_AUTOFINDDESTINATION_RESPONSE(
ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS
)
C++
public:
ZDO_AUTOFINDDESTINATION_RESPONSE(
ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_AUTOFINDDESTINATION_RESPONSE(
ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS
)
JScript
public function ZDO_AUTOFINDDESTINATION_RESPONSE(
: ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS
)

See Also

ZDO_AUTOFINDDESTINATION_RESPONSE Class
TI.ZPI1 Namespace
ZDO_AUTOFINDDESTINATION_RESPONSE Constructor Overload List


Fields

ZDO_AUTOFINDDESTINATION_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_AUTOFINDDESTINATION_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_AUTOFINDDESTINATION_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS
C#
public ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS;

See Also

ZDO_AUTOFINDDESTINATION_RESPONSE Class
TI.ZPI1 Namespace


ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS Enumeration

ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS : char
J#
public enum ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_BIND_REQUEST Class

ZDO_BIND_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Bind

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_BIND_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_BIND_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_BIND_REQUEST : IREQUEST, IZDO
J#
public class ZDO_BIND_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_BIND_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_BIND_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BIND_REQUEST Members
TI.ZPI1 Namespace


ZDO_BIND_REQUEST Members

ZDO_BIND_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Bind

The following tables list the members exposed by ZDO_BIND_REQUEST.

Public Constructors

Name | Description
ZDO_BIND_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | DstAddress | 64 bit Binding destination address. Not to be confused with DstAddr
Public field | DstAddrMode | Destination address mode: 01 for Group address; 03 for Extended address
Public field | DstEndpoint | Binding destination endpoint
Public field | SecuritySuite | Security options
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint. See Table 1 for formatting
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_BIND_REQUEST | Overloaded.
Top

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_BIND_REQUEST Constructor

ZDO_BIND_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_BIND_REQUEST | Constructor
Public method | ZDO_BIND_REQUEST (UInt16, UInt64, Byte, UInt16, ZDO_BIND_REQUEST.ADDRESS_MODE, UInt64, Byte, ZDO_BIND_REQUEST.SECURITY_SUITE) |

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_BIND_REQUEST Constructor ()

ZDO_BIND_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BIND_REQUEST()
C++
public:
ZDO_BIND_REQUEST() sealed
J#
public ZDO_BIND_REQUEST()
JScript
public function ZDO_BIND_REQUEST()

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_BIND_REQUEST Constructor Overload List


ZDO_BIND_REQUEST Constructor (UInt16, UInt64, Byte, UInt16, ZDO_BIND_REQUEST.ADDRESS_MODE, UInt64, Byte, ZDO_BIND_REQUEST.SECURITY_SUITE)

ZDO_BIND_REQUEST Constructor (UInt16, UInt64, Byte, UInt16, ZDO_BIND_REQUEST.ADDRESS_MODE, UInt64, Byte, ZDO_BIND_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As ZDO_BIND_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As ZDO_BIND_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_BIND_REQUEST(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_BIND_REQUEST.ADDRESS_MODE ,
ulong ,
byte ,
ZDO_BIND_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_BIND_REQUEST(
unsigned short ,
unsigned __int64 ,
char ,
unsigned short ,
ZDO_BIND_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
char ,
ZDO_BIND_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_BIND_REQUEST(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_BIND_REQUEST.ADDRESS_MODE ,
ulong ,
byte ,
ZDO_BIND_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_BIND_REQUEST(
: UInt16,
: UInt64,
: Byte,
: UInt16,
: ZDO_BIND_REQUEST.ADDRESS_MODE,
: UInt64,
: Byte,
: ZDO_BIND_REQUEST.SECURITY_SUITE
)

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_BIND_REQUEST Constructor Overload List


Fields

ZDO_BIND_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | DstAddress | 64 bit Binding destination address. Not to be confused with DstAddr
Public field | DstAddrMode | Destination address mode: 01 for Group address; 03 for Extended address
Public field | DstEndpoint | Binding destination endpoint
Public field | SecuritySuite | Security options
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint. See Table 1 for formatting
Top

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


ClusterID Field

ZDO_BIND_REQUEST.ClusterID Field
[image]

Cluster ID to match in messages

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_BIND_REQUEST.DstAddr Field
[image]

destination address, where this message is going

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


DstAddress Field

ZDO_BIND_REQUEST.DstAddress Field
[image]

64 bit Binding destination address. Not to be confused with DstAddr

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddress As UInt64
C#
public ulong DstAddress;
C++
public:
unsigned __int64 DstAddress sealed ;
J#
public ulong DstAddress
JScript
public DstAddress : UInt64;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


DstAddrMode Field

ZDO_BIND_REQUEST.DstAddrMode Field
[image]

Destination address mode: 01 for Group address; 03 for Extended address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As ZDO_BIND_REQUEST.ADDRESS_MODE
C#
public ZDO_BIND_REQUEST.ADDRESS_MODE DstAddrMode;
C++
public:
ZDO_BIND_REQUEST.ADDRESS_MODE DstAddrMode sealed ;
J#
public ZDO_BIND_REQUEST.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : ZDO_BIND_REQUEST.ADDRESS_MODE;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


DstEndpoint Field

ZDO_BIND_REQUEST.DstEndpoint Field
[image]

Binding destination endpoint

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstEndpoint As Byte
C#
public byte DstEndpoint;
C++
public:
char DstEndpoint sealed ;
J#
public byte DstEndpoint
JScript
public DstEndpoint : Byte;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_BIND_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_BIND_REQUEST.SECURITY_SUITE
C#
public ZDO_BIND_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_BIND_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_BIND_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_BIND_REQUEST.SECURITY_SUITE;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_BIND_REQUEST.SrcAddress Field
[image]

64 bit Binding source address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


SrcEndpoint Field

ZDO_BIND_REQUEST.SrcEndpoint Field
[image]

Binding source endpoint. See Table 1 for formatting

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

ZDO_BIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_BIND_REQUEST.ADDRESS_MODE Enumeration

ZDO_BIND_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_BIND_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZDO_BIND_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZDO_BIND_REQUEST.ADDRESS_MODE : char
J#
public enum ZDO_BIND_REQUEST.ADDRESS_MODE byte
JScript
public enum ZDO_BIND_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZDO_BIND_REQUEST.SECURITY_SUITE Enumeration

ZDO_BIND_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_BIND_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_BIND_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_BIND_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_BIND_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_BIND_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_BIND_RESPONSE Class

ZDO_BIND_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_BIND_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_BIND_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_BIND_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_BIND_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_BIND_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_BIND_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_BIND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BIND_RESPONSE Members
TI.ZPI1 Namespace


ZDO_BIND_RESPONSE Members

ZDO_BIND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_BIND_REQUEST

The following tables list the members exposed by ZDO_BIND_RESPONSE.

Public Constructors

Name | Description
ZDO_BIND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_BIND_RESPONSE | Overloaded.
Top

See Also

ZDO_BIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_BIND_RESPONSE Constructor

ZDO_BIND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_BIND_RESPONSE | Constructor
Public method | ZDO_BIND_RESPONSE (ZDO_BIND_RESPONSE.AF_STATUS) |

See Also

ZDO_BIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_BIND_RESPONSE Constructor ()

ZDO_BIND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BIND_RESPONSE()
C++
public:
ZDO_BIND_RESPONSE() sealed
J#
public ZDO_BIND_RESPONSE()
JScript
public function ZDO_BIND_RESPONSE()

See Also

ZDO_BIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_BIND_RESPONSE Constructor Overload List


ZDO_BIND_RESPONSE Constructor (ZDO_BIND_RESPONSE.AF_STATUS)

ZDO_BIND_RESPONSE Constructor (ZDO_BIND_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_BIND_RESPONSE.AF_STATUS _
)
C#
public ZDO_BIND_RESPONSE(
ZDO_BIND_RESPONSE.AF_STATUS
)
C++
public:
ZDO_BIND_RESPONSE(
ZDO_BIND_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_BIND_RESPONSE(
ZDO_BIND_RESPONSE.AF_STATUS
)
JScript
public function ZDO_BIND_RESPONSE(
: ZDO_BIND_RESPONSE.AF_STATUS
)

See Also

ZDO_BIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_BIND_RESPONSE Constructor Overload List


Fields

ZDO_BIND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_BIND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_BIND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_BIND_RESPONSE.AF_STATUS
C#
public ZDO_BIND_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_BIND_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_BIND_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_BIND_RESPONSE.AF_STATUS;

See Also

ZDO_BIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_BIND_RESPONSE.AF_STATUS Enumeration

ZDO_BIND_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_BIND_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_BIND_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_BIND_RESPONSE.AF_STATUS : char
J#
public enum ZDO_BIND_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_BIND_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_BIND_RESPONSECB Class

ZDO_BIND_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Bind Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_BIND_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_BIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_BIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_BIND_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_BIND_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_BIND_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BIND_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_BIND_RESPONSECB Members

ZDO_BIND_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Bind Request

The following tables list the members exposed by ZDO_BIND_RESPONSECB.

Public Constructors

Name | Description
ZDO_BIND_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates status of the bind request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_BIND_RESPONSECB | Overloaded.
Top

See Also

ZDO_BIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_BIND_RESPONSECB Constructor

ZDO_BIND_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_BIND_RESPONSECB | Constructor
Public method | ZDO_BIND_RESPONSECB (ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS, UInt16) |

See Also

ZDO_BIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_BIND_RESPONSECB Constructor ()

ZDO_BIND_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BIND_RESPONSECB()
C++
public:
ZDO_BIND_RESPONSECB() sealed
J#
public ZDO_BIND_RESPONSECB()
JScript
public function ZDO_BIND_RESPONSECB()

See Also

ZDO_BIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_BIND_RESPONSECB Constructor Overload List


ZDO_BIND_RESPONSECB Constructor (ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS, UInt16)

ZDO_BIND_RESPONSECB Constructor (ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS, _
ByVal As UInt16 _
)
C#
public ZDO_BIND_RESPONSECB(
ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS ,
ushort
)
C++
public:
ZDO_BIND_RESPONSECB(
ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS ,
unsigned short
) sealed
J#
public ZDO_BIND_RESPONSECB(
ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS ,
ushort
)
JScript
public function ZDO_BIND_RESPONSECB(
: ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS,
: UInt16
)

See Also

ZDO_BIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_BIND_RESPONSECB Constructor Overload List


Fields

ZDO_BIND_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates status of the bind request
Top

See Also

ZDO_BIND_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_BIND_RESPONSECB.SrcAddress Field
[image]

the message's source network address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_BIND_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_BIND_RESPONSECB.Status Field
[image]

this field indicates status of the bind request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS
C#
public ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS Status;
C++
public:
ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS Status sealed ;
J#
public ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS Status
JScript
public Status : ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS;

See Also

ZDO_BIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS Enumeration

ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS Enumeration
[image]

Status code for bind response

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS As Byte
C#
public enum ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS : byte
C++
public enum class ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS : char
J#
public enum ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS byte
JScript
public enum ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS :

Members

Member Name | Description
SUCCESS | Status code for bind response
NOT_SUPPORTED | Status code for bind response
TABLE_FULL | Status code for bind response

See Also

TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_REQUEST Class

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
See Also Example Members
[image]

This command is generated to request for the destination device's complex descriptor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_COMPLEXDESCRIPTOR_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_COMPLEXDESCRIPTOR_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_COMPLEXDESCRIPTOR_REQUEST : IREQUEST, IZDO
J#
public class ZDO_COMPLEXDESCRIPTOR_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_COMPLEXDESCRIPTOR_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Members
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_REQUEST Members

ZDO_COMPLEXDESCRIPTOR_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request for the destination device's complex descriptor

The following tables list the members exposed by ZDO_COMPLEXDESCRIPTOR_REQUEST.

Public Constructors

Name | Description
ZDO_COMPLEXDESCRIPTOR_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_COMPLEXDESCRIPTOR_REQUEST | Overloaded.
Top

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor

ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_COMPLEXDESCRIPTOR_REQUEST | Constructor
Public method | ZDO_COMPLEXDESCRIPTOR_REQUEST (UInt16, UInt16, ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE) |

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor ()

ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_COMPLEXDESCRIPTOR_REQUEST()
C++
public:
ZDO_COMPLEXDESCRIPTOR_REQUEST() sealed
J#
public ZDO_COMPLEXDESCRIPTOR_REQUEST()
JScript
public function ZDO_COMPLEXDESCRIPTOR_REQUEST()

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor Overload List


ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE)

ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_COMPLEXDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_COMPLEXDESCRIPTOR_REQUEST(
unsigned short ,
unsigned short ,
ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_COMPLEXDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_COMPLEXDESCRIPTOR_REQUEST(
: UInt16,
: UInt16,
: ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE
)

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_COMPLEXDESCRIPTOR_REQUEST Constructor Overload List


Fields

ZDO_COMPLEXDESCRIPTOR_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_COMPLEXDESCRIPTOR_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_COMPLEXDESCRIPTOR_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_COMPLEXDESCRIPTOR_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE
C#
public ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE;

See Also

ZDO_COMPLEXDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration

ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_RESPONSE Class

ZDO_COMPLEXDESCRIPTOR_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_COMPLEXDESCRIPTOR_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_COMPLEXDESCRIPTOR_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_COMPLEXDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_COMPLEXDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_COMPLEXDESCRIPTOR_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_COMPLEXDESCRIPTOR_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_COMPLEXDESCRIPTOR_RESPONSE Members
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_RESPONSE Members

ZDO_COMPLEXDESCRIPTOR_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_COMPLEXDESCRIPTOR_REQUEST

The following tables list the members exposed by ZDO_COMPLEXDESCRIPTOR_RESPONSE.

Public Constructors

Name | Description
ZDO_COMPLEXDESCRIPTOR_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_COMPLEXDESCRIPTOR_RESPONSE | Overloaded.
Top

See Also

ZDO_COMPLEXDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor

ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_COMPLEXDESCRIPTOR_RESPONSE | Constructor
Public method | ZDO_COMPLEXDESCRIPTOR_RESPONSE (ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS) |

See Also

ZDO_COMPLEXDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor ()

ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_COMPLEXDESCRIPTOR_RESPONSE()
C++
public:
ZDO_COMPLEXDESCRIPTOR_RESPONSE() sealed
J#
public ZDO_COMPLEXDESCRIPTOR_RESPONSE()
JScript
public function ZDO_COMPLEXDESCRIPTOR_RESPONSE()

See Also

ZDO_COMPLEXDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor Overload List


ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor (ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS)

ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor (ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS _
)
C#
public ZDO_COMPLEXDESCRIPTOR_RESPONSE(
ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS
)
C++
public:
ZDO_COMPLEXDESCRIPTOR_RESPONSE(
ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_COMPLEXDESCRIPTOR_RESPONSE(
ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS
)
JScript
public function ZDO_COMPLEXDESCRIPTOR_RESPONSE(
: ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS
)

See Also

ZDO_COMPLEXDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_COMPLEXDESCRIPTOR_RESPONSE Constructor Overload List


Fields

ZDO_COMPLEXDESCRIPTOR_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_COMPLEXDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_COMPLEXDESCRIPTOR_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS
C#
public ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS;

See Also

ZDO_COMPLEXDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS Enumeration

ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS : char
J#
public enum ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE Class

ZDO_END_DEVICE_ANNCE Class
See Also Example Members
[image]

This command is generated to request an End Device Announce.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_ANNCE
Implements IREQUEST, IZDO
C#
public class ZDO_END_DEVICE_ANNCE : IREQUEST, IZDO
C++
ref class ZDO_END_DEVICE_ANNCE : IREQUEST, IZDO
J#
public class ZDO_END_DEVICE_ANNCE implements IREQUEST, IZDO
JScript
public class ZDO_END_DEVICE_ANNCE extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_END_DEVICE_ANNCE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_ANNCE Members
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE Members

ZDO_END_DEVICE_ANNCE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request an End Device Announce.

The following tables list the members exposed by ZDO_END_DEVICE_ANNCE.

Public Constructors

Name | Description
ZDO_END_DEVICE_ANNCE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Capabilities | MAC capabilities
Public field | DevAddr | Device network address.
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to announce
Public field | SecuritySuite | Security options.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_ANNCE | Overloaded.
Top

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE Constructor

ZDO_END_DEVICE_ANNCE Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_ANNCE | Constructor
Public method | ZDO_END_DEVICE_ANNCE (UInt16, UInt64, ZDO_END_DEVICE_ANNCE.SECURITY_SUITE, ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO) |

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE Constructor ()

ZDO_END_DEVICE_ANNCE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_ANNCE()
C++
public:
ZDO_END_DEVICE_ANNCE() sealed
J#
public ZDO_END_DEVICE_ANNCE()
JScript
public function ZDO_END_DEVICE_ANNCE()

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace
ZDO_END_DEVICE_ANNCE Constructor Overload List


ZDO_END_DEVICE_ANNCE Constructor (UInt16, UInt64, ZDO_END_DEVICE_ANNCE.SECURITY_SUITE, ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO)

ZDO_END_DEVICE_ANNCE Constructor (UInt16, UInt64, ZDO_END_DEVICE_ANNCE.SECURITY_SUITE, ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As ZDO_END_DEVICE_ANNCE.SECURITY_SUITE, _
ByVal As ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO _
)
C#
public ZDO_END_DEVICE_ANNCE(
ushort ,
ulong ,
ZDO_END_DEVICE_ANNCE.SECURITY_SUITE ,
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
)
C++
public:
ZDO_END_DEVICE_ANNCE(
unsigned short ,
unsigned __int64 ,
ZDO_END_DEVICE_ANNCE.SECURITY_SUITE ,
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
) sealed
J#
public ZDO_END_DEVICE_ANNCE(
ushort ,
ulong ,
ZDO_END_DEVICE_ANNCE.SECURITY_SUITE ,
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
)
JScript
public function ZDO_END_DEVICE_ANNCE(
: UInt16,
: UInt64,
: ZDO_END_DEVICE_ANNCE.SECURITY_SUITE,
: ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
)

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace
ZDO_END_DEVICE_ANNCE Constructor Overload List


Fields

ZDO_END_DEVICE_ANNCE Fields
[image]

Public Fields

 | Name | Description
Public field | Capabilities | MAC capabilities
Public field | DevAddr | Device network address.
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to announce
Public field | SecuritySuite | Security options.
Top

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace


Capabilities Field

ZDO_END_DEVICE_ANNCE.Capabilities Field
[image]

MAC capabilities

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Capabilities As ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
C#
public ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Capabilities;
C++
public:
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Capabilities sealed ;
J#
public ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Capabilities
JScript
public Capabilities : ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO;

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace


DevAddr Field

ZDO_END_DEVICE_ANNCE.DevAddr Field
[image]

Device network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DevAddr As UInt16
C#
public ushort DevAddr;
C++
public:
unsigned short DevAddr sealed ;
J#
public ushort DevAddr
JScript
public DevAddr : UInt16;

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace


DeviceAddress Field

ZDO_END_DEVICE_ANNCE.DeviceAddress Field
[image]

The 64 bit IEEE Address of the device you want to announce

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_END_DEVICE_ANNCE.SecuritySuite Field
[image]

Security options.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_END_DEVICE_ANNCE.SECURITY_SUITE
C#
public ZDO_END_DEVICE_ANNCE.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_END_DEVICE_ANNCE.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_END_DEVICE_ANNCE.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_END_DEVICE_ANNCE.SECURITY_SUITE;

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Enumeration

ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO byte
JScript
public enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE.SECURITY_SUITE Enumeration

ZDO_END_DEVICE_ANNCE.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_END_DEVICE_ANNCE.SECURITY_SUITE As Byte
C#
public enum ZDO_END_DEVICE_ANNCE.SECURITY_SUITE : byte
C++
public enum class ZDO_END_DEVICE_ANNCE.SECURITY_SUITE : char
J#
public enum ZDO_END_DEVICE_ANNCE.SECURITY_SUITE byte
JScript
public enum ZDO_END_DEVICE_ANNCE.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE_RESPONSE Class

ZDO_END_DEVICE_ANNCE_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_END_DEVICE_ANNCE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_ANNCE_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_END_DEVICE_ANNCE_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_END_DEVICE_ANNCE_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_END_DEVICE_ANNCE_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_END_DEVICE_ANNCE_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_END_DEVICE_ANNCE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_ANNCE_RESPONSE Members
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE_RESPONSE Members

ZDO_END_DEVICE_ANNCE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_END_DEVICE_ANNCE_REQUEST

The following tables list the members exposed by ZDO_END_DEVICE_ANNCE_RESPONSE.

Public Constructors

Name | Description
ZDO_END_DEVICE_ANNCE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_ANNCE_RESPONSE | Overloaded.
Top

See Also

ZDO_END_DEVICE_ANNCE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE_RESPONSE Constructor

ZDO_END_DEVICE_ANNCE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_ANNCE_RESPONSE | Constructor
Public method | ZDO_END_DEVICE_ANNCE_RESPONSE (ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS) |

See Also

ZDO_END_DEVICE_ANNCE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE_RESPONSE Constructor ()

ZDO_END_DEVICE_ANNCE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_ANNCE_RESPONSE()
C++
public:
ZDO_END_DEVICE_ANNCE_RESPONSE() sealed
J#
public ZDO_END_DEVICE_ANNCE_RESPONSE()
JScript
public function ZDO_END_DEVICE_ANNCE_RESPONSE()

See Also

ZDO_END_DEVICE_ANNCE_RESPONSE Class
TI.ZPI1 Namespace
ZDO_END_DEVICE_ANNCE_RESPONSE Constructor Overload List


ZDO_END_DEVICE_ANNCE_RESPONSE Constructor (ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS)

ZDO_END_DEVICE_ANNCE_RESPONSE Constructor (ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS _
)
C#
public ZDO_END_DEVICE_ANNCE_RESPONSE(
ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_END_DEVICE_ANNCE_RESPONSE(
ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_END_DEVICE_ANNCE_RESPONSE(
ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_END_DEVICE_ANNCE_RESPONSE(
: ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS
)

See Also

ZDO_END_DEVICE_ANNCE_RESPONSE Class
TI.ZPI1 Namespace
ZDO_END_DEVICE_ANNCE_RESPONSE Constructor Overload List


Fields

ZDO_END_DEVICE_ANNCE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_END_DEVICE_ANNCE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_END_DEVICE_ANNCE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS
C#
public ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS;

See Also

ZDO_END_DEVICE_ANNCE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS Enumeration

ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_REQUEST Class

ZDO_ENDDEVICEBIND_REQUEST Class
See Also Example Members
[image]

This command is generated to request an End Device Bind with the destination device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ENDDEVICEBIND_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_ENDDEVICEBIND_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_ENDDEVICEBIND_REQUEST : IREQUEST, IZDO
J#
public class ZDO_ENDDEVICEBIND_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_ENDDEVICEBIND_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_ENDDEVICEBIND_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ENDDEVICEBIND_REQUEST Members
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_REQUEST Members

ZDO_ENDDEVICEBIND_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request an End Device Bind with the destination device

The following tables list the members exposed by ZDO_ENDDEVICEBIND_REQUEST.

Public Constructors

Name | Description
ZDO_ENDDEVICEBIND_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | Device's Endpoint
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | LocalCoordinator | Local coordinator's short address
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the OutClusterList
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ENDDEVICEBIND_REQUEST | Overloaded.
Top

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_REQUEST Constructor

ZDO_ENDDEVICEBIND_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_ENDDEVICEBIND_REQUEST | Constructor
Public method | ZDO_ENDDEVICEBIND_REQUEST (UInt16, UInt16, Byte, UInt16, Byte, UInt16, Byte, UInt16, ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE) |

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_REQUEST Constructor ()

ZDO_ENDDEVICEBIND_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ENDDEVICEBIND_REQUEST()
C++
public:
ZDO_ENDDEVICEBIND_REQUEST() sealed
J#
public ZDO_ENDDEVICEBIND_REQUEST()
JScript
public function ZDO_ENDDEVICEBIND_REQUEST()

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_ENDDEVICEBIND_REQUEST Constructor Overload List


ZDO_ENDDEVICEBIND_REQUEST Constructor (UInt16, UInt16, Byte, UInt16, Byte, UInt16[], Byte, UInt16[], ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE)

ZDO_ENDDEVICEBIND_REQUEST Constructor (UInt16, UInt16, Byte, UInt16, Byte, UInt16[], Byte, UInt16[], ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_ENDDEVICEBIND_REQUEST(
ushort ,
ushort ,
byte ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[] ,
ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_ENDDEVICEBIND_REQUEST(
unsigned short ,
unsigned short ,
char ,
unsigned short ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^ ,
ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_ENDDEVICEBIND_REQUEST(
ushort ,
ushort ,
byte ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[] ,
ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_ENDDEVICEBIND_REQUEST(
: UInt16,
: UInt16,
: Byte,
: UInt16,
: Byte,
: UInt16[],
: Byte,
: UInt16[],
: ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE
)

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_ENDDEVICEBIND_REQUEST Constructor Overload List


Fields

ZDO_ENDDEVICEBIND_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | Device's Endpoint
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | LocalCoordinator | Local coordinator's short address
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the OutClusterList
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Public field | SecuritySuite | Security options
Top

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_ENDDEVICEBIND_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


Endpoint Field

ZDO_ENDDEVICEBIND_REQUEST.Endpoint Field
[image]

Device's Endpoint

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


InClusterList Field

ZDO_ENDDEVICEBIND_REQUEST.InClusterList Field
[image]

Array of input cluster IDs - NumInClusters long

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InClusterList As UInt16()
C#
public ushort[] InClusterList;
C++
public:
array<unsigned short>^ InClusterList sealed ;
J#
public ushort[] InClusterList
JScript
public InClusterList : UInt16[];

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


LocalCoordinator Field

ZDO_ENDDEVICEBIND_REQUEST.LocalCoordinator Field
[image]

Local coordinator's short address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LocalCoordinator As UInt16
C#
public ushort LocalCoordinator;
C++
public:
unsigned short LocalCoordinator sealed ;
J#
public ushort LocalCoordinator
JScript
public LocalCoordinator : UInt16;

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


NumInClusters Field

ZDO_ENDDEVICEBIND_REQUEST.NumInClusters Field
[image]

Number of ClusterIds in the InClusterList

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumInClusters As Byte
C#
public byte NumInClusters;
C++
public:
char NumInClusters sealed ;
J#
public byte NumInClusters
JScript
public NumInClusters : Byte;

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


NumOutClusters Field

ZDO_ENDDEVICEBIND_REQUEST.NumOutClusters Field
[image]

Number of ClusterIds in the OutClusterList

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOutClusters As Byte
C#
public byte NumOutClusters;
C++
public:
char NumOutClusters sealed ;
J#
public byte NumOutClusters
JScript
public NumOutClusters : Byte;

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


OutClusterList Field

ZDO_ENDDEVICEBIND_REQUEST.OutClusterList Field
[image]

Array of output cluster IDs - NumOutClusters long

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutClusterList As UInt16()
C#
public ushort[] OutClusterList;
C++
public:
array<unsigned short>^ OutClusterList sealed ;
J#
public ushort[] OutClusterList
JScript
public OutClusterList : UInt16[];

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


ProfileID Field

ZDO_ENDDEVICEBIND_REQUEST.ProfileID Field
[image]

Profile ID to match

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ProfileID As UInt16
C#
public ushort ProfileID;
C++
public:
unsigned short ProfileID sealed ;
J#
public ushort ProfileID
JScript
public ProfileID : UInt16;

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_ENDDEVICEBIND_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE
C#
public ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE;

See Also

ZDO_ENDDEVICEBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE Enumeration

ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSE Class

ZDO_ENDDEVICEBIND_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_ENDDEVICEBIND_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ENDDEVICEBIND_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_ENDDEVICEBIND_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_ENDDEVICEBIND_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_ENDDEVICEBIND_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_ENDDEVICEBIND_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ENDDEVICEBIND_RESPONSE Members
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSE Members

ZDO_ENDDEVICEBIND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_ENDDEVICEBIND_REQUEST

The following tables list the members exposed by ZDO_ENDDEVICEBIND_RESPONSE.

Public Constructors

Name | Description
ZDO_ENDDEVICEBIND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ENDDEVICEBIND_RESPONSE | Overloaded.
Top

See Also

ZDO_ENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSE Constructor

ZDO_ENDDEVICEBIND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_ENDDEVICEBIND_RESPONSE | Constructor
Public method | ZDO_ENDDEVICEBIND_RESPONSE (ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS) |

See Also

ZDO_ENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSE Constructor ()

ZDO_ENDDEVICEBIND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ENDDEVICEBIND_RESPONSE()
C++
public:
ZDO_ENDDEVICEBIND_RESPONSE() sealed
J#
public ZDO_ENDDEVICEBIND_RESPONSE()
JScript
public function ZDO_ENDDEVICEBIND_RESPONSE()

See Also

ZDO_ENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_ENDDEVICEBIND_RESPONSE Constructor Overload List


ZDO_ENDDEVICEBIND_RESPONSE Constructor (ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS)

ZDO_ENDDEVICEBIND_RESPONSE Constructor (ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS _
)
C#
public ZDO_ENDDEVICEBIND_RESPONSE(
ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS
)
C++
public:
ZDO_ENDDEVICEBIND_RESPONSE(
ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_ENDDEVICEBIND_RESPONSE(
ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS
)
JScript
public function ZDO_ENDDEVICEBIND_RESPONSE(
: ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS
)

See Also

ZDO_ENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_ENDDEVICEBIND_RESPONSE Constructor Overload List


Fields

ZDO_ENDDEVICEBIND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_ENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_ENDDEVICEBIND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS
C#
public ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS;

See Also

ZDO_ENDDEVICEBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS Enumeration

ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS : char
J#
public enum ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSECB Class

ZDO_ENDDEVICEBIND_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO End Device Bind Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ENDDEVICEBIND_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_ENDDEVICEBIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_ENDDEVICEBIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_ENDDEVICEBIND_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_ENDDEVICEBIND_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSECB Members

ZDO_ENDDEVICEBIND_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO End Device Bind Request

The following tables list the members exposed by ZDO_ENDDEVICEBIND_RESPONSECB.

Public Constructors

Name | Description
ZDO_ENDDEVICEBIND_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates status of the bind request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ENDDEVICEBIND_RESPONSECB | Overloaded.
Top

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSECB Constructor

ZDO_ENDDEVICEBIND_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_ENDDEVICEBIND_RESPONSECB | Constructor
Public method | ZDO_ENDDEVICEBIND_RESPONSECB (ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS, UInt16) |

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSECB Constructor ()

ZDO_ENDDEVICEBIND_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ENDDEVICEBIND_RESPONSECB()
C++
public:
ZDO_ENDDEVICEBIND_RESPONSECB() sealed
J#
public ZDO_ENDDEVICEBIND_RESPONSECB()
JScript
public function ZDO_ENDDEVICEBIND_RESPONSECB()

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_ENDDEVICEBIND_RESPONSECB Constructor Overload List


ZDO_ENDDEVICEBIND_RESPONSECB Constructor (ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS, UInt16)

ZDO_ENDDEVICEBIND_RESPONSECB Constructor (ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS, _
ByVal As UInt16 _
)
C#
public ZDO_ENDDEVICEBIND_RESPONSECB(
ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS ,
ushort
)
C++
public:
ZDO_ENDDEVICEBIND_RESPONSECB(
ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS ,
unsigned short
) sealed
J#
public ZDO_ENDDEVICEBIND_RESPONSECB(
ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS ,
ushort
)
JScript
public function ZDO_ENDDEVICEBIND_RESPONSECB(
: ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS,
: UInt16
)

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_ENDDEVICEBIND_RESPONSECB Constructor Overload List


Fields

ZDO_ENDDEVICEBIND_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates status of the bind request
Top

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_ENDDEVICEBIND_RESPONSECB.SrcAddress Field
[image]

the message's source network address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_ENDDEVICEBIND_RESPONSECB.Status Field
[image]

this field indicates status of the bind request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS
C#
public ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS Status;
C++
public:
ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS Status sealed ;
J#
public ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS Status
JScript
public Status : ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS;

See Also

ZDO_ENDDEVICEBIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS Enumeration

ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS Enumeration
See Also Example
[image]

status code for End Device bind Response

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS As Byte
C#
public enum ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS : byte
C++
public enum class ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS : char
J#
public enum ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS byte
JScript
public enum ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS :

Members

Member Name | Description
SUCCESS | status code for End Device bind Response
NOT_SUPPORTED | status code for End Device bind Response
TIMEOUT | status code for End Device bind Response
NO_MATCH | status code for End Device bind Response

See Also

TI.ZPI1 Namespace


ZDO_IEEEADDRESS_REQUEST Class

ZDO_IEEEADDRESS_REQUEST Class
See Also Example Members
[image]

This command will request a device's IEEE 64-bit address. You must subscribe to "ZDO IEEE Address Response" to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_IEEEADDRESS_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_IEEEADDRESS_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_IEEEADDRESS_REQUEST : IREQUEST, IZDO
J#
public class ZDO_IEEEADDRESS_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_IEEEADDRESS_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_IEEEADDRESS_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_IEEEADDRESS_REQUEST Members
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_REQUEST Members

ZDO_IEEEADDRESS_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command will request a device's IEEE 64-bit address. You must subscribe to "ZDO IEEE Address Response" to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.

The following tables list the members exposed by ZDO_IEEEADDRESS_REQUEST.

Public Constructors

Name | Description
ZDO_IEEEADDRESS_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ReqType | Request type
Public field | SecuritySuite | Security options
Public field | ShortAddr | short address of the destination device
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_IEEEADDRESS_REQUEST | Overloaded.
Top

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_REQUEST Constructor

ZDO_IEEEADDRESS_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_IEEEADDRESS_REQUEST | Constructor
Public method | ZDO_IEEEADDRESS_REQUEST (UInt16, ZDO_IEEEADDRESS_REQUEST.REQ_TYPE, Byte, ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE) |

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_REQUEST Constructor ()

ZDO_IEEEADDRESS_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_IEEEADDRESS_REQUEST()
C++
public:
ZDO_IEEEADDRESS_REQUEST() sealed
J#
public ZDO_IEEEADDRESS_REQUEST()
JScript
public function ZDO_IEEEADDRESS_REQUEST()

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace
ZDO_IEEEADDRESS_REQUEST Constructor Overload List


ZDO_IEEEADDRESS_REQUEST Constructor (UInt16, ZDO_IEEEADDRESS_REQUEST.REQ_TYPE, Byte, ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE)

ZDO_IEEEADDRESS_REQUEST Constructor (UInt16, ZDO_IEEEADDRESS_REQUEST.REQ_TYPE, Byte, ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_IEEEADDRESS_REQUEST.REQ_TYPE, _
ByVal As Byte, _
ByVal As ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_IEEEADDRESS_REQUEST(
ushort ,
ZDO_IEEEADDRESS_REQUEST.REQ_TYPE ,
byte ,
ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_IEEEADDRESS_REQUEST(
unsigned short ,
ZDO_IEEEADDRESS_REQUEST.REQ_TYPE ,
char ,
ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_IEEEADDRESS_REQUEST(
ushort ,
ZDO_IEEEADDRESS_REQUEST.REQ_TYPE ,
byte ,
ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_IEEEADDRESS_REQUEST(
: UInt16,
: ZDO_IEEEADDRESS_REQUEST.REQ_TYPE,
: Byte,
: ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE
)

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace
ZDO_IEEEADDRESS_REQUEST Constructor Overload List


Fields

ZDO_IEEEADDRESS_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ReqType | Request type
Public field | SecuritySuite | Security options
Public field | ShortAddr | short address of the destination device
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace


ReqType Field

ZDO_IEEEADDRESS_REQUEST.ReqType Field
[image]

Request type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReqType As ZDO_IEEEADDRESS_REQUEST.REQ_TYPE
C#
public ZDO_IEEEADDRESS_REQUEST.REQ_TYPE ReqType;
C++
public:
ZDO_IEEEADDRESS_REQUEST.REQ_TYPE ReqType sealed ;
J#
public ZDO_IEEEADDRESS_REQUEST.REQ_TYPE ReqType
JScript
public ReqType : ZDO_IEEEADDRESS_REQUEST.REQ_TYPE;

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_IEEEADDRESS_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE
C#
public ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE;

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace


ShortAddr Field

ZDO_IEEEADDRESS_REQUEST.ShortAddr Field
[image]

short address of the destination device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ShortAddr As UInt16
C#
public ushort ShortAddr;
C++
public:
unsigned short ShortAddr sealed ;
J#
public ushort ShortAddr
JScript
public ShortAddr : UInt16;

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_IEEEADDRESS_REQUEST.StartIndex Field
[image]

Starting index into the list of children. This is used to get more of the list if the list is to large for one message.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_IEEEADDRESS_REQUEST Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_REQUEST.REQ_TYPE Enumeration

ZDO_IEEEADDRESS_REQUEST.REQ_TYPE Enumeration
[image]

Request type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEEADDRESS_REQUEST.REQ_TYPE As Byte
C#
public enum ZDO_IEEEADDRESS_REQUEST.REQ_TYPE : byte
C++
public enum class ZDO_IEEEADDRESS_REQUEST.REQ_TYPE : char
J#
public enum ZDO_IEEEADDRESS_REQUEST.REQ_TYPE byte
JScript
public enum ZDO_IEEEADDRESS_REQUEST.REQ_TYPE :

Members

Member Name | Description
SINGLE_DEVICE_RESPONSE | Request type
EXTENDED | Request type

See Also

TI.ZPI1 Namespace


ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE Enumeration

ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSE Class

ZDO_IEEEADDRESS_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_IEEEADDRESS_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_IEEEADDRESS_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_IEEEADDRESS_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_IEEEADDRESS_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_IEEEADDRESS_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_IEEEADDRESS_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_IEEEADDRESS_RESPONSE Members
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSE Members

ZDO_IEEEADDRESS_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_IEEEADDRESS_REQUEST

The following tables list the members exposed by ZDO_IEEEADDRESS_RESPONSE.

Public Constructors

Name | Description
ZDO_IEEEADDRESS_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_IEEEADDRESS_RESPONSE | Overloaded.
Top

See Also

ZDO_IEEEADDRESS_RESPONSE Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSE Constructor

ZDO_IEEEADDRESS_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_IEEEADDRESS_RESPONSE | Constructor
Public method | ZDO_IEEEADDRESS_RESPONSE (ZDO_IEEEADDRESS_RESPONSE.AF_STATUS) |

See Also

ZDO_IEEEADDRESS_RESPONSE Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSE Constructor ()

ZDO_IEEEADDRESS_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_IEEEADDRESS_RESPONSE()
C++
public:
ZDO_IEEEADDRESS_RESPONSE() sealed
J#
public ZDO_IEEEADDRESS_RESPONSE()
JScript
public function ZDO_IEEEADDRESS_RESPONSE()

See Also

ZDO_IEEEADDRESS_RESPONSE Class
TI.ZPI1 Namespace
ZDO_IEEEADDRESS_RESPONSE Constructor Overload List


ZDO_IEEEADDRESS_RESPONSE Constructor (ZDO_IEEEADDRESS_RESPONSE.AF_STATUS)

ZDO_IEEEADDRESS_RESPONSE Constructor (ZDO_IEEEADDRESS_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_IEEEADDRESS_RESPONSE.AF_STATUS _
)
C#
public ZDO_IEEEADDRESS_RESPONSE(
ZDO_IEEEADDRESS_RESPONSE.AF_STATUS
)
C++
public:
ZDO_IEEEADDRESS_RESPONSE(
ZDO_IEEEADDRESS_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_IEEEADDRESS_RESPONSE(
ZDO_IEEEADDRESS_RESPONSE.AF_STATUS
)
JScript
public function ZDO_IEEEADDRESS_RESPONSE(
: ZDO_IEEEADDRESS_RESPONSE.AF_STATUS
)

See Also

ZDO_IEEEADDRESS_RESPONSE Class
TI.ZPI1 Namespace
ZDO_IEEEADDRESS_RESPONSE Constructor Overload List


Fields

ZDO_IEEEADDRESS_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_IEEEADDRESS_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_IEEEADDRESS_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_IEEEADDRESS_RESPONSE.AF_STATUS
C#
public ZDO_IEEEADDRESS_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_IEEEADDRESS_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_IEEEADDRESS_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_IEEEADDRESS_RESPONSE.AF_STATUS;

See Also

ZDO_IEEEADDRESS_RESPONSE Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSE.AF_STATUS Enumeration

ZDO_IEEEADDRESS_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEEADDRESS_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_IEEEADDRESS_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_IEEEADDRESS_RESPONSE.AF_STATUS : char
J#
public enum ZDO_IEEEADDRESS_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_IEEEADDRESS_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSECB Class

ZDO_IEEEADDRESS_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO IEEE Address Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_IEEEADDRESS_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_IEEEADDRESS_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_IEEEADDRESS_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_IEEEADDRESS_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_IEEEADDRESS_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_IEEEADDRESS_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSECB Members

ZDO_IEEEADDRESS_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO IEEE Address Request.

The following tables list the members exposed by ZDO_IEEEADDRESS_RESPONSECB.

Public Constructors

Name | Description
ZDO_IEEEADDRESS_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | the number of associated devices
Public field | SrcAddress | Source address, size is dependent on SrcAddrMode
Public field | SrcAddrMode | indicates that the SrcAddr is either 16 bits or 64 bits
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_IEEEADDRESS_RESPONSECB | Overloaded.
Top

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSECB Constructor

ZDO_IEEEADDRESS_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_IEEEADDRESS_RESPONSECB | Constructor
Public method | ZDO_IEEEADDRESS_RESPONSECB (ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE, UInt64, ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS, UInt64, Byte, Byte, UInt16) |

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSECB Constructor ()

ZDO_IEEEADDRESS_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_IEEEADDRESS_RESPONSECB()
C++
public:
ZDO_IEEEADDRESS_RESPONSECB() sealed
J#
public ZDO_IEEEADDRESS_RESPONSECB()
JScript
public function ZDO_IEEEADDRESS_RESPONSECB()

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_IEEEADDRESS_RESPONSECB Constructor Overload List


ZDO_IEEEADDRESS_RESPONSECB Constructor (ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE, UInt64, ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS, UInt64, Byte, Byte, UInt16[])

ZDO_IEEEADDRESS_RESPONSECB Constructor (ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE, UInt64, ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS, UInt64, Byte, Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_IEEEADDRESS_RESPONSECB(
ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE ,
ulong ,
ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS ,
ulong ,
byte ,
byte ,
ushort[]
)
C++
public:
ZDO_IEEEADDRESS_RESPONSECB(
ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE ,
unsigned __int64 ,
ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS ,
unsigned __int64 ,
char ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_IEEEADDRESS_RESPONSECB(
ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE ,
ulong ,
ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS ,
ulong ,
byte ,
byte ,
ushort[]
)
JScript
public function ZDO_IEEEADDRESS_RESPONSECB(
: ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE,
: UInt64,
: ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS,
: UInt64,
: Byte,
: Byte,
: UInt16[]
)

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_IEEEADDRESS_RESPONSECB Constructor Overload List


Fields

ZDO_IEEEADDRESS_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | the number of associated devices
Public field | SrcAddress | Source address, size is dependent on SrcAddrMode
Public field | SrcAddrMode | indicates that the SrcAddr is either 16 bits or 64 bits
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


AssocDevList Field

ZDO_IEEEADDRESS_RESPONSECB.AssocDevList Field
[image]

Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocDevList As UInt16()
C#
public ushort[] AssocDevList;
C++
public:
array<unsigned short>^ AssocDevList sealed ;
J#
public ushort[] AssocDevList
JScript
public AssocDevList : UInt16[];

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


IEEEAddr Field

ZDO_IEEEADDRESS_RESPONSECB.IEEEAddr Field
[image]

64 bit IEEE address of source device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


NumAssocDev Field

ZDO_IEEEADDRESS_RESPONSECB.NumAssocDev Field
[image]

the number of associated devices

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumAssocDev As Byte
C#
public byte NumAssocDev;
C++
public:
char NumAssocDev sealed ;
J#
public byte NumAssocDev
JScript
public NumAssocDev : Byte;

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_IEEEADDRESS_RESPONSECB.SrcAddress Field
[image]

Source address, size is dependent on SrcAddrMode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddrMode Field

ZDO_IEEEADDRESS_RESPONSECB.SrcAddrMode Field
[image]

indicates that the SrcAddr is either 16 bits or 64 bits

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddrMode As ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE
C#
public ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE SrcAddrMode;
C++
public:
ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE SrcAddrMode sealed ;
J#
public ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE SrcAddrMode
JScript
public SrcAddrMode : ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE;

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_IEEEADDRESS_RESPONSECB.StartIndex Field
[image]

Starting index into the list of associated devices for this report.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_IEEEADDRESS_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS
C#
public ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS;

See Also

ZDO_IEEEADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE Enumeration

ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE As Byte
C#
public enum ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE : byte
C++
public enum class ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE : char
J#
public enum ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE byte
JScript
public enum ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS Enumeration

ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_REQUEST Class

ZDO_MATCHDESCRIPTOR_REQUEST Class
See Also Example Members
[image]

This command is generated to request a list of active endpoint from the destination device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MATCHDESCRIPTOR_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MATCHDESCRIPTOR_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MATCHDESCRIPTOR_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MATCHDESCRIPTOR_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MATCHDESCRIPTOR_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MATCHDESCRIPTOR_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Members
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_REQUEST Members

ZDO_MATCHDESCRIPTOR_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a list of active endpoint from the destination device

The following tables list the members exposed by ZDO_MATCHDESCRIPTOR_REQUEST.

Public Constructors

Name | Description
ZDO_MATCHDESCRIPTOR_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the
Public field | NWKAddrOfInterest | NWK address for the request
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MATCHDESCRIPTOR_REQUEST | Overloaded.
Top

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_REQUEST Constructor

ZDO_MATCHDESCRIPTOR_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MATCHDESCRIPTOR_REQUEST | Constructor
Public method | ZDO_MATCHDESCRIPTOR_REQUEST (UInt16, UInt16, UInt16, Byte, UInt16, Byte, UInt16, ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE) |

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_REQUEST Constructor ()

ZDO_MATCHDESCRIPTOR_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MATCHDESCRIPTOR_REQUEST()
C++
public:
ZDO_MATCHDESCRIPTOR_REQUEST() sealed
J#
public ZDO_MATCHDESCRIPTOR_REQUEST()
JScript
public function ZDO_MATCHDESCRIPTOR_REQUEST()

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_MATCHDESCRIPTOR_REQUEST Constructor Overload List


ZDO_MATCHDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, UInt16, Byte, UInt16[], Byte, UInt16[], ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE)

ZDO_MATCHDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, UInt16, Byte, UInt16[], Byte, UInt16[], ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_MATCHDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[] ,
ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_MATCHDESCRIPTOR_REQUEST(
unsigned short ,
unsigned short ,
unsigned short ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^ ,
ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_MATCHDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[] ,
ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_MATCHDESCRIPTOR_REQUEST(
: UInt16,
: UInt16,
: UInt16,
: Byte,
: UInt16[],
: Byte,
: UInt16[],
: ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE
)

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_MATCHDESCRIPTOR_REQUEST Constructor Overload List


Fields

ZDO_MATCHDESCRIPTOR_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the
Public field | NWKAddrOfInterest | NWK address for the request
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Public field | SecuritySuite | Security options
Top

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MATCHDESCRIPTOR_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


InClusterList Field

ZDO_MATCHDESCRIPTOR_REQUEST.InClusterList Field
[image]

Array of input cluster IDs - NumInClusters long

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InClusterList As UInt16()
C#
public ushort[] InClusterList;
C++
public:
array<unsigned short>^ InClusterList sealed ;
J#
public ushort[] InClusterList
JScript
public InClusterList : UInt16[];

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NumInClusters Field

ZDO_MATCHDESCRIPTOR_REQUEST.NumInClusters Field
[image]

Number of ClusterIds in the InClusterList

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumInClusters As Byte
C#
public byte NumInClusters;
C++
public:
char NumInClusters sealed ;
J#
public byte NumInClusters
JScript
public NumInClusters : Byte;

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NumOutClusters Field

ZDO_MATCHDESCRIPTOR_REQUEST.NumOutClusters Field
[image]

Number of ClusterIds in the

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOutClusters As Byte
C#
public byte NumOutClusters;
C++
public:
char NumOutClusters sealed ;
J#
public byte NumOutClusters
JScript
public NumOutClusters : Byte;

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_MATCHDESCRIPTOR_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


OutClusterList Field

ZDO_MATCHDESCRIPTOR_REQUEST.OutClusterList Field
[image]

Array of output cluster IDs - NumOutClusters long

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutClusterList As UInt16()
C#
public ushort[] OutClusterList;
C++
public:
array<unsigned short>^ OutClusterList sealed ;
J#
public ushort[] OutClusterList
JScript
public OutClusterList : UInt16[];

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ProfileID Field

ZDO_MATCHDESCRIPTOR_REQUEST.ProfileID Field
[image]

Profile ID to match

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ProfileID As UInt16
C#
public ushort ProfileID;
C++
public:
unsigned short ProfileID sealed ;
J#
public ushort ProfileID
JScript
public ProfileID : UInt16;

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_MATCHDESCRIPTOR_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE
C#
public ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE;

See Also

ZDO_MATCHDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration

ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSE Class

ZDO_MATCHDESCRIPTOR_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MATCHDESCRIPTOR_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MATCHDESCRIPTOR_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MATCHDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MATCHDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MATCHDESCRIPTOR_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MATCHDESCRIPTOR_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MATCHDESCRIPTOR_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSE Members

ZDO_MATCHDESCRIPTOR_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MATCHDESCRIPTOR_REQUEST

The following tables list the members exposed by ZDO_MATCHDESCRIPTOR_RESPONSE.

Public Constructors

Name | Description
ZDO_MATCHDESCRIPTOR_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MATCHDESCRIPTOR_RESPONSE | Overloaded.
Top

See Also

ZDO_MATCHDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSE Constructor

ZDO_MATCHDESCRIPTOR_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MATCHDESCRIPTOR_RESPONSE | Constructor
Public method | ZDO_MATCHDESCRIPTOR_RESPONSE (ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS) |

See Also

ZDO_MATCHDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSE Constructor ()

ZDO_MATCHDESCRIPTOR_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MATCHDESCRIPTOR_RESPONSE()
C++
public:
ZDO_MATCHDESCRIPTOR_RESPONSE() sealed
J#
public ZDO_MATCHDESCRIPTOR_RESPONSE()
JScript
public function ZDO_MATCHDESCRIPTOR_RESPONSE()

See Also

ZDO_MATCHDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MATCHDESCRIPTOR_RESPONSE Constructor Overload List


ZDO_MATCHDESCRIPTOR_RESPONSE Constructor (ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS)

ZDO_MATCHDESCRIPTOR_RESPONSE Constructor (ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS _
)
C#
public ZDO_MATCHDESCRIPTOR_RESPONSE(
ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS
)
C++
public:
ZDO_MATCHDESCRIPTOR_RESPONSE(
ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_MATCHDESCRIPTOR_RESPONSE(
ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS
)
JScript
public function ZDO_MATCHDESCRIPTOR_RESPONSE(
: ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS
)

See Also

ZDO_MATCHDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MATCHDESCRIPTOR_RESPONSE Constructor Overload List


Fields

ZDO_MATCHDESCRIPTOR_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MATCHDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MATCHDESCRIPTOR_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS
C#
public ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS;

See Also

ZDO_MATCHDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS Enumeration

ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS : char
J#
public enum ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSECB Class

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Match Description Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MATCHDESCRIPTOR_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MATCHDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MATCHDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MATCHDESCRIPTOR_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MATCHDESCRIPTOR_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSECB Members

ZDO_MATCHDESCRIPTOR_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Match Description Request

The following tables list the members exposed by ZDO_MATCHDESCRIPTOR_RESPONSECB.

Public Constructors

Name | Description
ZDO_MATCHDESCRIPTOR_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MatchCount | Number of active endpoints in the list
Public field | MatchEndpointList | Array of active endpoints on this device
Public field | NWKAddrOfInterest | Device's short address that this response describes
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MATCHDESCRIPTOR_RESPONSECB | Overloaded.
Top

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor

ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MATCHDESCRIPTOR_RESPONSECB | Constructor
Public method | ZDO_MATCHDESCRIPTOR_RESPONSECB (ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte) |

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor ()

ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MATCHDESCRIPTOR_RESPONSECB()
C++
public:
ZDO_MATCHDESCRIPTOR_RESPONSECB() sealed
J#
public ZDO_MATCHDESCRIPTOR_RESPONSECB()
JScript
public function ZDO_MATCHDESCRIPTOR_RESPONSECB()

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor Overload List


ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor (ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte[])

ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor (ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_MATCHDESCRIPTOR_RESPONSECB(
ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_MATCHDESCRIPTOR_RESPONSECB(
ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS ,
unsigned short ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_MATCHDESCRIPTOR_RESPONSECB(
ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_MATCHDESCRIPTOR_RESPONSECB(
: ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS,
: UInt16,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MATCHDESCRIPTOR_RESPONSECB Constructor Overload List


Fields

ZDO_MATCHDESCRIPTOR_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | MatchCount | Number of active endpoints in the list
Public field | MatchEndpointList | Array of active endpoints on this device
Public field | NWKAddrOfInterest | Device's short address that this response describes
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


MatchCount Field

ZDO_MATCHDESCRIPTOR_RESPONSECB.MatchCount Field
[image]

Number of active endpoints in the list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MatchCount As Byte
C#
public byte MatchCount;
C++
public:
char MatchCount sealed ;
J#
public byte MatchCount
JScript
public MatchCount : Byte;

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


MatchEndpointList Field

ZDO_MATCHDESCRIPTOR_RESPONSECB.MatchEndpointList Field
[image]

Array of active endpoints on this device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MatchEndpointList As Byte()
C#
public byte[] MatchEndpointList;
C++
public:
array<char>^ MatchEndpointList sealed ;
J#
public byte[] MatchEndpointList
JScript
public MatchEndpointList : Byte[];

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_MATCHDESCRIPTOR_RESPONSECB.NWKAddrOfInterest Field
[image]

Device's short address that this response describes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MATCHDESCRIPTOR_RESPONSECB.SrcAddress Field
[image]

the message's source network address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MATCHDESCRIPTOR_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS
C#
public ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS;

See Also

ZDO_MATCHDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration

ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_BIND_REQUEST Class

ZDO_MGMT_BIND_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management Binding Table Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_BIND_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_BIND_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_BIND_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_BIND_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_BIND_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_BIND_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_BIND_REQUEST Members

ZDO_MGMT_BIND_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Binding Table Request.

The following tables list the members exposed by ZDO_MGMT_BIND_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_BIND_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_BIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_REQUEST Constructor

ZDO_MGMT_BIND_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_REQUEST | Constructor
Public method | ZDO_MGMT_BIND_REQUEST (UInt16, Byte) | Constructor

See Also

ZDO_MGMT_BIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_REQUEST Constructor ()

ZDO_MGMT_BIND_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_REQUEST()
C++
public:
ZDO_MGMT_BIND_REQUEST() sealed
J#
public ZDO_MGMT_BIND_REQUEST()
JScript
public function ZDO_MGMT_BIND_REQUEST()

See Also

ZDO_MGMT_BIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_BIND_REQUEST Constructor Overload List


ZDO_MGMT_BIND_REQUEST Constructor (UInt16, Byte)

ZDO_MGMT_BIND_REQUEST Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_MGMT_BIND_REQUEST(
ushort ,
byte
)
C++
public:
ZDO_MGMT_BIND_REQUEST(
unsigned short ,
char
) sealed
J#
public ZDO_MGMT_BIND_REQUEST(
ushort ,
byte
)
JScript
public function ZDO_MGMT_BIND_REQUEST(
: UInt16,
: Byte
)

See Also

ZDO_MGMT_BIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_BIND_REQUEST Constructor Overload List


Fields

ZDO_MGMT_BIND_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

See Also

ZDO_MGMT_BIND_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_BIND_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_BIND_REQUEST Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_BIND_REQUEST.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_BIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSE Class

ZDO_MGMT_BIND_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_BIND_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_BIND_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_BIND_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_BIND_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_BIND_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_BIND_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_BIND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSE Members

ZDO_MGMT_BIND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_BIND_REQUEST

The following tables list the members exposed by ZDO_MGMT_BIND_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_BIND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_BIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSE Constructor

ZDO_MGMT_BIND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_RESPONSE | Constructor
Public method | ZDO_MGMT_BIND_RESPONSE (ZDO_MGMT_BIND_RESPONSE.CMD_STATUS) |

See Also

ZDO_MGMT_BIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSE Constructor ()

ZDO_MGMT_BIND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_RESPONSE()
C++
public:
ZDO_MGMT_BIND_RESPONSE() sealed
J#
public ZDO_MGMT_BIND_RESPONSE()
JScript
public function ZDO_MGMT_BIND_RESPONSE()

See Also

ZDO_MGMT_BIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_BIND_RESPONSE Constructor Overload List


ZDO_MGMT_BIND_RESPONSE Constructor (ZDO_MGMT_BIND_RESPONSE.CMD_STATUS)

ZDO_MGMT_BIND_RESPONSE Constructor (ZDO_MGMT_BIND_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_BIND_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MGMT_BIND_RESPONSE(
ZDO_MGMT_BIND_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MGMT_BIND_RESPONSE(
ZDO_MGMT_BIND_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MGMT_BIND_RESPONSE(
ZDO_MGMT_BIND_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MGMT_BIND_RESPONSE(
: ZDO_MGMT_BIND_RESPONSE.CMD_STATUS
)

See Also

ZDO_MGMT_BIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_BIND_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_BIND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_BIND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_BIND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_BIND_RESPONSE.CMD_STATUS
C#
public ZDO_MGMT_BIND_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MGMT_BIND_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_BIND_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_BIND_RESPONSE.CMD_STATUS;

See Also

ZDO_MGMT_BIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSE.CMD_STATUS Enumeration

ZDO_MGMT_BIND_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_BIND_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_BIND_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_BIND_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MGMT_BIND_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MGMT_BIND_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB Class

ZDO_MGMT_BIND_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Binding Table Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_BIND_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_BIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_BIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_BIND_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_BIND_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_BIND_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB Members

ZDO_MGMT_BIND_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Binding Table Request

The following tables list the members exposed by ZDO_MGMT_BIND_RESPONSECB.

Public Constructors

Name | Description
ZDO_MGMT_BIND_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BindCount | Total number of entries available in the device.
Public field | BindList | Dynamic array, an array of BindList items. BindListCount contains the number of items in this table.
Public field | BindListCount | Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_RESPONSECB | Overloaded.
Top

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB Constructor

ZDO_MGMT_BIND_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_RESPONSECB | Constructor
Public method | ZDO_MGMT_BIND_RESPONSECB (UInt16, ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object) |

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB Constructor ()

ZDO_MGMT_BIND_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_RESPONSECB()
C++
public:
ZDO_MGMT_BIND_RESPONSECB() sealed
J#
public ZDO_MGMT_BIND_RESPONSECB()
JScript
public function ZDO_MGMT_BIND_RESPONSECB()

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_BIND_RESPONSECB Constructor Overload List


ZDO_MGMT_BIND_RESPONSECB Constructor (UInt16, ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object[])

ZDO_MGMT_BIND_RESPONSECB Constructor (UInt16, ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_MGMT_BIND_RESPONSECB(
ushort ,
ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
object[]
)
C++
public:
ZDO_MGMT_BIND_RESPONSECB(
unsigned short ,
ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS ,
char ,
char ,
char ,
array<Object>^
) sealed
J#
public ZDO_MGMT_BIND_RESPONSECB(
ushort ,
ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
object[]
)
JScript
public function ZDO_MGMT_BIND_RESPONSECB(
: UInt16,
: ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS,
: Byte,
: Byte,
: Byte,
: Object[]
)

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_BIND_RESPONSECB Constructor Overload List


Fields

ZDO_MGMT_BIND_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | BindCount | Total number of entries available in the device.
Public field | BindList | Dynamic array, an array of BindList items. BindListCount contains the number of items in this table.
Public field | BindListCount | Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


BindCount Field

ZDO_MGMT_BIND_RESPONSECB.BindCount Field
[image]

Total number of entries available in the device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindCount As Byte
C#
public byte BindCount;
C++
public:
char BindCount sealed ;
J#
public byte BindCount
JScript
public BindCount : Byte;

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


BindList Field

ZDO_MGMT_BIND_RESPONSECB.BindList Field
[image]

Dynamic array, an array of BindList items. BindListCount contains the number of items in this table.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindList As Object()
C#
public object[] BindList;
C++
public:
array<Object>^ BindList sealed ;
J#
public object[] BindList
JScript
public BindList : Object[];

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


BindListCount Field

ZDO_MGMT_BIND_RESPONSECB.BindListCount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindListCount As Byte
C#
public byte BindListCount;
C++
public:
char BindListCount sealed ;
J#
public byte BindListCount
JScript
public BindListCount : Byte;

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_BIND_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_BIND_RESPONSECB.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_BIND_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS
C#
public ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS;

See Also

ZDO_MGMT_BIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
See Also Example Members
[image]

Contains information in a single item of a bind list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_MGMT_BIND_RESPONSECB.BindListItemClass
C#
public struct ZDO_MGMT_BIND_RESPONSECB.BindListItemClass
C++
value class ZDO_MGMT_BIND_RESPONSECB.BindListItemClass
J#
public final class ZDO_MGMT_BIND_RESPONSECB.BindListItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_BIND_RESPONSECB.BindListItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Members
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Members

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Contains information in a single item of a bind list

The following tables list the members exposed by ZDO_MGMT_BIND_RESPONSECB.BindListItemClass.

Public Constructors

Name | Description
ZDO_MGMT_BIND_RESPONSECB.BindListItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID |
Public field | DestAddr |
Public field | DestAddrMode |
Public field | DestEndpoint |
Public field | SrcAddress |
Public field | SrcEndpoint |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_RESPONSECB.BindListItemClass | Overloaded.
Top

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_RESPONSECB.BindListItemClass | Initializes a new instance of the ZDO_MGMT_BIND_RESPONSECB.BindListItemClass class.
Public method | ZDO_MGMT_BIND_RESPONSECB.BindListItemClass (UInt64, Byte, UInt16, Byte, UInt64, Byte) |

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor ()

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the ZDO_MGMT_BIND_RESPONSECB.BindListItemClass class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_RESPONSECB.BindListItemClass()
C++
public:
ZDO_MGMT_BIND_RESPONSECB.BindListItemClass() sealed
J#
public ZDO_MGMT_BIND_RESPONSECB.BindListItemClass()
JScript
public function ZDO_MGMT_BIND_RESPONSECB.BindListItemClass()

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace
ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor Overload List


ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor (UInt64, Byte, UInt16, Byte, UInt64, Byte)

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor (UInt64, Byte, UInt16, Byte, UInt64, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt64, _
ByVal As Byte _
)
C#
public ZDO_MGMT_BIND_RESPONSECB.BindListItemClass(
ulong ,
byte ,
ushort ,
byte ,
ulong ,
byte
)
C++
public:
ZDO_MGMT_BIND_RESPONSECB.BindListItemClass(
unsigned __int64 ,
char ,
unsigned short ,
char ,
unsigned __int64 ,
char
) sealed
J#
public ZDO_MGMT_BIND_RESPONSECB.BindListItemClass(
ulong ,
byte ,
ushort ,
byte ,
ulong ,
byte
)
JScript
public function ZDO_MGMT_BIND_RESPONSECB.BindListItemClass(
: UInt64,
: Byte,
: UInt16,
: Byte,
: UInt64,
: Byte
)

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace
ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Constructor Overload List


Fields

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID |
Public field | DestAddr |
Public field | DestAddrMode |
Public field | DestEndpoint |
Public field | SrcAddress |
Public field | SrcEndpoint |
Top

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


ClusterID Field

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass.ClusterID Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


DestAddr Field

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass.DestAddr Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddr As UInt64
C#
public ulong DestAddr;
C++
public:
unsigned __int64 DestAddr sealed ;
J#
public ulong DestAddr
JScript
public DestAddr : UInt64;

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


DestAddrMode Field

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass.DestAddrMode Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddrMode As Byte
C#
public byte DestAddrMode;
C++
public:
char DestAddrMode sealed ;
J#
public byte DestAddrMode
JScript
public DestAddrMode : Byte;

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


DestEndpoint Field

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass.DestEndpoint Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass.SrcAddress Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


SrcEndpoint Field

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass.SrcEndpoint Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

ZDO_MGMT_BIND_RESPONSECB.BindListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS Enumeration

ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_REQUEST Class

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management Direct Join Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_DIRECT_JOIN_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_DIRECT_JOIN_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_DIRECT_JOIN_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_DIRECT_JOIN_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_DIRECT_JOIN_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_REQUEST Members

ZDO_MGMT_DIRECT_JOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Direct Join Request

The following tables list the members exposed by ZDO_MGMT_DIRECT_JOIN_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_DIRECT_JOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapInfo | The operating capabilities of the device being directly joined
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to be joined to the device at DstAddr
Public field | DstAddr | Destination network address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_DIRECT_JOIN_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor

ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_DIRECT_JOIN_REQUEST | Constructor
Public method | ZDO_MGMT_DIRECT_JOIN_REQUEST (UInt16, UInt64, ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO) |

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor ()

ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_DIRECT_JOIN_REQUEST()
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQUEST() sealed
J#
public ZDO_MGMT_DIRECT_JOIN_REQUEST()
JScript
public function ZDO_MGMT_DIRECT_JOIN_REQUEST()

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor Overload List


ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor (UInt16, UInt64, ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO)

ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor (UInt16, UInt64, ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO _
)
C#
public ZDO_MGMT_DIRECT_JOIN_REQUEST(
ushort ,
ulong ,
ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO
)
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQUEST(
unsigned short ,
unsigned __int64 ,
ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO
) sealed
J#
public ZDO_MGMT_DIRECT_JOIN_REQUEST(
ushort ,
ulong ,
ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO
)
JScript
public function ZDO_MGMT_DIRECT_JOIN_REQUEST(
: UInt16,
: UInt64,
: ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO
)

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_DIRECT_JOIN_REQUEST Constructor Overload List


Fields

ZDO_MGMT_DIRECT_JOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CapInfo | The operating capabilities of the device being directly joined
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to be joined to the device at DstAddr
Public field | DstAddr | Destination network address.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace


CapInfo Field

ZDO_MGMT_DIRECT_JOIN_REQUEST.CapInfo Field
[image]

The operating capabilities of the device being directly joined

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapInfo As ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO
C#
public ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO CapInfo;
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO CapInfo sealed ;
J#
public ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO CapInfo
JScript
public CapInfo : ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO;

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace


DeviceAddress Field

ZDO_MGMT_DIRECT_JOIN_REQUEST.DeviceAddress Field
[image]

The 64 bit IEEE Address of the device you want to be joined to the device at DstAddr

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_DIRECT_JOIN_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_DIRECT_JOIN_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO Enumeration

ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO byte
JScript
public enum ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSE Class

ZDO_MGMT_DIRECT_JOIN_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_DIRECT_JOIN_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_DIRECT_JOIN_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_DIRECT_JOIN_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_DIRECT_JOIN_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_DIRECT_JOIN_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_DIRECT_JOIN_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSE Members

ZDO_MGMT_DIRECT_JOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_DIRECT_JOIN_REQUEST

The following tables list the members exposed by ZDO_MGMT_DIRECT_JOIN_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_DIRECT_JOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_DIRECT_JOIN_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor

ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_DIRECT_JOIN_RESPONSE | Constructor
Public method | ZDO_MGMT_DIRECT_JOIN_RESPONSE (ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS) |

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor ()

ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_DIRECT_JOIN_RESPONSE()
C++
public:
ZDO_MGMT_DIRECT_JOIN_RESPONSE() sealed
J#
public ZDO_MGMT_DIRECT_JOIN_RESPONSE()
JScript
public function ZDO_MGMT_DIRECT_JOIN_RESPONSE()

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor Overload List


ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor (ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS)

ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor (ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MGMT_DIRECT_JOIN_RESPONSE(
ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MGMT_DIRECT_JOIN_RESPONSE(
ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MGMT_DIRECT_JOIN_RESPONSE(
ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MGMT_DIRECT_JOIN_RESPONSE(
: ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS
)

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_DIRECT_JOIN_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_DIRECT_JOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_DIRECT_JOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS
C#
public ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS;

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS Enumeration

ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Direct Join Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_DIRECT_JOIN_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_DIRECT_JOIN_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_DIRECT_JOIN_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_DIRECT_JOIN_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_DIRECT_JOIN_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSECB Members

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Direct Join Request.

The following tables list the members exposed by ZDO_MGMT_DIRECT_JOIN_RESPONSECB.

Public Constructors

Name | Description
ZDO_MGMT_DIRECT_JOIN_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_DIRECT_JOIN_RESPONSECB | Overloaded.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_DIRECT_JOIN_RESPONSECB | Constructor
Public method | ZDO_MGMT_DIRECT_JOIN_RESPONSECB (UInt16, ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS) |

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor ()

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_DIRECT_JOIN_RESPONSECB()
C++
public:
ZDO_MGMT_DIRECT_JOIN_RESPONSECB() sealed
J#
public ZDO_MGMT_DIRECT_JOIN_RESPONSECB()
JScript
public function ZDO_MGMT_DIRECT_JOIN_RESPONSECB()

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor Overload List


ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor (UInt16, ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS)

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor (UInt16, ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS _
)
C#
public ZDO_MGMT_DIRECT_JOIN_RESPONSECB(
ushort ,
ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS
)
C++
public:
ZDO_MGMT_DIRECT_JOIN_RESPONSECB(
unsigned short ,
ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS
) sealed
J#
public ZDO_MGMT_DIRECT_JOIN_RESPONSECB(
ushort ,
ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS
)
JScript
public function ZDO_MGMT_DIRECT_JOIN_RESPONSECB(
: UInt16,
: ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS
)

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_DIRECT_JOIN_RESPONSECB Constructor Overload List


Fields

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_DIRECT_JOIN_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_DIRECT_JOIN_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS (0) or FAILURE (1).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS
C#
public ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS;

See Also

ZDO_MGMT_DIRECT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS Enumeration

ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_REQUEST Class

ZDO_MGMT_LEAVE_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management Leave Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LEAVE_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_LEAVE_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_LEAVE_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_LEAVE_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_LEAVE_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_LEAVE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LEAVE_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_REQUEST Members

ZDO_MGMT_LEAVE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Leave Request

The following tables list the members exposed by ZDO_MGMT_LEAVE_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_LEAVE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to leave.
Public field | DstAddr | Destination network address.
Public field | Rejoin | This field has a value of 1 if the device being asked to leave from the current parent is requested to rejoin the network. Otherwise, it has a value of 0.
Public field | RemoveChildren | This field has a value of 1 if the device being asked to leave the network is also being asked to remove its child devices, if any. Otherwise it has a value of 0. Currently, the stack profile of Home Control specifies that this field should always be set to 0
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LEAVE_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_REQUEST Constructor

ZDO_MGMT_LEAVE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LEAVE_REQUEST | Constructor
Public method | ZDO_MGMT_LEAVE_REQUEST (UInt16, UInt64, ZDO_MGMT_LEAVE_REQUEST.BOOLEAN, ZDO_MGMT_LEAVE_REQUEST.BOOLEAN) |

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_REQUEST Constructor ()

ZDO_MGMT_LEAVE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LEAVE_REQUEST()
C++
public:
ZDO_MGMT_LEAVE_REQUEST() sealed
J#
public ZDO_MGMT_LEAVE_REQUEST()
JScript
public function ZDO_MGMT_LEAVE_REQUEST()

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_LEAVE_REQUEST Constructor Overload List


ZDO_MGMT_LEAVE_REQUEST Constructor (UInt16, UInt64, ZDO_MGMT_LEAVE_REQUEST.BOOLEAN, ZDO_MGMT_LEAVE_REQUEST.BOOLEAN)

ZDO_MGMT_LEAVE_REQUEST Constructor (UInt16, UInt64, ZDO_MGMT_LEAVE_REQUEST.BOOLEAN, ZDO_MGMT_LEAVE_REQUEST.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As ZDO_MGMT_LEAVE_REQUEST.BOOLEAN, _
ByVal As ZDO_MGMT_LEAVE_REQUEST.BOOLEAN _
)
C#
public ZDO_MGMT_LEAVE_REQUEST(
ushort ,
ulong ,
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN ,
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN
)
C++
public:
ZDO_MGMT_LEAVE_REQUEST(
unsigned short ,
unsigned __int64 ,
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN ,
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN
) sealed
J#
public ZDO_MGMT_LEAVE_REQUEST(
ushort ,
ulong ,
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN ,
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN
)
JScript
public function ZDO_MGMT_LEAVE_REQUEST(
: UInt16,
: UInt64,
: ZDO_MGMT_LEAVE_REQUEST.BOOLEAN,
: ZDO_MGMT_LEAVE_REQUEST.BOOLEAN
)

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_LEAVE_REQUEST Constructor Overload List


Fields

ZDO_MGMT_LEAVE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to leave.
Public field | DstAddr | Destination network address.
Public field | Rejoin | This field has a value of 1 if the device being asked to leave from the current parent is requested to rejoin the network. Otherwise, it has a value of 0.
Public field | RemoveChildren | This field has a value of 1 if the device being asked to leave the network is also being asked to remove its child devices, if any. Otherwise it has a value of 0. Currently, the stack profile of Home Control specifies that this field should always be set to 0
Top

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace


DeviceAddress Field

ZDO_MGMT_LEAVE_REQUEST.DeviceAddress Field
[image]

The 64 bit IEEE Address of the device you want to leave.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_LEAVE_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace


Rejoin Field

ZDO_MGMT_LEAVE_REQUEST.Rejoin Field
[image]

This field has a value of 1 if the device being asked to leave from the current parent is requested to rejoin the network. Otherwise, it has a value of 0.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Rejoin As ZDO_MGMT_LEAVE_REQUEST.BOOLEAN
C#
public ZDO_MGMT_LEAVE_REQUEST.BOOLEAN Rejoin;
C++
public:
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN Rejoin sealed ;
J#
public ZDO_MGMT_LEAVE_REQUEST.BOOLEAN Rejoin
JScript
public Rejoin : ZDO_MGMT_LEAVE_REQUEST.BOOLEAN;

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace


RemoveChildren Field

ZDO_MGMT_LEAVE_REQUEST.RemoveChildren Field
[image]

This field has a value of 1 if the device being asked to leave the network is also being asked to remove its child devices, if any. Otherwise it has a value of 0. Currently, the stack profile of Home Control specifies that this field should always be set to 0

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RemoveChildren As ZDO_MGMT_LEAVE_REQUEST.BOOLEAN
C#
public ZDO_MGMT_LEAVE_REQUEST.BOOLEAN RemoveChildren;
C++
public:
ZDO_MGMT_LEAVE_REQUEST.BOOLEAN RemoveChildren sealed ;
J#
public ZDO_MGMT_LEAVE_REQUEST.BOOLEAN RemoveChildren
JScript
public RemoveChildren : ZDO_MGMT_LEAVE_REQUEST.BOOLEAN;

See Also

ZDO_MGMT_LEAVE_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_REQUEST.BOOLEAN Enumeration

ZDO_MGMT_LEAVE_REQUEST.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LEAVE_REQUEST.BOOLEAN As Byte
C#
public enum ZDO_MGMT_LEAVE_REQUEST.BOOLEAN : byte
C++
public enum class ZDO_MGMT_LEAVE_REQUEST.BOOLEAN : char
J#
public enum ZDO_MGMT_LEAVE_REQUEST.BOOLEAN byte
JScript
public enum ZDO_MGMT_LEAVE_REQUEST.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSE Class

ZDO_MGMT_LEAVE_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_LEAVE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LEAVE_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_LEAVE_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_LEAVE_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_LEAVE_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_LEAVE_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LEAVE_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSE Members

ZDO_MGMT_LEAVE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_LEAVE_REQUEST

The following tables list the members exposed by ZDO_MGMT_LEAVE_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_LEAVE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LEAVE_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSE Constructor

ZDO_MGMT_LEAVE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LEAVE_RESPONSE | Constructor
Public method | ZDO_MGMT_LEAVE_RESPONSE (ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS) |

See Also

ZDO_MGMT_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSE Constructor ()

ZDO_MGMT_LEAVE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LEAVE_RESPONSE()
C++
public:
ZDO_MGMT_LEAVE_RESPONSE() sealed
J#
public ZDO_MGMT_LEAVE_RESPONSE()
JScript
public function ZDO_MGMT_LEAVE_RESPONSE()

See Also

ZDO_MGMT_LEAVE_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_LEAVE_RESPONSE Constructor Overload List


ZDO_MGMT_LEAVE_RESPONSE Constructor (ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS)

ZDO_MGMT_LEAVE_RESPONSE Constructor (ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MGMT_LEAVE_RESPONSE(
ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MGMT_LEAVE_RESPONSE(
ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MGMT_LEAVE_RESPONSE(
ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MGMT_LEAVE_RESPONSE(
: ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS
)

See Also

ZDO_MGMT_LEAVE_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_LEAVE_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_LEAVE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_LEAVE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS
C#
public ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS;

See Also

ZDO_MGMT_LEAVE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS Enumeration

ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSECB Class

ZDO_MGMT_LEAVE_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Leave Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LEAVE_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_LEAVE_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_LEAVE_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_LEAVE_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_LEAVE_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LEAVE_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSECB Members

ZDO_MGMT_LEAVE_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Leave Request.

The following tables list the members exposed by ZDO_MGMT_LEAVE_RESPONSECB.

Public Constructors

Name | Description
ZDO_MGMT_LEAVE_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LEAVE_RESPONSECB | Overloaded.
Top

See Also

ZDO_MGMT_LEAVE_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSECB Constructor

ZDO_MGMT_LEAVE_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LEAVE_RESPONSECB | Constructor
Public method | ZDO_MGMT_LEAVE_RESPONSECB (ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS, UInt16) |

See Also

ZDO_MGMT_LEAVE_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSECB Constructor ()

ZDO_MGMT_LEAVE_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LEAVE_RESPONSECB()
C++
public:
ZDO_MGMT_LEAVE_RESPONSECB() sealed
J#
public ZDO_MGMT_LEAVE_RESPONSECB()
JScript
public function ZDO_MGMT_LEAVE_RESPONSECB()

See Also

ZDO_MGMT_LEAVE_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_LEAVE_RESPONSECB Constructor Overload List


ZDO_MGMT_LEAVE_RESPONSECB Constructor (ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS, UInt16)

ZDO_MGMT_LEAVE_RESPONSECB Constructor (ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS, _
ByVal As UInt16 _
)
C#
public ZDO_MGMT_LEAVE_RESPONSECB(
ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS ,
ushort
)
C++
public:
ZDO_MGMT_LEAVE_RESPONSECB(
ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS ,
unsigned short
) sealed
J#
public ZDO_MGMT_LEAVE_RESPONSECB(
ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS ,
ushort
)
JScript
public function ZDO_MGMT_LEAVE_RESPONSECB(
: ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS,
: UInt16
)

See Also

ZDO_MGMT_LEAVE_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_LEAVE_RESPONSECB Constructor Overload List


Fields

ZDO_MGMT_LEAVE_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

See Also

ZDO_MGMT_LEAVE_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_LEAVE_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MGMT_LEAVE_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_LEAVE_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS (0) or FAILURE (1).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS
C#
public ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS;

See Also

ZDO_MGMT_LEAVE_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS Enumeration

ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_LQI_REQUEST Class

ZDO_MGMT_LQI_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management LQI Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LQI_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_LQI_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_LQI_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_LQI_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_LQI_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_LQI_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_LQI_REQUEST Members

ZDO_MGMT_LQI_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management LQI Request.

The following tables list the members exposed by ZDO_MGMT_LQI_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_LQI_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_LQI_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_REQUEST Constructor

ZDO_MGMT_LQI_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_REQUEST | Constructor
Public method | ZDO_MGMT_LQI_REQUEST (UInt16, Byte) | Constructor

See Also

ZDO_MGMT_LQI_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_REQUEST Constructor ()

ZDO_MGMT_LQI_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_REQUEST()
C++
public:
ZDO_MGMT_LQI_REQUEST() sealed
J#
public ZDO_MGMT_LQI_REQUEST()
JScript
public function ZDO_MGMT_LQI_REQUEST()

See Also

ZDO_MGMT_LQI_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_LQI_REQUEST Constructor Overload List


ZDO_MGMT_LQI_REQUEST Constructor (UInt16, Byte)

ZDO_MGMT_LQI_REQUEST Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_MGMT_LQI_REQUEST(
ushort ,
byte
)
C++
public:
ZDO_MGMT_LQI_REQUEST(
unsigned short ,
char
) sealed
J#
public ZDO_MGMT_LQI_REQUEST(
ushort ,
byte
)
JScript
public function ZDO_MGMT_LQI_REQUEST(
: UInt16,
: Byte
)

See Also

ZDO_MGMT_LQI_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_LQI_REQUEST Constructor Overload List


Fields

ZDO_MGMT_LQI_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

See Also

ZDO_MGMT_LQI_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_LQI_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_LQI_REQUEST Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_LQI_REQUEST.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_LQI_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSE Class

ZDO_MGMT_LQI_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_LQI_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LQI_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_LQI_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_LQI_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_LQI_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_LQI_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_LQI_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSE Members

ZDO_MGMT_LQI_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_LQI_REQUEST

The following tables list the members exposed by ZDO_MGMT_LQI_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_LQI_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_LQI_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSE Constructor

ZDO_MGMT_LQI_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_RESPONSE | Constructor
Public method | ZDO_MGMT_LQI_RESPONSE (ZDO_MGMT_LQI_RESPONSE.AF_STATUS) |

See Also

ZDO_MGMT_LQI_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSE Constructor ()

ZDO_MGMT_LQI_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_RESPONSE()
C++
public:
ZDO_MGMT_LQI_RESPONSE() sealed
J#
public ZDO_MGMT_LQI_RESPONSE()
JScript
public function ZDO_MGMT_LQI_RESPONSE()

See Also

ZDO_MGMT_LQI_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_LQI_RESPONSE Constructor Overload List


ZDO_MGMT_LQI_RESPONSE Constructor (ZDO_MGMT_LQI_RESPONSE.AF_STATUS)

ZDO_MGMT_LQI_RESPONSE Constructor (ZDO_MGMT_LQI_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_LQI_RESPONSE.AF_STATUS _
)
C#
public ZDO_MGMT_LQI_RESPONSE(
ZDO_MGMT_LQI_RESPONSE.AF_STATUS
)
C++
public:
ZDO_MGMT_LQI_RESPONSE(
ZDO_MGMT_LQI_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_MGMT_LQI_RESPONSE(
ZDO_MGMT_LQI_RESPONSE.AF_STATUS
)
JScript
public function ZDO_MGMT_LQI_RESPONSE(
: ZDO_MGMT_LQI_RESPONSE.AF_STATUS
)

See Also

ZDO_MGMT_LQI_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_LQI_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_LQI_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_LQI_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_LQI_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LQI_RESPONSE.AF_STATUS
C#
public ZDO_MGMT_LQI_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_MGMT_LQI_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_MGMT_LQI_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_MGMT_LQI_RESPONSE.AF_STATUS;

See Also

ZDO_MGMT_LQI_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSE.AF_STATUS Enumeration

ZDO_MGMT_LQI_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LQI_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_MGMT_LQI_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_MGMT_LQI_RESPONSE.AF_STATUS : char
J#
public enum ZDO_MGMT_LQI_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_MGMT_LQI_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB Class

ZDO_MGMT_LQI_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management LQI Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LQI_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_LQI_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_LQI_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_LQI_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_LQI_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_LQI_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB Members

ZDO_MGMT_LQI_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management LQI Request.

The following tables list the members exposed by ZDO_MGMT_LQI_RESPONSECB.

Public Constructors

Name | Description
ZDO_MGMT_LQI_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NeighborLQICount | Number of entries in this response.
Public field | NeighborLQIEntries | Total number of entries available in the device.
Public field | NeighborLqiList | Dynamic array, Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_RESPONSECB | Overloaded.
Top

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB Constructor

ZDO_MGMT_LQI_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_RESPONSECB | Constructor
Public method | ZDO_MGMT_LQI_RESPONSECB (UInt16, ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object) |

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB Constructor ()

ZDO_MGMT_LQI_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_RESPONSECB()
C++
public:
ZDO_MGMT_LQI_RESPONSECB() sealed
J#
public ZDO_MGMT_LQI_RESPONSECB()
JScript
public function ZDO_MGMT_LQI_RESPONSECB()

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_LQI_RESPONSECB Constructor Overload List


ZDO_MGMT_LQI_RESPONSECB Constructor (UInt16, ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object[])

ZDO_MGMT_LQI_RESPONSECB Constructor (UInt16, ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_MGMT_LQI_RESPONSECB(
ushort ,
ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
object[]
)
C++
public:
ZDO_MGMT_LQI_RESPONSECB(
unsigned short ,
ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS ,
char ,
char ,
char ,
array<Object>^
) sealed
J#
public ZDO_MGMT_LQI_RESPONSECB(
ushort ,
ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
object[]
)
JScript
public function ZDO_MGMT_LQI_RESPONSECB(
: UInt16,
: ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS,
: Byte,
: Byte,
: Byte,
: Object[]
)

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_LQI_RESPONSECB Constructor Overload List


Fields

ZDO_MGMT_LQI_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | NeighborLQICount | Number of entries in this response.
Public field | NeighborLQIEntries | Total number of entries available in the device.
Public field | NeighborLqiList | Dynamic array, Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


NeighborLQICount Field

ZDO_MGMT_LQI_RESPONSECB.NeighborLQICount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NeighborLQICount As Byte
C#
public byte NeighborLQICount;
C++
public:
char NeighborLQICount sealed ;
J#
public byte NeighborLQICount
JScript
public NeighborLQICount : Byte;

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


NeighborLQIEntries Field

ZDO_MGMT_LQI_RESPONSECB.NeighborLQIEntries Field
[image]

Total number of entries available in the device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NeighborLQIEntries As Byte
C#
public byte NeighborLQIEntries;
C++
public:
char NeighborLQIEntries sealed ;
J#
public byte NeighborLQIEntries
JScript
public NeighborLQIEntries : Byte;

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


NeighborLqiList Field

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiList Field
[image]

Dynamic array, Number of entries in this response.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NeighborLqiList As Object()
C#
public object[] NeighborLqiList;
C++
public:
array<Object>^ NeighborLqiList sealed ;
J#
public object[] NeighborLqiList
JScript
public NeighborLqiList : Object[];

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_LQI_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_LQI_RESPONSECB.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_LQI_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS
C#
public ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS;

See Also

ZDO_MGMT_LQI_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS Enumeration

ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
See Also Example Members
[image]

Contains information in a single item of a network list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass
C#
public struct ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass
C++
value class ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass
J#
public final class ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Members
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Members

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Contains information in a single item of a network list

The following tables list the members exposed by ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass.

Public Constructors

Name | Description
ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NetworkAddress |
Public field | PanID |
Public field | RxLQI |
Public field | TxQuality |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass | Overloaded.
Top

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass | Initializes a new instance of the ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass class.
Public method | ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass (UInt64, UInt16, Byte, Byte) |

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor ()

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass()
C++
public:
ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass() sealed
J#
public ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass()
JScript
public function ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass()

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace
ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor Overload List


ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor (UInt64, UInt16, Byte, Byte)

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor (UInt64, UInt16, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass(
ulong ,
ushort ,
byte ,
byte
)
C++
public:
ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass(
unsigned __int64 ,
unsigned short ,
char ,
char
) sealed
J#
public ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass(
ulong ,
ushort ,
byte ,
byte
)
JScript
public function ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass(
: UInt64,
: UInt16,
: Byte,
: Byte
)

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace
ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Constructor Overload List


Fields

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | NetworkAddress |
Public field | PanID |
Public field | RxLQI |
Public field | TxQuality |
Top

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace


NetworkAddress Field

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass.NetworkAddress Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkAddress As UInt16
C#
public ushort NetworkAddress;
C++
public:
unsigned short NetworkAddress sealed ;
J#
public ushort NetworkAddress
JScript
public NetworkAddress : UInt16;

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace


PanID Field

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass.PanID Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt64
C#
public ulong PanID;
C++
public:
unsigned __int64 PanID sealed ;
J#
public ulong PanID
JScript
public PanID : UInt64;

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace


RxLQI Field

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass.RxLQI Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RxLQI As Byte
C#
public byte RxLQI;
C++
public:
char RxLQI sealed ;
J#
public byte RxLQI
JScript
public RxLQI : Byte;

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace


TxQuality Field

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass.TxQuality Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxQuality As Byte
C#
public byte TxQuality;
C++
public:
char TxQuality sealed ;
J#
public byte TxQuality
JScript
public TxQuality : Byte;

See Also

ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
See Also Example Members
[image]

This callback message is in response to the Mgmt NWK Update Request. Upon receiving the request, remote device shall determine from the contents of the ScanDuration parameter whether this request is an update to the apsChannelMask and nwkManagerAddr parameters, a channel change command, or a request to scan channels and report the results

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_UPDATE_NOTIFYCB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_NWK_UPDATE_NOTIFYCB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_NWK_UPDATE_NOTIFYCB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_NWK_UPDATE_NOTIFYCB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_NWK_UPDATE_NOTIFYCB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_NOTIFYCB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Members
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_NOTIFYCB Members

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the Mgmt NWK Update Request. Upon receiving the request, remote device shall determine from the contents of the ScanDuration parameter whether this request is an update to the apsChannelMask and nwkManagerAddr parameters, a channel change command, or a request to scan channels and report the results

The following tables list the members exposed by ZDO_MGMT_NWK_UPDATE_NOTIFYCB.

Public Constructors

Name | Description
ZDO_MGMT_NWK_UPDATE_NOTIFYCB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | EnergyValues | variable length array of 8-bits specifying Energy Detect values, one for each of ListCount
Public field | ScannedChannelListCount | number of records contained in the EnergyValues list
Public field | ScannedChannels | bitmap indicating the list of channels scanned by the request
Public field | SrcAddr | Source address of the message
Public field | Status | status of the command: SUCCESS(0x00), INVALID_REQUEST(0xc2) or NOT_SUPPORTTED(0x84).
Public field | TotalTransmissions | count of the total transmissions reported by the device
Public field | TransmissionFailtures | sum of the total transmission failures reported by the device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_UPDATE_NOTIFYCB | Overloaded.
Top

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_UPDATE_NOTIFYCB | Constructor
Public method | ZDO_MGMT_NWK_UPDATE_NOTIFYCB (UInt16, ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS, ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS, UInt16, UInt16, Byte, Byte) |

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor ()

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB()
C++
public:
ZDO_MGMT_NWK_UPDATE_NOTIFYCB() sealed
J#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB()
JScript
public function ZDO_MGMT_NWK_UPDATE_NOTIFYCB()

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace
ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor Overload List


ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor (UInt16, ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS, ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS, UInt16, UInt16, Byte, Byte[])

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor (UInt16, ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS, ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS, UInt16, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS, _
ByVal As ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB(
ushort ,
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS ,
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS ,
ushort ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_MGMT_NWK_UPDATE_NOTIFYCB(
unsigned short ,
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS ,
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS ,
unsigned short ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB(
ushort ,
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS ,
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS ,
ushort ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_MGMT_NWK_UPDATE_NOTIFYCB(
: UInt16,
: ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS,
: ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS,
: UInt16,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace
ZDO_MGMT_NWK_UPDATE_NOTIFYCB Constructor Overload List


Fields

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Fields
[image]

Public Fields

 | Name | Description
Public field | EnergyValues | variable length array of 8-bits specifying Energy Detect values, one for each of ListCount
Public field | ScannedChannelListCount | number of records contained in the EnergyValues list
Public field | ScannedChannels | bitmap indicating the list of channels scanned by the request
Public field | SrcAddr | Source address of the message
Public field | Status | status of the command: SUCCESS(0x00), INVALID_REQUEST(0xc2) or NOT_SUPPORTTED(0x84).
Public field | TotalTransmissions | count of the total transmissions reported by the device
Public field | TransmissionFailtures | sum of the total transmission failures reported by the device
Top

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


EnergyValues Field

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.EnergyValues Field
[image]

variable length array of 8-bits specifying Energy Detect values, one for each of ListCount

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public EnergyValues As Byte()
C#
public byte[] EnergyValues;
C++
public:
array<char>^ EnergyValues sealed ;
J#
public byte[] EnergyValues
JScript
public EnergyValues : Byte[];

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


ScannedChannelListCount Field

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ScannedChannelListCount Field
[image]

number of records contained in the EnergyValues list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScannedChannelListCount As Byte
C#
public byte ScannedChannelListCount;
C++
public:
char ScannedChannelListCount sealed ;
J#
public byte ScannedChannelListCount
JScript
public ScannedChannelListCount : Byte;

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


ScannedChannels Field

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ScannedChannels Field
[image]

bitmap indicating the list of channels scanned by the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScannedChannels As ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS
C#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS ScannedChannels;
C++
public:
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS ScannedChannels sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS ScannedChannels
JScript
public ScannedChannels : ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS;

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


SrcAddr Field

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.SrcAddr Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.Status Field
[image]

status of the command: SUCCESS(0x00), INVALID_REQUEST(0xc2) or NOT_SUPPORTTED(0x84).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS
C#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS;

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


TotalTransmissions Field

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.TotalTransmissions Field
[image]

count of the total transmissions reported by the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TotalTransmissions As UInt16
C#
public ushort TotalTransmissions;
C++
public:
unsigned short TotalTransmissions sealed ;
J#
public ushort TotalTransmissions
JScript
public TotalTransmissions : UInt16;

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


TransmissionFailtures Field

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.TransmissionFailtures Field
[image]

sum of the total transmission failures reported by the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransmissionFailtures As UInt16
C#
public ushort TransmissionFailtures;
C++
public:
unsigned short TransmissionFailtures sealed ;
J#
public ushort TransmissionFailtures
JScript
public TransmissionFailtures : UInt16;

See Also

ZDO_MGMT_NWK_UPDATE_NOTIFYCB Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS Enumeration

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS : char
J#
public enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS Enumeration

ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS uint
JScript
public enum ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Class

ZDO_MGMT_NWK_UPDATE_REQUEST Class
See Also Example Members
[image]

This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_UPDATE_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_NWK_UPDATE_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_NWK_UPDATE_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_NWK_UPDATE_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_NWK_UPDATE_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Members

ZDO_MGMT_NWK_UPDATE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.

The following tables list the members exposed by ZDO_MGMT_NWK_UPDATE_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_NWK_UPDATE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelMask | a bitmap indicating which channels are to be scanned.
Public field | DstAddr | short address of the destination device(s). The destination addressing on this primitive can be unicast or broadcast to all devices for which macRxOnWhenIdle=TRUE (i.e., 0xFFFD).
Public field | DstAddrMode | destination addressing mode: 2 for unicast address; 15 for broadcast address
Public field | NwkManagerAddr | indicates the NWK address for the device with the Network Manager bit set in its Node Descriptor
Public field | ScanCount | This field represents the number of energy scans to be conducted and reported
Public field | ScanDuration | a value used to calculate the length of time to spend scanning each channel.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_UPDATE_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Constructor

ZDO_MGMT_NWK_UPDATE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_UPDATE_REQUEST | Constructor
Public method | ZDO_MGMT_NWK_UPDATE_REQUEST (UInt16, ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, UInt16) |

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Constructor ()

ZDO_MGMT_NWK_UPDATE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST()
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST() sealed
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST()
JScript
public function ZDO_MGMT_NWK_UPDATE_REQUEST()

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_NWK_UPDATE_REQUEST Constructor Overload List


ZDO_MGMT_NWK_UPDATE_REQUEST Constructor (UInt16, ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, UInt16)

ZDO_MGMT_NWK_UPDATE_REQUEST Constructor (UInt16, ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, _
ByVal As ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16 _
)
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST(
ushort ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
ushort
)
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST(
unsigned short ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ,
char ,
char ,
unsigned short
) sealed
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST(
ushort ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
ushort
)
JScript
public function ZDO_MGMT_NWK_UPDATE_REQUEST(
: UInt16,
: ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE,
: ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS,
: Byte,
: Byte,
: UInt16
)

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_NWK_UPDATE_REQUEST Constructor Overload List


Fields

ZDO_MGMT_NWK_UPDATE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelMask | a bitmap indicating which channels are to be scanned.
Public field | DstAddr | short address of the destination device(s). The destination addressing on this primitive can be unicast or broadcast to all devices for which macRxOnWhenIdle=TRUE (i.e., 0xFFFD).
Public field | DstAddrMode | destination addressing mode: 2 for unicast address; 15 for broadcast address
Public field | NwkManagerAddr | indicates the NWK address for the device with the Network Manager bit set in its Node Descriptor
Public field | ScanCount | This field represents the number of energy scans to be conducted and reported
Public field | ScanDuration | a value used to calculate the length of time to spend scanning each channel.
Top

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


ChannelMask Field

ZDO_MGMT_NWK_UPDATE_REQUEST.ChannelMask Field
[image]

a bitmap indicating which channels are to be scanned.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelMask As ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ChannelMask;
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ChannelMask sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ChannelMask
JScript
public ChannelMask : ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_NWK_UPDATE_REQUEST.DstAddr Field
[image]

short address of the destination device(s). The destination addressing on this primitive can be unicast or broadcast to all devices for which macRxOnWhenIdle=TRUE (i.e., 0xFFFD).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


DstAddrMode Field

ZDO_MGMT_NWK_UPDATE_REQUEST.DstAddrMode Field
[image]

destination addressing mode: 2 for unicast address; 15 for broadcast address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE DstAddrMode;
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE DstAddrMode sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


ScanCount Field

ZDO_MGMT_NWK_UPDATE_REQUEST.ScanCount Field
[image]

This field represents the number of energy scans to be conducted and reported

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanCount As Byte
C#
public byte ScanCount;
C++
public:
char ScanCount sealed ;
J#
public byte ScanCount
JScript
public ScanCount : Byte;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


ScanDuration Field

ZDO_MGMT_NWK_UPDATE_REQUEST.ScanDuration Field
[image]

a value used to calculate the length of time to spend scanning each channel.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE Enumeration

ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE : char
J#
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE byte
JScript
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS Enumeration

ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Class

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_NWK_UPDATE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_UPDATE_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_NWK_UPDATE_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_NWK_UPDATE_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_NWK_UPDATE_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_NWK_UPDATE_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Members

ZDO_MGMT_NWK_UPDATE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_NWK_UPDATE_REQUEST

The following tables list the members exposed by ZDO_MGMT_NWK_UPDATE_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_NWK_UPDATE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_UPDATE_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor

ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_UPDATE_RESPONSE | Constructor
Public method | ZDO_MGMT_NWK_UPDATE_RESPONSE (ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS) |

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor ()

ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_UPDATE_RESPONSE()
C++
public:
ZDO_MGMT_NWK_UPDATE_RESPONSE() sealed
J#
public ZDO_MGMT_NWK_UPDATE_RESPONSE()
JScript
public function ZDO_MGMT_NWK_UPDATE_RESPONSE()

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor Overload List


ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor (ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS)

ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor (ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MGMT_NWK_UPDATE_RESPONSE(
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MGMT_NWK_UPDATE_RESPONSE(
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MGMT_NWK_UPDATE_RESPONSE(
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MGMT_NWK_UPDATE_RESPONSE(
: ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
)

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_NWK_UPDATE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_NWK_UPDATE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
C#
public ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS;

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Enumeration

ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_REQUEST Class

ZDO_MGMT_NWKDISC_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management Network Discovery Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWKDISC_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_NWKDISC_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_NWKDISC_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_NWKDISC_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_NWKDISC_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_NWKDISC_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWKDISC_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_REQUEST Members

ZDO_MGMT_NWKDISC_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Network Discovery Request

The following tables list the members exposed by ZDO_MGMT_NWKDISC_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_NWKDISC_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address
Public field | ScanChannels | Bit Mask for channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows to ask for more
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWKDISC_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_REQUEST Constructor

ZDO_MGMT_NWKDISC_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWKDISC_REQUEST | Constructor
Public method | ZDO_MGMT_NWKDISC_REQUEST (UInt16, ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS, Byte, Byte) |

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_REQUEST Constructor ()

ZDO_MGMT_NWKDISC_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWKDISC_REQUEST()
C++
public:
ZDO_MGMT_NWKDISC_REQUEST() sealed
J#
public ZDO_MGMT_NWKDISC_REQUEST()
JScript
public function ZDO_MGMT_NWKDISC_REQUEST()

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_REQUEST Constructor Overload List


ZDO_MGMT_NWKDISC_REQUEST Constructor (UInt16, ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS, Byte, Byte)

ZDO_MGMT_NWKDISC_REQUEST Constructor (UInt16, ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_NWKDISC_REQUEST(
ushort ,
ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte
)
C++
public:
ZDO_MGMT_NWKDISC_REQUEST(
unsigned short ,
ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS ,
char ,
char
) sealed
J#
public ZDO_MGMT_NWKDISC_REQUEST(
ushort ,
ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte
)
JScript
public function ZDO_MGMT_NWKDISC_REQUEST(
: UInt16,
: ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS,
: Byte,
: Byte
)

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_REQUEST Constructor Overload List


Fields

ZDO_MGMT_NWKDISC_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address
Public field | ScanChannels | Bit Mask for channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows to ask for more
Top

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_NWKDISC_REQUEST.DstAddr Field
[image]

Destination network address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace


ScanChannels Field

ZDO_MGMT_NWKDISC_REQUEST.ScanChannels Field
[image]

Bit Mask for channels to scan

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS
C#
public ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS;

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace


ScanDuration Field

ZDO_MGMT_NWKDISC_REQUEST.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_NWKDISC_REQUEST.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows to ask for more

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_NWKDISC_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS Enumeration

ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSE Class

ZDO_MGMT_NWKDISC_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_NWKDISC_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWKDISC_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_NWKDISC_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_NWKDISC_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_NWKDISC_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_NWKDISC_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWKDISC_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSE Members

ZDO_MGMT_NWKDISC_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_NWKDISC_REQUEST

The following tables list the members exposed by ZDO_MGMT_NWKDISC_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_NWKDISC_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWKDISC_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_NWKDISC_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSE Constructor

ZDO_MGMT_NWKDISC_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWKDISC_RESPONSE | Constructor
Public method | ZDO_MGMT_NWKDISC_RESPONSE (ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS) |

See Also

ZDO_MGMT_NWKDISC_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSE Constructor ()

ZDO_MGMT_NWKDISC_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWKDISC_RESPONSE()
C++
public:
ZDO_MGMT_NWKDISC_RESPONSE() sealed
J#
public ZDO_MGMT_NWKDISC_RESPONSE()
JScript
public function ZDO_MGMT_NWKDISC_RESPONSE()

See Also

ZDO_MGMT_NWKDISC_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_RESPONSE Constructor Overload List


ZDO_MGMT_NWKDISC_RESPONSE Constructor (ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS)

ZDO_MGMT_NWKDISC_RESPONSE Constructor (ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS _
)
C#
public ZDO_MGMT_NWKDISC_RESPONSE(
ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS
)
C++
public:
ZDO_MGMT_NWKDISC_RESPONSE(
ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_MGMT_NWKDISC_RESPONSE(
ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS
)
JScript
public function ZDO_MGMT_NWKDISC_RESPONSE(
: ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS
)

See Also

ZDO_MGMT_NWKDISC_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_NWKDISC_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_NWKDISC_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_NWKDISC_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS
C#
public ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS;

See Also

ZDO_MGMT_NWKDISC_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS Enumeration

ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS : char
J#
public enum ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB Class

ZDO_MGMT_NWKDISC_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Network Discovery Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWKDISC_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_NWKDISC_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_NWKDISC_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_NWKDISC_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_NWKDISC_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB Members

ZDO_MGMT_NWKDISC_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Network Discovery Request

The following tables list the members exposed by ZDO_MGMT_NWKDISC_RESPONSECB.

Public Constructors

Name | Description
ZDO_MGMT_NWKDISC_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NetworkCount | Total number of entries available in the device
Public field | NetworkList | Dynamic array, an array of NetworkList items. NetworkListCount contains the number of items in this table
Public field | NetworkListCount | Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWKDISC_RESPONSECB | Overloaded.
Top

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB Constructor

ZDO_MGMT_NWKDISC_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWKDISC_RESPONSECB | Constructor
Public method | ZDO_MGMT_NWKDISC_RESPONSECB (UInt16, ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object) |

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB Constructor ()

ZDO_MGMT_NWKDISC_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWKDISC_RESPONSECB()
C++
public:
ZDO_MGMT_NWKDISC_RESPONSECB() sealed
J#
public ZDO_MGMT_NWKDISC_RESPONSECB()
JScript
public function ZDO_MGMT_NWKDISC_RESPONSECB()

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_RESPONSECB Constructor Overload List


ZDO_MGMT_NWKDISC_RESPONSECB Constructor (UInt16, ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object[])

ZDO_MGMT_NWKDISC_RESPONSECB Constructor (UInt16, ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Object[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_MGMT_NWKDISC_RESPONSECB(
ushort ,
ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
object[]
)
C++
public:
ZDO_MGMT_NWKDISC_RESPONSECB(
unsigned short ,
ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS ,
char ,
char ,
char ,
array<Object>^
) sealed
J#
public ZDO_MGMT_NWKDISC_RESPONSECB(
ushort ,
ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
object[]
)
JScript
public function ZDO_MGMT_NWKDISC_RESPONSECB(
: UInt16,
: ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS,
: Byte,
: Byte,
: Byte,
: Object[]
)

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_RESPONSECB Constructor Overload List


Fields

ZDO_MGMT_NWKDISC_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | NetworkCount | Total number of entries available in the device
Public field | NetworkList | Dynamic array, an array of NetworkList items. NetworkListCount contains the number of items in this table
Public field | NetworkListCount | Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


NetworkCount Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkCount Field
[image]

Total number of entries available in the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkCount As Byte
C#
public byte NetworkCount;
C++
public:
char NetworkCount sealed ;
J#
public byte NetworkCount
JScript
public NetworkCount : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


NetworkList Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkList Field
[image]

Dynamic array, an array of NetworkList items. NetworkListCount contains the number of items in this table

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkList As Object()
C#
public object[] NetworkList;
C++
public:
array<Object>^ NetworkList sealed ;
J#
public object[] NetworkList
JScript
public NetworkList : Object[];

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


NetworkListCount Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListCount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkListCount As Byte
C#
public byte NetworkListCount;
C++
public:
char NetworkListCount sealed ;
J#
public byte NetworkListCount
JScript
public NetworkListCount : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_NWKDISC_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_NWKDISC_RESPONSECB.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_NWKDISC_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS
C#
public ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS Enumeration

ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
See Also Example Members
[image]

Contains information in a single item of a network list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass
C#
public struct ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass
C++
value class ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass
J#
public final class ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Members
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Members

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Contains information in a single item of a network list

The following tables list the members exposed by ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.

Public Constructors

Name | Description
ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BeaconOrder |
Public field | LogicalChannel |
Public field | PanID |
Public field | PermitJoining |
Public field | StackProfile |
Public field | SuperFrameOrder |
Public field | ZigBeeVersion |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass | Overloaded.
Top

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass | Initializes a new instance of the ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass class.
Public method | ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass (UInt64, Byte, Byte, Byte, Byte, Byte, Byte) |

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor ()

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass class.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass()
C++
public:
ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass() sealed
J#
public ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass()
JScript
public function ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass()

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor Overload List


ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor (UInt64, Byte, Byte, Byte, Byte, Byte, Byte)

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor (UInt64, Byte, Byte, Byte, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass(
ulong ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
C++
public:
ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass(
unsigned __int64 ,
char ,
char ,
char ,
char ,
char ,
char
) sealed
J#
public ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass(
ulong ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
JScript
public function ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass(
: UInt64,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace
ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Constructor Overload List


Fields

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | BeaconOrder |
Public field | LogicalChannel |
Public field | PanID |
Public field | PermitJoining |
Public field | StackProfile |
Public field | SuperFrameOrder |
Public field | ZigBeeVersion |
Top

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


BeaconOrder Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.BeaconOrder Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


LogicalChannel Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.LogicalChannel Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


PanID Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.PanID Field
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt64
C#
public ulong PanID;
C++
public:
unsigned __int64 PanID sealed ;
J#
public ulong PanID
JScript
public PanID : UInt64;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


PermitJoining Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.PermitJoining Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PermitJoining As Byte
C#
public byte PermitJoining;
C++
public:
char PermitJoining sealed ;
J#
public byte PermitJoining
JScript
public PermitJoining : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


StackProfile Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.StackProfile Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StackProfile As Byte
C#
public byte StackProfile;
C++
public:
char StackProfile sealed ;
J#
public byte StackProfile
JScript
public StackProfile : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


SuperFrameOrder Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.SuperFrameOrder Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameOrder As Byte
C#
public byte SuperFrameOrder;
C++
public:
char SuperFrameOrder sealed ;
J#
public byte SuperFrameOrder
JScript
public SuperFrameOrder : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


ZigBeeVersion Field

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass.ZigBeeVersion Field
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ZigBeeVersion As Byte
C#
public byte ZigBeeVersion;
C++
public:
char ZigBeeVersion sealed ;
J#
public byte ZigBeeVersion
JScript
public ZigBeeVersion : Byte;

See Also

ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass Structure
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Class

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management Join Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_PERMIT_JOIN_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_PERMIT_JOIN_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_PERMIT_JOIN_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_PERMIT_JOIN_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_PERMIT_JOIN_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Members

ZDO_MGMT_PERMIT_JOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Join Request

The following tables list the members exposed by ZDO_MGMT_PERMIT_JOIN_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_PERMIT_JOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | Duration | The duration to permit joining. 0 = join disabled. 0xff = join enabled. 0x01-0xfe = number of seconds to permit joining
Public field | TCSignificance | Trust Center Significance
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_PERMIT_JOIN_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor

ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_PERMIT_JOIN_REQUEST | Constructor
Public method | ZDO_MGMT_PERMIT_JOIN_REQUEST (UInt16, Byte, Byte) | Constructor

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor ()

ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_PERMIT_JOIN_REQUEST()
C++
public:
ZDO_MGMT_PERMIT_JOIN_REQUEST() sealed
J#
public ZDO_MGMT_PERMIT_JOIN_REQUEST()
JScript
public function ZDO_MGMT_PERMIT_JOIN_REQUEST()

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor Overload List


ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor (UInt16, Byte, Byte)

ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor (UInt16, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_PERMIT_JOIN_REQUEST(
ushort ,
byte ,
byte
)
C++
public:
ZDO_MGMT_PERMIT_JOIN_REQUEST(
unsigned short ,
char ,
char
) sealed
J#
public ZDO_MGMT_PERMIT_JOIN_REQUEST(
ushort ,
byte ,
byte
)
JScript
public function ZDO_MGMT_PERMIT_JOIN_REQUEST(
: UInt16,
: Byte,
: Byte
)

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor Overload List


Fields

ZDO_MGMT_PERMIT_JOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | Duration | The duration to permit joining. 0 = join disabled. 0xff = join enabled. 0x01-0xfe = number of seconds to permit joining
Public field | TCSignificance | Trust Center Significance
Top

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_PERMIT_JOIN_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace


Duration Field

ZDO_MGMT_PERMIT_JOIN_REQUEST.Duration Field
[image]

The duration to permit joining. 0 = join disabled. 0xff = join enabled. 0x01-0xfe = number of seconds to permit joining

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Duration As Byte
C#
public byte Duration;
C++
public:
char Duration sealed ;
J#
public byte Duration
JScript
public Duration : Byte;

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace


TCSignificance Field

ZDO_MGMT_PERMIT_JOIN_REQUEST.TCSignificance Field
[image]

Trust Center Significance

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TCSignificance As Byte
C#
public byte TCSignificance;
C++
public:
char TCSignificance sealed ;
J#
public byte TCSignificance
JScript
public TCSignificance : Byte;

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSE Class

ZDO_MGMT_PERMIT_JOIN_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_PERMIT_JOIN_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_PERMIT_JOIN_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_PERMIT_JOIN_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_PERMIT_JOIN_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_PERMIT_JOIN_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_PERMIT_JOIN_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSE Members

ZDO_MGMT_PERMIT_JOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_PERMIT_JOIN_REQUEST

The following tables list the members exposed by ZDO_MGMT_PERMIT_JOIN_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_PERMIT_JOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_PERMIT_JOIN_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor

ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_PERMIT_JOIN_RESPONSE | Constructor
Public method | ZDO_MGMT_PERMIT_JOIN_RESPONSE (ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS) |

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor ()

ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_PERMIT_JOIN_RESPONSE()
C++
public:
ZDO_MGMT_PERMIT_JOIN_RESPONSE() sealed
J#
public ZDO_MGMT_PERMIT_JOIN_RESPONSE()
JScript
public function ZDO_MGMT_PERMIT_JOIN_RESPONSE()

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor Overload List


ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor (ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS)

ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor (ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MGMT_PERMIT_JOIN_RESPONSE(
ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MGMT_PERMIT_JOIN_RESPONSE(
ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MGMT_PERMIT_JOIN_RESPONSE(
ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MGMT_PERMIT_JOIN_RESPONSE(
: ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS
)

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_PERMIT_JOIN_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_PERMIT_JOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_PERMIT_JOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS
C#
public ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS;

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS Enumeration

ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Permit Join Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_PERMIT_JOIN_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_PERMIT_JOIN_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_PERMIT_JOIN_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_PERMIT_JOIN_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_PERMIT_JOIN_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSECB Members

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Permit Join Request

The following tables list the members exposed by ZDO_MGMT_PERMIT_JOIN_RESPONSECB.

Public Constructors

Name | Description
ZDO_MGMT_PERMIT_JOIN_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_PERMIT_JOIN_RESPONSECB | Overloaded.
Top

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_PERMIT_JOIN_RESPONSECB | Constructor
Public method | ZDO_MGMT_PERMIT_JOIN_RESPONSECB (ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS, UInt16) |

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor ()

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_PERMIT_JOIN_RESPONSECB()
C++
public:
ZDO_MGMT_PERMIT_JOIN_RESPONSECB() sealed
J#
public ZDO_MGMT_PERMIT_JOIN_RESPONSECB()
JScript
public function ZDO_MGMT_PERMIT_JOIN_RESPONSECB()

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor Overload List


ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor (ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS, UInt16)

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor (ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS, _
ByVal As UInt16 _
)
C#
public ZDO_MGMT_PERMIT_JOIN_RESPONSECB(
ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS ,
ushort
)
C++
public:
ZDO_MGMT_PERMIT_JOIN_RESPONSECB(
ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS ,
unsigned short
) sealed
J#
public ZDO_MGMT_PERMIT_JOIN_RESPONSECB(
ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS ,
ushort
)
JScript
public function ZDO_MGMT_PERMIT_JOIN_RESPONSECB(
: ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS,
: UInt16
)

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_PERMIT_JOIN_RESPONSECB Constructor Overload List


Fields

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_PERMIT_JOIN_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_PERMIT_JOIN_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS (0) or FAILURE (1).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS
C#
public ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS;

See Also

ZDO_MGMT_PERMIT_JOIN_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS Enumeration

ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_RTG_REQUEST Class

ZDO_MGMT_RTG_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management Routing Table Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_RTG_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_RTG_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_RTG_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_RTG_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_RTG_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_RTG_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_RTG_REQUEST Members
TI.ZPI1 Namespace


ZDO_MGMT_RTG_REQUEST Members

ZDO_MGMT_RTG_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Routing Table Request.

The following tables list the members exposed by ZDO_MGMT_RTG_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_RTG_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_RTG_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_RTG_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_REQUEST Constructor

ZDO_MGMT_RTG_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_RTG_REQUEST | Constructor
Public method | ZDO_MGMT_RTG_REQUEST (UInt16, Byte) | Constructor

See Also

ZDO_MGMT_RTG_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_REQUEST Constructor ()

ZDO_MGMT_RTG_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_RTG_REQUEST()
C++
public:
ZDO_MGMT_RTG_REQUEST() sealed
J#
public ZDO_MGMT_RTG_REQUEST()
JScript
public function ZDO_MGMT_RTG_REQUEST()

See Also

ZDO_MGMT_RTG_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_RTG_REQUEST Constructor Overload List


ZDO_MGMT_RTG_REQUEST Constructor (UInt16, Byte)

ZDO_MGMT_RTG_REQUEST Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_MGMT_RTG_REQUEST(
ushort ,
byte
)
C++
public:
ZDO_MGMT_RTG_REQUEST(
unsigned short ,
char
) sealed
J#
public ZDO_MGMT_RTG_REQUEST(
ushort ,
byte
)
JScript
public function ZDO_MGMT_RTG_REQUEST(
: UInt16,
: Byte
)

See Also

ZDO_MGMT_RTG_REQUEST Class
TI.ZPI1 Namespace
ZDO_MGMT_RTG_REQUEST Constructor Overload List


Fields

ZDO_MGMT_RTG_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

See Also

ZDO_MGMT_RTG_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_MGMT_RTG_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_RTG_REQUEST Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_RTG_REQUEST.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_RTG_REQUEST Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSE Class

ZDO_MGMT_RTG_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_RTG_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_RTG_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_RTG_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_RTG_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_RTG_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_RTG_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_RTG_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_RTG_RESPONSE Members
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSE Members

ZDO_MGMT_RTG_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_RTG_REQUEST

The following tables list the members exposed by ZDO_MGMT_RTG_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_RTG_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_RTG_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_RTG_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSE Constructor

ZDO_MGMT_RTG_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_RTG_RESPONSE | Constructor
Public method | ZDO_MGMT_RTG_RESPONSE (ZDO_MGMT_RTG_RESPONSE.CMD_STATUS) |

See Also

ZDO_MGMT_RTG_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSE Constructor ()

ZDO_MGMT_RTG_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_RTG_RESPONSE()
C++
public:
ZDO_MGMT_RTG_RESPONSE() sealed
J#
public ZDO_MGMT_RTG_RESPONSE()
JScript
public function ZDO_MGMT_RTG_RESPONSE()

See Also

ZDO_MGMT_RTG_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_RTG_RESPONSE Constructor Overload List


ZDO_MGMT_RTG_RESPONSE Constructor (ZDO_MGMT_RTG_RESPONSE.CMD_STATUS)

ZDO_MGMT_RTG_RESPONSE Constructor (ZDO_MGMT_RTG_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_RTG_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MGMT_RTG_RESPONSE(
ZDO_MGMT_RTG_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MGMT_RTG_RESPONSE(
ZDO_MGMT_RTG_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MGMT_RTG_RESPONSE(
ZDO_MGMT_RTG_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MGMT_RTG_RESPONSE(
: ZDO_MGMT_RTG_RESPONSE.CMD_STATUS
)

See Also

ZDO_MGMT_RTG_RESPONSE Class
TI.ZPI1 Namespace
ZDO_MGMT_RTG_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_RTG_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_RTG_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_RTG_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_RTG_RESPONSE.CMD_STATUS
C#
public ZDO_MGMT_RTG_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MGMT_RTG_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_RTG_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_RTG_RESPONSE.CMD_STATUS;

See Also

ZDO_MGMT_RTG_RESPONSE Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSE.CMD_STATUS Enumeration

ZDO_MGMT_RTG_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_RTG_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_RTG_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_RTG_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MGMT_RTG_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MGMT_RTG_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSECB Class

ZDO_MGMT_RTG_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Routing Table Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_RTG_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_RTG_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_RTG_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_RTG_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_RTG_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_MGMT_RTG_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_RTG_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSECB Members

ZDO_MGMT_RTG_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Routing Table Request.

The following tables list the members exposed by ZDO_MGMT_RTG_RESPONSECB.

Public Constructors

Name | Description
ZDO_MGMT_RTG_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | RtgCount | Total number of entries available in the device.
Public field | RtgList | Dynamic array, an array of RtgList items. RtgListCount contains the number of items in this table.
Public field | RtgListCount | Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_RTG_RESPONSECB | Overloaded.
Top

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSECB Constructor

ZDO_MGMT_RTG_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_RTG_RESPONSECB | Constructor
Public method | ZDO_MGMT_RTG_RESPONSECB (UInt16, ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Byte) |

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSECB Constructor ()

ZDO_MGMT_RTG_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_RTG_RESPONSECB()
C++
public:
ZDO_MGMT_RTG_RESPONSECB() sealed
J#
public ZDO_MGMT_RTG_RESPONSECB()
JScript
public function ZDO_MGMT_RTG_RESPONSECB()

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_RTG_RESPONSECB Constructor Overload List


ZDO_MGMT_RTG_RESPONSECB Constructor (UInt16, ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Byte[])

ZDO_MGMT_RTG_RESPONSECB Constructor (UInt16, ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS, Byte, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_MGMT_RTG_RESPONSECB(
ushort ,
ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
byte[]
)
C++
public:
ZDO_MGMT_RTG_RESPONSECB(
unsigned short ,
ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS ,
char ,
char ,
char ,
array<char>^
) sealed
J#
public ZDO_MGMT_RTG_RESPONSECB(
ushort ,
ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS ,
byte ,
byte ,
byte ,
byte[]
)
JScript
public function ZDO_MGMT_RTG_RESPONSECB(
: UInt16,
: ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS,
: Byte,
: Byte,
: Byte,
: Byte[]
)

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_MGMT_RTG_RESPONSECB Constructor Overload List


Fields

ZDO_MGMT_RTG_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | RtgCount | Total number of entries available in the device.
Public field | RtgList | Dynamic array, an array of RtgList items. RtgListCount contains the number of items in this table.
Public field | RtgListCount | Number of entries in this response.
Public field | SrcAddress | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


RtgCount Field

ZDO_MGMT_RTG_RESPONSECB.RtgCount Field
[image]

Total number of entries available in the device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RtgCount As Byte
C#
public byte RtgCount;
C++
public:
char RtgCount sealed ;
J#
public byte RtgCount
JScript
public RtgCount : Byte;

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


RtgList Field

ZDO_MGMT_RTG_RESPONSECB.RtgList Field
[image]

Dynamic array, an array of RtgList items. RtgListCount contains the number of items in this table.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RtgList As Byte()
C#
public byte[] RtgList;
C++
public:
array<char>^ RtgList sealed ;
J#
public byte[] RtgList
JScript
public RtgList : Byte[];

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


RtgListCount Field

ZDO_MGMT_RTG_RESPONSECB.RtgListCount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RtgListCount As Byte
C#
public byte RtgListCount;
C++
public:
char RtgListCount sealed ;
J#
public byte RtgListCount
JScript
public RtgListCount : Byte;

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_MGMT_RTG_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_MGMT_RTG_RESPONSECB.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_MGMT_RTG_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS
C#
public ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS;

See Also

ZDO_MGMT_RTG_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS Enumeration

ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_NETWORK_START_REQUEST Class

ZDO_NETWORK_START_REQUEST Class
See Also Example Members
[image]

In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NETWORK_START_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_NETWORK_START_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_NETWORK_START_REQUEST : IREQUEST, IZDO
J#
public class ZDO_NETWORK_START_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_NETWORK_START_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NETWORK_START_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NETWORK_START_REQUEST Members
TI.ZPI1 Namespace


ZDO_NETWORK_START_REQUEST Members

ZDO_NETWORK_START_REQUEST Members
See Also Example Constructors Methods
[image]

In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.

The following tables list the members exposed by ZDO_NETWORK_START_REQUEST.

Public Constructors

 | Name | Description
Public method | ZDO_NETWORK_START_REQUEST | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZDO_NETWORK_START_REQUEST Class
TI.ZPI1 Namespace


ZDO_NETWORK_START_REQUEST Constructor

ZDO_NETWORK_START_REQUEST Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NETWORK_START_REQUEST()
C++
public:
ZDO_NETWORK_START_REQUEST() sealed
J#
public ZDO_NETWORK_START_REQUEST()
JScript
public function ZDO_NETWORK_START_REQUEST()

See Also

ZDO_NETWORK_START_REQUEST Class
TI.ZPI1 Namespace


ZDO_NETWORK_START_RESPONSE Class

ZDO_NETWORK_START_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_NETWORK_START_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NETWORK_START_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_NETWORK_START_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_NETWORK_START_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_NETWORK_START_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_NETWORK_START_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NETWORK_START_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NETWORK_START_RESPONSE Members
TI.ZPI1 Namespace


ZDO_NETWORK_START_RESPONSE Members

ZDO_NETWORK_START_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_NETWORK_START_REQUEST

The following tables list the members exposed by ZDO_NETWORK_START_RESPONSE.

Public Constructors

Name | Description
ZDO_NETWORK_START_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NETWORK_START_RESPONSE | Overloaded.
Top

See Also

ZDO_NETWORK_START_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NETWORK_START_RESPONSE Constructor

ZDO_NETWORK_START_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_NETWORK_START_RESPONSE | Constructor
Public method | ZDO_NETWORK_START_RESPONSE (ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS) |

See Also

ZDO_NETWORK_START_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NETWORK_START_RESPONSE Constructor ()

ZDO_NETWORK_START_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NETWORK_START_RESPONSE()
C++
public:
ZDO_NETWORK_START_RESPONSE() sealed
J#
public ZDO_NETWORK_START_RESPONSE()
JScript
public function ZDO_NETWORK_START_RESPONSE()

See Also

ZDO_NETWORK_START_RESPONSE Class
TI.ZPI1 Namespace
ZDO_NETWORK_START_RESPONSE Constructor Overload List


ZDO_NETWORK_START_RESPONSE Constructor (ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS)

ZDO_NETWORK_START_RESPONSE Constructor (ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS _
)
C#
public ZDO_NETWORK_START_RESPONSE(
ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS
)
C++
public:
ZDO_NETWORK_START_RESPONSE(
ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS
) sealed
J#
public ZDO_NETWORK_START_RESPONSE(
ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS
)
JScript
public function ZDO_NETWORK_START_RESPONSE(
: ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS
)

See Also

ZDO_NETWORK_START_RESPONSE Class
TI.ZPI1 Namespace
ZDO_NETWORK_START_RESPONSE Constructor Overload List


Fields

ZDO_NETWORK_START_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_NETWORK_START_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_NETWORK_START_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS
C#
public ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS Status;
C++
public:
ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS Status sealed ;
J#
public ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS Status
JScript
public Status : ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS;

See Also

ZDO_NETWORK_START_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS Enumeration

ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS Enumeration
[image]

Status of network start response

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS As Byte
C#
public enum ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS : byte
C++
public enum class ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS : char
J#
public enum ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS byte
JScript
public enum ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS :

Members

Member Name | Description
STATE_RESTORED | Status of network start response
STATE_INITIALIZED | Status of network start response
NOT_IN_NETWORK | Status of network start response

See Also

TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_REQUEST Class

ZDO_NETWORKADDRESS_REQUEST Class
See Also Example Members
[image]

This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NETWORKADDRESS_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_NETWORKADDRESS_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_NETWORKADDRESS_REQUEST : IREQUEST, IZDO
J#
public class ZDO_NETWORKADDRESS_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_NETWORKADDRESS_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NETWORKADDRESS_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NETWORKADDRESS_REQUEST Members
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_REQUEST Members

ZDO_NETWORKADDRESS_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.

The following tables list the members exposed by ZDO_NETWORKADDRESS_REQUEST.

Public Constructors

Name | Description
ZDO_NETWORKADDRESS_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEAddress | 64 bit address bait
Public field | ReqType | Request type
Public field | SecurityEnable | Security options
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NETWORKADDRESS_REQUEST | Overloaded.
Top

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_REQUEST Constructor

ZDO_NETWORKADDRESS_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_NETWORKADDRESS_REQUEST | Constructor
Public method | ZDO_NETWORKADDRESS_REQUEST (UInt64, ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE, Byte, ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS) |

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_REQUEST Constructor ()

ZDO_NETWORKADDRESS_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NETWORKADDRESS_REQUEST()
C++
public:
ZDO_NETWORKADDRESS_REQUEST() sealed
J#
public ZDO_NETWORKADDRESS_REQUEST()
JScript
public function ZDO_NETWORKADDRESS_REQUEST()

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace
ZDO_NETWORKADDRESS_REQUEST Constructor Overload List


ZDO_NETWORKADDRESS_REQUEST Constructor (UInt64, ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE, Byte, ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS)

ZDO_NETWORKADDRESS_REQUEST Constructor (UInt64, ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE, Byte, ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE, _
ByVal As Byte, _
ByVal As ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS _
)
C#
public ZDO_NETWORKADDRESS_REQUEST(
ulong ,
ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE ,
byte ,
ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS
)
C++
public:
ZDO_NETWORKADDRESS_REQUEST(
unsigned __int64 ,
ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE ,
char ,
ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS
) sealed
J#
public ZDO_NETWORKADDRESS_REQUEST(
ulong ,
ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE ,
byte ,
ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS
)
JScript
public function ZDO_NETWORKADDRESS_REQUEST(
: UInt64,
: ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE,
: Byte,
: ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS
)

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace
ZDO_NETWORKADDRESS_REQUEST Constructor Overload List


Fields

ZDO_NETWORKADDRESS_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEAddress | 64 bit address bait
Public field | ReqType | Request type
Public field | SecurityEnable | Security options
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace


IEEEAddress Field

ZDO_NETWORKADDRESS_REQUEST.IEEEAddress Field
[image]

64 bit address bait

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddress As UInt64
C#
public ulong IEEEAddress;
C++
public:
unsigned __int64 IEEEAddress sealed ;
J#
public ulong IEEEAddress
JScript
public IEEEAddress : UInt64;

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace


ReqType Field

ZDO_NETWORKADDRESS_REQUEST.ReqType Field
[image]

Request type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReqType As ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE
C#
public ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE ReqType;
C++
public:
ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE ReqType sealed ;
J#
public ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE ReqType
JScript
public ReqType : ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE;

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace


SecurityEnable Field

ZDO_NETWORKADDRESS_REQUEST.SecurityEnable Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityEnable As ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS
C#
public ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS SecurityEnable;
C++
public:
ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS SecurityEnable sealed ;
J#
public ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS SecurityEnable
JScript
public SecurityEnable : ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS;

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_NETWORKADDRESS_REQUEST.StartIndex Field
[image]

Starting index into the list of children. This is used to get more of the list if the list is to large for one message.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_NETWORKADDRESS_REQUEST Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE Enumeration

ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE Enumeration
[image]

Request type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE As Byte
C#
public enum ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE : byte
C++
public enum class ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE : char
J#
public enum ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE byte
JScript
public enum ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE :

Members

Member Name | Description
SINGLE_DEVICE_RESPONSE | Request type
EXTENDED | Request type

See Also

TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS Enumeration

ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS Enumeration
[image]

Security status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS As Byte
C#
public enum ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS : byte
C++
public enum class ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS : char
J#
public enum ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS byte
JScript
public enum ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS :

Members

Member Name | Description
NOT_ENABLED | Security status
ENABLED | Security status

See Also

TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSE Class

ZDO_NETWORKADDRESS_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_NETWORKADDRESS_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NETWORKADDRESS_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_NETWORKADDRESS_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_NETWORKADDRESS_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_NETWORKADDRESS_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_NETWORKADDRESS_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NETWORKADDRESS_RESPONSE Members
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSE Members

ZDO_NETWORKADDRESS_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_NETWORKADDRESS_REQUEST

The following tables list the members exposed by ZDO_NETWORKADDRESS_RESPONSE.

Public Constructors

Name | Description
ZDO_NETWORKADDRESS_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NETWORKADDRESS_RESPONSE | Overloaded.
Top

See Also

ZDO_NETWORKADDRESS_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSE Constructor

ZDO_NETWORKADDRESS_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_NETWORKADDRESS_RESPONSE | Constructor
Public method | ZDO_NETWORKADDRESS_RESPONSE (ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS) |

See Also

ZDO_NETWORKADDRESS_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSE Constructor ()

ZDO_NETWORKADDRESS_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NETWORKADDRESS_RESPONSE()
C++
public:
ZDO_NETWORKADDRESS_RESPONSE() sealed
J#
public ZDO_NETWORKADDRESS_RESPONSE()
JScript
public function ZDO_NETWORKADDRESS_RESPONSE()

See Also

ZDO_NETWORKADDRESS_RESPONSE Class
TI.ZPI1 Namespace
ZDO_NETWORKADDRESS_RESPONSE Constructor Overload List


ZDO_NETWORKADDRESS_RESPONSE Constructor (ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS)

ZDO_NETWORKADDRESS_RESPONSE Constructor (ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS _
)
C#
public ZDO_NETWORKADDRESS_RESPONSE(
ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS
)
C++
public:
ZDO_NETWORKADDRESS_RESPONSE(
ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_NETWORKADDRESS_RESPONSE(
ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS
)
JScript
public function ZDO_NETWORKADDRESS_RESPONSE(
: ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS
)

See Also

ZDO_NETWORKADDRESS_RESPONSE Class
TI.ZPI1 Namespace
ZDO_NETWORKADDRESS_RESPONSE Constructor Overload List


Fields

ZDO_NETWORKADDRESS_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_NETWORKADDRESS_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_NETWORKADDRESS_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS
C#
public ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS;

See Also

ZDO_NETWORKADDRESS_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS Enumeration

ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS : char
J#
public enum ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSECB Class

ZDO_NETWORKADDRESS_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Network Address Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NETWORKADDRESS_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_NETWORKADDRESS_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_NETWORKADDRESS_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_NETWORKADDRESS_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_NETWORKADDRESS_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NETWORKADDRESS_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSECB Members

ZDO_NETWORKADDRESS_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Network Address Request.

The following tables list the members exposed by ZDO_NETWORKADDRESS_RESPONSECB.

Public Constructors

Name | Description
ZDO_NETWORKADDRESS_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | number of associated devices
Public field | nwkAddr | short network address of responding device
Public field | SrcAddress | Source address, size is dependent on SrcAddrMode
Public field | SrcAddrMode | indicates that the SrcAddr is either 16 bits or 64 bits
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NETWORKADDRESS_RESPONSECB | Overloaded.
Top

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSECB Constructor

ZDO_NETWORKADDRESS_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_NETWORKADDRESS_RESPONSECB | Constructor
Public method | ZDO_NETWORKADDRESS_RESPONSECB (ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE, UInt64, ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS, UInt64, UInt16, Byte, Byte, UInt16) |

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSECB Constructor ()

ZDO_NETWORKADDRESS_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NETWORKADDRESS_RESPONSECB()
C++
public:
ZDO_NETWORKADDRESS_RESPONSECB() sealed
J#
public ZDO_NETWORKADDRESS_RESPONSECB()
JScript
public function ZDO_NETWORKADDRESS_RESPONSECB()

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_NETWORKADDRESS_RESPONSECB Constructor Overload List


ZDO_NETWORKADDRESS_RESPONSECB Constructor (ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE, UInt64, ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS, UInt64, UInt16, Byte, Byte, UInt16[])

ZDO_NETWORKADDRESS_RESPONSECB Constructor (ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE, UInt64, ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS, UInt64, UInt16, Byte, Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_NETWORKADDRESS_RESPONSECB(
ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE ,
ulong ,
ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS ,
ulong ,
ushort ,
byte ,
byte ,
ushort[]
)
C++
public:
ZDO_NETWORKADDRESS_RESPONSECB(
ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE ,
unsigned __int64 ,
ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS ,
unsigned __int64 ,
unsigned short ,
char ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_NETWORKADDRESS_RESPONSECB(
ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE ,
ulong ,
ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS ,
ulong ,
ushort ,
byte ,
byte ,
ushort[]
)
JScript
public function ZDO_NETWORKADDRESS_RESPONSECB(
: ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE,
: UInt64,
: ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS,
: UInt64,
: UInt16,
: Byte,
: Byte,
: UInt16[]
)

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_NETWORKADDRESS_RESPONSECB Constructor Overload List


Fields

ZDO_NETWORKADDRESS_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | number of associated devices
Public field | nwkAddr | short network address of responding device
Public field | SrcAddress | Source address, size is dependent on SrcAddrMode
Public field | SrcAddrMode | indicates that the SrcAddr is either 16 bits or 64 bits
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


AssocDevList Field

ZDO_NETWORKADDRESS_RESPONSECB.AssocDevList Field
[image]

Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocDevList As UInt16()
C#
public ushort[] AssocDevList;
C++
public:
array<unsigned short>^ AssocDevList sealed ;
J#
public ushort[] AssocDevList
JScript
public AssocDevList : UInt16[];

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


IEEEAddr Field

ZDO_NETWORKADDRESS_RESPONSECB.IEEEAddr Field
[image]

64 bit IEEE address of source device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


NumAssocDev Field

ZDO_NETWORKADDRESS_RESPONSECB.NumAssocDev Field
[image]

number of associated devices

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumAssocDev As Byte
C#
public byte NumAssocDev;
C++
public:
char NumAssocDev sealed ;
J#
public byte NumAssocDev
JScript
public NumAssocDev : Byte;

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


nwkAddr Field

ZDO_NETWORKADDRESS_RESPONSECB.nwkAddr Field
[image]

short network address of responding device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public nwkAddr As UInt16
C#
public ushort nwkAddr;
C++
public:
unsigned short nwkAddr sealed ;
J#
public ushort nwkAddr
JScript
public nwkAddr : UInt16;

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_NETWORKADDRESS_RESPONSECB.SrcAddress Field
[image]

Source address, size is dependent on SrcAddrMode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddrMode Field

ZDO_NETWORKADDRESS_RESPONSECB.SrcAddrMode Field
[image]

indicates that the SrcAddr is either 16 bits or 64 bits

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddrMode As ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE
C#
public ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE SrcAddrMode;
C++
public:
ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE SrcAddrMode sealed ;
J#
public ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE SrcAddrMode
JScript
public SrcAddrMode : ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE;

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


StartIndex Field

ZDO_NETWORKADDRESS_RESPONSECB.StartIndex Field
[image]

Starting index into the list of associated devices for this report.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_NETWORKADDRESS_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS
C#
public ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS;

See Also

ZDO_NETWORKADDRESS_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE Enumeration

ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE As Byte
C#
public enum ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE : byte
C++
public enum class ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE : char
J#
public enum ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE byte
JScript
public enum ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS Enumeration

ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_REQUEST Class

ZDO_NODEDESCRIPTOR_REQUEST Class
See Also Example Members
[image]

This command is generated to inquire as to the Node Descriptor of the destination device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NODEDESCRIPTOR_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_NODEDESCRIPTOR_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_NODEDESCRIPTOR_REQUEST : IREQUEST, IZDO
J#
public class ZDO_NODEDESCRIPTOR_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_NODEDESCRIPTOR_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NODEDESCRIPTOR_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NODEDESCRIPTOR_REQUEST Members
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_REQUEST Members

ZDO_NODEDESCRIPTOR_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to inquire as to the Node Descriptor of the destination device

The following tables list the members exposed by ZDO_NODEDESCRIPTOR_REQUEST.

Public Constructors

Name | Description
ZDO_NODEDESCRIPTOR_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NODEDESCRIPTOR_REQUEST | Overloaded.
Top

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_REQUEST Constructor

ZDO_NODEDESCRIPTOR_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_NODEDESCRIPTOR_REQUEST | Constructor
Public method | ZDO_NODEDESCRIPTOR_REQUEST (UInt16, UInt16, ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE) |

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_REQUEST Constructor ()

ZDO_NODEDESCRIPTOR_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NODEDESCRIPTOR_REQUEST()
C++
public:
ZDO_NODEDESCRIPTOR_REQUEST() sealed
J#
public ZDO_NODEDESCRIPTOR_REQUEST()
JScript
public function ZDO_NODEDESCRIPTOR_REQUEST()

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_NODEDESCRIPTOR_REQUEST Constructor Overload List


ZDO_NODEDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE)

ZDO_NODEDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_NODEDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_NODEDESCRIPTOR_REQUEST(
unsigned short ,
unsigned short ,
ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_NODEDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_NODEDESCRIPTOR_REQUEST(
: UInt16,
: UInt16,
: ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE
)

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_NODEDESCRIPTOR_REQUEST Constructor Overload List


Fields

ZDO_NODEDESCRIPTOR_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_NODEDESCRIPTOR_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_NODEDESCRIPTOR_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_NODEDESCRIPTOR_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE
C#
public ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE;

See Also

ZDO_NODEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration

ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSE Class

ZDO_NODEDESCRIPTOR_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_NODEDESCRIPTOR_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NODEDESCRIPTOR_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_NODEDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_NODEDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_NODEDESCRIPTOR_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_NODEDESCRIPTOR_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NODEDESCRIPTOR_RESPONSE Members
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSE Members

ZDO_NODEDESCRIPTOR_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_NODEDESCRIPTOR_REQUEST

The following tables list the members exposed by ZDO_NODEDESCRIPTOR_RESPONSE.

Public Constructors

Name | Description
ZDO_NODEDESCRIPTOR_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NODEDESCRIPTOR_RESPONSE | Overloaded.
Top

See Also

ZDO_NODEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSE Constructor

ZDO_NODEDESCRIPTOR_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_NODEDESCRIPTOR_RESPONSE | Constructor
Public method | ZDO_NODEDESCRIPTOR_RESPONSE (ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS) |

See Also

ZDO_NODEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSE Constructor ()

ZDO_NODEDESCRIPTOR_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NODEDESCRIPTOR_RESPONSE()
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSE() sealed
J#
public ZDO_NODEDESCRIPTOR_RESPONSE()
JScript
public function ZDO_NODEDESCRIPTOR_RESPONSE()

See Also

ZDO_NODEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_NODEDESCRIPTOR_RESPONSE Constructor Overload List


ZDO_NODEDESCRIPTOR_RESPONSE Constructor (ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS)

ZDO_NODEDESCRIPTOR_RESPONSE Constructor (ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS _
)
C#
public ZDO_NODEDESCRIPTOR_RESPONSE(
ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS
)
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSE(
ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_NODEDESCRIPTOR_RESPONSE(
ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS
)
JScript
public function ZDO_NODEDESCRIPTOR_RESPONSE(
: ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS
)

See Also

ZDO_NODEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_NODEDESCRIPTOR_RESPONSE Constructor Overload List


Fields

ZDO_NODEDESCRIPTOR_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_NODEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_NODEDESCRIPTOR_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS
C#
public ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS;

See Also

ZDO_NODEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS Enumeration

ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS : char
J#
public enum ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB Class

ZDO_NODEDESCRIPTOR_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Node Descriptor Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NODEDESCRIPTOR_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_NODEDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_NODEDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_NODEDESCRIPTOR_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_NODEDESCRIPTOR_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB Members

ZDO_NODEDESCRIPTOR_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Node Descriptor Request.

The following tables list the members exposed by ZDO_NODEDESCRIPTOR_RESPONSECB.

Public Constructors

Name | Description
ZDO_NODEDESCRIPTOR_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | APSFlags | Node Flags assigned for APS. For V1.0 all bits are reserved
Public field | BufferSize | Indicates size of maximum NPDU. This field is used as a high level indication for management
Public field | Capabilities | Capability flags stored for the MAC
Public field | ComplexDescriptorAvailable | Indicates if complex descriptor is available for the node
Public field | ManufacturerCode | Specifies a manufacturer code that is allocated by ZigBee Alliance, relating to the manufacturer to the device
Public field | NodeType | Node type
Public field | NWKAddrOfInterest | Device's short address of this Node descriptor
Public field | ServerMask | Specifies the system server capability
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Public field | TransferSize | Indicates maximum size of Transfer up to 0x7fff (This field is reserved in version 1.0 and shall be set to zero ).
Public field | UserDescriptorAvailable | Indicates if user descriptor is available for the node
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NODEDESCRIPTOR_RESPONSECB | Overloaded.
Top

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB Constructor

ZDO_NODEDESCRIPTOR_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_NODEDESCRIPTOR_RESPONSECB | Constructor
Public method | ZDO_NODEDESCRIPTOR_RESPONSECB (ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE, Byte, Byte, Byte, ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO, UInt16, Byte, UInt16, ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY) |

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB Constructor ()

ZDO_NODEDESCRIPTOR_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NODEDESCRIPTOR_RESPONSECB()
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSECB() sealed
J#
public ZDO_NODEDESCRIPTOR_RESPONSECB()
JScript
public function ZDO_NODEDESCRIPTOR_RESPONSECB()

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_NODEDESCRIPTOR_RESPONSECB Constructor Overload List


ZDO_NODEDESCRIPTOR_RESPONSECB Constructor (ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE, Byte, Byte, Byte, ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO, UInt16, Byte, UInt16, ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY)

ZDO_NODEDESCRIPTOR_RESPONSECB Constructor (ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE, Byte, Byte, Byte, ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO, UInt16, Byte, UInt16, ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY _
)
C#
public ZDO_NODEDESCRIPTOR_RESPONSECB(
ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE ,
byte ,
byte ,
byte ,
ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO ,
ushort ,
byte ,
ushort ,
ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY
)
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSECB(
ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS ,
unsigned short ,
unsigned short ,
ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE ,
char ,
char ,
char ,
ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO ,
unsigned short ,
char ,
unsigned short ,
ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY
) sealed
J#
public ZDO_NODEDESCRIPTOR_RESPONSECB(
ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE ,
byte ,
byte ,
byte ,
ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO ,
ushort ,
byte ,
ushort ,
ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY
)
JScript
public function ZDO_NODEDESCRIPTOR_RESPONSECB(
: ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS,
: UInt16,
: UInt16,
: ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE,
: Byte,
: Byte,
: Byte,
: ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO,
: UInt16,
: Byte,
: UInt16,
: ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY
)

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_NODEDESCRIPTOR_RESPONSECB Constructor Overload List


Fields

ZDO_NODEDESCRIPTOR_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | APSFlags | Node Flags assigned for APS. For V1.0 all bits are reserved
Public field | BufferSize | Indicates size of maximum NPDU. This field is used as a high level indication for management
Public field | Capabilities | Capability flags stored for the MAC
Public field | ComplexDescriptorAvailable | Indicates if complex descriptor is available for the node
Public field | ManufacturerCode | Specifies a manufacturer code that is allocated by ZigBee Alliance, relating to the manufacturer to the device
Public field | NodeType | Node type
Public field | NWKAddrOfInterest | Device's short address of this Node descriptor
Public field | ServerMask | Specifies the system server capability
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Public field | TransferSize | Indicates maximum size of Transfer up to 0x7fff (This field is reserved in version 1.0 and shall be set to zero ).
Public field | UserDescriptorAvailable | Indicates if user descriptor is available for the node
Top

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


APSFlags Field

ZDO_NODEDESCRIPTOR_RESPONSECB.APSFlags Field
[image]

Node Flags assigned for APS. For V1.0 all bits are reserved

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public APSFlags As Byte
C#
public byte APSFlags;
C++
public:
char APSFlags sealed ;
J#
public byte APSFlags
JScript
public APSFlags : Byte;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


BufferSize Field

ZDO_NODEDESCRIPTOR_RESPONSECB.BufferSize Field
[image]

Indicates size of maximum NPDU. This field is used as a high level indication for management

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BufferSize As Byte
C#
public byte BufferSize;
C++
public:
char BufferSize sealed ;
J#
public byte BufferSize
JScript
public BufferSize : Byte;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Capabilities Field

ZDO_NODEDESCRIPTOR_RESPONSECB.Capabilities Field
[image]

Capability flags stored for the MAC

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Capabilities As ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO
C#
public ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO Capabilities;
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO Capabilities sealed ;
J#
public ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO Capabilities
JScript
public Capabilities : ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ComplexDescriptorAvailable Field

ZDO_NODEDESCRIPTOR_RESPONSECB.ComplexDescriptorAvailable Field
See Also Example
[image]

Indicates if complex descriptor is available for the node

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ComplexDescriptorAvailable As Byte
C#
public byte ComplexDescriptorAvailable;
C++
public:
char ComplexDescriptorAvailable sealed ;
J#
public byte ComplexDescriptorAvailable
JScript
public ComplexDescriptorAvailable : Byte;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ManufacturerCode Field

ZDO_NODEDESCRIPTOR_RESPONSECB.ManufacturerCode Field
[image]

Specifies a manufacturer code that is allocated by ZigBee Alliance, relating to the manufacturer to the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ManufacturerCode As UInt16
C#
public ushort ManufacturerCode;
C++
public:
unsigned short ManufacturerCode sealed ;
J#
public ushort ManufacturerCode
JScript
public ManufacturerCode : UInt16;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NodeType Field

ZDO_NODEDESCRIPTOR_RESPONSECB.NodeType Field
[image]

Node type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NodeType As ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE
C#
public ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE NodeType;
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE NodeType sealed ;
J#
public ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE NodeType
JScript
public NodeType : ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_NODEDESCRIPTOR_RESPONSECB.NWKAddrOfInterest Field
[image]

Device's short address of this Node descriptor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ServerMask Field

ZDO_NODEDESCRIPTOR_RESPONSECB.ServerMask Field
[image]

Specifies the system server capability

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ServerMask As ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY
C#
public ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY ServerMask;
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY ServerMask sealed ;
J#
public ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY ServerMask
JScript
public ServerMask : ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_NODEDESCRIPTOR_RESPONSECB.SrcAddress Field
[image]

the message's source network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_NODEDESCRIPTOR_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS
C#
public ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


TransferSize Field

ZDO_NODEDESCRIPTOR_RESPONSECB.TransferSize Field
[image]

Indicates maximum size of Transfer up to 0x7fff (This field is reserved in version 1.0 and shall be set to zero ).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransferSize As UInt16
C#
public ushort TransferSize;
C++
public:
unsigned short TransferSize sealed ;
J#
public ushort TransferSize
JScript
public TransferSize : UInt16;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


UserDescriptorAvailable Field

ZDO_NODEDESCRIPTOR_RESPONSECB.UserDescriptorAvailable Field
[image]

Indicates if user descriptor is available for the node

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UserDescriptorAvailable As Byte
C#
public byte UserDescriptorAvailable;
C++
public:
char UserDescriptorAvailable sealed ;
J#
public byte UserDescriptorAvailable
JScript
public UserDescriptorAvailable : Byte;

See Also

ZDO_NODEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO Enumeration

ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO byte
JScript
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration

ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE Enumeration

ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE Enumeration
[image]

Type of Node

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE As Byte
C#
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE : byte
C++
public enum class ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE : char
J#
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE byte
JScript
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE :

Members

Member Name | Description
COORDINATOR | Type of Node
ROUTER | Type of Node
END_DEVICE | Type of Node

See Also

TI.ZPI1 Namespace


ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY Enumeration

ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY Enumeration
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY As
C#
[FlagsAttribute]
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY : ushort
C++
[FlagsAttribute]
public enum class ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY ushort
JScript
public enum ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
PRIM_TRUST_CENTER | Capabilities bitfield | 1
BACKUP_TRUST_CENTER | Capabilities bitfield | 2
PRIM_BIND_TABLE_CACHE | Capabilities bitfield | 4
BAK_BIND_TABLE_CACHE | Capabilities bitfield | 8
PRIM_DISC_CACHE | Capabilities bitfield | 22
BAK_DISC_CACHE | Capabilities bitfield | 50

See Also

TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_REQUEST Class

ZDO_POWERDESCRIPTOR_REQUEST Class
See Also Example Members
[image]

This command is generated to inquire as to the Power Descriptor of the destination

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_POWERDESCRIPTOR_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_POWERDESCRIPTOR_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_POWERDESCRIPTOR_REQUEST : IREQUEST, IZDO
J#
public class ZDO_POWERDESCRIPTOR_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_POWERDESCRIPTOR_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_POWERDESCRIPTOR_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_POWERDESCRIPTOR_REQUEST Members
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_REQUEST Members

ZDO_POWERDESCRIPTOR_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to inquire as to the Power Descriptor of the destination

The following tables list the members exposed by ZDO_POWERDESCRIPTOR_REQUEST.

Public Constructors

Name | Description
ZDO_POWERDESCRIPTOR_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_POWERDESCRIPTOR_REQUEST | Overloaded.
Top

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_REQUEST Constructor

ZDO_POWERDESCRIPTOR_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_POWERDESCRIPTOR_REQUEST | Constructor
Public method | ZDO_POWERDESCRIPTOR_REQUEST (UInt16, UInt16, ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE) |

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_REQUEST Constructor ()

ZDO_POWERDESCRIPTOR_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_POWERDESCRIPTOR_REQUEST()
C++
public:
ZDO_POWERDESCRIPTOR_REQUEST() sealed
J#
public ZDO_POWERDESCRIPTOR_REQUEST()
JScript
public function ZDO_POWERDESCRIPTOR_REQUEST()

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_POWERDESCRIPTOR_REQUEST Constructor Overload List


ZDO_POWERDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE)

ZDO_POWERDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_POWERDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_POWERDESCRIPTOR_REQUEST(
unsigned short ,
unsigned short ,
ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_POWERDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_POWERDESCRIPTOR_REQUEST(
: UInt16,
: UInt16,
: ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE
)

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_POWERDESCRIPTOR_REQUEST Constructor Overload List


Fields

ZDO_POWERDESCRIPTOR_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_POWERDESCRIPTOR_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_POWERDESCRIPTOR_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_POWERDESCRIPTOR_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE
C#
public ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE;

See Also

ZDO_POWERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration

ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSE Class

ZDO_POWERDESCRIPTOR_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_POWERDESCRIPTOR_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_POWERDESCRIPTOR_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_POWERDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_POWERDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_POWERDESCRIPTOR_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_POWERDESCRIPTOR_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_POWERDESCRIPTOR_RESPONSE Members
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSE Members

ZDO_POWERDESCRIPTOR_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_POWERDESCRIPTOR_REQUEST

The following tables list the members exposed by ZDO_POWERDESCRIPTOR_RESPONSE.

Public Constructors

Name | Description
ZDO_POWERDESCRIPTOR_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_POWERDESCRIPTOR_RESPONSE | Overloaded.
Top

See Also

ZDO_POWERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSE Constructor

ZDO_POWERDESCRIPTOR_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_POWERDESCRIPTOR_RESPONSE | Constructor
Public method | ZDO_POWERDESCRIPTOR_RESPONSE (ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS) |

See Also

ZDO_POWERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSE Constructor ()

ZDO_POWERDESCRIPTOR_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_POWERDESCRIPTOR_RESPONSE()
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSE() sealed
J#
public ZDO_POWERDESCRIPTOR_RESPONSE()
JScript
public function ZDO_POWERDESCRIPTOR_RESPONSE()

See Also

ZDO_POWERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_POWERDESCRIPTOR_RESPONSE Constructor Overload List


ZDO_POWERDESCRIPTOR_RESPONSE Constructor (ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS)

ZDO_POWERDESCRIPTOR_RESPONSE Constructor (ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS _
)
C#
public ZDO_POWERDESCRIPTOR_RESPONSE(
ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS
)
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSE(
ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_POWERDESCRIPTOR_RESPONSE(
ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS
)
JScript
public function ZDO_POWERDESCRIPTOR_RESPONSE(
: ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS
)

See Also

ZDO_POWERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_POWERDESCRIPTOR_RESPONSE Constructor Overload List


Fields

ZDO_POWERDESCRIPTOR_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_POWERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_POWERDESCRIPTOR_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS
C#
public ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS;

See Also

ZDO_POWERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS Enumeration

ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS : char
J#
public enum ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSECB Class

ZDO_POWERDESCRIPTOR_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Power Descriptor Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_POWERDESCRIPTOR_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_POWERDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_POWERDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_POWERDESCRIPTOR_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_POWERDESCRIPTOR_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSECB Members

ZDO_POWERDESCRIPTOR_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Power Descriptor Request.

The following tables list the members exposed by ZDO_POWERDESCRIPTOR_RESPONSECB.

Public Constructors

Name | Description
ZDO_POWERDESCRIPTOR_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NodeAvailablePowerSources | Bit field showing available power sources
Public field | NodeCurrentPowerMode | Indicates Power Mode
Public field | NodeCurrentPowerSource | Indicates current power source
Public field | NodeCurrentPowerSourceLevel | Indicates charge status of power supply
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_POWERDESCRIPTOR_RESPONSECB | Overloaded.
Top

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSECB Constructor

ZDO_POWERDESCRIPTOR_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_POWERDESCRIPTOR_RESPONSECB | Constructor
Public method | ZDO_POWERDESCRIPTOR_RESPONSECB (ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, Byte) |

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSECB Constructor ()

ZDO_POWERDESCRIPTOR_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_POWERDESCRIPTOR_RESPONSECB()
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSECB() sealed
J#
public ZDO_POWERDESCRIPTOR_RESPONSECB()
JScript
public function ZDO_POWERDESCRIPTOR_RESPONSECB()

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_POWERDESCRIPTOR_RESPONSECB Constructor Overload List


ZDO_POWERDESCRIPTOR_RESPONSECB Constructor (ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, Byte)

ZDO_POWERDESCRIPTOR_RESPONSECB Constructor (ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE, _
ByVal As ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, _
ByVal As ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC, _
ByVal As Byte _
)
C#
public ZDO_POWERDESCRIPTOR_RESPONSECB(
ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC ,
byte
)
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSECB(
ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS ,
unsigned short ,
unsigned short ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC ,
char
) sealed
J#
public ZDO_POWERDESCRIPTOR_RESPONSECB(
ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC ,
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC ,
byte
)
JScript
public function ZDO_POWERDESCRIPTOR_RESPONSECB(
: ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS,
: UInt16,
: UInt16,
: ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE,
: ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC,
: ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC,
: Byte
)

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_POWERDESCRIPTOR_RESPONSECB Constructor Overload List


Fields

ZDO_POWERDESCRIPTOR_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | NodeAvailablePowerSources | Bit field showing available power sources
Public field | NodeCurrentPowerMode | Indicates Power Mode
Public field | NodeCurrentPowerSource | Indicates current power source
Public field | NodeCurrentPowerSourceLevel | Indicates charge status of power supply
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NodeAvailablePowerSources Field

ZDO_POWERDESCRIPTOR_RESPONSECB.NodeAvailablePowerSources Field
See Also Example
[image]

Bit field showing available power sources

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NodeAvailablePowerSources As ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC
C#
public ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC NodeAvailablePowerSources;
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC NodeAvailablePowerSources sealed ;
J#
public ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC NodeAvailablePowerSources
JScript
public NodeAvailablePowerSources : ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC;

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NodeCurrentPowerMode Field

ZDO_POWERDESCRIPTOR_RESPONSECB.NodeCurrentPowerMode Field
[image]

Indicates Power Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NodeCurrentPowerMode As ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE
C#
public ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE NodeCurrentPowerMode;
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE NodeCurrentPowerMode sealed ;
J#
public ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE NodeCurrentPowerMode
JScript
public NodeCurrentPowerMode : ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE;

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NodeCurrentPowerSource Field

ZDO_POWERDESCRIPTOR_RESPONSECB.NodeCurrentPowerSource Field
[image]

Indicates current power source

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NodeCurrentPowerSource As ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC
C#
public ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC NodeCurrentPowerSource;
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC NodeCurrentPowerSource sealed ;
J#
public ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC NodeCurrentPowerSource
JScript
public NodeCurrentPowerSource : ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC;

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NodeCurrentPowerSourceLevel Field

ZDO_POWERDESCRIPTOR_RESPONSECB.NodeCurrentPowerSourceLevel Field
See Also Example
[image]

Indicates charge status of power supply

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NodeCurrentPowerSourceLevel As Byte
C#
public byte NodeCurrentPowerSourceLevel;
C++
public:
char NodeCurrentPowerSourceLevel sealed ;
J#
public byte NodeCurrentPowerSourceLevel
JScript
public NodeCurrentPowerSourceLevel : Byte;

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_POWERDESCRIPTOR_RESPONSECB.NWKAddrOfInterest Field
[image]

Device's short address that this response describes.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_POWERDESCRIPTOR_RESPONSECB.SrcAddress Field
[image]

the message's source network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_POWERDESCRIPTOR_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS
C#
public ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS;

See Also

ZDO_POWERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration

ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC Enumeration

ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC Enumeration
See Also Example
[image]

Node Available power sources bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC As Byte
C#
[FlagsAttribute]
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC : byte
C++
[FlagsAttribute]
public enum class ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC : char
J#
/** @attribute FlagsAttribute() */
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC byte
JScript
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC :

Members

Member Name | Description | Value
NONE | Node Available power sources bitfield | 0
CONST_PWR | Node Available power sources bitfield | 1
REC_BATT | Node Available power sources bitfield | 2
DIS_BATT | Node Available power sources bitfield | 4

See Also

TI.ZPI1 Namespace


ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE Enumeration

ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE Enumeration
See Also Example
[image]

Node current power mode bitfield

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE As Byte
C#
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE : byte
C++
public enum class ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE : char
J#
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE byte
JScript
public enum ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE :

Members

Member Name | Description
REC_PERM_ON | Node current power mode bitfield
REC_PER_ON | Node current power mode bitfield
REC_ON_WHEN_STIMULATED | Node current power mode bitfield

See Also

TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_REQUEST Class

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
See Also Example Members
[image]

This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SIMPLEDESCRIPTOR_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_SIMPLEDESCRIPTOR_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_SIMPLEDESCRIPTOR_REQUEST : IREQUEST, IZDO
J#
public class ZDO_SIMPLEDESCRIPTOR_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_SIMPLEDESCRIPTOR_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Members
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_REQUEST Members

ZDO_SIMPLEDESCRIPTOR_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint

The following tables list the members exposed by ZDO_SIMPLEDESCRIPTOR_REQUEST.

Public Constructors

Name | Description
ZDO_SIMPLEDESCRIPTOR_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | End point
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SIMPLEDESCRIPTOR_REQUEST | Overloaded.
Top

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor

ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_SIMPLEDESCRIPTOR_REQUEST | Constructor
Public method | ZDO_SIMPLEDESCRIPTOR_REQUEST (UInt16, UInt16, Byte, ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE) |

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor ()

ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SIMPLEDESCRIPTOR_REQUEST()
C++
public:
ZDO_SIMPLEDESCRIPTOR_REQUEST() sealed
J#
public ZDO_SIMPLEDESCRIPTOR_REQUEST()
JScript
public function ZDO_SIMPLEDESCRIPTOR_REQUEST()

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor Overload List


ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, Byte, ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE)

ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, Byte, ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_SIMPLEDESCRIPTOR_REQUEST(
ushort ,
ushort ,
byte ,
ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_SIMPLEDESCRIPTOR_REQUEST(
unsigned short ,
unsigned short ,
char ,
ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_SIMPLEDESCRIPTOR_REQUEST(
ushort ,
ushort ,
byte ,
ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_SIMPLEDESCRIPTOR_REQUEST(
: UInt16,
: UInt16,
: Byte,
: ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE
)

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_SIMPLEDESCRIPTOR_REQUEST Constructor Overload List


Fields

ZDO_SIMPLEDESCRIPTOR_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | End point
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_SIMPLEDESCRIPTOR_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


Endpoint Field

ZDO_SIMPLEDESCRIPTOR_REQUEST.Endpoint Field
[image]

End point

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_SIMPLEDESCRIPTOR_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_SIMPLEDESCRIPTOR_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE
C#
public ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE;

See Also

ZDO_SIMPLEDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration

ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSE Class

ZDO_SIMPLEDESCRIPTOR_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_SIMPLEDESCRIPTOR_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SIMPLEDESCRIPTOR_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_SIMPLEDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_SIMPLEDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_SIMPLEDESCRIPTOR_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_SIMPLEDESCRIPTOR_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSE Members
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSE Members

ZDO_SIMPLEDESCRIPTOR_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_SIMPLEDESCRIPTOR_REQUEST

The following tables list the members exposed by ZDO_SIMPLEDESCRIPTOR_RESPONSE.

Public Constructors

Name | Description
ZDO_SIMPLEDESCRIPTOR_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SIMPLEDESCRIPTOR_RESPONSE | Overloaded.
Top

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor

ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_SIMPLEDESCRIPTOR_RESPONSE | Constructor
Public method | ZDO_SIMPLEDESCRIPTOR_RESPONSE (ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS) |

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor ()

ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSE()
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSE() sealed
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSE()
JScript
public function ZDO_SIMPLEDESCRIPTOR_RESPONSE()

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor Overload List


ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor (ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS)

ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor (ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS _
)
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSE(
ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS
)
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSE(
ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSE(
ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS
)
JScript
public function ZDO_SIMPLEDESCRIPTOR_RESPONSE(
: ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS
)

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_SIMPLEDESCRIPTOR_RESPONSE Constructor Overload List


Fields

ZDO_SIMPLEDESCRIPTOR_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_SIMPLEDESCRIPTOR_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS Enumeration

ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS : char
J#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Simple Descriptor Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SIMPLEDESCRIPTOR_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_SIMPLEDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_SIMPLEDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_SIMPLEDESCRIPTOR_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_SIMPLEDESCRIPTOR_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSECB Members

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Simple Descriptor Request.

The following tables list the members exposed by ZDO_SIMPLEDESCRIPTOR_RESPONSECB.

Public Constructors

Name | Description
ZDO_SIMPLEDESCRIPTOR_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppDevID | The Device Description ID for this endpoint.
Public field | AppDevVer | Flags indicating app version
Public field | AppInClusterCount | The number of input clusters in the AppInClusterList
Public field | AppInClusterList | List of input cluster IDs supported
Public field | AppOutClusterCount | The number of output clusters in the AppOutClusterList
Public field | AppOutClusterList | List of output cluster IDs supported
Public field | AppProfID | The profile ID for this endpoint.
Public field | AppVerFlags | Flags indicating app Flags
Public field | Endpoint | End point
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SIMPLEDESCRIPTOR_RESPONSECB | Overloaded.
Top

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_SIMPLEDESCRIPTOR_RESPONSECB | Constructor
Public method | ZDO_SIMPLEDESCRIPTOR_RESPONSECB (ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER, ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS, Byte, UInt16, Byte, UInt16) |

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor ()

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB()
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSECB() sealed
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB()
JScript
public function ZDO_SIMPLEDESCRIPTOR_RESPONSECB()

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor Overload List


ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor (ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER, ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS, Byte, UInt16[], Byte, UInt16[])

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor (ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER, ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS, Byte, UInt16[], Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER, _
ByVal As ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB(
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
ushort ,
ushort ,
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER ,
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS ,
byte ,
ushort[] ,
byte ,
ushort[]
)
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSECB(
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS ,
unsigned short ,
unsigned short ,
char ,
unsigned short ,
unsigned short ,
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER ,
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB(
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
ushort ,
ushort ,
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER ,
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS ,
byte ,
ushort[] ,
byte ,
ushort[]
)
JScript
public function ZDO_SIMPLEDESCRIPTOR_RESPONSECB(
: ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS,
: UInt16,
: UInt16,
: Byte,
: UInt16,
: UInt16,
: ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER,
: ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS,
: Byte,
: UInt16[],
: Byte,
: UInt16[]
)

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_SIMPLEDESCRIPTOR_RESPONSECB Constructor Overload List


Fields

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | AppDevID | The Device Description ID for this endpoint.
Public field | AppDevVer | Flags indicating app version
Public field | AppInClusterCount | The number of input clusters in the AppInClusterList
Public field | AppInClusterList | List of input cluster IDs supported
Public field | AppOutClusterCount | The number of output clusters in the AppOutClusterList
Public field | AppOutClusterList | List of output cluster IDs supported
Public field | AppProfID | The profile ID for this endpoint.
Public field | AppVerFlags | Flags indicating app Flags
Public field | Endpoint | End point
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppDevID Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppDevID Field
[image]

The Device Description ID for this endpoint.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppDevID As UInt16
C#
public ushort AppDevID;
C++
public:
unsigned short AppDevID sealed ;
J#
public ushort AppDevID
JScript
public AppDevID : UInt16;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppDevVer Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppDevVer Field
[image]

Flags indicating app version

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppDevVer As ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER AppDevVer;
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER AppDevVer sealed ;
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER AppDevVer
JScript
public AppDevVer : ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppInClusterCount Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppInClusterCount Field
[image]

The number of input clusters in the AppInClusterList

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppInClusterCount As Byte
C#
public byte AppInClusterCount;
C++
public:
char AppInClusterCount sealed ;
J#
public byte AppInClusterCount
JScript
public AppInClusterCount : Byte;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppInClusterList Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppInClusterList Field
[image]

List of input cluster IDs supported

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppInClusterList As UInt16()
C#
public ushort[] AppInClusterList;
C++
public:
array<unsigned short>^ AppInClusterList sealed ;
J#
public ushort[] AppInClusterList
JScript
public AppInClusterList : UInt16[];

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppOutClusterCount Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppOutClusterCount Field
[image]

The number of output clusters in the AppOutClusterList

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppOutClusterCount As Byte
C#
public byte AppOutClusterCount;
C++
public:
char AppOutClusterCount sealed ;
J#
public byte AppOutClusterCount
JScript
public AppOutClusterCount : Byte;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppOutClusterList Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppOutClusterList Field
[image]

List of output cluster IDs supported

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppOutClusterList As UInt16()
C#
public ushort[] AppOutClusterList;
C++
public:
array<unsigned short>^ AppOutClusterList sealed ;
J#
public ushort[] AppOutClusterList
JScript
public AppOutClusterList : UInt16[];

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppProfID Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppProfID Field
[image]

The profile ID for this endpoint.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppProfID As UInt16
C#
public ushort AppProfID;
C++
public:
unsigned short AppProfID sealed ;
J#
public ushort AppProfID
JScript
public AppProfID : UInt16;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


AppVerFlags Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.AppVerFlags Field
[image]

Flags indicating app Flags

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppVerFlags As ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS AppVerFlags;
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS AppVerFlags sealed ;
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS AppVerFlags
JScript
public AppVerFlags : ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Endpoint Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.Endpoint Field
[image]

End point

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.NWKAddrOfInterest Field
[image]

Device's short address that this response describes.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.SrcAddress Field
[image]

the message's source network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS
C#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS;

See Also

ZDO_SIMPLEDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER Enumeration

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER Enumeration
[image]

App dev ver

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER As Byte
C#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER : byte
C++
public enum class ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER : char
J#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER byte
JScript
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER :

Members

Member Name | Description
VER_100 | App dev ver

See Also

TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS Enumeration

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS Enumeration
[image]

App flags

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS As Byte
C#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS : byte
C++
public enum class ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS : char
J#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS byte
JScript
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS :

Members

Member Name | Description
COMPLEX_DESC_AVAIL | App flags
USER_DESC_AVAIL | App flags

See Also

TI.ZPI1 Namespace


ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration

ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_REQUEST Class

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
See Also Example Members
[image]

The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SYSTEM_SERVER_DISC_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_SYSTEM_SERVER_DISC_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_SYSTEM_SERVER_DISC_REQUEST : IREQUEST, IZDO
J#
public class ZDO_SYSTEM_SERVER_DISC_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_SYSTEM_SERVER_DISC_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Members
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_REQUEST Members

ZDO_SYSTEM_SERVER_DISC_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.

The following tables list the members exposed by ZDO_SYSTEM_SERVER_DISC_REQUEST.

Public Constructors

Name | Description
ZDO_SYSTEM_SERVER_DISC_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SecuriySuite | Security Suit: one byte security option
Public field | ServerMask | Server Mask is a two byte field with bit settings signifying the system server capabililties of the device.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SYSTEM_SERVER_DISC_REQUEST | Overloaded.
Top

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor

ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_SYSTEM_SERVER_DISC_REQUEST | Constructor
Public method | ZDO_SYSTEM_SERVER_DISC_REQUEST (UInt16, Byte) | Constructor

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor ()

ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SYSTEM_SERVER_DISC_REQUEST()
C++
public:
ZDO_SYSTEM_SERVER_DISC_REQUEST() sealed
J#
public ZDO_SYSTEM_SERVER_DISC_REQUEST()
JScript
public function ZDO_SYSTEM_SERVER_DISC_REQUEST()

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
TI.ZPI1 Namespace
ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor Overload List


ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor (UInt16, Byte)

ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_SYSTEM_SERVER_DISC_REQUEST(
ushort ,
byte
)
C++
public:
ZDO_SYSTEM_SERVER_DISC_REQUEST(
unsigned short ,
char
) sealed
J#
public ZDO_SYSTEM_SERVER_DISC_REQUEST(
ushort ,
byte
)
JScript
public function ZDO_SYSTEM_SERVER_DISC_REQUEST(
: UInt16,
: Byte
)

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
TI.ZPI1 Namespace
ZDO_SYSTEM_SERVER_DISC_REQUEST Constructor Overload List


Fields

ZDO_SYSTEM_SERVER_DISC_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | SecuriySuite | Security Suit: one byte security option
Public field | ServerMask | Server Mask is a two byte field with bit settings signifying the system server capabililties of the device.
Top

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
TI.ZPI1 Namespace


SecuriySuite Field

ZDO_SYSTEM_SERVER_DISC_REQUEST.SecuriySuite Field
[image]

Security Suit: one byte security option

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuriySuite As Byte
C#
public byte SecuriySuite;
C++
public:
char SecuriySuite sealed ;
J#
public byte SecuriySuite
JScript
public SecuriySuite : Byte;

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
TI.ZPI1 Namespace


ServerMask Field

ZDO_SYSTEM_SERVER_DISC_REQUEST.ServerMask Field
[image]

Server Mask is a two byte field with bit settings signifying the system server capabililties of the device.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ServerMask As UInt16
C#
public ushort ServerMask;
C++
public:
unsigned short ServerMask sealed ;
J#
public ushort ServerMask
JScript
public ServerMask : UInt16;

See Also

ZDO_SYSTEM_SERVER_DISC_REQUEST Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSE Class

ZDO_SYSTEM_SERVER_DISC_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_SYSTEM_SERVER_DISC_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SYSTEM_SERVER_DISC_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_SYSTEM_SERVER_DISC_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_SYSTEM_SERVER_DISC_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_SYSTEM_SERVER_DISC_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_SYSTEM_SERVER_DISC_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSE Members
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSE Members

ZDO_SYSTEM_SERVER_DISC_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_SYSTEM_SERVER_DISC_REQUEST

The following tables list the members exposed by ZDO_SYSTEM_SERVER_DISC_RESPONSE.

Public Constructors

Name | Description
ZDO_SYSTEM_SERVER_DISC_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SYSTEM_SERVER_DISC_RESPONSE | Overloaded.
Top

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSE Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor

ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_SYSTEM_SERVER_DISC_RESPONSE | Constructor
Public method | ZDO_SYSTEM_SERVER_DISC_RESPONSE (ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS) |

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSE Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor ()

ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SYSTEM_SERVER_DISC_RESPONSE()
C++
public:
ZDO_SYSTEM_SERVER_DISC_RESPONSE() sealed
J#
public ZDO_SYSTEM_SERVER_DISC_RESPONSE()
JScript
public function ZDO_SYSTEM_SERVER_DISC_RESPONSE()

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSE Class
TI.ZPI1 Namespace
ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor Overload List


ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor (ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS)

ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor (ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS _
)
C#
public ZDO_SYSTEM_SERVER_DISC_RESPONSE(
ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_SYSTEM_SERVER_DISC_RESPONSE(
ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_SYSTEM_SERVER_DISC_RESPONSE(
ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_SYSTEM_SERVER_DISC_RESPONSE(
: ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS
)

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSE Class
TI.ZPI1 Namespace
ZDO_SYSTEM_SERVER_DISC_RESPONSE Constructor Overload List


Fields

ZDO_SYSTEM_SERVER_DISC_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_SYSTEM_SERVER_DISC_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS
C#
public ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS;

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSE Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS Enumeration

ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Permit Join Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SYSTEM_SERVER_DISC_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_SYSTEM_SERVER_DISC_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_SYSTEM_SERVER_DISC_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_SYSTEM_SERVER_DISC_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_SYSTEM_SERVER_DISC_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSECB Members

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Permit Join Request

The following tables list the members exposed by ZDO_SYSTEM_SERVER_DISC_RESPONSECB.

Public Constructors

Name | Description
ZDO_SYSTEM_SERVER_DISC_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ServerMask | each bit signifies one system server capability of the node
Public field | SrcAddr | Source address of the address
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SYSTEM_SERVER_DISC_RESPONSECB | Overloaded.
Top

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_SYSTEM_SERVER_DISC_RESPONSECB | Constructor
Public method | ZDO_SYSTEM_SERVER_DISC_RESPONSECB (ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS, UInt16, ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY) |

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor ()

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB()
C++
public:
ZDO_SYSTEM_SERVER_DISC_RESPONSECB() sealed
J#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB()
JScript
public function ZDO_SYSTEM_SERVER_DISC_RESPONSECB()

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor Overload List


ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor (ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS, UInt16, ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY)

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor (ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS, UInt16, ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS, _
ByVal As UInt16, _
ByVal As ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY _
)
C#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB(
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS ,
ushort ,
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY
)
C++
public:
ZDO_SYSTEM_SERVER_DISC_RESPONSECB(
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS ,
unsigned short ,
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY
) sealed
J#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB(
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS ,
ushort ,
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY
)
JScript
public function ZDO_SYSTEM_SERVER_DISC_RESPONSECB(
: ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS,
: UInt16,
: ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY
)

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_SYSTEM_SERVER_DISC_RESPONSECB Constructor Overload List


Fields

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | ServerMask | each bit signifies one system server capability of the node
Public field | SrcAddr | Source address of the address
Public field | Status | this field indicates either SUCCESS (0) or FAILURE (1).
Top

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace


ServerMask Field

ZDO_SYSTEM_SERVER_DISC_RESPONSECB.ServerMask Field
[image]

each bit signifies one system server capability of the node

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ServerMask As ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY
C#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY ServerMask;
C++
public:
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY ServerMask sealed ;
J#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY ServerMask
JScript
public ServerMask : ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY;

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddr Field

ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SrcAddr Field
[image]

Source address of the address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_SYSTEM_SERVER_DISC_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS (0) or FAILURE (1).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS
C#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS;

See Also

ZDO_SYSTEM_SERVER_DISC_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS Enumeration

ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY Enumeration

ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY Enumeration
See Also Example
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY As
C#
[FlagsAttribute]
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY : ushort
C++
[FlagsAttribute]
public enum class ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY ushort
JScript
public enum ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
PRIM_TRUST_CENTER | Capabilities bitfield | 1
BACKUP_TRUST_CENTER | Capabilities bitfield | 2
PRIM_BIND_TABLE_CACHE | Capabilities bitfield | 4
BAK_BIND_TABLE_CACHE | Capabilities bitfield | 8
PRIM_DISC_CACHE | Capabilities bitfield | 22
BAK_DISC_CACHE | Capabilities bitfield | 50

See Also

TI.ZPI1 Namespace


ZDO_UNBIND_REQUEST Class

ZDO_UNBIND_REQUEST Class
See Also Example Members
[image]

This command is generated to request an UnBind

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_UNBIND_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_UNBIND_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_UNBIND_REQUEST : IREQUEST, IZDO
J#
public class ZDO_UNBIND_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_UNBIND_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_UNBIND_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_UNBIND_REQUEST Members
TI.ZPI1 Namespace


ZDO_UNBIND_REQUEST Members

ZDO_UNBIND_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request an UnBind

The following tables list the members exposed by ZDO_UNBIND_REQUEST.

Public Constructors

Name | Description
ZDO_UNBIND_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | DstAddress | 64 bit Binding destination address. Not to be confused with DstAddr
Public field | DstAddrMode | Destination address mode: 01 for Group address; 03 for Extended address
Public field | DstEndpoint | Binding destination endpoint. See Table 1 for formatting
Public field | SecuritySuite | Security options
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_UNBIND_REQUEST | Overloaded.
Top

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_UNBIND_REQUEST Constructor

ZDO_UNBIND_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_UNBIND_REQUEST | Constructor
Public method | ZDO_UNBIND_REQUEST (UInt16, UInt64, Byte, UInt16, ZDO_UNBIND_REQUEST.ADDRESS_MODE, UInt64, Byte, ZDO_UNBIND_REQUEST.SECURITY_SUITE) |

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_UNBIND_REQUEST Constructor ()

ZDO_UNBIND_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_UNBIND_REQUEST()
C++
public:
ZDO_UNBIND_REQUEST() sealed
J#
public ZDO_UNBIND_REQUEST()
JScript
public function ZDO_UNBIND_REQUEST()

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_UNBIND_REQUEST Constructor Overload List


ZDO_UNBIND_REQUEST Constructor (UInt16, UInt64, Byte, UInt16, ZDO_UNBIND_REQUEST.ADDRESS_MODE, UInt64, Byte, ZDO_UNBIND_REQUEST.SECURITY_SUITE)

ZDO_UNBIND_REQUEST Constructor (UInt16, UInt64, Byte, UInt16, ZDO_UNBIND_REQUEST.ADDRESS_MODE, UInt64, Byte, ZDO_UNBIND_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As ZDO_UNBIND_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As ZDO_UNBIND_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_UNBIND_REQUEST(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_UNBIND_REQUEST.ADDRESS_MODE ,
ulong ,
byte ,
ZDO_UNBIND_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_UNBIND_REQUEST(
unsigned short ,
unsigned __int64 ,
char ,
unsigned short ,
ZDO_UNBIND_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
char ,
ZDO_UNBIND_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_UNBIND_REQUEST(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_UNBIND_REQUEST.ADDRESS_MODE ,
ulong ,
byte ,
ZDO_UNBIND_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_UNBIND_REQUEST(
: UInt16,
: UInt64,
: Byte,
: UInt16,
: ZDO_UNBIND_REQUEST.ADDRESS_MODE,
: UInt64,
: Byte,
: ZDO_UNBIND_REQUEST.SECURITY_SUITE
)

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace
ZDO_UNBIND_REQUEST Constructor Overload List


Fields

ZDO_UNBIND_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | DstAddress | 64 bit Binding destination address. Not to be confused with DstAddr
Public field | DstAddrMode | Destination address mode: 01 for Group address; 03 for Extended address
Public field | DstEndpoint | Binding destination endpoint. See Table 1 for formatting
Public field | SecuritySuite | Security options
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint
Top

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


ClusterID Field

ZDO_UNBIND_REQUEST.ClusterID Field
[image]

Cluster ID to match in messages

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_UNBIND_REQUEST.DstAddr Field
[image]

destination address, where this message is going

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


DstAddress Field

ZDO_UNBIND_REQUEST.DstAddress Field
[image]

64 bit Binding destination address. Not to be confused with DstAddr

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddress As UInt64
C#
public ulong DstAddress;
C++
public:
unsigned __int64 DstAddress sealed ;
J#
public ulong DstAddress
JScript
public DstAddress : UInt64;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


DstAddrMode Field

ZDO_UNBIND_REQUEST.DstAddrMode Field
[image]

Destination address mode: 01 for Group address; 03 for Extended address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As ZDO_UNBIND_REQUEST.ADDRESS_MODE
C#
public ZDO_UNBIND_REQUEST.ADDRESS_MODE DstAddrMode;
C++
public:
ZDO_UNBIND_REQUEST.ADDRESS_MODE DstAddrMode sealed ;
J#
public ZDO_UNBIND_REQUEST.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : ZDO_UNBIND_REQUEST.ADDRESS_MODE;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


DstEndpoint Field

ZDO_UNBIND_REQUEST.DstEndpoint Field
[image]

Binding destination endpoint. See Table 1 for formatting

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstEndpoint As Byte
C#
public byte DstEndpoint;
C++
public:
char DstEndpoint sealed ;
J#
public byte DstEndpoint
JScript
public DstEndpoint : Byte;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_UNBIND_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_UNBIND_REQUEST.SECURITY_SUITE
C#
public ZDO_UNBIND_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_UNBIND_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_UNBIND_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_UNBIND_REQUEST.SECURITY_SUITE;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_UNBIND_REQUEST.SrcAddress Field
[image]

64 bit Binding source address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


SrcEndpoint Field

ZDO_UNBIND_REQUEST.SrcEndpoint Field
[image]

Binding source endpoint

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

ZDO_UNBIND_REQUEST Class
TI.ZPI1 Namespace


ZDO_UNBIND_REQUEST.ADDRESS_MODE Enumeration

ZDO_UNBIND_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_UNBIND_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZDO_UNBIND_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZDO_UNBIND_REQUEST.ADDRESS_MODE : char
J#
public enum ZDO_UNBIND_REQUEST.ADDRESS_MODE byte
JScript
public enum ZDO_UNBIND_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZDO_UNBIND_REQUEST.SECURITY_SUITE Enumeration

ZDO_UNBIND_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_UNBIND_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_UNBIND_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_UNBIND_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_UNBIND_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_UNBIND_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSE Class

ZDO_UNBIND_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_UNBIND_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_UNBIND_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_UNBIND_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_UNBIND_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_UNBIND_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_UNBIND_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_UNBIND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_UNBIND_RESPONSE Members
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSE Members

ZDO_UNBIND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_UNBIND_REQUEST

The following tables list the members exposed by ZDO_UNBIND_RESPONSE.

Public Constructors

Name | Description
ZDO_UNBIND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_UNBIND_RESPONSE | Overloaded.
Top

See Also

ZDO_UNBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSE Constructor

ZDO_UNBIND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_UNBIND_RESPONSE | Constructor
Public method | ZDO_UNBIND_RESPONSE (ZDO_UNBIND_RESPONSE.AF_STATUS) |

See Also

ZDO_UNBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSE Constructor ()

ZDO_UNBIND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_UNBIND_RESPONSE()
C++
public:
ZDO_UNBIND_RESPONSE() sealed
J#
public ZDO_UNBIND_RESPONSE()
JScript
public function ZDO_UNBIND_RESPONSE()

See Also

ZDO_UNBIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_UNBIND_RESPONSE Constructor Overload List


ZDO_UNBIND_RESPONSE Constructor (ZDO_UNBIND_RESPONSE.AF_STATUS)

ZDO_UNBIND_RESPONSE Constructor (ZDO_UNBIND_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_UNBIND_RESPONSE.AF_STATUS _
)
C#
public ZDO_UNBIND_RESPONSE(
ZDO_UNBIND_RESPONSE.AF_STATUS
)
C++
public:
ZDO_UNBIND_RESPONSE(
ZDO_UNBIND_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_UNBIND_RESPONSE(
ZDO_UNBIND_RESPONSE.AF_STATUS
)
JScript
public function ZDO_UNBIND_RESPONSE(
: ZDO_UNBIND_RESPONSE.AF_STATUS
)

See Also

ZDO_UNBIND_RESPONSE Class
TI.ZPI1 Namespace
ZDO_UNBIND_RESPONSE Constructor Overload List


Fields

ZDO_UNBIND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_UNBIND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_UNBIND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_UNBIND_RESPONSE.AF_STATUS
C#
public ZDO_UNBIND_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_UNBIND_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_UNBIND_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_UNBIND_RESPONSE.AF_STATUS;

See Also

ZDO_UNBIND_RESPONSE Class
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSE.AF_STATUS Enumeration

ZDO_UNBIND_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_UNBIND_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_UNBIND_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_UNBIND_RESPONSE.AF_STATUS : char
J#
public enum ZDO_UNBIND_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_UNBIND_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSECB Class

ZDO_UNBIND_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO UnBind Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_UNBIND_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_UNBIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_UNBIND_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_UNBIND_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_UNBIND_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_UNBIND_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_UNBIND_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSECB Members

ZDO_UNBIND_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO UnBind Request

The following tables list the members exposed by ZDO_UNBIND_RESPONSECB.

Public Constructors

Name | Description
ZDO_UNBIND_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates status of the bind request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_UNBIND_RESPONSECB | Overloaded.
Top

See Also

ZDO_UNBIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSECB Constructor

ZDO_UNBIND_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_UNBIND_RESPONSECB | Constructor
Public method | ZDO_UNBIND_RESPONSECB (ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS, UInt16) |

See Also

ZDO_UNBIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSECB Constructor ()

ZDO_UNBIND_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_UNBIND_RESPONSECB()
C++
public:
ZDO_UNBIND_RESPONSECB() sealed
J#
public ZDO_UNBIND_RESPONSECB()
JScript
public function ZDO_UNBIND_RESPONSECB()

See Also

ZDO_UNBIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_UNBIND_RESPONSECB Constructor Overload List


ZDO_UNBIND_RESPONSECB Constructor (ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS, UInt16)

ZDO_UNBIND_RESPONSECB Constructor (ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS, _
ByVal As UInt16 _
)
C#
public ZDO_UNBIND_RESPONSECB(
ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS ,
ushort
)
C++
public:
ZDO_UNBIND_RESPONSECB(
ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS ,
unsigned short
) sealed
J#
public ZDO_UNBIND_RESPONSECB(
ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS ,
ushort
)
JScript
public function ZDO_UNBIND_RESPONSECB(
: ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS,
: UInt16
)

See Also

ZDO_UNBIND_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_UNBIND_RESPONSECB Constructor Overload List


Fields

ZDO_UNBIND_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddress | the message's source network address
Public field | Status | this field indicates status of the bind request
Top

See Also

ZDO_UNBIND_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_UNBIND_RESPONSECB.SrcAddress Field
[image]

the message's source network address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_UNBIND_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_UNBIND_RESPONSECB.Status Field
[image]

this field indicates status of the bind request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS
C#
public ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS Status;
C++
public:
ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS Status sealed ;
J#
public ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS Status
JScript
public Status : ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS;

See Also

ZDO_UNBIND_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS Enumeration

ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS Enumeration
[image]

Status code for Unbind response

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS As Byte
C#
public enum ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS : byte
C++
public enum class ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS : char
J#
public enum ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS byte
JScript
public enum ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS :

Members

Member Name | Description
SUCCESS | Status code for Unbind response
NOT_SUPPORTED | Status code for Unbind response
NO_ENTRY | Status code for Unbind response

See Also

TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_REQUEST Class

ZDO_USERDESCRIPTOR_REQUEST Class
See Also Example Members
[image]

This command is generated to request for the destination device's user descriptor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USERDESCRIPTOR_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_USERDESCRIPTOR_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_USERDESCRIPTOR_REQUEST : IREQUEST, IZDO
J#
public class ZDO_USERDESCRIPTOR_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_USERDESCRIPTOR_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_USERDESCRIPTOR_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USERDESCRIPTOR_REQUEST Members
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_REQUEST Members

ZDO_USERDESCRIPTOR_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request for the destination device's user descriptor

The following tables list the members exposed by ZDO_USERDESCRIPTOR_REQUEST.

Public Constructors

Name | Description
ZDO_USERDESCRIPTOR_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USERDESCRIPTOR_REQUEST | Overloaded.
Top

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_REQUEST Constructor

ZDO_USERDESCRIPTOR_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_USERDESCRIPTOR_REQUEST | Constructor
Public method | ZDO_USERDESCRIPTOR_REQUEST (UInt16, UInt16, ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE) |

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_REQUEST Constructor ()

ZDO_USERDESCRIPTOR_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USERDESCRIPTOR_REQUEST()
C++
public:
ZDO_USERDESCRIPTOR_REQUEST() sealed
J#
public ZDO_USERDESCRIPTOR_REQUEST()
JScript
public function ZDO_USERDESCRIPTOR_REQUEST()

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_REQUEST Constructor Overload List


ZDO_USERDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE)

ZDO_USERDESCRIPTOR_REQUEST Constructor (UInt16, UInt16, ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_USERDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_USERDESCRIPTOR_REQUEST(
unsigned short ,
unsigned short ,
ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_USERDESCRIPTOR_REQUEST(
ushort ,
ushort ,
ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_USERDESCRIPTOR_REQUEST(
: UInt16,
: UInt16,
: ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE
)

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_REQUEST Constructor Overload List


Fields

ZDO_USERDESCRIPTOR_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Public field | SecuritySuite | Security options
Top

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_USERDESCRIPTOR_REQUEST.DstAddr Field
[image]

destination address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_USERDESCRIPTOR_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_USERDESCRIPTOR_REQUEST.SecuritySuite Field
[image]

Security options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE
C#
public ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE;

See Also

ZDO_USERDESCRIPTOR_REQUEST Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration

ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSE Class

ZDO_USERDESCRIPTOR_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_USERDESCRIPTOR_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USERDESCRIPTOR_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_USERDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_USERDESCRIPTOR_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_USERDESCRIPTOR_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_USERDESCRIPTOR_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USERDESCRIPTOR_RESPONSE Members
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSE Members

ZDO_USERDESCRIPTOR_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_USERDESCRIPTOR_REQUEST

The following tables list the members exposed by ZDO_USERDESCRIPTOR_RESPONSE.

Public Constructors

Name | Description
ZDO_USERDESCRIPTOR_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USERDESCRIPTOR_RESPONSE | Overloaded.
Top

See Also

ZDO_USERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSE Constructor

ZDO_USERDESCRIPTOR_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_USERDESCRIPTOR_RESPONSE | Constructor
Public method | ZDO_USERDESCRIPTOR_RESPONSE (ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS) |

See Also

ZDO_USERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSE Constructor ()

ZDO_USERDESCRIPTOR_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USERDESCRIPTOR_RESPONSE()
C++
public:
ZDO_USERDESCRIPTOR_RESPONSE() sealed
J#
public ZDO_USERDESCRIPTOR_RESPONSE()
JScript
public function ZDO_USERDESCRIPTOR_RESPONSE()

See Also

ZDO_USERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_RESPONSE Constructor Overload List


ZDO_USERDESCRIPTOR_RESPONSE Constructor (ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS)

ZDO_USERDESCRIPTOR_RESPONSE Constructor (ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS _
)
C#
public ZDO_USERDESCRIPTOR_RESPONSE(
ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS
)
C++
public:
ZDO_USERDESCRIPTOR_RESPONSE(
ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS
) sealed
J#
public ZDO_USERDESCRIPTOR_RESPONSE(
ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS
)
JScript
public function ZDO_USERDESCRIPTOR_RESPONSE(
: ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS
)

See Also

ZDO_USERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_RESPONSE Constructor Overload List


Fields

ZDO_USERDESCRIPTOR_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_USERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_USERDESCRIPTOR_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS
C#
public ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS Status;
C++
public:
ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS Status sealed ;
J#
public ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS Status
JScript
public Status : ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS;

See Also

ZDO_USERDESCRIPTOR_RESPONSE Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS Enumeration

ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS As Byte
C#
public enum ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS : byte
C++
public enum class ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS : char
J#
public enum ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS byte
JScript
public enum ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS :

Members

Member Name | Description
SUCCESS | Status code for AF responses
FAILED | Status code for AF responses
INVALID_PARAMETER | Status code for AF responses
MEM_FAIL | Status code for AF responses

See Also

TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSECB Class

ZDO_USERDESCRIPTOR_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO User Description Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USERDESCRIPTOR_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_USERDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_USERDESCRIPTOR_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_USERDESCRIPTOR_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_USERDESCRIPTOR_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSECB Members

ZDO_USERDESCRIPTOR_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO User Description Request.

The following tables list the members exposed by ZDO_USERDESCRIPTOR_RESPONSECB.

Public Constructors

Name | Description
ZDO_USERDESCRIPTOR_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DescLen | Length, in bytes, of the user descriptor
Public field | Descriptor | Dynamic array, User descriptor array (can be up to 15 bytes).
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USERDESCRIPTOR_RESPONSECB | Overloaded.
Top

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSECB Constructor

ZDO_USERDESCRIPTOR_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_USERDESCRIPTOR_RESPONSECB | Constructor
Public method | ZDO_USERDESCRIPTOR_RESPONSECB (ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte) |

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSECB Constructor ()

ZDO_USERDESCRIPTOR_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USERDESCRIPTOR_RESPONSECB()
C++
public:
ZDO_USERDESCRIPTOR_RESPONSECB() sealed
J#
public ZDO_USERDESCRIPTOR_RESPONSECB()
JScript
public function ZDO_USERDESCRIPTOR_RESPONSECB()

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_RESPONSECB Constructor Overload List


ZDO_USERDESCRIPTOR_RESPONSECB Constructor (ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte[])

ZDO_USERDESCRIPTOR_RESPONSECB Constructor (ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS, UInt16, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_USERDESCRIPTOR_RESPONSECB(
ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_USERDESCRIPTOR_RESPONSECB(
ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS ,
unsigned short ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_USERDESCRIPTOR_RESPONSECB(
ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS ,
ushort ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_USERDESCRIPTOR_RESPONSECB(
: ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS,
: UInt16,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_RESPONSECB Constructor Overload List


Fields

ZDO_USERDESCRIPTOR_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | DescLen | Length, in bytes, of the user descriptor
Public field | Descriptor | Dynamic array, User descriptor array (can be up to 15 bytes).
Public field | NWKAddrOfInterest | Device's short address that this response describes.
Public field | SrcAddress | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


DescLen Field

ZDO_USERDESCRIPTOR_RESPONSECB.DescLen Field
[image]

Length, in bytes, of the user descriptor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DescLen As Byte
C#
public byte DescLen;
C++
public:
char DescLen sealed ;
J#
public byte DescLen
JScript
public DescLen : Byte;

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Descriptor Field

ZDO_USERDESCRIPTOR_RESPONSECB.Descriptor Field
[image]

Dynamic array, User descriptor array (can be up to 15 bytes).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Descriptor As Byte()
C#
public byte[] Descriptor;
C++
public:
array<char>^ Descriptor sealed ;
J#
public byte[] Descriptor
JScript
public Descriptor : Byte[];

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_USERDESCRIPTOR_RESPONSECB.NWKAddrOfInterest Field
[image]

Device's short address that this response describes.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_USERDESCRIPTOR_RESPONSECB.SrcAddress Field
[image]

the message's source network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_USERDESCRIPTOR_RESPONSECB.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS
C#
public ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS;

See Also

ZDO_USERDESCRIPTOR_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration

ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_REQUEST Class

ZDO_USERDESCRIPTOR_SET_REQUEST Class
See Also Example Members
[image]

This command is generated to request a User Descriptor Set Request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USERDESCRIPTOR_SET_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_USERDESCRIPTOR_SET_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_USERDESCRIPTOR_SET_REQUEST : IREQUEST, IZDO
J#
public class ZDO_USERDESCRIPTOR_SET_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_USERDESCRIPTOR_SET_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Members
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_REQUEST Members

ZDO_USERDESCRIPTOR_SET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a User Descriptor Set Request

The following tables list the members exposed by ZDO_USERDESCRIPTOR_SET_REQUEST.

Public Constructors

Name | Description
ZDO_USERDESCRIPTOR_SET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DescLen | Length, in bytes, of the user descriptor.
Public field | Descriptor | User descriptor array (can be up to 15 bytes).
Public field | DstAddr | Destination network address.
Public field | NWKAddrOfInterest | NWK address for the request.
Public field | SecuritySuite | Security options.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USERDESCRIPTOR_SET_REQUEST | Overloaded.
Top

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_REQUEST Constructor

ZDO_USERDESCRIPTOR_SET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_USERDESCRIPTOR_SET_REQUEST | Constructor
Public method | ZDO_USERDESCRIPTOR_SET_REQUEST (UInt16, UInt16, Byte, Byte, ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE) |

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_REQUEST Constructor ()

ZDO_USERDESCRIPTOR_SET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USERDESCRIPTOR_SET_REQUEST()
C++
public:
ZDO_USERDESCRIPTOR_SET_REQUEST() sealed
J#
public ZDO_USERDESCRIPTOR_SET_REQUEST()
JScript
public function ZDO_USERDESCRIPTOR_SET_REQUEST()

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_SET_REQUEST Constructor Overload List


ZDO_USERDESCRIPTOR_SET_REQUEST Constructor (UInt16, UInt16, Byte, Byte[], ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE)

ZDO_USERDESCRIPTOR_SET_REQUEST Constructor (UInt16, UInt16, Byte, Byte[], ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE _
)
C#
public ZDO_USERDESCRIPTOR_SET_REQUEST(
ushort ,
ushort ,
byte ,
byte[] ,
ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE
)
C++
public:
ZDO_USERDESCRIPTOR_SET_REQUEST(
unsigned short ,
unsigned short ,
char ,
array<char>^ ,
ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE
) sealed
J#
public ZDO_USERDESCRIPTOR_SET_REQUEST(
ushort ,
ushort ,
byte ,
byte[] ,
ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE
)
JScript
public function ZDO_USERDESCRIPTOR_SET_REQUEST(
: UInt16,
: UInt16,
: Byte,
: Byte[],
: ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE
)

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_SET_REQUEST Constructor Overload List


Fields

ZDO_USERDESCRIPTOR_SET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DescLen | Length, in bytes, of the user descriptor.
Public field | Descriptor | User descriptor array (can be up to 15 bytes).
Public field | DstAddr | Destination network address.
Public field | NWKAddrOfInterest | NWK address for the request.
Public field | SecuritySuite | Security options.
Top

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


DescLen Field

ZDO_USERDESCRIPTOR_SET_REQUEST.DescLen Field
[image]

Length, in bytes, of the user descriptor.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DescLen As Byte
C#
public byte DescLen;
C++
public:
char DescLen sealed ;
J#
public byte DescLen
JScript
public DescLen : Byte;

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


Descriptor Field

ZDO_USERDESCRIPTOR_SET_REQUEST.Descriptor Field
[image]

User descriptor array (can be up to 15 bytes).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Descriptor As Byte()
C#
public byte[] Descriptor;
C++
public:
array<char>^ Descriptor sealed ;
J#
public byte[] Descriptor
JScript
public Descriptor : Byte[];

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


DstAddr Field

ZDO_USERDESCRIPTOR_SET_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


NWKAddrOfInterest Field

ZDO_USERDESCRIPTOR_SET_REQUEST.NWKAddrOfInterest Field
[image]

NWK address for the request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


SecuritySuite Field

ZDO_USERDESCRIPTOR_SET_REQUEST.SecuritySuite Field
[image]

Security options.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecuritySuite As ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE
C#
public ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE SecuritySuite;
C++
public:
ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE SecuritySuite sealed ;
J#
public ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE SecuritySuite
JScript
public SecuritySuite : ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE;

See Also

ZDO_USERDESCRIPTOR_SET_REQUEST Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE Enumeration

ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE Enumeration
[image]

Security suite list

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE As Byte
C#
public enum ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE : byte
C++
public enum class ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE : char
J#
public enum ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE byte
JScript
public enum ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE :

Members

Member Name | Description
NONE | Security suite list
AES_CTR | Security suite list
AES_CCM_128 | Security suite list
AES_CCM_64 | Security suite list
AES_CCM_32 | Security suite list
AES_CBC_MAC_128 | Security suite list
AES_CBC_MAC_64 | Security suite list
AES_CBC_MAC_32 | Security suite list

See Also

TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSE Class

ZDO_USERDESCRIPTOR_SET_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_USERDESCRIPTOR_SET_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USERDESCRIPTOR_SET_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_USERDESCRIPTOR_SET_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_USERDESCRIPTOR_SET_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_USERDESCRIPTOR_SET_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_USERDESCRIPTOR_SET_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSE Members
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSE Members

ZDO_USERDESCRIPTOR_SET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_USERDESCRIPTOR_SET_REQUEST

The following tables list the members exposed by ZDO_USERDESCRIPTOR_SET_RESPONSE.

Public Constructors

Name | Description
ZDO_USERDESCRIPTOR_SET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USERDESCRIPTOR_SET_RESPONSE | Overloaded.
Top

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSE Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor

ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_USERDESCRIPTOR_SET_RESPONSE | Constructor
Public method | ZDO_USERDESCRIPTOR_SET_RESPONSE (ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS) |

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSE Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor ()

ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USERDESCRIPTOR_SET_RESPONSE()
C++
public:
ZDO_USERDESCRIPTOR_SET_RESPONSE() sealed
J#
public ZDO_USERDESCRIPTOR_SET_RESPONSE()
JScript
public function ZDO_USERDESCRIPTOR_SET_RESPONSE()

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSE Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor Overload List


ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor (ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS)

ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor (ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS _
)
C#
public ZDO_USERDESCRIPTOR_SET_RESPONSE(
ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_USERDESCRIPTOR_SET_RESPONSE(
ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_USERDESCRIPTOR_SET_RESPONSE(
ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_USERDESCRIPTOR_SET_RESPONSE(
: ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS
)

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSE Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_SET_RESPONSE Constructor Overload List


Fields

ZDO_USERDESCRIPTOR_SET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZDO_USERDESCRIPTOR_SET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS
C#
public ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS;

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSE Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS Enumeration

ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSECB Class

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
See Also Example Members
[image]

This callback message is in response to the ZDO User Descriptor Set Request.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USERDESCRIPTOR_SET_RESPONSECB
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_USERDESCRIPTOR_SET_RESPONSECB : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_USERDESCRIPTOR_SET_RESPONSECB : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_USERDESCRIPTOR_SET_RESPONSECB implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_USERDESCRIPTOR_SET_RESPONSECB extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSECB

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Members
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSECB Members

ZDO_USERDESCRIPTOR_SET_RESPONSECB Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO User Descriptor Set Request.

The following tables list the members exposed by ZDO_USERDESCRIPTOR_SET_RESPONSECB.

Public Constructors

Name | Description
ZDO_USERDESCRIPTOR_SET_RESPONSECB | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates status of the request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USERDESCRIPTOR_SET_RESPONSECB | Overloaded.
Top

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor

ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor

Overload List

 | Name | Description
Public method | ZDO_USERDESCRIPTOR_SET_RESPONSECB | Constructor
Public method | ZDO_USERDESCRIPTOR_SET_RESPONSECB (ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS, UInt16) |

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor ()

ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USERDESCRIPTOR_SET_RESPONSECB()
C++
public:
ZDO_USERDESCRIPTOR_SET_RESPONSECB() sealed
J#
public ZDO_USERDESCRIPTOR_SET_RESPONSECB()
JScript
public function ZDO_USERDESCRIPTOR_SET_RESPONSECB()

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor Overload List


ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor (ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS, UInt16)

ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor (ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS, _
ByVal As UInt16 _
)
C#
public ZDO_USERDESCRIPTOR_SET_RESPONSECB(
ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS ,
ushort
)
C++
public:
ZDO_USERDESCRIPTOR_SET_RESPONSECB(
ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS ,
unsigned short
) sealed
J#
public ZDO_USERDESCRIPTOR_SET_RESPONSECB(
ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS ,
ushort
)
JScript
public function ZDO_USERDESCRIPTOR_SET_RESPONSECB(
: ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS,
: UInt16
)

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
TI.ZPI1 Namespace
ZDO_USERDESCRIPTOR_SET_RESPONSECB Constructor Overload List


Fields

ZDO_USERDESCRIPTOR_SET_RESPONSECB Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddress | Source address of the message
Public field | Status | this field indicates status of the request
Top

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
TI.ZPI1 Namespace


SrcAddress Field

ZDO_USERDESCRIPTOR_SET_RESPONSECB.SrcAddress Field
[image]

Source address of the message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
TI.ZPI1 Namespace


Status Field

ZDO_USERDESCRIPTOR_SET_RESPONSECB.Status Field
[image]

this field indicates status of the request

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS
C#
public ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS Status;
C++
public:
ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS Status sealed ;
J#
public ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS Status
JScript
public Status : ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS;

See Also

ZDO_USERDESCRIPTOR_SET_RESPONSECB Class
TI.ZPI1 Namespace


ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS Enumeration

ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS As Byte
C#
public enum ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS : byte
C++
public enum class ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS : char
J#
public enum ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS byte
JScript
public enum ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST Class

ZMAC_ASSOCIATE_REQUEST Class
See Also Example Members
[image]

This command is used to request (on behalf of the next higher layer) an association with a coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_ASSOCIATE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_ASSOCIATE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_ASSOCIATE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_ASSOCIATE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_REQUEST Members
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST Members

ZMAC_ASSOCIATE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request (on behalf of the next higher layer) an association with a coordinator

The following tables list the members exposed by ZMAC_ASSOCIATE_REQUEST.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInformation | Bit map which specifies the operational capabilities of the device
Public field | ChannelPage | The channel page that the device will associate
Public field | CoordAddress | Address of the Coordinator
Public field | CoordAddressMode | Specifies the format of the coordinator device address
Public field | CoordPanID | PAN ID of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | The channel that the device will associate
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_REQUEST | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST Constructor

ZMAC_ASSOCIATE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_REQUEST | Constructor
Public method | ZMAC_ASSOCIATE_REQUEST (Byte, Byte, ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO, Byte, ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST Constructor ()

ZMAC_ASSOCIATE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_REQUEST()
C++
public:
ZMAC_ASSOCIATE_REQUEST() sealed
J#
public ZMAC_ASSOCIATE_REQUEST()
JScript
public function ZMAC_ASSOCIATE_REQUEST()

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_REQUEST Constructor Overload List


ZMAC_ASSOCIATE_REQUEST Constructor (Byte, Byte, ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO, Byte[], ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, Byte)

ZMAC_ASSOCIATE_REQUEST Constructor (Byte, Byte, ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO, Byte[], ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO, _
ByVal As Byte(), _
ByVal As ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ASSOCIATE_REQUEST(
byte ,
byte ,
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO ,
byte[] ,
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ASSOCIATE_REQUEST(
char ,
char ,
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO ,
array<char>^ ,
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ASSOCIATE_REQUEST(
byte ,
byte ,
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO ,
byte[] ,
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ASSOCIATE_REQUEST(
: Byte,
: Byte,
: ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO,
: Byte[],
: ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL,
: ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_REQUEST Constructor Overload List


Fields

ZMAC_ASSOCIATE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInformation | Bit map which specifies the operational capabilities of the device
Public field | ChannelPage | The channel page that the device will associate
Public field | CoordAddress | Address of the Coordinator
Public field | CoordAddressMode | Specifies the format of the coordinator device address
Public field | CoordPanID | PAN ID of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | The channel that the device will associate
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


CapabilityInformation Field

ZMAC_ASSOCIATE_REQUEST.CapabilityInformation Field
[image]

Bit map which specifies the operational capabilities of the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInformation As ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO
C#
public ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO CapabilityInformation;
C++
public:
ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO CapabilityInformation sealed ;
J#
public ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO CapabilityInformation
JScript
public CapabilityInformation : ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


ChannelPage Field

ZMAC_ASSOCIATE_REQUEST.ChannelPage Field
[image]

The channel page that the device will associate

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


CoordAddress Field

ZMAC_ASSOCIATE_REQUEST.CoordAddress Field
[image]

Address of the Coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddress As UInt64
C#
public ulong CoordAddress;
C++
public:
unsigned __int64 CoordAddress sealed ;
J#
public ulong CoordAddress
JScript
public CoordAddress : UInt64;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


CoordAddressMode Field

ZMAC_ASSOCIATE_REQUEST.CoordAddressMode Field
[image]

Specifies the format of the coordinator device address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddressMode As ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE
C#
public ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE CoordAddressMode;
C++
public:
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE CoordAddressMode sealed ;
J#
public ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE CoordAddressMode
JScript
public CoordAddressMode : ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


CoordPanID Field

ZMAC_ASSOCIATE_REQUEST.CoordPanID Field
[image]

PAN ID of the coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordPanID As UInt16
C#
public ushort CoordPanID;
C++
public:
unsigned short CoordPanID sealed ;
J#
public ushort CoordPanID
JScript
public CoordPanID : UInt16;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


KeyIdMode Field

ZMAC_ASSOCIATE_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE
C#
public ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


KeyIndex Field

ZMAC_ASSOCIATE_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


KeySource Field

ZMAC_ASSOCIATE_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


LogicalChannel Field

ZMAC_ASSOCIATE_REQUEST.LogicalChannel Field
[image]

The channel that the device will associate

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


SecurityLevel Field

ZMAC_ASSOCIATE_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL
C#
public ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE Enumeration

ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO Enumeration

ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO byte
JScript
public enum ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE Enumeration

ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND Class

ZMAC_ASSOCIATE_RESPOND Class
See Also Example Members
[image]

This command is used to send (on behalf of the next higher layer) an association response message

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_RESPOND
Implements IREQUEST, IZMAC
C#
public class ZMAC_ASSOCIATE_RESPOND : IREQUEST, IZMAC
C++
ref class ZMAC_ASSOCIATE_RESPOND : IREQUEST, IZMAC
J#
public class ZMAC_ASSOCIATE_RESPOND implements IREQUEST, IZMAC
JScript
public class ZMAC_ASSOCIATE_RESPOND extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_RESPOND Members
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND Members

ZMAC_ASSOCIATE_RESPOND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send (on behalf of the next higher layer) an association response message

The following tables list the members exposed by ZMAC_ASSOCIATE_RESPOND.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_RESPOND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocShortAddress | The short address allocated to the device
Public field | DeviceExtendedAddress | Extended Address of the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Indicates success or failure
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_RESPOND | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND Constructor

ZMAC_ASSOCIATE_RESPOND Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_RESPOND | Constructor
Public method | ZMAC_ASSOCIATE_RESPOND (UInt64, UInt16, ZMAC_ASSOCIATE_RESPOND.CMD_STATUS, Byte, ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL, ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE, Byte) |

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND Constructor ()

ZMAC_ASSOCIATE_RESPOND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_RESPOND()
C++
public:
ZMAC_ASSOCIATE_RESPOND() sealed
J#
public ZMAC_ASSOCIATE_RESPOND()
JScript
public function ZMAC_ASSOCIATE_RESPOND()

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_RESPOND Constructor Overload List


ZMAC_ASSOCIATE_RESPOND Constructor (UInt64, UInt16, ZMAC_ASSOCIATE_RESPOND.CMD_STATUS, Byte[], ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL, ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE, Byte)

ZMAC_ASSOCIATE_RESPOND Constructor (UInt64, UInt16, ZMAC_ASSOCIATE_RESPOND.CMD_STATUS, Byte[], ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL, ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As ZMAC_ASSOCIATE_RESPOND.CMD_STATUS, _
ByVal As Byte(), _
ByVal As ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL, _
ByVal As ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ASSOCIATE_RESPOND(
ulong ,
ushort ,
ZMAC_ASSOCIATE_RESPOND.CMD_STATUS ,
byte[] ,
ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ASSOCIATE_RESPOND(
unsigned __int64 ,
unsigned short ,
ZMAC_ASSOCIATE_RESPOND.CMD_STATUS ,
array<char>^ ,
ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ASSOCIATE_RESPOND(
ulong ,
ushort ,
ZMAC_ASSOCIATE_RESPOND.CMD_STATUS ,
byte[] ,
ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ASSOCIATE_RESPOND(
: UInt64,
: UInt16,
: ZMAC_ASSOCIATE_RESPOND.CMD_STATUS,
: Byte[],
: ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL,
: ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_RESPOND Constructor Overload List


Fields

ZMAC_ASSOCIATE_RESPOND Fields
[image]

Public Fields

 | Name | Description
Public field | AssocShortAddress | The short address allocated to the device
Public field | DeviceExtendedAddress | Extended Address of the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Indicates success or failure
Top

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


AssocShortAddress Field

ZMAC_ASSOCIATE_RESPOND.AssocShortAddress Field
[image]

The short address allocated to the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocShortAddress As UInt16
C#
public ushort AssocShortAddress;
C++
public:
unsigned short AssocShortAddress sealed ;
J#
public ushort AssocShortAddress
JScript
public AssocShortAddress : UInt16;

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


DeviceExtendedAddress Field

ZMAC_ASSOCIATE_RESPOND.DeviceExtendedAddress Field
[image]

Extended Address of the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceExtendedAddress As UInt64
C#
public ulong DeviceExtendedAddress;
C++
public:
unsigned __int64 DeviceExtendedAddress sealed ;
J#
public ulong DeviceExtendedAddress
JScript
public DeviceExtendedAddress : UInt64;

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


KeyIdMode Field

ZMAC_ASSOCIATE_RESPOND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE
C#
public ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE;

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


KeyIndex Field

ZMAC_ASSOCIATE_RESPOND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


KeySource Field

ZMAC_ASSOCIATE_RESPOND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


SecurityLevel Field

ZMAC_ASSOCIATE_RESPOND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL
C#
public ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL;

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


Status Field

ZMAC_ASSOCIATE_RESPOND.Status Field
[image]

Indicates success or failure

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ASSOCIATE_RESPOND.CMD_STATUS
C#
public ZMAC_ASSOCIATE_RESPOND.CMD_STATUS Status;
C++
public:
ZMAC_ASSOCIATE_RESPOND.CMD_STATUS Status sealed ;
J#
public ZMAC_ASSOCIATE_RESPOND.CMD_STATUS Status
JScript
public Status : ZMAC_ASSOCIATE_RESPOND.CMD_STATUS;

See Also

ZMAC_ASSOCIATE_RESPOND Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND.CMD_STATUS Enumeration

ZMAC_ASSOCIATE_RESPOND.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RESPOND.CMD_STATUS As Byte
C#
public enum ZMAC_ASSOCIATE_RESPOND.CMD_STATUS : byte
C++
public enum class ZMAC_ASSOCIATE_RESPOND.CMD_STATUS : char
J#
public enum ZMAC_ASSOCIATE_RESPOND.CMD_STATUS byte
JScript
public enum ZMAC_ASSOCIATE_RESPOND.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE Enumeration

ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE : char
J#
public enum ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE byte
JScript
public enum ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL Enumeration

ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL : char
J#
public enum ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL byte
JScript
public enum ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND_RESPONSE Class

ZMAC_ASSOCIATE_RESPOND_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_ASSOCIATE_RESPOND

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_RESPOND_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ASSOCIATE_RESPOND_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_ASSOCIATE_RESPOND_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_ASSOCIATE_RESPOND_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_ASSOCIATE_RESPOND_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_RESPOND_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND_RESPONSE Members

ZMAC_ASSOCIATE_RESPOND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_ASSOCIATE_RESPOND

The following tables list the members exposed by ZMAC_ASSOCIATE_RESPOND_RESPONSE.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_RESPOND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_RESPOND_RESPONSE | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor

ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_RESPOND_RESPONSE | Constructor
Public method | ZMAC_ASSOCIATE_RESPOND_RESPONSE (ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS) |

See Also

ZMAC_ASSOCIATE_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor ()

ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_RESPOND_RESPONSE()
C++
public:
ZMAC_ASSOCIATE_RESPOND_RESPONSE() sealed
J#
public ZMAC_ASSOCIATE_RESPOND_RESPONSE()
JScript
public function ZMAC_ASSOCIATE_RESPOND_RESPONSE()

See Also

ZMAC_ASSOCIATE_RESPOND_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor Overload List


ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor (ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS)

ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor (ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_ASSOCIATE_RESPOND_RESPONSE(
ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_ASSOCIATE_RESPOND_RESPONSE(
ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_ASSOCIATE_RESPOND_RESPONSE(
ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_ASSOCIATE_RESPOND_RESPONSE(
: ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS
)

See Also

ZMAC_ASSOCIATE_RESPOND_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_RESPOND_RESPONSE Constructor Overload List


Fields

ZMAC_ASSOCIATE_RESPOND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_ASSOCIATE_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_ASSOCIATE_RESPOND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS
C#
public ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS;

See Also

ZMAC_ASSOCIATE_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS Enumeration

ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPONSE Class

ZMAC_ASSOCIATE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_ASSOCIATE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ASSOCIATE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_ASSOCIATE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_ASSOCIATE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_ASSOCIATE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_ASSOCIATE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPONSE Members

ZMAC_ASSOCIATE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_ASSOCIATE_REQUEST

The following tables list the members exposed by ZMAC_ASSOCIATE_RESPONSE.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_RESPONSE | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPONSE Constructor

ZMAC_ASSOCIATE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_RESPONSE | Constructor
Public method | ZMAC_ASSOCIATE_RESPONSE (ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPONSE Constructor ()

ZMAC_ASSOCIATE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_RESPONSE()
C++
public:
ZMAC_ASSOCIATE_RESPONSE() sealed
J#
public ZMAC_ASSOCIATE_RESPONSE()
JScript
public function ZMAC_ASSOCIATE_RESPONSE()

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_RESPONSE Constructor Overload List


ZMAC_ASSOCIATE_RESPONSE Constructor (ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS)

ZMAC_ASSOCIATE_RESPONSE Constructor (ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_ASSOCIATE_RESPONSE(
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_ASSOCIATE_RESPONSE(
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_ASSOCIATE_RESPONSE(
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_ASSOCIATE_RESPONSE(
: ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_ASSOCIATE_RESPONSE Constructor Overload List


Fields

ZMAC_ASSOCIATE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_ASSOCIATE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
C#
public ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS;

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Enumeration

ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_DATA_REQUEST Class

ZMAC_DATA_REQUEST Class
See Also Example Members
[image]

This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DATA_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_DATA_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_DATA_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_DATA_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_DATA_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DATA_REQUEST Members
TI.ZPI1 Namespace


ZMAC_DATA_REQUEST Members

ZMAC_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.

The following tables list the members exposed by ZMAC_DATA_REQUEST.

Public Constructors

Name | Description
ZMAC_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | Address of the destination.
Public field | DestAddressMode | Specifies the format of the destination address.
Public field | DestPanID | PAN ID of the destination.
Public field | Handle | Handle of the packet.
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Channel that data frame will be transmitted
Public field | MSDU | Dynamic array, requires memory allocation. Actual data
Public field | MSDULength | Length of the data
Public field | Power | Power level that data frame will be transmitted
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddressMode | Specifies the format of the source address.
Public field | TxOption | Transmitting options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DATA_REQUEST | Overloaded.
Top

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


ZMAC_DATA_REQUEST Constructor

ZMAC_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_DATA_REQUEST | Constructor
Public method | ZMAC_DATA_REQUEST (ZMAC_DATA_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DATA_REQUEST.ADDRESS_MODE, Byte, ZMAC_DATA_REQUEST.TX_OPT, Byte, Byte, Byte, ZMAC_DATA_REQUEST.SECURITY_LEVEL, ZMAC_DATA_REQUEST.KEY_ID_MODE, Byte, Byte, Byte) |

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


ZMAC_DATA_REQUEST Constructor ()

ZMAC_DATA_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DATA_REQUEST()
C++
public:
ZMAC_DATA_REQUEST() sealed
J#
public ZMAC_DATA_REQUEST()
JScript
public function ZMAC_DATA_REQUEST()

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace
ZMAC_DATA_REQUEST Constructor Overload List


ZMAC_DATA_REQUEST Constructor (ZMAC_DATA_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DATA_REQUEST.ADDRESS_MODE, Byte, ZMAC_DATA_REQUEST.TX_OPT, Byte, Byte, Byte[], ZMAC_DATA_REQUEST.SECURITY_LEVEL, ZMAC_DATA_REQUEST.KEY_ID_MODE, Byte, Byte, Byte[])

ZMAC_DATA_REQUEST Constructor (ZMAC_DATA_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DATA_REQUEST.ADDRESS_MODE, Byte, ZMAC_DATA_REQUEST.TX_OPT, Byte, Byte, Byte[], ZMAC_DATA_REQUEST.SECURITY_LEVEL, ZMAC_DATA_REQUEST.KEY_ID_MODE, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DATA_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As ZMAC_DATA_REQUEST.ADDRESS_MODE, _
ByVal As Byte, _
ByVal As ZMAC_DATA_REQUEST.TX_OPT, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_DATA_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_DATA_REQUEST.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZMAC_DATA_REQUEST(
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
byte ,
ZMAC_DATA_REQUEST.TX_OPT ,
byte ,
byte ,
byte[] ,
ZMAC_DATA_REQUEST.SECURITY_LEVEL ,
ZMAC_DATA_REQUEST.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
C++
public:
ZMAC_DATA_REQUEST(
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
char ,
ZMAC_DATA_REQUEST.TX_OPT ,
char ,
char ,
array<char>^ ,
ZMAC_DATA_REQUEST.SECURITY_LEVEL ,
ZMAC_DATA_REQUEST.KEY_ID_MODE ,
char ,
char ,
array<char>^
) sealed
J#
public ZMAC_DATA_REQUEST(
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
byte ,
ZMAC_DATA_REQUEST.TX_OPT ,
byte ,
byte ,
byte[] ,
ZMAC_DATA_REQUEST.SECURITY_LEVEL ,
ZMAC_DATA_REQUEST.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
JScript
public function ZMAC_DATA_REQUEST(
: ZMAC_DATA_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: ZMAC_DATA_REQUEST.ADDRESS_MODE,
: Byte,
: ZMAC_DATA_REQUEST.TX_OPT,
: Byte,
: Byte,
: Byte[],
: ZMAC_DATA_REQUEST.SECURITY_LEVEL,
: ZMAC_DATA_REQUEST.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[]
)

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace
ZMAC_DATA_REQUEST Constructor Overload List


Fields

ZMAC_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | Address of the destination.
Public field | DestAddressMode | Specifies the format of the destination address.
Public field | DestPanID | PAN ID of the destination.
Public field | Handle | Handle of the packet.
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Channel that data frame will be transmitted
Public field | MSDU | Dynamic array, requires memory allocation. Actual data
Public field | MSDULength | Length of the data
Public field | Power | Power level that data frame will be transmitted
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddressMode | Specifies the format of the source address.
Public field | TxOption | Transmitting options
Top

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


DestAddress Field

ZMAC_DATA_REQUEST.DestAddress Field
[image]

Address of the destination.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


DestAddressMode Field

ZMAC_DATA_REQUEST.DestAddressMode Field
[image]

Specifies the format of the destination address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressMode As ZMAC_DATA_REQUEST.ADDRESS_MODE
C#
public ZMAC_DATA_REQUEST.ADDRESS_MODE DestAddressMode;
C++
public:
ZMAC_DATA_REQUEST.ADDRESS_MODE DestAddressMode sealed ;
J#
public ZMAC_DATA_REQUEST.ADDRESS_MODE DestAddressMode
JScript
public DestAddressMode : ZMAC_DATA_REQUEST.ADDRESS_MODE;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


DestPanID Field

ZMAC_DATA_REQUEST.DestPanID Field
[image]

PAN ID of the destination.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestPanID As UInt16
C#
public ushort DestPanID;
C++
public:
unsigned short DestPanID sealed ;
J#
public ushort DestPanID
JScript
public DestPanID : UInt16;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


Handle Field

ZMAC_DATA_REQUEST.Handle Field
[image]

Handle of the packet.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


KeyIdMode Field

ZMAC_DATA_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_DATA_REQUEST.KEY_ID_MODE
C#
public ZMAC_DATA_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_DATA_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_DATA_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_DATA_REQUEST.KEY_ID_MODE;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


KeyIndex Field

ZMAC_DATA_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


KeySource Field

ZMAC_DATA_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


LogicalChannel Field

ZMAC_DATA_REQUEST.LogicalChannel Field
[image]

Channel that data frame will be transmitted

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


MSDU Field

ZMAC_DATA_REQUEST.MSDU Field
[image]

Dynamic array, requires memory allocation. Actual data

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDU As Byte()
C#
public byte[] MSDU;
C++
public:
array<char>^ MSDU sealed ;
J#
public byte[] MSDU
JScript
public MSDU : Byte[];

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


MSDULength Field

ZMAC_DATA_REQUEST.MSDULength Field
[image]

Length of the data

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDULength As Byte
C#
public byte MSDULength;
C++
public:
char MSDULength sealed ;
J#
public byte MSDULength
JScript
public MSDULength : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


Power Field

ZMAC_DATA_REQUEST.Power Field
[image]

Power level that data frame will be transmitted

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Power As Byte
C#
public byte Power;
C++
public:
char Power sealed ;
J#
public byte Power
JScript
public Power : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


SecurityLevel Field

ZMAC_DATA_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_DATA_REQUEST.SECURITY_LEVEL
C#
public ZMAC_DATA_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_DATA_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_DATA_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_DATA_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


SrcAddressMode Field

ZMAC_DATA_REQUEST.SrcAddressMode Field
[image]

Specifies the format of the source address.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddressMode As ZMAC_DATA_REQUEST.ADDRESS_MODE
C#
public ZMAC_DATA_REQUEST.ADDRESS_MODE SrcAddressMode;
C++
public:
ZMAC_DATA_REQUEST.ADDRESS_MODE SrcAddressMode sealed ;
J#
public ZMAC_DATA_REQUEST.ADDRESS_MODE SrcAddressMode
JScript
public SrcAddressMode : ZMAC_DATA_REQUEST.ADDRESS_MODE;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


TxOption Field

ZMAC_DATA_REQUEST.TxOption Field
[image]

Transmitting options

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxOption As ZMAC_DATA_REQUEST.TX_OPT
C#
public ZMAC_DATA_REQUEST.TX_OPT TxOption;
C++
public:
ZMAC_DATA_REQUEST.TX_OPT TxOption sealed ;
J#
public ZMAC_DATA_REQUEST.TX_OPT TxOption
JScript
public TxOption : ZMAC_DATA_REQUEST.TX_OPT;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI1 Namespace


ZMAC_DATA_REQUEST.ADDRESS_MODE Enumeration

ZMAC_DATA_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_DATA_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_DATA_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_DATA_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_DATA_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZMAC_DATA_REQUEST.KEY_ID_MODE Enumeration

ZMAC_DATA_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_DATA_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_DATA_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_DATA_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_DATA_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_DATA_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_DATA_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_DATA_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_DATA_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_DATA_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_DATA_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_DATA_REQUEST.TX_OPT Enumeration

ZMAC_DATA_REQUEST.TX_OPT Enumeration
[image]

Transmission options bitfield

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.TX_OPT As Byte
C#
public enum ZMAC_DATA_REQUEST.TX_OPT : byte
C++
public enum class ZMAC_DATA_REQUEST.TX_OPT : char
J#
public enum ZMAC_DATA_REQUEST.TX_OPT byte
JScript
public enum ZMAC_DATA_REQUEST.TX_OPT :

Members

Member Name | Description
ACK_TRANS | Transmission options bitfield
GTS_TRANS | Transmission options bitfield
IND_TRANS | Transmission options bitfield
SEC_ENABLED_TRANS | Transmission options bitfield
NO_RE_TRANS | Transmission options bitfield
NO_CONFIRM_TRANS | Transmission options bitfield
USE_PIB_VALUE | Transmission options bitfield

See Also

TI.ZPI1 Namespace


ZMAC_DATA_RESPONSE Class

ZMAC_DATA_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_DATA_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DATA_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DATA_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_DATA_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_DATA_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_DATA_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_DATA_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DATA_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_DATA_RESPONSE Members

ZMAC_DATA_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_DATA_REQUEST

The following tables list the members exposed by ZMAC_DATA_RESPONSE.

Public Constructors

Name | Description
ZMAC_DATA_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DATA_RESPONSE | Overloaded.
Top

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_DATA_RESPONSE Constructor

ZMAC_DATA_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_DATA_RESPONSE | Constructor
Public method | ZMAC_DATA_RESPONSE (ZMAC_DATA_RESPONSE.CMD_STATUS) |

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_DATA_RESPONSE Constructor ()

ZMAC_DATA_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DATA_RESPONSE()
C++
public:
ZMAC_DATA_RESPONSE() sealed
J#
public ZMAC_DATA_RESPONSE()
JScript
public function ZMAC_DATA_RESPONSE()

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_DATA_RESPONSE Constructor Overload List


ZMAC_DATA_RESPONSE Constructor (ZMAC_DATA_RESPONSE.CMD_STATUS)

ZMAC_DATA_RESPONSE Constructor (ZMAC_DATA_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DATA_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_DATA_RESPONSE(
ZMAC_DATA_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_DATA_RESPONSE(
ZMAC_DATA_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_DATA_RESPONSE(
ZMAC_DATA_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_DATA_RESPONSE(
: ZMAC_DATA_RESPONSE.CMD_STATUS
)

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_DATA_RESPONSE Constructor Overload List


Fields

ZMAC_DATA_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_DATA_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_DATA_RESPONSE.CMD_STATUS
C#
public ZMAC_DATA_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_DATA_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_DATA_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_DATA_RESPONSE.CMD_STATUS;

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_DATA_RESPONSE.CMD_STATUS Enumeration

ZMAC_DATA_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_DATA_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_DATA_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_DATA_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_DATA_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST Class

ZMAC_DISASSOCIATE_REQUEST Class
See Also Example Members
[image]

This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DISASSOCIATE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_DISASSOCIATE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_DISASSOCIATE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_DISASSOCIATE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_DISASSOCIATE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DISASSOCIATE_REQUEST Members
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST Members

ZMAC_DISASSOCIATE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.

The following tables list the members exposed by ZMAC_DISASSOCIATE_REQUEST.

Public Constructors

Name | Description
ZMAC_DISASSOCIATE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | Device Address
Public field | DeviceAddressMode | Specifies the format of the device address
Public field | DevicePanID | Network PAN ID of device
Public field | DisassociateReason | Reason of disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | TxIndirect | Tx indirect
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DISASSOCIATE_REQUEST | Overloaded.
Top

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST Constructor

ZMAC_DISASSOCIATE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_DISASSOCIATE_REQUEST | Constructor
Public method | ZMAC_DISASSOCIATE_REQUEST (ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, Byte, Byte, ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST Constructor ()

ZMAC_DISASSOCIATE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DISASSOCIATE_REQUEST()
C++
public:
ZMAC_DISASSOCIATE_REQUEST() sealed
J#
public ZMAC_DISASSOCIATE_REQUEST()
JScript
public function ZMAC_DISASSOCIATE_REQUEST()

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_DISASSOCIATE_REQUEST Constructor Overload List


ZMAC_DISASSOCIATE_REQUEST Constructor (ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, Byte, Byte[], ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, Byte)

ZMAC_DISASSOCIATE_REQUEST Constructor (ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, Byte, Byte[], ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_DISASSOCIATE_REQUEST(
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON ,
byte ,
byte[] ,
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_DISASSOCIATE_REQUEST(
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON ,
char ,
array<char>^ ,
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_DISASSOCIATE_REQUEST(
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON ,
byte ,
byte[] ,
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_DISASSOCIATE_REQUEST(
: ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON,
: Byte,
: Byte[],
: ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL,
: ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_DISASSOCIATE_REQUEST Constructor Overload List


Fields

ZMAC_DISASSOCIATE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | Device Address
Public field | DeviceAddressMode | Specifies the format of the device address
Public field | DevicePanID | Network PAN ID of device
Public field | DisassociateReason | Reason of disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | TxIndirect | Tx indirect
Top

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


DeviceAddress Field

ZMAC_DISASSOCIATE_REQUEST.DeviceAddress Field
[image]

Device Address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


DeviceAddressMode Field

ZMAC_DISASSOCIATE_REQUEST.DeviceAddressMode Field
[image]

Specifies the format of the device address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddressMode As ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE
C#
public ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE DeviceAddressMode;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE DeviceAddressMode sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE DeviceAddressMode
JScript
public DeviceAddressMode : ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


DevicePanID Field

ZMAC_DISASSOCIATE_REQUEST.DevicePanID Field
[image]

Network PAN ID of device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DevicePanID As UInt16
C#
public ushort DevicePanID;
C++
public:
unsigned short DevicePanID sealed ;
J#
public ushort DevicePanID
JScript
public DevicePanID : UInt16;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


DisassociateReason Field

ZMAC_DISASSOCIATE_REQUEST.DisassociateReason Field
[image]

Reason of disassociation

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DisassociateReason As ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON
C#
public ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON DisassociateReason;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON DisassociateReason sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON DisassociateReason
JScript
public DisassociateReason : ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


KeyIdMode Field

ZMAC_DISASSOCIATE_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE
C#
public ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


KeyIndex Field

ZMAC_DISASSOCIATE_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


KeySource Field

ZMAC_DISASSOCIATE_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


SecurityLevel Field

ZMAC_DISASSOCIATE_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL
C#
public ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


TxIndirect Field

ZMAC_DISASSOCIATE_REQUEST.TxIndirect Field
[image]

Tx indirect

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxIndirect As Byte
C#
public byte TxIndirect;
C++
public:
char TxIndirect sealed ;
J#
public byte TxIndirect
JScript
public TxIndirect : Byte;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE Enumeration

ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON Enumeration

ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON Enumeration
[image]

Valid disassociation reason codes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON :

Members

Member Name | Description
RESERVED | Valid disassociation reason codes
COOR_WISHES_DEV_LEAVE | Valid disassociation reason codes
DEV_WISHES_LEAVE | Valid disassociation reason codes

See Also

TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE Enumeration

ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_RESPONSE Class

ZMAC_DISASSOCIATE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_DISASSOCIATE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DISASSOCIATE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DISASSOCIATE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_DISASSOCIATE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_DISASSOCIATE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_DISASSOCIATE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_DISASSOCIATE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DISASSOCIATE_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_RESPONSE Members

ZMAC_DISASSOCIATE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_DISASSOCIATE_REQUEST

The following tables list the members exposed by ZMAC_DISASSOCIATE_RESPONSE.

Public Constructors

Name | Description
ZMAC_DISASSOCIATE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DISASSOCIATE_RESPONSE | Overloaded.
Top

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_RESPONSE Constructor

ZMAC_DISASSOCIATE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_DISASSOCIATE_RESPONSE | Constructor
Public method | ZMAC_DISASSOCIATE_RESPONSE (ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_RESPONSE Constructor ()

ZMAC_DISASSOCIATE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DISASSOCIATE_RESPONSE()
C++
public:
ZMAC_DISASSOCIATE_RESPONSE() sealed
J#
public ZMAC_DISASSOCIATE_RESPONSE()
JScript
public function ZMAC_DISASSOCIATE_RESPONSE()

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_DISASSOCIATE_RESPONSE Constructor Overload List


ZMAC_DISASSOCIATE_RESPONSE Constructor (ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS)

ZMAC_DISASSOCIATE_RESPONSE Constructor (ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_DISASSOCIATE_RESPONSE(
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_DISASSOCIATE_RESPONSE(
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_DISASSOCIATE_RESPONSE(
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_DISASSOCIATE_RESPONSE(
: ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_DISASSOCIATE_RESPONSE Constructor Overload List


Fields

ZMAC_DISASSOCIATE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_DISASSOCIATE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
C#
public ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS;

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Enumeration

ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_GET_REQUEST Class

ZMAC_GET_REQUEST Class
See Also Example Members
[image]

This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_GET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_GET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_GET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_GET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_GET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_GET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_GET_REQUEST Members
TI.ZPI1 Namespace


ZMAC_GET_REQUEST Members

ZMAC_GET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.

The following tables list the members exposed by ZMAC_GET_REQUEST.

Public Constructors

Name | Description
ZMAC_GET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_GET_REQUEST | Overloaded.
Top

See Also

ZMAC_GET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_GET_REQUEST Constructor

ZMAC_GET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_GET_REQUEST | Constructor
Public method | ZMAC_GET_REQUEST (ZMAC_GET_REQUEST.MAC_PID_ATTR) |

See Also

ZMAC_GET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_GET_REQUEST Constructor ()

ZMAC_GET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_GET_REQUEST()
C++
public:
ZMAC_GET_REQUEST() sealed
J#
public ZMAC_GET_REQUEST()
JScript
public function ZMAC_GET_REQUEST()

See Also

ZMAC_GET_REQUEST Class
TI.ZPI1 Namespace
ZMAC_GET_REQUEST Constructor Overload List


ZMAC_GET_REQUEST Constructor (ZMAC_GET_REQUEST.MAC_PID_ATTR)

ZMAC_GET_REQUEST Constructor (ZMAC_GET_REQUEST.MAC_PID_ATTR)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_GET_REQUEST.MAC_PID_ATTR _
)
C#
public ZMAC_GET_REQUEST(
ZMAC_GET_REQUEST.MAC_PID_ATTR
)
C++
public:
ZMAC_GET_REQUEST(
ZMAC_GET_REQUEST.MAC_PID_ATTR
) sealed
J#
public ZMAC_GET_REQUEST(
ZMAC_GET_REQUEST.MAC_PID_ATTR
)
JScript
public function ZMAC_GET_REQUEST(
: ZMAC_GET_REQUEST.MAC_PID_ATTR
)

See Also

ZMAC_GET_REQUEST Class
TI.ZPI1 Namespace
ZMAC_GET_REQUEST Constructor Overload List


Fields

ZMAC_GET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Top

See Also

ZMAC_GET_REQUEST Class
TI.ZPI1 Namespace


Attribute Field

ZMAC_GET_REQUEST.Attribute Field
[image]

Specifies the MAC PID Attributes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As ZMAC_GET_REQUEST.MAC_PID_ATTR
C#
public ZMAC_GET_REQUEST.MAC_PID_ATTR Attribute;
C++
public:
ZMAC_GET_REQUEST.MAC_PID_ATTR Attribute sealed ;
J#
public ZMAC_GET_REQUEST.MAC_PID_ATTR Attribute
JScript
public Attribute : ZMAC_GET_REQUEST.MAC_PID_ATTR;

See Also

ZMAC_GET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_GET_REQUEST.MAC_PID_ATTR Enumeration

ZMAC_GET_REQUEST.MAC_PID_ATTR Enumeration
[image]

MAC PID Attribute

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_GET_REQUEST.MAC_PID_ATTR As Byte
C#
public enum ZMAC_GET_REQUEST.MAC_PID_ATTR : byte
C++
public enum class ZMAC_GET_REQUEST.MAC_PID_ATTR : char
J#
public enum ZMAC_GET_REQUEST.MAC_PID_ATTR byte
JScript
public enum ZMAC_GET_REQUEST.MAC_PID_ATTR :

Members

Member Name | Description
ZMAC_ACK_WAIT_DURATION | MAC PID Attribute
ZMAC_ASSOCIATION_PERMIT | MAC PID Attribute
ZMAC_AUTO_REQUEST | MAC PID Attribute
ZMAC_BATT_LIFE_EXT | MAC PID Attribute
ZMAC_BATT_LEFT_EXT_PERIODS | MAC PID Attribute
ZMAC_BEACON_MSDU | MAC PID Attribute
ZMAC_BEACON_MSDU_LENGTH | MAC PID Attribute
ZMAC_BEACON_ORDER | MAC PID Attribute
ZMAC_BEACON_TX_TIME | MAC PID Attribute
ZMAC_BSN | MAC PID Attribute
ZMAC_COORD_EXTENDED_ADDRESS | MAC PID Attribute
ZMAC_COORD_SHORT_ADDRESS | MAC PID Attribute
ZMAC_DSN | MAC PID Attribute
ZMAC_GTS_PERMIT | MAC PID Attribute
ZMAC_MAX_CSMA_BACKOFFS | MAC PID Attribute
ZMAC_MIN_BE | MAC PID Attribute
ZMAC_PANID | MAC PID Attribute
ZMAC_PROMISCUOUS_MODE | MAC PID Attribute
ZMAC_RX_ON_IDLE | MAC PID Attribute
ZMAC_SUPER_FRAME_ORDER | MAC PID Attribute
ZMAC_TRANSACTION_PERSISTENCE_TIME | MAC PID Attribute
ZMAC_ACL_ENTRY_DESCRIPTOR_SET | MAC PID Attribute
ZMAC_ACL_ENTRY_DESCRIPTOR_SET | MAC PID Attribute
ZMAC_ACL_ENTRY_DESCRIPTOR_SET_SIZE | MAC PID Attribute
ZMAC_DEFAULT_SECURITY | MAC PID Attribute
ZMAC_ACL_DEFAULT_SECURITY_MATERIAL_LENGTH | MAC PID Attribute
ZMAC_ACL_DEFAULT_SECURITY_MATERIAL | MAC PID Attribute
ZMAC_DEFAULT_SECURITY_SUITE | MAC PID Attribute
ZMAC_SECURITY_MODE | MAC PID Attribute
ZMAC_TX_GTS_ID | MAC PID Attribute
ZMAC_UPPER_LAYER_TYPE | MAC PID Attribute
ZMAC_RX_GTS_ID | MAC PID Attribute
ZMAC_SNOOZE_PERMIT | MAC PID Attribute
ZMAC_CHANNEL | MAC PID Attribute
ZMAC_EXT_ADDR | MAC PID Attribute

See Also

TI.ZPI1 Namespace


ZMAC_GET_RESPONSE Class

ZMAC_GET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_GET_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_GET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_GET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_GET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_GET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_GET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_GET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_GET_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_GET_RESPONSE Members

ZMAC_GET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_GET_REQUEST

The following tables list the members exposed by ZMAC_GET_RESPONSE.

Public Constructors

Name | Description
ZMAC_GET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_GET_RESPONSE | Overloaded.
Top

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_GET_RESPONSE Constructor

ZMAC_GET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_GET_RESPONSE | Constructor
Public method | ZMAC_GET_RESPONSE (ZMAC_GET_RESPONSE.CMD_STATUS) |

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_GET_RESPONSE Constructor ()

ZMAC_GET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_GET_RESPONSE()
C++
public:
ZMAC_GET_RESPONSE() sealed
J#
public ZMAC_GET_RESPONSE()
JScript
public function ZMAC_GET_RESPONSE()

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_GET_RESPONSE Constructor Overload List


ZMAC_GET_RESPONSE Constructor (ZMAC_GET_RESPONSE.CMD_STATUS)

ZMAC_GET_RESPONSE Constructor (ZMAC_GET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_GET_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_GET_RESPONSE(
ZMAC_GET_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_GET_RESPONSE(
ZMAC_GET_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_GET_RESPONSE(
ZMAC_GET_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_GET_RESPONSE(
: ZMAC_GET_RESPONSE.CMD_STATUS
)

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_GET_RESPONSE Constructor Overload List


Fields

ZMAC_GET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_GET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_GET_RESPONSE.CMD_STATUS
C#
public ZMAC_GET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_GET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_GET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_GET_RESPONSE.CMD_STATUS;

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_GET_RESPONSE.CMD_STATUS Enumeration

ZMAC_GET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_GET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_GET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_GET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_GET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_GET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_INIT_REQUEST Class

ZMAC_INIT_REQUEST Class
See Also Example Members
[image]

This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_INIT_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_INIT_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_INIT_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_INIT_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_INIT_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_INIT_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_INIT_REQUEST Members
TI.ZPI1 Namespace


ZMAC_INIT_REQUEST Members

ZMAC_INIT_REQUEST Members
See Also Example Constructors Methods
[image]

This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).

The following tables list the members exposed by ZMAC_INIT_REQUEST.

Public Constructors

 | Name | Description
Public method | ZMAC_INIT_REQUEST | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZMAC_INIT_REQUEST Class
TI.ZPI1 Namespace


ZMAC_INIT_REQUEST Constructor

ZMAC_INIT_REQUEST Constructor
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_INIT_REQUEST()
C++
public:
ZMAC_INIT_REQUEST() sealed
J#
public ZMAC_INIT_REQUEST()
JScript
public function ZMAC_INIT_REQUEST()

See Also

ZMAC_INIT_REQUEST Class
TI.ZPI1 Namespace


ZMAC_INIT_RESPONSE Class

ZMAC_INIT_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_INIT_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_INIT_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_INIT_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_INIT_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_INIT_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_INIT_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_INIT_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_INIT_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_INIT_RESPONSE Members

ZMAC_INIT_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_INIT_REQUEST

The following tables list the members exposed by ZMAC_INIT_RESPONSE.

Public Constructors

Name | Description
ZMAC_INIT_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_INIT_RESPONSE | Overloaded.
Top

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_INIT_RESPONSE Constructor

ZMAC_INIT_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_INIT_RESPONSE | Constructor
Public method | ZMAC_INIT_RESPONSE (ZMAC_INIT_RESPONSE.CMD_STATUS) |

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_INIT_RESPONSE Constructor ()

ZMAC_INIT_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_INIT_RESPONSE()
C++
public:
ZMAC_INIT_RESPONSE() sealed
J#
public ZMAC_INIT_RESPONSE()
JScript
public function ZMAC_INIT_RESPONSE()

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_INIT_RESPONSE Constructor Overload List


ZMAC_INIT_RESPONSE Constructor (ZMAC_INIT_RESPONSE.CMD_STATUS)

ZMAC_INIT_RESPONSE Constructor (ZMAC_INIT_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_INIT_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_INIT_RESPONSE(
ZMAC_INIT_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_INIT_RESPONSE(
ZMAC_INIT_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_INIT_RESPONSE(
ZMAC_INIT_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_INIT_RESPONSE(
: ZMAC_INIT_RESPONSE.CMD_STATUS
)

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_INIT_RESPONSE Constructor Overload List


Fields

ZMAC_INIT_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_INIT_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_INIT_RESPONSE.CMD_STATUS
C#
public ZMAC_INIT_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_INIT_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_INIT_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_INIT_RESPONSE.CMD_STATUS;

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_INIT_RESPONSE.CMD_STATUS Enumeration

ZMAC_INIT_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_INIT_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_INIT_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_INIT_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_INIT_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_INIT_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND Class

ZMAC_ORPHAN_RESPOND Class
See Also Example Members
[image]

This command is used to send a response to the Orphan Indication message.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ORPHAN_RESPOND
Implements IREQUEST, IZMAC
C#
public class ZMAC_ORPHAN_RESPOND : IREQUEST, IZMAC
C++
ref class ZMAC_ORPHAN_RESPOND : IREQUEST, IZMAC
J#
public class ZMAC_ORPHAN_RESPOND implements IREQUEST, IZMAC
JScript
public class ZMAC_ORPHAN_RESPOND extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_ORPHAN_RESPOND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ORPHAN_RESPOND Members
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND Members

ZMAC_ORPHAN_RESPOND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a response to the Orphan Indication message.

The following tables list the members exposed by ZMAC_ORPHAN_RESPOND.

Public Constructors

Name | Description
ZMAC_ORPHAN_RESPOND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssociatedMember | TRUE if the orphaned device is associated with this coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | OrphanExtendedAddress | Extended address of the device sending the orphan notification
Public field | OrphanShortAddress | Allocated short address of the orphaned device
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ORPHAN_RESPOND | Overloaded.
Top

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND Constructor

ZMAC_ORPHAN_RESPOND Constructor

Overload List

 | Name | Description
Public method | ZMAC_ORPHAN_RESPOND | Constructor
Public method | ZMAC_ORPHAN_RESPOND (UInt64, UInt16, Byte, Byte, ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL, ZMAC_ORPHAN_RESPOND.KEY_ID_MODE, Byte) |

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND Constructor ()

ZMAC_ORPHAN_RESPOND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ORPHAN_RESPOND()
C++
public:
ZMAC_ORPHAN_RESPOND() sealed
J#
public ZMAC_ORPHAN_RESPOND()
JScript
public function ZMAC_ORPHAN_RESPOND()

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace
ZMAC_ORPHAN_RESPOND Constructor Overload List


ZMAC_ORPHAN_RESPOND Constructor (UInt64, UInt16, Byte, Byte[], ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL, ZMAC_ORPHAN_RESPOND.KEY_ID_MODE, Byte)

ZMAC_ORPHAN_RESPOND Constructor (UInt64, UInt16, Byte, Byte[], ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL, ZMAC_ORPHAN_RESPOND.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL, _
ByVal As ZMAC_ORPHAN_RESPOND.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ORPHAN_RESPOND(
ulong ,
ushort ,
byte ,
byte[] ,
ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL ,
ZMAC_ORPHAN_RESPOND.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ORPHAN_RESPOND(
unsigned __int64 ,
unsigned short ,
char ,
array<char>^ ,
ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL ,
ZMAC_ORPHAN_RESPOND.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ORPHAN_RESPOND(
ulong ,
ushort ,
byte ,
byte[] ,
ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL ,
ZMAC_ORPHAN_RESPOND.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ORPHAN_RESPOND(
: UInt64,
: UInt16,
: Byte,
: Byte[],
: ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL,
: ZMAC_ORPHAN_RESPOND.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace
ZMAC_ORPHAN_RESPOND Constructor Overload List


Fields

ZMAC_ORPHAN_RESPOND Fields
[image]

Public Fields

 | Name | Description
Public field | AssociatedMember | TRUE if the orphaned device is associated with this coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | OrphanExtendedAddress | Extended address of the device sending the orphan notification
Public field | OrphanShortAddress | Allocated short address of the orphaned device
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


AssociatedMember Field

ZMAC_ORPHAN_RESPOND.AssociatedMember Field
[image]

TRUE if the orphaned device is associated with this coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssociatedMember As Byte
C#
public byte AssociatedMember;
C++
public:
char AssociatedMember sealed ;
J#
public byte AssociatedMember
JScript
public AssociatedMember : Byte;

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


KeyIdMode Field

ZMAC_ORPHAN_RESPOND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ORPHAN_RESPOND.KEY_ID_MODE
C#
public ZMAC_ORPHAN_RESPOND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ORPHAN_RESPOND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ORPHAN_RESPOND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ORPHAN_RESPOND.KEY_ID_MODE;

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


KeyIndex Field

ZMAC_ORPHAN_RESPOND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


KeySource Field

ZMAC_ORPHAN_RESPOND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


OrphanExtendedAddress Field

ZMAC_ORPHAN_RESPOND.OrphanExtendedAddress Field
[image]

Extended address of the device sending the orphan notification

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OrphanExtendedAddress As UInt64
C#
public ulong OrphanExtendedAddress;
C++
public:
unsigned __int64 OrphanExtendedAddress sealed ;
J#
public ulong OrphanExtendedAddress
JScript
public OrphanExtendedAddress : UInt64;

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


OrphanShortAddress Field

ZMAC_ORPHAN_RESPOND.OrphanShortAddress Field
[image]

Allocated short address of the orphaned device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OrphanShortAddress As UInt16
C#
public ushort OrphanShortAddress;
C++
public:
unsigned short OrphanShortAddress sealed ;
J#
public ushort OrphanShortAddress
JScript
public OrphanShortAddress : UInt16;

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


SecurityLevel Field

ZMAC_ORPHAN_RESPOND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL
C#
public ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL;

See Also

ZMAC_ORPHAN_RESPOND Class
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND.KEY_ID_MODE Enumeration

ZMAC_ORPHAN_RESPOND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_RESPOND.KEY_ID_MODE As Byte
C#
public enum ZMAC_ORPHAN_RESPOND.KEY_ID_MODE : byte
C++
public enum class ZMAC_ORPHAN_RESPOND.KEY_ID_MODE : char
J#
public enum ZMAC_ORPHAN_RESPOND.KEY_ID_MODE byte
JScript
public enum ZMAC_ORPHAN_RESPOND.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL Enumeration

ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL : char
J#
public enum ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL byte
JScript
public enum ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND_RESPONSE Class

ZMAC_ORPHAN_RESPOND_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_ORPHAN_RESPOND

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ORPHAN_RESPOND_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ORPHAN_RESPOND_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_ORPHAN_RESPOND_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_ORPHAN_RESPOND_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_ORPHAN_RESPOND_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_ORPHAN_RESPOND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ORPHAN_RESPOND_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND_RESPONSE Members

ZMAC_ORPHAN_RESPOND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_ORPHAN_RESPOND

The following tables list the members exposed by ZMAC_ORPHAN_RESPOND_RESPONSE.

Public Constructors

Name | Description
ZMAC_ORPHAN_RESPOND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ORPHAN_RESPOND_RESPONSE | Overloaded.
Top

See Also

ZMAC_ORPHAN_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND_RESPONSE Constructor

ZMAC_ORPHAN_RESPOND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_ORPHAN_RESPOND_RESPONSE | Constructor
Public method | ZMAC_ORPHAN_RESPOND_RESPONSE (ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS) |

See Also

ZMAC_ORPHAN_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND_RESPONSE Constructor ()

ZMAC_ORPHAN_RESPOND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ORPHAN_RESPOND_RESPONSE()
C++
public:
ZMAC_ORPHAN_RESPOND_RESPONSE() sealed
J#
public ZMAC_ORPHAN_RESPOND_RESPONSE()
JScript
public function ZMAC_ORPHAN_RESPOND_RESPONSE()

See Also

ZMAC_ORPHAN_RESPOND_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_ORPHAN_RESPOND_RESPONSE Constructor Overload List


ZMAC_ORPHAN_RESPOND_RESPONSE Constructor (ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS)

ZMAC_ORPHAN_RESPOND_RESPONSE Constructor (ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_ORPHAN_RESPOND_RESPONSE(
ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_ORPHAN_RESPOND_RESPONSE(
ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_ORPHAN_RESPOND_RESPONSE(
ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_ORPHAN_RESPOND_RESPONSE(
: ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS
)

See Also

ZMAC_ORPHAN_RESPOND_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_ORPHAN_RESPOND_RESPONSE Constructor Overload List


Fields

ZMAC_ORPHAN_RESPOND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_ORPHAN_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_ORPHAN_RESPOND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS
C#
public ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS;

See Also

ZMAC_ORPHAN_RESPOND_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS Enumeration

ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_POLL_REQUEST Class

ZMAC_POLL_REQUEST Class
See Also Example Members
[image]

This command is used to send a MAC data request poll

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_POLL_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_POLL_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_POLL_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_POLL_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_POLL_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_POLL_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_POLL_REQUEST Members
TI.ZPI1 Namespace


ZMAC_POLL_REQUEST Members

ZMAC_POLL_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a MAC data request poll

The following tables list the members exposed by ZMAC_POLL_REQUEST.

Public Constructors

Name | Description
ZMAC_POLL_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CoordAddress | Coordinator Address
Public field | CoordAddressMode | Specified the format of the coordinator address
Public field | CoordPanID | PAN Id of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_POLL_REQUEST | Overloaded.
Top

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


ZMAC_POLL_REQUEST Constructor

ZMAC_POLL_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_POLL_REQUEST | Constructor
Public method | ZMAC_POLL_REQUEST (ZMAC_POLL_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte, ZMAC_POLL_REQUEST.SECURITY_LEVEL, ZMAC_POLL_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


ZMAC_POLL_REQUEST Constructor ()

ZMAC_POLL_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_POLL_REQUEST()
C++
public:
ZMAC_POLL_REQUEST() sealed
J#
public ZMAC_POLL_REQUEST()
JScript
public function ZMAC_POLL_REQUEST()

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace
ZMAC_POLL_REQUEST Constructor Overload List


ZMAC_POLL_REQUEST Constructor (ZMAC_POLL_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte[], ZMAC_POLL_REQUEST.SECURITY_LEVEL, ZMAC_POLL_REQUEST.KEY_ID_MODE, Byte)

ZMAC_POLL_REQUEST Constructor (ZMAC_POLL_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte[], ZMAC_POLL_REQUEST.SECURITY_LEVEL, ZMAC_POLL_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_POLL_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte(), _
ByVal As ZMAC_POLL_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_POLL_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_POLL_REQUEST(
ZMAC_POLL_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
byte[] ,
ZMAC_POLL_REQUEST.SECURITY_LEVEL ,
ZMAC_POLL_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_POLL_REQUEST(
ZMAC_POLL_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
array<char>^ ,
ZMAC_POLL_REQUEST.SECURITY_LEVEL ,
ZMAC_POLL_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_POLL_REQUEST(
ZMAC_POLL_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
byte[] ,
ZMAC_POLL_REQUEST.SECURITY_LEVEL ,
ZMAC_POLL_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_POLL_REQUEST(
: ZMAC_POLL_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: Byte[],
: ZMAC_POLL_REQUEST.SECURITY_LEVEL,
: ZMAC_POLL_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace
ZMAC_POLL_REQUEST Constructor Overload List


Fields

ZMAC_POLL_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CoordAddress | Coordinator Address
Public field | CoordAddressMode | Specified the format of the coordinator address
Public field | CoordPanID | PAN Id of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


CoordAddress Field

ZMAC_POLL_REQUEST.CoordAddress Field
[image]

Coordinator Address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddress As UInt64
C#
public ulong CoordAddress;
C++
public:
unsigned __int64 CoordAddress sealed ;
J#
public ulong CoordAddress
JScript
public CoordAddress : UInt64;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


CoordAddressMode Field

ZMAC_POLL_REQUEST.CoordAddressMode Field
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddressMode As ZMAC_POLL_REQUEST.ADDRESS_MODE
C#
public ZMAC_POLL_REQUEST.ADDRESS_MODE CoordAddressMode;
C++
public:
ZMAC_POLL_REQUEST.ADDRESS_MODE CoordAddressMode sealed ;
J#
public ZMAC_POLL_REQUEST.ADDRESS_MODE CoordAddressMode
JScript
public CoordAddressMode : ZMAC_POLL_REQUEST.ADDRESS_MODE;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


CoordPanID Field

ZMAC_POLL_REQUEST.CoordPanID Field
[image]

PAN Id of the coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordPanID As UInt16
C#
public ushort CoordPanID;
C++
public:
unsigned short CoordPanID sealed ;
J#
public ushort CoordPanID
JScript
public CoordPanID : UInt16;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


KeyIdMode Field

ZMAC_POLL_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_POLL_REQUEST.KEY_ID_MODE
C#
public ZMAC_POLL_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_POLL_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_POLL_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_POLL_REQUEST.KEY_ID_MODE;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


KeyIndex Field

ZMAC_POLL_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


KeySource Field

ZMAC_POLL_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


SecurityLevel Field

ZMAC_POLL_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_POLL_REQUEST.SECURITY_LEVEL
C#
public ZMAC_POLL_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_POLL_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_POLL_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_POLL_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI1 Namespace


ZMAC_POLL_REQUEST.ADDRESS_MODE Enumeration

ZMAC_POLL_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_POLL_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_POLL_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_POLL_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_POLL_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
ADDRESS_NOT_PRESENT | Specified the format of the coordinator address
GROUP_ADDRESS | Specified the format of the coordinator address
ADDRESS_16_BIT | Specified the format of the coordinator address
ADDRESS_64_BIT | Specified the format of the coordinator address
BROADCAST | Specified the format of the coordinator address

See Also

TI.ZPI1 Namespace


ZMAC_POLL_REQUEST.KEY_ID_MODE Enumeration

ZMAC_POLL_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_POLL_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_POLL_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_POLL_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_POLL_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_POLL_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_POLL_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_POLL_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_POLL_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_POLL_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_POLL_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_POLL_RESPONSE Class

ZMAC_POLL_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_POLL_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_POLL_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_POLL_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_POLL_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_POLL_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_POLL_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_POLL_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_POLL_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_POLL_RESPONSE Members

ZMAC_POLL_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_POLL_REQUEST

The following tables list the members exposed by ZMAC_POLL_RESPONSE.

Public Constructors

Name | Description
ZMAC_POLL_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_POLL_RESPONSE | Overloaded.
Top

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_POLL_RESPONSE Constructor

ZMAC_POLL_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_POLL_RESPONSE | Constructor
Public method | ZMAC_POLL_RESPONSE (ZMAC_POLL_RESPONSE.CMD_STATUS) |

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_POLL_RESPONSE Constructor ()

ZMAC_POLL_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_POLL_RESPONSE()
C++
public:
ZMAC_POLL_RESPONSE() sealed
J#
public ZMAC_POLL_RESPONSE()
JScript
public function ZMAC_POLL_RESPONSE()

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_POLL_RESPONSE Constructor Overload List


ZMAC_POLL_RESPONSE Constructor (ZMAC_POLL_RESPONSE.CMD_STATUS)

ZMAC_POLL_RESPONSE Constructor (ZMAC_POLL_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_POLL_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_POLL_RESPONSE(
ZMAC_POLL_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_POLL_RESPONSE(
ZMAC_POLL_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_POLL_RESPONSE(
ZMAC_POLL_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_POLL_RESPONSE(
: ZMAC_POLL_RESPONSE.CMD_STATUS
)

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_POLL_RESPONSE Constructor Overload List


Fields

ZMAC_POLL_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_POLL_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_POLL_RESPONSE.CMD_STATUS
C#
public ZMAC_POLL_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_POLL_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_POLL_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_POLL_RESPONSE.CMD_STATUS;

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_POLL_RESPONSE.CMD_STATUS Enumeration

ZMAC_POLL_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_POLL_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_POLL_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_POLL_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_POLL_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_PURGE_REQUEST Class

ZMAC_PURGE_REQUEST Class
See Also Example Members
[image]

This command is used to send a request to the device to purge a data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_PURGE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_PURGE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_PURGE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_PURGE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_PURGE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_PURGE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_PURGE_REQUEST Members
TI.ZPI1 Namespace


ZMAC_PURGE_REQUEST Members

ZMAC_PURGE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a request to the device to purge a data frame

The following tables list the members exposed by ZMAC_PURGE_REQUEST.

Public Constructors

Name | Description
ZMAC_PURGE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MsduHandle | Msdu Handle
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_PURGE_REQUEST | Overloaded.
Top

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_PURGE_REQUEST Constructor

ZMAC_PURGE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_PURGE_REQUEST | Constructor
Public method | ZMAC_PURGE_REQUEST (Byte) | Constructor

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_PURGE_REQUEST Constructor ()

ZMAC_PURGE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_PURGE_REQUEST()
C++
public:
ZMAC_PURGE_REQUEST() sealed
J#
public ZMAC_PURGE_REQUEST()
JScript
public function ZMAC_PURGE_REQUEST()

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_PURGE_REQUEST Constructor Overload List


ZMAC_PURGE_REQUEST Constructor (Byte)

ZMAC_PURGE_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZMAC_PURGE_REQUEST(
byte
)
C++
public:
ZMAC_PURGE_REQUEST(
char
) sealed
J#
public ZMAC_PURGE_REQUEST(
byte
)
JScript
public function ZMAC_PURGE_REQUEST(
: Byte
)

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_PURGE_REQUEST Constructor Overload List


Fields

ZMAC_PURGE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | MsduHandle | Msdu Handle
Top

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI1 Namespace


MsduHandle Field

ZMAC_PURGE_REQUEST.MsduHandle Field
[image]

Msdu Handle

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsduHandle As Byte
C#
public byte MsduHandle;
C++
public:
char MsduHandle sealed ;
J#
public byte MsduHandle
JScript
public MsduHandle : Byte;

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_PURGE_RESPONSE Class

ZMAC_PURGE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_PURGE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_PURGE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_PURGE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_PURGE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_PURGE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_PURGE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_PURGE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_PURGE_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_PURGE_RESPONSE Members

ZMAC_PURGE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_PURGE_REQUEST

The following tables list the members exposed by ZMAC_PURGE_RESPONSE.

Public Constructors

Name | Description
ZMAC_PURGE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_PURGE_RESPONSE | Overloaded.
Top

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_PURGE_RESPONSE Constructor

ZMAC_PURGE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_PURGE_RESPONSE | Constructor
Public method | ZMAC_PURGE_RESPONSE (ZMAC_PURGE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_PURGE_RESPONSE Constructor ()

ZMAC_PURGE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_PURGE_RESPONSE()
C++
public:
ZMAC_PURGE_RESPONSE() sealed
J#
public ZMAC_PURGE_RESPONSE()
JScript
public function ZMAC_PURGE_RESPONSE()

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_PURGE_RESPONSE Constructor Overload List


ZMAC_PURGE_RESPONSE Constructor (ZMAC_PURGE_RESPONSE.CMD_STATUS)

ZMAC_PURGE_RESPONSE Constructor (ZMAC_PURGE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_PURGE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_PURGE_RESPONSE(
ZMAC_PURGE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_PURGE_RESPONSE(
ZMAC_PURGE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_PURGE_RESPONSE(
ZMAC_PURGE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_PURGE_RESPONSE(
: ZMAC_PURGE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_PURGE_RESPONSE Constructor Overload List


Fields

ZMAC_PURGE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_PURGE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_PURGE_RESPONSE.CMD_STATUS
C#
public ZMAC_PURGE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_PURGE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_PURGE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_PURGE_RESPONSE.CMD_STATUS;

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_PURGE_RESPONSE.CMD_STATUS Enumeration

ZMAC_PURGE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_PURGE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_PURGE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_PURGE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_PURGE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_PURGE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_RESET_REQUEST Class

ZMAC_RESET_REQUEST Class
See Also Example Members
[image]

This command is used to send a MAC Reset command to reset MAC state machine

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_RESET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_RESET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_RESET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_RESET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_RESET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_RESET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_RESET_REQUEST Members
TI.ZPI1 Namespace


ZMAC_RESET_REQUEST Members

ZMAC_RESET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a MAC Reset command to reset MAC state machine

The following tables list the members exposed by ZMAC_RESET_REQUEST.

Public Constructors

Name | Description
ZMAC_RESET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SetDefault | Set Default
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_RESET_REQUEST | Overloaded.
Top

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_RESET_REQUEST Constructor

ZMAC_RESET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_RESET_REQUEST | Constructor
Public method | ZMAC_RESET_REQUEST (Byte) | Constructor

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_RESET_REQUEST Constructor ()

ZMAC_RESET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_RESET_REQUEST()
C++
public:
ZMAC_RESET_REQUEST() sealed
J#
public ZMAC_RESET_REQUEST()
JScript
public function ZMAC_RESET_REQUEST()

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI1 Namespace
ZMAC_RESET_REQUEST Constructor Overload List


ZMAC_RESET_REQUEST Constructor (Byte)

ZMAC_RESET_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZMAC_RESET_REQUEST(
byte
)
C++
public:
ZMAC_RESET_REQUEST(
char
) sealed
J#
public ZMAC_RESET_REQUEST(
byte
)
JScript
public function ZMAC_RESET_REQUEST(
: Byte
)

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI1 Namespace
ZMAC_RESET_REQUEST Constructor Overload List


Fields

ZMAC_RESET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | SetDefault | Set Default
Top

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI1 Namespace


SetDefault Field

ZMAC_RESET_REQUEST.SetDefault Field
[image]

Set Default

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SetDefault As Byte
C#
public byte SetDefault;
C++
public:
char SetDefault sealed ;
J#
public byte SetDefault
JScript
public SetDefault : Byte;

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_RESET_RESPONSE Class

ZMAC_RESET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_RESET_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_RESET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_RESET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_RESET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_RESET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_RESET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_RESET_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_RESET_RESPONSE Members

ZMAC_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_RESET_REQUEST

The following tables list the members exposed by ZMAC_RESET_RESPONSE.

Public Constructors

Name | Description
ZMAC_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_RESET_RESPONSE | Overloaded.
Top

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_RESET_RESPONSE Constructor

ZMAC_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_RESET_RESPONSE | Constructor
Public method | ZMAC_RESET_RESPONSE (ZMAC_RESET_RESPONSE.CMD_STATUS) |

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_RESET_RESPONSE Constructor ()

ZMAC_RESET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_RESET_RESPONSE()
C++
public:
ZMAC_RESET_RESPONSE() sealed
J#
public ZMAC_RESET_RESPONSE()
JScript
public function ZMAC_RESET_RESPONSE()

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_RESET_RESPONSE Constructor Overload List


ZMAC_RESET_RESPONSE Constructor (ZMAC_RESET_RESPONSE.CMD_STATUS)

ZMAC_RESET_RESPONSE Constructor (ZMAC_RESET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_RESET_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_RESET_RESPONSE(
ZMAC_RESET_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_RESET_RESPONSE(
ZMAC_RESET_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_RESET_RESPONSE(
ZMAC_RESET_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_RESET_RESPONSE(
: ZMAC_RESET_RESPONSE.CMD_STATUS
)

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_RESET_RESPONSE Constructor Overload List


Fields

ZMAC_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_RESET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_RESET_RESPONSE.CMD_STATUS
C#
public ZMAC_RESET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_RESET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_RESET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_RESET_RESPONSE.CMD_STATUS;

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_RESET_RESPONSE.CMD_STATUS Enumeration

ZMAC_RESET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_RESET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_RESET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_RESET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_RESET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_RESET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_RX_ENABLE_REQUEST Class

ZMAC_RX_ENABLE_REQUEST Class
See Also Example Members
[image]

This command contains timing information that tells the device when to enable or disable its receiver, in order to schedule a data transfer between itself and another device. The information is sent from the upper layers directly to the MAC sublayer.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_RX_ENABLE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_RX_ENABLE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_RX_ENABLE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_RX_ENABLE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_RX_ENABLE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_RX_ENABLE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_RX_ENABLE_REQUEST Members
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_REQUEST Members

ZMAC_RX_ENABLE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command contains timing information that tells the device when to enable or disable its receiver, in order to schedule a data transfer between itself and another device. The information is sent from the upper layers directly to the MAC sublayer.

The following tables list the members exposed by ZMAC_RX_ENABLE_REQUEST.

Public Constructors

Name | Description
ZMAC_RX_ENABLE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeferPermit | Defer Permit
Public field | RxOnDuration | Rx On Duration
Public field | RxOnTime | Rx On Time
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_RX_ENABLE_REQUEST | Overloaded.
Top

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_REQUEST Constructor

ZMAC_RX_ENABLE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_RX_ENABLE_REQUEST | Constructor
Public method | ZMAC_RX_ENABLE_REQUEST (Byte, Byte, Byte) | Constructor

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_REQUEST Constructor ()

ZMAC_RX_ENABLE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_RX_ENABLE_REQUEST()
C++
public:
ZMAC_RX_ENABLE_REQUEST() sealed
J#
public ZMAC_RX_ENABLE_REQUEST()
JScript
public function ZMAC_RX_ENABLE_REQUEST()

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_RX_ENABLE_REQUEST Constructor Overload List


ZMAC_RX_ENABLE_REQUEST Constructor (Byte, Byte[], Byte[])

ZMAC_RX_ENABLE_REQUEST Constructor (Byte, Byte[], Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte() _
)
C#
public ZMAC_RX_ENABLE_REQUEST(
byte ,
byte[] ,
byte[]
)
C++
public:
ZMAC_RX_ENABLE_REQUEST(
char ,
array<char>^ ,
array<char>^
) sealed
J#
public ZMAC_RX_ENABLE_REQUEST(
byte ,
byte[] ,
byte[]
)
JScript
public function ZMAC_RX_ENABLE_REQUEST(
: Byte,
: Byte[],
: Byte[]
)

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_RX_ENABLE_REQUEST Constructor Overload List


Fields

ZMAC_RX_ENABLE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DeferPermit | Defer Permit
Public field | RxOnDuration | Rx On Duration
Public field | RxOnTime | Rx On Time
Top

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace


DeferPermit Field

ZMAC_RX_ENABLE_REQUEST.DeferPermit Field
[image]

Defer Permit

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeferPermit As Byte
C#
public byte DeferPermit;
C++
public:
char DeferPermit sealed ;
J#
public byte DeferPermit
JScript
public DeferPermit : Byte;

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace


RxOnDuration Field

ZMAC_RX_ENABLE_REQUEST.RxOnDuration Field
[image]

Rx On Duration

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RxOnDuration As Byte()
C#
public byte[] RxOnDuration;
C++
public:
array<char>^ RxOnDuration sealed ;
J#
public byte[] RxOnDuration
JScript
public RxOnDuration : Byte[];

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace


RxOnTime Field

ZMAC_RX_ENABLE_REQUEST.RxOnTime Field
[image]

Rx On Time

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RxOnTime As Byte()
C#
public byte[] RxOnTime;
C++
public:
array<char>^ RxOnTime sealed ;
J#
public byte[] RxOnTime
JScript
public RxOnTime : Byte[];

See Also

ZMAC_RX_ENABLE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_RESPONSE Class

ZMAC_RX_ENABLE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_RX_ENABLE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_RX_ENABLE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_RX_ENABLE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_RX_ENABLE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_RX_ENABLE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_RX_ENABLE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_RX_ENABLE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_RX_ENABLE_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_RESPONSE Members

ZMAC_RX_ENABLE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_RX_ENABLE_REQUEST

The following tables list the members exposed by ZMAC_RX_ENABLE_RESPONSE.

Public Constructors

Name | Description
ZMAC_RX_ENABLE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_RX_ENABLE_RESPONSE | Overloaded.
Top

See Also

ZMAC_RX_ENABLE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_RESPONSE Constructor

ZMAC_RX_ENABLE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_RX_ENABLE_RESPONSE | Constructor
Public method | ZMAC_RX_ENABLE_RESPONSE (ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_RX_ENABLE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_RESPONSE Constructor ()

ZMAC_RX_ENABLE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_RX_ENABLE_RESPONSE()
C++
public:
ZMAC_RX_ENABLE_RESPONSE() sealed
J#
public ZMAC_RX_ENABLE_RESPONSE()
JScript
public function ZMAC_RX_ENABLE_RESPONSE()

See Also

ZMAC_RX_ENABLE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_RX_ENABLE_RESPONSE Constructor Overload List


ZMAC_RX_ENABLE_RESPONSE Constructor (ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS)

ZMAC_RX_ENABLE_RESPONSE Constructor (ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_RX_ENABLE_RESPONSE(
ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_RX_ENABLE_RESPONSE(
ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_RX_ENABLE_RESPONSE(
ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_RX_ENABLE_RESPONSE(
: ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_RX_ENABLE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_RX_ENABLE_RESPONSE Constructor Overload List


Fields

ZMAC_RX_ENABLE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_RX_ENABLE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_RX_ENABLE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS
C#
public ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS;

See Also

ZMAC_RX_ENABLE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS Enumeration

ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST Class

ZMAC_SCAN_REQUEST Class
See Also Example Members
[image]

This command is used to send a request to the device to perform a network scan.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SCAN_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SCAN_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SCAN_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SCAN_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SCAN_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_SCAN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SCAN_REQUEST Members
TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST Members

ZMAC_SCAN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a request to the device to perform a network scan.

The following tables list the members exposed by ZMAC_SCAN_REQUEST.

Public Constructors

Name | Description
ZMAC_SCAN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page that the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | MaxResults | Maximum number of PAN descriptor results
Public field | ScanChannels | Channels to be scanned
Public field | ScanDuration | Duration of the scan
Public field | ScanType | Type of the scan
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SCAN_REQUEST | Overloaded.
Top

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST Constructor

ZMAC_SCAN_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SCAN_REQUEST | Constructor
Public method | ZMAC_SCAN_REQUEST (ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte, ZMAC_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_SCAN_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST Constructor ()

ZMAC_SCAN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SCAN_REQUEST()
C++
public:
ZMAC_SCAN_REQUEST() sealed
J#
public ZMAC_SCAN_REQUEST()
JScript
public function ZMAC_SCAN_REQUEST()

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace
ZMAC_SCAN_REQUEST Constructor Overload List


ZMAC_SCAN_REQUEST Constructor (ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte[], ZMAC_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_SCAN_REQUEST.KEY_ID_MODE, Byte)

ZMAC_SCAN_REQUEST Constructor (ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte[], ZMAC_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_SCAN_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, _
ByVal As ZMAC_SCAN_REQUEST.SCAN_TYPE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_SCAN_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_SCAN_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_SCAN_REQUEST(
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_SCAN_REQUEST.SCAN_TYPE ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_SCAN_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_SCAN_REQUEST(
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_SCAN_REQUEST.SCAN_TYPE ,
char ,
char ,
char ,
array<char>^ ,
ZMAC_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_SCAN_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_SCAN_REQUEST(
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_SCAN_REQUEST.SCAN_TYPE ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_SCAN_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_SCAN_REQUEST(
: ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS,
: ZMAC_SCAN_REQUEST.SCAN_TYPE,
: Byte,
: Byte,
: Byte,
: Byte[],
: ZMAC_SCAN_REQUEST.SECURITY_LEVEL,
: ZMAC_SCAN_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace
ZMAC_SCAN_REQUEST Constructor Overload List


Fields

ZMAC_SCAN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page that the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | MaxResults | Maximum number of PAN descriptor results
Public field | ScanChannels | Channels to be scanned
Public field | ScanDuration | Duration of the scan
Public field | ScanType | Type of the scan
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


ChannelPage Field

ZMAC_SCAN_REQUEST.ChannelPage Field
[image]

The channel page that the device

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


KeyIdMode Field

ZMAC_SCAN_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_SCAN_REQUEST.KEY_ID_MODE
C#
public ZMAC_SCAN_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_SCAN_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_SCAN_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_SCAN_REQUEST.KEY_ID_MODE;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


KeyIndex Field

ZMAC_SCAN_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


KeySource Field

ZMAC_SCAN_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


MaxResults Field

ZMAC_SCAN_REQUEST.MaxResults Field
[image]

Maximum number of PAN descriptor results

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MaxResults As Byte
C#
public byte MaxResults;
C++
public:
char MaxResults sealed ;
J#
public byte MaxResults
JScript
public MaxResults : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


ScanChannels Field

ZMAC_SCAN_REQUEST.ScanChannels Field
[image]

Channels to be scanned

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS
C#
public ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


ScanDuration Field

ZMAC_SCAN_REQUEST.ScanDuration Field
[image]

Duration of the scan

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


ScanType Field

ZMAC_SCAN_REQUEST.ScanType Field
[image]

Type of the scan

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanType As ZMAC_SCAN_REQUEST.SCAN_TYPE
C#
public ZMAC_SCAN_REQUEST.SCAN_TYPE ScanType;
C++
public:
ZMAC_SCAN_REQUEST.SCAN_TYPE ScanType sealed ;
J#
public ZMAC_SCAN_REQUEST.SCAN_TYPE ScanType
JScript
public ScanType : ZMAC_SCAN_REQUEST.SCAN_TYPE;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


SecurityLevel Field

ZMAC_SCAN_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_SCAN_REQUEST.SECURITY_LEVEL
C#
public ZMAC_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_SCAN_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST.KEY_ID_MODE Enumeration

ZMAC_SCAN_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_SCAN_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_SCAN_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_SCAN_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_SCAN_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST.SCAN_TYPE Enumeration

ZMAC_SCAN_REQUEST.SCAN_TYPE Enumeration
[image]

Scan type

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_REQUEST.SCAN_TYPE As Byte
C#
public enum ZMAC_SCAN_REQUEST.SCAN_TYPE : byte
C++
public enum class ZMAC_SCAN_REQUEST.SCAN_TYPE : char
J#
public enum ZMAC_SCAN_REQUEST.SCAN_TYPE byte
JScript
public enum ZMAC_SCAN_REQUEST.SCAN_TYPE :

Members

Member Name | Description
ENERGY_DETECT | Scan type
ACTIVE | Scan type
PASSIVE | Scan type
ORPHAN | Scan type

See Also

TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_SCAN_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_SCAN_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS Enumeration

ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI1 Namespace


ZMAC_SCAN_RESPONSE Class

ZMAC_SCAN_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SCAN_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SCAN_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SCAN_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SCAN_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SCAN_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SCAN_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_SCAN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SCAN_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_SCAN_RESPONSE Members

ZMAC_SCAN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SCAN_REQUEST

The following tables list the members exposed by ZMAC_SCAN_RESPONSE.

Public Constructors

Name | Description
ZMAC_SCAN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SCAN_RESPONSE | Overloaded.
Top

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SCAN_RESPONSE Constructor

ZMAC_SCAN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SCAN_RESPONSE | Constructor
Public method | ZMAC_SCAN_RESPONSE (ZMAC_SCAN_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SCAN_RESPONSE Constructor ()

ZMAC_SCAN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SCAN_RESPONSE()
C++
public:
ZMAC_SCAN_RESPONSE() sealed
J#
public ZMAC_SCAN_RESPONSE()
JScript
public function ZMAC_SCAN_RESPONSE()

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_SCAN_RESPONSE Constructor Overload List


ZMAC_SCAN_RESPONSE Constructor (ZMAC_SCAN_RESPONSE.CMD_STATUS)

ZMAC_SCAN_RESPONSE Constructor (ZMAC_SCAN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SCAN_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SCAN_RESPONSE(
ZMAC_SCAN_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SCAN_RESPONSE(
ZMAC_SCAN_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SCAN_RESPONSE(
ZMAC_SCAN_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SCAN_RESPONSE(
: ZMAC_SCAN_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_SCAN_RESPONSE Constructor Overload List


Fields

ZMAC_SCAN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_SCAN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SCAN_RESPONSE.CMD_STATUS
C#
public ZMAC_SCAN_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SCAN_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SCAN_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SCAN_RESPONSE.CMD_STATUS;

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SCAN_RESPONSE.CMD_STATUS Enumeration

ZMAC_SCAN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SCAN_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SCAN_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SCAN_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SCAN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_SET_REQUEST Class

ZMAC_SET_REQUEST Class
See Also Example Members
[image]

This command is used to request the device to write a MAC PIB value.

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_SET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SET_REQUEST Members
TI.ZPI1 Namespace


ZMAC_SET_REQUEST Members

ZMAC_SET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request the device to write a MAC PIB value.

The following tables list the members exposed by ZMAC_SET_REQUEST.

Public Constructors

Name | Description
ZMAC_SET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Public field | AttributeValue | 1-16 bytes value of the attribute
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SET_REQUEST | Overloaded.
Top

See Also

ZMAC_SET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SET_REQUEST Constructor

ZMAC_SET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SET_REQUEST | Constructor
Public method | ZMAC_SET_REQUEST (ZMAC_SET_REQUEST.MAC_PID_ATTR, Byte) |

See Also

ZMAC_SET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SET_REQUEST Constructor ()

ZMAC_SET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SET_REQUEST()
C++
public:
ZMAC_SET_REQUEST() sealed
J#
public ZMAC_SET_REQUEST()
JScript
public function ZMAC_SET_REQUEST()

See Also

ZMAC_SET_REQUEST Class
TI.ZPI1 Namespace
ZMAC_SET_REQUEST Constructor Overload List


ZMAC_SET_REQUEST Constructor (ZMAC_SET_REQUEST.MAC_PID_ATTR, Byte[])

ZMAC_SET_REQUEST Constructor (ZMAC_SET_REQUEST.MAC_PID_ATTR, Byte[])
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SET_REQUEST.MAC_PID_ATTR, _
ByVal As Byte() _
)
C#
public ZMAC_SET_REQUEST(
ZMAC_SET_REQUEST.MAC_PID_ATTR ,
byte[]
)
C++
public:
ZMAC_SET_REQUEST(
ZMAC_SET_REQUEST.MAC_PID_ATTR ,
array<char>^
) sealed
J#
public ZMAC_SET_REQUEST(
ZMAC_SET_REQUEST.MAC_PID_ATTR ,
byte[]
)
JScript
public function ZMAC_SET_REQUEST(
: ZMAC_SET_REQUEST.MAC_PID_ATTR,
: Byte[]
)

See Also

ZMAC_SET_REQUEST Class
TI.ZPI1 Namespace
ZMAC_SET_REQUEST Constructor Overload List


Fields

ZMAC_SET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Public field | AttributeValue | 1-16 bytes value of the attribute
Top

See Also

ZMAC_SET_REQUEST Class
TI.ZPI1 Namespace


Attribute Field

ZMAC_SET_REQUEST.Attribute Field
[image]

Specifies the MAC PID Attributes

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As ZMAC_SET_REQUEST.MAC_PID_ATTR
C#
public ZMAC_SET_REQUEST.MAC_PID_ATTR Attribute;
C++
public:
ZMAC_SET_REQUEST.MAC_PID_ATTR Attribute sealed ;
J#
public ZMAC_SET_REQUEST.MAC_PID_ATTR Attribute
JScript
public Attribute : ZMAC_SET_REQUEST.MAC_PID_ATTR;

See Also

ZMAC_SET_REQUEST Class
TI.ZPI1 Namespace


AttributeValue Field

ZMAC_SET_REQUEST.AttributeValue Field
[image]

1-16 bytes value of the attribute

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AttributeValue As Byte()
C#
public byte[] AttributeValue;
C++
public:
array<char>^ AttributeValue sealed ;
J#
public byte[] AttributeValue
JScript
public AttributeValue : Byte[];

See Also

ZMAC_SET_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SET_REQUEST.MAC_PID_ATTR Enumeration

ZMAC_SET_REQUEST.MAC_PID_ATTR Enumeration
[image]

MAC PID Attribute

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SET_REQUEST.MAC_PID_ATTR As Byte
C#
public enum ZMAC_SET_REQUEST.MAC_PID_ATTR : byte
C++
public enum class ZMAC_SET_REQUEST.MAC_PID_ATTR : char
J#
public enum ZMAC_SET_REQUEST.MAC_PID_ATTR byte
JScript
public enum ZMAC_SET_REQUEST.MAC_PID_ATTR :

Members

Member Name | Description
ZMAC_ACK_WAIT_DURATION | MAC PID Attribute
ZMAC_ASSOCIATION_PERMIT | MAC PID Attribute
ZMAC_AUTO_REQUEST | MAC PID Attribute
ZMAC_BATT_LIFE_EXT | MAC PID Attribute
ZMAC_BATT_LEFT_EXT_PERIODS | MAC PID Attribute
ZMAC_BEACON_MSDU | MAC PID Attribute
ZMAC_BEACON_MSDU_LENGTH | MAC PID Attribute
ZMAC_BEACON_ORDER | MAC PID Attribute
ZMAC_BEACON_TX_TIME | MAC PID Attribute
ZMAC_BSN | MAC PID Attribute
ZMAC_COORD_EXTENDED_ADDRESS | MAC PID Attribute
ZMAC_COORD_SHORT_ADDRESS | MAC PID Attribute
ZMAC_DSN | MAC PID Attribute
ZMAC_GTS_PERMIT | MAC PID Attribute
ZMAC_MAX_CSMA_BACKOFFS | MAC PID Attribute
ZMAC_MIN_BE | MAC PID Attribute
ZMAC_PANID | MAC PID Attribute
ZMAC_PROMISCUOUS_MODE | MAC PID Attribute
ZMAC_RX_ON_IDLE | MAC PID Attribute
ZMAC_SUPER_FRAME_ORDER | MAC PID Attribute
ZMAC_TRANSACTION_PERSISTENCE_TIME | MAC PID Attribute
ZMAC_ACL_ENTRY_DESCRIPTOR_SET | MAC PID Attribute
ZMAC_ACL_ENTRY_DESCRIPTOR_SET | MAC PID Attribute
ZMAC_ACL_ENTRY_DESCRIPTOR_SET_SIZE | MAC PID Attribute
ZMAC_DEFAULT_SECURITY | MAC PID Attribute
ZMAC_ACL_DEFAULT_SECURITY_MATERIAL_LENGTH | MAC PID Attribute
ZMAC_ACL_DEFAULT_SECURITY_MATERIAL | MAC PID Attribute
ZMAC_DEFAULT_SECURITY_SUITE | MAC PID Attribute
ZMAC_SECURITY_MODE | MAC PID Attribute
ZMAC_TX_GTS_ID | MAC PID Attribute
ZMAC_UPPER_LAYER_TYPE | MAC PID Attribute
ZMAC_RX_GTS_ID | MAC PID Attribute
ZMAC_SNOOZE_PERMIT | MAC PID Attribute
ZMAC_CHANNEL | MAC PID Attribute
ZMAC_EXT_ADDR | MAC PID Attribute

See Also

TI.ZPI1 Namespace


ZMAC_SET_RESPONSE Class

ZMAC_SET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SET_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_SET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SET_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_SET_RESPONSE Members

ZMAC_SET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SET_REQUEST

The following tables list the members exposed by ZMAC_SET_RESPONSE.

Public Constructors

Name | Description
ZMAC_SET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SET_RESPONSE | Overloaded.
Top

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SET_RESPONSE Constructor

ZMAC_SET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SET_RESPONSE | Constructor
Public method | ZMAC_SET_RESPONSE (ZMAC_SET_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SET_RESPONSE Constructor ()

ZMAC_SET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SET_RESPONSE()
C++
public:
ZMAC_SET_RESPONSE() sealed
J#
public ZMAC_SET_RESPONSE()
JScript
public function ZMAC_SET_RESPONSE()

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_SET_RESPONSE Constructor Overload List


ZMAC_SET_RESPONSE Constructor (ZMAC_SET_RESPONSE.CMD_STATUS)

ZMAC_SET_RESPONSE Constructor (ZMAC_SET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SET_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SET_RESPONSE(
ZMAC_SET_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SET_RESPONSE(
ZMAC_SET_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SET_RESPONSE(
ZMAC_SET_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SET_RESPONSE(
: ZMAC_SET_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_SET_RESPONSE Constructor Overload List


Fields

ZMAC_SET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_SET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SET_RESPONSE.CMD_STATUS
C#
public ZMAC_SET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SET_RESPONSE.CMD_STATUS;

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SET_RESPONSE.CMD_STATUS Enumeration

ZMAC_SET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_START_REQUEST Class

ZMAC_START_REQUEST Class
See Also Example Members
[image]

This command is used to request the MAC to transmit beacons and become a coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_START_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_START_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_START_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_START_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_START_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_START_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_START_REQUEST Members
TI.ZPI1 Namespace


ZMAC_START_REQUEST Members

ZMAC_START_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request the MAC to transmit beacons and become a coordinator

The following tables list the members exposed by ZMAC_START_REQUEST.

Public Constructors

Name | Description
ZMAC_START_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BatteryLifeExt | If this value is TRUE, the receiver is disabled after MAC_BATT_LIFE_EXT_PERIODS full backoff periods following the interframe spacing period of the beacon frame
Public field | BeaconKeyIdMode | Key Id Mode of this data frame
Public field | BeaconKeyIndex | Key Index of this data frame
Public field | BeaconKeySource | Key Source of this data frame
Public field | BeaconOrder | The exponent used to calculate the beacon interval
Public field | BeaconSecurityLevel | Security Level of this data frame
Public field | ChannelPage | The channel page to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | CoordRealignment | Coord Realignment
Public field | LogicalChannel | The logical channel to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | PanCoordinator | Set to TRUE to start a network as PAN coordinator
Public field | PanID | The PAN ID to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | RealignKeyIdMode | Key Id Mode of this data frame
Public field | RealignKeyIndex | Key Index of this data frame
Public field | RealignKeySource | Key Source of this data frame
Public field | RealignSecurityLevel | Security Level of this data frame
Public field | StartTime | The time to begin transmitting beacons relative to the received beacon
Public field | SuperFrameOrder | The exponent used to calculate the superframe duration
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_START_REQUEST | Overloaded.
Top

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


ZMAC_START_REQUEST Constructor

ZMAC_START_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_START_REQUEST | Constructor
Public method | ZMAC_START_REQUEST (UInt32, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte, Byte, ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


ZMAC_START_REQUEST Constructor ()

ZMAC_START_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_START_REQUEST()
C++
public:
ZMAC_START_REQUEST() sealed
J#
public ZMAC_START_REQUEST()
JScript
public function ZMAC_START_REQUEST()

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace
ZMAC_START_REQUEST Constructor Overload List


ZMAC_START_REQUEST Constructor (UInt32, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte)

ZMAC_START_REQUEST Constructor (UInt32, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt32, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_START_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_START_REQUEST.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_START_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_START_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_START_REQUEST(
uint ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_START_REQUEST(
unsigned int ,
unsigned short ,
char ,
char ,
char ,
char ,
char ,
char ,
char ,
array<char>^ ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
char ,
array<char>^ ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_START_REQUEST(
uint ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_START_REQUEST(
: UInt32,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[],
: ZMAC_START_REQUEST.SECURITY_LEVEL,
: ZMAC_START_REQUEST.KEY_ID_MODE,
: Byte,
: Byte[],
: ZMAC_START_REQUEST.SECURITY_LEVEL,
: ZMAC_START_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace
ZMAC_START_REQUEST Constructor Overload List


Fields

ZMAC_START_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | BatteryLifeExt | If this value is TRUE, the receiver is disabled after MAC_BATT_LIFE_EXT_PERIODS full backoff periods following the interframe spacing period of the beacon frame
Public field | BeaconKeyIdMode | Key Id Mode of this data frame
Public field | BeaconKeyIndex | Key Index of this data frame
Public field | BeaconKeySource | Key Source of this data frame
Public field | BeaconOrder | The exponent used to calculate the beacon interval
Public field | BeaconSecurityLevel | Security Level of this data frame
Public field | ChannelPage | The channel page to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | CoordRealignment | Coord Realignment
Public field | LogicalChannel | The logical channel to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | PanCoordinator | Set to TRUE to start a network as PAN coordinator
Public field | PanID | The PAN ID to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | RealignKeyIdMode | Key Id Mode of this data frame
Public field | RealignKeyIndex | Key Index of this data frame
Public field | RealignKeySource | Key Source of this data frame
Public field | RealignSecurityLevel | Security Level of this data frame
Public field | StartTime | The time to begin transmitting beacons relative to the received beacon
Public field | SuperFrameOrder | The exponent used to calculate the superframe duration
Top

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


BatteryLifeExt Field

ZMAC_START_REQUEST.BatteryLifeExt Field
[image]

If this value is TRUE, the receiver is disabled after MAC_BATT_LIFE_EXT_PERIODS full backoff periods following the interframe spacing period of the beacon frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BatteryLifeExt As Byte
C#
public byte BatteryLifeExt;
C++
public:
char BatteryLifeExt sealed ;
J#
public byte BatteryLifeExt
JScript
public BatteryLifeExt : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


BeaconKeyIdMode Field

ZMAC_START_REQUEST.BeaconKeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconKeyIdMode As ZMAC_START_REQUEST.KEY_ID_MODE
C#
public ZMAC_START_REQUEST.KEY_ID_MODE BeaconKeyIdMode;
C++
public:
ZMAC_START_REQUEST.KEY_ID_MODE BeaconKeyIdMode sealed ;
J#
public ZMAC_START_REQUEST.KEY_ID_MODE BeaconKeyIdMode
JScript
public BeaconKeyIdMode : ZMAC_START_REQUEST.KEY_ID_MODE;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


BeaconKeyIndex Field

ZMAC_START_REQUEST.BeaconKeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconKeyIndex As Byte
C#
public byte BeaconKeyIndex;
C++
public:
char BeaconKeyIndex sealed ;
J#
public byte BeaconKeyIndex
JScript
public BeaconKeyIndex : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


BeaconKeySource Field

ZMAC_START_REQUEST.BeaconKeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconKeySource As Byte()
C#
public byte[] BeaconKeySource;
C++
public:
array<char>^ BeaconKeySource sealed ;
J#
public byte[] BeaconKeySource
JScript
public BeaconKeySource : Byte[];

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


BeaconOrder Field

ZMAC_START_REQUEST.BeaconOrder Field
[image]

The exponent used to calculate the beacon interval

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


BeaconSecurityLevel Field

ZMAC_START_REQUEST.BeaconSecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconSecurityLevel As ZMAC_START_REQUEST.SECURITY_LEVEL
C#
public ZMAC_START_REQUEST.SECURITY_LEVEL BeaconSecurityLevel;
C++
public:
ZMAC_START_REQUEST.SECURITY_LEVEL BeaconSecurityLevel sealed ;
J#
public ZMAC_START_REQUEST.SECURITY_LEVEL BeaconSecurityLevel
JScript
public BeaconSecurityLevel : ZMAC_START_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


ChannelPage Field

ZMAC_START_REQUEST.ChannelPage Field
[image]

The channel page to use. This parameter is ignored if Pan Coordinator is FALSE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


CoordRealignment Field

ZMAC_START_REQUEST.CoordRealignment Field
[image]

Coord Realignment

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordRealignment As Byte
C#
public byte CoordRealignment;
C++
public:
char CoordRealignment sealed ;
J#
public byte CoordRealignment
JScript
public CoordRealignment : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


LogicalChannel Field

ZMAC_START_REQUEST.LogicalChannel Field
[image]

The logical channel to use. This parameter is ignored if Pan Coordinator is FALSE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


PanCoordinator Field

ZMAC_START_REQUEST.PanCoordinator Field
[image]

Set to TRUE to start a network as PAN coordinator

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanCoordinator As Byte
C#
public byte PanCoordinator;
C++
public:
char PanCoordinator sealed ;
J#
public byte PanCoordinator
JScript
public PanCoordinator : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


PanID Field

ZMAC_START_REQUEST.PanID Field
[image]

The PAN ID to use. This parameter is ignored if Pan Coordinator is FALSE

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


RealignKeyIdMode Field

ZMAC_START_REQUEST.RealignKeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignKeyIdMode As ZMAC_START_REQUEST.KEY_ID_MODE
C#
public ZMAC_START_REQUEST.KEY_ID_MODE RealignKeyIdMode;
C++
public:
ZMAC_START_REQUEST.KEY_ID_MODE RealignKeyIdMode sealed ;
J#
public ZMAC_START_REQUEST.KEY_ID_MODE RealignKeyIdMode
JScript
public RealignKeyIdMode : ZMAC_START_REQUEST.KEY_ID_MODE;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


RealignKeyIndex Field

ZMAC_START_REQUEST.RealignKeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignKeyIndex As Byte
C#
public byte RealignKeyIndex;
C++
public:
char RealignKeyIndex sealed ;
J#
public byte RealignKeyIndex
JScript
public RealignKeyIndex : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


RealignKeySource Field

ZMAC_START_REQUEST.RealignKeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignKeySource As Byte()
C#
public byte[] RealignKeySource;
C++
public:
array<char>^ RealignKeySource sealed ;
J#
public byte[] RealignKeySource
JScript
public RealignKeySource : Byte[];

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


RealignSecurityLevel Field

ZMAC_START_REQUEST.RealignSecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignSecurityLevel As ZMAC_START_REQUEST.SECURITY_LEVEL
C#
public ZMAC_START_REQUEST.SECURITY_LEVEL RealignSecurityLevel;
C++
public:
ZMAC_START_REQUEST.SECURITY_LEVEL RealignSecurityLevel sealed ;
J#
public ZMAC_START_REQUEST.SECURITY_LEVEL RealignSecurityLevel
JScript
public RealignSecurityLevel : ZMAC_START_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


StartTime Field

ZMAC_START_REQUEST.StartTime Field
[image]

The time to begin transmitting beacons relative to the received beacon

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartTime As UInt32
C#
public uint StartTime;
C++
public:
unsigned int StartTime sealed ;
J#
public uint StartTime
JScript
public StartTime : UInt32;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


SuperFrameOrder Field

ZMAC_START_REQUEST.SuperFrameOrder Field
[image]

The exponent used to calculate the superframe duration

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameOrder As Byte
C#
public byte SuperFrameOrder;
C++
public:
char SuperFrameOrder sealed ;
J#
public byte SuperFrameOrder
JScript
public SuperFrameOrder : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI1 Namespace


ZMAC_START_REQUEST.KEY_ID_MODE Enumeration

ZMAC_START_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_START_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_START_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_START_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_START_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_START_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
NOT_USED | Key Id Mode
KEY_1BYTE_INDEX | Key Id Mode
KEY_4BYTE_INDEX | Key Id Mode
KEY_8BYTE_INDEX | Key Id Mode

See Also

TI.ZPI1 Namespace


ZMAC_START_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_START_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_START_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_START_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_START_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_START_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_START_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
NO_SECURITY | Security Level
MIC_32_AUTH | Security Level
MIC_64_AUTH | Security Level
MIC_128_AUTH | Security Level
AES_ENCRYPTION | Security Level
AES_ENCRYPTION_MIC_32 | Security Level
AES_ENCRYPTION_MIC_64 | Security Level
AES_ENCRYPTION_MIC_128 | Security Level

See Also

TI.ZPI1 Namespace


ZMAC_START_RESPONSE Class

ZMAC_START_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_START_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_START_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_START_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_START_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_START_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_START_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_START_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_START_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_START_RESPONSE Members

ZMAC_START_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_START_REQUEST

The following tables list the members exposed by ZMAC_START_RESPONSE.

Public Constructors

Name | Description
ZMAC_START_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_START_RESPONSE | Overloaded.
Top

See Also

ZMAC_START_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_START_RESPONSE Constructor

ZMAC_START_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_START_RESPONSE | Constructor
Public method | ZMAC_START_RESPONSE (ZMAC_START_RESPONSE.CMD_STATUS) |

See Also

ZMAC_START_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_START_RESPONSE Constructor ()

ZMAC_START_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_START_RESPONSE()
C++
public:
ZMAC_START_RESPONSE() sealed
J#
public ZMAC_START_RESPONSE()
JScript
public function ZMAC_START_RESPONSE()

See Also

ZMAC_START_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_START_RESPONSE Constructor Overload List


ZMAC_START_RESPONSE Constructor (ZMAC_START_RESPONSE.CMD_STATUS)

ZMAC_START_RESPONSE Constructor (ZMAC_START_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_START_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_START_RESPONSE(
ZMAC_START_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_START_RESPONSE(
ZMAC_START_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_START_RESPONSE(
ZMAC_START_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_START_RESPONSE(
: ZMAC_START_RESPONSE.CMD_STATUS
)

See Also

ZMAC_START_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_START_RESPONSE Constructor Overload List


Fields

ZMAC_START_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_START_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_START_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_START_RESPONSE.CMD_STATUS
C#
public ZMAC_START_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_START_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_START_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_START_RESPONSE.CMD_STATUS;

See Also

ZMAC_START_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_START_RESPONSE.CMD_STATUS Enumeration

ZMAC_START_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_START_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_START_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_START_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_START_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_START_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_REQUEST Class

ZMAC_SYNCHRONIZE_REQUEST Class
See Also Example Members
[image]

This command is used to request synchronization to the current network beacon

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SYNCHRONIZE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SYNCHRONIZE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SYNCHRONIZE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SYNCHRONIZE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SYNCHRONIZE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_SYNCHRONIZE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SYNCHRONIZE_REQUEST Members
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_REQUEST Members

ZMAC_SYNCHRONIZE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request synchronization to the current network beacon

The following tables list the members exposed by ZMAC_SYNCHRONIZE_REQUEST.

Public Constructors

Name | Description
ZMAC_SYNCHRONIZE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page to use
Public field | LogicalChannel | The logical channel to use
Public field | TrackBeacon | Set to TRUE to continue tracking beacons after synchronizing with the first beacon. Set to FALSE to only synchronize with the first beacon
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SYNCHRONIZE_REQUEST | Overloaded.
Top

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_REQUEST Constructor

ZMAC_SYNCHRONIZE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SYNCHRONIZE_REQUEST | Constructor
Public method | ZMAC_SYNCHRONIZE_REQUEST (Byte, Byte, Byte) | Constructor

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_REQUEST Constructor ()

ZMAC_SYNCHRONIZE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SYNCHRONIZE_REQUEST()
C++
public:
ZMAC_SYNCHRONIZE_REQUEST() sealed
J#
public ZMAC_SYNCHRONIZE_REQUEST()
JScript
public function ZMAC_SYNCHRONIZE_REQUEST()

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_SYNCHRONIZE_REQUEST Constructor Overload List


ZMAC_SYNCHRONIZE_REQUEST Constructor (Byte, Byte, Byte)

ZMAC_SYNCHRONIZE_REQUEST Constructor (Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZMAC_SYNCHRONIZE_REQUEST(
byte ,
byte ,
byte
)
C++
public:
ZMAC_SYNCHRONIZE_REQUEST(
char ,
char ,
char
) sealed
J#
public ZMAC_SYNCHRONIZE_REQUEST(
byte ,
byte ,
byte
)
JScript
public function ZMAC_SYNCHRONIZE_REQUEST(
: Byte,
: Byte,
: Byte
)

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace
ZMAC_SYNCHRONIZE_REQUEST Constructor Overload List


Fields

ZMAC_SYNCHRONIZE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page to use
Public field | LogicalChannel | The logical channel to use
Public field | TrackBeacon | Set to TRUE to continue tracking beacons after synchronizing with the first beacon. Set to FALSE to only synchronize with the first beacon
Top

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace


ChannelPage Field

ZMAC_SYNCHRONIZE_REQUEST.ChannelPage Field
[image]

The channel page to use

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace


LogicalChannel Field

ZMAC_SYNCHRONIZE_REQUEST.LogicalChannel Field
[image]

The logical channel to use

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace


TrackBeacon Field

ZMAC_SYNCHRONIZE_REQUEST.TrackBeacon Field
[image]

Set to TRUE to continue tracking beacons after synchronizing with the first beacon. Set to FALSE to only synchronize with the first beacon

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TrackBeacon As Byte
C#
public byte TrackBeacon;
C++
public:
char TrackBeacon sealed ;
J#
public byte TrackBeacon
JScript
public TrackBeacon : Byte;

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Class

ZMAC_SYNCHRONIZE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SYNCHRONIZE_REQUEST

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SYNCHRONIZE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SYNCHRONIZE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SYNCHRONIZE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SYNCHRONIZE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SYNCHRONIZE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI1.ZMAC_SYNCHRONIZE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SYNCHRONIZE_RESPONSE Members
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Members

ZMAC_SYNCHRONIZE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SYNCHRONIZE_REQUEST

The following tables list the members exposed by ZMAC_SYNCHRONIZE_RESPONSE.

Public Constructors

Name | Description
ZMAC_SYNCHRONIZE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SYNCHRONIZE_RESPONSE | Overloaded.
Top

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Constructor

ZMAC_SYNCHRONIZE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SYNCHRONIZE_RESPONSE | Constructor
Public method | ZMAC_SYNCHRONIZE_RESPONSE (ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Constructor ()

ZMAC_SYNCHRONIZE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SYNCHRONIZE_RESPONSE()
C++
public:
ZMAC_SYNCHRONIZE_RESPONSE() sealed
J#
public ZMAC_SYNCHRONIZE_RESPONSE()
JScript
public function ZMAC_SYNCHRONIZE_RESPONSE()

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_SYNCHRONIZE_RESPONSE Constructor Overload List


ZMAC_SYNCHRONIZE_RESPONSE Constructor (ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS)

ZMAC_SYNCHRONIZE_RESPONSE Constructor (ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SYNCHRONIZE_RESPONSE(
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SYNCHRONIZE_RESPONSE(
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SYNCHRONIZE_RESPONSE(
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SYNCHRONIZE_RESPONSE(
: ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI1 Namespace
ZMAC_SYNCHRONIZE_RESPONSE Constructor Overload List


Fields

ZMAC_SYNCHRONIZE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI1 Namespace


Status Field

ZMAC_SYNCHRONIZE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
C#
public ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS;

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI1 Namespace


ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Enumeration

ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command

See Also

TI.ZPI1 Namespace


TI.ZPI2

TI.ZPI2 Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AF_APSF_CONFIG_SET | MT proxy for afAPSF_ConfigSet().
Public class | AF_APSF_CONFIG_SET_SRSP | Response for AF_APSF_CONFIG_SET
Public class | AF_DATA_CONFIRM | AF Data confirm.
Public class | AF_DATA_REQUEST | This command is used by tester to build and send a data request message
Public class | AF_DATA_REQUEST_EXT | This command is used by tester to build and send a data request message with PanId field.
Public class | AF_DATA_REQUEST_EXT_SRSP | Response for AF_DATA_REQUEST_EXT
Public class | AF_DATA_REQUEST_SRC_RTG | This command is used by tester to build and send a data request message via source routing
Public class | AF_DATA_REQUEST_SRC_RTG_SRSP | Response for AF_DATA_REQUEST_SRC_RTG
Public class | AF_DATA_REQUEST_SRSP | Response for AF_DATA_REQUEST
Public class | AF_DATA_RETRIEVE | AF huge incoming message data retrieve command.
Public class | AF_DATA_RETRIEVE_SRSP | Response for AF_DATA_RETRIEVE
Public class | AF_DATA_STORE | AF huge data request data store command and data.
Public class | AF_DATA_STORE_SRSP | Response for AF_DATA_STORE
Public class | AF_INCOMING_MSG | Incoming AF data.
Public class | AF_INCOMING_MSG_EXT | Incoming AF data extended.
Public class | AF_INTER_PAN_CTL | Inter-Pan control command and data.
Public class | AF_INTER_PAN_CTL_SRSP | Response for AF_INTER_PAN_SET_PARAM
Public class | AF_REGISTER | This command enables the tester to register an application's endpoint description
Public class | AF_REGISTER_SRSP | Response for AF_REGISTER
Public class | APP_MSG | Use this message to send raw data to an application.
Public class | APP_MSG_RESPONSE | Status for APP_MSG
Public class | APP_MSG_RSP | Response for APP_MSG
Public class | APP_USER_TEST | This command is used by the tester to set the debug threshold level for a particular software component in the target.
Public class | APP_USER_TEST_RESPONSE | Response for APP_USER_TEST
Public class | APSDE_DATA_CONFIRMATION | This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.
Public class | APSME_BIND_RESPONSE | Response for APSME_BIND
Public class | DEBUG_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
Public class | DEBUG_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
Public class | DEBUG_STRING | Debug message sent by device
Public class | MT_UTIL_SYNC_REQ | This is an asynchronous request/response handshake.
Public class | MT_UTIL_ZCL_KEY_ESTABLISH_IND | This is the RPC proxy indication for a ZCL_KEY_ESTABLISH_IND.
Public class | MT_ZDO_MSG_CB_INCOMING | This message is the RPC proxy for receiving a SYS_EVENT_MSG with the ZDO_CB_MSG event. It results after registering for a callback on a Cluster Id with ZDO_MSG_CB_REGISTER. The parameter list is a packed zdoIncomingMsg_t structure less the asduLen since it can be deduced from the RPC length.
Public class | NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
Public class | NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
Public class | NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
Public class | NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
Public class | NLDE_NWK_INIT | This function will initialize the nwk with the NWK_TASKID.
Public class | NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
Public class | NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
Public class | NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
Public class | NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
Public class | NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
Public class | NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
Public class | NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
Public class | NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
Public class | NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
Public class | NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
Public class | NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
Public class | NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
Public class | NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
Public class | NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
Public class | NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
Public class | NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
Public class | NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
Public class | NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
Public class | NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
Public class | NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
Public class | NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
Public class | NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
Public class | NLME_POLL_CONFIRMATION | This function reports the results of a polling attempt.
Public class | NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
Public class | NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
Public class | NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
Public class | NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
Public class | NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
Public class | NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
Public class | NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
Public class | NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
Public class | NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
Public class | NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
Public class | NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
Public class | NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
Public class | NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
Public class | NWK_COMM_STATUS_INDICATION | This function reports a comm status error
Public class | NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
Public class | NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
Public class | NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
Public class | NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
Public class | NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
Public class | NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
Public class | NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
Public class | NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
Public class | NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
Public class | NWK_START_CONFIRMATION | This function reports the success of the start request.
Public class | NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon
Public class | SYS_ADC_READ | Stop timer.
Public class | SYS_ADC_READ_SRSP | Response for SYS_ADC_READ
Public class | SYS_GET_TIME | Get the device's time. Returns 32-bit UTC time and parsed date/time values.
Public class | SYS_GET_TIME_SRSP | Response for SYS_GET_TIME
Public class | SYS_GPIO | Control ZNP GPIO.
Public class | SYS_GPIO_SRSP | Response for SYS_GPIO
Public class | SYS_OSAL_NV_DELETE | Deletes an item from non-volatile memory.
Public class | SYS_OSAL_NV_DELETE_SRSP | Response for SYS_OSAL_NV_DELETE
Public class | SYS_OSAL_NV_ITEM_INIT | Creates a new item in non-volatile memory.
Public class | SYS_OSAL_NV_ITEM_INIT_SRSP | Response for SYS_OSAL_NV_ITEM_INIT
Public class | SYS_OSAL_NV_LENGTH | Gets the length of an item in non-volatile memory.
Public class | SYS_OSAL_NV_LENGTH_SRSP | Response for SYS_OSAL_NV_LENGTH
Public class | SYS_OSAL_NV_READ | Reads data from an item in non-volatile memory.
Public class | SYS_OSAL_NV_READ_SRSP | Response for SYS_OSAL_NV_READ
Public class | SYS_OSAL_NV_WRITE | Writes data to an item in non-volatile memory.
Public class | SYS_OSAL_NV_WRITE_SRSP | Response for SYS_OSAL_NV_WRITE
Public class | SYS_OSAL_START_TIMER | Start timer.
Public class | SYS_OSAL_START_TIMER_SRSP | Response for SYS_OSAL_START_TIMER
Public class | SYS_OSAL_STOP_TIMER | Stop timer.
Public class | SYS_OSAL_STOP_TIMER_SRSP | Response for SYS_OSAL_STOP_TIMER
Public class | SYS_OSAL_TIMER_EXPIRED_IND | OSAL timer expired
Public class | SYS_PING | This command is used to check for a device.
Public class | SYS_PING_RESPONSE | Response for SYS_PING
Public class | SYS_RANDOM | Generate random number.
Public class | SYS_RANDOM_SRSP | Response for SYS_RANDOM
Public class | SYS_RESET | This command is used to reset the target device.
Public class | SYS_RESET_RESPONSE | Indicates a device has reset.
Public class | SYS_RPC_ERROR | RPC transport layer error.
Public class | SYS_SET_TIME | Set the device's time. Accepts 32-bit UTC time and date/time parameters. The UTC time is used if it's non-zero.
Public class | SYS_SET_TIME_SRSP | Response for SYS_SET_TIME
Public class | SYS_SET_TX_POWER | Set the transmit power.
Public class | SYS_SET_TX_POWER_SRSP | Response for SYS_SET_TX_POWER
Public class | SYS_STACK_TUNE | Stack Tuning.
Public class | SYS_STACK_TUNE_SRSP | Response for SYS_STACK_TUNE
Public class | SYS_VERSION | This command is used to get the device's version string.
Public class | SYS_VERSION_RESPONSE | Response for SYS_VERSION
Public class | USERTEST_REQUEST | This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).
Public class | USERTEST_RESPONSE | Response for USERTEST_REQUEST
Public class | UTIL_ADDRMGR_EXT_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupExt().
Public class | UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupExt().
Public class | UTIL_ADDRMGR_NWK_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupNwk().
Public class | UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupNwk().
Public class | UTIL_APSME_LINK_KEY_DATA_GET | Use this message to retrieve APS link key data and frame counters.
Public class | UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE | Response for UTIL_APSME_LINK_KEY_DATA_GET.
Public class | UTIL_APSME_LINK_KEY_NV_ID_GET | Use this message to proxy a call to the APSME_LinkKeyNvIdGet() function.
Public class | UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE | This is the RPC proxy response from APSME_LinkKeyNvIdGet().
Public class | UTIL_APSME_REQUEST_KEY_CMD | This command is used to send a request key to the Trust Center from an originator device who wants to exchange messages with a partner device.
Public class | UTIL_APSME_REQUEST_KEY_CMD_SRSP | Response for UTIL_APSME_REQUEST_KEY_CMD
Public class | UTIL_ASSOC_COUNT | Use this message to proxy a call to the AssocCount() function.
Public class | UTIL_ASSOC_COUNT_RESPONSE | This is the RPC proxy response from AssocCount().
Public class | UTIL_ASSOC_FIND_DEVICE | Use this message to proxy a call to the AssocFindDevice() function.
Public class | UTIL_ASSOC_FIND_DEVICE_RESPONSE | This is the RPC proxy response from AssocFindDevice().
Public class | UTIL_ASSOC_GET_WITH_ADDRESS | Use this message to proxy a call to the AssocGetWithAddress() function.
Public class | UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE | This is the RPC proxy response from AssocGetWithAddress().
Public class | UTIL_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
Public class | UTIL_CALLBACK_SUBSCRIBE_RESPONSE | Response for UTIL_CALLBACK_SUBSCRIBE
Public class | UTIL_DATA_REQ | Use this message to effect a MAC MLME Poll Request.
Public class | UTIL_DATA_REQ_RESPONSE | Response for UTIL_DATA_REQ
Public class | UTIL_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
Public class | UTIL_GET_DEVICE_INFO_RESPONSE | Response for UTIL_GET_DEVICE_INFO
Public class | UTIL_GET_NV_INFO | Use this message to get the NV information.
Public class | UTIL_GET_NV_INFO_RESPONSE | Response for UTIL_GET_NV_INFO
Public class | UTIL_GET_TIME_ALIVE | Use this message to get board's time alive.
Public class | UTIL_GET_TIME_ALIVE_RESPONSE | Response for UTIL_GET_TIME_ALIVE
Public class | UTIL_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
Public class | UTIL_KEY_EVENT_RESPONSE | Response for UTIL_KEY_EVENT
Public class | UTIL_LED_CONTROL | Use this message to control LEDs on the board.
Public class | UTIL_LED_CONTROL_RESPONSE | Response for UTIL_LED_CONTROL
Public class | UTIL_LOOPBACK_RESPONSE | Data buffer loopback response.
Public class | UTIL_SET_CHANNELS | Use this message to set the channels.
Public class | UTIL_SET_CHANNELS_RESPONSE | Response for UTIL_SET_CHANNELS
Public class | UTIL_SET_PANID | Use this message to set PANID.
Public class | UTIL_SET_PANID_RESPONSE | Response for UTIL_SET_PANID
Public class | UTIL_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
Public class | UTIL_SET_PRECONFIG_KEY_RESPONSE | Response for UTIL_SET_PRECONFIG_KEY
Public class | UTIL_SET_SECURITY_LEVEL | Use this message to set the security level.
Public class | UTIL_SET_SECURITY_LEVEL_RESPONSE | Response for UTIL_SET_SECURITY_LEVEL
Public class | UTIL_SRC_MATCH_ACK_ALL_PENDING | Enabled/disable acknowledging all packets with pending bit set.
Public class | UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_ACK_ALL_PENDING
Public class | UTIL_SRC_MATCH_ADD_ENTRY | Add a short or extended address to source address table
Public class | UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_ADD_ENTRY
Public class | UTIL_SRC_MATCH_CHECK_ALL_PENDING | Check if acknowledging all packets with pending bit set is enabled.
Public class | UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_ALL_PENDING
Public class | UTIL_SRC_MATCH_CHECK_SRC_ADDR | Check if a short or extended address is in the source address table
Public class | UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_SRC_ADDR
Public class | UTIL_SRC_MATCH_DELETE_ENTRY | Delete a short or extended address to source address table
Public class | UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_DELETE_ENTRY
Public class | UTIL_SRC_MATCH_ENABLE | Enabled AUTOPEND and source address matching.
Public class | UTIL_SRC_MATCH_ENABLE_RESPONSE | Response for UTIL_SRC_MATCH_ENABLE
Public class | UTIL_SRNG_GEN | Generate secure random number generator
Public class | UTIL_SRNG_GEN_RESPONSE | Response for Generate secure random number generator
Public class | UTIL_TEST_LOOPBACK | Use this message to receive an echo or loopback of the data bytes sent.
Public class | UTIL_ZCL_KEY_EST_INIT_EST | Use this message to proxy a call to the zclGeneral_KeyEstablish_InitiateKeyEstablishment() function.
Public class | UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablish_InitiateKeyEstablishment().
Public class | UTIL_ZCL_KEY_EST_SIGN | Use this message to proxy a call to the zclGeneral_KeyEstablishment_ECDSASign() function.
Public class | UTIL_ZCL_KEY_EST_SIGN_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablishment_ECDSASign().
Public class | ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
Public class | ZB_ALLOW_BIND_CONFIRM | Response for ZB_ALLOW_BIND
Public class | ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
Public class | ZB_APP_REGISTER_REQUEST | This command register the device descriptor
Public class | ZB_APP_REGISTER_RSP | Response for ZB_APP_REGISTER_REQUEST
Public class | ZB_BIND_CONFIRM | Response for ZB_BIND_DEVICE
Public class | ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
Public class | ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
Public class | ZB_FIND_DEVICE_CONFIRM | (zb_FindDeviceConfirm)
Public class | ZB_FIND_DEVICE_REQUEST | Search for a device's short address given its IEEE address.
Public class | ZB_FIND_DEVICE_REQUEST_RSP | Response for ZB_FIND_DEVICE_REQUEST
Public class | ZB_GET_DEVICE_INFO | Reads current device infromation.
Public class | ZB_GET_DEVICE_INFO_RSP | Response for ZB_GET_DEVICE_INFO
Public class | ZB_PERMIT_JOINING_REQUEST | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
Public class | ZB_PERMIT_JOINING_REQUEST_RSP | Response for ZB_PERMIT_JOINING_REQUEST
Public class | ZB_READ_CONFIGURATION | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
Public class | ZB_READ_CONFIGURATION_RSP |
Public class | ZB_RECEIVE_DATA_INDICATION | (zb_ReceiveDataIndication)
Public class | ZB_SEND_DATA_CONFIRM | Response for ZB_SEND_DATA_REQUEST
Public class | ZB_SEND_DATA_REQUEST | Send a data packet to another device (zb_SendDataRequest).
Public class | ZB_SEND_DATA_REQUEST_RSP | Response for ZB_SEND_DATA_REQUEST
Public class | ZB_START_CONFIRM | Response for ZB_START_REQUEST
Public class | ZB_START_REQUEST | Starts the ZigBee stack (zb_StartRequest).
Public class | ZB_START_REQUEST_RSP | Response for ZB_START_REQUEST
Public class | ZB_SYSTEM_RESET | Reboot the device (zb_SystemReset)
Public class | ZB_WRITE_CONFIGURATION | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
Public class | ZB_WRITE_CONFIGURATION_RSP | Response for ZB_WRITE_CONFIGURATION
Public class | ZDO_ACTIVE_EP_REQ | This command is generated to request a list of active endpoint from the destination device.
Public class | ZDO_ACTIVE_EP_REQ_SRSP | Response for ZDO_ACTIVE_EP_REQ
Public class | ZDO_ACTIVE_EP_RSP | This callback message is in response to the ZDO Active Endpoint Request.
Public class | ZDO_AUTO_FIND_DESTINATION | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
Public class | ZDO_BEACON_NOTIFY_IND | This message is an indication to inform host device the receipt of a beacon notification
Public class | ZDO_BIND_REQ | This command is generated to request a Bind
Public class | ZDO_BIND_REQ_SRSP | Response for ZDO_BIND_REQ
Public class | ZDO_BIND_RSP | This callback message is in response to the ZDO Bind Request
Public class | ZDO_COMPLEX_DESC_REQ | This command is generated to request for the destination device's complex descriptor
Public class | ZDO_COMPLEX_DESC_REQ_SRSP | Response for ZDO_COMPLEX_DESC_REQ
Public class | ZDO_COMPLEX_DESC_RSP | Response for ZDO_COMPLEX_DESC_REQ
Public class | ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
Public class | ZDO_END_DEVICE_ANNCE_IND | ZDO end device announce indication.
Public class | ZDO_END_DEVICE_ANNCE_SRSP | Response for ZDO_END_DEVICE_ANNCE
Public class | ZDO_END_DEVICE_BIND_REQ | This command is generated to request an End Device Bind with the destination device
Public class | ZDO_END_DEVICE_BIND_REQ_SRSP | Response for ZDO_END_DEVICE_BIND_REQ
Public class | ZDO_END_DEVICE_BIND_RSP | This callback message is in response to the ZDO End Device Bind Request
Public class | ZDO_END_DEVICE_TIMEOUT_REQ | The command is used to send an End Device Timeout Request message.
Public class | ZDO_END_DEVICE_TIMEOUT_REQ_SRSP | Response for ZDO_END_DEVICE_TIMEOUT_REQ
Public class | ZDO_END_DEVICE_TIMEOUT_RSP | This callback message is in response to the End Device Timeout Request.
Public class | ZDO_GET_LINK_KEY | This function will return the application or trust center link key of a given device.
Public class | ZDO_GET_LINK_KEY_SRSP | Response for ZDO_GET_LINK_KEY
Public class | ZDO_IEEE_ADDR_REQ | This command will request a device's IEEE 64-bit address. You must subscribe to 'ZDO IEEE Address Response' to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
Public class | ZDO_IEEE_ADDR_REQ_SRSP | Response for ZDO_IEEE_ADDR_REQ
Public class | ZDO_IEEE_ADDR_RSP | This callback message is in response to the ZDO IEEE Address Request.
Public class | ZDO_JOIN_CNF | This message is an indication to the host device the result of a ZDO join request .
Public class | ZDO_JOIN_REQ | This command is used to request the device to join itself to a parent device on a network.
Public class | ZDO_JOIN_REQ_SRSP | Response for ZDO_JOIN_REQ
Public class | ZDO_LEAVE_IND | ZDO leave indication.
Public class | ZDO_MATCH_DESC_REQ | This command is generated to request a list of active endpoint from the destination device
Public class | ZDO_MATCH_DESC_REQ_SRSP | Response for ZDO_MATCH_DESC_REQ
Public class | ZDO_MATCH_DESC_RSP | This callback message is in response to the ZDO Match Description Request
Public class | ZDO_MATCH_DESC_RSP_SENT | This callback indicates that Match Descriptor Response has been sent.
Public class | ZDO_MGMT_BIND_REQ | This command is generated to request a Management Binding Table Request.
Public class | ZDO_MGMT_BIND_REQ_SRSP | Response for ZDO_MGMT_BIND_REQ
Public class | ZDO_MGMT_BIND_RSP | This callback message is in response to the ZDO Management Binding Table Request
Public class | ZDO_MGMT_DIRECT_JOIN_REQ | This command is generated to request a Management Direct Join Request
Public class | ZDO_MGMT_DIRECT_JOIN_REQ_SRSP | Response for ZDO_MGMT_DIRECT_JOIN_REQ
Public class | ZDO_MGMT_DIRECT_JOIN_RSP | This callback message is in response to the ZDO Management Direct Join Request.
Public class | ZDO_MGMT_LEAVE_REQ | This command is generated to request a Management Leave Request
Public class | ZDO_MGMT_LEAVE_REQ_SRSP | Response for ZDO_MGMT_LEAVE_REQ
Public class | ZDO_MGMT_LEAVE_RSP | This callback message is in response to the ZDO Management Leave Request.
Public class | ZDO_MGMT_LQI_REQ | This command is generated to request a Management LQI Request.
Public class | ZDO_MGMT_LQI_REQ_SRSP | Response for ZDO_MGMT_LQI_REQ
Public class | ZDO_MGMT_LQI_RSP | This callback message is in response to the ZDO Management LQI Request.
Public class | ZDO_MGMT_NWK_DISC_REQ | This command is generated to request a Management Network Discovery Request
Public class | ZDO_MGMT_NWK_DISC_REQ_SRSP | Response for ZDO_MGMT_NWK_DISC_REQ
Public class | ZDO_MGMT_NWK_DISC_RSP | This callback message is in response to the ZDO Management Network Discovery Request
Public class | ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
Public class | ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
Public class | ZDO_MGMT_PERMIT_JOIN_REQ_SRSP | Response for ZDO_MGMT_PERMIT_JOIN_REQ
Public class | ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
Public class | ZDO_MGMT_PERMIT_JOIN_RSP | This callback message is in response to the ZDO Management Permit Join Request
Public class | ZDO_MGMT_RTG_REQ | This command is generated to request a Management Routing Table Request.
Public class | ZDO_MGMT_RTG_REQ_SRSP | Response for ZDO_MGMT_RTG_REQ
Public class | ZDO_MGMT_RTG_RSP | This callback message is in response to the ZDO Management Routing Table Request.
Public class | ZDO_MSG_CB_REGISTER | This command is the RPC proxy to ZDO_RegisterForZDOMsg() and registers for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
Public class | ZDO_MSG_CB_REGISTER_RESPONSE | Response for ZDO_MSG_CB_REGISTER
Public class | ZDO_MSG_CB_REMOVE | This command is the RPC proxy to ZDO_RemoveRegisteredCB() and removes registration for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
Public class | ZDO_MSG_CB_REMOVE_RESPONSE | Response for ZDO_MSG_CB_REMOVE
Public class | ZDO_NODE_DESC_REQ | This command is generated to inquire as to the Node Descriptor of the destination device
Public class | ZDO_NODE_DESC_REQ_SRSP | Response for ZDO_NODE_DESC_REQ
Public class | ZDO_NODE_DESC_RSP | This callback message is in response to the ZDO Node Descriptor Request.
Public class | ZDO_NWK_ADDR_REQ | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
Public class | ZDO_NWK_ADDR_REQ_SRSP | Response for ZDO_NWK_ADDR_REQ
Public class | ZDO_NWK_ADDR_RSP | This callback message is in response to the ZDO Network Address Request.
Public class | ZDO_NWK_DISCOVERY_CNF | This message sends an indication to inform host device the completion of network discovery scan.
Public class | ZDO_NWK_DISCOVERY_REQ | This command will initiate a network discovery (active scan).
Public class | ZDO_NWK_DISCOVERY_REQ_SRSP | Response for ZDO_NWK_DISCOVERY_REQ
Public class | ZDO_POWER_DESC_REQ | This command is generated to inquire as to the Power Descriptor of the destination
Public class | ZDO_POWER_DESC_REQ_SRSP | Response for ZDO_POWER_DESC_REQ
Public class | ZDO_POWER_DESC_RSP | This callback message is in response to the ZDO Power Descriptor Request.
Public class | ZDO_REMOVE_LINK_KEY | This command removes the application or trust center link key of a given device.
Public class | ZDO_REMOVE_LINK_KEY_SRSP | Response for ZDO_REMOVE_LINK_KEY
Public class | ZDO_SERVER_DISC_REQ | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
Public class | ZDO_SERVER_DISC_REQ_SRSP | Response for ZDO_SERVER_DISC_REQ
Public class | ZDO_SERVER_DISC_RSP | This callback message is
Public class | ZDO_SET_LINK_KEY | This Command sets the application or trust center link key for a given device.
Public class | ZDO_SET_LINK_KEY_SRSP | Response for ZDO_SET_LINK_KEY
Public class | ZDO_SIMPLE_DESC_REQ | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
Public class | ZDO_SIMPLE_DESC_REQ_SRSP | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
Public class | ZDO_SIMPLE_DESC_RSP | This callback message is in response to the ZDO Simple Descriptor Request.
Public class | ZDO_SRC_RTG_IND | This message is an indication to inform host device the receipt of a source route to a given device.
Public class | ZDO_STARTUP_FROM_APP | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
Public class | ZDO_STARTUP_FROM_APP_SRSP | Response for ZDO_STARTUP_FROM_APP
Public class | ZDO_STATE_CHANGE_IND | ZDO state change indication.
Public class | ZDO_STATUS_ERROR_RSP | This message is the default message for error status.
Public class | ZDO_UNBIND_REQ | This command is generated to request an UnBind
Public class | ZDO_UNBIND_REQ_SRSP | Response for ZDO_UNBIND_REQ
Public class | ZDO_UNBIND_RSP | This callback message is in response to the ZDO UnBind Request
Public class | ZDO_USER_DESC_CONF | This callback message is in response to the ZDO User Descriptor Set Request.
Public class | ZDO_USER_DESC_REQ | This command is generated to request for the destination device's user descriptor
Public class | ZDO_USER_DESC_REQ_SRSP | Response for ZDO_USER_DESC_REQ
Public class | ZDO_USER_DESC_RSP | This callback message is in response to the ZDO User Description Request.
Public class | ZDO_USER_DESC_SET | This command is generated to request a User Descriptor Set Request
Public class | ZDO_USER_DESC_SET_SRSP | Response for ZDO_USER_DESC_SET
Public class | ZLL_TOUCH_LINK_INDICATION | ZLL Touch Link Indication
Public class | ZMAC_ASSOCIATE_CNF | This sends a associat confirm command
Public class | ZMAC_ASSOCIATE_IND | This command is used to send (on behalf of the next higher layer) an association indication message
Public class | ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
Public class | ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
Public class | ZMAC_ASSOCIATE_RSP | This command is sent by the host to response to the ASSOCIATE_IND
Public class | ZMAC_ASSOCIATE_RSP_RESPONSE | Response for ZMAC_ASSOCIATE_RSP
Public class | ZMAC_BEACON_NOTIFY_IND | Beacon Notify Indication
Public class | ZMAC_COMM_STATUS_IND | Communcation status indication
Public class | ZMAC_DATA_CNF | Data Request Confirmation
Public class | ZMAC_DATA_IND | Data Indication
Public class | ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
Public class | ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
Public class | ZMAC_DISASSOCIATE_CNF | Disassociate Indication
Public class | ZMAC_DISASSOCIATE_IND | Disassociate Indication
Public class | ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
Public class | ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
Public class | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST | This command is used to send a request to the device to send an enhanced beacon request.
Public class | ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE | Response for ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST
Public class | ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
Public class | ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
Public class | ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
Public class | ZMAC_INIT_RESPONSE | Response for ZMAC_INIT_REQUEST
Public class | ZMAC_ORPHAN_IND | Orphan Indication
Public class | ZMAC_ORPHAN_RSP | This command is sent by the host to response to the ORPHAN_IND
Public class | ZMAC_ORPHAN_RSP_RESPONSE | Response for ZMAC_ORPHAN_RSP
Public class | ZMAC_POLL_CNF | Mac Poll Confirmation
Public class | ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
Public class | ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
Public class | ZMAC_PURGE_CNF | Mac RX enable Confirmation
Public class | ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
Public class | ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
Public class | ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
Public class | ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
Public class | ZMAC_RX_ENABLE_CNF | Mac RX enable Confirmation
Public class | ZMAC_SCAN_CNF | Scan Confirmation
Public class | ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
Public class | ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
Public class | ZMAC_SECURITY_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC Security PIB attribute.
Public class | ZMAC_SECURITY_GET_RESPONSE | Response for ZMAC_SECURITY_GET_REQUEST
Public class | ZMAC_SECURITY_SET_REQUEST | This command is used to request the device to write a MAC Security PIB value.
Public class | ZMAC_SECURITY_SET_RESPONSE | Response for ZMAC_SECURITY_SET_REQUEST
Public class | ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
Public class | ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
Public class | ZMAC_SET_RX_GAIN_REQUEST | This command is used to send a request to the device to set Rx gain
Public class | ZMAC_SET_RX_GAIN_RESPONSE | Response for ZMAC_SET_RX_GAIN_REQUEST
Public class | ZMAC_START_CNF | Mac Start Confirmation
Public class | ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
Public class | ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
Public class | ZMAC_SYNC_LOSS_IND | Indication for sync loss
Public class | ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon
Public class | ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST

Interfaces

 | Interface | Description
Public interface | IAF |
Public interface | IAPP |
Public interface | ICONFIRMATION |
Public interface | IDEBUG |
Public interface | IINDICATION |
Public interface | INETWORK |
Public interface | IREQUEST |
Public interface | IRESPONSE |
Public interface | IRESPONSE_CALLBACK |
Public interface | ISIMPLEAPI |
Public interface | ISYSTEM |
Public interface | IUTIL |
Public interface | IZDO |
Public interface | IZMAC |

Structures

 | Structure | Description
NestedPublic structure | APP_MSG.BLIND_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST | Send this message to a Blind Node to request its configuration. The response to this request is the Blind Node Configuration (Cluster ID 6) message. This message doesn't have a body to the message (just cluster ID)
NestedPublic structure | APP_MSG.BLIND_NODE_REQUEST | Send this message to a Blind Node to request its location. The response to this message will be sent by the blind node when the location process is complete (which will take seconds). This message doesn't have a body to the message (just cluster ID)
NestedPublic structure | APP_MSG.REFERENCE_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST | Send this message to a Reference Node to request its configuration. The response to this request is the Reference Node Configuration (Cluster ID 5) message. This message doesn't have a body to the message (just cluster ID)
NestedPublic structure | APP_MSG.REFERENCE_NODE_REQUEST | Send this message to a reference node to request its position information. In this request is the number of responses expected
NestedPublic structure | APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Used by Commissioner to assign Client status to a device and therefore to cause a new image to be downloaded to that device. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | This command causes the target device to enable the downloaded image. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | This command requests the target device to reset. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG.ZLMSGID_RESET_REQUEST | This command requests the target device to terminate all OAD activity and return to the idle state. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Response for ZLMSGID_SEND_DATA_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Response for ZLMSGID_SESSION_START_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Response for ZLMSGID_SESSION_TERM_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG.ZLMSGID_STATUSQ_REQUEST | Used to determine images currently existing on a device. This is part of the Commissioner's enumeration process. Based on need each device may then be either a Client or a Server depending on current images on-board. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.BLIND_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | APP_MSG_RSP.BLIND_NODE_RESPONSE | This message is sent out of the Blind Node in response to the "Bind Node Request" message. The blind node, upon receiving the request message, will send a "Reference Node Request" (radius 1 - broadcast) to its immediate neighbors and wait for responses. Use the Blind Node Configuration message to change the parameters used to generate this response message (ie. number of reference node response, collect time)
NestedPublic structure | APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION | Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"
NestedPublic structure | APP_MSG_RSP.REFERENCE_NODE_RESPONSE | This message is sent by a Reference Node in response to a "Reference Node Request" message. The number of time that this message is sent depends on the number request in the request. When multiple responses are request, the delay between responses are from 2-16 milliseconds
NestedPublic structure | APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE | Response for ZLMSGID_CLIENT_CMD_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE | Response for ZLMSGID_CODE_ENABLE_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE | Response for ZLMSGID_RESET_BOARD_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.ZLMSGID_RESET_RESPONSE | Response for ZLMSGID_RESET_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST | This command requests the target device to send a data packet. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST | Used to mark the beginning of a set of data transfer transactions and to establish Server status on the part of the target device. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST | Used to terminate a session and reset the OAD context of the target platform. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE | Response for ZLMSGID_STATUSQ_REQUEST. (latest OAD protocol version, OAD protocol version 1)
NestedPublic structure | NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Pan Information. Used with NLME_NETWORKDISCOVERY_CONFIRMATION
NestedPublic structure | ZDO_BEACON_NOTIFY_IND.BeaconListItemClass | Beacon List Class. Used with ZDO_BEACON_NOTIFY_IND
NestedPublic structure | ZDO_MGMT_BIND_RSP.BindListItemClass | Contains information in a single item of a bind list
NestedPublic structure | ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass | Contains information in a single item of a network list
NestedPublic structure | ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass | Contains information in a single item of a network list
NestedPublic structure | ZDO_MGMT_RTG_RSP.RoutingTableListClass | Contains information in a single item of a Routing Table List

Enumerations

 | Enumeration | Description
NestedPublic enumeration | AF_APSF_CONFIG_SET_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_DATA_CONFIRM.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_DATA_REQUEST_EXT.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | AF_DATA_REQUEST_EXT_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_DATA_REQUEST_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_DATA_RETRIEVE_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_DATA_STORE_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | AF_INCOMING_MSG_EXT.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | AF_INTER_PAN_CTL_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | AF_REGISTER.LATENCY_TYPE | Latency type
NestedPublic enumeration | AF_REGISTER_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT |
NestedPublic enumeration | APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE |
NestedPublic enumeration | APP_MSG.LOC_REQ_MESSAGE_ID | Message id for LOC_REQ_MESSAGE_ID
NestedPublic enumeration | APP_MSG.OAD_REQ_MESSAGE_ID | Message id for OAD_REQ_MESSAGE_ID
NestedPublic enumeration | APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT |
NestedPublic enumeration | APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE |
NestedPublic enumeration | APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE |
NestedPublic enumeration | APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE |
NestedPublic enumeration | APP_MSG_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT |
NestedPublic enumeration | APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE |
NestedPublic enumeration | APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS |
NestedPublic enumeration | APP_MSG_RSP.LOC_RSP_MESSAGE_ID | Message id for LOC_RSP_MESSAGE_ID
NestedPublic enumeration | APP_MSG_RSP.OAD_RSP_MESSAGE_ID | Message id for OAD_RSP_MESSAGE_ID
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE |
NestedPublic enumeration | APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE |
NestedPublic enumeration | APP_USER_TEST_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | APSDE_DATA_CONFIRMATION.APSDE_STATUS | Status code for APSDE responses
NestedPublic enumeration | APSDE_DATA_CONFIRMATION.BOOLEAN | True or False flag
NestedPublic enumeration | APSME_BIND_RESPONSE.NLME_STATUS | Status code for NLME response
NestedPublic enumeration | DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD | specifies the threshold value for reporting debug messages by that software component
NestedPublic enumeration | DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS | Status of command
Public enumeration | MESSAGE_ID | Contains SPI message ID's
NestedPublic enumeration | NLDE_DATA_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLDE_DATA_RESPONSE.NLDE_STATUS | Status code for NLDE response
NestedPublic enumeration | NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | NLME_DIRECTJOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_GET_REQUEST.NIB_ATTR | Network layer information base attributes
NestedPublic enumeration | NLME_GET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_JOIN_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_JOIN_INDICATION.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | NLME_JOIN_REQUEST.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | NLME_JOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_LEAVE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_LEAVE_INDICATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_LEAVE_REQUEST.BOOLEAN | True or False flag
NestedPublic enumeration | NLME_LEAVE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS | Status code for NLME response
NestedPublic enumeration | NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NLME_ORPHANJOIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_PERMITJOINING_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_POLL_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_RESET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_SET_REQUEST.NIB_ATTR | Network layer information base attributes
NestedPublic enumeration | NLME_SET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_STARTROUTER_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_STARTROUTER_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | NLME_SYNC_INDICATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_ASSOCIATE_INDICATION.CAPABILITIES | Capabilities bitfield
NestedPublic enumeration | NWK_ASSOCIATE_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.BOOLEAN | True or False flag
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_DATA_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_DATA_INDICATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_DATA_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_DATA_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON | Valid disassociation reason codes
NestedPublic enumeration | NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_ORPHAN_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_ORPHAN_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | NWK_POLL_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_PURGE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_SCAN_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_SCAN_CONFIRMATION.SCAN_TYPE | Scan type
NestedPublic enumeration | NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | NWK_START_CONFIRMATION.CMD_STATUS | Status of command
NestedPublic enumeration | NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL | Security Level
NestedPublic enumeration | SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_OSAL_NV_READ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_OSAL_START_TIMER_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_PING_RESPONSE.CAPABILITIES | Capabilities bitfield
NestedPublic enumeration | SYS_RESET.RESET_TYPE | Reset type
NestedPublic enumeration | SYS_RPC_ERROR.RPC_ERROR_STATUS | RPC Error status code
NestedPublic enumeration | SYS_SET_TIME_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | SYS_STACK_TUNE_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | USERTEST_REQUEST.USERTEST_COMMAND | Usertest command
NestedPublic enumeration | USERTEST_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION | Subscribe Action
NestedPublic enumeration | UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_DATA_REQ.BOOLEAN | True or False flag
NestedPublic enumeration | UTIL_DATA_REQ_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE | Device state
NestedPublic enumeration | UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE | Device type bitfield
NestedPublic enumeration | UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | UTIL_KEY_EVENT.BOOLEAN | True or False flag
NestedPublic enumeration | UTIL_KEY_EVENT.KEY_EVENT | Key event
NestedPublic enumeration | UTIL_KEY_EVENT_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_LED_CONTROL.LED_MODE | Mode of the LED
NestedPublic enumeration | UTIL_LED_CONTROL.LED_NUM | The ID of the LED
NestedPublic enumeration | UTIL_LED_CONTROL_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SET_CHANNELS.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SET_PANID_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN | True or False flag
NestedPublic enumeration | UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN | True or False flag
NestedPublic enumeration | UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE | Address types used in AutoPend
NestedPublic enumeration | UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_SRNG_GEN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZB_APP_REGISTER_RSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZB_BIND_CONFIRM.CMD_STATUS | Status of command
NestedPublic enumeration | ZB_BIND_DEVICE.BIND_ACTION_TYPE | Reset type
NestedPublic enumeration | ZB_GET_DEVICE_INFO.DEV_INFO_TYPE | Reset type
NestedPublic enumeration | ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZB_READ_CONFIGURATION_RSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZB_SEND_DATA_CONFIRM.CMD_STATUS | Status of command
NestedPublic enumeration | ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE | Reset type
NestedPublic enumeration | ZB_START_CONFIRM.CMD_STATUS | Status of command
NestedPublic enumeration | ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_ACTIVE_EP_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_BIND_REQ.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_BIND_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_BIND_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_COMPLEX_DESC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_GET_LINK_KEY_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_IEEE_ADDR_REQ.REQ_TYPE | Request type
NestedPublic enumeration | ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_IEEE_ADDR_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_JOIN_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_JOIN_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_MATCH_DESC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_BIND_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_LEAVE_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_MGMT_LQI_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MGMT_RTG_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_NODE_DESC_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_NODE_DESC_RSP.CAPABILITY_INFO | Capability Information bitfield
NestedPublic enumeration | ZDO_NODE_DESC_RSP.SERVER_CAPABILITY | Capabilities bitfield
NestedPublic enumeration | ZDO_NODE_DESC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_NWK_ADDR_REQ.REQ_TYPE | Request type
NestedPublic enumeration | ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_NWK_ADDR_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_NWK_DISCOVERY_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_POWER_DESC_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_POWER_DESC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY | Capabilities bitfield
NestedPublic enumeration | ZDO_SERVER_DISC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_SET_LINK_KEY_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_SIMPLE_DESC_RSP.APP_DEV_VER | App dev ver
NestedPublic enumeration | ZDO_SIMPLE_DESC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_STATE_CHANGE_IND.CMD_STATUS | Status of command
NestedPublic enumeration | ZDO_STATUS_ERROR_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_UNBIND_REQ.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZDO_UNBIND_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_UNBIND_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_USER_DESC_CONF.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_USER_DESC_REQ_SRSP.AF_STATUS | Status code for AF responses
NestedPublic enumeration | ZDO_USER_DESC_RSP.ZDO_STATUS | ZDO status
NestedPublic enumeration | ZDO_USER_DESC_SET_SRSP.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ASSOCIATE_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ASSOCIATE_CNF.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ASSOCIATE_IND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ASSOCIATE_IND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS | Address types used in AutoPend
NestedPublic enumeration | ZMAC_ASSOCIATE_RSP.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_COMM_STATUS_IND.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_COMM_STATUS_IND.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_COMM_STATUS_IND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_COMM_STATUS_IND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_DATA_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_DATA_IND.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_DATA_IND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_DATA_IND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_DATA_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_DATA_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_DATA_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_DATA_REQUEST.TX_OPT | Transmission options bitfield
NestedPublic enumeration | ZMAC_DATA_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_DISASSOCIATE_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_DISASSOCIATE_IND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON | Valid disassociation reason codes
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN | True or False flag
NestedPublic enumeration | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE | Scan type
NestedPublic enumeration | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_GET_REQUEST.MAC_PID_ATTR | MAC PID Attribute
NestedPublic enumeration | ZMAC_GET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_INIT_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_ORPHAN_IND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ORPHAN_IND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ORPHAN_RSP.BOOLEAN | True or False flag
NestedPublic enumeration | ZMAC_ORPHAN_RSP.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_ORPHAN_RSP.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_POLL_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_POLL_REQUEST.ADDRESS_MODE | Specified the format of the coordinator address
NestedPublic enumeration | ZMAC_POLL_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_POLL_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_POLL_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_PURGE_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_PURGE_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_RESET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_RX_ENABLE_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SCAN_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SCAN_CNF.SCAN_TYPE | Scan type
NestedPublic enumeration | ZMAC_SCAN_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_SCAN_REQUEST.SCAN_TYPE | Scan type
NestedPublic enumeration | ZMAC_SCAN_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS | Channels bitfield
NestedPublic enumeration | ZMAC_SCAN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR | MAC Security PID Attribute
NestedPublic enumeration | ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR | MAC Security PID Attribute
NestedPublic enumeration | ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SET_REQUEST.MAC_PID_ATTR | MAC PID Attribute
NestedPublic enumeration | ZMAC_SET_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN | True or False flag
NestedPublic enumeration | ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_START_CNF.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_START_REQUEST.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_START_REQUEST.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_START_RESPONSE.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SYNC_LOSS_IND.CMD_STATUS | Status of command
NestedPublic enumeration | ZMAC_SYNC_LOSS_IND.KEY_ID_MODE | Key Id Mode
NestedPublic enumeration | ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL | Security Level
NestedPublic enumeration | ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS | Status of command


AF_APSF_CONFIG_SET Class

AF_APSF_CONFIG_SET Class
See Also Example Members
[image]

MT proxy for afAPSF_ConfigSet().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_APSF_CONFIG_SET
Implements IREQUEST, IAF
C#
public class AF_APSF_CONFIG_SET : IREQUEST, IAF
C++
ref class AF_APSF_CONFIG_SET : IREQUEST, IAF
J#
public class AF_APSF_CONFIG_SET implements IREQUEST, IAF
JScript
public class AF_APSF_CONFIG_SET extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_APSF_CONFIG_SET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_APSF_CONFIG_SET Members
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET Members

AF_APSF_CONFIG_SET Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

MT proxy for afAPSF_ConfigSet().

The following tables list the members exposed by AF_APSF_CONFIG_SET.

Public Constructors

Name | Description
AF_APSF_CONFIG_SET | Overloaded.
Top

Public Fields

 | Name | Description
Public field | APSF_Config | The afAPSF_Config_t structure populated with the configuration: frameDelay, windowSize.
Public field | Endpoint | End point
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_APSF_CONFIG_SET | Overloaded.
Top

See Also

AF_APSF_CONFIG_SET Class
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET Constructor

AF_APSF_CONFIG_SET Constructor

Overload List

 | Name | Description
Public method | AF_APSF_CONFIG_SET | Constructor
Public method | AF_APSF_CONFIG_SET (Byte, Byte) | Constructor

See Also

AF_APSF_CONFIG_SET Class
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET Constructor ()

AF_APSF_CONFIG_SET Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_APSF_CONFIG_SET()
C++
public:
AF_APSF_CONFIG_SET() sealed
J#
public AF_APSF_CONFIG_SET()
JScript
public function AF_APSF_CONFIG_SET()

See Also

AF_APSF_CONFIG_SET Class
TI.ZPI2 Namespace
AF_APSF_CONFIG_SET Constructor Overload List


AF_APSF_CONFIG_SET Constructor (Byte, Byte[])

AF_APSF_CONFIG_SET Constructor (Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public AF_APSF_CONFIG_SET(
byte ,
byte[]
)
C++
public:
AF_APSF_CONFIG_SET(
char ,
array<char>^
) sealed
J#
public AF_APSF_CONFIG_SET(
byte ,
byte[]
)
JScript
public function AF_APSF_CONFIG_SET(
: Byte,
: Byte[]
)

See Also

AF_APSF_CONFIG_SET Class
TI.ZPI2 Namespace
AF_APSF_CONFIG_SET Constructor Overload List


Fields

AF_APSF_CONFIG_SET Fields
[image]

Public Fields

 | Name | Description
Public field | APSF_Config | The afAPSF_Config_t structure populated with the configuration: frameDelay, windowSize.
Public field | Endpoint | End point
Top

See Also

AF_APSF_CONFIG_SET Class
TI.ZPI2 Namespace


APSF_Config Field

AF_APSF_CONFIG_SET.APSF_Config Field
[image]

The afAPSF_Config_t structure populated with the configuration: frameDelay, windowSize.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public APSF_Config As Byte()
C#
public byte[] APSF_Config;
C++
public:
array<char>^ APSF_Config sealed ;
J#
public byte[] APSF_Config
JScript
public APSF_Config : Byte[];

See Also

AF_APSF_CONFIG_SET Class
TI.ZPI2 Namespace


Endpoint Field

AF_APSF_CONFIG_SET.Endpoint Field
[image]

End point

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

AF_APSF_CONFIG_SET Class
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET_SRSP Class

AF_APSF_CONFIG_SET_SRSP Class
See Also Example Members
[image]

Response for AF_APSF_CONFIG_SET

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_APSF_CONFIG_SET_SRSP
Implements IRESPONSE, IAF
C#
public class AF_APSF_CONFIG_SET_SRSP : IRESPONSE, IAF
C++
ref class AF_APSF_CONFIG_SET_SRSP : IRESPONSE, IAF
J#
public class AF_APSF_CONFIG_SET_SRSP implements IRESPONSE, IAF
JScript
public class AF_APSF_CONFIG_SET_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_APSF_CONFIG_SET_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_APSF_CONFIG_SET_SRSP Members
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET_SRSP Members

AF_APSF_CONFIG_SET_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_APSF_CONFIG_SET

The following tables list the members exposed by AF_APSF_CONFIG_SET_SRSP.

Public Constructors

Name | Description
AF_APSF_CONFIG_SET_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_APSF_CONFIG_SET_SRSP | Overloaded.
Top

See Also

AF_APSF_CONFIG_SET_SRSP Class
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET_SRSP Constructor

AF_APSF_CONFIG_SET_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_APSF_CONFIG_SET_SRSP | Constructor
Public method | AF_APSF_CONFIG_SET_SRSP (AF_APSF_CONFIG_SET_SRSP.AF_STATUS) |

See Also

AF_APSF_CONFIG_SET_SRSP Class
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET_SRSP Constructor ()

AF_APSF_CONFIG_SET_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_APSF_CONFIG_SET_SRSP()
C++
public:
AF_APSF_CONFIG_SET_SRSP() sealed
J#
public AF_APSF_CONFIG_SET_SRSP()
JScript
public function AF_APSF_CONFIG_SET_SRSP()

See Also

AF_APSF_CONFIG_SET_SRSP Class
TI.ZPI2 Namespace
AF_APSF_CONFIG_SET_SRSP Constructor Overload List


AF_APSF_CONFIG_SET_SRSP Constructor (AF_APSF_CONFIG_SET_SRSP.AF_STATUS)

AF_APSF_CONFIG_SET_SRSP Constructor (AF_APSF_CONFIG_SET_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_APSF_CONFIG_SET_SRSP.AF_STATUS _
)
C#
public AF_APSF_CONFIG_SET_SRSP(
AF_APSF_CONFIG_SET_SRSP.AF_STATUS
)
C++
public:
AF_APSF_CONFIG_SET_SRSP(
AF_APSF_CONFIG_SET_SRSP.AF_STATUS
) sealed
J#
public AF_APSF_CONFIG_SET_SRSP(
AF_APSF_CONFIG_SET_SRSP.AF_STATUS
)
JScript
public function AF_APSF_CONFIG_SET_SRSP(
: AF_APSF_CONFIG_SET_SRSP.AF_STATUS
)

See Also

AF_APSF_CONFIG_SET_SRSP Class
TI.ZPI2 Namespace
AF_APSF_CONFIG_SET_SRSP Constructor Overload List


Fields

AF_APSF_CONFIG_SET_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_APSF_CONFIG_SET_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_APSF_CONFIG_SET_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_APSF_CONFIG_SET_SRSP.AF_STATUS
C#
public AF_APSF_CONFIG_SET_SRSP.AF_STATUS Status;
C++
public:
AF_APSF_CONFIG_SET_SRSP.AF_STATUS Status sealed ;
J#
public AF_APSF_CONFIG_SET_SRSP.AF_STATUS Status
JScript
public Status : AF_APSF_CONFIG_SET_SRSP.AF_STATUS;

See Also

AF_APSF_CONFIG_SET_SRSP Class
TI.ZPI2 Namespace


AF_APSF_CONFIG_SET_SRSP.AF_STATUS Enumeration

AF_APSF_CONFIG_SET_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_APSF_CONFIG_SET_SRSP.AF_STATUS As Byte
C#
public enum AF_APSF_CONFIG_SET_SRSP.AF_STATUS : byte
C++
public enum class AF_APSF_CONFIG_SET_SRSP.AF_STATUS : char
J#
public enum AF_APSF_CONFIG_SET_SRSP.AF_STATUS byte
JScript
public enum AF_APSF_CONFIG_SET_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


AF_DATA_CONFIRM Class

AF_DATA_CONFIRM Class
See Also Example Members
[image]

AF Data confirm.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_CONFIRM
Implements ICONFIRMATION, IAF
C#
public class AF_DATA_CONFIRM : ICONFIRMATION, IAF
C++
ref class AF_DATA_CONFIRM : ICONFIRMATION, IAF
J#
public class AF_DATA_CONFIRM implements ICONFIRMATION, IAF
JScript
public class AF_DATA_CONFIRM extends ICONFIRMATION, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_CONFIRM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_CONFIRM Members
TI.ZPI2 Namespace


AF_DATA_CONFIRM Members

AF_DATA_CONFIRM Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

AF Data confirm.

The following tables list the members exposed by AF_DATA_CONFIRM.

Public Constructors

Name | Description
AF_DATA_CONFIRM | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Endpoint | specifies the endpoint of the message
Public field | Status | Status
Public field | TransID | Transaction ID
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_CONFIRM | Overloaded.
Top

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace


AF_DATA_CONFIRM Constructor

AF_DATA_CONFIRM Constructor

Overload List

 | Name | Description
Public method | AF_DATA_CONFIRM | Constructor
Public method | AF_DATA_CONFIRM (AF_DATA_CONFIRM.AF_STATUS, Byte, Byte) |

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace


AF_DATA_CONFIRM Constructor ()

AF_DATA_CONFIRM Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_CONFIRM()
C++
public:
AF_DATA_CONFIRM() sealed
J#
public AF_DATA_CONFIRM()
JScript
public function AF_DATA_CONFIRM()

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace
AF_DATA_CONFIRM Constructor Overload List


AF_DATA_CONFIRM Constructor (AF_DATA_CONFIRM.AF_STATUS, Byte, Byte)

AF_DATA_CONFIRM Constructor (AF_DATA_CONFIRM.AF_STATUS, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_DATA_CONFIRM.AF_STATUS, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public AF_DATA_CONFIRM(
AF_DATA_CONFIRM.AF_STATUS ,
byte ,
byte
)
C++
public:
AF_DATA_CONFIRM(
AF_DATA_CONFIRM.AF_STATUS ,
char ,
char
) sealed
J#
public AF_DATA_CONFIRM(
AF_DATA_CONFIRM.AF_STATUS ,
byte ,
byte
)
JScript
public function AF_DATA_CONFIRM(
: AF_DATA_CONFIRM.AF_STATUS,
: Byte,
: Byte
)

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace
AF_DATA_CONFIRM Constructor Overload List


Fields

AF_DATA_CONFIRM Fields
[image]

Public Fields

 | Name | Description
Public field | Endpoint | specifies the endpoint of the message
Public field | Status | Status
Public field | TransID | Transaction ID
Top

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace


Endpoint Field

AF_DATA_CONFIRM.Endpoint Field
[image]

specifies the endpoint of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace


Status Field

AF_DATA_CONFIRM.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_DATA_CONFIRM.AF_STATUS
C#
public AF_DATA_CONFIRM.AF_STATUS Status;
C++
public:
AF_DATA_CONFIRM.AF_STATUS Status sealed ;
J#
public AF_DATA_CONFIRM.AF_STATUS Status
JScript
public Status : AF_DATA_CONFIRM.AF_STATUS;

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace


TransID Field

AF_DATA_CONFIRM.TransID Field
[image]

Transaction ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransID As Byte
C#
public byte TransID;
C++
public:
char TransID sealed ;
J#
public byte TransID
JScript
public TransID : Byte;

See Also

AF_DATA_CONFIRM Class
TI.ZPI2 Namespace


AF_DATA_CONFIRM.AF_STATUS Enumeration

AF_DATA_CONFIRM.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_DATA_CONFIRM.AF_STATUS As Byte
C#
public enum AF_DATA_CONFIRM.AF_STATUS : byte
C++
public enum class AF_DATA_CONFIRM.AF_STATUS : char
J#
public enum AF_DATA_CONFIRM.AF_STATUS byte
JScript
public enum AF_DATA_CONFIRM.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


AF_DATA_REQUEST Class

AF_DATA_REQUEST Class
See Also Example Members
[image]

This command is used by tester to build and send a data request message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_REQUEST
Implements IREQUEST, IAF
C#
public class AF_DATA_REQUEST : IREQUEST, IAF
C++
ref class AF_DATA_REQUEST : IREQUEST, IAF
J#
public class AF_DATA_REQUEST implements IREQUEST, IAF
JScript
public class AF_DATA_REQUEST extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_REQUEST Members
TI.ZPI2 Namespace


AF_DATA_REQUEST Members

AF_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to build and send a data request message

The following tables list the members exposed by AF_DATA_REQUEST.

Public Constructors

Name | Description
AF_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame
Public field | DestEndpoint | specifies the endpoint of the device
Public field | DstAddr | the address of the destination device
Public field | Len | specifies the length of the TransactionData field
Public field | Options | consists of the AF Tx Options bit fields; zero for none
Public field | Radius | the number of hops allowed to deliver the message; usually use 7
Public field | SrcEndpoint | specifies the endpoint of the device
Public field | TransID | specifies the transaction Id of the device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_REQUEST | Overloaded.
Top

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


AF_DATA_REQUEST Constructor

AF_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | AF_DATA_REQUEST | Constructor
Public method | AF_DATA_REQUEST (UInt16, Byte, Byte, UInt16, Byte, Byte, Byte, Byte, Byte) | Constructor

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


AF_DATA_REQUEST Constructor ()

AF_DATA_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_REQUEST()
C++
public:
AF_DATA_REQUEST() sealed
J#
public AF_DATA_REQUEST()
JScript
public function AF_DATA_REQUEST()

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace
AF_DATA_REQUEST Constructor Overload List


AF_DATA_REQUEST Constructor (UInt16, Byte, Byte, UInt16, Byte, Byte, Byte, Byte, Byte[])

AF_DATA_REQUEST Constructor (UInt16, Byte, Byte, UInt16, Byte, Byte, Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public AF_DATA_REQUEST(
ushort ,
byte ,
byte ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[]
)
C++
public:
AF_DATA_REQUEST(
unsigned short ,
char ,
char ,
unsigned short ,
char ,
char ,
char ,
char ,
array<char>^
) sealed
J#
public AF_DATA_REQUEST(
ushort ,
byte ,
byte ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[]
)
JScript
public function AF_DATA_REQUEST(
: UInt16,
: Byte,
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[]
)

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace
AF_DATA_REQUEST Constructor Overload List


Fields

AF_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame
Public field | DestEndpoint | specifies the endpoint of the device
Public field | DstAddr | the address of the destination device
Public field | Len | specifies the length of the TransactionData field
Public field | Options | consists of the AF Tx Options bit fields; zero for none
Public field | Radius | the number of hops allowed to deliver the message; usually use 7
Public field | SrcEndpoint | specifies the endpoint of the device
Public field | TransID | specifies the transaction Id of the device
Top

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


ClusterID Field

AF_DATA_REQUEST.ClusterID Field
[image]

specifies the cluster ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


Data Field

AF_DATA_REQUEST.Data Field
[image]

Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


DestEndpoint Field

AF_DATA_REQUEST.DestEndpoint Field
[image]

specifies the endpoint of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


DstAddr Field

AF_DATA_REQUEST.DstAddr Field
[image]

the address of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


Len Field

AF_DATA_REQUEST.Len Field
[image]

specifies the length of the TransactionData field

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


Options Field

AF_DATA_REQUEST.Options Field
[image]

consists of the AF Tx Options bit fields; zero for none

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Options As Byte
C#
public byte Options;
C++
public:
char Options sealed ;
J#
public byte Options
JScript
public Options : Byte;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


Radius Field

AF_DATA_REQUEST.Radius Field
[image]

the number of hops allowed to deliver the message; usually use 7

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Radius As Byte
C#
public byte Radius;
C++
public:
char Radius sealed ;
J#
public byte Radius
JScript
public Radius : Byte;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


SrcEndpoint Field

AF_DATA_REQUEST.SrcEndpoint Field
[image]

specifies the endpoint of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


TransID Field

AF_DATA_REQUEST.TransID Field
[image]

specifies the transaction Id of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransID As Byte
C#
public byte TransID;
C++
public:
char TransID sealed ;
J#
public byte TransID
JScript
public TransID : Byte;

See Also

AF_DATA_REQUEST Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT Class

AF_DATA_REQUEST_EXT Class
See Also Example Members
[image]

This command is used by tester to build and send a data request message with PanId field.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_REQUEST_EXT
Implements IREQUEST, IAF
C#
public class AF_DATA_REQUEST_EXT : IREQUEST, IAF
C++
ref class AF_DATA_REQUEST_EXT : IREQUEST, IAF
J#
public class AF_DATA_REQUEST_EXT implements IREQUEST, IAF
JScript
public class AF_DATA_REQUEST_EXT extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_REQUEST_EXT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_REQUEST_EXT Members
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT Members

AF_DATA_REQUEST_EXT Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to build and send a data request message with PanId field.

The following tables list the members exposed by AF_DATA_REQUEST_EXT.

Public Constructors

Name | Description
AF_DATA_REQUEST_EXT | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame
Public field | DstAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | DstEndPoint | The destination EndPoint.
Public field | DstPanId | The destination PanId.
Public field | Len | Specifies the length of the TransactionData field (LSB:MSB).
Public field | Options | consists of the AF Tx Options bit fields; zero for none
Public field | Radius | the number of hops allowed to deliver the message; usually use 7
Public field | SrcEndpoint | specifies the endpoint of the device
Public field | TransID | specifies the transaction Id of the device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_REQUEST_EXT | Overloaded.
Top

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT Constructor

AF_DATA_REQUEST_EXT Constructor

Overload List

 | Name | Description
Public method | AF_DATA_REQUEST_EXT | Constructor
Public method | AF_DATA_REQUEST_EXT (AF_DATA_REQUEST_EXT.ADDRESS_MODE, Byte, Byte, UInt16, Byte, UInt16, Byte, Byte, Byte, UInt16, Byte) |

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT Constructor ()

AF_DATA_REQUEST_EXT Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_REQUEST_EXT()
C++
public:
AF_DATA_REQUEST_EXT() sealed
J#
public AF_DATA_REQUEST_EXT()
JScript
public function AF_DATA_REQUEST_EXT()

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_EXT Constructor Overload List


AF_DATA_REQUEST_EXT Constructor (AF_DATA_REQUEST_EXT.ADDRESS_MODE, Byte[], Byte, UInt16, Byte, UInt16, Byte, Byte, Byte, UInt16, Byte[])

AF_DATA_REQUEST_EXT Constructor (AF_DATA_REQUEST_EXT.ADDRESS_MODE, Byte[], Byte, UInt16, Byte, UInt16, Byte, Byte, Byte, UInt16, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_DATA_REQUEST_EXT.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte() _
)
C#
public AF_DATA_REQUEST_EXT(
AF_DATA_REQUEST_EXT.ADDRESS_MODE ,
byte[] ,
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte ,
byte ,
ushort ,
byte[]
)
C++
public:
AF_DATA_REQUEST_EXT(
AF_DATA_REQUEST_EXT.ADDRESS_MODE ,
array<char>^ ,
char ,
unsigned short ,
char ,
unsigned short ,
char ,
char ,
char ,
unsigned short ,
array<char>^
) sealed
J#
public AF_DATA_REQUEST_EXT(
AF_DATA_REQUEST_EXT.ADDRESS_MODE ,
byte[] ,
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte ,
byte ,
ushort ,
byte[]
)
JScript
public function AF_DATA_REQUEST_EXT(
: AF_DATA_REQUEST_EXT.ADDRESS_MODE,
: Byte[],
: Byte,
: UInt16,
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte,
: UInt16,
: Byte[]
)

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_EXT Constructor Overload List


Fields

AF_DATA_REQUEST_EXT Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame
Public field | DstAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | DstEndPoint | The destination EndPoint.
Public field | DstPanId | The destination PanId.
Public field | Len | Specifies the length of the TransactionData field (LSB:MSB).
Public field | Options | consists of the AF Tx Options bit fields; zero for none
Public field | Radius | the number of hops allowed to deliver the message; usually use 7
Public field | SrcEndpoint | specifies the endpoint of the device
Public field | TransID | specifies the transaction Id of the device
Top

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


ClusterID Field

AF_DATA_REQUEST_EXT.ClusterID Field
[image]

specifies the cluster ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


Data Field

AF_DATA_REQUEST_EXT.Data Field
[image]

Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


DstAddr Field

AF_DATA_REQUEST_EXT.DstAddr Field
[image]

The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As Byte()
C#
public byte[] DstAddr;
C++
public:
array<char>^ DstAddr sealed ;
J#
public byte[] DstAddr
JScript
public DstAddr : Byte[];

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


DstAddrMode Field

AF_DATA_REQUEST_EXT.DstAddrMode Field
[image]

The destination address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As AF_DATA_REQUEST_EXT.ADDRESS_MODE
C#
public AF_DATA_REQUEST_EXT.ADDRESS_MODE DstAddrMode;
C++
public:
AF_DATA_REQUEST_EXT.ADDRESS_MODE DstAddrMode sealed ;
J#
public AF_DATA_REQUEST_EXT.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : AF_DATA_REQUEST_EXT.ADDRESS_MODE;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


DstEndPoint Field

AF_DATA_REQUEST_EXT.DstEndPoint Field
[image]

The destination EndPoint.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstEndPoint As Byte
C#
public byte DstEndPoint;
C++
public:
char DstEndPoint sealed ;
J#
public byte DstEndPoint
JScript
public DstEndPoint : Byte;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


DstPanId Field

AF_DATA_REQUEST_EXT.DstPanId Field
[image]

The destination PanId.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstPanId As UInt16
C#
public ushort DstPanId;
C++
public:
unsigned short DstPanId sealed ;
J#
public ushort DstPanId
JScript
public DstPanId : UInt16;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


Len Field

AF_DATA_REQUEST_EXT.Len Field
[image]

Specifies the length of the TransactionData field (LSB:MSB).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As UInt16
C#
public ushort Len;
C++
public:
unsigned short Len sealed ;
J#
public ushort Len
JScript
public Len : UInt16;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


Options Field

AF_DATA_REQUEST_EXT.Options Field
[image]

consists of the AF Tx Options bit fields; zero for none

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Options As Byte
C#
public byte Options;
C++
public:
char Options sealed ;
J#
public byte Options
JScript
public Options : Byte;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


Radius Field

AF_DATA_REQUEST_EXT.Radius Field
[image]

the number of hops allowed to deliver the message; usually use 7

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Radius As Byte
C#
public byte Radius;
C++
public:
char Radius sealed ;
J#
public byte Radius
JScript
public Radius : Byte;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


SrcEndpoint Field

AF_DATA_REQUEST_EXT.SrcEndpoint Field
[image]

specifies the endpoint of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


TransID Field

AF_DATA_REQUEST_EXT.TransID Field
[image]

specifies the transaction Id of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransID As Byte
C#
public byte TransID;
C++
public:
char TransID sealed ;
J#
public byte TransID
JScript
public TransID : Byte;

See Also

AF_DATA_REQUEST_EXT Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT.ADDRESS_MODE Enumeration

AF_DATA_REQUEST_EXT.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_DATA_REQUEST_EXT.ADDRESS_MODE As Byte
C#
public enum AF_DATA_REQUEST_EXT.ADDRESS_MODE : byte
C++
public enum class AF_DATA_REQUEST_EXT.ADDRESS_MODE : char
J#
public enum AF_DATA_REQUEST_EXT.ADDRESS_MODE byte
JScript
public enum AF_DATA_REQUEST_EXT.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT_SRSP Class

AF_DATA_REQUEST_EXT_SRSP Class
See Also Example Members
[image]

Response for AF_DATA_REQUEST_EXT

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_REQUEST_EXT_SRSP
Implements IRESPONSE, IAF
C#
public class AF_DATA_REQUEST_EXT_SRSP : IRESPONSE, IAF
C++
ref class AF_DATA_REQUEST_EXT_SRSP : IRESPONSE, IAF
J#
public class AF_DATA_REQUEST_EXT_SRSP implements IRESPONSE, IAF
JScript
public class AF_DATA_REQUEST_EXT_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_REQUEST_EXT_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_REQUEST_EXT_SRSP Members
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT_SRSP Members

AF_DATA_REQUEST_EXT_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_DATA_REQUEST_EXT

The following tables list the members exposed by AF_DATA_REQUEST_EXT_SRSP.

Public Constructors

Name | Description
AF_DATA_REQUEST_EXT_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_REQUEST_EXT_SRSP | Overloaded.
Top

See Also

AF_DATA_REQUEST_EXT_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT_SRSP Constructor

AF_DATA_REQUEST_EXT_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_DATA_REQUEST_EXT_SRSP | Constructor
Public method | AF_DATA_REQUEST_EXT_SRSP (AF_DATA_REQUEST_EXT_SRSP.AF_STATUS) |

See Also

AF_DATA_REQUEST_EXT_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT_SRSP Constructor ()

AF_DATA_REQUEST_EXT_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_REQUEST_EXT_SRSP()
C++
public:
AF_DATA_REQUEST_EXT_SRSP() sealed
J#
public AF_DATA_REQUEST_EXT_SRSP()
JScript
public function AF_DATA_REQUEST_EXT_SRSP()

See Also

AF_DATA_REQUEST_EXT_SRSP Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_EXT_SRSP Constructor Overload List


AF_DATA_REQUEST_EXT_SRSP Constructor (AF_DATA_REQUEST_EXT_SRSP.AF_STATUS)

AF_DATA_REQUEST_EXT_SRSP Constructor (AF_DATA_REQUEST_EXT_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_DATA_REQUEST_EXT_SRSP.AF_STATUS _
)
C#
public AF_DATA_REQUEST_EXT_SRSP(
AF_DATA_REQUEST_EXT_SRSP.AF_STATUS
)
C++
public:
AF_DATA_REQUEST_EXT_SRSP(
AF_DATA_REQUEST_EXT_SRSP.AF_STATUS
) sealed
J#
public AF_DATA_REQUEST_EXT_SRSP(
AF_DATA_REQUEST_EXT_SRSP.AF_STATUS
)
JScript
public function AF_DATA_REQUEST_EXT_SRSP(
: AF_DATA_REQUEST_EXT_SRSP.AF_STATUS
)

See Also

AF_DATA_REQUEST_EXT_SRSP Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_EXT_SRSP Constructor Overload List


Fields

AF_DATA_REQUEST_EXT_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_DATA_REQUEST_EXT_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_DATA_REQUEST_EXT_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_DATA_REQUEST_EXT_SRSP.AF_STATUS
C#
public AF_DATA_REQUEST_EXT_SRSP.AF_STATUS Status;
C++
public:
AF_DATA_REQUEST_EXT_SRSP.AF_STATUS Status sealed ;
J#
public AF_DATA_REQUEST_EXT_SRSP.AF_STATUS Status
JScript
public Status : AF_DATA_REQUEST_EXT_SRSP.AF_STATUS;

See Also

AF_DATA_REQUEST_EXT_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_EXT_SRSP.AF_STATUS Enumeration

AF_DATA_REQUEST_EXT_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_DATA_REQUEST_EXT_SRSP.AF_STATUS As Byte
C#
public enum AF_DATA_REQUEST_EXT_SRSP.AF_STATUS : byte
C++
public enum class AF_DATA_REQUEST_EXT_SRSP.AF_STATUS : char
J#
public enum AF_DATA_REQUEST_EXT_SRSP.AF_STATUS byte
JScript
public enum AF_DATA_REQUEST_EXT_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG Class

AF_DATA_REQUEST_SRC_RTG Class
See Also Example Members
[image]

This command is used by tester to build and send a data request message via source routing

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_REQUEST_SRC_RTG
Implements IREQUEST, IAF
C#
public class AF_DATA_REQUEST_SRC_RTG : IREQUEST, IAF
C++
ref class AF_DATA_REQUEST_SRC_RTG : IREQUEST, IAF
J#
public class AF_DATA_REQUEST_SRC_RTG implements IREQUEST, IAF
JScript
public class AF_DATA_REQUEST_SRC_RTG extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_REQUEST_SRC_RTG Members
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG Members

AF_DATA_REQUEST_SRC_RTG Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to build and send a data request message via source routing

The following tables list the members exposed by AF_DATA_REQUEST_SRC_RTG.

Public Constructors

Name | Description
AF_DATA_REQUEST_SRC_RTG | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame
Public field | DestEndpoint | specifies the endpoint of the device
Public field | DstAddr | the address of the destination device
Public field | Len | specifies the length of the TransactionData field
Public field | Options | consists of the AF Tx Options bit fields; zero for none
Public field | Radius | the number of hops allowed to deliver the message; usually use 7
Public field | RelayCount | The number of devices in the relay list for source routing
Public field | RelayList | List of relay devices on the source routing path. For each device, it contains 2 bytes short address for each device.
Public field | SrcEndpoint | specifies the endpoint of the device
Public field | TransID | specifies the transaction Id of the device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_REQUEST_SRC_RTG | Overloaded.
Top

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG Constructor

AF_DATA_REQUEST_SRC_RTG Constructor

Overload List

 | Name | Description
Public method | AF_DATA_REQUEST_SRC_RTG | Constructor
Public method | AF_DATA_REQUEST_SRC_RTG (UInt16, Byte, Byte, UInt16, Byte, Byte, Byte, Byte, UInt16, Byte, Byte) | Constructor

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG Constructor ()

AF_DATA_REQUEST_SRC_RTG Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_REQUEST_SRC_RTG()
C++
public:
AF_DATA_REQUEST_SRC_RTG() sealed
J#
public AF_DATA_REQUEST_SRC_RTG()
JScript
public function AF_DATA_REQUEST_SRC_RTG()

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_SRC_RTG Constructor Overload List


AF_DATA_REQUEST_SRC_RTG Constructor (UInt16, Byte, Byte, UInt16, Byte, Byte, Byte, Byte, UInt16[], Byte, Byte[])

AF_DATA_REQUEST_SRC_RTG Constructor (UInt16, Byte, Byte, UInt16, Byte, Byte, Byte, Byte, UInt16[], Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public AF_DATA_REQUEST_SRC_RTG(
ushort ,
byte ,
byte ,
ushort ,
byte ,
byte ,
byte ,
byte ,
ushort[] ,
byte ,
byte[]
)
C++
public:
AF_DATA_REQUEST_SRC_RTG(
unsigned short ,
char ,
char ,
unsigned short ,
char ,
char ,
char ,
char ,
array<unsigned short>^ ,
char ,
array<char>^
) sealed
J#
public AF_DATA_REQUEST_SRC_RTG(
ushort ,
byte ,
byte ,
ushort ,
byte ,
byte ,
byte ,
byte ,
ushort[] ,
byte ,
byte[]
)
JScript
public function AF_DATA_REQUEST_SRC_RTG(
: UInt16,
: Byte,
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: UInt16[],
: Byte,
: Byte[]
)

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_SRC_RTG Constructor Overload List


Fields

AF_DATA_REQUEST_SRC_RTG Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame
Public field | DestEndpoint | specifies the endpoint of the device
Public field | DstAddr | the address of the destination device
Public field | Len | specifies the length of the TransactionData field
Public field | Options | consists of the AF Tx Options bit fields; zero for none
Public field | Radius | the number of hops allowed to deliver the message; usually use 7
Public field | RelayCount | The number of devices in the relay list for source routing
Public field | RelayList | List of relay devices on the source routing path. For each device, it contains 2 bytes short address for each device.
Public field | SrcEndpoint | specifies the endpoint of the device
Public field | TransID | specifies the transaction Id of the device
Top

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


ClusterID Field

AF_DATA_REQUEST_SRC_RTG.ClusterID Field
[image]

specifies the cluster ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


Data Field

AF_DATA_REQUEST_SRC_RTG.Data Field
[image]

Dynamic array, requires memory allocation. Variable length field of size 'Len' and is the transaction data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


DestEndpoint Field

AF_DATA_REQUEST_SRC_RTG.DestEndpoint Field
[image]

specifies the endpoint of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


DstAddr Field

AF_DATA_REQUEST_SRC_RTG.DstAddr Field
[image]

the address of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


Len Field

AF_DATA_REQUEST_SRC_RTG.Len Field
[image]

specifies the length of the TransactionData field

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


Options Field

AF_DATA_REQUEST_SRC_RTG.Options Field
[image]

consists of the AF Tx Options bit fields; zero for none

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Options As Byte
C#
public byte Options;
C++
public:
char Options sealed ;
J#
public byte Options
JScript
public Options : Byte;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


Radius Field

AF_DATA_REQUEST_SRC_RTG.Radius Field
[image]

the number of hops allowed to deliver the message; usually use 7

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Radius As Byte
C#
public byte Radius;
C++
public:
char Radius sealed ;
J#
public byte Radius
JScript
public Radius : Byte;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


RelayCount Field

AF_DATA_REQUEST_SRC_RTG.RelayCount Field
[image]

The number of devices in the relay list for source routing

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RelayCount As Byte
C#
public byte RelayCount;
C++
public:
char RelayCount sealed ;
J#
public byte RelayCount
JScript
public RelayCount : Byte;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


RelayList Field

AF_DATA_REQUEST_SRC_RTG.RelayList Field
[image]

List of relay devices on the source routing path. For each device, it contains 2 bytes short address for each device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RelayList As UInt16()
C#
public ushort[] RelayList;
C++
public:
array<unsigned short>^ RelayList sealed ;
J#
public ushort[] RelayList
JScript
public RelayList : UInt16[];

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


SrcEndpoint Field

AF_DATA_REQUEST_SRC_RTG.SrcEndpoint Field
[image]

specifies the endpoint of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


TransID Field

AF_DATA_REQUEST_SRC_RTG.TransID Field
[image]

specifies the transaction Id of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransID As Byte
C#
public byte TransID;
C++
public:
char TransID sealed ;
J#
public byte TransID
JScript
public TransID : Byte;

See Also

AF_DATA_REQUEST_SRC_RTG Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG_SRSP Class

AF_DATA_REQUEST_SRC_RTG_SRSP Class
See Also Example Members
[image]

Response for AF_DATA_REQUEST_SRC_RTG

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_REQUEST_SRC_RTG_SRSP
Implements IRESPONSE, IAF
C#
public class AF_DATA_REQUEST_SRC_RTG_SRSP : IRESPONSE, IAF
C++
ref class AF_DATA_REQUEST_SRC_RTG_SRSP : IRESPONSE, IAF
J#
public class AF_DATA_REQUEST_SRC_RTG_SRSP implements IRESPONSE, IAF
JScript
public class AF_DATA_REQUEST_SRC_RTG_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_REQUEST_SRC_RTG_SRSP Members
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG_SRSP Members

AF_DATA_REQUEST_SRC_RTG_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_DATA_REQUEST_SRC_RTG

The following tables list the members exposed by AF_DATA_REQUEST_SRC_RTG_SRSP.

Public Constructors

Name | Description
AF_DATA_REQUEST_SRC_RTG_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_REQUEST_SRC_RTG_SRSP | Overloaded.
Top

See Also

AF_DATA_REQUEST_SRC_RTG_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG_SRSP Constructor

AF_DATA_REQUEST_SRC_RTG_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_DATA_REQUEST_SRC_RTG_SRSP | Constructor
Public method | AF_DATA_REQUEST_SRC_RTG_SRSP (AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS) |

See Also

AF_DATA_REQUEST_SRC_RTG_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG_SRSP Constructor ()

AF_DATA_REQUEST_SRC_RTG_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_REQUEST_SRC_RTG_SRSP()
C++
public:
AF_DATA_REQUEST_SRC_RTG_SRSP() sealed
J#
public AF_DATA_REQUEST_SRC_RTG_SRSP()
JScript
public function AF_DATA_REQUEST_SRC_RTG_SRSP()

See Also

AF_DATA_REQUEST_SRC_RTG_SRSP Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_SRC_RTG_SRSP Constructor Overload List


AF_DATA_REQUEST_SRC_RTG_SRSP Constructor (AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS)

AF_DATA_REQUEST_SRC_RTG_SRSP Constructor (AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS _
)
C#
public AF_DATA_REQUEST_SRC_RTG_SRSP(
AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS
)
C++
public:
AF_DATA_REQUEST_SRC_RTG_SRSP(
AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS
) sealed
J#
public AF_DATA_REQUEST_SRC_RTG_SRSP(
AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS
)
JScript
public function AF_DATA_REQUEST_SRC_RTG_SRSP(
: AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS
)

See Also

AF_DATA_REQUEST_SRC_RTG_SRSP Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_SRC_RTG_SRSP Constructor Overload List


Fields

AF_DATA_REQUEST_SRC_RTG_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_DATA_REQUEST_SRC_RTG_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_DATA_REQUEST_SRC_RTG_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS
C#
public AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS Status;
C++
public:
AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS Status sealed ;
J#
public AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS Status
JScript
public Status : AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS;

See Also

AF_DATA_REQUEST_SRC_RTG_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS Enumeration

AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS As Byte
C#
public enum AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS : byte
C++
public enum class AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS : char
J#
public enum AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS byte
JScript
public enum AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


AF_DATA_REQUEST_SRSP Class

AF_DATA_REQUEST_SRSP Class
See Also Example Members
[image]

Response for AF_DATA_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_REQUEST_SRSP
Implements IRESPONSE, IAF
C#
public class AF_DATA_REQUEST_SRSP : IRESPONSE, IAF
C++
ref class AF_DATA_REQUEST_SRSP : IRESPONSE, IAF
J#
public class AF_DATA_REQUEST_SRSP implements IRESPONSE, IAF
JScript
public class AF_DATA_REQUEST_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_REQUEST_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_REQUEST_SRSP Members
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRSP Members

AF_DATA_REQUEST_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_DATA_REQUEST

The following tables list the members exposed by AF_DATA_REQUEST_SRSP.

Public Constructors

Name | Description
AF_DATA_REQUEST_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_REQUEST_SRSP | Overloaded.
Top

See Also

AF_DATA_REQUEST_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRSP Constructor

AF_DATA_REQUEST_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_DATA_REQUEST_SRSP | Constructor
Public method | AF_DATA_REQUEST_SRSP (AF_DATA_REQUEST_SRSP.AF_STATUS) |

See Also

AF_DATA_REQUEST_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRSP Constructor ()

AF_DATA_REQUEST_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_REQUEST_SRSP()
C++
public:
AF_DATA_REQUEST_SRSP() sealed
J#
public AF_DATA_REQUEST_SRSP()
JScript
public function AF_DATA_REQUEST_SRSP()

See Also

AF_DATA_REQUEST_SRSP Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_SRSP Constructor Overload List


AF_DATA_REQUEST_SRSP Constructor (AF_DATA_REQUEST_SRSP.AF_STATUS)

AF_DATA_REQUEST_SRSP Constructor (AF_DATA_REQUEST_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_DATA_REQUEST_SRSP.AF_STATUS _
)
C#
public AF_DATA_REQUEST_SRSP(
AF_DATA_REQUEST_SRSP.AF_STATUS
)
C++
public:
AF_DATA_REQUEST_SRSP(
AF_DATA_REQUEST_SRSP.AF_STATUS
) sealed
J#
public AF_DATA_REQUEST_SRSP(
AF_DATA_REQUEST_SRSP.AF_STATUS
)
JScript
public function AF_DATA_REQUEST_SRSP(
: AF_DATA_REQUEST_SRSP.AF_STATUS
)

See Also

AF_DATA_REQUEST_SRSP Class
TI.ZPI2 Namespace
AF_DATA_REQUEST_SRSP Constructor Overload List


Fields

AF_DATA_REQUEST_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_DATA_REQUEST_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_DATA_REQUEST_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_DATA_REQUEST_SRSP.AF_STATUS
C#
public AF_DATA_REQUEST_SRSP.AF_STATUS Status;
C++
public:
AF_DATA_REQUEST_SRSP.AF_STATUS Status sealed ;
J#
public AF_DATA_REQUEST_SRSP.AF_STATUS Status
JScript
public Status : AF_DATA_REQUEST_SRSP.AF_STATUS;

See Also

AF_DATA_REQUEST_SRSP Class
TI.ZPI2 Namespace


AF_DATA_REQUEST_SRSP.AF_STATUS Enumeration

AF_DATA_REQUEST_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_DATA_REQUEST_SRSP.AF_STATUS As Byte
C#
public enum AF_DATA_REQUEST_SRSP.AF_STATUS : byte
C++
public enum class AF_DATA_REQUEST_SRSP.AF_STATUS : char
J#
public enum AF_DATA_REQUEST_SRSP.AF_STATUS byte
JScript
public enum AF_DATA_REQUEST_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


AF_DATA_RETRIEVE Class

AF_DATA_RETRIEVE Class
See Also Example Members
[image]

AF huge incoming message data retrieve command.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_RETRIEVE
Implements IREQUEST, IAF
C#
public class AF_DATA_RETRIEVE : IREQUEST, IAF
C++
ref class AF_DATA_RETRIEVE : IREQUEST, IAF
J#
public class AF_DATA_RETRIEVE implements IREQUEST, IAF
JScript
public class AF_DATA_RETRIEVE extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_RETRIEVE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_RETRIEVE Members
TI.ZPI2 Namespace


AF_DATA_RETRIEVE Members

AF_DATA_RETRIEVE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

AF huge incoming message data retrieve command.

The following tables list the members exposed by AF_DATA_RETRIEVE.

Public Constructors

Name | Description
AF_DATA_RETRIEVE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Index | Index into the incoming data buffer to start the retrieving of this chunk of data.
Public field | Length | Length of this chunk of data to retrieve from the incoming data buffer.
Public field | Timestamp | Timestamp of the incoming message in order to identify it in a list of incoming huge messages.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_RETRIEVE | Overloaded.
Top

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace


AF_DATA_RETRIEVE Constructor

AF_DATA_RETRIEVE Constructor

Overload List

 | Name | Description
Public method | AF_DATA_RETRIEVE | Constructor
Public method | AF_DATA_RETRIEVE (UInt32, UInt16, Byte) | Constructor

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace


AF_DATA_RETRIEVE Constructor ()

AF_DATA_RETRIEVE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_RETRIEVE()
C++
public:
AF_DATA_RETRIEVE() sealed
J#
public AF_DATA_RETRIEVE()
JScript
public function AF_DATA_RETRIEVE()

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace
AF_DATA_RETRIEVE Constructor Overload List


AF_DATA_RETRIEVE Constructor (UInt32, UInt16, Byte)

AF_DATA_RETRIEVE Constructor (UInt32, UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt32, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public AF_DATA_RETRIEVE(
uint ,
ushort ,
byte
)
C++
public:
AF_DATA_RETRIEVE(
unsigned int ,
unsigned short ,
char
) sealed
J#
public AF_DATA_RETRIEVE(
uint ,
ushort ,
byte
)
JScript
public function AF_DATA_RETRIEVE(
: UInt32,
: UInt16,
: Byte
)

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace
AF_DATA_RETRIEVE Constructor Overload List


Fields

AF_DATA_RETRIEVE Fields
[image]

Public Fields

 | Name | Description
Public field | Index | Index into the incoming data buffer to start the retrieving of this chunk of data.
Public field | Length | Length of this chunk of data to retrieve from the incoming data buffer.
Public field | Timestamp | Timestamp of the incoming message in order to identify it in a list of incoming huge messages.
Top

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace


Index Field

AF_DATA_RETRIEVE.Index Field
[image]

Index into the incoming data buffer to start the retrieving of this chunk of data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index As UInt16
C#
public ushort Index;
C++
public:
unsigned short Index sealed ;
J#
public ushort Index
JScript
public Index : UInt16;

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace


Length Field

AF_DATA_RETRIEVE.Length Field
[image]

Length of this chunk of data to retrieve from the incoming data buffer.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace


Timestamp Field

AF_DATA_RETRIEVE.Timestamp Field
[image]

Timestamp of the incoming message in order to identify it in a list of incoming huge messages.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp As UInt32
C#
public uint Timestamp;
C++
public:
unsigned int Timestamp sealed ;
J#
public uint Timestamp
JScript
public Timestamp : UInt32;

See Also

AF_DATA_RETRIEVE Class
TI.ZPI2 Namespace


AF_DATA_RETRIEVE_SRSP Class

AF_DATA_RETRIEVE_SRSP Class
See Also Example Members
[image]

Response for AF_DATA_RETRIEVE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_RETRIEVE_SRSP
Implements IRESPONSE, IAF
C#
public class AF_DATA_RETRIEVE_SRSP : IRESPONSE, IAF
C++
ref class AF_DATA_RETRIEVE_SRSP : IRESPONSE, IAF
J#
public class AF_DATA_RETRIEVE_SRSP implements IRESPONSE, IAF
JScript
public class AF_DATA_RETRIEVE_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_RETRIEVE_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_RETRIEVE_SRSP Members
TI.ZPI2 Namespace


AF_DATA_RETRIEVE_SRSP Members

AF_DATA_RETRIEVE_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_DATA_RETRIEVE

The following tables list the members exposed by AF_DATA_RETRIEVE_SRSP.

Public Constructors

Name | Description
AF_DATA_RETRIEVE_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Data | Variable length data field depends on Length parameter which is thhe data of length specified and retrieved from the index specified from the huge incoming message.
Public field | Length | Length of this chunk of data to store into the outgoing data buffer.
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_RETRIEVE_SRSP | Overloaded.
Top

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace


AF_DATA_RETRIEVE_SRSP Constructor

AF_DATA_RETRIEVE_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_DATA_RETRIEVE_SRSP | Constructor
Public method | AF_DATA_RETRIEVE_SRSP (AF_DATA_RETRIEVE_SRSP.AF_STATUS, Byte, Byte) |

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace


AF_DATA_RETRIEVE_SRSP Constructor ()

AF_DATA_RETRIEVE_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_RETRIEVE_SRSP()
C++
public:
AF_DATA_RETRIEVE_SRSP() sealed
J#
public AF_DATA_RETRIEVE_SRSP()
JScript
public function AF_DATA_RETRIEVE_SRSP()

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace
AF_DATA_RETRIEVE_SRSP Constructor Overload List


AF_DATA_RETRIEVE_SRSP Constructor (AF_DATA_RETRIEVE_SRSP.AF_STATUS, Byte, Byte[])

AF_DATA_RETRIEVE_SRSP Constructor (AF_DATA_RETRIEVE_SRSP.AF_STATUS, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_DATA_RETRIEVE_SRSP.AF_STATUS, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public AF_DATA_RETRIEVE_SRSP(
AF_DATA_RETRIEVE_SRSP.AF_STATUS ,
byte ,
byte[]
)
C++
public:
AF_DATA_RETRIEVE_SRSP(
AF_DATA_RETRIEVE_SRSP.AF_STATUS ,
char ,
array<char>^
) sealed
J#
public AF_DATA_RETRIEVE_SRSP(
AF_DATA_RETRIEVE_SRSP.AF_STATUS ,
byte ,
byte[]
)
JScript
public function AF_DATA_RETRIEVE_SRSP(
: AF_DATA_RETRIEVE_SRSP.AF_STATUS,
: Byte,
: Byte[]
)

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace
AF_DATA_RETRIEVE_SRSP Constructor Overload List


Fields

AF_DATA_RETRIEVE_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Data | Variable length data field depends on Length parameter which is thhe data of length specified and retrieved from the index specified from the huge incoming message.
Public field | Length | Length of this chunk of data to store into the outgoing data buffer.
Public field | Status | Status
Top

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace


Data Field

AF_DATA_RETRIEVE_SRSP.Data Field
[image]

Variable length data field depends on Length parameter which is thhe data of length specified and retrieved from the index specified from the huge incoming message.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace


Length Field

AF_DATA_RETRIEVE_SRSP.Length Field
[image]

Length of this chunk of data to store into the outgoing data buffer.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_DATA_RETRIEVE_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_DATA_RETRIEVE_SRSP.AF_STATUS
C#
public AF_DATA_RETRIEVE_SRSP.AF_STATUS Status;
C++
public:
AF_DATA_RETRIEVE_SRSP.AF_STATUS Status sealed ;
J#
public AF_DATA_RETRIEVE_SRSP.AF_STATUS Status
JScript
public Status : AF_DATA_RETRIEVE_SRSP.AF_STATUS;

See Also

AF_DATA_RETRIEVE_SRSP Class
TI.ZPI2 Namespace


AF_DATA_RETRIEVE_SRSP.AF_STATUS Enumeration

AF_DATA_RETRIEVE_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_DATA_RETRIEVE_SRSP.AF_STATUS As Byte
C#
public enum AF_DATA_RETRIEVE_SRSP.AF_STATUS : byte
C++
public enum class AF_DATA_RETRIEVE_SRSP.AF_STATUS : char
J#
public enum AF_DATA_RETRIEVE_SRSP.AF_STATUS byte
JScript
public enum AF_DATA_RETRIEVE_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


AF_DATA_STORE Class

AF_DATA_STORE Class
See Also Example Members
[image]

AF huge data request data store command and data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_STORE
Implements IREQUEST, IAF
C#
public class AF_DATA_STORE : IREQUEST, IAF
C++
ref class AF_DATA_STORE : IREQUEST, IAF
J#
public class AF_DATA_STORE implements IREQUEST, IAF
JScript
public class AF_DATA_STORE extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_STORE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_STORE Members
TI.ZPI2 Namespace


AF_DATA_STORE Members

AF_DATA_STORE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

AF huge data request data store command and data.

The following tables list the members exposed by AF_DATA_STORE.

Public Constructors

Name | Description
AF_DATA_STORE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Data | Variable length data field depends on Length parameter.
Public field | Index | Index into the outgoing data buffer to start the storing of this chunk of data.
Public field | Length | Length of this chunk of data to store into the outgoing data buffer.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_STORE | Overloaded.
Top

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace


AF_DATA_STORE Constructor

AF_DATA_STORE Constructor

Overload List

 | Name | Description
Public method | AF_DATA_STORE | Constructor
Public method | AF_DATA_STORE (UInt16, Byte, Byte) | Constructor

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace


AF_DATA_STORE Constructor ()

AF_DATA_STORE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_STORE()
C++
public:
AF_DATA_STORE() sealed
J#
public AF_DATA_STORE()
JScript
public function AF_DATA_STORE()

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace
AF_DATA_STORE Constructor Overload List


AF_DATA_STORE Constructor (UInt16, Byte, Byte[])

AF_DATA_STORE Constructor (UInt16, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public AF_DATA_STORE(
ushort ,
byte ,
byte[]
)
C++
public:
AF_DATA_STORE(
unsigned short ,
char ,
array<char>^
) sealed
J#
public AF_DATA_STORE(
ushort ,
byte ,
byte[]
)
JScript
public function AF_DATA_STORE(
: UInt16,
: Byte,
: Byte[]
)

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace
AF_DATA_STORE Constructor Overload List


Fields

AF_DATA_STORE Fields
[image]

Public Fields

 | Name | Description
Public field | Data | Variable length data field depends on Length parameter.
Public field | Index | Index into the outgoing data buffer to start the storing of this chunk of data.
Public field | Length | Length of this chunk of data to store into the outgoing data buffer.
Top

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace


Data Field

AF_DATA_STORE.Data Field
[image]

Variable length data field depends on Length parameter.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace


Index Field

AF_DATA_STORE.Index Field
[image]

Index into the outgoing data buffer to start the storing of this chunk of data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index As UInt16
C#
public ushort Index;
C++
public:
unsigned short Index sealed ;
J#
public ushort Index
JScript
public Index : UInt16;

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace


Length Field

AF_DATA_STORE.Length Field
[image]

Length of this chunk of data to store into the outgoing data buffer.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

AF_DATA_STORE Class
TI.ZPI2 Namespace


AF_DATA_STORE_SRSP Class

AF_DATA_STORE_SRSP Class
See Also Example Members
[image]

Response for AF_DATA_STORE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_DATA_STORE_SRSP
Implements IRESPONSE, IAF
C#
public class AF_DATA_STORE_SRSP : IRESPONSE, IAF
C++
ref class AF_DATA_STORE_SRSP : IRESPONSE, IAF
J#
public class AF_DATA_STORE_SRSP implements IRESPONSE, IAF
JScript
public class AF_DATA_STORE_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_DATA_STORE_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_DATA_STORE_SRSP Members
TI.ZPI2 Namespace


AF_DATA_STORE_SRSP Members

AF_DATA_STORE_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_DATA_STORE

The following tables list the members exposed by AF_DATA_STORE_SRSP.

Public Constructors

Name | Description
AF_DATA_STORE_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_DATA_STORE_SRSP | Overloaded.
Top

See Also

AF_DATA_STORE_SRSP Class
TI.ZPI2 Namespace


AF_DATA_STORE_SRSP Constructor

AF_DATA_STORE_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_DATA_STORE_SRSP | Constructor
Public method | AF_DATA_STORE_SRSP (AF_DATA_STORE_SRSP.AF_STATUS) |

See Also

AF_DATA_STORE_SRSP Class
TI.ZPI2 Namespace


AF_DATA_STORE_SRSP Constructor ()

AF_DATA_STORE_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_DATA_STORE_SRSP()
C++
public:
AF_DATA_STORE_SRSP() sealed
J#
public AF_DATA_STORE_SRSP()
JScript
public function AF_DATA_STORE_SRSP()

See Also

AF_DATA_STORE_SRSP Class
TI.ZPI2 Namespace
AF_DATA_STORE_SRSP Constructor Overload List


AF_DATA_STORE_SRSP Constructor (AF_DATA_STORE_SRSP.AF_STATUS)

AF_DATA_STORE_SRSP Constructor (AF_DATA_STORE_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_DATA_STORE_SRSP.AF_STATUS _
)
C#
public AF_DATA_STORE_SRSP(
AF_DATA_STORE_SRSP.AF_STATUS
)
C++
public:
AF_DATA_STORE_SRSP(
AF_DATA_STORE_SRSP.AF_STATUS
) sealed
J#
public AF_DATA_STORE_SRSP(
AF_DATA_STORE_SRSP.AF_STATUS
)
JScript
public function AF_DATA_STORE_SRSP(
: AF_DATA_STORE_SRSP.AF_STATUS
)

See Also

AF_DATA_STORE_SRSP Class
TI.ZPI2 Namespace
AF_DATA_STORE_SRSP Constructor Overload List


Fields

AF_DATA_STORE_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_DATA_STORE_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_DATA_STORE_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_DATA_STORE_SRSP.AF_STATUS
C#
public AF_DATA_STORE_SRSP.AF_STATUS Status;
C++
public:
AF_DATA_STORE_SRSP.AF_STATUS Status sealed ;
J#
public AF_DATA_STORE_SRSP.AF_STATUS Status
JScript
public Status : AF_DATA_STORE_SRSP.AF_STATUS;

See Also

AF_DATA_STORE_SRSP Class
TI.ZPI2 Namespace


AF_DATA_STORE_SRSP.AF_STATUS Enumeration

AF_DATA_STORE_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_DATA_STORE_SRSP.AF_STATUS As Byte
C#
public enum AF_DATA_STORE_SRSP.AF_STATUS : byte
C++
public enum class AF_DATA_STORE_SRSP.AF_STATUS : char
J#
public enum AF_DATA_STORE_SRSP.AF_STATUS byte
JScript
public enum AF_DATA_STORE_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


AF_INCOMING_MSG Class

AF_INCOMING_MSG Class
See Also Example Members
[image]

Incoming AF data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_INCOMING_MSG
Implements IINDICATION, IAF
C#
public class AF_INCOMING_MSG : IINDICATION, IAF
C++
ref class AF_INCOMING_MSG : IINDICATION, IAF
J#
public class AF_INCOMING_MSG implements IINDICATION, IAF
JScript
public class AF_INCOMING_MSG extends IINDICATION, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_INCOMING_MSG

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_INCOMING_MSG Members
TI.ZPI2 Namespace


AF_INCOMING_MSG Members

AF_INCOMING_MSG Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Incoming AF data.

The following tables list the members exposed by AF_INCOMING_MSG.

Public Constructors

Name | Description
AF_INCOMING_MSG | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, variable length field of size 'Len' and is the transaction data frame
Public field | DstEndpoint | specifies the endpoint of the destination device
Public field | GroupID | Group ID
Public field | Len | specifies the length of the Data field
Public field | LinkQuality | indicates the link quality measured during reception. TBD
Public field | SecurityUse | indicates the type of security applied for the incoming NPDU. This field is no longer used.
Public field | SrcAddr | specifies the address of the source device
Public field | SrcEndpoint | specifies the endpoint of the source device
Public field | Timestamp | Timestamp
Public field | TransSeqNumber | specifies the transaction Id of the device
Public field | WasBroadcast | WasBroadcast
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_INCOMING_MSG | Overloaded.
Top

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


AF_INCOMING_MSG Constructor

AF_INCOMING_MSG Constructor

Overload List

 | Name | Description
Public method | AF_INCOMING_MSG | Constructor
Public method | AF_INCOMING_MSG (UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, UInt32, Byte, Byte, Byte) | Constructor

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


AF_INCOMING_MSG Constructor ()

AF_INCOMING_MSG Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_INCOMING_MSG()
C++
public:
AF_INCOMING_MSG() sealed
J#
public AF_INCOMING_MSG()
JScript
public function AF_INCOMING_MSG()

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace
AF_INCOMING_MSG Constructor Overload List


AF_INCOMING_MSG Constructor (UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, UInt32, Byte, Byte, Byte[])

AF_INCOMING_MSG Constructor (UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, UInt32, Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public AF_INCOMING_MSG(
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
uint ,
byte ,
byte ,
byte[]
)
C++
public:
AF_INCOMING_MSG(
unsigned short ,
unsigned short ,
unsigned short ,
char ,
char ,
char ,
char ,
char ,
unsigned int ,
char ,
char ,
array<char>^
) sealed
J#
public AF_INCOMING_MSG(
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
uint ,
byte ,
byte ,
byte[]
)
JScript
public function AF_INCOMING_MSG(
: UInt16,
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: UInt32,
: Byte,
: Byte,
: Byte[]
)

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace
AF_INCOMING_MSG Constructor Overload List


Fields

AF_INCOMING_MSG Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, variable length field of size 'Len' and is the transaction data frame
Public field | DstEndpoint | specifies the endpoint of the destination device
Public field | GroupID | Group ID
Public field | Len | specifies the length of the Data field
Public field | LinkQuality | indicates the link quality measured during reception. TBD
Public field | SecurityUse | indicates the type of security applied for the incoming NPDU. This field is no longer used.
Public field | SrcAddr | specifies the address of the source device
Public field | SrcEndpoint | specifies the endpoint of the source device
Public field | Timestamp | Timestamp
Public field | TransSeqNumber | specifies the transaction Id of the device
Public field | WasBroadcast | WasBroadcast
Top

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


ClusterID Field

AF_INCOMING_MSG.ClusterID Field
[image]

specifies the cluster ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


Data Field

AF_INCOMING_MSG.Data Field
[image]

Dynamic array, variable length field of size 'Len' and is the transaction data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


DstEndpoint Field

AF_INCOMING_MSG.DstEndpoint Field
[image]

specifies the endpoint of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstEndpoint As Byte
C#
public byte DstEndpoint;
C++
public:
char DstEndpoint sealed ;
J#
public byte DstEndpoint
JScript
public DstEndpoint : Byte;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


GroupID Field

AF_INCOMING_MSG.GroupID Field
[image]

Group ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public GroupID As UInt16
C#
public ushort GroupID;
C++
public:
unsigned short GroupID sealed ;
J#
public ushort GroupID
JScript
public GroupID : UInt16;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


Len Field

AF_INCOMING_MSG.Len Field
[image]

specifies the length of the Data field

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


LinkQuality Field

AF_INCOMING_MSG.LinkQuality Field
[image]

indicates the link quality measured during reception. TBD

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


SecurityUse Field

AF_INCOMING_MSG.SecurityUse Field
[image]

indicates the type of security applied for the incoming NPDU. This field is no longer used.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityUse As Byte
C#
public byte SecurityUse;
C++
public:
char SecurityUse sealed ;
J#
public byte SecurityUse
JScript
public SecurityUse : Byte;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


SrcAddr Field

AF_INCOMING_MSG.SrcAddr Field
[image]

specifies the address of the source device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


SrcEndpoint Field

AF_INCOMING_MSG.SrcEndpoint Field
[image]

specifies the endpoint of the source device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


Timestamp Field

AF_INCOMING_MSG.Timestamp Field
[image]

Timestamp

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp As UInt32
C#
public uint Timestamp;
C++
public:
unsigned int Timestamp sealed ;
J#
public uint Timestamp
JScript
public Timestamp : UInt32;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


TransSeqNumber Field

AF_INCOMING_MSG.TransSeqNumber Field
[image]

specifies the transaction Id of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransSeqNumber As Byte
C#
public byte TransSeqNumber;
C++
public:
char TransSeqNumber sealed ;
J#
public byte TransSeqNumber
JScript
public TransSeqNumber : Byte;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


WasBroadcast Field

AF_INCOMING_MSG.WasBroadcast Field
[image]

WasBroadcast

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public WasBroadcast As Byte
C#
public byte WasBroadcast;
C++
public:
char WasBroadcast sealed ;
J#
public byte WasBroadcast
JScript
public WasBroadcast : Byte;

See Also

AF_INCOMING_MSG Class
TI.ZPI2 Namespace


AF_INCOMING_MSG_EXT Class

AF_INCOMING_MSG_EXT Class
See Also Example Members
[image]

Incoming AF data extended.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_INCOMING_MSG_EXT
Implements IINDICATION, IAF
C#
public class AF_INCOMING_MSG_EXT : IINDICATION, IAF
C++
ref class AF_INCOMING_MSG_EXT : IINDICATION, IAF
J#
public class AF_INCOMING_MSG_EXT implements IINDICATION, IAF
JScript
public class AF_INCOMING_MSG_EXT extends IINDICATION, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_INCOMING_MSG_EXT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_INCOMING_MSG_EXT Members
TI.ZPI2 Namespace


AF_INCOMING_MSG_EXT Members

AF_INCOMING_MSG_EXT Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Incoming AF data extended.

The following tables list the members exposed by AF_INCOMING_MSG_EXT.

Public Constructors

Name | Description
AF_INCOMING_MSG_EXT | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, variable length field of size 'Len' and is the transaction data frame
Public field | DstEndpoint | specifies the endpoint of the destination device
Public field | GroupID | Group ID
Public field | Len | Specifies the length of the TransactionData field (LSB:MSB).
Public field | LinkQuality | indicates the link quality measured during reception. TBD
Public field | SecurityUse | indicates the type of security applied for the incoming NPDU. This field is no longer used.
Public field | SrcAddr | The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SrcAddrMode | The source address mode according to afAddrMode_t.
Public field | SrcEndpoint | specifies the endpoint of the source device
Public field | SrcPanId | The source PanId.
Public field | Timestamp | Timestamp
Public field | TransSeqNumber | specifies the transaction Id of the device
Public field | WasBroadcast | WasBroadcast
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_INCOMING_MSG_EXT | Overloaded.
Top

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


AF_INCOMING_MSG_EXT Constructor

AF_INCOMING_MSG_EXT Constructor

Overload List

 | Name | Description
Public method | AF_INCOMING_MSG_EXT | Constructor
Public method | AF_INCOMING_MSG_EXT (UInt16, UInt16, AF_INCOMING_MSG_EXT.ADDRESS_MODE, Byte, Byte, UInt16, Byte, Byte, Byte, Byte, UInt32, Byte, UInt16, Byte) |

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


AF_INCOMING_MSG_EXT Constructor ()

AF_INCOMING_MSG_EXT Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_INCOMING_MSG_EXT()
C++
public:
AF_INCOMING_MSG_EXT() sealed
J#
public AF_INCOMING_MSG_EXT()
JScript
public function AF_INCOMING_MSG_EXT()

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace
AF_INCOMING_MSG_EXT Constructor Overload List


AF_INCOMING_MSG_EXT Constructor (UInt16, UInt16, AF_INCOMING_MSG_EXT.ADDRESS_MODE, Byte[], Byte, UInt16, Byte, Byte, Byte, Byte, UInt32, Byte, UInt16, Byte[])

AF_INCOMING_MSG_EXT Constructor (UInt16, UInt16, AF_INCOMING_MSG_EXT.ADDRESS_MODE, Byte[], Byte, UInt16, Byte, Byte, Byte, Byte, UInt32, Byte, UInt16, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As AF_INCOMING_MSG_EXT.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte() _
)
C#
public AF_INCOMING_MSG_EXT(
ushort ,
ushort ,
AF_INCOMING_MSG_EXT.ADDRESS_MODE ,
byte[] ,
byte ,
ushort ,
byte ,
byte ,
byte ,
byte ,
uint ,
byte ,
ushort ,
byte[]
)
C++
public:
AF_INCOMING_MSG_EXT(
unsigned short ,
unsigned short ,
AF_INCOMING_MSG_EXT.ADDRESS_MODE ,
array<char>^ ,
char ,
unsigned short ,
char ,
char ,
char ,
char ,
unsigned int ,
char ,
unsigned short ,
array<char>^
) sealed
J#
public AF_INCOMING_MSG_EXT(
ushort ,
ushort ,
AF_INCOMING_MSG_EXT.ADDRESS_MODE ,
byte[] ,
byte ,
ushort ,
byte ,
byte ,
byte ,
byte ,
uint ,
byte ,
ushort ,
byte[]
)
JScript
public function AF_INCOMING_MSG_EXT(
: UInt16,
: UInt16,
: AF_INCOMING_MSG_EXT.ADDRESS_MODE,
: Byte[],
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: UInt32,
: Byte,
: UInt16,
: Byte[]
)

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace
AF_INCOMING_MSG_EXT Constructor Overload List


Fields

AF_INCOMING_MSG_EXT Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | specifies the cluster ID
Public field | Data | Dynamic array, variable length field of size 'Len' and is the transaction data frame
Public field | DstEndpoint | specifies the endpoint of the destination device
Public field | GroupID | Group ID
Public field | Len | Specifies the length of the TransactionData field (LSB:MSB).
Public field | LinkQuality | indicates the link quality measured during reception. TBD
Public field | SecurityUse | indicates the type of security applied for the incoming NPDU. This field is no longer used.
Public field | SrcAddr | The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SrcAddrMode | The source address mode according to afAddrMode_t.
Public field | SrcEndpoint | specifies the endpoint of the source device
Public field | SrcPanId | The source PanId.
Public field | Timestamp | Timestamp
Public field | TransSeqNumber | specifies the transaction Id of the device
Public field | WasBroadcast | WasBroadcast
Top

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


ClusterID Field

AF_INCOMING_MSG_EXT.ClusterID Field
[image]

specifies the cluster ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


Data Field

AF_INCOMING_MSG_EXT.Data Field
[image]

Dynamic array, variable length field of size 'Len' and is the transaction data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


DstEndpoint Field

AF_INCOMING_MSG_EXT.DstEndpoint Field
[image]

specifies the endpoint of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstEndpoint As Byte
C#
public byte DstEndpoint;
C++
public:
char DstEndpoint sealed ;
J#
public byte DstEndpoint
JScript
public DstEndpoint : Byte;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


GroupID Field

AF_INCOMING_MSG_EXT.GroupID Field
[image]

Group ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public GroupID As UInt16
C#
public ushort GroupID;
C++
public:
unsigned short GroupID sealed ;
J#
public ushort GroupID
JScript
public GroupID : UInt16;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


Len Field

AF_INCOMING_MSG_EXT.Len Field
[image]

Specifies the length of the TransactionData field (LSB:MSB).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As UInt16
C#
public ushort Len;
C++
public:
unsigned short Len sealed ;
J#
public ushort Len
JScript
public Len : UInt16;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


LinkQuality Field

AF_INCOMING_MSG_EXT.LinkQuality Field
[image]

indicates the link quality measured during reception. TBD

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


SecurityUse Field

AF_INCOMING_MSG_EXT.SecurityUse Field
[image]

indicates the type of security applied for the incoming NPDU. This field is no longer used.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityUse As Byte
C#
public byte SecurityUse;
C++
public:
char SecurityUse sealed ;
J#
public byte SecurityUse
JScript
public SecurityUse : Byte;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


SrcAddr Field

AF_INCOMING_MSG_EXT.SrcAddr Field
[image]

The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As Byte()
C#
public byte[] SrcAddr;
C++
public:
array<char>^ SrcAddr sealed ;
J#
public byte[] SrcAddr
JScript
public SrcAddr : Byte[];

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


SrcAddrMode Field

AF_INCOMING_MSG_EXT.SrcAddrMode Field
[image]

The source address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddrMode As AF_INCOMING_MSG_EXT.ADDRESS_MODE
C#
public AF_INCOMING_MSG_EXT.ADDRESS_MODE SrcAddrMode;
C++
public:
AF_INCOMING_MSG_EXT.ADDRESS_MODE SrcAddrMode sealed ;
J#
public AF_INCOMING_MSG_EXT.ADDRESS_MODE SrcAddrMode
JScript
public SrcAddrMode : AF_INCOMING_MSG_EXT.ADDRESS_MODE;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


SrcEndpoint Field

AF_INCOMING_MSG_EXT.SrcEndpoint Field
[image]

specifies the endpoint of the source device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


SrcPanId Field

AF_INCOMING_MSG_EXT.SrcPanId Field
[image]

The source PanId.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcPanId As UInt16
C#
public ushort SrcPanId;
C++
public:
unsigned short SrcPanId sealed ;
J#
public ushort SrcPanId
JScript
public SrcPanId : UInt16;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


Timestamp Field

AF_INCOMING_MSG_EXT.Timestamp Field
[image]

Timestamp

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp As UInt32
C#
public uint Timestamp;
C++
public:
unsigned int Timestamp sealed ;
J#
public uint Timestamp
JScript
public Timestamp : UInt32;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


TransSeqNumber Field

AF_INCOMING_MSG_EXT.TransSeqNumber Field
[image]

specifies the transaction Id of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransSeqNumber As Byte
C#
public byte TransSeqNumber;
C++
public:
char TransSeqNumber sealed ;
J#
public byte TransSeqNumber
JScript
public TransSeqNumber : Byte;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


WasBroadcast Field

AF_INCOMING_MSG_EXT.WasBroadcast Field
[image]

WasBroadcast

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public WasBroadcast As Byte
C#
public byte WasBroadcast;
C++
public:
char WasBroadcast sealed ;
J#
public byte WasBroadcast
JScript
public WasBroadcast : Byte;

See Also

AF_INCOMING_MSG_EXT Class
TI.ZPI2 Namespace


AF_INCOMING_MSG_EXT.ADDRESS_MODE Enumeration

AF_INCOMING_MSG_EXT.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_INCOMING_MSG_EXT.ADDRESS_MODE As Byte
C#
public enum AF_INCOMING_MSG_EXT.ADDRESS_MODE : byte
C++
public enum class AF_INCOMING_MSG_EXT.ADDRESS_MODE : char
J#
public enum AF_INCOMING_MSG_EXT.ADDRESS_MODE byte
JScript
public enum AF_INCOMING_MSG_EXT.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


AF_INTER_PAN_CTL Class

AF_INTER_PAN_CTL Class
See Also Example Members
[image]

Inter-Pan control command and data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_INTER_PAN_CTL
Implements IREQUEST, IAF
C#
public class AF_INTER_PAN_CTL : IREQUEST, IAF
C++
ref class AF_INTER_PAN_CTL : IREQUEST, IAF
J#
public class AF_INTER_PAN_CTL implements IREQUEST, IAF
JScript
public class AF_INTER_PAN_CTL extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_INTER_PAN_CTL

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_INTER_PAN_CTL Members
TI.ZPI2 Namespace


AF_INTER_PAN_CTL Members

AF_INTER_PAN_CTL Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Inter-Pan control command and data.

The following tables list the members exposed by AF_INTER_PAN_CTL.

Public Constructors

Name | Description
AF_INTER_PAN_CTL | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Cmd | Parameter type: 0=InterPanClr 1=InterPanSet 2=InterPanReg 3=InterPanChk
Public field | Data | Variable length data field depends on Cmd: 0=N/A 1=1-byte logical channel for InterPan messages 2=1-byte EndPoint for InterPan Rx (must correspond to an EndPoint already registered with AF) 3=2-byte PanId and 1-byte EndPoint.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_INTER_PAN_CTL | Overloaded.
Top

See Also

AF_INTER_PAN_CTL Class
TI.ZPI2 Namespace


AF_INTER_PAN_CTL Constructor

AF_INTER_PAN_CTL Constructor

Overload List

 | Name | Description
Public method | AF_INTER_PAN_CTL | Constructor
Public method | AF_INTER_PAN_CTL (Byte, Byte) | Constructor

See Also

AF_INTER_PAN_CTL Class
TI.ZPI2 Namespace


AF_INTER_PAN_CTL Constructor ()

AF_INTER_PAN_CTL Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_INTER_PAN_CTL()
C++
public:
AF_INTER_PAN_CTL() sealed
J#
public AF_INTER_PAN_CTL()
JScript
public function AF_INTER_PAN_CTL()

See Also

AF_INTER_PAN_CTL Class
TI.ZPI2 Namespace
AF_INTER_PAN_CTL Constructor Overload List


AF_INTER_PAN_CTL Constructor (Byte, Byte[])

AF_INTER_PAN_CTL Constructor (Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public AF_INTER_PAN_CTL(
byte ,
byte[]
)
C++
public:
AF_INTER_PAN_CTL(
char ,
array<char>^
) sealed
J#
public AF_INTER_PAN_CTL(
byte ,
byte[]
)
JScript
public function AF_INTER_PAN_CTL(
: Byte,
: Byte[]
)

See Also

AF_INTER_PAN_CTL Class
TI.ZPI2 Namespace
AF_INTER_PAN_CTL Constructor Overload List


Fields

AF_INTER_PAN_CTL Fields
[image]

Public Fields

 | Name | Description
Public field | Cmd | Parameter type: 0=InterPanClr 1=InterPanSet 2=InterPanReg 3=InterPanChk
Public field | Data | Variable length data field depends on Cmd: 0=N/A 1=1-byte logical channel for InterPan messages 2=1-byte EndPoint for InterPan Rx (must correspond to an EndPoint already registered with AF) 3=2-byte PanId and 1-byte EndPoint.
Top

See Also

AF_INTER_PAN_CTL Class
TI.ZPI2 Namespace


Cmd Field

AF_INTER_PAN_CTL.Cmd Field
[image]

Parameter type: 0=InterPanClr 1=InterPanSet 2=InterPanReg 3=InterPanChk

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Cmd As Byte
C#
public byte Cmd;
C++
public:
char Cmd sealed ;
J#
public byte Cmd
JScript
public Cmd : Byte;

See Also

AF_INTER_PAN_CTL Class
TI.ZPI2 Namespace


Data Field

AF_INTER_PAN_CTL.Data Field
[image]

Variable length data field depends on Cmd: 0=N/A 1=1-byte logical channel for InterPan messages 2=1-byte EndPoint for InterPan Rx (must correspond to an EndPoint already registered with AF) 3=2-byte PanId and 1-byte EndPoint.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

AF_INTER_PAN_CTL Class
TI.ZPI2 Namespace


AF_INTER_PAN_CTL_SRSP Class

AF_INTER_PAN_CTL_SRSP Class
See Also Example Members
[image]

Response for AF_INTER_PAN_SET_PARAM

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_INTER_PAN_CTL_SRSP
Implements IRESPONSE, IAF
C#
public class AF_INTER_PAN_CTL_SRSP : IRESPONSE, IAF
C++
ref class AF_INTER_PAN_CTL_SRSP : IRESPONSE, IAF
J#
public class AF_INTER_PAN_CTL_SRSP implements IRESPONSE, IAF
JScript
public class AF_INTER_PAN_CTL_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_INTER_PAN_CTL_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_INTER_PAN_CTL_SRSP Members
TI.ZPI2 Namespace


AF_INTER_PAN_CTL_SRSP Members

AF_INTER_PAN_CTL_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_INTER_PAN_SET_PARAM

The following tables list the members exposed by AF_INTER_PAN_CTL_SRSP.

Public Constructors

Name | Description
AF_INTER_PAN_CTL_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_INTER_PAN_CTL_SRSP | Overloaded.
Top

See Also

AF_INTER_PAN_CTL_SRSP Class
TI.ZPI2 Namespace


AF_INTER_PAN_CTL_SRSP Constructor

AF_INTER_PAN_CTL_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_INTER_PAN_CTL_SRSP | Constructor
Public method | AF_INTER_PAN_CTL_SRSP (AF_INTER_PAN_CTL_SRSP.CMD_STATUS) |

See Also

AF_INTER_PAN_CTL_SRSP Class
TI.ZPI2 Namespace


AF_INTER_PAN_CTL_SRSP Constructor ()

AF_INTER_PAN_CTL_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_INTER_PAN_CTL_SRSP()
C++
public:
AF_INTER_PAN_CTL_SRSP() sealed
J#
public AF_INTER_PAN_CTL_SRSP()
JScript
public function AF_INTER_PAN_CTL_SRSP()

See Also

AF_INTER_PAN_CTL_SRSP Class
TI.ZPI2 Namespace
AF_INTER_PAN_CTL_SRSP Constructor Overload List


AF_INTER_PAN_CTL_SRSP Constructor (AF_INTER_PAN_CTL_SRSP.CMD_STATUS)

AF_INTER_PAN_CTL_SRSP Constructor (AF_INTER_PAN_CTL_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_INTER_PAN_CTL_SRSP.CMD_STATUS _
)
C#
public AF_INTER_PAN_CTL_SRSP(
AF_INTER_PAN_CTL_SRSP.CMD_STATUS
)
C++
public:
AF_INTER_PAN_CTL_SRSP(
AF_INTER_PAN_CTL_SRSP.CMD_STATUS
) sealed
J#
public AF_INTER_PAN_CTL_SRSP(
AF_INTER_PAN_CTL_SRSP.CMD_STATUS
)
JScript
public function AF_INTER_PAN_CTL_SRSP(
: AF_INTER_PAN_CTL_SRSP.CMD_STATUS
)

See Also

AF_INTER_PAN_CTL_SRSP Class
TI.ZPI2 Namespace
AF_INTER_PAN_CTL_SRSP Constructor Overload List


Fields

AF_INTER_PAN_CTL_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_INTER_PAN_CTL_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_INTER_PAN_CTL_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_INTER_PAN_CTL_SRSP.CMD_STATUS
C#
public AF_INTER_PAN_CTL_SRSP.CMD_STATUS Status;
C++
public:
AF_INTER_PAN_CTL_SRSP.CMD_STATUS Status sealed ;
J#
public AF_INTER_PAN_CTL_SRSP.CMD_STATUS Status
JScript
public Status : AF_INTER_PAN_CTL_SRSP.CMD_STATUS;

See Also

AF_INTER_PAN_CTL_SRSP Class
TI.ZPI2 Namespace


AF_INTER_PAN_CTL_SRSP.CMD_STATUS Enumeration

AF_INTER_PAN_CTL_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_INTER_PAN_CTL_SRSP.CMD_STATUS As Byte
C#
public enum AF_INTER_PAN_CTL_SRSP.CMD_STATUS : byte
C++
public enum class AF_INTER_PAN_CTL_SRSP.CMD_STATUS : char
J#
public enum AF_INTER_PAN_CTL_SRSP.CMD_STATUS byte
JScript
public enum AF_INTER_PAN_CTL_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


AF_REGISTER Class

AF_REGISTER Class
See Also Example Members
[image]

This command enables the tester to register an application's endpoint description

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_REGISTER
Implements IREQUEST, IAF
C#
public class AF_REGISTER : IREQUEST, IAF
C++
ref class AF_REGISTER : IREQUEST, IAF
J#
public class AF_REGISTER implements IREQUEST, IAF
JScript
public class AF_REGISTER extends IREQUEST, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_REGISTER

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_REGISTER Members
TI.ZPI2 Namespace


AF_REGISTER Members

AF_REGISTER Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command enables the tester to register an application's endpoint description

The following tables list the members exposed by AF_REGISTER.

Public Constructors

Name | Description
AF_REGISTER | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppDeviceId | specifies the device description id for this endpoint
Public field | AppDevVer | specifies the version of the device description
Public field | AppInClusterList | Dynamic array, requires memory allocation. variable length field of size 'AppNumInClusters' and is the list of Input Cluster Ids
Public field | AppNumInClusters | the number of Input cluster Ids following in the AppInClusterList
Public field | AppNumOutClusters | specifies the number of Output cluster Ids following in the AppOutClusterList
Public field | AppOutClusterList | Dynamic array, requires memory allocation. Variable length field of size 'AppNumOutClusters' and is the list of Output Cluster Ids
Public field | AppProfID | specifies the profile id of the application
Public field | EndPoint | specifies the endpoint of the device
Public field | LatencyReq | Latency
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_REGISTER | Overloaded.
Top

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AF_REGISTER Constructor

AF_REGISTER Constructor

Overload List

 | Name | Description
Public method | AF_REGISTER | Constructor
Public method | AF_REGISTER (Byte, UInt16, UInt16, Byte, AF_REGISTER.LATENCY_TYPE, Byte, UInt16, Byte, UInt16) |

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AF_REGISTER Constructor ()

AF_REGISTER Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_REGISTER()
C++
public:
AF_REGISTER() sealed
J#
public AF_REGISTER()
JScript
public function AF_REGISTER()

See Also

AF_REGISTER Class
TI.ZPI2 Namespace
AF_REGISTER Constructor Overload List


AF_REGISTER Constructor (Byte, UInt16, UInt16, Byte, AF_REGISTER.LATENCY_TYPE, Byte, UInt16[], Byte, UInt16[])

AF_REGISTER Constructor (Byte, UInt16, UInt16, Byte, AF_REGISTER.LATENCY_TYPE, Byte, UInt16[], Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As AF_REGISTER.LATENCY_TYPE, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public AF_REGISTER(
byte ,
ushort ,
ushort ,
byte ,
AF_REGISTER.LATENCY_TYPE ,
byte ,
ushort[] ,
byte ,
ushort[]
)
C++
public:
AF_REGISTER(
char ,
unsigned short ,
unsigned short ,
char ,
AF_REGISTER.LATENCY_TYPE ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^
) sealed
J#
public AF_REGISTER(
byte ,
ushort ,
ushort ,
byte ,
AF_REGISTER.LATENCY_TYPE ,
byte ,
ushort[] ,
byte ,
ushort[]
)
JScript
public function AF_REGISTER(
: Byte,
: UInt16,
: UInt16,
: Byte,
: AF_REGISTER.LATENCY_TYPE,
: Byte,
: UInt16[],
: Byte,
: UInt16[]
)

See Also

AF_REGISTER Class
TI.ZPI2 Namespace
AF_REGISTER Constructor Overload List


Fields

AF_REGISTER Fields
[image]

Public Fields

 | Name | Description
Public field | AppDeviceId | specifies the device description id for this endpoint
Public field | AppDevVer | specifies the version of the device description
Public field | AppInClusterList | Dynamic array, requires memory allocation. variable length field of size 'AppNumInClusters' and is the list of Input Cluster Ids
Public field | AppNumInClusters | the number of Input cluster Ids following in the AppInClusterList
Public field | AppNumOutClusters | specifies the number of Output cluster Ids following in the AppOutClusterList
Public field | AppOutClusterList | Dynamic array, requires memory allocation. Variable length field of size 'AppNumOutClusters' and is the list of Output Cluster Ids
Public field | AppProfID | specifies the profile id of the application
Public field | EndPoint | specifies the endpoint of the device
Public field | LatencyReq | Latency
Top

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AppDeviceId Field

AF_REGISTER.AppDeviceId Field
[image]

specifies the device description id for this endpoint

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppDeviceId As UInt16
C#
public ushort AppDeviceId;
C++
public:
unsigned short AppDeviceId sealed ;
J#
public ushort AppDeviceId
JScript
public AppDeviceId : UInt16;

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AppDevVer Field

AF_REGISTER.AppDevVer Field
[image]

specifies the version of the device description

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppDevVer As Byte
C#
public byte AppDevVer;
C++
public:
char AppDevVer sealed ;
J#
public byte AppDevVer
JScript
public AppDevVer : Byte;

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AppInClusterList Field

AF_REGISTER.AppInClusterList Field
[image]

Dynamic array, requires memory allocation. variable length field of size 'AppNumInClusters' and is the list of Input Cluster Ids

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppInClusterList As UInt16()
C#
public ushort[] AppInClusterList;
C++
public:
array<unsigned short>^ AppInClusterList sealed ;
J#
public ushort[] AppInClusterList
JScript
public AppInClusterList : UInt16[];

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AppNumInClusters Field

AF_REGISTER.AppNumInClusters Field
[image]

the number of Input cluster Ids following in the AppInClusterList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppNumInClusters As Byte
C#
public byte AppNumInClusters;
C++
public:
char AppNumInClusters sealed ;
J#
public byte AppNumInClusters
JScript
public AppNumInClusters : Byte;

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AppNumOutClusters Field

AF_REGISTER.AppNumOutClusters Field
[image]

specifies the number of Output cluster Ids following in the AppOutClusterList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppNumOutClusters As Byte
C#
public byte AppNumOutClusters;
C++
public:
char AppNumOutClusters sealed ;
J#
public byte AppNumOutClusters
JScript
public AppNumOutClusters : Byte;

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AppOutClusterList Field

AF_REGISTER.AppOutClusterList Field
[image]

Dynamic array, requires memory allocation. Variable length field of size 'AppNumOutClusters' and is the list of Output Cluster Ids

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppOutClusterList As UInt16()
C#
public ushort[] AppOutClusterList;
C++
public:
array<unsigned short>^ AppOutClusterList sealed ;
J#
public ushort[] AppOutClusterList
JScript
public AppOutClusterList : UInt16[];

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AppProfID Field

AF_REGISTER.AppProfID Field
[image]

specifies the profile id of the application

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppProfID As UInt16
C#
public ushort AppProfID;
C++
public:
unsigned short AppProfID sealed ;
J#
public ushort AppProfID
JScript
public AppProfID : UInt16;

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


EndPoint Field

AF_REGISTER.EndPoint Field
[image]

specifies the endpoint of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public EndPoint As Byte
C#
public byte EndPoint;
C++
public:
char EndPoint sealed ;
J#
public byte EndPoint
JScript
public EndPoint : Byte;

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


LatencyReq Field

AF_REGISTER.LatencyReq Field
[image]

Latency

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LatencyReq As AF_REGISTER.LATENCY_TYPE
C#
public AF_REGISTER.LATENCY_TYPE LatencyReq;
C++
public:
AF_REGISTER.LATENCY_TYPE LatencyReq sealed ;
J#
public AF_REGISTER.LATENCY_TYPE LatencyReq
JScript
public LatencyReq : AF_REGISTER.LATENCY_TYPE;

See Also

AF_REGISTER Class
TI.ZPI2 Namespace


AF_REGISTER.LATENCY_TYPE Enumeration

AF_REGISTER.LATENCY_TYPE Enumeration
[image]

Latency type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_REGISTER.LATENCY_TYPE As Byte
C#
public enum AF_REGISTER.LATENCY_TYPE : byte
C++
public enum class AF_REGISTER.LATENCY_TYPE : char
J#
public enum AF_REGISTER.LATENCY_TYPE byte
JScript
public enum AF_REGISTER.LATENCY_TYPE :

Members

Member Name | Description
NO_LATENCY_REQS | Latency type
FAST_BEACONS | Latency type
SLOW_BEACONS | Latency type

See Also

TI.ZPI2 Namespace


AF_REGISTER_SRSP Class

AF_REGISTER_SRSP Class
See Also Example Members
[image]

Response for AF_REGISTER

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AF_REGISTER_SRSP
Implements IRESPONSE, IAF
C#
public class AF_REGISTER_SRSP : IRESPONSE, IAF
C++
ref class AF_REGISTER_SRSP : IRESPONSE, IAF
J#
public class AF_REGISTER_SRSP implements IRESPONSE, IAF
JScript
public class AF_REGISTER_SRSP extends IRESPONSE, IAF

Inheritance Hierarchy

System.Object
TI.ZPI2.AF_REGISTER_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AF_REGISTER_SRSP Members
TI.ZPI2 Namespace


AF_REGISTER_SRSP Members

AF_REGISTER_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for AF_REGISTER

The following tables list the members exposed by AF_REGISTER_SRSP.

Public Constructors

Name | Description
AF_REGISTER_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AF_REGISTER_SRSP | Overloaded.
Top

See Also

AF_REGISTER_SRSP Class
TI.ZPI2 Namespace


AF_REGISTER_SRSP Constructor

AF_REGISTER_SRSP Constructor

Overload List

 | Name | Description
Public method | AF_REGISTER_SRSP | Constructor
Public method | AF_REGISTER_SRSP (AF_REGISTER_SRSP.AF_STATUS) |

See Also

AF_REGISTER_SRSP Class
TI.ZPI2 Namespace


AF_REGISTER_SRSP Constructor ()

AF_REGISTER_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AF_REGISTER_SRSP()
C++
public:
AF_REGISTER_SRSP() sealed
J#
public AF_REGISTER_SRSP()
JScript
public function AF_REGISTER_SRSP()

See Also

AF_REGISTER_SRSP Class
TI.ZPI2 Namespace
AF_REGISTER_SRSP Constructor Overload List


AF_REGISTER_SRSP Constructor (AF_REGISTER_SRSP.AF_STATUS)

AF_REGISTER_SRSP Constructor (AF_REGISTER_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As AF_REGISTER_SRSP.AF_STATUS _
)
C#
public AF_REGISTER_SRSP(
AF_REGISTER_SRSP.AF_STATUS
)
C++
public:
AF_REGISTER_SRSP(
AF_REGISTER_SRSP.AF_STATUS
) sealed
J#
public AF_REGISTER_SRSP(
AF_REGISTER_SRSP.AF_STATUS
)
JScript
public function AF_REGISTER_SRSP(
: AF_REGISTER_SRSP.AF_STATUS
)

See Also

AF_REGISTER_SRSP Class
TI.ZPI2 Namespace
AF_REGISTER_SRSP Constructor Overload List


Fields

AF_REGISTER_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

AF_REGISTER_SRSP Class
TI.ZPI2 Namespace


Status Field

AF_REGISTER_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As AF_REGISTER_SRSP.AF_STATUS
C#
public AF_REGISTER_SRSP.AF_STATUS Status;
C++
public:
AF_REGISTER_SRSP.AF_STATUS Status sealed ;
J#
public AF_REGISTER_SRSP.AF_STATUS Status
JScript
public Status : AF_REGISTER_SRSP.AF_STATUS;

See Also

AF_REGISTER_SRSP Class
TI.ZPI2 Namespace


AF_REGISTER_SRSP.AF_STATUS Enumeration

AF_REGISTER_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum AF_REGISTER_SRSP.AF_STATUS As Byte
C#
public enum AF_REGISTER_SRSP.AF_STATUS : byte
C++
public enum class AF_REGISTER_SRSP.AF_STATUS : char
J#
public enum AF_REGISTER_SRSP.AF_STATUS byte
JScript
public enum AF_REGISTER_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


APP_MSG Class

APP_MSG Class
See Also Example Members
[image]

Use this message to send raw data to an application.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APP_MSG
Implements IREQUEST, IAPP
C#
public class APP_MSG : IREQUEST, IAPP
C++
ref class APP_MSG : IREQUEST, IAPP
J#
public class APP_MSG implements IREQUEST, IAPP
JScript
public class APP_MSG extends IREQUEST, IAPP

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG Members
TI.ZPI2 Namespace


APP_MSG Members

APP_MSG Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to send raw data to an application.

The following tables list the members exposed by APP_MSG.

Public Constructors

Name | Description
APP_MSG | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppEndpoint | Application endpoint of the outgoing message
Public field | ClusterID | Cluster ID of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Public field | DestAddress | Destination address of the outgoing message
Public field | DestEndpoint | Destination endpoint of the outgoing message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APP_MSG | Overloaded.
Top

See Also

APP_MSG Class
TI.ZPI2 Namespace


APP_MSG Constructor

APP_MSG Constructor

Overload List

 | Name | Description
Public method | APP_MSG | Constructor
Public method | APP_MSG (Byte, UInt16, Byte, UInt16, Byte, Byte) | Constructor

See Also

APP_MSG Class
TI.ZPI2 Namespace


APP_MSG Constructor ()

APP_MSG Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG()
C++
public:
APP_MSG() sealed
J#
public APP_MSG()
JScript
public function APP_MSG()

See Also

APP_MSG Class
TI.ZPI2 Namespace
APP_MSG Constructor Overload List


APP_MSG Constructor (Byte, UInt16, Byte, UInt16, Byte, Byte[])

APP_MSG Constructor (Byte, UInt16, Byte, UInt16, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public APP_MSG(
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte[]
)
C++
public:
APP_MSG(
char ,
unsigned short ,
char ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public APP_MSG(
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte[]
)
JScript
public function APP_MSG(
: Byte,
: UInt16,
: Byte,
: UInt16,
: Byte,
: Byte[]
)

See Also

APP_MSG Class
TI.ZPI2 Namespace
APP_MSG Constructor Overload List


Fields

APP_MSG Fields
[image]

Public Fields

 | Name | Description
Public field | AppEndpoint | Application endpoint of the outgoing message
Public field | ClusterID | Cluster ID of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Public field | DestAddress | Destination address of the outgoing message
Public field | DestEndpoint | Destination endpoint of the outgoing message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the outgoing message. Can be left blank (filled in automatically by Z-Architect)
Top

See Also

APP_MSG Class
TI.ZPI2 Namespace


AppEndpoint Field

APP_MSG.AppEndpoint Field
[image]

Application endpoint of the outgoing message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppEndpoint As Byte
C#
public byte AppEndpoint;
C++
public:
char AppEndpoint sealed ;
J#
public byte AppEndpoint
JScript
public AppEndpoint : Byte;

See Also

APP_MSG Class
TI.ZPI2 Namespace


ClusterID Field

APP_MSG.ClusterID Field
[image]

Cluster ID of the outgoing message. Can be left blank (filled in automatically by Z-Architect)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

APP_MSG Class
TI.ZPI2 Namespace


DestAddress Field

APP_MSG.DestAddress Field
[image]

Destination address of the outgoing message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt16
C#
public ushort DestAddress;
C++
public:
unsigned short DestAddress sealed ;
J#
public ushort DestAddress
JScript
public DestAddress : UInt16;

See Also

APP_MSG Class
TI.ZPI2 Namespace


DestEndpoint Field

APP_MSG.DestEndpoint Field
[image]

Destination endpoint of the outgoing message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

APP_MSG Class
TI.ZPI2 Namespace


Message Field

APP_MSG.Message Field
[image]

raw data packet to send to the application

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Message As Byte()
C#
public byte[] Message;
C++
public:
array<char>^ Message sealed ;
J#
public byte[] Message
JScript
public Message : Byte[];

See Also

APP_MSG Class
TI.ZPI2 Namespace


MsgLen Field

APP_MSG.MsgLen Field
[image]

Length of the outgoing message. Can be left blank (filled in automatically by Z-Architect)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsgLen As Byte
C#
public byte MsgLen;
C++
public:
char MsgLen sealed ;
J#
public byte MsgLen
JScript
public MsgLen : Byte;

See Also

APP_MSG Class
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION Structure

APP_MSG.BLIND_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.BLIND_NODE_CONFIGURATION
C#
public struct APP_MSG.BLIND_NODE_CONFIGURATION
C++
value class APP_MSG.BLIND_NODE_CONFIGURATION
J#
public final class APP_MSG.BLIND_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.BLIND_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Members
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION Members

APP_MSG.BLIND_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by APP_MSG.BLIND_NODE_CONFIGURATION.

Public Constructors

Name | Description
APP_MSG.BLIND_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.BLIND_NODE_CONFIGURATION | Overloaded.
Top

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION Constructor

APP_MSG.BLIND_NODE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | APP_MSG.BLIND_NODE_CONFIGURATION | Initializes a new instance of the APP_MSG.BLIND_NODE_CONFIGURATION class.
Public method | APP_MSG.BLIND_NODE_CONFIGURATION (Byte, Byte, APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte) |

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION Constructor ()

APP_MSG.BLIND_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.BLIND_NODE_CONFIGURATION class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.BLIND_NODE_CONFIGURATION()
C++
public:
APP_MSG.BLIND_NODE_CONFIGURATION() sealed
J#
public APP_MSG.BLIND_NODE_CONFIGURATION()
JScript
public function APP_MSG.BLIND_NODE_CONFIGURATION()

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG.BLIND_NODE_CONFIGURATION Constructor Overload List


APP_MSG.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)

APP_MSG.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT, _
ByVal As Byte _
)
C#
public APP_MSG.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
C++
public:
APP_MSG.BLIND_NODE_CONFIGURATION(
char ,
char ,
APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
unsigned short ,
unsigned short ,
unsigned short ,
APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
char
) sealed
J#
public APP_MSG.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
JScript
public function APP_MSG.BLIND_NODE_CONFIGURATION(
: Byte,
: Byte,
: APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE,
: UInt16,
: UInt16,
: UInt16,
: APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT,
: Byte
)

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG.BLIND_NODE_CONFIGURATION Constructor Overload List


Fields

APP_MSG.BLIND_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


AParameter Field

APP_MSG.BLIND_NODE_CONFIGURATION.AParameter Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AParameter As Byte
C#
public byte AParameter;
C++
public:
char AParameter sealed ;
J#
public byte AParameter
JScript
public AParameter : Byte;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


CollectTime Field

APP_MSG.BLIND_NODE_CONFIGURATION.CollectTime Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CollectTime As UInt16
C#
public ushort CollectTime;
C++
public:
unsigned short CollectTime sealed ;
J#
public ushort CollectTime
JScript
public CollectTime : UInt16;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


CycleTime Field

APP_MSG.BLIND_NODE_CONFIGURATION.CycleTime Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CycleTime As UInt16
C#
public ushort CycleTime;
C++
public:
unsigned short CycleTime sealed ;
J#
public ushort CycleTime
JScript
public CycleTime : UInt16;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


MinRefNodes Field

APP_MSG.BLIND_NODE_CONFIGURATION.MinRefNodes Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MinRefNodes As Byte
C#
public byte MinRefNodes;
C++
public:
char MinRefNodes sealed ;
J#
public byte MinRefNodes
JScript
public MinRefNodes : Byte;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


Mode Field

APP_MSG.BLIND_NODE_CONFIGURATION.Mode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
C#
public APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode;
C++
public:
APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode sealed ;
J#
public APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode
JScript
public Mode : APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


nParameter Field

APP_MSG.BLIND_NODE_CONFIGURATION.nParameter Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public nParameter As Byte
C#
public byte nParameter;
C++
public:
char nParameter sealed ;
J#
public byte nParameter
JScript
public nParameter : Byte;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


ReportEndpoint Field

APP_MSG.BLIND_NODE_CONFIGURATION.ReportEndpoint Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportEndpoint As APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT
C#
public APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint;
C++
public:
APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint sealed ;
J#
public APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint
JScript
public ReportEndpoint : APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


ReportShortAddress Field

APP_MSG.BLIND_NODE_CONFIGURATION.ReportShortAddress Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportShortAddress As UInt16
C#
public ushort ReportShortAddress;
C++
public:
unsigned short ReportShortAddress sealed ;
J#
public ushort ReportShortAddress
JScript
public ReportShortAddress : UInt16;

See Also

APP_MSG.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration

APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT As Byte
C#
public enum APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT : byte
C++
public enum class APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT : char
J#
public enum APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT byte
JScript
public enum APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT :

Members

Member Name | Description
OAD |
LOCATION |
LOCATION_DONGLE |

See Also

TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration

APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE As Byte
C#
public enum APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : byte
C++
public enum class APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : char
J#
public enum APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE byte
JScript
public enum APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE :

Members

Member Name | Description
POLLED |
AUTO |

See Also

TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure

APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure
See Also Example Members
[image]

Send this message to a Blind Node to request its configuration. The response to this request is the Blind Node Configuration (Cluster ID 6) message. This message doesn't have a body to the message (just cluster ID)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
C#
public struct APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
C++
value class APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
J#
public final class APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Members

APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Members
See Also Example Constructors Methods
[image]

Send this message to a Blind Node to request its configuration. The response to this request is the Blind Node Configuration (Cluster ID 6) message. This message doesn't have a body to the message (just cluster ID)

The following tables list the members exposed by APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST.

Public Constructors

 | Name | Description
Public method | APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST | Initializes a new instance of the APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST class.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Constructor

APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Constructor
[image]

Initializes a new instance of the APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST()
C++
public:
APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST() sealed
J#
public APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST()
JScript
public function APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST()

See Also

APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_REQUEST Structure

APP_MSG.BLIND_NODE_REQUEST Structure
See Also Example Members
[image]

Send this message to a Blind Node to request its location. The response to this message will be sent by the blind node when the location process is complete (which will take seconds). This message doesn't have a body to the message (just cluster ID)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.BLIND_NODE_REQUEST
C#
public struct APP_MSG.BLIND_NODE_REQUEST
C++
value class APP_MSG.BLIND_NODE_REQUEST
J#
public final class APP_MSG.BLIND_NODE_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.BLIND_NODE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.BLIND_NODE_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_REQUEST Members

APP_MSG.BLIND_NODE_REQUEST Members
See Also Example Constructors Methods
[image]

Send this message to a Blind Node to request its location. The response to this message will be sent by the blind node when the location process is complete (which will take seconds). This message doesn't have a body to the message (just cluster ID)

The following tables list the members exposed by APP_MSG.BLIND_NODE_REQUEST.

Public Constructors

 | Name | Description
Public method | APP_MSG.BLIND_NODE_REQUEST | Initializes a new instance of the APP_MSG.BLIND_NODE_REQUEST class.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

APP_MSG.BLIND_NODE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.BLIND_NODE_REQUEST Constructor

APP_MSG.BLIND_NODE_REQUEST Constructor
[image]

Initializes a new instance of the APP_MSG.BLIND_NODE_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.BLIND_NODE_REQUEST()
C++
public:
APP_MSG.BLIND_NODE_REQUEST() sealed
J#
public APP_MSG.BLIND_NODE_REQUEST()
JScript
public function APP_MSG.BLIND_NODE_REQUEST()

See Also

APP_MSG.BLIND_NODE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.LOC_REQ_MESSAGE_ID Enumeration

APP_MSG.LOC_REQ_MESSAGE_ID Enumeration
[image]

Message id for LOC_REQ_MESSAGE_ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.LOC_REQ_MESSAGE_ID As Short
C#
public enum APP_MSG.LOC_REQ_MESSAGE_ID : short
C++
public enum class APP_MSG.LOC_REQ_MESSAGE_ID : short
J#
public enum APP_MSG.LOC_REQ_MESSAGE_ID short
JScript
public enum APP_MSG.LOC_REQ_MESSAGE_ID : short

Members

Member Name | Description
REFERENCE_NODE_REQUEST | Message id for LOC_REQ_MESSAGE_ID
BLIND_NODE_REQUEST | Message id for LOC_REQ_MESSAGE_ID
REFERENCE_NODE_CONFIGURATION | Message id for LOC_REQ_MESSAGE_ID
BLIND_NODE_CONFIGURATION | Message id for LOC_REQ_MESSAGE_ID
REFERENCE_NODE_CONFIGURATION_REQUEST | Message id for LOC_REQ_MESSAGE_ID
BLIND_NODE_CONFIGURATION_REQUEST | Message id for LOC_REQ_MESSAGE_ID

See Also

TI.ZPI2 Namespace


APP_MSG.OAD_REQ_MESSAGE_ID Enumeration

APP_MSG.OAD_REQ_MESSAGE_ID Enumeration
[image]

Message id for OAD_REQ_MESSAGE_ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.OAD_REQ_MESSAGE_ID As Short
C#
public enum APP_MSG.OAD_REQ_MESSAGE_ID : short
C++
public enum class APP_MSG.OAD_REQ_MESSAGE_ID : short
J#
public enum APP_MSG.OAD_REQ_MESSAGE_ID short
JScript
public enum APP_MSG.OAD_REQ_MESSAGE_ID : short

Members

Member Name | Description
ZLMSGID_STATUSQ_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_SESSION_START_RESPONSE | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_SESSION_TERM_RESPONSE | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_CLIENT_CMD_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_CODE_ENABLE_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_SEND_DATA_RESPONSE | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_RESET_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_RESET_BOARD_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_GET_DONGLE_INFO_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_STATUSQ_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_CLIENT_CMD_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_CODE_ENABLE_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_RESET_REQUEST | Message id for OAD_REQ_MESSAGE_ID
ZLMSGID_PROXY_RESET_BOARD_REQUEST | Message id for OAD_REQ_MESSAGE_ID

See Also

TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_CONFIGURATION Structure

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.REFERENCE_NODE_CONFIGURATION
C#
public struct APP_MSG.REFERENCE_NODE_CONFIGURATION
C++
value class APP_MSG.REFERENCE_NODE_CONFIGURATION
J#
public final class APP_MSG.REFERENCE_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.REFERENCE_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Members
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_CONFIGURATION Members

APP_MSG.REFERENCE_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by APP_MSG.REFERENCE_NODE_CONFIGURATION.

Public Constructors

Name | Description
APP_MSG.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor

APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | APP_MSG.REFERENCE_NODE_CONFIGURATION | Initializes a new instance of the APP_MSG.REFERENCE_NODE_CONFIGURATION class.
Public method | APP_MSG.REFERENCE_NODE_CONFIGURATION (UInt16, UInt16) |

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor ()

APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.REFERENCE_NODE_CONFIGURATION class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.REFERENCE_NODE_CONFIGURATION()
C++
public:
APP_MSG.REFERENCE_NODE_CONFIGURATION() sealed
J#
public APP_MSG.REFERENCE_NODE_CONFIGURATION()
JScript
public function APP_MSG.REFERENCE_NODE_CONFIGURATION()

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor Overload List


APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)

APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public APP_MSG.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
C++
public:
APP_MSG.REFERENCE_NODE_CONFIGURATION(
unsigned short ,
unsigned short
) sealed
J#
public APP_MSG.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
JScript
public function APP_MSG.REFERENCE_NODE_CONFIGURATION(
: UInt16,
: UInt16
)

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG.REFERENCE_NODE_CONFIGURATION Constructor Overload List


Fields

APP_MSG.REFERENCE_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


XPos Field

APP_MSG.REFERENCE_NODE_CONFIGURATION.XPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


YPos Field

APP_MSG.REFERENCE_NODE_CONFIGURATION.YPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure

APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure
See Also Example Members
[image]

Send this message to a Reference Node to request its configuration. The response to this request is the Reference Node Configuration (Cluster ID 5) message. This message doesn't have a body to the message (just cluster ID)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
C#
public struct APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
C++
value class APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
J#
public final class APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Members

APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Members
See Also Example Constructors Methods
[image]

Send this message to a Reference Node to request its configuration. The response to this request is the Reference Node Configuration (Cluster ID 5) message. This message doesn't have a body to the message (just cluster ID)

The following tables list the members exposed by APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST.

Public Constructors

 | Name | Description
Public method | APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST | Initializes a new instance of the APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST class.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Constructor

APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Constructor
[image]

Initializes a new instance of the APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST()
C++
public:
APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST() sealed
J#
public APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST()
JScript
public function APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST()

See Also

APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_REQUEST Structure

APP_MSG.REFERENCE_NODE_REQUEST Structure
See Also Example Members
[image]

Send this message to a reference node to request its position information. In this request is the number of responses expected

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.REFERENCE_NODE_REQUEST
C#
public struct APP_MSG.REFERENCE_NODE_REQUEST
C++
value class APP_MSG.REFERENCE_NODE_REQUEST
J#
public final class APP_MSG.REFERENCE_NODE_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.REFERENCE_NODE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.REFERENCE_NODE_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_REQUEST Members

APP_MSG.REFERENCE_NODE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to a reference node to request its position information. In this request is the number of responses expected

The following tables list the members exposed by APP_MSG.REFERENCE_NODE_REQUEST.

Public Constructors

Name | Description
APP_MSG.REFERENCE_NODE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NumberMessages |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.REFERENCE_NODE_REQUEST | Overloaded.
Top

See Also

APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_REQUEST Constructor

APP_MSG.REFERENCE_NODE_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG.REFERENCE_NODE_REQUEST | Initializes a new instance of the APP_MSG.REFERENCE_NODE_REQUEST class.
Public method | APP_MSG.REFERENCE_NODE_REQUEST (Byte) |

See Also

APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.REFERENCE_NODE_REQUEST Constructor ()

APP_MSG.REFERENCE_NODE_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.REFERENCE_NODE_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.REFERENCE_NODE_REQUEST()
C++
public:
APP_MSG.REFERENCE_NODE_REQUEST() sealed
J#
public APP_MSG.REFERENCE_NODE_REQUEST()
JScript
public function APP_MSG.REFERENCE_NODE_REQUEST()

See Also

APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.REFERENCE_NODE_REQUEST Constructor Overload List


APP_MSG.REFERENCE_NODE_REQUEST Constructor (Byte)

APP_MSG.REFERENCE_NODE_REQUEST Constructor (Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public APP_MSG.REFERENCE_NODE_REQUEST(
byte
)
C++
public:
APP_MSG.REFERENCE_NODE_REQUEST(
char
) sealed
J#
public APP_MSG.REFERENCE_NODE_REQUEST(
byte
)
JScript
public function APP_MSG.REFERENCE_NODE_REQUEST(
: Byte
)

See Also

APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.REFERENCE_NODE_REQUEST Constructor Overload List


Fields

APP_MSG.REFERENCE_NODE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | NumberMessages |
Top

See Also

APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI2 Namespace


NumberMessages Field

APP_MSG.REFERENCE_NODE_REQUEST.NumberMessages Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumberMessages As Byte
C#
public byte NumberMessages;
C++
public:
char NumberMessages sealed ;
J#
public byte NumberMessages
JScript
public NumberMessages : Byte;

See Also

APP_MSG.REFERENCE_NODE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
See Also Example Members
[image]

Used by Commissioner to assign Client status to a device and therefore to cause a new image to be downloaded to that device. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
C#
public struct APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
C++
value class APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
J#
public final class APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Members

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used by Commissioner to assign Client status to a device and therefore to cause a new image to be downloaded to that device. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlclC_endp |
Public field | zlclC_IEEE |
Public field | zlclC_manu |
Public field | zlclC_nwk |
Public field | zlclC_prod |
Public field | zlclC_ver |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST | Initializes a new instance of the APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST class.
Public method | APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST (Byte, Byte, UInt16, UInt16, UInt16, UInt64, UInt16, APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT) |

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor ()

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST()
C++
public:
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST() sealed
J#
public APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST()
JScript
public function APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST()

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor Overload List


APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, UInt64, UInt16, APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT)

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, UInt64, UInt16, APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT _
)
C#
public APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ulong ,
ushort ,
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
)
C++
public:
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned __int64 ,
unsigned short ,
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
) sealed
J#
public APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ulong ,
ushort ,
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
)
JScript
public function APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST(
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: UInt64,
: UInt16,
: APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
)

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Constructor Overload List


Fields

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlclC_endp |
Public field | zlclC_IEEE |
Public field | zlclC_manu |
Public field | zlclC_nwk |
Public field | zlclC_prod |
Public field | zlclC_ver |
Top

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


zlclC_endp Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_endp Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_endp As APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
C#
public APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT zlclC_endp;
C++
public:
APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT zlclC_endp sealed ;
J#
public APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT zlclC_endp
JScript
public zlclC_endp : APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


zlclC_IEEE Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_IEEE Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_IEEE As UInt64
C#
public ulong zlclC_IEEE;
C++
public:
unsigned __int64 zlclC_IEEE sealed ;
J#
public ulong zlclC_IEEE
JScript
public zlclC_IEEE : UInt64;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


zlclC_manu Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_manu Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_manu As UInt16
C#
public ushort zlclC_manu;
C++
public:
unsigned short zlclC_manu sealed ;
J#
public ushort zlclC_manu
JScript
public zlclC_manu : UInt16;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


zlclC_nwk Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_nwk Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_nwk As UInt16
C#
public ushort zlclC_nwk;
C++
public:
unsigned short zlclC_nwk sealed ;
J#
public ushort zlclC_nwk
JScript
public zlclC_nwk : UInt16;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


zlclC_prod Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_prod Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_prod As UInt16
C#
public ushort zlclC_prod;
C++
public:
unsigned short zlclC_prod sealed ;
J#
public ushort zlclC_prod
JScript
public zlclC_prod : UInt16;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


zlclC_ver Field

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.zlclC_ver Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlclC_ver As UInt16
C#
public ushort zlclC_ver;
C++
public:
unsigned short zlclC_ver sealed ;
J#
public ushort zlclC_ver
JScript
public zlclC_ver : UInt16;

See Also

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT Enumeration

APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT Enumeration
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT As Byte
C#
public enum APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT : byte
C++
public enum class APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT : char
J#
public enum APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT byte
JScript
public enum APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT :

Members

Member Name | Description
OAD |
LOCATION |
LOCATION_DONGLE |

See Also

TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
See Also Example Members
[image]

This command causes the target device to enable the downloaded image. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
C#
public struct APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
C++
value class APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
J#
public final class APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Members

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command causes the target device to enable the downloaded image. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlceC_manu |
Public field | zlceC_prod |
Public field | zlceC_ver |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST | Initializes a new instance of the APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST class.
Public method | APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST (Byte, Byte, UInt16, UInt16, UInt16) |

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor ()

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST()
C++
public:
APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST() sealed
J#
public APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST()
JScript
public function APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST()

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor Overload List


APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16)

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort
)
C++
public:
APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short
) sealed
J#
public APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort
)
JScript
public function APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST(
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16
)

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Constructor Overload List


Fields

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlceC_manu |
Public field | zlceC_prod |
Public field | zlceC_ver |
Top

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


zlceC_manu Field

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.zlceC_manu Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlceC_manu As UInt16
C#
public ushort zlceC_manu;
C++
public:
unsigned short zlceC_manu sealed ;
J#
public ushort zlceC_manu
JScript
public zlceC_manu : UInt16;

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


zlceC_prod Field

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.zlceC_prod Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlceC_prod As UInt16
C#
public ushort zlceC_prod;
C++
public:
unsigned short zlceC_prod sealed ;
J#
public ushort zlceC_prod
JScript
public zlceC_prod : UInt16;

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


zlceC_ver Field

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST.zlceC_ver Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlceC_ver As UInt16
C#
public ushort zlceC_ver;
C++
public:
unsigned short zlceC_ver sealed ;
J#
public ushort zlceC_ver
JScript
public zlceC_ver : UInt16;

See Also

APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
See Also Example Members
[image]

This command requests the target device to reset. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
C#
public struct APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
C++
value class APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
J#
public final class APP_MSG.ZLMSGID_RESET_BOARD_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_RESET_BOARD_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Members

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command requests the target device to reset. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_RESET_BOARD_REQUEST.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_RESET_BOARD_REQUEST | Initializes a new instance of the APP_MSG.ZLMSGID_RESET_BOARD_REQUEST class.
Public method | APP_MSG.ZLMSGID_RESET_BOARD_REQUEST (Byte, Byte) |

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor ()

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_RESET_BOARD_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_RESET_BOARD_REQUEST()
C++
public:
APP_MSG.ZLMSGID_RESET_BOARD_REQUEST() sealed
J#
public APP_MSG.ZLMSGID_RESET_BOARD_REQUEST()
JScript
public function APP_MSG.ZLMSGID_RESET_BOARD_REQUEST()

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor Overload List


APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor (Byte, Byte)

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor (Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
byte ,
byte
)
C++
public:
APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
char ,
char
) sealed
J#
public APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
byte ,
byte
)
JScript
public function APP_MSG.ZLMSGID_RESET_BOARD_REQUEST(
: Byte,
: Byte
)

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Constructor Overload List


Fields

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_RESET_BOARD_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_REQUEST Structure

APP_MSG.ZLMSGID_RESET_REQUEST Structure
See Also Example Members
[image]

This command requests the target device to terminate all OAD activity and return to the idle state. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_RESET_REQUEST
C#
public struct APP_MSG.ZLMSGID_RESET_REQUEST
C++
value class APP_MSG.ZLMSGID_RESET_REQUEST
J#
public final class APP_MSG.ZLMSGID_RESET_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_RESET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_REQUEST Members

APP_MSG.ZLMSGID_RESET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command requests the target device to terminate all OAD activity and return to the idle state. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_RESET_REQUEST.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_RESET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_RESET_REQUEST | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_REQUEST Constructor

APP_MSG.ZLMSGID_RESET_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_RESET_REQUEST | Initializes a new instance of the APP_MSG.ZLMSGID_RESET_REQUEST class.
Public method | APP_MSG.ZLMSGID_RESET_REQUEST (Byte, Byte) |

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_RESET_REQUEST Constructor ()

APP_MSG.ZLMSGID_RESET_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_RESET_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_RESET_REQUEST()
C++
public:
APP_MSG.ZLMSGID_RESET_REQUEST() sealed
J#
public APP_MSG.ZLMSGID_RESET_REQUEST()
JScript
public function APP_MSG.ZLMSGID_RESET_REQUEST()

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_RESET_REQUEST Constructor Overload List


APP_MSG.ZLMSGID_RESET_REQUEST Constructor (Byte, Byte)

APP_MSG.ZLMSGID_RESET_REQUEST Constructor (Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public APP_MSG.ZLMSGID_RESET_REQUEST(
byte ,
byte
)
C++
public:
APP_MSG.ZLMSGID_RESET_REQUEST(
char ,
char
) sealed
J#
public APP_MSG.ZLMSGID_RESET_REQUEST(
byte ,
byte
)
JScript
public function APP_MSG.ZLMSGID_RESET_REQUEST(
: Byte,
: Byte
)

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_RESET_REQUEST Constructor Overload List


Fields

APP_MSG.ZLMSGID_RESET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_RESET_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_RESET_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_RESET_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_SEND_DATA_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
C#
public struct APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
C++
value class APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
J#
public final class APP_MSG.ZLMSGID_SEND_DATA_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_SEND_DATA_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Members

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_SEND_DATA_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdR_data |
Public field | zlsdR_errorCode |
Public field | zlsdR_pktNum |
Public field | zlsdR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_SEND_DATA_RESPONSE | Initializes a new instance of the APP_MSG.ZLMSGID_SEND_DATA_RESPONSE class.
Public method | APP_MSG.ZLMSGID_SEND_DATA_RESPONSE (Byte, Byte, APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, UInt16, Byte) |

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor ()

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_SEND_DATA_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE()
C++
public:
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE() sealed
J#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE()
JScript
public function APP_MSG.ZLMSGID_SEND_DATA_RESPONSE()

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor Overload List


APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor (Byte, Byte, APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, UInt16, Byte[])

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor (Byte, Byte, APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, UInt16, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE, _
ByVal As UInt16, _
ByVal As Byte() _
)
C#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
byte ,
byte ,
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE ,
ushort ,
byte[]
)
C++
public:
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
char ,
char ,
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE ,
unsigned short ,
array<char>^
) sealed
J#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
byte ,
byte ,
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE ,
ushort ,
byte[]
)
JScript
public function APP_MSG.ZLMSGID_SEND_DATA_RESPONSE(
: Byte,
: Byte,
: APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE,
: UInt16,
: Byte[]
)

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Constructor Overload List


Fields

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdR_data |
Public field | zlsdR_errorCode |
Public field | zlsdR_pktNum |
Public field | zlsdR_state |
Top

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


zlsdR_data Field

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_data Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_data As Byte()
C#
public byte[] zlsdR_data;
C++
public:
array<char>^ zlsdR_data sealed ;
J#
public byte[] zlsdR_data
JScript
public zlsdR_data : Byte[];

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


zlsdR_errorCode Field

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_errorCode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_errorCode As APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE
C#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE zlsdR_errorCode;
C++
public:
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE zlsdR_errorCode sealed ;
J#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE zlsdR_errorCode
JScript
public zlsdR_errorCode : APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE;

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


zlsdR_pktNum Field

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_pktNum Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_pktNum As UInt16
C#
public ushort zlsdR_pktNum;
C++
public:
unsigned short zlsdR_pktNum sealed ;
J#
public ushort zlsdR_pktNum
JScript
public zlsdR_pktNum : UInt16;

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


zlsdR_state Field

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.zlsdR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdR_state As APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE zlsdR_state;
C++
public:
APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE zlsdR_state sealed ;
J#
public APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE zlsdR_state
JScript
public zlsdR_state : APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE Enumeration

APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE As Byte
C#
public enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE : byte
C++
public enum class APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE : char
J#
public enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE byte
JScript
public enum APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NOT_IN_SVR_ST |
BAD_SESS_ID |
OOR_PKT_NUM |
NO_PRE_START_SESS_CMD |

See Also

TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_SESSION_START_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_SESSION_START_RESPONSE
C#
public struct APP_MSG.ZLMSGID_SESSION_START_RESPONSE
C++
value class APP_MSG.ZLMSGID_SESSION_START_RESPONSE
J#
public final class APP_MSG.ZLMSGID_SESSION_START_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_START_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_START_RESPONSE Members

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_SESSION_START_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_SESSION_START_RESPONSE.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsR_blkSize |
Public field | zlbsR_errorCode |
Public field | zlbsR_imgLen |
Public field | zlbsR_imgOffset |
Public field | zlbsR_numBlks |
Public field | zlbsR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_SESSION_START_RESPONSE | Initializes a new instance of the APP_MSG.ZLMSGID_SESSION_START_RESPONSE class.
Public method | APP_MSG.ZLMSGID_SESSION_START_RESPONSE (Byte, Byte, APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, UInt32, Byte, Byte, Byte) |

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor ()

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_SESSION_START_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE()
C++
public:
APP_MSG.ZLMSGID_SESSION_START_RESPONSE() sealed
J#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE()
JScript
public function APP_MSG.ZLMSGID_SESSION_START_RESPONSE()

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor Overload List


APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor (Byte, Byte, APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, UInt32, Byte, Byte, Byte)

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor (Byte, Byte, APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, UInt32, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE, _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
byte ,
byte ,
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE ,
uint ,
byte ,
byte ,
byte
)
C++
public:
APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
char ,
char ,
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE ,
unsigned int ,
char ,
char ,
char
) sealed
J#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
byte ,
byte ,
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE ,
uint ,
byte ,
byte ,
byte
)
JScript
public function APP_MSG.ZLMSGID_SESSION_START_RESPONSE(
: Byte,
: Byte,
: APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE,
: UInt32,
: Byte,
: Byte,
: Byte
)

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_SESSION_START_RESPONSE Constructor Overload List


Fields

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsR_blkSize |
Public field | zlbsR_errorCode |
Public field | zlbsR_imgLen |
Public field | zlbsR_imgOffset |
Public field | zlbsR_numBlks |
Public field | zlbsR_state |
Top

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


zlbsR_blkSize Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_blkSize Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_blkSize As Byte
C#
public byte zlbsR_blkSize;
C++
public:
char zlbsR_blkSize sealed ;
J#
public byte zlbsR_blkSize
JScript
public zlbsR_blkSize : Byte;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


zlbsR_errorCode Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_errorCode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_errorCode As APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE
C#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE zlbsR_errorCode;
C++
public:
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE zlbsR_errorCode sealed ;
J#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE zlbsR_errorCode
JScript
public zlbsR_errorCode : APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


zlbsR_imgLen Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_imgLen Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_imgLen As UInt32
C#
public uint zlbsR_imgLen;
C++
public:
unsigned int zlbsR_imgLen sealed ;
J#
public uint zlbsR_imgLen
JScript
public zlbsR_imgLen : UInt32;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


zlbsR_imgOffset Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_imgOffset Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_imgOffset As Byte
C#
public byte zlbsR_imgOffset;
C++
public:
char zlbsR_imgOffset sealed ;
J#
public byte zlbsR_imgOffset
JScript
public zlbsR_imgOffset : Byte;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


zlbsR_numBlks Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_numBlks Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_numBlks As Byte
C#
public byte zlbsR_numBlks;
C++
public:
char zlbsR_numBlks sealed ;
J#
public byte zlbsR_numBlks
JScript
public zlbsR_numBlks : Byte;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


zlbsR_state Field

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.zlbsR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsR_state As APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE zlbsR_state;
C++
public:
APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE zlbsR_state sealed ;
J#
public APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE zlbsR_state
JScript
public zlbsR_state : APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG.ZLMSGID_SESSION_START_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE Enumeration

APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE As Byte
C#
public enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE : byte
C++
public enum class APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE : char
J#
public enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE byte
JScript
public enum APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NOT_IN_IDLE_ST |
NO_IMG_MATCH |
CANT_ALLOC_MEM |

See Also

TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_SESSION_TERM_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
C#
public struct APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
C++
value class APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
J#
public final class APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Members

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_SESSION_TERM_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE | Initializes a new instance of the APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE class.
Public method | APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE (Byte, Byte, APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE) |

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor ()

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE()
C++
public:
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE() sealed
J#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE()
JScript
public function APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE()

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor Overload List


APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor (Byte, Byte, APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE)

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor (Byte, Byte, APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE _
)
C#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
byte ,
byte ,
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
)
C++
public:
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
char ,
char ,
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
) sealed
J#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
byte ,
byte ,
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
)
JScript
public function APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE(
: Byte,
: Byte,
: APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
)

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Constructor Overload List


Fields

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_errorCode Field

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.zlesR_errorCode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
C#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE zlesR_errorCode;
C++
public:
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE zlesR_errorCode sealed ;
J#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE;

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_state Field

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.zlesR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE Enumeration

APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE As Byte
C#
public enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE : byte
C++
public enum class APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE : char
J#
public enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE byte
JScript
public enum APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
BAD_SESSION_ID |
NOT_IN_SVR_ST |

See Also

TI.ZPI2 Namespace


APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
See Also Example Members
[image]

Used to determine images currently existing on a device. This is part of the Commissioner's enumeration process. Based on need each device may then be either a Client or a Server depending on current images on-board. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG.ZLMSGID_STATUSQ_REQUEST
C#
public struct APP_MSG.ZLMSGID_STATUSQ_REQUEST
C++
value class APP_MSG.ZLMSGID_STATUSQ_REQUEST
J#
public final class APP_MSG.ZLMSGID_STATUSQ_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG.ZLMSGID_STATUSQ_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Members
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_STATUSQ_REQUEST Members

APP_MSG.ZLMSGID_STATUSQ_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used to determine images currently existing on a device. This is part of the Commissioner's enumeration process. Based on need each device may then be either a Client or a Server depending on current images on-board. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG.ZLMSGID_STATUSQ_REQUEST.

Public Constructors

Name | Description
APP_MSG.ZLMSGID_STATUSQ_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG.ZLMSGID_STATUSQ_REQUEST | Overloaded.
Top

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor

APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG.ZLMSGID_STATUSQ_REQUEST | Initializes a new instance of the APP_MSG.ZLMSGID_STATUSQ_REQUEST class.
Public method | APP_MSG.ZLMSGID_STATUSQ_REQUEST (Byte, Byte) |

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor ()

APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG.ZLMSGID_STATUSQ_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG.ZLMSGID_STATUSQ_REQUEST()
C++
public:
APP_MSG.ZLMSGID_STATUSQ_REQUEST() sealed
J#
public APP_MSG.ZLMSGID_STATUSQ_REQUEST()
JScript
public function APP_MSG.ZLMSGID_STATUSQ_REQUEST()

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor Overload List


APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor (Byte, Byte)

APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor (Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public APP_MSG.ZLMSGID_STATUSQ_REQUEST(
byte ,
byte
)
C++
public:
APP_MSG.ZLMSGID_STATUSQ_REQUEST(
char ,
char
) sealed
J#
public APP_MSG.ZLMSGID_STATUSQ_REQUEST(
byte ,
byte
)
JScript
public function APP_MSG.ZLMSGID_STATUSQ_REQUEST(
: Byte,
: Byte
)

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG.ZLMSGID_STATUSQ_REQUEST Constructor Overload List


Fields

APP_MSG.ZLMSGID_STATUSQ_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Top

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG.ZLMSGID_STATUSQ_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG.ZLMSGID_STATUSQ_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG.ZLMSGID_STATUSQ_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RESPONSE Class

APP_MSG_RESPONSE Class
See Also Example Members
[image]

Status for APP_MSG

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APP_MSG_RESPONSE
Implements IRESPONSE, IAPP
C#
public class APP_MSG_RESPONSE : IRESPONSE, IAPP
C++
ref class APP_MSG_RESPONSE : IRESPONSE, IAPP
J#
public class APP_MSG_RESPONSE implements IRESPONSE, IAPP
JScript
public class APP_MSG_RESPONSE extends IRESPONSE, IAPP

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RESPONSE Members

APP_MSG_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Status for APP_MSG

The following tables list the members exposed by APP_MSG_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RESPONSE Class
TI.ZPI2 Namespace


APP_MSG_RESPONSE Constructor

APP_MSG_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RESPONSE | Constructor
Public method | APP_MSG_RESPONSE (APP_MSG_RESPONSE.CMD_STATUS) |

See Also

APP_MSG_RESPONSE Class
TI.ZPI2 Namespace


APP_MSG_RESPONSE Constructor ()

APP_MSG_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RESPONSE()
C++
public:
APP_MSG_RESPONSE() sealed
J#
public APP_MSG_RESPONSE()
JScript
public function APP_MSG_RESPONSE()

See Also

APP_MSG_RESPONSE Class
TI.ZPI2 Namespace
APP_MSG_RESPONSE Constructor Overload List


APP_MSG_RESPONSE Constructor (APP_MSG_RESPONSE.CMD_STATUS)

APP_MSG_RESPONSE Constructor (APP_MSG_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As APP_MSG_RESPONSE.CMD_STATUS _
)
C#
public APP_MSG_RESPONSE(
APP_MSG_RESPONSE.CMD_STATUS
)
C++
public:
APP_MSG_RESPONSE(
APP_MSG_RESPONSE.CMD_STATUS
) sealed
J#
public APP_MSG_RESPONSE(
APP_MSG_RESPONSE.CMD_STATUS
)
JScript
public function APP_MSG_RESPONSE(
: APP_MSG_RESPONSE.CMD_STATUS
)

See Also

APP_MSG_RESPONSE Class
TI.ZPI2 Namespace
APP_MSG_RESPONSE Constructor Overload List


Fields

APP_MSG_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

See Also

APP_MSG_RESPONSE Class
TI.ZPI2 Namespace


Status Field

APP_MSG_RESPONSE.Status Field
[image]

The fail status is returned if the component identifier in the comand message was not valid.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As APP_MSG_RESPONSE.CMD_STATUS
C#
public APP_MSG_RESPONSE.CMD_STATUS Status;
C++
public:
APP_MSG_RESPONSE.CMD_STATUS Status sealed ;
J#
public APP_MSG_RESPONSE.CMD_STATUS Status
JScript
public Status : APP_MSG_RESPONSE.CMD_STATUS;

See Also

APP_MSG_RESPONSE Class
TI.ZPI2 Namespace


APP_MSG_RESPONSE.CMD_STATUS Enumeration

APP_MSG_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RESPONSE.CMD_STATUS As Byte
C#
public enum APP_MSG_RESPONSE.CMD_STATUS : byte
C++
public enum class APP_MSG_RESPONSE.CMD_STATUS : char
J#
public enum APP_MSG_RESPONSE.CMD_STATUS byte
JScript
public enum APP_MSG_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


APP_MSG_RSP Class

APP_MSG_RSP Class
See Also Example Members
[image]

Response for APP_MSG

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APP_MSG_RSP
Implements IRESPONSE, IAPP
C#
public class APP_MSG_RSP : IRESPONSE, IAPP
C++
ref class APP_MSG_RSP : IRESPONSE, IAPP
J#
public class APP_MSG_RSP implements IRESPONSE, IAPP
JScript
public class APP_MSG_RSP extends IRESPONSE, IAPP

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP Members
TI.ZPI2 Namespace


APP_MSG_RSP Members

APP_MSG_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for APP_MSG

The following tables list the members exposed by APP_MSG_RSP.

Public Constructors

Name | Description
APP_MSG_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppEndpoint | this represents the application endpoint to send the data
Public field | ClusterID | Cluster ID of the received message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the received message
Public field | SrcAddress | Source address of the received message
Public field | SrcEndpoint | Source endpoint of the received message
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP | Overloaded.
Top

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


APP_MSG_RSP Constructor

APP_MSG_RSP Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP | Constructor
Public method | APP_MSG_RSP (Byte, UInt16, Byte, UInt16, Byte, Byte) | Constructor

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


APP_MSG_RSP Constructor ()

APP_MSG_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP()
C++
public:
APP_MSG_RSP() sealed
J#
public APP_MSG_RSP()
JScript
public function APP_MSG_RSP()

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace
APP_MSG_RSP Constructor Overload List


APP_MSG_RSP Constructor (Byte, UInt16, Byte, UInt16, Byte, Byte[])

APP_MSG_RSP Constructor (Byte, UInt16, Byte, UInt16, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public APP_MSG_RSP(
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte[]
)
C++
public:
APP_MSG_RSP(
char ,
unsigned short ,
char ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public APP_MSG_RSP(
byte ,
ushort ,
byte ,
ushort ,
byte ,
byte[]
)
JScript
public function APP_MSG_RSP(
: Byte,
: UInt16,
: Byte,
: UInt16,
: Byte,
: Byte[]
)

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace
APP_MSG_RSP Constructor Overload List


Fields

APP_MSG_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | AppEndpoint | this represents the application endpoint to send the data
Public field | ClusterID | Cluster ID of the received message
Public field | Message | raw data packet to send to the application
Public field | MsgLen | Length of the received message
Public field | SrcAddress | Source address of the received message
Public field | SrcEndpoint | Source endpoint of the received message
Top

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


AppEndpoint Field

APP_MSG_RSP.AppEndpoint Field
[image]

this represents the application endpoint to send the data

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppEndpoint As Byte
C#
public byte AppEndpoint;
C++
public:
char AppEndpoint sealed ;
J#
public byte AppEndpoint
JScript
public AppEndpoint : Byte;

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


ClusterID Field

APP_MSG_RSP.ClusterID Field
[image]

Cluster ID of the received message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


Message Field

APP_MSG_RSP.Message Field
[image]

raw data packet to send to the application

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Message As Byte()
C#
public byte[] Message;
C++
public:
array<char>^ Message sealed ;
J#
public byte[] Message
JScript
public Message : Byte[];

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


MsgLen Field

APP_MSG_RSP.MsgLen Field
[image]

Length of the received message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsgLen As Byte
C#
public byte MsgLen;
C++
public:
char MsgLen sealed ;
J#
public byte MsgLen
JScript
public MsgLen : Byte;

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


SrcAddress Field

APP_MSG_RSP.SrcAddress Field
[image]

Source address of the received message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


SrcEndpoint Field

APP_MSG_RSP.SrcEndpoint Field
[image]

Source endpoint of the received message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

APP_MSG_RSP Class
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.BLIND_NODE_CONFIGURATION
C#
public struct APP_MSG_RSP.BLIND_NODE_CONFIGURATION
C++
value class APP_MSG_RSP.BLIND_NODE_CONFIGURATION
J#
public final class APP_MSG_RSP.BLIND_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.BLIND_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Members
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_CONFIGURATION Members

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by APP_MSG_RSP.BLIND_NODE_CONFIGURATION.

Public Constructors

Name | Description
APP_MSG_RSP.BLIND_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.BLIND_NODE_CONFIGURATION | Overloaded.
Top

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.BLIND_NODE_CONFIGURATION | Initializes a new instance of the APP_MSG_RSP.BLIND_NODE_CONFIGURATION class.
Public method | APP_MSG_RSP.BLIND_NODE_CONFIGURATION (Byte, Byte, APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte) |

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor ()

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.BLIND_NODE_CONFIGURATION class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION()
C++
public:
APP_MSG_RSP.BLIND_NODE_CONFIGURATION() sealed
J#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION()
JScript
public function APP_MSG_RSP.BLIND_NODE_CONFIGURATION()

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor Overload List


APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor (Byte, Byte, APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, UInt16, UInt16, UInt16, APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT, _
ByVal As Byte _
)
C#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
C++
public:
APP_MSG_RSP.BLIND_NODE_CONFIGURATION(
char ,
char ,
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
unsigned short ,
unsigned short ,
unsigned short ,
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
char
) sealed
J#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION(
byte ,
byte ,
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE ,
ushort ,
ushort ,
ushort ,
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT ,
byte
)
JScript
public function APP_MSG_RSP.BLIND_NODE_CONFIGURATION(
: Byte,
: Byte,
: APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE,
: UInt16,
: UInt16,
: UInt16,
: APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT,
: Byte
)

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG_RSP.BLIND_NODE_CONFIGURATION Constructor Overload List


Fields

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | AParameter |
Public field | CollectTime |
Public field | CycleTime |
Public field | MinRefNodes |
Public field | Mode |
Public field | nParameter |
Public field | ReportEndpoint |
Public field | ReportShortAddress |
Top

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


AParameter Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.AParameter Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AParameter As Byte
C#
public byte AParameter;
C++
public:
char AParameter sealed ;
J#
public byte AParameter
JScript
public AParameter : Byte;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


CollectTime Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.CollectTime Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CollectTime As UInt16
C#
public ushort CollectTime;
C++
public:
unsigned short CollectTime sealed ;
J#
public ushort CollectTime
JScript
public CollectTime : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


CycleTime Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.CycleTime Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CycleTime As UInt16
C#
public ushort CycleTime;
C++
public:
unsigned short CycleTime sealed ;
J#
public ushort CycleTime
JScript
public CycleTime : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


MinRefNodes Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.MinRefNodes Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MinRefNodes As Byte
C#
public byte MinRefNodes;
C++
public:
char MinRefNodes sealed ;
J#
public byte MinRefNodes
JScript
public MinRefNodes : Byte;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


Mode Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.Mode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
C#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode;
C++
public:
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode sealed ;
J#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Mode
JScript
public Mode : APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


nParameter Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.nParameter Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public nParameter As Byte
C#
public byte nParameter;
C++
public:
char nParameter sealed ;
J#
public byte nParameter
JScript
public nParameter : Byte;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


ReportEndpoint Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.ReportEndpoint Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportEndpoint As APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT
C#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint;
C++
public:
APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint sealed ;
J#
public APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT ReportEndpoint
JScript
public ReportEndpoint : APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


ReportShortAddress Field

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.ReportShortAddress Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReportShortAddress As UInt16
C#
public ushort ReportShortAddress;
C++
public:
unsigned short ReportShortAddress sealed ;
J#
public ushort ReportShortAddress
JScript
public ReportShortAddress : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT As Byte
C#
public enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT : byte
C++
public enum class APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT : char
J#
public enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT byte
JScript
public enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT :

Members

Member Name | Description
OAD |
LOCATION |
LOCATION_DONGLE |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration

APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE As Byte
C#
public enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : byte
C++
public enum class APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE : char
J#
public enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE byte
JScript
public enum APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE :

Members

Member Name | Description
POLLED |
AUTO |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_RESPONSE Structure

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
See Also Example Members
[image]

This message is sent out of the Blind Node in response to the "Bind Node Request" message. The blind node, upon receiving the request message, will send a "Reference Node Request" (radius 1 - broadcast) to its immediate neighbors and wait for responses. Use the Blind Node Configuration message to change the parameters used to generate this response message (ie. number of reference node response, collect time)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.BLIND_NODE_RESPONSE
C#
public struct APP_MSG_RSP.BLIND_NODE_RESPONSE
C++
value class APP_MSG_RSP.BLIND_NODE_RESPONSE
J#
public final class APP_MSG_RSP.BLIND_NODE_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.BLIND_NODE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_RESPONSE Members

APP_MSG_RSP.BLIND_NODE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent out of the Blind Node in response to the "Bind Node Request" message. The blind node, upon receiving the request message, will send a "Reference Node Request" (radius 1 - broadcast) to its immediate neighbors and wait for responses. Use the Blind Node Configuration message to change the parameters used to generate this response message (ie. number of reference node response, collect time)

The following tables list the members exposed by APP_MSG_RSP.BLIND_NODE_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RSP.BLIND_NODE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClosestRSSI |
Public field | ClosestShortAddr |
Public field | ClosestXPos |
Public field | ClosestYPos |
Public field | NumOfRef |
Public field | Status |
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.BLIND_NODE_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor

APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.BLIND_NODE_RESPONSE | Initializes a new instance of the APP_MSG_RSP.BLIND_NODE_RESPONSE class.
Public method | APP_MSG_RSP.BLIND_NODE_RESPONSE (APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, UInt16, Byte) |

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor ()

APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.BLIND_NODE_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.BLIND_NODE_RESPONSE()
C++
public:
APP_MSG_RSP.BLIND_NODE_RESPONSE() sealed
J#
public APP_MSG_RSP.BLIND_NODE_RESPONSE()
JScript
public function APP_MSG_RSP.BLIND_NODE_RESPONSE()

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor Overload List


APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor (APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, UInt16, Byte)

APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor (APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, UInt16, UInt16, Byte, UInt16, UInt16, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public APP_MSG_RSP.BLIND_NODE_RESPONSE(
APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS ,
ushort ,
ushort ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
C++
public:
APP_MSG_RSP.BLIND_NODE_RESPONSE(
APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS ,
unsigned short ,
unsigned short ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
char
) sealed
J#
public APP_MSG_RSP.BLIND_NODE_RESPONSE(
APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS ,
ushort ,
ushort ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
JScript
public function APP_MSG_RSP.BLIND_NODE_RESPONSE(
: APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS,
: UInt16,
: UInt16,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: Byte
)

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.BLIND_NODE_RESPONSE Constructor Overload List


Fields

APP_MSG_RSP.BLIND_NODE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | ClosestRSSI |
Public field | ClosestShortAddr |
Public field | ClosestXPos |
Public field | ClosestYPos |
Public field | NumOfRef |
Public field | Status |
Public field | XPos |
Public field | YPos |
Top

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


ClosestRSSI Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.ClosestRSSI Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestRSSI As Byte
C#
public byte ClosestRSSI;
C++
public:
char ClosestRSSI sealed ;
J#
public byte ClosestRSSI
JScript
public ClosestRSSI : Byte;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


ClosestShortAddr Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.ClosestShortAddr Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestShortAddr As UInt16
C#
public ushort ClosestShortAddr;
C++
public:
unsigned short ClosestShortAddr sealed ;
J#
public ushort ClosestShortAddr
JScript
public ClosestShortAddr : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


ClosestXPos Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.ClosestXPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestXPos As UInt16
C#
public ushort ClosestXPos;
C++
public:
unsigned short ClosestXPos sealed ;
J#
public ushort ClosestXPos
JScript
public ClosestXPos : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


ClosestYPos Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.ClosestYPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClosestYPos As UInt16
C#
public ushort ClosestYPos;
C++
public:
unsigned short ClosestYPos sealed ;
J#
public ushort ClosestYPos
JScript
public ClosestYPos : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


NumOfRef Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.NumOfRef Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOfRef As Byte
C#
public byte NumOfRef;
C++
public:
char NumOfRef sealed ;
J#
public byte NumOfRef
JScript
public NumOfRef : Byte;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


Status Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.Status Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS
C#
public APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Status;
C++
public:
APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Status sealed ;
J#
public APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Status
JScript
public Status : APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


XPos Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.XPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


YPos Field

APP_MSG_RSP.BLIND_NODE_RESPONSE.YPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

APP_MSG_RSP.BLIND_NODE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Enumeration

APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS As Byte
C#
public enum APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS : byte
C++
public enum class APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS : char
J#
public enum APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS byte
JScript
public enum APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS :

Members

Member Name | Description
SUCCESS |
NOT_ENOUGH_REF |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.LOC_RSP_MESSAGE_ID Enumeration

APP_MSG_RSP.LOC_RSP_MESSAGE_ID Enumeration
[image]

Message id for LOC_RSP_MESSAGE_ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.LOC_RSP_MESSAGE_ID As Short
C#
public enum APP_MSG_RSP.LOC_RSP_MESSAGE_ID : short
C++
public enum class APP_MSG_RSP.LOC_RSP_MESSAGE_ID : short
J#
public enum APP_MSG_RSP.LOC_RSP_MESSAGE_ID short
JScript
public enum APP_MSG_RSP.LOC_RSP_MESSAGE_ID : short

Members

Member Name | Description
REFERENCE_NODE_RESPONSE | Message id for LOC_RSP_MESSAGE_ID
BLIND_NODE_RESPONSE | Message id for LOC_RSP_MESSAGE_ID
REFERENCE_NODE_CONFIGURATION | Message id for LOC_RSP_MESSAGE_ID
BLIND_NODE_CONFIGURATION | Message id for LOC_RSP_MESSAGE_ID

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.OAD_RSP_MESSAGE_ID Enumeration

APP_MSG_RSP.OAD_RSP_MESSAGE_ID Enumeration
[image]

Message id for OAD_RSP_MESSAGE_ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.OAD_RSP_MESSAGE_ID As Short
C#
public enum APP_MSG_RSP.OAD_RSP_MESSAGE_ID : short
C++
public enum class APP_MSG_RSP.OAD_RSP_MESSAGE_ID : short
J#
public enum APP_MSG_RSP.OAD_RSP_MESSAGE_ID short
JScript
public enum APP_MSG_RSP.OAD_RSP_MESSAGE_ID : short

Members

Member Name | Description
ZLMSGID_STATUSQ_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_SESSION_START_REQUEST | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_SESSION_TERM_REQUEST | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_CLIENT_CMD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_CODE_ENABLE_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_SEND_DATA_REQUEST | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_RESET_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_RESET_BOARD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_GET_DONGLE_INFO_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_STATUSQ_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_CLIENT_CMD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_CODE_ENABLE_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_RESET_RESPONSE | Message id for OAD_RSP_MESSAGE_ID
ZLMSGID_PROXY_RESET_BOARD_RESPONSE | Message id for OAD_RSP_MESSAGE_ID

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
See Also Example Members
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION
C#
public struct APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION
C++
value class APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION
J#
public final class APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Members
TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Members

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send this message to the Reference Node to set its configuration items. This message is also sent from the Reference Node in response to the "Reference Node Configuration Request"

The following tables list the members exposed by APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION.

Public Constructors

Name | Description
APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION | Overloaded.
Top

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION | Initializes a new instance of the APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION class.
Public method | APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION (UInt16, UInt16) |

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor ()

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION()
C++
public:
APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION() sealed
J#
public APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION()
JScript
public function APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION()

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor Overload List


APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor (UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
C++
public:
APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION(
unsigned short ,
unsigned short
) sealed
J#
public APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION(
ushort ,
ushort
)
JScript
public function APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION(
: UInt16,
: UInt16
)

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace
APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Constructor Overload List


Fields

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | XPos |
Public field | YPos |
Top

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


XPos Field

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION.XPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


YPos Field

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION.YPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION Structure
TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
See Also Example Members
[image]

This message is sent by a Reference Node in response to a "Reference Node Request" message. The number of time that this message is sent depends on the number request in the request. When multiple responses are request, the delay between responses are from 2-16 milliseconds

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.REFERENCE_NODE_RESPONSE
C#
public struct APP_MSG_RSP.REFERENCE_NODE_RESPONSE
C++
value class APP_MSG_RSP.REFERENCE_NODE_RESPONSE
J#
public final class APP_MSG_RSP.REFERENCE_NODE_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.REFERENCE_NODE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_RESPONSE Members

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by a Reference Node in response to a "Reference Node Request" message. The number of time that this message is sent depends on the number request in the request. When multiple responses are request, the delay between responses are from 2-16 milliseconds

The following tables list the members exposed by APP_MSG_RSP.REFERENCE_NODE_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RSP.REFERENCE_NODE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ResponseNumber |
Public field | XPos |
Public field | YPos |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.REFERENCE_NODE_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.REFERENCE_NODE_RESPONSE | Initializes a new instance of the APP_MSG_RSP.REFERENCE_NODE_RESPONSE class.
Public method | APP_MSG_RSP.REFERENCE_NODE_RESPONSE (UInt16, UInt16, Byte) |

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor ()

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.REFERENCE_NODE_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.REFERENCE_NODE_RESPONSE()
C++
public:
APP_MSG_RSP.REFERENCE_NODE_RESPONSE() sealed
J#
public APP_MSG_RSP.REFERENCE_NODE_RESPONSE()
JScript
public function APP_MSG_RSP.REFERENCE_NODE_RESPONSE()

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor Overload List


APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor (UInt16, UInt16, Byte)

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor (UInt16, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public APP_MSG_RSP.REFERENCE_NODE_RESPONSE(
ushort ,
ushort ,
byte
)
C++
public:
APP_MSG_RSP.REFERENCE_NODE_RESPONSE(
unsigned short ,
unsigned short ,
char
) sealed
J#
public APP_MSG_RSP.REFERENCE_NODE_RESPONSE(
ushort ,
ushort ,
byte
)
JScript
public function APP_MSG_RSP.REFERENCE_NODE_RESPONSE(
: UInt16,
: UInt16,
: Byte
)

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.REFERENCE_NODE_RESPONSE Constructor Overload List


Fields

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | ResponseNumber |
Public field | XPos |
Public field | YPos |
Top

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace


ResponseNumber Field

APP_MSG_RSP.REFERENCE_NODE_RESPONSE.ResponseNumber Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ResponseNumber As Byte
C#
public byte ResponseNumber;
C++
public:
char ResponseNumber sealed ;
J#
public byte ResponseNumber
JScript
public ResponseNumber : Byte;

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace


XPos Field

APP_MSG_RSP.REFERENCE_NODE_RESPONSE.XPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public XPos As UInt16
C#
public ushort XPos;
C++
public:
unsigned short XPos sealed ;
J#
public ushort XPos
JScript
public XPos : UInt16;

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace


YPos Field

APP_MSG_RSP.REFERENCE_NODE_RESPONSE.YPos Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public YPos As UInt16
C#
public ushort YPos;
C++
public:
unsigned short YPos sealed ;
J#
public ushort YPos
JScript
public YPos : UInt16;

See Also

APP_MSG_RSP.REFERENCE_NODE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_CLIENT_CMD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE
C#
public struct APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE
C++
value class APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE
J#
public final class APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Members

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_CLIENT_CMD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE class.
Public method | APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE (Byte, Byte, APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE) |

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor ()

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE()
C++
public:
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE() sealed
J#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE()
JScript
public function APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE()

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor Overload List


APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE)

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE _
)
C#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
)
C++
public:
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE(
char ,
char ,
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
) sealed
J#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
)
JScript
public function APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE(
: Byte,
: Byte,
: APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
)

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_errorCode Field

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
C#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE zlesR_errorCode;
C++
public:
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE zlesR_errorCode sealed ;
J#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE;

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_state Field

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.zlesR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE Enumeration

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE : char
J#
public enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NOT_IN_IDLE_ST |
CANT_ALLOC_MEM |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_CODE_ENABLE_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE
C#
public struct APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE
C++
value class APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE
J#
public final class APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Members

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_CODE_ENABLE_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE class.
Public method | APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE (Byte, Byte, APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE) |

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor ()

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE()
C++
public:
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE() sealed
J#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE()
JScript
public function APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE()

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor Overload List


APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE)

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE _
)
C#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
)
C++
public:
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE(
char ,
char ,
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
) sealed
J#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
)
JScript
public function APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE(
: Byte,
: Byte,
: APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
)

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_errorCode Field

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
C#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE zlesR_errorCode;
C++
public:
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE zlesR_errorCode sealed ;
J#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE;

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_state Field

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.zlesR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE Enumeration

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE : char
J#
public enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE :

Members

Member Name | Description
NO_ERROR |
NO_VALID_DL_IMG |
NO_IMG_SPEC_MATCH |
NOT_IN_IDLE_ST |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_RESET_BOARD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE
C#
public struct APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE
C++
value class APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE
J#
public final class APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Members

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_RESET_BOARD_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE class.
Public method | APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE (Byte, Byte, APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE) |

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor ()

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE()
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE() sealed
J#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE()
JScript
public function APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE()

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor Overload List


APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE)

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE _
)
C#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
)
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE(
char ,
char ,
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
) sealed
J#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
)
JScript
public function APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE(
: Byte,
: Byte,
: APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
)

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_errorCode Field

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.zlesR_errorCode Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
C#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE zlesR_errorCode;
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE zlesR_errorCode sealed ;
J#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE;

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_state Field

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.zlesR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE Enumeration

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE : char
J#
public enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE :

Members

Member Name | Description
NO_ERROR |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_RESET_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_RESET_RESPONSE
C#
public struct APP_MSG_RSP.ZLMSGID_RESET_RESPONSE
C++
value class APP_MSG_RSP.ZLMSGID_RESET_RESPONSE
J#
public final class APP_MSG_RSP.ZLMSGID_RESET_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Members

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_RESET_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_RESET_RESPONSE | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_RESET_RESPONSE class.
Public method | APP_MSG_RSP.ZLMSGID_RESET_RESPONSE (Byte, Byte, APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE) |

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor ()

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_RESET_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE()
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE() sealed
J#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE()
JScript
public function APP_MSG_RSP.ZLMSGID_RESET_RESPONSE()

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor Overload List


APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE)

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE _
)
C#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE
)
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE(
char ,
char ,
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE
) sealed
J#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE
)
JScript
public function APP_MSG_RSP.ZLMSGID_RESET_RESPONSE(
: Byte,
: Byte,
: APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE
)

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesR_errorCode |
Public field | zlesR_state |
Top

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_errorCode Field

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.zlesR_errorCode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_errorCode As APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE
C#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE zlesR_errorCode;
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE zlesR_errorCode sealed ;
J#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE zlesR_errorCode
JScript
public zlesR_errorCode : APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE;

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace


zlesR_state Field

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.zlesR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesR_state As APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE zlesR_state;
C++
public:
APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE zlesR_state sealed ;
J#
public APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE zlesR_state
JScript
public zlesR_state : APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE Enumeration

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE Enumeration
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE : char
J#
public enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE :

Members

Member Name | Description
NO_ERROR |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
See Also Example Members
[image]

This command requests the target device to send a data packet. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST
C#
public struct APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST
C++
value class APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST
J#
public final class APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Members

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command requests the target device to send a data packet. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdC_pktNum |
Public field | zlsdC_sessionID |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST class.
Public method | APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST (Byte, Byte, UInt16, Byte) |

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor ()

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST()
C++
public:
APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST() sealed
J#
public APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST()
JScript
public function APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST()

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor Overload List


APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor (Byte, Byte, UInt16, Byte)

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor (Byte, Byte, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST(
byte ,
byte ,
ushort ,
byte
)
C++
public:
APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST(
char ,
char ,
unsigned short ,
char
) sealed
J#
public APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST(
byte ,
byte ,
ushort ,
byte
)
JScript
public function APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST(
: Byte,
: Byte,
: UInt16,
: Byte
)

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsdC_pktNum |
Public field | zlsdC_sessionID |
Top

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace


zlsdC_pktNum Field

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST.zlsdC_pktNum Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdC_pktNum As UInt16
C#
public ushort zlsdC_pktNum;
C++
public:
unsigned short zlsdC_pktNum sealed ;
J#
public ushort zlsdC_pktNum
JScript
public zlsdC_pktNum : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace


zlsdC_sessionID Field

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST.zlsdC_sessionID Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsdC_sessionID As Byte
C#
public byte zlsdC_sessionID;
C++
public:
char zlsdC_sessionID sealed ;
J#
public byte zlsdC_sessionID
JScript
public zlsdC_sessionID : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
See Also Example Members
[image]

Used to mark the beginning of a set of data transfer transactions and to establish Server status on the part of the target device. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST
C#
public struct APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST
C++
value class APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST
J#
public final class APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Members

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used to mark the beginning of a set of data transfer transactions and to establish Server status on the part of the target device. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsC_manu |
Public field | zlbsC_prod |
Public field | zlbsC_sessionID |
Public field | zlbsC_ver |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST class.
Public method | APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST (Byte, Byte, UInt16, UInt16, UInt16, Byte) |

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor ()

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST()
C++
public:
APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST() sealed
J#
public APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST()
JScript
public function APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST()

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor Overload List


APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, Byte)

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor (Byte, Byte, UInt16, UInt16, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
C++
public:
APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST(
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
char
) sealed
J#
public APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST(
byte ,
byte ,
ushort ,
ushort ,
ushort ,
byte
)
JScript
public function APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST(
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: Byte
)

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlbsC_manu |
Public field | zlbsC_prod |
Public field | zlbsC_sessionID |
Public field | zlbsC_ver |
Top

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


zlbsC_manu Field

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST.zlbsC_manu Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_manu As UInt16
C#
public ushort zlbsC_manu;
C++
public:
unsigned short zlbsC_manu sealed ;
J#
public ushort zlbsC_manu
JScript
public zlbsC_manu : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


zlbsC_prod Field

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST.zlbsC_prod Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_prod As UInt16
C#
public ushort zlbsC_prod;
C++
public:
unsigned short zlbsC_prod sealed ;
J#
public ushort zlbsC_prod
JScript
public zlbsC_prod : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


zlbsC_sessionID Field

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST.zlbsC_sessionID Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_sessionID As Byte
C#
public byte zlbsC_sessionID;
C++
public:
char zlbsC_sessionID sealed ;
J#
public byte zlbsC_sessionID
JScript
public zlbsC_sessionID : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


zlbsC_ver Field

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST.zlbsC_ver Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlbsC_ver As UInt16
C#
public ushort zlbsC_ver;
C++
public:
unsigned short zlbsC_ver sealed ;
J#
public ushort zlbsC_ver
JScript
public zlbsC_ver : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
See Also Example Members
[image]

Used to terminate a session and reset the OAD context of the target platform. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST
C#
public struct APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST
C++
value class APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST
J#
public final class APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Members

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Used to terminate a session and reset the OAD context of the target platform. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesC_sessionID |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST class.
Public method | APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST (Byte, Byte, Byte) |

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor ()

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST()
C++
public:
APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST() sealed
J#
public APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST()
JScript
public function APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST()

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor Overload List


APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor (Byte, Byte, Byte)

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor (Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST(
byte ,
byte ,
byte
)
C++
public:
APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST(
char ,
char ,
char
) sealed
J#
public APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST(
byte ,
byte ,
byte
)
JScript
public function APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST(
: Byte,
: Byte,
: Byte
)

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlesC_sessionID |
Top

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace


zlesC_sessionID Field

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST.zlesC_sessionID Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlesC_sessionID As Byte
C#
public byte zlesC_sessionID;
C++
public:
char zlesC_sessionID sealed ;
J#
public byte zlesC_sessionID
JScript
public zlesC_sessionID : Byte;

See Also

APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
See Also Example Members
[image]

Response for ZLMSGID_STATUSQ_REQUEST. (latest OAD protocol version, OAD protocol version 1)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE
C#
public struct APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE
C++
value class APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE
J#
public final class APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Members
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Members

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZLMSGID_STATUSQ_REQUEST. (latest OAD protocol version, OAD protocol version 1)

The following tables list the members exposed by APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.

Public Constructors

Name | Description
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsqR_capabilties |
Public field | zlsqR_curPkt |
Public field | zlsqR_dlManu |
Public field | zlsqR_dlProd |
Public field | zlsqR_dlVer |
Public field | zlsqR_errorCode |
Public field | zlsqR_opManu |
Public field | zlsqR_opProd |
Public field | zlsqR_opVer |
Public field | zlsqR_protocolVer |
Public field | zlsqR_state |
Public field | zlsqR_totPkt |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE | Overloaded.
Top

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE | Initializes a new instance of the APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE class.
Public method | APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE (Byte, Byte, APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, Byte, Byte, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16) |

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor ()

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor ()
See Also Example
[image]

Initializes a new instance of the APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE()
C++
public:
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE() sealed
J#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE()
JScript
public function APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE()

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor Overload List


APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, Byte, Byte, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16)

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor (Byte, Byte, APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, Byte, Byte, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE, _
ByVal As APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE ,
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort
)
C++
public:
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE(
char ,
char ,
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE ,
char ,
char ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short ,
unsigned short
) sealed
J#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE(
byte ,
byte ,
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE ,
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE ,
byte ,
byte ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort ,
ushort
)
JScript
public function APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE(
: Byte,
: Byte,
: APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE,
: APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE,
: Byte,
: Byte,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16,
: UInt16
)

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Constructor Overload List


Fields

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Length |
Public field | Session |
Public field | zlsqR_capabilties |
Public field | zlsqR_curPkt |
Public field | zlsqR_dlManu |
Public field | zlsqR_dlProd |
Public field | zlsqR_dlVer |
Public field | zlsqR_errorCode |
Public field | zlsqR_opManu |
Public field | zlsqR_opProd |
Public field | zlsqR_opVer |
Public field | zlsqR_protocolVer |
Public field | zlsqR_state |
Public field | zlsqR_totPkt |
Top

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


Length Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.Length Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


Session Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.Session Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Session As Byte
C#
public byte Session;
C++
public:
char Session sealed ;
J#
public byte Session
JScript
public Session : Byte;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_capabilties Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_capabilties Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_capabilties As Byte
C#
public byte zlsqR_capabilties;
C++
public:
char zlsqR_capabilties sealed ;
J#
public byte zlsqR_capabilties
JScript
public zlsqR_capabilties : Byte;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_curPkt Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_curPkt Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_curPkt As UInt16
C#
public ushort zlsqR_curPkt;
C++
public:
unsigned short zlsqR_curPkt sealed ;
J#
public ushort zlsqR_curPkt
JScript
public zlsqR_curPkt : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_dlManu Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_dlManu Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_dlManu As UInt16
C#
public ushort zlsqR_dlManu;
C++
public:
unsigned short zlsqR_dlManu sealed ;
J#
public ushort zlsqR_dlManu
JScript
public zlsqR_dlManu : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_dlProd Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_dlProd Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_dlProd As UInt16
C#
public ushort zlsqR_dlProd;
C++
public:
unsigned short zlsqR_dlProd sealed ;
J#
public ushort zlsqR_dlProd
JScript
public zlsqR_dlProd : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_dlVer Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_dlVer Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_dlVer As UInt16
C#
public ushort zlsqR_dlVer;
C++
public:
unsigned short zlsqR_dlVer sealed ;
J#
public ushort zlsqR_dlVer
JScript
public zlsqR_dlVer : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_errorCode Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_errorCode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_errorCode As APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE
C#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE zlsqR_errorCode;
C++
public:
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE zlsqR_errorCode sealed ;
J#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE zlsqR_errorCode
JScript
public zlsqR_errorCode : APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_opManu Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_opManu Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_opManu As UInt16
C#
public ushort zlsqR_opManu;
C++
public:
unsigned short zlsqR_opManu sealed ;
J#
public ushort zlsqR_opManu
JScript
public zlsqR_opManu : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_opProd Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_opProd Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_opProd As UInt16
C#
public ushort zlsqR_opProd;
C++
public:
unsigned short zlsqR_opProd sealed ;
J#
public ushort zlsqR_opProd
JScript
public zlsqR_opProd : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_opVer Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_opVer Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_opVer As UInt16
C#
public ushort zlsqR_opVer;
C++
public:
unsigned short zlsqR_opVer sealed ;
J#
public ushort zlsqR_opVer
JScript
public zlsqR_opVer : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_protocolVer Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_protocolVer Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_protocolVer As Byte
C#
public byte zlsqR_protocolVer;
C++
public:
char zlsqR_protocolVer sealed ;
J#
public byte zlsqR_protocolVer
JScript
public zlsqR_protocolVer : Byte;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_state Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_state Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_state As APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE
C#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE zlsqR_state;
C++
public:
APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE zlsqR_state sealed ;
J#
public APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE zlsqR_state
JScript
public zlsqR_state : APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


zlsqR_totPkt Field

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.zlsqR_totPkt Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public zlsqR_totPkt As UInt16
C#
public ushort zlsqR_totPkt;
C++
public:
unsigned short zlsqR_totPkt sealed ;
J#
public ushort zlsqR_totPkt
JScript
public zlsqR_totPkt : UInt16;

See Also

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE Structure
TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE Enumeration

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE Enumeration
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE : char
J#
public enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE :

Members

Member Name | Description
NO_ERROR |

See Also

TI.ZPI2 Namespace


APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE Enumeration

APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE Enumeration
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE As Byte
C#
public enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE : byte
C++
public enum class APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE : char
J#
public enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE byte
JScript
public enum APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE :

Members

Member Name | Description
IDLE |
CLIENT |
SERVER |

See Also

TI.ZPI2 Namespace


APP_USER_TEST Class

APP_USER_TEST Class
See Also Example Members
[image]

This command is used by the tester to set the debug threshold level for a particular software component in the target.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APP_USER_TEST
Implements IREQUEST, IAPP
C#
public class APP_USER_TEST : IREQUEST, IAPP
C++
ref class APP_USER_TEST : IREQUEST, IAPP
J#
public class APP_USER_TEST implements IREQUEST, IAPP
JScript
public class APP_USER_TEST extends IREQUEST, IAPP

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_USER_TEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_USER_TEST Members
TI.ZPI2 Namespace


APP_USER_TEST Members

APP_USER_TEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to set the debug threshold level for a particular software component in the target.

The following tables list the members exposed by APP_USER_TEST.

Public Constructors

Name | Description
APP_USER_TEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CommandID | Command ID of the user-defined command
Public field | Parameter1 | Parameter #1 of the command
Public field | Parameter2 | Parameter #2 of the command
Public field | SrcEP | Source Endpoint of the user-defined command
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APP_USER_TEST | Overloaded.
Top

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace


APP_USER_TEST Constructor

APP_USER_TEST Constructor

Overload List

 | Name | Description
Public method | APP_USER_TEST | Constructor
Public method | APP_USER_TEST (Byte, UInt16, UInt16, UInt16) | Constructor

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace


APP_USER_TEST Constructor ()

APP_USER_TEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_USER_TEST()
C++
public:
APP_USER_TEST() sealed
J#
public APP_USER_TEST()
JScript
public function APP_USER_TEST()

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace
APP_USER_TEST Constructor Overload List


APP_USER_TEST Constructor (Byte, UInt16, UInt16, UInt16)

APP_USER_TEST Constructor (Byte, UInt16, UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public APP_USER_TEST(
byte ,
ushort ,
ushort ,
ushort
)
C++
public:
APP_USER_TEST(
char ,
unsigned short ,
unsigned short ,
unsigned short
) sealed
J#
public APP_USER_TEST(
byte ,
ushort ,
ushort ,
ushort
)
JScript
public function APP_USER_TEST(
: Byte,
: UInt16,
: UInt16,
: UInt16
)

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace
APP_USER_TEST Constructor Overload List


Fields

APP_USER_TEST Fields
[image]

Public Fields

 | Name | Description
Public field | CommandID | Command ID of the user-defined command
Public field | Parameter1 | Parameter #1 of the command
Public field | Parameter2 | Parameter #2 of the command
Public field | SrcEP | Source Endpoint of the user-defined command
Top

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace


CommandID Field

APP_USER_TEST.CommandID Field
[image]

Command ID of the user-defined command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandID As UInt16
C#
public ushort CommandID;
C++
public:
unsigned short CommandID sealed ;
J#
public ushort CommandID
JScript
public CommandID : UInt16;

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace


Parameter1 Field

APP_USER_TEST.Parameter1 Field
[image]

Parameter #1 of the command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Parameter1 As UInt16
C#
public ushort Parameter1;
C++
public:
unsigned short Parameter1 sealed ;
J#
public ushort Parameter1
JScript
public Parameter1 : UInt16;

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace


Parameter2 Field

APP_USER_TEST.Parameter2 Field
[image]

Parameter #2 of the command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Parameter2 As UInt16
C#
public ushort Parameter2;
C++
public:
unsigned short Parameter2 sealed ;
J#
public ushort Parameter2
JScript
public Parameter2 : UInt16;

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace


SrcEP Field

APP_USER_TEST.SrcEP Field
[image]

Source Endpoint of the user-defined command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEP As Byte
C#
public byte SrcEP;
C++
public:
char SrcEP sealed ;
J#
public byte SrcEP
JScript
public SrcEP : Byte;

See Also

APP_USER_TEST Class
TI.ZPI2 Namespace


APP_USER_TEST_RESPONSE Class

APP_USER_TEST_RESPONSE Class
See Also Example Members
[image]

Response for APP_USER_TEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APP_USER_TEST_RESPONSE
Implements IRESPONSE, IAPP
C#
public class APP_USER_TEST_RESPONSE : IRESPONSE, IAPP
C++
ref class APP_USER_TEST_RESPONSE : IRESPONSE, IAPP
J#
public class APP_USER_TEST_RESPONSE implements IRESPONSE, IAPP
JScript
public class APP_USER_TEST_RESPONSE extends IRESPONSE, IAPP

Inheritance Hierarchy

System.Object
TI.ZPI2.APP_USER_TEST_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APP_USER_TEST_RESPONSE Members
TI.ZPI2 Namespace


APP_USER_TEST_RESPONSE Members

APP_USER_TEST_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for APP_USER_TEST

The following tables list the members exposed by APP_USER_TEST_RESPONSE.

Public Constructors

Name | Description
APP_USER_TEST_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APP_USER_TEST_RESPONSE | Overloaded.
Top

See Also

APP_USER_TEST_RESPONSE Class
TI.ZPI2 Namespace


APP_USER_TEST_RESPONSE Constructor

APP_USER_TEST_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APP_USER_TEST_RESPONSE | Constructor
Public method | APP_USER_TEST_RESPONSE (APP_USER_TEST_RESPONSE.CMD_STATUS) |

See Also

APP_USER_TEST_RESPONSE Class
TI.ZPI2 Namespace


APP_USER_TEST_RESPONSE Constructor ()

APP_USER_TEST_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APP_USER_TEST_RESPONSE()
C++
public:
APP_USER_TEST_RESPONSE() sealed
J#
public APP_USER_TEST_RESPONSE()
JScript
public function APP_USER_TEST_RESPONSE()

See Also

APP_USER_TEST_RESPONSE Class
TI.ZPI2 Namespace
APP_USER_TEST_RESPONSE Constructor Overload List


APP_USER_TEST_RESPONSE Constructor (APP_USER_TEST_RESPONSE.CMD_STATUS)

APP_USER_TEST_RESPONSE Constructor (APP_USER_TEST_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As APP_USER_TEST_RESPONSE.CMD_STATUS _
)
C#
public APP_USER_TEST_RESPONSE(
APP_USER_TEST_RESPONSE.CMD_STATUS
)
C++
public:
APP_USER_TEST_RESPONSE(
APP_USER_TEST_RESPONSE.CMD_STATUS
) sealed
J#
public APP_USER_TEST_RESPONSE(
APP_USER_TEST_RESPONSE.CMD_STATUS
)
JScript
public function APP_USER_TEST_RESPONSE(
: APP_USER_TEST_RESPONSE.CMD_STATUS
)

See Also

APP_USER_TEST_RESPONSE Class
TI.ZPI2 Namespace
APP_USER_TEST_RESPONSE Constructor Overload List


Fields

APP_USER_TEST_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

See Also

APP_USER_TEST_RESPONSE Class
TI.ZPI2 Namespace


Status Field

APP_USER_TEST_RESPONSE.Status Field
[image]

The fail status is returned if the component identifier in the comand message was not valid.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As APP_USER_TEST_RESPONSE.CMD_STATUS
C#
public APP_USER_TEST_RESPONSE.CMD_STATUS Status;
C++
public:
APP_USER_TEST_RESPONSE.CMD_STATUS Status sealed ;
J#
public APP_USER_TEST_RESPONSE.CMD_STATUS Status
JScript
public Status : APP_USER_TEST_RESPONSE.CMD_STATUS;

See Also

APP_USER_TEST_RESPONSE Class
TI.ZPI2 Namespace


APP_USER_TEST_RESPONSE.CMD_STATUS Enumeration

APP_USER_TEST_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APP_USER_TEST_RESPONSE.CMD_STATUS As Byte
C#
public enum APP_USER_TEST_RESPONSE.CMD_STATUS : byte
C++
public enum class APP_USER_TEST_RESPONSE.CMD_STATUS : char
J#
public enum APP_USER_TEST_RESPONSE.CMD_STATUS byte
JScript
public enum APP_USER_TEST_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


APSDE_DATA_CONFIRMATION Class

APSDE_DATA_CONFIRMATION Class
See Also Example Members
[image]

This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APSDE_DATA_CONFIRMATION
Implements ICONFIRMATION
C#
public class APSDE_DATA_CONFIRMATION : ICONFIRMATION
C++
ref class APSDE_DATA_CONFIRMATION : ICONFIRMATION
J#
public class APSDE_DATA_CONFIRMATION implements ICONFIRMATION
JScript
public class APSDE_DATA_CONFIRMATION extends ICONFIRMATION

Inheritance Hierarchy

System.Object
TI.ZPI2.APSDE_DATA_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APSDE_DATA_CONFIRMATION Members
TI.ZPI2 Namespace


APSDE_DATA_CONFIRMATION Members

APSDE_DATA_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.

The following tables list the members exposed by APSDE_DATA_CONFIRMATION.

Public Constructors

Name | Description
APSDE_DATA_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | indicates the IEEE extended address of the remote device
Public field | DestAddressPresent | indicates if the destination address and endpoint information is present
Public field | DestEndpoint | indicates the endpoint of the destination device
Public field | SrcEndpoint | indicates the endpoint of the destination device
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APSDE_DATA_CONFIRMATION | Overloaded.
Top

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


APSDE_DATA_CONFIRMATION Constructor

APSDE_DATA_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | APSDE_DATA_CONFIRMATION | Constructor
Public method | APSDE_DATA_CONFIRMATION (APSDE_DATA_CONFIRMATION.BOOLEAN, UInt64, Byte, Byte, APSDE_DATA_CONFIRMATION.APSDE_STATUS) |

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


APSDE_DATA_CONFIRMATION Constructor ()

APSDE_DATA_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APSDE_DATA_CONFIRMATION()
C++
public:
APSDE_DATA_CONFIRMATION() sealed
J#
public APSDE_DATA_CONFIRMATION()
JScript
public function APSDE_DATA_CONFIRMATION()

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace
APSDE_DATA_CONFIRMATION Constructor Overload List


APSDE_DATA_CONFIRMATION Constructor (APSDE_DATA_CONFIRMATION.BOOLEAN, UInt64, Byte, Byte, APSDE_DATA_CONFIRMATION.APSDE_STATUS)

APSDE_DATA_CONFIRMATION Constructor (APSDE_DATA_CONFIRMATION.BOOLEAN, UInt64, Byte, Byte, APSDE_DATA_CONFIRMATION.APSDE_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As APSDE_DATA_CONFIRMATION.BOOLEAN, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As APSDE_DATA_CONFIRMATION.APSDE_STATUS _
)
C#
public APSDE_DATA_CONFIRMATION(
APSDE_DATA_CONFIRMATION.BOOLEAN ,
ulong ,
byte ,
byte ,
APSDE_DATA_CONFIRMATION.APSDE_STATUS
)
C++
public:
APSDE_DATA_CONFIRMATION(
APSDE_DATA_CONFIRMATION.BOOLEAN ,
unsigned __int64 ,
char ,
char ,
APSDE_DATA_CONFIRMATION.APSDE_STATUS
) sealed
J#
public APSDE_DATA_CONFIRMATION(
APSDE_DATA_CONFIRMATION.BOOLEAN ,
ulong ,
byte ,
byte ,
APSDE_DATA_CONFIRMATION.APSDE_STATUS
)
JScript
public function APSDE_DATA_CONFIRMATION(
: APSDE_DATA_CONFIRMATION.BOOLEAN,
: UInt64,
: Byte,
: Byte,
: APSDE_DATA_CONFIRMATION.APSDE_STATUS
)

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace
APSDE_DATA_CONFIRMATION Constructor Overload List


Fields

APSDE_DATA_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | indicates the IEEE extended address of the remote device
Public field | DestAddressPresent | indicates if the destination address and endpoint information is present
Public field | DestEndpoint | indicates the endpoint of the destination device
Public field | SrcEndpoint | indicates the endpoint of the destination device
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


DestAddress Field

APSDE_DATA_CONFIRMATION.DestAddress Field
[image]

indicates the IEEE extended address of the remote device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


DestAddressPresent Field

APSDE_DATA_CONFIRMATION.DestAddressPresent Field
[image]

indicates if the destination address and endpoint information is present

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressPresent As APSDE_DATA_CONFIRMATION.BOOLEAN
C#
public APSDE_DATA_CONFIRMATION.BOOLEAN DestAddressPresent;
C++
public:
APSDE_DATA_CONFIRMATION.BOOLEAN DestAddressPresent sealed ;
J#
public APSDE_DATA_CONFIRMATION.BOOLEAN DestAddressPresent
JScript
public DestAddressPresent : APSDE_DATA_CONFIRMATION.BOOLEAN;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


DestEndpoint Field

APSDE_DATA_CONFIRMATION.DestEndpoint Field
[image]

indicates the endpoint of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


SrcEndpoint Field

APSDE_DATA_CONFIRMATION.SrcEndpoint Field
[image]

indicates the endpoint of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

APSDE_DATA_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As APSDE_DATA_CONFIRMATION.APSDE_STATUS
C#
public APSDE_DATA_CONFIRMATION.APSDE_STATUS Status;
C++
public:
APSDE_DATA_CONFIRMATION.APSDE_STATUS Status sealed ;
J#
public APSDE_DATA_CONFIRMATION.APSDE_STATUS Status
JScript
public Status : APSDE_DATA_CONFIRMATION.APSDE_STATUS;

See Also

APSDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


APSDE_DATA_CONFIRMATION.APSDE_STATUS Enumeration

APSDE_DATA_CONFIRMATION.APSDE_STATUS Enumeration
[image]

Status code for APSDE responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APSDE_DATA_CONFIRMATION.APSDE_STATUS As Byte
C#
public enum APSDE_DATA_CONFIRMATION.APSDE_STATUS : byte
C++
public enum class APSDE_DATA_CONFIRMATION.APSDE_STATUS : char
J#
public enum APSDE_DATA_CONFIRMATION.APSDE_STATUS byte
JScript
public enum APSDE_DATA_CONFIRMATION.APSDE_STATUS :

Members

Member Name | Description
APSDE_SUCCESS | Status code for APSDE responses
APSDE_INVALID_TARGET | Status code for APSDE responses
APSDE_NO_BOUND_DEVICE | Status code for APSDE responses
APSDE_BUFFER_FULL | Status code for APSDE responses
APSDE_MEMORY_ERROR | Status code for APSDE responses
APSDE_INVALID_NETWORK_STATE | Status code for APSDE responses
APSDE_TX_ERROR | Status code for APSDE responses
APSDE_FAIL | Status code for APSDE responses

See Also

TI.ZPI2 Namespace


APSDE_DATA_CONFIRMATION.BOOLEAN Enumeration

APSDE_DATA_CONFIRMATION.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APSDE_DATA_CONFIRMATION.BOOLEAN As Byte
C#
public enum APSDE_DATA_CONFIRMATION.BOOLEAN : byte
C++
public enum class APSDE_DATA_CONFIRMATION.BOOLEAN : char
J#
public enum APSDE_DATA_CONFIRMATION.BOOLEAN byte
JScript
public enum APSDE_DATA_CONFIRMATION.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


APSME_BIND_RESPONSE Class

APSME_BIND_RESPONSE Class
See Also Example Members
[image]

Response for APSME_BIND

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class APSME_BIND_RESPONSE
Implements IRESPONSE
C#
public class APSME_BIND_RESPONSE : IRESPONSE
C++
ref class APSME_BIND_RESPONSE : IRESPONSE
J#
public class APSME_BIND_RESPONSE implements IRESPONSE
JScript
public class APSME_BIND_RESPONSE extends IRESPONSE

Inheritance Hierarchy

System.Object
TI.ZPI2.APSME_BIND_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

APSME_BIND_RESPONSE Members
TI.ZPI2 Namespace


APSME_BIND_RESPONSE Members

APSME_BIND_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for APSME_BIND

The following tables list the members exposed by APSME_BIND_RESPONSE.

Public Constructors

Name | Description
APSME_BIND_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
APSME_BIND_RESPONSE | Overloaded.
Top

See Also

APSME_BIND_RESPONSE Class
TI.ZPI2 Namespace


APSME_BIND_RESPONSE Constructor

APSME_BIND_RESPONSE Constructor

Overload List

 | Name | Description
Public method | APSME_BIND_RESPONSE | Constructor
Public method | APSME_BIND_RESPONSE (APSME_BIND_RESPONSE.NLME_STATUS) |

See Also

APSME_BIND_RESPONSE Class
TI.ZPI2 Namespace


APSME_BIND_RESPONSE Constructor ()

APSME_BIND_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public APSME_BIND_RESPONSE()
C++
public:
APSME_BIND_RESPONSE() sealed
J#
public APSME_BIND_RESPONSE()
JScript
public function APSME_BIND_RESPONSE()

See Also

APSME_BIND_RESPONSE Class
TI.ZPI2 Namespace
APSME_BIND_RESPONSE Constructor Overload List


APSME_BIND_RESPONSE Constructor (APSME_BIND_RESPONSE.NLME_STATUS)

APSME_BIND_RESPONSE Constructor (APSME_BIND_RESPONSE.NLME_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As APSME_BIND_RESPONSE.NLME_STATUS _
)
C#
public APSME_BIND_RESPONSE(
APSME_BIND_RESPONSE.NLME_STATUS
)
C++
public:
APSME_BIND_RESPONSE(
APSME_BIND_RESPONSE.NLME_STATUS
) sealed
J#
public APSME_BIND_RESPONSE(
APSME_BIND_RESPONSE.NLME_STATUS
)
JScript
public function APSME_BIND_RESPONSE(
: APSME_BIND_RESPONSE.NLME_STATUS
)

See Also

APSME_BIND_RESPONSE Class
TI.ZPI2 Namespace
APSME_BIND_RESPONSE Constructor Overload List


Fields

APSME_BIND_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

APSME_BIND_RESPONSE Class
TI.ZPI2 Namespace


Status Field

APSME_BIND_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As APSME_BIND_RESPONSE.NLME_STATUS
C#
public APSME_BIND_RESPONSE.NLME_STATUS Status;
C++
public:
APSME_BIND_RESPONSE.NLME_STATUS Status sealed ;
J#
public APSME_BIND_RESPONSE.NLME_STATUS Status
JScript
public Status : APSME_BIND_RESPONSE.NLME_STATUS;

See Also

APSME_BIND_RESPONSE Class
TI.ZPI2 Namespace


APSME_BIND_RESPONSE.NLME_STATUS Enumeration

APSME_BIND_RESPONSE.NLME_STATUS Enumeration
[image]

Status code for NLME response

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum APSME_BIND_RESPONSE.NLME_STATUS As Byte
C#
public enum APSME_BIND_RESPONSE.NLME_STATUS : byte
C++
public enum class APSME_BIND_RESPONSE.NLME_STATUS : char
J#
public enum APSME_BIND_RESPONSE.NLME_STATUS byte
JScript
public enum APSME_BIND_RESPONSE.NLME_STATUS :

Members

Member Name | Description
NLME_SUCCESS | Status code for NLME response
NLME_FAILURE | Status code for NLME response
NLME_ILLEGAL_REQUEST | Status code for NLME response
NLME_UNKNOWN_DEVICE | Status code for NLME response
NLME_STARTUP_FAILURE | Status code for NLME response
NLME_NO_SHORT_ADDRESS | Status code for NLME response
NLME_UNAVAILABLE_KEY | Status code for NLME response
NLME_FRAME_TOO_LONG | Status code for NLME response
NLME_FAILED_SECURITY_CHECK | Status code for NLME response
NLME_INVALID_PARAMETER | Status code for NLME response
NLME_UNSUPPORTED_ATTRIBUTE | Status code for NLME response
NLME_NOT_JOINED | Status code for NLME response
NLME_ALREADY_JOINED | Status code for NLME response
NLME_NOT_POSSIBLE | Status code for NLME response
NLME_TX_FAIL | Status code for NLME response
NLME_TX_ERROR | Status code for NLME response
NLME_RX_SUCCESS | Status code for NLME response
NLME_RX_FAILURE | Status code for NLME response
NLME_ALREADY_PRESENT | Status code for NLME response
NLME_NO_NETWORKS | Status code for NLME response
NLME_TABLE_FULL | Status code for NLME response

See Also

TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD Class

DEBUG_SET_DEBUG_THRESHOLD Class
See Also Example Members
[image]

This command is used by the tester to set the debug threshold level for a particular software component in the target.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DEBUG_SET_DEBUG_THRESHOLD
Implements IREQUEST, IDEBUG
C#
public class DEBUG_SET_DEBUG_THRESHOLD : IREQUEST, IDEBUG
C++
ref class DEBUG_SET_DEBUG_THRESHOLD : IREQUEST, IDEBUG
J#
public class DEBUG_SET_DEBUG_THRESHOLD implements IREQUEST, IDEBUG
JScript
public class DEBUG_SET_DEBUG_THRESHOLD extends IREQUEST, IDEBUG

Inheritance Hierarchy

System.Object
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DEBUG_SET_DEBUG_THRESHOLD Members
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD Members

DEBUG_SET_DEBUG_THRESHOLD Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to set the debug threshold level for a particular software component in the target.

The following tables list the members exposed by DEBUG_SET_DEBUG_THRESHOLD.

Public Constructors

Name | Description
DEBUG_SET_DEBUG_THRESHOLD | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ComponentID | uniquely identifies a particular software component on the target
Public field | Threshold | specifies the threshold value for reporting debug messages by that software component
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
DEBUG_SET_DEBUG_THRESHOLD | Overloaded.
Top

See Also

DEBUG_SET_DEBUG_THRESHOLD Class
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD Constructor

DEBUG_SET_DEBUG_THRESHOLD Constructor

Overload List

 | Name | Description
Public method | DEBUG_SET_DEBUG_THRESHOLD | Constructor
Public method | DEBUG_SET_DEBUG_THRESHOLD (Byte, DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD) |

See Also

DEBUG_SET_DEBUG_THRESHOLD Class
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD Constructor ()

DEBUG_SET_DEBUG_THRESHOLD Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DEBUG_SET_DEBUG_THRESHOLD()
C++
public:
DEBUG_SET_DEBUG_THRESHOLD() sealed
J#
public DEBUG_SET_DEBUG_THRESHOLD()
JScript
public function DEBUG_SET_DEBUG_THRESHOLD()

See Also

DEBUG_SET_DEBUG_THRESHOLD Class
TI.ZPI2 Namespace
DEBUG_SET_DEBUG_THRESHOLD Constructor Overload List


DEBUG_SET_DEBUG_THRESHOLD Constructor (Byte, DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD)

DEBUG_SET_DEBUG_THRESHOLD Constructor (Byte, DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD _
)
C#
public DEBUG_SET_DEBUG_THRESHOLD(
byte ,
DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
)
C++
public:
DEBUG_SET_DEBUG_THRESHOLD(
char ,
DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
) sealed
J#
public DEBUG_SET_DEBUG_THRESHOLD(
byte ,
DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
)
JScript
public function DEBUG_SET_DEBUG_THRESHOLD(
: Byte,
: DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
)

See Also

DEBUG_SET_DEBUG_THRESHOLD Class
TI.ZPI2 Namespace
DEBUG_SET_DEBUG_THRESHOLD Constructor Overload List


Fields

DEBUG_SET_DEBUG_THRESHOLD Fields
[image]

Public Fields

 | Name | Description
Public field | ComponentID | uniquely identifies a particular software component on the target
Public field | Threshold | specifies the threshold value for reporting debug messages by that software component
Top

See Also

DEBUG_SET_DEBUG_THRESHOLD Class
TI.ZPI2 Namespace


ComponentID Field

DEBUG_SET_DEBUG_THRESHOLD.ComponentID Field
[image]

uniquely identifies a particular software component on the target

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ComponentID As Byte
C#
public byte ComponentID;
C++
public:
char ComponentID sealed ;
J#
public byte ComponentID
JScript
public ComponentID : Byte;

See Also

DEBUG_SET_DEBUG_THRESHOLD Class
TI.ZPI2 Namespace


Threshold Field

DEBUG_SET_DEBUG_THRESHOLD.Threshold Field
[image]

specifies the threshold value for reporting debug messages by that software component

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Threshold As DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
C#
public DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Threshold;
C++
public:
DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Threshold sealed ;
J#
public DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Threshold
JScript
public Threshold : DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD;

See Also

DEBUG_SET_DEBUG_THRESHOLD Class
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Enumeration

DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD Enumeration
[image]

specifies the threshold value for reporting debug messages by that software component

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD As Byte
C#
public enum DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD : byte
C++
public enum class DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD : char
J#
public enum DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD byte
JScript
public enum DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD :

Members

Member Name | Description
CRITICAL | specifies the threshold value for reporting debug messages by that software component
ERROR | specifies the threshold value for reporting debug messages by that software component
INFORMATION | specifies the threshold value for reporting debug messages by that software component
TRACE | specifies the threshold value for reporting debug messages by that software component

See Also

TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class
See Also Example Members
[image]

Response for SYS_SET_DEBUG_THRESHOLD

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DEBUG_SET_DEBUG_THRESHOLD_RESPONSE
Implements IRESPONSE, IDEBUG
C#
public class DEBUG_SET_DEBUG_THRESHOLD_RESPONSE : IRESPONSE, IDEBUG
C++
ref class DEBUG_SET_DEBUG_THRESHOLD_RESPONSE : IRESPONSE, IDEBUG
J#
public class DEBUG_SET_DEBUG_THRESHOLD_RESPONSE implements IRESPONSE, IDEBUG
JScript
public class DEBUG_SET_DEBUG_THRESHOLD_RESPONSE extends IRESPONSE, IDEBUG

Inheritance Hierarchy

System.Object
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Members
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Members

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_DEBUG_THRESHOLD

The following tables list the members exposed by DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.

Public Constructors

Name | Description
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE | Overloaded.
Top

See Also

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor

Overload List

 | Name | Description
Public method | DEBUG_SET_DEBUG_THRESHOLD_RESPONSE | Constructor
Public method | DEBUG_SET_DEBUG_THRESHOLD_RESPONSE (DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS) |

See Also

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor ()

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DEBUG_SET_DEBUG_THRESHOLD_RESPONSE()
C++
public:
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE() sealed
J#
public DEBUG_SET_DEBUG_THRESHOLD_RESPONSE()
JScript
public function DEBUG_SET_DEBUG_THRESHOLD_RESPONSE()

See Also

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI2 Namespace
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor Overload List


DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor (DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS)

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor (DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS _
)
C#
public DEBUG_SET_DEBUG_THRESHOLD_RESPONSE(
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
)
C++
public:
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE(
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
) sealed
J#
public DEBUG_SET_DEBUG_THRESHOLD_RESPONSE(
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
)
JScript
public function DEBUG_SET_DEBUG_THRESHOLD_RESPONSE(
: DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
)

See Also

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI2 Namespace
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Constructor Overload List


Fields

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The fail status is returned if the component identifier in the comand message was not valid.
Top

See Also

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI2 Namespace


Status Field

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.Status Field
[image]

The fail status is returned if the component identifier in the comand message was not valid.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
C#
public DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Status;
C++
public:
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Status sealed ;
J#
public DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Status
JScript
public Status : DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS;

See Also

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE Class
TI.ZPI2 Namespace


DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Enumeration

DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS As Byte
C#
public enum DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS : byte
C++
public enum class DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS : char
J#
public enum DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS byte
JScript
public enum DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


DEBUG_STRING Class

DEBUG_STRING Class
See Also Example Members
[image]

Debug message sent by device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DEBUG_STRING
Implements IRESPONSE, IDEBUG
C#
public class DEBUG_STRING : IRESPONSE, IDEBUG
C++
ref class DEBUG_STRING : IRESPONSE, IDEBUG
J#
public class DEBUG_STRING implements IRESPONSE, IDEBUG
JScript
public class DEBUG_STRING extends IRESPONSE, IDEBUG

Inheritance Hierarchy

System.Object
TI.ZPI2.DEBUG_STRING

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DEBUG_STRING Members
TI.ZPI2 Namespace


DEBUG_STRING Members

DEBUG_STRING Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Debug message sent by device

The following tables list the members exposed by DEBUG_STRING.

Public Constructors

Name | Description
DEBUG_STRING | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DebugString | Debug string sent by device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
DEBUG_STRING | Overloaded.
Top

See Also

DEBUG_STRING Class
TI.ZPI2 Namespace


DEBUG_STRING Constructor

DEBUG_STRING Constructor

Overload List

 | Name | Description
Public method | DEBUG_STRING | Constructor
Public method | DEBUG_STRING (Byte) | Constructor

See Also

DEBUG_STRING Class
TI.ZPI2 Namespace


DEBUG_STRING Constructor ()

DEBUG_STRING Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DEBUG_STRING()
C++
public:
DEBUG_STRING() sealed
J#
public DEBUG_STRING()
JScript
public function DEBUG_STRING()

See Also

DEBUG_STRING Class
TI.ZPI2 Namespace
DEBUG_STRING Constructor Overload List


DEBUG_STRING Constructor (Byte[])

DEBUG_STRING Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public DEBUG_STRING(
byte[]
)
C++
public:
DEBUG_STRING(
array<char>^
) sealed
J#
public DEBUG_STRING(
byte[]
)
JScript
public function DEBUG_STRING(
: Byte[]
)

See Also

DEBUG_STRING Class
TI.ZPI2 Namespace
DEBUG_STRING Constructor Overload List


Fields

DEBUG_STRING Fields
[image]

Public Fields

 | Name | Description
Public field | DebugString | Debug string sent by device
Top

See Also

DEBUG_STRING Class
TI.ZPI2 Namespace


DebugString Field

DEBUG_STRING.DebugString Field
[image]

Debug string sent by device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DebugString As Byte()
C#
public byte[] DebugString;
C++
public:
array<char>^ DebugString sealed ;
J#
public byte[] DebugString
JScript
public DebugString : Byte[];

See Also

DEBUG_STRING Class
TI.ZPI2 Namespace


IAF Interface

IAF Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAF
C#
public interface IAF
C++
interface class IAF
J#
public interface IAF
JScript
public interface IAF

Types that implement IAF

Type | Description
TI.ZPI2.AF_APSF_CONFIG_SET | MT proxy for afAPSF_ConfigSet().
TI.ZPI2.AF_APSF_CONFIG_SET_SRSP | Response for AF_APSF_CONFIG_SET
TI.ZPI2.AF_DATA_CONFIRM | AF Data confirm.
TI.ZPI2.AF_DATA_REQUEST | This command is used by tester to build and send a data request message
TI.ZPI2.AF_DATA_REQUEST_EXT | This command is used by tester to build and send a data request message with PanId field.
TI.ZPI2.AF_DATA_REQUEST_EXT_SRSP | Response for AF_DATA_REQUEST_EXT
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG | This command is used by tester to build and send a data request message via source routing
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG_SRSP | Response for AF_DATA_REQUEST_SRC_RTG
TI.ZPI2.AF_DATA_REQUEST_SRSP | Response for AF_DATA_REQUEST
TI.ZPI2.AF_DATA_RETRIEVE | AF huge incoming message data retrieve command.
TI.ZPI2.AF_DATA_RETRIEVE_SRSP | Response for AF_DATA_RETRIEVE
TI.ZPI2.AF_DATA_STORE | AF huge data request data store command and data.
TI.ZPI2.AF_DATA_STORE_SRSP | Response for AF_DATA_STORE
TI.ZPI2.AF_INCOMING_MSG | Incoming AF data.
TI.ZPI2.AF_INCOMING_MSG_EXT | Incoming AF data extended.
TI.ZPI2.AF_INTER_PAN_CTL | Inter-Pan control command and data.
TI.ZPI2.AF_INTER_PAN_CTL_SRSP | Response for AF_INTER_PAN_SET_PARAM
TI.ZPI2.AF_REGISTER | This command enables the tester to register an application's endpoint description
TI.ZPI2.AF_REGISTER_SRSP | Response for AF_REGISTER

See Also

IAF Members
TI.ZPI2 Namespace


IAPP Interface

IAPP Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAPP
C#
public interface IAPP
C++
interface class IAPP
J#
public interface IAPP
JScript
public interface IAPP

Types that implement IAPP

Type | Description
TI.ZPI2.APP_MSG | Use this message to send raw data to an application.
TI.ZPI2.APP_MSG_RESPONSE | Status for APP_MSG
TI.ZPI2.APP_MSG_RSP | Response for APP_MSG
TI.ZPI2.APP_USER_TEST | This command is used by the tester to set the debug threshold level for a particular software component in the target.
TI.ZPI2.APP_USER_TEST_RESPONSE | Response for APP_USER_TEST
TI.ZPI2.ZLL_TOUCH_LINK_INDICATION | ZLL Touch Link Indication

See Also

IAPP Members
TI.ZPI2 Namespace


ICONFIRMATION Interface

ICONFIRMATION Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICONFIRMATION
C#
public interface ICONFIRMATION
C++
interface class ICONFIRMATION
J#
public interface ICONFIRMATION
JScript
public interface ICONFIRMATION

Types that implement ICONFIRMATION

Type | Description
TI.ZPI2.AF_DATA_CONFIRM | AF Data confirm.
TI.ZPI2.APSDE_DATA_CONFIRMATION | This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.
TI.ZPI2.NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
TI.ZPI2.NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
TI.ZPI2.NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
TI.ZPI2.NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
TI.ZPI2.NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
TI.ZPI2.NLME_POLL_CONFIRMATION | This function reports the results of a polling attempt.
TI.ZPI2.NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
TI.ZPI2.NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
TI.ZPI2.NWK_COMM_STATUS_INDICATION | This function reports a comm status error
TI.ZPI2.NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
TI.ZPI2.NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
TI.ZPI2.NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
TI.ZPI2.NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
TI.ZPI2.NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
TI.ZPI2.NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
TI.ZPI2.NWK_START_CONFIRMATION | This function reports the success of the start request.

See Also

ICONFIRMATION Members
TI.ZPI2 Namespace


IDEBUG Interface

IDEBUG Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDEBUG
C#
public interface IDEBUG
C++
interface class IDEBUG
J#
public interface IDEBUG
JScript
public interface IDEBUG

Types that implement IDEBUG

Type | Description
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
TI.ZPI2.DEBUG_STRING | Debug message sent by device

See Also

IDEBUG Members
TI.ZPI2 Namespace


IINDICATION Interface

IINDICATION Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IINDICATION
C#
public interface IINDICATION
C++
interface class IINDICATION
J#
public interface IINDICATION
JScript
public interface IINDICATION

Types that implement IINDICATION

Type | Description
TI.ZPI2.AF_INCOMING_MSG | Incoming AF data.
TI.ZPI2.AF_INCOMING_MSG_EXT | Incoming AF data extended.
TI.ZPI2.NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
TI.ZPI2.NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
TI.ZPI2.NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
TI.ZPI2.NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
TI.ZPI2.NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
TI.ZPI2.NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
TI.ZPI2.NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
TI.ZPI2.NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
TI.ZPI2.NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon
TI.ZPI2.SYS_OSAL_TIMER_EXPIRED_IND | OSAL timer expired
TI.ZPI2.SYS_RESET_RESPONSE | Indicates a device has reset.
TI.ZPI2.ZLL_TOUCH_LINK_INDICATION | ZLL Touch Link Indication

See Also

IINDICATION Members
TI.ZPI2 Namespace


INETWORK Interface

INETWORK Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface INETWORK
C#
public interface INETWORK
C++
interface class INETWORK
J#
public interface INETWORK
JScript
public interface INETWORK

Types that implement INETWORK

Type | Description
TI.ZPI2.NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
TI.ZPI2.NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
TI.ZPI2.NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
TI.ZPI2.NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
TI.ZPI2.NLDE_NWK_INIT | This function will initialize the nwk with the NWK_TASKID.
TI.ZPI2.NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
TI.ZPI2.NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
TI.ZPI2.NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
TI.ZPI2.NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
TI.ZPI2.NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
TI.ZPI2.NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
TI.ZPI2.NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
TI.ZPI2.NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
TI.ZPI2.NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
TI.ZPI2.NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
TI.ZPI2.NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
TI.ZPI2.NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
TI.ZPI2.NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
TI.ZPI2.NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
TI.ZPI2.NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
TI.ZPI2.NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
TI.ZPI2.NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
TI.ZPI2.NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
TI.ZPI2.NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
TI.ZPI2.NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
TI.ZPI2.NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
TI.ZPI2.NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
TI.ZPI2.NLME_POLL_CONFIRMATION | This function reports the results of a polling attempt.
TI.ZPI2.NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
TI.ZPI2.NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
TI.ZPI2.NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
TI.ZPI2.NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
TI.ZPI2.NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
TI.ZPI2.NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
TI.ZPI2.NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
TI.ZPI2.NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
TI.ZPI2.NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
TI.ZPI2.NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
TI.ZPI2.NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
TI.ZPI2.NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
TI.ZPI2.NWK_COMM_STATUS_INDICATION | This function reports a comm status error
TI.ZPI2.NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
TI.ZPI2.NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
TI.ZPI2.NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
TI.ZPI2.NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
TI.ZPI2.NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
TI.ZPI2.NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
TI.ZPI2.NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
TI.ZPI2.NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
TI.ZPI2.NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
TI.ZPI2.NWK_START_CONFIRMATION | This function reports the success of the start request.
TI.ZPI2.NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon

See Also

INETWORK Members
TI.ZPI2 Namespace


IREQUEST Interface

IREQUEST Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IREQUEST
C#
public interface IREQUEST
C++
interface class IREQUEST
J#
public interface IREQUEST
JScript
public interface IREQUEST

Types that implement IREQUEST

Type | Description
TI.ZPI2.AF_APSF_CONFIG_SET | MT proxy for afAPSF_ConfigSet().
TI.ZPI2.AF_DATA_REQUEST | This command is used by tester to build and send a data request message
TI.ZPI2.AF_DATA_REQUEST_EXT | This command is used by tester to build and send a data request message with PanId field.
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG | This command is used by tester to build and send a data request message via source routing
TI.ZPI2.AF_DATA_RETRIEVE | AF huge incoming message data retrieve command.
TI.ZPI2.AF_DATA_STORE | AF huge data request data store command and data.
TI.ZPI2.AF_INTER_PAN_CTL | Inter-Pan control command and data.
TI.ZPI2.AF_REGISTER | This command enables the tester to register an application's endpoint description
TI.ZPI2.APP_MSG | Use this message to send raw data to an application.
TI.ZPI2.APP_USER_TEST | This command is used by the tester to set the debug threshold level for a particular software component in the target.
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
TI.ZPI2.NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
TI.ZPI2.NLDE_NWK_INIT | This function will initialize the nwk with the NWK_TASKID.
TI.ZPI2.NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
TI.ZPI2.NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
TI.ZPI2.NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
TI.ZPI2.NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
TI.ZPI2.NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
TI.ZPI2.NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
TI.ZPI2.NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
TI.ZPI2.NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
TI.ZPI2.NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
TI.ZPI2.NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
TI.ZPI2.NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
TI.ZPI2.NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
TI.ZPI2.SYS_ADC_READ | Stop timer.
TI.ZPI2.SYS_GET_TIME | Get the device's time. Returns 32-bit UTC time and parsed date/time values.
TI.ZPI2.SYS_GPIO | Control ZNP GPIO.
TI.ZPI2.SYS_OSAL_NV_DELETE | Deletes an item from non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT | Creates a new item in non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_LENGTH | Gets the length of an item in non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_READ | Reads data from an item in non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_WRITE | Writes data to an item in non-volatile memory.
TI.ZPI2.SYS_OSAL_START_TIMER | Start timer.
TI.ZPI2.SYS_OSAL_STOP_TIMER | Stop timer.
TI.ZPI2.SYS_PING | This command is used to check for a device.
TI.ZPI2.SYS_RANDOM | Generate random number.
TI.ZPI2.SYS_RESET | This command is used to reset the target device.
TI.ZPI2.SYS_SET_TIME | Set the device's time. Accepts 32-bit UTC time and date/time parameters. The UTC time is used if it's non-zero.
TI.ZPI2.SYS_SET_TX_POWER | Set the transmit power.
TI.ZPI2.SYS_STACK_TUNE | Stack Tuning.
TI.ZPI2.SYS_VERSION | This command is used to get the device's version string.
TI.ZPI2.USERTEST_REQUEST | This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupExt().
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupNwk().
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET | Use this message to retrieve APS link key data and frame counters.
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET | Use this message to proxy a call to the APSME_LinkKeyNvIdGet() function.
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD | This command is used to send a request key to the Trust Center from an originator device who wants to exchange messages with a partner device.
TI.ZPI2.UTIL_ASSOC_COUNT | Use this message to proxy a call to the AssocCount() function.
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE | Use this message to proxy a call to the AssocFindDevice() function.
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS | Use this message to proxy a call to the AssocGetWithAddress() function.
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
TI.ZPI2.UTIL_DATA_REQ | Use this message to effect a MAC MLME Poll Request.
TI.ZPI2.UTIL_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
TI.ZPI2.UTIL_GET_NV_INFO | Use this message to get the NV information.
TI.ZPI2.UTIL_GET_TIME_ALIVE | Use this message to get board's time alive.
TI.ZPI2.UTIL_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
TI.ZPI2.UTIL_LED_CONTROL | Use this message to control LEDs on the board.
TI.ZPI2.UTIL_SET_CHANNELS | Use this message to set the channels.
TI.ZPI2.UTIL_SET_PANID | Use this message to set PANID.
TI.ZPI2.UTIL_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
TI.ZPI2.UTIL_SET_SECURITY_LEVEL | Use this message to set the security level.
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING | Enabled/disable acknowledging all packets with pending bit set.
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY | Add a short or extended address to source address table
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING | Check if acknowledging all packets with pending bit set is enabled.
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR | Check if a short or extended address is in the source address table
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY | Delete a short or extended address to source address table
TI.ZPI2.UTIL_SRC_MATCH_ENABLE | Enabled AUTOPEND and source address matching.
TI.ZPI2.UTIL_SRNG_GEN | Generate secure random number generator
TI.ZPI2.UTIL_TEST_LOOPBACK | Use this message to receive an echo or loopback of the data bytes sent.
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST | Use this message to proxy a call to the zclGeneral_KeyEstablish_InitiateKeyEstablishment() function.
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN | Use this message to proxy a call to the zclGeneral_KeyEstablishment_ECDSASign() function.
TI.ZPI2.ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
TI.ZPI2.ZB_APP_REGISTER_REQUEST | This command register the device descriptor
TI.ZPI2.ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
TI.ZPI2.ZB_FIND_DEVICE_REQUEST | Search for a device's short address given its IEEE address.
TI.ZPI2.ZB_GET_DEVICE_INFO | Reads current device infromation.
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
TI.ZPI2.ZB_READ_CONFIGURATION | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
TI.ZPI2.ZB_SEND_DATA_REQUEST | Send a data packet to another device (zb_SendDataRequest).
TI.ZPI2.ZB_START_REQUEST | Starts the ZigBee stack (zb_StartRequest).
TI.ZPI2.ZB_SYSTEM_RESET | Reboot the device (zb_SystemReset)
TI.ZPI2.ZB_WRITE_CONFIGURATION | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
TI.ZPI2.ZDO_ACTIVE_EP_REQ | This command is generated to request a list of active endpoint from the destination device.
TI.ZPI2.ZDO_AUTO_FIND_DESTINATION | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
TI.ZPI2.ZDO_BIND_REQ | This command is generated to request a Bind
TI.ZPI2.ZDO_COMPLEX_DESC_REQ | This command is generated to request for the destination device's complex descriptor
TI.ZPI2.ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ | This command is generated to request an End Device Bind with the destination device
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ | The command is used to send an End Device Timeout Request message.
TI.ZPI2.ZDO_GET_LINK_KEY | This function will return the application or trust center link key of a given device.
TI.ZPI2.ZDO_IEEE_ADDR_REQ | This command will request a device's IEEE 64-bit address. You must subscribe to 'ZDO IEEE Address Response' to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI2.ZDO_JOIN_REQ | This command is used to request the device to join itself to a parent device on a network.
TI.ZPI2.ZDO_MATCH_DESC_REQ | This command is generated to request a list of active endpoint from the destination device
TI.ZPI2.ZDO_MGMT_BIND_REQ | This command is generated to request a Management Binding Table Request.
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ | This command is generated to request a Management Direct Join Request
TI.ZPI2.ZDO_MGMT_LEAVE_REQ | This command is generated to request a Management Leave Request
TI.ZPI2.ZDO_MGMT_LQI_REQ | This command is generated to request a Management LQI Request.
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ | This command is generated to request a Management Network Discovery Request
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
TI.ZPI2.ZDO_MGMT_RTG_REQ | This command is generated to request a Management Routing Table Request.
TI.ZPI2.ZDO_MSG_CB_REGISTER | This command is the RPC proxy to ZDO_RegisterForZDOMsg() and registers for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
TI.ZPI2.ZDO_MSG_CB_REMOVE | This command is the RPC proxy to ZDO_RemoveRegisteredCB() and removes registration for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
TI.ZPI2.ZDO_NODE_DESC_REQ | This command is generated to inquire as to the Node Descriptor of the destination device
TI.ZPI2.ZDO_NWK_ADDR_REQ | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ | This command will initiate a network discovery (active scan).
TI.ZPI2.ZDO_POWER_DESC_REQ | This command is generated to inquire as to the Power Descriptor of the destination
TI.ZPI2.ZDO_REMOVE_LINK_KEY | This command removes the application or trust center link key of a given device.
TI.ZPI2.ZDO_SERVER_DISC_REQ | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
TI.ZPI2.ZDO_SET_LINK_KEY | This Command sets the application or trust center link key for a given device.
TI.ZPI2.ZDO_SIMPLE_DESC_REQ | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
TI.ZPI2.ZDO_STARTUP_FROM_APP | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
TI.ZPI2.ZDO_UNBIND_REQ | This command is generated to request an UnBind
TI.ZPI2.ZDO_USER_DESC_REQ | This command is generated to request for the destination device's user descriptor
TI.ZPI2.ZDO_USER_DESC_SET | This command is generated to request a User Descriptor Set Request
TI.ZPI2.ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
TI.ZPI2.ZMAC_ASSOCIATE_RSP | This command is sent by the host to response to the ASSOCIATE_IND
TI.ZPI2.ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST | This command is used to send a request to the device to send an enhanced beacon request.
TI.ZPI2.ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
TI.ZPI2.ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
TI.ZPI2.ZMAC_ORPHAN_RSP | This command is sent by the host to response to the ORPHAN_IND
TI.ZPI2.ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
TI.ZPI2.ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
TI.ZPI2.ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
TI.ZPI2.ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
TI.ZPI2.ZMAC_SECURITY_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC Security PIB attribute.
TI.ZPI2.ZMAC_SECURITY_SET_REQUEST | This command is used to request the device to write a MAC Security PIB value.
TI.ZPI2.ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
TI.ZPI2.ZMAC_SET_RX_GAIN_REQUEST | This command is used to send a request to the device to set Rx gain
TI.ZPI2.ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
TI.ZPI2.ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon

See Also

IREQUEST Members
TI.ZPI2 Namespace


IRESPONSE Interface

IRESPONSE Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRESPONSE
C#
public interface IRESPONSE
C++
interface class IRESPONSE
J#
public interface IRESPONSE
JScript
public interface IRESPONSE

Types that implement IRESPONSE

Type | Description
TI.ZPI2.AF_APSF_CONFIG_SET_SRSP | Response for AF_APSF_CONFIG_SET
TI.ZPI2.AF_DATA_REQUEST_EXT_SRSP | Response for AF_DATA_REQUEST_EXT
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG_SRSP | Response for AF_DATA_REQUEST_SRC_RTG
TI.ZPI2.AF_DATA_REQUEST_SRSP | Response for AF_DATA_REQUEST
TI.ZPI2.AF_DATA_RETRIEVE_SRSP | Response for AF_DATA_RETRIEVE
TI.ZPI2.AF_DATA_STORE_SRSP | Response for AF_DATA_STORE
TI.ZPI2.AF_INTER_PAN_CTL_SRSP | Response for AF_INTER_PAN_SET_PARAM
TI.ZPI2.AF_REGISTER_SRSP | Response for AF_REGISTER
TI.ZPI2.APP_MSG_RESPONSE | Status for APP_MSG
TI.ZPI2.APP_MSG_RSP | Response for APP_MSG
TI.ZPI2.APP_USER_TEST_RESPONSE | Response for APP_USER_TEST
TI.ZPI2.APSME_BIND_RESPONSE | Response for APSME_BIND
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
TI.ZPI2.DEBUG_STRING | Debug message sent by device
TI.ZPI2.MT_UTIL_SYNC_REQ | This is an asynchronous request/response handshake.
TI.ZPI2.MT_UTIL_ZCL_KEY_ESTABLISH_IND | This is the RPC proxy indication for a ZCL_KEY_ESTABLISH_IND.
TI.ZPI2.MT_ZDO_MSG_CB_INCOMING | This message is the RPC proxy for receiving a SYS_EVENT_MSG with the ZDO_CB_MSG event. It results after registering for a callback on a Cluster Id with ZDO_MSG_CB_REGISTER. The parameter list is a packed zdoIncomingMsg_t structure less the asduLen since it can be deduced from the RPC length.
TI.ZPI2.NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
TI.ZPI2.NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
TI.ZPI2.NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
TI.ZPI2.NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
TI.ZPI2.NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
TI.ZPI2.NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
TI.ZPI2.NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
TI.ZPI2.NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
TI.ZPI2.NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
TI.ZPI2.NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
TI.ZPI2.NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
TI.ZPI2.NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
TI.ZPI2.NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
TI.ZPI2.SYS_ADC_READ_SRSP | Response for SYS_ADC_READ
TI.ZPI2.SYS_GET_TIME_SRSP | Response for SYS_GET_TIME
TI.ZPI2.SYS_GPIO_SRSP | Response for SYS_GPIO
TI.ZPI2.SYS_OSAL_NV_DELETE_SRSP | Response for SYS_OSAL_NV_DELETE
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT_SRSP | Response for SYS_OSAL_NV_ITEM_INIT
TI.ZPI2.SYS_OSAL_NV_LENGTH_SRSP | Response for SYS_OSAL_NV_LENGTH
TI.ZPI2.SYS_OSAL_NV_READ_SRSP | Response for SYS_OSAL_NV_READ
TI.ZPI2.SYS_OSAL_NV_WRITE_SRSP | Response for SYS_OSAL_NV_WRITE
TI.ZPI2.SYS_OSAL_START_TIMER_SRSP | Response for SYS_OSAL_START_TIMER
TI.ZPI2.SYS_OSAL_STOP_TIMER_SRSP | Response for SYS_OSAL_STOP_TIMER
TI.ZPI2.SYS_PING_RESPONSE | Response for SYS_PING
TI.ZPI2.SYS_RANDOM_SRSP | Response for SYS_RANDOM
TI.ZPI2.SYS_RPC_ERROR | RPC transport layer error.
TI.ZPI2.SYS_SET_TIME_SRSP | Response for SYS_SET_TIME
TI.ZPI2.SYS_SET_TX_POWER_SRSP | Response for SYS_SET_TX_POWER
TI.ZPI2.SYS_STACK_TUNE_SRSP | Response for SYS_STACK_TUNE
TI.ZPI2.SYS_VERSION_RESPONSE | Response for SYS_VERSION
TI.ZPI2.USERTEST_RESPONSE | Response for USERTEST_REQUEST
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupExt().
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupNwk().
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE | Response for UTIL_APSME_LINK_KEY_DATA_GET.
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE | This is the RPC proxy response from APSME_LinkKeyNvIdGet().
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD_SRSP | Response for UTIL_APSME_REQUEST_KEY_CMD
TI.ZPI2.UTIL_ASSOC_COUNT_RESPONSE | This is the RPC proxy response from AssocCount().
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE_RESPONSE | This is the RPC proxy response from AssocFindDevice().
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE | This is the RPC proxy response from AssocGetWithAddress().
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE_RESPONSE | Response for UTIL_CALLBACK_SUBSCRIBE
TI.ZPI2.UTIL_DATA_REQ_RESPONSE | Response for UTIL_DATA_REQ
TI.ZPI2.UTIL_GET_DEVICE_INFO_RESPONSE | Response for UTIL_GET_DEVICE_INFO
TI.ZPI2.UTIL_GET_NV_INFO_RESPONSE | Response for UTIL_GET_NV_INFO
TI.ZPI2.UTIL_GET_TIME_ALIVE_RESPONSE | Response for UTIL_GET_TIME_ALIVE
TI.ZPI2.UTIL_KEY_EVENT_RESPONSE | Response for UTIL_KEY_EVENT
TI.ZPI2.UTIL_LED_CONTROL_RESPONSE | Response for UTIL_LED_CONTROL
TI.ZPI2.UTIL_LOOPBACK_RESPONSE | Data buffer loopback response.
TI.ZPI2.UTIL_SET_CHANNELS_RESPONSE | Response for UTIL_SET_CHANNELS
TI.ZPI2.UTIL_SET_PANID_RESPONSE | Response for UTIL_SET_PANID
TI.ZPI2.UTIL_SET_PRECONFIG_KEY_RESPONSE | Response for UTIL_SET_PRECONFIG_KEY
TI.ZPI2.UTIL_SET_SECURITY_LEVEL_RESPONSE | Response for UTIL_SET_SECURITY_LEVEL
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_ACK_ALL_PENDING
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_ADD_ENTRY
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_ALL_PENDING
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_SRC_ADDR
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_DELETE_ENTRY
TI.ZPI2.UTIL_SRC_MATCH_ENABLE_RESPONSE | Response for UTIL_SRC_MATCH_ENABLE
TI.ZPI2.UTIL_SRNG_GEN_RESPONSE | Response for Generate secure random number generator
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablish_InitiateKeyEstablishment().
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablishment_ECDSASign().
TI.ZPI2.ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
TI.ZPI2.ZB_APP_REGISTER_RSP | Response for ZB_APP_REGISTER_REQUEST
TI.ZPI2.ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
TI.ZPI2.ZB_FIND_DEVICE_REQUEST_RSP | Response for ZB_FIND_DEVICE_REQUEST
TI.ZPI2.ZB_GET_DEVICE_INFO_RSP | Response for ZB_GET_DEVICE_INFO
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST_RSP | Response for ZB_PERMIT_JOINING_REQUEST
TI.ZPI2.ZB_READ_CONFIGURATION_RSP |
TI.ZPI2.ZB_SEND_DATA_REQUEST_RSP | Response for ZB_SEND_DATA_REQUEST
TI.ZPI2.ZB_START_REQUEST_RSP | Response for ZB_START_REQUEST
TI.ZPI2.ZB_WRITE_CONFIGURATION_RSP | Response for ZB_WRITE_CONFIGURATION
TI.ZPI2.ZDO_ACTIVE_EP_REQ_SRSP | Response for ZDO_ACTIVE_EP_REQ
TI.ZPI2.ZDO_BEACON_NOTIFY_IND | This message is an indication to inform host device the receipt of a beacon notification
TI.ZPI2.ZDO_BIND_REQ_SRSP | Response for ZDO_BIND_REQ
TI.ZPI2.ZDO_COMPLEX_DESC_REQ_SRSP | Response for ZDO_COMPLEX_DESC_REQ
TI.ZPI2.ZDO_END_DEVICE_ANNCE_SRSP | Response for ZDO_END_DEVICE_ANNCE
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ_SRSP | Response for ZDO_END_DEVICE_BIND_REQ
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ_SRSP | Response for ZDO_END_DEVICE_TIMEOUT_REQ
TI.ZPI2.ZDO_GET_LINK_KEY_SRSP | Response for ZDO_GET_LINK_KEY
TI.ZPI2.ZDO_IEEE_ADDR_REQ_SRSP | Response for ZDO_IEEE_ADDR_REQ
TI.ZPI2.ZDO_JOIN_CNF | This message is an indication to the host device the result of a ZDO join request .
TI.ZPI2.ZDO_JOIN_REQ_SRSP | Response for ZDO_JOIN_REQ
TI.ZPI2.ZDO_LEAVE_IND | ZDO leave indication.
TI.ZPI2.ZDO_MATCH_DESC_REQ_SRSP | Response for ZDO_MATCH_DESC_REQ
TI.ZPI2.ZDO_MGMT_BIND_REQ_SRSP | Response for ZDO_MGMT_BIND_REQ
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ_SRSP | Response for ZDO_MGMT_DIRECT_JOIN_REQ
TI.ZPI2.ZDO_MGMT_LEAVE_REQ_SRSP | Response for ZDO_MGMT_LEAVE_REQ
TI.ZPI2.ZDO_MGMT_LQI_REQ_SRSP | Response for ZDO_MGMT_LQI_REQ
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ_SRSP | Response for ZDO_MGMT_NWK_DISC_REQ
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQ_SRSP | Response for ZDO_MGMT_PERMIT_JOIN_REQ
TI.ZPI2.ZDO_MGMT_RTG_REQ_SRSP | Response for ZDO_MGMT_RTG_REQ
TI.ZPI2.ZDO_MSG_CB_REGISTER_RESPONSE | Response for ZDO_MSG_CB_REGISTER
TI.ZPI2.ZDO_MSG_CB_REMOVE_RESPONSE | Response for ZDO_MSG_CB_REMOVE
TI.ZPI2.ZDO_NODE_DESC_REQ_SRSP | Response for ZDO_NODE_DESC_REQ
TI.ZPI2.ZDO_NWK_ADDR_REQ_SRSP | Response for ZDO_NWK_ADDR_REQ
TI.ZPI2.ZDO_NWK_DISCOVERY_CNF | This message sends an indication to inform host device the completion of network discovery scan.
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ_SRSP | Response for ZDO_NWK_DISCOVERY_REQ
TI.ZPI2.ZDO_POWER_DESC_REQ_SRSP | Response for ZDO_POWER_DESC_REQ
TI.ZPI2.ZDO_REMOVE_LINK_KEY_SRSP | Response for ZDO_REMOVE_LINK_KEY
TI.ZPI2.ZDO_SERVER_DISC_REQ_SRSP | Response for ZDO_SERVER_DISC_REQ
TI.ZPI2.ZDO_SET_LINK_KEY_SRSP | Response for ZDO_SET_LINK_KEY
TI.ZPI2.ZDO_SIMPLE_DESC_REQ_SRSP | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
TI.ZPI2.ZDO_SRC_RTG_IND | This message is an indication to inform host device the receipt of a source route to a given device.
TI.ZPI2.ZDO_STARTUP_FROM_APP_SRSP | Response for ZDO_STARTUP_FROM_APP
TI.ZPI2.ZDO_STATUS_ERROR_RSP | This message is the default message for error status.
TI.ZPI2.ZDO_UNBIND_REQ_SRSP | Response for ZDO_UNBIND_REQ
TI.ZPI2.ZDO_USER_DESC_REQ_SRSP | Response for ZDO_USER_DESC_REQ
TI.ZPI2.ZDO_USER_DESC_SET_SRSP | Response for ZDO_USER_DESC_SET
TI.ZPI2.ZMAC_ASSOCIATE_CNF | This sends a associat confirm command
TI.ZPI2.ZMAC_ASSOCIATE_IND | This command is used to send (on behalf of the next higher layer) an association indication message
TI.ZPI2.ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
TI.ZPI2.ZMAC_ASSOCIATE_RSP_RESPONSE | Response for ZMAC_ASSOCIATE_RSP
TI.ZPI2.ZMAC_BEACON_NOTIFY_IND | Beacon Notify Indication
TI.ZPI2.ZMAC_COMM_STATUS_IND | Communcation status indication
TI.ZPI2.ZMAC_DATA_CNF | Data Request Confirmation
TI.ZPI2.ZMAC_DATA_IND | Data Indication
TI.ZPI2.ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
TI.ZPI2.ZMAC_DISASSOCIATE_CNF | Disassociate Indication
TI.ZPI2.ZMAC_DISASSOCIATE_IND | Disassociate Indication
TI.ZPI2.ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE | Response for ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST
TI.ZPI2.ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
TI.ZPI2.ZMAC_INIT_RESPONSE | Response for ZMAC_INIT_REQUEST
TI.ZPI2.ZMAC_ORPHAN_IND | Orphan Indication
TI.ZPI2.ZMAC_ORPHAN_RSP_RESPONSE | Response for ZMAC_ORPHAN_RSP
TI.ZPI2.ZMAC_POLL_CNF | Mac Poll Confirmation
TI.ZPI2.ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
TI.ZPI2.ZMAC_PURGE_CNF | Mac RX enable Confirmation
TI.ZPI2.ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
TI.ZPI2.ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
TI.ZPI2.ZMAC_RX_ENABLE_CNF | Mac RX enable Confirmation
TI.ZPI2.ZMAC_SCAN_CNF | Scan Confirmation
TI.ZPI2.ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
TI.ZPI2.ZMAC_SECURITY_GET_RESPONSE | Response for ZMAC_SECURITY_GET_REQUEST
TI.ZPI2.ZMAC_SECURITY_SET_RESPONSE | Response for ZMAC_SECURITY_SET_REQUEST
TI.ZPI2.ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
TI.ZPI2.ZMAC_SET_RX_GAIN_RESPONSE | Response for ZMAC_SET_RX_GAIN_REQUEST
TI.ZPI2.ZMAC_START_CNF | Mac Start Confirmation
TI.ZPI2.ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
TI.ZPI2.ZMAC_SYNC_LOSS_IND | Indication for sync loss
TI.ZPI2.ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST

See Also

IRESPONSE Members
TI.ZPI2 Namespace


IRESPONSE_CALLBACK Interface

IRESPONSE_CALLBACK Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRESPONSE_CALLBACK
C#
public interface IRESPONSE_CALLBACK
C++
interface class IRESPONSE_CALLBACK
J#
public interface IRESPONSE_CALLBACK
JScript
public interface IRESPONSE_CALLBACK

Types that implement IRESPONSE_CALLBACK

Type | Description
TI.ZPI2.ZB_ALLOW_BIND_CONFIRM | Response for ZB_ALLOW_BIND
TI.ZPI2.ZB_BIND_CONFIRM | Response for ZB_BIND_DEVICE
TI.ZPI2.ZB_FIND_DEVICE_CONFIRM | (zb_FindDeviceConfirm)
TI.ZPI2.ZB_RECEIVE_DATA_INDICATION | (zb_ReceiveDataIndication)
TI.ZPI2.ZB_SEND_DATA_CONFIRM | Response for ZB_SEND_DATA_REQUEST
TI.ZPI2.ZB_START_CONFIRM | Response for ZB_START_REQUEST
TI.ZPI2.ZDO_ACTIVE_EP_RSP | This callback message is in response to the ZDO Active Endpoint Request.
TI.ZPI2.ZDO_BIND_RSP | This callback message is in response to the ZDO Bind Request
TI.ZPI2.ZDO_COMPLEX_DESC_RSP | Response for ZDO_COMPLEX_DESC_REQ
TI.ZPI2.ZDO_END_DEVICE_ANNCE_IND | ZDO end device announce indication.
TI.ZPI2.ZDO_END_DEVICE_BIND_RSP | This callback message is in response to the ZDO End Device Bind Request
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_RSP | This callback message is in response to the End Device Timeout Request.
TI.ZPI2.ZDO_IEEE_ADDR_RSP | This callback message is in response to the ZDO IEEE Address Request.
TI.ZPI2.ZDO_MATCH_DESC_RSP | This callback message is in response to the ZDO Match Description Request
TI.ZPI2.ZDO_MATCH_DESC_RSP_SENT | This callback indicates that Match Descriptor Response has been sent.
TI.ZPI2.ZDO_MGMT_BIND_RSP | This callback message is in response to the ZDO Management Binding Table Request
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_RSP | This callback message is in response to the ZDO Management Direct Join Request.
TI.ZPI2.ZDO_MGMT_LEAVE_RSP | This callback message is in response to the ZDO Management Leave Request.
TI.ZPI2.ZDO_MGMT_LQI_RSP | This callback message is in response to the ZDO Management LQI Request.
TI.ZPI2.ZDO_MGMT_NWK_DISC_RSP | This callback message is in response to the ZDO Management Network Discovery Request
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_RSP | This callback message is in response to the ZDO Management Permit Join Request
TI.ZPI2.ZDO_MGMT_RTG_RSP | This callback message is in response to the ZDO Management Routing Table Request.
TI.ZPI2.ZDO_NODE_DESC_RSP | This callback message is in response to the ZDO Node Descriptor Request.
TI.ZPI2.ZDO_NWK_ADDR_RSP | This callback message is in response to the ZDO Network Address Request.
TI.ZPI2.ZDO_POWER_DESC_RSP | This callback message is in response to the ZDO Power Descriptor Request.
TI.ZPI2.ZDO_SERVER_DISC_RSP | This callback message is
TI.ZPI2.ZDO_SIMPLE_DESC_RSP | This callback message is in response to the ZDO Simple Descriptor Request.
TI.ZPI2.ZDO_STATE_CHANGE_IND | ZDO state change indication.
TI.ZPI2.ZDO_UNBIND_RSP | This callback message is in response to the ZDO UnBind Request
TI.ZPI2.ZDO_USER_DESC_CONF | This callback message is in response to the ZDO User Descriptor Set Request.
TI.ZPI2.ZDO_USER_DESC_RSP | This callback message is in response to the ZDO User Description Request.

See Also

IRESPONSE_CALLBACK Members
TI.ZPI2 Namespace


ISIMPLEAPI Interface

ISIMPLEAPI Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISIMPLEAPI
C#
public interface ISIMPLEAPI
C++
interface class ISIMPLEAPI
J#
public interface ISIMPLEAPI
JScript
public interface ISIMPLEAPI

Types that implement ISIMPLEAPI

Type | Description
TI.ZPI2.ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
TI.ZPI2.ZB_ALLOW_BIND_CONFIRM | Response for ZB_ALLOW_BIND
TI.ZPI2.ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
TI.ZPI2.ZB_APP_REGISTER_REQUEST | This command register the device descriptor
TI.ZPI2.ZB_APP_REGISTER_RSP | Response for ZB_APP_REGISTER_REQUEST
TI.ZPI2.ZB_BIND_CONFIRM | Response for ZB_BIND_DEVICE
TI.ZPI2.ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
TI.ZPI2.ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
TI.ZPI2.ZB_FIND_DEVICE_CONFIRM | (zb_FindDeviceConfirm)
TI.ZPI2.ZB_FIND_DEVICE_REQUEST | Search for a device's short address given its IEEE address.
TI.ZPI2.ZB_FIND_DEVICE_REQUEST_RSP | Response for ZB_FIND_DEVICE_REQUEST
TI.ZPI2.ZB_GET_DEVICE_INFO | Reads current device infromation.
TI.ZPI2.ZB_GET_DEVICE_INFO_RSP | Response for ZB_GET_DEVICE_INFO
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST_RSP | Response for ZB_PERMIT_JOINING_REQUEST
TI.ZPI2.ZB_READ_CONFIGURATION | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
TI.ZPI2.ZB_READ_CONFIGURATION_RSP |
TI.ZPI2.ZB_RECEIVE_DATA_INDICATION | (zb_ReceiveDataIndication)
TI.ZPI2.ZB_SEND_DATA_CONFIRM | Response for ZB_SEND_DATA_REQUEST
TI.ZPI2.ZB_SEND_DATA_REQUEST | Send a data packet to another device (zb_SendDataRequest).
TI.ZPI2.ZB_SEND_DATA_REQUEST_RSP | Response for ZB_SEND_DATA_REQUEST
TI.ZPI2.ZB_START_CONFIRM | Response for ZB_START_REQUEST
TI.ZPI2.ZB_START_REQUEST | Starts the ZigBee stack (zb_StartRequest).
TI.ZPI2.ZB_START_REQUEST_RSP | Response for ZB_START_REQUEST
TI.ZPI2.ZB_SYSTEM_RESET | Reboot the device (zb_SystemReset)
TI.ZPI2.ZB_WRITE_CONFIGURATION | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
TI.ZPI2.ZB_WRITE_CONFIGURATION_RSP | Response for ZB_WRITE_CONFIGURATION

See Also

ISIMPLEAPI Members
TI.ZPI2 Namespace


ISYSTEM Interface

ISYSTEM Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISYSTEM
C#
public interface ISYSTEM
C++
interface class ISYSTEM
J#
public interface ISYSTEM
JScript
public interface ISYSTEM

Types that implement ISYSTEM

Type | Description
TI.ZPI2.SYS_ADC_READ | Stop timer.
TI.ZPI2.SYS_ADC_READ_SRSP | Response for SYS_ADC_READ
TI.ZPI2.SYS_GET_TIME | Get the device's time. Returns 32-bit UTC time and parsed date/time values.
TI.ZPI2.SYS_GET_TIME_SRSP | Response for SYS_GET_TIME
TI.ZPI2.SYS_GPIO | Control ZNP GPIO.
TI.ZPI2.SYS_GPIO_SRSP | Response for SYS_GPIO
TI.ZPI2.SYS_OSAL_NV_DELETE | Deletes an item from non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_DELETE_SRSP | Response for SYS_OSAL_NV_DELETE
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT | Creates a new item in non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT_SRSP | Response for SYS_OSAL_NV_ITEM_INIT
TI.ZPI2.SYS_OSAL_NV_LENGTH | Gets the length of an item in non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_LENGTH_SRSP | Response for SYS_OSAL_NV_LENGTH
TI.ZPI2.SYS_OSAL_NV_READ | Reads data from an item in non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_READ_SRSP | Response for SYS_OSAL_NV_READ
TI.ZPI2.SYS_OSAL_NV_WRITE | Writes data to an item in non-volatile memory.
TI.ZPI2.SYS_OSAL_NV_WRITE_SRSP | Response for SYS_OSAL_NV_WRITE
TI.ZPI2.SYS_OSAL_START_TIMER | Start timer.
TI.ZPI2.SYS_OSAL_START_TIMER_SRSP | Response for SYS_OSAL_START_TIMER
TI.ZPI2.SYS_OSAL_STOP_TIMER | Stop timer.
TI.ZPI2.SYS_OSAL_STOP_TIMER_SRSP | Response for SYS_OSAL_STOP_TIMER
TI.ZPI2.SYS_OSAL_TIMER_EXPIRED_IND | OSAL timer expired
TI.ZPI2.SYS_PING | This command is used to check for a device.
TI.ZPI2.SYS_PING_RESPONSE | Response for SYS_PING
TI.ZPI2.SYS_RANDOM | Generate random number.
TI.ZPI2.SYS_RANDOM_SRSP | Response for SYS_RANDOM
TI.ZPI2.SYS_RESET | This command is used to reset the target device.
TI.ZPI2.SYS_RESET_RESPONSE | Indicates a device has reset.
TI.ZPI2.SYS_RPC_ERROR | RPC transport layer error.
TI.ZPI2.SYS_SET_TIME | Set the device's time. Accepts 32-bit UTC time and date/time parameters. The UTC time is used if it's non-zero.
TI.ZPI2.SYS_SET_TIME_SRSP | Response for SYS_SET_TIME
TI.ZPI2.SYS_SET_TX_POWER | Set the transmit power.
TI.ZPI2.SYS_SET_TX_POWER_SRSP | Response for SYS_SET_TX_POWER
TI.ZPI2.SYS_STACK_TUNE | Stack Tuning.
TI.ZPI2.SYS_STACK_TUNE_SRSP | Response for SYS_STACK_TUNE
TI.ZPI2.SYS_VERSION | This command is used to get the device's version string.
TI.ZPI2.SYS_VERSION_RESPONSE | Response for SYS_VERSION

See Also

ISYSTEM Members
TI.ZPI2 Namespace


IUTIL Interface

IUTIL Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IUTIL
C#
public interface IUTIL
C++
interface class IUTIL
J#
public interface IUTIL
JScript
public interface IUTIL

Types that implement IUTIL

Type | Description
TI.ZPI2.MT_UTIL_SYNC_REQ | This is an asynchronous request/response handshake.
TI.ZPI2.MT_UTIL_ZCL_KEY_ESTABLISH_IND | This is the RPC proxy indication for a ZCL_KEY_ESTABLISH_IND.
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupExt().
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupExt().
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupNwk().
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupNwk().
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET | Use this message to retrieve APS link key data and frame counters.
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE | Response for UTIL_APSME_LINK_KEY_DATA_GET.
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET | Use this message to proxy a call to the APSME_LinkKeyNvIdGet() function.
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE | This is the RPC proxy response from APSME_LinkKeyNvIdGet().
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD | This command is used to send a request key to the Trust Center from an originator device who wants to exchange messages with a partner device.
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD_SRSP | Response for UTIL_APSME_REQUEST_KEY_CMD
TI.ZPI2.UTIL_ASSOC_COUNT | Use this message to proxy a call to the AssocCount() function.
TI.ZPI2.UTIL_ASSOC_COUNT_RESPONSE | This is the RPC proxy response from AssocCount().
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE | Use this message to proxy a call to the AssocFindDevice() function.
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE_RESPONSE | This is the RPC proxy response from AssocFindDevice().
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS | Use this message to proxy a call to the AssocGetWithAddress() function.
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE | This is the RPC proxy response from AssocGetWithAddress().
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE_RESPONSE | Response for UTIL_CALLBACK_SUBSCRIBE
TI.ZPI2.UTIL_DATA_REQ | Use this message to effect a MAC MLME Poll Request.
TI.ZPI2.UTIL_DATA_REQ_RESPONSE | Response for UTIL_DATA_REQ
TI.ZPI2.UTIL_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
TI.ZPI2.UTIL_GET_DEVICE_INFO_RESPONSE | Response for UTIL_GET_DEVICE_INFO
TI.ZPI2.UTIL_GET_NV_INFO | Use this message to get the NV information.
TI.ZPI2.UTIL_GET_NV_INFO_RESPONSE | Response for UTIL_GET_NV_INFO
TI.ZPI2.UTIL_GET_TIME_ALIVE | Use this message to get board's time alive.
TI.ZPI2.UTIL_GET_TIME_ALIVE_RESPONSE | Response for UTIL_GET_TIME_ALIVE
TI.ZPI2.UTIL_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
TI.ZPI2.UTIL_KEY_EVENT_RESPONSE | Response for UTIL_KEY_EVENT
TI.ZPI2.UTIL_LED_CONTROL | Use this message to control LEDs on the board.
TI.ZPI2.UTIL_LED_CONTROL_RESPONSE | Response for UTIL_LED_CONTROL
TI.ZPI2.UTIL_LOOPBACK_RESPONSE | Data buffer loopback response.
TI.ZPI2.UTIL_SET_CHANNELS | Use this message to set the channels.
TI.ZPI2.UTIL_SET_CHANNELS_RESPONSE | Response for UTIL_SET_CHANNELS
TI.ZPI2.UTIL_SET_PANID | Use this message to set PANID.
TI.ZPI2.UTIL_SET_PANID_RESPONSE | Response for UTIL_SET_PANID
TI.ZPI2.UTIL_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
TI.ZPI2.UTIL_SET_PRECONFIG_KEY_RESPONSE | Response for UTIL_SET_PRECONFIG_KEY
TI.ZPI2.UTIL_SET_SECURITY_LEVEL | Use this message to set the security level.
TI.ZPI2.UTIL_SET_SECURITY_LEVEL_RESPONSE | Response for UTIL_SET_SECURITY_LEVEL
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING | Enabled/disable acknowledging all packets with pending bit set.
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_ACK_ALL_PENDING
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY | Add a short or extended address to source address table
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_ADD_ENTRY
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING | Check if acknowledging all packets with pending bit set is enabled.
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_ALL_PENDING
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR | Check if a short or extended address is in the source address table
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_SRC_ADDR
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY | Delete a short or extended address to source address table
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_DELETE_ENTRY
TI.ZPI2.UTIL_SRC_MATCH_ENABLE | Enabled AUTOPEND and source address matching.
TI.ZPI2.UTIL_SRC_MATCH_ENABLE_RESPONSE | Response for UTIL_SRC_MATCH_ENABLE
TI.ZPI2.UTIL_SRNG_GEN | Generate secure random number generator
TI.ZPI2.UTIL_SRNG_GEN_RESPONSE | Response for Generate secure random number generator
TI.ZPI2.UTIL_TEST_LOOPBACK | Use this message to receive an echo or loopback of the data bytes sent.
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST | Use this message to proxy a call to the zclGeneral_KeyEstablish_InitiateKeyEstablishment() function.
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablish_InitiateKeyEstablishment().
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN | Use this message to proxy a call to the zclGeneral_KeyEstablishment_ECDSASign() function.
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablishment_ECDSASign().

See Also

IUTIL Members
TI.ZPI2 Namespace


IZDO Interface

IZDO Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IZDO
C#
public interface IZDO
C++
interface class IZDO
J#
public interface IZDO
JScript
public interface IZDO

Types that implement IZDO

Type | Description
TI.ZPI2.MT_ZDO_MSG_CB_INCOMING | This message is the RPC proxy for receiving a SYS_EVENT_MSG with the ZDO_CB_MSG event. It results after registering for a callback on a Cluster Id with ZDO_MSG_CB_REGISTER. The parameter list is a packed zdoIncomingMsg_t structure less the asduLen since it can be deduced from the RPC length.
TI.ZPI2.ZDO_ACTIVE_EP_REQ | This command is generated to request a list of active endpoint from the destination device.
TI.ZPI2.ZDO_ACTIVE_EP_REQ_SRSP | Response for ZDO_ACTIVE_EP_REQ
TI.ZPI2.ZDO_ACTIVE_EP_RSP | This callback message is in response to the ZDO Active Endpoint Request.
TI.ZPI2.ZDO_AUTO_FIND_DESTINATION | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
TI.ZPI2.ZDO_BEACON_NOTIFY_IND | This message is an indication to inform host device the receipt of a beacon notification
TI.ZPI2.ZDO_BIND_REQ | This command is generated to request a Bind
TI.ZPI2.ZDO_BIND_REQ_SRSP | Response for ZDO_BIND_REQ
TI.ZPI2.ZDO_BIND_RSP | This callback message is in response to the ZDO Bind Request
TI.ZPI2.ZDO_COMPLEX_DESC_REQ | This command is generated to request for the destination device's complex descriptor
TI.ZPI2.ZDO_COMPLEX_DESC_REQ_SRSP | Response for ZDO_COMPLEX_DESC_REQ
TI.ZPI2.ZDO_COMPLEX_DESC_RSP | Response for ZDO_COMPLEX_DESC_REQ
TI.ZPI2.ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
TI.ZPI2.ZDO_END_DEVICE_ANNCE_IND | ZDO end device announce indication.
TI.ZPI2.ZDO_END_DEVICE_ANNCE_SRSP | Response for ZDO_END_DEVICE_ANNCE
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ | This command is generated to request an End Device Bind with the destination device
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ_SRSP | Response for ZDO_END_DEVICE_BIND_REQ
TI.ZPI2.ZDO_END_DEVICE_BIND_RSP | This callback message is in response to the ZDO End Device Bind Request
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ | The command is used to send an End Device Timeout Request message.
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ_SRSP | Response for ZDO_END_DEVICE_TIMEOUT_REQ
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_RSP | This callback message is in response to the End Device Timeout Request.
TI.ZPI2.ZDO_GET_LINK_KEY | This function will return the application or trust center link key of a given device.
TI.ZPI2.ZDO_GET_LINK_KEY_SRSP | Response for ZDO_GET_LINK_KEY
TI.ZPI2.ZDO_IEEE_ADDR_REQ | This command will request a device's IEEE 64-bit address. You must subscribe to 'ZDO IEEE Address Response' to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI2.ZDO_IEEE_ADDR_REQ_SRSP | Response for ZDO_IEEE_ADDR_REQ
TI.ZPI2.ZDO_IEEE_ADDR_RSP | This callback message is in response to the ZDO IEEE Address Request.
TI.ZPI2.ZDO_JOIN_CNF | This message is an indication to the host device the result of a ZDO join request .
TI.ZPI2.ZDO_JOIN_REQ | This command is used to request the device to join itself to a parent device on a network.
TI.ZPI2.ZDO_JOIN_REQ_SRSP | Response for ZDO_JOIN_REQ
TI.ZPI2.ZDO_LEAVE_IND | ZDO leave indication.
TI.ZPI2.ZDO_MATCH_DESC_REQ | This command is generated to request a list of active endpoint from the destination device
TI.ZPI2.ZDO_MATCH_DESC_REQ_SRSP | Response for ZDO_MATCH_DESC_REQ
TI.ZPI2.ZDO_MATCH_DESC_RSP | This callback message is in response to the ZDO Match Description Request
TI.ZPI2.ZDO_MATCH_DESC_RSP_SENT | This callback indicates that Match Descriptor Response has been sent.
TI.ZPI2.ZDO_MGMT_BIND_REQ | This command is generated to request a Management Binding Table Request.
TI.ZPI2.ZDO_MGMT_BIND_REQ_SRSP | Response for ZDO_MGMT_BIND_REQ
TI.ZPI2.ZDO_MGMT_BIND_RSP | This callback message is in response to the ZDO Management Binding Table Request
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ | This command is generated to request a Management Direct Join Request
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ_SRSP | Response for ZDO_MGMT_DIRECT_JOIN_REQ
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_RSP | This callback message is in response to the ZDO Management Direct Join Request.
TI.ZPI2.ZDO_MGMT_LEAVE_REQ | This command is generated to request a Management Leave Request
TI.ZPI2.ZDO_MGMT_LEAVE_REQ_SRSP | Response for ZDO_MGMT_LEAVE_REQ
TI.ZPI2.ZDO_MGMT_LEAVE_RSP | This callback message is in response to the ZDO Management Leave Request.
TI.ZPI2.ZDO_MGMT_LQI_REQ | This command is generated to request a Management LQI Request.
TI.ZPI2.ZDO_MGMT_LQI_REQ_SRSP | Response for ZDO_MGMT_LQI_REQ
TI.ZPI2.ZDO_MGMT_LQI_RSP | This callback message is in response to the ZDO Management LQI Request.
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ | This command is generated to request a Management Network Discovery Request
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ_SRSP | Response for ZDO_MGMT_NWK_DISC_REQ
TI.ZPI2.ZDO_MGMT_NWK_DISC_RSP | This callback message is in response to the ZDO Management Network Discovery Request
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQ_SRSP | Response for ZDO_MGMT_PERMIT_JOIN_REQ
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_RSP | This callback message is in response to the ZDO Management Permit Join Request
TI.ZPI2.ZDO_MGMT_RTG_REQ | This command is generated to request a Management Routing Table Request.
TI.ZPI2.ZDO_MGMT_RTG_REQ_SRSP | Response for ZDO_MGMT_RTG_REQ
TI.ZPI2.ZDO_MGMT_RTG_RSP | This callback message is in response to the ZDO Management Routing Table Request.
TI.ZPI2.ZDO_MSG_CB_REGISTER | This command is the RPC proxy to ZDO_RegisterForZDOMsg() and registers for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
TI.ZPI2.ZDO_MSG_CB_REGISTER_RESPONSE | Response for ZDO_MSG_CB_REGISTER
TI.ZPI2.ZDO_MSG_CB_REMOVE | This command is the RPC proxy to ZDO_RemoveRegisteredCB() and removes registration for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
TI.ZPI2.ZDO_MSG_CB_REMOVE_RESPONSE | Response for ZDO_MSG_CB_REMOVE
TI.ZPI2.ZDO_NODE_DESC_REQ | This command is generated to inquire as to the Node Descriptor of the destination device
TI.ZPI2.ZDO_NODE_DESC_REQ_SRSP | Response for ZDO_NODE_DESC_REQ
TI.ZPI2.ZDO_NODE_DESC_RSP | This callback message is in response to the ZDO Node Descriptor Request.
TI.ZPI2.ZDO_NWK_ADDR_REQ | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
TI.ZPI2.ZDO_NWK_ADDR_REQ_SRSP | Response for ZDO_NWK_ADDR_REQ
TI.ZPI2.ZDO_NWK_ADDR_RSP | This callback message is in response to the ZDO Network Address Request.
TI.ZPI2.ZDO_NWK_DISCOVERY_CNF | This message sends an indication to inform host device the completion of network discovery scan.
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ | This command will initiate a network discovery (active scan).
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ_SRSP | Response for ZDO_NWK_DISCOVERY_REQ
TI.ZPI2.ZDO_POWER_DESC_REQ | This command is generated to inquire as to the Power Descriptor of the destination
TI.ZPI2.ZDO_POWER_DESC_REQ_SRSP | Response for ZDO_POWER_DESC_REQ
TI.ZPI2.ZDO_POWER_DESC_RSP | This callback message is in response to the ZDO Power Descriptor Request.
TI.ZPI2.ZDO_REMOVE_LINK_KEY | This command removes the application or trust center link key of a given device.
TI.ZPI2.ZDO_REMOVE_LINK_KEY_SRSP | Response for ZDO_REMOVE_LINK_KEY
TI.ZPI2.ZDO_SERVER_DISC_REQ | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
TI.ZPI2.ZDO_SERVER_DISC_REQ_SRSP | Response for ZDO_SERVER_DISC_REQ
TI.ZPI2.ZDO_SERVER_DISC_RSP | This callback message is
TI.ZPI2.ZDO_SET_LINK_KEY | This Command sets the application or trust center link key for a given device.
TI.ZPI2.ZDO_SET_LINK_KEY_SRSP | Response for ZDO_SET_LINK_KEY
TI.ZPI2.ZDO_SIMPLE_DESC_REQ | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
TI.ZPI2.ZDO_SIMPLE_DESC_REQ_SRSP | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
TI.ZPI2.ZDO_SIMPLE_DESC_RSP | This callback message is in response to the ZDO Simple Descriptor Request.
TI.ZPI2.ZDO_SRC_RTG_IND | This message is an indication to inform host device the receipt of a source route to a given device.
TI.ZPI2.ZDO_STARTUP_FROM_APP | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
TI.ZPI2.ZDO_STARTUP_FROM_APP_SRSP | Response for ZDO_STARTUP_FROM_APP
TI.ZPI2.ZDO_STATE_CHANGE_IND | ZDO state change indication.
TI.ZPI2.ZDO_STATUS_ERROR_RSP | This message is the default message for error status.
TI.ZPI2.ZDO_UNBIND_REQ | This command is generated to request an UnBind
TI.ZPI2.ZDO_UNBIND_REQ_SRSP | Response for ZDO_UNBIND_REQ
TI.ZPI2.ZDO_UNBIND_RSP | This callback message is in response to the ZDO UnBind Request
TI.ZPI2.ZDO_USER_DESC_CONF | This callback message is in response to the ZDO User Descriptor Set Request.
TI.ZPI2.ZDO_USER_DESC_REQ | This command is generated to request for the destination device's user descriptor
TI.ZPI2.ZDO_USER_DESC_REQ_SRSP | Response for ZDO_USER_DESC_REQ
TI.ZPI2.ZDO_USER_DESC_RSP | This callback message is in response to the ZDO User Description Request.
TI.ZPI2.ZDO_USER_DESC_SET | This command is generated to request a User Descriptor Set Request
TI.ZPI2.ZDO_USER_DESC_SET_SRSP | Response for ZDO_USER_DESC_SET

See Also

IZDO Members
TI.ZPI2 Namespace


IZMAC Interface

IZMAC Interface
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IZMAC
C#
public interface IZMAC
C++
interface class IZMAC
J#
public interface IZMAC
JScript
public interface IZMAC

Types that implement IZMAC

Type | Description
TI.ZPI2.ZMAC_ASSOCIATE_CNF | This sends a associat confirm command
TI.ZPI2.ZMAC_ASSOCIATE_IND | This command is used to send (on behalf of the next higher layer) an association indication message
TI.ZPI2.ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
TI.ZPI2.ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
TI.ZPI2.ZMAC_ASSOCIATE_RSP | This command is sent by the host to response to the ASSOCIATE_IND
TI.ZPI2.ZMAC_ASSOCIATE_RSP_RESPONSE | Response for ZMAC_ASSOCIATE_RSP
TI.ZPI2.ZMAC_BEACON_NOTIFY_IND | Beacon Notify Indication
TI.ZPI2.ZMAC_COMM_STATUS_IND | Communcation status indication
TI.ZPI2.ZMAC_DATA_CNF | Data Request Confirmation
TI.ZPI2.ZMAC_DATA_IND | Data Indication
TI.ZPI2.ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
TI.ZPI2.ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
TI.ZPI2.ZMAC_DISASSOCIATE_CNF | Disassociate Indication
TI.ZPI2.ZMAC_DISASSOCIATE_IND | Disassociate Indication
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
TI.ZPI2.ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST | This command is used to send a request to the device to send an enhanced beacon request.
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE | Response for ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST
TI.ZPI2.ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
TI.ZPI2.ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
TI.ZPI2.ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
TI.ZPI2.ZMAC_ORPHAN_IND | Orphan Indication
TI.ZPI2.ZMAC_ORPHAN_RSP | This command is sent by the host to response to the ORPHAN_IND
TI.ZPI2.ZMAC_ORPHAN_RSP_RESPONSE | Response for ZMAC_ORPHAN_RSP
TI.ZPI2.ZMAC_POLL_CNF | Mac Poll Confirmation
TI.ZPI2.ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
TI.ZPI2.ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
TI.ZPI2.ZMAC_PURGE_CNF | Mac RX enable Confirmation
TI.ZPI2.ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
TI.ZPI2.ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
TI.ZPI2.ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
TI.ZPI2.ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
TI.ZPI2.ZMAC_RX_ENABLE_CNF | Mac RX enable Confirmation
TI.ZPI2.ZMAC_SCAN_CNF | Scan Confirmation
TI.ZPI2.ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
TI.ZPI2.ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
TI.ZPI2.ZMAC_SECURITY_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC Security PIB attribute.
TI.ZPI2.ZMAC_SECURITY_GET_RESPONSE | Response for ZMAC_SECURITY_GET_REQUEST
TI.ZPI2.ZMAC_SECURITY_SET_REQUEST | This command is used to request the device to write a MAC Security PIB value.
TI.ZPI2.ZMAC_SECURITY_SET_RESPONSE | Response for ZMAC_SECURITY_SET_REQUEST
TI.ZPI2.ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
TI.ZPI2.ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
TI.ZPI2.ZMAC_SET_RX_GAIN_REQUEST | This command is used to send a request to the device to set Rx gain
TI.ZPI2.ZMAC_SET_RX_GAIN_RESPONSE | Response for ZMAC_SET_RX_GAIN_REQUEST
TI.ZPI2.ZMAC_START_CNF | Mac Start Confirmation
TI.ZPI2.ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
TI.ZPI2.ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
TI.ZPI2.ZMAC_SYNC_LOSS_IND | Indication for sync loss
TI.ZPI2.ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon
TI.ZPI2.ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST

See Also

IZMAC Members
TI.ZPI2 Namespace


MESSAGE_ID Enumeration

MESSAGE_ID Enumeration
[image]

Contains SPI message ID's

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum MESSAGE_ID
C#
public enum MESSAGE_ID
C++
public enum class MESSAGE_ID
J#
public enum MESSAGE_ID
JScript
public enum MESSAGE_ID

Members

Member Name | Description
SYS_RESET | This command is used to reset the target device.
SYS_PING | This command is used to check for a device.
SYS_VERSION | This command is used to get the device's version string.
SYS_OSAL_NV_ITEM_INIT | Creates a new item in non-volatile memory.
SYS_OSAL_NV_READ | Reads data from an item in non-volatile memory.
SYS_OSAL_NV_WRITE | Writes data to an item in non-volatile memory.
SYS_OSAL_NV_DELETE | Deletes an item from non-volatile memory.
SYS_OSAL_NV_LENGTH | Gets the length of an item in non-volatile memory.
SYS_OSAL_START_TIMER | Start timer.
SYS_OSAL_STOP_TIMER | Stop timer.
SYS_RANDOM | Generate random number.
SYS_ADC_READ | Stop timer.
SYS_GPIO | Control ZNP GPIO.
SYS_STACK_TUNE | Stack Tuning.
SYS_SET_TIME | Set the device's time. Accepts 32-bit UTC time and date/time parameters. The UTC time is used if it's non-zero.
SYS_GET_TIME | Get the device's time. Returns 32-bit UTC time and parsed date/time values.
SYS_SET_TX_POWER | Set the transmit power.
SYS_RESET_RESPONSE | Indicates a device has reset.
SYS_OSAL_TIMER_EXPIRED_IND | OSAL timer expired
SYS_RPC_ERROR | RPC transport layer error.
SYS_PING_RESPONSE | Response for SYS_PING
SYS_VERSION_RESPONSE | Response for SYS_VERSION
SYS_OSAL_NV_ITEM_INIT_SRSP | Response for SYS_OSAL_NV_ITEM_INIT
SYS_OSAL_NV_READ_SRSP | Response for SYS_OSAL_NV_READ
SYS_OSAL_NV_WRITE_SRSP | Response for SYS_OSAL_NV_WRITE
SYS_OSAL_NV_DELETE_SRSP | Response for SYS_OSAL_NV_DELETE
SYS_OSAL_NV_LENGTH_SRSP | Response for SYS_OSAL_NV_LENGTH
SYS_OSAL_START_TIMER_SRSP | Response for SYS_OSAL_START_TIMER
SYS_OSAL_STOP_TIMER_SRSP | Response for SYS_OSAL_STOP_TIMER
SYS_RANDOM_SRSP | Response for SYS_RANDOM
SYS_ADC_READ_SRSP | Response for SYS_ADC_READ
SYS_GPIO_SRSP | Response for SYS_GPIO
SYS_STACK_TUNE_SRSP | Response for SYS_STACK_TUNE
SYS_SET_TIME_SRSP | Response for SYS_SET_TIME
SYS_GET_TIME_SRSP | Response for SYS_GET_TIME
SYS_SET_TX_POWER_SRSP | Response for SYS_SET_TX_POWER
UTIL_GET_DEVICE_INFO | This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.
UTIL_GET_NV_INFO | Use this message to get the NV information.
UTIL_SET_PANID | Use this message to set PANID.
UTIL_SET_CHANNELS | Use this message to set the channels.
UTIL_SET_SECURITY_LEVEL | Use this message to set the security level.
UTIL_SET_PRECONFIG_KEY | Use this message to set the preconfig key.
UTIL_CALLBACK_SUBSCRIBE | This command subscribes/unsubscribes to layer callbacks.
UTIL_KEY_EVENT | Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.
UTIL_GET_TIME_ALIVE | Use this message to get board's time alive.
UTIL_LED_CONTROL | Use this message to control LEDs on the board.
UTIL_TEST_LOOPBACK | Use this message to receive an echo or loopback of the data bytes sent.
UTIL_DATA_REQ | Use this message to effect a MAC MLME Poll Request.
UTIL_SRC_MATCH_ENABLE | Enabled AUTOPEND and source address matching.
UTIL_SRC_MATCH_ENABLE_RESPONSE | Response for UTIL_SRC_MATCH_ENABLE
UTIL_SRC_MATCH_ADD_ENTRY | Add a short or extended address to source address table
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_ADD_ENTRY
UTIL_SRC_MATCH_DELETE_ENTRY | Delete a short or extended address to source address table
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE | Response for UTIL_SRC_MATCH_DELETE_ENTRY
UTIL_SRC_MATCH_CHECK_SRC_ADDR | Check if a short or extended address is in the source address table
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_SRC_ADDR
UTIL_SRC_MATCH_ACK_ALL_PENDING | Enabled/disable acknowledging all packets with pending bit set.
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_ACK_ALL_PENDING
UTIL_SRC_MATCH_CHECK_ALL_PENDING | Check if acknowledging all packets with pending bit set is enabled.
UTIL_SRNG_GEN | Generate secure random number generator
UTIL_SRNG_GEN_RESPONSE | Response for Generate secure random number generator
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE | Response for UTIL_SRC_MATCH_CHECK_ALL_PENDING
UTIL_ADDRMGR_EXT_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupExt().
UTIL_ADDRMGR_NWK_ADDR_LOOKUP | This command is the RPC proxy to AddrMgrEntryLookupNwk().
UTIL_APSME_LINK_KEY_DATA_GET | Use this message to retrieve APS link key data and frame counters.
UTIL_APSME_LINK_KEY_NV_ID_GET | Use this message to proxy a call to the APSME_LinkKeyNvIdGet() function.
UTIL_APSME_REQUEST_KEY_CMD | This command is used to send a request key to the Trust Center from an originator device who wants to exchange messages with a partner device.
UTIL_ASSOC_COUNT | Use this message to proxy a call to the AssocCount() function.
UTIL_ASSOC_FIND_DEVICE | Use this message to proxy a call to the AssocFindDevice() function.
UTIL_ASSOC_GET_WITH_ADDRESS | Use this message to proxy a call to the AssocGetWithAddress() function.
UTIL_ZCL_KEY_EST_INIT_EST | Use this message to proxy a call to the zclGeneral_KeyEstablish_InitiateKeyEstablishment() function.
UTIL_ZCL_KEY_EST_SIGN | Use this message to proxy a call to the zclGeneral_KeyEstablishment_ECDSASign() function.
UTIL_GET_DEVICE_INFO_RESPONSE | Response for UTIL_GET_DEVICE_INFO
UTIL_GET_NV_INFO_RESPONSE | Response for UTIL_GET_NV_INFO
UTIL_SET_PANID_RESPONSE | Response for UTIL_SET_PANID
UTIL_SET_CHANNELS_RESPONSE | Response for UTIL_SET_CHANNELS
UTIL_SET_SECURITY_LEVEL_RESPONSE | Response for UTIL_SET_SECURITY_LEVEL
UTIL_SET_PRECONFIG_KEY_RESPONSE | Response for UTIL_SET_PRECONFIG_KEY
UTIL_CALLBACK_SUBSCRIBE_RESPONSE | Response for UTIL_CALLBACK_SUBSCRIBE
UTIL_KEY_EVENT_RESPONSE | Response for UTIL_KEY_EVENT
UTIL_GET_TIME_ALIVE_RESPONSE | Response for UTIL_GET_TIME_ALIVE
UTIL_LED_CONTROL_RESPONSE | Response for UTIL_LED_CONTROL
UTIL_LOOPBACK_RESPONSE | Data buffer loopback response.
UTIL_DATA_REQ_RESPONSE | Response for UTIL_DATA_REQ
UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupExt().
UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE | This is the RPC proxy response from AddrMgrEntryLookupNwk().
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE | Response for UTIL_APSME_LINK_KEY_DATA_GET.
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE | This is the RPC proxy response from APSME_LinkKeyNvIdGet().
UTIL_APSME_REQUEST_KEY_CMD_SRSP | Response for UTIL_APSME_REQUEST_KEY_CMD
UTIL_ASSOC_COUNT_RESPONSE | This is the RPC proxy response from AssocCount().
UTIL_ASSOC_FIND_DEVICE_RESPONSE | This is the RPC proxy response from AssocFindDevice().
UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE | This is the RPC proxy response from AssocGetWithAddress().
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablish_InitiateKeyEstablishment().
UTIL_ZCL_KEY_EST_SIGN_RESPONSE | This is the RPC proxy response from zclGeneral_KeyEstablishment_ECDSASign().
MT_UTIL_SYNC_REQ | This is an asynchronous request/response handshake.
MT_UTIL_ZCL_KEY_ESTABLISH_IND | This is the RPC proxy indication for a ZCL_KEY_ESTABLISH_IND.
ZMAC_RESET_REQUEST | This command is used to send a MAC Reset command to reset MAC state machine
ZMAC_RESET_RESPONSE | Response for ZMAC_RESET_REQUEST
ZMAC_INIT_REQUEST | This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).
ZMAC_INIT_RESPONSE | Response for ZMAC_INIT_REQUEST
ZMAC_START_REQUEST | This command is used to request the MAC to transmit beacons and become a coordinator
ZMAC_START_RESPONSE | Response for ZMAC_START_REQUEST
ZMAC_SYNCHRONIZE_REQUEST | This command is used to request synchronization to the current network beacon
ZMAC_SYNCHRONIZE_RESPONSE | Response for ZMAC_SYNCHRONIZE_REQUEST
ZMAC_DATA_REQUEST | This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.
ZMAC_DATA_RESPONSE | Response for ZMAC_DATA_REQUEST
ZMAC_ASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) an association with a coordinator
ZMAC_ASSOCIATE_RESPONSE | Response for ZMAC_ASSOCIATE_REQUEST
ZMAC_ASSOCIATE_RSP | This command is sent by the host to response to the ASSOCIATE_IND
ZMAC_ASSOCIATE_RSP_RESPONSE | Response for ZMAC_ASSOCIATE_RSP
ZMAC_DISASSOCIATE_REQUEST | This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.
ZMAC_DISASSOCIATE_RESPONSE | Response for ZMAC_DISASSOCIATE_REQUEST
ZMAC_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.
ZMAC_GET_RESPONSE | Response for ZMAC_GET_REQUEST
ZMAC_SET_REQUEST | This command is used to request the device to write a MAC PIB value.
ZMAC_SET_RESPONSE | Response for ZMAC_SET_REQUEST
ZMAC_SECURITY_GET_REQUEST | This command is used to read (on behalf of the next higher layer) a MAC Security PIB attribute.
ZMAC_SECURITY_GET_RESPONSE | Response for ZMAC_SECURITY_GET_REQUEST
ZMAC_SECURITY_SET_REQUEST | This command is used to request the device to write a MAC Security PIB value.
ZMAC_SECURITY_SET_RESPONSE | Response for ZMAC_SECURITY_SET_REQUEST
ZMAC_SCAN_REQUEST | This command is used to send a request to the device to perform a network scan.
ZMAC_SCAN_RESPONSE | Response for ZMAC_SCAN_REQUEST
ZMAC_ORPHAN_RSP | This command is sent by the host to response to the ORPHAN_IND
ZMAC_ORPHAN_RSP_RESPONSE | Response for ZMAC_ORPHAN_RSP
ZMAC_POLL_REQUEST | This command is used to send a MAC data request poll
ZMAC_POLL_RESPONSE | Response for ZMAC_POLL_REQUEST
ZMAC_PURGE_REQUEST | This command is used to send a request to the device to purge a data frame
ZMAC_PURGE_RESPONSE | Response for ZMAC_PURGE_REQUEST
ZMAC_SET_RX_GAIN_REQUEST | This command is used to send a request to the device to set Rx gain
ZMAC_SET_RX_GAIN_RESPONSE | Response for ZMAC_SET_RX_GAIN_REQUEST
ZMAC_SYNC_LOSS_IND | Indication for sync loss
ZMAC_ASSOCIATE_IND | This command is used to send (on behalf of the next higher layer) an association indication message
ZMAC_ASSOCIATE_CNF | This sends a associat confirm command
ZMAC_BEACON_NOTIFY_IND | Beacon Notify Indication
ZMAC_DATA_CNF | Data Request Confirmation
ZMAC_DATA_IND | Data Indication
ZMAC_DISASSOCIATE_IND | Disassociate Indication
ZMAC_DISASSOCIATE_CNF | Disassociate Indication
ZMAC_ORPHAN_IND | Orphan Indication
ZMAC_POLL_CNF | Mac Poll Confirmation
ZMAC_SCAN_CNF | Scan Confirmation
ZMAC_COMM_STATUS_IND | Communcation status indication
ZMAC_START_CNF | Mac Start Confirmation
ZMAC_RX_ENABLE_CNF | Mac RX enable Confirmation
ZMAC_PURGE_CNF | Mac RX enable Confirmation
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST | This command is used to send a request to the device to send an enhanced beacon request.
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE | Response for ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST
NLDE_NWK_INIT | This function will initialize the nwk with the NWK_TASKID.
NLDE_DATA_REQUEST | This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.
NLME_NETWORK_FORMATION_REQUEST | This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.
NLME_PERMITJOINING_REQUEST | This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.
NLME_JOIN_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.
NLME_LEAVE_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.
NLME_RESET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation
NLME_GET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).
NLME_SET_REQUEST | This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).
NLME_NETWORKDISCOVERY_REQUEST | NLME Network discovery request used by tester
NLME_ROUTEDISCOVERY_REQUEST | NLME route discovery request used by tester
NLME_DIRECTJOIN_REQUEST | NLME direct join request used by tester
NLME_ORPHANJOIN_REQUEST | NLME orphan join request used by tester
NLME_STARTROUTER_REQUEST | NLME Start router request used by tester
NLDE_DATA_CONFIRMATION | This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.
NLDE_DATA_INDICATION | This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.
NLME_NETWORK_FORMATION_CONFIRMATION | This message is used by the target NWK to inform the tester of the result of a previous association request command
NLME_JOIN_CONFIRMATION | This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.
NLME_JOIN_INDICATION | This message is sent by the target to notify the next higher layer of a remote join request.
NLME_LEAVE_CONFIRMATION | This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.
NLME_LEAVE_INDICATION | This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator
NLME_POLL_CONFIRMATION | This function reports the results of a polling attempt.
NLME_SYNC_INDICATION | This message is sent by the target to indicate a sync request to the next higher layer of a coordinator
NLME_NETWORKDISCOVERY_CONFIRMATION | This message is sent by the target to indicate network discovery confirmation
NLME_STARTROUTER_CONFIRMATION | This message is sent by the target to the next higher layer of the results of its request to start a router
NLDE_DATA_RESPONSE | Response for NLDE_DATA_REQUEST
NLME_NETWORK_FORMATION_RESPONSE | Response for NLME_NETWORK_FORMATION_REQUEST
NLME_PERMITJOINING_RESPONSE | Response for NLME_PERMITJOINING_REQUEST
NLME_JOIN_RESPONSE | Response for NLME_JOIN_REQUEST
NLME_LEAVE_RESPONSE | Response for NLME_LEAVE_REQUEST
NLME_RESET_RESPONSE | Response for NLME_RESET_REQUEST
NLME_GET_RESPONSE | Response for NLME_GET_REQUEST
NLME_SET_RESPONSE | Response for NLME_SET_REQUEST
NLME_NETWORKDISCOVERY_RESPONSE | Response for NLME_NETWORKDISCOVERY_REQUEST
NLME_ROUTEDISCOVERY_RESPONSE | Response for NLME_ROUTEDISCOVERY_REQUEST
NLME_DIRECTJOIN_RESPONSE | Response for NLME_DIRECTJOIN_REQUEST
NLME_ORPHANJOIN_RESPONSE | Response for NLME_ORPHANJOIN_REQUEST
NLME_STARTROUTER_RESPONSE | Response for NLME_STARTROUTER_REQUEST
APSDE_DATA_CONFIRMATION | This message is issued by the target APS to the tester to report the results of a request to transfer a data PDU from a local NHLE (Next Higher Layer Entity) to a single peer NHLE.
NWK_SYNCHRONIZATION_LOSS_INDICATION | This function indicates the loss of synchronization of a network beacon
NWK_ASSOCIATE_INDICATION | This function is used to indicate the reception of an association request command.
NWK_ASSOCIATE_CONFIRMATION | This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.
NWK_BEACON_NOTIFY_INDICATION | This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.
NWK_DATA_CONFIRMATION | This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.
NWK_DATA_INDICATION | This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.
NWK_DISASSOCIATE_INDICATION | This function is used to indicate the reception of a disassociation notification command.
NWK_DISASSOCIATE_CONFIRMATION | This function is sent as the result of a disassociation request.
NWK_ORPHAN_INDICATION | This function allows the MLME to notify the next higher layer of an orphaned device
NWK_POLL_CONFIRMATION | This function reports the results of a polling attempt.
NWK_SCAN_CONFIRMATION | This function reports the results of a channel scan request.
NWK_COMM_STATUS_INDICATION | This function reports a comm status error
NWK_START_CONFIRMATION | This function reports the success of the start request.
NWK_RX_ENABLE_CONFIRMATION | This function reports the results of an RX enable attempt.
NWK_PURGE_CONFIRMATION | This function reports the results of a purge attempt.
AF_REGISTER | This command enables the tester to register an application's endpoint description
AF_DATA_REQUEST | This command is used by tester to build and send a data request message
AF_DATA_REQUEST_EXT | This command is used by tester to build and send a data request message with PanId field.
AF_DATA_REQUEST_SRC_RTG | This command is used by tester to build and send a data request message via source routing
AF_INTER_PAN_CTL | Inter-Pan control command and data.
AF_DATA_STORE | AF huge data request data store command and data.
AF_DATA_RETRIEVE | AF huge incoming message data retrieve command.
AF_APSF_CONFIG_SET | MT proxy for afAPSF_ConfigSet().
AF_DATA_CONFIRM | AF Data confirm.
AF_INCOMING_MSG | Incoming AF data.
AF_INCOMING_MSG_EXT | Incoming AF data extended.
AF_REGISTER_SRSP | Response for AF_REGISTER
AF_DATA_REQUEST_SRSP | Response for AF_DATA_REQUEST
AF_DATA_REQUEST_EXT_SRSP | Response for AF_DATA_REQUEST_EXT
AF_DATA_REQUEST_SRC_RTG_SRSP | Response for AF_DATA_REQUEST_SRC_RTG
AF_INTER_PAN_CTL_SRSP | Response for AF_INTER_PAN_SET_PARAM
AF_DATA_STORE_SRSP | Response for AF_DATA_STORE
AF_DATA_RETRIEVE_SRSP | Response for AF_DATA_RETRIEVE
AF_APSF_CONFIG_SET_SRSP | Response for AF_APSF_CONFIG_SET
ZDO_NWK_ADDR_REQ | This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.
ZDO_IEEE_ADDR_REQ | This command will request a device's IEEE 64-bit address. You must subscribe to 'ZDO IEEE Address Response' to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.
ZDO_NODE_DESC_REQ | This command is generated to inquire as to the Node Descriptor of the destination device
ZDO_POWER_DESC_REQ | This command is generated to inquire as to the Power Descriptor of the destination
ZDO_SIMPLE_DESC_REQ | This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint
ZDO_ACTIVE_EP_REQ | This command is generated to request a list of active endpoint from the destination device.
ZDO_MATCH_DESC_REQ | This command is generated to request a list of active endpoint from the destination device
ZDO_COMPLEX_DESC_REQ | This command is generated to request for the destination device's complex descriptor
ZDO_USER_DESC_REQ | This command is generated to request for the destination device's user descriptor
ZDO_END_DEVICE_ANNCE | This command is generated to request an End Device Announce.
ZDO_USER_DESC_SET | This command is generated to request a User Descriptor Set Request
ZDO_SERVER_DISC_REQ | The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.
ZDO_END_DEVICE_TIMEOUT_REQ | The command is used to send an End Device Timeout Request message.
ZDO_END_DEVICE_BIND_REQ | This command is generated to request an End Device Bind with the destination device
ZDO_BIND_REQ | This command is generated to request a Bind
ZDO_UNBIND_REQ | This command is generated to request an UnBind
ZDO_MGMT_NWK_DISC_REQ | This command is generated to request a Management Network Discovery Request
ZDO_MGMT_LQI_REQ | This command is generated to request a Management LQI Request.
ZDO_MGMT_RTG_REQ | This command is generated to request a Management Routing Table Request.
ZDO_MGMT_BIND_REQ | This command is generated to request a Management Binding Table Request.
ZDO_MGMT_LEAVE_REQ | This command is generated to request a Management Leave Request
ZDO_MGMT_DIRECT_JOIN_REQ | This command is generated to request a Management Direct Join Request
ZDO_MGMT_PERMIT_JOIN_REQUEST | This command is generated to request a Management Join Request
ZDO_MGMT_NWK_UPDATE_REQUEST | This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.
ZDO_MSG_CB_REGISTER | This command is the RPC proxy to ZDO_RegisterForZDOMsg() and registers for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
ZDO_MSG_CB_REMOVE | This command is the RPC proxy to ZDO_RemoveRegisteredCB() and removes registration for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.
ZDO_STARTUP_FROM_APP | In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.
ZDO_AUTO_FIND_DESTINATION | This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.
ZDO_SET_LINK_KEY | This Command sets the application or trust center link key for a given device.
ZDO_REMOVE_LINK_KEY | This command removes the application or trust center link key of a given device.
ZDO_GET_LINK_KEY | This function will return the application or trust center link key of a given device.
ZDO_NWK_DISCOVERY_REQ | This command will initiate a network discovery (active scan).
ZDO_JOIN_REQ | This command is used to request the device to join itself to a parent device on a network.
ZDO_NWK_ADDR_RSP | This callback message is in response to the ZDO Network Address Request.
ZDO_IEEE_ADDR_RSP | This callback message is in response to the ZDO IEEE Address Request.
ZDO_NODE_DESC_RSP | This callback message is in response to the ZDO Node Descriptor Request.
ZDO_POWER_DESC_RSP | This callback message is in response to the ZDO Power Descriptor Request.
ZDO_SIMPLE_DESC_RSP | This callback message is in response to the ZDO Simple Descriptor Request.
ZDO_ACTIVE_EP_RSP | This callback message is in response to the ZDO Active Endpoint Request.
ZDO_MATCH_DESC_RSP | This callback message is in response to the ZDO Match Description Request
ZDO_COMPLEX_DESC_RSP | Response for ZDO_COMPLEX_DESC_REQ
ZDO_USER_DESC_RSP | This callback message is in response to the ZDO User Description Request.
ZDO_END_DEVICE_ANNCE_IND | ZDO end device announce indication.
ZDO_USER_DESC_CONF | This callback message is in response to the ZDO User Descriptor Set Request.
ZDO_SERVER_DISC_RSP | This callback message is
ZDO_END_DEVICE_TIMEOUT_RSP | This callback message is in response to the End Device Timeout Request.
ZDO_END_DEVICE_BIND_RSP | This callback message is in response to the ZDO End Device Bind Request
ZDO_BIND_RSP | This callback message is in response to the ZDO Bind Request
ZDO_UNBIND_RSP | This callback message is in response to the ZDO UnBind Request
ZDO_MGMT_NWK_DISC_RSP | This callback message is in response to the ZDO Management Network Discovery Request
ZDO_MGMT_LQI_RSP | This callback message is in response to the ZDO Management LQI Request.
ZDO_MGMT_RTG_RSP | This callback message is in response to the ZDO Management Routing Table Request.
ZDO_MGMT_BIND_RSP | This callback message is in response to the ZDO Management Binding Table Request
ZDO_MGMT_LEAVE_RSP | This callback message is in response to the ZDO Management Leave Request.
ZDO_MGMT_DIRECT_JOIN_RSP | This callback message is in response to the ZDO Management Direct Join Request.
ZDO_MGMT_PERMIT_JOIN_RSP | This callback message is in response to the ZDO Management Permit Join Request
ZDO_STATUS_ERROR_RSP | This message is the default message for error status.
ZDO_STATE_CHANGE_IND | ZDO state change indication.
ZDO_MATCH_DESC_RSP_SENT | This callback indicates that Match Descriptor Response has been sent.
ZDO_SRC_RTG_IND | This message is an indication to inform host device the receipt of a source route to a given device.
ZDO_BEACON_NOTIFY_IND | This message is an indication to inform host device the receipt of a beacon notification
ZDO_JOIN_CNF | This message is an indication to the host device the result of a ZDO join request .
ZDO_NWK_DISCOVERY_CNF | This message sends an indication to inform host device the completion of network discovery scan.
ZDO_LEAVE_IND | ZDO leave indication.
MT_ZDO_MSG_CB_INCOMING | This message is the RPC proxy for receiving a SYS_EVENT_MSG with the ZDO_CB_MSG event. It results after registering for a callback on a Cluster Id with ZDO_MSG_CB_REGISTER. The parameter list is a packed zdoIncomingMsg_t structure less the asduLen since it can be deduced from the RPC length.
USERTEST_REQUEST | This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).
APSME_BIND_RESPONSE | Response for APSME_BIND
ZDO_NWK_ADDR_REQ_SRSP | Response for ZDO_NWK_ADDR_REQ
ZDO_IEEE_ADDR_REQ_SRSP | Response for ZDO_IEEE_ADDR_REQ
ZDO_NODE_DESC_REQ_SRSP | Response for ZDO_NODE_DESC_REQ
ZDO_POWER_DESC_REQ_SRSP | Response for ZDO_POWER_DESC_REQ
ZDO_SIMPLE_DESC_REQ_SRSP | Response for ZDO_SIMPLEDESCRIPTOR_REQUEST
ZDO_ACTIVE_EP_REQ_SRSP | Response for ZDO_ACTIVE_EP_REQ
ZDO_MATCH_DESC_REQ_SRSP | Response for ZDO_MATCH_DESC_REQ
ZDO_COMPLEX_DESC_REQ_SRSP | Response for ZDO_COMPLEX_DESC_REQ
ZDO_USER_DESC_REQ_SRSP | Response for ZDO_USER_DESC_REQ
ZDO_END_DEVICE_ANNCE_SRSP | Response for ZDO_END_DEVICE_ANNCE
ZDO_USER_DESC_SET_SRSP | Response for ZDO_USER_DESC_SET
ZDO_SERVER_DISC_REQ_SRSP | Response for ZDO_SERVER_DISC_REQ
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP | Response for ZDO_END_DEVICE_TIMEOUT_REQ
ZDO_END_DEVICE_BIND_REQ_SRSP | Response for ZDO_END_DEVICE_BIND_REQ
ZDO_BIND_REQ_SRSP | Response for ZDO_BIND_REQ
ZDO_UNBIND_REQ_SRSP | Response for ZDO_UNBIND_REQ
ZDO_MGMT_NWK_DISC_REQ_SRSP | Response for ZDO_MGMT_NWK_DISC_REQ
ZDO_MGMT_LQI_REQ_SRSP | Response for ZDO_MGMT_LQI_REQ
ZDO_MGMT_RTG_REQ_SRSP | Response for ZDO_MGMT_RTG_REQ
ZDO_MGMT_BIND_REQ_SRSP | Response for ZDO_MGMT_BIND_REQ
ZDO_MGMT_LEAVE_REQ_SRSP | Response for ZDO_MGMT_LEAVE_REQ
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP | Response for ZDO_MGMT_DIRECT_JOIN_REQ
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP | Response for ZDO_MGMT_PERMIT_JOIN_REQ
ZDO_MGMT_NWK_UPDATE_RESPONSE | Response for ZDO_MGMT_NWK_UPDATE_REQUEST
ZDO_MSG_CB_REGISTER_RESPONSE | Response for ZDO_MSG_CB_REGISTER
ZDO_MSG_CB_REMOVE_RESPONSE | Response for ZDO_MSG_CB_REMOVE
ZDO_STARTUP_FROM_APP_SRSP | Response for ZDO_STARTUP_FROM_APP
ZDO_SET_LINK_KEY_SRSP | Response for ZDO_SET_LINK_KEY
ZDO_REMOVE_LINK_KEY_SRSP | Response for ZDO_REMOVE_LINK_KEY
ZDO_GET_LINK_KEY_SRSP | Response for ZDO_GET_LINK_KEY
ZDO_NWK_DISCOVERY_REQ_SRSP | Response for ZDO_NWK_DISCOVERY_REQ
ZDO_JOIN_REQ_SRSP | Response for ZDO_JOIN_REQ
USERTEST_RESPONSE | Response for USERTEST_REQUEST
ZB_SYSTEM_RESET | Reboot the device (zb_SystemReset)
ZB_START_REQUEST | Starts the ZigBee stack (zb_StartRequest).
ZB_BIND_DEVICE | Create or remove a binding entry (zb_BindDevice).
ZB_ALLOW_BIND | Puts the device into the Allow Bind mode (zb_AllowBind).
ZB_SEND_DATA_REQUEST | Send a data packet to another device (zb_SendDataRequest).
ZB_READ_CONFIGURATION | Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).
ZB_WRITE_CONFIGURATION | Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).
ZB_GET_DEVICE_INFO | Reads current device infromation.
ZB_FIND_DEVICE_REQUEST | Search for a device's short address given its IEEE address.
ZB_PERMIT_JOINING_REQUEST | Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.
ZB_APP_REGISTER_REQUEST | This command register the device descriptor
ZB_START_REQUEST_RSP | Response for ZB_START_REQUEST
ZB_BIND_DEVICE_RSP | Response for ZB_BIND_DEVICE
ZB_ALLOW_BIND_RSP | Response for ZB_ALLOW_BIND
ZB_SEND_DATA_REQUEST_RSP | Response for ZB_SEND_DATA_REQUEST
ZB_READ_CONFIGURATION_RSP |
ZB_WRITE_CONFIGURATION_RSP | Response for ZB_WRITE_CONFIGURATION
ZB_GET_DEVICE_INFO_RSP | Response for ZB_GET_DEVICE_INFO
ZB_FIND_DEVICE_REQUEST_RSP | Response for ZB_FIND_DEVICE_REQUEST
ZB_PERMIT_JOINING_REQUEST_RSP | Response for ZB_PERMIT_JOINING_REQUEST
ZB_APP_REGISTER_RSP | Response for ZB_APP_REGISTER_REQUEST
ZB_START_CONFIRM | Response for ZB_START_REQUEST
ZB_BIND_CONFIRM | Response for ZB_BIND_DEVICE
ZB_ALLOW_BIND_CONFIRM | Response for ZB_ALLOW_BIND
ZB_SEND_DATA_CONFIRM | Response for ZB_SEND_DATA_REQUEST
ZB_FIND_DEVICE_CONFIRM | (zb_FindDeviceConfirm)
ZB_RECEIVE_DATA_INDICATION | (zb_ReceiveDataIndication)
DEBUG_SET_DEBUG_THRESHOLD | This command is used by the tester to set the debug threshold level for a particular software component in the target.
DEBUG_SET_DEBUG_THRESHOLD_RESPONSE | Response for SYS_SET_DEBUG_THRESHOLD
DEBUG_STRING | Debug message sent by device
APP_MSG | Use this message to send raw data to an application.
APP_MSG_RESPONSE | Status for APP_MSG
APP_MSG_RSP | Response for APP_MSG
ZLL_TOUCH_LINK_INDICATION | ZLL Touch Link Indication
APP_USER_TEST | This command is used by the tester to set the debug threshold level for a particular software component in the target.
APP_USER_TEST_RESPONSE | Response for APP_USER_TEST

See Also

TI.ZPI2 Namespace


MT_UTIL_SYNC_REQ Class

MT_UTIL_SYNC_REQ Class
See Also Example Members
[image]

This is an asynchronous request/response handshake.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MT_UTIL_SYNC_REQ
Implements IRESPONSE, IUTIL
C#
public class MT_UTIL_SYNC_REQ : IRESPONSE, IUTIL
C++
ref class MT_UTIL_SYNC_REQ : IRESPONSE, IUTIL
J#
public class MT_UTIL_SYNC_REQ implements IRESPONSE, IUTIL
JScript
public class MT_UTIL_SYNC_REQ extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.MT_UTIL_SYNC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MT_UTIL_SYNC_REQ Members
TI.ZPI2 Namespace


MT_UTIL_SYNC_REQ Members

MT_UTIL_SYNC_REQ Members
See Also Example Constructors Methods
[image]

This is an asynchronous request/response handshake.

The following tables list the members exposed by MT_UTIL_SYNC_REQ.

Public Constructors

 | Name | Description
Public method | MT_UTIL_SYNC_REQ | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MT_UTIL_SYNC_REQ Class
TI.ZPI2 Namespace


MT_UTIL_SYNC_REQ Constructor

MT_UTIL_SYNC_REQ Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MT_UTIL_SYNC_REQ()
C++
public:
MT_UTIL_SYNC_REQ() sealed
J#
public MT_UTIL_SYNC_REQ()
JScript
public function MT_UTIL_SYNC_REQ()

See Also

MT_UTIL_SYNC_REQ Class
TI.ZPI2 Namespace


MT_UTIL_ZCL_KEY_ESTABLISH_IND Class

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
See Also Example Members
[image]

This is the RPC proxy indication for a ZCL_KEY_ESTABLISH_IND.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MT_UTIL_ZCL_KEY_ESTABLISH_IND
Implements IRESPONSE, IUTIL
C#
public class MT_UTIL_ZCL_KEY_ESTABLISH_IND : IRESPONSE, IUTIL
C++
ref class MT_UTIL_ZCL_KEY_ESTABLISH_IND : IRESPONSE, IUTIL
J#
public class MT_UTIL_ZCL_KEY_ESTABLISH_IND implements IRESPONSE, IUTIL
JScript
public class MT_UTIL_ZCL_KEY_ESTABLISH_IND extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.MT_UTIL_ZCL_KEY_ESTABLISH_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Members
TI.ZPI2 Namespace


MT_UTIL_ZCL_KEY_ESTABLISH_IND Members

MT_UTIL_ZCL_KEY_ESTABLISH_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy indication for a ZCL_KEY_ESTABLISH_IND.

The following tables list the members exposed by MT_UTIL_ZCL_KEY_ESTABLISH_IND.

Public Constructors

Name | Description
MT_UTIL_ZCL_KEY_ESTABLISH_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Event | The OSAL message event.
Public field | Status | The OSAL message status.
Public field | Suite | The key establishment suite.
Public field | TaskId | The OSAL Task ID registered to receive this indication (see UTIL_ZCL_KEY_EST_INIT_EST).
Public field | WaitTime | The wait time.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
MT_UTIL_ZCL_KEY_ESTABLISH_IND | Overloaded.
Top

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor

MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor

Overload List

 | Name | Description
Public method | MT_UTIL_ZCL_KEY_ESTABLISH_IND | Constructor
Public method | MT_UTIL_ZCL_KEY_ESTABLISH_IND (Byte, Byte, Byte, Byte, UInt16) | Constructor

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor ()

MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MT_UTIL_ZCL_KEY_ESTABLISH_IND()
C++
public:
MT_UTIL_ZCL_KEY_ESTABLISH_IND() sealed
J#
public MT_UTIL_ZCL_KEY_ESTABLISH_IND()
JScript
public function MT_UTIL_ZCL_KEY_ESTABLISH_IND()

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace
MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor Overload List


MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor (Byte, Byte, Byte, Byte, UInt16)

MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor (Byte, Byte, Byte, Byte, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16 _
)
C#
public MT_UTIL_ZCL_KEY_ESTABLISH_IND(
byte ,
byte ,
byte ,
byte ,
ushort
)
C++
public:
MT_UTIL_ZCL_KEY_ESTABLISH_IND(
char ,
char ,
char ,
char ,
unsigned short
) sealed
J#
public MT_UTIL_ZCL_KEY_ESTABLISH_IND(
byte ,
byte ,
byte ,
byte ,
ushort
)
JScript
public function MT_UTIL_ZCL_KEY_ESTABLISH_IND(
: Byte,
: Byte,
: Byte,
: Byte,
: UInt16
)

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace
MT_UTIL_ZCL_KEY_ESTABLISH_IND Constructor Overload List


Fields

MT_UTIL_ZCL_KEY_ESTABLISH_IND Fields
[image]

Public Fields

 | Name | Description
Public field | Event | The OSAL message event.
Public field | Status | The OSAL message status.
Public field | Suite | The key establishment suite.
Public field | TaskId | The OSAL Task ID registered to receive this indication (see UTIL_ZCL_KEY_EST_INIT_EST).
Public field | WaitTime | The wait time.
Top

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


Event Field

MT_UTIL_ZCL_KEY_ESTABLISH_IND.Event Field
[image]

The OSAL message event.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Event As Byte
C#
public byte Event;
C++
public:
char Event sealed ;
J#
public byte Event
JScript
public Event : Byte;

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


Status Field

MT_UTIL_ZCL_KEY_ESTABLISH_IND.Status Field
[image]

The OSAL message status.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As Byte
C#
public byte Status;
C++
public:
char Status sealed ;
J#
public byte Status
JScript
public Status : Byte;

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


Suite Field

MT_UTIL_ZCL_KEY_ESTABLISH_IND.Suite Field
[image]

The key establishment suite.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Suite As UInt16
C#
public ushort Suite;
C++
public:
unsigned short Suite sealed ;
J#
public ushort Suite
JScript
public Suite : UInt16;

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


TaskId Field

MT_UTIL_ZCL_KEY_ESTABLISH_IND.TaskId Field
[image]

The OSAL Task ID registered to receive this indication (see UTIL_ZCL_KEY_EST_INIT_EST).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TaskId As Byte
C#
public byte TaskId;
C++
public:
char TaskId sealed ;
J#
public byte TaskId
JScript
public TaskId : Byte;

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


WaitTime Field

MT_UTIL_ZCL_KEY_ESTABLISH_IND.WaitTime Field
[image]

The wait time.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public WaitTime As Byte
C#
public byte WaitTime;
C++
public:
char WaitTime sealed ;
J#
public byte WaitTime
JScript
public WaitTime : Byte;

See Also

MT_UTIL_ZCL_KEY_ESTABLISH_IND Class
TI.ZPI2 Namespace


MT_ZDO_MSG_CB_INCOMING Class

MT_ZDO_MSG_CB_INCOMING Class
See Also Example Members
[image]

This message is the RPC proxy for receiving a SYS_EVENT_MSG with the ZDO_CB_MSG event. It results after registering for a callback on a Cluster Id with ZDO_MSG_CB_REGISTER. The parameter list is a packed zdoIncomingMsg_t structure less the asduLen since it can be deduced from the RPC length.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MT_ZDO_MSG_CB_INCOMING
Implements IRESPONSE, IZDO
C#
public class MT_ZDO_MSG_CB_INCOMING : IRESPONSE, IZDO
C++
ref class MT_ZDO_MSG_CB_INCOMING : IRESPONSE, IZDO
J#
public class MT_ZDO_MSG_CB_INCOMING implements IRESPONSE, IZDO
JScript
public class MT_ZDO_MSG_CB_INCOMING extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.MT_ZDO_MSG_CB_INCOMING

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MT_ZDO_MSG_CB_INCOMING Members
TI.ZPI2 Namespace


MT_ZDO_MSG_CB_INCOMING Members

MT_ZDO_MSG_CB_INCOMING Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is the RPC proxy for receiving a SYS_EVENT_MSG with the ZDO_CB_MSG event. It results after registering for a callback on a Cluster Id with ZDO_MSG_CB_REGISTER. The parameter list is a packed zdoIncomingMsg_t structure less the asduLen since it can be deduced from the RPC length.

The following tables list the members exposed by MT_ZDO_MSG_CB_INCOMING.

Public Constructors

Name | Description
MT_ZDO_MSG_CB_INCOMING | Overloaded.
Top

Public Fields

 | Name | Description
Public field | asdu | Dynamic array, requires memory allocation. Variable length field of size RPC message length minus 9.
Public field | clusterID | Cluster Id of the incoming message.
Public field | macDestAddr | Network MAC Destination Address of the incoming Cluster Id.
Public field | SecurityUse | A boolean whether the asdu has security or not - always FALSE.
Public field | srcAddr | Network Source Address of the incoming Cluster Id.
Public field | TransSeq | The unique transaction sequence number that can be used to differentiate duplicates within a short time span.
Public field | wasBroadcast | A boolean whether the message was broadcast or not.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
MT_ZDO_MSG_CB_INCOMING | Overloaded.
Top

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


MT_ZDO_MSG_CB_INCOMING Constructor

MT_ZDO_MSG_CB_INCOMING Constructor

Overload List

 | Name | Description
Public method | MT_ZDO_MSG_CB_INCOMING | Constructor
Public method | MT_ZDO_MSG_CB_INCOMING (UInt16, Byte, UInt16, Byte, Byte, UInt16, Byte) | Constructor

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


MT_ZDO_MSG_CB_INCOMING Constructor ()

MT_ZDO_MSG_CB_INCOMING Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MT_ZDO_MSG_CB_INCOMING()
C++
public:
MT_ZDO_MSG_CB_INCOMING() sealed
J#
public MT_ZDO_MSG_CB_INCOMING()
JScript
public function MT_ZDO_MSG_CB_INCOMING()

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace
MT_ZDO_MSG_CB_INCOMING Constructor Overload List


MT_ZDO_MSG_CB_INCOMING Constructor (UInt16, Byte, UInt16, Byte, Byte, UInt16, Byte[])

MT_ZDO_MSG_CB_INCOMING Constructor (UInt16, Byte, UInt16, Byte, Byte, UInt16, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte() _
)
C#
public MT_ZDO_MSG_CB_INCOMING(
ushort ,
byte ,
ushort ,
byte ,
byte ,
ushort ,
byte[]
)
C++
public:
MT_ZDO_MSG_CB_INCOMING(
unsigned short ,
char ,
unsigned short ,
char ,
char ,
unsigned short ,
array<char>^
) sealed
J#
public MT_ZDO_MSG_CB_INCOMING(
ushort ,
byte ,
ushort ,
byte ,
byte ,
ushort ,
byte[]
)
JScript
public function MT_ZDO_MSG_CB_INCOMING(
: UInt16,
: Byte,
: UInt16,
: Byte,
: Byte,
: UInt16,
: Byte[]
)

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace
MT_ZDO_MSG_CB_INCOMING Constructor Overload List


Fields

MT_ZDO_MSG_CB_INCOMING Fields
[image]

Public Fields

 | Name | Description
Public field | asdu | Dynamic array, requires memory allocation. Variable length field of size RPC message length minus 9.
Public field | clusterID | Cluster Id of the incoming message.
Public field | macDestAddr | Network MAC Destination Address of the incoming Cluster Id.
Public field | SecurityUse | A boolean whether the asdu has security or not - always FALSE.
Public field | srcAddr | Network Source Address of the incoming Cluster Id.
Public field | TransSeq | The unique transaction sequence number that can be used to differentiate duplicates within a short time span.
Public field | wasBroadcast | A boolean whether the message was broadcast or not.
Top

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


asdu Field

MT_ZDO_MSG_CB_INCOMING.asdu Field
[image]

Dynamic array, requires memory allocation. Variable length field of size RPC message length minus 9.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public asdu As Byte()
C#
public byte[] asdu;
C++
public:
array<char>^ asdu sealed ;
J#
public byte[] asdu
JScript
public asdu : Byte[];

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


clusterID Field

MT_ZDO_MSG_CB_INCOMING.clusterID Field
[image]

Cluster Id of the incoming message.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public clusterID As UInt16
C#
public ushort clusterID;
C++
public:
unsigned short clusterID sealed ;
J#
public ushort clusterID
JScript
public clusterID : UInt16;

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


macDestAddr Field

MT_ZDO_MSG_CB_INCOMING.macDestAddr Field
[image]

Network MAC Destination Address of the incoming Cluster Id.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public macDestAddr As UInt16
C#
public ushort macDestAddr;
C++
public:
unsigned short macDestAddr sealed ;
J#
public ushort macDestAddr
JScript
public macDestAddr : UInt16;

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


SecurityUse Field

MT_ZDO_MSG_CB_INCOMING.SecurityUse Field
[image]

A boolean whether the asdu has security or not - always FALSE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityUse As Byte
C#
public byte SecurityUse;
C++
public:
char SecurityUse sealed ;
J#
public byte SecurityUse
JScript
public SecurityUse : Byte;

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


srcAddr Field

MT_ZDO_MSG_CB_INCOMING.srcAddr Field
[image]

Network Source Address of the incoming Cluster Id.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public srcAddr As UInt16
C#
public ushort srcAddr;
C++
public:
unsigned short srcAddr sealed ;
J#
public ushort srcAddr
JScript
public srcAddr : UInt16;

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


TransSeq Field

MT_ZDO_MSG_CB_INCOMING.TransSeq Field
[image]

The unique transaction sequence number that can be used to differentiate duplicates within a short time span.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransSeq As Byte
C#
public byte TransSeq;
C++
public:
char TransSeq sealed ;
J#
public byte TransSeq
JScript
public TransSeq : Byte;

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


wasBroadcast Field

MT_ZDO_MSG_CB_INCOMING.wasBroadcast Field
[image]

A boolean whether the message was broadcast or not.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public wasBroadcast As Byte
C#
public byte wasBroadcast;
C++
public:
char wasBroadcast sealed ;
J#
public byte wasBroadcast
JScript
public wasBroadcast : Byte;

See Also

MT_ZDO_MSG_CB_INCOMING Class
TI.ZPI2 Namespace


NLDE_DATA_CONFIRMATION Class

NLDE_DATA_CONFIRMATION Class
See Also Example Members
[image]

This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLDE_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLDE_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLDE_DATA_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLDE_DATA_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLDE_DATA_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_CONFIRMATION Members
TI.ZPI2 Namespace


NLDE_DATA_CONFIRMATION Members

NLDE_DATA_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is issued by the target NWK to the tester to report the results of a request to transfer a data PDU from a local APS sub-layer entity to a single peer APS sub-layer entity.

The following tables list the members exposed by NLDE_DATA_CONFIRMATION.

Public Constructors

Name | Description
NLDE_DATA_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NSDUHandle | indicates the transaction handle (that was created when the data request was issued)
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_CONFIRMATION | Overloaded.
Top

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


NLDE_DATA_CONFIRMATION Constructor

NLDE_DATA_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_CONFIRMATION | Constructor
Public method | NLDE_DATA_CONFIRMATION (Byte, NLDE_DATA_CONFIRMATION.CMD_STATUS) |

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


NLDE_DATA_CONFIRMATION Constructor ()

NLDE_DATA_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_CONFIRMATION()
C++
public:
NLDE_DATA_CONFIRMATION() sealed
J#
public NLDE_DATA_CONFIRMATION()
JScript
public function NLDE_DATA_CONFIRMATION()

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace
NLDE_DATA_CONFIRMATION Constructor Overload List


NLDE_DATA_CONFIRMATION Constructor (Byte, NLDE_DATA_CONFIRMATION.CMD_STATUS)

NLDE_DATA_CONFIRMATION Constructor (Byte, NLDE_DATA_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As NLDE_DATA_CONFIRMATION.CMD_STATUS _
)
C#
public NLDE_DATA_CONFIRMATION(
byte ,
NLDE_DATA_CONFIRMATION.CMD_STATUS
)
C++
public:
NLDE_DATA_CONFIRMATION(
char ,
NLDE_DATA_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLDE_DATA_CONFIRMATION(
byte ,
NLDE_DATA_CONFIRMATION.CMD_STATUS
)
JScript
public function NLDE_DATA_CONFIRMATION(
: Byte,
: NLDE_DATA_CONFIRMATION.CMD_STATUS
)

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace
NLDE_DATA_CONFIRMATION Constructor Overload List


Fields

NLDE_DATA_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | NSDUHandle | indicates the transaction handle (that was created when the data request was issued)
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


NSDUHandle Field

NLDE_DATA_CONFIRMATION.NSDUHandle Field
[image]

indicates the transaction handle (that was created when the data request was issued)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDUHandle As Byte
C#
public byte NSDUHandle;
C++
public:
char NSDUHandle sealed ;
J#
public byte NSDUHandle
JScript
public NSDUHandle : Byte;

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NLDE_DATA_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLDE_DATA_CONFIRMATION.CMD_STATUS
C#
public NLDE_DATA_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLDE_DATA_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLDE_DATA_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLDE_DATA_CONFIRMATION.CMD_STATUS;

See Also

NLDE_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


NLDE_DATA_CONFIRMATION.CMD_STATUS Enumeration

NLDE_DATA_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLDE_DATA_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLDE_DATA_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLDE_DATA_CONFIRMATION.CMD_STATUS : char
J#
public enum NLDE_DATA_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLDE_DATA_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLDE_DATA_INDICATION Class

NLDE_DATA_INDICATION Class
See Also Example Members
[image]

This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLDE_DATA_INDICATION : IINDICATION, INETWORK
C++
ref class NLDE_DATA_INDICATION : IINDICATION, INETWORK
J#
public class NLDE_DATA_INDICATION implements IINDICATION, INETWORK
JScript
public class NLDE_DATA_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLDE_DATA_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_INDICATION Members
TI.ZPI2 Namespace


NLDE_DATA_INDICATION Members

NLDE_DATA_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is issued by the target NWK to the tester to indicate the transfer of a data PDU from the NWK layer to the local APS sub-layer entity.

The following tables list the members exposed by NLDE_DATA_INDICATION.

Public Constructors

Name | Description
NLDE_DATA_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | LinkQuality | indicates the link quality measured during reception
Public field | NSDU | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | NSDULength | indicates the length of the NSDU
Public field | SrcAddress | short address of the source device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_INDICATION | Overloaded.
Top

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace


NLDE_DATA_INDICATION Constructor

NLDE_DATA_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_INDICATION | Constructor
Public method | NLDE_DATA_INDICATION (UInt16, Byte, Byte, Byte) | Constructor

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace


NLDE_DATA_INDICATION Constructor ()

NLDE_DATA_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_INDICATION()
C++
public:
NLDE_DATA_INDICATION() sealed
J#
public NLDE_DATA_INDICATION()
JScript
public function NLDE_DATA_INDICATION()

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace
NLDE_DATA_INDICATION Constructor Overload List


NLDE_DATA_INDICATION Constructor (UInt16, Byte, Byte[], Byte)

NLDE_DATA_INDICATION Constructor (UInt16, Byte, Byte[], Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte _
)
C#
public NLDE_DATA_INDICATION(
ushort ,
byte ,
byte[] ,
byte
)
C++
public:
NLDE_DATA_INDICATION(
unsigned short ,
char ,
array<char>^ ,
char
) sealed
J#
public NLDE_DATA_INDICATION(
ushort ,
byte ,
byte[] ,
byte
)
JScript
public function NLDE_DATA_INDICATION(
: UInt16,
: Byte,
: Byte[],
: Byte
)

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace
NLDE_DATA_INDICATION Constructor Overload List


Fields

NLDE_DATA_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | LinkQuality | indicates the link quality measured during reception
Public field | NSDU | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | NSDULength | indicates the length of the NSDU
Public field | SrcAddress | short address of the source device
Top

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace


LinkQuality Field

NLDE_DATA_INDICATION.LinkQuality Field
[image]

indicates the link quality measured during reception

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace


NSDU Field

NLDE_DATA_INDICATION.NSDU Field
[image]

Dynamic array, actual network data packet which is of size indicated by NSDULength

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDU As Byte()
C#
public byte[] NSDU;
C++
public:
array<char>^ NSDU sealed ;
J#
public byte[] NSDU
JScript
public NSDU : Byte[];

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace


NSDULength Field

NLDE_DATA_INDICATION.NSDULength Field
[image]

indicates the length of the NSDU

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDULength As Byte
C#
public byte NSDULength;
C++
public:
char NSDULength sealed ;
J#
public byte NSDULength
JScript
public NSDULength : Byte;

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace


SrcAddress Field

NLDE_DATA_INDICATION.SrcAddress Field
[image]

short address of the source device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt16
C#
public ushort SrcAddress;
C++
public:
unsigned short SrcAddress sealed ;
J#
public ushort SrcAddress
JScript
public SrcAddress : UInt16;

See Also

NLDE_DATA_INDICATION Class
TI.ZPI2 Namespace


NLDE_DATA_REQUEST Class

NLDE_DATA_REQUEST Class
See Also Example Members
[image]

This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLDE_DATA_REQUEST : IREQUEST, INETWORK
C++
ref class NLDE_DATA_REQUEST : IREQUEST, INETWORK
J#
public class NLDE_DATA_REQUEST implements IREQUEST, INETWORK
JScript
public class NLDE_DATA_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLDE_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_REQUEST Members
TI.ZPI2 Namespace


NLDE_DATA_REQUEST Members

NLDE_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command enables the tester to request the transfer of data from the local APS sub-layer to a peer APS sublayer entity.

The following tables list the members exposed by NLDE_DATA_REQUEST.

Public Constructors

Name | Description
NLDE_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | short address of the destination device.
Public field | DiscoverRoute | if set to TRUE ( non-zero value ), will attempt a route discovery operation for the destination device if no route already exists.
Public field | NSDU | the actual network data packet which is of size indicated by nsduLength.
Public field | NSDUHandle | the transaction handle (that was created when the data request was issued)
Public field | NSDUHandleOptions | the options applied to the transmission of this packet.
Public field | NSDULength | length of the NSDU.
Public field | RadiusCounter | determines how many hops this packet will travel in the network.
Public field | SecurityEnable | if set to FALSE (0x00), explicitly prohibits this packet from being secured.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_REQUEST | Overloaded.
Top

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


NLDE_DATA_REQUEST Constructor

NLDE_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_REQUEST | Constructor
Public method | NLDE_DATA_REQUEST (UInt16, Byte, Byte, Byte, UInt16, Byte, Byte, Byte) | Constructor

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


NLDE_DATA_REQUEST Constructor ()

NLDE_DATA_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_REQUEST()
C++
public:
NLDE_DATA_REQUEST() sealed
J#
public NLDE_DATA_REQUEST()
JScript
public function NLDE_DATA_REQUEST()

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace
NLDE_DATA_REQUEST Constructor Overload List


NLDE_DATA_REQUEST Constructor (UInt16, Byte, Byte[], Byte, UInt16, Byte, Byte, Byte)

NLDE_DATA_REQUEST Constructor (UInt16, Byte, Byte[], Byte, UInt16, Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLDE_DATA_REQUEST(
ushort ,
byte ,
byte[] ,
byte ,
ushort ,
byte ,
byte ,
byte
)
C++
public:
NLDE_DATA_REQUEST(
unsigned short ,
char ,
array<char>^ ,
char ,
unsigned short ,
char ,
char ,
char
) sealed
J#
public NLDE_DATA_REQUEST(
ushort ,
byte ,
byte[] ,
byte ,
ushort ,
byte ,
byte ,
byte
)
JScript
public function NLDE_DATA_REQUEST(
: UInt16,
: Byte,
: Byte[],
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte
)

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace
NLDE_DATA_REQUEST Constructor Overload List


Fields

NLDE_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | short address of the destination device.
Public field | DiscoverRoute | if set to TRUE ( non-zero value ), will attempt a route discovery operation for the destination device if no route already exists.
Public field | NSDU | the actual network data packet which is of size indicated by nsduLength.
Public field | NSDUHandle | the transaction handle (that was created when the data request was issued)
Public field | NSDUHandleOptions | the options applied to the transmission of this packet.
Public field | NSDULength | length of the NSDU.
Public field | RadiusCounter | determines how many hops this packet will travel in the network.
Public field | SecurityEnable | if set to FALSE (0x00), explicitly prohibits this packet from being secured.
Top

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


DestAddress Field

NLDE_DATA_REQUEST.DestAddress Field
[image]

short address of the destination device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt16
C#
public ushort DestAddress;
C++
public:
unsigned short DestAddress sealed ;
J#
public ushort DestAddress
JScript
public DestAddress : UInt16;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


DiscoverRoute Field

NLDE_DATA_REQUEST.DiscoverRoute Field
[image]

if set to TRUE ( non-zero value ), will attempt a route discovery operation for the destination device if no route already exists.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DiscoverRoute As Byte
C#
public byte DiscoverRoute;
C++
public:
char DiscoverRoute sealed ;
J#
public byte DiscoverRoute
JScript
public DiscoverRoute : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


NSDU Field

NLDE_DATA_REQUEST.NSDU Field
[image]

the actual network data packet which is of size indicated by nsduLength.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDU As Byte()
C#
public byte[] NSDU;
C++
public:
array<char>^ NSDU sealed ;
J#
public byte[] NSDU
JScript
public NSDU : Byte[];

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


NSDUHandle Field

NLDE_DATA_REQUEST.NSDUHandle Field
[image]

the transaction handle (that was created when the data request was issued)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDUHandle As Byte
C#
public byte NSDUHandle;
C++
public:
char NSDUHandle sealed ;
J#
public byte NSDUHandle
JScript
public NSDUHandle : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


NSDUHandleOptions Field

NLDE_DATA_REQUEST.NSDUHandleOptions Field
[image]

the options applied to the transmission of this packet.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDUHandleOptions As UInt16
C#
public ushort NSDUHandleOptions;
C++
public:
unsigned short NSDUHandleOptions sealed ;
J#
public ushort NSDUHandleOptions
JScript
public NSDUHandleOptions : UInt16;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


NSDULength Field

NLDE_DATA_REQUEST.NSDULength Field
[image]

length of the NSDU.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDULength As Byte
C#
public byte NSDULength;
C++
public:
char NSDULength sealed ;
J#
public byte NSDULength
JScript
public NSDULength : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


RadiusCounter Field

NLDE_DATA_REQUEST.RadiusCounter Field
[image]

determines how many hops this packet will travel in the network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RadiusCounter As Byte
C#
public byte RadiusCounter;
C++
public:
char RadiusCounter sealed ;
J#
public byte RadiusCounter
JScript
public RadiusCounter : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


SecurityEnable Field

NLDE_DATA_REQUEST.SecurityEnable Field
[image]

if set to FALSE (0x00), explicitly prohibits this packet from being secured.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityEnable As Byte
C#
public byte SecurityEnable;
C++
public:
char SecurityEnable sealed ;
J#
public byte SecurityEnable
JScript
public SecurityEnable : Byte;

See Also

NLDE_DATA_REQUEST Class
TI.ZPI2 Namespace


NLDE_DATA_RESPONSE Class

NLDE_DATA_RESPONSE Class
See Also Example Members
[image]

Response for NLDE_DATA_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_DATA_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLDE_DATA_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLDE_DATA_RESPONSE : IRESPONSE, INETWORK
J#
public class NLDE_DATA_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLDE_DATA_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLDE_DATA_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_DATA_RESPONSE Members
TI.ZPI2 Namespace


NLDE_DATA_RESPONSE Members

NLDE_DATA_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLDE_DATA_REQUEST

The following tables list the members exposed by NLDE_DATA_RESPONSE.

Public Constructors

Name | Description
NLDE_DATA_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLDE_DATA_RESPONSE | Overloaded.
Top

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI2 Namespace


NLDE_DATA_RESPONSE Constructor

NLDE_DATA_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLDE_DATA_RESPONSE | Constructor
Public method | NLDE_DATA_RESPONSE (NLDE_DATA_RESPONSE.NLDE_STATUS) |

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI2 Namespace


NLDE_DATA_RESPONSE Constructor ()

NLDE_DATA_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_DATA_RESPONSE()
C++
public:
NLDE_DATA_RESPONSE() sealed
J#
public NLDE_DATA_RESPONSE()
JScript
public function NLDE_DATA_RESPONSE()

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI2 Namespace
NLDE_DATA_RESPONSE Constructor Overload List


NLDE_DATA_RESPONSE Constructor (NLDE_DATA_RESPONSE.NLDE_STATUS)

NLDE_DATA_RESPONSE Constructor (NLDE_DATA_RESPONSE.NLDE_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLDE_DATA_RESPONSE.NLDE_STATUS _
)
C#
public NLDE_DATA_RESPONSE(
NLDE_DATA_RESPONSE.NLDE_STATUS
)
C++
public:
NLDE_DATA_RESPONSE(
NLDE_DATA_RESPONSE.NLDE_STATUS
) sealed
J#
public NLDE_DATA_RESPONSE(
NLDE_DATA_RESPONSE.NLDE_STATUS
)
JScript
public function NLDE_DATA_RESPONSE(
: NLDE_DATA_RESPONSE.NLDE_STATUS
)

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI2 Namespace
NLDE_DATA_RESPONSE Constructor Overload List


Fields

NLDE_DATA_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLDE_DATA_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLDE_DATA_RESPONSE.NLDE_STATUS
C#
public NLDE_DATA_RESPONSE.NLDE_STATUS Status;
C++
public:
NLDE_DATA_RESPONSE.NLDE_STATUS Status sealed ;
J#
public NLDE_DATA_RESPONSE.NLDE_STATUS Status
JScript
public Status : NLDE_DATA_RESPONSE.NLDE_STATUS;

See Also

NLDE_DATA_RESPONSE Class
TI.ZPI2 Namespace


NLDE_DATA_RESPONSE.NLDE_STATUS Enumeration

NLDE_DATA_RESPONSE.NLDE_STATUS Enumeration
[image]

Status code for NLDE response

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLDE_DATA_RESPONSE.NLDE_STATUS As Byte
C#
public enum NLDE_DATA_RESPONSE.NLDE_STATUS : byte
C++
public enum class NLDE_DATA_RESPONSE.NLDE_STATUS : char
J#
public enum NLDE_DATA_RESPONSE.NLDE_STATUS byte
JScript
public enum NLDE_DATA_RESPONSE.NLDE_STATUS :

Members

Member Name | Description
NLDE_SUCCESS | Status code for NLDE response
NLDE_INVALID_TARGET | Status code for NLDE response
NLDE_INVALID_PARAMETER | Status code for NLDE response
NLDE_BUFFER_FULL | Status code for NLDE response
NLDE_MEMORY_ERROR | Status code for NLDE response
NLDE_INVALID_NETWORK_STATE | Status code for NLDE response
NLDE_FAILURE | Status code for NLDE response

See Also

TI.ZPI2 Namespace


NLDE_NWK_INIT Class

NLDE_NWK_INIT Class
See Also Example Members
[image]

This function will initialize the nwk with the NWK_TASKID.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLDE_NWK_INIT
Implements IREQUEST, INETWORK
C#
public class NLDE_NWK_INIT : IREQUEST, INETWORK
C++
ref class NLDE_NWK_INIT : IREQUEST, INETWORK
J#
public class NLDE_NWK_INIT implements IREQUEST, INETWORK
JScript
public class NLDE_NWK_INIT extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLDE_NWK_INIT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLDE_NWK_INIT Members
TI.ZPI2 Namespace


NLDE_NWK_INIT Members

NLDE_NWK_INIT Members
See Also Example Constructors Methods
[image]

This function will initialize the nwk with the NWK_TASKID.

The following tables list the members exposed by NLDE_NWK_INIT.

Public Constructors

 | Name | Description
Public method | NLDE_NWK_INIT | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NLDE_NWK_INIT Class
TI.ZPI2 Namespace


NLDE_NWK_INIT Constructor

NLDE_NWK_INIT Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLDE_NWK_INIT()
C++
public:
NLDE_NWK_INIT() sealed
J#
public NLDE_NWK_INIT()
JScript
public function NLDE_NWK_INIT()

See Also

NLDE_NWK_INIT Class
TI.ZPI2 Namespace


NLME_DIRECTJOIN_REQUEST Class

NLME_DIRECTJOIN_REQUEST Class
See Also Example Members
[image]

NLME direct join request used by tester

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_DIRECTJOIN_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_DIRECTJOIN_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_DIRECTJOIN_REQUEST : IREQUEST, INETWORK
J#
public class NLME_DIRECTJOIN_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_DIRECTJOIN_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_DIRECTJOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_DIRECTJOIN_REQUEST Members
TI.ZPI2 Namespace


NLME_DIRECTJOIN_REQUEST Members

NLME_DIRECTJOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME direct join request used by tester

The following tables list the members exposed by NLME_DIRECTJOIN_REQUEST.

Public Constructors

Name | Description
NLME_DIRECTJOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | Extended address
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_DIRECTJOIN_REQUEST | Overloaded.
Top

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_DIRECTJOIN_REQUEST Constructor

NLME_DIRECTJOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_DIRECTJOIN_REQUEST | Constructor
Public method | NLME_DIRECTJOIN_REQUEST (UInt64, NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO) |

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_DIRECTJOIN_REQUEST Constructor ()

NLME_DIRECTJOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_DIRECTJOIN_REQUEST()
C++
public:
NLME_DIRECTJOIN_REQUEST() sealed
J#
public NLME_DIRECTJOIN_REQUEST()
JScript
public function NLME_DIRECTJOIN_REQUEST()

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI2 Namespace
NLME_DIRECTJOIN_REQUEST Constructor Overload List


NLME_DIRECTJOIN_REQUEST Constructor (UInt64, NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO)

NLME_DIRECTJOIN_REQUEST Constructor (UInt64, NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO _
)
C#
public NLME_DIRECTJOIN_REQUEST(
ulong ,
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
)
C++
public:
NLME_DIRECTJOIN_REQUEST(
unsigned __int64 ,
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
) sealed
J#
public NLME_DIRECTJOIN_REQUEST(
ulong ,
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
)
JScript
public function NLME_DIRECTJOIN_REQUEST(
: UInt64,
: NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
)

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI2 Namespace
NLME_DIRECTJOIN_REQUEST Constructor Overload List


Fields

NLME_DIRECTJOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | Extended address
Top

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI2 Namespace


CapabilityInfo Field

NLME_DIRECTJOIN_REQUEST.CapabilityInfo Field
[image]

bitmap which specifies the operational capabilities of the joining device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInfo As NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
C#
public NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO CapabilityInfo;
C++
public:
NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO CapabilityInfo sealed ;
J#
public NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO CapabilityInfo
JScript
public CapabilityInfo : NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO;

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI2 Namespace


ExtendedAddress Field

NLME_DIRECTJOIN_REQUEST.ExtendedAddress Field
[image]

Extended address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedAddress As UInt64
C#
public ulong ExtendedAddress;
C++
public:
unsigned __int64 ExtendedAddress sealed ;
J#
public ulong ExtendedAddress
JScript
public ExtendedAddress : UInt64;

See Also

NLME_DIRECTJOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO Enumeration

NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO byte
JScript
public enum NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI2 Namespace


NLME_DIRECTJOIN_RESPONSE Class

NLME_DIRECTJOIN_RESPONSE Class
See Also Example Members
[image]

Response for NLME_DIRECTJOIN_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_DIRECTJOIN_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_DIRECTJOIN_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_DIRECTJOIN_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_DIRECTJOIN_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_DIRECTJOIN_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_DIRECTJOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_DIRECTJOIN_RESPONSE Members
TI.ZPI2 Namespace


NLME_DIRECTJOIN_RESPONSE Members

NLME_DIRECTJOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_DIRECTJOIN_REQUEST

The following tables list the members exposed by NLME_DIRECTJOIN_RESPONSE.

Public Constructors

Name | Description
NLME_DIRECTJOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_DIRECTJOIN_RESPONSE | Overloaded.
Top

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_DIRECTJOIN_RESPONSE Constructor

NLME_DIRECTJOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_DIRECTJOIN_RESPONSE | Constructor
Public method | NLME_DIRECTJOIN_RESPONSE (NLME_DIRECTJOIN_RESPONSE.CMD_STATUS) |

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_DIRECTJOIN_RESPONSE Constructor ()

NLME_DIRECTJOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_DIRECTJOIN_RESPONSE()
C++
public:
NLME_DIRECTJOIN_RESPONSE() sealed
J#
public NLME_DIRECTJOIN_RESPONSE()
JScript
public function NLME_DIRECTJOIN_RESPONSE()

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI2 Namespace
NLME_DIRECTJOIN_RESPONSE Constructor Overload List


NLME_DIRECTJOIN_RESPONSE Constructor (NLME_DIRECTJOIN_RESPONSE.CMD_STATUS)

NLME_DIRECTJOIN_RESPONSE Constructor (NLME_DIRECTJOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_DIRECTJOIN_RESPONSE.CMD_STATUS _
)
C#
public NLME_DIRECTJOIN_RESPONSE(
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
)
C++
public:
NLME_DIRECTJOIN_RESPONSE(
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_DIRECTJOIN_RESPONSE(
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
)
JScript
public function NLME_DIRECTJOIN_RESPONSE(
: NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
)

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI2 Namespace
NLME_DIRECTJOIN_RESPONSE Constructor Overload List


Fields

NLME_DIRECTJOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_DIRECTJOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
C#
public NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_DIRECTJOIN_RESPONSE.CMD_STATUS;

See Also

NLME_DIRECTJOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Enumeration

NLME_DIRECTJOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_DIRECTJOIN_RESPONSE.CMD_STATUS : char
J#
public enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_DIRECTJOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_GET_REQUEST Class

NLME_GET_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_GET_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_GET_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_GET_REQUEST : IREQUEST, INETWORK
J#
public class NLME_GET_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_GET_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_GET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_GET_REQUEST Members
TI.ZPI2 Namespace


NLME_GET_REQUEST Members

NLME_GET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to read the value of an attribute from the NWK information base (NIB).

The following tables list the members exposed by NLME_GET_REQUEST.

Public Constructors

Name | Description
NLME_GET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Index | used to index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | Value | contains the data value
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_GET_REQUEST | Overloaded.
Top

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace


NLME_GET_REQUEST Constructor

NLME_GET_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_GET_REQUEST | Constructor
Public method | NLME_GET_REQUEST (NLME_GET_REQUEST.NIB_ATTR, UInt16, UInt16) |

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace


NLME_GET_REQUEST Constructor ()

NLME_GET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_GET_REQUEST()
C++
public:
NLME_GET_REQUEST() sealed
J#
public NLME_GET_REQUEST()
JScript
public function NLME_GET_REQUEST()

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace
NLME_GET_REQUEST Constructor Overload List


NLME_GET_REQUEST Constructor (NLME_GET_REQUEST.NIB_ATTR, UInt16, UInt16)

NLME_GET_REQUEST Constructor (NLME_GET_REQUEST.NIB_ATTR, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_GET_REQUEST.NIB_ATTR, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public NLME_GET_REQUEST(
NLME_GET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
C++
public:
NLME_GET_REQUEST(
NLME_GET_REQUEST.NIB_ATTR ,
unsigned short ,
unsigned short
) sealed
J#
public NLME_GET_REQUEST(
NLME_GET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
JScript
public function NLME_GET_REQUEST(
: NLME_GET_REQUEST.NIB_ATTR,
: UInt16,
: UInt16
)

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace
NLME_GET_REQUEST Constructor Overload List


Fields

NLME_GET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Index | used to index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | Value | contains the data value
Top

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace


Index Field

NLME_GET_REQUEST.Index Field
[image]

used to index into table NIB items

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index As UInt16
C#
public ushort Index;
C++
public:
unsigned short Index sealed ;
J#
public ushort Index
JScript
public Index : UInt16;

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace


NIBAttribute Field

NLME_GET_REQUEST.NIBAttribute Field
[image]

identifies the intended attribute of the NIB

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NIBAttribute As NLME_GET_REQUEST.NIB_ATTR
C#
public NLME_GET_REQUEST.NIB_ATTR NIBAttribute;
C++
public:
NLME_GET_REQUEST.NIB_ATTR NIBAttribute sealed ;
J#
public NLME_GET_REQUEST.NIB_ATTR NIBAttribute
JScript
public NIBAttribute : NLME_GET_REQUEST.NIB_ATTR;

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace


Value Field

NLME_GET_REQUEST.Value Field
[image]

contains the data value

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As UInt16
C#
public ushort Value;
C++
public:
unsigned short Value sealed ;
J#
public ushort Value
JScript
public Value : UInt16;

See Also

NLME_GET_REQUEST Class
TI.ZPI2 Namespace


NLME_GET_REQUEST.NIB_ATTR Enumeration

NLME_GET_REQUEST.NIB_ATTR Enumeration
[image]

Network layer information base attributes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_GET_REQUEST.NIB_ATTR As Byte
C#
public enum NLME_GET_REQUEST.NIB_ATTR : byte
C++
public enum class NLME_GET_REQUEST.NIB_ATTR : char
J#
public enum NLME_GET_REQUEST.NIB_ATTR byte
JScript
public enum NLME_GET_REQUEST.NIB_ATTR :

Members

Member Name | Description
NWK_BCSN | Network layer information base attributes
NWK_PASSIVE_ACK_TIMEOUT | Network layer information base attributes
NWK_MAX_BROADCAST_RETRIES | Network layer information base attributes
NWK_MAX_CHILDREN | Network layer information base attributes
NWK_MAX_DEPTH | Network layer information base attributes
NWK_MAX_ROUTERS | Network layer information base attributes
NWK_NEIGHBOR_TABLE | Network layer information base attributes
NWK_BROADCAST_DELIVERY_TIME | Network layer information base attributes
NWK_REPORT_CONSTANT_COST | Network layer information base attributes
NWK_ROUTE_DISCOVERY_RETRIES_PERMITTED | Network layer information base attributes
NWK_ROUTE_TABLE | Network layer information base attributes
NWK_SECURE_ALL_FRAMES | Network layer information base attributes
NWK_SECURITY_LEVEL | Network layer information base attributes
NWK_SYM_LINK | Network layer information base attributes
NWK_CAP_INFO | Network layer information base attributes

See Also

TI.ZPI2 Namespace


NLME_GET_RESPONSE Class

NLME_GET_RESPONSE Class
See Also Example Members
[image]

Response for NLME_GET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_GET_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_GET_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_GET_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_GET_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_GET_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_GET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_GET_RESPONSE Members
TI.ZPI2 Namespace


NLME_GET_RESPONSE Members

NLME_GET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_GET_REQUEST

The following tables list the members exposed by NLME_GET_RESPONSE.

Public Constructors

Name | Description
NLME_GET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_GET_RESPONSE | Overloaded.
Top

See Also

NLME_GET_RESPONSE Class
TI.ZPI2 Namespace


NLME_GET_RESPONSE Constructor

NLME_GET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_GET_RESPONSE | Constructor
Public method | NLME_GET_RESPONSE (NLME_GET_RESPONSE.CMD_STATUS) |

See Also

NLME_GET_RESPONSE Class
TI.ZPI2 Namespace


NLME_GET_RESPONSE Constructor ()

NLME_GET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_GET_RESPONSE()
C++
public:
NLME_GET_RESPONSE() sealed
J#
public NLME_GET_RESPONSE()
JScript
public function NLME_GET_RESPONSE()

See Also

NLME_GET_RESPONSE Class
TI.ZPI2 Namespace
NLME_GET_RESPONSE Constructor Overload List


NLME_GET_RESPONSE Constructor (NLME_GET_RESPONSE.CMD_STATUS)

NLME_GET_RESPONSE Constructor (NLME_GET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_GET_RESPONSE.CMD_STATUS _
)
C#
public NLME_GET_RESPONSE(
NLME_GET_RESPONSE.CMD_STATUS
)
C++
public:
NLME_GET_RESPONSE(
NLME_GET_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_GET_RESPONSE(
NLME_GET_RESPONSE.CMD_STATUS
)
JScript
public function NLME_GET_RESPONSE(
: NLME_GET_RESPONSE.CMD_STATUS
)

See Also

NLME_GET_RESPONSE Class
TI.ZPI2 Namespace
NLME_GET_RESPONSE Constructor Overload List


Fields

NLME_GET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_GET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_GET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_GET_RESPONSE.CMD_STATUS
C#
public NLME_GET_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_GET_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_GET_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_GET_RESPONSE.CMD_STATUS;

See Also

NLME_GET_RESPONSE Class
TI.ZPI2 Namespace


NLME_GET_RESPONSE.CMD_STATUS Enumeration

NLME_GET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_GET_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_GET_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_GET_RESPONSE.CMD_STATUS : char
J#
public enum NLME_GET_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_GET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_JOIN_CONFIRMATION Class

NLME_JOIN_CONFIRMATION Class
See Also Example Members
[image]

This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_JOIN_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_JOIN_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_JOIN_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_JOIN_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_JOIN_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_CONFIRMATION Members
TI.ZPI2 Namespace


NLME_JOIN_CONFIRMATION Members

NLME_JOIN_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is issued by the target NWK (to tester) to notify the next higher layer of the results of its request to join itself or another device to a network.

The following tables list the members exposed by NLME_JOIN_CONFIRMATION.

Public Constructors

Name | Description
NLME_JOIN_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | PanId | indicates the PAN identifer of the network to which the device has joined
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_CONFIRMATION | Overloaded.
Top

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_JOIN_CONFIRMATION Constructor

NLME_JOIN_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_CONFIRMATION | Constructor
Public method | NLME_JOIN_CONFIRMATION (UInt64, UInt16, NLME_JOIN_CONFIRMATION.CMD_STATUS) |

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_JOIN_CONFIRMATION Constructor ()

NLME_JOIN_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_CONFIRMATION()
C++
public:
NLME_JOIN_CONFIRMATION() sealed
J#
public NLME_JOIN_CONFIRMATION()
JScript
public function NLME_JOIN_CONFIRMATION()

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_JOIN_CONFIRMATION Constructor Overload List


NLME_JOIN_CONFIRMATION Constructor (UInt64, UInt16, NLME_JOIN_CONFIRMATION.CMD_STATUS)

NLME_JOIN_CONFIRMATION Constructor (UInt64, UInt16, NLME_JOIN_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As NLME_JOIN_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_JOIN_CONFIRMATION(
ulong ,
ushort ,
NLME_JOIN_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_JOIN_CONFIRMATION(
unsigned __int64 ,
unsigned short ,
NLME_JOIN_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_JOIN_CONFIRMATION(
ulong ,
ushort ,
NLME_JOIN_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_JOIN_CONFIRMATION(
: UInt64,
: UInt16,
: NLME_JOIN_CONFIRMATION.CMD_STATUS
)

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_JOIN_CONFIRMATION Constructor Overload List


Fields

NLME_JOIN_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | PanId | indicates the PAN identifer of the network to which the device has joined
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace


DeviceAddress Field

NLME_JOIN_CONFIRMATION.DeviceAddress Field
[image]

specifies the IEEE extended address of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace


PanId Field

NLME_JOIN_CONFIRMATION.PanId Field
[image]

indicates the PAN identifer of the network to which the device has joined

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NLME_JOIN_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_JOIN_CONFIRMATION.CMD_STATUS
C#
public NLME_JOIN_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_JOIN_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_JOIN_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_JOIN_CONFIRMATION.CMD_STATUS;

See Also

NLME_JOIN_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_JOIN_CONFIRMATION.CMD_STATUS Enumeration

NLME_JOIN_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_JOIN_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_JOIN_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_JOIN_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_JOIN_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_JOIN_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_JOIN_INDICATION Class

NLME_JOIN_INDICATION Class
See Also Example Members
[image]

This message is sent by the target to notify the next higher layer of a remote join request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLME_JOIN_INDICATION : IINDICATION, INETWORK
C++
ref class NLME_JOIN_INDICATION : IINDICATION, INETWORK
J#
public class NLME_JOIN_INDICATION implements IINDICATION, INETWORK
JScript
public class NLME_JOIN_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_JOIN_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_INDICATION Members
TI.ZPI2 Namespace


NLME_JOIN_INDICATION Members

NLME_JOIN_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to notify the next higher layer of a remote join request.

The following tables list the members exposed by NLME_JOIN_INDICATION.

Public Constructors

Name | Description
NLME_JOIN_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInformation | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | specifies the IEEE extended address of the same entity
Public field | ShortAddress | indicates the network address of an entity that has been added to the network
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_INDICATION | Overloaded.
Top

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace


NLME_JOIN_INDICATION Constructor

NLME_JOIN_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_INDICATION | Constructor
Public method | NLME_JOIN_INDICATION (UInt16, UInt64, NLME_JOIN_INDICATION.CAPABILITY_INFO) |

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace


NLME_JOIN_INDICATION Constructor ()

NLME_JOIN_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_INDICATION()
C++
public:
NLME_JOIN_INDICATION() sealed
J#
public NLME_JOIN_INDICATION()
JScript
public function NLME_JOIN_INDICATION()

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace
NLME_JOIN_INDICATION Constructor Overload List


NLME_JOIN_INDICATION Constructor (UInt16, UInt64, NLME_JOIN_INDICATION.CAPABILITY_INFO)

NLME_JOIN_INDICATION Constructor (UInt16, UInt64, NLME_JOIN_INDICATION.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As NLME_JOIN_INDICATION.CAPABILITY_INFO _
)
C#
public NLME_JOIN_INDICATION(
ushort ,
ulong ,
NLME_JOIN_INDICATION.CAPABILITY_INFO
)
C++
public:
NLME_JOIN_INDICATION(
unsigned short ,
unsigned __int64 ,
NLME_JOIN_INDICATION.CAPABILITY_INFO
) sealed
J#
public NLME_JOIN_INDICATION(
ushort ,
ulong ,
NLME_JOIN_INDICATION.CAPABILITY_INFO
)
JScript
public function NLME_JOIN_INDICATION(
: UInt16,
: UInt64,
: NLME_JOIN_INDICATION.CAPABILITY_INFO
)

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace
NLME_JOIN_INDICATION Constructor Overload List


Fields

NLME_JOIN_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInformation | bitmap which specifies the operational capabilities of the joining device
Public field | ExtendedAddress | specifies the IEEE extended address of the same entity
Public field | ShortAddress | indicates the network address of an entity that has been added to the network
Top

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace


CapabilityInformation Field

NLME_JOIN_INDICATION.CapabilityInformation Field
[image]

bitmap which specifies the operational capabilities of the joining device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInformation As NLME_JOIN_INDICATION.CAPABILITY_INFO
C#
public NLME_JOIN_INDICATION.CAPABILITY_INFO CapabilityInformation;
C++
public:
NLME_JOIN_INDICATION.CAPABILITY_INFO CapabilityInformation sealed ;
J#
public NLME_JOIN_INDICATION.CAPABILITY_INFO CapabilityInformation
JScript
public CapabilityInformation : NLME_JOIN_INDICATION.CAPABILITY_INFO;

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace


ExtendedAddress Field

NLME_JOIN_INDICATION.ExtendedAddress Field
[image]

specifies the IEEE extended address of the same entity

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedAddress As UInt64
C#
public ulong ExtendedAddress;
C++
public:
unsigned __int64 ExtendedAddress sealed ;
J#
public ulong ExtendedAddress
JScript
public ExtendedAddress : UInt64;

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace


ShortAddress Field

NLME_JOIN_INDICATION.ShortAddress Field
[image]

indicates the network address of an entity that has been added to the network

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ShortAddress As UInt16
C#
public ushort ShortAddress;
C++
public:
unsigned short ShortAddress sealed ;
J#
public ushort ShortAddress
JScript
public ShortAddress : UInt16;

See Also

NLME_JOIN_INDICATION Class
TI.ZPI2 Namespace


NLME_JOIN_INDICATION.CAPABILITY_INFO Enumeration

NLME_JOIN_INDICATION.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_JOIN_INDICATION.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum NLME_JOIN_INDICATION.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class NLME_JOIN_INDICATION.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum NLME_JOIN_INDICATION.CAPABILITY_INFO byte
JScript
public enum NLME_JOIN_INDICATION.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI2 Namespace


NLME_JOIN_REQUEST Class

NLME_JOIN_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_JOIN_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_JOIN_REQUEST : IREQUEST, INETWORK
J#
public class NLME_JOIN_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_JOIN_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_JOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_REQUEST Members
TI.ZPI2 Namespace


NLME_JOIN_REQUEST Members

NLME_JOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to join the device itself or another device to a network.

The following tables list the members exposed by NLME_JOIN_REQUEST.

Public Constructors

Name | Description
NLME_JOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | Channel | specifies the channel of the intended device
Public field | PanId | indicates the short address of the intended device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_REQUEST | Overloaded.
Top

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_JOIN_REQUEST Constructor

NLME_JOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_REQUEST | Constructor
Public method | NLME_JOIN_REQUEST (UInt16, Byte, NLME_JOIN_REQUEST.CAPABILITY_INFO) |

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_JOIN_REQUEST Constructor ()

NLME_JOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_REQUEST()
C++
public:
NLME_JOIN_REQUEST() sealed
J#
public NLME_JOIN_REQUEST()
JScript
public function NLME_JOIN_REQUEST()

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace
NLME_JOIN_REQUEST Constructor Overload List


NLME_JOIN_REQUEST Constructor (UInt16, Byte, NLME_JOIN_REQUEST.CAPABILITY_INFO)

NLME_JOIN_REQUEST Constructor (UInt16, Byte, NLME_JOIN_REQUEST.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As NLME_JOIN_REQUEST.CAPABILITY_INFO _
)
C#
public NLME_JOIN_REQUEST(
ushort ,
byte ,
NLME_JOIN_REQUEST.CAPABILITY_INFO
)
C++
public:
NLME_JOIN_REQUEST(
unsigned short ,
char ,
NLME_JOIN_REQUEST.CAPABILITY_INFO
) sealed
J#
public NLME_JOIN_REQUEST(
ushort ,
byte ,
NLME_JOIN_REQUEST.CAPABILITY_INFO
)
JScript
public function NLME_JOIN_REQUEST(
: UInt16,
: Byte,
: NLME_JOIN_REQUEST.CAPABILITY_INFO
)

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace
NLME_JOIN_REQUEST Constructor Overload List


Fields

NLME_JOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInfo | bitmap which specifies the operational capabilities of the joining device
Public field | Channel | specifies the channel of the intended device
Public field | PanId | indicates the short address of the intended device
Top

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace


CapabilityInfo Field

NLME_JOIN_REQUEST.CapabilityInfo Field
[image]

bitmap which specifies the operational capabilities of the joining device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInfo As NLME_JOIN_REQUEST.CAPABILITY_INFO
C#
public NLME_JOIN_REQUEST.CAPABILITY_INFO CapabilityInfo;
C++
public:
NLME_JOIN_REQUEST.CAPABILITY_INFO CapabilityInfo sealed ;
J#
public NLME_JOIN_REQUEST.CAPABILITY_INFO CapabilityInfo
JScript
public CapabilityInfo : NLME_JOIN_REQUEST.CAPABILITY_INFO;

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace


Channel Field

NLME_JOIN_REQUEST.Channel Field
[image]

specifies the channel of the intended device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Channel As Byte
C#
public byte Channel;
C++
public:
char Channel sealed ;
J#
public byte Channel
JScript
public Channel : Byte;

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace


PanId Field

NLME_JOIN_REQUEST.PanId Field
[image]

indicates the short address of the intended device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

NLME_JOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_JOIN_REQUEST.CAPABILITY_INFO Enumeration

NLME_JOIN_REQUEST.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_JOIN_REQUEST.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum NLME_JOIN_REQUEST.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class NLME_JOIN_REQUEST.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum NLME_JOIN_REQUEST.CAPABILITY_INFO byte
JScript
public enum NLME_JOIN_REQUEST.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI2 Namespace


NLME_JOIN_RESPONSE Class

NLME_JOIN_RESPONSE Class
See Also Example Members
[image]

Response for NLME_JOIN_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_JOIN_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_JOIN_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_JOIN_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_JOIN_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_JOIN_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_JOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_JOIN_RESPONSE Members
TI.ZPI2 Namespace


NLME_JOIN_RESPONSE Members

NLME_JOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_JOIN_REQUEST

The following tables list the members exposed by NLME_JOIN_RESPONSE.

Public Constructors

Name | Description
NLME_JOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_JOIN_RESPONSE | Overloaded.
Top

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_JOIN_RESPONSE Constructor

NLME_JOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_JOIN_RESPONSE | Constructor
Public method | NLME_JOIN_RESPONSE (NLME_JOIN_RESPONSE.CMD_STATUS) |

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_JOIN_RESPONSE Constructor ()

NLME_JOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_JOIN_RESPONSE()
C++
public:
NLME_JOIN_RESPONSE() sealed
J#
public NLME_JOIN_RESPONSE()
JScript
public function NLME_JOIN_RESPONSE()

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI2 Namespace
NLME_JOIN_RESPONSE Constructor Overload List


NLME_JOIN_RESPONSE Constructor (NLME_JOIN_RESPONSE.CMD_STATUS)

NLME_JOIN_RESPONSE Constructor (NLME_JOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_JOIN_RESPONSE.CMD_STATUS _
)
C#
public NLME_JOIN_RESPONSE(
NLME_JOIN_RESPONSE.CMD_STATUS
)
C++
public:
NLME_JOIN_RESPONSE(
NLME_JOIN_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_JOIN_RESPONSE(
NLME_JOIN_RESPONSE.CMD_STATUS
)
JScript
public function NLME_JOIN_RESPONSE(
: NLME_JOIN_RESPONSE.CMD_STATUS
)

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI2 Namespace
NLME_JOIN_RESPONSE Constructor Overload List


Fields

NLME_JOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_JOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_JOIN_RESPONSE.CMD_STATUS
C#
public NLME_JOIN_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_JOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_JOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_JOIN_RESPONSE.CMD_STATUS;

See Also

NLME_JOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_JOIN_RESPONSE.CMD_STATUS Enumeration

NLME_JOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_JOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_JOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_JOIN_RESPONSE.CMD_STATUS : char
J#
public enum NLME_JOIN_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_JOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_LEAVE_CONFIRMATION Class

NLME_LEAVE_CONFIRMATION Class
See Also Example Members
[image]

This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_LEAVE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_LEAVE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_LEAVE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_LEAVE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_LEAVE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_CONFIRMATION Members
TI.ZPI2 Namespace


NLME_LEAVE_CONFIRMATION Members

NLME_LEAVE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate to the next higher layer that the device itself or another device is leaving the network.

The following tables list the members exposed by NLME_LEAVE_CONFIRMATION.

Public Constructors

Name | Description
NLME_LEAVE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_CONFIRMATION | Overloaded.
Top

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_LEAVE_CONFIRMATION Constructor

NLME_LEAVE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_CONFIRMATION | Constructor
Public method | NLME_LEAVE_CONFIRMATION (UInt64, NLME_LEAVE_CONFIRMATION.CMD_STATUS) |

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_LEAVE_CONFIRMATION Constructor ()

NLME_LEAVE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_CONFIRMATION()
C++
public:
NLME_LEAVE_CONFIRMATION() sealed
J#
public NLME_LEAVE_CONFIRMATION()
JScript
public function NLME_LEAVE_CONFIRMATION()

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_LEAVE_CONFIRMATION Constructor Overload List


NLME_LEAVE_CONFIRMATION Constructor (UInt64, NLME_LEAVE_CONFIRMATION.CMD_STATUS)

NLME_LEAVE_CONFIRMATION Constructor (UInt64, NLME_LEAVE_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_LEAVE_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_LEAVE_CONFIRMATION(
ulong ,
NLME_LEAVE_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_LEAVE_CONFIRMATION(
unsigned __int64 ,
NLME_LEAVE_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_LEAVE_CONFIRMATION(
ulong ,
NLME_LEAVE_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_LEAVE_CONFIRMATION(
: UInt64,
: NLME_LEAVE_CONFIRMATION.CMD_STATUS
)

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_LEAVE_CONFIRMATION Constructor Overload List


Fields

NLME_LEAVE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI2 Namespace


DeviceAddress Field

NLME_LEAVE_CONFIRMATION.DeviceAddress Field
[image]

specifies the IEEE extended address of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NLME_LEAVE_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_LEAVE_CONFIRMATION.CMD_STATUS
C#
public NLME_LEAVE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_LEAVE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_LEAVE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_LEAVE_CONFIRMATION.CMD_STATUS;

See Also

NLME_LEAVE_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_LEAVE_CONFIRMATION.CMD_STATUS Enumeration

NLME_LEAVE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_LEAVE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_LEAVE_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_LEAVE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_LEAVE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_LEAVE_INDICATION Class

NLME_LEAVE_INDICATION Class
See Also Example Members
[image]

This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLME_LEAVE_INDICATION : IINDICATION, INETWORK
C++
ref class NLME_LEAVE_INDICATION : IINDICATION, INETWORK
J#
public class NLME_LEAVE_INDICATION implements IINDICATION, INETWORK
JScript
public class NLME_LEAVE_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_LEAVE_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_INDICATION Members
TI.ZPI2 Namespace


NLME_LEAVE_INDICATION Members

NLME_LEAVE_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate a remote leave request to the next higher layer of a coordinator

The following tables list the members exposed by NLME_LEAVE_INDICATION.

Public Constructors

Name | Description
NLME_LEAVE_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_INDICATION | Overloaded.
Top

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI2 Namespace


NLME_LEAVE_INDICATION Constructor

NLME_LEAVE_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_INDICATION | Constructor
Public method | NLME_LEAVE_INDICATION (UInt64, NLME_LEAVE_INDICATION.CMD_STATUS) |

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI2 Namespace


NLME_LEAVE_INDICATION Constructor ()

NLME_LEAVE_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_INDICATION()
C++
public:
NLME_LEAVE_INDICATION() sealed
J#
public NLME_LEAVE_INDICATION()
JScript
public function NLME_LEAVE_INDICATION()

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI2 Namespace
NLME_LEAVE_INDICATION Constructor Overload List


NLME_LEAVE_INDICATION Constructor (UInt64, NLME_LEAVE_INDICATION.CMD_STATUS)

NLME_LEAVE_INDICATION Constructor (UInt64, NLME_LEAVE_INDICATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_LEAVE_INDICATION.CMD_STATUS _
)
C#
public NLME_LEAVE_INDICATION(
ulong ,
NLME_LEAVE_INDICATION.CMD_STATUS
)
C++
public:
NLME_LEAVE_INDICATION(
unsigned __int64 ,
NLME_LEAVE_INDICATION.CMD_STATUS
) sealed
J#
public NLME_LEAVE_INDICATION(
ulong ,
NLME_LEAVE_INDICATION.CMD_STATUS
)
JScript
public function NLME_LEAVE_INDICATION(
: UInt64,
: NLME_LEAVE_INDICATION.CMD_STATUS
)

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI2 Namespace
NLME_LEAVE_INDICATION Constructor Overload List


Fields

NLME_LEAVE_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | specifies the IEEE extended address of the device
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI2 Namespace


DeviceAddress Field

NLME_LEAVE_INDICATION.DeviceAddress Field
[image]

specifies the IEEE extended address of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI2 Namespace


Status Field

NLME_LEAVE_INDICATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_LEAVE_INDICATION.CMD_STATUS
C#
public NLME_LEAVE_INDICATION.CMD_STATUS Status;
C++
public:
NLME_LEAVE_INDICATION.CMD_STATUS Status sealed ;
J#
public NLME_LEAVE_INDICATION.CMD_STATUS Status
JScript
public Status : NLME_LEAVE_INDICATION.CMD_STATUS;

See Also

NLME_LEAVE_INDICATION Class
TI.ZPI2 Namespace


NLME_LEAVE_INDICATION.CMD_STATUS Enumeration

NLME_LEAVE_INDICATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_INDICATION.CMD_STATUS As Byte
C#
public enum NLME_LEAVE_INDICATION.CMD_STATUS : byte
C++
public enum class NLME_LEAVE_INDICATION.CMD_STATUS : char
J#
public enum NLME_LEAVE_INDICATION.CMD_STATUS byte
JScript
public enum NLME_LEAVE_INDICATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_LEAVE_REQUEST Class

NLME_LEAVE_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_LEAVE_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_LEAVE_REQUEST : IREQUEST, INETWORK
J#
public class NLME_LEAVE_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_LEAVE_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_LEAVE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_REQUEST Members
TI.ZPI2 Namespace


NLME_LEAVE_REQUEST Members

NLME_LEAVE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the device itself or another device leave the network.

The following tables list the members exposed by NLME_LEAVE_REQUEST.

Public Constructors

Name | Description
NLME_LEAVE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | indicates the IEEE extended address of the intended device
Public field | Reassociate | indicates whether the device, specified by the DeviceAddress, should reassociate after it leaves
Public field | RemoveChildren | indicates whether the device, specified by the DeviceAddress, should remove it's children
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_REQUEST | Overloaded.
Top

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace


NLME_LEAVE_REQUEST Constructor

NLME_LEAVE_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_REQUEST | Constructor
Public method | NLME_LEAVE_REQUEST (UInt64, NLME_LEAVE_REQUEST.BOOLEAN, NLME_LEAVE_REQUEST.BOOLEAN) |

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace


NLME_LEAVE_REQUEST Constructor ()

NLME_LEAVE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_REQUEST()
C++
public:
NLME_LEAVE_REQUEST() sealed
J#
public NLME_LEAVE_REQUEST()
JScript
public function NLME_LEAVE_REQUEST()

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace
NLME_LEAVE_REQUEST Constructor Overload List


NLME_LEAVE_REQUEST Constructor (UInt64, NLME_LEAVE_REQUEST.BOOLEAN, NLME_LEAVE_REQUEST.BOOLEAN)

NLME_LEAVE_REQUEST Constructor (UInt64, NLME_LEAVE_REQUEST.BOOLEAN, NLME_LEAVE_REQUEST.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NLME_LEAVE_REQUEST.BOOLEAN, _
ByVal As NLME_LEAVE_REQUEST.BOOLEAN _
)
C#
public NLME_LEAVE_REQUEST(
ulong ,
NLME_LEAVE_REQUEST.BOOLEAN ,
NLME_LEAVE_REQUEST.BOOLEAN
)
C++
public:
NLME_LEAVE_REQUEST(
unsigned __int64 ,
NLME_LEAVE_REQUEST.BOOLEAN ,
NLME_LEAVE_REQUEST.BOOLEAN
) sealed
J#
public NLME_LEAVE_REQUEST(
ulong ,
NLME_LEAVE_REQUEST.BOOLEAN ,
NLME_LEAVE_REQUEST.BOOLEAN
)
JScript
public function NLME_LEAVE_REQUEST(
: UInt64,
: NLME_LEAVE_REQUEST.BOOLEAN,
: NLME_LEAVE_REQUEST.BOOLEAN
)

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace
NLME_LEAVE_REQUEST Constructor Overload List


Fields

NLME_LEAVE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | indicates the IEEE extended address of the intended device
Public field | Reassociate | indicates whether the device, specified by the DeviceAddress, should reassociate after it leaves
Public field | RemoveChildren | indicates whether the device, specified by the DeviceAddress, should remove it's children
Top

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace


DeviceAddress Field

NLME_LEAVE_REQUEST.DeviceAddress Field
[image]

indicates the IEEE extended address of the intended device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace


Reassociate Field

NLME_LEAVE_REQUEST.Reassociate Field
[image]

indicates whether the device, specified by the DeviceAddress, should reassociate after it leaves

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reassociate As NLME_LEAVE_REQUEST.BOOLEAN
C#
public NLME_LEAVE_REQUEST.BOOLEAN Reassociate;
C++
public:
NLME_LEAVE_REQUEST.BOOLEAN Reassociate sealed ;
J#
public NLME_LEAVE_REQUEST.BOOLEAN Reassociate
JScript
public Reassociate : NLME_LEAVE_REQUEST.BOOLEAN;

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace


RemoveChildren Field

NLME_LEAVE_REQUEST.RemoveChildren Field
[image]

indicates whether the device, specified by the DeviceAddress, should remove it's children

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RemoveChildren As NLME_LEAVE_REQUEST.BOOLEAN
C#
public NLME_LEAVE_REQUEST.BOOLEAN RemoveChildren;
C++
public:
NLME_LEAVE_REQUEST.BOOLEAN RemoveChildren sealed ;
J#
public NLME_LEAVE_REQUEST.BOOLEAN RemoveChildren
JScript
public RemoveChildren : NLME_LEAVE_REQUEST.BOOLEAN;

See Also

NLME_LEAVE_REQUEST Class
TI.ZPI2 Namespace


NLME_LEAVE_REQUEST.BOOLEAN Enumeration

NLME_LEAVE_REQUEST.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_REQUEST.BOOLEAN As Byte
C#
public enum NLME_LEAVE_REQUEST.BOOLEAN : byte
C++
public enum class NLME_LEAVE_REQUEST.BOOLEAN : char
J#
public enum NLME_LEAVE_REQUEST.BOOLEAN byte
JScript
public enum NLME_LEAVE_REQUEST.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


NLME_LEAVE_RESPONSE Class

NLME_LEAVE_RESPONSE Class
See Also Example Members
[image]

Response for NLME_LEAVE_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_LEAVE_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_LEAVE_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_LEAVE_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_LEAVE_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_LEAVE_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_LEAVE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_LEAVE_RESPONSE Members
TI.ZPI2 Namespace


NLME_LEAVE_RESPONSE Members

NLME_LEAVE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_LEAVE_REQUEST

The following tables list the members exposed by NLME_LEAVE_RESPONSE.

Public Constructors

Name | Description
NLME_LEAVE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_LEAVE_RESPONSE | Overloaded.
Top

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI2 Namespace


NLME_LEAVE_RESPONSE Constructor

NLME_LEAVE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_LEAVE_RESPONSE | Constructor
Public method | NLME_LEAVE_RESPONSE (NLME_LEAVE_RESPONSE.CMD_STATUS) |

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI2 Namespace


NLME_LEAVE_RESPONSE Constructor ()

NLME_LEAVE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_LEAVE_RESPONSE()
C++
public:
NLME_LEAVE_RESPONSE() sealed
J#
public NLME_LEAVE_RESPONSE()
JScript
public function NLME_LEAVE_RESPONSE()

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI2 Namespace
NLME_LEAVE_RESPONSE Constructor Overload List


NLME_LEAVE_RESPONSE Constructor (NLME_LEAVE_RESPONSE.CMD_STATUS)

NLME_LEAVE_RESPONSE Constructor (NLME_LEAVE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_LEAVE_RESPONSE.CMD_STATUS _
)
C#
public NLME_LEAVE_RESPONSE(
NLME_LEAVE_RESPONSE.CMD_STATUS
)
C++
public:
NLME_LEAVE_RESPONSE(
NLME_LEAVE_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_LEAVE_RESPONSE(
NLME_LEAVE_RESPONSE.CMD_STATUS
)
JScript
public function NLME_LEAVE_RESPONSE(
: NLME_LEAVE_RESPONSE.CMD_STATUS
)

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI2 Namespace
NLME_LEAVE_RESPONSE Constructor Overload List


Fields

NLME_LEAVE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_LEAVE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_LEAVE_RESPONSE.CMD_STATUS
C#
public NLME_LEAVE_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_LEAVE_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_LEAVE_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_LEAVE_RESPONSE.CMD_STATUS;

See Also

NLME_LEAVE_RESPONSE Class
TI.ZPI2 Namespace


NLME_LEAVE_RESPONSE.CMD_STATUS Enumeration

NLME_LEAVE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_LEAVE_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_LEAVE_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_LEAVE_RESPONSE.CMD_STATUS : char
J#
public enum NLME_LEAVE_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_LEAVE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Class

NLME_NETWORK_FORMATION_CONFIRMATION Class
See Also Example Members
[image]

This message is used by the target NWK to inform the tester of the result of a previous association request command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORK_FORMATION_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_NETWORK_FORMATION_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_NETWORK_FORMATION_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_NETWORK_FORMATION_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_NETWORK_FORMATION_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_NETWORK_FORMATION_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Members
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Members

NLME_NETWORK_FORMATION_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is used by the target NWK to inform the tester of the result of a previous association request command

The following tables list the members exposed by NLME_NETWORK_FORMATION_CONFIRMATION.

Public Constructors

Name | Description
NLME_NETWORK_FORMATION_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORK_FORMATION_CONFIRMATION | Overloaded.
Top

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Constructor

NLME_NETWORK_FORMATION_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORK_FORMATION_CONFIRMATION | Constructor
Public method | NLME_NETWORK_FORMATION_CONFIRMATION (NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS) |

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION Constructor ()

NLME_NETWORK_FORMATION_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORK_FORMATION_CONFIRMATION()
C++
public:
NLME_NETWORK_FORMATION_CONFIRMATION() sealed
J#
public NLME_NETWORK_FORMATION_CONFIRMATION()
JScript
public function NLME_NETWORK_FORMATION_CONFIRMATION()

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_NETWORK_FORMATION_CONFIRMATION Constructor Overload List


NLME_NETWORK_FORMATION_CONFIRMATION Constructor (NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS)

NLME_NETWORK_FORMATION_CONFIRMATION Constructor (NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_NETWORK_FORMATION_CONFIRMATION(
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_NETWORK_FORMATION_CONFIRMATION(
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_NETWORK_FORMATION_CONFIRMATION(
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_NETWORK_FORMATION_CONFIRMATION(
: NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
)

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_NETWORK_FORMATION_CONFIRMATION Constructor Overload List


Fields

NLME_NETWORK_FORMATION_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NLME_NETWORK_FORMATION_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
C#
public NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS;

See Also

NLME_NETWORK_FORMATION_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Enumeration

NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_REQUEST Class

NLME_NETWORK_FORMATION_REQUEST Class
See Also Example Members
[image]

This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORK_FORMATION_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_NETWORK_FORMATION_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_NETWORK_FORMATION_REQUEST : IREQUEST, INETWORK
J#
public class NLME_NETWORK_FORMATION_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_NETWORK_FORMATION_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_NETWORK_FORMATION_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORK_FORMATION_REQUEST Members
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_REQUEST Members

NLME_NETWORK_FORMATION_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to request (on behalf of the next higher layer) that the device be initiated as a coordinator.

The following tables list the members exposed by NLME_NETWORK_FORMATION_REQUEST.

Public Constructors

Name | Description
NLME_NETWORK_FORMATION_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | indicates whether NLME will request that the Zigbee coordinator is started supporting battery life extension mode.
Public field | BeaconOrder | represents the beacon order type
Public field | PanId | short address of the intended device.
Public field | ScanChannels | indicates list of channels in bit map format.
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | SuperFrameOrder | specifies the length of the active portion of the superframe
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORK_FORMATION_REQUEST | Overloaded.
Top

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_REQUEST Constructor

NLME_NETWORK_FORMATION_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORK_FORMATION_REQUEST | Constructor
Public method | NLME_NETWORK_FORMATION_REQUEST (UInt16, NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, Byte, Byte) |

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_REQUEST Constructor ()

NLME_NETWORK_FORMATION_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORK_FORMATION_REQUEST()
C++
public:
NLME_NETWORK_FORMATION_REQUEST() sealed
J#
public NLME_NETWORK_FORMATION_REQUEST()
JScript
public function NLME_NETWORK_FORMATION_REQUEST()

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace
NLME_NETWORK_FORMATION_REQUEST Constructor Overload List


NLME_NETWORK_FORMATION_REQUEST Constructor (UInt16, NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, Byte, Byte)

NLME_NETWORK_FORMATION_REQUEST Constructor (UInt16, NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLME_NETWORK_FORMATION_REQUEST(
ushort ,
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
byte ,
byte
)
C++
public:
NLME_NETWORK_FORMATION_REQUEST(
unsigned short ,
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ,
char ,
char ,
char ,
char
) sealed
J#
public NLME_NETWORK_FORMATION_REQUEST(
ushort ,
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
byte ,
byte
)
JScript
public function NLME_NETWORK_FORMATION_REQUEST(
: UInt16,
: NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace
NLME_NETWORK_FORMATION_REQUEST Constructor Overload List


Fields

NLME_NETWORK_FORMATION_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | indicates whether NLME will request that the Zigbee coordinator is started supporting battery life extension mode.
Public field | BeaconOrder | represents the beacon order type
Public field | PanId | short address of the intended device.
Public field | ScanChannels | indicates list of channels in bit map format.
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | SuperFrameOrder | specifies the length of the active portion of the superframe
Top

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


BatteryLifeExtension Field

NLME_NETWORK_FORMATION_REQUEST.BatteryLifeExtension Field
[image]

indicates whether NLME will request that the Zigbee coordinator is started supporting battery life extension mode.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BatteryLifeExtension As Byte
C#
public byte BatteryLifeExtension;
C++
public:
char BatteryLifeExtension sealed ;
J#
public byte BatteryLifeExtension
JScript
public BatteryLifeExtension : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


BeaconOrder Field

NLME_NETWORK_FORMATION_REQUEST.BeaconOrder Field
[image]

represents the beacon order type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


PanId Field

NLME_NETWORK_FORMATION_REQUEST.PanId Field
[image]

short address of the intended device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


ScanChannels Field

NLME_NETWORK_FORMATION_REQUEST.ScanChannels Field
[image]

indicates list of channels in bit map format.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS
C#
public NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


ScanDuration Field

NLME_NETWORK_FORMATION_REQUEST.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


SuperFrameOrder Field

NLME_NETWORK_FORMATION_REQUEST.SuperFrameOrder Field
[image]

specifies the length of the active portion of the superframe

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameOrder As Byte
C#
public byte SuperFrameOrder;
C++
public:
char SuperFrameOrder sealed ;
J#
public byte SuperFrameOrder
JScript
public SuperFrameOrder : Byte;

See Also

NLME_NETWORK_FORMATION_REQUEST Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS Enumeration

NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_RESPONSE Class

NLME_NETWORK_FORMATION_RESPONSE Class
See Also Example Members
[image]

Response for NLME_NETWORK_FORMATION_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORK_FORMATION_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_NETWORK_FORMATION_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_NETWORK_FORMATION_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_NETWORK_FORMATION_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_NETWORK_FORMATION_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_NETWORK_FORMATION_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORK_FORMATION_RESPONSE Members
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_RESPONSE Members

NLME_NETWORK_FORMATION_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_NETWORK_FORMATION_REQUEST

The following tables list the members exposed by NLME_NETWORK_FORMATION_RESPONSE.

Public Constructors

Name | Description
NLME_NETWORK_FORMATION_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORK_FORMATION_RESPONSE | Overloaded.
Top

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_RESPONSE Constructor

NLME_NETWORK_FORMATION_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORK_FORMATION_RESPONSE | Constructor
Public method | NLME_NETWORK_FORMATION_RESPONSE (NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS) |

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_RESPONSE Constructor ()

NLME_NETWORK_FORMATION_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORK_FORMATION_RESPONSE()
C++
public:
NLME_NETWORK_FORMATION_RESPONSE() sealed
J#
public NLME_NETWORK_FORMATION_RESPONSE()
JScript
public function NLME_NETWORK_FORMATION_RESPONSE()

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI2 Namespace
NLME_NETWORK_FORMATION_RESPONSE Constructor Overload List


NLME_NETWORK_FORMATION_RESPONSE Constructor (NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS)

NLME_NETWORK_FORMATION_RESPONSE Constructor (NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS _
)
C#
public NLME_NETWORK_FORMATION_RESPONSE(
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
)
C++
public:
NLME_NETWORK_FORMATION_RESPONSE(
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
) sealed
J#
public NLME_NETWORK_FORMATION_RESPONSE(
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
)
JScript
public function NLME_NETWORK_FORMATION_RESPONSE(
: NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
)

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI2 Namespace
NLME_NETWORK_FORMATION_RESPONSE Constructor Overload List


Fields

NLME_NETWORK_FORMATION_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_NETWORK_FORMATION_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
C#
public NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Status;
C++
public:
NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Status sealed ;
J#
public NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Status
JScript
public Status : NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS;

See Also

NLME_NETWORK_FORMATION_RESPONSE Class
TI.ZPI2 Namespace


NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Enumeration

NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS Enumeration
[image]

Status code for NLME response

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS As Byte
C#
public enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS : byte
C++
public enum class NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS : char
J#
public enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS byte
JScript
public enum NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS :

Members

Member Name | Description
NLME_SUCCESS | Status code for NLME response
NLME_FAILURE | Status code for NLME response
NLME_ILLEGAL_REQUEST | Status code for NLME response
NLME_UNKNOWN_DEVICE | Status code for NLME response
NLME_STARTUP_FAILURE | Status code for NLME response
NLME_NO_SHORT_ADDRESS | Status code for NLME response
NLME_UNAVAILABLE_KEY | Status code for NLME response
NLME_FRAME_TOO_LONG | Status code for NLME response
NLME_FAILED_SECURITY_CHECK | Status code for NLME response
NLME_INVALID_PARAMETER | Status code for NLME response
NLME_UNSUPPORTED_ATTRIBUTE | Status code for NLME response
NLME_NOT_JOINED | Status code for NLME response
NLME_ALREADY_JOINED | Status code for NLME response
NLME_NOT_POSSIBLE | Status code for NLME response
NLME_TX_FAIL | Status code for NLME response
NLME_TX_ERROR | Status code for NLME response
NLME_RX_SUCCESS | Status code for NLME response
NLME_RX_FAILURE | Status code for NLME response
NLME_ALREADY_PRESENT | Status code for NLME response
NLME_NO_NETWORKS | Status code for NLME response
NLME_TABLE_FULL | Status code for NLME response

See Also

TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Class

NLME_NETWORKDISCOVERY_CONFIRMATION Class
See Also Example Members
[image]

This message is sent by the target to indicate network discovery confirmation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORKDISCOVERY_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_NETWORKDISCOVERY_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_NETWORKDISCOVERY_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_NETWORKDISCOVERY_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_NETWORKDISCOVERY_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_NETWORKDISCOVERY_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Members
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Members

NLME_NETWORKDISCOVERY_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate network discovery confirmation

The following tables list the members exposed by NLME_NETWORKDISCOVERY_CONFIRMATION.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Number | Number of networks found
Public field | PanInfo | Dynamic array, Pan Information
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Constructor

NLME_NETWORKDISCOVERY_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION | Constructor
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION (Byte, Object) | Constructor

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION Constructor ()

NLME_NETWORKDISCOVERY_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION()
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION() sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION()
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION()

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION Constructor Overload List


NLME_NETWORKDISCOVERY_CONFIRMATION Constructor (Byte, Object[])

NLME_NETWORKDISCOVERY_CONFIRMATION Constructor (Byte, Object[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Object() _
)
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION(
byte ,
object[]
)
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION(
char ,
array<Object>^
) sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION(
byte ,
object[]
)
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION(
: Byte,
: Object[]
)

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Number | Number of networks found
Public field | PanInfo | Dynamic array, Pan Information
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI2 Namespace


Number Field

NLME_NETWORKDISCOVERY_CONFIRMATION.Number Field
[image]

Number of networks found

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Number As Byte
C#
public byte Number;
C++
public:
char Number sealed ;
J#
public byte Number
JScript
public Number : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI2 Namespace


PanInfo Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfo Field
[image]

Dynamic array, Pan Information

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanInfo As Object()
C#
public object[] PanInfo;
C++
public:
array<Object>^ PanInfo sealed ;
J#
public object[] PanInfo
JScript
public PanInfo : Object[];

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
See Also Example Members
[image]

Pan Information. Used with NLME_NETWORKDISCOVERY_CONFIRMATION

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
C#
public struct NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
C++
value class NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
J#
public final class NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Members
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Members

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Pan Information. Used with NLME_NETWORKDISCOVERY_CONFIRMATION

The following tables list the members exposed by NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BeaconOrder |
Public field | DeviceCapacity |
Public field | LogicalChannel |
Public field | PanID |
Public field | RouterCapacity |
Public field | StackProfile |
Public field | SuperFrameOrder |
Public field | Version |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor
See Also Example

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass | Initializes a new instance of the NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass class.
Public method | NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass (UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte) |

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor ()

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass()
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass() sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass()
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass()

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor Overload List


NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor (UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte)

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor (UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
C++
public:
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
unsigned short ,
char ,
char ,
char ,
char ,
char ,
char ,
char
) sealed
J#
public NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
JScript
public function NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass(
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | BeaconOrder |
Public field | DeviceCapacity |
Public field | LogicalChannel |
Public field | PanID |
Public field | RouterCapacity |
Public field | StackProfile |
Public field | SuperFrameOrder |
Public field | Version |
Top

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


BeaconOrder Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.BeaconOrder Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


DeviceCapacity Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.DeviceCapacity Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceCapacity As Byte
C#
public byte DeviceCapacity;
C++
public:
char DeviceCapacity sealed ;
J#
public byte DeviceCapacity
JScript
public DeviceCapacity : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


LogicalChannel Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.LogicalChannel Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


PanID Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.PanID Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


RouterCapacity Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.RouterCapacity Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RouterCapacity As Byte
C#
public byte RouterCapacity;
C++
public:
char RouterCapacity sealed ;
J#
public byte RouterCapacity
JScript
public RouterCapacity : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


StackProfile Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.StackProfile Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StackProfile As Byte
C#
public byte StackProfile;
C++
public:
char StackProfile sealed ;
J#
public byte StackProfile
JScript
public StackProfile : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


SuperFrameOrder Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.SuperFrameOrder Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameOrder As Byte
C#
public byte SuperFrameOrder;
C++
public:
char SuperFrameOrder sealed ;
J#
public byte SuperFrameOrder
JScript
public SuperFrameOrder : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


Version Field

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass.Version Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Version As Byte
C#
public byte Version;
C++
public:
char Version sealed ;
J#
public byte Version
JScript
public Version : Byte;

See Also

NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass Structure
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_REQUEST Class

NLME_NETWORKDISCOVERY_REQUEST Class
See Also Example Members
[image]

NLME Network discovery request used by tester

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORKDISCOVERY_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_NETWORKDISCOVERY_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_NETWORKDISCOVERY_REQUEST : IREQUEST, INETWORK
J#
public class NLME_NETWORKDISCOVERY_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_NETWORKDISCOVERY_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_NETWORKDISCOVERY_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_REQUEST Members
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_REQUEST Members

NLME_NETWORKDISCOVERY_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME Network discovery request used by tester

The following tables list the members exposed by NLME_NETWORKDISCOVERY_REQUEST.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_REQUEST | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_REQUEST Constructor

NLME_NETWORKDISCOVERY_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_REQUEST | Constructor
Public method | NLME_NETWORKDISCOVERY_REQUEST (NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, Byte) |

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_REQUEST Constructor ()

NLME_NETWORKDISCOVERY_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_REQUEST()
C++
public:
NLME_NETWORKDISCOVERY_REQUEST() sealed
J#
public NLME_NETWORKDISCOVERY_REQUEST()
JScript
public function NLME_NETWORKDISCOVERY_REQUEST()

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_REQUEST Constructor Overload List


NLME_NETWORKDISCOVERY_REQUEST Constructor (NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, Byte)

NLME_NETWORKDISCOVERY_REQUEST Constructor (NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte _
)
C#
public NLME_NETWORKDISCOVERY_REQUEST(
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ,
byte
)
C++
public:
NLME_NETWORKDISCOVERY_REQUEST(
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ,
char
) sealed
J#
public NLME_NETWORKDISCOVERY_REQUEST(
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ,
byte
)
JScript
public function NLME_NETWORKDISCOVERY_REQUEST(
: NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS,
: Byte
)

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_REQUEST Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


ScanChannels Field

NLME_NETWORKDISCOVERY_REQUEST.ScanChannels Field
[image]

Channels to scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS
C#
public NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS;

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


ScanDuration Field

NLME_NETWORKDISCOVERY_REQUEST.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

NLME_NETWORKDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS Enumeration

NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Class

NLME_NETWORKDISCOVERY_RESPONSE Class
See Also Example Members
[image]

Response for NLME_NETWORKDISCOVERY_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_NETWORKDISCOVERY_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_NETWORKDISCOVERY_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_NETWORKDISCOVERY_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_NETWORKDISCOVERY_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_NETWORKDISCOVERY_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_NETWORKDISCOVERY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_NETWORKDISCOVERY_RESPONSE Members
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Members

NLME_NETWORKDISCOVERY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_NETWORKDISCOVERY_REQUEST

The following tables list the members exposed by NLME_NETWORKDISCOVERY_RESPONSE.

Public Constructors

Name | Description
NLME_NETWORKDISCOVERY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_NETWORKDISCOVERY_RESPONSE | Overloaded.
Top

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Constructor

NLME_NETWORKDISCOVERY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_NETWORKDISCOVERY_RESPONSE | Constructor
Public method | NLME_NETWORKDISCOVERY_RESPONSE (NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS) |

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_RESPONSE Constructor ()

NLME_NETWORKDISCOVERY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_NETWORKDISCOVERY_RESPONSE()
C++
public:
NLME_NETWORKDISCOVERY_RESPONSE() sealed
J#
public NLME_NETWORKDISCOVERY_RESPONSE()
JScript
public function NLME_NETWORKDISCOVERY_RESPONSE()

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_RESPONSE Constructor Overload List


NLME_NETWORKDISCOVERY_RESPONSE Constructor (NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS)

NLME_NETWORKDISCOVERY_RESPONSE Constructor (NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS _
)
C#
public NLME_NETWORKDISCOVERY_RESPONSE(
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
)
C++
public:
NLME_NETWORKDISCOVERY_RESPONSE(
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_NETWORKDISCOVERY_RESPONSE(
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
)
JScript
public function NLME_NETWORKDISCOVERY_RESPONSE(
: NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
)

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace
NLME_NETWORKDISCOVERY_RESPONSE Constructor Overload List


Fields

NLME_NETWORKDISCOVERY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_NETWORKDISCOVERY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
C#
public NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS;

See Also

NLME_NETWORKDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Enumeration

NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS : char
J#
public enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_ORPHANJOIN_REQUEST Class

NLME_ORPHANJOIN_REQUEST Class
See Also Example Members
[image]

NLME orphan join request used by tester

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ORPHANJOIN_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_ORPHANJOIN_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_ORPHANJOIN_REQUEST : IREQUEST, INETWORK
J#
public class NLME_ORPHANJOIN_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_ORPHANJOIN_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_ORPHANJOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ORPHANJOIN_REQUEST Members
TI.ZPI2 Namespace


NLME_ORPHANJOIN_REQUEST Members

NLME_ORPHANJOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME orphan join request used by tester

The following tables list the members exposed by NLME_ORPHANJOIN_REQUEST.

Public Constructors

Name | Description
NLME_ORPHANJOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ORPHANJOIN_REQUEST | Overloaded.
Top

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_ORPHANJOIN_REQUEST Constructor

NLME_ORPHANJOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_ORPHANJOIN_REQUEST | Constructor
Public method | NLME_ORPHANJOIN_REQUEST (NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, Byte) |

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_ORPHANJOIN_REQUEST Constructor ()

NLME_ORPHANJOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ORPHANJOIN_REQUEST()
C++
public:
NLME_ORPHANJOIN_REQUEST() sealed
J#
public NLME_ORPHANJOIN_REQUEST()
JScript
public function NLME_ORPHANJOIN_REQUEST()

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI2 Namespace
NLME_ORPHANJOIN_REQUEST Constructor Overload List


NLME_ORPHANJOIN_REQUEST Constructor (NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, Byte)

NLME_ORPHANJOIN_REQUEST Constructor (NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte _
)
C#
public NLME_ORPHANJOIN_REQUEST(
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ,
byte
)
C++
public:
NLME_ORPHANJOIN_REQUEST(
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ,
char
) sealed
J#
public NLME_ORPHANJOIN_REQUEST(
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ,
byte
)
JScript
public function NLME_ORPHANJOIN_REQUEST(
: NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS,
: Byte
)

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI2 Namespace
NLME_ORPHANJOIN_REQUEST Constructor Overload List


Fields

NLME_ORPHANJOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ScanChannels | Channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Top

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI2 Namespace


ScanChannels Field

NLME_ORPHANJOIN_REQUEST.ScanChannels Field
[image]

Channels to scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS
C#
public NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS;

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI2 Namespace


ScanDuration Field

NLME_ORPHANJOIN_REQUEST.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

NLME_ORPHANJOIN_REQUEST Class
TI.ZPI2 Namespace


NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS Enumeration

NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


NLME_ORPHANJOIN_RESPONSE Class

NLME_ORPHANJOIN_RESPONSE Class
See Also Example Members
[image]

Response for NLME_ORPHANJOIN_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ORPHANJOIN_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_ORPHANJOIN_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_ORPHANJOIN_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_ORPHANJOIN_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_ORPHANJOIN_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_ORPHANJOIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ORPHANJOIN_RESPONSE Members
TI.ZPI2 Namespace


NLME_ORPHANJOIN_RESPONSE Members

NLME_ORPHANJOIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_ORPHANJOIN_REQUEST

The following tables list the members exposed by NLME_ORPHANJOIN_RESPONSE.

Public Constructors

Name | Description
NLME_ORPHANJOIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ORPHANJOIN_RESPONSE | Overloaded.
Top

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_ORPHANJOIN_RESPONSE Constructor

NLME_ORPHANJOIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_ORPHANJOIN_RESPONSE | Constructor
Public method | NLME_ORPHANJOIN_RESPONSE (NLME_ORPHANJOIN_RESPONSE.CMD_STATUS) |

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_ORPHANJOIN_RESPONSE Constructor ()

NLME_ORPHANJOIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ORPHANJOIN_RESPONSE()
C++
public:
NLME_ORPHANJOIN_RESPONSE() sealed
J#
public NLME_ORPHANJOIN_RESPONSE()
JScript
public function NLME_ORPHANJOIN_RESPONSE()

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI2 Namespace
NLME_ORPHANJOIN_RESPONSE Constructor Overload List


NLME_ORPHANJOIN_RESPONSE Constructor (NLME_ORPHANJOIN_RESPONSE.CMD_STATUS)

NLME_ORPHANJOIN_RESPONSE Constructor (NLME_ORPHANJOIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_ORPHANJOIN_RESPONSE.CMD_STATUS _
)
C#
public NLME_ORPHANJOIN_RESPONSE(
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
)
C++
public:
NLME_ORPHANJOIN_RESPONSE(
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_ORPHANJOIN_RESPONSE(
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
)
JScript
public function NLME_ORPHANJOIN_RESPONSE(
: NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
)

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI2 Namespace
NLME_ORPHANJOIN_RESPONSE Constructor Overload List


Fields

NLME_ORPHANJOIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_ORPHANJOIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
C#
public NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_ORPHANJOIN_RESPONSE.CMD_STATUS;

See Also

NLME_ORPHANJOIN_RESPONSE Class
TI.ZPI2 Namespace


NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Enumeration

NLME_ORPHANJOIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_ORPHANJOIN_RESPONSE.CMD_STATUS : char
J#
public enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_ORPHANJOIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_PERMITJOINING_REQUEST Class

NLME_PERMITJOINING_REQUEST Class
See Also Example Members
[image]

This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_PERMITJOINING_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_PERMITJOINING_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_PERMITJOINING_REQUEST : IREQUEST, INETWORK
J#
public class NLME_PERMITJOINING_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_PERMITJOINING_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_PERMITJOINING_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_PERMITJOINING_REQUEST Members
TI.ZPI2 Namespace


NLME_PERMITJOINING_REQUEST Members

NLME_PERMITJOINING_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by the tester to define how the next higher layer of a coordinator device would permit devices to join its network for a fixed period.

The following tables list the members exposed by NLME_PERMITJOINING_REQUEST.

Public Constructors

Name | Description
NLME_PERMITJOINING_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | PermitDuration | indicates the length of time during which the Zigbee coordinatior will be allowing associations
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_PERMITJOINING_REQUEST | Overloaded.
Top

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI2 Namespace


NLME_PERMITJOINING_REQUEST Constructor

NLME_PERMITJOINING_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_PERMITJOINING_REQUEST | Constructor
Public method | NLME_PERMITJOINING_REQUEST (Byte) | Constructor

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI2 Namespace


NLME_PERMITJOINING_REQUEST Constructor ()

NLME_PERMITJOINING_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_PERMITJOINING_REQUEST()
C++
public:
NLME_PERMITJOINING_REQUEST() sealed
J#
public NLME_PERMITJOINING_REQUEST()
JScript
public function NLME_PERMITJOINING_REQUEST()

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI2 Namespace
NLME_PERMITJOINING_REQUEST Constructor Overload List


NLME_PERMITJOINING_REQUEST Constructor (Byte)

NLME_PERMITJOINING_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public NLME_PERMITJOINING_REQUEST(
byte
)
C++
public:
NLME_PERMITJOINING_REQUEST(
char
) sealed
J#
public NLME_PERMITJOINING_REQUEST(
byte
)
JScript
public function NLME_PERMITJOINING_REQUEST(
: Byte
)

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI2 Namespace
NLME_PERMITJOINING_REQUEST Constructor Overload List


Fields

NLME_PERMITJOINING_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | PermitDuration | indicates the length of time during which the Zigbee coordinatior will be allowing associations
Top

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI2 Namespace


PermitDuration Field

NLME_PERMITJOINING_REQUEST.PermitDuration Field
[image]

indicates the length of time during which the Zigbee coordinatior will be allowing associations

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PermitDuration As Byte
C#
public byte PermitDuration;
C++
public:
char PermitDuration sealed ;
J#
public byte PermitDuration
JScript
public PermitDuration : Byte;

See Also

NLME_PERMITJOINING_REQUEST Class
TI.ZPI2 Namespace


NLME_PERMITJOINING_RESPONSE Class

NLME_PERMITJOINING_RESPONSE Class
See Also Example Members
[image]

Response for NLME_PERMITJOINING_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_PERMITJOINING_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_PERMITJOINING_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_PERMITJOINING_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_PERMITJOINING_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_PERMITJOINING_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_PERMITJOINING_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_PERMITJOINING_RESPONSE Members
TI.ZPI2 Namespace


NLME_PERMITJOINING_RESPONSE Members

NLME_PERMITJOINING_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_PERMITJOINING_REQUEST

The following tables list the members exposed by NLME_PERMITJOINING_RESPONSE.

Public Constructors

Name | Description
NLME_PERMITJOINING_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_PERMITJOINING_RESPONSE | Overloaded.
Top

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI2 Namespace


NLME_PERMITJOINING_RESPONSE Constructor

NLME_PERMITJOINING_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_PERMITJOINING_RESPONSE | Constructor
Public method | NLME_PERMITJOINING_RESPONSE (NLME_PERMITJOINING_RESPONSE.CMD_STATUS) |

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI2 Namespace


NLME_PERMITJOINING_RESPONSE Constructor ()

NLME_PERMITJOINING_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_PERMITJOINING_RESPONSE()
C++
public:
NLME_PERMITJOINING_RESPONSE() sealed
J#
public NLME_PERMITJOINING_RESPONSE()
JScript
public function NLME_PERMITJOINING_RESPONSE()

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI2 Namespace
NLME_PERMITJOINING_RESPONSE Constructor Overload List


NLME_PERMITJOINING_RESPONSE Constructor (NLME_PERMITJOINING_RESPONSE.CMD_STATUS)

NLME_PERMITJOINING_RESPONSE Constructor (NLME_PERMITJOINING_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_PERMITJOINING_RESPONSE.CMD_STATUS _
)
C#
public NLME_PERMITJOINING_RESPONSE(
NLME_PERMITJOINING_RESPONSE.CMD_STATUS
)
C++
public:
NLME_PERMITJOINING_RESPONSE(
NLME_PERMITJOINING_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_PERMITJOINING_RESPONSE(
NLME_PERMITJOINING_RESPONSE.CMD_STATUS
)
JScript
public function NLME_PERMITJOINING_RESPONSE(
: NLME_PERMITJOINING_RESPONSE.CMD_STATUS
)

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI2 Namespace
NLME_PERMITJOINING_RESPONSE Constructor Overload List


Fields

NLME_PERMITJOINING_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_PERMITJOINING_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_PERMITJOINING_RESPONSE.CMD_STATUS
C#
public NLME_PERMITJOINING_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_PERMITJOINING_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_PERMITJOINING_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_PERMITJOINING_RESPONSE.CMD_STATUS;

See Also

NLME_PERMITJOINING_RESPONSE Class
TI.ZPI2 Namespace


NLME_PERMITJOINING_RESPONSE.CMD_STATUS Enumeration

NLME_PERMITJOINING_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_PERMITJOINING_RESPONSE.CMD_STATUS : char
J#
public enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_PERMITJOINING_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_POLL_CONFIRMATION Class

NLME_POLL_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of a polling attempt.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_POLL_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_POLL_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_POLL_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_POLL_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_POLL_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_POLL_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_POLL_CONFIRMATION Members
TI.ZPI2 Namespace


NLME_POLL_CONFIRMATION Members

NLME_POLL_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of a polling attempt.

The following tables list the members exposed by NLME_POLL_CONFIRMATION.

Public Constructors

Name | Description
NLME_POLL_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_POLL_CONFIRMATION | Overloaded.
Top

See Also

NLME_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_POLL_CONFIRMATION Constructor

NLME_POLL_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_POLL_CONFIRMATION | Constructor
Public method | NLME_POLL_CONFIRMATION (NLME_POLL_CONFIRMATION.CMD_STATUS) |

See Also

NLME_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_POLL_CONFIRMATION Constructor ()

NLME_POLL_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_POLL_CONFIRMATION()
C++
public:
NLME_POLL_CONFIRMATION() sealed
J#
public NLME_POLL_CONFIRMATION()
JScript
public function NLME_POLL_CONFIRMATION()

See Also

NLME_POLL_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_POLL_CONFIRMATION Constructor Overload List


NLME_POLL_CONFIRMATION Constructor (NLME_POLL_CONFIRMATION.CMD_STATUS)

NLME_POLL_CONFIRMATION Constructor (NLME_POLL_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_POLL_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_POLL_CONFIRMATION(
NLME_POLL_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_POLL_CONFIRMATION(
NLME_POLL_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_POLL_CONFIRMATION(
NLME_POLL_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_POLL_CONFIRMATION(
: NLME_POLL_CONFIRMATION.CMD_STATUS
)

See Also

NLME_POLL_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_POLL_CONFIRMATION Constructor Overload List


Fields

NLME_POLL_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NLME_POLL_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_POLL_CONFIRMATION.CMD_STATUS
C#
public NLME_POLL_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_POLL_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_POLL_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_POLL_CONFIRMATION.CMD_STATUS;

See Also

NLME_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_POLL_CONFIRMATION.CMD_STATUS Enumeration

NLME_POLL_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_POLL_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_POLL_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_POLL_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_POLL_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_POLL_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_RESET_REQUEST Class

NLME_RESET_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_RESET_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_RESET_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_RESET_REQUEST : IREQUEST, INETWORK
J#
public class NLME_RESET_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_RESET_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_RESET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_RESET_REQUEST Members
TI.ZPI2 Namespace


NLME_RESET_REQUEST Members

NLME_RESET_REQUEST Members
See Also Example Constructors Methods
[image]

This command is used by tester to make a request (on behalf of the next higher layer) that the NWK layer perform a reset operation

The following tables list the members exposed by NLME_RESET_REQUEST.

Public Constructors

 | Name | Description
Public method | NLME_RESET_REQUEST | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NLME_RESET_REQUEST Class
TI.ZPI2 Namespace


NLME_RESET_REQUEST Constructor

NLME_RESET_REQUEST Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_RESET_REQUEST()
C++
public:
NLME_RESET_REQUEST() sealed
J#
public NLME_RESET_REQUEST()
JScript
public function NLME_RESET_REQUEST()

See Also

NLME_RESET_REQUEST Class
TI.ZPI2 Namespace


NLME_RESET_RESPONSE Class

NLME_RESET_RESPONSE Class
See Also Example Members
[image]

Response for NLME_RESET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_RESET_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_RESET_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_RESET_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_RESET_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_RESET_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_RESET_RESPONSE Members
TI.ZPI2 Namespace


NLME_RESET_RESPONSE Members

NLME_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_RESET_REQUEST

The following tables list the members exposed by NLME_RESET_RESPONSE.

Public Constructors

Name | Description
NLME_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_RESET_RESPONSE | Overloaded.
Top

See Also

NLME_RESET_RESPONSE Class
TI.ZPI2 Namespace


NLME_RESET_RESPONSE Constructor

NLME_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_RESET_RESPONSE | Constructor
Public method | NLME_RESET_RESPONSE (NLME_RESET_RESPONSE.CMD_STATUS) |

See Also

NLME_RESET_RESPONSE Class
TI.ZPI2 Namespace


NLME_RESET_RESPONSE Constructor ()

NLME_RESET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_RESET_RESPONSE()
C++
public:
NLME_RESET_RESPONSE() sealed
J#
public NLME_RESET_RESPONSE()
JScript
public function NLME_RESET_RESPONSE()

See Also

NLME_RESET_RESPONSE Class
TI.ZPI2 Namespace
NLME_RESET_RESPONSE Constructor Overload List


NLME_RESET_RESPONSE Constructor (NLME_RESET_RESPONSE.CMD_STATUS)

NLME_RESET_RESPONSE Constructor (NLME_RESET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_RESET_RESPONSE.CMD_STATUS _
)
C#
public NLME_RESET_RESPONSE(
NLME_RESET_RESPONSE.CMD_STATUS
)
C++
public:
NLME_RESET_RESPONSE(
NLME_RESET_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_RESET_RESPONSE(
NLME_RESET_RESPONSE.CMD_STATUS
)
JScript
public function NLME_RESET_RESPONSE(
: NLME_RESET_RESPONSE.CMD_STATUS
)

See Also

NLME_RESET_RESPONSE Class
TI.ZPI2 Namespace
NLME_RESET_RESPONSE Constructor Overload List


Fields

NLME_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_RESET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_RESET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_RESET_RESPONSE.CMD_STATUS
C#
public NLME_RESET_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_RESET_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_RESET_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_RESET_RESPONSE.CMD_STATUS;

See Also

NLME_RESET_RESPONSE Class
TI.ZPI2 Namespace


NLME_RESET_RESPONSE.CMD_STATUS Enumeration

NLME_RESET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_RESET_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_RESET_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_RESET_RESPONSE.CMD_STATUS : char
J#
public enum NLME_RESET_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_RESET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_REQUEST Class

NLME_ROUTEDISCOVERY_REQUEST Class
See Also Example Members
[image]

NLME route discovery request used by tester

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ROUTEDISCOVERY_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_ROUTEDISCOVERY_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_ROUTEDISCOVERY_REQUEST : IREQUEST, INETWORK
J#
public class NLME_ROUTEDISCOVERY_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_ROUTEDISCOVERY_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_ROUTEDISCOVERY_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ROUTEDISCOVERY_REQUEST Members
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_REQUEST Members

NLME_ROUTEDISCOVERY_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME route discovery request used by tester

The following tables list the members exposed by NLME_ROUTEDISCOVERY_REQUEST.

Public Constructors

Name | Description
NLME_ROUTEDISCOVERY_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddress | Destination address
Public field | Option | specifies a route request option
Public field | Radius | specifies a route radius
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ROUTEDISCOVERY_REQUEST | Overloaded.
Top

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_REQUEST Constructor

NLME_ROUTEDISCOVERY_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_ROUTEDISCOVERY_REQUEST | Constructor
Public method | NLME_ROUTEDISCOVERY_REQUEST (UInt16, Byte, Byte) | Constructor

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_REQUEST Constructor ()

NLME_ROUTEDISCOVERY_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ROUTEDISCOVERY_REQUEST()
C++
public:
NLME_ROUTEDISCOVERY_REQUEST() sealed
J#
public NLME_ROUTEDISCOVERY_REQUEST()
JScript
public function NLME_ROUTEDISCOVERY_REQUEST()

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace
NLME_ROUTEDISCOVERY_REQUEST Constructor Overload List


NLME_ROUTEDISCOVERY_REQUEST Constructor (UInt16, Byte, Byte)

NLME_ROUTEDISCOVERY_REQUEST Constructor (UInt16, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLME_ROUTEDISCOVERY_REQUEST(
ushort ,
byte ,
byte
)
C++
public:
NLME_ROUTEDISCOVERY_REQUEST(
unsigned short ,
char ,
char
) sealed
J#
public NLME_ROUTEDISCOVERY_REQUEST(
ushort ,
byte ,
byte
)
JScript
public function NLME_ROUTEDISCOVERY_REQUEST(
: UInt16,
: Byte,
: Byte
)

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace
NLME_ROUTEDISCOVERY_REQUEST Constructor Overload List


Fields

NLME_ROUTEDISCOVERY_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddress | Destination address
Public field | Option | specifies a route request option
Public field | Radius | specifies a route radius
Top

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


DstAddress Field

NLME_ROUTEDISCOVERY_REQUEST.DstAddress Field
[image]

Destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddress As UInt16
C#
public ushort DstAddress;
C++
public:
unsigned short DstAddress sealed ;
J#
public ushort DstAddress
JScript
public DstAddress : UInt16;

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


Option Field

NLME_ROUTEDISCOVERY_REQUEST.Option Field
[image]

specifies a route request option

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Option As Byte
C#
public byte Option;
C++
public:
char Option sealed ;
J#
public byte Option
JScript
public Option : Byte;

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


Radius Field

NLME_ROUTEDISCOVERY_REQUEST.Radius Field
[image]

specifies a route radius

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Radius As Byte
C#
public byte Radius;
C++
public:
char Radius sealed ;
J#
public byte Radius
JScript
public Radius : Byte;

See Also

NLME_ROUTEDISCOVERY_REQUEST Class
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Class

NLME_ROUTEDISCOVERY_RESPONSE Class
See Also Example Members
[image]

Response for NLME_ROUTEDISCOVERY_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_ROUTEDISCOVERY_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_ROUTEDISCOVERY_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_ROUTEDISCOVERY_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_ROUTEDISCOVERY_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_ROUTEDISCOVERY_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_ROUTEDISCOVERY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_ROUTEDISCOVERY_RESPONSE Members
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Members

NLME_ROUTEDISCOVERY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_ROUTEDISCOVERY_REQUEST

The following tables list the members exposed by NLME_ROUTEDISCOVERY_RESPONSE.

Public Constructors

Name | Description
NLME_ROUTEDISCOVERY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_ROUTEDISCOVERY_RESPONSE | Overloaded.
Top

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Constructor

NLME_ROUTEDISCOVERY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_ROUTEDISCOVERY_RESPONSE | Constructor
Public method | NLME_ROUTEDISCOVERY_RESPONSE (NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS) |

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_RESPONSE Constructor ()

NLME_ROUTEDISCOVERY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_ROUTEDISCOVERY_RESPONSE()
C++
public:
NLME_ROUTEDISCOVERY_RESPONSE() sealed
J#
public NLME_ROUTEDISCOVERY_RESPONSE()
JScript
public function NLME_ROUTEDISCOVERY_RESPONSE()

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace
NLME_ROUTEDISCOVERY_RESPONSE Constructor Overload List


NLME_ROUTEDISCOVERY_RESPONSE Constructor (NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS)

NLME_ROUTEDISCOVERY_RESPONSE Constructor (NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS _
)
C#
public NLME_ROUTEDISCOVERY_RESPONSE(
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
)
C++
public:
NLME_ROUTEDISCOVERY_RESPONSE(
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_ROUTEDISCOVERY_RESPONSE(
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
)
JScript
public function NLME_ROUTEDISCOVERY_RESPONSE(
: NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
)

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace
NLME_ROUTEDISCOVERY_RESPONSE Constructor Overload List


Fields

NLME_ROUTEDISCOVERY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_ROUTEDISCOVERY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
C#
public NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS;

See Also

NLME_ROUTEDISCOVERY_RESPONSE Class
TI.ZPI2 Namespace


NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Enumeration

NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS : char
J#
public enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_SET_REQUEST Class

NLME_SET_REQUEST Class
See Also Example Members
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SET_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_SET_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_SET_REQUEST : IREQUEST, INETWORK
J#
public class NLME_SET_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_SET_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_SET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SET_REQUEST Members
TI.ZPI2 Namespace


NLME_SET_REQUEST Members

NLME_SET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used by tester to make a request (on behalf of the next higher layer) to set the value of an attribute in the NWK information base (NIB).

The following tables list the members exposed by NLME_SET_REQUEST.

Public Constructors

Name | Description
NLME_SET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Index | contains the index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | NIBAttributeValue | specifies the value of the NIBAttribute
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SET_REQUEST | Overloaded.
Top

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace


NLME_SET_REQUEST Constructor

NLME_SET_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_SET_REQUEST | Constructor
Public method | NLME_SET_REQUEST (NLME_SET_REQUEST.NIB_ATTR, UInt16, UInt16) |

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace


NLME_SET_REQUEST Constructor ()

NLME_SET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SET_REQUEST()
C++
public:
NLME_SET_REQUEST() sealed
J#
public NLME_SET_REQUEST()
JScript
public function NLME_SET_REQUEST()

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace
NLME_SET_REQUEST Constructor Overload List


NLME_SET_REQUEST Constructor (NLME_SET_REQUEST.NIB_ATTR, UInt16, UInt16)

NLME_SET_REQUEST Constructor (NLME_SET_REQUEST.NIB_ATTR, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SET_REQUEST.NIB_ATTR, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public NLME_SET_REQUEST(
NLME_SET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
C++
public:
NLME_SET_REQUEST(
NLME_SET_REQUEST.NIB_ATTR ,
unsigned short ,
unsigned short
) sealed
J#
public NLME_SET_REQUEST(
NLME_SET_REQUEST.NIB_ATTR ,
ushort ,
ushort
)
JScript
public function NLME_SET_REQUEST(
: NLME_SET_REQUEST.NIB_ATTR,
: UInt16,
: UInt16
)

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace
NLME_SET_REQUEST Constructor Overload List


Fields

NLME_SET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Index | contains the index into table NIB items
Public field | NIBAttribute | identifies the intended attribute of the NIB
Public field | NIBAttributeValue | specifies the value of the NIBAttribute
Top

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace


Index Field

NLME_SET_REQUEST.Index Field
[image]

contains the index into table NIB items

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index As UInt16
C#
public ushort Index;
C++
public:
unsigned short Index sealed ;
J#
public ushort Index
JScript
public Index : UInt16;

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace


NIBAttribute Field

NLME_SET_REQUEST.NIBAttribute Field
[image]

identifies the intended attribute of the NIB

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NIBAttribute As NLME_SET_REQUEST.NIB_ATTR
C#
public NLME_SET_REQUEST.NIB_ATTR NIBAttribute;
C++
public:
NLME_SET_REQUEST.NIB_ATTR NIBAttribute sealed ;
J#
public NLME_SET_REQUEST.NIB_ATTR NIBAttribute
JScript
public NIBAttribute : NLME_SET_REQUEST.NIB_ATTR;

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace


NIBAttributeValue Field

NLME_SET_REQUEST.NIBAttributeValue Field
[image]

specifies the value of the NIBAttribute

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NIBAttributeValue As UInt16
C#
public ushort NIBAttributeValue;
C++
public:
unsigned short NIBAttributeValue sealed ;
J#
public ushort NIBAttributeValue
JScript
public NIBAttributeValue : UInt16;

See Also

NLME_SET_REQUEST Class
TI.ZPI2 Namespace


NLME_SET_REQUEST.NIB_ATTR Enumeration

NLME_SET_REQUEST.NIB_ATTR Enumeration
[image]

Network layer information base attributes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SET_REQUEST.NIB_ATTR As Byte
C#
public enum NLME_SET_REQUEST.NIB_ATTR : byte
C++
public enum class NLME_SET_REQUEST.NIB_ATTR : char
J#
public enum NLME_SET_REQUEST.NIB_ATTR byte
JScript
public enum NLME_SET_REQUEST.NIB_ATTR :

Members

Member Name | Description
NWK_BCSN | Network layer information base attributes
NWK_PASSIVE_ACK_TIMEOUT | Network layer information base attributes
NWK_MAX_BROADCAST_RETRIES | Network layer information base attributes
NWK_MAX_CHILDREN | Network layer information base attributes
NWK_MAX_DEPTH | Network layer information base attributes
NWK_MAX_ROUTERS | Network layer information base attributes
NWK_NEIGHBOR_TABLE | Network layer information base attributes
NWK_BROADCAST_DELIVERY_TIME | Network layer information base attributes
NWK_REPORT_CONSTANT_COST | Network layer information base attributes
NWK_ROUTE_DISCOVERY_RETRIES_PERMITTED | Network layer information base attributes
NWK_ROUTE_TABLE | Network layer information base attributes
NWK_SECURE_ALL_FRAMES | Network layer information base attributes
NWK_SECURITY_LEVEL | Network layer information base attributes
NWK_SYM_LINK | Network layer information base attributes
NWK_CAP_INFO | Network layer information base attributes

See Also

TI.ZPI2 Namespace


NLME_SET_RESPONSE Class

NLME_SET_RESPONSE Class
See Also Example Members
[image]

Response for NLME_SET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SET_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_SET_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_SET_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_SET_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_SET_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_SET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SET_RESPONSE Members
TI.ZPI2 Namespace


NLME_SET_RESPONSE Members

NLME_SET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_SET_REQUEST

The following tables list the members exposed by NLME_SET_RESPONSE.

Public Constructors

Name | Description
NLME_SET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SET_RESPONSE | Overloaded.
Top

See Also

NLME_SET_RESPONSE Class
TI.ZPI2 Namespace


NLME_SET_RESPONSE Constructor

NLME_SET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_SET_RESPONSE | Constructor
Public method | NLME_SET_RESPONSE (NLME_SET_RESPONSE.CMD_STATUS) |

See Also

NLME_SET_RESPONSE Class
TI.ZPI2 Namespace


NLME_SET_RESPONSE Constructor ()

NLME_SET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SET_RESPONSE()
C++
public:
NLME_SET_RESPONSE() sealed
J#
public NLME_SET_RESPONSE()
JScript
public function NLME_SET_RESPONSE()

See Also

NLME_SET_RESPONSE Class
TI.ZPI2 Namespace
NLME_SET_RESPONSE Constructor Overload List


NLME_SET_RESPONSE Constructor (NLME_SET_RESPONSE.CMD_STATUS)

NLME_SET_RESPONSE Constructor (NLME_SET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SET_RESPONSE.CMD_STATUS _
)
C#
public NLME_SET_RESPONSE(
NLME_SET_RESPONSE.CMD_STATUS
)
C++
public:
NLME_SET_RESPONSE(
NLME_SET_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_SET_RESPONSE(
NLME_SET_RESPONSE.CMD_STATUS
)
JScript
public function NLME_SET_RESPONSE(
: NLME_SET_RESPONSE.CMD_STATUS
)

See Also

NLME_SET_RESPONSE Class
TI.ZPI2 Namespace
NLME_SET_RESPONSE Constructor Overload List


Fields

NLME_SET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_SET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_SET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_SET_RESPONSE.CMD_STATUS
C#
public NLME_SET_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_SET_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_SET_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_SET_RESPONSE.CMD_STATUS;

See Also

NLME_SET_RESPONSE Class
TI.ZPI2 Namespace


NLME_SET_RESPONSE.CMD_STATUS Enumeration

NLME_SET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SET_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_SET_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_SET_RESPONSE.CMD_STATUS : char
J#
public enum NLME_SET_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_SET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_STARTROUTER_CONFIRMATION Class

NLME_STARTROUTER_CONFIRMATION Class
See Also Example Members
[image]

This message is sent by the target to the next higher layer of the results of its request to start a router

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_STARTROUTER_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NLME_STARTROUTER_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NLME_STARTROUTER_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NLME_STARTROUTER_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NLME_STARTROUTER_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_STARTROUTER_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_STARTROUTER_CONFIRMATION Members
TI.ZPI2 Namespace


NLME_STARTROUTER_CONFIRMATION Members

NLME_STARTROUTER_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to the next higher layer of the results of its request to start a router

The following tables list the members exposed by NLME_STARTROUTER_CONFIRMATION.

Public Constructors

Name | Description
NLME_STARTROUTER_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_STARTROUTER_CONFIRMATION | Overloaded.
Top

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_STARTROUTER_CONFIRMATION Constructor

NLME_STARTROUTER_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NLME_STARTROUTER_CONFIRMATION | Constructor
Public method | NLME_STARTROUTER_CONFIRMATION (NLME_STARTROUTER_CONFIRMATION.CMD_STATUS) |

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_STARTROUTER_CONFIRMATION Constructor ()

NLME_STARTROUTER_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_STARTROUTER_CONFIRMATION()
C++
public:
NLME_STARTROUTER_CONFIRMATION() sealed
J#
public NLME_STARTROUTER_CONFIRMATION()
JScript
public function NLME_STARTROUTER_CONFIRMATION()

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_STARTROUTER_CONFIRMATION Constructor Overload List


NLME_STARTROUTER_CONFIRMATION Constructor (NLME_STARTROUTER_CONFIRMATION.CMD_STATUS)

NLME_STARTROUTER_CONFIRMATION Constructor (NLME_STARTROUTER_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_STARTROUTER_CONFIRMATION.CMD_STATUS _
)
C#
public NLME_STARTROUTER_CONFIRMATION(
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
)
C++
public:
NLME_STARTROUTER_CONFIRMATION(
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
) sealed
J#
public NLME_STARTROUTER_CONFIRMATION(
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
)
JScript
public function NLME_STARTROUTER_CONFIRMATION(
: NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
)

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI2 Namespace
NLME_STARTROUTER_CONFIRMATION Constructor Overload List


Fields

NLME_STARTROUTER_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NLME_STARTROUTER_CONFIRMATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
C#
public NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Status;
C++
public:
NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NLME_STARTROUTER_CONFIRMATION.CMD_STATUS;

See Also

NLME_STARTROUTER_CONFIRMATION Class
TI.ZPI2 Namespace


NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Enumeration

NLME_STARTROUTER_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NLME_STARTROUTER_CONFIRMATION.CMD_STATUS : char
J#
public enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS byte
JScript
public enum NLME_STARTROUTER_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_STARTROUTER_REQUEST Class

NLME_STARTROUTER_REQUEST Class
See Also Example Members
[image]

NLME Start router request used by tester

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_STARTROUTER_REQUEST
Implements IREQUEST, INETWORK
C#
public class NLME_STARTROUTER_REQUEST : IREQUEST, INETWORK
C++
ref class NLME_STARTROUTER_REQUEST : IREQUEST, INETWORK
J#
public class NLME_STARTROUTER_REQUEST implements IREQUEST, INETWORK
JScript
public class NLME_STARTROUTER_REQUEST extends IREQUEST, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_STARTROUTER_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_STARTROUTER_REQUEST Members
TI.ZPI2 Namespace


NLME_STARTROUTER_REQUEST Members

NLME_STARTROUTER_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

NLME Start router request used by tester

The following tables list the members exposed by NLME_STARTROUTER_REQUEST.

Public Constructors

Name | Description
NLME_STARTROUTER_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | Battery Life Extension
Public field | BeaconOrder | Beacon Order
Public field | SuperframeOrder | Super frame Order
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_STARTROUTER_REQUEST | Overloaded.
Top

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace


NLME_STARTROUTER_REQUEST Constructor

NLME_STARTROUTER_REQUEST Constructor

Overload List

 | Name | Description
Public method | NLME_STARTROUTER_REQUEST | Constructor
Public method | NLME_STARTROUTER_REQUEST (Byte, Byte, Byte) | Constructor

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace


NLME_STARTROUTER_REQUEST Constructor ()

NLME_STARTROUTER_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_STARTROUTER_REQUEST()
C++
public:
NLME_STARTROUTER_REQUEST() sealed
J#
public NLME_STARTROUTER_REQUEST()
JScript
public function NLME_STARTROUTER_REQUEST()

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace
NLME_STARTROUTER_REQUEST Constructor Overload List


NLME_STARTROUTER_REQUEST Constructor (Byte, Byte, Byte)

NLME_STARTROUTER_REQUEST Constructor (Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public NLME_STARTROUTER_REQUEST(
byte ,
byte ,
byte
)
C++
public:
NLME_STARTROUTER_REQUEST(
char ,
char ,
char
) sealed
J#
public NLME_STARTROUTER_REQUEST(
byte ,
byte ,
byte
)
JScript
public function NLME_STARTROUTER_REQUEST(
: Byte,
: Byte,
: Byte
)

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace
NLME_STARTROUTER_REQUEST Constructor Overload List


Fields

NLME_STARTROUTER_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | BatteryLifeExtension | Battery Life Extension
Public field | BeaconOrder | Beacon Order
Public field | SuperframeOrder | Super frame Order
Top

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace


BatteryLifeExtension Field

NLME_STARTROUTER_REQUEST.BatteryLifeExtension Field
[image]

Battery Life Extension

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BatteryLifeExtension As Byte
C#
public byte BatteryLifeExtension;
C++
public:
char BatteryLifeExtension sealed ;
J#
public byte BatteryLifeExtension
JScript
public BatteryLifeExtension : Byte;

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace


BeaconOrder Field

NLME_STARTROUTER_REQUEST.BeaconOrder Field
[image]

Beacon Order

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace


SuperframeOrder Field

NLME_STARTROUTER_REQUEST.SuperframeOrder Field
[image]

Super frame Order

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperframeOrder As Byte
C#
public byte SuperframeOrder;
C++
public:
char SuperframeOrder sealed ;
J#
public byte SuperframeOrder
JScript
public SuperframeOrder : Byte;

See Also

NLME_STARTROUTER_REQUEST Class
TI.ZPI2 Namespace


NLME_STARTROUTER_RESPONSE Class

NLME_STARTROUTER_RESPONSE Class
See Also Example Members
[image]

Response for NLME_STARTROUTER_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_STARTROUTER_RESPONSE
Implements IRESPONSE, INETWORK
C#
public class NLME_STARTROUTER_RESPONSE : IRESPONSE, INETWORK
C++
ref class NLME_STARTROUTER_RESPONSE : IRESPONSE, INETWORK
J#
public class NLME_STARTROUTER_RESPONSE implements IRESPONSE, INETWORK
JScript
public class NLME_STARTROUTER_RESPONSE extends IRESPONSE, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_STARTROUTER_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_STARTROUTER_RESPONSE Members
TI.ZPI2 Namespace


NLME_STARTROUTER_RESPONSE Members

NLME_STARTROUTER_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for NLME_STARTROUTER_REQUEST

The following tables list the members exposed by NLME_STARTROUTER_RESPONSE.

Public Constructors

Name | Description
NLME_STARTROUTER_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_STARTROUTER_RESPONSE | Overloaded.
Top

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI2 Namespace


NLME_STARTROUTER_RESPONSE Constructor

NLME_STARTROUTER_RESPONSE Constructor

Overload List

 | Name | Description
Public method | NLME_STARTROUTER_RESPONSE | Constructor
Public method | NLME_STARTROUTER_RESPONSE (NLME_STARTROUTER_RESPONSE.CMD_STATUS) |

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI2 Namespace


NLME_STARTROUTER_RESPONSE Constructor ()

NLME_STARTROUTER_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_STARTROUTER_RESPONSE()
C++
public:
NLME_STARTROUTER_RESPONSE() sealed
J#
public NLME_STARTROUTER_RESPONSE()
JScript
public function NLME_STARTROUTER_RESPONSE()

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI2 Namespace
NLME_STARTROUTER_RESPONSE Constructor Overload List


NLME_STARTROUTER_RESPONSE Constructor (NLME_STARTROUTER_RESPONSE.CMD_STATUS)

NLME_STARTROUTER_RESPONSE Constructor (NLME_STARTROUTER_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_STARTROUTER_RESPONSE.CMD_STATUS _
)
C#
public NLME_STARTROUTER_RESPONSE(
NLME_STARTROUTER_RESPONSE.CMD_STATUS
)
C++
public:
NLME_STARTROUTER_RESPONSE(
NLME_STARTROUTER_RESPONSE.CMD_STATUS
) sealed
J#
public NLME_STARTROUTER_RESPONSE(
NLME_STARTROUTER_RESPONSE.CMD_STATUS
)
JScript
public function NLME_STARTROUTER_RESPONSE(
: NLME_STARTROUTER_RESPONSE.CMD_STATUS
)

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI2 Namespace
NLME_STARTROUTER_RESPONSE Constructor Overload List


Fields

NLME_STARTROUTER_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI2 Namespace


Status Field

NLME_STARTROUTER_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_STARTROUTER_RESPONSE.CMD_STATUS
C#
public NLME_STARTROUTER_RESPONSE.CMD_STATUS Status;
C++
public:
NLME_STARTROUTER_RESPONSE.CMD_STATUS Status sealed ;
J#
public NLME_STARTROUTER_RESPONSE.CMD_STATUS Status
JScript
public Status : NLME_STARTROUTER_RESPONSE.CMD_STATUS;

See Also

NLME_STARTROUTER_RESPONSE Class
TI.ZPI2 Namespace


NLME_STARTROUTER_RESPONSE.CMD_STATUS Enumeration

NLME_STARTROUTER_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_STARTROUTER_RESPONSE.CMD_STATUS As Byte
C#
public enum NLME_STARTROUTER_RESPONSE.CMD_STATUS : byte
C++
public enum class NLME_STARTROUTER_RESPONSE.CMD_STATUS : char
J#
public enum NLME_STARTROUTER_RESPONSE.CMD_STATUS byte
JScript
public enum NLME_STARTROUTER_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NLME_SYNC_INDICATION Class

NLME_SYNC_INDICATION Class
See Also Example Members
[image]

This message is sent by the target to indicate a sync request to the next higher layer of a coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NLME_SYNC_INDICATION
Implements IINDICATION, INETWORK
C#
public class NLME_SYNC_INDICATION : IINDICATION, INETWORK
C++
ref class NLME_SYNC_INDICATION : IINDICATION, INETWORK
J#
public class NLME_SYNC_INDICATION implements IINDICATION, INETWORK
JScript
public class NLME_SYNC_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NLME_SYNC_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NLME_SYNC_INDICATION Members
TI.ZPI2 Namespace


NLME_SYNC_INDICATION Members

NLME_SYNC_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent by the target to indicate a sync request to the next higher layer of a coordinator

The following tables list the members exposed by NLME_SYNC_INDICATION.

Public Constructors

Name | Description
NLME_SYNC_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NLME_SYNC_INDICATION | Overloaded.
Top

See Also

NLME_SYNC_INDICATION Class
TI.ZPI2 Namespace


NLME_SYNC_INDICATION Constructor

NLME_SYNC_INDICATION Constructor

Overload List

 | Name | Description
Public method | NLME_SYNC_INDICATION | Constructor
Public method | NLME_SYNC_INDICATION (NLME_SYNC_INDICATION.CMD_STATUS) |

See Also

NLME_SYNC_INDICATION Class
TI.ZPI2 Namespace


NLME_SYNC_INDICATION Constructor ()

NLME_SYNC_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NLME_SYNC_INDICATION()
C++
public:
NLME_SYNC_INDICATION() sealed
J#
public NLME_SYNC_INDICATION()
JScript
public function NLME_SYNC_INDICATION()

See Also

NLME_SYNC_INDICATION Class
TI.ZPI2 Namespace
NLME_SYNC_INDICATION Constructor Overload List


NLME_SYNC_INDICATION Constructor (NLME_SYNC_INDICATION.CMD_STATUS)

NLME_SYNC_INDICATION Constructor (NLME_SYNC_INDICATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NLME_SYNC_INDICATION.CMD_STATUS _
)
C#
public NLME_SYNC_INDICATION(
NLME_SYNC_INDICATION.CMD_STATUS
)
C++
public:
NLME_SYNC_INDICATION(
NLME_SYNC_INDICATION.CMD_STATUS
) sealed
J#
public NLME_SYNC_INDICATION(
NLME_SYNC_INDICATION.CMD_STATUS
)
JScript
public function NLME_SYNC_INDICATION(
: NLME_SYNC_INDICATION.CMD_STATUS
)

See Also

NLME_SYNC_INDICATION Class
TI.ZPI2 Namespace
NLME_SYNC_INDICATION Constructor Overload List


Fields

NLME_SYNC_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

NLME_SYNC_INDICATION Class
TI.ZPI2 Namespace


Status Field

NLME_SYNC_INDICATION.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NLME_SYNC_INDICATION.CMD_STATUS
C#
public NLME_SYNC_INDICATION.CMD_STATUS Status;
C++
public:
NLME_SYNC_INDICATION.CMD_STATUS Status sealed ;
J#
public NLME_SYNC_INDICATION.CMD_STATUS Status
JScript
public Status : NLME_SYNC_INDICATION.CMD_STATUS;

See Also

NLME_SYNC_INDICATION Class
TI.ZPI2 Namespace


NLME_SYNC_INDICATION.CMD_STATUS Enumeration

NLME_SYNC_INDICATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NLME_SYNC_INDICATION.CMD_STATUS As Byte
C#
public enum NLME_SYNC_INDICATION.CMD_STATUS : byte
C++
public enum class NLME_SYNC_INDICATION.CMD_STATUS : char
J#
public enum NLME_SYNC_INDICATION.CMD_STATUS byte
JScript
public enum NLME_SYNC_INDICATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_ASSOCIATE_CONFIRMATION Class

NWK_ASSOCIATE_CONFIRMATION Class
See Also Example Members
[image]

This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_ASSOCIATE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_ASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_ASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_ASSOCIATE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_ASSOCIATE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_ASSOCIATE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_ASSOCIATE_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_ASSOCIATE_CONFIRMATION Members

NWK_ASSOCIATE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to inform the upper layers of the initiating device whether its request to associate was successful or unsuccessful.

The following tables list the members exposed by NWK_ASSOCIATE_CONFIRMATION.

Public Constructors

Name | Description
NWK_ASSOCIATE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AllocatedAddress | Allocated Address
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_ASSOCIATE_CONFIRMATION | Overloaded.
Top

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_ASSOCIATE_CONFIRMATION Constructor

NWK_ASSOCIATE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_ASSOCIATE_CONFIRMATION | Constructor
Public method | NWK_ASSOCIATE_CONFIRMATION (NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, UInt16, Byte, NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, Byte) |

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_ASSOCIATE_CONFIRMATION Constructor ()

NWK_ASSOCIATE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_ASSOCIATE_CONFIRMATION()
C++
public:
NWK_ASSOCIATE_CONFIRMATION() sealed
J#
public NWK_ASSOCIATE_CONFIRMATION()
JScript
public function NWK_ASSOCIATE_CONFIRMATION()

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_ASSOCIATE_CONFIRMATION Constructor Overload List


NWK_ASSOCIATE_CONFIRMATION Constructor (NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, UInt16, Byte[], NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, Byte)

NWK_ASSOCIATE_CONFIRMATION Constructor (NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, UInt16, Byte[], NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS, _
ByVal As UInt16, _
ByVal As Byte(), _
ByVal As NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL, _
ByVal As NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_ASSOCIATE_CONFIRMATION(
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS ,
ushort ,
byte[] ,
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_ASSOCIATE_CONFIRMATION(
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS ,
unsigned short ,
array<char>^ ,
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_ASSOCIATE_CONFIRMATION(
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS ,
ushort ,
byte[] ,
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_ASSOCIATE_CONFIRMATION(
: NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS,
: UInt16,
: Byte[],
: NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL,
: NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_ASSOCIATE_CONFIRMATION Constructor Overload List


Fields

NWK_ASSOCIATE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | AllocatedAddress | Allocated Address
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


AllocatedAddress Field

NWK_ASSOCIATE_CONFIRMATION.AllocatedAddress Field
[image]

Allocated Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AllocatedAddress As UInt16
C#
public ushort AllocatedAddress;
C++
public:
unsigned short AllocatedAddress sealed ;
J#
public ushort AllocatedAddress
JScript
public AllocatedAddress : UInt16;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_ASSOCIATE_CONFIRMATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE
C#
public NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_ASSOCIATE_CONFIRMATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_ASSOCIATE_CONFIRMATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_ASSOCIATE_CONFIRMATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL
C#
public NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_ASSOCIATE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS
C#
public NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS;

See Also

NWK_ASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration

NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE Enumeration

NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE As Byte
C#
public enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE : byte
C++
public enum class NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE : char
J#
public enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE byte
JScript
public enum NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL Enumeration

NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL As Byte
C#
public enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL : byte
C++
public enum class NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL : char
J#
public enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL byte
JScript
public enum NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


NWK_ASSOCIATE_INDICATION Class

NWK_ASSOCIATE_INDICATION Class
See Also Example Members
[image]

This function is used to indicate the reception of an association request command.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_ASSOCIATE_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_ASSOCIATE_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_ASSOCIATE_INDICATION : IINDICATION, INETWORK
J#
public class NWK_ASSOCIATE_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_ASSOCIATE_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_ASSOCIATE_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_ASSOCIATE_INDICATION Members
TI.ZPI2 Namespace


NWK_ASSOCIATE_INDICATION Members

NWK_ASSOCIATE_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to indicate the reception of an association request command.

The following tables list the members exposed by NWK_ASSOCIATE_INDICATION.

Public Constructors

Name | Description
NWK_ASSOCIATE_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInformation | capability of the associated device
Public field | DeviceAddresss | Address of the associated device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_ASSOCIATE_INDICATION | Overloaded.
Top

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


NWK_ASSOCIATE_INDICATION Constructor

NWK_ASSOCIATE_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_ASSOCIATE_INDICATION | Constructor
Public method | NWK_ASSOCIATE_INDICATION (UInt64, NWK_ASSOCIATE_INDICATION.CAPABILITIES, Byte, NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


NWK_ASSOCIATE_INDICATION Constructor ()

NWK_ASSOCIATE_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_ASSOCIATE_INDICATION()
C++
public:
NWK_ASSOCIATE_INDICATION() sealed
J#
public NWK_ASSOCIATE_INDICATION()
JScript
public function NWK_ASSOCIATE_INDICATION()

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace
NWK_ASSOCIATE_INDICATION Constructor Overload List


NWK_ASSOCIATE_INDICATION Constructor (UInt64, NWK_ASSOCIATE_INDICATION.CAPABILITIES, Byte[], NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, Byte)

NWK_ASSOCIATE_INDICATION Constructor (UInt64, NWK_ASSOCIATE_INDICATION.CAPABILITIES, Byte[], NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NWK_ASSOCIATE_INDICATION.CAPABILITIES, _
ByVal As Byte(), _
ByVal As NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_ASSOCIATE_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_ASSOCIATE_INDICATION(
ulong ,
NWK_ASSOCIATE_INDICATION.CAPABILITIES ,
byte[] ,
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_ASSOCIATE_INDICATION(
unsigned __int64 ,
NWK_ASSOCIATE_INDICATION.CAPABILITIES ,
array<char>^ ,
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_ASSOCIATE_INDICATION(
ulong ,
NWK_ASSOCIATE_INDICATION.CAPABILITIES ,
byte[] ,
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_ASSOCIATE_INDICATION(
: UInt64,
: NWK_ASSOCIATE_INDICATION.CAPABILITIES,
: Byte[],
: NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL,
: NWK_ASSOCIATE_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace
NWK_ASSOCIATE_INDICATION Constructor Overload List


Fields

NWK_ASSOCIATE_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInformation | capability of the associated device
Public field | DeviceAddresss | Address of the associated device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


CapabilityInformation Field

NWK_ASSOCIATE_INDICATION.CapabilityInformation Field
[image]

capability of the associated device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInformation As NWK_ASSOCIATE_INDICATION.CAPABILITIES
C#
public NWK_ASSOCIATE_INDICATION.CAPABILITIES CapabilityInformation;
C++
public:
NWK_ASSOCIATE_INDICATION.CAPABILITIES CapabilityInformation sealed ;
J#
public NWK_ASSOCIATE_INDICATION.CAPABILITIES CapabilityInformation
JScript
public CapabilityInformation : NWK_ASSOCIATE_INDICATION.CAPABILITIES;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


DeviceAddresss Field

NWK_ASSOCIATE_INDICATION.DeviceAddresss Field
[image]

Address of the associated device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddresss As UInt64
C#
public ulong DeviceAddresss;
C++
public:
unsigned __int64 DeviceAddresss sealed ;
J#
public ulong DeviceAddresss
JScript
public DeviceAddresss : UInt64;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_ASSOCIATE_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_ASSOCIATE_INDICATION.KEY_ID_MODE
C#
public NWK_ASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_ASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_ASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_ASSOCIATE_INDICATION.KEY_ID_MODE;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_ASSOCIATE_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_ASSOCIATE_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_ASSOCIATE_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL
C#
public NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL;

See Also

NWK_ASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


NWK_ASSOCIATE_INDICATION.CAPABILITIES Enumeration

NWK_ASSOCIATE_INDICATION.CAPABILITIES Enumeration
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NWK_ASSOCIATE_INDICATION.CAPABILITIES As
C#
[FlagsAttribute]
public enum NWK_ASSOCIATE_INDICATION.CAPABILITIES : ushort
C++
[FlagsAttribute]
public enum class NWK_ASSOCIATE_INDICATION.CAPABILITIES : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum NWK_ASSOCIATE_INDICATION.CAPABILITIES ushort
JScript
public enum NWK_ASSOCIATE_INDICATION.CAPABILITIES :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
MT_CAP_SYS | Capabilities bitfield | 1
MT_CAP_MAC | Capabilities bitfield | 2
MT_CAP_NWK | Capabilities bitfield | 4
MT_CAP_AF | Capabilities bitfield | 8
MT_CAP_ZDO | Capabilities bitfield | 16
MT_CAP_SAPI | Capabilities bitfield | 32
MT_CAP_UTIL | Capabilities bitfield | 64
MT_CAP_DEBUG | Capabilities bitfield | 128
MT_CAP_APP | Capabilities bitfield | 256

See Also

TI.ZPI2 Namespace


NWK_ASSOCIATE_INDICATION.KEY_ID_MODE Enumeration

NWK_ASSOCIATE_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_ASSOCIATE_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_ASSOCIATE_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration

NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION Class

NWK_BEACON_NOTIFY_INDICATION Class
See Also Example Members
[image]

This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_BEACON_NOTIFY_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_BEACON_NOTIFY_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_BEACON_NOTIFY_INDICATION : IINDICATION, INETWORK
J#
public class NWK_BEACON_NOTIFY_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_BEACON_NOTIFY_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_BEACON_NOTIFY_INDICATION Members
TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION Members

NWK_BEACON_NOTIFY_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to send parameters contained within a beacon frame received by the MAC sublayer to the next higher layer. The function also sends a measure of the link quality and the time the beacon was received.

The following tables list the members exposed by NWK_BEACON_NOTIFY_INDICATION.

Public Constructors

Name | Description
NWK_BEACON_NOTIFY_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AddressList | The list of device addresses for which the sender of the beacon has data
Public field | BSN | Beacon sequence number
Public field | CoordAddress | Address of the coordinator
Public field | CoordAddressMode | Coordinator Address Mode
Public field | CoordPanID | PAN ID of the coordinator
Public field | GTSPermit | TRUE if coordinator accepts GTS requests
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | The link quality of the received beacon
Public field | LogicalChannel | The logical channel of the network
Public field | PendingAddressSpec | The beacon pending address specification
Public field | SDU | Actual SDU data. Can be 0-32 bytes
Public field | SDULength | Length of the SDU data
Public field | SecurityFailure | Set to TRUE if there was an error in the security processing
Public field | SecurityLevel | Security Level of this data frame
Public field | SuperFrameSpec | The superframe specification of the network
Public field | TimeStamp | Time stamp when the beacon is received
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_BEACON_NOTIFY_INDICATION | Overloaded.
Top

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION Constructor

NWK_BEACON_NOTIFY_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_BEACON_NOTIFY_INDICATION | Constructor
Public method | NWK_BEACON_NOTIFY_INDICATION (Byte, UInt32, NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, UInt64, UInt16, UInt16, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE, Byte, Byte, Byte, Byte, Byte) |

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION Constructor ()

NWK_BEACON_NOTIFY_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_BEACON_NOTIFY_INDICATION()
C++
public:
NWK_BEACON_NOTIFY_INDICATION() sealed
J#
public NWK_BEACON_NOTIFY_INDICATION()
JScript
public function NWK_BEACON_NOTIFY_INDICATION()

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace
NWK_BEACON_NOTIFY_INDICATION Constructor Overload List


NWK_BEACON_NOTIFY_INDICATION Constructor (Byte, UInt32, NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, UInt64, UInt16, UInt16, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte[], NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, NWK_BEACON_NOTIFY_INDICATION.KEY_ID_

NWK_BEACON_NOTIFY_INDICATION Constructor (Byte, UInt32, NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, UInt64, UInt16, UInt16, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte, NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, Byte[], NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE, Byte, Byte, Byte[], Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, _
ByVal As Byte, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN, _
ByVal As Byte(), _
ByVal As NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public NWK_BEACON_NOTIFY_INDICATION(
byte ,
uint ,
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
ushort ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte[] ,
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL ,
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[] ,
byte ,
byte[]
)
C++
public:
NWK_BEACON_NOTIFY_INDICATION(
char ,
unsigned int ,
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
unsigned short ,
char ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
char ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
array<char>^ ,
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL ,
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE ,
char ,
char ,
array<char>^ ,
char ,
array<char>^
) sealed
J#
public NWK_BEACON_NOTIFY_INDICATION(
byte ,
uint ,
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
ushort ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte ,
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN ,
byte[] ,
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL ,
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[] ,
byte ,
byte[]
)
JScript
public function NWK_BEACON_NOTIFY_INDICATION(
: Byte,
: UInt32,
: NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE,
: UInt64,
: UInt16,
: UInt16,
: Byte,
: NWK_BEACON_NOTIFY_INDICATION.BOOLEAN,
: Byte,
: NWK_BEACON_NOTIFY_INDICATION.BOOLEAN,
: Byte[],
: NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL,
: NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[],
: Byte,
: Byte[]
)

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace
NWK_BEACON_NOTIFY_INDICATION Constructor Overload List


Fields

NWK_BEACON_NOTIFY_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | AddressList | The list of device addresses for which the sender of the beacon has data
Public field | BSN | Beacon sequence number
Public field | CoordAddress | Address of the coordinator
Public field | CoordAddressMode | Coordinator Address Mode
Public field | CoordPanID | PAN ID of the coordinator
Public field | GTSPermit | TRUE if coordinator accepts GTS requests
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | The link quality of the received beacon
Public field | LogicalChannel | The logical channel of the network
Public field | PendingAddressSpec | The beacon pending address specification
Public field | SDU | Actual SDU data. Can be 0-32 bytes
Public field | SDULength | Length of the SDU data
Public field | SecurityFailure | Set to TRUE if there was an error in the security processing
Public field | SecurityLevel | Security Level of this data frame
Public field | SuperFrameSpec | The superframe specification of the network
Public field | TimeStamp | Time stamp when the beacon is received
Top

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


AddressList Field

NWK_BEACON_NOTIFY_INDICATION.AddressList Field
[image]

The list of device addresses for which the sender of the beacon has data

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddressList As Byte()
C#
public byte[] AddressList;
C++
public:
array<char>^ AddressList sealed ;
J#
public byte[] AddressList
JScript
public AddressList : Byte[];

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


BSN Field

NWK_BEACON_NOTIFY_INDICATION.BSN Field
[image]

Beacon sequence number

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BSN As Byte
C#
public byte BSN;
C++
public:
char BSN sealed ;
J#
public byte BSN
JScript
public BSN : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


CoordAddress Field

NWK_BEACON_NOTIFY_INDICATION.CoordAddress Field
[image]

Address of the coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddress As UInt64
C#
public ulong CoordAddress;
C++
public:
unsigned __int64 CoordAddress sealed ;
J#
public ulong CoordAddress
JScript
public CoordAddress : UInt64;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


CoordAddressMode Field

NWK_BEACON_NOTIFY_INDICATION.CoordAddressMode Field
[image]

Coordinator Address Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddressMode As NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE
C#
public NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE CoordAddressMode;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE CoordAddressMode sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE CoordAddressMode
JScript
public CoordAddressMode : NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


CoordPanID Field

NWK_BEACON_NOTIFY_INDICATION.CoordPanID Field
[image]

PAN ID of the coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordPanID As UInt16
C#
public ushort CoordPanID;
C++
public:
unsigned short CoordPanID sealed ;
J#
public ushort CoordPanID
JScript
public CoordPanID : UInt16;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


GTSPermit Field

NWK_BEACON_NOTIFY_INDICATION.GTSPermit Field
[image]

TRUE if coordinator accepts GTS requests

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public GTSPermit As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN
C#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN GTSPermit;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN GTSPermit sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN GTSPermit
JScript
public GTSPermit : NWK_BEACON_NOTIFY_INDICATION.BOOLEAN;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_BEACON_NOTIFY_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE
C#
public NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_BEACON_NOTIFY_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_BEACON_NOTIFY_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


LinkQuality Field

NWK_BEACON_NOTIFY_INDICATION.LinkQuality Field
[image]

The link quality of the received beacon

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


LogicalChannel Field

NWK_BEACON_NOTIFY_INDICATION.LogicalChannel Field
[image]

The logical channel of the network

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


PendingAddressSpec Field

NWK_BEACON_NOTIFY_INDICATION.PendingAddressSpec Field
[image]

The beacon pending address specification

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PendingAddressSpec As Byte
C#
public byte PendingAddressSpec;
C++
public:
char PendingAddressSpec sealed ;
J#
public byte PendingAddressSpec
JScript
public PendingAddressSpec : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


SDU Field

NWK_BEACON_NOTIFY_INDICATION.SDU Field
[image]

Actual SDU data. Can be 0-32 bytes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SDU As Byte()
C#
public byte[] SDU;
C++
public:
array<char>^ SDU sealed ;
J#
public byte[] SDU
JScript
public SDU : Byte[];

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


SDULength Field

NWK_BEACON_NOTIFY_INDICATION.SDULength Field
[image]

Length of the SDU data

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SDULength As Byte
C#
public byte SDULength;
C++
public:
char SDULength sealed ;
J#
public byte SDULength
JScript
public SDULength : Byte;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


SecurityFailure Field

NWK_BEACON_NOTIFY_INDICATION.SecurityFailure Field
[image]

Set to TRUE if there was an error in the security processing

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityFailure As NWK_BEACON_NOTIFY_INDICATION.BOOLEAN
C#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN SecurityFailure;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.BOOLEAN SecurityFailure sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.BOOLEAN SecurityFailure
JScript
public SecurityFailure : NWK_BEACON_NOTIFY_INDICATION.BOOLEAN;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_BEACON_NOTIFY_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL
C#
public NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


SuperFrameSpec Field

NWK_BEACON_NOTIFY_INDICATION.SuperFrameSpec Field
[image]

The superframe specification of the network

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameSpec As UInt16
C#
public ushort SuperFrameSpec;
C++
public:
unsigned short SuperFrameSpec sealed ;
J#
public ushort SuperFrameSpec
JScript
public SuperFrameSpec : UInt16;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


TimeStamp Field

NWK_BEACON_NOTIFY_INDICATION.TimeStamp Field
[image]

Time stamp when the beacon is received

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp As UInt32
C#
public uint TimeStamp;
C++
public:
unsigned int TimeStamp sealed ;
J#
public uint TimeStamp
JScript
public TimeStamp : UInt32;

See Also

NWK_BEACON_NOTIFY_INDICATION Class
TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE Enumeration

NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION.BOOLEAN Enumeration

NWK_BEACON_NOTIFY_INDICATION.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.BOOLEAN : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE Enumeration

NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL Enumeration

NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION Class

NWK_COMM_STATUS_INDICATION Class
See Also Example Members
[image]

This function reports a comm status error

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_COMM_STATUS_INDICATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_COMM_STATUS_INDICATION : ICONFIRMATION, INETWORK
C++
ref class NWK_COMM_STATUS_INDICATION : ICONFIRMATION, INETWORK
J#
public class NWK_COMM_STATUS_INDICATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_COMM_STATUS_INDICATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_COMM_STATUS_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_COMM_STATUS_INDICATION Members
TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION Members

NWK_COMM_STATUS_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports a comm status error

The following tables list the members exposed by NWK_COMM_STATUS_INDICATION.

Public Constructors

Name | Description
NWK_COMM_STATUS_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | PanID | Pan Id of the Remote device
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Indicates the format of the source address.
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_COMM_STATUS_INDICATION | Overloaded.
Top

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION Constructor

NWK_COMM_STATUS_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_COMM_STATUS_INDICATION | Constructor
Public method | NWK_COMM_STATUS_INDICATION (NWK_COMM_STATUS_INDICATION.CMD_STATUS, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, UInt16, Byte, Byte, NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION Constructor ()

NWK_COMM_STATUS_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_COMM_STATUS_INDICATION()
C++
public:
NWK_COMM_STATUS_INDICATION() sealed
J#
public NWK_COMM_STATUS_INDICATION()
JScript
public function NWK_COMM_STATUS_INDICATION()

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace
NWK_COMM_STATUS_INDICATION Constructor Overload List


NWK_COMM_STATUS_INDICATION Constructor (NWK_COMM_STATUS_INDICATION.CMD_STATUS, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, UInt16, Byte, Byte[], NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, Byte)

NWK_COMM_STATUS_INDICATION Constructor (NWK_COMM_STATUS_INDICATION.CMD_STATUS, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, UInt64, UInt16, Byte, Byte[], NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_COMM_STATUS_INDICATION.CMD_STATUS, _
ByVal As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_COMM_STATUS_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_COMM_STATUS_INDICATION(
NWK_COMM_STATUS_INDICATION.CMD_STATUS ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
byte ,
byte[] ,
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL ,
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_COMM_STATUS_INDICATION(
NWK_COMM_STATUS_INDICATION.CMD_STATUS ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
char ,
array<char>^ ,
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL ,
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_COMM_STATUS_INDICATION(
NWK_COMM_STATUS_INDICATION.CMD_STATUS ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE ,
ulong ,
ushort ,
byte ,
byte[] ,
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL ,
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_COMM_STATUS_INDICATION(
: NWK_COMM_STATUS_INDICATION.CMD_STATUS,
: NWK_COMM_STATUS_INDICATION.ADDRESS_MODE,
: UInt64,
: NWK_COMM_STATUS_INDICATION.ADDRESS_MODE,
: UInt64,
: UInt16,
: Byte,
: Byte[],
: NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL,
: NWK_COMM_STATUS_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace
NWK_COMM_STATUS_INDICATION Constructor Overload List


Fields

NWK_COMM_STATUS_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | PanID | Pan Id of the Remote device
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Indicates the format of the source address.
Public field | Status | Status
Top

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


DestAddress Field

NWK_COMM_STATUS_INDICATION.DestAddress Field
[image]

Address of the Remote device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


DestAddressMode Field

NWK_COMM_STATUS_INDICATION.DestAddressMode Field
[image]

Remote device Address Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressMode As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE
C#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE DestAddressMode;
C++
public:
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE DestAddressMode sealed ;
J#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE DestAddressMode
JScript
public DestAddressMode : NWK_COMM_STATUS_INDICATION.ADDRESS_MODE;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_COMM_STATUS_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_COMM_STATUS_INDICATION.KEY_ID_MODE
C#
public NWK_COMM_STATUS_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_COMM_STATUS_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_COMM_STATUS_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_COMM_STATUS_INDICATION.KEY_ID_MODE;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_COMM_STATUS_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_COMM_STATUS_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


PanID Field

NWK_COMM_STATUS_INDICATION.PanID Field
[image]

Pan Id of the Remote device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


Reason Field

NWK_COMM_STATUS_INDICATION.Reason Field
[image]

Synchronization lost Reason

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reason As Byte
C#
public byte Reason;
C++
public:
char Reason sealed ;
J#
public byte Reason
JScript
public Reason : Byte;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_COMM_STATUS_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL
C#
public NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


SrcAddress Field

NWK_COMM_STATUS_INDICATION.SrcAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


SrcAddressMode Field

NWK_COMM_STATUS_INDICATION.SrcAddressMode Field
[image]

Indicates the format of the source address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddressMode As NWK_COMM_STATUS_INDICATION.ADDRESS_MODE
C#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE SrcAddressMode;
C++
public:
NWK_COMM_STATUS_INDICATION.ADDRESS_MODE SrcAddressMode sealed ;
J#
public NWK_COMM_STATUS_INDICATION.ADDRESS_MODE SrcAddressMode
JScript
public SrcAddressMode : NWK_COMM_STATUS_INDICATION.ADDRESS_MODE;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


Status Field

NWK_COMM_STATUS_INDICATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_COMM_STATUS_INDICATION.CMD_STATUS
C#
public NWK_COMM_STATUS_INDICATION.CMD_STATUS Status;
C++
public:
NWK_COMM_STATUS_INDICATION.CMD_STATUS Status sealed ;
J#
public NWK_COMM_STATUS_INDICATION.CMD_STATUS Status
JScript
public Status : NWK_COMM_STATUS_INDICATION.CMD_STATUS;

See Also

NWK_COMM_STATUS_INDICATION Class
TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION.ADDRESS_MODE Enumeration

NWK_COMM_STATUS_INDICATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.ADDRESS_MODE : char
J#
public enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE byte
JScript
public enum NWK_COMM_STATUS_INDICATION.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION.CMD_STATUS Enumeration

NWK_COMM_STATUS_INDICATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.CMD_STATUS As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.CMD_STATUS : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.CMD_STATUS : char
J#
public enum NWK_COMM_STATUS_INDICATION.CMD_STATUS byte
JScript
public enum NWK_COMM_STATUS_INDICATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION.KEY_ID_MODE Enumeration

NWK_COMM_STATUS_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_COMM_STATUS_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL Enumeration

NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


NWK_DATA_CONFIRMATION Class

NWK_DATA_CONFIRMATION Class
See Also Example Members
[image]

This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DATA_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_DATA_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_DATA_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_DATA_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_DATA_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DATA_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_DATA_CONFIRMATION Members

NWK_DATA_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to send the results of a request to transfer a data SPDU (MSDU) from a local SSCS entity to a single peer SSCS entity, or multiple peer SSCS entities.

The following tables list the members exposed by NWK_DATA_CONFIRMATION.

Public Constructors

Name | Description
NWK_DATA_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MsduHandle | Handle of the frame
Public field | Status | Status of the frame
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DATA_CONFIRMATION | Overloaded.
Top

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_DATA_CONFIRMATION Constructor

NWK_DATA_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_DATA_CONFIRMATION | Constructor
Public method | NWK_DATA_CONFIRMATION (NWK_DATA_CONFIRMATION.CMD_STATUS, Byte, UInt32, UInt16) |

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_DATA_CONFIRMATION Constructor ()

NWK_DATA_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DATA_CONFIRMATION()
C++
public:
NWK_DATA_CONFIRMATION() sealed
J#
public NWK_DATA_CONFIRMATION()
JScript
public function NWK_DATA_CONFIRMATION()

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_DATA_CONFIRMATION Constructor Overload List


NWK_DATA_CONFIRMATION Constructor (NWK_DATA_CONFIRMATION.CMD_STATUS, Byte, UInt32, UInt16)

NWK_DATA_CONFIRMATION Constructor (NWK_DATA_CONFIRMATION.CMD_STATUS, Byte, UInt32, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_DATA_CONFIRMATION.CMD_STATUS, _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As UInt16 _
)
C#
public NWK_DATA_CONFIRMATION(
NWK_DATA_CONFIRMATION.CMD_STATUS ,
byte ,
uint ,
ushort
)
C++
public:
NWK_DATA_CONFIRMATION(
NWK_DATA_CONFIRMATION.CMD_STATUS ,
char ,
unsigned int ,
unsigned short
) sealed
J#
public NWK_DATA_CONFIRMATION(
NWK_DATA_CONFIRMATION.CMD_STATUS ,
byte ,
uint ,
ushort
)
JScript
public function NWK_DATA_CONFIRMATION(
: NWK_DATA_CONFIRMATION.CMD_STATUS,
: Byte,
: UInt32,
: UInt16
)

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_DATA_CONFIRMATION Constructor Overload List


Fields

NWK_DATA_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | MsduHandle | Handle of the frame
Public field | Status | Status of the frame
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


MsduHandle Field

NWK_DATA_CONFIRMATION.MsduHandle Field
[image]

Handle of the frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsduHandle As Byte
C#
public byte MsduHandle;
C++
public:
char MsduHandle sealed ;
J#
public byte MsduHandle
JScript
public MsduHandle : Byte;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_DATA_CONFIRMATION.Status Field
[image]

Status of the frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_DATA_CONFIRMATION.CMD_STATUS
C#
public NWK_DATA_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_DATA_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_DATA_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_DATA_CONFIRMATION.CMD_STATUS;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


TimeStamp Field

NWK_DATA_CONFIRMATION.TimeStamp Field
[image]

The time, in backoffs, at which the data were received

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp As UInt32
C#
public uint TimeStamp;
C++
public:
unsigned int TimeStamp sealed ;
J#
public uint TimeStamp
JScript
public TimeStamp : UInt32;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


TimeStamp2 Field

NWK_DATA_CONFIRMATION.TimeStamp2 Field
[image]

The time, in internal MAC timer units, at which the data were recieved

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp2 As UInt16
C#
public ushort TimeStamp2;
C++
public:
unsigned short TimeStamp2 sealed ;
J#
public ushort TimeStamp2
JScript
public TimeStamp2 : UInt16;

See Also

NWK_DATA_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_DATA_CONFIRMATION.CMD_STATUS Enumeration

NWK_DATA_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_DATA_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_DATA_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_DATA_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_DATA_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_DATA_INDICATION Class

NWK_DATA_INDICATION Class
See Also Example Members
[image]

This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DATA_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_DATA_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_DATA_INDICATION : IINDICATION, INETWORK
J#
public class NWK_DATA_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_DATA_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_DATA_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DATA_INDICATION Members
TI.ZPI2 Namespace


NWK_DATA_INDICATION Members

NWK_DATA_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function indicates the transfer of a data SPDU (MSDU) from the MAC sublayer to the local SSCS entity.

The following tables list the members exposed by NWK_DATA_INDICATION.

Public Constructors

Name | Description
NWK_DATA_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | DestPanID | Pan Id of the Remote device
Public field | Dsn | Dsn
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Lqi | Raw LQI of the received data frame
Public field | mpduLinkQuality | Link Quality
Public field | MSDU | The actual data
Public field | MSDULength | Length of the data
Public field | Rssi | Raw RSSI of the received data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Initiating device Address Mode
Public field | SrcPanID | Pan Id of the initiating device
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DATA_INDICATION | Overloaded.
Top

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


NWK_DATA_INDICATION Constructor

NWK_DATA_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_DATA_INDICATION | Constructor
Public method | NWK_DATA_INDICATION (NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, NWK_DATA_INDICATION.SECURITY_LEVEL, NWK_DATA_INDICATION.KEY_ID_MODE, Byte, Byte, Byte) |

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


NWK_DATA_INDICATION Constructor ()

NWK_DATA_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DATA_INDICATION()
C++
public:
NWK_DATA_INDICATION() sealed
J#
public NWK_DATA_INDICATION()
JScript
public function NWK_DATA_INDICATION()

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace
NWK_DATA_INDICATION Constructor Overload List


NWK_DATA_INDICATION Constructor (NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], NWK_DATA_INDICATION.SECURITY_LEVEL, NWK_DATA_INDICATION.KEY_ID_MODE, Byte, Byte, Byte[])

NWK_DATA_INDICATION Constructor (NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, NWK_DATA_INDICATION.ADDRESS_MODE, UInt64, UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], NWK_DATA_INDICATION.SECURITY_LEVEL, NWK_DATA_INDICATION.KEY_ID_MODE, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_DATA_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As NWK_DATA_INDICATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt32, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As NWK_DATA_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_DATA_INDICATION.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public NWK_DATA_INDICATION(
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
uint ,
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
NWK_DATA_INDICATION.SECURITY_LEVEL ,
NWK_DATA_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
C++
public:
NWK_DATA_INDICATION(
NWK_DATA_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
NWK_DATA_INDICATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned int ,
unsigned short ,
unsigned short ,
unsigned short ,
char ,
char ,
char ,
char ,
array<char>^ ,
NWK_DATA_INDICATION.SECURITY_LEVEL ,
NWK_DATA_INDICATION.KEY_ID_MODE ,
char ,
char ,
array<char>^
) sealed
J#
public NWK_DATA_INDICATION(
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
NWK_DATA_INDICATION.ADDRESS_MODE ,
ulong ,
uint ,
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
NWK_DATA_INDICATION.SECURITY_LEVEL ,
NWK_DATA_INDICATION.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
JScript
public function NWK_DATA_INDICATION(
: NWK_DATA_INDICATION.ADDRESS_MODE,
: UInt64,
: NWK_DATA_INDICATION.ADDRESS_MODE,
: UInt64,
: UInt32,
: UInt16,
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[],
: NWK_DATA_INDICATION.SECURITY_LEVEL,
: NWK_DATA_INDICATION.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[]
)

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace
NWK_DATA_INDICATION Constructor Overload List


Fields

NWK_DATA_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | Address of the Remote device
Public field | DestAddressMode | Remote device Address Mode
Public field | DestPanID | Pan Id of the Remote device
Public field | Dsn | Dsn
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Lqi | Raw LQI of the received data frame
Public field | mpduLinkQuality | Link Quality
Public field | MSDU | The actual data
Public field | MSDULength | Length of the data
Public field | Rssi | Raw RSSI of the received data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddress | Address of the initiating device
Public field | SrcAddressMode | Initiating device Address Mode
Public field | SrcPanID | Pan Id of the initiating device
Public field | TimeStamp | The time, in backoffs, at which the data were received
Public field | TimeStamp2 | The time, in internal MAC timer units, at which the data were recieved
Top

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


DestAddress Field

NWK_DATA_INDICATION.DestAddress Field
[image]

Address of the Remote device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


DestAddressMode Field

NWK_DATA_INDICATION.DestAddressMode Field
[image]

Remote device Address Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressMode As NWK_DATA_INDICATION.ADDRESS_MODE
C#
public NWK_DATA_INDICATION.ADDRESS_MODE DestAddressMode;
C++
public:
NWK_DATA_INDICATION.ADDRESS_MODE DestAddressMode sealed ;
J#
public NWK_DATA_INDICATION.ADDRESS_MODE DestAddressMode
JScript
public DestAddressMode : NWK_DATA_INDICATION.ADDRESS_MODE;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


DestPanID Field

NWK_DATA_INDICATION.DestPanID Field
[image]

Pan Id of the Remote device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestPanID As UInt16
C#
public ushort DestPanID;
C++
public:
unsigned short DestPanID sealed ;
J#
public ushort DestPanID
JScript
public DestPanID : UInt16;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


Dsn Field

NWK_DATA_INDICATION.Dsn Field
[image]

Dsn

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Dsn As Byte
C#
public byte Dsn;
C++
public:
char Dsn sealed ;
J#
public byte Dsn
JScript
public Dsn : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_DATA_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_DATA_INDICATION.KEY_ID_MODE
C#
public NWK_DATA_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_DATA_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_DATA_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_DATA_INDICATION.KEY_ID_MODE;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_DATA_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_DATA_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


Lqi Field

NWK_DATA_INDICATION.Lqi Field
[image]

Raw LQI of the received data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Lqi As Byte
C#
public byte Lqi;
C++
public:
char Lqi sealed ;
J#
public byte Lqi
JScript
public Lqi : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


mpduLinkQuality Field

NWK_DATA_INDICATION.mpduLinkQuality Field
[image]

Link Quality

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public mpduLinkQuality As Byte
C#
public byte mpduLinkQuality;
C++
public:
char mpduLinkQuality sealed ;
J#
public byte mpduLinkQuality
JScript
public mpduLinkQuality : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


MSDU Field

NWK_DATA_INDICATION.MSDU Field
[image]

The actual data

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDU As Byte()
C#
public byte[] MSDU;
C++
public:
array<char>^ MSDU sealed ;
J#
public byte[] MSDU
JScript
public MSDU : Byte[];

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


MSDULength Field

NWK_DATA_INDICATION.MSDULength Field
[image]

Length of the data

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDULength As Byte
C#
public byte MSDULength;
C++
public:
char MSDULength sealed ;
J#
public byte MSDULength
JScript
public MSDULength : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


Rssi Field

NWK_DATA_INDICATION.Rssi Field
[image]

Raw RSSI of the received data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Rssi As Byte
C#
public byte Rssi;
C++
public:
char Rssi sealed ;
J#
public byte Rssi
JScript
public Rssi : Byte;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_DATA_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_DATA_INDICATION.SECURITY_LEVEL
C#
public NWK_DATA_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_DATA_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_DATA_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_DATA_INDICATION.SECURITY_LEVEL;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


SrcAddress Field

NWK_DATA_INDICATION.SrcAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


SrcAddressMode Field

NWK_DATA_INDICATION.SrcAddressMode Field
[image]

Initiating device Address Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddressMode As NWK_DATA_INDICATION.ADDRESS_MODE
C#
public NWK_DATA_INDICATION.ADDRESS_MODE SrcAddressMode;
C++
public:
NWK_DATA_INDICATION.ADDRESS_MODE SrcAddressMode sealed ;
J#
public NWK_DATA_INDICATION.ADDRESS_MODE SrcAddressMode
JScript
public SrcAddressMode : NWK_DATA_INDICATION.ADDRESS_MODE;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


SrcPanID Field

NWK_DATA_INDICATION.SrcPanID Field
[image]

Pan Id of the initiating device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcPanID As UInt16
C#
public ushort SrcPanID;
C++
public:
unsigned short SrcPanID sealed ;
J#
public ushort SrcPanID
JScript
public SrcPanID : UInt16;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


TimeStamp Field

NWK_DATA_INDICATION.TimeStamp Field
[image]

The time, in backoffs, at which the data were received

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp As UInt32
C#
public uint TimeStamp;
C++
public:
unsigned int TimeStamp sealed ;
J#
public uint TimeStamp
JScript
public TimeStamp : UInt32;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


TimeStamp2 Field

NWK_DATA_INDICATION.TimeStamp2 Field
[image]

The time, in internal MAC timer units, at which the data were recieved

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TimeStamp2 As UInt16
C#
public ushort TimeStamp2;
C++
public:
unsigned short TimeStamp2 sealed ;
J#
public ushort TimeStamp2
JScript
public TimeStamp2 : UInt16;

See Also

NWK_DATA_INDICATION Class
TI.ZPI2 Namespace


NWK_DATA_INDICATION.ADDRESS_MODE Enumeration

NWK_DATA_INDICATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_INDICATION.ADDRESS_MODE As Byte
C#
public enum NWK_DATA_INDICATION.ADDRESS_MODE : byte
C++
public enum class NWK_DATA_INDICATION.ADDRESS_MODE : char
J#
public enum NWK_DATA_INDICATION.ADDRESS_MODE byte
JScript
public enum NWK_DATA_INDICATION.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


NWK_DATA_INDICATION.KEY_ID_MODE Enumeration

NWK_DATA_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_DATA_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_DATA_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_DATA_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_DATA_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_DATA_INDICATION.SECURITY_LEVEL Enumeration

NWK_DATA_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DATA_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_DATA_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_DATA_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_DATA_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_DATA_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


NWK_DISASSOCIATE_CONFIRMATION Class

NWK_DISASSOCIATE_CONFIRMATION Class
See Also Example Members
[image]

This function is sent as the result of a disassociation request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DISASSOCIATE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_DISASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_DISASSOCIATE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_DISASSOCIATE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_DISASSOCIATE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_DISASSOCIATE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DISASSOCIATE_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_DISASSOCIATE_CONFIRMATION Members

NWK_DISASSOCIATE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is sent as the result of a disassociation request.

The following tables list the members exposed by NWK_DISASSOCIATE_CONFIRMATION.

Public Constructors

Name | Description
NWK_DISASSOCIATE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DeviceAddressMode | Specifies the format of the device address.
Public field | PanID | PAN ID of the remote device
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DISASSOCIATE_CONFIRMATION | Overloaded.
Top

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_DISASSOCIATE_CONFIRMATION Constructor

NWK_DISASSOCIATE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_DISASSOCIATE_CONFIRMATION | Constructor
Public method | NWK_DISASSOCIATE_CONFIRMATION (NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, UInt64, UInt16) |

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_DISASSOCIATE_CONFIRMATION Constructor ()

NWK_DISASSOCIATE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DISASSOCIATE_CONFIRMATION()
C++
public:
NWK_DISASSOCIATE_CONFIRMATION() sealed
J#
public NWK_DISASSOCIATE_CONFIRMATION()
JScript
public function NWK_DISASSOCIATE_CONFIRMATION()

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_DISASSOCIATE_CONFIRMATION Constructor Overload List


NWK_DISASSOCIATE_CONFIRMATION Constructor (NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, UInt64, UInt16)

NWK_DISASSOCIATE_CONFIRMATION Constructor (NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, UInt64, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS, _
ByVal As NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16 _
)
C#
public NWK_DISASSOCIATE_CONFIRMATION(
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS ,
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE ,
ulong ,
ushort
)
C++
public:
NWK_DISASSOCIATE_CONFIRMATION(
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS ,
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short
) sealed
J#
public NWK_DISASSOCIATE_CONFIRMATION(
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS ,
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE ,
ulong ,
ushort
)
JScript
public function NWK_DISASSOCIATE_CONFIRMATION(
: NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS,
: NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE,
: UInt64,
: UInt16
)

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_DISASSOCIATE_CONFIRMATION Constructor Overload List


Fields

NWK_DISASSOCIATE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DeviceAddressMode | Specifies the format of the device address.
Public field | PanID | PAN ID of the remote device
Public field | Status | Status
Top

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


DeviceAddress Field

NWK_DISASSOCIATE_CONFIRMATION.DeviceAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


DeviceAddressMode Field

NWK_DISASSOCIATE_CONFIRMATION.DeviceAddressMode Field
[image]

Specifies the format of the device address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddressMode As NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE
C#
public NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE DeviceAddressMode;
C++
public:
NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE DeviceAddressMode sealed ;
J#
public NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE DeviceAddressMode
JScript
public DeviceAddressMode : NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


PanID Field

NWK_DISASSOCIATE_CONFIRMATION.PanID Field
[image]

PAN ID of the remote device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_DISASSOCIATE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS
C#
public NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS;

See Also

NWK_DISASSOCIATE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE Enumeration

NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE As Byte
C#
public enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE : byte
C++
public enum class NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE : char
J#
public enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE byte
JScript
public enum NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration

NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_DISASSOCIATE_INDICATION Class

NWK_DISASSOCIATE_INDICATION Class
See Also Example Members
[image]

This function is used to indicate the reception of a disassociation notification command.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_DISASSOCIATE_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_DISASSOCIATE_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_DISASSOCIATE_INDICATION : IINDICATION, INETWORK
J#
public class NWK_DISASSOCIATE_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_DISASSOCIATE_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_DISASSOCIATE_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_DISASSOCIATE_INDICATION Members
TI.ZPI2 Namespace


NWK_DISASSOCIATE_INDICATION Members

NWK_DISASSOCIATE_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function is used to indicate the reception of a disassociation notification command.

The following tables list the members exposed by NWK_DISASSOCIATE_INDICATION.

Public Constructors

Name | Description
NWK_DISASSOCIATE_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DisassociateReason | Reason of the disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_DISASSOCIATE_INDICATION | Overloaded.
Top

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


NWK_DISASSOCIATE_INDICATION Constructor

NWK_DISASSOCIATE_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_DISASSOCIATE_INDICATION | Constructor
Public method | NWK_DISASSOCIATE_INDICATION (UInt64, NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, Byte, NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


NWK_DISASSOCIATE_INDICATION Constructor ()

NWK_DISASSOCIATE_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_DISASSOCIATE_INDICATION()
C++
public:
NWK_DISASSOCIATE_INDICATION() sealed
J#
public NWK_DISASSOCIATE_INDICATION()
JScript
public function NWK_DISASSOCIATE_INDICATION()

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace
NWK_DISASSOCIATE_INDICATION Constructor Overload List


NWK_DISASSOCIATE_INDICATION Constructor (UInt64, NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, Byte[], NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, Byte)

NWK_DISASSOCIATE_INDICATION Constructor (UInt64, NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, Byte[], NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON, _
ByVal As Byte(), _
ByVal As NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_DISASSOCIATE_INDICATION(
ulong ,
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON ,
byte[] ,
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_DISASSOCIATE_INDICATION(
unsigned __int64 ,
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON ,
array<char>^ ,
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_DISASSOCIATE_INDICATION(
ulong ,
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON ,
byte[] ,
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL ,
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_DISASSOCIATE_INDICATION(
: UInt64,
: NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON,
: Byte[],
: NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL,
: NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace
NWK_DISASSOCIATE_INDICATION Constructor Overload List


Fields

NWK_DISASSOCIATE_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | Address of the initiating device
Public field | DisassociateReason | Reason of the disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


DeviceAddress Field

NWK_DISASSOCIATE_INDICATION.DeviceAddress Field
[image]

Address of the initiating device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


DisassociateReason Field

NWK_DISASSOCIATE_INDICATION.DisassociateReason Field
[image]

Reason of the disassociation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DisassociateReason As NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON
C#
public NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON DisassociateReason;
C++
public:
NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON DisassociateReason sealed ;
J#
public NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON DisassociateReason
JScript
public DisassociateReason : NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_DISASSOCIATE_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE
C#
public NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_DISASSOCIATE_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_DISASSOCIATE_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_DISASSOCIATE_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL
C#
public NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL;

See Also

NWK_DISASSOCIATE_INDICATION Class
TI.ZPI2 Namespace


NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON Enumeration

NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON Enumeration
[image]

Valid disassociation reason codes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON As Byte
C#
public enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON : byte
C++
public enum class NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON : char
J#
public enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON byte
JScript
public enum NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON :

Members

Member Name | Description
0x00 (RESERVED) | Valid disassociation reason codes
0x01 (COOR_WISHES_DEV_LEAVE) | Valid disassociation reason codes
0x02 (DEV_WISHES_LEAVE) | Valid disassociation reason codes

See Also

TI.ZPI2 Namespace


NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE Enumeration

NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration

NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


NWK_ORPHAN_INDICATION Class

NWK_ORPHAN_INDICATION Class
See Also Example Members
[image]

This function allows the MLME to notify the next higher layer of an orphaned device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_ORPHAN_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_ORPHAN_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_ORPHAN_INDICATION : IINDICATION, INETWORK
J#
public class NWK_ORPHAN_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_ORPHAN_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_ORPHAN_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_ORPHAN_INDICATION Members
TI.ZPI2 Namespace


NWK_ORPHAN_INDICATION Members

NWK_ORPHAN_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function allows the MLME to notify the next higher layer of an orphaned device

The following tables list the members exposed by NWK_ORPHAN_INDICATION.

Public Constructors

Name | Description
NWK_ORPHAN_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | OrphanAddress | Orphan Address
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_ORPHAN_INDICATION | Overloaded.
Top

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


NWK_ORPHAN_INDICATION Constructor

NWK_ORPHAN_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_ORPHAN_INDICATION | Constructor
Public method | NWK_ORPHAN_INDICATION (UInt64, Byte, NWK_ORPHAN_INDICATION.SECURITY_LEVEL, NWK_ORPHAN_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


NWK_ORPHAN_INDICATION Constructor ()

NWK_ORPHAN_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_ORPHAN_INDICATION()
C++
public:
NWK_ORPHAN_INDICATION() sealed
J#
public NWK_ORPHAN_INDICATION()
JScript
public function NWK_ORPHAN_INDICATION()

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace
NWK_ORPHAN_INDICATION Constructor Overload List


NWK_ORPHAN_INDICATION Constructor (UInt64, Byte[], NWK_ORPHAN_INDICATION.SECURITY_LEVEL, NWK_ORPHAN_INDICATION.KEY_ID_MODE, Byte)

NWK_ORPHAN_INDICATION Constructor (UInt64, Byte[], NWK_ORPHAN_INDICATION.SECURITY_LEVEL, NWK_ORPHAN_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte(), _
ByVal As NWK_ORPHAN_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_ORPHAN_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_ORPHAN_INDICATION(
ulong ,
byte[] ,
NWK_ORPHAN_INDICATION.SECURITY_LEVEL ,
NWK_ORPHAN_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_ORPHAN_INDICATION(
unsigned __int64 ,
array<char>^ ,
NWK_ORPHAN_INDICATION.SECURITY_LEVEL ,
NWK_ORPHAN_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_ORPHAN_INDICATION(
ulong ,
byte[] ,
NWK_ORPHAN_INDICATION.SECURITY_LEVEL ,
NWK_ORPHAN_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_ORPHAN_INDICATION(
: UInt64,
: Byte[],
: NWK_ORPHAN_INDICATION.SECURITY_LEVEL,
: NWK_ORPHAN_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace
NWK_ORPHAN_INDICATION Constructor Overload List


Fields

NWK_ORPHAN_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | OrphanAddress | Orphan Address
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_ORPHAN_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_ORPHAN_INDICATION.KEY_ID_MODE
C#
public NWK_ORPHAN_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_ORPHAN_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_ORPHAN_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_ORPHAN_INDICATION.KEY_ID_MODE;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_ORPHAN_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_ORPHAN_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


OrphanAddress Field

NWK_ORPHAN_INDICATION.OrphanAddress Field
[image]

Orphan Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OrphanAddress As UInt64
C#
public ulong OrphanAddress;
C++
public:
unsigned __int64 OrphanAddress sealed ;
J#
public ulong OrphanAddress
JScript
public OrphanAddress : UInt64;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_ORPHAN_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_ORPHAN_INDICATION.SECURITY_LEVEL
C#
public NWK_ORPHAN_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_ORPHAN_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_ORPHAN_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_ORPHAN_INDICATION.SECURITY_LEVEL;

See Also

NWK_ORPHAN_INDICATION Class
TI.ZPI2 Namespace


NWK_ORPHAN_INDICATION.KEY_ID_MODE Enumeration

NWK_ORPHAN_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ORPHAN_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_ORPHAN_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_ORPHAN_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_ORPHAN_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_ORPHAN_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_ORPHAN_INDICATION.SECURITY_LEVEL Enumeration

NWK_ORPHAN_INDICATION.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_ORPHAN_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_ORPHAN_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


NWK_POLL_CONFIRMATION Class

NWK_POLL_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of a polling attempt.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_POLL_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_POLL_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_POLL_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_POLL_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_POLL_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_POLL_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_POLL_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_POLL_CONFIRMATION Members

NWK_POLL_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of a polling attempt.

The following tables list the members exposed by NWK_POLL_CONFIRMATION.

Public Constructors

Name | Description
NWK_POLL_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_POLL_CONFIRMATION | Overloaded.
Top

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_POLL_CONFIRMATION Constructor

NWK_POLL_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_POLL_CONFIRMATION | Constructor
Public method | NWK_POLL_CONFIRMATION (NWK_POLL_CONFIRMATION.CMD_STATUS) |

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_POLL_CONFIRMATION Constructor ()

NWK_POLL_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_POLL_CONFIRMATION()
C++
public:
NWK_POLL_CONFIRMATION() sealed
J#
public NWK_POLL_CONFIRMATION()
JScript
public function NWK_POLL_CONFIRMATION()

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_POLL_CONFIRMATION Constructor Overload List


NWK_POLL_CONFIRMATION Constructor (NWK_POLL_CONFIRMATION.CMD_STATUS)

NWK_POLL_CONFIRMATION Constructor (NWK_POLL_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_POLL_CONFIRMATION.CMD_STATUS _
)
C#
public NWK_POLL_CONFIRMATION(
NWK_POLL_CONFIRMATION.CMD_STATUS
)
C++
public:
NWK_POLL_CONFIRMATION(
NWK_POLL_CONFIRMATION.CMD_STATUS
) sealed
J#
public NWK_POLL_CONFIRMATION(
NWK_POLL_CONFIRMATION.CMD_STATUS
)
JScript
public function NWK_POLL_CONFIRMATION(
: NWK_POLL_CONFIRMATION.CMD_STATUS
)

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_POLL_CONFIRMATION Constructor Overload List


Fields

NWK_POLL_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_POLL_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_POLL_CONFIRMATION.CMD_STATUS
C#
public NWK_POLL_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_POLL_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_POLL_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_POLL_CONFIRMATION.CMD_STATUS;

See Also

NWK_POLL_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_POLL_CONFIRMATION.CMD_STATUS Enumeration

NWK_POLL_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_POLL_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_POLL_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_POLL_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_POLL_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_POLL_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_PURGE_CONFIRMATION Class

NWK_PURGE_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of a purge attempt.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_PURGE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_PURGE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_PURGE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_PURGE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_PURGE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_PURGE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_PURGE_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_PURGE_CONFIRMATION Members

NWK_PURGE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of a purge attempt.

The following tables list the members exposed by NWK_PURGE_CONFIRMATION.

Public Constructors

Name | Description
NWK_PURGE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MsduHandle | Application-defined handle value associated with the data request.
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_PURGE_CONFIRMATION | Overloaded.
Top

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_PURGE_CONFIRMATION Constructor

NWK_PURGE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_PURGE_CONFIRMATION | Constructor
Public method | NWK_PURGE_CONFIRMATION (NWK_PURGE_CONFIRMATION.CMD_STATUS, Byte) |

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_PURGE_CONFIRMATION Constructor ()

NWK_PURGE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_PURGE_CONFIRMATION()
C++
public:
NWK_PURGE_CONFIRMATION() sealed
J#
public NWK_PURGE_CONFIRMATION()
JScript
public function NWK_PURGE_CONFIRMATION()

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_PURGE_CONFIRMATION Constructor Overload List


NWK_PURGE_CONFIRMATION Constructor (NWK_PURGE_CONFIRMATION.CMD_STATUS, Byte)

NWK_PURGE_CONFIRMATION Constructor (NWK_PURGE_CONFIRMATION.CMD_STATUS, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_PURGE_CONFIRMATION.CMD_STATUS, _
ByVal As Byte _
)
C#
public NWK_PURGE_CONFIRMATION(
NWK_PURGE_CONFIRMATION.CMD_STATUS ,
byte
)
C++
public:
NWK_PURGE_CONFIRMATION(
NWK_PURGE_CONFIRMATION.CMD_STATUS ,
char
) sealed
J#
public NWK_PURGE_CONFIRMATION(
NWK_PURGE_CONFIRMATION.CMD_STATUS ,
byte
)
JScript
public function NWK_PURGE_CONFIRMATION(
: NWK_PURGE_CONFIRMATION.CMD_STATUS,
: Byte
)

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_PURGE_CONFIRMATION Constructor Overload List


Fields

NWK_PURGE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | MsduHandle | Application-defined handle value associated with the data request.
Public field | Status | Status
Top

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI2 Namespace


MsduHandle Field

NWK_PURGE_CONFIRMATION.MsduHandle Field
[image]

Application-defined handle value associated with the data request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsduHandle As Byte
C#
public byte MsduHandle;
C++
public:
char MsduHandle sealed ;
J#
public byte MsduHandle
JScript
public MsduHandle : Byte;

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_PURGE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_PURGE_CONFIRMATION.CMD_STATUS
C#
public NWK_PURGE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_PURGE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_PURGE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_PURGE_CONFIRMATION.CMD_STATUS;

See Also

NWK_PURGE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_PURGE_CONFIRMATION.CMD_STATUS Enumeration

NWK_PURGE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_PURGE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_PURGE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_PURGE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_PURGE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_PURGE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_RX_ENABLE_CONFIRMATION Class

NWK_RX_ENABLE_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of an RX enable attempt.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_RX_ENABLE_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_RX_ENABLE_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_RX_ENABLE_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_RX_ENABLE_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_RX_ENABLE_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_RX_ENABLE_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_RX_ENABLE_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_RX_ENABLE_CONFIRMATION Members

NWK_RX_ENABLE_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of an RX enable attempt.

The following tables list the members exposed by NWK_RX_ENABLE_CONFIRMATION.

Public Constructors

Name | Description
NWK_RX_ENABLE_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_RX_ENABLE_CONFIRMATION | Overloaded.
Top

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_RX_ENABLE_CONFIRMATION Constructor

NWK_RX_ENABLE_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_RX_ENABLE_CONFIRMATION | Constructor
Public method | NWK_RX_ENABLE_CONFIRMATION (NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS) |

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_RX_ENABLE_CONFIRMATION Constructor ()

NWK_RX_ENABLE_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_RX_ENABLE_CONFIRMATION()
C++
public:
NWK_RX_ENABLE_CONFIRMATION() sealed
J#
public NWK_RX_ENABLE_CONFIRMATION()
JScript
public function NWK_RX_ENABLE_CONFIRMATION()

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_RX_ENABLE_CONFIRMATION Constructor Overload List


NWK_RX_ENABLE_CONFIRMATION Constructor (NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS)

NWK_RX_ENABLE_CONFIRMATION Constructor (NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS _
)
C#
public NWK_RX_ENABLE_CONFIRMATION(
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
)
C++
public:
NWK_RX_ENABLE_CONFIRMATION(
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
) sealed
J#
public NWK_RX_ENABLE_CONFIRMATION(
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
)
JScript
public function NWK_RX_ENABLE_CONFIRMATION(
: NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
)

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_RX_ENABLE_CONFIRMATION Constructor Overload List


Fields

NWK_RX_ENABLE_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_RX_ENABLE_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
C#
public NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS;

See Also

NWK_RX_ENABLE_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Enumeration

NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_SCAN_CONFIRMATION Class

NWK_SCAN_CONFIRMATION Class
See Also Example Members
[image]

This function reports the results of a channel scan request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_SCAN_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_SCAN_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_SCAN_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_SCAN_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_SCAN_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_SCAN_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_SCAN_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_SCAN_CONFIRMATION Members

NWK_SCAN_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the results of a channel scan request.

The following tables list the members exposed by NWK_SCAN_CONFIRMATION.

Public Constructors

Name | Description
NWK_SCAN_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | EDMaxEnergy | Maximum possible energy detect value
Public field | ResultCount | Result Count
Public field | Results | List of energy measurements or PAN descriptors (depends on the scan type)
Public field | ScanType | ScanType
Public field | Status | Status of the scan request
Public field | UnscannedChannels | Bit mask of channels that were not scanned
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_SCAN_CONFIRMATION | Overloaded.
Top

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_SCAN_CONFIRMATION Constructor

NWK_SCAN_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_SCAN_CONFIRMATION | Constructor
Public method | NWK_SCAN_CONFIRMATION (NWK_SCAN_CONFIRMATION.CMD_STATUS, Byte, NWK_SCAN_CONFIRMATION.SCAN_TYPE, Byte, NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, Byte, Byte) |

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_SCAN_CONFIRMATION Constructor ()

NWK_SCAN_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_SCAN_CONFIRMATION()
C++
public:
NWK_SCAN_CONFIRMATION() sealed
J#
public NWK_SCAN_CONFIRMATION()
JScript
public function NWK_SCAN_CONFIRMATION()

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_SCAN_CONFIRMATION Constructor Overload List


NWK_SCAN_CONFIRMATION Constructor (NWK_SCAN_CONFIRMATION.CMD_STATUS, Byte, NWK_SCAN_CONFIRMATION.SCAN_TYPE, Byte, NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, Byte, Byte[])

NWK_SCAN_CONFIRMATION Constructor (NWK_SCAN_CONFIRMATION.CMD_STATUS, Byte, NWK_SCAN_CONFIRMATION.SCAN_TYPE, Byte, NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_SCAN_CONFIRMATION.CMD_STATUS, _
ByVal As Byte, _
ByVal As NWK_SCAN_CONFIRMATION.SCAN_TYPE, _
ByVal As Byte, _
ByVal As NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public NWK_SCAN_CONFIRMATION(
NWK_SCAN_CONFIRMATION.CMD_STATUS ,
byte ,
NWK_SCAN_CONFIRMATION.SCAN_TYPE ,
byte ,
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS ,
byte ,
byte[]
)
C++
public:
NWK_SCAN_CONFIRMATION(
NWK_SCAN_CONFIRMATION.CMD_STATUS ,
char ,
NWK_SCAN_CONFIRMATION.SCAN_TYPE ,
char ,
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS ,
char ,
array<char>^
) sealed
J#
public NWK_SCAN_CONFIRMATION(
NWK_SCAN_CONFIRMATION.CMD_STATUS ,
byte ,
NWK_SCAN_CONFIRMATION.SCAN_TYPE ,
byte ,
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS ,
byte ,
byte[]
)
JScript
public function NWK_SCAN_CONFIRMATION(
: NWK_SCAN_CONFIRMATION.CMD_STATUS,
: Byte,
: NWK_SCAN_CONFIRMATION.SCAN_TYPE,
: Byte,
: NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS,
: Byte,
: Byte[]
)

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_SCAN_CONFIRMATION Constructor Overload List


Fields

NWK_SCAN_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | EDMaxEnergy | Maximum possible energy detect value
Public field | ResultCount | Result Count
Public field | Results | List of energy measurements or PAN descriptors (depends on the scan type)
Public field | ScanType | ScanType
Public field | Status | Status of the scan request
Public field | UnscannedChannels | Bit mask of channels that were not scanned
Top

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


ChannelPage Field

NWK_SCAN_CONFIRMATION.ChannelPage Field
[image]

The channel page of the scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


EDMaxEnergy Field

NWK_SCAN_CONFIRMATION.EDMaxEnergy Field
[image]

Maximum possible energy detect value

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public EDMaxEnergy As Byte
C#
public byte EDMaxEnergy;
C++
public:
char EDMaxEnergy sealed ;
J#
public byte EDMaxEnergy
JScript
public EDMaxEnergy : Byte;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


ResultCount Field

NWK_SCAN_CONFIRMATION.ResultCount Field
[image]

Result Count

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ResultCount As Byte
C#
public byte ResultCount;
C++
public:
char ResultCount sealed ;
J#
public byte ResultCount
JScript
public ResultCount : Byte;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


Results Field

NWK_SCAN_CONFIRMATION.Results Field
[image]

List of energy measurements or PAN descriptors (depends on the scan type)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Results As Byte()
C#
public byte[] Results;
C++
public:
array<char>^ Results sealed ;
J#
public byte[] Results
JScript
public Results : Byte[];

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


ScanType Field

NWK_SCAN_CONFIRMATION.ScanType Field
[image]

ScanType

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanType As NWK_SCAN_CONFIRMATION.SCAN_TYPE
C#
public NWK_SCAN_CONFIRMATION.SCAN_TYPE ScanType;
C++
public:
NWK_SCAN_CONFIRMATION.SCAN_TYPE ScanType sealed ;
J#
public NWK_SCAN_CONFIRMATION.SCAN_TYPE ScanType
JScript
public ScanType : NWK_SCAN_CONFIRMATION.SCAN_TYPE;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_SCAN_CONFIRMATION.Status Field
[image]

Status of the scan request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_SCAN_CONFIRMATION.CMD_STATUS
C#
public NWK_SCAN_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_SCAN_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_SCAN_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_SCAN_CONFIRMATION.CMD_STATUS;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


UnscannedChannels Field

NWK_SCAN_CONFIRMATION.UnscannedChannels Field
[image]

Bit mask of channels that were not scanned

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UnscannedChannels As NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS
C#
public NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS UnscannedChannels;
C++
public:
NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS UnscannedChannels sealed ;
J#
public NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS UnscannedChannels
JScript
public UnscannedChannels : NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS;

See Also

NWK_SCAN_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_SCAN_CONFIRMATION.CMD_STATUS Enumeration

NWK_SCAN_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SCAN_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_SCAN_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_SCAN_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_SCAN_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_SCAN_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_SCAN_CONFIRMATION.SCAN_TYPE Enumeration

NWK_SCAN_CONFIRMATION.SCAN_TYPE Enumeration
[image]

Scan type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SCAN_CONFIRMATION.SCAN_TYPE As Byte
C#
public enum NWK_SCAN_CONFIRMATION.SCAN_TYPE : byte
C++
public enum class NWK_SCAN_CONFIRMATION.SCAN_TYPE : char
J#
public enum NWK_SCAN_CONFIRMATION.SCAN_TYPE byte
JScript
public enum NWK_SCAN_CONFIRMATION.SCAN_TYPE :

Members

Member Name | Description
0x00 (ENERGY_DETECT) | Scan type
0x01 (ACTIVE) | Scan type
0x02 (PASSIVE) | Scan type
0x03 (ORPHAN) | Scan type
0x05 (ENHANCED) | Scan type

See Also

TI.ZPI2 Namespace


NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS Enumeration

NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS uint
JScript
public enum NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


NWK_START_CONFIRMATION Class

NWK_START_CONFIRMATION Class
See Also Example Members
[image]

This function reports the success of the start request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_START_CONFIRMATION
Implements ICONFIRMATION, INETWORK
C#
public class NWK_START_CONFIRMATION : ICONFIRMATION, INETWORK
C++
ref class NWK_START_CONFIRMATION : ICONFIRMATION, INETWORK
J#
public class NWK_START_CONFIRMATION implements ICONFIRMATION, INETWORK
JScript
public class NWK_START_CONFIRMATION extends ICONFIRMATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_START_CONFIRMATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_START_CONFIRMATION Members
TI.ZPI2 Namespace


NWK_START_CONFIRMATION Members

NWK_START_CONFIRMATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function reports the success of the start request.

The following tables list the members exposed by NWK_START_CONFIRMATION.

Public Constructors

Name | Description
NWK_START_CONFIRMATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_START_CONFIRMATION | Overloaded.
Top

See Also

NWK_START_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_START_CONFIRMATION Constructor

NWK_START_CONFIRMATION Constructor

Overload List

 | Name | Description
Public method | NWK_START_CONFIRMATION | Constructor
Public method | NWK_START_CONFIRMATION (NWK_START_CONFIRMATION.CMD_STATUS) |

See Also

NWK_START_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_START_CONFIRMATION Constructor ()

NWK_START_CONFIRMATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_START_CONFIRMATION()
C++
public:
NWK_START_CONFIRMATION() sealed
J#
public NWK_START_CONFIRMATION()
JScript
public function NWK_START_CONFIRMATION()

See Also

NWK_START_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_START_CONFIRMATION Constructor Overload List


NWK_START_CONFIRMATION Constructor (NWK_START_CONFIRMATION.CMD_STATUS)

NWK_START_CONFIRMATION Constructor (NWK_START_CONFIRMATION.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As NWK_START_CONFIRMATION.CMD_STATUS _
)
C#
public NWK_START_CONFIRMATION(
NWK_START_CONFIRMATION.CMD_STATUS
)
C++
public:
NWK_START_CONFIRMATION(
NWK_START_CONFIRMATION.CMD_STATUS
) sealed
J#
public NWK_START_CONFIRMATION(
NWK_START_CONFIRMATION.CMD_STATUS
)
JScript
public function NWK_START_CONFIRMATION(
: NWK_START_CONFIRMATION.CMD_STATUS
)

See Also

NWK_START_CONFIRMATION Class
TI.ZPI2 Namespace
NWK_START_CONFIRMATION Constructor Overload List


Fields

NWK_START_CONFIRMATION Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

NWK_START_CONFIRMATION Class
TI.ZPI2 Namespace


Status Field

NWK_START_CONFIRMATION.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As NWK_START_CONFIRMATION.CMD_STATUS
C#
public NWK_START_CONFIRMATION.CMD_STATUS Status;
C++
public:
NWK_START_CONFIRMATION.CMD_STATUS Status sealed ;
J#
public NWK_START_CONFIRMATION.CMD_STATUS Status
JScript
public Status : NWK_START_CONFIRMATION.CMD_STATUS;

See Also

NWK_START_CONFIRMATION Class
TI.ZPI2 Namespace


NWK_START_CONFIRMATION.CMD_STATUS Enumeration

NWK_START_CONFIRMATION.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_START_CONFIRMATION.CMD_STATUS As Byte
C#
public enum NWK_START_CONFIRMATION.CMD_STATUS : byte
C++
public enum class NWK_START_CONFIRMATION.CMD_STATUS : char
J#
public enum NWK_START_CONFIRMATION.CMD_STATUS byte
JScript
public enum NWK_START_CONFIRMATION.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Class

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
See Also Example Members
[image]

This function indicates the loss of synchronization of a network beacon

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NWK_SYNCHRONIZATION_LOSS_INDICATION
Implements IINDICATION, INETWORK
C#
public class NWK_SYNCHRONIZATION_LOSS_INDICATION : IINDICATION, INETWORK
C++
ref class NWK_SYNCHRONIZATION_LOSS_INDICATION : IINDICATION, INETWORK
J#
public class NWK_SYNCHRONIZATION_LOSS_INDICATION implements IINDICATION, INETWORK
JScript
public class NWK_SYNCHRONIZATION_LOSS_INDICATION extends IINDICATION, INETWORK

Inheritance Hierarchy

System.Object
TI.ZPI2.NWK_SYNCHRONIZATION_LOSS_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Members
TI.ZPI2 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Members

NWK_SYNCHRONIZATION_LOSS_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function indicates the loss of synchronization of a network beacon

The following tables list the members exposed by NWK_SYNCHRONIZATION_LOSS_INDICATION.

Public Constructors

Name | Description
NWK_SYNCHRONIZATION_LOSS_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Logical channel for this frame
Public field | PanID | PanID.
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
NWK_SYNCHRONIZATION_LOSS_INDICATION | Overloaded.
Top

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor

NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor

Overload List

 | Name | Description
Public method | NWK_SYNCHRONIZATION_LOSS_INDICATION | Constructor
Public method | NWK_SYNCHRONIZATION_LOSS_INDICATION (Byte, UInt16, Byte, Byte, Byte, NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, Byte) |

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor ()

NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION()
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION() sealed
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION()
JScript
public function NWK_SYNCHRONIZATION_LOSS_INDICATION()

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace
NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor Overload List


NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor (Byte, UInt16, Byte, Byte, Byte[], NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, Byte)

NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor (Byte, UInt16, Byte, Byte, Byte[], NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL, _
ByVal As NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION(
byte ,
ushort ,
byte ,
byte ,
byte[] ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE ,
byte
)
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION(
char ,
unsigned short ,
char ,
char ,
array<char>^ ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE ,
char
) sealed
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION(
byte ,
ushort ,
byte ,
byte ,
byte[] ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL ,
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE ,
byte
)
JScript
public function NWK_SYNCHRONIZATION_LOSS_INDICATION(
: Byte,
: UInt16,
: Byte,
: Byte,
: Byte[],
: NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL,
: NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE,
: Byte
)

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace
NWK_SYNCHRONIZATION_LOSS_INDICATION Constructor Overload List


Fields

NWK_SYNCHRONIZATION_LOSS_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page of the scan
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Logical channel for this frame
Public field | PanID | PanID.
Public field | Reason | Synchronization lost Reason
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


ChannelPage Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.ChannelPage Field
[image]

The channel page of the scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


KeyIdMode Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE KeyIdMode;
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE KeyIdMode sealed ;
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


KeyIndex Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


KeySource Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


LogicalChannel Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.LogicalChannel Field
[image]

Logical channel for this frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


PanID Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.PanID Field
[image]

PanID.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


Reason Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.Reason Field
[image]

Synchronization lost Reason

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reason As Byte
C#
public byte Reason;
C++
public:
char Reason sealed ;
J#
public byte Reason
JScript
public Reason : Byte;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


SecurityLevel Field

NWK_SYNCHRONIZATION_LOSS_INDICATION.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL
C#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL SecurityLevel;
C++
public:
NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL SecurityLevel sealed ;
J#
public NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL;

See Also

NWK_SYNCHRONIZATION_LOSS_INDICATION Class
TI.ZPI2 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE Enumeration

NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE As Byte
C#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE : byte
C++
public enum class NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE : char
J#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE byte
JScript
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL Enumeration

NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL Enumeration
See Also Example
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL As Byte
C#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL : byte
C++
public enum class NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL : char
J#
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL byte
JScript
public enum NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


SYS_ADC_READ Class

SYS_ADC_READ Class
See Also Example Members
[image]

Stop timer.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_ADC_READ
Implements IREQUEST, ISYSTEM
C#
public class SYS_ADC_READ : IREQUEST, ISYSTEM
C++
ref class SYS_ADC_READ : IREQUEST, ISYSTEM
J#
public class SYS_ADC_READ implements IREQUEST, ISYSTEM
JScript
public class SYS_ADC_READ extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_ADC_READ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_ADC_READ Members
TI.ZPI2 Namespace


SYS_ADC_READ Members

SYS_ADC_READ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Stop timer.

The following tables list the members exposed by SYS_ADC_READ.

Public Constructors

Name | Description
SYS_ADC_READ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Channel | Channel: 0x00-0x07 = AIN0 - AIN7; 0x0E = temp; 0x0F = voltage
Public field | Resolution | Resolution: 1 = 8-bit; 2 = 10-bit; 3 = 12-bit; 4 = 14-bit
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_ADC_READ | Overloaded.
Top

See Also

SYS_ADC_READ Class
TI.ZPI2 Namespace


SYS_ADC_READ Constructor

SYS_ADC_READ Constructor

Overload List

 | Name | Description
Public method | SYS_ADC_READ | Constructor
Public method | SYS_ADC_READ (Byte, Byte) | Constructor

See Also

SYS_ADC_READ Class
TI.ZPI2 Namespace


SYS_ADC_READ Constructor ()

SYS_ADC_READ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_ADC_READ()
C++
public:
SYS_ADC_READ() sealed
J#
public SYS_ADC_READ()
JScript
public function SYS_ADC_READ()

See Also

SYS_ADC_READ Class
TI.ZPI2 Namespace
SYS_ADC_READ Constructor Overload List


SYS_ADC_READ Constructor (Byte, Byte)

SYS_ADC_READ Constructor (Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_ADC_READ(
byte ,
byte
)
C++
public:
SYS_ADC_READ(
char ,
char
) sealed
J#
public SYS_ADC_READ(
byte ,
byte
)
JScript
public function SYS_ADC_READ(
: Byte,
: Byte
)

See Also

SYS_ADC_READ Class
TI.ZPI2 Namespace
SYS_ADC_READ Constructor Overload List


Fields

SYS_ADC_READ Fields
[image]

Public Fields

 | Name | Description
Public field | Channel | Channel: 0x00-0x07 = AIN0 - AIN7; 0x0E = temp; 0x0F = voltage
Public field | Resolution | Resolution: 1 = 8-bit; 2 = 10-bit; 3 = 12-bit; 4 = 14-bit
Top

See Also

SYS_ADC_READ Class
TI.ZPI2 Namespace


Channel Field

SYS_ADC_READ.Channel Field
[image]

Channel: 0x00-0x07 = AIN0 - AIN7; 0x0E = temp; 0x0F = voltage

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Channel As Byte
C#
public byte Channel;
C++
public:
char Channel sealed ;
J#
public byte Channel
JScript
public Channel : Byte;

See Also

SYS_ADC_READ Class
TI.ZPI2 Namespace


Resolution Field

SYS_ADC_READ.Resolution Field
[image]

Resolution: 1 = 8-bit; 2 = 10-bit; 3 = 12-bit; 4 = 14-bit

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Resolution As Byte
C#
public byte Resolution;
C++
public:
char Resolution sealed ;
J#
public byte Resolution
JScript
public Resolution : Byte;

See Also

SYS_ADC_READ Class
TI.ZPI2 Namespace


SYS_ADC_READ_SRSP Class

SYS_ADC_READ_SRSP Class
See Also Example Members
[image]

Response for SYS_ADC_READ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_ADC_READ_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_ADC_READ_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_ADC_READ_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_ADC_READ_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_ADC_READ_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_ADC_READ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_ADC_READ_SRSP Members
TI.ZPI2 Namespace


SYS_ADC_READ_SRSP Members

SYS_ADC_READ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_ADC_READ

The following tables list the members exposed by SYS_ADC_READ_SRSP.

Public Constructors

Name | Description
SYS_ADC_READ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Value | ADC value
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_ADC_READ_SRSP | Overloaded.
Top

See Also

SYS_ADC_READ_SRSP Class
TI.ZPI2 Namespace


SYS_ADC_READ_SRSP Constructor

SYS_ADC_READ_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_ADC_READ_SRSP | Constructor
Public method | SYS_ADC_READ_SRSP (UInt16) | Constructor

See Also

SYS_ADC_READ_SRSP Class
TI.ZPI2 Namespace


SYS_ADC_READ_SRSP Constructor ()

SYS_ADC_READ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_ADC_READ_SRSP()
C++
public:
SYS_ADC_READ_SRSP() sealed
J#
public SYS_ADC_READ_SRSP()
JScript
public function SYS_ADC_READ_SRSP()

See Also

SYS_ADC_READ_SRSP Class
TI.ZPI2 Namespace
SYS_ADC_READ_SRSP Constructor Overload List


SYS_ADC_READ_SRSP Constructor (UInt16)

SYS_ADC_READ_SRSP Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public SYS_ADC_READ_SRSP(
ushort
)
C++
public:
SYS_ADC_READ_SRSP(
unsigned short
) sealed
J#
public SYS_ADC_READ_SRSP(
ushort
)
JScript
public function SYS_ADC_READ_SRSP(
: UInt16
)

See Also

SYS_ADC_READ_SRSP Class
TI.ZPI2 Namespace
SYS_ADC_READ_SRSP Constructor Overload List


Fields

SYS_ADC_READ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Value | ADC value
Top

See Also

SYS_ADC_READ_SRSP Class
TI.ZPI2 Namespace


Value Field

SYS_ADC_READ_SRSP.Value Field
[image]

ADC value

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As UInt16
C#
public ushort Value;
C++
public:
unsigned short Value sealed ;
J#
public ushort Value
JScript
public Value : UInt16;

See Also

SYS_ADC_READ_SRSP Class
TI.ZPI2 Namespace


SYS_GET_TIME Class

SYS_GET_TIME Class
See Also Example Members
[image]

Get the device's time. Returns 32-bit UTC time and parsed date/time values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_TIME
Implements IREQUEST, ISYSTEM
C#
public class SYS_GET_TIME : IREQUEST, ISYSTEM
C++
ref class SYS_GET_TIME : IREQUEST, ISYSTEM
J#
public class SYS_GET_TIME implements IREQUEST, ISYSTEM
JScript
public class SYS_GET_TIME extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_GET_TIME

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_TIME Members
TI.ZPI2 Namespace


SYS_GET_TIME Members

SYS_GET_TIME Members
See Also Example Constructors Methods
[image]

Get the device's time. Returns 32-bit UTC time and parsed date/time values.

The following tables list the members exposed by SYS_GET_TIME.

Public Constructors

 | Name | Description
Public method | SYS_GET_TIME | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_GET_TIME Class
TI.ZPI2 Namespace


SYS_GET_TIME Constructor

SYS_GET_TIME Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_TIME()
C++
public:
SYS_GET_TIME() sealed
J#
public SYS_GET_TIME()
JScript
public function SYS_GET_TIME()

See Also

SYS_GET_TIME Class
TI.ZPI2 Namespace


SYS_GET_TIME_SRSP Class

SYS_GET_TIME_SRSP Class
See Also Example Members
[image]

Response for SYS_GET_TIME

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GET_TIME_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_GET_TIME_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_GET_TIME_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_GET_TIME_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_GET_TIME_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_GET_TIME_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GET_TIME_SRSP Members
TI.ZPI2 Namespace


SYS_GET_TIME_SRSP Members

SYS_GET_TIME_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_GET_TIME

The following tables list the members exposed by SYS_GET_TIME_SRSP.

Public Constructors

Name | Description
SYS_GET_TIME_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Day | day of the month (1-31)
Public field | Hour | hour of the day (0-23)
Public field | Minute | minute of the hour (0-59)
Public field | Month | month of the year (1-12)
Public field | Second | second of the minute (0-59)
Public field | UTC | seconds since 00:00:00 on January 1, 2000.
Public field | Year | calendar year (2000- )
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GET_TIME_SRSP | Overloaded.
Top

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


SYS_GET_TIME_SRSP Constructor

SYS_GET_TIME_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_GET_TIME_SRSP | Constructor
Public method | SYS_GET_TIME_SRSP (UInt32, Byte, Byte, Byte, Byte, Byte, UInt16) | Constructor

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


SYS_GET_TIME_SRSP Constructor ()

SYS_GET_TIME_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GET_TIME_SRSP()
C++
public:
SYS_GET_TIME_SRSP() sealed
J#
public SYS_GET_TIME_SRSP()
JScript
public function SYS_GET_TIME_SRSP()

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace
SYS_GET_TIME_SRSP Constructor Overload List


SYS_GET_TIME_SRSP Constructor (UInt32, Byte, Byte, Byte, Byte, Byte, UInt16)

SYS_GET_TIME_SRSP Constructor (UInt32, Byte, Byte, Byte, Byte, Byte, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16 _
)
C#
public SYS_GET_TIME_SRSP(
uint ,
byte ,
byte ,
byte ,
byte ,
byte ,
ushort
)
C++
public:
SYS_GET_TIME_SRSP(
unsigned int ,
char ,
char ,
char ,
char ,
char ,
unsigned short
) sealed
J#
public SYS_GET_TIME_SRSP(
uint ,
byte ,
byte ,
byte ,
byte ,
byte ,
ushort
)
JScript
public function SYS_GET_TIME_SRSP(
: UInt32,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: UInt16
)

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace
SYS_GET_TIME_SRSP Constructor Overload List


Fields

SYS_GET_TIME_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Day | day of the month (1-31)
Public field | Hour | hour of the day (0-23)
Public field | Minute | minute of the hour (0-59)
Public field | Month | month of the year (1-12)
Public field | Second | second of the minute (0-59)
Public field | UTC | seconds since 00:00:00 on January 1, 2000.
Public field | Year | calendar year (2000- )
Top

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


Day Field

SYS_GET_TIME_SRSP.Day Field
[image]

day of the month (1-31)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Day As Byte
C#
public byte Day;
C++
public:
char Day sealed ;
J#
public byte Day
JScript
public Day : Byte;

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


Hour Field

SYS_GET_TIME_SRSP.Hour Field
[image]

hour of the day (0-23)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Hour As Byte
C#
public byte Hour;
C++
public:
char Hour sealed ;
J#
public byte Hour
JScript
public Hour : Byte;

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


Minute Field

SYS_GET_TIME_SRSP.Minute Field
[image]

minute of the hour (0-59)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Minute As Byte
C#
public byte Minute;
C++
public:
char Minute sealed ;
J#
public byte Minute
JScript
public Minute : Byte;

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


Month Field

SYS_GET_TIME_SRSP.Month Field
[image]

month of the year (1-12)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Month As Byte
C#
public byte Month;
C++
public:
char Month sealed ;
J#
public byte Month
JScript
public Month : Byte;

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


Second Field

SYS_GET_TIME_SRSP.Second Field
[image]

second of the minute (0-59)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Second As Byte
C#
public byte Second;
C++
public:
char Second sealed ;
J#
public byte Second
JScript
public Second : Byte;

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


UTC Field

SYS_GET_TIME_SRSP.UTC Field
[image]

seconds since 00:00:00 on January 1, 2000.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UTC As UInt32
C#
public uint UTC;
C++
public:
unsigned int UTC sealed ;
J#
public uint UTC
JScript
public UTC : UInt32;

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


Year Field

SYS_GET_TIME_SRSP.Year Field
[image]

calendar year (2000- )

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Year As UInt16
C#
public ushort Year;
C++
public:
unsigned short Year sealed ;
J#
public ushort Year
JScript
public Year : UInt16;

See Also

SYS_GET_TIME_SRSP Class
TI.ZPI2 Namespace


SYS_GPIO Class

SYS_GPIO Class
See Also Example Members
[image]

Control ZNP GPIO.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GPIO
Implements IREQUEST, ISYSTEM
C#
public class SYS_GPIO : IREQUEST, ISYSTEM
C++
ref class SYS_GPIO : IREQUEST, ISYSTEM
J#
public class SYS_GPIO implements IREQUEST, ISYSTEM
JScript
public class SYS_GPIO extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_GPIO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GPIO Members
TI.ZPI2 Namespace


SYS_GPIO Members

SYS_GPIO Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Control ZNP GPIO.

The following tables list the members exposed by SYS_GPIO.

Public Constructors

Name | Description
SYS_GPIO | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Operation | Operation being requested according to the GPIO_Op_t enumeration.
Public field | Value | Value of the GPIO pins to set according to the operation parameter and masked by the GPIO_MASK.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GPIO | Overloaded.
Top

See Also

SYS_GPIO Class
TI.ZPI2 Namespace


SYS_GPIO Constructor

SYS_GPIO Constructor

Overload List

 | Name | Description
Public method | SYS_GPIO | Constructor
Public method | SYS_GPIO (Byte, Byte) | Constructor

See Also

SYS_GPIO Class
TI.ZPI2 Namespace


SYS_GPIO Constructor ()

SYS_GPIO Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GPIO()
C++
public:
SYS_GPIO() sealed
J#
public SYS_GPIO()
JScript
public function SYS_GPIO()

See Also

SYS_GPIO Class
TI.ZPI2 Namespace
SYS_GPIO Constructor Overload List


SYS_GPIO Constructor (Byte, Byte)

SYS_GPIO Constructor (Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_GPIO(
byte ,
byte
)
C++
public:
SYS_GPIO(
char ,
char
) sealed
J#
public SYS_GPIO(
byte ,
byte
)
JScript
public function SYS_GPIO(
: Byte,
: Byte
)

See Also

SYS_GPIO Class
TI.ZPI2 Namespace
SYS_GPIO Constructor Overload List


Fields

SYS_GPIO Fields
[image]

Public Fields

 | Name | Description
Public field | Operation | Operation being requested according to the GPIO_Op_t enumeration.
Public field | Value | Value of the GPIO pins to set according to the operation parameter and masked by the GPIO_MASK.
Top

See Also

SYS_GPIO Class
TI.ZPI2 Namespace


Operation Field

SYS_GPIO.Operation Field
[image]

Operation being requested according to the GPIO_Op_t enumeration.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Operation As Byte
C#
public byte Operation;
C++
public:
char Operation sealed ;
J#
public byte Operation
JScript
public Operation : Byte;

See Also

SYS_GPIO Class
TI.ZPI2 Namespace


Value Field

SYS_GPIO.Value Field
[image]

Value of the GPIO pins to set according to the operation parameter and masked by the GPIO_MASK.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte
C#
public byte Value;
C++
public:
char Value sealed ;
J#
public byte Value
JScript
public Value : Byte;

See Also

SYS_GPIO Class
TI.ZPI2 Namespace


SYS_GPIO_SRSP Class

SYS_GPIO_SRSP Class
See Also Example Members
[image]

Response for SYS_GPIO

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_GPIO_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_GPIO_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_GPIO_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_GPIO_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_GPIO_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_GPIO_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_GPIO_SRSP Members
TI.ZPI2 Namespace


SYS_GPIO_SRSP Members

SYS_GPIO_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_GPIO

The following tables list the members exposed by SYS_GPIO_SRSP.

Public Constructors

Name | Description
SYS_GPIO_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Value | GPIO value
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_GPIO_SRSP | Overloaded.
Top

See Also

SYS_GPIO_SRSP Class
TI.ZPI2 Namespace


SYS_GPIO_SRSP Constructor

SYS_GPIO_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_GPIO_SRSP | Constructor
Public method | SYS_GPIO_SRSP (Byte) | Constructor

See Also

SYS_GPIO_SRSP Class
TI.ZPI2 Namespace


SYS_GPIO_SRSP Constructor ()

SYS_GPIO_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_GPIO_SRSP()
C++
public:
SYS_GPIO_SRSP() sealed
J#
public SYS_GPIO_SRSP()
JScript
public function SYS_GPIO_SRSP()

See Also

SYS_GPIO_SRSP Class
TI.ZPI2 Namespace
SYS_GPIO_SRSP Constructor Overload List


SYS_GPIO_SRSP Constructor (Byte)

SYS_GPIO_SRSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_GPIO_SRSP(
byte
)
C++
public:
SYS_GPIO_SRSP(
char
) sealed
J#
public SYS_GPIO_SRSP(
byte
)
JScript
public function SYS_GPIO_SRSP(
: Byte
)

See Also

SYS_GPIO_SRSP Class
TI.ZPI2 Namespace
SYS_GPIO_SRSP Constructor Overload List


Fields

SYS_GPIO_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Value | GPIO value
Top

See Also

SYS_GPIO_SRSP Class
TI.ZPI2 Namespace


Value Field

SYS_GPIO_SRSP.Value Field
[image]

GPIO value

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte
C#
public byte Value;
C++
public:
char Value sealed ;
J#
public byte Value
JScript
public Value : Byte;

See Also

SYS_GPIO_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE Class

SYS_OSAL_NV_DELETE Class
See Also Example Members
[image]

Deletes an item from non-volatile memory.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_DELETE
Implements IREQUEST, ISYSTEM
C#
public class SYS_OSAL_NV_DELETE : IREQUEST, ISYSTEM
C++
ref class SYS_OSAL_NV_DELETE : IREQUEST, ISYSTEM
J#
public class SYS_OSAL_NV_DELETE implements IREQUEST, ISYSTEM
JScript
public class SYS_OSAL_NV_DELETE extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_DELETE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_DELETE Members
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE Members

SYS_OSAL_NV_DELETE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Deletes an item from non-volatile memory.

The following tables list the members exposed by SYS_OSAL_NV_DELETE.

Public Constructors

Name | Description
SYS_OSAL_NV_DELETE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be deleted.
Public field | Len | Number of bytes in item.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_DELETE | Overloaded.
Top

See Also

SYS_OSAL_NV_DELETE Class
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE Constructor

SYS_OSAL_NV_DELETE Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_DELETE | Constructor
Public method | SYS_OSAL_NV_DELETE (UInt16, UInt16) | Constructor

See Also

SYS_OSAL_NV_DELETE Class
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE Constructor ()

SYS_OSAL_NV_DELETE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_DELETE()
C++
public:
SYS_OSAL_NV_DELETE() sealed
J#
public SYS_OSAL_NV_DELETE()
JScript
public function SYS_OSAL_NV_DELETE()

See Also

SYS_OSAL_NV_DELETE Class
TI.ZPI2 Namespace
SYS_OSAL_NV_DELETE Constructor Overload List


SYS_OSAL_NV_DELETE Constructor (UInt16, UInt16)

SYS_OSAL_NV_DELETE Constructor (UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public SYS_OSAL_NV_DELETE(
ushort ,
ushort
)
C++
public:
SYS_OSAL_NV_DELETE(
unsigned short ,
unsigned short
) sealed
J#
public SYS_OSAL_NV_DELETE(
ushort ,
ushort
)
JScript
public function SYS_OSAL_NV_DELETE(
: UInt16,
: UInt16
)

See Also

SYS_OSAL_NV_DELETE Class
TI.ZPI2 Namespace
SYS_OSAL_NV_DELETE Constructor Overload List


Fields

SYS_OSAL_NV_DELETE Fields
[image]

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be deleted.
Public field | Len | Number of bytes in item.
Top

See Also

SYS_OSAL_NV_DELETE Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_NV_DELETE.Id Field
[image]

ID of the NV item to be deleted.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As UInt16
C#
public ushort Id;
C++
public:
unsigned short Id sealed ;
J#
public ushort Id
JScript
public Id : UInt16;

See Also

SYS_OSAL_NV_DELETE Class
TI.ZPI2 Namespace


Len Field

SYS_OSAL_NV_DELETE.Len Field
[image]

Number of bytes in item.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As UInt16
C#
public ushort Len;
C++
public:
unsigned short Len sealed ;
J#
public ushort Len
JScript
public Len : UInt16;

See Also

SYS_OSAL_NV_DELETE Class
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE_SRSP Class

SYS_OSAL_NV_DELETE_SRSP Class
See Also Example Members
[image]

Response for SYS_OSAL_NV_DELETE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_DELETE_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_OSAL_NV_DELETE_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_OSAL_NV_DELETE_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_OSAL_NV_DELETE_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_OSAL_NV_DELETE_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_DELETE_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_DELETE_SRSP Members
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE_SRSP Members

SYS_OSAL_NV_DELETE_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_OSAL_NV_DELETE

The following tables list the members exposed by SYS_OSAL_NV_DELETE_SRSP.

Public Constructors

Name | Description
SYS_OSAL_NV_DELETE_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_DELETE_SRSP | Overloaded.
Top

See Also

SYS_OSAL_NV_DELETE_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE_SRSP Constructor

SYS_OSAL_NV_DELETE_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_DELETE_SRSP | Constructor
Public method | SYS_OSAL_NV_DELETE_SRSP (SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS) |

See Also

SYS_OSAL_NV_DELETE_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE_SRSP Constructor ()

SYS_OSAL_NV_DELETE_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_DELETE_SRSP()
C++
public:
SYS_OSAL_NV_DELETE_SRSP() sealed
J#
public SYS_OSAL_NV_DELETE_SRSP()
JScript
public function SYS_OSAL_NV_DELETE_SRSP()

See Also

SYS_OSAL_NV_DELETE_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_DELETE_SRSP Constructor Overload List


SYS_OSAL_NV_DELETE_SRSP Constructor (SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS)

SYS_OSAL_NV_DELETE_SRSP Constructor (SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS _
)
C#
public SYS_OSAL_NV_DELETE_SRSP(
SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS
)
C++
public:
SYS_OSAL_NV_DELETE_SRSP(
SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS
) sealed
J#
public SYS_OSAL_NV_DELETE_SRSP(
SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS
)
JScript
public function SYS_OSAL_NV_DELETE_SRSP(
: SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS
)

See Also

SYS_OSAL_NV_DELETE_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_DELETE_SRSP Constructor Overload List


Fields

SYS_OSAL_NV_DELETE_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_OSAL_NV_DELETE_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_OSAL_NV_DELETE_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS
C#
public SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS Status;
C++
public:
SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS Status
JScript
public Status : SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS;

See Also

SYS_OSAL_NV_DELETE_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS Enumeration

SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS As Byte
C#
public enum SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS : byte
C++
public enum class SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS : char
J#
public enum SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS byte
JScript
public enum SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT Class

SYS_OSAL_NV_ITEM_INIT Class
See Also Example Members
[image]

Creates a new item in non-volatile memory.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_ITEM_INIT
Implements IREQUEST, ISYSTEM
C#
public class SYS_OSAL_NV_ITEM_INIT : IREQUEST, ISYSTEM
C++
ref class SYS_OSAL_NV_ITEM_INIT : IREQUEST, ISYSTEM
J#
public class SYS_OSAL_NV_ITEM_INIT implements IREQUEST, ISYSTEM
JScript
public class SYS_OSAL_NV_ITEM_INIT extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_ITEM_INIT Members
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT Members

SYS_OSAL_NV_ITEM_INIT Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Creates a new item in non-volatile memory.

The following tables list the members exposed by SYS_OSAL_NV_ITEM_INIT.

Public Constructors

Name | Description
SYS_OSAL_NV_ITEM_INIT | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be created.
Public field | InitLen | Number of bytes (up to 250) in the initialization data.
Public field | InitValue | Initialization data to be written to the NV item. Dynamic array, requires memory allocation.
Public field | Len | Number of bytes in the NV item.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_ITEM_INIT | Overloaded.
Top

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT Constructor

SYS_OSAL_NV_ITEM_INIT Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_ITEM_INIT | Constructor
Public method | SYS_OSAL_NV_ITEM_INIT (UInt16, UInt16, Byte, Byte) | Constructor

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT Constructor ()

SYS_OSAL_NV_ITEM_INIT Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_ITEM_INIT()
C++
public:
SYS_OSAL_NV_ITEM_INIT() sealed
J#
public SYS_OSAL_NV_ITEM_INIT()
JScript
public function SYS_OSAL_NV_ITEM_INIT()

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace
SYS_OSAL_NV_ITEM_INIT Constructor Overload List


SYS_OSAL_NV_ITEM_INIT Constructor (UInt16, UInt16, Byte, Byte[])

SYS_OSAL_NV_ITEM_INIT Constructor (UInt16, UInt16, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public SYS_OSAL_NV_ITEM_INIT(
ushort ,
ushort ,
byte ,
byte[]
)
C++
public:
SYS_OSAL_NV_ITEM_INIT(
unsigned short ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public SYS_OSAL_NV_ITEM_INIT(
ushort ,
ushort ,
byte ,
byte[]
)
JScript
public function SYS_OSAL_NV_ITEM_INIT(
: UInt16,
: UInt16,
: Byte,
: Byte[]
)

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace
SYS_OSAL_NV_ITEM_INIT Constructor Overload List


Fields

SYS_OSAL_NV_ITEM_INIT Fields
[image]

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be created.
Public field | InitLen | Number of bytes (up to 250) in the initialization data.
Public field | InitValue | Initialization data to be written to the NV item. Dynamic array, requires memory allocation.
Public field | Len | Number of bytes in the NV item.
Top

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_NV_ITEM_INIT.Id Field
[image]

ID of the NV item to be created.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As UInt16
C#
public ushort Id;
C++
public:
unsigned short Id sealed ;
J#
public ushort Id
JScript
public Id : UInt16;

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace


InitLen Field

SYS_OSAL_NV_ITEM_INIT.InitLen Field
[image]

Number of bytes (up to 250) in the initialization data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InitLen As Byte
C#
public byte InitLen;
C++
public:
char InitLen sealed ;
J#
public byte InitLen
JScript
public InitLen : Byte;

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace


InitValue Field

SYS_OSAL_NV_ITEM_INIT.InitValue Field
[image]

Initialization data to be written to the NV item. Dynamic array, requires memory allocation.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InitValue As Byte()
C#
public byte[] InitValue;
C++
public:
array<char>^ InitValue sealed ;
J#
public byte[] InitValue
JScript
public InitValue : Byte[];

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace


Len Field

SYS_OSAL_NV_ITEM_INIT.Len Field
[image]

Number of bytes in the NV item.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As UInt16
C#
public ushort Len;
C++
public:
unsigned short Len sealed ;
J#
public ushort Len
JScript
public Len : UInt16;

See Also

SYS_OSAL_NV_ITEM_INIT Class
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT_SRSP Class

SYS_OSAL_NV_ITEM_INIT_SRSP Class
See Also Example Members
[image]

Response for SYS_OSAL_NV_ITEM_INIT

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_ITEM_INIT_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_OSAL_NV_ITEM_INIT_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_OSAL_NV_ITEM_INIT_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_OSAL_NV_ITEM_INIT_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_OSAL_NV_ITEM_INIT_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_ITEM_INIT_SRSP Members
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT_SRSP Members

SYS_OSAL_NV_ITEM_INIT_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_OSAL_NV_ITEM_INIT

The following tables list the members exposed by SYS_OSAL_NV_ITEM_INIT_SRSP.

Public Constructors

Name | Description
SYS_OSAL_NV_ITEM_INIT_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_ITEM_INIT_SRSP | Overloaded.
Top

See Also

SYS_OSAL_NV_ITEM_INIT_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT_SRSP Constructor

SYS_OSAL_NV_ITEM_INIT_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_ITEM_INIT_SRSP | Constructor
Public method | SYS_OSAL_NV_ITEM_INIT_SRSP (SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS) |

See Also

SYS_OSAL_NV_ITEM_INIT_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT_SRSP Constructor ()

SYS_OSAL_NV_ITEM_INIT_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_ITEM_INIT_SRSP()
C++
public:
SYS_OSAL_NV_ITEM_INIT_SRSP() sealed
J#
public SYS_OSAL_NV_ITEM_INIT_SRSP()
JScript
public function SYS_OSAL_NV_ITEM_INIT_SRSP()

See Also

SYS_OSAL_NV_ITEM_INIT_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_ITEM_INIT_SRSP Constructor Overload List


SYS_OSAL_NV_ITEM_INIT_SRSP Constructor (SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS)

SYS_OSAL_NV_ITEM_INIT_SRSP Constructor (SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS _
)
C#
public SYS_OSAL_NV_ITEM_INIT_SRSP(
SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS
)
C++
public:
SYS_OSAL_NV_ITEM_INIT_SRSP(
SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS
) sealed
J#
public SYS_OSAL_NV_ITEM_INIT_SRSP(
SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS
)
JScript
public function SYS_OSAL_NV_ITEM_INIT_SRSP(
: SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS
)

See Also

SYS_OSAL_NV_ITEM_INIT_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_ITEM_INIT_SRSP Constructor Overload List


Fields

SYS_OSAL_NV_ITEM_INIT_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_OSAL_NV_ITEM_INIT_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_OSAL_NV_ITEM_INIT_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS
C#
public SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS Status;
C++
public:
SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS Status
JScript
public Status : SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS;

See Also

SYS_OSAL_NV_ITEM_INIT_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS Enumeration

SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS As Byte
C#
public enum SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS : byte
C++
public enum class SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS : char
J#
public enum SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS byte
JScript
public enum SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH Class

SYS_OSAL_NV_LENGTH Class
See Also Example Members
[image]

Gets the length of an item in non-volatile memory.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_LENGTH
Implements IREQUEST, ISYSTEM
C#
public class SYS_OSAL_NV_LENGTH : IREQUEST, ISYSTEM
C++
ref class SYS_OSAL_NV_LENGTH : IREQUEST, ISYSTEM
J#
public class SYS_OSAL_NV_LENGTH implements IREQUEST, ISYSTEM
JScript
public class SYS_OSAL_NV_LENGTH extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_LENGTH

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_LENGTH Members
TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH Members

SYS_OSAL_NV_LENGTH Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Gets the length of an item in non-volatile memory.

The following tables list the members exposed by SYS_OSAL_NV_LENGTH.

Public Constructors

Name | Description
SYS_OSAL_NV_LENGTH | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be accessed.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_LENGTH | Overloaded.
Top

See Also

SYS_OSAL_NV_LENGTH Class
TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH Constructor

SYS_OSAL_NV_LENGTH Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_LENGTH | Constructor
Public method | SYS_OSAL_NV_LENGTH (UInt16) | Constructor

See Also

SYS_OSAL_NV_LENGTH Class
TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH Constructor ()

SYS_OSAL_NV_LENGTH Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_LENGTH()
C++
public:
SYS_OSAL_NV_LENGTH() sealed
J#
public SYS_OSAL_NV_LENGTH()
JScript
public function SYS_OSAL_NV_LENGTH()

See Also

SYS_OSAL_NV_LENGTH Class
TI.ZPI2 Namespace
SYS_OSAL_NV_LENGTH Constructor Overload List


SYS_OSAL_NV_LENGTH Constructor (UInt16)

SYS_OSAL_NV_LENGTH Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public SYS_OSAL_NV_LENGTH(
ushort
)
C++
public:
SYS_OSAL_NV_LENGTH(
unsigned short
) sealed
J#
public SYS_OSAL_NV_LENGTH(
ushort
)
JScript
public function SYS_OSAL_NV_LENGTH(
: UInt16
)

See Also

SYS_OSAL_NV_LENGTH Class
TI.ZPI2 Namespace
SYS_OSAL_NV_LENGTH Constructor Overload List


Fields

SYS_OSAL_NV_LENGTH Fields
[image]

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be accessed.
Top

See Also

SYS_OSAL_NV_LENGTH Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_NV_LENGTH.Id Field
[image]

ID of the NV item to be accessed.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As UInt16
C#
public ushort Id;
C++
public:
unsigned short Id sealed ;
J#
public ushort Id
JScript
public Id : UInt16;

See Also

SYS_OSAL_NV_LENGTH Class
TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH_SRSP Class

SYS_OSAL_NV_LENGTH_SRSP Class
See Also Example Members
[image]

Response for SYS_OSAL_NV_LENGTH

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_LENGTH_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_OSAL_NV_LENGTH_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_OSAL_NV_LENGTH_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_OSAL_NV_LENGTH_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_OSAL_NV_LENGTH_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_LENGTH_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_LENGTH_SRSP Members
TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH_SRSP Members

SYS_OSAL_NV_LENGTH_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_OSAL_NV_LENGTH

The following tables list the members exposed by SYS_OSAL_NV_LENGTH_SRSP.

Public Constructors

Name | Description
SYS_OSAL_NV_LENGTH_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Length | Length of NV item, 0 if no item.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_LENGTH_SRSP | Overloaded.
Top

See Also

SYS_OSAL_NV_LENGTH_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH_SRSP Constructor

SYS_OSAL_NV_LENGTH_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_LENGTH_SRSP | Constructor
Public method | SYS_OSAL_NV_LENGTH_SRSP (UInt16) | Constructor

See Also

SYS_OSAL_NV_LENGTH_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_LENGTH_SRSP Constructor ()

SYS_OSAL_NV_LENGTH_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_LENGTH_SRSP()
C++
public:
SYS_OSAL_NV_LENGTH_SRSP() sealed
J#
public SYS_OSAL_NV_LENGTH_SRSP()
JScript
public function SYS_OSAL_NV_LENGTH_SRSP()

See Also

SYS_OSAL_NV_LENGTH_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_LENGTH_SRSP Constructor Overload List


SYS_OSAL_NV_LENGTH_SRSP Constructor (UInt16)

SYS_OSAL_NV_LENGTH_SRSP Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public SYS_OSAL_NV_LENGTH_SRSP(
ushort
)
C++
public:
SYS_OSAL_NV_LENGTH_SRSP(
unsigned short
) sealed
J#
public SYS_OSAL_NV_LENGTH_SRSP(
ushort
)
JScript
public function SYS_OSAL_NV_LENGTH_SRSP(
: UInt16
)

See Also

SYS_OSAL_NV_LENGTH_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_LENGTH_SRSP Constructor Overload List


Fields

SYS_OSAL_NV_LENGTH_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Length | Length of NV item, 0 if no item.
Top

See Also

SYS_OSAL_NV_LENGTH_SRSP Class
TI.ZPI2 Namespace


Length Field

SYS_OSAL_NV_LENGTH_SRSP.Length Field
[image]

Length of NV item, 0 if no item.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As UInt16
C#
public ushort Length;
C++
public:
unsigned short Length sealed ;
J#
public ushort Length
JScript
public Length : UInt16;

See Also

SYS_OSAL_NV_LENGTH_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_READ Class

SYS_OSAL_NV_READ Class
See Also Example Members
[image]

Reads data from an item in non-volatile memory.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_READ
Implements IREQUEST, ISYSTEM
C#
public class SYS_OSAL_NV_READ : IREQUEST, ISYSTEM
C++
ref class SYS_OSAL_NV_READ : IREQUEST, ISYSTEM
J#
public class SYS_OSAL_NV_READ implements IREQUEST, ISYSTEM
JScript
public class SYS_OSAL_NV_READ extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_READ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_READ Members
TI.ZPI2 Namespace


SYS_OSAL_NV_READ Members

SYS_OSAL_NV_READ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Reads data from an item in non-volatile memory.

The following tables list the members exposed by SYS_OSAL_NV_READ.

Public Constructors

Name | Description
SYS_OSAL_NV_READ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be read.
Public field | Offset | Memory offset into item (up to 250).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_READ | Overloaded.
Top

See Also

SYS_OSAL_NV_READ Class
TI.ZPI2 Namespace


SYS_OSAL_NV_READ Constructor

SYS_OSAL_NV_READ Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_READ | Constructor
Public method | SYS_OSAL_NV_READ (UInt16, Byte) | Constructor

See Also

SYS_OSAL_NV_READ Class
TI.ZPI2 Namespace


SYS_OSAL_NV_READ Constructor ()

SYS_OSAL_NV_READ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_READ()
C++
public:
SYS_OSAL_NV_READ() sealed
J#
public SYS_OSAL_NV_READ()
JScript
public function SYS_OSAL_NV_READ()

See Also

SYS_OSAL_NV_READ Class
TI.ZPI2 Namespace
SYS_OSAL_NV_READ Constructor Overload List


SYS_OSAL_NV_READ Constructor (UInt16, Byte)

SYS_OSAL_NV_READ Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public SYS_OSAL_NV_READ(
ushort ,
byte
)
C++
public:
SYS_OSAL_NV_READ(
unsigned short ,
char
) sealed
J#
public SYS_OSAL_NV_READ(
ushort ,
byte
)
JScript
public function SYS_OSAL_NV_READ(
: UInt16,
: Byte
)

See Also

SYS_OSAL_NV_READ Class
TI.ZPI2 Namespace
SYS_OSAL_NV_READ Constructor Overload List


Fields

SYS_OSAL_NV_READ Fields
[image]

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be read.
Public field | Offset | Memory offset into item (up to 250).
Top

See Also

SYS_OSAL_NV_READ Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_NV_READ.Id Field
[image]

ID of the NV item to be read.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As UInt16
C#
public ushort Id;
C++
public:
unsigned short Id sealed ;
J#
public ushort Id
JScript
public Id : UInt16;

See Also

SYS_OSAL_NV_READ Class
TI.ZPI2 Namespace


Offset Field

SYS_OSAL_NV_READ.Offset Field
[image]

Memory offset into item (up to 250).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Offset As Byte
C#
public byte Offset;
C++
public:
char Offset sealed ;
J#
public byte Offset
JScript
public Offset : Byte;

See Also

SYS_OSAL_NV_READ Class
TI.ZPI2 Namespace


SYS_OSAL_NV_READ_SRSP Class

SYS_OSAL_NV_READ_SRSP Class
See Also Example Members
[image]

Response for SYS_OSAL_NV_READ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_READ_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_OSAL_NV_READ_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_OSAL_NV_READ_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_OSAL_NV_READ_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_OSAL_NV_READ_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_READ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_READ_SRSP Members
TI.ZPI2 Namespace


SYS_OSAL_NV_READ_SRSP Members

SYS_OSAL_NV_READ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_OSAL_NV_READ

The following tables list the members exposed by SYS_OSAL_NV_READ_SRSP.

Public Constructors

Name | Description
SYS_OSAL_NV_READ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Len | Length of value.
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Public field | Value | Dynamic array, contains the data read from the target.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_READ_SRSP | Overloaded.
Top

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_READ_SRSP Constructor

SYS_OSAL_NV_READ_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_READ_SRSP | Constructor
Public method | SYS_OSAL_NV_READ_SRSP (SYS_OSAL_NV_READ_SRSP.CMD_STATUS, Byte, Byte) |

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_READ_SRSP Constructor ()

SYS_OSAL_NV_READ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_READ_SRSP()
C++
public:
SYS_OSAL_NV_READ_SRSP() sealed
J#
public SYS_OSAL_NV_READ_SRSP()
JScript
public function SYS_OSAL_NV_READ_SRSP()

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_READ_SRSP Constructor Overload List


SYS_OSAL_NV_READ_SRSP Constructor (SYS_OSAL_NV_READ_SRSP.CMD_STATUS, Byte, Byte[])

SYS_OSAL_NV_READ_SRSP Constructor (SYS_OSAL_NV_READ_SRSP.CMD_STATUS, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_OSAL_NV_READ_SRSP.CMD_STATUS, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public SYS_OSAL_NV_READ_SRSP(
SYS_OSAL_NV_READ_SRSP.CMD_STATUS ,
byte ,
byte[]
)
C++
public:
SYS_OSAL_NV_READ_SRSP(
SYS_OSAL_NV_READ_SRSP.CMD_STATUS ,
char ,
array<char>^
) sealed
J#
public SYS_OSAL_NV_READ_SRSP(
SYS_OSAL_NV_READ_SRSP.CMD_STATUS ,
byte ,
byte[]
)
JScript
public function SYS_OSAL_NV_READ_SRSP(
: SYS_OSAL_NV_READ_SRSP.CMD_STATUS,
: Byte,
: Byte[]
)

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_READ_SRSP Constructor Overload List


Fields

SYS_OSAL_NV_READ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Len | Length of value.
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Public field | Value | Dynamic array, contains the data read from the target.
Top

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace


Len Field

SYS_OSAL_NV_READ_SRSP.Len Field
[image]

Length of value.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_OSAL_NV_READ_SRSP.Status Field
[image]

The fail status is returned if the address value in the command message was not within the valid range.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_OSAL_NV_READ_SRSP.CMD_STATUS
C#
public SYS_OSAL_NV_READ_SRSP.CMD_STATUS Status;
C++
public:
SYS_OSAL_NV_READ_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_OSAL_NV_READ_SRSP.CMD_STATUS Status
JScript
public Status : SYS_OSAL_NV_READ_SRSP.CMD_STATUS;

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace


Value Field

SYS_OSAL_NV_READ_SRSP.Value Field
[image]

Dynamic array, contains the data read from the target.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

SYS_OSAL_NV_READ_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_READ_SRSP.CMD_STATUS Enumeration

SYS_OSAL_NV_READ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_OSAL_NV_READ_SRSP.CMD_STATUS As Byte
C#
public enum SYS_OSAL_NV_READ_SRSP.CMD_STATUS : byte
C++
public enum class SYS_OSAL_NV_READ_SRSP.CMD_STATUS : char
J#
public enum SYS_OSAL_NV_READ_SRSP.CMD_STATUS byte
JScript
public enum SYS_OSAL_NV_READ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE Class

SYS_OSAL_NV_WRITE Class
See Also Example Members
[image]

Writes data to an item in non-volatile memory.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_WRITE
Implements IREQUEST, ISYSTEM
C#
public class SYS_OSAL_NV_WRITE : IREQUEST, ISYSTEM
C++
ref class SYS_OSAL_NV_WRITE : IREQUEST, ISYSTEM
J#
public class SYS_OSAL_NV_WRITE implements IREQUEST, ISYSTEM
JScript
public class SYS_OSAL_NV_WRITE extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_WRITE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_WRITE Members
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE Members

SYS_OSAL_NV_WRITE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Writes data to an item in non-volatile memory.

The following tables list the members exposed by SYS_OSAL_NV_WRITE.

Public Constructors

Name | Description
SYS_OSAL_NV_WRITE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be written.
Public field | Len | Number of bytes in item (up to 250).
Public field | Offset | Memory offset into item (up to 250).
Public field | Value | Data value to be written to the NV item. Dynamic array, requires memory allocation.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_WRITE | Overloaded.
Top

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE Constructor

SYS_OSAL_NV_WRITE Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_WRITE | Constructor
Public method | SYS_OSAL_NV_WRITE (UInt16, Byte, Byte, Byte) | Constructor

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE Constructor ()

SYS_OSAL_NV_WRITE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_WRITE()
C++
public:
SYS_OSAL_NV_WRITE() sealed
J#
public SYS_OSAL_NV_WRITE()
JScript
public function SYS_OSAL_NV_WRITE()

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace
SYS_OSAL_NV_WRITE Constructor Overload List


SYS_OSAL_NV_WRITE Constructor (UInt16, Byte, Byte, Byte[])

SYS_OSAL_NV_WRITE Constructor (UInt16, Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public SYS_OSAL_NV_WRITE(
ushort ,
byte ,
byte ,
byte[]
)
C++
public:
SYS_OSAL_NV_WRITE(
unsigned short ,
char ,
char ,
array<char>^
) sealed
J#
public SYS_OSAL_NV_WRITE(
ushort ,
byte ,
byte ,
byte[]
)
JScript
public function SYS_OSAL_NV_WRITE(
: UInt16,
: Byte,
: Byte,
: Byte[]
)

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace
SYS_OSAL_NV_WRITE Constructor Overload List


Fields

SYS_OSAL_NV_WRITE Fields
[image]

Public Fields

 | Name | Description
Public field | Id | ID of the NV item to be written.
Public field | Len | Number of bytes in item (up to 250).
Public field | Offset | Memory offset into item (up to 250).
Public field | Value | Data value to be written to the NV item. Dynamic array, requires memory allocation.
Top

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_NV_WRITE.Id Field
[image]

ID of the NV item to be written.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As UInt16
C#
public ushort Id;
C++
public:
unsigned short Id sealed ;
J#
public ushort Id
JScript
public Id : UInt16;

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace


Len Field

SYS_OSAL_NV_WRITE.Len Field
[image]

Number of bytes in item (up to 250).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace


Offset Field

SYS_OSAL_NV_WRITE.Offset Field
[image]

Memory offset into item (up to 250).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Offset As Byte
C#
public byte Offset;
C++
public:
char Offset sealed ;
J#
public byte Offset
JScript
public Offset : Byte;

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace


Value Field

SYS_OSAL_NV_WRITE.Value Field
[image]

Data value to be written to the NV item. Dynamic array, requires memory allocation.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

SYS_OSAL_NV_WRITE Class
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE_SRSP Class

SYS_OSAL_NV_WRITE_SRSP Class
See Also Example Members
[image]

Response for SYS_OSAL_NV_WRITE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_NV_WRITE_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_OSAL_NV_WRITE_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_OSAL_NV_WRITE_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_OSAL_NV_WRITE_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_OSAL_NV_WRITE_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_NV_WRITE_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_NV_WRITE_SRSP Members
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE_SRSP Members

SYS_OSAL_NV_WRITE_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_OSAL_NV_WRITE

The following tables list the members exposed by SYS_OSAL_NV_WRITE_SRSP.

Public Constructors

Name | Description
SYS_OSAL_NV_WRITE_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_NV_WRITE_SRSP | Overloaded.
Top

See Also

SYS_OSAL_NV_WRITE_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE_SRSP Constructor

SYS_OSAL_NV_WRITE_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_NV_WRITE_SRSP | Constructor
Public method | SYS_OSAL_NV_WRITE_SRSP (SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS) |

See Also

SYS_OSAL_NV_WRITE_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE_SRSP Constructor ()

SYS_OSAL_NV_WRITE_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_NV_WRITE_SRSP()
C++
public:
SYS_OSAL_NV_WRITE_SRSP() sealed
J#
public SYS_OSAL_NV_WRITE_SRSP()
JScript
public function SYS_OSAL_NV_WRITE_SRSP()

See Also

SYS_OSAL_NV_WRITE_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_WRITE_SRSP Constructor Overload List


SYS_OSAL_NV_WRITE_SRSP Constructor (SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS)

SYS_OSAL_NV_WRITE_SRSP Constructor (SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS _
)
C#
public SYS_OSAL_NV_WRITE_SRSP(
SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS
)
C++
public:
SYS_OSAL_NV_WRITE_SRSP(
SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS
) sealed
J#
public SYS_OSAL_NV_WRITE_SRSP(
SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS
)
JScript
public function SYS_OSAL_NV_WRITE_SRSP(
: SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS
)

See Also

SYS_OSAL_NV_WRITE_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_NV_WRITE_SRSP Constructor Overload List


Fields

SYS_OSAL_NV_WRITE_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_OSAL_NV_WRITE_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_OSAL_NV_WRITE_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS
C#
public SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS Status;
C++
public:
SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS Status
JScript
public Status : SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS;

See Also

SYS_OSAL_NV_WRITE_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS Enumeration

SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS As Byte
C#
public enum SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS : byte
C++
public enum class SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS : char
J#
public enum SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS byte
JScript
public enum SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_OSAL_START_TIMER Class

SYS_OSAL_START_TIMER Class
See Also Example Members
[image]

Start timer.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_START_TIMER
Implements IREQUEST, ISYSTEM
C#
public class SYS_OSAL_START_TIMER : IREQUEST, ISYSTEM
C++
ref class SYS_OSAL_START_TIMER : IREQUEST, ISYSTEM
J#
public class SYS_OSAL_START_TIMER implements IREQUEST, ISYSTEM
JScript
public class SYS_OSAL_START_TIMER extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_START_TIMER

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_START_TIMER Members
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER Members

SYS_OSAL_START_TIMER Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Start timer.

The following tables list the members exposed by SYS_OSAL_START_TIMER.

Public Constructors

Name | Description
SYS_OSAL_START_TIMER | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | Timer ID: 0-3
Public field | Timeout | Timeout in milliseconds.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_START_TIMER | Overloaded.
Top

See Also

SYS_OSAL_START_TIMER Class
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER Constructor

SYS_OSAL_START_TIMER Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_START_TIMER | Constructor
Public method | SYS_OSAL_START_TIMER (Byte, UInt16) | Constructor

See Also

SYS_OSAL_START_TIMER Class
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER Constructor ()

SYS_OSAL_START_TIMER Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_START_TIMER()
C++
public:
SYS_OSAL_START_TIMER() sealed
J#
public SYS_OSAL_START_TIMER()
JScript
public function SYS_OSAL_START_TIMER()

See Also

SYS_OSAL_START_TIMER Class
TI.ZPI2 Namespace
SYS_OSAL_START_TIMER Constructor Overload List


SYS_OSAL_START_TIMER Constructor (Byte, UInt16)

SYS_OSAL_START_TIMER Constructor (Byte, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16 _
)
C#
public SYS_OSAL_START_TIMER(
byte ,
ushort
)
C++
public:
SYS_OSAL_START_TIMER(
char ,
unsigned short
) sealed
J#
public SYS_OSAL_START_TIMER(
byte ,
ushort
)
JScript
public function SYS_OSAL_START_TIMER(
: Byte,
: UInt16
)

See Also

SYS_OSAL_START_TIMER Class
TI.ZPI2 Namespace
SYS_OSAL_START_TIMER Constructor Overload List


Fields

SYS_OSAL_START_TIMER Fields
[image]

Public Fields

 | Name | Description
Public field | Id | Timer ID: 0-3
Public field | Timeout | Timeout in milliseconds.
Top

See Also

SYS_OSAL_START_TIMER Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_START_TIMER.Id Field
[image]

Timer ID: 0-3

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As Byte
C#
public byte Id;
C++
public:
char Id sealed ;
J#
public byte Id
JScript
public Id : Byte;

See Also

SYS_OSAL_START_TIMER Class
TI.ZPI2 Namespace


Timeout Field

SYS_OSAL_START_TIMER.Timeout Field
[image]

Timeout in milliseconds.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timeout As UInt16
C#
public ushort Timeout;
C++
public:
unsigned short Timeout sealed ;
J#
public ushort Timeout
JScript
public Timeout : UInt16;

See Also

SYS_OSAL_START_TIMER Class
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER_SRSP Class

SYS_OSAL_START_TIMER_SRSP Class
See Also Example Members
[image]

Response for SYS_OSAL_START_TIMER

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_START_TIMER_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_OSAL_START_TIMER_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_OSAL_START_TIMER_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_OSAL_START_TIMER_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_OSAL_START_TIMER_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_START_TIMER_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_START_TIMER_SRSP Members
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER_SRSP Members

SYS_OSAL_START_TIMER_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_OSAL_START_TIMER

The following tables list the members exposed by SYS_OSAL_START_TIMER_SRSP.

Public Constructors

Name | Description
SYS_OSAL_START_TIMER_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_START_TIMER_SRSP | Overloaded.
Top

See Also

SYS_OSAL_START_TIMER_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER_SRSP Constructor

SYS_OSAL_START_TIMER_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_START_TIMER_SRSP | Constructor
Public method | SYS_OSAL_START_TIMER_SRSP (SYS_OSAL_START_TIMER_SRSP.CMD_STATUS) |

See Also

SYS_OSAL_START_TIMER_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER_SRSP Constructor ()

SYS_OSAL_START_TIMER_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_START_TIMER_SRSP()
C++
public:
SYS_OSAL_START_TIMER_SRSP() sealed
J#
public SYS_OSAL_START_TIMER_SRSP()
JScript
public function SYS_OSAL_START_TIMER_SRSP()

See Also

SYS_OSAL_START_TIMER_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_START_TIMER_SRSP Constructor Overload List


SYS_OSAL_START_TIMER_SRSP Constructor (SYS_OSAL_START_TIMER_SRSP.CMD_STATUS)

SYS_OSAL_START_TIMER_SRSP Constructor (SYS_OSAL_START_TIMER_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_OSAL_START_TIMER_SRSP.CMD_STATUS _
)
C#
public SYS_OSAL_START_TIMER_SRSP(
SYS_OSAL_START_TIMER_SRSP.CMD_STATUS
)
C++
public:
SYS_OSAL_START_TIMER_SRSP(
SYS_OSAL_START_TIMER_SRSP.CMD_STATUS
) sealed
J#
public SYS_OSAL_START_TIMER_SRSP(
SYS_OSAL_START_TIMER_SRSP.CMD_STATUS
)
JScript
public function SYS_OSAL_START_TIMER_SRSP(
: SYS_OSAL_START_TIMER_SRSP.CMD_STATUS
)

See Also

SYS_OSAL_START_TIMER_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_START_TIMER_SRSP Constructor Overload List


Fields

SYS_OSAL_START_TIMER_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_OSAL_START_TIMER_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_OSAL_START_TIMER_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_OSAL_START_TIMER_SRSP.CMD_STATUS
C#
public SYS_OSAL_START_TIMER_SRSP.CMD_STATUS Status;
C++
public:
SYS_OSAL_START_TIMER_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_OSAL_START_TIMER_SRSP.CMD_STATUS Status
JScript
public Status : SYS_OSAL_START_TIMER_SRSP.CMD_STATUS;

See Also

SYS_OSAL_START_TIMER_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_START_TIMER_SRSP.CMD_STATUS Enumeration

SYS_OSAL_START_TIMER_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_OSAL_START_TIMER_SRSP.CMD_STATUS As Byte
C#
public enum SYS_OSAL_START_TIMER_SRSP.CMD_STATUS : byte
C++
public enum class SYS_OSAL_START_TIMER_SRSP.CMD_STATUS : char
J#
public enum SYS_OSAL_START_TIMER_SRSP.CMD_STATUS byte
JScript
public enum SYS_OSAL_START_TIMER_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER Class

SYS_OSAL_STOP_TIMER Class
See Also Example Members
[image]

Stop timer.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_STOP_TIMER
Implements IREQUEST, ISYSTEM
C#
public class SYS_OSAL_STOP_TIMER : IREQUEST, ISYSTEM
C++
ref class SYS_OSAL_STOP_TIMER : IREQUEST, ISYSTEM
J#
public class SYS_OSAL_STOP_TIMER implements IREQUEST, ISYSTEM
JScript
public class SYS_OSAL_STOP_TIMER extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_STOP_TIMER

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_STOP_TIMER Members
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER Members

SYS_OSAL_STOP_TIMER Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Stop timer.

The following tables list the members exposed by SYS_OSAL_STOP_TIMER.

Public Constructors

Name | Description
SYS_OSAL_STOP_TIMER | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | Timer ID: 0-3
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_STOP_TIMER | Overloaded.
Top

See Also

SYS_OSAL_STOP_TIMER Class
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER Constructor

SYS_OSAL_STOP_TIMER Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_STOP_TIMER | Constructor
Public method | SYS_OSAL_STOP_TIMER (Byte) | Constructor

See Also

SYS_OSAL_STOP_TIMER Class
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER Constructor ()

SYS_OSAL_STOP_TIMER Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_STOP_TIMER()
C++
public:
SYS_OSAL_STOP_TIMER() sealed
J#
public SYS_OSAL_STOP_TIMER()
JScript
public function SYS_OSAL_STOP_TIMER()

See Also

SYS_OSAL_STOP_TIMER Class
TI.ZPI2 Namespace
SYS_OSAL_STOP_TIMER Constructor Overload List


SYS_OSAL_STOP_TIMER Constructor (Byte)

SYS_OSAL_STOP_TIMER Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_OSAL_STOP_TIMER(
byte
)
C++
public:
SYS_OSAL_STOP_TIMER(
char
) sealed
J#
public SYS_OSAL_STOP_TIMER(
byte
)
JScript
public function SYS_OSAL_STOP_TIMER(
: Byte
)

See Also

SYS_OSAL_STOP_TIMER Class
TI.ZPI2 Namespace
SYS_OSAL_STOP_TIMER Constructor Overload List


Fields

SYS_OSAL_STOP_TIMER Fields
[image]

Public Fields

 | Name | Description
Public field | Id | Timer ID: 0-3
Top

See Also

SYS_OSAL_STOP_TIMER Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_STOP_TIMER.Id Field
[image]

Timer ID: 0-3

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As Byte
C#
public byte Id;
C++
public:
char Id sealed ;
J#
public byte Id
JScript
public Id : Byte;

See Also

SYS_OSAL_STOP_TIMER Class
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER_SRSP Class

SYS_OSAL_STOP_TIMER_SRSP Class
See Also Example Members
[image]

Response for SYS_OSAL_STOP_TIMER

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_STOP_TIMER_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_OSAL_STOP_TIMER_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_OSAL_STOP_TIMER_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_OSAL_STOP_TIMER_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_OSAL_STOP_TIMER_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_STOP_TIMER_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_STOP_TIMER_SRSP Members
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER_SRSP Members

SYS_OSAL_STOP_TIMER_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_OSAL_STOP_TIMER

The following tables list the members exposed by SYS_OSAL_STOP_TIMER_SRSP.

Public Constructors

Name | Description
SYS_OSAL_STOP_TIMER_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_STOP_TIMER_SRSP | Overloaded.
Top

See Also

SYS_OSAL_STOP_TIMER_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER_SRSP Constructor

SYS_OSAL_STOP_TIMER_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_STOP_TIMER_SRSP | Constructor
Public method | SYS_OSAL_STOP_TIMER_SRSP (SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS) |

See Also

SYS_OSAL_STOP_TIMER_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER_SRSP Constructor ()

SYS_OSAL_STOP_TIMER_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_STOP_TIMER_SRSP()
C++
public:
SYS_OSAL_STOP_TIMER_SRSP() sealed
J#
public SYS_OSAL_STOP_TIMER_SRSP()
JScript
public function SYS_OSAL_STOP_TIMER_SRSP()

See Also

SYS_OSAL_STOP_TIMER_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_STOP_TIMER_SRSP Constructor Overload List


SYS_OSAL_STOP_TIMER_SRSP Constructor (SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS)

SYS_OSAL_STOP_TIMER_SRSP Constructor (SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS _
)
C#
public SYS_OSAL_STOP_TIMER_SRSP(
SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS
)
C++
public:
SYS_OSAL_STOP_TIMER_SRSP(
SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS
) sealed
J#
public SYS_OSAL_STOP_TIMER_SRSP(
SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS
)
JScript
public function SYS_OSAL_STOP_TIMER_SRSP(
: SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS
)

See Also

SYS_OSAL_STOP_TIMER_SRSP Class
TI.ZPI2 Namespace
SYS_OSAL_STOP_TIMER_SRSP Constructor Overload List


Fields

SYS_OSAL_STOP_TIMER_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_OSAL_STOP_TIMER_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_OSAL_STOP_TIMER_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS
C#
public SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS Status;
C++
public:
SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS Status
JScript
public Status : SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS;

See Also

SYS_OSAL_STOP_TIMER_SRSP Class
TI.ZPI2 Namespace


SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS Enumeration

SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS As Byte
C#
public enum SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS : byte
C++
public enum class SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS : char
J#
public enum SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS byte
JScript
public enum SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_OSAL_TIMER_EXPIRED_IND Class

SYS_OSAL_TIMER_EXPIRED_IND Class
See Also Example Members
[image]

OSAL timer expired

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_OSAL_TIMER_EXPIRED_IND
Implements IINDICATION, ISYSTEM
C#
public class SYS_OSAL_TIMER_EXPIRED_IND : IINDICATION, ISYSTEM
C++
ref class SYS_OSAL_TIMER_EXPIRED_IND : IINDICATION, ISYSTEM
J#
public class SYS_OSAL_TIMER_EXPIRED_IND implements IINDICATION, ISYSTEM
JScript
public class SYS_OSAL_TIMER_EXPIRED_IND extends IINDICATION, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_OSAL_TIMER_EXPIRED_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_OSAL_TIMER_EXPIRED_IND Members
TI.ZPI2 Namespace


SYS_OSAL_TIMER_EXPIRED_IND Members

SYS_OSAL_TIMER_EXPIRED_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

OSAL timer expired

The following tables list the members exposed by SYS_OSAL_TIMER_EXPIRED_IND.

Public Constructors

Name | Description
SYS_OSAL_TIMER_EXPIRED_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Id | Timer ID
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_OSAL_TIMER_EXPIRED_IND | Overloaded.
Top

See Also

SYS_OSAL_TIMER_EXPIRED_IND Class
TI.ZPI2 Namespace


SYS_OSAL_TIMER_EXPIRED_IND Constructor

SYS_OSAL_TIMER_EXPIRED_IND Constructor

Overload List

 | Name | Description
Public method | SYS_OSAL_TIMER_EXPIRED_IND | Constructor
Public method | SYS_OSAL_TIMER_EXPIRED_IND (Byte) | Constructor

See Also

SYS_OSAL_TIMER_EXPIRED_IND Class
TI.ZPI2 Namespace


SYS_OSAL_TIMER_EXPIRED_IND Constructor ()

SYS_OSAL_TIMER_EXPIRED_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_OSAL_TIMER_EXPIRED_IND()
C++
public:
SYS_OSAL_TIMER_EXPIRED_IND() sealed
J#
public SYS_OSAL_TIMER_EXPIRED_IND()
JScript
public function SYS_OSAL_TIMER_EXPIRED_IND()

See Also

SYS_OSAL_TIMER_EXPIRED_IND Class
TI.ZPI2 Namespace
SYS_OSAL_TIMER_EXPIRED_IND Constructor Overload List


SYS_OSAL_TIMER_EXPIRED_IND Constructor (Byte)

SYS_OSAL_TIMER_EXPIRED_IND Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_OSAL_TIMER_EXPIRED_IND(
byte
)
C++
public:
SYS_OSAL_TIMER_EXPIRED_IND(
char
) sealed
J#
public SYS_OSAL_TIMER_EXPIRED_IND(
byte
)
JScript
public function SYS_OSAL_TIMER_EXPIRED_IND(
: Byte
)

See Also

SYS_OSAL_TIMER_EXPIRED_IND Class
TI.ZPI2 Namespace
SYS_OSAL_TIMER_EXPIRED_IND Constructor Overload List


Fields

SYS_OSAL_TIMER_EXPIRED_IND Fields
[image]

Public Fields

 | Name | Description
Public field | Id | Timer ID
Top

See Also

SYS_OSAL_TIMER_EXPIRED_IND Class
TI.ZPI2 Namespace


Id Field

SYS_OSAL_TIMER_EXPIRED_IND.Id Field
[image]

Timer ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Id As Byte
C#
public byte Id;
C++
public:
char Id sealed ;
J#
public byte Id
JScript
public Id : Byte;

See Also

SYS_OSAL_TIMER_EXPIRED_IND Class
TI.ZPI2 Namespace


SYS_PING Class

SYS_PING Class
See Also Example Members
[image]

This command is used to check for a device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_PING
Implements IREQUEST, ISYSTEM
C#
public class SYS_PING : IREQUEST, ISYSTEM
C++
ref class SYS_PING : IREQUEST, ISYSTEM
J#
public class SYS_PING implements IREQUEST, ISYSTEM
JScript
public class SYS_PING extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_PING

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_PING Members
TI.ZPI2 Namespace


SYS_PING Members

SYS_PING Members
See Also Example Constructors Methods
[image]

This command is used to check for a device.

The following tables list the members exposed by SYS_PING.

Public Constructors

 | Name | Description
Public method | SYS_PING | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_PING Class
TI.ZPI2 Namespace


SYS_PING Constructor

SYS_PING Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_PING()
C++
public:
SYS_PING() sealed
J#
public SYS_PING()
JScript
public function SYS_PING()

See Also

SYS_PING Class
TI.ZPI2 Namespace


SYS_PING_RESPONSE Class

SYS_PING_RESPONSE Class
See Also Example Members
[image]

Response for SYS_PING

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_PING_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_PING_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_PING_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_PING_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_PING_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_PING_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_PING_RESPONSE Members
TI.ZPI2 Namespace


SYS_PING_RESPONSE Members

SYS_PING_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_PING

The following tables list the members exposed by SYS_PING_RESPONSE.

Public Constructors

Name | Description
SYS_PING_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Capabilities | This field represents the interfaces that this device can handle (compiled into the device).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_PING_RESPONSE | Overloaded.
Top

See Also

SYS_PING_RESPONSE Class
TI.ZPI2 Namespace


SYS_PING_RESPONSE Constructor

SYS_PING_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_PING_RESPONSE | Constructor
Public method | SYS_PING_RESPONSE (SYS_PING_RESPONSE.CAPABILITIES) |

See Also

SYS_PING_RESPONSE Class
TI.ZPI2 Namespace


SYS_PING_RESPONSE Constructor ()

SYS_PING_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_PING_RESPONSE()
C++
public:
SYS_PING_RESPONSE() sealed
J#
public SYS_PING_RESPONSE()
JScript
public function SYS_PING_RESPONSE()

See Also

SYS_PING_RESPONSE Class
TI.ZPI2 Namespace
SYS_PING_RESPONSE Constructor Overload List


SYS_PING_RESPONSE Constructor (SYS_PING_RESPONSE.CAPABILITIES)

SYS_PING_RESPONSE Constructor (SYS_PING_RESPONSE.CAPABILITIES)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_PING_RESPONSE.CAPABILITIES _
)
C#
public SYS_PING_RESPONSE(
SYS_PING_RESPONSE.CAPABILITIES
)
C++
public:
SYS_PING_RESPONSE(
SYS_PING_RESPONSE.CAPABILITIES
) sealed
J#
public SYS_PING_RESPONSE(
SYS_PING_RESPONSE.CAPABILITIES
)
JScript
public function SYS_PING_RESPONSE(
: SYS_PING_RESPONSE.CAPABILITIES
)

See Also

SYS_PING_RESPONSE Class
TI.ZPI2 Namespace
SYS_PING_RESPONSE Constructor Overload List


Fields

SYS_PING_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Capabilities | This field represents the interfaces that this device can handle (compiled into the device).
Top

See Also

SYS_PING_RESPONSE Class
TI.ZPI2 Namespace


Capabilities Field

SYS_PING_RESPONSE.Capabilities Field
[image]

This field represents the interfaces that this device can handle (compiled into the device).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Capabilities As SYS_PING_RESPONSE.CAPABILITIES
C#
public SYS_PING_RESPONSE.CAPABILITIES Capabilities;
C++
public:
SYS_PING_RESPONSE.CAPABILITIES Capabilities sealed ;
J#
public SYS_PING_RESPONSE.CAPABILITIES Capabilities
JScript
public Capabilities : SYS_PING_RESPONSE.CAPABILITIES;

See Also

SYS_PING_RESPONSE Class
TI.ZPI2 Namespace


SYS_PING_RESPONSE.CAPABILITIES Enumeration

SYS_PING_RESPONSE.CAPABILITIES Enumeration
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum SYS_PING_RESPONSE.CAPABILITIES As
C#
[FlagsAttribute]
public enum SYS_PING_RESPONSE.CAPABILITIES : ushort
C++
[FlagsAttribute]
public enum class SYS_PING_RESPONSE.CAPABILITIES : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum SYS_PING_RESPONSE.CAPABILITIES ushort
JScript
public enum SYS_PING_RESPONSE.CAPABILITIES :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
MT_CAP_SYS | Capabilities bitfield | 1
MT_CAP_MAC | Capabilities bitfield | 2
MT_CAP_NWK | Capabilities bitfield | 4
MT_CAP_AF | Capabilities bitfield | 8
MT_CAP_ZDO | Capabilities bitfield | 16
MT_CAP_SAPI | Capabilities bitfield | 32
MT_CAP_UTIL | Capabilities bitfield | 64
MT_CAP_DEBUG | Capabilities bitfield | 128
MT_CAP_APP | Capabilities bitfield | 256

See Also

TI.ZPI2 Namespace


SYS_RANDOM Class

SYS_RANDOM Class
See Also Example Members
[image]

Generate random number.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RANDOM
Implements IREQUEST, ISYSTEM
C#
public class SYS_RANDOM : IREQUEST, ISYSTEM
C++
ref class SYS_RANDOM : IREQUEST, ISYSTEM
J#
public class SYS_RANDOM implements IREQUEST, ISYSTEM
JScript
public class SYS_RANDOM extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_RANDOM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RANDOM Members
TI.ZPI2 Namespace


SYS_RANDOM Members

SYS_RANDOM Members
See Also Example Constructors Methods
[image]

Generate random number.

The following tables list the members exposed by SYS_RANDOM.

Public Constructors

 | Name | Description
Public method | SYS_RANDOM | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_RANDOM Class
TI.ZPI2 Namespace


SYS_RANDOM Constructor

SYS_RANDOM Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RANDOM()
C++
public:
SYS_RANDOM() sealed
J#
public SYS_RANDOM()
JScript
public function SYS_RANDOM()

See Also

SYS_RANDOM Class
TI.ZPI2 Namespace


SYS_RANDOM_SRSP Class

SYS_RANDOM_SRSP Class
See Also Example Members
[image]

Response for SYS_RANDOM

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RANDOM_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_RANDOM_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_RANDOM_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_RANDOM_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_RANDOM_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_RANDOM_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RANDOM_SRSP Members
TI.ZPI2 Namespace


SYS_RANDOM_SRSP Members

SYS_RANDOM_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_RANDOM

The following tables list the members exposed by SYS_RANDOM_SRSP.

Public Constructors

Name | Description
SYS_RANDOM_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Value | Random value
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RANDOM_SRSP | Overloaded.
Top

See Also

SYS_RANDOM_SRSP Class
TI.ZPI2 Namespace


SYS_RANDOM_SRSP Constructor

SYS_RANDOM_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_RANDOM_SRSP | Constructor
Public method | SYS_RANDOM_SRSP (UInt16) | Constructor

See Also

SYS_RANDOM_SRSP Class
TI.ZPI2 Namespace


SYS_RANDOM_SRSP Constructor ()

SYS_RANDOM_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RANDOM_SRSP()
C++
public:
SYS_RANDOM_SRSP() sealed
J#
public SYS_RANDOM_SRSP()
JScript
public function SYS_RANDOM_SRSP()

See Also

SYS_RANDOM_SRSP Class
TI.ZPI2 Namespace
SYS_RANDOM_SRSP Constructor Overload List


SYS_RANDOM_SRSP Constructor (UInt16)

SYS_RANDOM_SRSP Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public SYS_RANDOM_SRSP(
ushort
)
C++
public:
SYS_RANDOM_SRSP(
unsigned short
) sealed
J#
public SYS_RANDOM_SRSP(
ushort
)
JScript
public function SYS_RANDOM_SRSP(
: UInt16
)

See Also

SYS_RANDOM_SRSP Class
TI.ZPI2 Namespace
SYS_RANDOM_SRSP Constructor Overload List


Fields

SYS_RANDOM_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Value | Random value
Top

See Also

SYS_RANDOM_SRSP Class
TI.ZPI2 Namespace


Value Field

SYS_RANDOM_SRSP.Value Field
[image]

Random value

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As UInt16
C#
public ushort Value;
C++
public:
unsigned short Value sealed ;
J#
public ushort Value
JScript
public Value : UInt16;

See Also

SYS_RANDOM_SRSP Class
TI.ZPI2 Namespace


SYS_RESET Class

SYS_RESET Class
See Also Example Members
[image]

This command is used to reset the target device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RESET
Implements IREQUEST, ISYSTEM
C#
public class SYS_RESET : IREQUEST, ISYSTEM
C++
ref class SYS_RESET : IREQUEST, ISYSTEM
J#
public class SYS_RESET implements IREQUEST, ISYSTEM
JScript
public class SYS_RESET extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_RESET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RESET Members
TI.ZPI2 Namespace


SYS_RESET Members

SYS_RESET Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to reset the target device.

The following tables list the members exposed by SYS_RESET.

Public Constructors

Name | Description
SYS_RESET | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Type | Requests a hard or soft reset.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RESET | Overloaded.
Top

See Also

SYS_RESET Class
TI.ZPI2 Namespace


SYS_RESET Constructor

SYS_RESET Constructor

Overload List

 | Name | Description
Public method | SYS_RESET | Constructor
Public method | SYS_RESET (SYS_RESET.RESET_TYPE) |

See Also

SYS_RESET Class
TI.ZPI2 Namespace


SYS_RESET Constructor ()

SYS_RESET Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RESET()
C++
public:
SYS_RESET() sealed
J#
public SYS_RESET()
JScript
public function SYS_RESET()

See Also

SYS_RESET Class
TI.ZPI2 Namespace
SYS_RESET Constructor Overload List


SYS_RESET Constructor (SYS_RESET.RESET_TYPE)

SYS_RESET Constructor (SYS_RESET.RESET_TYPE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_RESET.RESET_TYPE _
)
C#
public SYS_RESET(
SYS_RESET.RESET_TYPE
)
C++
public:
SYS_RESET(
SYS_RESET.RESET_TYPE
) sealed
J#
public SYS_RESET(
SYS_RESET.RESET_TYPE
)
JScript
public function SYS_RESET(
: SYS_RESET.RESET_TYPE
)

See Also

SYS_RESET Class
TI.ZPI2 Namespace
SYS_RESET Constructor Overload List


Fields

SYS_RESET Fields
[image]

Public Fields

 | Name | Description
Public field | Type | Requests a hard or soft reset.
Top

See Also

SYS_RESET Class
TI.ZPI2 Namespace


Type Field

SYS_RESET.Type Field
[image]

Requests a hard or soft reset.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Type As SYS_RESET.RESET_TYPE
C#
public SYS_RESET.RESET_TYPE Type;
C++
public:
SYS_RESET.RESET_TYPE Type sealed ;
J#
public SYS_RESET.RESET_TYPE Type
JScript
public Type : SYS_RESET.RESET_TYPE;

See Also

SYS_RESET Class
TI.ZPI2 Namespace


SYS_RESET.RESET_TYPE Enumeration

SYS_RESET.RESET_TYPE Enumeration
[image]

Reset type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_RESET.RESET_TYPE As Byte
C#
public enum SYS_RESET.RESET_TYPE : byte
C++
public enum class SYS_RESET.RESET_TYPE : char
J#
public enum SYS_RESET.RESET_TYPE byte
JScript
public enum SYS_RESET.RESET_TYPE :

Members

Member Name | Description
0x00 (HARD RESET) | Reset type
0x01 (SOFT RESET) | Reset type

See Also

TI.ZPI2 Namespace


SYS_RESET_RESPONSE Class

SYS_RESET_RESPONSE Class
See Also Example Members
[image]

Indicates a device has reset.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RESET_RESPONSE
Implements IINDICATION, ISYSTEM
C#
public class SYS_RESET_RESPONSE : IINDICATION, ISYSTEM
C++
ref class SYS_RESET_RESPONSE : IINDICATION, ISYSTEM
J#
public class SYS_RESET_RESPONSE implements IINDICATION, ISYSTEM
JScript
public class SYS_RESET_RESPONSE extends IINDICATION, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RESET_RESPONSE Members
TI.ZPI2 Namespace


SYS_RESET_RESPONSE Members

SYS_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Indicates a device has reset.

The following tables list the members exposed by SYS_RESET_RESPONSE.

Public Constructors

Name | Description
SYS_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | HwRev | Hardware revision
Public field | MajorRel | Major release number
Public field | MinorRel | Minor release number
Public field | Product | Product ID
Public field | Reason | Reset reason
Public field | TransportRev | Transport revision
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RESET_RESPONSE | Overloaded.
Top

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


SYS_RESET_RESPONSE Constructor

SYS_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_RESET_RESPONSE | Constructor
Public method | SYS_RESET_RESPONSE (Byte, Byte, Byte, Byte, Byte, Byte) | Constructor

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


SYS_RESET_RESPONSE Constructor ()

SYS_RESET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RESET_RESPONSE()
C++
public:
SYS_RESET_RESPONSE() sealed
J#
public SYS_RESET_RESPONSE()
JScript
public function SYS_RESET_RESPONSE()

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace
SYS_RESET_RESPONSE Constructor Overload List


SYS_RESET_RESPONSE Constructor (Byte, Byte, Byte, Byte, Byte, Byte)

SYS_RESET_RESPONSE Constructor (Byte, Byte, Byte, Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_RESET_RESPONSE(
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
C++
public:
SYS_RESET_RESPONSE(
char ,
char ,
char ,
char ,
char ,
char
) sealed
J#
public SYS_RESET_RESPONSE(
byte ,
byte ,
byte ,
byte ,
byte ,
byte
)
JScript
public function SYS_RESET_RESPONSE(
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace
SYS_RESET_RESPONSE Constructor Overload List


Fields

SYS_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | HwRev | Hardware revision
Public field | MajorRel | Major release number
Public field | MinorRel | Minor release number
Public field | Product | Product ID
Public field | Reason | Reset reason
Public field | TransportRev | Transport revision
Top

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


HwRev Field

SYS_RESET_RESPONSE.HwRev Field
[image]

Hardware revision

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public HwRev As Byte
C#
public byte HwRev;
C++
public:
char HwRev sealed ;
J#
public byte HwRev
JScript
public HwRev : Byte;

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


MajorRel Field

SYS_RESET_RESPONSE.MajorRel Field
[image]

Major release number

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MajorRel As Byte
C#
public byte MajorRel;
C++
public:
char MajorRel sealed ;
J#
public byte MajorRel
JScript
public MajorRel : Byte;

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


MinorRel Field

SYS_RESET_RESPONSE.MinorRel Field
[image]

Minor release number

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MinorRel As Byte
C#
public byte MinorRel;
C++
public:
char MinorRel sealed ;
J#
public byte MinorRel
JScript
public MinorRel : Byte;

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


Product Field

SYS_RESET_RESPONSE.Product Field
[image]

Product ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Product As Byte
C#
public byte Product;
C++
public:
char Product sealed ;
J#
public byte Product
JScript
public Product : Byte;

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


Reason Field

SYS_RESET_RESPONSE.Reason Field
[image]

Reset reason

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reason As Byte
C#
public byte Reason;
C++
public:
char Reason sealed ;
J#
public byte Reason
JScript
public Reason : Byte;

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


TransportRev Field

SYS_RESET_RESPONSE.TransportRev Field
[image]

Transport revision

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransportRev As Byte
C#
public byte TransportRev;
C++
public:
char TransportRev sealed ;
J#
public byte TransportRev
JScript
public TransportRev : Byte;

See Also

SYS_RESET_RESPONSE Class
TI.ZPI2 Namespace


SYS_RPC_ERROR Class

SYS_RPC_ERROR Class
See Also Example Members
[image]

RPC transport layer error.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_RPC_ERROR
Implements IRESPONSE, ISYSTEM
C#
public class SYS_RPC_ERROR : IRESPONSE, ISYSTEM
C++
ref class SYS_RPC_ERROR : IRESPONSE, ISYSTEM
J#
public class SYS_RPC_ERROR implements IRESPONSE, ISYSTEM
JScript
public class SYS_RPC_ERROR extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_RPC_ERROR

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_RPC_ERROR Members
TI.ZPI2 Namespace


SYS_RPC_ERROR Members

SYS_RPC_ERROR Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

RPC transport layer error.

The following tables list the members exposed by SYS_RPC_ERROR.

Public Constructors

Name | Description
SYS_RPC_ERROR | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ErrCmd0 | Command byte 0 of the message causing an error.
Public field | ErrCmd1 | Command byte 1 of the message causing an error.
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_RPC_ERROR | Overloaded.
Top

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace


SYS_RPC_ERROR Constructor

SYS_RPC_ERROR Constructor

Overload List

 | Name | Description
Public method | SYS_RPC_ERROR | Constructor
Public method | SYS_RPC_ERROR (SYS_RPC_ERROR.RPC_ERROR_STATUS, Byte, Byte) |

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace


SYS_RPC_ERROR Constructor ()

SYS_RPC_ERROR Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_RPC_ERROR()
C++
public:
SYS_RPC_ERROR() sealed
J#
public SYS_RPC_ERROR()
JScript
public function SYS_RPC_ERROR()

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace
SYS_RPC_ERROR Constructor Overload List


SYS_RPC_ERROR Constructor (SYS_RPC_ERROR.RPC_ERROR_STATUS, Byte, Byte)

SYS_RPC_ERROR Constructor (SYS_RPC_ERROR.RPC_ERROR_STATUS, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_RPC_ERROR.RPC_ERROR_STATUS, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_RPC_ERROR(
SYS_RPC_ERROR.RPC_ERROR_STATUS ,
byte ,
byte
)
C++
public:
SYS_RPC_ERROR(
SYS_RPC_ERROR.RPC_ERROR_STATUS ,
char ,
char
) sealed
J#
public SYS_RPC_ERROR(
SYS_RPC_ERROR.RPC_ERROR_STATUS ,
byte ,
byte
)
JScript
public function SYS_RPC_ERROR(
: SYS_RPC_ERROR.RPC_ERROR_STATUS,
: Byte,
: Byte
)

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace
SYS_RPC_ERROR Constructor Overload List


Fields

SYS_RPC_ERROR Fields
[image]

Public Fields

 | Name | Description
Public field | ErrCmd0 | Command byte 0 of the message causing an error.
Public field | ErrCmd1 | Command byte 1 of the message causing an error.
Public field | Status | Status
Top

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace


ErrCmd0 Field

SYS_RPC_ERROR.ErrCmd0 Field
[image]

Command byte 0 of the message causing an error.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ErrCmd0 As Byte
C#
public byte ErrCmd0;
C++
public:
char ErrCmd0 sealed ;
J#
public byte ErrCmd0
JScript
public ErrCmd0 : Byte;

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace


ErrCmd1 Field

SYS_RPC_ERROR.ErrCmd1 Field
[image]

Command byte 1 of the message causing an error.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ErrCmd1 As Byte
C#
public byte ErrCmd1;
C++
public:
char ErrCmd1 sealed ;
J#
public byte ErrCmd1
JScript
public ErrCmd1 : Byte;

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace


Status Field

SYS_RPC_ERROR.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_RPC_ERROR.RPC_ERROR_STATUS
C#
public SYS_RPC_ERROR.RPC_ERROR_STATUS Status;
C++
public:
SYS_RPC_ERROR.RPC_ERROR_STATUS Status sealed ;
J#
public SYS_RPC_ERROR.RPC_ERROR_STATUS Status
JScript
public Status : SYS_RPC_ERROR.RPC_ERROR_STATUS;

See Also

SYS_RPC_ERROR Class
TI.ZPI2 Namespace


SYS_RPC_ERROR.RPC_ERROR_STATUS Enumeration

SYS_RPC_ERROR.RPC_ERROR_STATUS Enumeration
[image]

RPC Error status code

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_RPC_ERROR.RPC_ERROR_STATUS As Byte
C#
public enum SYS_RPC_ERROR.RPC_ERROR_STATUS : byte
C++
public enum class SYS_RPC_ERROR.RPC_ERROR_STATUS : char
J#
public enum SYS_RPC_ERROR.RPC_ERROR_STATUS byte
JScript
public enum SYS_RPC_ERROR.RPC_ERROR_STATUS :

Members

Member Name | Description
RPC_SUCCESS | RPC Error status code
INVALID_SUBSYSTEM | RPC Error status code
INVALID_COMMAND | RPC Error status code
INVALID_PARAMETER | RPC Error status code
INVALID_LENGTH | RPC Error status code

See Also

TI.ZPI2 Namespace


SYS_SET_TIME Class

SYS_SET_TIME Class
See Also Example Members
[image]

Set the device's time. Accepts 32-bit UTC time and date/time parameters. The UTC time is used if it's non-zero.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_TIME
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_TIME : IREQUEST, ISYSTEM
C++
ref class SYS_SET_TIME : IREQUEST, ISYSTEM
J#
public class SYS_SET_TIME implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_TIME extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_SET_TIME

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_TIME Members
TI.ZPI2 Namespace


SYS_SET_TIME Members

SYS_SET_TIME Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Set the device's time. Accepts 32-bit UTC time and date/time parameters. The UTC time is used if it's non-zero.

The following tables list the members exposed by SYS_SET_TIME.

Public Constructors

Name | Description
SYS_SET_TIME | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Day | day of the month (1-31)
Public field | Hour | hour of the day (0-23)
Public field | Minute | minute of the hour (0-59)
Public field | Month | month of the year (1-12)
Public field | Second | second of the minute (0-59)
Public field | UTC | seconds since 00:00:00 on January 1, 2000.
Public field | Year | calendar year (2000- )
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_TIME | Overloaded.
Top

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


SYS_SET_TIME Constructor

SYS_SET_TIME Constructor

Overload List

 | Name | Description
Public method | SYS_SET_TIME | Constructor
Public method | SYS_SET_TIME (UInt32, Byte, Byte, Byte, Byte, Byte, UInt16) | Constructor

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


SYS_SET_TIME Constructor ()

SYS_SET_TIME Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_TIME()
C++
public:
SYS_SET_TIME() sealed
J#
public SYS_SET_TIME()
JScript
public function SYS_SET_TIME()

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace
SYS_SET_TIME Constructor Overload List


SYS_SET_TIME Constructor (UInt32, Byte, Byte, Byte, Byte, Byte, UInt16)

SYS_SET_TIME Constructor (UInt32, Byte, Byte, Byte, Byte, Byte, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16 _
)
C#
public SYS_SET_TIME(
uint ,
byte ,
byte ,
byte ,
byte ,
byte ,
ushort
)
C++
public:
SYS_SET_TIME(
unsigned int ,
char ,
char ,
char ,
char ,
char ,
unsigned short
) sealed
J#
public SYS_SET_TIME(
uint ,
byte ,
byte ,
byte ,
byte ,
byte ,
ushort
)
JScript
public function SYS_SET_TIME(
: UInt32,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: UInt16
)

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace
SYS_SET_TIME Constructor Overload List


Fields

SYS_SET_TIME Fields
[image]

Public Fields

 | Name | Description
Public field | Day | day of the month (1-31)
Public field | Hour | hour of the day (0-23)
Public field | Minute | minute of the hour (0-59)
Public field | Month | month of the year (1-12)
Public field | Second | second of the minute (0-59)
Public field | UTC | seconds since 00:00:00 on January 1, 2000.
Public field | Year | calendar year (2000- )
Top

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


Day Field

SYS_SET_TIME.Day Field
[image]

day of the month (1-31)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Day As Byte
C#
public byte Day;
C++
public:
char Day sealed ;
J#
public byte Day
JScript
public Day : Byte;

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


Hour Field

SYS_SET_TIME.Hour Field
[image]

hour of the day (0-23)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Hour As Byte
C#
public byte Hour;
C++
public:
char Hour sealed ;
J#
public byte Hour
JScript
public Hour : Byte;

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


Minute Field

SYS_SET_TIME.Minute Field
[image]

minute of the hour (0-59)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Minute As Byte
C#
public byte Minute;
C++
public:
char Minute sealed ;
J#
public byte Minute
JScript
public Minute : Byte;

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


Month Field

SYS_SET_TIME.Month Field
[image]

month of the year (1-12)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Month As Byte
C#
public byte Month;
C++
public:
char Month sealed ;
J#
public byte Month
JScript
public Month : Byte;

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


Second Field

SYS_SET_TIME.Second Field
[image]

second of the minute (0-59)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Second As Byte
C#
public byte Second;
C++
public:
char Second sealed ;
J#
public byte Second
JScript
public Second : Byte;

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


UTC Field

SYS_SET_TIME.UTC Field
[image]

seconds since 00:00:00 on January 1, 2000.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UTC As UInt32
C#
public uint UTC;
C++
public:
unsigned int UTC sealed ;
J#
public uint UTC
JScript
public UTC : UInt32;

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


Year Field

SYS_SET_TIME.Year Field
[image]

calendar year (2000- )

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Year As UInt16
C#
public ushort Year;
C++
public:
unsigned short Year sealed ;
J#
public ushort Year
JScript
public Year : UInt16;

See Also

SYS_SET_TIME Class
TI.ZPI2 Namespace


SYS_SET_TIME_SRSP Class

SYS_SET_TIME_SRSP Class
See Also Example Members
[image]

Response for SYS_SET_TIME

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_TIME_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_TIME_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_TIME_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_SET_TIME_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_TIME_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_SET_TIME_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_TIME_SRSP Members
TI.ZPI2 Namespace


SYS_SET_TIME_SRSP Members

SYS_SET_TIME_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_TIME

The following tables list the members exposed by SYS_SET_TIME_SRSP.

Public Constructors

Name | Description
SYS_SET_TIME_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_TIME_SRSP | Overloaded.
Top

See Also

SYS_SET_TIME_SRSP Class
TI.ZPI2 Namespace


SYS_SET_TIME_SRSP Constructor

SYS_SET_TIME_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_SET_TIME_SRSP | Constructor
Public method | SYS_SET_TIME_SRSP (SYS_SET_TIME_SRSP.CMD_STATUS) |

See Also

SYS_SET_TIME_SRSP Class
TI.ZPI2 Namespace


SYS_SET_TIME_SRSP Constructor ()

SYS_SET_TIME_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_TIME_SRSP()
C++
public:
SYS_SET_TIME_SRSP() sealed
J#
public SYS_SET_TIME_SRSP()
JScript
public function SYS_SET_TIME_SRSP()

See Also

SYS_SET_TIME_SRSP Class
TI.ZPI2 Namespace
SYS_SET_TIME_SRSP Constructor Overload List


SYS_SET_TIME_SRSP Constructor (SYS_SET_TIME_SRSP.CMD_STATUS)

SYS_SET_TIME_SRSP Constructor (SYS_SET_TIME_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_SET_TIME_SRSP.CMD_STATUS _
)
C#
public SYS_SET_TIME_SRSP(
SYS_SET_TIME_SRSP.CMD_STATUS
)
C++
public:
SYS_SET_TIME_SRSP(
SYS_SET_TIME_SRSP.CMD_STATUS
) sealed
J#
public SYS_SET_TIME_SRSP(
SYS_SET_TIME_SRSP.CMD_STATUS
)
JScript
public function SYS_SET_TIME_SRSP(
: SYS_SET_TIME_SRSP.CMD_STATUS
)

See Also

SYS_SET_TIME_SRSP Class
TI.ZPI2 Namespace
SYS_SET_TIME_SRSP Constructor Overload List


Fields

SYS_SET_TIME_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_SET_TIME_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_SET_TIME_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_SET_TIME_SRSP.CMD_STATUS
C#
public SYS_SET_TIME_SRSP.CMD_STATUS Status;
C++
public:
SYS_SET_TIME_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_SET_TIME_SRSP.CMD_STATUS Status
JScript
public Status : SYS_SET_TIME_SRSP.CMD_STATUS;

See Also

SYS_SET_TIME_SRSP Class
TI.ZPI2 Namespace


SYS_SET_TIME_SRSP.CMD_STATUS Enumeration

SYS_SET_TIME_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_SET_TIME_SRSP.CMD_STATUS As Byte
C#
public enum SYS_SET_TIME_SRSP.CMD_STATUS : byte
C++
public enum class SYS_SET_TIME_SRSP.CMD_STATUS : char
J#
public enum SYS_SET_TIME_SRSP.CMD_STATUS byte
JScript
public enum SYS_SET_TIME_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_SET_TX_POWER Class

SYS_SET_TX_POWER Class
See Also Example Members
[image]

Set the transmit power.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_TX_POWER
Implements IREQUEST, ISYSTEM
C#
public class SYS_SET_TX_POWER : IREQUEST, ISYSTEM
C++
ref class SYS_SET_TX_POWER : IREQUEST, ISYSTEM
J#
public class SYS_SET_TX_POWER implements IREQUEST, ISYSTEM
JScript
public class SYS_SET_TX_POWER extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_SET_TX_POWER

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_TX_POWER Members
TI.ZPI2 Namespace


SYS_SET_TX_POWER Members

SYS_SET_TX_POWER Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Set the transmit power.

The following tables list the members exposed by SYS_SET_TX_POWER.

Public Constructors

Name | Description
SYS_SET_TX_POWER | Overloaded.
Top

Public Fields

 | Name | Description
Public field | level | Transmit power level being requested according to the ZMacTransmitPower_t enumeration.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_TX_POWER | Overloaded.
Top

See Also

SYS_SET_TX_POWER Class
TI.ZPI2 Namespace


SYS_SET_TX_POWER Constructor

SYS_SET_TX_POWER Constructor

Overload List

 | Name | Description
Public method | SYS_SET_TX_POWER | Constructor
Public method | SYS_SET_TX_POWER (Byte) | Constructor

See Also

SYS_SET_TX_POWER Class
TI.ZPI2 Namespace


SYS_SET_TX_POWER Constructor ()

SYS_SET_TX_POWER Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_TX_POWER()
C++
public:
SYS_SET_TX_POWER() sealed
J#
public SYS_SET_TX_POWER()
JScript
public function SYS_SET_TX_POWER()

See Also

SYS_SET_TX_POWER Class
TI.ZPI2 Namespace
SYS_SET_TX_POWER Constructor Overload List


SYS_SET_TX_POWER Constructor (Byte)

SYS_SET_TX_POWER Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_SET_TX_POWER(
byte
)
C++
public:
SYS_SET_TX_POWER(
char
) sealed
J#
public SYS_SET_TX_POWER(
byte
)
JScript
public function SYS_SET_TX_POWER(
: Byte
)

See Also

SYS_SET_TX_POWER Class
TI.ZPI2 Namespace
SYS_SET_TX_POWER Constructor Overload List


Fields

SYS_SET_TX_POWER Fields
[image]

Public Fields

 | Name | Description
Public field | level | Transmit power level being requested according to the ZMacTransmitPower_t enumeration.
Top

See Also

SYS_SET_TX_POWER Class
TI.ZPI2 Namespace


level Field

SYS_SET_TX_POWER.level Field
[image]

Transmit power level being requested according to the ZMacTransmitPower_t enumeration.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public level As Byte
C#
public byte level;
C++
public:
char level sealed ;
J#
public byte level
JScript
public level : Byte;

See Also

SYS_SET_TX_POWER Class
TI.ZPI2 Namespace


SYS_SET_TX_POWER_SRSP Class

SYS_SET_TX_POWER_SRSP Class
See Also Example Members
[image]

Response for SYS_SET_TX_POWER

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_SET_TX_POWER_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_SET_TX_POWER_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_SET_TX_POWER_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_SET_TX_POWER_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_SET_TX_POWER_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_SET_TX_POWER_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_SET_TX_POWER_SRSP Members
TI.ZPI2 Namespace


SYS_SET_TX_POWER_SRSP Members

SYS_SET_TX_POWER_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_SET_TX_POWER

The following tables list the members exposed by SYS_SET_TX_POWER_SRSP.

Public Constructors

Name | Description
SYS_SET_TX_POWER_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | level | Transmit power level achieved as a ZMacTransmitPower_t enumeration.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_SET_TX_POWER_SRSP | Overloaded.
Top

See Also

SYS_SET_TX_POWER_SRSP Class
TI.ZPI2 Namespace


SYS_SET_TX_POWER_SRSP Constructor

SYS_SET_TX_POWER_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_SET_TX_POWER_SRSP | Constructor
Public method | SYS_SET_TX_POWER_SRSP (Byte) | Constructor

See Also

SYS_SET_TX_POWER_SRSP Class
TI.ZPI2 Namespace


SYS_SET_TX_POWER_SRSP Constructor ()

SYS_SET_TX_POWER_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_SET_TX_POWER_SRSP()
C++
public:
SYS_SET_TX_POWER_SRSP() sealed
J#
public SYS_SET_TX_POWER_SRSP()
JScript
public function SYS_SET_TX_POWER_SRSP()

See Also

SYS_SET_TX_POWER_SRSP Class
TI.ZPI2 Namespace
SYS_SET_TX_POWER_SRSP Constructor Overload List


SYS_SET_TX_POWER_SRSP Constructor (Byte)

SYS_SET_TX_POWER_SRSP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public SYS_SET_TX_POWER_SRSP(
byte
)
C++
public:
SYS_SET_TX_POWER_SRSP(
char
) sealed
J#
public SYS_SET_TX_POWER_SRSP(
byte
)
JScript
public function SYS_SET_TX_POWER_SRSP(
: Byte
)

See Also

SYS_SET_TX_POWER_SRSP Class
TI.ZPI2 Namespace
SYS_SET_TX_POWER_SRSP Constructor Overload List


Fields

SYS_SET_TX_POWER_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | level | Transmit power level achieved as a ZMacTransmitPower_t enumeration.
Top

See Also

SYS_SET_TX_POWER_SRSP Class
TI.ZPI2 Namespace


level Field

SYS_SET_TX_POWER_SRSP.level Field
[image]

Transmit power level achieved as a ZMacTransmitPower_t enumeration.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public level As Byte
C#
public byte level;
C++
public:
char level sealed ;
J#
public byte level
JScript
public level : Byte;

See Also

SYS_SET_TX_POWER_SRSP Class
TI.ZPI2 Namespace


SYS_STACK_TUNE Class

SYS_STACK_TUNE Class
See Also Example Members
[image]

Stack Tuning.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_STACK_TUNE
Implements IREQUEST, ISYSTEM
C#
public class SYS_STACK_TUNE : IREQUEST, ISYSTEM
C++
ref class SYS_STACK_TUNE : IREQUEST, ISYSTEM
J#
public class SYS_STACK_TUNE implements IREQUEST, ISYSTEM
JScript
public class SYS_STACK_TUNE extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_STACK_TUNE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_STACK_TUNE Members
TI.ZPI2 Namespace


SYS_STACK_TUNE Members

SYS_STACK_TUNE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Stack Tuning.

The following tables list the members exposed by SYS_STACK_TUNE.

Public Constructors

Name | Description
SYS_STACK_TUNE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Operation | Operation being requested according to the STK_Tune_t enumeration.
Public field | Value | Value of the stack tuning parameter according to the operation requested.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_STACK_TUNE | Overloaded.
Top

See Also

SYS_STACK_TUNE Class
TI.ZPI2 Namespace


SYS_STACK_TUNE Constructor

SYS_STACK_TUNE Constructor

Overload List

 | Name | Description
Public method | SYS_STACK_TUNE | Constructor
Public method | SYS_STACK_TUNE (Byte, Byte) | Constructor

See Also

SYS_STACK_TUNE Class
TI.ZPI2 Namespace


SYS_STACK_TUNE Constructor ()

SYS_STACK_TUNE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_STACK_TUNE()
C++
public:
SYS_STACK_TUNE() sealed
J#
public SYS_STACK_TUNE()
JScript
public function SYS_STACK_TUNE()

See Also

SYS_STACK_TUNE Class
TI.ZPI2 Namespace
SYS_STACK_TUNE Constructor Overload List


SYS_STACK_TUNE Constructor (Byte, Byte)

SYS_STACK_TUNE Constructor (Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_STACK_TUNE(
byte ,
byte
)
C++
public:
SYS_STACK_TUNE(
char ,
char
) sealed
J#
public SYS_STACK_TUNE(
byte ,
byte
)
JScript
public function SYS_STACK_TUNE(
: Byte,
: Byte
)

See Also

SYS_STACK_TUNE Class
TI.ZPI2 Namespace
SYS_STACK_TUNE Constructor Overload List


Fields

SYS_STACK_TUNE Fields
[image]

Public Fields

 | Name | Description
Public field | Operation | Operation being requested according to the STK_Tune_t enumeration.
Public field | Value | Value of the stack tuning parameter according to the operation requested.
Top

See Also

SYS_STACK_TUNE Class
TI.ZPI2 Namespace


Operation Field

SYS_STACK_TUNE.Operation Field
[image]

Operation being requested according to the STK_Tune_t enumeration.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Operation As Byte
C#
public byte Operation;
C++
public:
char Operation sealed ;
J#
public byte Operation
JScript
public Operation : Byte;

See Also

SYS_STACK_TUNE Class
TI.ZPI2 Namespace


Value Field

SYS_STACK_TUNE.Value Field
[image]

Value of the stack tuning parameter according to the operation requested.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte
C#
public byte Value;
C++
public:
char Value sealed ;
J#
public byte Value
JScript
public Value : Byte;

See Also

SYS_STACK_TUNE Class
TI.ZPI2 Namespace


SYS_STACK_TUNE_SRSP Class

SYS_STACK_TUNE_SRSP Class
See Also Example Members
[image]

Response for SYS_STACK_TUNE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_STACK_TUNE_SRSP
Implements IRESPONSE, ISYSTEM
C#
public class SYS_STACK_TUNE_SRSP : IRESPONSE, ISYSTEM
C++
ref class SYS_STACK_TUNE_SRSP : IRESPONSE, ISYSTEM
J#
public class SYS_STACK_TUNE_SRSP implements IRESPONSE, ISYSTEM
JScript
public class SYS_STACK_TUNE_SRSP extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_STACK_TUNE_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_STACK_TUNE_SRSP Members
TI.ZPI2 Namespace


SYS_STACK_TUNE_SRSP Members

SYS_STACK_TUNE_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_STACK_TUNE

The following tables list the members exposed by SYS_STACK_TUNE_SRSP.

Public Constructors

Name | Description
SYS_STACK_TUNE_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_STACK_TUNE_SRSP | Overloaded.
Top

See Also

SYS_STACK_TUNE_SRSP Class
TI.ZPI2 Namespace


SYS_STACK_TUNE_SRSP Constructor

SYS_STACK_TUNE_SRSP Constructor

Overload List

 | Name | Description
Public method | SYS_STACK_TUNE_SRSP | Constructor
Public method | SYS_STACK_TUNE_SRSP (SYS_STACK_TUNE_SRSP.CMD_STATUS) |

See Also

SYS_STACK_TUNE_SRSP Class
TI.ZPI2 Namespace


SYS_STACK_TUNE_SRSP Constructor ()

SYS_STACK_TUNE_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_STACK_TUNE_SRSP()
C++
public:
SYS_STACK_TUNE_SRSP() sealed
J#
public SYS_STACK_TUNE_SRSP()
JScript
public function SYS_STACK_TUNE_SRSP()

See Also

SYS_STACK_TUNE_SRSP Class
TI.ZPI2 Namespace
SYS_STACK_TUNE_SRSP Constructor Overload List


SYS_STACK_TUNE_SRSP Constructor (SYS_STACK_TUNE_SRSP.CMD_STATUS)

SYS_STACK_TUNE_SRSP Constructor (SYS_STACK_TUNE_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As SYS_STACK_TUNE_SRSP.CMD_STATUS _
)
C#
public SYS_STACK_TUNE_SRSP(
SYS_STACK_TUNE_SRSP.CMD_STATUS
)
C++
public:
SYS_STACK_TUNE_SRSP(
SYS_STACK_TUNE_SRSP.CMD_STATUS
) sealed
J#
public SYS_STACK_TUNE_SRSP(
SYS_STACK_TUNE_SRSP.CMD_STATUS
)
JScript
public function SYS_STACK_TUNE_SRSP(
: SYS_STACK_TUNE_SRSP.CMD_STATUS
)

See Also

SYS_STACK_TUNE_SRSP Class
TI.ZPI2 Namespace
SYS_STACK_TUNE_SRSP Constructor Overload List


Fields

SYS_STACK_TUNE_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

SYS_STACK_TUNE_SRSP Class
TI.ZPI2 Namespace


Status Field

SYS_STACK_TUNE_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As SYS_STACK_TUNE_SRSP.CMD_STATUS
C#
public SYS_STACK_TUNE_SRSP.CMD_STATUS Status;
C++
public:
SYS_STACK_TUNE_SRSP.CMD_STATUS Status sealed ;
J#
public SYS_STACK_TUNE_SRSP.CMD_STATUS Status
JScript
public Status : SYS_STACK_TUNE_SRSP.CMD_STATUS;

See Also

SYS_STACK_TUNE_SRSP Class
TI.ZPI2 Namespace


SYS_STACK_TUNE_SRSP.CMD_STATUS Enumeration

SYS_STACK_TUNE_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SYS_STACK_TUNE_SRSP.CMD_STATUS As Byte
C#
public enum SYS_STACK_TUNE_SRSP.CMD_STATUS : byte
C++
public enum class SYS_STACK_TUNE_SRSP.CMD_STATUS : char
J#
public enum SYS_STACK_TUNE_SRSP.CMD_STATUS byte
JScript
public enum SYS_STACK_TUNE_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


SYS_VERSION Class

SYS_VERSION Class
See Also Example Members
[image]

This command is used to get the device's version string.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_VERSION
Implements IREQUEST, ISYSTEM
C#
public class SYS_VERSION : IREQUEST, ISYSTEM
C++
ref class SYS_VERSION : IREQUEST, ISYSTEM
J#
public class SYS_VERSION implements IREQUEST, ISYSTEM
JScript
public class SYS_VERSION extends IREQUEST, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_VERSION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_VERSION Members
TI.ZPI2 Namespace


SYS_VERSION Members

SYS_VERSION Members
See Also Example Constructors Methods
[image]

This command is used to get the device's version string.

The following tables list the members exposed by SYS_VERSION.

Public Constructors

 | Name | Description
Public method | SYS_VERSION | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SYS_VERSION Class
TI.ZPI2 Namespace


SYS_VERSION Constructor

SYS_VERSION Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_VERSION()
C++
public:
SYS_VERSION() sealed
J#
public SYS_VERSION()
JScript
public function SYS_VERSION()

See Also

SYS_VERSION Class
TI.ZPI2 Namespace


SYS_VERSION_RESPONSE Class

SYS_VERSION_RESPONSE Class
See Also Example Members
[image]

Response for SYS_VERSION

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SYS_VERSION_RESPONSE
Implements IRESPONSE, ISYSTEM
C#
public class SYS_VERSION_RESPONSE : IRESPONSE, ISYSTEM
C++
ref class SYS_VERSION_RESPONSE : IRESPONSE, ISYSTEM
J#
public class SYS_VERSION_RESPONSE implements IRESPONSE, ISYSTEM
JScript
public class SYS_VERSION_RESPONSE extends IRESPONSE, ISYSTEM

Inheritance Hierarchy

System.Object
TI.ZPI2.SYS_VERSION_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SYS_VERSION_RESPONSE Members
TI.ZPI2 Namespace


SYS_VERSION_RESPONSE Members

SYS_VERSION_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for SYS_VERSION

The following tables list the members exposed by SYS_VERSION_RESPONSE.

Public Constructors

Name | Description
SYS_VERSION_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | HwRev | Hardware revision
Public field | MajorRel | Major release number
Public field | MinorRel | Minor release number
Public field | Product | Product ID
Public field | TransportRev | Transport revision
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SYS_VERSION_RESPONSE | Overloaded.
Top

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


SYS_VERSION_RESPONSE Constructor

SYS_VERSION_RESPONSE Constructor

Overload List

 | Name | Description
Public method | SYS_VERSION_RESPONSE | Constructor
Public method | SYS_VERSION_RESPONSE (Byte, Byte, Byte, Byte, Byte) | Constructor

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


SYS_VERSION_RESPONSE Constructor ()

SYS_VERSION_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SYS_VERSION_RESPONSE()
C++
public:
SYS_VERSION_RESPONSE() sealed
J#
public SYS_VERSION_RESPONSE()
JScript
public function SYS_VERSION_RESPONSE()

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace
SYS_VERSION_RESPONSE Constructor Overload List


SYS_VERSION_RESPONSE Constructor (Byte, Byte, Byte, Byte, Byte)

SYS_VERSION_RESPONSE Constructor (Byte, Byte, Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public SYS_VERSION_RESPONSE(
byte ,
byte ,
byte ,
byte ,
byte
)
C++
public:
SYS_VERSION_RESPONSE(
char ,
char ,
char ,
char ,
char
) sealed
J#
public SYS_VERSION_RESPONSE(
byte ,
byte ,
byte ,
byte ,
byte
)
JScript
public function SYS_VERSION_RESPONSE(
: Byte,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace
SYS_VERSION_RESPONSE Constructor Overload List


Fields

SYS_VERSION_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | HwRev | Hardware revision
Public field | MajorRel | Major release number
Public field | MinorRel | Minor release number
Public field | Product | Product ID
Public field | TransportRev | Transport revision
Top

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


HwRev Field

SYS_VERSION_RESPONSE.HwRev Field
[image]

Hardware revision

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public HwRev As Byte
C#
public byte HwRev;
C++
public:
char HwRev sealed ;
J#
public byte HwRev
JScript
public HwRev : Byte;

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


MajorRel Field

SYS_VERSION_RESPONSE.MajorRel Field
[image]

Major release number

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MajorRel As Byte
C#
public byte MajorRel;
C++
public:
char MajorRel sealed ;
J#
public byte MajorRel
JScript
public MajorRel : Byte;

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


MinorRel Field

SYS_VERSION_RESPONSE.MinorRel Field
[image]

Minor release number

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MinorRel As Byte
C#
public byte MinorRel;
C++
public:
char MinorRel sealed ;
J#
public byte MinorRel
JScript
public MinorRel : Byte;

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


Product Field

SYS_VERSION_RESPONSE.Product Field
[image]

Product ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Product As Byte
C#
public byte Product;
C++
public:
char Product sealed ;
J#
public byte Product
JScript
public Product : Byte;

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


TransportRev Field

SYS_VERSION_RESPONSE.TransportRev Field
[image]

Transport revision

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TransportRev As Byte
C#
public byte TransportRev;
C++
public:
char TransportRev sealed ;
J#
public byte TransportRev
JScript
public TransportRev : Byte;

See Also

SYS_VERSION_RESPONSE Class
TI.ZPI2 Namespace


USERTEST_REQUEST Class

USERTEST_REQUEST Class
See Also Example Members
[image]

This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class USERTEST_REQUEST
Implements IREQUEST
C#
public class USERTEST_REQUEST : IREQUEST
C++
ref class USERTEST_REQUEST : IREQUEST
J#
public class USERTEST_REQUEST implements IREQUEST
JScript
public class USERTEST_REQUEST extends IREQUEST

Inheritance Hierarchy

System.Object
TI.ZPI2.USERTEST_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

USERTEST_REQUEST Members
TI.ZPI2 Namespace


USERTEST_REQUEST Members

USERTEST_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is sent to the target in order to test the functions defined for individual applications (which internally use attributes and cluster IDs from various device descriptions).

The following tables list the members exposed by USERTEST_REQUEST.

Public Constructors

Name | Description
USERTEST_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Command | Source address of the message
Public field | Endpoint | indicates the endpoint of the application
Public field | Param1 | first parameter of the command (usually an On/Off indicator or a level indicating value)
Public field | Param2 | second parameter of the command (usually an On/Off indicator or a level indicating value)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
USERTEST_REQUEST | Overloaded.
Top

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace


USERTEST_REQUEST Constructor

USERTEST_REQUEST Constructor

Overload List

 | Name | Description
Public method | USERTEST_REQUEST | Constructor
Public method | USERTEST_REQUEST (Byte, USERTEST_REQUEST.USERTEST_COMMAND, UInt16, UInt16) |

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace


USERTEST_REQUEST Constructor ()

USERTEST_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public USERTEST_REQUEST()
C++
public:
USERTEST_REQUEST() sealed
J#
public USERTEST_REQUEST()
JScript
public function USERTEST_REQUEST()

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace
USERTEST_REQUEST Constructor Overload List


USERTEST_REQUEST Constructor (Byte, USERTEST_REQUEST.USERTEST_COMMAND, UInt16, UInt16)

USERTEST_REQUEST Constructor (Byte, USERTEST_REQUEST.USERTEST_COMMAND, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As USERTEST_REQUEST.USERTEST_COMMAND, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public USERTEST_REQUEST(
byte ,
USERTEST_REQUEST.USERTEST_COMMAND ,
ushort ,
ushort
)
C++
public:
USERTEST_REQUEST(
char ,
USERTEST_REQUEST.USERTEST_COMMAND ,
unsigned short ,
unsigned short
) sealed
J#
public USERTEST_REQUEST(
byte ,
USERTEST_REQUEST.USERTEST_COMMAND ,
ushort ,
ushort
)
JScript
public function USERTEST_REQUEST(
: Byte,
: USERTEST_REQUEST.USERTEST_COMMAND,
: UInt16,
: UInt16
)

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace
USERTEST_REQUEST Constructor Overload List


Fields

USERTEST_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Command | Source address of the message
Public field | Endpoint | indicates the endpoint of the application
Public field | Param1 | first parameter of the command (usually an On/Off indicator or a level indicating value)
Public field | Param2 | second parameter of the command (usually an On/Off indicator or a level indicating value)
Top

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace


Command Field

USERTEST_REQUEST.Command Field
[image]

Source address of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Command As USERTEST_REQUEST.USERTEST_COMMAND
C#
public USERTEST_REQUEST.USERTEST_COMMAND Command;
C++
public:
USERTEST_REQUEST.USERTEST_COMMAND Command sealed ;
J#
public USERTEST_REQUEST.USERTEST_COMMAND Command
JScript
public Command : USERTEST_REQUEST.USERTEST_COMMAND;

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace


Endpoint Field

USERTEST_REQUEST.Endpoint Field
[image]

indicates the endpoint of the application

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace


Param1 Field

USERTEST_REQUEST.Param1 Field
[image]

first parameter of the command (usually an On/Off indicator or a level indicating value)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Param1 As UInt16
C#
public ushort Param1;
C++
public:
unsigned short Param1 sealed ;
J#
public ushort Param1
JScript
public Param1 : UInt16;

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace


Param2 Field

USERTEST_REQUEST.Param2 Field
[image]

second parameter of the command (usually an On/Off indicator or a level indicating value)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Param2 As UInt16
C#
public ushort Param2;
C++
public:
unsigned short Param2 sealed ;
J#
public ushort Param2
JScript
public Param2 : UInt16;

See Also

USERTEST_REQUEST Class
TI.ZPI2 Namespace


USERTEST_REQUEST.USERTEST_COMMAND Enumeration

USERTEST_REQUEST.USERTEST_COMMAND Enumeration
[image]

Usertest command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum USERTEST_REQUEST.USERTEST_COMMAND As Short
C#
public enum USERTEST_REQUEST.USERTEST_COMMAND : short
C++
public enum class USERTEST_REQUEST.USERTEST_COMMAND : short
J#
public enum USERTEST_REQUEST.USERTEST_COMMAND short
JScript
public enum USERTEST_REQUEST.USERTEST_COMMAND : short

Members

Member Name | Description
SRC03391_CHANGESTATE | Usertest command
DRC03392_TOGGLESTATE | Usertest command
DRC03392_TOGGLEPRESET | Usertest command
DRC03392_DIMBRIGHT | Usertest command
OS03393_TOGGLESTATE | Usertest command
SLC03394_RCVSET_ONOFFSRC | Usertest command
DLC03395_RCVSET_ONOFFDRC | Usertest command
DLC03395_RCVSET_DIMBRIGHTDRC | Usertest command
DLC03395_RCVSET_PRESETDRC | Usertest command
LSM02080_TOGGLESTATE | Usertest command
TP_SEND_NODATA | Usertest command
TP_SEND_BUFFERTEST | Usertest command
TP_SEND_UINT8 | Usertest command
TP_SEND_INT8 | Usertest command
TP_SEND_UINT16 | Usertest command
TP_SEND_INT16 | Usertest command
TP_SEND_SEMIPREC | Usertest command
TP_SEND_FREEFORM | Usertest command
TP_SEND_ABS_TIME | Usertest command
TP_SEND_REL_TIME | Usertest command
TP_SEND_CHAR_STRING | Usertest command
TP_SEND_OCTET_STRING | Usertest command
TP_SET_DSTADDRESS | Usertest command
TP_SEND_BUFFER | Usertest command
TP_SEND_CON_INT8 | Usertest command
TP_SEND_CON_INT16 | Usertest command
TP_SEND_CON_TIME | Usertest command
TP_SEND_MULT_KVP_8BIT | Usertest command
TP_SEND_MULT_KVP_16BIT | Usertest command
TP_SEND_MULT_KVP_TIME | Usertest command
TP_SEND_MULT_KVP_STRING | Usertest command
TP_SEND_COUNTED_PKTS | Usertest command
TP_SEND_RESET_COUNTER | Usertest command
TP_SEND_GET_COUNTER | Usertest command
TP_SEND_MULTI_KVP_STR_TIME | Usertest command

See Also

TI.ZPI2 Namespace


USERTEST_RESPONSE Class

USERTEST_RESPONSE Class
See Also Example Members
[image]

Response for USERTEST_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class USERTEST_RESPONSE
Implements IRESPONSE
C#
public class USERTEST_RESPONSE : IRESPONSE
C++
ref class USERTEST_RESPONSE : IRESPONSE
J#
public class USERTEST_RESPONSE implements IRESPONSE
JScript
public class USERTEST_RESPONSE extends IRESPONSE

Inheritance Hierarchy

System.Object
TI.ZPI2.USERTEST_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

USERTEST_RESPONSE Members
TI.ZPI2 Namespace


USERTEST_RESPONSE Members

USERTEST_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for USERTEST_REQUEST

The following tables list the members exposed by USERTEST_RESPONSE.

Public Constructors

Name | Description
USERTEST_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
USERTEST_RESPONSE | Overloaded.
Top

See Also

USERTEST_RESPONSE Class
TI.ZPI2 Namespace


USERTEST_RESPONSE Constructor

USERTEST_RESPONSE Constructor

Overload List

 | Name | Description
Public method | USERTEST_RESPONSE | Constructor
Public method | USERTEST_RESPONSE (USERTEST_RESPONSE.CMD_STATUS) |

See Also

USERTEST_RESPONSE Class
TI.ZPI2 Namespace


USERTEST_RESPONSE Constructor ()

USERTEST_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public USERTEST_RESPONSE()
C++
public:
USERTEST_RESPONSE() sealed
J#
public USERTEST_RESPONSE()
JScript
public function USERTEST_RESPONSE()

See Also

USERTEST_RESPONSE Class
TI.ZPI2 Namespace
USERTEST_RESPONSE Constructor Overload List


USERTEST_RESPONSE Constructor (USERTEST_RESPONSE.CMD_STATUS)

USERTEST_RESPONSE Constructor (USERTEST_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As USERTEST_RESPONSE.CMD_STATUS _
)
C#
public USERTEST_RESPONSE(
USERTEST_RESPONSE.CMD_STATUS
)
C++
public:
USERTEST_RESPONSE(
USERTEST_RESPONSE.CMD_STATUS
) sealed
J#
public USERTEST_RESPONSE(
USERTEST_RESPONSE.CMD_STATUS
)
JScript
public function USERTEST_RESPONSE(
: USERTEST_RESPONSE.CMD_STATUS
)

See Also

USERTEST_RESPONSE Class
TI.ZPI2 Namespace
USERTEST_RESPONSE Constructor Overload List


Fields

USERTEST_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

USERTEST_RESPONSE Class
TI.ZPI2 Namespace


Status Field

USERTEST_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As USERTEST_RESPONSE.CMD_STATUS
C#
public USERTEST_RESPONSE.CMD_STATUS Status;
C++
public:
USERTEST_RESPONSE.CMD_STATUS Status sealed ;
J#
public USERTEST_RESPONSE.CMD_STATUS Status
JScript
public Status : USERTEST_RESPONSE.CMD_STATUS;

See Also

USERTEST_RESPONSE Class
TI.ZPI2 Namespace


USERTEST_RESPONSE.CMD_STATUS Enumeration

USERTEST_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum USERTEST_RESPONSE.CMD_STATUS As Byte
C#
public enum USERTEST_RESPONSE.CMD_STATUS : byte
C++
public enum class USERTEST_RESPONSE.CMD_STATUS : char
J#
public enum USERTEST_RESPONSE.CMD_STATUS byte
JScript
public enum USERTEST_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class
See Also Example Members
[image]

This command is the RPC proxy to AddrMgrEntryLookupExt().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ADDRMGR_EXT_ADDR_LOOKUP
Implements IREQUEST, IUTIL
C#
public class UTIL_ADDRMGR_EXT_ADDR_LOOKUP : IREQUEST, IUTIL
C++
ref class UTIL_ADDRMGR_EXT_ADDR_LOOKUP : IREQUEST, IUTIL
J#
public class UTIL_ADDRMGR_EXT_ADDR_LOOKUP implements IREQUEST, IUTIL
JScript
public class UTIL_ADDRMGR_EXT_ADDR_LOOKUP extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Members
TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP Members

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is the RPC proxy to AddrMgrEntryLookupExt().

The following tables list the members exposed by UTIL_ADDRMGR_EXT_ADDR_LOOKUP.

Public Constructors

Name | Description
UTIL_ADDRMGR_EXT_ADDR_LOOKUP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ExtAddr | Extended Address for which to lookup the corresponding Network Address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ADDRMGR_EXT_ADDR_LOOKUP | Overloaded.
Top

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor

Overload List

 | Name | Description
Public method | UTIL_ADDRMGR_EXT_ADDR_LOOKUP | Constructor
Public method | UTIL_ADDRMGR_EXT_ADDR_LOOKUP (UInt64) | Constructor

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor ()

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP()
C++
public:
UTIL_ADDRMGR_EXT_ADDR_LOOKUP() sealed
J#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP()
JScript
public function UTIL_ADDRMGR_EXT_ADDR_LOOKUP()

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor Overload List


UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor (UInt64)

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP(
ulong
)
C++
public:
UTIL_ADDRMGR_EXT_ADDR_LOOKUP(
unsigned __int64
) sealed
J#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP(
ulong
)
JScript
public function UTIL_ADDRMGR_EXT_ADDR_LOOKUP(
: UInt64
)

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_EXT_ADDR_LOOKUP Constructor Overload List


Fields

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Fields
[image]

Public Fields

 | Name | Description
Public field | ExtAddr | Extended Address for which to lookup the corresponding Network Address.
Top

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class
TI.ZPI2 Namespace


ExtAddr Field

UTIL_ADDRMGR_EXT_ADDR_LOOKUP.ExtAddr Field
[image]

Extended Address for which to lookup the corresponding Network Address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As UInt64
C#
public ulong ExtAddr;
C++
public:
unsigned __int64 ExtAddr sealed ;
J#
public ulong ExtAddr
JScript
public ExtAddr : UInt64;

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from AddrMgrEntryLookupExt().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Members
TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Members

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from AddrMgrEntryLookupExt().

The following tables list the members exposed by UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE.

Public Constructors

Name | Description
UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NwkAddr | Network Address that corresponds to the Extended Address looked-up - 0xFFFE if failure.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE | Overloaded.
Top

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE | Constructor
Public method | UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE (UInt16) | Constructor

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor ()

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE()
C++
public:
UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE() sealed
J#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE()
JScript
public function UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE()

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor Overload List


UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor (UInt16)

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE(
ushort
)
C++
public:
UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE(
unsigned short
) sealed
J#
public UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE(
ushort
)
JScript
public function UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE(
: UInt16
)

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Constructor Overload List


Fields

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | NwkAddr | Network Address that corresponds to the Extended Address looked-up - 0xFFFE if failure.
Top

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


NwkAddr Field

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE.NwkAddr Field
[image]

Network Address that corresponds to the Extended Address looked-up - 0xFFFE if failure.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class
See Also Example Members
[image]

This command is the RPC proxy to AddrMgrEntryLookupNwk().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ADDRMGR_NWK_ADDR_LOOKUP
Implements IREQUEST, IUTIL
C#
public class UTIL_ADDRMGR_NWK_ADDR_LOOKUP : IREQUEST, IUTIL
C++
ref class UTIL_ADDRMGR_NWK_ADDR_LOOKUP : IREQUEST, IUTIL
J#
public class UTIL_ADDRMGR_NWK_ADDR_LOOKUP implements IREQUEST, IUTIL
JScript
public class UTIL_ADDRMGR_NWK_ADDR_LOOKUP extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Members
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP Members

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is the RPC proxy to AddrMgrEntryLookupNwk().

The following tables list the members exposed by UTIL_ADDRMGR_NWK_ADDR_LOOKUP.

Public Constructors

Name | Description
UTIL_ADDRMGR_NWK_ADDR_LOOKUP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NwkAddr | Network Address for which to lookup the corresponding Extended Address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ADDRMGR_NWK_ADDR_LOOKUP | Overloaded.
Top

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor

Overload List

 | Name | Description
Public method | UTIL_ADDRMGR_NWK_ADDR_LOOKUP | Constructor
Public method | UTIL_ADDRMGR_NWK_ADDR_LOOKUP (UInt16) | Constructor

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor ()

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP()
C++
public:
UTIL_ADDRMGR_NWK_ADDR_LOOKUP() sealed
J#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP()
JScript
public function UTIL_ADDRMGR_NWK_ADDR_LOOKUP()

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor Overload List


UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor (UInt16)

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP(
ushort
)
C++
public:
UTIL_ADDRMGR_NWK_ADDR_LOOKUP(
unsigned short
) sealed
J#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP(
ushort
)
JScript
public function UTIL_ADDRMGR_NWK_ADDR_LOOKUP(
: UInt16
)

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_NWK_ADDR_LOOKUP Constructor Overload List


Fields

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Fields
[image]

Public Fields

 | Name | Description
Public field | NwkAddr | Network Address for which to lookup the corresponding Extended Address.
Top

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class
TI.ZPI2 Namespace


NwkAddr Field

UTIL_ADDRMGR_NWK_ADDR_LOOKUP.NwkAddr Field
[image]

Network Address for which to lookup the corresponding Extended Address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from AddrMgrEntryLookupNwk().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Members
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Members

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from AddrMgrEntryLookupNwk().

The following tables list the members exposed by UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE.

Public Constructors

Name | Description
UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ExtAddr | Extended Address that corresponds to the Network Address looked-up - 0x00000000 if failure.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE | Overloaded.
Top

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE | Constructor
Public method | UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE (UInt64) | Constructor

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor ()

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE()
C++
public:
UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE() sealed
J#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE()
JScript
public function UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE()

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor Overload List


UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor (UInt64)

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE(
ulong
)
C++
public:
UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE(
unsigned __int64
) sealed
J#
public UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE(
ulong
)
JScript
public function UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE(
: UInt64
)

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Constructor Overload List


Fields

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | ExtAddr | Extended Address that corresponds to the Network Address looked-up - 0x00000000 if failure.
Top

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


ExtAddr Field

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE.ExtAddr Field
[image]

Extended Address that corresponds to the Network Address looked-up - 0x00000000 if failure.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As UInt64
C#
public ulong ExtAddr;
C++
public:
unsigned __int64 ExtAddr sealed ;
J#
public ulong ExtAddr
JScript
public ExtAddr : UInt64;

See Also

UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET Class

UTIL_APSME_LINK_KEY_DATA_GET Class
See Also Example Members
[image]

Use this message to retrieve APS link key data and frame counters.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_APSME_LINK_KEY_DATA_GET
Implements IREQUEST, IUTIL
C#
public class UTIL_APSME_LINK_KEY_DATA_GET : IREQUEST, IUTIL
C++
ref class UTIL_APSME_LINK_KEY_DATA_GET : IREQUEST, IUTIL
J#
public class UTIL_APSME_LINK_KEY_DATA_GET implements IREQUEST, IUTIL
JScript
public class UTIL_APSME_LINK_KEY_DATA_GET extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_APSME_LINK_KEY_DATA_GET Members
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET Members

UTIL_APSME_LINK_KEY_DATA_GET Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to retrieve APS link key data and frame counters.

The following tables list the members exposed by UTIL_APSME_LINK_KEY_DATA_GET.

Public Constructors

Name | Description
UTIL_APSME_LINK_KEY_DATA_GET | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ExtAddr | Extended address for which to lookup the corresponding APS link key data.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_APSME_LINK_KEY_DATA_GET | Overloaded.
Top

See Also

UTIL_APSME_LINK_KEY_DATA_GET Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET Constructor

UTIL_APSME_LINK_KEY_DATA_GET Constructor

Overload List

 | Name | Description
Public method | UTIL_APSME_LINK_KEY_DATA_GET | Constructor
Public method | UTIL_APSME_LINK_KEY_DATA_GET (UInt64) | Constructor

See Also

UTIL_APSME_LINK_KEY_DATA_GET Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET Constructor ()

UTIL_APSME_LINK_KEY_DATA_GET Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_APSME_LINK_KEY_DATA_GET()
C++
public:
UTIL_APSME_LINK_KEY_DATA_GET() sealed
J#
public UTIL_APSME_LINK_KEY_DATA_GET()
JScript
public function UTIL_APSME_LINK_KEY_DATA_GET()

See Also

UTIL_APSME_LINK_KEY_DATA_GET Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_DATA_GET Constructor Overload List


UTIL_APSME_LINK_KEY_DATA_GET Constructor (UInt64)

UTIL_APSME_LINK_KEY_DATA_GET Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public UTIL_APSME_LINK_KEY_DATA_GET(
ulong
)
C++
public:
UTIL_APSME_LINK_KEY_DATA_GET(
unsigned __int64
) sealed
J#
public UTIL_APSME_LINK_KEY_DATA_GET(
ulong
)
JScript
public function UTIL_APSME_LINK_KEY_DATA_GET(
: UInt64
)

See Also

UTIL_APSME_LINK_KEY_DATA_GET Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_DATA_GET Constructor Overload List


Fields

UTIL_APSME_LINK_KEY_DATA_GET Fields
[image]

Public Fields

 | Name | Description
Public field | ExtAddr | Extended address for which to lookup the corresponding APS link key data.
Top

See Also

UTIL_APSME_LINK_KEY_DATA_GET Class
TI.ZPI2 Namespace


ExtAddr Field

UTIL_APSME_LINK_KEY_DATA_GET.ExtAddr Field
[image]

Extended address for which to lookup the corresponding APS link key data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As UInt64
C#
public ulong ExtAddr;
C++
public:
unsigned __int64 ExtAddr sealed ;
J#
public ulong ExtAddr
JScript
public ExtAddr : UInt64;

See Also

UTIL_APSME_LINK_KEY_DATA_GET Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_APSME_LINK_KEY_DATA_GET.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Members
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Members

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_APSME_LINK_KEY_DATA_GET.

The following tables list the members exposed by UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.

Public Constructors

Name | Description
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | RxFrmCntr | On success, the RX frame counter; otherwise N/A.
Public field | SecKey | On success, the security key looked up; otherwise N/A.
Public field | Status | Status of proxy call to APSME_LinkKeyNvIdGet().
Public field | TxFrmCntr | On success, the TX frame counter; otherwise N/A.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE | Overloaded.
Top

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE | Constructor
Public method | UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE (UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS, Byte, UInt32, UInt32) |

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor ()

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE()
C++
public:
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE() sealed
J#
public UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE()
JScript
public function UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE()

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor Overload List


UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor (UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS, Byte[], UInt32, UInt32)

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor (UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS, Byte[], UInt32, UInt32)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS, _
ByVal As Byte(), _
ByVal As UInt32, _
ByVal As UInt32 _
)
C#
public UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE(
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS ,
byte[] ,
uint ,
uint
)
C++
public:
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE(
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS ,
array<char>^ ,
unsigned int ,
unsigned int
) sealed
J#
public UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE(
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS ,
byte[] ,
uint ,
uint
)
JScript
public function UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE(
: UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS,
: Byte[],
: UInt32,
: UInt32
)

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Constructor Overload List


Fields

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | RxFrmCntr | On success, the RX frame counter; otherwise N/A.
Public field | SecKey | On success, the security key looked up; otherwise N/A.
Public field | Status | Status of proxy call to APSME_LinkKeyNvIdGet().
Public field | TxFrmCntr | On success, the TX frame counter; otherwise N/A.
Top

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace


RxFrmCntr Field

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.RxFrmCntr Field
[image]

On success, the RX frame counter; otherwise N/A.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RxFrmCntr As UInt32
C#
public uint RxFrmCntr;
C++
public:
unsigned int RxFrmCntr sealed ;
J#
public uint RxFrmCntr
JScript
public RxFrmCntr : UInt32;

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace


SecKey Field

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.SecKey Field
[image]

On success, the security key looked up; otherwise N/A.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecKey As Byte()
C#
public byte[] SecKey;
C++
public:
array<char>^ SecKey sealed ;
J#
public byte[] SecKey
JScript
public SecKey : Byte[];

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.Status Field
[image]

Status of proxy call to APSME_LinkKeyNvIdGet().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS
C#
public UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS;

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace


TxFrmCntr Field

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.TxFrmCntr Field
[image]

On success, the TX frame counter; otherwise N/A.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxFrmCntr As UInt32
C#
public uint TxFrmCntr;
C++
public:
unsigned int TxFrmCntr sealed ;
J#
public uint TxFrmCntr
JScript
public TxFrmCntr : UInt32;

See Also

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS Enumeration

UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET Class

UTIL_APSME_LINK_KEY_NV_ID_GET Class
See Also Example Members
[image]

Use this message to proxy a call to the APSME_LinkKeyNvIdGet() function.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_APSME_LINK_KEY_NV_ID_GET
Implements IREQUEST, IUTIL
C#
public class UTIL_APSME_LINK_KEY_NV_ID_GET : IREQUEST, IUTIL
C++
ref class UTIL_APSME_LINK_KEY_NV_ID_GET : IREQUEST, IUTIL
J#
public class UTIL_APSME_LINK_KEY_NV_ID_GET implements IREQUEST, IUTIL
JScript
public class UTIL_APSME_LINK_KEY_NV_ID_GET extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET Members
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET Members

UTIL_APSME_LINK_KEY_NV_ID_GET Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to proxy a call to the APSME_LinkKeyNvIdGet() function.

The following tables list the members exposed by UTIL_APSME_LINK_KEY_NV_ID_GET.

Public Constructors

Name | Description
UTIL_APSME_LINK_KEY_NV_ID_GET | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ExtAddr | Extended address for which to lookup the corresponding APS link key NV Id.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_APSME_LINK_KEY_NV_ID_GET | Overloaded.
Top

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET Constructor

UTIL_APSME_LINK_KEY_NV_ID_GET Constructor

Overload List

 | Name | Description
Public method | UTIL_APSME_LINK_KEY_NV_ID_GET | Constructor
Public method | UTIL_APSME_LINK_KEY_NV_ID_GET (UInt64) | Constructor

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET Constructor ()

UTIL_APSME_LINK_KEY_NV_ID_GET Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_APSME_LINK_KEY_NV_ID_GET()
C++
public:
UTIL_APSME_LINK_KEY_NV_ID_GET() sealed
J#
public UTIL_APSME_LINK_KEY_NV_ID_GET()
JScript
public function UTIL_APSME_LINK_KEY_NV_ID_GET()

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_NV_ID_GET Constructor Overload List


UTIL_APSME_LINK_KEY_NV_ID_GET Constructor (UInt64)

UTIL_APSME_LINK_KEY_NV_ID_GET Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public UTIL_APSME_LINK_KEY_NV_ID_GET(
ulong
)
C++
public:
UTIL_APSME_LINK_KEY_NV_ID_GET(
unsigned __int64
) sealed
J#
public UTIL_APSME_LINK_KEY_NV_ID_GET(
ulong
)
JScript
public function UTIL_APSME_LINK_KEY_NV_ID_GET(
: UInt64
)

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_NV_ID_GET Constructor Overload List


Fields

UTIL_APSME_LINK_KEY_NV_ID_GET Fields
[image]

Public Fields

 | Name | Description
Public field | ExtAddr | Extended address for which to lookup the corresponding APS link key NV Id.
Top

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET Class
TI.ZPI2 Namespace


ExtAddr Field

UTIL_APSME_LINK_KEY_NV_ID_GET.ExtAddr Field
[image]

Extended address for which to lookup the corresponding APS link key NV Id.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As UInt64
C#
public ulong ExtAddr;
C++
public:
unsigned __int64 ExtAddr sealed ;
J#
public ulong ExtAddr
JScript
public ExtAddr : UInt64;

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from APSME_LinkKeyNvIdGet().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Members
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Members

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from APSME_LinkKeyNvIdGet().

The following tables list the members exposed by UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.

Public Constructors

Name | Description
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | LinkKeyNvId | On success, link key NV Id; otherwise 0xFFFF.
Public field | Status | Status of proxy call to APSME_LinkKeyNvIdGet().
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE | Overloaded.
Top

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE | Constructor
Public method | UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE (UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS, UInt16) |

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor ()

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE()
C++
public:
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE() sealed
J#
public UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE()
JScript
public function UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE()

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor Overload List


UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor (UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS, UInt16)

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor (UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS, _
ByVal As UInt16 _
)
C#
public UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE(
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS ,
ushort
)
C++
public:
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE(
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS ,
unsigned short
) sealed
J#
public UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE(
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS ,
ushort
)
JScript
public function UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE(
: UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS,
: UInt16
)

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
TI.ZPI2 Namespace
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Constructor Overload List


Fields

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | LinkKeyNvId | On success, link key NV Id; otherwise 0xFFFF.
Public field | Status | Status of proxy call to APSME_LinkKeyNvIdGet().
Top

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
TI.ZPI2 Namespace


LinkKeyNvId Field

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.LinkKeyNvId Field
[image]

On success, link key NV Id; otherwise 0xFFFF.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkKeyNvId As UInt16
C#
public ushort LinkKeyNvId;
C++
public:
unsigned short LinkKeyNvId sealed ;
J#
public ushort LinkKeyNvId
JScript
public LinkKeyNvId : UInt16;

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.Status Field
[image]

Status of proxy call to APSME_LinkKeyNvIdGet().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS
C#
public UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS;

See Also

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE Class
TI.ZPI2 Namespace


UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS Enumeration

UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS Enumeration
See Also Example
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD Class

UTIL_APSME_REQUEST_KEY_CMD Class
See Also Example Members
[image]

This command is used to send a request key to the Trust Center from an originator device who wants to exchange messages with a partner device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_APSME_REQUEST_KEY_CMD
Implements IREQUEST, IUTIL
C#
public class UTIL_APSME_REQUEST_KEY_CMD : IREQUEST, IUTIL
C++
ref class UTIL_APSME_REQUEST_KEY_CMD : IREQUEST, IUTIL
J#
public class UTIL_APSME_REQUEST_KEY_CMD implements IREQUEST, IUTIL
JScript
public class UTIL_APSME_REQUEST_KEY_CMD extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_APSME_REQUEST_KEY_CMD Members
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD Members

UTIL_APSME_REQUEST_KEY_CMD Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a request key to the Trust Center from an originator device who wants to exchange messages with a partner device.

The following tables list the members exposed by UTIL_APSME_REQUEST_KEY_CMD.

Public Constructors

Name | Description
UTIL_APSME_REQUEST_KEY_CMD | Overloaded.
Top

Public Fields

 | Name | Description
Public field | PartnerAddr | Partner extended address
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_APSME_REQUEST_KEY_CMD | Overloaded.
Top

See Also

UTIL_APSME_REQUEST_KEY_CMD Class
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD Constructor

UTIL_APSME_REQUEST_KEY_CMD Constructor

Overload List

 | Name | Description
Public method | UTIL_APSME_REQUEST_KEY_CMD | Constructor
Public method | UTIL_APSME_REQUEST_KEY_CMD (UInt64) | Constructor

See Also

UTIL_APSME_REQUEST_KEY_CMD Class
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD Constructor ()

UTIL_APSME_REQUEST_KEY_CMD Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_APSME_REQUEST_KEY_CMD()
C++
public:
UTIL_APSME_REQUEST_KEY_CMD() sealed
J#
public UTIL_APSME_REQUEST_KEY_CMD()
JScript
public function UTIL_APSME_REQUEST_KEY_CMD()

See Also

UTIL_APSME_REQUEST_KEY_CMD Class
TI.ZPI2 Namespace
UTIL_APSME_REQUEST_KEY_CMD Constructor Overload List


UTIL_APSME_REQUEST_KEY_CMD Constructor (UInt64)

UTIL_APSME_REQUEST_KEY_CMD Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public UTIL_APSME_REQUEST_KEY_CMD(
ulong
)
C++
public:
UTIL_APSME_REQUEST_KEY_CMD(
unsigned __int64
) sealed
J#
public UTIL_APSME_REQUEST_KEY_CMD(
ulong
)
JScript
public function UTIL_APSME_REQUEST_KEY_CMD(
: UInt64
)

See Also

UTIL_APSME_REQUEST_KEY_CMD Class
TI.ZPI2 Namespace
UTIL_APSME_REQUEST_KEY_CMD Constructor Overload List


Fields

UTIL_APSME_REQUEST_KEY_CMD Fields
[image]

Public Fields

 | Name | Description
Public field | PartnerAddr | Partner extended address
Top

See Also

UTIL_APSME_REQUEST_KEY_CMD Class
TI.ZPI2 Namespace


PartnerAddr Field

UTIL_APSME_REQUEST_KEY_CMD.PartnerAddr Field
[image]

Partner extended address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PartnerAddr As UInt64
C#
public ulong PartnerAddr;
C++
public:
unsigned __int64 PartnerAddr sealed ;
J#
public ulong PartnerAddr
JScript
public PartnerAddr : UInt64;

See Also

UTIL_APSME_REQUEST_KEY_CMD Class
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD_SRSP Class

UTIL_APSME_REQUEST_KEY_CMD_SRSP Class
See Also Example Members
[image]

Response for UTIL_APSME_REQUEST_KEY_CMD

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_APSME_REQUEST_KEY_CMD_SRSP
Implements IRESPONSE, IUTIL
C#
public class UTIL_APSME_REQUEST_KEY_CMD_SRSP : IRESPONSE, IUTIL
C++
ref class UTIL_APSME_REQUEST_KEY_CMD_SRSP : IRESPONSE, IUTIL
J#
public class UTIL_APSME_REQUEST_KEY_CMD_SRSP implements IRESPONSE, IUTIL
JScript
public class UTIL_APSME_REQUEST_KEY_CMD_SRSP extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_APSME_REQUEST_KEY_CMD_SRSP Members
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD_SRSP Members

UTIL_APSME_REQUEST_KEY_CMD_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_APSME_REQUEST_KEY_CMD

The following tables list the members exposed by UTIL_APSME_REQUEST_KEY_CMD_SRSP.

Public Constructors

Name | Description
UTIL_APSME_REQUEST_KEY_CMD_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_APSME_REQUEST_KEY_CMD_SRSP | Overloaded.
Top

See Also

UTIL_APSME_REQUEST_KEY_CMD_SRSP Class
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor

UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor

Overload List

 | Name | Description
Public method | UTIL_APSME_REQUEST_KEY_CMD_SRSP | Constructor
Public method | UTIL_APSME_REQUEST_KEY_CMD_SRSP (UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS) |

See Also

UTIL_APSME_REQUEST_KEY_CMD_SRSP Class
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor ()

UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_APSME_REQUEST_KEY_CMD_SRSP()
C++
public:
UTIL_APSME_REQUEST_KEY_CMD_SRSP() sealed
J#
public UTIL_APSME_REQUEST_KEY_CMD_SRSP()
JScript
public function UTIL_APSME_REQUEST_KEY_CMD_SRSP()

See Also

UTIL_APSME_REQUEST_KEY_CMD_SRSP Class
TI.ZPI2 Namespace
UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor Overload List


UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor (UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS)

UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor (UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS _
)
C#
public UTIL_APSME_REQUEST_KEY_CMD_SRSP(
UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS
)
C++
public:
UTIL_APSME_REQUEST_KEY_CMD_SRSP(
UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS
) sealed
J#
public UTIL_APSME_REQUEST_KEY_CMD_SRSP(
UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS
)
JScript
public function UTIL_APSME_REQUEST_KEY_CMD_SRSP(
: UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS
)

See Also

UTIL_APSME_REQUEST_KEY_CMD_SRSP Class
TI.ZPI2 Namespace
UTIL_APSME_REQUEST_KEY_CMD_SRSP Constructor Overload List


Fields

UTIL_APSME_REQUEST_KEY_CMD_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_APSME_REQUEST_KEY_CMD_SRSP Class
TI.ZPI2 Namespace


Status Field

UTIL_APSME_REQUEST_KEY_CMD_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS
C#
public UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS Status;
C++
public:
UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS Status sealed ;
J#
public UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS Status
JScript
public Status : UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS;

See Also

UTIL_APSME_REQUEST_KEY_CMD_SRSP Class
TI.ZPI2 Namespace


UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS Enumeration

UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS As Byte
C#
public enum UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS : byte
C++
public enum class UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS : char
J#
public enum UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS byte
JScript
public enum UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_ASSOC_COUNT Class

UTIL_ASSOC_COUNT Class
See Also Example Members
[image]

Use this message to proxy a call to the AssocCount() function.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ASSOC_COUNT
Implements IREQUEST, IUTIL
C#
public class UTIL_ASSOC_COUNT : IREQUEST, IUTIL
C++
ref class UTIL_ASSOC_COUNT : IREQUEST, IUTIL
J#
public class UTIL_ASSOC_COUNT implements IREQUEST, IUTIL
JScript
public class UTIL_ASSOC_COUNT extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ASSOC_COUNT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ASSOC_COUNT Members
TI.ZPI2 Namespace


UTIL_ASSOC_COUNT Members

UTIL_ASSOC_COUNT Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to proxy a call to the AssocCount() function.

The following tables list the members exposed by UTIL_ASSOC_COUNT.

Public Constructors

Name | Description
UTIL_ASSOC_COUNT | Overloaded.
Top

Public Fields

 | Name | Description
Public field | EndRelation | Same as StartRelation, but the node relation at which to stop counting.
Public field | StartRelation | A valid node relation from AssocList.h: (PARENT = 0 CHILD_RFD = 1 CHILD_RFD_RX_IDLE = 2 CHILD_FFD = 3 CHILD_FFD_RX_IDLE = 4 NEIGHBOR = 5 OTHER = 6 The node relation at which to start counting.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ASSOC_COUNT | Overloaded.
Top

See Also

UTIL_ASSOC_COUNT Class
TI.ZPI2 Namespace


UTIL_ASSOC_COUNT Constructor

UTIL_ASSOC_COUNT Constructor

Overload List

 | Name | Description
Public method | UTIL_ASSOC_COUNT | Constructor
Public method | UTIL_ASSOC_COUNT (Byte, Byte) | Constructor

See Also

UTIL_ASSOC_COUNT Class
TI.ZPI2 Namespace


UTIL_ASSOC_COUNT Constructor ()

UTIL_ASSOC_COUNT Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ASSOC_COUNT()
C++
public:
UTIL_ASSOC_COUNT() sealed
J#
public UTIL_ASSOC_COUNT()
JScript
public function UTIL_ASSOC_COUNT()

See Also

UTIL_ASSOC_COUNT Class
TI.ZPI2 Namespace
UTIL_ASSOC_COUNT Constructor Overload List


UTIL_ASSOC_COUNT Constructor (Byte, Byte)

UTIL_ASSOC_COUNT Constructor (Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte _
)
C#
public UTIL_ASSOC_COUNT(
byte ,
byte
)
C++
public:
UTIL_ASSOC_COUNT(
char ,
char
) sealed
J#
public UTIL_ASSOC_COUNT(
byte ,
byte
)
JScript
public function UTIL_ASSOC_COUNT(
: Byte,
: Byte
)

See Also

UTIL_ASSOC_COUNT Class
TI.ZPI2 Namespace
UTIL_ASSOC_COUNT Constructor Overload List


Fields

UTIL_ASSOC_COUNT Fields
[image]

Public Fields

 | Name | Description
Public field | EndRelation | Same as StartRelation, but the node relation at which to stop counting.
Public field | StartRelation | A valid node relation from AssocList.h: (PARENT = 0 CHILD_RFD = 1 CHILD_RFD_RX_IDLE = 2 CHILD_FFD = 3 CHILD_FFD_RX_IDLE = 4 NEIGHBOR = 5 OTHER = 6 The node relation at which to start counting.
Top

See Also

UTIL_ASSOC_COUNT Class
TI.ZPI2 Namespace


EndRelation Field

UTIL_ASSOC_COUNT.EndRelation Field
[image]

Same as StartRelation, but the node relation at which to stop counting.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public EndRelation As Byte
C#
public byte EndRelation;
C++
public:
char EndRelation sealed ;
J#
public byte EndRelation
JScript
public EndRelation : Byte;

See Also

UTIL_ASSOC_COUNT Class
TI.ZPI2 Namespace


StartRelation Field

UTIL_ASSOC_COUNT.StartRelation Field
[image]

A valid node relation from AssocList.h: (PARENT = 0 CHILD_RFD = 1 CHILD_RFD_RX_IDLE = 2 CHILD_FFD = 3 CHILD_FFD_RX_IDLE = 4 NEIGHBOR = 5 OTHER = 6 The node relation at which to start counting.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartRelation As Byte
C#
public byte StartRelation;
C++
public:
char StartRelation sealed ;
J#
public byte StartRelation
JScript
public StartRelation : Byte;

See Also

UTIL_ASSOC_COUNT Class
TI.ZPI2 Namespace


UTIL_ASSOC_COUNT_RESPONSE Class

UTIL_ASSOC_COUNT_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from AssocCount().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ASSOC_COUNT_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_ASSOC_COUNT_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_ASSOC_COUNT_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_ASSOC_COUNT_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_ASSOC_COUNT_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ASSOC_COUNT_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ASSOC_COUNT_RESPONSE Members
TI.ZPI2 Namespace


UTIL_ASSOC_COUNT_RESPONSE Members

UTIL_ASSOC_COUNT_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from AssocCount().

The following tables list the members exposed by UTIL_ASSOC_COUNT_RESPONSE.

Public Constructors

Name | Description
UTIL_ASSOC_COUNT_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Count | The count returned by the proxy call to AssocCount().
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ASSOC_COUNT_RESPONSE | Overloaded.
Top

See Also

UTIL_ASSOC_COUNT_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_COUNT_RESPONSE Constructor

UTIL_ASSOC_COUNT_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_ASSOC_COUNT_RESPONSE | Constructor
Public method | UTIL_ASSOC_COUNT_RESPONSE (UInt16) | Constructor

See Also

UTIL_ASSOC_COUNT_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_COUNT_RESPONSE Constructor ()

UTIL_ASSOC_COUNT_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ASSOC_COUNT_RESPONSE()
C++
public:
UTIL_ASSOC_COUNT_RESPONSE() sealed
J#
public UTIL_ASSOC_COUNT_RESPONSE()
JScript
public function UTIL_ASSOC_COUNT_RESPONSE()

See Also

UTIL_ASSOC_COUNT_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ASSOC_COUNT_RESPONSE Constructor Overload List


UTIL_ASSOC_COUNT_RESPONSE Constructor (UInt16)

UTIL_ASSOC_COUNT_RESPONSE Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public UTIL_ASSOC_COUNT_RESPONSE(
ushort
)
C++
public:
UTIL_ASSOC_COUNT_RESPONSE(
unsigned short
) sealed
J#
public UTIL_ASSOC_COUNT_RESPONSE(
ushort
)
JScript
public function UTIL_ASSOC_COUNT_RESPONSE(
: UInt16
)

See Also

UTIL_ASSOC_COUNT_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ASSOC_COUNT_RESPONSE Constructor Overload List


Fields

UTIL_ASSOC_COUNT_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Count | The count returned by the proxy call to AssocCount().
Top

See Also

UTIL_ASSOC_COUNT_RESPONSE Class
TI.ZPI2 Namespace


Count Field

UTIL_ASSOC_COUNT_RESPONSE.Count Field
[image]

The count returned by the proxy call to AssocCount().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Count As UInt16
C#
public ushort Count;
C++
public:
unsigned short Count sealed ;
J#
public ushort Count
JScript
public Count : UInt16;

See Also

UTIL_ASSOC_COUNT_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE Class

UTIL_ASSOC_FIND_DEVICE Class
See Also Example Members
[image]

Use this message to proxy a call to the AssocFindDevice() function.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ASSOC_FIND_DEVICE
Implements IREQUEST, IUTIL
C#
public class UTIL_ASSOC_FIND_DEVICE : IREQUEST, IUTIL
C++
ref class UTIL_ASSOC_FIND_DEVICE : IREQUEST, IUTIL
J#
public class UTIL_ASSOC_FIND_DEVICE implements IREQUEST, IUTIL
JScript
public class UTIL_ASSOC_FIND_DEVICE extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ASSOC_FIND_DEVICE Members
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE Members

UTIL_ASSOC_FIND_DEVICE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to proxy a call to the AssocFindDevice() function.

The following tables list the members exposed by UTIL_ASSOC_FIND_DEVICE.

Public Constructors

Name | Description
UTIL_ASSOC_FIND_DEVICE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Number | Nth active entry in the device list.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ASSOC_FIND_DEVICE | Overloaded.
Top

See Also

UTIL_ASSOC_FIND_DEVICE Class
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE Constructor

UTIL_ASSOC_FIND_DEVICE Constructor

Overload List

 | Name | Description
Public method | UTIL_ASSOC_FIND_DEVICE | Constructor
Public method | UTIL_ASSOC_FIND_DEVICE (Byte) | Constructor

See Also

UTIL_ASSOC_FIND_DEVICE Class
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE Constructor ()

UTIL_ASSOC_FIND_DEVICE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ASSOC_FIND_DEVICE()
C++
public:
UTIL_ASSOC_FIND_DEVICE() sealed
J#
public UTIL_ASSOC_FIND_DEVICE()
JScript
public function UTIL_ASSOC_FIND_DEVICE()

See Also

UTIL_ASSOC_FIND_DEVICE Class
TI.ZPI2 Namespace
UTIL_ASSOC_FIND_DEVICE Constructor Overload List


UTIL_ASSOC_FIND_DEVICE Constructor (Byte)

UTIL_ASSOC_FIND_DEVICE Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public UTIL_ASSOC_FIND_DEVICE(
byte
)
C++
public:
UTIL_ASSOC_FIND_DEVICE(
char
) sealed
J#
public UTIL_ASSOC_FIND_DEVICE(
byte
)
JScript
public function UTIL_ASSOC_FIND_DEVICE(
: Byte
)

See Also

UTIL_ASSOC_FIND_DEVICE Class
TI.ZPI2 Namespace
UTIL_ASSOC_FIND_DEVICE Constructor Overload List


Fields

UTIL_ASSOC_FIND_DEVICE Fields
[image]

Public Fields

 | Name | Description
Public field | Number | Nth active entry in the device list.
Top

See Also

UTIL_ASSOC_FIND_DEVICE Class
TI.ZPI2 Namespace


Number Field

UTIL_ASSOC_FIND_DEVICE.Number Field
[image]

Nth active entry in the device list.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Number As Byte
C#
public byte Number;
C++
public:
char Number sealed ;
J#
public byte Number
JScript
public Number : Byte;

See Also

UTIL_ASSOC_FIND_DEVICE Class
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE_RESPONSE Class

UTIL_ASSOC_FIND_DEVICE_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from AssocFindDevice().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ASSOC_FIND_DEVICE_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_ASSOC_FIND_DEVICE_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_ASSOC_FIND_DEVICE_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_ASSOC_FIND_DEVICE_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_ASSOC_FIND_DEVICE_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ASSOC_FIND_DEVICE_RESPONSE Members
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE_RESPONSE Members

UTIL_ASSOC_FIND_DEVICE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from AssocFindDevice().

The following tables list the members exposed by UTIL_ASSOC_FIND_DEVICE_RESPONSE.

Public Constructors

Name | Description
UTIL_ASSOC_FIND_DEVICE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Device | The packed (LSB-MSB) associated_devices_t structure returned by the proxy call to AssocFindDevice(). The device short address is set to INVALID_NODE_ADDR to indicate failure.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ASSOC_FIND_DEVICE_RESPONSE | Overloaded.
Top

See Also

UTIL_ASSOC_FIND_DEVICE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor

UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_ASSOC_FIND_DEVICE_RESPONSE | Constructor
Public method | UTIL_ASSOC_FIND_DEVICE_RESPONSE (Byte) | Constructor

See Also

UTIL_ASSOC_FIND_DEVICE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor ()

UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ASSOC_FIND_DEVICE_RESPONSE()
C++
public:
UTIL_ASSOC_FIND_DEVICE_RESPONSE() sealed
J#
public UTIL_ASSOC_FIND_DEVICE_RESPONSE()
JScript
public function UTIL_ASSOC_FIND_DEVICE_RESPONSE()

See Also

UTIL_ASSOC_FIND_DEVICE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor Overload List


UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor (Byte[])

UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public UTIL_ASSOC_FIND_DEVICE_RESPONSE(
byte[]
)
C++
public:
UTIL_ASSOC_FIND_DEVICE_RESPONSE(
array<char>^
) sealed
J#
public UTIL_ASSOC_FIND_DEVICE_RESPONSE(
byte[]
)
JScript
public function UTIL_ASSOC_FIND_DEVICE_RESPONSE(
: Byte[]
)

See Also

UTIL_ASSOC_FIND_DEVICE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ASSOC_FIND_DEVICE_RESPONSE Constructor Overload List


Fields

UTIL_ASSOC_FIND_DEVICE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Device | The packed (LSB-MSB) associated_devices_t structure returned by the proxy call to AssocFindDevice(). The device short address is set to INVALID_NODE_ADDR to indicate failure.
Top

See Also

UTIL_ASSOC_FIND_DEVICE_RESPONSE Class
TI.ZPI2 Namespace


Device Field

UTIL_ASSOC_FIND_DEVICE_RESPONSE.Device Field
[image]

The packed (LSB-MSB) associated_devices_t structure returned by the proxy call to AssocFindDevice(). The device short address is set to INVALID_NODE_ADDR to indicate failure.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Device As Byte()
C#
public byte[] Device;
C++
public:
array<char>^ Device sealed ;
J#
public byte[] Device
JScript
public Device : Byte[];

See Also

UTIL_ASSOC_FIND_DEVICE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS Class

UTIL_ASSOC_GET_WITH_ADDRESS Class
See Also Example Members
[image]

Use this message to proxy a call to the AssocGetWithAddress() function.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ASSOC_GET_WITH_ADDRESS
Implements IREQUEST, IUTIL
C#
public class UTIL_ASSOC_GET_WITH_ADDRESS : IREQUEST, IUTIL
C++
ref class UTIL_ASSOC_GET_WITH_ADDRESS : IREQUEST, IUTIL
J#
public class UTIL_ASSOC_GET_WITH_ADDRESS implements IREQUEST, IUTIL
JScript
public class UTIL_ASSOC_GET_WITH_ADDRESS extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Members
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS Members

UTIL_ASSOC_GET_WITH_ADDRESS Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to proxy a call to the AssocGetWithAddress() function.

The following tables list the members exposed by UTIL_ASSOC_GET_WITH_ADDRESS.

Public Constructors

Name | Description
UTIL_ASSOC_GET_WITH_ADDRESS | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ExtAddr | The extended address to use for the lookup or all zeroes to use the NwkAddr for the lookup.
Public field | NwkAddr | Network Address (LSB-MSB) to use for the lookup if the ExtAddr is all zeroes.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ASSOC_GET_WITH_ADDRESS | Overloaded.
Top

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Class
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS Constructor

UTIL_ASSOC_GET_WITH_ADDRESS Constructor

Overload List

 | Name | Description
Public method | UTIL_ASSOC_GET_WITH_ADDRESS | Constructor
Public method | UTIL_ASSOC_GET_WITH_ADDRESS (UInt64, UInt16) | Constructor

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Class
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS Constructor ()

UTIL_ASSOC_GET_WITH_ADDRESS Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ASSOC_GET_WITH_ADDRESS()
C++
public:
UTIL_ASSOC_GET_WITH_ADDRESS() sealed
J#
public UTIL_ASSOC_GET_WITH_ADDRESS()
JScript
public function UTIL_ASSOC_GET_WITH_ADDRESS()

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Class
TI.ZPI2 Namespace
UTIL_ASSOC_GET_WITH_ADDRESS Constructor Overload List


UTIL_ASSOC_GET_WITH_ADDRESS Constructor (UInt64, UInt16)

UTIL_ASSOC_GET_WITH_ADDRESS Constructor (UInt64, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt16 _
)
C#
public UTIL_ASSOC_GET_WITH_ADDRESS(
ulong ,
ushort
)
C++
public:
UTIL_ASSOC_GET_WITH_ADDRESS(
unsigned __int64 ,
unsigned short
) sealed
J#
public UTIL_ASSOC_GET_WITH_ADDRESS(
ulong ,
ushort
)
JScript
public function UTIL_ASSOC_GET_WITH_ADDRESS(
: UInt64,
: UInt16
)

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Class
TI.ZPI2 Namespace
UTIL_ASSOC_GET_WITH_ADDRESS Constructor Overload List


Fields

UTIL_ASSOC_GET_WITH_ADDRESS Fields
[image]

Public Fields

 | Name | Description
Public field | ExtAddr | The extended address to use for the lookup or all zeroes to use the NwkAddr for the lookup.
Public field | NwkAddr | Network Address (LSB-MSB) to use for the lookup if the ExtAddr is all zeroes.
Top

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Class
TI.ZPI2 Namespace


ExtAddr Field

UTIL_ASSOC_GET_WITH_ADDRESS.ExtAddr Field
[image]

The extended address to use for the lookup or all zeroes to use the NwkAddr for the lookup.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As UInt64
C#
public ulong ExtAddr;
C++
public:
unsigned __int64 ExtAddr sealed ;
J#
public ulong ExtAddr
JScript
public ExtAddr : UInt64;

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Class
TI.ZPI2 Namespace


NwkAddr Field

UTIL_ASSOC_GET_WITH_ADDRESS.NwkAddr Field
[image]

Network Address (LSB-MSB) to use for the lookup if the ExtAddr is all zeroes.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

UTIL_ASSOC_GET_WITH_ADDRESS Class
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from AssocGetWithAddress().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Members
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Members

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from AssocGetWithAddress().

The following tables list the members exposed by UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE.

Public Constructors

Name | Description
UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Device | The packed (LSB-MSB) associated_devices_t structure returned by the proxy call to AssocGetWithAddress(). The device short address is set to INVALID_NODE_ADDR to indicate failure.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE | Overloaded.
Top

See Also

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE | Constructor
Public method | UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE (Byte) | Constructor

See Also

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor ()

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE()
C++
public:
UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE() sealed
J#
public UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE()
JScript
public function UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE()

See Also

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor Overload List


UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor (Byte[])

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE(
byte[]
)
C++
public:
UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE(
array<char>^
) sealed
J#
public UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE(
byte[]
)
JScript
public function UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE(
: Byte[]
)

See Also

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Constructor Overload List


Fields

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Device | The packed (LSB-MSB) associated_devices_t structure returned by the proxy call to AssocGetWithAddress(). The device short address is set to INVALID_NODE_ADDR to indicate failure.
Top

See Also

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class
TI.ZPI2 Namespace


Device Field

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE.Device Field
[image]

The packed (LSB-MSB) associated_devices_t structure returned by the proxy call to AssocGetWithAddress(). The device short address is set to INVALID_NODE_ADDR to indicate failure.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Device As Byte()
C#
public byte[] Device;
C++
public:
array<char>^ Device sealed ;
J#
public byte[] Device
JScript
public Device : Byte[];

See Also

UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE Class
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE Class

UTIL_CALLBACK_SUBSCRIBE Class
See Also Example Members
[image]

This command subscribes/unsubscribes to layer callbacks.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_CALLBACK_SUBSCRIBE
Implements IREQUEST, IUTIL
C#
public class UTIL_CALLBACK_SUBSCRIBE : IREQUEST, IUTIL
C++
ref class UTIL_CALLBACK_SUBSCRIBE : IREQUEST, IUTIL
J#
public class UTIL_CALLBACK_SUBSCRIBE implements IREQUEST, IUTIL
JScript
public class UTIL_CALLBACK_SUBSCRIBE extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_CALLBACK_SUBSCRIBE Members
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE Members

UTIL_CALLBACK_SUBSCRIBE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command subscribes/unsubscribes to layer callbacks.

The following tables list the members exposed by UTIL_CALLBACK_SUBSCRIBE.

Public Constructors

Name | Description
UTIL_CALLBACK_SUBSCRIBE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Action | contains the action of the command
Public field | CommandID | contains the Command ID field of the expected callback message
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_CALLBACK_SUBSCRIBE | Overloaded.
Top

See Also

UTIL_CALLBACK_SUBSCRIBE Class
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE Constructor

UTIL_CALLBACK_SUBSCRIBE Constructor

Overload List

 | Name | Description
Public method | UTIL_CALLBACK_SUBSCRIBE | Constructor
Public method | UTIL_CALLBACK_SUBSCRIBE (UInt16, UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION) |

See Also

UTIL_CALLBACK_SUBSCRIBE Class
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE Constructor ()

UTIL_CALLBACK_SUBSCRIBE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_CALLBACK_SUBSCRIBE()
C++
public:
UTIL_CALLBACK_SUBSCRIBE() sealed
J#
public UTIL_CALLBACK_SUBSCRIBE()
JScript
public function UTIL_CALLBACK_SUBSCRIBE()

See Also

UTIL_CALLBACK_SUBSCRIBE Class
TI.ZPI2 Namespace
UTIL_CALLBACK_SUBSCRIBE Constructor Overload List


UTIL_CALLBACK_SUBSCRIBE Constructor (UInt16, UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION)

UTIL_CALLBACK_SUBSCRIBE Constructor (UInt16, UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION _
)
C#
public UTIL_CALLBACK_SUBSCRIBE(
ushort ,
UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION
)
C++
public:
UTIL_CALLBACK_SUBSCRIBE(
unsigned short ,
UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION
) sealed
J#
public UTIL_CALLBACK_SUBSCRIBE(
ushort ,
UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION
)
JScript
public function UTIL_CALLBACK_SUBSCRIBE(
: UInt16,
: UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION
)

See Also

UTIL_CALLBACK_SUBSCRIBE Class
TI.ZPI2 Namespace
UTIL_CALLBACK_SUBSCRIBE Constructor Overload List


Fields

UTIL_CALLBACK_SUBSCRIBE Fields
[image]

Public Fields

 | Name | Description
Public field | Action | contains the action of the command
Public field | CommandID | contains the Command ID field of the expected callback message
Top

See Also

UTIL_CALLBACK_SUBSCRIBE Class
TI.ZPI2 Namespace


Action Field

UTIL_CALLBACK_SUBSCRIBE.Action Field
[image]

contains the action of the command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Action As UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION
C#
public UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION Action;
C++
public:
UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION Action sealed ;
J#
public UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION Action
JScript
public Action : UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION;

See Also

UTIL_CALLBACK_SUBSCRIBE Class
TI.ZPI2 Namespace


CommandID Field

UTIL_CALLBACK_SUBSCRIBE.CommandID Field
[image]

contains the Command ID field of the expected callback message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandID As UInt16
C#
public ushort CommandID;
C++
public:
unsigned short CommandID sealed ;
J#
public ushort CommandID
JScript
public CommandID : UInt16;

See Also

UTIL_CALLBACK_SUBSCRIBE Class
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION Enumeration

UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION Enumeration
[image]

Subscribe Action

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION As Byte
C#
public enum UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION : byte
C++
public enum class UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION : char
J#
public enum UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION byte
JScript
public enum UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION :

Members

Member Name | Description
0x00 (UNSUBSCRIBE) | Subscribe Action
0x01 (SUBSCRIBE) | Subscribe Action

See Also

TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_CALLBACK_SUBSCRIBE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_CALLBACK_SUBSCRIBE_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_CALLBACK_SUBSCRIBE_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_CALLBACK_SUBSCRIBE_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_CALLBACK_SUBSCRIBE_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_CALLBACK_SUBSCRIBE_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Members
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE_RESPONSE Members

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_CALLBACK_SUBSCRIBE

The following tables list the members exposed by UTIL_CALLBACK_SUBSCRIBE_RESPONSE.

Public Constructors

Name | Description
UTIL_CALLBACK_SUBSCRIBE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_CALLBACK_SUBSCRIBE_RESPONSE | Overloaded.
Top

See Also

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_CALLBACK_SUBSCRIBE_RESPONSE | Constructor
Public method | UTIL_CALLBACK_SUBSCRIBE_RESPONSE (UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS) |

See Also

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor ()

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_CALLBACK_SUBSCRIBE_RESPONSE()
C++
public:
UTIL_CALLBACK_SUBSCRIBE_RESPONSE() sealed
J#
public UTIL_CALLBACK_SUBSCRIBE_RESPONSE()
JScript
public function UTIL_CALLBACK_SUBSCRIBE_RESPONSE()

See Also

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor Overload List


UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor (UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS)

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor (UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS _
)
C#
public UTIL_CALLBACK_SUBSCRIBE_RESPONSE(
UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_CALLBACK_SUBSCRIBE_RESPONSE(
UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_CALLBACK_SUBSCRIBE_RESPONSE(
UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_CALLBACK_SUBSCRIBE_RESPONSE(
: UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
)

See Also

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_CALLBACK_SUBSCRIBE_RESPONSE Constructor Overload List


Fields

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | indicates SUCCESS or FAILURE
Top

See Also

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_CALLBACK_SUBSCRIBE_RESPONSE.Status Field
[image]

indicates SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
C#
public UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS;

See Also

UTIL_CALLBACK_SUBSCRIBE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Enumeration

UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_DATA_REQ Class

UTIL_DATA_REQ Class
See Also Example Members
[image]

Use this message to effect a MAC MLME Poll Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_DATA_REQ
Implements IREQUEST, IUTIL
C#
public class UTIL_DATA_REQ : IREQUEST, IUTIL
C++
ref class UTIL_DATA_REQ : IREQUEST, IUTIL
J#
public class UTIL_DATA_REQ implements IREQUEST, IUTIL
JScript
public class UTIL_DATA_REQ extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_DATA_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_DATA_REQ Members
TI.ZPI2 Namespace


UTIL_DATA_REQ Members

UTIL_DATA_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to effect a MAC MLME Poll Request.

The following tables list the members exposed by UTIL_DATA_REQ.

Public Constructors

Name | Description
UTIL_DATA_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SecurityUse | TRUE to request MAC security, but not used for now.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_DATA_REQ | Overloaded.
Top

See Also

UTIL_DATA_REQ Class
TI.ZPI2 Namespace


UTIL_DATA_REQ Constructor

UTIL_DATA_REQ Constructor

Overload List

 | Name | Description
Public method | UTIL_DATA_REQ | Constructor
Public method | UTIL_DATA_REQ (UTIL_DATA_REQ.BOOLEAN) |

See Also

UTIL_DATA_REQ Class
TI.ZPI2 Namespace


UTIL_DATA_REQ Constructor ()

UTIL_DATA_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_DATA_REQ()
C++
public:
UTIL_DATA_REQ() sealed
J#
public UTIL_DATA_REQ()
JScript
public function UTIL_DATA_REQ()

See Also

UTIL_DATA_REQ Class
TI.ZPI2 Namespace
UTIL_DATA_REQ Constructor Overload List


UTIL_DATA_REQ Constructor (UTIL_DATA_REQ.BOOLEAN)

UTIL_DATA_REQ Constructor (UTIL_DATA_REQ.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_DATA_REQ.BOOLEAN _
)
C#
public UTIL_DATA_REQ(
UTIL_DATA_REQ.BOOLEAN
)
C++
public:
UTIL_DATA_REQ(
UTIL_DATA_REQ.BOOLEAN
) sealed
J#
public UTIL_DATA_REQ(
UTIL_DATA_REQ.BOOLEAN
)
JScript
public function UTIL_DATA_REQ(
: UTIL_DATA_REQ.BOOLEAN
)

See Also

UTIL_DATA_REQ Class
TI.ZPI2 Namespace
UTIL_DATA_REQ Constructor Overload List


Fields

UTIL_DATA_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | SecurityUse | TRUE to request MAC security, but not used for now.
Top

See Also

UTIL_DATA_REQ Class
TI.ZPI2 Namespace


SecurityUse Field

UTIL_DATA_REQ.SecurityUse Field
[image]

TRUE to request MAC security, but not used for now.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityUse As UTIL_DATA_REQ.BOOLEAN
C#
public UTIL_DATA_REQ.BOOLEAN SecurityUse;
C++
public:
UTIL_DATA_REQ.BOOLEAN SecurityUse sealed ;
J#
public UTIL_DATA_REQ.BOOLEAN SecurityUse
JScript
public SecurityUse : UTIL_DATA_REQ.BOOLEAN;

See Also

UTIL_DATA_REQ Class
TI.ZPI2 Namespace


UTIL_DATA_REQ.BOOLEAN Enumeration

UTIL_DATA_REQ.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_DATA_REQ.BOOLEAN As Byte
C#
public enum UTIL_DATA_REQ.BOOLEAN : byte
C++
public enum class UTIL_DATA_REQ.BOOLEAN : char
J#
public enum UTIL_DATA_REQ.BOOLEAN byte
JScript
public enum UTIL_DATA_REQ.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


UTIL_DATA_REQ_RESPONSE Class

UTIL_DATA_REQ_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_DATA_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_DATA_REQ_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_DATA_REQ_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_DATA_REQ_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_DATA_REQ_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_DATA_REQ_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_DATA_REQ_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_DATA_REQ_RESPONSE Members
TI.ZPI2 Namespace


UTIL_DATA_REQ_RESPONSE Members

UTIL_DATA_REQ_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_DATA_REQ

The following tables list the members exposed by UTIL_DATA_REQ_RESPONSE.

Public Constructors

Name | Description
UTIL_DATA_REQ_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status: A MAC status value from ZComDef.h, but only ZMacSuccess for now.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_DATA_REQ_RESPONSE | Overloaded.
Top

See Also

UTIL_DATA_REQ_RESPONSE Class
TI.ZPI2 Namespace


UTIL_DATA_REQ_RESPONSE Constructor

UTIL_DATA_REQ_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_DATA_REQ_RESPONSE | Constructor
Public method | UTIL_DATA_REQ_RESPONSE (UTIL_DATA_REQ_RESPONSE.CMD_STATUS) |

See Also

UTIL_DATA_REQ_RESPONSE Class
TI.ZPI2 Namespace


UTIL_DATA_REQ_RESPONSE Constructor ()

UTIL_DATA_REQ_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_DATA_REQ_RESPONSE()
C++
public:
UTIL_DATA_REQ_RESPONSE() sealed
J#
public UTIL_DATA_REQ_RESPONSE()
JScript
public function UTIL_DATA_REQ_RESPONSE()

See Also

UTIL_DATA_REQ_RESPONSE Class
TI.ZPI2 Namespace
UTIL_DATA_REQ_RESPONSE Constructor Overload List


UTIL_DATA_REQ_RESPONSE Constructor (UTIL_DATA_REQ_RESPONSE.CMD_STATUS)

UTIL_DATA_REQ_RESPONSE Constructor (UTIL_DATA_REQ_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_DATA_REQ_RESPONSE.CMD_STATUS _
)
C#
public UTIL_DATA_REQ_RESPONSE(
UTIL_DATA_REQ_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_DATA_REQ_RESPONSE(
UTIL_DATA_REQ_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_DATA_REQ_RESPONSE(
UTIL_DATA_REQ_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_DATA_REQ_RESPONSE(
: UTIL_DATA_REQ_RESPONSE.CMD_STATUS
)

See Also

UTIL_DATA_REQ_RESPONSE Class
TI.ZPI2 Namespace
UTIL_DATA_REQ_RESPONSE Constructor Overload List


Fields

UTIL_DATA_REQ_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status: A MAC status value from ZComDef.h, but only ZMacSuccess for now.
Top

See Also

UTIL_DATA_REQ_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_DATA_REQ_RESPONSE.Status Field
[image]

Status: A MAC status value from ZComDef.h, but only ZMacSuccess for now.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_DATA_REQ_RESPONSE.CMD_STATUS
C#
public UTIL_DATA_REQ_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_DATA_REQ_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_DATA_REQ_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_DATA_REQ_RESPONSE.CMD_STATUS;

See Also

UTIL_DATA_REQ_RESPONSE Class
TI.ZPI2 Namespace


UTIL_DATA_REQ_RESPONSE.CMD_STATUS Enumeration

UTIL_DATA_REQ_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_DATA_REQ_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_DATA_REQ_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_DATA_REQ_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_DATA_REQ_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_DATA_REQ_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO Class

UTIL_GET_DEVICE_INFO Class
See Also Example Members
[image]

This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_GET_DEVICE_INFO
Implements IREQUEST, IUTIL
C#
public class UTIL_GET_DEVICE_INFO : IREQUEST, IUTIL
C++
ref class UTIL_GET_DEVICE_INFO : IREQUEST, IUTIL
J#
public class UTIL_GET_DEVICE_INFO implements IREQUEST, IUTIL
JScript
public class UTIL_GET_DEVICE_INFO extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_GET_DEVICE_INFO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_GET_DEVICE_INFO Members
TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO Members

UTIL_GET_DEVICE_INFO Members
See Also Example Constructors Methods
[image]

This command is used by the tester to read a single memory location in the target non-volatile memory. The command accepts an address value and returns the memory value present in the target at that address.

The following tables list the members exposed by UTIL_GET_DEVICE_INFO.

Public Constructors

 | Name | Description
Public method | UTIL_GET_DEVICE_INFO | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UTIL_GET_DEVICE_INFO Class
TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO Constructor

UTIL_GET_DEVICE_INFO Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_GET_DEVICE_INFO()
C++
public:
UTIL_GET_DEVICE_INFO() sealed
J#
public UTIL_GET_DEVICE_INFO()
JScript
public function UTIL_GET_DEVICE_INFO()

See Also

UTIL_GET_DEVICE_INFO Class
TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO_RESPONSE Class

UTIL_GET_DEVICE_INFO_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_GET_DEVICE_INFO

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_GET_DEVICE_INFO_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_GET_DEVICE_INFO_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_GET_DEVICE_INFO_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_GET_DEVICE_INFO_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_GET_DEVICE_INFO_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_GET_DEVICE_INFO_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Members
TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO_RESPONSE Members

UTIL_GET_DEVICE_INFO_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_GET_DEVICE_INFO

The following tables list the members exposed by UTIL_GET_DEVICE_INFO_RESPONSE.

Public Constructors

Name | Description
UTIL_GET_DEVICE_INFO_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocDevicesList | Dynamic array, Assoc Devices List
Public field | DeviceState | Device Type
Public field | DeviceType | Bitmap byte field indicating device type, where bits 0 to 2 indicate the capability for the device to operate as a coordinator, router, or end device, respectively
Public field | IEEEAddr | IEEE Address
Public field | NumAssocDevices | Number Assoc Devices
Public field | ShortAddress | Short Address
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_GET_DEVICE_INFO_RESPONSE | Overloaded.
Top

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO_RESPONSE Constructor

UTIL_GET_DEVICE_INFO_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_GET_DEVICE_INFO_RESPONSE | Constructor
Public method | UTIL_GET_DEVICE_INFO_RESPONSE (UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, UInt64, UInt16, UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, Byte, UInt16) |

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO_RESPONSE Constructor ()

UTIL_GET_DEVICE_INFO_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_GET_DEVICE_INFO_RESPONSE()
C++
public:
UTIL_GET_DEVICE_INFO_RESPONSE() sealed
J#
public UTIL_GET_DEVICE_INFO_RESPONSE()
JScript
public function UTIL_GET_DEVICE_INFO_RESPONSE()

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace
UTIL_GET_DEVICE_INFO_RESPONSE Constructor Overload List


UTIL_GET_DEVICE_INFO_RESPONSE Constructor (UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, UInt64, UInt16, UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, Byte, UInt16[])

UTIL_GET_DEVICE_INFO_RESPONSE Constructor (UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, UInt64, UInt16, UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE, _
ByVal As UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE, _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public UTIL_GET_DEVICE_INFO_RESPONSE(
UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS ,
ulong ,
ushort ,
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE ,
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE ,
byte ,
ushort[]
)
C++
public:
UTIL_GET_DEVICE_INFO_RESPONSE(
UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS ,
unsigned __int64 ,
unsigned short ,
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE ,
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE ,
char ,
array<unsigned short>^
) sealed
J#
public UTIL_GET_DEVICE_INFO_RESPONSE(
UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS ,
ulong ,
ushort ,
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE ,
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE ,
byte ,
ushort[]
)
JScript
public function UTIL_GET_DEVICE_INFO_RESPONSE(
: UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS,
: UInt64,
: UInt16,
: UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE,
: UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE,
: Byte,
: UInt16[]
)

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace
UTIL_GET_DEVICE_INFO_RESPONSE Constructor Overload List


Fields

UTIL_GET_DEVICE_INFO_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | AssocDevicesList | Dynamic array, Assoc Devices List
Public field | DeviceState | Device Type
Public field | DeviceType | Bitmap byte field indicating device type, where bits 0 to 2 indicate the capability for the device to operate as a coordinator, router, or end device, respectively
Public field | IEEEAddr | IEEE Address
Public field | NumAssocDevices | Number Assoc Devices
Public field | ShortAddress | Short Address
Public field | Status | The fail status is returned if the address value in the command message was not within the valid range.
Top

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


AssocDevicesList Field

UTIL_GET_DEVICE_INFO_RESPONSE.AssocDevicesList Field
[image]

Dynamic array, Assoc Devices List

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocDevicesList As UInt16()
C#
public ushort[] AssocDevicesList;
C++
public:
array<unsigned short>^ AssocDevicesList sealed ;
J#
public ushort[] AssocDevicesList
JScript
public AssocDevicesList : UInt16[];

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


DeviceState Field

UTIL_GET_DEVICE_INFO_RESPONSE.DeviceState Field
[image]

Device Type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceState As UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE
C#
public UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE DeviceState;
C++
public:
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE DeviceState sealed ;
J#
public UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE DeviceState
JScript
public DeviceState : UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE;

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


DeviceType Field

UTIL_GET_DEVICE_INFO_RESPONSE.DeviceType Field
[image]

Bitmap byte field indicating device type, where bits 0 to 2 indicate the capability for the device to operate as a coordinator, router, or end device, respectively

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceType As UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE
C#
public UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE DeviceType;
C++
public:
UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE DeviceType sealed ;
J#
public UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE DeviceType
JScript
public DeviceType : UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE;

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


IEEEAddr Field

UTIL_GET_DEVICE_INFO_RESPONSE.IEEEAddr Field
[image]

IEEE Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


NumAssocDevices Field

UTIL_GET_DEVICE_INFO_RESPONSE.NumAssocDevices Field
[image]

Number Assoc Devices

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumAssocDevices As Byte
C#
public byte NumAssocDevices;
C++
public:
char NumAssocDevices sealed ;
J#
public byte NumAssocDevices
JScript
public NumAssocDevices : Byte;

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


ShortAddress Field

UTIL_GET_DEVICE_INFO_RESPONSE.ShortAddress Field
[image]

Short Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ShortAddress As UInt16
C#
public ushort ShortAddress;
C++
public:
unsigned short ShortAddress sealed ;
J#
public ushort ShortAddress
JScript
public ShortAddress : UInt16;

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_GET_DEVICE_INFO_RESPONSE.Status Field
[image]

The fail status is returned if the address value in the command message was not within the valid range.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS
C#
public UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS;

See Also

UTIL_GET_DEVICE_INFO_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Enumeration

UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE Enumeration

UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE Enumeration
[image]

Device state

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE As Byte
C#
public enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE : byte
C++
public enum class UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE : char
J#
public enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE byte
JScript
public enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE :

Members

Member Name | Description
DEV_HOLD | Device state
DEV_INIT | Device state
DEV_NWK_DISC | Device state
DEV_NWK_JOINING | Device state
DEV_NWK_REJOIN | Device state
DEV_END_DEVICE_UNAUTH | Device state
DEV_END_DEVICE | Device state
DEV_ROUTER | Device state
DEV_COORD_STARTING | Device state
DEV_ZB_COORD | Device state
DEV_NWK_ORPHAN | Device state

See Also

TI.ZPI2 Namespace


UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE Enumeration

UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE Enumeration
[image]

Device type bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE As Byte
C#
[FlagsAttribute]
public enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE : byte
C++
[FlagsAttribute]
public enum class UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE : char
J#
/** @attribute FlagsAttribute() */
public enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE byte
JScript
public enum UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE :

Members

Member Name | Description | Value
NONE | Device type bitfield | 0
COORDINATOR | Device type bitfield | 1
ROUTER | Device type bitfield | 2
END_DEVICE | Device type bitfield | 4

See Also

TI.ZPI2 Namespace


UTIL_GET_NV_INFO Class

UTIL_GET_NV_INFO Class
See Also Example Members
[image]

Use this message to get the NV information.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_GET_NV_INFO
Implements IREQUEST, IUTIL
C#
public class UTIL_GET_NV_INFO : IREQUEST, IUTIL
C++
ref class UTIL_GET_NV_INFO : IREQUEST, IUTIL
J#
public class UTIL_GET_NV_INFO implements IREQUEST, IUTIL
JScript
public class UTIL_GET_NV_INFO extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_GET_NV_INFO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_GET_NV_INFO Members
TI.ZPI2 Namespace


UTIL_GET_NV_INFO Members

UTIL_GET_NV_INFO Members
See Also Example Constructors Methods
[image]

Use this message to get the NV information.

The following tables list the members exposed by UTIL_GET_NV_INFO.

Public Constructors

 | Name | Description
Public method | UTIL_GET_NV_INFO | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UTIL_GET_NV_INFO Class
TI.ZPI2 Namespace


UTIL_GET_NV_INFO Constructor

UTIL_GET_NV_INFO Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_GET_NV_INFO()
C++
public:
UTIL_GET_NV_INFO() sealed
J#
public UTIL_GET_NV_INFO()
JScript
public function UTIL_GET_NV_INFO()

See Also

UTIL_GET_NV_INFO Class
TI.ZPI2 Namespace


UTIL_GET_NV_INFO_RESPONSE Class

UTIL_GET_NV_INFO_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_GET_NV_INFO

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_GET_NV_INFO_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_GET_NV_INFO_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_GET_NV_INFO_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_GET_NV_INFO_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_GET_NV_INFO_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_GET_NV_INFO_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_GET_NV_INFO_RESPONSE Members
TI.ZPI2 Namespace


UTIL_GET_NV_INFO_RESPONSE Members

UTIL_GET_NV_INFO_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_GET_NV_INFO

The following tables list the members exposed by UTIL_GET_NV_INFO_RESPONSE.

Public Constructors

Name | Description
UTIL_GET_NV_INFO_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEAddress | IEEE Address
Public field | PanID | Pan ID
Public field | PreConfigKey | PreConfigKey
Public field | ScanChannels | Scan Channels
Public field | SecurityLevel | Security Level
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_GET_NV_INFO_RESPONSE | Overloaded.
Top

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_NV_INFO_RESPONSE Constructor

UTIL_GET_NV_INFO_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_GET_NV_INFO_RESPONSE | Constructor
Public method | UTIL_GET_NV_INFO_RESPONSE (UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS, UInt64, UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, UInt16, Byte, Byte) |

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_NV_INFO_RESPONSE Constructor ()

UTIL_GET_NV_INFO_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_GET_NV_INFO_RESPONSE()
C++
public:
UTIL_GET_NV_INFO_RESPONSE() sealed
J#
public UTIL_GET_NV_INFO_RESPONSE()
JScript
public function UTIL_GET_NV_INFO_RESPONSE()

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace
UTIL_GET_NV_INFO_RESPONSE Constructor Overload List


UTIL_GET_NV_INFO_RESPONSE Constructor (UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS, UInt64, UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, UInt16, Byte, Byte[])

UTIL_GET_NV_INFO_RESPONSE Constructor (UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS, UInt64, UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS, _
ByVal As UInt64, _
ByVal As UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public UTIL_GET_NV_INFO_RESPONSE(
UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS ,
ulong ,
UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ,
ushort ,
byte ,
byte[]
)
C++
public:
UTIL_GET_NV_INFO_RESPONSE(
UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS ,
unsigned __int64 ,
UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public UTIL_GET_NV_INFO_RESPONSE(
UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS ,
ulong ,
UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ,
ushort ,
byte ,
byte[]
)
JScript
public function UTIL_GET_NV_INFO_RESPONSE(
: UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS,
: UInt64,
: UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS,
: UInt16,
: Byte,
: Byte[]
)

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace
UTIL_GET_NV_INFO_RESPONSE Constructor Overload List


Fields

UTIL_GET_NV_INFO_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEAddress | IEEE Address
Public field | PanID | Pan ID
Public field | PreConfigKey | PreConfigKey
Public field | ScanChannels | Scan Channels
Public field | SecurityLevel | Security Level
Public field | Status | Status
Top

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


IEEEAddress Field

UTIL_GET_NV_INFO_RESPONSE.IEEEAddress Field
[image]

IEEE Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddress As UInt64
C#
public ulong IEEEAddress;
C++
public:
unsigned __int64 IEEEAddress sealed ;
J#
public ulong IEEEAddress
JScript
public IEEEAddress : UInt64;

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


PanID Field

UTIL_GET_NV_INFO_RESPONSE.PanID Field
[image]

Pan ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


PreConfigKey Field

UTIL_GET_NV_INFO_RESPONSE.PreConfigKey Field
[image]

PreConfigKey

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PreConfigKey As Byte()
C#
public byte[] PreConfigKey;
C++
public:
array<char>^ PreConfigKey sealed ;
J#
public byte[] PreConfigKey
JScript
public PreConfigKey : Byte[];

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


ScanChannels Field

UTIL_GET_NV_INFO_RESPONSE.ScanChannels Field
[image]

Scan Channels

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS
C#
public UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ScanChannels;
C++
public:
UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS;

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


SecurityLevel Field

UTIL_GET_NV_INFO_RESPONSE.SecurityLevel Field
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As Byte
C#
public byte SecurityLevel;
C++
public:
char SecurityLevel sealed ;
J#
public byte SecurityLevel
JScript
public SecurityLevel : Byte;

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_GET_NV_INFO_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS
C#
public UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS;

See Also

UTIL_GET_NV_INFO_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS Enumeration

UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS Enumeration

UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS uint
JScript
public enum UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


UTIL_GET_TIME_ALIVE Class

UTIL_GET_TIME_ALIVE Class
See Also Example Members
[image]

Use this message to get board's time alive.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_GET_TIME_ALIVE
Implements IREQUEST, IUTIL
C#
public class UTIL_GET_TIME_ALIVE : IREQUEST, IUTIL
C++
ref class UTIL_GET_TIME_ALIVE : IREQUEST, IUTIL
J#
public class UTIL_GET_TIME_ALIVE implements IREQUEST, IUTIL
JScript
public class UTIL_GET_TIME_ALIVE extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_GET_TIME_ALIVE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_GET_TIME_ALIVE Members
TI.ZPI2 Namespace


UTIL_GET_TIME_ALIVE Members

UTIL_GET_TIME_ALIVE Members
See Also Example Constructors Methods
[image]

Use this message to get board's time alive.

The following tables list the members exposed by UTIL_GET_TIME_ALIVE.

Public Constructors

 | Name | Description
Public method | UTIL_GET_TIME_ALIVE | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UTIL_GET_TIME_ALIVE Class
TI.ZPI2 Namespace


UTIL_GET_TIME_ALIVE Constructor

UTIL_GET_TIME_ALIVE Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_GET_TIME_ALIVE()
C++
public:
UTIL_GET_TIME_ALIVE() sealed
J#
public UTIL_GET_TIME_ALIVE()
JScript
public function UTIL_GET_TIME_ALIVE()

See Also

UTIL_GET_TIME_ALIVE Class
TI.ZPI2 Namespace


UTIL_GET_TIME_ALIVE_RESPONSE Class

UTIL_GET_TIME_ALIVE_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_GET_TIME_ALIVE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_GET_TIME_ALIVE_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_GET_TIME_ALIVE_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_GET_TIME_ALIVE_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_GET_TIME_ALIVE_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_GET_TIME_ALIVE_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_GET_TIME_ALIVE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_GET_TIME_ALIVE_RESPONSE Members
TI.ZPI2 Namespace


UTIL_GET_TIME_ALIVE_RESPONSE Members

UTIL_GET_TIME_ALIVE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_GET_TIME_ALIVE

The following tables list the members exposed by UTIL_GET_TIME_ALIVE_RESPONSE.

Public Constructors

Name | Description
UTIL_GET_TIME_ALIVE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Seconds | Seconds
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_GET_TIME_ALIVE_RESPONSE | Overloaded.
Top

See Also

UTIL_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_TIME_ALIVE_RESPONSE Constructor

UTIL_GET_TIME_ALIVE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_GET_TIME_ALIVE_RESPONSE | Constructor
Public method | UTIL_GET_TIME_ALIVE_RESPONSE (UInt32) | Constructor

See Also

UTIL_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_GET_TIME_ALIVE_RESPONSE Constructor ()

UTIL_GET_TIME_ALIVE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_GET_TIME_ALIVE_RESPONSE()
C++
public:
UTIL_GET_TIME_ALIVE_RESPONSE() sealed
J#
public UTIL_GET_TIME_ALIVE_RESPONSE()
JScript
public function UTIL_GET_TIME_ALIVE_RESPONSE()

See Also

UTIL_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_GET_TIME_ALIVE_RESPONSE Constructor Overload List


UTIL_GET_TIME_ALIVE_RESPONSE Constructor (UInt32)

UTIL_GET_TIME_ALIVE_RESPONSE Constructor (UInt32)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt32 _
)
C#
public UTIL_GET_TIME_ALIVE_RESPONSE(
uint
)
C++
public:
UTIL_GET_TIME_ALIVE_RESPONSE(
unsigned int
) sealed
J#
public UTIL_GET_TIME_ALIVE_RESPONSE(
uint
)
JScript
public function UTIL_GET_TIME_ALIVE_RESPONSE(
: UInt32
)

See Also

UTIL_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_GET_TIME_ALIVE_RESPONSE Constructor Overload List


Fields

UTIL_GET_TIME_ALIVE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Seconds | Seconds
Top

See Also

UTIL_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI2 Namespace


Seconds Field

UTIL_GET_TIME_ALIVE_RESPONSE.Seconds Field
[image]

Seconds

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Seconds As UInt32
C#
public uint Seconds;
C++
public:
unsigned int Seconds sealed ;
J#
public uint Seconds
JScript
public Seconds : UInt32;

See Also

UTIL_GET_TIME_ALIVE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_KEY_EVENT Class

UTIL_KEY_EVENT Class
See Also Example Members
[image]

Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_KEY_EVENT
Implements IREQUEST, IUTIL
C#
public class UTIL_KEY_EVENT : IREQUEST, IUTIL
C++
ref class UTIL_KEY_EVENT : IREQUEST, IUTIL
J#
public class UTIL_KEY_EVENT implements IREQUEST, IUTIL
JScript
public class UTIL_KEY_EVENT extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_KEY_EVENT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_KEY_EVENT Members
TI.ZPI2 Namespace


UTIL_KEY_EVENT Members

UTIL_KEY_EVENT Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Sends a key event to the device registered application. The device register application means that the application registered for key events with OnBoard. Not all application support all keys, so you must know what keys the application supports.

The following tables list the members exposed by UTIL_KEY_EVENT.

Public Constructors

Name | Description
UTIL_KEY_EVENT | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Key | byte field with bit values for the keys
Public field | Shift | True (0x01) means that the shift was enabled
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_KEY_EVENT | Overloaded.
Top

See Also

UTIL_KEY_EVENT Class
TI.ZPI2 Namespace


UTIL_KEY_EVENT Constructor

UTIL_KEY_EVENT Constructor

Overload List

 | Name | Description
Public method | UTIL_KEY_EVENT | Constructor
Public method | UTIL_KEY_EVENT (UTIL_KEY_EVENT.KEY_EVENT, UTIL_KEY_EVENT.BOOLEAN) |

See Also

UTIL_KEY_EVENT Class
TI.ZPI2 Namespace


UTIL_KEY_EVENT Constructor ()

UTIL_KEY_EVENT Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_KEY_EVENT()
C++
public:
UTIL_KEY_EVENT() sealed
J#
public UTIL_KEY_EVENT()
JScript
public function UTIL_KEY_EVENT()

See Also

UTIL_KEY_EVENT Class
TI.ZPI2 Namespace
UTIL_KEY_EVENT Constructor Overload List


UTIL_KEY_EVENT Constructor (UTIL_KEY_EVENT.KEY_EVENT, UTIL_KEY_EVENT.BOOLEAN)

UTIL_KEY_EVENT Constructor (UTIL_KEY_EVENT.KEY_EVENT, UTIL_KEY_EVENT.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_KEY_EVENT.KEY_EVENT, _
ByVal As UTIL_KEY_EVENT.BOOLEAN _
)
C#
public UTIL_KEY_EVENT(
UTIL_KEY_EVENT.KEY_EVENT ,
UTIL_KEY_EVENT.BOOLEAN
)
C++
public:
UTIL_KEY_EVENT(
UTIL_KEY_EVENT.KEY_EVENT ,
UTIL_KEY_EVENT.BOOLEAN
) sealed
J#
public UTIL_KEY_EVENT(
UTIL_KEY_EVENT.KEY_EVENT ,
UTIL_KEY_EVENT.BOOLEAN
)
JScript
public function UTIL_KEY_EVENT(
: UTIL_KEY_EVENT.KEY_EVENT,
: UTIL_KEY_EVENT.BOOLEAN
)

See Also

UTIL_KEY_EVENT Class
TI.ZPI2 Namespace
UTIL_KEY_EVENT Constructor Overload List


Fields

UTIL_KEY_EVENT Fields
[image]

Public Fields

 | Name | Description
Public field | Key | byte field with bit values for the keys
Public field | Shift | True (0x01) means that the shift was enabled
Top

See Also

UTIL_KEY_EVENT Class
TI.ZPI2 Namespace


Key Field

UTIL_KEY_EVENT.Key Field
[image]

byte field with bit values for the keys

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Key As UTIL_KEY_EVENT.KEY_EVENT
C#
public UTIL_KEY_EVENT.KEY_EVENT Key;
C++
public:
UTIL_KEY_EVENT.KEY_EVENT Key sealed ;
J#
public UTIL_KEY_EVENT.KEY_EVENT Key
JScript
public Key : UTIL_KEY_EVENT.KEY_EVENT;

See Also

UTIL_KEY_EVENT Class
TI.ZPI2 Namespace


Shift Field

UTIL_KEY_EVENT.Shift Field
[image]

True (0x01) means that the shift was enabled

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Shift As UTIL_KEY_EVENT.BOOLEAN
C#
public UTIL_KEY_EVENT.BOOLEAN Shift;
C++
public:
UTIL_KEY_EVENT.BOOLEAN Shift sealed ;
J#
public UTIL_KEY_EVENT.BOOLEAN Shift
JScript
public Shift : UTIL_KEY_EVENT.BOOLEAN;

See Also

UTIL_KEY_EVENT Class
TI.ZPI2 Namespace


UTIL_KEY_EVENT.BOOLEAN Enumeration

UTIL_KEY_EVENT.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_KEY_EVENT.BOOLEAN As Byte
C#
public enum UTIL_KEY_EVENT.BOOLEAN : byte
C++
public enum class UTIL_KEY_EVENT.BOOLEAN : char
J#
public enum UTIL_KEY_EVENT.BOOLEAN byte
JScript
public enum UTIL_KEY_EVENT.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


UTIL_KEY_EVENT.KEY_EVENT Enumeration

UTIL_KEY_EVENT.KEY_EVENT Enumeration
[image]

Key event

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_KEY_EVENT.KEY_EVENT As Byte
C#
public enum UTIL_KEY_EVENT.KEY_EVENT : byte
C++
public enum class UTIL_KEY_EVENT.KEY_EVENT : char
J#
public enum UTIL_KEY_EVENT.KEY_EVENT byte
JScript
public enum UTIL_KEY_EVENT.KEY_EVENT :

Members

Member Name | Description
KEY_1 | Key event
KEY_2 | Key event
KEY_3 | Key event
KEY_4 | Key event
KEY_5 | Key event
KEY_6 | Key event
KEY_7 | Key event
KEY_8 | Key event

See Also

TI.ZPI2 Namespace


UTIL_KEY_EVENT_RESPONSE Class

UTIL_KEY_EVENT_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_KEY_EVENT

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_KEY_EVENT_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_KEY_EVENT_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_KEY_EVENT_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_KEY_EVENT_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_KEY_EVENT_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_KEY_EVENT_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_KEY_EVENT_RESPONSE Members
TI.ZPI2 Namespace


UTIL_KEY_EVENT_RESPONSE Members

UTIL_KEY_EVENT_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_KEY_EVENT

The following tables list the members exposed by UTIL_KEY_EVENT_RESPONSE.

Public Constructors

Name | Description
UTIL_KEY_EVENT_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_KEY_EVENT_RESPONSE | Overloaded.
Top

See Also

UTIL_KEY_EVENT_RESPONSE Class
TI.ZPI2 Namespace


UTIL_KEY_EVENT_RESPONSE Constructor

UTIL_KEY_EVENT_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_KEY_EVENT_RESPONSE | Constructor
Public method | UTIL_KEY_EVENT_RESPONSE (UTIL_KEY_EVENT_RESPONSE.CMD_STATUS) |

See Also

UTIL_KEY_EVENT_RESPONSE Class
TI.ZPI2 Namespace


UTIL_KEY_EVENT_RESPONSE Constructor ()

UTIL_KEY_EVENT_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_KEY_EVENT_RESPONSE()
C++
public:
UTIL_KEY_EVENT_RESPONSE() sealed
J#
public UTIL_KEY_EVENT_RESPONSE()
JScript
public function UTIL_KEY_EVENT_RESPONSE()

See Also

UTIL_KEY_EVENT_RESPONSE Class
TI.ZPI2 Namespace
UTIL_KEY_EVENT_RESPONSE Constructor Overload List


UTIL_KEY_EVENT_RESPONSE Constructor (UTIL_KEY_EVENT_RESPONSE.CMD_STATUS)

UTIL_KEY_EVENT_RESPONSE Constructor (UTIL_KEY_EVENT_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_KEY_EVENT_RESPONSE.CMD_STATUS _
)
C#
public UTIL_KEY_EVENT_RESPONSE(
UTIL_KEY_EVENT_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_KEY_EVENT_RESPONSE(
UTIL_KEY_EVENT_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_KEY_EVENT_RESPONSE(
UTIL_KEY_EVENT_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_KEY_EVENT_RESPONSE(
: UTIL_KEY_EVENT_RESPONSE.CMD_STATUS
)

See Also

UTIL_KEY_EVENT_RESPONSE Class
TI.ZPI2 Namespace
UTIL_KEY_EVENT_RESPONSE Constructor Overload List


Fields

UTIL_KEY_EVENT_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_KEY_EVENT_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_KEY_EVENT_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_KEY_EVENT_RESPONSE.CMD_STATUS
C#
public UTIL_KEY_EVENT_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_KEY_EVENT_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_KEY_EVENT_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_KEY_EVENT_RESPONSE.CMD_STATUS;

See Also

UTIL_KEY_EVENT_RESPONSE Class
TI.ZPI2 Namespace


UTIL_KEY_EVENT_RESPONSE.CMD_STATUS Enumeration

UTIL_KEY_EVENT_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_KEY_EVENT_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_KEY_EVENT_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_KEY_EVENT_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_KEY_EVENT_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_KEY_EVENT_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_LED_CONTROL Class

UTIL_LED_CONTROL Class
See Also Example Members
[image]

Use this message to control LEDs on the board.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_LED_CONTROL
Implements IREQUEST, IUTIL
C#
public class UTIL_LED_CONTROL : IREQUEST, IUTIL
C++
ref class UTIL_LED_CONTROL : IREQUEST, IUTIL
J#
public class UTIL_LED_CONTROL implements IREQUEST, IUTIL
JScript
public class UTIL_LED_CONTROL extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_LED_CONTROL

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_LED_CONTROL Members
TI.ZPI2 Namespace


UTIL_LED_CONTROL Members

UTIL_LED_CONTROL Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to control LEDs on the board.

The following tables list the members exposed by UTIL_LED_CONTROL.

Public Constructors

Name | Description
UTIL_LED_CONTROL | Overloaded.
Top

Public Fields

 | Name | Description
Public field | LedID | The ID of the LED to be controlled
Public field | Mode | Mode to set the LED to
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_LED_CONTROL | Overloaded.
Top

See Also

UTIL_LED_CONTROL Class
TI.ZPI2 Namespace


UTIL_LED_CONTROL Constructor

UTIL_LED_CONTROL Constructor

Overload List

 | Name | Description
Public method | UTIL_LED_CONTROL | Constructor
Public method | UTIL_LED_CONTROL (UTIL_LED_CONTROL.LED_NUM, UTIL_LED_CONTROL.LED_MODE) |

See Also

UTIL_LED_CONTROL Class
TI.ZPI2 Namespace


UTIL_LED_CONTROL Constructor ()

UTIL_LED_CONTROL Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_LED_CONTROL()
C++
public:
UTIL_LED_CONTROL() sealed
J#
public UTIL_LED_CONTROL()
JScript
public function UTIL_LED_CONTROL()

See Also

UTIL_LED_CONTROL Class
TI.ZPI2 Namespace
UTIL_LED_CONTROL Constructor Overload List


UTIL_LED_CONTROL Constructor (UTIL_LED_CONTROL.LED_NUM, UTIL_LED_CONTROL.LED_MODE)

UTIL_LED_CONTROL Constructor (UTIL_LED_CONTROL.LED_NUM, UTIL_LED_CONTROL.LED_MODE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_LED_CONTROL.LED_NUM, _
ByVal As UTIL_LED_CONTROL.LED_MODE _
)
C#
public UTIL_LED_CONTROL(
UTIL_LED_CONTROL.LED_NUM ,
UTIL_LED_CONTROL.LED_MODE
)
C++
public:
UTIL_LED_CONTROL(
UTIL_LED_CONTROL.LED_NUM ,
UTIL_LED_CONTROL.LED_MODE
) sealed
J#
public UTIL_LED_CONTROL(
UTIL_LED_CONTROL.LED_NUM ,
UTIL_LED_CONTROL.LED_MODE
)
JScript
public function UTIL_LED_CONTROL(
: UTIL_LED_CONTROL.LED_NUM,
: UTIL_LED_CONTROL.LED_MODE
)

See Also

UTIL_LED_CONTROL Class
TI.ZPI2 Namespace
UTIL_LED_CONTROL Constructor Overload List


Fields

UTIL_LED_CONTROL Fields
[image]

Public Fields

 | Name | Description
Public field | LedID | The ID of the LED to be controlled
Public field | Mode | Mode to set the LED to
Top

See Also

UTIL_LED_CONTROL Class
TI.ZPI2 Namespace


LedID Field

UTIL_LED_CONTROL.LedID Field
[image]

The ID of the LED to be controlled

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LedID As UTIL_LED_CONTROL.LED_NUM
C#
public UTIL_LED_CONTROL.LED_NUM LedID;
C++
public:
UTIL_LED_CONTROL.LED_NUM LedID sealed ;
J#
public UTIL_LED_CONTROL.LED_NUM LedID
JScript
public LedID : UTIL_LED_CONTROL.LED_NUM;

See Also

UTIL_LED_CONTROL Class
TI.ZPI2 Namespace


Mode Field

UTIL_LED_CONTROL.Mode Field
[image]

Mode to set the LED to

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As UTIL_LED_CONTROL.LED_MODE
C#
public UTIL_LED_CONTROL.LED_MODE Mode;
C++
public:
UTIL_LED_CONTROL.LED_MODE Mode sealed ;
J#
public UTIL_LED_CONTROL.LED_MODE Mode
JScript
public Mode : UTIL_LED_CONTROL.LED_MODE;

See Also

UTIL_LED_CONTROL Class
TI.ZPI2 Namespace


UTIL_LED_CONTROL.LED_MODE Enumeration

UTIL_LED_CONTROL.LED_MODE Enumeration
[image]

Mode of the LED

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_LED_CONTROL.LED_MODE As Byte
C#
public enum UTIL_LED_CONTROL.LED_MODE : byte
C++
public enum class UTIL_LED_CONTROL.LED_MODE : char
J#
public enum UTIL_LED_CONTROL.LED_MODE byte
JScript
public enum UTIL_LED_CONTROL.LED_MODE :

Members

Member Name | Description
LED_OFF | Mode of the LED
LED_ON | Mode of the LED
BLINK | Mode of the LED
FLASH | Mode of the LED
TOGGLE | Mode of the LED

See Also

TI.ZPI2 Namespace


UTIL_LED_CONTROL.LED_NUM Enumeration

UTIL_LED_CONTROL.LED_NUM Enumeration
[image]

The ID of the LED

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_LED_CONTROL.LED_NUM As Byte
C#
public enum UTIL_LED_CONTROL.LED_NUM : byte
C++
public enum class UTIL_LED_CONTROL.LED_NUM : char
J#
public enum UTIL_LED_CONTROL.LED_NUM byte
JScript
public enum UTIL_LED_CONTROL.LED_NUM :

Members

Member Name | Description
LED_1 | The ID of the LED
LED_2 | The ID of the LED
LED_3 | The ID of the LED
LED_4 | The ID of the LED
ALL_LEDS | The ID of the LED

See Also

TI.ZPI2 Namespace


UTIL_LED_CONTROL_RESPONSE Class

UTIL_LED_CONTROL_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_LED_CONTROL

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_LED_CONTROL_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_LED_CONTROL_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_LED_CONTROL_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_LED_CONTROL_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_LED_CONTROL_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_LED_CONTROL_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_LED_CONTROL_RESPONSE Members
TI.ZPI2 Namespace


UTIL_LED_CONTROL_RESPONSE Members

UTIL_LED_CONTROL_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_LED_CONTROL

The following tables list the members exposed by UTIL_LED_CONTROL_RESPONSE.

Public Constructors

Name | Description
UTIL_LED_CONTROL_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_LED_CONTROL_RESPONSE | Overloaded.
Top

See Also

UTIL_LED_CONTROL_RESPONSE Class
TI.ZPI2 Namespace


UTIL_LED_CONTROL_RESPONSE Constructor

UTIL_LED_CONTROL_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_LED_CONTROL_RESPONSE | Constructor
Public method | UTIL_LED_CONTROL_RESPONSE (UTIL_LED_CONTROL_RESPONSE.CMD_STATUS) |

See Also

UTIL_LED_CONTROL_RESPONSE Class
TI.ZPI2 Namespace


UTIL_LED_CONTROL_RESPONSE Constructor ()

UTIL_LED_CONTROL_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_LED_CONTROL_RESPONSE()
C++
public:
UTIL_LED_CONTROL_RESPONSE() sealed
J#
public UTIL_LED_CONTROL_RESPONSE()
JScript
public function UTIL_LED_CONTROL_RESPONSE()

See Also

UTIL_LED_CONTROL_RESPONSE Class
TI.ZPI2 Namespace
UTIL_LED_CONTROL_RESPONSE Constructor Overload List


UTIL_LED_CONTROL_RESPONSE Constructor (UTIL_LED_CONTROL_RESPONSE.CMD_STATUS)

UTIL_LED_CONTROL_RESPONSE Constructor (UTIL_LED_CONTROL_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_LED_CONTROL_RESPONSE.CMD_STATUS _
)
C#
public UTIL_LED_CONTROL_RESPONSE(
UTIL_LED_CONTROL_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_LED_CONTROL_RESPONSE(
UTIL_LED_CONTROL_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_LED_CONTROL_RESPONSE(
UTIL_LED_CONTROL_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_LED_CONTROL_RESPONSE(
: UTIL_LED_CONTROL_RESPONSE.CMD_STATUS
)

See Also

UTIL_LED_CONTROL_RESPONSE Class
TI.ZPI2 Namespace
UTIL_LED_CONTROL_RESPONSE Constructor Overload List


Fields

UTIL_LED_CONTROL_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_LED_CONTROL_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_LED_CONTROL_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_LED_CONTROL_RESPONSE.CMD_STATUS
C#
public UTIL_LED_CONTROL_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_LED_CONTROL_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_LED_CONTROL_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_LED_CONTROL_RESPONSE.CMD_STATUS;

See Also

UTIL_LED_CONTROL_RESPONSE Class
TI.ZPI2 Namespace


UTIL_LED_CONTROL_RESPONSE.CMD_STATUS Enumeration

UTIL_LED_CONTROL_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_LED_CONTROL_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_LED_CONTROL_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_LED_CONTROL_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_LED_CONTROL_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_LED_CONTROL_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_LOOPBACK_RESPONSE Class

UTIL_LOOPBACK_RESPONSE Class
See Also Example Members
[image]

Data buffer loopback response.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_LOOPBACK_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_LOOPBACK_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_LOOPBACK_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_LOOPBACK_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_LOOPBACK_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_LOOPBACK_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_LOOPBACK_RESPONSE Members
TI.ZPI2 Namespace


UTIL_LOOPBACK_RESPONSE Members

UTIL_LOOPBACK_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Data buffer loopback response.

The following tables list the members exposed by UTIL_LOOPBACK_RESPONSE.

Public Constructors

Name | Description
UTIL_LOOPBACK_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DataBuf | The data bytes to be looped back.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_LOOPBACK_RESPONSE | Overloaded.
Top

See Also

UTIL_LOOPBACK_RESPONSE Class
TI.ZPI2 Namespace


UTIL_LOOPBACK_RESPONSE Constructor

UTIL_LOOPBACK_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_LOOPBACK_RESPONSE | Constructor
Public method | UTIL_LOOPBACK_RESPONSE (Byte) | Constructor

See Also

UTIL_LOOPBACK_RESPONSE Class
TI.ZPI2 Namespace


UTIL_LOOPBACK_RESPONSE Constructor ()

UTIL_LOOPBACK_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_LOOPBACK_RESPONSE()
C++
public:
UTIL_LOOPBACK_RESPONSE() sealed
J#
public UTIL_LOOPBACK_RESPONSE()
JScript
public function UTIL_LOOPBACK_RESPONSE()

See Also

UTIL_LOOPBACK_RESPONSE Class
TI.ZPI2 Namespace
UTIL_LOOPBACK_RESPONSE Constructor Overload List


UTIL_LOOPBACK_RESPONSE Constructor (Byte[])

UTIL_LOOPBACK_RESPONSE Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public UTIL_LOOPBACK_RESPONSE(
byte[]
)
C++
public:
UTIL_LOOPBACK_RESPONSE(
array<char>^
) sealed
J#
public UTIL_LOOPBACK_RESPONSE(
byte[]
)
JScript
public function UTIL_LOOPBACK_RESPONSE(
: Byte[]
)

See Also

UTIL_LOOPBACK_RESPONSE Class
TI.ZPI2 Namespace
UTIL_LOOPBACK_RESPONSE Constructor Overload List


Fields

UTIL_LOOPBACK_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | DataBuf | The data bytes to be looped back.
Top

See Also

UTIL_LOOPBACK_RESPONSE Class
TI.ZPI2 Namespace


DataBuf Field

UTIL_LOOPBACK_RESPONSE.DataBuf Field
[image]

The data bytes to be looped back.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DataBuf As Byte()
C#
public byte[] DataBuf;
C++
public:
array<char>^ DataBuf sealed ;
J#
public byte[] DataBuf
JScript
public DataBuf : Byte[];

See Also

UTIL_LOOPBACK_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_CHANNELS Class

UTIL_SET_CHANNELS Class
See Also Example Members
[image]

Use this message to set the channels.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_CHANNELS
Implements IREQUEST, IUTIL
C#
public class UTIL_SET_CHANNELS : IREQUEST, IUTIL
C++
ref class UTIL_SET_CHANNELS : IREQUEST, IUTIL
J#
public class UTIL_SET_CHANNELS implements IREQUEST, IUTIL
JScript
public class UTIL_SET_CHANNELS extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_CHANNELS

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_CHANNELS Members
TI.ZPI2 Namespace


UTIL_SET_CHANNELS Members

UTIL_SET_CHANNELS Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set the channels.

The following tables list the members exposed by UTIL_SET_CHANNELS.

Public Constructors

Name | Description
UTIL_SET_CHANNELS | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Channels | Channels.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_CHANNELS | Overloaded.
Top

See Also

UTIL_SET_CHANNELS Class
TI.ZPI2 Namespace


UTIL_SET_CHANNELS Constructor

UTIL_SET_CHANNELS Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_CHANNELS | Constructor
Public method | UTIL_SET_CHANNELS (UTIL_SET_CHANNELS.ZIGBEE_CHANNELS) |

See Also

UTIL_SET_CHANNELS Class
TI.ZPI2 Namespace


UTIL_SET_CHANNELS Constructor ()

UTIL_SET_CHANNELS Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_CHANNELS()
C++
public:
UTIL_SET_CHANNELS() sealed
J#
public UTIL_SET_CHANNELS()
JScript
public function UTIL_SET_CHANNELS()

See Also

UTIL_SET_CHANNELS Class
TI.ZPI2 Namespace
UTIL_SET_CHANNELS Constructor Overload List


UTIL_SET_CHANNELS Constructor (UTIL_SET_CHANNELS.ZIGBEE_CHANNELS)

UTIL_SET_CHANNELS Constructor (UTIL_SET_CHANNELS.ZIGBEE_CHANNELS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SET_CHANNELS.ZIGBEE_CHANNELS _
)
C#
public UTIL_SET_CHANNELS(
UTIL_SET_CHANNELS.ZIGBEE_CHANNELS
)
C++
public:
UTIL_SET_CHANNELS(
UTIL_SET_CHANNELS.ZIGBEE_CHANNELS
) sealed
J#
public UTIL_SET_CHANNELS(
UTIL_SET_CHANNELS.ZIGBEE_CHANNELS
)
JScript
public function UTIL_SET_CHANNELS(
: UTIL_SET_CHANNELS.ZIGBEE_CHANNELS
)

See Also

UTIL_SET_CHANNELS Class
TI.ZPI2 Namespace
UTIL_SET_CHANNELS Constructor Overload List


Fields

UTIL_SET_CHANNELS Fields
[image]

Public Fields

 | Name | Description
Public field | Channels | Channels.
Top

See Also

UTIL_SET_CHANNELS Class
TI.ZPI2 Namespace


Channels Field

UTIL_SET_CHANNELS.Channels Field
[image]

Channels.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Channels As UTIL_SET_CHANNELS.ZIGBEE_CHANNELS
C#
public UTIL_SET_CHANNELS.ZIGBEE_CHANNELS Channels;
C++
public:
UTIL_SET_CHANNELS.ZIGBEE_CHANNELS Channels sealed ;
J#
public UTIL_SET_CHANNELS.ZIGBEE_CHANNELS Channels
JScript
public Channels : UTIL_SET_CHANNELS.ZIGBEE_CHANNELS;

See Also

UTIL_SET_CHANNELS Class
TI.ZPI2 Namespace


UTIL_SET_CHANNELS.ZIGBEE_CHANNELS Enumeration

UTIL_SET_CHANNELS.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum UTIL_SET_CHANNELS.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum UTIL_SET_CHANNELS.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class UTIL_SET_CHANNELS.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum UTIL_SET_CHANNELS.ZIGBEE_CHANNELS uint
JScript
public enum UTIL_SET_CHANNELS.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


UTIL_SET_CHANNELS_RESPONSE Class

UTIL_SET_CHANNELS_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SET_CHANNELS

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_CHANNELS_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SET_CHANNELS_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SET_CHANNELS_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SET_CHANNELS_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SET_CHANNELS_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_CHANNELS_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_CHANNELS_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SET_CHANNELS_RESPONSE Members

UTIL_SET_CHANNELS_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SET_CHANNELS

The following tables list the members exposed by UTIL_SET_CHANNELS_RESPONSE.

Public Constructors

Name | Description
UTIL_SET_CHANNELS_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_CHANNELS_RESPONSE | Overloaded.
Top

See Also

UTIL_SET_CHANNELS_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_CHANNELS_RESPONSE Constructor

UTIL_SET_CHANNELS_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_CHANNELS_RESPONSE | Constructor
Public method | UTIL_SET_CHANNELS_RESPONSE (UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS) |

See Also

UTIL_SET_CHANNELS_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_CHANNELS_RESPONSE Constructor ()

UTIL_SET_CHANNELS_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_CHANNELS_RESPONSE()
C++
public:
UTIL_SET_CHANNELS_RESPONSE() sealed
J#
public UTIL_SET_CHANNELS_RESPONSE()
JScript
public function UTIL_SET_CHANNELS_RESPONSE()

See Also

UTIL_SET_CHANNELS_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_CHANNELS_RESPONSE Constructor Overload List


UTIL_SET_CHANNELS_RESPONSE Constructor (UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS)

UTIL_SET_CHANNELS_RESPONSE Constructor (UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SET_CHANNELS_RESPONSE(
UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SET_CHANNELS_RESPONSE(
UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SET_CHANNELS_RESPONSE(
UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SET_CHANNELS_RESPONSE(
: UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS
)

See Also

UTIL_SET_CHANNELS_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_CHANNELS_RESPONSE Constructor Overload List


Fields

UTIL_SET_CHANNELS_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SET_CHANNELS_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SET_CHANNELS_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS
C#
public UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS;

See Also

UTIL_SET_CHANNELS_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS Enumeration

UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SET_PANID Class

UTIL_SET_PANID Class
See Also Example Members
[image]

Use this message to set PANID.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_PANID
Implements IREQUEST, IUTIL
C#
public class UTIL_SET_PANID : IREQUEST, IUTIL
C++
ref class UTIL_SET_PANID : IREQUEST, IUTIL
J#
public class UTIL_SET_PANID implements IREQUEST, IUTIL
JScript
public class UTIL_SET_PANID extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_PANID

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_PANID Members
TI.ZPI2 Namespace


UTIL_SET_PANID Members

UTIL_SET_PANID Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set PANID.

The following tables list the members exposed by UTIL_SET_PANID.

Public Constructors

Name | Description
UTIL_SET_PANID | Overloaded.
Top

Public Fields

 | Name | Description
Public field | PanID | PanID.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_PANID | Overloaded.
Top

See Also

UTIL_SET_PANID Class
TI.ZPI2 Namespace


UTIL_SET_PANID Constructor

UTIL_SET_PANID Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_PANID | Constructor
Public method | UTIL_SET_PANID (UInt16) | Constructor

See Also

UTIL_SET_PANID Class
TI.ZPI2 Namespace


UTIL_SET_PANID Constructor ()

UTIL_SET_PANID Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_PANID()
C++
public:
UTIL_SET_PANID() sealed
J#
public UTIL_SET_PANID()
JScript
public function UTIL_SET_PANID()

See Also

UTIL_SET_PANID Class
TI.ZPI2 Namespace
UTIL_SET_PANID Constructor Overload List


UTIL_SET_PANID Constructor (UInt16)

UTIL_SET_PANID Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public UTIL_SET_PANID(
ushort
)
C++
public:
UTIL_SET_PANID(
unsigned short
) sealed
J#
public UTIL_SET_PANID(
ushort
)
JScript
public function UTIL_SET_PANID(
: UInt16
)

See Also

UTIL_SET_PANID Class
TI.ZPI2 Namespace
UTIL_SET_PANID Constructor Overload List


Fields

UTIL_SET_PANID Fields
[image]

Public Fields

 | Name | Description
Public field | PanID | PanID.
Top

See Also

UTIL_SET_PANID Class
TI.ZPI2 Namespace


PanID Field

UTIL_SET_PANID.PanID Field
[image]

PanID.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

UTIL_SET_PANID Class
TI.ZPI2 Namespace


UTIL_SET_PANID_RESPONSE Class

UTIL_SET_PANID_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SET_PANID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_PANID_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SET_PANID_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SET_PANID_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SET_PANID_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SET_PANID_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_PANID_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_PANID_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SET_PANID_RESPONSE Members

UTIL_SET_PANID_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SET_PANID

The following tables list the members exposed by UTIL_SET_PANID_RESPONSE.

Public Constructors

Name | Description
UTIL_SET_PANID_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_PANID_RESPONSE | Overloaded.
Top

See Also

UTIL_SET_PANID_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_PANID_RESPONSE Constructor

UTIL_SET_PANID_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_PANID_RESPONSE | Constructor
Public method | UTIL_SET_PANID_RESPONSE (UTIL_SET_PANID_RESPONSE.CMD_STATUS) |

See Also

UTIL_SET_PANID_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_PANID_RESPONSE Constructor ()

UTIL_SET_PANID_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_PANID_RESPONSE()
C++
public:
UTIL_SET_PANID_RESPONSE() sealed
J#
public UTIL_SET_PANID_RESPONSE()
JScript
public function UTIL_SET_PANID_RESPONSE()

See Also

UTIL_SET_PANID_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_PANID_RESPONSE Constructor Overload List


UTIL_SET_PANID_RESPONSE Constructor (UTIL_SET_PANID_RESPONSE.CMD_STATUS)

UTIL_SET_PANID_RESPONSE Constructor (UTIL_SET_PANID_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SET_PANID_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SET_PANID_RESPONSE(
UTIL_SET_PANID_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SET_PANID_RESPONSE(
UTIL_SET_PANID_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SET_PANID_RESPONSE(
UTIL_SET_PANID_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SET_PANID_RESPONSE(
: UTIL_SET_PANID_RESPONSE.CMD_STATUS
)

See Also

UTIL_SET_PANID_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_PANID_RESPONSE Constructor Overload List


Fields

UTIL_SET_PANID_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SET_PANID_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SET_PANID_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SET_PANID_RESPONSE.CMD_STATUS
C#
public UTIL_SET_PANID_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SET_PANID_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SET_PANID_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SET_PANID_RESPONSE.CMD_STATUS;

See Also

UTIL_SET_PANID_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_PANID_RESPONSE.CMD_STATUS Enumeration

UTIL_SET_PANID_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SET_PANID_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SET_PANID_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SET_PANID_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SET_PANID_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SET_PANID_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY Class

UTIL_SET_PRECONFIG_KEY Class
See Also Example Members
[image]

Use this message to set the preconfig key.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_PRECONFIG_KEY
Implements IREQUEST, IUTIL
C#
public class UTIL_SET_PRECONFIG_KEY : IREQUEST, IUTIL
C++
ref class UTIL_SET_PRECONFIG_KEY : IREQUEST, IUTIL
J#
public class UTIL_SET_PRECONFIG_KEY implements IREQUEST, IUTIL
JScript
public class UTIL_SET_PRECONFIG_KEY extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_PRECONFIG_KEY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_PRECONFIG_KEY Members
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY Members

UTIL_SET_PRECONFIG_KEY Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set the preconfig key.

The following tables list the members exposed by UTIL_SET_PRECONFIG_KEY.

Public Constructors

Name | Description
UTIL_SET_PRECONFIG_KEY | Overloaded.
Top

Public Fields

 | Name | Description
Public field | PreConfigKey | PreConfigKey.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_PRECONFIG_KEY | Overloaded.
Top

See Also

UTIL_SET_PRECONFIG_KEY Class
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY Constructor

UTIL_SET_PRECONFIG_KEY Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_PRECONFIG_KEY | Constructor
Public method | UTIL_SET_PRECONFIG_KEY (Byte) | Constructor

See Also

UTIL_SET_PRECONFIG_KEY Class
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY Constructor ()

UTIL_SET_PRECONFIG_KEY Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_PRECONFIG_KEY()
C++
public:
UTIL_SET_PRECONFIG_KEY() sealed
J#
public UTIL_SET_PRECONFIG_KEY()
JScript
public function UTIL_SET_PRECONFIG_KEY()

See Also

UTIL_SET_PRECONFIG_KEY Class
TI.ZPI2 Namespace
UTIL_SET_PRECONFIG_KEY Constructor Overload List


UTIL_SET_PRECONFIG_KEY Constructor (Byte[])

UTIL_SET_PRECONFIG_KEY Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public UTIL_SET_PRECONFIG_KEY(
byte[]
)
C++
public:
UTIL_SET_PRECONFIG_KEY(
array<char>^
) sealed
J#
public UTIL_SET_PRECONFIG_KEY(
byte[]
)
JScript
public function UTIL_SET_PRECONFIG_KEY(
: Byte[]
)

See Also

UTIL_SET_PRECONFIG_KEY Class
TI.ZPI2 Namespace
UTIL_SET_PRECONFIG_KEY Constructor Overload List


Fields

UTIL_SET_PRECONFIG_KEY Fields
[image]

Public Fields

 | Name | Description
Public field | PreConfigKey | PreConfigKey.
Top

See Also

UTIL_SET_PRECONFIG_KEY Class
TI.ZPI2 Namespace


PreConfigKey Field

UTIL_SET_PRECONFIG_KEY.PreConfigKey Field
[image]

PreConfigKey.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PreConfigKey As Byte()
C#
public byte[] PreConfigKey;
C++
public:
array<char>^ PreConfigKey sealed ;
J#
public byte[] PreConfigKey
JScript
public PreConfigKey : Byte[];

See Also

UTIL_SET_PRECONFIG_KEY Class
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY_RESPONSE Class

UTIL_SET_PRECONFIG_KEY_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SET_PRECONFIG_KEY

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_PRECONFIG_KEY_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SET_PRECONFIG_KEY_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SET_PRECONFIG_KEY_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SET_PRECONFIG_KEY_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SET_PRECONFIG_KEY_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_PRECONFIG_KEY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_PRECONFIG_KEY_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY_RESPONSE Members

UTIL_SET_PRECONFIG_KEY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SET_PRECONFIG_KEY

The following tables list the members exposed by UTIL_SET_PRECONFIG_KEY_RESPONSE.

Public Constructors

Name | Description
UTIL_SET_PRECONFIG_KEY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_PRECONFIG_KEY_RESPONSE | Overloaded.
Top

See Also

UTIL_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor

UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_PRECONFIG_KEY_RESPONSE | Constructor
Public method | UTIL_SET_PRECONFIG_KEY_RESPONSE (UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS) |

See Also

UTIL_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor ()

UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_PRECONFIG_KEY_RESPONSE()
C++
public:
UTIL_SET_PRECONFIG_KEY_RESPONSE() sealed
J#
public UTIL_SET_PRECONFIG_KEY_RESPONSE()
JScript
public function UTIL_SET_PRECONFIG_KEY_RESPONSE()

See Also

UTIL_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor Overload List


UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor (UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS)

UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor (UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SET_PRECONFIG_KEY_RESPONSE(
UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SET_PRECONFIG_KEY_RESPONSE(
UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SET_PRECONFIG_KEY_RESPONSE(
UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SET_PRECONFIG_KEY_RESPONSE(
: UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
)

See Also

UTIL_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_PRECONFIG_KEY_RESPONSE Constructor Overload List


Fields

UTIL_SET_PRECONFIG_KEY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SET_PRECONFIG_KEY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
C#
public UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS;

See Also

UTIL_SET_PRECONFIG_KEY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Enumeration

UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL Class

UTIL_SET_SECURITY_LEVEL Class
See Also Example Members
[image]

Use this message to set the security level.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_SECURITY_LEVEL
Implements IREQUEST, IUTIL
C#
public class UTIL_SET_SECURITY_LEVEL : IREQUEST, IUTIL
C++
ref class UTIL_SET_SECURITY_LEVEL : IREQUEST, IUTIL
J#
public class UTIL_SET_SECURITY_LEVEL implements IREQUEST, IUTIL
JScript
public class UTIL_SET_SECURITY_LEVEL extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_SECURITY_LEVEL

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_SECURITY_LEVEL Members
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL Members

UTIL_SET_SECURITY_LEVEL Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to set the security level.

The following tables list the members exposed by UTIL_SET_SECURITY_LEVEL.

Public Constructors

Name | Description
UTIL_SET_SECURITY_LEVEL | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SecurityLevel | Security Level.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_SECURITY_LEVEL | Overloaded.
Top

See Also

UTIL_SET_SECURITY_LEVEL Class
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL Constructor

UTIL_SET_SECURITY_LEVEL Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_SECURITY_LEVEL | Constructor
Public method | UTIL_SET_SECURITY_LEVEL (Byte) | Constructor

See Also

UTIL_SET_SECURITY_LEVEL Class
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL Constructor ()

UTIL_SET_SECURITY_LEVEL Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_SECURITY_LEVEL()
C++
public:
UTIL_SET_SECURITY_LEVEL() sealed
J#
public UTIL_SET_SECURITY_LEVEL()
JScript
public function UTIL_SET_SECURITY_LEVEL()

See Also

UTIL_SET_SECURITY_LEVEL Class
TI.ZPI2 Namespace
UTIL_SET_SECURITY_LEVEL Constructor Overload List


UTIL_SET_SECURITY_LEVEL Constructor (Byte)

UTIL_SET_SECURITY_LEVEL Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public UTIL_SET_SECURITY_LEVEL(
byte
)
C++
public:
UTIL_SET_SECURITY_LEVEL(
char
) sealed
J#
public UTIL_SET_SECURITY_LEVEL(
byte
)
JScript
public function UTIL_SET_SECURITY_LEVEL(
: Byte
)

See Also

UTIL_SET_SECURITY_LEVEL Class
TI.ZPI2 Namespace
UTIL_SET_SECURITY_LEVEL Constructor Overload List


Fields

UTIL_SET_SECURITY_LEVEL Fields
[image]

Public Fields

 | Name | Description
Public field | SecurityLevel | Security Level.
Top

See Also

UTIL_SET_SECURITY_LEVEL Class
TI.ZPI2 Namespace


SecurityLevel Field

UTIL_SET_SECURITY_LEVEL.SecurityLevel Field
[image]

Security Level.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As Byte
C#
public byte SecurityLevel;
C++
public:
char SecurityLevel sealed ;
J#
public byte SecurityLevel
JScript
public SecurityLevel : Byte;

See Also

UTIL_SET_SECURITY_LEVEL Class
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL_RESPONSE Class

UTIL_SET_SECURITY_LEVEL_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SET_SECURITY_LEVEL

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SET_SECURITY_LEVEL_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SET_SECURITY_LEVEL_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SET_SECURITY_LEVEL_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SET_SECURITY_LEVEL_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SET_SECURITY_LEVEL_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SET_SECURITY_LEVEL_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SET_SECURITY_LEVEL_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL_RESPONSE Members

UTIL_SET_SECURITY_LEVEL_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SET_SECURITY_LEVEL

The following tables list the members exposed by UTIL_SET_SECURITY_LEVEL_RESPONSE.

Public Constructors

Name | Description
UTIL_SET_SECURITY_LEVEL_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SET_SECURITY_LEVEL_RESPONSE | Overloaded.
Top

See Also

UTIL_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor

UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SET_SECURITY_LEVEL_RESPONSE | Constructor
Public method | UTIL_SET_SECURITY_LEVEL_RESPONSE (UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS) |

See Also

UTIL_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor ()

UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SET_SECURITY_LEVEL_RESPONSE()
C++
public:
UTIL_SET_SECURITY_LEVEL_RESPONSE() sealed
J#
public UTIL_SET_SECURITY_LEVEL_RESPONSE()
JScript
public function UTIL_SET_SECURITY_LEVEL_RESPONSE()

See Also

UTIL_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor Overload List


UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor (UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS)

UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor (UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SET_SECURITY_LEVEL_RESPONSE(
UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SET_SECURITY_LEVEL_RESPONSE(
UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SET_SECURITY_LEVEL_RESPONSE(
UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SET_SECURITY_LEVEL_RESPONSE(
: UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
)

See Also

UTIL_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SET_SECURITY_LEVEL_RESPONSE Constructor Overload List


Fields

UTIL_SET_SECURITY_LEVEL_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SET_SECURITY_LEVEL_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
C#
public UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS;

See Also

UTIL_SET_SECURITY_LEVEL_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Enumeration

UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING Class

UTIL_SRC_MATCH_ACK_ALL_PENDING Class
See Also Example Members
[image]

Enabled/disable acknowledging all packets with pending bit set.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_ACK_ALL_PENDING
Implements IREQUEST, IUTIL
C#
public class UTIL_SRC_MATCH_ACK_ALL_PENDING : IREQUEST, IUTIL
C++
ref class UTIL_SRC_MATCH_ACK_ALL_PENDING : IREQUEST, IUTIL
J#
public class UTIL_SRC_MATCH_ACK_ALL_PENDING implements IREQUEST, IUTIL
JScript
public class UTIL_SRC_MATCH_ACK_ALL_PENDING extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING Members

UTIL_SRC_MATCH_ACK_ALL_PENDING Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Enabled/disable acknowledging all packets with pending bit set.

The following tables list the members exposed by UTIL_SRC_MATCH_ACK_ALL_PENDING.

Public Constructors

Name | Description
UTIL_SRC_MATCH_ACK_ALL_PENDING | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Option | TRUE - acknowledging all packets with pending field set. FALSE - Otherwise
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_ACK_ALL_PENDING | Overloaded.
Top

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor

UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_ACK_ALL_PENDING | Constructor
Public method | UTIL_SRC_MATCH_ACK_ALL_PENDING (UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN) |

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor ()

UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_ACK_ALL_PENDING()
C++
public:
UTIL_SRC_MATCH_ACK_ALL_PENDING() sealed
J#
public UTIL_SRC_MATCH_ACK_ALL_PENDING()
JScript
public function UTIL_SRC_MATCH_ACK_ALL_PENDING()

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor Overload List


UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor (UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN)

UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor (UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN _
)
C#
public UTIL_SRC_MATCH_ACK_ALL_PENDING(
UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN
)
C++
public:
UTIL_SRC_MATCH_ACK_ALL_PENDING(
UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN
) sealed
J#
public UTIL_SRC_MATCH_ACK_ALL_PENDING(
UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN
)
JScript
public function UTIL_SRC_MATCH_ACK_ALL_PENDING(
: UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN
)

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ACK_ALL_PENDING Constructor Overload List


Fields

UTIL_SRC_MATCH_ACK_ALL_PENDING Fields
[image]

Public Fields

 | Name | Description
Public field | Option | TRUE - acknowledging all packets with pending field set. FALSE - Otherwise
Top

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING Class
TI.ZPI2 Namespace


Option Field

UTIL_SRC_MATCH_ACK_ALL_PENDING.Option Field
[image]

TRUE - acknowledging all packets with pending field set. FALSE - Otherwise

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Option As UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN
C#
public UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN Option;
C++
public:
UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN Option sealed ;
J#
public UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN Option
JScript
public Option : UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN;

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN Enumeration

UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN As Byte
C#
public enum UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN : byte
C++
public enum class UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN : char
J#
public enum UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN byte
JScript
public enum UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SRC_MATCH_ACK_ALL_PENDING

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Members

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SRC_MATCH_ACK_ALL_PENDING

The following tables list the members exposed by UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.

Public Constructors

Name | Description
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE | Overloaded.
Top

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE | Constructor
Public method | UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE (UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS) |

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor ()

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE()
C++
public:
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE() sealed
J#
public UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE()
JScript
public function UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE()

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor Overload List


UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor (UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS)

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor (UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE(
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE(
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE(
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE(
: UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS
)

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Constructor Overload List


Fields

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS
C#
public UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS;

See Also

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS Enumeration

UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS Enumeration
See Also Example
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY Class

UTIL_SRC_MATCH_ADD_ENTRY Class
See Also Example Members
[image]

Add a short or extended address to source address table

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_ADD_ENTRY
Implements IREQUEST, IUTIL
C#
public class UTIL_SRC_MATCH_ADD_ENTRY : IREQUEST, IUTIL
C++
ref class UTIL_SRC_MATCH_ADD_ENTRY : IREQUEST, IUTIL
J#
public class UTIL_SRC_MATCH_ADD_ENTRY implements IREQUEST, IUTIL
JScript
public class UTIL_SRC_MATCH_ADD_ENTRY extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_ADD_ENTRY Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY Members

UTIL_SRC_MATCH_ADD_ENTRY Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Add a short or extended address to source address table

The following tables list the members exposed by UTIL_SRC_MATCH_ADD_ENTRY.

Public Constructors

Name | Description
UTIL_SRC_MATCH_ADD_ENTRY | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Address | Address of the device that will be added - Can be short or extended depends on the address mode.
Public field | AddressMode | Specifies the format of the device address that will be added.
Public field | PanID | PAN ID of the device. Only use when the address is a short address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_ADD_ENTRY | Overloaded.
Top

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY Constructor

UTIL_SRC_MATCH_ADD_ENTRY Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_ADD_ENTRY | Constructor
Public method | UTIL_SRC_MATCH_ADD_ENTRY (UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE, UInt64, UInt16) |

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY Constructor ()

UTIL_SRC_MATCH_ADD_ENTRY Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_ADD_ENTRY()
C++
public:
UTIL_SRC_MATCH_ADD_ENTRY() sealed
J#
public UTIL_SRC_MATCH_ADD_ENTRY()
JScript
public function UTIL_SRC_MATCH_ADD_ENTRY()

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ADD_ENTRY Constructor Overload List


UTIL_SRC_MATCH_ADD_ENTRY Constructor (UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE, UInt64, UInt16)

UTIL_SRC_MATCH_ADD_ENTRY Constructor (UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE, UInt64, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16 _
)
C#
public UTIL_SRC_MATCH_ADD_ENTRY(
UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE ,
ulong ,
ushort
)
C++
public:
UTIL_SRC_MATCH_ADD_ENTRY(
UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short
) sealed
J#
public UTIL_SRC_MATCH_ADD_ENTRY(
UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE ,
ulong ,
ushort
)
JScript
public function UTIL_SRC_MATCH_ADD_ENTRY(
: UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE,
: UInt64,
: UInt16
)

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ADD_ENTRY Constructor Overload List


Fields

UTIL_SRC_MATCH_ADD_ENTRY Fields
[image]

Public Fields

 | Name | Description
Public field | Address | Address of the device that will be added - Can be short or extended depends on the address mode.
Public field | AddressMode | Specifies the format of the device address that will be added.
Public field | PanID | PAN ID of the device. Only use when the address is a short address.
Top

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace


Address Field

UTIL_SRC_MATCH_ADD_ENTRY.Address Field
[image]

Address of the device that will be added - Can be short or extended depends on the address mode.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Address As UInt64
C#
public ulong Address;
C++
public:
unsigned __int64 Address sealed ;
J#
public ulong Address
JScript
public Address : UInt64;

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace


AddressMode Field

UTIL_SRC_MATCH_ADD_ENTRY.AddressMode Field
[image]

Specifies the format of the device address that will be added.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddressMode As UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE
C#
public UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE AddressMode;
C++
public:
UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE AddressMode sealed ;
J#
public UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE AddressMode
JScript
public AddressMode : UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE;

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace


PanID Field

UTIL_SRC_MATCH_ADD_ENTRY.PanID Field
[image]

PAN ID of the device. Only use when the address is a short address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

UTIL_SRC_MATCH_ADD_ENTRY Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE Enumeration

UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE As Byte
C#
public enum UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE : byte
C++
public enum class UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE : char
J#
public enum UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE byte
JScript
public enum UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SRC_MATCH_ADD_ENTRY

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Members

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SRC_MATCH_ADD_ENTRY

The following tables list the members exposed by UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.

Public Constructors

Name | Description
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE | Overloaded.
Top

See Also

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE | Constructor
Public method | UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE (UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS) |

See Also

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor ()

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE()
C++
public:
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE() sealed
J#
public UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE()
JScript
public function UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE()

See Also

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor Overload List


UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor (UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS)

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor (UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE(
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE(
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE(
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE(
: UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS
)

See Also

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Constructor Overload List


Fields

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS
C#
public UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS;

See Also

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS Enumeration

UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING Class

UTIL_SRC_MATCH_CHECK_ALL_PENDING Class
See Also Example Members
[image]

Check if acknowledging all packets with pending bit set is enabled.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_CHECK_ALL_PENDING
Implements IREQUEST, IUTIL
C#
public class UTIL_SRC_MATCH_CHECK_ALL_PENDING : IREQUEST, IUTIL
C++
ref class UTIL_SRC_MATCH_CHECK_ALL_PENDING : IREQUEST, IUTIL
J#
public class UTIL_SRC_MATCH_CHECK_ALL_PENDING implements IREQUEST, IUTIL
JScript
public class UTIL_SRC_MATCH_CHECK_ALL_PENDING extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING Members

UTIL_SRC_MATCH_CHECK_ALL_PENDING Members
See Also Example Constructors Methods
[image]

Check if acknowledging all packets with pending bit set is enabled.

The following tables list the members exposed by UTIL_SRC_MATCH_CHECK_ALL_PENDING.

Public Constructors

 | Name | Description
Public method | UTIL_SRC_MATCH_CHECK_ALL_PENDING | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING Constructor

UTIL_SRC_MATCH_CHECK_ALL_PENDING Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING()
C++
public:
UTIL_SRC_MATCH_CHECK_ALL_PENDING() sealed
J#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING()
JScript
public function UTIL_SRC_MATCH_CHECK_ALL_PENDING()

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SRC_MATCH_CHECK_ALL_PENDING

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Members

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SRC_MATCH_CHECK_ALL_PENDING

The following tables list the members exposed by UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.

Public Constructors

Name | Description
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Public field | Value | Value
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE | Overloaded.
Top

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE | Constructor
Public method | UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE (UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS, UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN) |

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor ()

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE()
C++
public:
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE() sealed
J#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE()
JScript
public function UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE()

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor Overload List


UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor (UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS, UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN)

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor (UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS, UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS, _
ByVal As UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN _
)
C#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE(
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS ,
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN
)
C++
public:
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE(
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS ,
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN
) sealed
J#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE(
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS ,
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN
)
JScript
public function UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE(
: UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS,
: UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN
)

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Constructor Overload List


Fields

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Public field | Value | Value
Top

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS
C#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS;

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


Value Field

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.Value Field
[image]

Value

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN
C#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN Value;
C++
public:
UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN Value sealed ;
J#
public UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN Value
JScript
public Value : UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN;

See Also

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN Enumeration

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN Enumeration
See Also Example
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN As Byte
C#
public enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN : byte
C++
public enum class UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN : char
J#
public enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN byte
JScript
public enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS Enumeration

UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS Enumeration
See Also Example
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR Class

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
See Also Example Members
[image]

Check if a short or extended address is in the source address table

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_CHECK_SRC_ADDR
Implements IREQUEST, IUTIL
C#
public class UTIL_SRC_MATCH_CHECK_SRC_ADDR : IREQUEST, IUTIL
C++
ref class UTIL_SRC_MATCH_CHECK_SRC_ADDR : IREQUEST, IUTIL
J#
public class UTIL_SRC_MATCH_CHECK_SRC_ADDR implements IREQUEST, IUTIL
JScript
public class UTIL_SRC_MATCH_CHECK_SRC_ADDR extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR Members

UTIL_SRC_MATCH_CHECK_SRC_ADDR Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Check if a short or extended address is in the source address table

The following tables list the members exposed by UTIL_SRC_MATCH_CHECK_SRC_ADDR.

Public Constructors

Name | Description
UTIL_SRC_MATCH_CHECK_SRC_ADDR | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Address | Address of the device that will be checked - Can be short or extended depends on the address mode.
Public field | AddressMode | Specifies the format of the device address that will be checked.
Public field | PanID | PAN ID of the device. Only use when the address is a short address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_CHECK_SRC_ADDR | Overloaded.
Top

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor

UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_CHECK_SRC_ADDR | Constructor
Public method | UTIL_SRC_MATCH_CHECK_SRC_ADDR (UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE, UInt64, UInt16) |

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor ()

UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR()
C++
public:
UTIL_SRC_MATCH_CHECK_SRC_ADDR() sealed
J#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR()
JScript
public function UTIL_SRC_MATCH_CHECK_SRC_ADDR()

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor Overload List


UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor (UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE, UInt64, UInt16)

UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor (UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE, UInt64, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16 _
)
C#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR(
UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE ,
ulong ,
ushort
)
C++
public:
UTIL_SRC_MATCH_CHECK_SRC_ADDR(
UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short
) sealed
J#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR(
UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE ,
ulong ,
ushort
)
JScript
public function UTIL_SRC_MATCH_CHECK_SRC_ADDR(
: UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE,
: UInt64,
: UInt16
)

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_CHECK_SRC_ADDR Constructor Overload List


Fields

UTIL_SRC_MATCH_CHECK_SRC_ADDR Fields
[image]

Public Fields

 | Name | Description
Public field | Address | Address of the device that will be checked - Can be short or extended depends on the address mode.
Public field | AddressMode | Specifies the format of the device address that will be checked.
Public field | PanID | PAN ID of the device. Only use when the address is a short address.
Top

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace


Address Field

UTIL_SRC_MATCH_CHECK_SRC_ADDR.Address Field
[image]

Address of the device that will be checked - Can be short or extended depends on the address mode.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Address As UInt64
C#
public ulong Address;
C++
public:
unsigned __int64 Address sealed ;
J#
public ulong Address
JScript
public Address : UInt64;

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace


AddressMode Field

UTIL_SRC_MATCH_CHECK_SRC_ADDR.AddressMode Field
[image]

Specifies the format of the device address that will be checked.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddressMode As UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE
C#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE AddressMode;
C++
public:
UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE AddressMode sealed ;
J#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE AddressMode
JScript
public AddressMode : UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE;

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace


PanID Field

UTIL_SRC_MATCH_CHECK_SRC_ADDR.PanID Field
[image]

PAN ID of the device. Only use when the address is a short address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE Enumeration

UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE As Byte
C#
public enum UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE : byte
C++
public enum class UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE : char
J#
public enum UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE byte
JScript
public enum UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SRC_MATCH_CHECK_SRC_ADDR

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Members

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SRC_MATCH_CHECK_SRC_ADDR

The following tables list the members exposed by UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.

Public Constructors

Name | Description
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Index | Index where the address is found
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE | Overloaded.
Top

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE | Constructor
Public method | UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE (UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS, Byte) |

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor ()

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE()
C++
public:
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE() sealed
J#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE()
JScript
public function UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE()

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor Overload List


UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor (UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS, Byte)

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor (UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS, _
ByVal As Byte _
)
C#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE(
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS ,
byte
)
C++
public:
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE(
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS ,
char
) sealed
J#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE(
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS ,
byte
)
JScript
public function UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE(
: UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS,
: Byte
)

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Constructor Overload List


Fields

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Index | Index where the address is found
Public field | Status | Status
Top

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
TI.ZPI2 Namespace


Index Field

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.Index Field
[image]

Index where the address is found

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index As Byte
C#
public byte Index;
C++
public:
char Index sealed ;
J#
public byte Index
JScript
public Index : Byte;

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS
C#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS;

See Also

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS Enumeration

UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS Enumeration
See Also Example
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY Class

UTIL_SRC_MATCH_DELETE_ENTRY Class
See Also Example Members
[image]

Delete a short or extended address to source address table

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_DELETE_ENTRY
Implements IREQUEST, IUTIL
C#
public class UTIL_SRC_MATCH_DELETE_ENTRY : IREQUEST, IUTIL
C++
ref class UTIL_SRC_MATCH_DELETE_ENTRY : IREQUEST, IUTIL
J#
public class UTIL_SRC_MATCH_DELETE_ENTRY implements IREQUEST, IUTIL
JScript
public class UTIL_SRC_MATCH_DELETE_ENTRY extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY Members

UTIL_SRC_MATCH_DELETE_ENTRY Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Delete a short or extended address to source address table

The following tables list the members exposed by UTIL_SRC_MATCH_DELETE_ENTRY.

Public Constructors

Name | Description
UTIL_SRC_MATCH_DELETE_ENTRY | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Address | Address of the device that will be deleted - Can be short or extended depends on the address mode.
Public field | AddressMode | Specifies the format of the device address that will be deleted.
Public field | PanID | PAN ID of the device. Only use when the address is a short address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_DELETE_ENTRY | Overloaded.
Top

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY Constructor

UTIL_SRC_MATCH_DELETE_ENTRY Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_DELETE_ENTRY | Constructor
Public method | UTIL_SRC_MATCH_DELETE_ENTRY (UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE, UInt64, UInt16) |

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY Constructor ()

UTIL_SRC_MATCH_DELETE_ENTRY Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_DELETE_ENTRY()
C++
public:
UTIL_SRC_MATCH_DELETE_ENTRY() sealed
J#
public UTIL_SRC_MATCH_DELETE_ENTRY()
JScript
public function UTIL_SRC_MATCH_DELETE_ENTRY()

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_DELETE_ENTRY Constructor Overload List


UTIL_SRC_MATCH_DELETE_ENTRY Constructor (UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE, UInt64, UInt16)

UTIL_SRC_MATCH_DELETE_ENTRY Constructor (UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE, UInt64, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16 _
)
C#
public UTIL_SRC_MATCH_DELETE_ENTRY(
UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE ,
ulong ,
ushort
)
C++
public:
UTIL_SRC_MATCH_DELETE_ENTRY(
UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short
) sealed
J#
public UTIL_SRC_MATCH_DELETE_ENTRY(
UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE ,
ulong ,
ushort
)
JScript
public function UTIL_SRC_MATCH_DELETE_ENTRY(
: UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE,
: UInt64,
: UInt16
)

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_DELETE_ENTRY Constructor Overload List


Fields

UTIL_SRC_MATCH_DELETE_ENTRY Fields
[image]

Public Fields

 | Name | Description
Public field | Address | Address of the device that will be deleted - Can be short or extended depends on the address mode.
Public field | AddressMode | Specifies the format of the device address that will be deleted.
Public field | PanID | PAN ID of the device. Only use when the address is a short address.
Top

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace


Address Field

UTIL_SRC_MATCH_DELETE_ENTRY.Address Field
[image]

Address of the device that will be deleted - Can be short or extended depends on the address mode.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Address As UInt64
C#
public ulong Address;
C++
public:
unsigned __int64 Address sealed ;
J#
public ulong Address
JScript
public Address : UInt64;

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace


AddressMode Field

UTIL_SRC_MATCH_DELETE_ENTRY.AddressMode Field
[image]

Specifies the format of the device address that will be deleted.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddressMode As UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE
C#
public UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE AddressMode;
C++
public:
UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE AddressMode sealed ;
J#
public UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE AddressMode
JScript
public AddressMode : UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE;

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace


PanID Field

UTIL_SRC_MATCH_DELETE_ENTRY.PanID Field
[image]

PAN ID of the device. Only use when the address is a short address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

UTIL_SRC_MATCH_DELETE_ENTRY Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE Enumeration

UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE As Byte
C#
public enum UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE : byte
C++
public enum class UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE : char
J#
public enum UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE byte
JScript
public enum UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SRC_MATCH_DELETE_ENTRY

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Members

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SRC_MATCH_DELETE_ENTRY

The following tables list the members exposed by UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.

Public Constructors

Name | Description
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE | Overloaded.
Top

See Also

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE | Constructor
Public method | UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE (UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS) |

See Also

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor ()

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE()
C++
public:
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE() sealed
J#
public UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE()
JScript
public function UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE()

See Also

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor Overload List


UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor (UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS)

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor (UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE(
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE(
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE(
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE(
: UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS
)

See Also

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Constructor Overload List


Fields

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS
C#
public UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS;

See Also

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS Enumeration

UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE Class

UTIL_SRC_MATCH_ENABLE Class
See Also Example Members
[image]

Enabled AUTOPEND and source address matching.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_ENABLE
Implements IREQUEST, IUTIL
C#
public class UTIL_SRC_MATCH_ENABLE : IREQUEST, IUTIL
C++
ref class UTIL_SRC_MATCH_ENABLE : IREQUEST, IUTIL
J#
public class UTIL_SRC_MATCH_ENABLE implements IREQUEST, IUTIL
JScript
public class UTIL_SRC_MATCH_ENABLE extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_ENABLE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_ENABLE Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE Members

UTIL_SRC_MATCH_ENABLE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Enabled AUTOPEND and source address matching.

The following tables list the members exposed by UTIL_SRC_MATCH_ENABLE.

Public Constructors

Name | Description
UTIL_SRC_MATCH_ENABLE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AddrType | Type of address that the application uses (2-Short and 3-Extended).
Public field | NumEntries | Number of source address table entries to be used.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_ENABLE | Overloaded.
Top

See Also

UTIL_SRC_MATCH_ENABLE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE Constructor

UTIL_SRC_MATCH_ENABLE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_ENABLE | Constructor
Public method | UTIL_SRC_MATCH_ENABLE (UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE, Byte) |

See Also

UTIL_SRC_MATCH_ENABLE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE Constructor ()

UTIL_SRC_MATCH_ENABLE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_ENABLE()
C++
public:
UTIL_SRC_MATCH_ENABLE() sealed
J#
public UTIL_SRC_MATCH_ENABLE()
JScript
public function UTIL_SRC_MATCH_ENABLE()

See Also

UTIL_SRC_MATCH_ENABLE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ENABLE Constructor Overload List


UTIL_SRC_MATCH_ENABLE Constructor (UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE, Byte)

UTIL_SRC_MATCH_ENABLE Constructor (UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE, _
ByVal As Byte _
)
C#
public UTIL_SRC_MATCH_ENABLE(
UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE ,
byte
)
C++
public:
UTIL_SRC_MATCH_ENABLE(
UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE ,
char
) sealed
J#
public UTIL_SRC_MATCH_ENABLE(
UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE ,
byte
)
JScript
public function UTIL_SRC_MATCH_ENABLE(
: UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE,
: Byte
)

See Also

UTIL_SRC_MATCH_ENABLE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ENABLE Constructor Overload List


Fields

UTIL_SRC_MATCH_ENABLE Fields
[image]

Public Fields

 | Name | Description
Public field | AddrType | Type of address that the application uses (2-Short and 3-Extended).
Public field | NumEntries | Number of source address table entries to be used.
Top

See Also

UTIL_SRC_MATCH_ENABLE Class
TI.ZPI2 Namespace


AddrType Field

UTIL_SRC_MATCH_ENABLE.AddrType Field
[image]

Type of address that the application uses (2-Short and 3-Extended).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddrType As UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE
C#
public UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE AddrType;
C++
public:
UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE AddrType sealed ;
J#
public UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE AddrType
JScript
public AddrType : UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE;

See Also

UTIL_SRC_MATCH_ENABLE Class
TI.ZPI2 Namespace


NumEntries Field

UTIL_SRC_MATCH_ENABLE.NumEntries Field
[image]

Number of source address table entries to be used.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumEntries As Byte
C#
public byte NumEntries;
C++
public:
char NumEntries sealed ;
J#
public byte NumEntries
JScript
public NumEntries : Byte;

See Also

UTIL_SRC_MATCH_ENABLE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE Enumeration

UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE Enumeration
[image]

Address types used in AutoPend

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE As Byte
C#
public enum UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE : byte
C++
public enum class UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE : char
J#
public enum UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE byte
JScript
public enum UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE :

Members

Member Name | Description
0x00 (UNDEFINED) | Address types used in AutoPend
0x02 (SHORT_ADDRESS) | Address types used in AutoPend
0x03 (EXTENDED_ADDRESS) | Address types used in AutoPend

See Also

TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE_RESPONSE Class

UTIL_SRC_MATCH_ENABLE_RESPONSE Class
See Also Example Members
[image]

Response for UTIL_SRC_MATCH_ENABLE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRC_MATCH_ENABLE_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SRC_MATCH_ENABLE_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SRC_MATCH_ENABLE_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SRC_MATCH_ENABLE_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SRC_MATCH_ENABLE_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRC_MATCH_ENABLE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRC_MATCH_ENABLE_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE_RESPONSE Members

UTIL_SRC_MATCH_ENABLE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for UTIL_SRC_MATCH_ENABLE

The following tables list the members exposed by UTIL_SRC_MATCH_ENABLE_RESPONSE.

Public Constructors

Name | Description
UTIL_SRC_MATCH_ENABLE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRC_MATCH_ENABLE_RESPONSE | Overloaded.
Top

See Also

UTIL_SRC_MATCH_ENABLE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor

UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRC_MATCH_ENABLE_RESPONSE | Constructor
Public method | UTIL_SRC_MATCH_ENABLE_RESPONSE (UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS) |

See Also

UTIL_SRC_MATCH_ENABLE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor ()

UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRC_MATCH_ENABLE_RESPONSE()
C++
public:
UTIL_SRC_MATCH_ENABLE_RESPONSE() sealed
J#
public UTIL_SRC_MATCH_ENABLE_RESPONSE()
JScript
public function UTIL_SRC_MATCH_ENABLE_RESPONSE()

See Also

UTIL_SRC_MATCH_ENABLE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor Overload List


UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor (UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS)

UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor (UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SRC_MATCH_ENABLE_RESPONSE(
UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SRC_MATCH_ENABLE_RESPONSE(
UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SRC_MATCH_ENABLE_RESPONSE(
UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SRC_MATCH_ENABLE_RESPONSE(
: UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS
)

See Also

UTIL_SRC_MATCH_ENABLE_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRC_MATCH_ENABLE_RESPONSE Constructor Overload List


Fields

UTIL_SRC_MATCH_ENABLE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SRC_MATCH_ENABLE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SRC_MATCH_ENABLE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS
C#
public UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS;

See Also

UTIL_SRC_MATCH_ENABLE_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS Enumeration

UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_SRNG_GEN Class

UTIL_SRNG_GEN Class
See Also Example Members
[image]

Generate secure random number generator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRNG_GEN
Implements IREQUEST, IUTIL
C#
public class UTIL_SRNG_GEN : IREQUEST, IUTIL
C++
ref class UTIL_SRNG_GEN : IREQUEST, IUTIL
J#
public class UTIL_SRNG_GEN implements IREQUEST, IUTIL
JScript
public class UTIL_SRNG_GEN extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRNG_GEN

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRNG_GEN Members
TI.ZPI2 Namespace


UTIL_SRNG_GEN Members

UTIL_SRNG_GEN Members
See Also Example Constructors Methods
[image]

Generate secure random number generator

The following tables list the members exposed by UTIL_SRNG_GEN.

Public Constructors

 | Name | Description
Public method | UTIL_SRNG_GEN | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UTIL_SRNG_GEN Class
TI.ZPI2 Namespace


UTIL_SRNG_GEN Constructor

UTIL_SRNG_GEN Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRNG_GEN()
C++
public:
UTIL_SRNG_GEN() sealed
J#
public UTIL_SRNG_GEN()
JScript
public function UTIL_SRNG_GEN()

See Also

UTIL_SRNG_GEN Class
TI.ZPI2 Namespace


UTIL_SRNG_GEN_RESPONSE Class

UTIL_SRNG_GEN_RESPONSE Class
See Also Example Members
[image]

Response for Generate secure random number generator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_SRNG_GEN_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_SRNG_GEN_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_SRNG_GEN_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_SRNG_GEN_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_SRNG_GEN_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_SRNG_GEN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_SRNG_GEN_RESPONSE Members
TI.ZPI2 Namespace


UTIL_SRNG_GEN_RESPONSE Members

UTIL_SRNG_GEN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for Generate secure random number generator

The following tables list the members exposed by UTIL_SRNG_GEN_RESPONSE.

Public Constructors

Name | Description
UTIL_SRNG_GEN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_SRNG_GEN_RESPONSE | Overloaded.
Top

See Also

UTIL_SRNG_GEN_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRNG_GEN_RESPONSE Constructor

UTIL_SRNG_GEN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_SRNG_GEN_RESPONSE | Constructor
Public method | UTIL_SRNG_GEN_RESPONSE (UTIL_SRNG_GEN_RESPONSE.CMD_STATUS) |

See Also

UTIL_SRNG_GEN_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRNG_GEN_RESPONSE Constructor ()

UTIL_SRNG_GEN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_SRNG_GEN_RESPONSE()
C++
public:
UTIL_SRNG_GEN_RESPONSE() sealed
J#
public UTIL_SRNG_GEN_RESPONSE()
JScript
public function UTIL_SRNG_GEN_RESPONSE()

See Also

UTIL_SRNG_GEN_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRNG_GEN_RESPONSE Constructor Overload List


UTIL_SRNG_GEN_RESPONSE Constructor (UTIL_SRNG_GEN_RESPONSE.CMD_STATUS)

UTIL_SRNG_GEN_RESPONSE Constructor (UTIL_SRNG_GEN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_SRNG_GEN_RESPONSE.CMD_STATUS _
)
C#
public UTIL_SRNG_GEN_RESPONSE(
UTIL_SRNG_GEN_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_SRNG_GEN_RESPONSE(
UTIL_SRNG_GEN_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_SRNG_GEN_RESPONSE(
UTIL_SRNG_GEN_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_SRNG_GEN_RESPONSE(
: UTIL_SRNG_GEN_RESPONSE.CMD_STATUS
)

See Also

UTIL_SRNG_GEN_RESPONSE Class
TI.ZPI2 Namespace
UTIL_SRNG_GEN_RESPONSE Constructor Overload List


Fields

UTIL_SRNG_GEN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_SRNG_GEN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_SRNG_GEN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_SRNG_GEN_RESPONSE.CMD_STATUS
C#
public UTIL_SRNG_GEN_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_SRNG_GEN_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_SRNG_GEN_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_SRNG_GEN_RESPONSE.CMD_STATUS;

See Also

UTIL_SRNG_GEN_RESPONSE Class
TI.ZPI2 Namespace


UTIL_SRNG_GEN_RESPONSE.CMD_STATUS Enumeration

UTIL_SRNG_GEN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_SRNG_GEN_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_SRNG_GEN_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_SRNG_GEN_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_SRNG_GEN_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_SRNG_GEN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_TEST_LOOPBACK Class

UTIL_TEST_LOOPBACK Class
See Also Example Members
[image]

Use this message to receive an echo or loopback of the data bytes sent.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_TEST_LOOPBACK
Implements IREQUEST, IUTIL
C#
public class UTIL_TEST_LOOPBACK : IREQUEST, IUTIL
C++
ref class UTIL_TEST_LOOPBACK : IREQUEST, IUTIL
J#
public class UTIL_TEST_LOOPBACK implements IREQUEST, IUTIL
JScript
public class UTIL_TEST_LOOPBACK extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_TEST_LOOPBACK

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_TEST_LOOPBACK Members
TI.ZPI2 Namespace


UTIL_TEST_LOOPBACK Members

UTIL_TEST_LOOPBACK Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to receive an echo or loopback of the data bytes sent.

The following tables list the members exposed by UTIL_TEST_LOOPBACK.

Public Constructors

Name | Description
UTIL_TEST_LOOPBACK | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DataBuf | The data bytes to be looped back.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_TEST_LOOPBACK | Overloaded.
Top

See Also

UTIL_TEST_LOOPBACK Class
TI.ZPI2 Namespace


UTIL_TEST_LOOPBACK Constructor

UTIL_TEST_LOOPBACK Constructor

Overload List

 | Name | Description
Public method | UTIL_TEST_LOOPBACK | Constructor
Public method | UTIL_TEST_LOOPBACK (Byte) | Constructor

See Also

UTIL_TEST_LOOPBACK Class
TI.ZPI2 Namespace


UTIL_TEST_LOOPBACK Constructor ()

UTIL_TEST_LOOPBACK Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_TEST_LOOPBACK()
C++
public:
UTIL_TEST_LOOPBACK() sealed
J#
public UTIL_TEST_LOOPBACK()
JScript
public function UTIL_TEST_LOOPBACK()

See Also

UTIL_TEST_LOOPBACK Class
TI.ZPI2 Namespace
UTIL_TEST_LOOPBACK Constructor Overload List


UTIL_TEST_LOOPBACK Constructor (Byte[])

UTIL_TEST_LOOPBACK Constructor (Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte() _
)
C#
public UTIL_TEST_LOOPBACK(
byte[]
)
C++
public:
UTIL_TEST_LOOPBACK(
array<char>^
) sealed
J#
public UTIL_TEST_LOOPBACK(
byte[]
)
JScript
public function UTIL_TEST_LOOPBACK(
: Byte[]
)

See Also

UTIL_TEST_LOOPBACK Class
TI.ZPI2 Namespace
UTIL_TEST_LOOPBACK Constructor Overload List


Fields

UTIL_TEST_LOOPBACK Fields
[image]

Public Fields

 | Name | Description
Public field | DataBuf | The data bytes to be looped back.
Top

See Also

UTIL_TEST_LOOPBACK Class
TI.ZPI2 Namespace


DataBuf Field

UTIL_TEST_LOOPBACK.DataBuf Field
[image]

The data bytes to be looped back.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DataBuf As Byte()
C#
public byte[] DataBuf;
C++
public:
array<char>^ DataBuf sealed ;
J#
public byte[] DataBuf
JScript
public DataBuf : Byte[];

See Also

UTIL_TEST_LOOPBACK Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST Class

UTIL_ZCL_KEY_EST_INIT_EST Class
See Also Example Members
[image]

Use this message to proxy a call to the zclGeneral_KeyEstablish_InitiateKeyEstablishment() function.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ZCL_KEY_EST_INIT_EST
Implements IREQUEST, IUTIL
C#
public class UTIL_ZCL_KEY_EST_INIT_EST : IREQUEST, IUTIL
C++
ref class UTIL_ZCL_KEY_EST_INIT_EST : IREQUEST, IUTIL
J#
public class UTIL_ZCL_KEY_EST_INIT_EST implements IREQUEST, IUTIL
JScript
public class UTIL_ZCL_KEY_EST_INIT_EST extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ZCL_KEY_EST_INIT_EST Members
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST Members

UTIL_ZCL_KEY_EST_INIT_EST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to proxy a call to the zclGeneral_KeyEstablish_InitiateKeyEstablishment() function.

The following tables list the members exposed by UTIL_ZCL_KEY_EST_INIT_EST.

Public Constructors

Name | Description
UTIL_ZCL_KEY_EST_INIT_EST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AddrMode | The destination address mode according to afAddrMode_t.
Public field | EndPoint | The endpoint on the partner.
Public field | ExtAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SeqNum | The sequence number of the request.
Public field | TaskId | The OSAL Task ID making the request.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ZCL_KEY_EST_INIT_EST | Overloaded.
Top

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST Constructor

UTIL_ZCL_KEY_EST_INIT_EST Constructor

Overload List

 | Name | Description
Public method | UTIL_ZCL_KEY_EST_INIT_EST | Constructor
Public method | UTIL_ZCL_KEY_EST_INIT_EST (Byte, Byte, Byte, UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE, Byte) |

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST Constructor ()

UTIL_ZCL_KEY_EST_INIT_EST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ZCL_KEY_EST_INIT_EST()
C++
public:
UTIL_ZCL_KEY_EST_INIT_EST() sealed
J#
public UTIL_ZCL_KEY_EST_INIT_EST()
JScript
public function UTIL_ZCL_KEY_EST_INIT_EST()

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_INIT_EST Constructor Overload List


UTIL_ZCL_KEY_EST_INIT_EST Constructor (Byte, Byte, Byte, UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE, Byte[])

UTIL_ZCL_KEY_EST_INIT_EST Constructor (Byte, Byte, Byte, UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE, _
ByVal As Byte() _
)
C#
public UTIL_ZCL_KEY_EST_INIT_EST(
byte ,
byte ,
byte ,
UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE ,
byte[]
)
C++
public:
UTIL_ZCL_KEY_EST_INIT_EST(
char ,
char ,
char ,
UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE ,
array<char>^
) sealed
J#
public UTIL_ZCL_KEY_EST_INIT_EST(
byte ,
byte ,
byte ,
UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE ,
byte[]
)
JScript
public function UTIL_ZCL_KEY_EST_INIT_EST(
: Byte,
: Byte,
: Byte,
: UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE,
: Byte[]
)

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_INIT_EST Constructor Overload List


Fields

UTIL_ZCL_KEY_EST_INIT_EST Fields
[image]

Public Fields

 | Name | Description
Public field | AddrMode | The destination address mode according to afAddrMode_t.
Public field | EndPoint | The endpoint on the partner.
Public field | ExtAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SeqNum | The sequence number of the request.
Public field | TaskId | The OSAL Task ID making the request.
Top

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


AddrMode Field

UTIL_ZCL_KEY_EST_INIT_EST.AddrMode Field
[image]

The destination address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddrMode As UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE
C#
public UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE AddrMode;
C++
public:
UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE AddrMode sealed ;
J#
public UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE AddrMode
JScript
public AddrMode : UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE;

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


EndPoint Field

UTIL_ZCL_KEY_EST_INIT_EST.EndPoint Field
[image]

The endpoint on the partner.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public EndPoint As Byte
C#
public byte EndPoint;
C++
public:
char EndPoint sealed ;
J#
public byte EndPoint
JScript
public EndPoint : Byte;

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


ExtAddr Field

UTIL_ZCL_KEY_EST_INIT_EST.ExtAddr Field
[image]

The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As Byte()
C#
public byte[] ExtAddr;
C++
public:
array<char>^ ExtAddr sealed ;
J#
public byte[] ExtAddr
JScript
public ExtAddr : Byte[];

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


SeqNum Field

UTIL_ZCL_KEY_EST_INIT_EST.SeqNum Field
[image]

The sequence number of the request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SeqNum As Byte
C#
public byte SeqNum;
C++
public:
char SeqNum sealed ;
J#
public byte SeqNum
JScript
public SeqNum : Byte;

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


TaskId Field

UTIL_ZCL_KEY_EST_INIT_EST.TaskId Field
[image]

The OSAL Task ID making the request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TaskId As Byte
C#
public byte TaskId;
C++
public:
char TaskId sealed ;
J#
public byte TaskId
JScript
public TaskId : Byte;

See Also

UTIL_ZCL_KEY_EST_INIT_EST Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE Enumeration

UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE As Byte
C#
public enum UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE : byte
C++
public enum class UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE : char
J#
public enum UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE byte
JScript
public enum UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from zclGeneral_KeyEstablish_InitiateKeyEstablishment().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Members
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Members

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from zclGeneral_KeyEstablish_InitiateKeyEstablishment().

The following tables list the members exposed by UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.

Public Constructors

Name | Description
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE | Overloaded.
Top

See Also

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE | Constructor
Public method | UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE (UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS) |

See Also

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor ()

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE()
C++
public:
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE() sealed
J#
public UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE()
JScript
public function UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE()

See Also

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor Overload List


UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor (UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS)

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor (UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS _
)
C#
public UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE(
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS
)
C++
public:
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE(
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS
) sealed
J#
public UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE(
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS
)
JScript
public function UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE(
: UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS
)

See Also

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Constructor Overload List


Fields

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS
C#
public UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS;

See Also

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS Enumeration

UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN Class

UTIL_ZCL_KEY_EST_SIGN Class
See Also Example Members
[image]

Use this message to proxy a call to the zclGeneral_KeyEstablishment_ECDSASign() function.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ZCL_KEY_EST_SIGN
Implements IREQUEST, IUTIL
C#
public class UTIL_ZCL_KEY_EST_SIGN : IREQUEST, IUTIL
C++
ref class UTIL_ZCL_KEY_EST_SIGN : IREQUEST, IUTIL
J#
public class UTIL_ZCL_KEY_EST_SIGN implements IREQUEST, IUTIL
JScript
public class UTIL_ZCL_KEY_EST_SIGN extends IREQUEST, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ZCL_KEY_EST_SIGN Members
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN Members

UTIL_ZCL_KEY_EST_SIGN Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Use this message to proxy a call to the zclGeneral_KeyEstablishment_ECDSASign() function.

The following tables list the members exposed by UTIL_ZCL_KEY_EST_SIGN.

Public Constructors

Name | Description
UTIL_ZCL_KEY_EST_SIGN | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Input | The input data (length according to InputLen).
Public field | InputLen | The length of the input data.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ZCL_KEY_EST_SIGN | Overloaded.
Top

See Also

UTIL_ZCL_KEY_EST_SIGN Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN Constructor

UTIL_ZCL_KEY_EST_SIGN Constructor

Overload List

 | Name | Description
Public method | UTIL_ZCL_KEY_EST_SIGN | Constructor
Public method | UTIL_ZCL_KEY_EST_SIGN (Byte, Byte) | Constructor

See Also

UTIL_ZCL_KEY_EST_SIGN Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN Constructor ()

UTIL_ZCL_KEY_EST_SIGN Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ZCL_KEY_EST_SIGN()
C++
public:
UTIL_ZCL_KEY_EST_SIGN() sealed
J#
public UTIL_ZCL_KEY_EST_SIGN()
JScript
public function UTIL_ZCL_KEY_EST_SIGN()

See Also

UTIL_ZCL_KEY_EST_SIGN Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_SIGN Constructor Overload List


UTIL_ZCL_KEY_EST_SIGN Constructor (Byte, Byte[])

UTIL_ZCL_KEY_EST_SIGN Constructor (Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public UTIL_ZCL_KEY_EST_SIGN(
byte ,
byte[]
)
C++
public:
UTIL_ZCL_KEY_EST_SIGN(
char ,
array<char>^
) sealed
J#
public UTIL_ZCL_KEY_EST_SIGN(
byte ,
byte[]
)
JScript
public function UTIL_ZCL_KEY_EST_SIGN(
: Byte,
: Byte[]
)

See Also

UTIL_ZCL_KEY_EST_SIGN Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_SIGN Constructor Overload List


Fields

UTIL_ZCL_KEY_EST_SIGN Fields
[image]

Public Fields

 | Name | Description
Public field | Input | The input data (length according to InputLen).
Public field | InputLen | The length of the input data.
Top

See Also

UTIL_ZCL_KEY_EST_SIGN Class
TI.ZPI2 Namespace


Input Field

UTIL_ZCL_KEY_EST_SIGN.Input Field
[image]

The input data (length according to InputLen).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Input As Byte()
C#
public byte[] Input;
C++
public:
array<char>^ Input sealed ;
J#
public byte[] Input
JScript
public Input : Byte[];

See Also

UTIL_ZCL_KEY_EST_SIGN Class
TI.ZPI2 Namespace


InputLen Field

UTIL_ZCL_KEY_EST_SIGN.InputLen Field
[image]

The length of the input data.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InputLen As Byte
C#
public byte InputLen;
C++
public:
char InputLen sealed ;
J#
public byte InputLen
JScript
public InputLen : Byte;

See Also

UTIL_ZCL_KEY_EST_SIGN Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
See Also Example Members
[image]

This is the RPC proxy response from zclGeneral_KeyEstablishment_ECDSASign().

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UTIL_ZCL_KEY_EST_SIGN_RESPONSE
Implements IRESPONSE, IUTIL
C#
public class UTIL_ZCL_KEY_EST_SIGN_RESPONSE : IRESPONSE, IUTIL
C++
ref class UTIL_ZCL_KEY_EST_SIGN_RESPONSE : IRESPONSE, IUTIL
J#
public class UTIL_ZCL_KEY_EST_SIGN_RESPONSE implements IRESPONSE, IUTIL
JScript
public class UTIL_ZCL_KEY_EST_SIGN_RESPONSE extends IRESPONSE, IUTIL

Inheritance Hierarchy

System.Object
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Members
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN_RESPONSE Members

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This is the RPC proxy response from zclGeneral_KeyEstablishment_ECDSASign().

The following tables list the members exposed by UTIL_ZCL_KEY_EST_SIGN_RESPONSE.

Public Constructors

Name | Description
UTIL_ZCL_KEY_EST_SIGN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Key | The output key on success.
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UTIL_ZCL_KEY_EST_SIGN_RESPONSE | Overloaded.
Top

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | UTIL_ZCL_KEY_EST_SIGN_RESPONSE | Constructor
Public method | UTIL_ZCL_KEY_EST_SIGN_RESPONSE (UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS, Byte) |

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor ()

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UTIL_ZCL_KEY_EST_SIGN_RESPONSE()
C++
public:
UTIL_ZCL_KEY_EST_SIGN_RESPONSE() sealed
J#
public UTIL_ZCL_KEY_EST_SIGN_RESPONSE()
JScript
public function UTIL_ZCL_KEY_EST_SIGN_RESPONSE()

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor Overload List


UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor (UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS, Byte[])

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor (UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS, _
ByVal As Byte() _
)
C#
public UTIL_ZCL_KEY_EST_SIGN_RESPONSE(
UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS ,
byte[]
)
C++
public:
UTIL_ZCL_KEY_EST_SIGN_RESPONSE(
UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS ,
array<char>^
) sealed
J#
public UTIL_ZCL_KEY_EST_SIGN_RESPONSE(
UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS ,
byte[]
)
JScript
public function UTIL_ZCL_KEY_EST_SIGN_RESPONSE(
: UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS,
: Byte[]
)

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
TI.ZPI2 Namespace
UTIL_ZCL_KEY_EST_SIGN_RESPONSE Constructor Overload List


Fields

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Key | The output key on success.
Public field | Status | Status
Top

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
TI.ZPI2 Namespace


Key Field

UTIL_ZCL_KEY_EST_SIGN_RESPONSE.Key Field
[image]

The output key on success.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Key As Byte()
C#
public byte[] Key;
C++
public:
array<char>^ Key sealed ;
J#
public byte[] Key
JScript
public Key : Byte[];

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

UTIL_ZCL_KEY_EST_SIGN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS
C#
public UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS Status;
C++
public:
UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS Status sealed ;
J#
public UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS Status
JScript
public Status : UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS;

See Also

UTIL_ZCL_KEY_EST_SIGN_RESPONSE Class
TI.ZPI2 Namespace


UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS Enumeration

UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS As Byte
C#
public enum UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS : byte
C++
public enum class UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS : char
J#
public enum UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS byte
JScript
public enum UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZB_ALLOW_BIND Class

ZB_ALLOW_BIND Class
See Also Example Members
[image]

Puts the device into the Allow Bind mode (zb_AllowBind).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_ALLOW_BIND
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_ALLOW_BIND : IREQUEST, ISIMPLEAPI
C++
ref class ZB_ALLOW_BIND : IREQUEST, ISIMPLEAPI
J#
public class ZB_ALLOW_BIND implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_ALLOW_BIND extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_ALLOW_BIND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_ALLOW_BIND Members
TI.ZPI2 Namespace


ZB_ALLOW_BIND Members

ZB_ALLOW_BIND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Puts the device into the Allow Bind mode (zb_AllowBind).

The following tables list the members exposed by ZB_ALLOW_BIND.

Public Constructors

Name | Description
ZB_ALLOW_BIND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Timeout | The number of seconds ( max. 64 ) for which the device will remain in the Allow Bind mode ( If 0, the device will turn off Allow Bind mode immediately. If 0xFF, the device will remain in the mode indefinitely. )
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_ALLOW_BIND | Overloaded.
Top

See Also

ZB_ALLOW_BIND Class
TI.ZPI2 Namespace


ZB_ALLOW_BIND Constructor

ZB_ALLOW_BIND Constructor

Overload List

 | Name | Description
Public method | ZB_ALLOW_BIND | Constructor
Public method | ZB_ALLOW_BIND (Byte) | Constructor

See Also

ZB_ALLOW_BIND Class
TI.ZPI2 Namespace


ZB_ALLOW_BIND Constructor ()

ZB_ALLOW_BIND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_ALLOW_BIND()
C++
public:
ZB_ALLOW_BIND() sealed
J#
public ZB_ALLOW_BIND()
JScript
public function ZB_ALLOW_BIND()

See Also

ZB_ALLOW_BIND Class
TI.ZPI2 Namespace
ZB_ALLOW_BIND Constructor Overload List


ZB_ALLOW_BIND Constructor (Byte)

ZB_ALLOW_BIND Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_ALLOW_BIND(
byte
)
C++
public:
ZB_ALLOW_BIND(
char
) sealed
J#
public ZB_ALLOW_BIND(
byte
)
JScript
public function ZB_ALLOW_BIND(
: Byte
)

See Also

ZB_ALLOW_BIND Class
TI.ZPI2 Namespace
ZB_ALLOW_BIND Constructor Overload List


Fields

ZB_ALLOW_BIND Fields
[image]

Public Fields

 | Name | Description
Public field | Timeout | The number of seconds ( max. 64 ) for which the device will remain in the Allow Bind mode ( If 0, the device will turn off Allow Bind mode immediately. If 0xFF, the device will remain in the mode indefinitely. )
Top

See Also

ZB_ALLOW_BIND Class
TI.ZPI2 Namespace


Timeout Field

ZB_ALLOW_BIND.Timeout Field
[image]

The number of seconds ( max. 64 ) for which the device will remain in the Allow Bind mode ( If 0, the device will turn off Allow Bind mode immediately. If 0xFF, the device will remain in the mode indefinitely. )

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timeout As Byte
C#
public byte Timeout;
C++
public:
char Timeout sealed ;
J#
public byte Timeout
JScript
public Timeout : Byte;

See Also

ZB_ALLOW_BIND Class
TI.ZPI2 Namespace


ZB_ALLOW_BIND_CONFIRM Class

ZB_ALLOW_BIND_CONFIRM Class
See Also Example Members
[image]

Response for ZB_ALLOW_BIND

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_ALLOW_BIND_CONFIRM
Implements IRESPONSE_CALLBACK, ISIMPLEAPI
C#
public class ZB_ALLOW_BIND_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
C++
ref class ZB_ALLOW_BIND_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
J#
public class ZB_ALLOW_BIND_CONFIRM implements IRESPONSE_CALLBACK, ISIMPLEAPI
JScript
public class ZB_ALLOW_BIND_CONFIRM extends IRESPONSE_CALLBACK, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_ALLOW_BIND_CONFIRM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_ALLOW_BIND_CONFIRM Members
TI.ZPI2 Namespace


ZB_ALLOW_BIND_CONFIRM Members

ZB_ALLOW_BIND_CONFIRM Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_ALLOW_BIND

The following tables list the members exposed by ZB_ALLOW_BIND_CONFIRM.

Public Constructors

Name | Description
ZB_ALLOW_BIND_CONFIRM | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Source | Source
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_ALLOW_BIND_CONFIRM | Overloaded.
Top

See Also

ZB_ALLOW_BIND_CONFIRM Class
TI.ZPI2 Namespace


ZB_ALLOW_BIND_CONFIRM Constructor

ZB_ALLOW_BIND_CONFIRM Constructor

Overload List

 | Name | Description
Public method | ZB_ALLOW_BIND_CONFIRM | Constructor
Public method | ZB_ALLOW_BIND_CONFIRM (UInt16) | Constructor

See Also

ZB_ALLOW_BIND_CONFIRM Class
TI.ZPI2 Namespace


ZB_ALLOW_BIND_CONFIRM Constructor ()

ZB_ALLOW_BIND_CONFIRM Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_ALLOW_BIND_CONFIRM()
C++
public:
ZB_ALLOW_BIND_CONFIRM() sealed
J#
public ZB_ALLOW_BIND_CONFIRM()
JScript
public function ZB_ALLOW_BIND_CONFIRM()

See Also

ZB_ALLOW_BIND_CONFIRM Class
TI.ZPI2 Namespace
ZB_ALLOW_BIND_CONFIRM Constructor Overload List


ZB_ALLOW_BIND_CONFIRM Constructor (UInt16)

ZB_ALLOW_BIND_CONFIRM Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public ZB_ALLOW_BIND_CONFIRM(
ushort
)
C++
public:
ZB_ALLOW_BIND_CONFIRM(
unsigned short
) sealed
J#
public ZB_ALLOW_BIND_CONFIRM(
ushort
)
JScript
public function ZB_ALLOW_BIND_CONFIRM(
: UInt16
)

See Also

ZB_ALLOW_BIND_CONFIRM Class
TI.ZPI2 Namespace
ZB_ALLOW_BIND_CONFIRM Constructor Overload List


Fields

ZB_ALLOW_BIND_CONFIRM Fields
[image]

Public Fields

 | Name | Description
Public field | Source | Source
Top

See Also

ZB_ALLOW_BIND_CONFIRM Class
TI.ZPI2 Namespace


Source Field

ZB_ALLOW_BIND_CONFIRM.Source Field
[image]

Source

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Source As UInt16
C#
public ushort Source;
C++
public:
unsigned short Source sealed ;
J#
public ushort Source
JScript
public Source : UInt16;

See Also

ZB_ALLOW_BIND_CONFIRM Class
TI.ZPI2 Namespace


ZB_ALLOW_BIND_RSP Class

ZB_ALLOW_BIND_RSP Class
See Also Example Members
[image]

Response for ZB_ALLOW_BIND

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_ALLOW_BIND_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_ALLOW_BIND_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_ALLOW_BIND_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_ALLOW_BIND_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_ALLOW_BIND_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_ALLOW_BIND_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_ALLOW_BIND_RSP Members
TI.ZPI2 Namespace


ZB_ALLOW_BIND_RSP Members

ZB_ALLOW_BIND_RSP Members
See Also Example Constructors Methods
[image]

Response for ZB_ALLOW_BIND

The following tables list the members exposed by ZB_ALLOW_BIND_RSP.

Public Constructors

 | Name | Description
Public method | ZB_ALLOW_BIND_RSP | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI2 Namespace


ZB_ALLOW_BIND_RSP Constructor

ZB_ALLOW_BIND_RSP Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_ALLOW_BIND_RSP()
C++
public:
ZB_ALLOW_BIND_RSP() sealed
J#
public ZB_ALLOW_BIND_RSP()
JScript
public function ZB_ALLOW_BIND_RSP()

See Also

ZB_ALLOW_BIND_RSP Class
TI.ZPI2 Namespace


ZB_APP_REGISTER_REQUEST Class

ZB_APP_REGISTER_REQUEST Class
See Also Example Members
[image]

This command register the device descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_APP_REGISTER_REQUEST
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_APP_REGISTER_REQUEST : IREQUEST, ISIMPLEAPI
C++
ref class ZB_APP_REGISTER_REQUEST : IREQUEST, ISIMPLEAPI
J#
public class ZB_APP_REGISTER_REQUEST implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_APP_REGISTER_REQUEST extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_APP_REGISTER_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_APP_REGISTER_REQUEST Members
TI.ZPI2 Namespace


ZB_APP_REGISTER_REQUEST Members

ZB_APP_REGISTER_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command register the device descriptor

The following tables list the members exposed by ZB_APP_REGISTER_REQUEST.

Public Constructors

Name | Description
ZB_APP_REGISTER_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AppEndPoint | The endpoint of the device on which this application should reside ( value 1 through 240 ). This should be set to same value for all devices in this network.
Public field | AppProfileID | The profile id of the application. This should be set to same value for all devices in this network.
Public field | DeviceId | The device description id for this endpoint
Public field | DeviceVersion | The version of the device description
Public field | InputCommandsList | List of input commands that are processed by this device application
Public field | InputCommandsNum | The number of Input commands Ids following in the InputCommandsList
Public field | OutputCommandsList | List of output commands that are generated by this device application
Public field | OutputCommandsNum | The number of Output command Ids in the OutputCommandsList
Public field | Unused | Unused parameter
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_APP_REGISTER_REQUEST | Overloaded.
Top

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


ZB_APP_REGISTER_REQUEST Constructor

ZB_APP_REGISTER_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZB_APP_REGISTER_REQUEST | Constructor
Public method | ZB_APP_REGISTER_REQUEST (Byte, UInt16, UInt16, Byte, Byte, Byte, UInt16, Byte, UInt16) | Constructor

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


ZB_APP_REGISTER_REQUEST Constructor ()

ZB_APP_REGISTER_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_APP_REGISTER_REQUEST()
C++
public:
ZB_APP_REGISTER_REQUEST() sealed
J#
public ZB_APP_REGISTER_REQUEST()
JScript
public function ZB_APP_REGISTER_REQUEST()

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace
ZB_APP_REGISTER_REQUEST Constructor Overload List


ZB_APP_REGISTER_REQUEST Constructor (Byte, UInt16, UInt16, Byte, Byte, Byte, UInt16[], Byte, UInt16[])

ZB_APP_REGISTER_REQUEST Constructor (Byte, UInt16, UInt16, Byte, Byte, Byte, UInt16[], Byte, UInt16[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZB_APP_REGISTER_REQUEST(
byte ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
ushort[] ,
byte ,
ushort[]
)
C++
public:
ZB_APP_REGISTER_REQUEST(
char ,
unsigned short ,
unsigned short ,
char ,
char ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^
) sealed
J#
public ZB_APP_REGISTER_REQUEST(
byte ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
ushort[] ,
byte ,
ushort[]
)
JScript
public function ZB_APP_REGISTER_REQUEST(
: Byte,
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: UInt16[],
: Byte,
: UInt16[]
)

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace
ZB_APP_REGISTER_REQUEST Constructor Overload List


Fields

ZB_APP_REGISTER_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | AppEndPoint | The endpoint of the device on which this application should reside ( value 1 through 240 ). This should be set to same value for all devices in this network.
Public field | AppProfileID | The profile id of the application. This should be set to same value for all devices in this network.
Public field | DeviceId | The device description id for this endpoint
Public field | DeviceVersion | The version of the device description
Public field | InputCommandsList | List of input commands that are processed by this device application
Public field | InputCommandsNum | The number of Input commands Ids following in the InputCommandsList
Public field | OutputCommandsList | List of output commands that are generated by this device application
Public field | OutputCommandsNum | The number of Output command Ids in the OutputCommandsList
Public field | Unused | Unused parameter
Top

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


AppEndPoint Field

ZB_APP_REGISTER_REQUEST.AppEndPoint Field
[image]

The endpoint of the device on which this application should reside ( value 1 through 240 ). This should be set to same value for all devices in this network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppEndPoint As Byte
C#
public byte AppEndPoint;
C++
public:
char AppEndPoint sealed ;
J#
public byte AppEndPoint
JScript
public AppEndPoint : Byte;

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


AppProfileID Field

ZB_APP_REGISTER_REQUEST.AppProfileID Field
[image]

The profile id of the application. This should be set to same value for all devices in this network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AppProfileID As UInt16
C#
public ushort AppProfileID;
C++
public:
unsigned short AppProfileID sealed ;
J#
public ushort AppProfileID
JScript
public AppProfileID : UInt16;

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


DeviceId Field

ZB_APP_REGISTER_REQUEST.DeviceId Field
[image]

The device description id for this endpoint

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceId As UInt16
C#
public ushort DeviceId;
C++
public:
unsigned short DeviceId sealed ;
J#
public ushort DeviceId
JScript
public DeviceId : UInt16;

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


DeviceVersion Field

ZB_APP_REGISTER_REQUEST.DeviceVersion Field
[image]

The version of the device description

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceVersion As Byte
C#
public byte DeviceVersion;
C++
public:
char DeviceVersion sealed ;
J#
public byte DeviceVersion
JScript
public DeviceVersion : Byte;

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


InputCommandsList Field

ZB_APP_REGISTER_REQUEST.InputCommandsList Field
[image]

List of input commands that are processed by this device application

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InputCommandsList As UInt16()
C#
public ushort[] InputCommandsList;
C++
public:
array<unsigned short>^ InputCommandsList sealed ;
J#
public ushort[] InputCommandsList
JScript
public InputCommandsList : UInt16[];

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


InputCommandsNum Field

ZB_APP_REGISTER_REQUEST.InputCommandsNum Field
[image]

The number of Input commands Ids following in the InputCommandsList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InputCommandsNum As Byte
C#
public byte InputCommandsNum;
C++
public:
char InputCommandsNum sealed ;
J#
public byte InputCommandsNum
JScript
public InputCommandsNum : Byte;

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


OutputCommandsList Field

ZB_APP_REGISTER_REQUEST.OutputCommandsList Field
[image]

List of output commands that are generated by this device application

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutputCommandsList As UInt16()
C#
public ushort[] OutputCommandsList;
C++
public:
array<unsigned short>^ OutputCommandsList sealed ;
J#
public ushort[] OutputCommandsList
JScript
public OutputCommandsList : UInt16[];

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


OutputCommandsNum Field

ZB_APP_REGISTER_REQUEST.OutputCommandsNum Field
[image]

The number of Output command Ids in the OutputCommandsList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutputCommandsNum As Byte
C#
public byte OutputCommandsNum;
C++
public:
char OutputCommandsNum sealed ;
J#
public byte OutputCommandsNum
JScript
public OutputCommandsNum : Byte;

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


Unused Field

ZB_APP_REGISTER_REQUEST.Unused Field
[image]

Unused parameter

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Unused As Byte
C#
public byte Unused;
C++
public:
char Unused sealed ;
J#
public byte Unused
JScript
public Unused : Byte;

See Also

ZB_APP_REGISTER_REQUEST Class
TI.ZPI2 Namespace


ZB_APP_REGISTER_RSP Class

ZB_APP_REGISTER_RSP Class
See Also Example Members
[image]

Response for ZB_APP_REGISTER_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_APP_REGISTER_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_APP_REGISTER_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_APP_REGISTER_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_APP_REGISTER_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_APP_REGISTER_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_APP_REGISTER_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_APP_REGISTER_RSP Members
TI.ZPI2 Namespace


ZB_APP_REGISTER_RSP Members

ZB_APP_REGISTER_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_APP_REGISTER_REQUEST

The following tables list the members exposed by ZB_APP_REGISTER_RSP.

Public Constructors

Name | Description
ZB_APP_REGISTER_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_APP_REGISTER_RSP | Overloaded.
Top

See Also

ZB_APP_REGISTER_RSP Class
TI.ZPI2 Namespace


ZB_APP_REGISTER_RSP Constructor

ZB_APP_REGISTER_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_APP_REGISTER_RSP | Constructor
Public method | ZB_APP_REGISTER_RSP (ZB_APP_REGISTER_RSP.AF_STATUS) |

See Also

ZB_APP_REGISTER_RSP Class
TI.ZPI2 Namespace


ZB_APP_REGISTER_RSP Constructor ()

ZB_APP_REGISTER_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_APP_REGISTER_RSP()
C++
public:
ZB_APP_REGISTER_RSP() sealed
J#
public ZB_APP_REGISTER_RSP()
JScript
public function ZB_APP_REGISTER_RSP()

See Also

ZB_APP_REGISTER_RSP Class
TI.ZPI2 Namespace
ZB_APP_REGISTER_RSP Constructor Overload List


ZB_APP_REGISTER_RSP Constructor (ZB_APP_REGISTER_RSP.AF_STATUS)

ZB_APP_REGISTER_RSP Constructor (ZB_APP_REGISTER_RSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZB_APP_REGISTER_RSP.AF_STATUS _
)
C#
public ZB_APP_REGISTER_RSP(
ZB_APP_REGISTER_RSP.AF_STATUS
)
C++
public:
ZB_APP_REGISTER_RSP(
ZB_APP_REGISTER_RSP.AF_STATUS
) sealed
J#
public ZB_APP_REGISTER_RSP(
ZB_APP_REGISTER_RSP.AF_STATUS
)
JScript
public function ZB_APP_REGISTER_RSP(
: ZB_APP_REGISTER_RSP.AF_STATUS
)

See Also

ZB_APP_REGISTER_RSP Class
TI.ZPI2 Namespace
ZB_APP_REGISTER_RSP Constructor Overload List


Fields

ZB_APP_REGISTER_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZB_APP_REGISTER_RSP Class
TI.ZPI2 Namespace


Status Field

ZB_APP_REGISTER_RSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZB_APP_REGISTER_RSP.AF_STATUS
C#
public ZB_APP_REGISTER_RSP.AF_STATUS Status;
C++
public:
ZB_APP_REGISTER_RSP.AF_STATUS Status sealed ;
J#
public ZB_APP_REGISTER_RSP.AF_STATUS Status
JScript
public Status : ZB_APP_REGISTER_RSP.AF_STATUS;

See Also

ZB_APP_REGISTER_RSP Class
TI.ZPI2 Namespace


ZB_APP_REGISTER_RSP.AF_STATUS Enumeration

ZB_APP_REGISTER_RSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_APP_REGISTER_RSP.AF_STATUS As Byte
C#
public enum ZB_APP_REGISTER_RSP.AF_STATUS : byte
C++
public enum class ZB_APP_REGISTER_RSP.AF_STATUS : char
J#
public enum ZB_APP_REGISTER_RSP.AF_STATUS byte
JScript
public enum ZB_APP_REGISTER_RSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZB_BIND_CONFIRM Class

ZB_BIND_CONFIRM Class
See Also Example Members
[image]

Response for ZB_BIND_DEVICE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_BIND_CONFIRM
Implements IRESPONSE_CALLBACK, ISIMPLEAPI
C#
public class ZB_BIND_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
C++
ref class ZB_BIND_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
J#
public class ZB_BIND_CONFIRM implements IRESPONSE_CALLBACK, ISIMPLEAPI
JScript
public class ZB_BIND_CONFIRM extends IRESPONSE_CALLBACK, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_BIND_CONFIRM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_BIND_CONFIRM Members
TI.ZPI2 Namespace


ZB_BIND_CONFIRM Members

ZB_BIND_CONFIRM Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_BIND_DEVICE

The following tables list the members exposed by ZB_BIND_CONFIRM.

Public Constructors

Name | Description
ZB_BIND_CONFIRM | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CommandId | CommandId
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_BIND_CONFIRM | Overloaded.
Top

See Also

ZB_BIND_CONFIRM Class
TI.ZPI2 Namespace


ZB_BIND_CONFIRM Constructor

ZB_BIND_CONFIRM Constructor

Overload List

 | Name | Description
Public method | ZB_BIND_CONFIRM | Constructor
Public method | ZB_BIND_CONFIRM (UInt16, ZB_BIND_CONFIRM.CMD_STATUS) |

See Also

ZB_BIND_CONFIRM Class
TI.ZPI2 Namespace


ZB_BIND_CONFIRM Constructor ()

ZB_BIND_CONFIRM Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_BIND_CONFIRM()
C++
public:
ZB_BIND_CONFIRM() sealed
J#
public ZB_BIND_CONFIRM()
JScript
public function ZB_BIND_CONFIRM()

See Also

ZB_BIND_CONFIRM Class
TI.ZPI2 Namespace
ZB_BIND_CONFIRM Constructor Overload List


ZB_BIND_CONFIRM Constructor (UInt16, ZB_BIND_CONFIRM.CMD_STATUS)

ZB_BIND_CONFIRM Constructor (UInt16, ZB_BIND_CONFIRM.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZB_BIND_CONFIRM.CMD_STATUS _
)
C#
public ZB_BIND_CONFIRM(
ushort ,
ZB_BIND_CONFIRM.CMD_STATUS
)
C++
public:
ZB_BIND_CONFIRM(
unsigned short ,
ZB_BIND_CONFIRM.CMD_STATUS
) sealed
J#
public ZB_BIND_CONFIRM(
ushort ,
ZB_BIND_CONFIRM.CMD_STATUS
)
JScript
public function ZB_BIND_CONFIRM(
: UInt16,
: ZB_BIND_CONFIRM.CMD_STATUS
)

See Also

ZB_BIND_CONFIRM Class
TI.ZPI2 Namespace
ZB_BIND_CONFIRM Constructor Overload List


Fields

ZB_BIND_CONFIRM Fields
[image]

Public Fields

 | Name | Description
Public field | CommandId | CommandId
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_BIND_CONFIRM Class
TI.ZPI2 Namespace


CommandId Field

ZB_BIND_CONFIRM.CommandId Field
[image]

CommandId

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandId As UInt16
C#
public ushort CommandId;
C++
public:
unsigned short CommandId sealed ;
J#
public ushort CommandId
JScript
public CommandId : UInt16;

See Also

ZB_BIND_CONFIRM Class
TI.ZPI2 Namespace


Status Field

ZB_BIND_CONFIRM.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZB_BIND_CONFIRM.CMD_STATUS
C#
public ZB_BIND_CONFIRM.CMD_STATUS Status;
C++
public:
ZB_BIND_CONFIRM.CMD_STATUS Status sealed ;
J#
public ZB_BIND_CONFIRM.CMD_STATUS Status
JScript
public Status : ZB_BIND_CONFIRM.CMD_STATUS;

See Also

ZB_BIND_CONFIRM Class
TI.ZPI2 Namespace


ZB_BIND_CONFIRM.CMD_STATUS Enumeration

ZB_BIND_CONFIRM.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_BIND_CONFIRM.CMD_STATUS As Byte
C#
public enum ZB_BIND_CONFIRM.CMD_STATUS : byte
C++
public enum class ZB_BIND_CONFIRM.CMD_STATUS : char
J#
public enum ZB_BIND_CONFIRM.CMD_STATUS byte
JScript
public enum ZB_BIND_CONFIRM.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZB_BIND_DEVICE Class

ZB_BIND_DEVICE Class
See Also Example Members
[image]

Create or remove a binding entry (zb_BindDevice).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_BIND_DEVICE
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_BIND_DEVICE : IREQUEST, ISIMPLEAPI
C++
ref class ZB_BIND_DEVICE : IREQUEST, ISIMPLEAPI
J#
public class ZB_BIND_DEVICE implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_BIND_DEVICE extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_BIND_DEVICE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_BIND_DEVICE Members
TI.ZPI2 Namespace


ZB_BIND_DEVICE Members

ZB_BIND_DEVICE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Create or remove a binding entry (zb_BindDevice).

The following tables list the members exposed by ZB_BIND_DEVICE.

Public Constructors

Name | Description
ZB_BIND_DEVICE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Action | CREATE or DELETE a binding entry.
Public field | CommandId | The Command identifier of packets for this binding.
Public field | Destination | IEEE address of device to establish the binding with ( all zeros indicate NULL ).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_BIND_DEVICE | Overloaded.
Top

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace


ZB_BIND_DEVICE Constructor

ZB_BIND_DEVICE Constructor

Overload List

 | Name | Description
Public method | ZB_BIND_DEVICE | Constructor
Public method | ZB_BIND_DEVICE (ZB_BIND_DEVICE.BIND_ACTION_TYPE, UInt16, UInt64) |

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace


ZB_BIND_DEVICE Constructor ()

ZB_BIND_DEVICE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_BIND_DEVICE()
C++
public:
ZB_BIND_DEVICE() sealed
J#
public ZB_BIND_DEVICE()
JScript
public function ZB_BIND_DEVICE()

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace
ZB_BIND_DEVICE Constructor Overload List


ZB_BIND_DEVICE Constructor (ZB_BIND_DEVICE.BIND_ACTION_TYPE, UInt16, UInt64)

ZB_BIND_DEVICE Constructor (ZB_BIND_DEVICE.BIND_ACTION_TYPE, UInt16, UInt64)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZB_BIND_DEVICE.BIND_ACTION_TYPE, _
ByVal As UInt16, _
ByVal As UInt64 _
)
C#
public ZB_BIND_DEVICE(
ZB_BIND_DEVICE.BIND_ACTION_TYPE ,
ushort ,
ulong
)
C++
public:
ZB_BIND_DEVICE(
ZB_BIND_DEVICE.BIND_ACTION_TYPE ,
unsigned short ,
unsigned __int64
) sealed
J#
public ZB_BIND_DEVICE(
ZB_BIND_DEVICE.BIND_ACTION_TYPE ,
ushort ,
ulong
)
JScript
public function ZB_BIND_DEVICE(
: ZB_BIND_DEVICE.BIND_ACTION_TYPE,
: UInt16,
: UInt64
)

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace
ZB_BIND_DEVICE Constructor Overload List


Fields

ZB_BIND_DEVICE Fields
[image]

Public Fields

 | Name | Description
Public field | Action | CREATE or DELETE a binding entry.
Public field | CommandId | The Command identifier of packets for this binding.
Public field | Destination | IEEE address of device to establish the binding with ( all zeros indicate NULL ).
Top

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace


Action Field

ZB_BIND_DEVICE.Action Field
[image]

CREATE or DELETE a binding entry.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Action As ZB_BIND_DEVICE.BIND_ACTION_TYPE
C#
public ZB_BIND_DEVICE.BIND_ACTION_TYPE Action;
C++
public:
ZB_BIND_DEVICE.BIND_ACTION_TYPE Action sealed ;
J#
public ZB_BIND_DEVICE.BIND_ACTION_TYPE Action
JScript
public Action : ZB_BIND_DEVICE.BIND_ACTION_TYPE;

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace


CommandId Field

ZB_BIND_DEVICE.CommandId Field
[image]

The Command identifier of packets for this binding.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandId As UInt16
C#
public ushort CommandId;
C++
public:
unsigned short CommandId sealed ;
J#
public ushort CommandId
JScript
public CommandId : UInt16;

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace


Destination Field

ZB_BIND_DEVICE.Destination Field
[image]

IEEE address of device to establish the binding with ( all zeros indicate NULL ).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Destination As UInt64
C#
public ulong Destination;
C++
public:
unsigned __int64 Destination sealed ;
J#
public ulong Destination
JScript
public Destination : UInt64;

See Also

ZB_BIND_DEVICE Class
TI.ZPI2 Namespace


ZB_BIND_DEVICE.BIND_ACTION_TYPE Enumeration

ZB_BIND_DEVICE.BIND_ACTION_TYPE Enumeration
[image]

Reset type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_BIND_DEVICE.BIND_ACTION_TYPE As Byte
C#
public enum ZB_BIND_DEVICE.BIND_ACTION_TYPE : byte
C++
public enum class ZB_BIND_DEVICE.BIND_ACTION_TYPE : char
J#
public enum ZB_BIND_DEVICE.BIND_ACTION_TYPE byte
JScript
public enum ZB_BIND_DEVICE.BIND_ACTION_TYPE :

Members

Member Name | Description
CREATE_BIND | Reset type
DELETE_BIND | Reset type

See Also

TI.ZPI2 Namespace


ZB_BIND_DEVICE_RSP Class

ZB_BIND_DEVICE_RSP Class
See Also Example Members
[image]

Response for ZB_BIND_DEVICE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_BIND_DEVICE_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_BIND_DEVICE_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_BIND_DEVICE_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_BIND_DEVICE_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_BIND_DEVICE_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_BIND_DEVICE_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_BIND_DEVICE_RSP Members
TI.ZPI2 Namespace


ZB_BIND_DEVICE_RSP Members

ZB_BIND_DEVICE_RSP Members
See Also Example Constructors Methods
[image]

Response for ZB_BIND_DEVICE

The following tables list the members exposed by ZB_BIND_DEVICE_RSP.

Public Constructors

 | Name | Description
Public method | ZB_BIND_DEVICE_RSP | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI2 Namespace


ZB_BIND_DEVICE_RSP Constructor

ZB_BIND_DEVICE_RSP Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_BIND_DEVICE_RSP()
C++
public:
ZB_BIND_DEVICE_RSP() sealed
J#
public ZB_BIND_DEVICE_RSP()
JScript
public function ZB_BIND_DEVICE_RSP()

See Also

ZB_BIND_DEVICE_RSP Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_CONFIRM Class

ZB_FIND_DEVICE_CONFIRM Class
See Also Example Members
[image]

(zb_FindDeviceConfirm)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_FIND_DEVICE_CONFIRM
Implements IRESPONSE_CALLBACK, ISIMPLEAPI
C#
public class ZB_FIND_DEVICE_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
C++
ref class ZB_FIND_DEVICE_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
J#
public class ZB_FIND_DEVICE_CONFIRM implements IRESPONSE_CALLBACK, ISIMPLEAPI
JScript
public class ZB_FIND_DEVICE_CONFIRM extends IRESPONSE_CALLBACK, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_FIND_DEVICE_CONFIRM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_FIND_DEVICE_CONFIRM Members
TI.ZPI2 Namespace


ZB_FIND_DEVICE_CONFIRM Members

ZB_FIND_DEVICE_CONFIRM Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

(zb_FindDeviceConfirm)

The following tables list the members exposed by ZB_FIND_DEVICE_CONFIRM.

Public Constructors

Name | Description
ZB_FIND_DEVICE_CONFIRM | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Result | The 64-bit IEEE address of device that was searched for.
Public field | SearchKey | The 16-bit short address of the device that was found.
Public field | SearchType | The type of search that was performed.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_FIND_DEVICE_CONFIRM | Overloaded.
Top

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_CONFIRM Constructor

ZB_FIND_DEVICE_CONFIRM Constructor

Overload List

 | Name | Description
Public method | ZB_FIND_DEVICE_CONFIRM | Constructor
Public method | ZB_FIND_DEVICE_CONFIRM (Byte, UInt16, UInt64) | Constructor

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_CONFIRM Constructor ()

ZB_FIND_DEVICE_CONFIRM Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_FIND_DEVICE_CONFIRM()
C++
public:
ZB_FIND_DEVICE_CONFIRM() sealed
J#
public ZB_FIND_DEVICE_CONFIRM()
JScript
public function ZB_FIND_DEVICE_CONFIRM()

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace
ZB_FIND_DEVICE_CONFIRM Constructor Overload List


ZB_FIND_DEVICE_CONFIRM Constructor (Byte, UInt16, UInt64)

ZB_FIND_DEVICE_CONFIRM Constructor (Byte, UInt16, UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt64 _
)
C#
public ZB_FIND_DEVICE_CONFIRM(
byte ,
ushort ,
ulong
)
C++
public:
ZB_FIND_DEVICE_CONFIRM(
char ,
unsigned short ,
unsigned __int64
) sealed
J#
public ZB_FIND_DEVICE_CONFIRM(
byte ,
ushort ,
ulong
)
JScript
public function ZB_FIND_DEVICE_CONFIRM(
: Byte,
: UInt16,
: UInt64
)

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace
ZB_FIND_DEVICE_CONFIRM Constructor Overload List


Fields

ZB_FIND_DEVICE_CONFIRM Fields
[image]

Public Fields

 | Name | Description
Public field | Result | The 64-bit IEEE address of device that was searched for.
Public field | SearchKey | The 16-bit short address of the device that was found.
Public field | SearchType | The type of search that was performed.
Top

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace


Result Field

ZB_FIND_DEVICE_CONFIRM.Result Field
[image]

The 64-bit IEEE address of device that was searched for.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Result As UInt64
C#
public ulong Result;
C++
public:
unsigned __int64 Result sealed ;
J#
public ulong Result
JScript
public Result : UInt64;

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace


SearchKey Field

ZB_FIND_DEVICE_CONFIRM.SearchKey Field
[image]

The 16-bit short address of the device that was found.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SearchKey As UInt16
C#
public ushort SearchKey;
C++
public:
unsigned short SearchKey sealed ;
J#
public ushort SearchKey
JScript
public SearchKey : UInt16;

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace


SearchType Field

ZB_FIND_DEVICE_CONFIRM.SearchType Field
[image]

The type of search that was performed.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SearchType As Byte
C#
public byte SearchType;
C++
public:
char SearchType sealed ;
J#
public byte SearchType
JScript
public SearchType : Byte;

See Also

ZB_FIND_DEVICE_CONFIRM Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_REQUEST Class

ZB_FIND_DEVICE_REQUEST Class
See Also Example Members
[image]

Search for a device's short address given its IEEE address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_FIND_DEVICE_REQUEST
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_FIND_DEVICE_REQUEST : IREQUEST, ISIMPLEAPI
C++
ref class ZB_FIND_DEVICE_REQUEST : IREQUEST, ISIMPLEAPI
J#
public class ZB_FIND_DEVICE_REQUEST implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_FIND_DEVICE_REQUEST extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_FIND_DEVICE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_FIND_DEVICE_REQUEST Members
TI.ZPI2 Namespace


ZB_FIND_DEVICE_REQUEST Members

ZB_FIND_DEVICE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Search for a device's short address given its IEEE address.

The following tables list the members exposed by ZB_FIND_DEVICE_REQUEST.

Public Constructors

Name | Description
ZB_FIND_DEVICE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SearchKey | IEEE address of the device to find.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_FIND_DEVICE_REQUEST | Overloaded.
Top

See Also

ZB_FIND_DEVICE_REQUEST Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_REQUEST Constructor

ZB_FIND_DEVICE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZB_FIND_DEVICE_REQUEST | Constructor
Public method | ZB_FIND_DEVICE_REQUEST (UInt64) | Constructor

See Also

ZB_FIND_DEVICE_REQUEST Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_REQUEST Constructor ()

ZB_FIND_DEVICE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_FIND_DEVICE_REQUEST()
C++
public:
ZB_FIND_DEVICE_REQUEST() sealed
J#
public ZB_FIND_DEVICE_REQUEST()
JScript
public function ZB_FIND_DEVICE_REQUEST()

See Also

ZB_FIND_DEVICE_REQUEST Class
TI.ZPI2 Namespace
ZB_FIND_DEVICE_REQUEST Constructor Overload List


ZB_FIND_DEVICE_REQUEST Constructor (UInt64)

ZB_FIND_DEVICE_REQUEST Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public ZB_FIND_DEVICE_REQUEST(
ulong
)
C++
public:
ZB_FIND_DEVICE_REQUEST(
unsigned __int64
) sealed
J#
public ZB_FIND_DEVICE_REQUEST(
ulong
)
JScript
public function ZB_FIND_DEVICE_REQUEST(
: UInt64
)

See Also

ZB_FIND_DEVICE_REQUEST Class
TI.ZPI2 Namespace
ZB_FIND_DEVICE_REQUEST Constructor Overload List


Fields

ZB_FIND_DEVICE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | SearchKey | IEEE address of the device to find.
Top

See Also

ZB_FIND_DEVICE_REQUEST Class
TI.ZPI2 Namespace


SearchKey Field

ZB_FIND_DEVICE_REQUEST.SearchKey Field
[image]

IEEE address of the device to find.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SearchKey As UInt64
C#
public ulong SearchKey;
C++
public:
unsigned __int64 SearchKey sealed ;
J#
public ulong SearchKey
JScript
public SearchKey : UInt64;

See Also

ZB_FIND_DEVICE_REQUEST Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_REQUEST_RSP Class

ZB_FIND_DEVICE_REQUEST_RSP Class
See Also Example Members
[image]

Response for ZB_FIND_DEVICE_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_FIND_DEVICE_REQUEST_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_FIND_DEVICE_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_FIND_DEVICE_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_FIND_DEVICE_REQUEST_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_FIND_DEVICE_REQUEST_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_FIND_DEVICE_REQUEST_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_FIND_DEVICE_REQUEST_RSP Members
TI.ZPI2 Namespace


ZB_FIND_DEVICE_REQUEST_RSP Members

ZB_FIND_DEVICE_REQUEST_RSP Members
See Also Example Constructors Methods
[image]

Response for ZB_FIND_DEVICE_REQUEST

The following tables list the members exposed by ZB_FIND_DEVICE_REQUEST_RSP.

Public Constructors

 | Name | Description
Public method | ZB_FIND_DEVICE_REQUEST_RSP | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_FIND_DEVICE_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_FIND_DEVICE_REQUEST_RSP Constructor

ZB_FIND_DEVICE_REQUEST_RSP Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_FIND_DEVICE_REQUEST_RSP()
C++
public:
ZB_FIND_DEVICE_REQUEST_RSP() sealed
J#
public ZB_FIND_DEVICE_REQUEST_RSP()
JScript
public function ZB_FIND_DEVICE_REQUEST_RSP()

See Also

ZB_FIND_DEVICE_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO Class

ZB_GET_DEVICE_INFO Class
See Also Example Members
[image]

Reads current device infromation.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_GET_DEVICE_INFO
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_GET_DEVICE_INFO : IREQUEST, ISIMPLEAPI
C++
ref class ZB_GET_DEVICE_INFO : IREQUEST, ISIMPLEAPI
J#
public class ZB_GET_DEVICE_INFO implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_GET_DEVICE_INFO extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_GET_DEVICE_INFO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_GET_DEVICE_INFO Members
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO Members

ZB_GET_DEVICE_INFO Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Reads current device infromation.

The following tables list the members exposed by ZB_GET_DEVICE_INFO.

Public Constructors

Name | Description
ZB_GET_DEVICE_INFO | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Param | Identifier of the device info parameter to read.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_GET_DEVICE_INFO | Overloaded.
Top

See Also

ZB_GET_DEVICE_INFO Class
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO Constructor

ZB_GET_DEVICE_INFO Constructor

Overload List

 | Name | Description
Public method | ZB_GET_DEVICE_INFO | Constructor
Public method | ZB_GET_DEVICE_INFO (ZB_GET_DEVICE_INFO.DEV_INFO_TYPE) |

See Also

ZB_GET_DEVICE_INFO Class
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO Constructor ()

ZB_GET_DEVICE_INFO Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_GET_DEVICE_INFO()
C++
public:
ZB_GET_DEVICE_INFO() sealed
J#
public ZB_GET_DEVICE_INFO()
JScript
public function ZB_GET_DEVICE_INFO()

See Also

ZB_GET_DEVICE_INFO Class
TI.ZPI2 Namespace
ZB_GET_DEVICE_INFO Constructor Overload List


ZB_GET_DEVICE_INFO Constructor (ZB_GET_DEVICE_INFO.DEV_INFO_TYPE)

ZB_GET_DEVICE_INFO Constructor (ZB_GET_DEVICE_INFO.DEV_INFO_TYPE)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZB_GET_DEVICE_INFO.DEV_INFO_TYPE _
)
C#
public ZB_GET_DEVICE_INFO(
ZB_GET_DEVICE_INFO.DEV_INFO_TYPE
)
C++
public:
ZB_GET_DEVICE_INFO(
ZB_GET_DEVICE_INFO.DEV_INFO_TYPE
) sealed
J#
public ZB_GET_DEVICE_INFO(
ZB_GET_DEVICE_INFO.DEV_INFO_TYPE
)
JScript
public function ZB_GET_DEVICE_INFO(
: ZB_GET_DEVICE_INFO.DEV_INFO_TYPE
)

See Also

ZB_GET_DEVICE_INFO Class
TI.ZPI2 Namespace
ZB_GET_DEVICE_INFO Constructor Overload List


Fields

ZB_GET_DEVICE_INFO Fields
[image]

Public Fields

 | Name | Description
Public field | Param | Identifier of the device info parameter to read.
Top

See Also

ZB_GET_DEVICE_INFO Class
TI.ZPI2 Namespace


Param Field

ZB_GET_DEVICE_INFO.Param Field
[image]

Identifier of the device info parameter to read.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Param As ZB_GET_DEVICE_INFO.DEV_INFO_TYPE
C#
public ZB_GET_DEVICE_INFO.DEV_INFO_TYPE Param;
C++
public:
ZB_GET_DEVICE_INFO.DEV_INFO_TYPE Param sealed ;
J#
public ZB_GET_DEVICE_INFO.DEV_INFO_TYPE Param
JScript
public Param : ZB_GET_DEVICE_INFO.DEV_INFO_TYPE;

See Also

ZB_GET_DEVICE_INFO Class
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO.DEV_INFO_TYPE Enumeration

ZB_GET_DEVICE_INFO.DEV_INFO_TYPE Enumeration
[image]

Reset type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_GET_DEVICE_INFO.DEV_INFO_TYPE As Byte
C#
public enum ZB_GET_DEVICE_INFO.DEV_INFO_TYPE : byte
C++
public enum class ZB_GET_DEVICE_INFO.DEV_INFO_TYPE : char
J#
public enum ZB_GET_DEVICE_INFO.DEV_INFO_TYPE byte
JScript
public enum ZB_GET_DEVICE_INFO.DEV_INFO_TYPE :

Members

Member Name | Description
STATE | Reset type
IEEE_ADDR | Reset type
SHORT_ADDR | Reset type
PARENT_SHORT_ADDR | Reset type
PARENT_IEEE_ADDR | Reset type
CHANNEL | Reset type
PAN_ID | Reset type
EXT_PAN_ID | Reset type

See Also

TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO_RSP Class

ZB_GET_DEVICE_INFO_RSP Class
See Also Example Members
[image]

Response for ZB_GET_DEVICE_INFO

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_GET_DEVICE_INFO_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_GET_DEVICE_INFO_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_GET_DEVICE_INFO_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_GET_DEVICE_INFO_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_GET_DEVICE_INFO_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_GET_DEVICE_INFO_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_GET_DEVICE_INFO_RSP Members
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO_RSP Members

ZB_GET_DEVICE_INFO_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_GET_DEVICE_INFO

The following tables list the members exposed by ZB_GET_DEVICE_INFO_RSP.

Public Constructors

Name | Description
ZB_GET_DEVICE_INFO_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Param | Device parameter.
Public field | Value | Parameter value.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_GET_DEVICE_INFO_RSP | Overloaded.
Top

See Also

ZB_GET_DEVICE_INFO_RSP Class
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO_RSP Constructor

ZB_GET_DEVICE_INFO_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_GET_DEVICE_INFO_RSP | Constructor
Public method | ZB_GET_DEVICE_INFO_RSP (Byte, Byte) | Constructor

See Also

ZB_GET_DEVICE_INFO_RSP Class
TI.ZPI2 Namespace


ZB_GET_DEVICE_INFO_RSP Constructor ()

ZB_GET_DEVICE_INFO_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_GET_DEVICE_INFO_RSP()
C++
public:
ZB_GET_DEVICE_INFO_RSP() sealed
J#
public ZB_GET_DEVICE_INFO_RSP()
JScript
public function ZB_GET_DEVICE_INFO_RSP()

See Also

ZB_GET_DEVICE_INFO_RSP Class
TI.ZPI2 Namespace
ZB_GET_DEVICE_INFO_RSP Constructor Overload List


ZB_GET_DEVICE_INFO_RSP Constructor (Byte, Byte[])

ZB_GET_DEVICE_INFO_RSP Constructor (Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_GET_DEVICE_INFO_RSP(
byte ,
byte[]
)
C++
public:
ZB_GET_DEVICE_INFO_RSP(
char ,
array<char>^
) sealed
J#
public ZB_GET_DEVICE_INFO_RSP(
byte ,
byte[]
)
JScript
public function ZB_GET_DEVICE_INFO_RSP(
: Byte,
: Byte[]
)

See Also

ZB_GET_DEVICE_INFO_RSP Class
TI.ZPI2 Namespace
ZB_GET_DEVICE_INFO_RSP Constructor Overload List


Fields

ZB_GET_DEVICE_INFO_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Param | Device parameter.
Public field | Value | Parameter value.
Top

See Also

ZB_GET_DEVICE_INFO_RSP Class
TI.ZPI2 Namespace


Param Field

ZB_GET_DEVICE_INFO_RSP.Param Field
[image]

Device parameter.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Param As Byte
C#
public byte Param;
C++
public:
char Param sealed ;
J#
public byte Param
JScript
public Param : Byte;

See Also

ZB_GET_DEVICE_INFO_RSP Class
TI.ZPI2 Namespace


Value Field

ZB_GET_DEVICE_INFO_RSP.Value Field
[image]

Parameter value.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZB_GET_DEVICE_INFO_RSP Class
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST Class

ZB_PERMIT_JOINING_REQUEST Class
See Also Example Members
[image]

Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_PERMIT_JOINING_REQUEST
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_PERMIT_JOINING_REQUEST : IREQUEST, ISIMPLEAPI
C++
ref class ZB_PERMIT_JOINING_REQUEST : IREQUEST, ISIMPLEAPI
J#
public class ZB_PERMIT_JOINING_REQUEST implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_PERMIT_JOINING_REQUEST extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_PERMIT_JOINING_REQUEST Members
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST Members

ZB_PERMIT_JOINING_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Enables or disables the joining permissions on the destination device thus controlling the ability of new devices to join the network.

The following tables list the members exposed by ZB_PERMIT_JOINING_REQUEST.

Public Constructors

Name | Description
ZB_PERMIT_JOINING_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Destination | Short adddress of the device on which to control the joining permissions. This is usually the local device address or the special broadcast address that denotes all routers and coordinator ( 0xFFFC ).
Public field | Timeout | The amount of time in seconds for which the joining permissions should be turned on. If set to 0x00, the device will turn off the joining permissions indefinitely. If it is set to 0xFF, the joining permissions will be turned on indefinitely.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_PERMIT_JOINING_REQUEST | Overloaded.
Top

See Also

ZB_PERMIT_JOINING_REQUEST Class
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST Constructor

ZB_PERMIT_JOINING_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZB_PERMIT_JOINING_REQUEST | Constructor
Public method | ZB_PERMIT_JOINING_REQUEST (UInt16, Byte) | Constructor

See Also

ZB_PERMIT_JOINING_REQUEST Class
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST Constructor ()

ZB_PERMIT_JOINING_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_PERMIT_JOINING_REQUEST()
C++
public:
ZB_PERMIT_JOINING_REQUEST() sealed
J#
public ZB_PERMIT_JOINING_REQUEST()
JScript
public function ZB_PERMIT_JOINING_REQUEST()

See Also

ZB_PERMIT_JOINING_REQUEST Class
TI.ZPI2 Namespace
ZB_PERMIT_JOINING_REQUEST Constructor Overload List


ZB_PERMIT_JOINING_REQUEST Constructor (UInt16, Byte)

ZB_PERMIT_JOINING_REQUEST Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZB_PERMIT_JOINING_REQUEST(
ushort ,
byte
)
C++
public:
ZB_PERMIT_JOINING_REQUEST(
unsigned short ,
char
) sealed
J#
public ZB_PERMIT_JOINING_REQUEST(
ushort ,
byte
)
JScript
public function ZB_PERMIT_JOINING_REQUEST(
: UInt16,
: Byte
)

See Also

ZB_PERMIT_JOINING_REQUEST Class
TI.ZPI2 Namespace
ZB_PERMIT_JOINING_REQUEST Constructor Overload List


Fields

ZB_PERMIT_JOINING_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Destination | Short adddress of the device on which to control the joining permissions. This is usually the local device address or the special broadcast address that denotes all routers and coordinator ( 0xFFFC ).
Public field | Timeout | The amount of time in seconds for which the joining permissions should be turned on. If set to 0x00, the device will turn off the joining permissions indefinitely. If it is set to 0xFF, the joining permissions will be turned on indefinitely.
Top

See Also

ZB_PERMIT_JOINING_REQUEST Class
TI.ZPI2 Namespace


Destination Field

ZB_PERMIT_JOINING_REQUEST.Destination Field
[image]

Short adddress of the device on which to control the joining permissions. This is usually the local device address or the special broadcast address that denotes all routers and coordinator ( 0xFFFC ).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Destination As UInt16
C#
public ushort Destination;
C++
public:
unsigned short Destination sealed ;
J#
public ushort Destination
JScript
public Destination : UInt16;

See Also

ZB_PERMIT_JOINING_REQUEST Class
TI.ZPI2 Namespace


Timeout Field

ZB_PERMIT_JOINING_REQUEST.Timeout Field
[image]

The amount of time in seconds for which the joining permissions should be turned on. If set to 0x00, the device will turn off the joining permissions indefinitely. If it is set to 0xFF, the joining permissions will be turned on indefinitely.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timeout As Byte
C#
public byte Timeout;
C++
public:
char Timeout sealed ;
J#
public byte Timeout
JScript
public Timeout : Byte;

See Also

ZB_PERMIT_JOINING_REQUEST Class
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST_RSP Class

ZB_PERMIT_JOINING_REQUEST_RSP Class
See Also Example Members
[image]

Response for ZB_PERMIT_JOINING_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_PERMIT_JOINING_REQUEST_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_PERMIT_JOINING_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_PERMIT_JOINING_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_PERMIT_JOINING_REQUEST_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_PERMIT_JOINING_REQUEST_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_PERMIT_JOINING_REQUEST_RSP Members
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST_RSP Members

ZB_PERMIT_JOINING_REQUEST_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_PERMIT_JOINING_REQUEST

The following tables list the members exposed by ZB_PERMIT_JOINING_REQUEST_RSP.

Public Constructors

Name | Description
ZB_PERMIT_JOINING_REQUEST_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_PERMIT_JOINING_REQUEST_RSP | Overloaded.
Top

See Also

ZB_PERMIT_JOINING_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST_RSP Constructor

ZB_PERMIT_JOINING_REQUEST_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_PERMIT_JOINING_REQUEST_RSP | Constructor
Public method | ZB_PERMIT_JOINING_REQUEST_RSP (ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS) |

See Also

ZB_PERMIT_JOINING_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST_RSP Constructor ()

ZB_PERMIT_JOINING_REQUEST_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_PERMIT_JOINING_REQUEST_RSP()
C++
public:
ZB_PERMIT_JOINING_REQUEST_RSP() sealed
J#
public ZB_PERMIT_JOINING_REQUEST_RSP()
JScript
public function ZB_PERMIT_JOINING_REQUEST_RSP()

See Also

ZB_PERMIT_JOINING_REQUEST_RSP Class
TI.ZPI2 Namespace
ZB_PERMIT_JOINING_REQUEST_RSP Constructor Overload List


ZB_PERMIT_JOINING_REQUEST_RSP Constructor (ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS)

ZB_PERMIT_JOINING_REQUEST_RSP Constructor (ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS _
)
C#
public ZB_PERMIT_JOINING_REQUEST_RSP(
ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS
)
C++
public:
ZB_PERMIT_JOINING_REQUEST_RSP(
ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS
) sealed
J#
public ZB_PERMIT_JOINING_REQUEST_RSP(
ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS
)
JScript
public function ZB_PERMIT_JOINING_REQUEST_RSP(
: ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS
)

See Also

ZB_PERMIT_JOINING_REQUEST_RSP Class
TI.ZPI2 Namespace
ZB_PERMIT_JOINING_REQUEST_RSP Constructor Overload List


Fields

ZB_PERMIT_JOINING_REQUEST_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status.
Top

See Also

ZB_PERMIT_JOINING_REQUEST_RSP Class
TI.ZPI2 Namespace


Status Field

ZB_PERMIT_JOINING_REQUEST_RSP.Status Field
[image]

Status.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS
C#
public ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS Status;
C++
public:
ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS Status sealed ;
J#
public ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS Status
JScript
public Status : ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS;

See Also

ZB_PERMIT_JOINING_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS Enumeration

ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS As Byte
C#
public enum ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS : byte
C++
public enum class ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS : char
J#
public enum ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS byte
JScript
public enum ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZB_READ_CONFIGURATION Class

ZB_READ_CONFIGURATION Class
See Also Example Members
[image]

Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_READ_CONFIGURATION
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_READ_CONFIGURATION : IREQUEST, ISIMPLEAPI
C++
ref class ZB_READ_CONFIGURATION : IREQUEST, ISIMPLEAPI
J#
public class ZB_READ_CONFIGURATION implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_READ_CONFIGURATION extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_READ_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_READ_CONFIGURATION Members
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION Members

ZB_READ_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Reads a configuration property from nonvolatile memory (zb_ReadConfiguration).

The following tables list the members exposed by ZB_READ_CONFIGURATION.

Public Constructors

Name | Description
ZB_READ_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigId | Identifier of property to read.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_READ_CONFIGURATION | Overloaded.
Top

See Also

ZB_READ_CONFIGURATION Class
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION Constructor

ZB_READ_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | ZB_READ_CONFIGURATION | Constructor
Public method | ZB_READ_CONFIGURATION (Byte) | Constructor

See Also

ZB_READ_CONFIGURATION Class
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION Constructor ()

ZB_READ_CONFIGURATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_READ_CONFIGURATION()
C++
public:
ZB_READ_CONFIGURATION() sealed
J#
public ZB_READ_CONFIGURATION()
JScript
public function ZB_READ_CONFIGURATION()

See Also

ZB_READ_CONFIGURATION Class
TI.ZPI2 Namespace
ZB_READ_CONFIGURATION Constructor Overload List


ZB_READ_CONFIGURATION Constructor (Byte)

ZB_READ_CONFIGURATION Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZB_READ_CONFIGURATION(
byte
)
C++
public:
ZB_READ_CONFIGURATION(
char
) sealed
J#
public ZB_READ_CONFIGURATION(
byte
)
JScript
public function ZB_READ_CONFIGURATION(
: Byte
)

See Also

ZB_READ_CONFIGURATION Class
TI.ZPI2 Namespace
ZB_READ_CONFIGURATION Constructor Overload List


Fields

ZB_READ_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigId | Identifier of property to read.
Top

See Also

ZB_READ_CONFIGURATION Class
TI.ZPI2 Namespace


ConfigId Field

ZB_READ_CONFIGURATION.ConfigId Field
[image]

Identifier of property to read.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigId As Byte
C#
public byte ConfigId;
C++
public:
char ConfigId sealed ;
J#
public byte ConfigId
JScript
public ConfigId : Byte;

See Also

ZB_READ_CONFIGURATION Class
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION_RSP Class

ZB_READ_CONFIGURATION_RSP Class
See Also Example Members
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_READ_CONFIGURATION_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_READ_CONFIGURATION_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_READ_CONFIGURATION_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_READ_CONFIGURATION_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_READ_CONFIGURATION_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_READ_CONFIGURATION_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_READ_CONFIGURATION_RSP Members
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION_RSP Members

ZB_READ_CONFIGURATION_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by ZB_READ_CONFIGURATION_RSP.

Public Constructors

Name | Description
ZB_READ_CONFIGURATION_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigId | The identifier of the property that was read.
Public field | Len | The size of the value of the property.
Public field | Status | The result of the read operation.
Public field | Value | The value of the property that was read.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_READ_CONFIGURATION_RSP | Overloaded.
Top

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION_RSP Constructor

ZB_READ_CONFIGURATION_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_READ_CONFIGURATION_RSP | Constructor
Public method | ZB_READ_CONFIGURATION_RSP (ZB_READ_CONFIGURATION_RSP.CMD_STATUS, Byte, Byte, Byte) |

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION_RSP Constructor ()

ZB_READ_CONFIGURATION_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_READ_CONFIGURATION_RSP()
C++
public:
ZB_READ_CONFIGURATION_RSP() sealed
J#
public ZB_READ_CONFIGURATION_RSP()
JScript
public function ZB_READ_CONFIGURATION_RSP()

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace
ZB_READ_CONFIGURATION_RSP Constructor Overload List


ZB_READ_CONFIGURATION_RSP Constructor (ZB_READ_CONFIGURATION_RSP.CMD_STATUS, Byte, Byte, Byte[])

ZB_READ_CONFIGURATION_RSP Constructor (ZB_READ_CONFIGURATION_RSP.CMD_STATUS, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZB_READ_CONFIGURATION_RSP.CMD_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_READ_CONFIGURATION_RSP(
ZB_READ_CONFIGURATION_RSP.CMD_STATUS ,
byte ,
byte ,
byte[]
)
C++
public:
ZB_READ_CONFIGURATION_RSP(
ZB_READ_CONFIGURATION_RSP.CMD_STATUS ,
char ,
char ,
array<char>^
) sealed
J#
public ZB_READ_CONFIGURATION_RSP(
ZB_READ_CONFIGURATION_RSP.CMD_STATUS ,
byte ,
byte ,
byte[]
)
JScript
public function ZB_READ_CONFIGURATION_RSP(
: ZB_READ_CONFIGURATION_RSP.CMD_STATUS,
: Byte,
: Byte,
: Byte[]
)

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace
ZB_READ_CONFIGURATION_RSP Constructor Overload List


Fields

ZB_READ_CONFIGURATION_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigId | The identifier of the property that was read.
Public field | Len | The size of the value of the property.
Public field | Status | The result of the read operation.
Public field | Value | The value of the property that was read.
Top

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


ConfigId Field

ZB_READ_CONFIGURATION_RSP.ConfigId Field
[image]

The identifier of the property that was read.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigId As Byte
C#
public byte ConfigId;
C++
public:
char ConfigId sealed ;
J#
public byte ConfigId
JScript
public ConfigId : Byte;

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


Len Field

ZB_READ_CONFIGURATION_RSP.Len Field
[image]

The size of the value of the property.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


Status Field

ZB_READ_CONFIGURATION_RSP.Status Field
[image]

The result of the read operation.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZB_READ_CONFIGURATION_RSP.CMD_STATUS
C#
public ZB_READ_CONFIGURATION_RSP.CMD_STATUS Status;
C++
public:
ZB_READ_CONFIGURATION_RSP.CMD_STATUS Status sealed ;
J#
public ZB_READ_CONFIGURATION_RSP.CMD_STATUS Status
JScript
public Status : ZB_READ_CONFIGURATION_RSP.CMD_STATUS;

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


Value Field

ZB_READ_CONFIGURATION_RSP.Value Field
[image]

The value of the property that was read.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZB_READ_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


ZB_READ_CONFIGURATION_RSP.CMD_STATUS Enumeration

ZB_READ_CONFIGURATION_RSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_READ_CONFIGURATION_RSP.CMD_STATUS As Byte
C#
public enum ZB_READ_CONFIGURATION_RSP.CMD_STATUS : byte
C++
public enum class ZB_READ_CONFIGURATION_RSP.CMD_STATUS : char
J#
public enum ZB_READ_CONFIGURATION_RSP.CMD_STATUS byte
JScript
public enum ZB_READ_CONFIGURATION_RSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZB_RECEIVE_DATA_INDICATION Class

ZB_RECEIVE_DATA_INDICATION Class
See Also Example Members
[image]

(zb_ReceiveDataIndication)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_RECEIVE_DATA_INDICATION
Implements IRESPONSE_CALLBACK, ISIMPLEAPI
C#
public class ZB_RECEIVE_DATA_INDICATION : IRESPONSE_CALLBACK, ISIMPLEAPI
C++
ref class ZB_RECEIVE_DATA_INDICATION : IRESPONSE_CALLBACK, ISIMPLEAPI
J#
public class ZB_RECEIVE_DATA_INDICATION implements IRESPONSE_CALLBACK, ISIMPLEAPI
JScript
public class ZB_RECEIVE_DATA_INDICATION extends IRESPONSE_CALLBACK, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_RECEIVE_DATA_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_RECEIVE_DATA_INDICATION Members
TI.ZPI2 Namespace


ZB_RECEIVE_DATA_INDICATION Members

ZB_RECEIVE_DATA_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

(zb_ReceiveDataIndication)

The following tables list the members exposed by ZB_RECEIVE_DATA_INDICATION.

Public Constructors

Name | Description
ZB_RECEIVE_DATA_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Command | The CommandId of the data packet.
Public field | Data | The received data packet payload.
Public field | Len | The length of the data payload.
Public field | Source | The 16-bit address of the device that sent the data packet.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_RECEIVE_DATA_INDICATION | Overloaded.
Top

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace


ZB_RECEIVE_DATA_INDICATION Constructor

ZB_RECEIVE_DATA_INDICATION Constructor

Overload List

 | Name | Description
Public method | ZB_RECEIVE_DATA_INDICATION | Constructor
Public method | ZB_RECEIVE_DATA_INDICATION (UInt16, UInt16, UInt16, Byte) | Constructor

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace


ZB_RECEIVE_DATA_INDICATION Constructor ()

ZB_RECEIVE_DATA_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_RECEIVE_DATA_INDICATION()
C++
public:
ZB_RECEIVE_DATA_INDICATION() sealed
J#
public ZB_RECEIVE_DATA_INDICATION()
JScript
public function ZB_RECEIVE_DATA_INDICATION()

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace
ZB_RECEIVE_DATA_INDICATION Constructor Overload List


ZB_RECEIVE_DATA_INDICATION Constructor (UInt16, UInt16, UInt16, Byte[])

ZB_RECEIVE_DATA_INDICATION Constructor (UInt16, UInt16, UInt16, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte() _
)
C#
public ZB_RECEIVE_DATA_INDICATION(
ushort ,
ushort ,
ushort ,
byte[]
)
C++
public:
ZB_RECEIVE_DATA_INDICATION(
unsigned short ,
unsigned short ,
unsigned short ,
array<char>^
) sealed
J#
public ZB_RECEIVE_DATA_INDICATION(
ushort ,
ushort ,
ushort ,
byte[]
)
JScript
public function ZB_RECEIVE_DATA_INDICATION(
: UInt16,
: UInt16,
: UInt16,
: Byte[]
)

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace
ZB_RECEIVE_DATA_INDICATION Constructor Overload List


Fields

ZB_RECEIVE_DATA_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | Command | The CommandId of the data packet.
Public field | Data | The received data packet payload.
Public field | Len | The length of the data payload.
Public field | Source | The 16-bit address of the device that sent the data packet.
Top

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace


Command Field

ZB_RECEIVE_DATA_INDICATION.Command Field
[image]

The CommandId of the data packet.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Command As UInt16
C#
public ushort Command;
C++
public:
unsigned short Command sealed ;
J#
public ushort Command
JScript
public Command : UInt16;

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace


Data Field

ZB_RECEIVE_DATA_INDICATION.Data Field
[image]

The received data packet payload.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace


Len Field

ZB_RECEIVE_DATA_INDICATION.Len Field
[image]

The length of the data payload.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As UInt16
C#
public ushort Len;
C++
public:
unsigned short Len sealed ;
J#
public ushort Len
JScript
public Len : UInt16;

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace


Source Field

ZB_RECEIVE_DATA_INDICATION.Source Field
[image]

The 16-bit address of the device that sent the data packet.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Source As UInt16
C#
public ushort Source;
C++
public:
unsigned short Source sealed ;
J#
public ushort Source
JScript
public Source : UInt16;

See Also

ZB_RECEIVE_DATA_INDICATION Class
TI.ZPI2 Namespace


ZB_SEND_DATA_CONFIRM Class

ZB_SEND_DATA_CONFIRM Class
See Also Example Members
[image]

Response for ZB_SEND_DATA_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SEND_DATA_CONFIRM
Implements IRESPONSE_CALLBACK, ISIMPLEAPI
C#
public class ZB_SEND_DATA_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
C++
ref class ZB_SEND_DATA_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
J#
public class ZB_SEND_DATA_CONFIRM implements IRESPONSE_CALLBACK, ISIMPLEAPI
JScript
public class ZB_SEND_DATA_CONFIRM extends IRESPONSE_CALLBACK, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_SEND_DATA_CONFIRM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SEND_DATA_CONFIRM Members
TI.ZPI2 Namespace


ZB_SEND_DATA_CONFIRM Members

ZB_SEND_DATA_CONFIRM Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_SEND_DATA_REQUEST

The following tables list the members exposed by ZB_SEND_DATA_CONFIRM.

Public Constructors

Name | Description
ZB_SEND_DATA_CONFIRM | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Handle | Handle.
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_SEND_DATA_CONFIRM | Overloaded.
Top

See Also

ZB_SEND_DATA_CONFIRM Class
TI.ZPI2 Namespace


ZB_SEND_DATA_CONFIRM Constructor

ZB_SEND_DATA_CONFIRM Constructor

Overload List

 | Name | Description
Public method | ZB_SEND_DATA_CONFIRM | Constructor
Public method | ZB_SEND_DATA_CONFIRM (Byte, ZB_SEND_DATA_CONFIRM.CMD_STATUS) |

See Also

ZB_SEND_DATA_CONFIRM Class
TI.ZPI2 Namespace


ZB_SEND_DATA_CONFIRM Constructor ()

ZB_SEND_DATA_CONFIRM Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SEND_DATA_CONFIRM()
C++
public:
ZB_SEND_DATA_CONFIRM() sealed
J#
public ZB_SEND_DATA_CONFIRM()
JScript
public function ZB_SEND_DATA_CONFIRM()

See Also

ZB_SEND_DATA_CONFIRM Class
TI.ZPI2 Namespace
ZB_SEND_DATA_CONFIRM Constructor Overload List


ZB_SEND_DATA_CONFIRM Constructor (Byte, ZB_SEND_DATA_CONFIRM.CMD_STATUS)

ZB_SEND_DATA_CONFIRM Constructor (Byte, ZB_SEND_DATA_CONFIRM.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As ZB_SEND_DATA_CONFIRM.CMD_STATUS _
)
C#
public ZB_SEND_DATA_CONFIRM(
byte ,
ZB_SEND_DATA_CONFIRM.CMD_STATUS
)
C++
public:
ZB_SEND_DATA_CONFIRM(
char ,
ZB_SEND_DATA_CONFIRM.CMD_STATUS
) sealed
J#
public ZB_SEND_DATA_CONFIRM(
byte ,
ZB_SEND_DATA_CONFIRM.CMD_STATUS
)
JScript
public function ZB_SEND_DATA_CONFIRM(
: Byte,
: ZB_SEND_DATA_CONFIRM.CMD_STATUS
)

See Also

ZB_SEND_DATA_CONFIRM Class
TI.ZPI2 Namespace
ZB_SEND_DATA_CONFIRM Constructor Overload List


Fields

ZB_SEND_DATA_CONFIRM Fields
[image]

Public Fields

 | Name | Description
Public field | Handle | Handle.
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_SEND_DATA_CONFIRM Class
TI.ZPI2 Namespace


Handle Field

ZB_SEND_DATA_CONFIRM.Handle Field
[image]

Handle.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZB_SEND_DATA_CONFIRM Class
TI.ZPI2 Namespace


Status Field

ZB_SEND_DATA_CONFIRM.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZB_SEND_DATA_CONFIRM.CMD_STATUS
C#
public ZB_SEND_DATA_CONFIRM.CMD_STATUS Status;
C++
public:
ZB_SEND_DATA_CONFIRM.CMD_STATUS Status sealed ;
J#
public ZB_SEND_DATA_CONFIRM.CMD_STATUS Status
JScript
public Status : ZB_SEND_DATA_CONFIRM.CMD_STATUS;

See Also

ZB_SEND_DATA_CONFIRM Class
TI.ZPI2 Namespace


ZB_SEND_DATA_CONFIRM.CMD_STATUS Enumeration

ZB_SEND_DATA_CONFIRM.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_SEND_DATA_CONFIRM.CMD_STATUS As Byte
C#
public enum ZB_SEND_DATA_CONFIRM.CMD_STATUS : byte
C++
public enum class ZB_SEND_DATA_CONFIRM.CMD_STATUS : char
J#
public enum ZB_SEND_DATA_CONFIRM.CMD_STATUS byte
JScript
public enum ZB_SEND_DATA_CONFIRM.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST Class

ZB_SEND_DATA_REQUEST Class
See Also Example Members
[image]

Send a data packet to another device (zb_SendDataRequest).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SEND_DATA_REQUEST
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_SEND_DATA_REQUEST : IREQUEST, ISIMPLEAPI
C++
ref class ZB_SEND_DATA_REQUEST : IREQUEST, ISIMPLEAPI
J#
public class ZB_SEND_DATA_REQUEST implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_SEND_DATA_REQUEST extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_SEND_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SEND_DATA_REQUEST Members
TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST Members

ZB_SEND_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Send a data packet to another device (zb_SendDataRequest).

The following tables list the members exposed by ZB_SEND_DATA_REQUEST.

Public Constructors

Name | Description
ZB_SEND_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CommandId | Command identifier of the data packet.
Public field | Destination | Short address of destination device ( 0xFFFE indicates NULL address and a binding must have been established previously for this command identifier. Broadcast addresses include 0xFFFF for all devices, 0xFFFC for all routers/coordinator devices and 0xFFFD for all devices with receiver turned ON ).
Public field | Handle | Identifier for this data send operation.
Public field | PayloadLen | Size in bytes of the data packet payload.
Public field | PayloadValue | Packet payload.
Public field | Radius | Max number of hops the data packet can travel ( set to 0 to use default value ).
Public field | TxOptions | Bit mask of transmission options ( 0x10 for end-to-end acknowledgements and retransmissions ).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_SEND_DATA_REQUEST | Overloaded.
Top

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST Constructor

ZB_SEND_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZB_SEND_DATA_REQUEST | Constructor
Public method | ZB_SEND_DATA_REQUEST (UInt16, UInt16, Byte, ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE, Byte, Byte, Byte) |

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST Constructor ()

ZB_SEND_DATA_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SEND_DATA_REQUEST()
C++
public:
ZB_SEND_DATA_REQUEST() sealed
J#
public ZB_SEND_DATA_REQUEST()
JScript
public function ZB_SEND_DATA_REQUEST()

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace
ZB_SEND_DATA_REQUEST Constructor Overload List


ZB_SEND_DATA_REQUEST Constructor (UInt16, UInt16, Byte, ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE, Byte, Byte, Byte[])

ZB_SEND_DATA_REQUEST Constructor (UInt16, UInt16, Byte, ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_SEND_DATA_REQUEST(
ushort ,
ushort ,
byte ,
ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE ,
byte ,
byte ,
byte[]
)
C++
public:
ZB_SEND_DATA_REQUEST(
unsigned short ,
unsigned short ,
char ,
ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE ,
char ,
char ,
array<char>^
) sealed
J#
public ZB_SEND_DATA_REQUEST(
ushort ,
ushort ,
byte ,
ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE ,
byte ,
byte ,
byte[]
)
JScript
public function ZB_SEND_DATA_REQUEST(
: UInt16,
: UInt16,
: Byte,
: ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE,
: Byte,
: Byte,
: Byte[]
)

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace
ZB_SEND_DATA_REQUEST Constructor Overload List


Fields

ZB_SEND_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CommandId | Command identifier of the data packet.
Public field | Destination | Short address of destination device ( 0xFFFE indicates NULL address and a binding must have been established previously for this command identifier. Broadcast addresses include 0xFFFF for all devices, 0xFFFC for all routers/coordinator devices and 0xFFFD for all devices with receiver turned ON ).
Public field | Handle | Identifier for this data send operation.
Public field | PayloadLen | Size in bytes of the data packet payload.
Public field | PayloadValue | Packet payload.
Public field | Radius | Max number of hops the data packet can travel ( set to 0 to use default value ).
Public field | TxOptions | Bit mask of transmission options ( 0x10 for end-to-end acknowledgements and retransmissions ).
Top

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


CommandId Field

ZB_SEND_DATA_REQUEST.CommandId Field
[image]

Command identifier of the data packet.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CommandId As UInt16
C#
public ushort CommandId;
C++
public:
unsigned short CommandId sealed ;
J#
public ushort CommandId
JScript
public CommandId : UInt16;

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


Destination Field

ZB_SEND_DATA_REQUEST.Destination Field
[image]

Short address of destination device ( 0xFFFE indicates NULL address and a binding must have been established previously for this command identifier. Broadcast addresses include 0xFFFF for all devices, 0xFFFC for all routers/coordinator devices and 0xFFFD for all devices with receiver turned ON ).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Destination As UInt16
C#
public ushort Destination;
C++
public:
unsigned short Destination sealed ;
J#
public ushort Destination
JScript
public Destination : UInt16;

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


Handle Field

ZB_SEND_DATA_REQUEST.Handle Field
[image]

Identifier for this data send operation.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


PayloadLen Field

ZB_SEND_DATA_REQUEST.PayloadLen Field
[image]

Size in bytes of the data packet payload.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadLen As Byte
C#
public byte PayloadLen;
C++
public:
char PayloadLen sealed ;
J#
public byte PayloadLen
JScript
public PayloadLen : Byte;

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


PayloadValue Field

ZB_SEND_DATA_REQUEST.PayloadValue Field
[image]

Packet payload.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PayloadValue As Byte()
C#
public byte[] PayloadValue;
C++
public:
array<char>^ PayloadValue sealed ;
J#
public byte[] PayloadValue
JScript
public PayloadValue : Byte[];

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


Radius Field

ZB_SEND_DATA_REQUEST.Radius Field
[image]

Max number of hops the data packet can travel ( set to 0 to use default value ).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Radius As Byte
C#
public byte Radius;
C++
public:
char Radius sealed ;
J#
public byte Radius
JScript
public Radius : Byte;

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


TxOptions Field

ZB_SEND_DATA_REQUEST.TxOptions Field
[image]

Bit mask of transmission options ( 0x10 for end-to-end acknowledgements and retransmissions ).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxOptions As ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE
C#
public ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE TxOptions;
C++
public:
ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE TxOptions sealed ;
J#
public ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE TxOptions
JScript
public TxOptions : ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE;

See Also

ZB_SEND_DATA_REQUEST Class
TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE Enumeration

ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE Enumeration
[image]

Reset type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE As Byte
C#
public enum ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE : byte
C++
public enum class ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE : char
J#
public enum ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE byte
JScript
public enum ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE :

Members

Member Name | Description
NONE | Reset type
END-TO-END-ACK | Reset type

See Also

TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST_RSP Class

ZB_SEND_DATA_REQUEST_RSP Class
See Also Example Members
[image]

Response for ZB_SEND_DATA_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SEND_DATA_REQUEST_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_SEND_DATA_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_SEND_DATA_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_SEND_DATA_REQUEST_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_SEND_DATA_REQUEST_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_SEND_DATA_REQUEST_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SEND_DATA_REQUEST_RSP Members
TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST_RSP Members

ZB_SEND_DATA_REQUEST_RSP Members
See Also Example Constructors Methods
[image]

Response for ZB_SEND_DATA_REQUEST

The following tables list the members exposed by ZB_SEND_DATA_REQUEST_RSP.

Public Constructors

 | Name | Description
Public method | ZB_SEND_DATA_REQUEST_RSP | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_SEND_DATA_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_SEND_DATA_REQUEST_RSP Constructor

ZB_SEND_DATA_REQUEST_RSP Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SEND_DATA_REQUEST_RSP()
C++
public:
ZB_SEND_DATA_REQUEST_RSP() sealed
J#
public ZB_SEND_DATA_REQUEST_RSP()
JScript
public function ZB_SEND_DATA_REQUEST_RSP()

See Also

ZB_SEND_DATA_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_START_CONFIRM Class

ZB_START_CONFIRM Class
See Also Example Members
[image]

Response for ZB_START_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_START_CONFIRM
Implements IRESPONSE_CALLBACK, ISIMPLEAPI
C#
public class ZB_START_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
C++
ref class ZB_START_CONFIRM : IRESPONSE_CALLBACK, ISIMPLEAPI
J#
public class ZB_START_CONFIRM implements IRESPONSE_CALLBACK, ISIMPLEAPI
JScript
public class ZB_START_CONFIRM extends IRESPONSE_CALLBACK, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_START_CONFIRM

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_START_CONFIRM Members
TI.ZPI2 Namespace


ZB_START_CONFIRM Members

ZB_START_CONFIRM Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_START_REQUEST

The following tables list the members exposed by ZB_START_CONFIRM.

Public Constructors

Name | Description
ZB_START_CONFIRM | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_START_CONFIRM | Overloaded.
Top

See Also

ZB_START_CONFIRM Class
TI.ZPI2 Namespace


ZB_START_CONFIRM Constructor

ZB_START_CONFIRM Constructor

Overload List

 | Name | Description
Public method | ZB_START_CONFIRM | Constructor
Public method | ZB_START_CONFIRM (ZB_START_CONFIRM.CMD_STATUS) |

See Also

ZB_START_CONFIRM Class
TI.ZPI2 Namespace


ZB_START_CONFIRM Constructor ()

ZB_START_CONFIRM Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_START_CONFIRM()
C++
public:
ZB_START_CONFIRM() sealed
J#
public ZB_START_CONFIRM()
JScript
public function ZB_START_CONFIRM()

See Also

ZB_START_CONFIRM Class
TI.ZPI2 Namespace
ZB_START_CONFIRM Constructor Overload List


ZB_START_CONFIRM Constructor (ZB_START_CONFIRM.CMD_STATUS)

ZB_START_CONFIRM Constructor (ZB_START_CONFIRM.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZB_START_CONFIRM.CMD_STATUS _
)
C#
public ZB_START_CONFIRM(
ZB_START_CONFIRM.CMD_STATUS
)
C++
public:
ZB_START_CONFIRM(
ZB_START_CONFIRM.CMD_STATUS
) sealed
J#
public ZB_START_CONFIRM(
ZB_START_CONFIRM.CMD_STATUS
)
JScript
public function ZB_START_CONFIRM(
: ZB_START_CONFIRM.CMD_STATUS
)

See Also

ZB_START_CONFIRM Class
TI.ZPI2 Namespace
ZB_START_CONFIRM Constructor Overload List


Fields

ZB_START_CONFIRM Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_START_CONFIRM Class
TI.ZPI2 Namespace


Status Field

ZB_START_CONFIRM.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZB_START_CONFIRM.CMD_STATUS
C#
public ZB_START_CONFIRM.CMD_STATUS Status;
C++
public:
ZB_START_CONFIRM.CMD_STATUS Status sealed ;
J#
public ZB_START_CONFIRM.CMD_STATUS Status
JScript
public Status : ZB_START_CONFIRM.CMD_STATUS;

See Also

ZB_START_CONFIRM Class
TI.ZPI2 Namespace


ZB_START_CONFIRM.CMD_STATUS Enumeration

ZB_START_CONFIRM.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_START_CONFIRM.CMD_STATUS As Byte
C#
public enum ZB_START_CONFIRM.CMD_STATUS : byte
C++
public enum class ZB_START_CONFIRM.CMD_STATUS : char
J#
public enum ZB_START_CONFIRM.CMD_STATUS byte
JScript
public enum ZB_START_CONFIRM.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZB_START_REQUEST Class

ZB_START_REQUEST Class
See Also Example Members
[image]

Starts the ZigBee stack (zb_StartRequest).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_START_REQUEST
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_START_REQUEST : IREQUEST, ISIMPLEAPI
C++
ref class ZB_START_REQUEST : IREQUEST, ISIMPLEAPI
J#
public class ZB_START_REQUEST implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_START_REQUEST extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_START_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_START_REQUEST Members
TI.ZPI2 Namespace


ZB_START_REQUEST Members

ZB_START_REQUEST Members
See Also Example Constructors Methods
[image]

Starts the ZigBee stack (zb_StartRequest).

The following tables list the members exposed by ZB_START_REQUEST.

Public Constructors

 | Name | Description
Public method | ZB_START_REQUEST | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_START_REQUEST Class
TI.ZPI2 Namespace


ZB_START_REQUEST Constructor

ZB_START_REQUEST Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_START_REQUEST()
C++
public:
ZB_START_REQUEST() sealed
J#
public ZB_START_REQUEST()
JScript
public function ZB_START_REQUEST()

See Also

ZB_START_REQUEST Class
TI.ZPI2 Namespace


ZB_START_REQUEST_RSP Class

ZB_START_REQUEST_RSP Class
See Also Example Members
[image]

Response for ZB_START_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_START_REQUEST_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_START_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_START_REQUEST_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_START_REQUEST_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_START_REQUEST_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_START_REQUEST_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_START_REQUEST_RSP Members
TI.ZPI2 Namespace


ZB_START_REQUEST_RSP Members

ZB_START_REQUEST_RSP Members
See Also Example Constructors Methods
[image]

Response for ZB_START_REQUEST

The following tables list the members exposed by ZB_START_REQUEST_RSP.

Public Constructors

 | Name | Description
Public method | ZB_START_REQUEST_RSP | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_START_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_START_REQUEST_RSP Constructor

ZB_START_REQUEST_RSP Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_START_REQUEST_RSP()
C++
public:
ZB_START_REQUEST_RSP() sealed
J#
public ZB_START_REQUEST_RSP()
JScript
public function ZB_START_REQUEST_RSP()

See Also

ZB_START_REQUEST_RSP Class
TI.ZPI2 Namespace


ZB_SYSTEM_RESET Class

ZB_SYSTEM_RESET Class
See Also Example Members
[image]

Reboot the device (zb_SystemReset)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_SYSTEM_RESET
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_SYSTEM_RESET : IREQUEST, ISIMPLEAPI
C++
ref class ZB_SYSTEM_RESET : IREQUEST, ISIMPLEAPI
J#
public class ZB_SYSTEM_RESET implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_SYSTEM_RESET extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_SYSTEM_RESET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_SYSTEM_RESET Members
TI.ZPI2 Namespace


ZB_SYSTEM_RESET Members

ZB_SYSTEM_RESET Members
See Also Example Constructors Methods
[image]

Reboot the device (zb_SystemReset)

The following tables list the members exposed by ZB_SYSTEM_RESET.

Public Constructors

 | Name | Description
Public method | ZB_SYSTEM_RESET | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZB_SYSTEM_RESET Class
TI.ZPI2 Namespace


ZB_SYSTEM_RESET Constructor

ZB_SYSTEM_RESET Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_SYSTEM_RESET()
C++
public:
ZB_SYSTEM_RESET() sealed
J#
public ZB_SYSTEM_RESET()
JScript
public function ZB_SYSTEM_RESET()

See Also

ZB_SYSTEM_RESET Class
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION Class

ZB_WRITE_CONFIGURATION Class
See Also Example Members
[image]

Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_WRITE_CONFIGURATION
Implements IREQUEST, ISIMPLEAPI
C#
public class ZB_WRITE_CONFIGURATION : IREQUEST, ISIMPLEAPI
C++
ref class ZB_WRITE_CONFIGURATION : IREQUEST, ISIMPLEAPI
J#
public class ZB_WRITE_CONFIGURATION implements IREQUEST, ISIMPLEAPI
JScript
public class ZB_WRITE_CONFIGURATION extends IREQUEST, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_WRITE_CONFIGURATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_WRITE_CONFIGURATION Members
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION Members

ZB_WRITE_CONFIGURATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Writes a configuration property to nonvolatile memory (zb_WriteConfiguration).

The following tables list the members exposed by ZB_WRITE_CONFIGURATION.

Public Constructors

Name | Description
ZB_WRITE_CONFIGURATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ConfigId | Identifier of property to write.
Public field | Len | Length of the value of the property.
Public field | Value | Array containing value to write to property
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_WRITE_CONFIGURATION | Overloaded.
Top

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION Constructor

ZB_WRITE_CONFIGURATION Constructor

Overload List

 | Name | Description
Public method | ZB_WRITE_CONFIGURATION | Constructor
Public method | ZB_WRITE_CONFIGURATION (Byte, Byte, Byte) | Constructor

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION Constructor ()

ZB_WRITE_CONFIGURATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_WRITE_CONFIGURATION()
C++
public:
ZB_WRITE_CONFIGURATION() sealed
J#
public ZB_WRITE_CONFIGURATION()
JScript
public function ZB_WRITE_CONFIGURATION()

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace
ZB_WRITE_CONFIGURATION Constructor Overload List


ZB_WRITE_CONFIGURATION Constructor (Byte, Byte, Byte[])

ZB_WRITE_CONFIGURATION Constructor (Byte, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZB_WRITE_CONFIGURATION(
byte ,
byte ,
byte[]
)
C++
public:
ZB_WRITE_CONFIGURATION(
char ,
char ,
array<char>^
) sealed
J#
public ZB_WRITE_CONFIGURATION(
byte ,
byte ,
byte[]
)
JScript
public function ZB_WRITE_CONFIGURATION(
: Byte,
: Byte,
: Byte[]
)

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace
ZB_WRITE_CONFIGURATION Constructor Overload List


Fields

ZB_WRITE_CONFIGURATION Fields
[image]

Public Fields

 | Name | Description
Public field | ConfigId | Identifier of property to write.
Public field | Len | Length of the value of the property.
Public field | Value | Array containing value to write to property
Top

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace


ConfigId Field

ZB_WRITE_CONFIGURATION.ConfigId Field
[image]

Identifier of property to write.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ConfigId As Byte
C#
public byte ConfigId;
C++
public:
char ConfigId sealed ;
J#
public byte ConfigId
JScript
public ConfigId : Byte;

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace


Len Field

ZB_WRITE_CONFIGURATION.Len Field
[image]

Length of the value of the property.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace


Value Field

ZB_WRITE_CONFIGURATION.Value Field
[image]

Array containing value to write to property

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZB_WRITE_CONFIGURATION Class
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION_RSP Class

ZB_WRITE_CONFIGURATION_RSP Class
See Also Example Members
[image]

Response for ZB_WRITE_CONFIGURATION

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZB_WRITE_CONFIGURATION_RSP
Implements IRESPONSE, ISIMPLEAPI
C#
public class ZB_WRITE_CONFIGURATION_RSP : IRESPONSE, ISIMPLEAPI
C++
ref class ZB_WRITE_CONFIGURATION_RSP : IRESPONSE, ISIMPLEAPI
J#
public class ZB_WRITE_CONFIGURATION_RSP implements IRESPONSE, ISIMPLEAPI
JScript
public class ZB_WRITE_CONFIGURATION_RSP extends IRESPONSE, ISIMPLEAPI

Inheritance Hierarchy

System.Object
TI.ZPI2.ZB_WRITE_CONFIGURATION_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZB_WRITE_CONFIGURATION_RSP Members
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION_RSP Members

ZB_WRITE_CONFIGURATION_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZB_WRITE_CONFIGURATION

The following tables list the members exposed by ZB_WRITE_CONFIGURATION_RSP.

Public Constructors

Name | Description
ZB_WRITE_CONFIGURATION_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZB_WRITE_CONFIGURATION_RSP | Overloaded.
Top

See Also

ZB_WRITE_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION_RSP Constructor

ZB_WRITE_CONFIGURATION_RSP Constructor

Overload List

 | Name | Description
Public method | ZB_WRITE_CONFIGURATION_RSP | Constructor
Public method | ZB_WRITE_CONFIGURATION_RSP (ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS) |

See Also

ZB_WRITE_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION_RSP Constructor ()

ZB_WRITE_CONFIGURATION_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZB_WRITE_CONFIGURATION_RSP()
C++
public:
ZB_WRITE_CONFIGURATION_RSP() sealed
J#
public ZB_WRITE_CONFIGURATION_RSP()
JScript
public function ZB_WRITE_CONFIGURATION_RSP()

See Also

ZB_WRITE_CONFIGURATION_RSP Class
TI.ZPI2 Namespace
ZB_WRITE_CONFIGURATION_RSP Constructor Overload List


ZB_WRITE_CONFIGURATION_RSP Constructor (ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS)

ZB_WRITE_CONFIGURATION_RSP Constructor (ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS _
)
C#
public ZB_WRITE_CONFIGURATION_RSP(
ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS
)
C++
public:
ZB_WRITE_CONFIGURATION_RSP(
ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS
) sealed
J#
public ZB_WRITE_CONFIGURATION_RSP(
ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS
)
JScript
public function ZB_WRITE_CONFIGURATION_RSP(
: ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS
)

See Also

ZB_WRITE_CONFIGURATION_RSP Class
TI.ZPI2 Namespace
ZB_WRITE_CONFIGURATION_RSP Constructor Overload List


Fields

ZB_WRITE_CONFIGURATION_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | The immediate return value from executing the RPC.
Top

See Also

ZB_WRITE_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


Status Field

ZB_WRITE_CONFIGURATION_RSP.Status Field
[image]

The immediate return value from executing the RPC.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS
C#
public ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS Status;
C++
public:
ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS Status sealed ;
J#
public ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS Status
JScript
public Status : ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS;

See Also

ZB_WRITE_CONFIGURATION_RSP Class
TI.ZPI2 Namespace


ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS Enumeration

ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS As Byte
C#
public enum ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS : byte
C++
public enum class ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS : char
J#
public enum ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS byte
JScript
public enum ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ Class

ZDO_ACTIVE_EP_REQ Class
See Also Example Members
[image]

This command is generated to request a list of active endpoint from the destination device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ACTIVE_EP_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_ACTIVE_EP_REQ : IREQUEST, IZDO
C++
ref class ZDO_ACTIVE_EP_REQ : IREQUEST, IZDO
J#
public class ZDO_ACTIVE_EP_REQ implements IREQUEST, IZDO
JScript
public class ZDO_ACTIVE_EP_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_ACTIVE_EP_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ACTIVE_EP_REQ Members
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ Members

ZDO_ACTIVE_EP_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a list of active endpoint from the destination device.

The following tables list the members exposed by ZDO_ACTIVE_EP_REQ.

Public Constructors

Name | Description
ZDO_ACTIVE_EP_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ACTIVE_EP_REQ | Overloaded.
Top

See Also

ZDO_ACTIVE_EP_REQ Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ Constructor

ZDO_ACTIVE_EP_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_ACTIVE_EP_REQ | Constructor
Public method | ZDO_ACTIVE_EP_REQ (UInt16, UInt16) | Constructor

See Also

ZDO_ACTIVE_EP_REQ Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ Constructor ()

ZDO_ACTIVE_EP_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ACTIVE_EP_REQ()
C++
public:
ZDO_ACTIVE_EP_REQ() sealed
J#
public ZDO_ACTIVE_EP_REQ()
JScript
public function ZDO_ACTIVE_EP_REQ()

See Also

ZDO_ACTIVE_EP_REQ Class
TI.ZPI2 Namespace
ZDO_ACTIVE_EP_REQ Constructor Overload List


ZDO_ACTIVE_EP_REQ Constructor (UInt16, UInt16)

ZDO_ACTIVE_EP_REQ Constructor (UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public ZDO_ACTIVE_EP_REQ(
ushort ,
ushort
)
C++
public:
ZDO_ACTIVE_EP_REQ(
unsigned short ,
unsigned short
) sealed
J#
public ZDO_ACTIVE_EP_REQ(
ushort ,
ushort
)
JScript
public function ZDO_ACTIVE_EP_REQ(
: UInt16,
: UInt16
)

See Also

ZDO_ACTIVE_EP_REQ Class
TI.ZPI2 Namespace
ZDO_ACTIVE_EP_REQ Constructor Overload List


Fields

ZDO_ACTIVE_EP_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

See Also

ZDO_ACTIVE_EP_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_ACTIVE_EP_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_ACTIVE_EP_REQ Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_ACTIVE_EP_REQ.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_ACTIVE_EP_REQ Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ_SRSP Class

ZDO_ACTIVE_EP_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_ACTIVE_EP_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ACTIVE_EP_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_ACTIVE_EP_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_ACTIVE_EP_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_ACTIVE_EP_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_ACTIVE_EP_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_ACTIVE_EP_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ACTIVE_EP_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ_SRSP Members

ZDO_ACTIVE_EP_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_ACTIVE_EP_REQ

The following tables list the members exposed by ZDO_ACTIVE_EP_REQ_SRSP.

Public Constructors

Name | Description
ZDO_ACTIVE_EP_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ACTIVE_EP_REQ_SRSP | Overloaded.
Top

See Also

ZDO_ACTIVE_EP_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ_SRSP Constructor

ZDO_ACTIVE_EP_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_ACTIVE_EP_REQ_SRSP | Constructor
Public method | ZDO_ACTIVE_EP_REQ_SRSP (ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS) |

See Also

ZDO_ACTIVE_EP_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ_SRSP Constructor ()

ZDO_ACTIVE_EP_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ACTIVE_EP_REQ_SRSP()
C++
public:
ZDO_ACTIVE_EP_REQ_SRSP() sealed
J#
public ZDO_ACTIVE_EP_REQ_SRSP()
JScript
public function ZDO_ACTIVE_EP_REQ_SRSP()

See Also

ZDO_ACTIVE_EP_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_ACTIVE_EP_REQ_SRSP Constructor Overload List


ZDO_ACTIVE_EP_REQ_SRSP Constructor (ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS)

ZDO_ACTIVE_EP_REQ_SRSP Constructor (ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_ACTIVE_EP_REQ_SRSP(
ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_ACTIVE_EP_REQ_SRSP(
ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_ACTIVE_EP_REQ_SRSP(
ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_ACTIVE_EP_REQ_SRSP(
: ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS
)

See Also

ZDO_ACTIVE_EP_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_ACTIVE_EP_REQ_SRSP Constructor Overload List


Fields

ZDO_ACTIVE_EP_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_ACTIVE_EP_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_ACTIVE_EP_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS
C#
public ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS;

See Also

ZDO_ACTIVE_EP_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS Enumeration

ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_ACTIVE_EP_RSP Class

ZDO_ACTIVE_EP_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Active Endpoint Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_ACTIVE_EP_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_ACTIVE_EP_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_ACTIVE_EP_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_ACTIVE_EP_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_ACTIVE_EP_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_ACTIVE_EP_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_ACTIVE_EP_RSP Members
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_RSP Members

ZDO_ACTIVE_EP_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Active Endpoint Request.

The following tables list the members exposed by ZDO_ACTIVE_EP_RSP.

Public Constructors

Name | Description
ZDO_ACTIVE_EP_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ActiveEPCount | Number of active endpoint in the list
Public field | ActiveEPList | Array of active endpoints on this device
Public field | NwkAddr | Device's short address that this response describes.
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_ACTIVE_EP_RSP | Overloaded.
Top

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_RSP Constructor

ZDO_ACTIVE_EP_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_ACTIVE_EP_RSP | Constructor
Public method | ZDO_ACTIVE_EP_RSP (UInt16, ZDO_ACTIVE_EP_RSP.ZDO_STATUS, UInt16, Byte, Byte) |

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_RSP Constructor ()

ZDO_ACTIVE_EP_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_ACTIVE_EP_RSP()
C++
public:
ZDO_ACTIVE_EP_RSP() sealed
J#
public ZDO_ACTIVE_EP_RSP()
JScript
public function ZDO_ACTIVE_EP_RSP()

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace
ZDO_ACTIVE_EP_RSP Constructor Overload List


ZDO_ACTIVE_EP_RSP Constructor (UInt16, ZDO_ACTIVE_EP_RSP.ZDO_STATUS, UInt16, Byte, Byte[])

ZDO_ACTIVE_EP_RSP Constructor (UInt16, ZDO_ACTIVE_EP_RSP.ZDO_STATUS, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_ACTIVE_EP_RSP.ZDO_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_ACTIVE_EP_RSP(
ushort ,
ZDO_ACTIVE_EP_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_ACTIVE_EP_RSP(
unsigned short ,
ZDO_ACTIVE_EP_RSP.ZDO_STATUS ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_ACTIVE_EP_RSP(
ushort ,
ZDO_ACTIVE_EP_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_ACTIVE_EP_RSP(
: UInt16,
: ZDO_ACTIVE_EP_RSP.ZDO_STATUS,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace
ZDO_ACTIVE_EP_RSP Constructor Overload List


Fields

ZDO_ACTIVE_EP_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | ActiveEPCount | Number of active endpoint in the list
Public field | ActiveEPList | Array of active endpoints on this device
Public field | NwkAddr | Device's short address that this response describes.
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


ActiveEPCount Field

ZDO_ACTIVE_EP_RSP.ActiveEPCount Field
[image]

Number of active endpoint in the list

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ActiveEPCount As Byte
C#
public byte ActiveEPCount;
C++
public:
char ActiveEPCount sealed ;
J#
public byte ActiveEPCount
JScript
public ActiveEPCount : Byte;

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


ActiveEPList Field

ZDO_ACTIVE_EP_RSP.ActiveEPList Field
[image]

Array of active endpoints on this device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ActiveEPList As Byte()
C#
public byte[] ActiveEPList;
C++
public:
array<char>^ ActiveEPList sealed ;
J#
public byte[] ActiveEPList
JScript
public ActiveEPList : Byte[];

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_ACTIVE_EP_RSP.NwkAddr Field
[image]

Device's short address that this response describes.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_ACTIVE_EP_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_ACTIVE_EP_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_ACTIVE_EP_RSP.ZDO_STATUS
C#
public ZDO_ACTIVE_EP_RSP.ZDO_STATUS Status;
C++
public:
ZDO_ACTIVE_EP_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_ACTIVE_EP_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_ACTIVE_EP_RSP.ZDO_STATUS;

See Also

ZDO_ACTIVE_EP_RSP Class
TI.ZPI2 Namespace


ZDO_ACTIVE_EP_RSP.ZDO_STATUS Enumeration

ZDO_ACTIVE_EP_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_ACTIVE_EP_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_ACTIVE_EP_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_ACTIVE_EP_RSP.ZDO_STATUS : char
J#
public enum ZDO_ACTIVE_EP_RSP.ZDO_STATUS byte
JScript
public enum ZDO_ACTIVE_EP_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_AUTO_FIND_DESTINATION Class

ZDO_AUTO_FIND_DESTINATION Class
See Also Example Members
[image]

This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_AUTO_FIND_DESTINATION
Implements IREQUEST, IZDO
C#
public class ZDO_AUTO_FIND_DESTINATION : IREQUEST, IZDO
C++
ref class ZDO_AUTO_FIND_DESTINATION : IREQUEST, IZDO
J#
public class ZDO_AUTO_FIND_DESTINATION implements IREQUEST, IZDO
JScript
public class ZDO_AUTO_FIND_DESTINATION extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_AUTO_FIND_DESTINATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_AUTO_FIND_DESTINATION Members
TI.ZPI2 Namespace


ZDO_AUTO_FIND_DESTINATION Members

ZDO_AUTO_FIND_DESTINATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function will issue a Match Description Request for the requested endpoint outputs. This message will generate a broadcast message.

The following tables list the members exposed by ZDO_AUTO_FIND_DESTINATION.

Public Constructors

Name | Description
ZDO_AUTO_FIND_DESTINATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Endpoint | Specifies which endpoint to issue the End Device Bind request for
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_AUTO_FIND_DESTINATION | Overloaded.
Top

See Also

ZDO_AUTO_FIND_DESTINATION Class
TI.ZPI2 Namespace


ZDO_AUTO_FIND_DESTINATION Constructor

ZDO_AUTO_FIND_DESTINATION Constructor

Overload List

 | Name | Description
Public method | ZDO_AUTO_FIND_DESTINATION | Constructor
Public method | ZDO_AUTO_FIND_DESTINATION (Byte) | Constructor

See Also

ZDO_AUTO_FIND_DESTINATION Class
TI.ZPI2 Namespace


ZDO_AUTO_FIND_DESTINATION Constructor ()

ZDO_AUTO_FIND_DESTINATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_AUTO_FIND_DESTINATION()
C++
public:
ZDO_AUTO_FIND_DESTINATION() sealed
J#
public ZDO_AUTO_FIND_DESTINATION()
JScript
public function ZDO_AUTO_FIND_DESTINATION()

See Also

ZDO_AUTO_FIND_DESTINATION Class
TI.ZPI2 Namespace
ZDO_AUTO_FIND_DESTINATION Constructor Overload List


ZDO_AUTO_FIND_DESTINATION Constructor (Byte)

ZDO_AUTO_FIND_DESTINATION Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZDO_AUTO_FIND_DESTINATION(
byte
)
C++
public:
ZDO_AUTO_FIND_DESTINATION(
char
) sealed
J#
public ZDO_AUTO_FIND_DESTINATION(
byte
)
JScript
public function ZDO_AUTO_FIND_DESTINATION(
: Byte
)

See Also

ZDO_AUTO_FIND_DESTINATION Class
TI.ZPI2 Namespace
ZDO_AUTO_FIND_DESTINATION Constructor Overload List


Fields

ZDO_AUTO_FIND_DESTINATION Fields
[image]

Public Fields

 | Name | Description
Public field | Endpoint | Specifies which endpoint to issue the End Device Bind request for
Top

See Also

ZDO_AUTO_FIND_DESTINATION Class
TI.ZPI2 Namespace


Endpoint Field

ZDO_AUTO_FIND_DESTINATION.Endpoint Field
[image]

Specifies which endpoint to issue the End Device Bind request for

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_AUTO_FIND_DESTINATION Class
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND Class

ZDO_BEACON_NOTIFY_IND Class
See Also Example Members
[image]

This message is an indication to inform host device the receipt of a beacon notification

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_BEACON_NOTIFY_IND
Implements IRESPONSE, IZDO
C#
public class ZDO_BEACON_NOTIFY_IND : IRESPONSE, IZDO
C++
ref class ZDO_BEACON_NOTIFY_IND : IRESPONSE, IZDO
J#
public class ZDO_BEACON_NOTIFY_IND implements IRESPONSE, IZDO
JScript
public class ZDO_BEACON_NOTIFY_IND extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_BEACON_NOTIFY_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BEACON_NOTIFY_IND Members
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND Members

ZDO_BEACON_NOTIFY_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is an indication to inform host device the receipt of a beacon notification

The following tables list the members exposed by ZDO_BEACON_NOTIFY_IND.

Public Constructors

Name | Description
ZDO_BEACON_NOTIFY_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BeaconCount | Number of beacon in the list
Public field | BeaconList | Array of beacon structures
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_BEACON_NOTIFY_IND | Overloaded.
Top

See Also

ZDO_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND Constructor

ZDO_BEACON_NOTIFY_IND Constructor

Overload List

 | Name | Description
Public method | ZDO_BEACON_NOTIFY_IND | Constructor
Public method | ZDO_BEACON_NOTIFY_IND (Byte, Object) | Constructor

See Also

ZDO_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND Constructor ()

ZDO_BEACON_NOTIFY_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BEACON_NOTIFY_IND()
C++
public:
ZDO_BEACON_NOTIFY_IND() sealed
J#
public ZDO_BEACON_NOTIFY_IND()
JScript
public function ZDO_BEACON_NOTIFY_IND()

See Also

ZDO_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace
ZDO_BEACON_NOTIFY_IND Constructor Overload List


ZDO_BEACON_NOTIFY_IND Constructor (Byte, Object[])

ZDO_BEACON_NOTIFY_IND Constructor (Byte, Object[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_BEACON_NOTIFY_IND(
byte ,
object[]
)
C++
public:
ZDO_BEACON_NOTIFY_IND(
char ,
array<Object>^
) sealed
J#
public ZDO_BEACON_NOTIFY_IND(
byte ,
object[]
)
JScript
public function ZDO_BEACON_NOTIFY_IND(
: Byte,
: Object[]
)

See Also

ZDO_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace
ZDO_BEACON_NOTIFY_IND Constructor Overload List


Fields

ZDO_BEACON_NOTIFY_IND Fields
[image]

Public Fields

 | Name | Description
Public field | BeaconCount | Number of beacon in the list
Public field | BeaconList | Array of beacon structures
Top

See Also

ZDO_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


BeaconCount Field

ZDO_BEACON_NOTIFY_IND.BeaconCount Field
[image]

Number of beacon in the list

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconCount As Byte
C#
public byte BeaconCount;
C++
public:
char BeaconCount sealed ;
J#
public byte BeaconCount
JScript
public BeaconCount : Byte;

See Also

ZDO_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


BeaconList Field

ZDO_BEACON_NOTIFY_IND.BeaconList Field
[image]

Array of beacon structures

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconList As Object()
C#
public object[] BeaconList;
C++
public:
array<Object>^ BeaconList sealed ;
J#
public object[] BeaconList
JScript
public BeaconList : Object[];

See Also

ZDO_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
See Also Example Members
[image]

Beacon List Class. Used with ZDO_BEACON_NOTIFY_IND

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_BEACON_NOTIFY_IND.BeaconListItemClass
C#
public struct ZDO_BEACON_NOTIFY_IND.BeaconListItemClass
C++
value class ZDO_BEACON_NOTIFY_IND.BeaconListItemClass
J#
public final class ZDO_BEACON_NOTIFY_IND.BeaconListItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_BEACON_NOTIFY_IND.BeaconListItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Members
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Members

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Beacon List Class. Used with ZDO_BEACON_NOTIFY_IND

The following tables list the members exposed by ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.

Public Constructors

Name | Description
ZDO_BEACON_NOTIFY_IND.BeaconListItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Depth |
Public field | DeviceCapacity |
Public field | ExtendedPanId |
Public field | LogicalChannel |
Public field | LQI |
Public field | PanId |
Public field | PermitJoining |
Public field | ProtocolVersion |
Public field | RouterCapacity |
Public field | SourceAddress |
Public field | StackProfile |
Public field | UpdateId |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
ZDO_BEACON_NOTIFY_IND.BeaconListItemClass | Overloaded.
Top

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor

Overload List

 | Name | Description
Public method | ZDO_BEACON_NOTIFY_IND.BeaconListItemClass | Initializes a new instance of the ZDO_BEACON_NOTIFY_IND.BeaconListItemClass class.
Public method | ZDO_BEACON_NOTIFY_IND.BeaconListItemClass (UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, UInt64) |

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor ()

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the ZDO_BEACON_NOTIFY_IND.BeaconListItemClass class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BEACON_NOTIFY_IND.BeaconListItemClass()
C++
public:
ZDO_BEACON_NOTIFY_IND.BeaconListItemClass() sealed
J#
public ZDO_BEACON_NOTIFY_IND.BeaconListItemClass()
JScript
public function ZDO_BEACON_NOTIFY_IND.BeaconListItemClass()

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace
ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor Overload List


ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor (UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, UInt64)

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor (UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, UInt64)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt64 _
)
C#
public ZDO_BEACON_NOTIFY_IND.BeaconListItemClass(
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
ulong
)
C++
public:
ZDO_BEACON_NOTIFY_IND.BeaconListItemClass(
unsigned short ,
unsigned short ,
char ,
char ,
char ,
char ,
char ,
char ,
char ,
char ,
char ,
unsigned __int64
) sealed
J#
public ZDO_BEACON_NOTIFY_IND.BeaconListItemClass(
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
ulong
)
JScript
public function ZDO_BEACON_NOTIFY_IND.BeaconListItemClass(
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: UInt64
)

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace
ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Constructor Overload List


Fields

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | Depth |
Public field | DeviceCapacity |
Public field | ExtendedPanId |
Public field | LogicalChannel |
Public field | LQI |
Public field | PanId |
Public field | PermitJoining |
Public field | ProtocolVersion |
Public field | RouterCapacity |
Public field | SourceAddress |
Public field | StackProfile |
Public field | UpdateId |
Top

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


Depth Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.Depth Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Depth As Byte
C#
public byte Depth;
C++
public:
char Depth sealed ;
J#
public byte Depth
JScript
public Depth : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


DeviceCapacity Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.DeviceCapacity Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceCapacity As Byte
C#
public byte DeviceCapacity;
C++
public:
char DeviceCapacity sealed ;
J#
public byte DeviceCapacity
JScript
public DeviceCapacity : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


ExtendedPanId Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.ExtendedPanId Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedPanId As UInt64
C#
public ulong ExtendedPanId;
C++
public:
unsigned __int64 ExtendedPanId sealed ;
J#
public ulong ExtendedPanId
JScript
public ExtendedPanId : UInt64;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


LogicalChannel Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.LogicalChannel Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


LQI Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.LQI Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LQI As Byte
C#
public byte LQI;
C++
public:
char LQI sealed ;
J#
public byte LQI
JScript
public LQI : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


PanId Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.PanId Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


PermitJoining Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.PermitJoining Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PermitJoining As Byte
C#
public byte PermitJoining;
C++
public:
char PermitJoining sealed ;
J#
public byte PermitJoining
JScript
public PermitJoining : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


ProtocolVersion Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.ProtocolVersion Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ProtocolVersion As Byte
C#
public byte ProtocolVersion;
C++
public:
char ProtocolVersion sealed ;
J#
public byte ProtocolVersion
JScript
public ProtocolVersion : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


RouterCapacity Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.RouterCapacity Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RouterCapacity As Byte
C#
public byte RouterCapacity;
C++
public:
char RouterCapacity sealed ;
J#
public byte RouterCapacity
JScript
public RouterCapacity : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


SourceAddress Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.SourceAddress Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SourceAddress As UInt16
C#
public ushort SourceAddress;
C++
public:
unsigned short SourceAddress sealed ;
J#
public ushort SourceAddress
JScript
public SourceAddress : UInt16;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


StackProfile Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.StackProfile Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StackProfile As Byte
C#
public byte StackProfile;
C++
public:
char StackProfile sealed ;
J#
public byte StackProfile
JScript
public StackProfile : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


UpdateId Field

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass.UpdateId Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UpdateId As Byte
C#
public byte UpdateId;
C++
public:
char UpdateId sealed ;
J#
public byte UpdateId
JScript
public UpdateId : Byte;

See Also

ZDO_BEACON_NOTIFY_IND.BeaconListItemClass Structure
TI.ZPI2 Namespace


ZDO_BIND_REQ Class

ZDO_BIND_REQ Class
See Also Example Members
[image]

This command is generated to request a Bind

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_BIND_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_BIND_REQ : IREQUEST, IZDO
C++
ref class ZDO_BIND_REQ : IREQUEST, IZDO
J#
public class ZDO_BIND_REQ implements IREQUEST, IZDO
JScript
public class ZDO_BIND_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_BIND_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BIND_REQ Members
TI.ZPI2 Namespace


ZDO_BIND_REQ Members

ZDO_BIND_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Bind

The following tables list the members exposed by ZDO_BIND_REQ.

Public Constructors

Name | Description
ZDO_BIND_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BindAddr | The binding destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | BindAddrMode | The binding destination address mode according to afAddrMode_t.
Public field | BindEndpoint | The binding destination endpoint
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint. See Table 1 for formatting
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_BIND_REQ | Overloaded.
Top

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_BIND_REQ Constructor

ZDO_BIND_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_BIND_REQ | Constructor
Public method | ZDO_BIND_REQ (UInt16, UInt64, Byte, UInt16, ZDO_BIND_REQ.ADDRESS_MODE, Byte, Byte) |

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_BIND_REQ Constructor ()

ZDO_BIND_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BIND_REQ()
C++
public:
ZDO_BIND_REQ() sealed
J#
public ZDO_BIND_REQ()
JScript
public function ZDO_BIND_REQ()

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace
ZDO_BIND_REQ Constructor Overload List


ZDO_BIND_REQ Constructor (UInt16, UInt64, Byte, UInt16, ZDO_BIND_REQ.ADDRESS_MODE, Byte[], Byte)

ZDO_BIND_REQ Constructor (UInt16, UInt64, Byte, UInt16, ZDO_BIND_REQ.ADDRESS_MODE, Byte[], Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As ZDO_BIND_REQ.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As Byte _
)
C#
public ZDO_BIND_REQ(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_BIND_REQ.ADDRESS_MODE ,
byte[] ,
byte
)
C++
public:
ZDO_BIND_REQ(
unsigned short ,
unsigned __int64 ,
char ,
unsigned short ,
ZDO_BIND_REQ.ADDRESS_MODE ,
array<char>^ ,
char
) sealed
J#
public ZDO_BIND_REQ(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_BIND_REQ.ADDRESS_MODE ,
byte[] ,
byte
)
JScript
public function ZDO_BIND_REQ(
: UInt16,
: UInt64,
: Byte,
: UInt16,
: ZDO_BIND_REQ.ADDRESS_MODE,
: Byte[],
: Byte
)

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace
ZDO_BIND_REQ Constructor Overload List


Fields

ZDO_BIND_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | BindAddr | The binding destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | BindAddrMode | The binding destination address mode according to afAddrMode_t.
Public field | BindEndpoint | The binding destination endpoint
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint. See Table 1 for formatting
Top

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


BindAddr Field

ZDO_BIND_REQ.BindAddr Field
[image]

The binding destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindAddr As Byte()
C#
public byte[] BindAddr;
C++
public:
array<char>^ BindAddr sealed ;
J#
public byte[] BindAddr
JScript
public BindAddr : Byte[];

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


BindAddrMode Field

ZDO_BIND_REQ.BindAddrMode Field
[image]

The binding destination address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindAddrMode As ZDO_BIND_REQ.ADDRESS_MODE
C#
public ZDO_BIND_REQ.ADDRESS_MODE BindAddrMode;
C++
public:
ZDO_BIND_REQ.ADDRESS_MODE BindAddrMode sealed ;
J#
public ZDO_BIND_REQ.ADDRESS_MODE BindAddrMode
JScript
public BindAddrMode : ZDO_BIND_REQ.ADDRESS_MODE;

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


BindEndpoint Field

ZDO_BIND_REQ.BindEndpoint Field
[image]

The binding destination endpoint

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindEndpoint As Byte
C#
public byte BindEndpoint;
C++
public:
char BindEndpoint sealed ;
J#
public byte BindEndpoint
JScript
public BindEndpoint : Byte;

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


ClusterID Field

ZDO_BIND_REQ.ClusterID Field
[image]

Cluster ID to match in messages

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_BIND_REQ.DstAddr Field
[image]

destination address, where this message is going

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


SrcAddress Field

ZDO_BIND_REQ.SrcAddress Field
[image]

64 bit Binding source address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


SrcEndpoint Field

ZDO_BIND_REQ.SrcEndpoint Field
[image]

Binding source endpoint. See Table 1 for formatting

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

ZDO_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_BIND_REQ.ADDRESS_MODE Enumeration

ZDO_BIND_REQ.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_BIND_REQ.ADDRESS_MODE As Byte
C#
public enum ZDO_BIND_REQ.ADDRESS_MODE : byte
C++
public enum class ZDO_BIND_REQ.ADDRESS_MODE : char
J#
public enum ZDO_BIND_REQ.ADDRESS_MODE byte
JScript
public enum ZDO_BIND_REQ.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZDO_BIND_REQ_SRSP Class

ZDO_BIND_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_BIND_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_BIND_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_BIND_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_BIND_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_BIND_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_BIND_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_BIND_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BIND_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_BIND_REQ_SRSP Members

ZDO_BIND_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_BIND_REQ

The following tables list the members exposed by ZDO_BIND_REQ_SRSP.

Public Constructors

Name | Description
ZDO_BIND_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_BIND_REQ_SRSP | Overloaded.
Top

See Also

ZDO_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_BIND_REQ_SRSP Constructor

ZDO_BIND_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_BIND_REQ_SRSP | Constructor
Public method | ZDO_BIND_REQ_SRSP (ZDO_BIND_REQ_SRSP.AF_STATUS) |

See Also

ZDO_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_BIND_REQ_SRSP Constructor ()

ZDO_BIND_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BIND_REQ_SRSP()
C++
public:
ZDO_BIND_REQ_SRSP() sealed
J#
public ZDO_BIND_REQ_SRSP()
JScript
public function ZDO_BIND_REQ_SRSP()

See Also

ZDO_BIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_BIND_REQ_SRSP Constructor Overload List


ZDO_BIND_REQ_SRSP Constructor (ZDO_BIND_REQ_SRSP.AF_STATUS)

ZDO_BIND_REQ_SRSP Constructor (ZDO_BIND_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_BIND_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_BIND_REQ_SRSP(
ZDO_BIND_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_BIND_REQ_SRSP(
ZDO_BIND_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_BIND_REQ_SRSP(
ZDO_BIND_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_BIND_REQ_SRSP(
: ZDO_BIND_REQ_SRSP.AF_STATUS
)

See Also

ZDO_BIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_BIND_REQ_SRSP Constructor Overload List


Fields

ZDO_BIND_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_BIND_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_BIND_REQ_SRSP.AF_STATUS
C#
public ZDO_BIND_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_BIND_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_BIND_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_BIND_REQ_SRSP.AF_STATUS;

See Also

ZDO_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_BIND_REQ_SRSP.AF_STATUS Enumeration

ZDO_BIND_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_BIND_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_BIND_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_BIND_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_BIND_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_BIND_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_BIND_RSP Class

ZDO_BIND_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Bind Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_BIND_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_BIND_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_BIND_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_BIND_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_BIND_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_BIND_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_BIND_RSP Members
TI.ZPI2 Namespace


ZDO_BIND_RSP Members

ZDO_BIND_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Bind Request

The following tables list the members exposed by ZDO_BIND_RSP.

Public Constructors

Name | Description
ZDO_BIND_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_BIND_RSP | Overloaded.
Top

See Also

ZDO_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_BIND_RSP Constructor

ZDO_BIND_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_BIND_RSP | Constructor
Public method | ZDO_BIND_RSP (UInt16, ZDO_BIND_RSP.ZDO_STATUS) |

See Also

ZDO_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_BIND_RSP Constructor ()

ZDO_BIND_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_BIND_RSP()
C++
public:
ZDO_BIND_RSP() sealed
J#
public ZDO_BIND_RSP()
JScript
public function ZDO_BIND_RSP()

See Also

ZDO_BIND_RSP Class
TI.ZPI2 Namespace
ZDO_BIND_RSP Constructor Overload List


ZDO_BIND_RSP Constructor (UInt16, ZDO_BIND_RSP.ZDO_STATUS)

ZDO_BIND_RSP Constructor (UInt16, ZDO_BIND_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_BIND_RSP.ZDO_STATUS _
)
C#
public ZDO_BIND_RSP(
ushort ,
ZDO_BIND_RSP.ZDO_STATUS
)
C++
public:
ZDO_BIND_RSP(
unsigned short ,
ZDO_BIND_RSP.ZDO_STATUS
) sealed
J#
public ZDO_BIND_RSP(
ushort ,
ZDO_BIND_RSP.ZDO_STATUS
)
JScript
public function ZDO_BIND_RSP(
: UInt16,
: ZDO_BIND_RSP.ZDO_STATUS
)

See Also

ZDO_BIND_RSP Class
TI.ZPI2 Namespace
ZDO_BIND_RSP Constructor Overload List


Fields

ZDO_BIND_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_BIND_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_BIND_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_BIND_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_BIND_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_BIND_RSP.ZDO_STATUS
C#
public ZDO_BIND_RSP.ZDO_STATUS Status;
C++
public:
ZDO_BIND_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_BIND_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_BIND_RSP.ZDO_STATUS;

See Also

ZDO_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_BIND_RSP.ZDO_STATUS Enumeration

ZDO_BIND_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_BIND_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_BIND_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_BIND_RSP.ZDO_STATUS : char
J#
public enum ZDO_BIND_RSP.ZDO_STATUS byte
JScript
public enum ZDO_BIND_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ Class

ZDO_COMPLEX_DESC_REQ Class
See Also Example Members
[image]

This command is generated to request for the destination device's complex descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_COMPLEX_DESC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_COMPLEX_DESC_REQ : IREQUEST, IZDO
C++
ref class ZDO_COMPLEX_DESC_REQ : IREQUEST, IZDO
J#
public class ZDO_COMPLEX_DESC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_COMPLEX_DESC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_COMPLEX_DESC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_COMPLEX_DESC_REQ Members
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ Members

ZDO_COMPLEX_DESC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request for the destination device's complex descriptor

The following tables list the members exposed by ZDO_COMPLEX_DESC_REQ.

Public Constructors

Name | Description
ZDO_COMPLEX_DESC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_COMPLEX_DESC_REQ | Overloaded.
Top

See Also

ZDO_COMPLEX_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ Constructor

ZDO_COMPLEX_DESC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_COMPLEX_DESC_REQ | Constructor
Public method | ZDO_COMPLEX_DESC_REQ (UInt16, UInt16) | Constructor

See Also

ZDO_COMPLEX_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ Constructor ()

ZDO_COMPLEX_DESC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_COMPLEX_DESC_REQ()
C++
public:
ZDO_COMPLEX_DESC_REQ() sealed
J#
public ZDO_COMPLEX_DESC_REQ()
JScript
public function ZDO_COMPLEX_DESC_REQ()

See Also

ZDO_COMPLEX_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_COMPLEX_DESC_REQ Constructor Overload List


ZDO_COMPLEX_DESC_REQ Constructor (UInt16, UInt16)

ZDO_COMPLEX_DESC_REQ Constructor (UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public ZDO_COMPLEX_DESC_REQ(
ushort ,
ushort
)
C++
public:
ZDO_COMPLEX_DESC_REQ(
unsigned short ,
unsigned short
) sealed
J#
public ZDO_COMPLEX_DESC_REQ(
ushort ,
ushort
)
JScript
public function ZDO_COMPLEX_DESC_REQ(
: UInt16,
: UInt16
)

See Also

ZDO_COMPLEX_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_COMPLEX_DESC_REQ Constructor Overload List


Fields

ZDO_COMPLEX_DESC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

See Also

ZDO_COMPLEX_DESC_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_COMPLEX_DESC_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_COMPLEX_DESC_REQ Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_COMPLEX_DESC_REQ.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_COMPLEX_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ_SRSP Class

ZDO_COMPLEX_DESC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_COMPLEX_DESC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_COMPLEX_DESC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_COMPLEX_DESC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_COMPLEX_DESC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_COMPLEX_DESC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_COMPLEX_DESC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_COMPLEX_DESC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_COMPLEX_DESC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ_SRSP Members

ZDO_COMPLEX_DESC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_COMPLEX_DESC_REQ

The following tables list the members exposed by ZDO_COMPLEX_DESC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_COMPLEX_DESC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_COMPLEX_DESC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_COMPLEX_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ_SRSP Constructor

ZDO_COMPLEX_DESC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_COMPLEX_DESC_REQ_SRSP | Constructor
Public method | ZDO_COMPLEX_DESC_REQ_SRSP (ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS) |

See Also

ZDO_COMPLEX_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ_SRSP Constructor ()

ZDO_COMPLEX_DESC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_COMPLEX_DESC_REQ_SRSP()
C++
public:
ZDO_COMPLEX_DESC_REQ_SRSP() sealed
J#
public ZDO_COMPLEX_DESC_REQ_SRSP()
JScript
public function ZDO_COMPLEX_DESC_REQ_SRSP()

See Also

ZDO_COMPLEX_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_COMPLEX_DESC_REQ_SRSP Constructor Overload List


ZDO_COMPLEX_DESC_REQ_SRSP Constructor (ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS)

ZDO_COMPLEX_DESC_REQ_SRSP Constructor (ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_COMPLEX_DESC_REQ_SRSP(
ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_COMPLEX_DESC_REQ_SRSP(
ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_COMPLEX_DESC_REQ_SRSP(
ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_COMPLEX_DESC_REQ_SRSP(
: ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS
)

See Also

ZDO_COMPLEX_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_COMPLEX_DESC_REQ_SRSP Constructor Overload List


Fields

ZDO_COMPLEX_DESC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_COMPLEX_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_COMPLEX_DESC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS
C#
public ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS;

See Also

ZDO_COMPLEX_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS Enumeration

ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_RSP Class

ZDO_COMPLEX_DESC_RSP Class
See Also Example Members
[image]

Response for ZDO_COMPLEX_DESC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_COMPLEX_DESC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_COMPLEX_DESC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_COMPLEX_DESC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_COMPLEX_DESC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_COMPLEX_DESC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_COMPLEX_DESC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_COMPLEX_DESC_RSP Members
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_RSP Members

ZDO_COMPLEX_DESC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_COMPLEX_DESC_REQ

The following tables list the members exposed by ZDO_COMPLEX_DESC_RSP.

Public Constructors

Name | Description
ZDO_COMPLEX_DESC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ComplexDesc | Array of bytes contains the complex descriptor.
Public field | ComplexLength | Length of the Complex Descriptor
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_COMPLEX_DESC_RSP | Overloaded.
Top

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_RSP Constructor

ZDO_COMPLEX_DESC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_COMPLEX_DESC_RSP | Constructor
Public method | ZDO_COMPLEX_DESC_RSP (UInt16, ZDO_COMPLEX_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte) |

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_RSP Constructor ()

ZDO_COMPLEX_DESC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_COMPLEX_DESC_RSP()
C++
public:
ZDO_COMPLEX_DESC_RSP() sealed
J#
public ZDO_COMPLEX_DESC_RSP()
JScript
public function ZDO_COMPLEX_DESC_RSP()

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_COMPLEX_DESC_RSP Constructor Overload List


ZDO_COMPLEX_DESC_RSP Constructor (UInt16, ZDO_COMPLEX_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte[])

ZDO_COMPLEX_DESC_RSP Constructor (UInt16, ZDO_COMPLEX_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_COMPLEX_DESC_RSP.ZDO_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_COMPLEX_DESC_RSP(
ushort ,
ZDO_COMPLEX_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_COMPLEX_DESC_RSP(
unsigned short ,
ZDO_COMPLEX_DESC_RSP.ZDO_STATUS ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_COMPLEX_DESC_RSP(
ushort ,
ZDO_COMPLEX_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_COMPLEX_DESC_RSP(
: UInt16,
: ZDO_COMPLEX_DESC_RSP.ZDO_STATUS,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_COMPLEX_DESC_RSP Constructor Overload List


Fields

ZDO_COMPLEX_DESC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | ComplexDesc | Array of bytes contains the complex descriptor.
Public field | ComplexLength | Length of the Complex Descriptor
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


ComplexDesc Field

ZDO_COMPLEX_DESC_RSP.ComplexDesc Field
[image]

Array of bytes contains the complex descriptor.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ComplexDesc As Byte()
C#
public byte[] ComplexDesc;
C++
public:
array<char>^ ComplexDesc sealed ;
J#
public byte[] ComplexDesc
JScript
public ComplexDesc : Byte[];

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


ComplexLength Field

ZDO_COMPLEX_DESC_RSP.ComplexLength Field
[image]

Length of the Complex Descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ComplexLength As Byte
C#
public byte ComplexLength;
C++
public:
char ComplexLength sealed ;
J#
public byte ComplexLength
JScript
public ComplexLength : Byte;

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_COMPLEX_DESC_RSP.NwkAddr Field
[image]

Device's short address that this response describes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_COMPLEX_DESC_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_COMPLEX_DESC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_COMPLEX_DESC_RSP.ZDO_STATUS
C#
public ZDO_COMPLEX_DESC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_COMPLEX_DESC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_COMPLEX_DESC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_COMPLEX_DESC_RSP.ZDO_STATUS;

See Also

ZDO_COMPLEX_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_COMPLEX_DESC_RSP.ZDO_STATUS Enumeration

ZDO_COMPLEX_DESC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_COMPLEX_DESC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_COMPLEX_DESC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_COMPLEX_DESC_RSP.ZDO_STATUS : char
J#
public enum ZDO_COMPLEX_DESC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_COMPLEX_DESC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE Class

ZDO_END_DEVICE_ANNCE Class
See Also Example Members
[image]

This command is generated to request an End Device Announce.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_ANNCE
Implements IREQUEST, IZDO
C#
public class ZDO_END_DEVICE_ANNCE : IREQUEST, IZDO
C++
ref class ZDO_END_DEVICE_ANNCE : IREQUEST, IZDO
J#
public class ZDO_END_DEVICE_ANNCE implements IREQUEST, IZDO
JScript
public class ZDO_END_DEVICE_ANNCE extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_ANNCE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_ANNCE Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE Members

ZDO_END_DEVICE_ANNCE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request an End Device Announce.

The following tables list the members exposed by ZDO_END_DEVICE_ANNCE.

Public Constructors

Name | Description
ZDO_END_DEVICE_ANNCE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Capabilities | MAC capabilities
Public field | IEEEAddr | The 64 bit IEEE Address of the device you want to announce
Public field | NwkAddr | Device network address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_ANNCE | Overloaded.
Top

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE Constructor

ZDO_END_DEVICE_ANNCE Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_ANNCE | Constructor
Public method | ZDO_END_DEVICE_ANNCE (UInt16, UInt64, ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO) |

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE Constructor ()

ZDO_END_DEVICE_ANNCE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_ANNCE()
C++
public:
ZDO_END_DEVICE_ANNCE() sealed
J#
public ZDO_END_DEVICE_ANNCE()
JScript
public function ZDO_END_DEVICE_ANNCE()

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_ANNCE Constructor Overload List


ZDO_END_DEVICE_ANNCE Constructor (UInt16, UInt64, ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO)

ZDO_END_DEVICE_ANNCE Constructor (UInt16, UInt64, ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO _
)
C#
public ZDO_END_DEVICE_ANNCE(
ushort ,
ulong ,
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
)
C++
public:
ZDO_END_DEVICE_ANNCE(
unsigned short ,
unsigned __int64 ,
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
) sealed
J#
public ZDO_END_DEVICE_ANNCE(
ushort ,
ulong ,
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
)
JScript
public function ZDO_END_DEVICE_ANNCE(
: UInt16,
: UInt64,
: ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
)

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_ANNCE Constructor Overload List


Fields

ZDO_END_DEVICE_ANNCE Fields
[image]

Public Fields

 | Name | Description
Public field | Capabilities | MAC capabilities
Public field | IEEEAddr | The 64 bit IEEE Address of the device you want to announce
Public field | NwkAddr | Device network address.
Top

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace


Capabilities Field

ZDO_END_DEVICE_ANNCE.Capabilities Field
[image]

MAC capabilities

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Capabilities As ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
C#
public ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Capabilities;
C++
public:
ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Capabilities sealed ;
J#
public ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Capabilities
JScript
public Capabilities : ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO;

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace


IEEEAddr Field

ZDO_END_DEVICE_ANNCE.IEEEAddr Field
[image]

The 64 bit IEEE Address of the device you want to announce

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_END_DEVICE_ANNCE.NwkAddr Field
[image]

Device network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_END_DEVICE_ANNCE Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Enumeration

ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO byte
JScript
public enum ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_IND Class

ZDO_END_DEVICE_ANNCE_IND Class
See Also Example Members
[image]

ZDO end device announce indication.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_ANNCE_IND
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_END_DEVICE_ANNCE_IND : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_END_DEVICE_ANNCE_IND : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_END_DEVICE_ANNCE_IND implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_END_DEVICE_ANNCE_IND extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_ANNCE_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_ANNCE_IND Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_IND Members

ZDO_END_DEVICE_ANNCE_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

ZDO end device announce indication.

The following tables list the members exposed by ZDO_END_DEVICE_ANNCE_IND.

Public Constructors

Name | Description
ZDO_END_DEVICE_ANNCE_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Capabilities | Capabilities
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NwkAddr | Network address
Public field | SrcAddr | Source address
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_ANNCE_IND | Overloaded.
Top

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_IND Constructor

ZDO_END_DEVICE_ANNCE_IND Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_ANNCE_IND | Constructor
Public method | ZDO_END_DEVICE_ANNCE_IND (UInt16, UInt16, UInt64, Byte) | Constructor

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_IND Constructor ()

ZDO_END_DEVICE_ANNCE_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_ANNCE_IND()
C++
public:
ZDO_END_DEVICE_ANNCE_IND() sealed
J#
public ZDO_END_DEVICE_ANNCE_IND()
JScript
public function ZDO_END_DEVICE_ANNCE_IND()

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_ANNCE_IND Constructor Overload List


ZDO_END_DEVICE_ANNCE_IND Constructor (UInt16, UInt16, UInt64, Byte)

ZDO_END_DEVICE_ANNCE_IND Constructor (UInt16, UInt16, UInt64, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte _
)
C#
public ZDO_END_DEVICE_ANNCE_IND(
ushort ,
ushort ,
ulong ,
byte
)
C++
public:
ZDO_END_DEVICE_ANNCE_IND(
unsigned short ,
unsigned short ,
unsigned __int64 ,
char
) sealed
J#
public ZDO_END_DEVICE_ANNCE_IND(
ushort ,
ushort ,
ulong ,
byte
)
JScript
public function ZDO_END_DEVICE_ANNCE_IND(
: UInt16,
: UInt16,
: UInt64,
: Byte
)

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_ANNCE_IND Constructor Overload List


Fields

ZDO_END_DEVICE_ANNCE_IND Fields
[image]

Public Fields

 | Name | Description
Public field | Capabilities | Capabilities
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NwkAddr | Network address
Public field | SrcAddr | Source address
Top

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace


Capabilities Field

ZDO_END_DEVICE_ANNCE_IND.Capabilities Field
[image]

Capabilities

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Capabilities As Byte
C#
public byte Capabilities;
C++
public:
char Capabilities sealed ;
J#
public byte Capabilities
JScript
public Capabilities : Byte;

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace


IEEEAddr Field

ZDO_END_DEVICE_ANNCE_IND.IEEEAddr Field
[image]

64 bit IEEE address of source device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_END_DEVICE_ANNCE_IND.NwkAddr Field
[image]

Network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_END_DEVICE_ANNCE_IND.SrcAddr Field
[image]

Source address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_END_DEVICE_ANNCE_IND Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_SRSP Class

ZDO_END_DEVICE_ANNCE_SRSP Class
See Also Example Members
[image]

Response for ZDO_END_DEVICE_ANNCE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_ANNCE_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_END_DEVICE_ANNCE_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_END_DEVICE_ANNCE_SRSP : IRESPONSE, IZDO
J#
public class ZDO_END_DEVICE_ANNCE_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_END_DEVICE_ANNCE_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_ANNCE_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_ANNCE_SRSP Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_SRSP Members

ZDO_END_DEVICE_ANNCE_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_END_DEVICE_ANNCE

The following tables list the members exposed by ZDO_END_DEVICE_ANNCE_SRSP.

Public Constructors

Name | Description
ZDO_END_DEVICE_ANNCE_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_ANNCE_SRSP | Overloaded.
Top

See Also

ZDO_END_DEVICE_ANNCE_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_SRSP Constructor

ZDO_END_DEVICE_ANNCE_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_ANNCE_SRSP | Constructor
Public method | ZDO_END_DEVICE_ANNCE_SRSP (ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS) |

See Also

ZDO_END_DEVICE_ANNCE_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_SRSP Constructor ()

ZDO_END_DEVICE_ANNCE_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_ANNCE_SRSP()
C++
public:
ZDO_END_DEVICE_ANNCE_SRSP() sealed
J#
public ZDO_END_DEVICE_ANNCE_SRSP()
JScript
public function ZDO_END_DEVICE_ANNCE_SRSP()

See Also

ZDO_END_DEVICE_ANNCE_SRSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_ANNCE_SRSP Constructor Overload List


ZDO_END_DEVICE_ANNCE_SRSP Constructor (ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS)

ZDO_END_DEVICE_ANNCE_SRSP Constructor (ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS _
)
C#
public ZDO_END_DEVICE_ANNCE_SRSP(
ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS
)
C++
public:
ZDO_END_DEVICE_ANNCE_SRSP(
ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS
) sealed
J#
public ZDO_END_DEVICE_ANNCE_SRSP(
ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS
)
JScript
public function ZDO_END_DEVICE_ANNCE_SRSP(
: ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS
)

See Also

ZDO_END_DEVICE_ANNCE_SRSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_ANNCE_SRSP Constructor Overload List


Fields

ZDO_END_DEVICE_ANNCE_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_END_DEVICE_ANNCE_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_END_DEVICE_ANNCE_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS
C#
public ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS Status;
C++
public:
ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS;

See Also

ZDO_END_DEVICE_ANNCE_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS Enumeration

ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS : char
J#
public enum ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS byte
JScript
public enum ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ Class

ZDO_END_DEVICE_BIND_REQ Class
See Also Example Members
[image]

This command is generated to request an End Device Bind with the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_BIND_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_END_DEVICE_BIND_REQ : IREQUEST, IZDO
C++
ref class ZDO_END_DEVICE_BIND_REQ : IREQUEST, IZDO
J#
public class ZDO_END_DEVICE_BIND_REQ implements IREQUEST, IZDO
JScript
public class ZDO_END_DEVICE_BIND_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_BIND_REQ Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ Members

ZDO_END_DEVICE_BIND_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request an End Device Bind with the destination device

The following tables list the members exposed by ZDO_END_DEVICE_BIND_REQ.

Public Constructors

Name | Description
ZDO_END_DEVICE_BIND_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | Device's Endpoint
Public field | IEEE | Local coordinator's IEEE address
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | LocalCoordinator | Local coordinator's short address
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the OutClusterList
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_BIND_REQ | Overloaded.
Top

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ Constructor

ZDO_END_DEVICE_BIND_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_BIND_REQ | Constructor
Public method | ZDO_END_DEVICE_BIND_REQ (UInt16, UInt16, UInt64, Byte, UInt16, Byte, UInt16, Byte, UInt16) | Constructor

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ Constructor ()

ZDO_END_DEVICE_BIND_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_BIND_REQ()
C++
public:
ZDO_END_DEVICE_BIND_REQ() sealed
J#
public ZDO_END_DEVICE_BIND_REQ()
JScript
public function ZDO_END_DEVICE_BIND_REQ()

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_BIND_REQ Constructor Overload List


ZDO_END_DEVICE_BIND_REQ Constructor (UInt16, UInt16, UInt64, Byte, UInt16, Byte, UInt16[], Byte, UInt16[])

ZDO_END_DEVICE_BIND_REQ Constructor (UInt16, UInt16, UInt64, Byte, UInt16, Byte, UInt16[], Byte, UInt16[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_END_DEVICE_BIND_REQ(
ushort ,
ushort ,
ulong ,
byte ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[]
)
C++
public:
ZDO_END_DEVICE_BIND_REQ(
unsigned short ,
unsigned short ,
unsigned __int64 ,
char ,
unsigned short ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_END_DEVICE_BIND_REQ(
ushort ,
ushort ,
ulong ,
byte ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[]
)
JScript
public function ZDO_END_DEVICE_BIND_REQ(
: UInt16,
: UInt16,
: UInt64,
: Byte,
: UInt16,
: Byte,
: UInt16[],
: Byte,
: UInt16[]
)

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_BIND_REQ Constructor Overload List


Fields

ZDO_END_DEVICE_BIND_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | Device's Endpoint
Public field | IEEE | Local coordinator's IEEE address
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | LocalCoordinator | Local coordinator's short address
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the OutClusterList
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Top

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_END_DEVICE_BIND_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


Endpoint Field

ZDO_END_DEVICE_BIND_REQ.Endpoint Field
[image]

Device's Endpoint

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


IEEE Field

ZDO_END_DEVICE_BIND_REQ.IEEE Field
[image]

Local coordinator's IEEE address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEE As UInt64
C#
public ulong IEEE;
C++
public:
unsigned __int64 IEEE sealed ;
J#
public ulong IEEE
JScript
public IEEE : UInt64;

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


InClusterList Field

ZDO_END_DEVICE_BIND_REQ.InClusterList Field
[image]

Array of input cluster IDs - NumInClusters long

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InClusterList As UInt16()
C#
public ushort[] InClusterList;
C++
public:
array<unsigned short>^ InClusterList sealed ;
J#
public ushort[] InClusterList
JScript
public InClusterList : UInt16[];

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


LocalCoordinator Field

ZDO_END_DEVICE_BIND_REQ.LocalCoordinator Field
[image]

Local coordinator's short address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LocalCoordinator As UInt16
C#
public ushort LocalCoordinator;
C++
public:
unsigned short LocalCoordinator sealed ;
J#
public ushort LocalCoordinator
JScript
public LocalCoordinator : UInt16;

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


NumInClusters Field

ZDO_END_DEVICE_BIND_REQ.NumInClusters Field
[image]

Number of ClusterIds in the InClusterList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumInClusters As Byte
C#
public byte NumInClusters;
C++
public:
char NumInClusters sealed ;
J#
public byte NumInClusters
JScript
public NumInClusters : Byte;

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


NumOutClusters Field

ZDO_END_DEVICE_BIND_REQ.NumOutClusters Field
[image]

Number of ClusterIds in the OutClusterList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOutClusters As Byte
C#
public byte NumOutClusters;
C++
public:
char NumOutClusters sealed ;
J#
public byte NumOutClusters
JScript
public NumOutClusters : Byte;

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


OutClusterList Field

ZDO_END_DEVICE_BIND_REQ.OutClusterList Field
[image]

Array of output cluster IDs - NumOutClusters long

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutClusterList As UInt16()
C#
public ushort[] OutClusterList;
C++
public:
array<unsigned short>^ OutClusterList sealed ;
J#
public ushort[] OutClusterList
JScript
public OutClusterList : UInt16[];

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


ProfileID Field

ZDO_END_DEVICE_BIND_REQ.ProfileID Field
[image]

Profile ID to match

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ProfileID As UInt16
C#
public ushort ProfileID;
C++
public:
unsigned short ProfileID sealed ;
J#
public ushort ProfileID
JScript
public ProfileID : UInt16;

See Also

ZDO_END_DEVICE_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ_SRSP Class

ZDO_END_DEVICE_BIND_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_END_DEVICE_BIND_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_BIND_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_END_DEVICE_BIND_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_END_DEVICE_BIND_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_END_DEVICE_BIND_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_END_DEVICE_BIND_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_BIND_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ_SRSP Members

ZDO_END_DEVICE_BIND_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_END_DEVICE_BIND_REQ

The following tables list the members exposed by ZDO_END_DEVICE_BIND_REQ_SRSP.

Public Constructors

Name | Description
ZDO_END_DEVICE_BIND_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_BIND_REQ_SRSP | Overloaded.
Top

See Also

ZDO_END_DEVICE_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ_SRSP Constructor

ZDO_END_DEVICE_BIND_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_BIND_REQ_SRSP | Constructor
Public method | ZDO_END_DEVICE_BIND_REQ_SRSP (ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS) |

See Also

ZDO_END_DEVICE_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ_SRSP Constructor ()

ZDO_END_DEVICE_BIND_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_BIND_REQ_SRSP()
C++
public:
ZDO_END_DEVICE_BIND_REQ_SRSP() sealed
J#
public ZDO_END_DEVICE_BIND_REQ_SRSP()
JScript
public function ZDO_END_DEVICE_BIND_REQ_SRSP()

See Also

ZDO_END_DEVICE_BIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_BIND_REQ_SRSP Constructor Overload List


ZDO_END_DEVICE_BIND_REQ_SRSP Constructor (ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS)

ZDO_END_DEVICE_BIND_REQ_SRSP Constructor (ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_END_DEVICE_BIND_REQ_SRSP(
ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_END_DEVICE_BIND_REQ_SRSP(
ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_END_DEVICE_BIND_REQ_SRSP(
ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_END_DEVICE_BIND_REQ_SRSP(
: ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS
)

See Also

ZDO_END_DEVICE_BIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_BIND_REQ_SRSP Constructor Overload List


Fields

ZDO_END_DEVICE_BIND_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_END_DEVICE_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_END_DEVICE_BIND_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS
C#
public ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS;

See Also

ZDO_END_DEVICE_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS Enumeration

ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_RSP Class

ZDO_END_DEVICE_BIND_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO End Device Bind Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_BIND_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_END_DEVICE_BIND_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_END_DEVICE_BIND_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_END_DEVICE_BIND_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_END_DEVICE_BIND_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_BIND_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_BIND_RSP Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_RSP Members

ZDO_END_DEVICE_BIND_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO End Device Bind Request

The following tables list the members exposed by ZDO_END_DEVICE_BIND_RSP.

Public Constructors

Name | Description
ZDO_END_DEVICE_BIND_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_BIND_RSP | Overloaded.
Top

See Also

ZDO_END_DEVICE_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_RSP Constructor

ZDO_END_DEVICE_BIND_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_BIND_RSP | Constructor
Public method | ZDO_END_DEVICE_BIND_RSP (UInt16, ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS) |

See Also

ZDO_END_DEVICE_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_RSP Constructor ()

ZDO_END_DEVICE_BIND_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_BIND_RSP()
C++
public:
ZDO_END_DEVICE_BIND_RSP() sealed
J#
public ZDO_END_DEVICE_BIND_RSP()
JScript
public function ZDO_END_DEVICE_BIND_RSP()

See Also

ZDO_END_DEVICE_BIND_RSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_BIND_RSP Constructor Overload List


ZDO_END_DEVICE_BIND_RSP Constructor (UInt16, ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS)

ZDO_END_DEVICE_BIND_RSP Constructor (UInt16, ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS _
)
C#
public ZDO_END_DEVICE_BIND_RSP(
ushort ,
ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS
)
C++
public:
ZDO_END_DEVICE_BIND_RSP(
unsigned short ,
ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS
) sealed
J#
public ZDO_END_DEVICE_BIND_RSP(
ushort ,
ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS
)
JScript
public function ZDO_END_DEVICE_BIND_RSP(
: UInt16,
: ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS
)

See Also

ZDO_END_DEVICE_BIND_RSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_BIND_RSP Constructor Overload List


Fields

ZDO_END_DEVICE_BIND_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_END_DEVICE_BIND_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_END_DEVICE_BIND_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_END_DEVICE_BIND_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_END_DEVICE_BIND_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS
C#
public ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS Status;
C++
public:
ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS;

See Also

ZDO_END_DEVICE_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS Enumeration

ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS : char
J#
public enum ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS byte
JScript
public enum ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ Class

ZDO_END_DEVICE_TIMEOUT_REQ Class
See Also Example Members
[image]

The command is used to send an End Device Timeout Request message.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_TIMEOUT_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_END_DEVICE_TIMEOUT_REQ : IREQUEST, IZDO
C++
ref class ZDO_END_DEVICE_TIMEOUT_REQ : IREQUEST, IZDO
J#
public class ZDO_END_DEVICE_TIMEOUT_REQ implements IREQUEST, IZDO
JScript
public class ZDO_END_DEVICE_TIMEOUT_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ Members

ZDO_END_DEVICE_TIMEOUT_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

The command is used to send an End Device Timeout Request message.

The following tables list the members exposed by ZDO_END_DEVICE_TIMEOUT_REQ.

Public Constructors

Name | Description
ZDO_END_DEVICE_TIMEOUT_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ParentAddr | Parent's address.
Public field | ReqTimeout | Requested timeout value in minutes.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_TIMEOUT_REQ | Overloaded.
Top

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ Constructor

ZDO_END_DEVICE_TIMEOUT_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_TIMEOUT_REQ | Constructor
Public method | ZDO_END_DEVICE_TIMEOUT_REQ (UInt16, UInt16) | Constructor

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ Constructor ()

ZDO_END_DEVICE_TIMEOUT_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_TIMEOUT_REQ()
C++
public:
ZDO_END_DEVICE_TIMEOUT_REQ() sealed
J#
public ZDO_END_DEVICE_TIMEOUT_REQ()
JScript
public function ZDO_END_DEVICE_TIMEOUT_REQ()

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_TIMEOUT_REQ Constructor Overload List


ZDO_END_DEVICE_TIMEOUT_REQ Constructor (UInt16, UInt16)

ZDO_END_DEVICE_TIMEOUT_REQ Constructor (UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public ZDO_END_DEVICE_TIMEOUT_REQ(
ushort ,
ushort
)
C++
public:
ZDO_END_DEVICE_TIMEOUT_REQ(
unsigned short ,
unsigned short
) sealed
J#
public ZDO_END_DEVICE_TIMEOUT_REQ(
ushort ,
ushort
)
JScript
public function ZDO_END_DEVICE_TIMEOUT_REQ(
: UInt16,
: UInt16
)

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_TIMEOUT_REQ Constructor Overload List


Fields

ZDO_END_DEVICE_TIMEOUT_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | ParentAddr | Parent's address.
Public field | ReqTimeout | Requested timeout value in minutes.
Top

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Class
TI.ZPI2 Namespace


ParentAddr Field

ZDO_END_DEVICE_TIMEOUT_REQ.ParentAddr Field
[image]

Parent's address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ParentAddr As UInt16
C#
public ushort ParentAddr;
C++
public:
unsigned short ParentAddr sealed ;
J#
public ushort ParentAddr
JScript
public ParentAddr : UInt16;

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Class
TI.ZPI2 Namespace


ReqTimeout Field

ZDO_END_DEVICE_TIMEOUT_REQ.ReqTimeout Field
[image]

Requested timeout value in minutes.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReqTimeout As UInt16
C#
public ushort ReqTimeout;
C++
public:
unsigned short ReqTimeout sealed ;
J#
public ushort ReqTimeout
JScript
public ReqTimeout : UInt16;

See Also

ZDO_END_DEVICE_TIMEOUT_REQ Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_END_DEVICE_TIMEOUT_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_TIMEOUT_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_END_DEVICE_TIMEOUT_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_END_DEVICE_TIMEOUT_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_END_DEVICE_TIMEOUT_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_END_DEVICE_TIMEOUT_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Members

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_END_DEVICE_TIMEOUT_REQ

The following tables list the members exposed by ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.

Public Constructors

Name | Description
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP | Overloaded.
Top

See Also

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_TIMEOUT_REQ_SRSP | Constructor
Public method | ZDO_END_DEVICE_TIMEOUT_REQ_SRSP (ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor ()

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_TIMEOUT_REQ_SRSP()
C++
public:
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP() sealed
J#
public ZDO_END_DEVICE_TIMEOUT_REQ_SRSP()
JScript
public function ZDO_END_DEVICE_TIMEOUT_REQ_SRSP()

See Also

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor Overload List


ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor (ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS)

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor (ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_END_DEVICE_TIMEOUT_REQ_SRSP(
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP(
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_END_DEVICE_TIMEOUT_REQ_SRSP(
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_END_DEVICE_TIMEOUT_REQ_SRSP(
: ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Constructor Overload List


Fields

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS
C#
public ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS;

See Also

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS Enumeration

ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_RSP Class

ZDO_END_DEVICE_TIMEOUT_RSP Class
See Also Example Members
[image]

This callback message is in response to the End Device Timeout Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_END_DEVICE_TIMEOUT_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_END_DEVICE_TIMEOUT_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_END_DEVICE_TIMEOUT_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_END_DEVICE_TIMEOUT_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_END_DEVICE_TIMEOUT_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Members
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_RSP Members

ZDO_END_DEVICE_TIMEOUT_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the End Device Timeout Request.

The following tables list the members exposed by ZDO_END_DEVICE_TIMEOUT_RSP.

Public Constructors

Name | Description
ZDO_END_DEVICE_TIMEOUT_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or ZDO error.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_END_DEVICE_TIMEOUT_RSP | Overloaded.
Top

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_RSP Constructor

ZDO_END_DEVICE_TIMEOUT_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_END_DEVICE_TIMEOUT_RSP | Constructor
Public method | ZDO_END_DEVICE_TIMEOUT_RSP (UInt16, ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS) |

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_RSP Constructor ()

ZDO_END_DEVICE_TIMEOUT_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_END_DEVICE_TIMEOUT_RSP()
C++
public:
ZDO_END_DEVICE_TIMEOUT_RSP() sealed
J#
public ZDO_END_DEVICE_TIMEOUT_RSP()
JScript
public function ZDO_END_DEVICE_TIMEOUT_RSP()

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_TIMEOUT_RSP Constructor Overload List


ZDO_END_DEVICE_TIMEOUT_RSP Constructor (UInt16, ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS)

ZDO_END_DEVICE_TIMEOUT_RSP Constructor (UInt16, ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS _
)
C#
public ZDO_END_DEVICE_TIMEOUT_RSP(
ushort ,
ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS
)
C++
public:
ZDO_END_DEVICE_TIMEOUT_RSP(
unsigned short ,
ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS
) sealed
J#
public ZDO_END_DEVICE_TIMEOUT_RSP(
ushort ,
ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS
)
JScript
public function ZDO_END_DEVICE_TIMEOUT_RSP(
: UInt16,
: ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS
)

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Class
TI.ZPI2 Namespace
ZDO_END_DEVICE_TIMEOUT_RSP Constructor Overload List


Fields

ZDO_END_DEVICE_TIMEOUT_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or ZDO error.
Top

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_END_DEVICE_TIMEOUT_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_END_DEVICE_TIMEOUT_RSP.Status Field
[image]

this field indicates either SUCCESS or ZDO error.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS
C#
public ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS Status;
C++
public:
ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS;

See Also

ZDO_END_DEVICE_TIMEOUT_RSP Class
TI.ZPI2 Namespace


ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS Enumeration

ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS : char
J#
public enum ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS byte
JScript
public enum ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_GET_LINK_KEY Class

ZDO_GET_LINK_KEY Class
See Also Example Members
[image]

This function will return the application or trust center link key of a given device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_GET_LINK_KEY
Implements IREQUEST, IZDO
C#
public class ZDO_GET_LINK_KEY : IREQUEST, IZDO
C++
ref class ZDO_GET_LINK_KEY : IREQUEST, IZDO
J#
public class ZDO_GET_LINK_KEY implements IREQUEST, IZDO
JScript
public class ZDO_GET_LINK_KEY extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_GET_LINK_KEY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_GET_LINK_KEY Members
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY Members

ZDO_GET_LINK_KEY Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This function will return the application or trust center link key of a given device.

The following tables list the members exposed by ZDO_GET_LINK_KEY.

Public Constructors

Name | Description
ZDO_GET_LINK_KEY | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEAddr | Specifies the IEEE address of the device.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_GET_LINK_KEY | Overloaded.
Top

See Also

ZDO_GET_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY Constructor

ZDO_GET_LINK_KEY Constructor

Overload List

 | Name | Description
Public method | ZDO_GET_LINK_KEY | Constructor
Public method | ZDO_GET_LINK_KEY (UInt64) | Constructor

See Also

ZDO_GET_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY Constructor ()

ZDO_GET_LINK_KEY Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_GET_LINK_KEY()
C++
public:
ZDO_GET_LINK_KEY() sealed
J#
public ZDO_GET_LINK_KEY()
JScript
public function ZDO_GET_LINK_KEY()

See Also

ZDO_GET_LINK_KEY Class
TI.ZPI2 Namespace
ZDO_GET_LINK_KEY Constructor Overload List


ZDO_GET_LINK_KEY Constructor (UInt64)

ZDO_GET_LINK_KEY Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public ZDO_GET_LINK_KEY(
ulong
)
C++
public:
ZDO_GET_LINK_KEY(
unsigned __int64
) sealed
J#
public ZDO_GET_LINK_KEY(
ulong
)
JScript
public function ZDO_GET_LINK_KEY(
: UInt64
)

See Also

ZDO_GET_LINK_KEY Class
TI.ZPI2 Namespace
ZDO_GET_LINK_KEY Constructor Overload List


Fields

ZDO_GET_LINK_KEY Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEAddr | Specifies the IEEE address of the device.
Top

See Also

ZDO_GET_LINK_KEY Class
TI.ZPI2 Namespace


IEEEAddr Field

ZDO_GET_LINK_KEY.IEEEAddr Field
[image]

Specifies the IEEE address of the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

ZDO_GET_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY_SRSP Class

ZDO_GET_LINK_KEY_SRSP Class
See Also Example Members
[image]

Response for ZDO_GET_LINK_KEY

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_GET_LINK_KEY_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_GET_LINK_KEY_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_GET_LINK_KEY_SRSP : IRESPONSE, IZDO
J#
public class ZDO_GET_LINK_KEY_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_GET_LINK_KEY_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_GET_LINK_KEY_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_GET_LINK_KEY_SRSP Members
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY_SRSP Members

ZDO_GET_LINK_KEY_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_GET_LINK_KEY

The following tables list the members exposed by ZDO_GET_LINK_KEY_SRSP.

Public Constructors

Name | Description
ZDO_GET_LINK_KEY_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEaddr | IEEE address of the device
Public field | LinkKeyData | Link key data of the device
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_GET_LINK_KEY_SRSP | Overloaded.
Top

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY_SRSP Constructor

ZDO_GET_LINK_KEY_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_GET_LINK_KEY_SRSP | Constructor
Public method | ZDO_GET_LINK_KEY_SRSP (ZDO_GET_LINK_KEY_SRSP.CMD_STATUS, UInt64, Byte) |

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY_SRSP Constructor ()

ZDO_GET_LINK_KEY_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_GET_LINK_KEY_SRSP()
C++
public:
ZDO_GET_LINK_KEY_SRSP() sealed
J#
public ZDO_GET_LINK_KEY_SRSP()
JScript
public function ZDO_GET_LINK_KEY_SRSP()

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace
ZDO_GET_LINK_KEY_SRSP Constructor Overload List


ZDO_GET_LINK_KEY_SRSP Constructor (ZDO_GET_LINK_KEY_SRSP.CMD_STATUS, UInt64, Byte[])

ZDO_GET_LINK_KEY_SRSP Constructor (ZDO_GET_LINK_KEY_SRSP.CMD_STATUS, UInt64, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_GET_LINK_KEY_SRSP.CMD_STATUS, _
ByVal As UInt64, _
ByVal As Byte() _
)
C#
public ZDO_GET_LINK_KEY_SRSP(
ZDO_GET_LINK_KEY_SRSP.CMD_STATUS ,
ulong ,
byte[]
)
C++
public:
ZDO_GET_LINK_KEY_SRSP(
ZDO_GET_LINK_KEY_SRSP.CMD_STATUS ,
unsigned __int64 ,
array<char>^
) sealed
J#
public ZDO_GET_LINK_KEY_SRSP(
ZDO_GET_LINK_KEY_SRSP.CMD_STATUS ,
ulong ,
byte[]
)
JScript
public function ZDO_GET_LINK_KEY_SRSP(
: ZDO_GET_LINK_KEY_SRSP.CMD_STATUS,
: UInt64,
: Byte[]
)

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace
ZDO_GET_LINK_KEY_SRSP Constructor Overload List


Fields

ZDO_GET_LINK_KEY_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEaddr | IEEE address of the device
Public field | LinkKeyData | Link key data of the device
Public field | Status | Status
Top

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


IEEEaddr Field

ZDO_GET_LINK_KEY_SRSP.IEEEaddr Field
[image]

IEEE address of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEaddr As UInt64
C#
public ulong IEEEaddr;
C++
public:
unsigned __int64 IEEEaddr sealed ;
J#
public ulong IEEEaddr
JScript
public IEEEaddr : UInt64;

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


LinkKeyData Field

ZDO_GET_LINK_KEY_SRSP.LinkKeyData Field
[image]

Link key data of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkKeyData As Byte()
C#
public byte[] LinkKeyData;
C++
public:
array<char>^ LinkKeyData sealed ;
J#
public byte[] LinkKeyData
JScript
public LinkKeyData : Byte[];

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_GET_LINK_KEY_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_GET_LINK_KEY_SRSP.CMD_STATUS
C#
public ZDO_GET_LINK_KEY_SRSP.CMD_STATUS Status;
C++
public:
ZDO_GET_LINK_KEY_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_GET_LINK_KEY_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_GET_LINK_KEY_SRSP.CMD_STATUS;

See Also

ZDO_GET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_GET_LINK_KEY_SRSP.CMD_STATUS Enumeration

ZDO_GET_LINK_KEY_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_GET_LINK_KEY_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_GET_LINK_KEY_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_GET_LINK_KEY_SRSP.CMD_STATUS : char
J#
public enum ZDO_GET_LINK_KEY_SRSP.CMD_STATUS byte
JScript
public enum ZDO_GET_LINK_KEY_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ Class

ZDO_IEEE_ADDR_REQ Class
See Also Example Members
[image]

This command will request a device's IEEE 64-bit address. You must subscribe to 'ZDO IEEE Address Response' to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_IEEE_ADDR_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_IEEE_ADDR_REQ : IREQUEST, IZDO
C++
ref class ZDO_IEEE_ADDR_REQ : IREQUEST, IZDO
J#
public class ZDO_IEEE_ADDR_REQ implements IREQUEST, IZDO
JScript
public class ZDO_IEEE_ADDR_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_IEEE_ADDR_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_IEEE_ADDR_REQ Members
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ Members

ZDO_IEEE_ADDR_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command will request a device's IEEE 64-bit address. You must subscribe to 'ZDO IEEE Address Response' to receive the data response to this message. The response message listed below only indicates whether or not the message was received properly.

The following tables list the members exposed by ZDO_IEEE_ADDR_REQ.

Public Constructors

Name | Description
ZDO_IEEE_ADDR_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ReqType | Request type
Public field | ShortAddr | short address of the destination device
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_IEEE_ADDR_REQ | Overloaded.
Top

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ Constructor

ZDO_IEEE_ADDR_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_IEEE_ADDR_REQ | Constructor
Public method | ZDO_IEEE_ADDR_REQ (UInt16, ZDO_IEEE_ADDR_REQ.REQ_TYPE, Byte) |

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ Constructor ()

ZDO_IEEE_ADDR_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_IEEE_ADDR_REQ()
C++
public:
ZDO_IEEE_ADDR_REQ() sealed
J#
public ZDO_IEEE_ADDR_REQ()
JScript
public function ZDO_IEEE_ADDR_REQ()

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace
ZDO_IEEE_ADDR_REQ Constructor Overload List


ZDO_IEEE_ADDR_REQ Constructor (UInt16, ZDO_IEEE_ADDR_REQ.REQ_TYPE, Byte)

ZDO_IEEE_ADDR_REQ Constructor (UInt16, ZDO_IEEE_ADDR_REQ.REQ_TYPE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_IEEE_ADDR_REQ.REQ_TYPE, _
ByVal As Byte _
)
C#
public ZDO_IEEE_ADDR_REQ(
ushort ,
ZDO_IEEE_ADDR_REQ.REQ_TYPE ,
byte
)
C++
public:
ZDO_IEEE_ADDR_REQ(
unsigned short ,
ZDO_IEEE_ADDR_REQ.REQ_TYPE ,
char
) sealed
J#
public ZDO_IEEE_ADDR_REQ(
ushort ,
ZDO_IEEE_ADDR_REQ.REQ_TYPE ,
byte
)
JScript
public function ZDO_IEEE_ADDR_REQ(
: UInt16,
: ZDO_IEEE_ADDR_REQ.REQ_TYPE,
: Byte
)

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace
ZDO_IEEE_ADDR_REQ Constructor Overload List


Fields

ZDO_IEEE_ADDR_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | ReqType | Request type
Public field | ShortAddr | short address of the destination device
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace


ReqType Field

ZDO_IEEE_ADDR_REQ.ReqType Field
[image]

Request type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReqType As ZDO_IEEE_ADDR_REQ.REQ_TYPE
C#
public ZDO_IEEE_ADDR_REQ.REQ_TYPE ReqType;
C++
public:
ZDO_IEEE_ADDR_REQ.REQ_TYPE ReqType sealed ;
J#
public ZDO_IEEE_ADDR_REQ.REQ_TYPE ReqType
JScript
public ReqType : ZDO_IEEE_ADDR_REQ.REQ_TYPE;

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace


ShortAddr Field

ZDO_IEEE_ADDR_REQ.ShortAddr Field
[image]

short address of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ShortAddr As UInt16
C#
public ushort ShortAddr;
C++
public:
unsigned short ShortAddr sealed ;
J#
public ushort ShortAddr
JScript
public ShortAddr : UInt16;

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_IEEE_ADDR_REQ.StartIndex Field
[image]

Starting index into the list of children. This is used to get more of the list if the list is to large for one message.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_IEEE_ADDR_REQ Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ.REQ_TYPE Enumeration

ZDO_IEEE_ADDR_REQ.REQ_TYPE Enumeration
[image]

Request type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEE_ADDR_REQ.REQ_TYPE As Byte
C#
public enum ZDO_IEEE_ADDR_REQ.REQ_TYPE : byte
C++
public enum class ZDO_IEEE_ADDR_REQ.REQ_TYPE : char
J#
public enum ZDO_IEEE_ADDR_REQ.REQ_TYPE byte
JScript
public enum ZDO_IEEE_ADDR_REQ.REQ_TYPE :

Members

Member Name | Description
SINGLE_DEVICE_RESPONSE | Request type
EXTENDED | Request type

See Also

TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ_SRSP Class

ZDO_IEEE_ADDR_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_IEEE_ADDR_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_IEEE_ADDR_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_IEEE_ADDR_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_IEEE_ADDR_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_IEEE_ADDR_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_IEEE_ADDR_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_IEEE_ADDR_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_IEEE_ADDR_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ_SRSP Members

ZDO_IEEE_ADDR_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_IEEE_ADDR_REQ

The following tables list the members exposed by ZDO_IEEE_ADDR_REQ_SRSP.

Public Constructors

Name | Description
ZDO_IEEE_ADDR_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_IEEE_ADDR_REQ_SRSP | Overloaded.
Top

See Also

ZDO_IEEE_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ_SRSP Constructor

ZDO_IEEE_ADDR_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_IEEE_ADDR_REQ_SRSP | Constructor
Public method | ZDO_IEEE_ADDR_REQ_SRSP (ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS) |

See Also

ZDO_IEEE_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ_SRSP Constructor ()

ZDO_IEEE_ADDR_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_IEEE_ADDR_REQ_SRSP()
C++
public:
ZDO_IEEE_ADDR_REQ_SRSP() sealed
J#
public ZDO_IEEE_ADDR_REQ_SRSP()
JScript
public function ZDO_IEEE_ADDR_REQ_SRSP()

See Also

ZDO_IEEE_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_IEEE_ADDR_REQ_SRSP Constructor Overload List


ZDO_IEEE_ADDR_REQ_SRSP Constructor (ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS)

ZDO_IEEE_ADDR_REQ_SRSP Constructor (ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_IEEE_ADDR_REQ_SRSP(
ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_IEEE_ADDR_REQ_SRSP(
ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_IEEE_ADDR_REQ_SRSP(
ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_IEEE_ADDR_REQ_SRSP(
: ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS
)

See Also

ZDO_IEEE_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_IEEE_ADDR_REQ_SRSP Constructor Overload List


Fields

ZDO_IEEE_ADDR_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_IEEE_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_IEEE_ADDR_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS
C#
public ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS;

See Also

ZDO_IEEE_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS Enumeration

ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_IEEE_ADDR_RSP Class

ZDO_IEEE_ADDR_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO IEEE Address Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_IEEE_ADDR_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_IEEE_ADDR_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_IEEE_ADDR_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_IEEE_ADDR_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_IEEE_ADDR_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_IEEE_ADDR_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_IEEE_ADDR_RSP Members
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_RSP Members

ZDO_IEEE_ADDR_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO IEEE Address Request.

The following tables list the members exposed by ZDO_IEEE_ADDR_RSP.

Public Constructors

Name | Description
ZDO_IEEE_ADDR_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | the number of associated devices
Public field | NwkAddr | short network address of responding device
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_IEEE_ADDR_RSP | Overloaded.
Top

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_RSP Constructor

ZDO_IEEE_ADDR_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_IEEE_ADDR_RSP | Constructor
Public method | ZDO_IEEE_ADDR_RSP (ZDO_IEEE_ADDR_RSP.ZDO_STATUS, UInt64, UInt16, Byte, Byte, UInt16) |

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_RSP Constructor ()

ZDO_IEEE_ADDR_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_IEEE_ADDR_RSP()
C++
public:
ZDO_IEEE_ADDR_RSP() sealed
J#
public ZDO_IEEE_ADDR_RSP()
JScript
public function ZDO_IEEE_ADDR_RSP()

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace
ZDO_IEEE_ADDR_RSP Constructor Overload List


ZDO_IEEE_ADDR_RSP Constructor (ZDO_IEEE_ADDR_RSP.ZDO_STATUS, UInt64, UInt16, Byte, Byte, UInt16[])

ZDO_IEEE_ADDR_RSP Constructor (ZDO_IEEE_ADDR_RSP.ZDO_STATUS, UInt64, UInt16, Byte, Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_IEEE_ADDR_RSP.ZDO_STATUS, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_IEEE_ADDR_RSP(
ZDO_IEEE_ADDR_RSP.ZDO_STATUS ,
ulong ,
ushort ,
byte ,
byte ,
ushort[]
)
C++
public:
ZDO_IEEE_ADDR_RSP(
ZDO_IEEE_ADDR_RSP.ZDO_STATUS ,
unsigned __int64 ,
unsigned short ,
char ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_IEEE_ADDR_RSP(
ZDO_IEEE_ADDR_RSP.ZDO_STATUS ,
ulong ,
ushort ,
byte ,
byte ,
ushort[]
)
JScript
public function ZDO_IEEE_ADDR_RSP(
: ZDO_IEEE_ADDR_RSP.ZDO_STATUS,
: UInt64,
: UInt16,
: Byte,
: Byte,
: UInt16[]
)

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace
ZDO_IEEE_ADDR_RSP Constructor Overload List


Fields

ZDO_IEEE_ADDR_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | the number of associated devices
Public field | NwkAddr | short network address of responding device
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


AssocDevList Field

ZDO_IEEE_ADDR_RSP.AssocDevList Field
[image]

Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocDevList As UInt16()
C#
public ushort[] AssocDevList;
C++
public:
array<unsigned short>^ AssocDevList sealed ;
J#
public ushort[] AssocDevList
JScript
public AssocDevList : UInt16[];

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


IEEEAddr Field

ZDO_IEEE_ADDR_RSP.IEEEAddr Field
[image]

64 bit IEEE address of source device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


NumAssocDev Field

ZDO_IEEE_ADDR_RSP.NumAssocDev Field
[image]

the number of associated devices

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumAssocDev As Byte
C#
public byte NumAssocDev;
C++
public:
char NumAssocDev sealed ;
J#
public byte NumAssocDev
JScript
public NumAssocDev : Byte;

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_IEEE_ADDR_RSP.NwkAddr Field
[image]

short network address of responding device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_IEEE_ADDR_RSP.StartIndex Field
[image]

Starting index into the list of associated devices for this report.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_IEEE_ADDR_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_IEEE_ADDR_RSP.ZDO_STATUS
C#
public ZDO_IEEE_ADDR_RSP.ZDO_STATUS Status;
C++
public:
ZDO_IEEE_ADDR_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_IEEE_ADDR_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_IEEE_ADDR_RSP.ZDO_STATUS;

See Also

ZDO_IEEE_ADDR_RSP Class
TI.ZPI2 Namespace


ZDO_IEEE_ADDR_RSP.ZDO_STATUS Enumeration

ZDO_IEEE_ADDR_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_IEEE_ADDR_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_IEEE_ADDR_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_IEEE_ADDR_RSP.ZDO_STATUS : char
J#
public enum ZDO_IEEE_ADDR_RSP.ZDO_STATUS byte
JScript
public enum ZDO_IEEE_ADDR_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_JOIN_CNF Class

ZDO_JOIN_CNF Class
See Also Example Members
[image]

This message is an indication to the host device the result of a ZDO join request .

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_JOIN_CNF
Implements IRESPONSE, IZDO
C#
public class ZDO_JOIN_CNF : IRESPONSE, IZDO
C++
ref class ZDO_JOIN_CNF : IRESPONSE, IZDO
J#
public class ZDO_JOIN_CNF implements IRESPONSE, IZDO
JScript
public class ZDO_JOIN_CNF extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_JOIN_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_JOIN_CNF Members
TI.ZPI2 Namespace


ZDO_JOIN_CNF Members

ZDO_JOIN_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is an indication to the host device the result of a ZDO join request .

The following tables list the members exposed by ZDO_JOIN_CNF.

Public Constructors

Name | Description
ZDO_JOIN_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | The new device short address allocated by the parent.
Public field | ParentAddress | Parent short address.
Public field | Status | Return status of the join confirm
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_JOIN_CNF | Overloaded.
Top

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace


ZDO_JOIN_CNF Constructor

ZDO_JOIN_CNF Constructor

Overload List

 | Name | Description
Public method | ZDO_JOIN_CNF | Constructor
Public method | ZDO_JOIN_CNF (ZDO_JOIN_CNF.CMD_STATUS, UInt16, UInt16) |

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace


ZDO_JOIN_CNF Constructor ()

ZDO_JOIN_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_JOIN_CNF()
C++
public:
ZDO_JOIN_CNF() sealed
J#
public ZDO_JOIN_CNF()
JScript
public function ZDO_JOIN_CNF()

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace
ZDO_JOIN_CNF Constructor Overload List


ZDO_JOIN_CNF Constructor (ZDO_JOIN_CNF.CMD_STATUS, UInt16, UInt16)

ZDO_JOIN_CNF Constructor (ZDO_JOIN_CNF.CMD_STATUS, UInt16, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_JOIN_CNF.CMD_STATUS, _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public ZDO_JOIN_CNF(
ZDO_JOIN_CNF.CMD_STATUS ,
ushort ,
ushort
)
C++
public:
ZDO_JOIN_CNF(
ZDO_JOIN_CNF.CMD_STATUS ,
unsigned short ,
unsigned short
) sealed
J#
public ZDO_JOIN_CNF(
ZDO_JOIN_CNF.CMD_STATUS ,
ushort ,
ushort
)
JScript
public function ZDO_JOIN_CNF(
: ZDO_JOIN_CNF.CMD_STATUS,
: UInt16,
: UInt16
)

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace
ZDO_JOIN_CNF Constructor Overload List


Fields

ZDO_JOIN_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | The new device short address allocated by the parent.
Public field | ParentAddress | Parent short address.
Public field | Status | Return status of the join confirm
Top

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace


DeviceAddress Field

ZDO_JOIN_CNF.DeviceAddress Field
[image]

The new device short address allocated by the parent.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt16
C#
public ushort DeviceAddress;
C++
public:
unsigned short DeviceAddress sealed ;
J#
public ushort DeviceAddress
JScript
public DeviceAddress : UInt16;

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace


ParentAddress Field

ZDO_JOIN_CNF.ParentAddress Field
[image]

Parent short address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ParentAddress As UInt16
C#
public ushort ParentAddress;
C++
public:
unsigned short ParentAddress sealed ;
J#
public ushort ParentAddress
JScript
public ParentAddress : UInt16;

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace


Status Field

ZDO_JOIN_CNF.Status Field
[image]

Return status of the join confirm

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_JOIN_CNF.CMD_STATUS
C#
public ZDO_JOIN_CNF.CMD_STATUS Status;
C++
public:
ZDO_JOIN_CNF.CMD_STATUS Status sealed ;
J#
public ZDO_JOIN_CNF.CMD_STATUS Status
JScript
public Status : ZDO_JOIN_CNF.CMD_STATUS;

See Also

ZDO_JOIN_CNF Class
TI.ZPI2 Namespace


ZDO_JOIN_CNF.CMD_STATUS Enumeration

ZDO_JOIN_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_JOIN_CNF.CMD_STATUS As Byte
C#
public enum ZDO_JOIN_CNF.CMD_STATUS : byte
C++
public enum class ZDO_JOIN_CNF.CMD_STATUS : char
J#
public enum ZDO_JOIN_CNF.CMD_STATUS byte
JScript
public enum ZDO_JOIN_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_JOIN_REQ Class

ZDO_JOIN_REQ Class
See Also Example Members
[image]

This command is used to request the device to join itself to a parent device on a network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_JOIN_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_JOIN_REQ : IREQUEST, IZDO
C++
ref class ZDO_JOIN_REQ : IREQUEST, IZDO
J#
public class ZDO_JOIN_REQ implements IREQUEST, IZDO
JScript
public class ZDO_JOIN_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_JOIN_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_JOIN_REQ Members
TI.ZPI2 Namespace


ZDO_JOIN_REQ Members

ZDO_JOIN_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request the device to join itself to a parent device on a network.

The following tables list the members exposed by ZDO_JOIN_REQ.

Public Constructors

Name | Description
ZDO_JOIN_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChosenParent | Short address of the parent device chosen to join.
Public field | ExtendedPanID | 64-bit extended PAN ID (ver 1.1 only). If not v1.1 or don't care, use all 0xFF.
Public field | LogicalChannel | Channel where the PAN is located.
Public field | PanID | Id of PAN to join.
Public field | ParentDepth | Depth of the parent.
Public field | StackProfile | Stack profile of the network to join.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_JOIN_REQ | Overloaded.
Top

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


ZDO_JOIN_REQ Constructor

ZDO_JOIN_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_JOIN_REQ | Constructor
Public method | ZDO_JOIN_REQ (Byte, UInt16, UInt64, UInt16, Byte, Byte) | Constructor

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


ZDO_JOIN_REQ Constructor ()

ZDO_JOIN_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_JOIN_REQ()
C++
public:
ZDO_JOIN_REQ() sealed
J#
public ZDO_JOIN_REQ()
JScript
public function ZDO_JOIN_REQ()

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace
ZDO_JOIN_REQ Constructor Overload List


ZDO_JOIN_REQ Constructor (Byte, UInt16, UInt64, UInt16, Byte, Byte)

ZDO_JOIN_REQ Constructor (Byte, UInt16, UInt64, UInt16, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_JOIN_REQ(
byte ,
ushort ,
ulong ,
ushort ,
byte ,
byte
)
C++
public:
ZDO_JOIN_REQ(
char ,
unsigned short ,
unsigned __int64 ,
unsigned short ,
char ,
char
) sealed
J#
public ZDO_JOIN_REQ(
byte ,
ushort ,
ulong ,
ushort ,
byte ,
byte
)
JScript
public function ZDO_JOIN_REQ(
: Byte,
: UInt16,
: UInt64,
: UInt16,
: Byte,
: Byte
)

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace
ZDO_JOIN_REQ Constructor Overload List


Fields

ZDO_JOIN_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | ChosenParent | Short address of the parent device chosen to join.
Public field | ExtendedPanID | 64-bit extended PAN ID (ver 1.1 only). If not v1.1 or don't care, use all 0xFF.
Public field | LogicalChannel | Channel where the PAN is located.
Public field | PanID | Id of PAN to join.
Public field | ParentDepth | Depth of the parent.
Public field | StackProfile | Stack profile of the network to join.
Top

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


ChosenParent Field

ZDO_JOIN_REQ.ChosenParent Field
[image]

Short address of the parent device chosen to join.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChosenParent As UInt16
C#
public ushort ChosenParent;
C++
public:
unsigned short ChosenParent sealed ;
J#
public ushort ChosenParent
JScript
public ChosenParent : UInt16;

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


ExtendedPanID Field

ZDO_JOIN_REQ.ExtendedPanID Field
[image]

64-bit extended PAN ID (ver 1.1 only). If not v1.1 or don't care, use all 0xFF.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedPanID As UInt64
C#
public ulong ExtendedPanID;
C++
public:
unsigned __int64 ExtendedPanID sealed ;
J#
public ulong ExtendedPanID
JScript
public ExtendedPanID : UInt64;

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


LogicalChannel Field

ZDO_JOIN_REQ.LogicalChannel Field
[image]

Channel where the PAN is located.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


PanID Field

ZDO_JOIN_REQ.PanID Field
[image]

Id of PAN to join.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


ParentDepth Field

ZDO_JOIN_REQ.ParentDepth Field
[image]

Depth of the parent.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ParentDepth As Byte
C#
public byte ParentDepth;
C++
public:
char ParentDepth sealed ;
J#
public byte ParentDepth
JScript
public ParentDepth : Byte;

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


StackProfile Field

ZDO_JOIN_REQ.StackProfile Field
[image]

Stack profile of the network to join.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StackProfile As Byte
C#
public byte StackProfile;
C++
public:
char StackProfile sealed ;
J#
public byte StackProfile
JScript
public StackProfile : Byte;

See Also

ZDO_JOIN_REQ Class
TI.ZPI2 Namespace


ZDO_JOIN_REQ_SRSP Class

ZDO_JOIN_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_JOIN_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_JOIN_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_JOIN_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_JOIN_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_JOIN_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_JOIN_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_JOIN_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_JOIN_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_JOIN_REQ_SRSP Members

ZDO_JOIN_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_JOIN_REQ

The following tables list the members exposed by ZDO_JOIN_REQ_SRSP.

Public Constructors

Name | Description
ZDO_JOIN_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_JOIN_REQ_SRSP | Overloaded.
Top

See Also

ZDO_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_JOIN_REQ_SRSP Constructor

ZDO_JOIN_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_JOIN_REQ_SRSP | Constructor
Public method | ZDO_JOIN_REQ_SRSP (ZDO_JOIN_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_JOIN_REQ_SRSP Constructor ()

ZDO_JOIN_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_JOIN_REQ_SRSP()
C++
public:
ZDO_JOIN_REQ_SRSP() sealed
J#
public ZDO_JOIN_REQ_SRSP()
JScript
public function ZDO_JOIN_REQ_SRSP()

See Also

ZDO_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_JOIN_REQ_SRSP Constructor Overload List


ZDO_JOIN_REQ_SRSP Constructor (ZDO_JOIN_REQ_SRSP.CMD_STATUS)

ZDO_JOIN_REQ_SRSP Constructor (ZDO_JOIN_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_JOIN_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_JOIN_REQ_SRSP(
ZDO_JOIN_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_JOIN_REQ_SRSP(
ZDO_JOIN_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_JOIN_REQ_SRSP(
ZDO_JOIN_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_JOIN_REQ_SRSP(
: ZDO_JOIN_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_JOIN_REQ_SRSP Constructor Overload List


Fields

ZDO_JOIN_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_JOIN_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_JOIN_REQ_SRSP.CMD_STATUS
C#
public ZDO_JOIN_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_JOIN_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_JOIN_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_JOIN_REQ_SRSP.CMD_STATUS;

See Also

ZDO_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_JOIN_REQ_SRSP.CMD_STATUS Enumeration

ZDO_JOIN_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_JOIN_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_JOIN_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_JOIN_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_JOIN_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_JOIN_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_LEAVE_IND Class

ZDO_LEAVE_IND Class
See Also Example Members
[image]

ZDO leave indication.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_LEAVE_IND
Implements IRESPONSE, IZDO
C#
public class ZDO_LEAVE_IND : IRESPONSE, IZDO
C++
ref class ZDO_LEAVE_IND : IRESPONSE, IZDO
J#
public class ZDO_LEAVE_IND implements IRESPONSE, IZDO
JScript
public class ZDO_LEAVE_IND extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_LEAVE_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_LEAVE_IND Members
TI.ZPI2 Namespace


ZDO_LEAVE_IND Members

ZDO_LEAVE_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

ZDO leave indication.

The following tables list the members exposed by ZDO_LEAVE_IND.

Public Constructors

Name | Description
ZDO_LEAVE_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | extAddr | Extended address corresponding to the leave indication.
Public field | rejoin | A boolean whether or not to rejoin.
Public field | removeChildren | A boolean whether or not to remove children.
Public field | request | Request of the leave indication.
Public field | srcAddr | Network Source Address of the leave indication.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_LEAVE_IND | Overloaded.
Top

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


ZDO_LEAVE_IND Constructor

ZDO_LEAVE_IND Constructor

Overload List

 | Name | Description
Public method | ZDO_LEAVE_IND | Constructor
Public method | ZDO_LEAVE_IND (UInt16, UInt64, Byte, Byte, Byte) | Constructor

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


ZDO_LEAVE_IND Constructor ()

ZDO_LEAVE_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_LEAVE_IND()
C++
public:
ZDO_LEAVE_IND() sealed
J#
public ZDO_LEAVE_IND()
JScript
public function ZDO_LEAVE_IND()

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace
ZDO_LEAVE_IND Constructor Overload List


ZDO_LEAVE_IND Constructor (UInt16, UInt64, Byte, Byte, Byte)

ZDO_LEAVE_IND Constructor (UInt16, UInt64, Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_LEAVE_IND(
ushort ,
ulong ,
byte ,
byte ,
byte
)
C++
public:
ZDO_LEAVE_IND(
unsigned short ,
unsigned __int64 ,
char ,
char ,
char
) sealed
J#
public ZDO_LEAVE_IND(
ushort ,
ulong ,
byte ,
byte ,
byte
)
JScript
public function ZDO_LEAVE_IND(
: UInt16,
: UInt64,
: Byte,
: Byte,
: Byte
)

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace
ZDO_LEAVE_IND Constructor Overload List


Fields

ZDO_LEAVE_IND Fields
[image]

Public Fields

 | Name | Description
Public field | extAddr | Extended address corresponding to the leave indication.
Public field | rejoin | A boolean whether or not to rejoin.
Public field | removeChildren | A boolean whether or not to remove children.
Public field | request | Request of the leave indication.
Public field | srcAddr | Network Source Address of the leave indication.
Top

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


extAddr Field

ZDO_LEAVE_IND.extAddr Field
[image]

Extended address corresponding to the leave indication.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public extAddr As UInt64
C#
public ulong extAddr;
C++
public:
unsigned __int64 extAddr sealed ;
J#
public ulong extAddr
JScript
public extAddr : UInt64;

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


rejoin Field

ZDO_LEAVE_IND.rejoin Field
[image]

A boolean whether or not to rejoin.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public rejoin As Byte
C#
public byte rejoin;
C++
public:
char rejoin sealed ;
J#
public byte rejoin
JScript
public rejoin : Byte;

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


removeChildren Field

ZDO_LEAVE_IND.removeChildren Field
[image]

A boolean whether or not to remove children.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public removeChildren As Byte
C#
public byte removeChildren;
C++
public:
char removeChildren sealed ;
J#
public byte removeChildren
JScript
public removeChildren : Byte;

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


request Field

ZDO_LEAVE_IND.request Field
[image]

Request of the leave indication.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public request As Byte
C#
public byte request;
C++
public:
char request sealed ;
J#
public byte request
JScript
public request : Byte;

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


srcAddr Field

ZDO_LEAVE_IND.srcAddr Field
[image]

Network Source Address of the leave indication.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public srcAddr As UInt16
C#
public ushort srcAddr;
C++
public:
unsigned short srcAddr sealed ;
J#
public ushort srcAddr
JScript
public srcAddr : UInt16;

See Also

ZDO_LEAVE_IND Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ Class

ZDO_MATCH_DESC_REQ Class
See Also Example Members
[image]

This command is generated to request a list of active endpoint from the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MATCH_DESC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_MATCH_DESC_REQ : IREQUEST, IZDO
C++
ref class ZDO_MATCH_DESC_REQ : IREQUEST, IZDO
J#
public class ZDO_MATCH_DESC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_MATCH_DESC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MATCH_DESC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MATCH_DESC_REQ Members
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ Members

ZDO_MATCH_DESC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a list of active endpoint from the destination device

The following tables list the members exposed by ZDO_MATCH_DESC_REQ.

Public Constructors

Name | Description
ZDO_MATCH_DESC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the
Public field | NWKAddrOfInterest | NWK address for the request
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MATCH_DESC_REQ | Overloaded.
Top

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ Constructor

ZDO_MATCH_DESC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_MATCH_DESC_REQ | Constructor
Public method | ZDO_MATCH_DESC_REQ (UInt16, UInt16, UInt16, Byte, UInt16, Byte, UInt16) | Constructor

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ Constructor ()

ZDO_MATCH_DESC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MATCH_DESC_REQ()
C++
public:
ZDO_MATCH_DESC_REQ() sealed
J#
public ZDO_MATCH_DESC_REQ()
JScript
public function ZDO_MATCH_DESC_REQ()

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_REQ Constructor Overload List


ZDO_MATCH_DESC_REQ Constructor (UInt16, UInt16, UInt16, Byte, UInt16[], Byte, UInt16[])

ZDO_MATCH_DESC_REQ Constructor (UInt16, UInt16, UInt16, Byte, UInt16[], Byte, UInt16[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_MATCH_DESC_REQ(
ushort ,
ushort ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[]
)
C++
public:
ZDO_MATCH_DESC_REQ(
unsigned short ,
unsigned short ,
unsigned short ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_MATCH_DESC_REQ(
ushort ,
ushort ,
ushort ,
byte ,
ushort[] ,
byte ,
ushort[]
)
JScript
public function ZDO_MATCH_DESC_REQ(
: UInt16,
: UInt16,
: UInt16,
: Byte,
: UInt16[],
: Byte,
: UInt16[]
)

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_REQ Constructor Overload List


Fields

ZDO_MATCH_DESC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | InClusterList | Array of input cluster IDs - NumInClusters long
Public field | NumInClusters | Number of ClusterIds in the InClusterList
Public field | NumOutClusters | Number of ClusterIds in the
Public field | NWKAddrOfInterest | NWK address for the request
Public field | OutClusterList | Array of output cluster IDs - NumOutClusters long
Public field | ProfileID | Profile ID to match
Top

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MATCH_DESC_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


InClusterList Field

ZDO_MATCH_DESC_REQ.InClusterList Field
[image]

Array of input cluster IDs - NumInClusters long

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InClusterList As UInt16()
C#
public ushort[] InClusterList;
C++
public:
array<unsigned short>^ InClusterList sealed ;
J#
public ushort[] InClusterList
JScript
public InClusterList : UInt16[];

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


NumInClusters Field

ZDO_MATCH_DESC_REQ.NumInClusters Field
[image]

Number of ClusterIds in the InClusterList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumInClusters As Byte
C#
public byte NumInClusters;
C++
public:
char NumInClusters sealed ;
J#
public byte NumInClusters
JScript
public NumInClusters : Byte;

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


NumOutClusters Field

ZDO_MATCH_DESC_REQ.NumOutClusters Field
[image]

Number of ClusterIds in the

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOutClusters As Byte
C#
public byte NumOutClusters;
C++
public:
char NumOutClusters sealed ;
J#
public byte NumOutClusters
JScript
public NumOutClusters : Byte;

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_MATCH_DESC_REQ.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


OutClusterList Field

ZDO_MATCH_DESC_REQ.OutClusterList Field
[image]

Array of output cluster IDs - NumOutClusters long

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutClusterList As UInt16()
C#
public ushort[] OutClusterList;
C++
public:
array<unsigned short>^ OutClusterList sealed ;
J#
public ushort[] OutClusterList
JScript
public OutClusterList : UInt16[];

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


ProfileID Field

ZDO_MATCH_DESC_REQ.ProfileID Field
[image]

Profile ID to match

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ProfileID As UInt16
C#
public ushort ProfileID;
C++
public:
unsigned short ProfileID sealed ;
J#
public ushort ProfileID
JScript
public ProfileID : UInt16;

See Also

ZDO_MATCH_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ_SRSP Class

ZDO_MATCH_DESC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MATCH_DESC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MATCH_DESC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MATCH_DESC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MATCH_DESC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MATCH_DESC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MATCH_DESC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MATCH_DESC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MATCH_DESC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ_SRSP Members

ZDO_MATCH_DESC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MATCH_DESC_REQ

The following tables list the members exposed by ZDO_MATCH_DESC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MATCH_DESC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MATCH_DESC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MATCH_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ_SRSP Constructor

ZDO_MATCH_DESC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MATCH_DESC_REQ_SRSP | Constructor
Public method | ZDO_MATCH_DESC_REQ_SRSP (ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS) |

See Also

ZDO_MATCH_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ_SRSP Constructor ()

ZDO_MATCH_DESC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MATCH_DESC_REQ_SRSP()
C++
public:
ZDO_MATCH_DESC_REQ_SRSP() sealed
J#
public ZDO_MATCH_DESC_REQ_SRSP()
JScript
public function ZDO_MATCH_DESC_REQ_SRSP()

See Also

ZDO_MATCH_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_REQ_SRSP Constructor Overload List


ZDO_MATCH_DESC_REQ_SRSP Constructor (ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS)

ZDO_MATCH_DESC_REQ_SRSP Constructor (ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_MATCH_DESC_REQ_SRSP(
ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_MATCH_DESC_REQ_SRSP(
ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_MATCH_DESC_REQ_SRSP(
ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_MATCH_DESC_REQ_SRSP(
: ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS
)

See Also

ZDO_MATCH_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_REQ_SRSP Constructor Overload List


Fields

ZDO_MATCH_DESC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MATCH_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MATCH_DESC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS
C#
public ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS;

See Also

ZDO_MATCH_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS Enumeration

ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP Class

ZDO_MATCH_DESC_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Match Description Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MATCH_DESC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MATCH_DESC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MATCH_DESC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MATCH_DESC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MATCH_DESC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MATCH_DESC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MATCH_DESC_RSP Members
TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP Members

ZDO_MATCH_DESC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Match Description Request

The following tables list the members exposed by ZDO_MATCH_DESC_RSP.

Public Constructors

Name | Description
ZDO_MATCH_DESC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MatchLength | The count of endpoints on the remote device that match the request criteria
Public field | MatchList | List of bytes, each represents an 8 bit endpoint
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MATCH_DESC_RSP | Overloaded.
Top

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP Constructor

ZDO_MATCH_DESC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MATCH_DESC_RSP | Constructor
Public method | ZDO_MATCH_DESC_RSP (UInt16, ZDO_MATCH_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte) |

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP Constructor ()

ZDO_MATCH_DESC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MATCH_DESC_RSP()
C++
public:
ZDO_MATCH_DESC_RSP() sealed
J#
public ZDO_MATCH_DESC_RSP()
JScript
public function ZDO_MATCH_DESC_RSP()

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_RSP Constructor Overload List


ZDO_MATCH_DESC_RSP Constructor (UInt16, ZDO_MATCH_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte[])

ZDO_MATCH_DESC_RSP Constructor (UInt16, ZDO_MATCH_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MATCH_DESC_RSP.ZDO_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_MATCH_DESC_RSP(
ushort ,
ZDO_MATCH_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_MATCH_DESC_RSP(
unsigned short ,
ZDO_MATCH_DESC_RSP.ZDO_STATUS ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_MATCH_DESC_RSP(
ushort ,
ZDO_MATCH_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_MATCH_DESC_RSP(
: UInt16,
: ZDO_MATCH_DESC_RSP.ZDO_STATUS,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_RSP Constructor Overload List


Fields

ZDO_MATCH_DESC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | MatchLength | The count of endpoints on the remote device that match the request criteria
Public field | MatchList | List of bytes, each represents an 8 bit endpoint
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


MatchLength Field

ZDO_MATCH_DESC_RSP.MatchLength Field
[image]

The count of endpoints on the remote device that match the request criteria

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MatchLength As Byte
C#
public byte MatchLength;
C++
public:
char MatchLength sealed ;
J#
public byte MatchLength
JScript
public MatchLength : Byte;

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


MatchList Field

ZDO_MATCH_DESC_RSP.MatchList Field
[image]

List of bytes, each represents an 8 bit endpoint

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MatchList As Byte()
C#
public byte[] MatchList;
C++
public:
array<char>^ MatchList sealed ;
J#
public byte[] MatchList
JScript
public MatchList : Byte[];

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_MATCH_DESC_RSP.NwkAddr Field
[image]

Device's short address that this response describes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MATCH_DESC_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MATCH_DESC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MATCH_DESC_RSP.ZDO_STATUS
C#
public ZDO_MATCH_DESC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MATCH_DESC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MATCH_DESC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MATCH_DESC_RSP.ZDO_STATUS;

See Also

ZDO_MATCH_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP.ZDO_STATUS Enumeration

ZDO_MATCH_DESC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MATCH_DESC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MATCH_DESC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MATCH_DESC_RSP.ZDO_STATUS : char
J#
public enum ZDO_MATCH_DESC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MATCH_DESC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP_SENT Class

ZDO_MATCH_DESC_RSP_SENT Class
See Also Example Members
[image]

This callback indicates that Match Descriptor Response has been sent.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MATCH_DESC_RSP_SENT
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MATCH_DESC_RSP_SENT : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MATCH_DESC_RSP_SENT : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MATCH_DESC_RSP_SENT implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MATCH_DESC_RSP_SENT extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MATCH_DESC_RSP_SENT

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MATCH_DESC_RSP_SENT Members
TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP_SENT Members

ZDO_MATCH_DESC_RSP_SENT Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback indicates that Match Descriptor Response has been sent.

The following tables list the members exposed by ZDO_MATCH_DESC_RSP_SENT.

Public Constructors

Name | Description
ZDO_MATCH_DESC_RSP_SENT | Overloaded.
Top

Public Fields

 | Name | Description
Public field | InClusterList | List of input cluster IDs supported.
Public field | NumInClusters | Network address
Public field | NumOutClusters | The number of output clusters in the OutClusterList.
Public field | NwkAddr | Specifies the device short address.
Public field | OutClusterList | List of output cluster IDs supported.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MATCH_DESC_RSP_SENT | Overloaded.
Top

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP_SENT Constructor

ZDO_MATCH_DESC_RSP_SENT Constructor

Overload List

 | Name | Description
Public method | ZDO_MATCH_DESC_RSP_SENT | Constructor
Public method | ZDO_MATCH_DESC_RSP_SENT (UInt16, Byte, Byte, Byte, Byte) | Constructor

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


ZDO_MATCH_DESC_RSP_SENT Constructor ()

ZDO_MATCH_DESC_RSP_SENT Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MATCH_DESC_RSP_SENT()
C++
public:
ZDO_MATCH_DESC_RSP_SENT() sealed
J#
public ZDO_MATCH_DESC_RSP_SENT()
JScript
public function ZDO_MATCH_DESC_RSP_SENT()

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_RSP_SENT Constructor Overload List


ZDO_MATCH_DESC_RSP_SENT Constructor (UInt16, Byte, Byte[], Byte, Byte[])

ZDO_MATCH_DESC_RSP_SENT Constructor (UInt16, Byte, Byte[], Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_MATCH_DESC_RSP_SENT(
ushort ,
byte ,
byte[] ,
byte ,
byte[]
)
C++
public:
ZDO_MATCH_DESC_RSP_SENT(
unsigned short ,
char ,
array<char>^ ,
char ,
array<char>^
) sealed
J#
public ZDO_MATCH_DESC_RSP_SENT(
ushort ,
byte ,
byte[] ,
byte ,
byte[]
)
JScript
public function ZDO_MATCH_DESC_RSP_SENT(
: UInt16,
: Byte,
: Byte[],
: Byte,
: Byte[]
)

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace
ZDO_MATCH_DESC_RSP_SENT Constructor Overload List


Fields

ZDO_MATCH_DESC_RSP_SENT Fields
[image]

Public Fields

 | Name | Description
Public field | InClusterList | List of input cluster IDs supported.
Public field | NumInClusters | Network address
Public field | NumOutClusters | The number of output clusters in the OutClusterList.
Public field | NwkAddr | Specifies the device short address.
Public field | OutClusterList | List of output cluster IDs supported.
Top

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


InClusterList Field

ZDO_MATCH_DESC_RSP_SENT.InClusterList Field
[image]

List of input cluster IDs supported.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InClusterList As Byte()
C#
public byte[] InClusterList;
C++
public:
array<char>^ InClusterList sealed ;
J#
public byte[] InClusterList
JScript
public InClusterList : Byte[];

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


NumInClusters Field

ZDO_MATCH_DESC_RSP_SENT.NumInClusters Field
[image]

Network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumInClusters As Byte
C#
public byte NumInClusters;
C++
public:
char NumInClusters sealed ;
J#
public byte NumInClusters
JScript
public NumInClusters : Byte;

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


NumOutClusters Field

ZDO_MATCH_DESC_RSP_SENT.NumOutClusters Field
[image]

The number of output clusters in the OutClusterList.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOutClusters As Byte
C#
public byte NumOutClusters;
C++
public:
char NumOutClusters sealed ;
J#
public byte NumOutClusters
JScript
public NumOutClusters : Byte;

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_MATCH_DESC_RSP_SENT.NwkAddr Field
[image]

Specifies the device short address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


OutClusterList Field

ZDO_MATCH_DESC_RSP_SENT.OutClusterList Field
[image]

List of output cluster IDs supported.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutClusterList As Byte()
C#
public byte[] OutClusterList;
C++
public:
array<char>^ OutClusterList sealed ;
J#
public byte[] OutClusterList
JScript
public OutClusterList : Byte[];

See Also

ZDO_MATCH_DESC_RSP_SENT Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ Class

ZDO_MGMT_BIND_REQ Class
See Also Example Members
[image]

This command is generated to request a Management Binding Table Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_BIND_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_BIND_REQ : IREQUEST, IZDO
C++
ref class ZDO_MGMT_BIND_REQ : IREQUEST, IZDO
J#
public class ZDO_MGMT_BIND_REQ implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_BIND_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_BIND_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_REQ Members
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ Members

ZDO_MGMT_BIND_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Binding Table Request.

The following tables list the members exposed by ZDO_MGMT_BIND_REQ.

Public Constructors

Name | Description
ZDO_MGMT_BIND_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_REQ | Overloaded.
Top

See Also

ZDO_MGMT_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ Constructor

ZDO_MGMT_BIND_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_REQ | Constructor
Public method | ZDO_MGMT_BIND_REQ (UInt16, Byte) | Constructor

See Also

ZDO_MGMT_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ Constructor ()

ZDO_MGMT_BIND_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_REQ()
C++
public:
ZDO_MGMT_BIND_REQ() sealed
J#
public ZDO_MGMT_BIND_REQ()
JScript
public function ZDO_MGMT_BIND_REQ()

See Also

ZDO_MGMT_BIND_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_BIND_REQ Constructor Overload List


ZDO_MGMT_BIND_REQ Constructor (UInt16, Byte)

ZDO_MGMT_BIND_REQ Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_MGMT_BIND_REQ(
ushort ,
byte
)
C++
public:
ZDO_MGMT_BIND_REQ(
unsigned short ,
char
) sealed
J#
public ZDO_MGMT_BIND_REQ(
ushort ,
byte
)
JScript
public function ZDO_MGMT_BIND_REQ(
: UInt16,
: Byte
)

See Also

ZDO_MGMT_BIND_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_BIND_REQ Constructor Overload List


Fields

ZDO_MGMT_BIND_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

See Also

ZDO_MGMT_BIND_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_BIND_REQ.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_BIND_REQ Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_BIND_REQ.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_BIND_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ_SRSP Class

ZDO_MGMT_BIND_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MGMT_BIND_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_BIND_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_BIND_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_BIND_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MGMT_BIND_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_BIND_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_BIND_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ_SRSP Members

ZDO_MGMT_BIND_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_BIND_REQ

The following tables list the members exposed by ZDO_MGMT_BIND_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MGMT_BIND_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MGMT_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ_SRSP Constructor

ZDO_MGMT_BIND_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_REQ_SRSP | Constructor
Public method | ZDO_MGMT_BIND_REQ_SRSP (ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_MGMT_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ_SRSP Constructor ()

ZDO_MGMT_BIND_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_REQ_SRSP()
C++
public:
ZDO_MGMT_BIND_REQ_SRSP() sealed
J#
public ZDO_MGMT_BIND_REQ_SRSP()
JScript
public function ZDO_MGMT_BIND_REQ_SRSP()

See Also

ZDO_MGMT_BIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_BIND_REQ_SRSP Constructor Overload List


ZDO_MGMT_BIND_REQ_SRSP Constructor (ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS)

ZDO_MGMT_BIND_REQ_SRSP Constructor (ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_MGMT_BIND_REQ_SRSP(
ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_MGMT_BIND_REQ_SRSP(
ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_MGMT_BIND_REQ_SRSP(
ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_MGMT_BIND_REQ_SRSP(
: ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_MGMT_BIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_BIND_REQ_SRSP Constructor Overload List


Fields

ZDO_MGMT_BIND_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_BIND_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS
C#
public ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS;

See Also

ZDO_MGMT_BIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS Enumeration

ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP Class

ZDO_MGMT_BIND_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Binding Table Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_BIND_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_BIND_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_BIND_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_BIND_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_BIND_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_BIND_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_RSP Members
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP Members

ZDO_MGMT_BIND_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Binding Table Request

The following tables list the members exposed by ZDO_MGMT_BIND_RSP.

Public Constructors

Name | Description
ZDO_MGMT_BIND_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BindingTableEntries | Total number of entries available in the device.
Public field | BindingTableList | Dynamic array, an array of BindList items. BindListCount contains the number of items in this table.
Public field | BindingTableListCount | Number of entries in this response.
Public field | SrcAddr | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_RSP | Overloaded.
Top

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP Constructor

ZDO_MGMT_BIND_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_RSP | Constructor
Public method | ZDO_MGMT_BIND_RSP (UInt16, ZDO_MGMT_BIND_RSP.ZDO_STATUS, Byte, Byte, Byte, Object) |

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP Constructor ()

ZDO_MGMT_BIND_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_RSP()
C++
public:
ZDO_MGMT_BIND_RSP() sealed
J#
public ZDO_MGMT_BIND_RSP()
JScript
public function ZDO_MGMT_BIND_RSP()

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_BIND_RSP Constructor Overload List


ZDO_MGMT_BIND_RSP Constructor (UInt16, ZDO_MGMT_BIND_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])

ZDO_MGMT_BIND_RSP Constructor (UInt16, ZDO_MGMT_BIND_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_BIND_RSP.ZDO_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_MGMT_BIND_RSP(
ushort ,
ZDO_MGMT_BIND_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
C++
public:
ZDO_MGMT_BIND_RSP(
unsigned short ,
ZDO_MGMT_BIND_RSP.ZDO_STATUS ,
char ,
char ,
char ,
array<Object>^
) sealed
J#
public ZDO_MGMT_BIND_RSP(
ushort ,
ZDO_MGMT_BIND_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
JScript
public function ZDO_MGMT_BIND_RSP(
: UInt16,
: ZDO_MGMT_BIND_RSP.ZDO_STATUS,
: Byte,
: Byte,
: Byte,
: Object[]
)

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_BIND_RSP Constructor Overload List


Fields

ZDO_MGMT_BIND_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | BindingTableEntries | Total number of entries available in the device.
Public field | BindingTableList | Dynamic array, an array of BindList items. BindListCount contains the number of items in this table.
Public field | BindingTableListCount | Number of entries in this response.
Public field | SrcAddr | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


BindingTableEntries Field

ZDO_MGMT_BIND_RSP.BindingTableEntries Field
[image]

Total number of entries available in the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindingTableEntries As Byte
C#
public byte BindingTableEntries;
C++
public:
char BindingTableEntries sealed ;
J#
public byte BindingTableEntries
JScript
public BindingTableEntries : Byte;

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


BindingTableList Field

ZDO_MGMT_BIND_RSP.BindingTableList Field
[image]

Dynamic array, an array of BindList items. BindListCount contains the number of items in this table.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindingTableList As Object()
C#
public object[] BindingTableList;
C++
public:
array<Object>^ BindingTableList sealed ;
J#
public object[] BindingTableList
JScript
public BindingTableList : Object[];

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


BindingTableListCount Field

ZDO_MGMT_BIND_RSP.BindingTableListCount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BindingTableListCount As Byte
C#
public byte BindingTableListCount;
C++
public:
char BindingTableListCount sealed ;
J#
public byte BindingTableListCount
JScript
public BindingTableListCount : Byte;

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MGMT_BIND_RSP.SrcAddr Field
[image]

Source address of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_BIND_RSP.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_BIND_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_BIND_RSP.ZDO_STATUS
C#
public ZDO_MGMT_BIND_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MGMT_BIND_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MGMT_BIND_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MGMT_BIND_RSP.ZDO_STATUS;

See Also

ZDO_MGMT_BIND_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP.BindListItemClass Structure

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
See Also Example Members
[image]

Contains information in a single item of a bind list

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_MGMT_BIND_RSP.BindListItemClass
C#
public struct ZDO_MGMT_BIND_RSP.BindListItemClass
C++
value class ZDO_MGMT_BIND_RSP.BindListItemClass
J#
public final class ZDO_MGMT_BIND_RSP.BindListItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_BIND_RSP.BindListItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Members
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP.BindListItemClass Members

ZDO_MGMT_BIND_RSP.BindListItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Contains information in a single item of a bind list

The following tables list the members exposed by ZDO_MGMT_BIND_RSP.BindListItemClass.

Public Constructors

Name | Description
ZDO_MGMT_BIND_RSP.BindListItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID |
Public field | DestAddr |
Public field | DestAddrMode |
Public field | DestEndpoint |
Public field | SrcAddress |
Public field | SrcEndpoint |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_BIND_RSP.BindListItemClass | Overloaded.
Top

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP.BindListItemClass Constructor

ZDO_MGMT_BIND_RSP.BindListItemClass Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_BIND_RSP.BindListItemClass | Initializes a new instance of the ZDO_MGMT_BIND_RSP.BindListItemClass class.
Public method | ZDO_MGMT_BIND_RSP.BindListItemClass (UInt64, Byte, UInt16, Byte, UInt64, Byte) |

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP.BindListItemClass Constructor ()

ZDO_MGMT_BIND_RSP.BindListItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the ZDO_MGMT_BIND_RSP.BindListItemClass class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_BIND_RSP.BindListItemClass()
C++
public:
ZDO_MGMT_BIND_RSP.BindListItemClass() sealed
J#
public ZDO_MGMT_BIND_RSP.BindListItemClass()
JScript
public function ZDO_MGMT_BIND_RSP.BindListItemClass()

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace
ZDO_MGMT_BIND_RSP.BindListItemClass Constructor Overload List


ZDO_MGMT_BIND_RSP.BindListItemClass Constructor (UInt64, Byte, UInt16, Byte, UInt64, Byte)

ZDO_MGMT_BIND_RSP.BindListItemClass Constructor (UInt64, Byte, UInt16, Byte, UInt64, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt64, _
ByVal As Byte _
)
C#
public ZDO_MGMT_BIND_RSP.BindListItemClass(
ulong ,
byte ,
ushort ,
byte ,
ulong ,
byte
)
C++
public:
ZDO_MGMT_BIND_RSP.BindListItemClass(
unsigned __int64 ,
char ,
unsigned short ,
char ,
unsigned __int64 ,
char
) sealed
J#
public ZDO_MGMT_BIND_RSP.BindListItemClass(
ulong ,
byte ,
ushort ,
byte ,
ulong ,
byte
)
JScript
public function ZDO_MGMT_BIND_RSP.BindListItemClass(
: UInt64,
: Byte,
: UInt16,
: Byte,
: UInt64,
: Byte
)

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace
ZDO_MGMT_BIND_RSP.BindListItemClass Constructor Overload List


Fields

ZDO_MGMT_BIND_RSP.BindListItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID |
Public field | DestAddr |
Public field | DestAddrMode |
Public field | DestEndpoint |
Public field | SrcAddress |
Public field | SrcEndpoint |
Top

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


ClusterID Field

ZDO_MGMT_BIND_RSP.BindListItemClass.ClusterID Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


DestAddr Field

ZDO_MGMT_BIND_RSP.BindListItemClass.DestAddr Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddr As UInt64
C#
public ulong DestAddr;
C++
public:
unsigned __int64 DestAddr sealed ;
J#
public ulong DestAddr
JScript
public DestAddr : UInt64;

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


DestAddrMode Field

ZDO_MGMT_BIND_RSP.BindListItemClass.DestAddrMode Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddrMode As Byte
C#
public byte DestAddrMode;
C++
public:
char DestAddrMode sealed ;
J#
public byte DestAddrMode
JScript
public DestAddrMode : Byte;

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


DestEndpoint Field

ZDO_MGMT_BIND_RSP.BindListItemClass.DestEndpoint Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestEndpoint As Byte
C#
public byte DestEndpoint;
C++
public:
char DestEndpoint sealed ;
J#
public byte DestEndpoint
JScript
public DestEndpoint : Byte;

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


SrcAddress Field

ZDO_MGMT_BIND_RSP.BindListItemClass.SrcAddress Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


SrcEndpoint Field

ZDO_MGMT_BIND_RSP.BindListItemClass.SrcEndpoint Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

ZDO_MGMT_BIND_RSP.BindListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_BIND_RSP.ZDO_STATUS Enumeration

ZDO_MGMT_BIND_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_BIND_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MGMT_BIND_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MGMT_BIND_RSP.ZDO_STATUS : char
J#
public enum ZDO_MGMT_BIND_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MGMT_BIND_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ Class

ZDO_MGMT_DIRECT_JOIN_REQ Class
See Also Example Members
[image]

This command is generated to request a Management Direct Join Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_DIRECT_JOIN_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_DIRECT_JOIN_REQ : IREQUEST, IZDO
C++
ref class ZDO_MGMT_DIRECT_JOIN_REQ : IREQUEST, IZDO
J#
public class ZDO_MGMT_DIRECT_JOIN_REQ implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_DIRECT_JOIN_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Members
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ Members

ZDO_MGMT_DIRECT_JOIN_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Direct Join Request

The following tables list the members exposed by ZDO_MGMT_DIRECT_JOIN_REQ.

Public Constructors

Name | Description
ZDO_MGMT_DIRECT_JOIN_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapInfo | The operating capabilities of the device being directly joined
Public field | DeviceAddr | The 64 bit IEEE Address of the device you want to be joined to the device at DstAddr
Public field | DstAddr | Destination network address.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_DIRECT_JOIN_REQ | Overloaded.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ Constructor

ZDO_MGMT_DIRECT_JOIN_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_DIRECT_JOIN_REQ | Constructor
Public method | ZDO_MGMT_DIRECT_JOIN_REQ (UInt16, UInt64, ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO) |

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ Constructor ()

ZDO_MGMT_DIRECT_JOIN_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_DIRECT_JOIN_REQ()
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQ() sealed
J#
public ZDO_MGMT_DIRECT_JOIN_REQ()
JScript
public function ZDO_MGMT_DIRECT_JOIN_REQ()

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_DIRECT_JOIN_REQ Constructor Overload List


ZDO_MGMT_DIRECT_JOIN_REQ Constructor (UInt16, UInt64, ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO)

ZDO_MGMT_DIRECT_JOIN_REQ Constructor (UInt16, UInt64, ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO _
)
C#
public ZDO_MGMT_DIRECT_JOIN_REQ(
ushort ,
ulong ,
ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO
)
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQ(
unsigned short ,
unsigned __int64 ,
ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO
) sealed
J#
public ZDO_MGMT_DIRECT_JOIN_REQ(
ushort ,
ulong ,
ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO
)
JScript
public function ZDO_MGMT_DIRECT_JOIN_REQ(
: UInt16,
: UInt64,
: ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO
)

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_DIRECT_JOIN_REQ Constructor Overload List


Fields

ZDO_MGMT_DIRECT_JOIN_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | CapInfo | The operating capabilities of the device being directly joined
Public field | DeviceAddr | The 64 bit IEEE Address of the device you want to be joined to the device at DstAddr
Public field | DstAddr | Destination network address.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace


CapInfo Field

ZDO_MGMT_DIRECT_JOIN_REQ.CapInfo Field
[image]

The operating capabilities of the device being directly joined

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapInfo As ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO
C#
public ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO CapInfo;
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO CapInfo sealed ;
J#
public ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO CapInfo
JScript
public CapInfo : ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO;

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace


DeviceAddr Field

ZDO_MGMT_DIRECT_JOIN_REQ.DeviceAddr Field
[image]

The 64 bit IEEE Address of the device you want to be joined to the device at DstAddr

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddr As UInt64
C#
public ulong DeviceAddr;
C++
public:
unsigned __int64 DeviceAddr sealed ;
J#
public ulong DeviceAddr
JScript
public DeviceAddr : UInt64;

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_DIRECT_JOIN_REQ.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_DIRECT_JOIN_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO Enumeration

ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO byte
JScript
public enum ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MGMT_DIRECT_JOIN_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_DIRECT_JOIN_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_DIRECT_JOIN_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_DIRECT_JOIN_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MGMT_DIRECT_JOIN_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_DIRECT_JOIN_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Members

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_DIRECT_JOIN_REQ

The following tables list the members exposed by ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_DIRECT_JOIN_REQ_SRSP | Constructor
Public method | ZDO_MGMT_DIRECT_JOIN_REQ_SRSP (ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor ()

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_DIRECT_JOIN_REQ_SRSP()
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP() sealed
J#
public ZDO_MGMT_DIRECT_JOIN_REQ_SRSP()
JScript
public function ZDO_MGMT_DIRECT_JOIN_REQ_SRSP()

See Also

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor Overload List


ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor (ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS)

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor (ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_MGMT_DIRECT_JOIN_REQ_SRSP(
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP(
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_MGMT_DIRECT_JOIN_REQ_SRSP(
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_MGMT_DIRECT_JOIN_REQ_SRSP(
: ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Constructor Overload List


Fields

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS
C#
public ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS;

See Also

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS Enumeration

ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_RSP Class

ZDO_MGMT_DIRECT_JOIN_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Direct Join Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_DIRECT_JOIN_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_DIRECT_JOIN_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_DIRECT_JOIN_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_DIRECT_JOIN_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_DIRECT_JOIN_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Members
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_RSP Members

ZDO_MGMT_DIRECT_JOIN_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Direct Join Request.

The following tables list the members exposed by ZDO_MGMT_DIRECT_JOIN_RSP.

Public Constructors

Name | Description
ZDO_MGMT_DIRECT_JOIN_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_DIRECT_JOIN_RSP | Overloaded.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_RSP Constructor

ZDO_MGMT_DIRECT_JOIN_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_DIRECT_JOIN_RSP | Constructor
Public method | ZDO_MGMT_DIRECT_JOIN_RSP (UInt16, ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS) |

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_RSP Constructor ()

ZDO_MGMT_DIRECT_JOIN_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_DIRECT_JOIN_RSP()
C++
public:
ZDO_MGMT_DIRECT_JOIN_RSP() sealed
J#
public ZDO_MGMT_DIRECT_JOIN_RSP()
JScript
public function ZDO_MGMT_DIRECT_JOIN_RSP()

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_DIRECT_JOIN_RSP Constructor Overload List


ZDO_MGMT_DIRECT_JOIN_RSP Constructor (UInt16, ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS)

ZDO_MGMT_DIRECT_JOIN_RSP Constructor (UInt16, ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS _
)
C#
public ZDO_MGMT_DIRECT_JOIN_RSP(
ushort ,
ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS
)
C++
public:
ZDO_MGMT_DIRECT_JOIN_RSP(
unsigned short ,
ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS
) sealed
J#
public ZDO_MGMT_DIRECT_JOIN_RSP(
ushort ,
ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS
)
JScript
public function ZDO_MGMT_DIRECT_JOIN_RSP(
: UInt16,
: ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS
)

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_DIRECT_JOIN_RSP Constructor Overload List


Fields

ZDO_MGMT_DIRECT_JOIN_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MGMT_DIRECT_JOIN_RSP.SrcAddr Field
[image]

Source address of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_DIRECT_JOIN_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS
C#
public ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS;

See Also

ZDO_MGMT_DIRECT_JOIN_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS Enumeration

ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS : char
J#
public enum ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ Class

ZDO_MGMT_LEAVE_REQ Class
See Also Example Members
[image]

This command is generated to request a Management Leave Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LEAVE_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_LEAVE_REQ : IREQUEST, IZDO
C++
ref class ZDO_MGMT_LEAVE_REQ : IREQUEST, IZDO
J#
public class ZDO_MGMT_LEAVE_REQ implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_LEAVE_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_LEAVE_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LEAVE_REQ Members
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ Members

ZDO_MGMT_LEAVE_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Leave Request

The following tables list the members exposed by ZDO_MGMT_LEAVE_REQ.

Public Constructors

Name | Description
ZDO_MGMT_LEAVE_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to leave.
Public field | DstAddr | Destination network address.
Public field | RemoveChildren_Rejoin | RemoveChildren: bit 1, Rejoin: bit 0
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LEAVE_REQ | Overloaded.
Top

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ Constructor

ZDO_MGMT_LEAVE_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LEAVE_REQ | Constructor
Public method | ZDO_MGMT_LEAVE_REQ (UInt16, UInt64, Byte) | Constructor

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ Constructor ()

ZDO_MGMT_LEAVE_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LEAVE_REQ()
C++
public:
ZDO_MGMT_LEAVE_REQ() sealed
J#
public ZDO_MGMT_LEAVE_REQ()
JScript
public function ZDO_MGMT_LEAVE_REQ()

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_LEAVE_REQ Constructor Overload List


ZDO_MGMT_LEAVE_REQ Constructor (UInt16, UInt64, Byte)

ZDO_MGMT_LEAVE_REQ Constructor (UInt16, UInt64, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte _
)
C#
public ZDO_MGMT_LEAVE_REQ(
ushort ,
ulong ,
byte
)
C++
public:
ZDO_MGMT_LEAVE_REQ(
unsigned short ,
unsigned __int64 ,
char
) sealed
J#
public ZDO_MGMT_LEAVE_REQ(
ushort ,
ulong ,
byte
)
JScript
public function ZDO_MGMT_LEAVE_REQ(
: UInt16,
: UInt64,
: Byte
)

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_LEAVE_REQ Constructor Overload List


Fields

ZDO_MGMT_LEAVE_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | The 64 bit IEEE Address of the device you want to leave.
Public field | DstAddr | Destination network address.
Public field | RemoveChildren_Rejoin | RemoveChildren: bit 1, Rejoin: bit 0
Top

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace


DeviceAddress Field

ZDO_MGMT_LEAVE_REQ.DeviceAddress Field
[image]

The 64 bit IEEE Address of the device you want to leave.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_LEAVE_REQ.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace


RemoveChildren_Rejoin Field

ZDO_MGMT_LEAVE_REQ.RemoveChildren_Rejoin Field
[image]

RemoveChildren: bit 1, Rejoin: bit 0

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RemoveChildren_Rejoin As Byte
C#
public byte RemoveChildren_Rejoin;
C++
public:
char RemoveChildren_Rejoin sealed ;
J#
public byte RemoveChildren_Rejoin
JScript
public RemoveChildren_Rejoin : Byte;

See Also

ZDO_MGMT_LEAVE_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ_SRSP Class

ZDO_MGMT_LEAVE_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MGMT_LEAVE_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LEAVE_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_LEAVE_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_LEAVE_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MGMT_LEAVE_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_LEAVE_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_LEAVE_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LEAVE_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ_SRSP Members

ZDO_MGMT_LEAVE_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_LEAVE_REQ

The following tables list the members exposed by ZDO_MGMT_LEAVE_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MGMT_LEAVE_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LEAVE_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MGMT_LEAVE_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ_SRSP Constructor

ZDO_MGMT_LEAVE_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LEAVE_REQ_SRSP | Constructor
Public method | ZDO_MGMT_LEAVE_REQ_SRSP (ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_MGMT_LEAVE_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ_SRSP Constructor ()

ZDO_MGMT_LEAVE_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LEAVE_REQ_SRSP()
C++
public:
ZDO_MGMT_LEAVE_REQ_SRSP() sealed
J#
public ZDO_MGMT_LEAVE_REQ_SRSP()
JScript
public function ZDO_MGMT_LEAVE_REQ_SRSP()

See Also

ZDO_MGMT_LEAVE_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LEAVE_REQ_SRSP Constructor Overload List


ZDO_MGMT_LEAVE_REQ_SRSP Constructor (ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS)

ZDO_MGMT_LEAVE_REQ_SRSP Constructor (ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_MGMT_LEAVE_REQ_SRSP(
ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_MGMT_LEAVE_REQ_SRSP(
ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_MGMT_LEAVE_REQ_SRSP(
ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_MGMT_LEAVE_REQ_SRSP(
: ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_MGMT_LEAVE_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LEAVE_REQ_SRSP Constructor Overload List


Fields

ZDO_MGMT_LEAVE_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_LEAVE_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_LEAVE_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS
C#
public ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS;

See Also

ZDO_MGMT_LEAVE_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS Enumeration

ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_RSP Class

ZDO_MGMT_LEAVE_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Leave Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LEAVE_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_LEAVE_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_LEAVE_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_LEAVE_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_LEAVE_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_LEAVE_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LEAVE_RSP Members
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_RSP Members

ZDO_MGMT_LEAVE_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Leave Request.

The following tables list the members exposed by ZDO_MGMT_LEAVE_RSP.

Public Constructors

Name | Description
ZDO_MGMT_LEAVE_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LEAVE_RSP | Overloaded.
Top

See Also

ZDO_MGMT_LEAVE_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_RSP Constructor

ZDO_MGMT_LEAVE_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LEAVE_RSP | Constructor
Public method | ZDO_MGMT_LEAVE_RSP (UInt16, ZDO_MGMT_LEAVE_RSP.ZDO_STATUS) |

See Also

ZDO_MGMT_LEAVE_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_RSP Constructor ()

ZDO_MGMT_LEAVE_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LEAVE_RSP()
C++
public:
ZDO_MGMT_LEAVE_RSP() sealed
J#
public ZDO_MGMT_LEAVE_RSP()
JScript
public function ZDO_MGMT_LEAVE_RSP()

See Also

ZDO_MGMT_LEAVE_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LEAVE_RSP Constructor Overload List


ZDO_MGMT_LEAVE_RSP Constructor (UInt16, ZDO_MGMT_LEAVE_RSP.ZDO_STATUS)

ZDO_MGMT_LEAVE_RSP Constructor (UInt16, ZDO_MGMT_LEAVE_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_LEAVE_RSP.ZDO_STATUS _
)
C#
public ZDO_MGMT_LEAVE_RSP(
ushort ,
ZDO_MGMT_LEAVE_RSP.ZDO_STATUS
)
C++
public:
ZDO_MGMT_LEAVE_RSP(
unsigned short ,
ZDO_MGMT_LEAVE_RSP.ZDO_STATUS
) sealed
J#
public ZDO_MGMT_LEAVE_RSP(
ushort ,
ZDO_MGMT_LEAVE_RSP.ZDO_STATUS
)
JScript
public function ZDO_MGMT_LEAVE_RSP(
: UInt16,
: ZDO_MGMT_LEAVE_RSP.ZDO_STATUS
)

See Also

ZDO_MGMT_LEAVE_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LEAVE_RSP Constructor Overload List


Fields

ZDO_MGMT_LEAVE_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_LEAVE_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MGMT_LEAVE_RSP.SrcAddr Field
[image]

Source address of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_LEAVE_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_LEAVE_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LEAVE_RSP.ZDO_STATUS
C#
public ZDO_MGMT_LEAVE_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MGMT_LEAVE_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MGMT_LEAVE_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MGMT_LEAVE_RSP.ZDO_STATUS;

See Also

ZDO_MGMT_LEAVE_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LEAVE_RSP.ZDO_STATUS Enumeration

ZDO_MGMT_LEAVE_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LEAVE_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MGMT_LEAVE_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MGMT_LEAVE_RSP.ZDO_STATUS : char
J#
public enum ZDO_MGMT_LEAVE_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MGMT_LEAVE_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ Class

ZDO_MGMT_LQI_REQ Class
See Also Example Members
[image]

This command is generated to request a Management LQI Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LQI_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_LQI_REQ : IREQUEST, IZDO
C++
ref class ZDO_MGMT_LQI_REQ : IREQUEST, IZDO
J#
public class ZDO_MGMT_LQI_REQ implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_LQI_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_LQI_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_REQ Members
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ Members

ZDO_MGMT_LQI_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management LQI Request.

The following tables list the members exposed by ZDO_MGMT_LQI_REQ.

Public Constructors

Name | Description
ZDO_MGMT_LQI_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_REQ | Overloaded.
Top

See Also

ZDO_MGMT_LQI_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ Constructor

ZDO_MGMT_LQI_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_REQ | Constructor
Public method | ZDO_MGMT_LQI_REQ (UInt16, Byte) | Constructor

See Also

ZDO_MGMT_LQI_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ Constructor ()

ZDO_MGMT_LQI_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_REQ()
C++
public:
ZDO_MGMT_LQI_REQ() sealed
J#
public ZDO_MGMT_LQI_REQ()
JScript
public function ZDO_MGMT_LQI_REQ()

See Also

ZDO_MGMT_LQI_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_LQI_REQ Constructor Overload List


ZDO_MGMT_LQI_REQ Constructor (UInt16, Byte)

ZDO_MGMT_LQI_REQ Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_MGMT_LQI_REQ(
ushort ,
byte
)
C++
public:
ZDO_MGMT_LQI_REQ(
unsigned short ,
char
) sealed
J#
public ZDO_MGMT_LQI_REQ(
ushort ,
byte
)
JScript
public function ZDO_MGMT_LQI_REQ(
: UInt16,
: Byte
)

See Also

ZDO_MGMT_LQI_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_LQI_REQ Constructor Overload List


Fields

ZDO_MGMT_LQI_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

See Also

ZDO_MGMT_LQI_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_LQI_REQ.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_LQI_REQ Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_LQI_REQ.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_LQI_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ_SRSP Class

ZDO_MGMT_LQI_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MGMT_LQI_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LQI_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_LQI_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_LQI_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MGMT_LQI_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_LQI_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_LQI_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ_SRSP Members

ZDO_MGMT_LQI_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_LQI_REQ

The following tables list the members exposed by ZDO_MGMT_LQI_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MGMT_LQI_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MGMT_LQI_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ_SRSP Constructor

ZDO_MGMT_LQI_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_REQ_SRSP | Constructor
Public method | ZDO_MGMT_LQI_REQ_SRSP (ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS) |

See Also

ZDO_MGMT_LQI_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ_SRSP Constructor ()

ZDO_MGMT_LQI_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_REQ_SRSP()
C++
public:
ZDO_MGMT_LQI_REQ_SRSP() sealed
J#
public ZDO_MGMT_LQI_REQ_SRSP()
JScript
public function ZDO_MGMT_LQI_REQ_SRSP()

See Also

ZDO_MGMT_LQI_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LQI_REQ_SRSP Constructor Overload List


ZDO_MGMT_LQI_REQ_SRSP Constructor (ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS)

ZDO_MGMT_LQI_REQ_SRSP Constructor (ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_MGMT_LQI_REQ_SRSP(
ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_MGMT_LQI_REQ_SRSP(
ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_MGMT_LQI_REQ_SRSP(
ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_MGMT_LQI_REQ_SRSP(
: ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS
)

See Also

ZDO_MGMT_LQI_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LQI_REQ_SRSP Constructor Overload List


Fields

ZDO_MGMT_LQI_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_LQI_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_LQI_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS
C#
public ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS;

See Also

ZDO_MGMT_LQI_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS Enumeration

ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP Class

ZDO_MGMT_LQI_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management LQI Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_LQI_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_LQI_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_LQI_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_LQI_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_LQI_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_LQI_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_RSP Members
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP Members

ZDO_MGMT_LQI_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management LQI Request.

The following tables list the members exposed by ZDO_MGMT_LQI_RSP.

Public Constructors

Name | Description
ZDO_MGMT_LQI_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NeighborLqiList | Dynamic array, an array of NeighborLqiList items.
Public field | NeighborLqiListCount | Number of entries in this response.
Public field | NeighborTableEntries | Total number of entries available in the device.
Public field | SrcAddr | the message's source network address
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_RSP | Overloaded.
Top

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP Constructor

ZDO_MGMT_LQI_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_RSP | Constructor
Public method | ZDO_MGMT_LQI_RSP (UInt16, ZDO_MGMT_LQI_RSP.ZDO_STATUS, Byte, Byte, Byte, Object) |

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP Constructor ()

ZDO_MGMT_LQI_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_RSP()
C++
public:
ZDO_MGMT_LQI_RSP() sealed
J#
public ZDO_MGMT_LQI_RSP()
JScript
public function ZDO_MGMT_LQI_RSP()

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LQI_RSP Constructor Overload List


ZDO_MGMT_LQI_RSP Constructor (UInt16, ZDO_MGMT_LQI_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])

ZDO_MGMT_LQI_RSP Constructor (UInt16, ZDO_MGMT_LQI_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_LQI_RSP.ZDO_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_MGMT_LQI_RSP(
ushort ,
ZDO_MGMT_LQI_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
C++
public:
ZDO_MGMT_LQI_RSP(
unsigned short ,
ZDO_MGMT_LQI_RSP.ZDO_STATUS ,
char ,
char ,
char ,
array<Object>^
) sealed
J#
public ZDO_MGMT_LQI_RSP(
ushort ,
ZDO_MGMT_LQI_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
JScript
public function ZDO_MGMT_LQI_RSP(
: UInt16,
: ZDO_MGMT_LQI_RSP.ZDO_STATUS,
: Byte,
: Byte,
: Byte,
: Object[]
)

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_LQI_RSP Constructor Overload List


Fields

ZDO_MGMT_LQI_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | NeighborLqiList | Dynamic array, an array of NeighborLqiList items.
Public field | NeighborLqiListCount | Number of entries in this response.
Public field | NeighborTableEntries | Total number of entries available in the device.
Public field | SrcAddr | the message's source network address
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


NeighborLqiList Field

ZDO_MGMT_LQI_RSP.NeighborLqiList Field
[image]

Dynamic array, an array of NeighborLqiList items.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NeighborLqiList As Object()
C#
public object[] NeighborLqiList;
C++
public:
array<Object>^ NeighborLqiList sealed ;
J#
public object[] NeighborLqiList
JScript
public NeighborLqiList : Object[];

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


NeighborLqiListCount Field

ZDO_MGMT_LQI_RSP.NeighborLqiListCount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NeighborLqiListCount As Byte
C#
public byte NeighborLqiListCount;
C++
public:
char NeighborLqiListCount sealed ;
J#
public byte NeighborLqiListCount
JScript
public NeighborLqiListCount : Byte;

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


NeighborTableEntries Field

ZDO_MGMT_LQI_RSP.NeighborTableEntries Field
[image]

Total number of entries available in the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NeighborTableEntries As Byte
C#
public byte NeighborTableEntries;
C++
public:
char NeighborTableEntries sealed ;
J#
public byte NeighborTableEntries
JScript
public NeighborTableEntries : Byte;

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MGMT_LQI_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_LQI_RSP.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_LQI_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_LQI_RSP.ZDO_STATUS
C#
public ZDO_MGMT_LQI_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MGMT_LQI_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MGMT_LQI_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MGMT_LQI_RSP.ZDO_STATUS;

See Also

ZDO_MGMT_LQI_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
See Also Example Members
[image]

Contains information in a single item of a network list

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass
C#
public struct ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass
C++
value class ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass
J#
public final class ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Members
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Members

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Contains information in a single item of a network list

The following tables list the members exposed by ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.

Public Constructors

Name | Description
ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Depth |
Public field | ExtendedAddress |
Public field | ExtendedPanID |
Public field | NetworkAddress |
Public field | Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0) |
Public field | Reserved(7-2)PermitJoining(1-0) |
Public field | RxLQI |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass | Overloaded.
Top

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass | Initializes a new instance of the ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass class.
Public method | ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass (UInt64, UInt64, UInt16, Byte, Byte, Byte, Byte) |

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor ()

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass()
C++
public:
ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass() sealed
J#
public ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass()
JScript
public function ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass()

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace
ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor Overload List


ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor (UInt64, UInt64, UInt16, Byte, Byte, Byte, Byte)

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor (UInt64, UInt64, UInt16, Byte, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass(
ulong ,
ulong ,
ushort ,
byte ,
byte ,
byte ,
byte
)
C++
public:
ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass(
unsigned __int64 ,
unsigned __int64 ,
unsigned short ,
char ,
char ,
char ,
char
) sealed
J#
public ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass(
ulong ,
ulong ,
ushort ,
byte ,
byte ,
byte ,
byte
)
JScript
public function ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass(
: UInt64,
: UInt64,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace
ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Constructor Overload List


Fields

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | Depth |
Public field | ExtendedAddress |
Public field | ExtendedPanID |
Public field | NetworkAddress |
Public field | Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0) |
Public field | Reserved(7-2)PermitJoining(1-0) |
Public field | RxLQI |
Top

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


Depth Field

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.Depth Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Depth As Byte
C#
public byte Depth;
C++
public:
char Depth sealed ;
J#
public byte Depth
JScript
public Depth : Byte;

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


ExtendedAddress Field

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.ExtendedAddress Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedAddress As UInt64
C#
public ulong ExtendedAddress;
C++
public:
unsigned __int64 ExtendedAddress sealed ;
J#
public ulong ExtendedAddress
JScript
public ExtendedAddress : UInt64;

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


ExtendedPanID Field

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.ExtendedPanID Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedPanID As UInt64
C#
public ulong ExtendedPanID;
C++
public:
unsigned __int64 ExtendedPanID sealed ;
J#
public ulong ExtendedPanID
JScript
public ExtendedPanID : UInt64;

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


NetworkAddress Field

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.NetworkAddress Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkAddress As UInt16
C#
public ushort NetworkAddress;
C++
public:
unsigned short NetworkAddress sealed ;
J#
public ushort NetworkAddress
JScript
public NetworkAddress : UInt16;

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0) Field

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0) Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0) As Byte
C#
public byte Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0);
C++
public:
char Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0) sealed ;
J#
public byte Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0)
JScript
public Reserved(7)Relationship(6-4)RxOnWhenIdle(3-2)DeviceType(1-0) : Byte;

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


Reserved(7-2)PermitJoining(1-0) Field

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.Reserved(7-2)PermitJoining(1-0) Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reserved(7-2)PermitJoining(1-0) As Byte
C#
public byte Reserved(7-2)PermitJoining(1-0);
C++
public:
char Reserved(7-2)PermitJoining(1-0) sealed ;
J#
public byte Reserved(7-2)PermitJoining(1-0)
JScript
public Reserved(7-2)PermitJoining(1-0) : Byte;

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


RxLQI Field

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass.RxLQI Field
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RxLQI As Byte
C#
public byte RxLQI;
C++
public:
char RxLQI sealed ;
J#
public byte RxLQI
JScript
public RxLQI : Byte;

See Also

ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_LQI_RSP.ZDO_STATUS Enumeration

ZDO_MGMT_LQI_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_LQI_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MGMT_LQI_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MGMT_LQI_RSP.ZDO_STATUS : char
J#
public enum ZDO_MGMT_LQI_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MGMT_LQI_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ Class

ZDO_MGMT_NWK_DISC_REQ Class
See Also Example Members
[image]

This command is generated to request a Management Network Discovery Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_DISC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_NWK_DISC_REQ : IREQUEST, IZDO
C++
ref class ZDO_MGMT_NWK_DISC_REQ : IREQUEST, IZDO
J#
public class ZDO_MGMT_NWK_DISC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_NWK_DISC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_DISC_REQ Members
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ Members

ZDO_MGMT_NWK_DISC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Network Discovery Request

The following tables list the members exposed by ZDO_MGMT_NWK_DISC_REQ.

Public Constructors

Name | Description
ZDO_MGMT_NWK_DISC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address
Public field | ScanChannels | Bit Mask for channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows to ask for more
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_DISC_REQ | Overloaded.
Top

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ Constructor

ZDO_MGMT_NWK_DISC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_DISC_REQ | Constructor
Public method | ZDO_MGMT_NWK_DISC_REQ (UInt16, ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS, Byte, Byte) |

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ Constructor ()

ZDO_MGMT_NWK_DISC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_DISC_REQ()
C++
public:
ZDO_MGMT_NWK_DISC_REQ() sealed
J#
public ZDO_MGMT_NWK_DISC_REQ()
JScript
public function ZDO_MGMT_NWK_DISC_REQ()

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_REQ Constructor Overload List


ZDO_MGMT_NWK_DISC_REQ Constructor (UInt16, ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS, Byte, Byte)

ZDO_MGMT_NWK_DISC_REQ Constructor (UInt16, ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_NWK_DISC_REQ(
ushort ,
ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS ,
byte ,
byte
)
C++
public:
ZDO_MGMT_NWK_DISC_REQ(
unsigned short ,
ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS ,
char ,
char
) sealed
J#
public ZDO_MGMT_NWK_DISC_REQ(
ushort ,
ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS ,
byte ,
byte
)
JScript
public function ZDO_MGMT_NWK_DISC_REQ(
: UInt16,
: ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS,
: Byte,
: Byte
)

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_REQ Constructor Overload List


Fields

ZDO_MGMT_NWK_DISC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address
Public field | ScanChannels | Bit Mask for channels to scan
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows to ask for more
Top

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_NWK_DISC_REQ.DstAddr Field
[image]

Destination network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace


ScanChannels Field

ZDO_MGMT_NWK_DISC_REQ.ScanChannels Field
[image]

Bit Mask for channels to scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS
C#
public ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS ScanChannels;
C++
public:
ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS;

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace


ScanDuration Field

ZDO_MGMT_NWK_DISC_REQ.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_NWK_DISC_REQ.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows to ask for more

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_NWK_DISC_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS Enumeration

ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS uint
JScript
public enum ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ_SRSP Class

ZDO_MGMT_NWK_DISC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MGMT_NWK_DISC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_DISC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_NWK_DISC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_NWK_DISC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MGMT_NWK_DISC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_NWK_DISC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_DISC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ_SRSP Members

ZDO_MGMT_NWK_DISC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_NWK_DISC_REQ

The following tables list the members exposed by ZDO_MGMT_NWK_DISC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MGMT_NWK_DISC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_DISC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MGMT_NWK_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor

ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_DISC_REQ_SRSP | Constructor
Public method | ZDO_MGMT_NWK_DISC_REQ_SRSP (ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS) |

See Also

ZDO_MGMT_NWK_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor ()

ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_DISC_REQ_SRSP()
C++
public:
ZDO_MGMT_NWK_DISC_REQ_SRSP() sealed
J#
public ZDO_MGMT_NWK_DISC_REQ_SRSP()
JScript
public function ZDO_MGMT_NWK_DISC_REQ_SRSP()

See Also

ZDO_MGMT_NWK_DISC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor Overload List


ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor (ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS)

ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor (ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_MGMT_NWK_DISC_REQ_SRSP(
ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_MGMT_NWK_DISC_REQ_SRSP(
ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_MGMT_NWK_DISC_REQ_SRSP(
ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_MGMT_NWK_DISC_REQ_SRSP(
: ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS
)

See Also

ZDO_MGMT_NWK_DISC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_REQ_SRSP Constructor Overload List


Fields

ZDO_MGMT_NWK_DISC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_NWK_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_NWK_DISC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS
C#
public ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS;

See Also

ZDO_MGMT_NWK_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS Enumeration

ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP Class

ZDO_MGMT_NWK_DISC_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Network Discovery Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_DISC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_NWK_DISC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_NWK_DISC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_NWK_DISC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_NWK_DISC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_NWK_DISC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_DISC_RSP Members
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP Members

ZDO_MGMT_NWK_DISC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Network Discovery Request

The following tables list the members exposed by ZDO_MGMT_NWK_DISC_RSP.

Public Constructors

Name | Description
ZDO_MGMT_NWK_DISC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NetworkCount | Total number of entries available in the device
Public field | NetworkList | Dynamic array, an array of NetworkList items. NetworkListCount contains the number of items in this table
Public field | NetworkListCount | Number of entries in this response.
Public field | SrcAddr | the message's source network address
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_DISC_RSP | Overloaded.
Top

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP Constructor

ZDO_MGMT_NWK_DISC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_DISC_RSP | Constructor
Public method | ZDO_MGMT_NWK_DISC_RSP (UInt16, ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS, Byte, Byte, Byte, Object) |

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP Constructor ()

ZDO_MGMT_NWK_DISC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_DISC_RSP()
C++
public:
ZDO_MGMT_NWK_DISC_RSP() sealed
J#
public ZDO_MGMT_NWK_DISC_RSP()
JScript
public function ZDO_MGMT_NWK_DISC_RSP()

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_RSP Constructor Overload List


ZDO_MGMT_NWK_DISC_RSP Constructor (UInt16, ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])

ZDO_MGMT_NWK_DISC_RSP Constructor (UInt16, ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_MGMT_NWK_DISC_RSP(
ushort ,
ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
C++
public:
ZDO_MGMT_NWK_DISC_RSP(
unsigned short ,
ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS ,
char ,
char ,
char ,
array<Object>^
) sealed
J#
public ZDO_MGMT_NWK_DISC_RSP(
ushort ,
ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
JScript
public function ZDO_MGMT_NWK_DISC_RSP(
: UInt16,
: ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS,
: Byte,
: Byte,
: Byte,
: Object[]
)

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_RSP Constructor Overload List


Fields

ZDO_MGMT_NWK_DISC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | NetworkCount | Total number of entries available in the device
Public field | NetworkList | Dynamic array, an array of NetworkList items. NetworkListCount contains the number of items in this table
Public field | NetworkListCount | Number of entries in this response.
Public field | SrcAddr | the message's source network address
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


NetworkCount Field

ZDO_MGMT_NWK_DISC_RSP.NetworkCount Field
[image]

Total number of entries available in the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkCount As Byte
C#
public byte NetworkCount;
C++
public:
char NetworkCount sealed ;
J#
public byte NetworkCount
JScript
public NetworkCount : Byte;

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


NetworkList Field

ZDO_MGMT_NWK_DISC_RSP.NetworkList Field
[image]

Dynamic array, an array of NetworkList items. NetworkListCount contains the number of items in this table

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkList As Object()
C#
public object[] NetworkList;
C++
public:
array<Object>^ NetworkList sealed ;
J#
public object[] NetworkList
JScript
public NetworkList : Object[];

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


NetworkListCount Field

ZDO_MGMT_NWK_DISC_RSP.NetworkListCount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NetworkListCount As Byte
C#
public byte NetworkListCount;
C++
public:
char NetworkListCount sealed ;
J#
public byte NetworkListCount
JScript
public NetworkListCount : Byte;

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MGMT_NWK_DISC_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_NWK_DISC_RSP.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_NWK_DISC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS
C#
public ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS;

See Also

ZDO_MGMT_NWK_DISC_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
See Also Example Members
[image]

Contains information in a single item of a network list

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass
C#
public struct ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass
C++
value class ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass
J#
public final class ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Members
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Members

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Contains information in a single item of a network list

The following tables list the members exposed by ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass.

Public Constructors

Name | Description
ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BeaconOrder(7-4)SuperFrameOrder(3-0) |
Public field | ExtendedPanID |
Public field | LogicalChannel |
Public field | PermitJoining |
Public field | StackProfile(7-4)ZigbeeVersion(3-0) |
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass | Overloaded.
Top

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass | Initializes a new instance of the ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass class.
Public method | ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass (UInt64, Byte, Byte, Byte, Byte) |

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor ()

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor ()
See Also Example
[image]

Initializes a new instance of the ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass()
C++
public:
ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass() sealed
J#
public ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass()
JScript
public function ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass()

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor Overload List


ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor (UInt64, Byte, Byte, Byte, Byte)

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor (UInt64, Byte, Byte, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass(
ulong ,
byte ,
byte ,
byte ,
byte
)
C++
public:
ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass(
unsigned __int64 ,
char ,
char ,
char ,
char
) sealed
J#
public ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass(
ulong ,
byte ,
byte ,
byte ,
byte
)
JScript
public function ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass(
: UInt64,
: Byte,
: Byte,
: Byte,
: Byte
)

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace
ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Constructor Overload List


Fields

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Fields
[image]

Public Fields

 | Name | Description
Public field | BeaconOrder(7-4)SuperFrameOrder(3-0) |
Public field | ExtendedPanID |
Public field | LogicalChannel |
Public field | PermitJoining |
Public field | StackProfile(7-4)ZigbeeVersion(3-0) |
Top

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


BeaconOrder(7-4)SuperFrameOrder(3-0) Field

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass.BeaconOrder(7-4)SuperFrameOrder(3-0) Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder(7-4)SuperFrameOrder(3-0) As Byte
C#
public byte BeaconOrder(7-4)SuperFrameOrder(3-0);
C++
public:
char BeaconOrder(7-4)SuperFrameOrder(3-0) sealed ;
J#
public byte BeaconOrder(7-4)SuperFrameOrder(3-0)
JScript
public BeaconOrder(7-4)SuperFrameOrder(3-0) : Byte;

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


ExtendedPanID Field

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass.ExtendedPanID Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedPanID As UInt64
C#
public ulong ExtendedPanID;
C++
public:
unsigned __int64 ExtendedPanID sealed ;
J#
public ulong ExtendedPanID
JScript
public ExtendedPanID : UInt64;

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


LogicalChannel Field

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass.LogicalChannel Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


PermitJoining Field

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass.PermitJoining Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PermitJoining As Byte
C#
public byte PermitJoining;
C++
public:
char PermitJoining sealed ;
J#
public byte PermitJoining
JScript
public PermitJoining : Byte;

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


StackProfile(7-4)ZigbeeVersion(3-0) Field

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass.StackProfile(7-4)ZigbeeVersion(3-0) Field
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StackProfile(7-4)ZigbeeVersion(3-0) As Byte
C#
public byte StackProfile(7-4)ZigbeeVersion(3-0);
C++
public:
char StackProfile(7-4)ZigbeeVersion(3-0) sealed ;
J#
public byte StackProfile(7-4)ZigbeeVersion(3-0)
JScript
public StackProfile(7-4)ZigbeeVersion(3-0) : Byte;

See Also

ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS Enumeration

ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS : char
J#
public enum ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Class

ZDO_MGMT_NWK_UPDATE_REQUEST Class
See Also Example Members
[image]

This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_UPDATE_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_NWK_UPDATE_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_NWK_UPDATE_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_NWK_UPDATE_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_NWK_UPDATE_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Members
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Members

ZDO_MGMT_NWK_UPDATE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is provided to allow updating of network configuration parameters or to request information from devices on network conditions in the local operating environment.

The following tables list the members exposed by ZDO_MGMT_NWK_UPDATE_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_NWK_UPDATE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelMask | a bitmap indicating which channels are to be scanned.
Public field | DstAddr | short address of the destination device(s). The destination addressing on this primitive can be unicast or broadcast to all devices for which macRxOnWhenIdle=TRUE (i.e., 0xFFFD).
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | NwkManagerAddr | indicates the NWK address for the device with the Network Manager bit set in its Node Descriptor
Public field | ScanCount | This field represents the number of energy scans to be conducted and reported
Public field | ScanDuration | a value used to calculate the length of time to spend scanning each channel.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_UPDATE_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Constructor

ZDO_MGMT_NWK_UPDATE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_UPDATE_REQUEST | Constructor
Public method | ZDO_MGMT_NWK_UPDATE_REQUEST (UInt16, ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, UInt16) |

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST Constructor ()

ZDO_MGMT_NWK_UPDATE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST()
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST() sealed
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST()
JScript
public function ZDO_MGMT_NWK_UPDATE_REQUEST()

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_UPDATE_REQUEST Constructor Overload List


ZDO_MGMT_NWK_UPDATE_REQUEST Constructor (UInt16, ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, UInt16)

ZDO_MGMT_NWK_UPDATE_REQUEST Constructor (UInt16, ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, Byte, Byte, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE, _
ByVal As ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16 _
)
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST(
ushort ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
ushort
)
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST(
unsigned short ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ,
char ,
char ,
unsigned short
) sealed
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST(
ushort ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE ,
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ,
byte ,
byte ,
ushort
)
JScript
public function ZDO_MGMT_NWK_UPDATE_REQUEST(
: UInt16,
: ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE,
: ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS,
: Byte,
: Byte,
: UInt16
)

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_UPDATE_REQUEST Constructor Overload List


Fields

ZDO_MGMT_NWK_UPDATE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelMask | a bitmap indicating which channels are to be scanned.
Public field | DstAddr | short address of the destination device(s). The destination addressing on this primitive can be unicast or broadcast to all devices for which macRxOnWhenIdle=TRUE (i.e., 0xFFFD).
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | NwkManagerAddr | indicates the NWK address for the device with the Network Manager bit set in its Node Descriptor
Public field | ScanCount | This field represents the number of energy scans to be conducted and reported
Public field | ScanDuration | a value used to calculate the length of time to spend scanning each channel.
Top

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


ChannelMask Field

ZDO_MGMT_NWK_UPDATE_REQUEST.ChannelMask Field
[image]

a bitmap indicating which channels are to be scanned.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelMask As ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ChannelMask;
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ChannelMask sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS ChannelMask
JScript
public ChannelMask : ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_NWK_UPDATE_REQUEST.DstAddr Field
[image]

short address of the destination device(s). The destination addressing on this primitive can be unicast or broadcast to all devices for which macRxOnWhenIdle=TRUE (i.e., 0xFFFD).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


DstAddrMode Field

ZDO_MGMT_NWK_UPDATE_REQUEST.DstAddrMode Field
[image]

The destination address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE
C#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE DstAddrMode;
C++
public:
ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE DstAddrMode sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


NwkManagerAddr Field

ZDO_MGMT_NWK_UPDATE_REQUEST.NwkManagerAddr Field
[image]

indicates the NWK address for the device with the Network Manager bit set in its Node Descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkManagerAddr As UInt16
C#
public ushort NwkManagerAddr;
C++
public:
unsigned short NwkManagerAddr sealed ;
J#
public ushort NwkManagerAddr
JScript
public NwkManagerAddr : UInt16;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


ScanCount Field

ZDO_MGMT_NWK_UPDATE_REQUEST.ScanCount Field
[image]

This field represents the number of energy scans to be conducted and reported

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanCount As Byte
C#
public byte ScanCount;
C++
public:
char ScanCount sealed ;
J#
public byte ScanCount
JScript
public ScanCount : Byte;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


ScanDuration Field

ZDO_MGMT_NWK_UPDATE_REQUEST.ScanDuration Field
[image]

a value used to calculate the length of time to spend scanning each channel.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE Enumeration

ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE : char
J#
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE byte
JScript
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS Enumeration

ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Class

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MGMT_NWK_UPDATE_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_NWK_UPDATE_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_NWK_UPDATE_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_NWK_UPDATE_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MGMT_NWK_UPDATE_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_NWK_UPDATE_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Members
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Members

ZDO_MGMT_NWK_UPDATE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_NWK_UPDATE_REQUEST

The following tables list the members exposed by ZDO_MGMT_NWK_UPDATE_RESPONSE.

Public Constructors

Name | Description
ZDO_MGMT_NWK_UPDATE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_NWK_UPDATE_RESPONSE | Overloaded.
Top

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor

ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_NWK_UPDATE_RESPONSE | Constructor
Public method | ZDO_MGMT_NWK_UPDATE_RESPONSE (ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS) |

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor ()

ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_NWK_UPDATE_RESPONSE()
C++
public:
ZDO_MGMT_NWK_UPDATE_RESPONSE() sealed
J#
public ZDO_MGMT_NWK_UPDATE_RESPONSE()
JScript
public function ZDO_MGMT_NWK_UPDATE_RESPONSE()

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor Overload List


ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor (ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS)

ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor (ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MGMT_NWK_UPDATE_RESPONSE(
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MGMT_NWK_UPDATE_RESPONSE(
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MGMT_NWK_UPDATE_RESPONSE(
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MGMT_NWK_UPDATE_RESPONSE(
: ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
)

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI2 Namespace
ZDO_MGMT_NWK_UPDATE_RESPONSE Constructor Overload List


Fields

ZDO_MGMT_NWK_UPDATE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_NWK_UPDATE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
C#
public ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS;

See Also

ZDO_MGMT_NWK_UPDATE_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Enumeration

ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MGMT_PERMIT_JOIN_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_PERMIT_JOIN_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_PERMIT_JOIN_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_PERMIT_JOIN_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MGMT_PERMIT_JOIN_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_PERMIT_JOIN_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Members

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_PERMIT_JOIN_REQ

The following tables list the members exposed by ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_PERMIT_JOIN_REQ_SRSP | Constructor
Public method | ZDO_MGMT_PERMIT_JOIN_REQ_SRSP (ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor ()

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_PERMIT_JOIN_REQ_SRSP()
C++
public:
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP() sealed
J#
public ZDO_MGMT_PERMIT_JOIN_REQ_SRSP()
JScript
public function ZDO_MGMT_PERMIT_JOIN_REQ_SRSP()

See Also

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor Overload List


ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor (ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS)

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor (ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_MGMT_PERMIT_JOIN_REQ_SRSP(
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP(
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_MGMT_PERMIT_JOIN_REQ_SRSP(
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_MGMT_PERMIT_JOIN_REQ_SRSP(
: ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Constructor Overload List


Fields

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS
C#
public ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS;

See Also

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS Enumeration

ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Class

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
See Also Example Members
[image]

This command is generated to request a Management Join Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_PERMIT_JOIN_REQUEST
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_PERMIT_JOIN_REQUEST : IREQUEST, IZDO
C++
ref class ZDO_MGMT_PERMIT_JOIN_REQUEST : IREQUEST, IZDO
J#
public class ZDO_MGMT_PERMIT_JOIN_REQUEST implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_PERMIT_JOIN_REQUEST extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Members
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Members

ZDO_MGMT_PERMIT_JOIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Join Request

The following tables list the members exposed by ZDO_MGMT_PERMIT_JOIN_REQUEST.

Public Constructors

Name | Description
ZDO_MGMT_PERMIT_JOIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | Duration | The duration to permit joining. 0 = join disabled. 0xff = join enabled. 0x01-0xfe = number of seconds to permit joining
Public field | TCSignificance | Trust Center Significance
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_PERMIT_JOIN_REQUEST | Overloaded.
Top

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor

ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_PERMIT_JOIN_REQUEST | Constructor
Public method | ZDO_MGMT_PERMIT_JOIN_REQUEST (UInt16, Byte, Byte) | Constructor

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor ()

ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_PERMIT_JOIN_REQUEST()
C++
public:
ZDO_MGMT_PERMIT_JOIN_REQUEST() sealed
J#
public ZDO_MGMT_PERMIT_JOIN_REQUEST()
JScript
public function ZDO_MGMT_PERMIT_JOIN_REQUEST()

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace
ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor Overload List


ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor (UInt16, Byte, Byte)

ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor (UInt16, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_MGMT_PERMIT_JOIN_REQUEST(
ushort ,
byte ,
byte
)
C++
public:
ZDO_MGMT_PERMIT_JOIN_REQUEST(
unsigned short ,
char ,
char
) sealed
J#
public ZDO_MGMT_PERMIT_JOIN_REQUEST(
ushort ,
byte ,
byte
)
JScript
public function ZDO_MGMT_PERMIT_JOIN_REQUEST(
: UInt16,
: Byte,
: Byte
)

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace
ZDO_MGMT_PERMIT_JOIN_REQUEST Constructor Overload List


Fields

ZDO_MGMT_PERMIT_JOIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | Duration | The duration to permit joining. 0 = join disabled. 0xff = join enabled. 0x01-0xfe = number of seconds to permit joining
Public field | TCSignificance | Trust Center Significance
Top

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_PERMIT_JOIN_REQUEST.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace


Duration Field

ZDO_MGMT_PERMIT_JOIN_REQUEST.Duration Field
[image]

The duration to permit joining. 0 = join disabled. 0xff = join enabled. 0x01-0xfe = number of seconds to permit joining

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Duration As Byte
C#
public byte Duration;
C++
public:
char Duration sealed ;
J#
public byte Duration
JScript
public Duration : Byte;

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace


TCSignificance Field

ZDO_MGMT_PERMIT_JOIN_REQUEST.TCSignificance Field
[image]

Trust Center Significance

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TCSignificance As Byte
C#
public byte TCSignificance;
C++
public:
char TCSignificance sealed ;
J#
public byte TCSignificance
JScript
public TCSignificance : Byte;

See Also

ZDO_MGMT_PERMIT_JOIN_REQUEST Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_RSP Class

ZDO_MGMT_PERMIT_JOIN_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Permit Join Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_PERMIT_JOIN_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_PERMIT_JOIN_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_PERMIT_JOIN_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_PERMIT_JOIN_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_PERMIT_JOIN_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Members
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_RSP Members

ZDO_MGMT_PERMIT_JOIN_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Permit Join Request

The following tables list the members exposed by ZDO_MGMT_PERMIT_JOIN_RSP.

Public Constructors

Name | Description
ZDO_MGMT_PERMIT_JOIN_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_PERMIT_JOIN_RSP | Overloaded.
Top

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_RSP Constructor

ZDO_MGMT_PERMIT_JOIN_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_PERMIT_JOIN_RSP | Constructor
Public method | ZDO_MGMT_PERMIT_JOIN_RSP (UInt16, ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS) |

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_RSP Constructor ()

ZDO_MGMT_PERMIT_JOIN_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_PERMIT_JOIN_RSP()
C++
public:
ZDO_MGMT_PERMIT_JOIN_RSP() sealed
J#
public ZDO_MGMT_PERMIT_JOIN_RSP()
JScript
public function ZDO_MGMT_PERMIT_JOIN_RSP()

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_PERMIT_JOIN_RSP Constructor Overload List


ZDO_MGMT_PERMIT_JOIN_RSP Constructor (UInt16, ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS)

ZDO_MGMT_PERMIT_JOIN_RSP Constructor (UInt16, ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS _
)
C#
public ZDO_MGMT_PERMIT_JOIN_RSP(
ushort ,
ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS
)
C++
public:
ZDO_MGMT_PERMIT_JOIN_RSP(
unsigned short ,
ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS
) sealed
J#
public ZDO_MGMT_PERMIT_JOIN_RSP(
ushort ,
ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS
)
JScript
public function ZDO_MGMT_PERMIT_JOIN_RSP(
: UInt16,
: ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS
)

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_PERMIT_JOIN_RSP Constructor Overload List


Fields

ZDO_MGMT_PERMIT_JOIN_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MGMT_PERMIT_JOIN_RSP.SrcAddr Field
[image]

Source address of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_PERMIT_JOIN_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS
C#
public ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS;

See Also

ZDO_MGMT_PERMIT_JOIN_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS Enumeration

ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS : char
J#
public enum ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ Class

ZDO_MGMT_RTG_REQ Class
See Also Example Members
[image]

This command is generated to request a Management Routing Table Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_RTG_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_MGMT_RTG_REQ : IREQUEST, IZDO
C++
ref class ZDO_MGMT_RTG_REQ : IREQUEST, IZDO
J#
public class ZDO_MGMT_RTG_REQ implements IREQUEST, IZDO
JScript
public class ZDO_MGMT_RTG_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_RTG_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_RTG_REQ Members
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ Members

ZDO_MGMT_RTG_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a Management Routing Table Request.

The following tables list the members exposed by ZDO_MGMT_RTG_REQ.

Public Constructors

Name | Description
ZDO_MGMT_RTG_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_RTG_REQ | Overloaded.
Top

See Also

ZDO_MGMT_RTG_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ Constructor

ZDO_MGMT_RTG_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_RTG_REQ | Constructor
Public method | ZDO_MGMT_RTG_REQ (UInt16, Byte) | Constructor

See Also

ZDO_MGMT_RTG_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ Constructor ()

ZDO_MGMT_RTG_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_RTG_REQ()
C++
public:
ZDO_MGMT_RTG_REQ() sealed
J#
public ZDO_MGMT_RTG_REQ()
JScript
public function ZDO_MGMT_RTG_REQ()

See Also

ZDO_MGMT_RTG_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_RTG_REQ Constructor Overload List


ZDO_MGMT_RTG_REQ Constructor (UInt16, Byte)

ZDO_MGMT_RTG_REQ Constructor (UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_MGMT_RTG_REQ(
ushort ,
byte
)
C++
public:
ZDO_MGMT_RTG_REQ(
unsigned short ,
char
) sealed
J#
public ZDO_MGMT_RTG_REQ(
ushort ,
byte
)
JScript
public function ZDO_MGMT_RTG_REQ(
: UInt16,
: Byte
)

See Also

ZDO_MGMT_RTG_REQ Class
TI.ZPI2 Namespace
ZDO_MGMT_RTG_REQ Constructor Overload List


Fields

ZDO_MGMT_RTG_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | StartIndex | Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.
Top

See Also

ZDO_MGMT_RTG_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_MGMT_RTG_REQ.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_MGMT_RTG_REQ Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_RTG_REQ.StartIndex Field
[image]

Where to start. The result can be more networks than can be reported, so this field allows a user to ask for more.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_RTG_REQ Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ_SRSP Class

ZDO_MGMT_RTG_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_MGMT_RTG_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_RTG_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_MGMT_RTG_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_MGMT_RTG_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_MGMT_RTG_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_MGMT_RTG_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_RTG_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_RTG_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ_SRSP Members

ZDO_MGMT_RTG_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MGMT_RTG_REQ

The following tables list the members exposed by ZDO_MGMT_RTG_REQ_SRSP.

Public Constructors

Name | Description
ZDO_MGMT_RTG_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_RTG_REQ_SRSP | Overloaded.
Top

See Also

ZDO_MGMT_RTG_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ_SRSP Constructor

ZDO_MGMT_RTG_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_RTG_REQ_SRSP | Constructor
Public method | ZDO_MGMT_RTG_REQ_SRSP (ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_MGMT_RTG_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ_SRSP Constructor ()

ZDO_MGMT_RTG_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_RTG_REQ_SRSP()
C++
public:
ZDO_MGMT_RTG_REQ_SRSP() sealed
J#
public ZDO_MGMT_RTG_REQ_SRSP()
JScript
public function ZDO_MGMT_RTG_REQ_SRSP()

See Also

ZDO_MGMT_RTG_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_RTG_REQ_SRSP Constructor Overload List


ZDO_MGMT_RTG_REQ_SRSP Constructor (ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS)

ZDO_MGMT_RTG_REQ_SRSP Constructor (ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_MGMT_RTG_REQ_SRSP(
ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_MGMT_RTG_REQ_SRSP(
ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_MGMT_RTG_REQ_SRSP(
ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_MGMT_RTG_REQ_SRSP(
: ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_MGMT_RTG_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_MGMT_RTG_REQ_SRSP Constructor Overload List


Fields

ZDO_MGMT_RTG_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MGMT_RTG_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_RTG_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS
C#
public ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS;

See Also

ZDO_MGMT_RTG_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS Enumeration

ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP Class

ZDO_MGMT_RTG_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Management Routing Table Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MGMT_RTG_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_MGMT_RTG_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_MGMT_RTG_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_MGMT_RTG_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_MGMT_RTG_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_RTG_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_RTG_RSP Members
TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP Members

ZDO_MGMT_RTG_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Management Routing Table Request.

The following tables list the members exposed by ZDO_MGMT_RTG_RSP.

Public Constructors

Name | Description
ZDO_MGMT_RTG_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | RoutingTableEntries | Total number of entries available in the device.
Public field | RoutingTableList | Dynamic array, an array of RtgList items.
Public field | RoutingTableListCount | Number of entries in this response.
Public field | SrcAddr | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MGMT_RTG_RSP | Overloaded.
Top

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP Constructor

ZDO_MGMT_RTG_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_MGMT_RTG_RSP | Constructor
Public method | ZDO_MGMT_RTG_RSP (UInt16, ZDO_MGMT_RTG_RSP.ZDO_STATUS, Byte, Byte, Byte, Object) |

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP Constructor ()

ZDO_MGMT_RTG_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_RTG_RSP()
C++
public:
ZDO_MGMT_RTG_RSP() sealed
J#
public ZDO_MGMT_RTG_RSP()
JScript
public function ZDO_MGMT_RTG_RSP()

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_RTG_RSP Constructor Overload List


ZDO_MGMT_RTG_RSP Constructor (UInt16, ZDO_MGMT_RTG_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])

ZDO_MGMT_RTG_RSP Constructor (UInt16, ZDO_MGMT_RTG_RSP.ZDO_STATUS, Byte, Byte, Byte, Object[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_MGMT_RTG_RSP.ZDO_STATUS, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Object() _
)
C#
public ZDO_MGMT_RTG_RSP(
ushort ,
ZDO_MGMT_RTG_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
C++
public:
ZDO_MGMT_RTG_RSP(
unsigned short ,
ZDO_MGMT_RTG_RSP.ZDO_STATUS ,
char ,
char ,
char ,
array<Object>^
) sealed
J#
public ZDO_MGMT_RTG_RSP(
ushort ,
ZDO_MGMT_RTG_RSP.ZDO_STATUS ,
byte ,
byte ,
byte ,
object[]
)
JScript
public function ZDO_MGMT_RTG_RSP(
: UInt16,
: ZDO_MGMT_RTG_RSP.ZDO_STATUS,
: Byte,
: Byte,
: Byte,
: Object[]
)

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace
ZDO_MGMT_RTG_RSP Constructor Overload List


Fields

ZDO_MGMT_RTG_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | RoutingTableEntries | Total number of entries available in the device.
Public field | RoutingTableList | Dynamic array, an array of RtgList items.
Public field | RoutingTableListCount | Number of entries in this response.
Public field | SrcAddr | Source address of the message
Public field | StartIndex | Where in the total number of entries this response starts.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


RoutingTableEntries Field

ZDO_MGMT_RTG_RSP.RoutingTableEntries Field
[image]

Total number of entries available in the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RoutingTableEntries As Byte
C#
public byte RoutingTableEntries;
C++
public:
char RoutingTableEntries sealed ;
J#
public byte RoutingTableEntries
JScript
public RoutingTableEntries : Byte;

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


RoutingTableList Field

ZDO_MGMT_RTG_RSP.RoutingTableList Field
[image]

Dynamic array, an array of RtgList items.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RoutingTableList As Object()
C#
public object[] RoutingTableList;
C++
public:
array<Object>^ RoutingTableList sealed ;
J#
public object[] RoutingTableList
JScript
public RoutingTableList : Object[];

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


RoutingTableListCount Field

ZDO_MGMT_RTG_RSP.RoutingTableListCount Field
[image]

Number of entries in this response.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RoutingTableListCount As Byte
C#
public byte RoutingTableListCount;
C++
public:
char RoutingTableListCount sealed ;
J#
public byte RoutingTableListCount
JScript
public RoutingTableListCount : Byte;

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_MGMT_RTG_RSP.SrcAddr Field
[image]

Source address of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_MGMT_RTG_RSP.StartIndex Field
[image]

Where in the total number of entries this response starts.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_MGMT_RTG_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MGMT_RTG_RSP.ZDO_STATUS
C#
public ZDO_MGMT_RTG_RSP.ZDO_STATUS Status;
C++
public:
ZDO_MGMT_RTG_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_MGMT_RTG_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_MGMT_RTG_RSP.ZDO_STATUS;

See Also

ZDO_MGMT_RTG_RSP Class
TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP.RoutingTableListClass Structure

ZDO_MGMT_RTG_RSP.RoutingTableListClass Structure
See Also Example Members
[image]

Contains information in a single item of a Routing Table List

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Structure ZDO_MGMT_RTG_RSP.RoutingTableListClass
C#
public struct ZDO_MGMT_RTG_RSP.RoutingTableListClass
C++
value class ZDO_MGMT_RTG_RSP.RoutingTableListClass
J#
public final class ZDO_MGMT_RTG_RSP.RoutingTableListClass extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MGMT_RTG_RSP.RoutingTableListClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MGMT_RTG_RSP.RoutingTableListClass Members
TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP.RoutingTableListClass Members

ZDO_MGMT_RTG_RSP.RoutingTableListClass Members
See Also Example Constructors Methods
[image]

Contains information in a single item of a Routing Table List

The following tables list the members exposed by ZDO_MGMT_RTG_RSP.RoutingTableListClass.

Public Constructors

 | Name | Description
Public method | ZDO_MGMT_RTG_RSP.RoutingTableListClass | Initializes a new instance of the ZDO_MGMT_RTG_RSP.RoutingTableListClass class.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

ZDO_MGMT_RTG_RSP.RoutingTableListClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP.RoutingTableListClass Constructor

ZDO_MGMT_RTG_RSP.RoutingTableListClass Constructor
[image]

Initializes a new instance of the ZDO_MGMT_RTG_RSP.RoutingTableListClass class.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MGMT_RTG_RSP.RoutingTableListClass()
C++
public:
ZDO_MGMT_RTG_RSP.RoutingTableListClass() sealed
J#
public ZDO_MGMT_RTG_RSP.RoutingTableListClass()
JScript
public function ZDO_MGMT_RTG_RSP.RoutingTableListClass()

See Also

ZDO_MGMT_RTG_RSP.RoutingTableListClass Structure
TI.ZPI2 Namespace


ZDO_MGMT_RTG_RSP.ZDO_STATUS Enumeration

ZDO_MGMT_RTG_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MGMT_RTG_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_MGMT_RTG_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_MGMT_RTG_RSP.ZDO_STATUS : char
J#
public enum ZDO_MGMT_RTG_RSP.ZDO_STATUS byte
JScript
public enum ZDO_MGMT_RTG_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER Class

ZDO_MSG_CB_REGISTER Class
See Also Example Members
[image]

This command is the RPC proxy to ZDO_RegisterForZDOMsg() and registers for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MSG_CB_REGISTER
Implements IREQUEST, IZDO
C#
public class ZDO_MSG_CB_REGISTER : IREQUEST, IZDO
C++
ref class ZDO_MSG_CB_REGISTER : IREQUEST, IZDO
J#
public class ZDO_MSG_CB_REGISTER implements IREQUEST, IZDO
JScript
public class ZDO_MSG_CB_REGISTER extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MSG_CB_REGISTER

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MSG_CB_REGISTER Members
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER Members

ZDO_MSG_CB_REGISTER Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is the RPC proxy to ZDO_RegisterForZDOMsg() and registers for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.

The following tables list the members exposed by ZDO_MSG_CB_REGISTER.

Public Constructors

Name | Description
ZDO_MSG_CB_REGISTER | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | Cluster Id of the callback desired.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MSG_CB_REGISTER | Overloaded.
Top

See Also

ZDO_MSG_CB_REGISTER Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER Constructor

ZDO_MSG_CB_REGISTER Constructor

Overload List

 | Name | Description
Public method | ZDO_MSG_CB_REGISTER | Constructor
Public method | ZDO_MSG_CB_REGISTER (UInt16) | Constructor

See Also

ZDO_MSG_CB_REGISTER Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER Constructor ()

ZDO_MSG_CB_REGISTER Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MSG_CB_REGISTER()
C++
public:
ZDO_MSG_CB_REGISTER() sealed
J#
public ZDO_MSG_CB_REGISTER()
JScript
public function ZDO_MSG_CB_REGISTER()

See Also

ZDO_MSG_CB_REGISTER Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REGISTER Constructor Overload List


ZDO_MSG_CB_REGISTER Constructor (UInt16)

ZDO_MSG_CB_REGISTER Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public ZDO_MSG_CB_REGISTER(
ushort
)
C++
public:
ZDO_MSG_CB_REGISTER(
unsigned short
) sealed
J#
public ZDO_MSG_CB_REGISTER(
ushort
)
JScript
public function ZDO_MSG_CB_REGISTER(
: UInt16
)

See Also

ZDO_MSG_CB_REGISTER Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REGISTER Constructor Overload List


Fields

ZDO_MSG_CB_REGISTER Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | Cluster Id of the callback desired.
Top

See Also

ZDO_MSG_CB_REGISTER Class
TI.ZPI2 Namespace


ClusterID Field

ZDO_MSG_CB_REGISTER.ClusterID Field
[image]

Cluster Id of the callback desired.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_MSG_CB_REGISTER Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER_RESPONSE Class

ZDO_MSG_CB_REGISTER_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MSG_CB_REGISTER

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MSG_CB_REGISTER_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MSG_CB_REGISTER_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MSG_CB_REGISTER_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MSG_CB_REGISTER_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MSG_CB_REGISTER_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MSG_CB_REGISTER_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MSG_CB_REGISTER_RESPONSE Members
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER_RESPONSE Members

ZDO_MSG_CB_REGISTER_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MSG_CB_REGISTER

The following tables list the members exposed by ZDO_MSG_CB_REGISTER_RESPONSE.

Public Constructors

Name | Description
ZDO_MSG_CB_REGISTER_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MSG_CB_REGISTER_RESPONSE | Overloaded.
Top

See Also

ZDO_MSG_CB_REGISTER_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER_RESPONSE Constructor

ZDO_MSG_CB_REGISTER_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MSG_CB_REGISTER_RESPONSE | Constructor
Public method | ZDO_MSG_CB_REGISTER_RESPONSE (ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS) |

See Also

ZDO_MSG_CB_REGISTER_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER_RESPONSE Constructor ()

ZDO_MSG_CB_REGISTER_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MSG_CB_REGISTER_RESPONSE()
C++
public:
ZDO_MSG_CB_REGISTER_RESPONSE() sealed
J#
public ZDO_MSG_CB_REGISTER_RESPONSE()
JScript
public function ZDO_MSG_CB_REGISTER_RESPONSE()

See Also

ZDO_MSG_CB_REGISTER_RESPONSE Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REGISTER_RESPONSE Constructor Overload List


ZDO_MSG_CB_REGISTER_RESPONSE Constructor (ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS)

ZDO_MSG_CB_REGISTER_RESPONSE Constructor (ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MSG_CB_REGISTER_RESPONSE(
ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MSG_CB_REGISTER_RESPONSE(
ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MSG_CB_REGISTER_RESPONSE(
ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MSG_CB_REGISTER_RESPONSE(
: ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS
)

See Also

ZDO_MSG_CB_REGISTER_RESPONSE Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REGISTER_RESPONSE Constructor Overload List


Fields

ZDO_MSG_CB_REGISTER_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MSG_CB_REGISTER_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZDO_MSG_CB_REGISTER_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS
C#
public ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS;

See Also

ZDO_MSG_CB_REGISTER_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS Enumeration

ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE Class

ZDO_MSG_CB_REMOVE Class
See Also Example Members
[image]

This command is the RPC proxy to ZDO_RemoveRegisteredCB() and removes registration for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MSG_CB_REMOVE
Implements IREQUEST, IZDO
C#
public class ZDO_MSG_CB_REMOVE : IREQUEST, IZDO
C++
ref class ZDO_MSG_CB_REMOVE : IREQUEST, IZDO
J#
public class ZDO_MSG_CB_REMOVE implements IREQUEST, IZDO
JScript
public class ZDO_MSG_CB_REMOVE extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MSG_CB_REMOVE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MSG_CB_REMOVE Members
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE Members

ZDO_MSG_CB_REMOVE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is the RPC proxy to ZDO_RemoveRegisteredCB() and removes registration for the ZDO callback on the specified Cluster Id which is the ZDO_MSG_CB_INCOMING.

The following tables list the members exposed by ZDO_MSG_CB_REMOVE.

Public Constructors

Name | Description
ZDO_MSG_CB_REMOVE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | Cluster Id of the callback desired.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MSG_CB_REMOVE | Overloaded.
Top

See Also

ZDO_MSG_CB_REMOVE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE Constructor

ZDO_MSG_CB_REMOVE Constructor

Overload List

 | Name | Description
Public method | ZDO_MSG_CB_REMOVE | Constructor
Public method | ZDO_MSG_CB_REMOVE (UInt16) | Constructor

See Also

ZDO_MSG_CB_REMOVE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE Constructor ()

ZDO_MSG_CB_REMOVE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MSG_CB_REMOVE()
C++
public:
ZDO_MSG_CB_REMOVE() sealed
J#
public ZDO_MSG_CB_REMOVE()
JScript
public function ZDO_MSG_CB_REMOVE()

See Also

ZDO_MSG_CB_REMOVE Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REMOVE Constructor Overload List


ZDO_MSG_CB_REMOVE Constructor (UInt16)

ZDO_MSG_CB_REMOVE Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public ZDO_MSG_CB_REMOVE(
ushort
)
C++
public:
ZDO_MSG_CB_REMOVE(
unsigned short
) sealed
J#
public ZDO_MSG_CB_REMOVE(
ushort
)
JScript
public function ZDO_MSG_CB_REMOVE(
: UInt16
)

See Also

ZDO_MSG_CB_REMOVE Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REMOVE Constructor Overload List


Fields

ZDO_MSG_CB_REMOVE Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | Cluster Id of the callback desired.
Top

See Also

ZDO_MSG_CB_REMOVE Class
TI.ZPI2 Namespace


ClusterID Field

ZDO_MSG_CB_REMOVE.ClusterID Field
[image]

Cluster Id of the callback desired.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_MSG_CB_REMOVE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE_RESPONSE Class

ZDO_MSG_CB_REMOVE_RESPONSE Class
See Also Example Members
[image]

Response for ZDO_MSG_CB_REMOVE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_MSG_CB_REMOVE_RESPONSE
Implements IRESPONSE, IZDO
C#
public class ZDO_MSG_CB_REMOVE_RESPONSE : IRESPONSE, IZDO
C++
ref class ZDO_MSG_CB_REMOVE_RESPONSE : IRESPONSE, IZDO
J#
public class ZDO_MSG_CB_REMOVE_RESPONSE implements IRESPONSE, IZDO
JScript
public class ZDO_MSG_CB_REMOVE_RESPONSE extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_MSG_CB_REMOVE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_MSG_CB_REMOVE_RESPONSE Members
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE_RESPONSE Members

ZDO_MSG_CB_REMOVE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_MSG_CB_REMOVE

The following tables list the members exposed by ZDO_MSG_CB_REMOVE_RESPONSE.

Public Constructors

Name | Description
ZDO_MSG_CB_REMOVE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_MSG_CB_REMOVE_RESPONSE | Overloaded.
Top

See Also

ZDO_MSG_CB_REMOVE_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE_RESPONSE Constructor

ZDO_MSG_CB_REMOVE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZDO_MSG_CB_REMOVE_RESPONSE | Constructor
Public method | ZDO_MSG_CB_REMOVE_RESPONSE (ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS) |

See Also

ZDO_MSG_CB_REMOVE_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE_RESPONSE Constructor ()

ZDO_MSG_CB_REMOVE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_MSG_CB_REMOVE_RESPONSE()
C++
public:
ZDO_MSG_CB_REMOVE_RESPONSE() sealed
J#
public ZDO_MSG_CB_REMOVE_RESPONSE()
JScript
public function ZDO_MSG_CB_REMOVE_RESPONSE()

See Also

ZDO_MSG_CB_REMOVE_RESPONSE Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REMOVE_RESPONSE Constructor Overload List


ZDO_MSG_CB_REMOVE_RESPONSE Constructor (ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS)

ZDO_MSG_CB_REMOVE_RESPONSE Constructor (ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS _
)
C#
public ZDO_MSG_CB_REMOVE_RESPONSE(
ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS
)
C++
public:
ZDO_MSG_CB_REMOVE_RESPONSE(
ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS
) sealed
J#
public ZDO_MSG_CB_REMOVE_RESPONSE(
ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS
)
JScript
public function ZDO_MSG_CB_REMOVE_RESPONSE(
: ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS
)

See Also

ZDO_MSG_CB_REMOVE_RESPONSE Class
TI.ZPI2 Namespace
ZDO_MSG_CB_REMOVE_RESPONSE Constructor Overload List


Fields

ZDO_MSG_CB_REMOVE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_MSG_CB_REMOVE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZDO_MSG_CB_REMOVE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS
C#
public ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS Status;
C++
public:
ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS;

See Also

ZDO_MSG_CB_REMOVE_RESPONSE Class
TI.ZPI2 Namespace


ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS Enumeration

ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS : char
J#
public enum ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS byte
JScript
public enum ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ Class

ZDO_NODE_DESC_REQ Class
See Also Example Members
[image]

This command is generated to inquire as to the Node Descriptor of the destination device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NODE_DESC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_NODE_DESC_REQ : IREQUEST, IZDO
C++
ref class ZDO_NODE_DESC_REQ : IREQUEST, IZDO
J#
public class ZDO_NODE_DESC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_NODE_DESC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NODE_DESC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NODE_DESC_REQ Members
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ Members

ZDO_NODE_DESC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to inquire as to the Node Descriptor of the destination device

The following tables list the members exposed by ZDO_NODE_DESC_REQ.

Public Constructors

Name | Description
ZDO_NODE_DESC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NODE_DESC_REQ | Overloaded.
Top

See Also

ZDO_NODE_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ Constructor

ZDO_NODE_DESC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_NODE_DESC_REQ | Constructor
Public method | ZDO_NODE_DESC_REQ (UInt16, UInt16) | Constructor

See Also

ZDO_NODE_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ Constructor ()

ZDO_NODE_DESC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NODE_DESC_REQ()
C++
public:
ZDO_NODE_DESC_REQ() sealed
J#
public ZDO_NODE_DESC_REQ()
JScript
public function ZDO_NODE_DESC_REQ()

See Also

ZDO_NODE_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_NODE_DESC_REQ Constructor Overload List


ZDO_NODE_DESC_REQ Constructor (UInt16, UInt16)

ZDO_NODE_DESC_REQ Constructor (UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public ZDO_NODE_DESC_REQ(
ushort ,
ushort
)
C++
public:
ZDO_NODE_DESC_REQ(
unsigned short ,
unsigned short
) sealed
J#
public ZDO_NODE_DESC_REQ(
ushort ,
ushort
)
JScript
public function ZDO_NODE_DESC_REQ(
: UInt16,
: UInt16
)

See Also

ZDO_NODE_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_NODE_DESC_REQ Constructor Overload List


Fields

ZDO_NODE_DESC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

See Also

ZDO_NODE_DESC_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_NODE_DESC_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_NODE_DESC_REQ Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_NODE_DESC_REQ.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_NODE_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ_SRSP Class

ZDO_NODE_DESC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_NODE_DESC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NODE_DESC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_NODE_DESC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_NODE_DESC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_NODE_DESC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_NODE_DESC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NODE_DESC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NODE_DESC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ_SRSP Members

ZDO_NODE_DESC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_NODE_DESC_REQ

The following tables list the members exposed by ZDO_NODE_DESC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_NODE_DESC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NODE_DESC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_NODE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ_SRSP Constructor

ZDO_NODE_DESC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_NODE_DESC_REQ_SRSP | Constructor
Public method | ZDO_NODE_DESC_REQ_SRSP (ZDO_NODE_DESC_REQ_SRSP.AF_STATUS) |

See Also

ZDO_NODE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ_SRSP Constructor ()

ZDO_NODE_DESC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NODE_DESC_REQ_SRSP()
C++
public:
ZDO_NODE_DESC_REQ_SRSP() sealed
J#
public ZDO_NODE_DESC_REQ_SRSP()
JScript
public function ZDO_NODE_DESC_REQ_SRSP()

See Also

ZDO_NODE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_NODE_DESC_REQ_SRSP Constructor Overload List


ZDO_NODE_DESC_REQ_SRSP Constructor (ZDO_NODE_DESC_REQ_SRSP.AF_STATUS)

ZDO_NODE_DESC_REQ_SRSP Constructor (ZDO_NODE_DESC_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NODE_DESC_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_NODE_DESC_REQ_SRSP(
ZDO_NODE_DESC_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_NODE_DESC_REQ_SRSP(
ZDO_NODE_DESC_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_NODE_DESC_REQ_SRSP(
ZDO_NODE_DESC_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_NODE_DESC_REQ_SRSP(
: ZDO_NODE_DESC_REQ_SRSP.AF_STATUS
)

See Also

ZDO_NODE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_NODE_DESC_REQ_SRSP Constructor Overload List


Fields

ZDO_NODE_DESC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_NODE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_NODE_DESC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NODE_DESC_REQ_SRSP.AF_STATUS
C#
public ZDO_NODE_DESC_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_NODE_DESC_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_NODE_DESC_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_NODE_DESC_REQ_SRSP.AF_STATUS;

See Also

ZDO_NODE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_REQ_SRSP.AF_STATUS Enumeration

ZDO_NODE_DESC_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NODE_DESC_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_NODE_DESC_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_NODE_DESC_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_NODE_DESC_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_NODE_DESC_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_NODE_DESC_RSP Class

ZDO_NODE_DESC_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Node Descriptor Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NODE_DESC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_NODE_DESC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_NODE_DESC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_NODE_DESC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_NODE_DESC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NODE_DESC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NODE_DESC_RSP Members
TI.ZPI2 Namespace


ZDO_NODE_DESC_RSP Members

ZDO_NODE_DESC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Node Descriptor Request.

The following tables list the members exposed by ZDO_NODE_DESC_RSP.

Public Constructors

Name | Description
ZDO_NODE_DESC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | APSFlags_FrequencyBand | APSFlags: bits 4-0, FrequencyBand: bits 7-5
Public field | DescriptorCapabilities | Specifies the Descriptor capabilities
Public field | LogicalType_ComplexDescAvailable_UserDescAvailable | LogicalType: bits 3-0, ComplexDescAvailable: bit 4, UserDescAvailable: bit 5
Public field | MACCapabilityFlags | Capability flags stored for the MAC
Public field | ManufacturerCode | Specifies a manufacturer code that is allocated by ZigBee Alliance, relating to the manufacturer to the device
Public field | MaxBufferSize | Indicates size of maximum NPDU. This field is used as a high level indication for management
Public field | MaxInTransferSize | Indicates maximum size of Transfer up to 0x7fff.
Public field | MaxOutTransferSize | Indicates maximum size of Transfer up to 0x7fff.
Public field | NwkAddr | Device's short address of this Node descriptor
Public field | ServerMask | Specifies the system server capability
Public field | SrcAddr | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NODE_DESC_RSP | Overloaded.
Top

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_RSP Constructor

ZDO_NODE_DESC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_NODE_DESC_RSP | Constructor
Public method | ZDO_NODE_DESC_RSP (UInt16, ZDO_NODE_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte, ZDO_NODE_DESC_RSP.CAPABILITY_INFO, UInt16, Byte, UInt16, ZDO_NODE_DESC_RSP.SERVER_CAPABILITY, UInt16, Byte) |

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_RSP Constructor ()

ZDO_NODE_DESC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NODE_DESC_RSP()
C++
public:
ZDO_NODE_DESC_RSP() sealed
J#
public ZDO_NODE_DESC_RSP()
JScript
public function ZDO_NODE_DESC_RSP()

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_NODE_DESC_RSP Constructor Overload List


ZDO_NODE_DESC_RSP Constructor (UInt16, ZDO_NODE_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte, ZDO_NODE_DESC_RSP.CAPABILITY_INFO, UInt16, Byte, UInt16, ZDO_NODE_DESC_RSP.SERVER_CAPABILITY, UInt16, Byte)

ZDO_NODE_DESC_RSP Constructor (UInt16, ZDO_NODE_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte, ZDO_NODE_DESC_RSP.CAPABILITY_INFO, UInt16, Byte, UInt16, ZDO_NODE_DESC_RSP.SERVER_CAPABILITY, UInt16, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_NODE_DESC_RSP.ZDO_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As ZDO_NODE_DESC_RSP.CAPABILITY_INFO, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As ZDO_NODE_DESC_RSP.SERVER_CAPABILITY, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_NODE_DESC_RSP(
ushort ,
ZDO_NODE_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte ,
ZDO_NODE_DESC_RSP.CAPABILITY_INFO ,
ushort ,
byte ,
ushort ,
ZDO_NODE_DESC_RSP.SERVER_CAPABILITY ,
ushort ,
byte
)
C++
public:
ZDO_NODE_DESC_RSP(
unsigned short ,
ZDO_NODE_DESC_RSP.ZDO_STATUS ,
unsigned short ,
char ,
char ,
ZDO_NODE_DESC_RSP.CAPABILITY_INFO ,
unsigned short ,
char ,
unsigned short ,
ZDO_NODE_DESC_RSP.SERVER_CAPABILITY ,
unsigned short ,
char
) sealed
J#
public ZDO_NODE_DESC_RSP(
ushort ,
ZDO_NODE_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte ,
ZDO_NODE_DESC_RSP.CAPABILITY_INFO ,
ushort ,
byte ,
ushort ,
ZDO_NODE_DESC_RSP.SERVER_CAPABILITY ,
ushort ,
byte
)
JScript
public function ZDO_NODE_DESC_RSP(
: UInt16,
: ZDO_NODE_DESC_RSP.ZDO_STATUS,
: UInt16,
: Byte,
: Byte,
: ZDO_NODE_DESC_RSP.CAPABILITY_INFO,
: UInt16,
: Byte,
: UInt16,
: ZDO_NODE_DESC_RSP.SERVER_CAPABILITY,
: UInt16,
: Byte
)

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_NODE_DESC_RSP Constructor Overload List


Fields

ZDO_NODE_DESC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | APSFlags_FrequencyBand | APSFlags: bits 4-0, FrequencyBand: bits 7-5
Public field | DescriptorCapabilities | Specifies the Descriptor capabilities
Public field | LogicalType_ComplexDescAvailable_UserDescAvailable | LogicalType: bits 3-0, ComplexDescAvailable: bit 4, UserDescAvailable: bit 5
Public field | MACCapabilityFlags | Capability flags stored for the MAC
Public field | ManufacturerCode | Specifies a manufacturer code that is allocated by ZigBee Alliance, relating to the manufacturer to the device
Public field | MaxBufferSize | Indicates size of maximum NPDU. This field is used as a high level indication for management
Public field | MaxInTransferSize | Indicates maximum size of Transfer up to 0x7fff.
Public field | MaxOutTransferSize | Indicates maximum size of Transfer up to 0x7fff.
Public field | NwkAddr | Device's short address of this Node descriptor
Public field | ServerMask | Specifies the system server capability
Public field | SrcAddr | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


APSFlags_FrequencyBand Field

ZDO_NODE_DESC_RSP.APSFlags_FrequencyBand Field
[image]

APSFlags: bits 4-0, FrequencyBand: bits 7-5

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public APSFlags_FrequencyBand As Byte
C#
public byte APSFlags_FrequencyBand;
C++
public:
char APSFlags_FrequencyBand sealed ;
J#
public byte APSFlags_FrequencyBand
JScript
public APSFlags_FrequencyBand : Byte;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


DescriptorCapabilities Field

ZDO_NODE_DESC_RSP.DescriptorCapabilities Field
[image]

Specifies the Descriptor capabilities

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DescriptorCapabilities As Byte
C#
public byte DescriptorCapabilities;
C++
public:
char DescriptorCapabilities sealed ;
J#
public byte DescriptorCapabilities
JScript
public DescriptorCapabilities : Byte;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


LogicalType_ComplexDescAvailable_UserDescAvailable Field

ZDO_NODE_DESC_RSP.LogicalType_ComplexDescAvailable_UserDescAvailable Field
See Also Example
[image]

LogicalType: bits 3-0, ComplexDescAvailable: bit 4, UserDescAvailable: bit 5

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalType_ComplexDescAvailable_UserDescAvailable As Byte
C#
public byte LogicalType_ComplexDescAvailable_UserDescAvailable;
C++
public:
char LogicalType_ComplexDescAvailable_UserDescAvailable sealed ;
J#
public byte LogicalType_ComplexDescAvailable_UserDescAvailable
JScript
public LogicalType_ComplexDescAvailable_UserDescAvailable : Byte;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


MACCapabilityFlags Field

ZDO_NODE_DESC_RSP.MACCapabilityFlags Field
[image]

Capability flags stored for the MAC

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MACCapabilityFlags As ZDO_NODE_DESC_RSP.CAPABILITY_INFO
C#
public ZDO_NODE_DESC_RSP.CAPABILITY_INFO MACCapabilityFlags;
C++
public:
ZDO_NODE_DESC_RSP.CAPABILITY_INFO MACCapabilityFlags sealed ;
J#
public ZDO_NODE_DESC_RSP.CAPABILITY_INFO MACCapabilityFlags
JScript
public MACCapabilityFlags : ZDO_NODE_DESC_RSP.CAPABILITY_INFO;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


ManufacturerCode Field

ZDO_NODE_DESC_RSP.ManufacturerCode Field
[image]

Specifies a manufacturer code that is allocated by ZigBee Alliance, relating to the manufacturer to the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ManufacturerCode As UInt16
C#
public ushort ManufacturerCode;
C++
public:
unsigned short ManufacturerCode sealed ;
J#
public ushort ManufacturerCode
JScript
public ManufacturerCode : UInt16;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


MaxBufferSize Field

ZDO_NODE_DESC_RSP.MaxBufferSize Field
[image]

Indicates size of maximum NPDU. This field is used as a high level indication for management

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MaxBufferSize As Byte
C#
public byte MaxBufferSize;
C++
public:
char MaxBufferSize sealed ;
J#
public byte MaxBufferSize
JScript
public MaxBufferSize : Byte;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


MaxInTransferSize Field

ZDO_NODE_DESC_RSP.MaxInTransferSize Field
[image]

Indicates maximum size of Transfer up to 0x7fff.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MaxInTransferSize As UInt16
C#
public ushort MaxInTransferSize;
C++
public:
unsigned short MaxInTransferSize sealed ;
J#
public ushort MaxInTransferSize
JScript
public MaxInTransferSize : UInt16;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


MaxOutTransferSize Field

ZDO_NODE_DESC_RSP.MaxOutTransferSize Field
[image]

Indicates maximum size of Transfer up to 0x7fff.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MaxOutTransferSize As UInt16
C#
public ushort MaxOutTransferSize;
C++
public:
unsigned short MaxOutTransferSize sealed ;
J#
public ushort MaxOutTransferSize
JScript
public MaxOutTransferSize : UInt16;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_NODE_DESC_RSP.NwkAddr Field
[image]

Device's short address of this Node descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


ServerMask Field

ZDO_NODE_DESC_RSP.ServerMask Field
[image]

Specifies the system server capability

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ServerMask As ZDO_NODE_DESC_RSP.SERVER_CAPABILITY
C#
public ZDO_NODE_DESC_RSP.SERVER_CAPABILITY ServerMask;
C++
public:
ZDO_NODE_DESC_RSP.SERVER_CAPABILITY ServerMask sealed ;
J#
public ZDO_NODE_DESC_RSP.SERVER_CAPABILITY ServerMask
JScript
public ServerMask : ZDO_NODE_DESC_RSP.SERVER_CAPABILITY;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_NODE_DESC_RSP.SrcAddr Field
[image]

the message's source network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_NODE_DESC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NODE_DESC_RSP.ZDO_STATUS
C#
public ZDO_NODE_DESC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_NODE_DESC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_NODE_DESC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_NODE_DESC_RSP.ZDO_STATUS;

See Also

ZDO_NODE_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_NODE_DESC_RSP.CAPABILITY_INFO Enumeration

ZDO_NODE_DESC_RSP.CAPABILITY_INFO Enumeration
[image]

Capability Information bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_NODE_DESC_RSP.CAPABILITY_INFO As Byte
C#
[FlagsAttribute]
public enum ZDO_NODE_DESC_RSP.CAPABILITY_INFO : byte
C++
[FlagsAttribute]
public enum class ZDO_NODE_DESC_RSP.CAPABILITY_INFO : char
J#
/** @attribute FlagsAttribute() */
public enum ZDO_NODE_DESC_RSP.CAPABILITY_INFO byte
JScript
public enum ZDO_NODE_DESC_RSP.CAPABILITY_INFO :

Members

Member Name | Description | Value
NONE | Capability Information bitfield | 0
ALTER_PAN_COORD | Capability Information bitfield | 1
DEVICE_TYPE | Capability Information bitfield | 2
POWER_SOURCE | Capability Information bitfield | 4
RECEIVER_ON_WHEN_IDLE | Capability Information bitfield | 8
SECURITY_CAPABILITY | Capability Information bitfield | 64
ALLOCATE_ADDRESS | Capability Information bitfield | 128

See Also

TI.ZPI2 Namespace


ZDO_NODE_DESC_RSP.SERVER_CAPABILITY Enumeration

ZDO_NODE_DESC_RSP.SERVER_CAPABILITY Enumeration
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_NODE_DESC_RSP.SERVER_CAPABILITY As
C#
[FlagsAttribute]
public enum ZDO_NODE_DESC_RSP.SERVER_CAPABILITY : ushort
C++
[FlagsAttribute]
public enum class ZDO_NODE_DESC_RSP.SERVER_CAPABILITY : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum ZDO_NODE_DESC_RSP.SERVER_CAPABILITY ushort
JScript
public enum ZDO_NODE_DESC_RSP.SERVER_CAPABILITY :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
PRIM_TRUST_CENTER | Capabilities bitfield | 1
BACKUP_TRUST_CENTER | Capabilities bitfield | 2
PRIM_BIND_TABLE_CACHE | Capabilities bitfield | 4
BAK_BIND_TABLE_CACHE | Capabilities bitfield | 8
PRIM_DISC_CACHE | Capabilities bitfield | 22
BAK_DISC_CACHE | Capabilities bitfield | 50

See Also

TI.ZPI2 Namespace


ZDO_NODE_DESC_RSP.ZDO_STATUS Enumeration

ZDO_NODE_DESC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NODE_DESC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_NODE_DESC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_NODE_DESC_RSP.ZDO_STATUS : char
J#
public enum ZDO_NODE_DESC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_NODE_DESC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ Class

ZDO_NWK_ADDR_REQ Class
See Also Example Members
[image]

This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NWK_ADDR_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_NWK_ADDR_REQ : IREQUEST, IZDO
C++
ref class ZDO_NWK_ADDR_REQ : IREQUEST, IZDO
J#
public class ZDO_NWK_ADDR_REQ implements IREQUEST, IZDO
JScript
public class ZDO_NWK_ADDR_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NWK_ADDR_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NWK_ADDR_REQ Members
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ Members

ZDO_NWK_ADDR_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message will request the device to send a "Network Address Request". This message sends a broadcast message looking for a 16 bit address with a 64 bit address as bait. You must subscribe to "ZDO Network Address Response" to receive the response to this message. The response message listed below only indicates whether or not the message was received properly.

The following tables list the members exposed by ZDO_NWK_ADDR_REQ.

Public Constructors

Name | Description
ZDO_NWK_ADDR_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEAddress | 64 bit address
Public field | ReqType | Request type
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NWK_ADDR_REQ | Overloaded.
Top

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ Constructor

ZDO_NWK_ADDR_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_NWK_ADDR_REQ | Constructor
Public method | ZDO_NWK_ADDR_REQ (UInt64, ZDO_NWK_ADDR_REQ.REQ_TYPE, Byte) |

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ Constructor ()

ZDO_NWK_ADDR_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NWK_ADDR_REQ()
C++
public:
ZDO_NWK_ADDR_REQ() sealed
J#
public ZDO_NWK_ADDR_REQ()
JScript
public function ZDO_NWK_ADDR_REQ()

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace
ZDO_NWK_ADDR_REQ Constructor Overload List


ZDO_NWK_ADDR_REQ Constructor (UInt64, ZDO_NWK_ADDR_REQ.REQ_TYPE, Byte)

ZDO_NWK_ADDR_REQ Constructor (UInt64, ZDO_NWK_ADDR_REQ.REQ_TYPE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As ZDO_NWK_ADDR_REQ.REQ_TYPE, _
ByVal As Byte _
)
C#
public ZDO_NWK_ADDR_REQ(
ulong ,
ZDO_NWK_ADDR_REQ.REQ_TYPE ,
byte
)
C++
public:
ZDO_NWK_ADDR_REQ(
unsigned __int64 ,
ZDO_NWK_ADDR_REQ.REQ_TYPE ,
char
) sealed
J#
public ZDO_NWK_ADDR_REQ(
ulong ,
ZDO_NWK_ADDR_REQ.REQ_TYPE ,
byte
)
JScript
public function ZDO_NWK_ADDR_REQ(
: UInt64,
: ZDO_NWK_ADDR_REQ.REQ_TYPE,
: Byte
)

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace
ZDO_NWK_ADDR_REQ Constructor Overload List


Fields

ZDO_NWK_ADDR_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEAddress | 64 bit address
Public field | ReqType | Request type
Public field | StartIndex | Starting index into the list of children. This is used to get more of the list if the list is to large for one message.
Top

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace


IEEEAddress Field

ZDO_NWK_ADDR_REQ.IEEEAddress Field
[image]

64 bit address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddress As UInt64
C#
public ulong IEEEAddress;
C++
public:
unsigned __int64 IEEEAddress sealed ;
J#
public ulong IEEEAddress
JScript
public IEEEAddress : UInt64;

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace


ReqType Field

ZDO_NWK_ADDR_REQ.ReqType Field
[image]

Request type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ReqType As ZDO_NWK_ADDR_REQ.REQ_TYPE
C#
public ZDO_NWK_ADDR_REQ.REQ_TYPE ReqType;
C++
public:
ZDO_NWK_ADDR_REQ.REQ_TYPE ReqType sealed ;
J#
public ZDO_NWK_ADDR_REQ.REQ_TYPE ReqType
JScript
public ReqType : ZDO_NWK_ADDR_REQ.REQ_TYPE;

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_NWK_ADDR_REQ.StartIndex Field
[image]

Starting index into the list of children. This is used to get more of the list if the list is to large for one message.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_NWK_ADDR_REQ Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ.REQ_TYPE Enumeration

ZDO_NWK_ADDR_REQ.REQ_TYPE Enumeration
[image]

Request type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NWK_ADDR_REQ.REQ_TYPE As Byte
C#
public enum ZDO_NWK_ADDR_REQ.REQ_TYPE : byte
C++
public enum class ZDO_NWK_ADDR_REQ.REQ_TYPE : char
J#
public enum ZDO_NWK_ADDR_REQ.REQ_TYPE byte
JScript
public enum ZDO_NWK_ADDR_REQ.REQ_TYPE :

Members

Member Name | Description
SINGLE_DEVICE_RESPONSE | Request type
EXTENDED | Request type

See Also

TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ_SRSP Class

ZDO_NWK_ADDR_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_NWK_ADDR_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NWK_ADDR_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_NWK_ADDR_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_NWK_ADDR_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_NWK_ADDR_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_NWK_ADDR_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NWK_ADDR_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NWK_ADDR_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ_SRSP Members

ZDO_NWK_ADDR_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_NWK_ADDR_REQ

The following tables list the members exposed by ZDO_NWK_ADDR_REQ_SRSP.

Public Constructors

Name | Description
ZDO_NWK_ADDR_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NWK_ADDR_REQ_SRSP | Overloaded.
Top

See Also

ZDO_NWK_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ_SRSP Constructor

ZDO_NWK_ADDR_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_NWK_ADDR_REQ_SRSP | Constructor
Public method | ZDO_NWK_ADDR_REQ_SRSP (ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS) |

See Also

ZDO_NWK_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ_SRSP Constructor ()

ZDO_NWK_ADDR_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NWK_ADDR_REQ_SRSP()
C++
public:
ZDO_NWK_ADDR_REQ_SRSP() sealed
J#
public ZDO_NWK_ADDR_REQ_SRSP()
JScript
public function ZDO_NWK_ADDR_REQ_SRSP()

See Also

ZDO_NWK_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_NWK_ADDR_REQ_SRSP Constructor Overload List


ZDO_NWK_ADDR_REQ_SRSP Constructor (ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS)

ZDO_NWK_ADDR_REQ_SRSP Constructor (ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_NWK_ADDR_REQ_SRSP(
ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_NWK_ADDR_REQ_SRSP(
ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_NWK_ADDR_REQ_SRSP(
ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_NWK_ADDR_REQ_SRSP(
: ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS
)

See Also

ZDO_NWK_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_NWK_ADDR_REQ_SRSP Constructor Overload List


Fields

ZDO_NWK_ADDR_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_NWK_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_NWK_ADDR_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS
C#
public ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS;

See Also

ZDO_NWK_ADDR_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS Enumeration

ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_NWK_ADDR_RSP Class

ZDO_NWK_ADDR_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Network Address Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NWK_ADDR_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_NWK_ADDR_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_NWK_ADDR_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_NWK_ADDR_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_NWK_ADDR_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NWK_ADDR_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NWK_ADDR_RSP Members
TI.ZPI2 Namespace


ZDO_NWK_ADDR_RSP Members

ZDO_NWK_ADDR_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Network Address Request.

The following tables list the members exposed by ZDO_NWK_ADDR_RSP.

Public Constructors

Name | Description
ZDO_NWK_ADDR_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | number of associated devices
Public field | NwkAddr | short network address of responding device
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NWK_ADDR_RSP | Overloaded.
Top

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_RSP Constructor

ZDO_NWK_ADDR_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_NWK_ADDR_RSP | Constructor
Public method | ZDO_NWK_ADDR_RSP (ZDO_NWK_ADDR_RSP.ZDO_STATUS, UInt64, UInt16, Byte, Byte, UInt16) |

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_RSP Constructor ()

ZDO_NWK_ADDR_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NWK_ADDR_RSP()
C++
public:
ZDO_NWK_ADDR_RSP() sealed
J#
public ZDO_NWK_ADDR_RSP()
JScript
public function ZDO_NWK_ADDR_RSP()

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace
ZDO_NWK_ADDR_RSP Constructor Overload List


ZDO_NWK_ADDR_RSP Constructor (ZDO_NWK_ADDR_RSP.ZDO_STATUS, UInt64, UInt16, Byte, Byte, UInt16[])

ZDO_NWK_ADDR_RSP Constructor (ZDO_NWK_ADDR_RSP.ZDO_STATUS, UInt64, UInt16, Byte, Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NWK_ADDR_RSP.ZDO_STATUS, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_NWK_ADDR_RSP(
ZDO_NWK_ADDR_RSP.ZDO_STATUS ,
ulong ,
ushort ,
byte ,
byte ,
ushort[]
)
C++
public:
ZDO_NWK_ADDR_RSP(
ZDO_NWK_ADDR_RSP.ZDO_STATUS ,
unsigned __int64 ,
unsigned short ,
char ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_NWK_ADDR_RSP(
ZDO_NWK_ADDR_RSP.ZDO_STATUS ,
ulong ,
ushort ,
byte ,
byte ,
ushort[]
)
JScript
public function ZDO_NWK_ADDR_RSP(
: ZDO_NWK_ADDR_RSP.ZDO_STATUS,
: UInt64,
: UInt16,
: Byte,
: Byte,
: UInt16[]
)

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace
ZDO_NWK_ADDR_RSP Constructor Overload List


Fields

ZDO_NWK_ADDR_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | AssocDevList | Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.
Public field | IEEEAddr | 64 bit IEEE address of source device
Public field | NumAssocDev | number of associated devices
Public field | NwkAddr | short network address of responding device
Public field | StartIndex | Starting index into the list of associated devices for this report.
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


AssocDevList Field

ZDO_NWK_ADDR_RSP.AssocDevList Field
[image]

Dynamic array, array of 16 bit short addresses - list of network address for associated devices. This list can be a partial list if the entire list doesn't fit into a packet. If it is a partial list, the starting index is StartIndex.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocDevList As UInt16()
C#
public ushort[] AssocDevList;
C++
public:
array<unsigned short>^ AssocDevList sealed ;
J#
public ushort[] AssocDevList
JScript
public AssocDevList : UInt16[];

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


IEEEAddr Field

ZDO_NWK_ADDR_RSP.IEEEAddr Field
[image]

64 bit IEEE address of source device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEAddr As UInt64
C#
public ulong IEEEAddr;
C++
public:
unsigned __int64 IEEEAddr sealed ;
J#
public ulong IEEEAddr
JScript
public IEEEAddr : UInt64;

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


NumAssocDev Field

ZDO_NWK_ADDR_RSP.NumAssocDev Field
[image]

number of associated devices

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumAssocDev As Byte
C#
public byte NumAssocDev;
C++
public:
char NumAssocDev sealed ;
J#
public byte NumAssocDev
JScript
public NumAssocDev : Byte;

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_NWK_ADDR_RSP.NwkAddr Field
[image]

short network address of responding device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


StartIndex Field

ZDO_NWK_ADDR_RSP.StartIndex Field
[image]

Starting index into the list of associated devices for this report.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartIndex As Byte
C#
public byte StartIndex;
C++
public:
char StartIndex sealed ;
J#
public byte StartIndex
JScript
public StartIndex : Byte;

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_NWK_ADDR_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NWK_ADDR_RSP.ZDO_STATUS
C#
public ZDO_NWK_ADDR_RSP.ZDO_STATUS Status;
C++
public:
ZDO_NWK_ADDR_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_NWK_ADDR_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_NWK_ADDR_RSP.ZDO_STATUS;

See Also

ZDO_NWK_ADDR_RSP Class
TI.ZPI2 Namespace


ZDO_NWK_ADDR_RSP.ZDO_STATUS Enumeration

ZDO_NWK_ADDR_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NWK_ADDR_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_NWK_ADDR_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_NWK_ADDR_RSP.ZDO_STATUS : char
J#
public enum ZDO_NWK_ADDR_RSP.ZDO_STATUS byte
JScript
public enum ZDO_NWK_ADDR_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_CNF Class

ZDO_NWK_DISCOVERY_CNF Class
See Also Example Members
[image]

This message sends an indication to inform host device the completion of network discovery scan.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NWK_DISCOVERY_CNF
Implements IRESPONSE, IZDO
C#
public class ZDO_NWK_DISCOVERY_CNF : IRESPONSE, IZDO
C++
ref class ZDO_NWK_DISCOVERY_CNF : IRESPONSE, IZDO
J#
public class ZDO_NWK_DISCOVERY_CNF implements IRESPONSE, IZDO
JScript
public class ZDO_NWK_DISCOVERY_CNF extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NWK_DISCOVERY_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NWK_DISCOVERY_CNF Members
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_CNF Members

ZDO_NWK_DISCOVERY_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message sends an indication to inform host device the completion of network discovery scan.

The following tables list the members exposed by ZDO_NWK_DISCOVERY_CNF.

Public Constructors

Name | Description
ZDO_NWK_DISCOVERY_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Return status of the network discovery scan
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NWK_DISCOVERY_CNF | Overloaded.
Top

See Also

ZDO_NWK_DISCOVERY_CNF Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_CNF Constructor

ZDO_NWK_DISCOVERY_CNF Constructor

Overload List

 | Name | Description
Public method | ZDO_NWK_DISCOVERY_CNF | Constructor
Public method | ZDO_NWK_DISCOVERY_CNF (ZDO_NWK_DISCOVERY_CNF.CMD_STATUS) |

See Also

ZDO_NWK_DISCOVERY_CNF Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_CNF Constructor ()

ZDO_NWK_DISCOVERY_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NWK_DISCOVERY_CNF()
C++
public:
ZDO_NWK_DISCOVERY_CNF() sealed
J#
public ZDO_NWK_DISCOVERY_CNF()
JScript
public function ZDO_NWK_DISCOVERY_CNF()

See Also

ZDO_NWK_DISCOVERY_CNF Class
TI.ZPI2 Namespace
ZDO_NWK_DISCOVERY_CNF Constructor Overload List


ZDO_NWK_DISCOVERY_CNF Constructor (ZDO_NWK_DISCOVERY_CNF.CMD_STATUS)

ZDO_NWK_DISCOVERY_CNF Constructor (ZDO_NWK_DISCOVERY_CNF.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NWK_DISCOVERY_CNF.CMD_STATUS _
)
C#
public ZDO_NWK_DISCOVERY_CNF(
ZDO_NWK_DISCOVERY_CNF.CMD_STATUS
)
C++
public:
ZDO_NWK_DISCOVERY_CNF(
ZDO_NWK_DISCOVERY_CNF.CMD_STATUS
) sealed
J#
public ZDO_NWK_DISCOVERY_CNF(
ZDO_NWK_DISCOVERY_CNF.CMD_STATUS
)
JScript
public function ZDO_NWK_DISCOVERY_CNF(
: ZDO_NWK_DISCOVERY_CNF.CMD_STATUS
)

See Also

ZDO_NWK_DISCOVERY_CNF Class
TI.ZPI2 Namespace
ZDO_NWK_DISCOVERY_CNF Constructor Overload List


Fields

ZDO_NWK_DISCOVERY_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Return status of the network discovery scan
Top

See Also

ZDO_NWK_DISCOVERY_CNF Class
TI.ZPI2 Namespace


Status Field

ZDO_NWK_DISCOVERY_CNF.Status Field
[image]

Return status of the network discovery scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NWK_DISCOVERY_CNF.CMD_STATUS
C#
public ZDO_NWK_DISCOVERY_CNF.CMD_STATUS Status;
C++
public:
ZDO_NWK_DISCOVERY_CNF.CMD_STATUS Status sealed ;
J#
public ZDO_NWK_DISCOVERY_CNF.CMD_STATUS Status
JScript
public Status : ZDO_NWK_DISCOVERY_CNF.CMD_STATUS;

See Also

ZDO_NWK_DISCOVERY_CNF Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_CNF.CMD_STATUS Enumeration

ZDO_NWK_DISCOVERY_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NWK_DISCOVERY_CNF.CMD_STATUS As Byte
C#
public enum ZDO_NWK_DISCOVERY_CNF.CMD_STATUS : byte
C++
public enum class ZDO_NWK_DISCOVERY_CNF.CMD_STATUS : char
J#
public enum ZDO_NWK_DISCOVERY_CNF.CMD_STATUS byte
JScript
public enum ZDO_NWK_DISCOVERY_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ Class

ZDO_NWK_DISCOVERY_REQ Class
See Also Example Members
[image]

This command will initiate a network discovery (active scan).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NWK_DISCOVERY_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_NWK_DISCOVERY_REQ : IREQUEST, IZDO
C++
ref class ZDO_NWK_DISCOVERY_REQ : IREQUEST, IZDO
J#
public class ZDO_NWK_DISCOVERY_REQ implements IREQUEST, IZDO
JScript
public class ZDO_NWK_DISCOVERY_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NWK_DISCOVERY_REQ Members
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ Members

ZDO_NWK_DISCOVERY_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command will initiate a network discovery (active scan).

The following tables list the members exposed by ZDO_NWK_DISCOVERY_REQ.

Public Constructors

Name | Description
ZDO_NWK_DISCOVERY_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ScanChannels | Bit mask for channels to scan.
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NWK_DISCOVERY_REQ | Overloaded.
Top

See Also

ZDO_NWK_DISCOVERY_REQ Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ Constructor

ZDO_NWK_DISCOVERY_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_NWK_DISCOVERY_REQ | Constructor
Public method | ZDO_NWK_DISCOVERY_REQ (ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS, Byte) |

See Also

ZDO_NWK_DISCOVERY_REQ Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ Constructor ()

ZDO_NWK_DISCOVERY_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NWK_DISCOVERY_REQ()
C++
public:
ZDO_NWK_DISCOVERY_REQ() sealed
J#
public ZDO_NWK_DISCOVERY_REQ()
JScript
public function ZDO_NWK_DISCOVERY_REQ()

See Also

ZDO_NWK_DISCOVERY_REQ Class
TI.ZPI2 Namespace
ZDO_NWK_DISCOVERY_REQ Constructor Overload List


ZDO_NWK_DISCOVERY_REQ Constructor (ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS, Byte)

ZDO_NWK_DISCOVERY_REQ Constructor (ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS, _
ByVal As Byte _
)
C#
public ZDO_NWK_DISCOVERY_REQ(
ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS ,
byte
)
C++
public:
ZDO_NWK_DISCOVERY_REQ(
ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS ,
char
) sealed
J#
public ZDO_NWK_DISCOVERY_REQ(
ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS ,
byte
)
JScript
public function ZDO_NWK_DISCOVERY_REQ(
: ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS,
: Byte
)

See Also

ZDO_NWK_DISCOVERY_REQ Class
TI.ZPI2 Namespace
ZDO_NWK_DISCOVERY_REQ Constructor Overload List


Fields

ZDO_NWK_DISCOVERY_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | ScanChannels | Bit mask for channels to scan.
Public field | ScanDuration | A value used to calculate the length of time to spend scanning each channel.
Top

See Also

ZDO_NWK_DISCOVERY_REQ Class
TI.ZPI2 Namespace


ScanChannels Field

ZDO_NWK_DISCOVERY_REQ.ScanChannels Field
[image]

Bit mask for channels to scan.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS
C#
public ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS ScanChannels;
C++
public:
ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS;

See Also

ZDO_NWK_DISCOVERY_REQ Class
TI.ZPI2 Namespace


ScanDuration Field

ZDO_NWK_DISCOVERY_REQ.ScanDuration Field
[image]

A value used to calculate the length of time to spend scanning each channel.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZDO_NWK_DISCOVERY_REQ Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS Enumeration

ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS uint
JScript
public enum ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ_SRSP Class

ZDO_NWK_DISCOVERY_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_NWK_DISCOVERY_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_NWK_DISCOVERY_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_NWK_DISCOVERY_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_NWK_DISCOVERY_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_NWK_DISCOVERY_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_NWK_DISCOVERY_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_NWK_DISCOVERY_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ_SRSP Members

ZDO_NWK_DISCOVERY_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_NWK_DISCOVERY_REQ

The following tables list the members exposed by ZDO_NWK_DISCOVERY_REQ_SRSP.

Public Constructors

Name | Description
ZDO_NWK_DISCOVERY_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_NWK_DISCOVERY_REQ_SRSP | Overloaded.
Top

See Also

ZDO_NWK_DISCOVERY_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ_SRSP Constructor

ZDO_NWK_DISCOVERY_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_NWK_DISCOVERY_REQ_SRSP | Constructor
Public method | ZDO_NWK_DISCOVERY_REQ_SRSP (ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_NWK_DISCOVERY_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ_SRSP Constructor ()

ZDO_NWK_DISCOVERY_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_NWK_DISCOVERY_REQ_SRSP()
C++
public:
ZDO_NWK_DISCOVERY_REQ_SRSP() sealed
J#
public ZDO_NWK_DISCOVERY_REQ_SRSP()
JScript
public function ZDO_NWK_DISCOVERY_REQ_SRSP()

See Also

ZDO_NWK_DISCOVERY_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_NWK_DISCOVERY_REQ_SRSP Constructor Overload List


ZDO_NWK_DISCOVERY_REQ_SRSP Constructor (ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS)

ZDO_NWK_DISCOVERY_REQ_SRSP Constructor (ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_NWK_DISCOVERY_REQ_SRSP(
ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_NWK_DISCOVERY_REQ_SRSP(
ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_NWK_DISCOVERY_REQ_SRSP(
ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_NWK_DISCOVERY_REQ_SRSP(
: ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_NWK_DISCOVERY_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_NWK_DISCOVERY_REQ_SRSP Constructor Overload List


Fields

ZDO_NWK_DISCOVERY_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_NWK_DISCOVERY_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_NWK_DISCOVERY_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS
C#
public ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS;

See Also

ZDO_NWK_DISCOVERY_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS Enumeration

ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ Class

ZDO_POWER_DESC_REQ Class
See Also Example Members
[image]

This command is generated to inquire as to the Power Descriptor of the destination

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_POWER_DESC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_POWER_DESC_REQ : IREQUEST, IZDO
C++
ref class ZDO_POWER_DESC_REQ : IREQUEST, IZDO
J#
public class ZDO_POWER_DESC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_POWER_DESC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_POWER_DESC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_POWER_DESC_REQ Members
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ Members

ZDO_POWER_DESC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to inquire as to the Power Descriptor of the destination

The following tables list the members exposed by ZDO_POWER_DESC_REQ.

Public Constructors

Name | Description
ZDO_POWER_DESC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_POWER_DESC_REQ | Overloaded.
Top

See Also

ZDO_POWER_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ Constructor

ZDO_POWER_DESC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_POWER_DESC_REQ | Constructor
Public method | ZDO_POWER_DESC_REQ (UInt16, UInt16) | Constructor

See Also

ZDO_POWER_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ Constructor ()

ZDO_POWER_DESC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_POWER_DESC_REQ()
C++
public:
ZDO_POWER_DESC_REQ() sealed
J#
public ZDO_POWER_DESC_REQ()
JScript
public function ZDO_POWER_DESC_REQ()

See Also

ZDO_POWER_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_POWER_DESC_REQ Constructor Overload List


ZDO_POWER_DESC_REQ Constructor (UInt16, UInt16)

ZDO_POWER_DESC_REQ Constructor (UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public ZDO_POWER_DESC_REQ(
ushort ,
ushort
)
C++
public:
ZDO_POWER_DESC_REQ(
unsigned short ,
unsigned short
) sealed
J#
public ZDO_POWER_DESC_REQ(
ushort ,
ushort
)
JScript
public function ZDO_POWER_DESC_REQ(
: UInt16,
: UInt16
)

See Also

ZDO_POWER_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_POWER_DESC_REQ Constructor Overload List


Fields

ZDO_POWER_DESC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

See Also

ZDO_POWER_DESC_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_POWER_DESC_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_POWER_DESC_REQ Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_POWER_DESC_REQ.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_POWER_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ_SRSP Class

ZDO_POWER_DESC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_POWER_DESC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_POWER_DESC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_POWER_DESC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_POWER_DESC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_POWER_DESC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_POWER_DESC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_POWER_DESC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_POWER_DESC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ_SRSP Members

ZDO_POWER_DESC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_POWER_DESC_REQ

The following tables list the members exposed by ZDO_POWER_DESC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_POWER_DESC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_POWER_DESC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_POWER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ_SRSP Constructor

ZDO_POWER_DESC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_POWER_DESC_REQ_SRSP | Constructor
Public method | ZDO_POWER_DESC_REQ_SRSP (ZDO_POWER_DESC_REQ_SRSP.AF_STATUS) |

See Also

ZDO_POWER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ_SRSP Constructor ()

ZDO_POWER_DESC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_POWER_DESC_REQ_SRSP()
C++
public:
ZDO_POWER_DESC_REQ_SRSP() sealed
J#
public ZDO_POWER_DESC_REQ_SRSP()
JScript
public function ZDO_POWER_DESC_REQ_SRSP()

See Also

ZDO_POWER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_POWER_DESC_REQ_SRSP Constructor Overload List


ZDO_POWER_DESC_REQ_SRSP Constructor (ZDO_POWER_DESC_REQ_SRSP.AF_STATUS)

ZDO_POWER_DESC_REQ_SRSP Constructor (ZDO_POWER_DESC_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_POWER_DESC_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_POWER_DESC_REQ_SRSP(
ZDO_POWER_DESC_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_POWER_DESC_REQ_SRSP(
ZDO_POWER_DESC_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_POWER_DESC_REQ_SRSP(
ZDO_POWER_DESC_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_POWER_DESC_REQ_SRSP(
: ZDO_POWER_DESC_REQ_SRSP.AF_STATUS
)

See Also

ZDO_POWER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_POWER_DESC_REQ_SRSP Constructor Overload List


Fields

ZDO_POWER_DESC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_POWER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_POWER_DESC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_POWER_DESC_REQ_SRSP.AF_STATUS
C#
public ZDO_POWER_DESC_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_POWER_DESC_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_POWER_DESC_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_POWER_DESC_REQ_SRSP.AF_STATUS;

See Also

ZDO_POWER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_REQ_SRSP.AF_STATUS Enumeration

ZDO_POWER_DESC_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_POWER_DESC_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_POWER_DESC_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_POWER_DESC_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_POWER_DESC_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_POWER_DESC_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_POWER_DESC_RSP Class

ZDO_POWER_DESC_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Power Descriptor Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_POWER_DESC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_POWER_DESC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_POWER_DESC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_POWER_DESC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_POWER_DESC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_POWER_DESC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_POWER_DESC_RSP Members
TI.ZPI2 Namespace


ZDO_POWER_DESC_RSP Members

ZDO_POWER_DESC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Power Descriptor Request.

The following tables list the members exposed by ZDO_POWER_DESC_RSP.

Public Constructors

Name | Description
ZDO_POWER_DESC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CurrentPowerMode_AvailablePowerSources | CurrentPowerMode: bits 3-0, AvailablePowerSources: bits 7-4
Public field | CurrentPowerSource_CurrentPowerSourceLevel | CurrentPowerSource: bits 3-0, CurrentPowerSourceLevel: bits 7-4
Public field | NWKAddr | Device's short address that this response describes.
Public field | SrcAddr | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_POWER_DESC_RSP | Overloaded.
Top

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_RSP Constructor

ZDO_POWER_DESC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_POWER_DESC_RSP | Constructor
Public method | ZDO_POWER_DESC_RSP (UInt16, ZDO_POWER_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte) |

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_RSP Constructor ()

ZDO_POWER_DESC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_POWER_DESC_RSP()
C++
public:
ZDO_POWER_DESC_RSP() sealed
J#
public ZDO_POWER_DESC_RSP()
JScript
public function ZDO_POWER_DESC_RSP()

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_POWER_DESC_RSP Constructor Overload List


ZDO_POWER_DESC_RSP Constructor (UInt16, ZDO_POWER_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte)

ZDO_POWER_DESC_RSP Constructor (UInt16, ZDO_POWER_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_POWER_DESC_RSP.ZDO_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZDO_POWER_DESC_RSP(
ushort ,
ZDO_POWER_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte
)
C++
public:
ZDO_POWER_DESC_RSP(
unsigned short ,
ZDO_POWER_DESC_RSP.ZDO_STATUS ,
unsigned short ,
char ,
char
) sealed
J#
public ZDO_POWER_DESC_RSP(
ushort ,
ZDO_POWER_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte
)
JScript
public function ZDO_POWER_DESC_RSP(
: UInt16,
: ZDO_POWER_DESC_RSP.ZDO_STATUS,
: UInt16,
: Byte,
: Byte
)

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_POWER_DESC_RSP Constructor Overload List


Fields

ZDO_POWER_DESC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | CurrentPowerMode_AvailablePowerSources | CurrentPowerMode: bits 3-0, AvailablePowerSources: bits 7-4
Public field | CurrentPowerSource_CurrentPowerSourceLevel | CurrentPowerSource: bits 3-0, CurrentPowerSourceLevel: bits 7-4
Public field | NWKAddr | Device's short address that this response describes.
Public field | SrcAddr | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


CurrentPowerMode_AvailablePowerSources Field

ZDO_POWER_DESC_RSP.CurrentPowerMode_AvailablePowerSources Field
See Also Example
[image]

CurrentPowerMode: bits 3-0, AvailablePowerSources: bits 7-4

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CurrentPowerMode_AvailablePowerSources As Byte
C#
public byte CurrentPowerMode_AvailablePowerSources;
C++
public:
char CurrentPowerMode_AvailablePowerSources sealed ;
J#
public byte CurrentPowerMode_AvailablePowerSources
JScript
public CurrentPowerMode_AvailablePowerSources : Byte;

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


CurrentPowerSource_CurrentPowerSourceLevel Field

ZDO_POWER_DESC_RSP.CurrentPowerSource_CurrentPowerSourceLevel Field
See Also Example
[image]

CurrentPowerSource: bits 3-0, CurrentPowerSourceLevel: bits 7-4

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CurrentPowerSource_CurrentPowerSourceLevel As Byte
C#
public byte CurrentPowerSource_CurrentPowerSourceLevel;
C++
public:
char CurrentPowerSource_CurrentPowerSourceLevel sealed ;
J#
public byte CurrentPowerSource_CurrentPowerSourceLevel
JScript
public CurrentPowerSource_CurrentPowerSourceLevel : Byte;

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


NWKAddr Field

ZDO_POWER_DESC_RSP.NWKAddr Field
[image]

Device's short address that this response describes.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddr As UInt16
C#
public ushort NWKAddr;
C++
public:
unsigned short NWKAddr sealed ;
J#
public ushort NWKAddr
JScript
public NWKAddr : UInt16;

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_POWER_DESC_RSP.SrcAddr Field
[image]

the message's source network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_POWER_DESC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_POWER_DESC_RSP.ZDO_STATUS
C#
public ZDO_POWER_DESC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_POWER_DESC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_POWER_DESC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_POWER_DESC_RSP.ZDO_STATUS;

See Also

ZDO_POWER_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_POWER_DESC_RSP.ZDO_STATUS Enumeration

ZDO_POWER_DESC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_POWER_DESC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_POWER_DESC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_POWER_DESC_RSP.ZDO_STATUS : char
J#
public enum ZDO_POWER_DESC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_POWER_DESC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY Class

ZDO_REMOVE_LINK_KEY Class
See Also Example Members
[image]

This command removes the application or trust center link key of a given device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_REMOVE_LINK_KEY
Implements IREQUEST, IZDO
C#
public class ZDO_REMOVE_LINK_KEY : IREQUEST, IZDO
C++
ref class ZDO_REMOVE_LINK_KEY : IREQUEST, IZDO
J#
public class ZDO_REMOVE_LINK_KEY implements IREQUEST, IZDO
JScript
public class ZDO_REMOVE_LINK_KEY extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_REMOVE_LINK_KEY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_REMOVE_LINK_KEY Members
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY Members

ZDO_REMOVE_LINK_KEY Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command removes the application or trust center link key of a given device.

The following tables list the members exposed by ZDO_REMOVE_LINK_KEY.

Public Constructors

Name | Description
ZDO_REMOVE_LINK_KEY | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEaddr | Specifies the IEEE address of the device.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_REMOVE_LINK_KEY | Overloaded.
Top

See Also

ZDO_REMOVE_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY Constructor

ZDO_REMOVE_LINK_KEY Constructor

Overload List

 | Name | Description
Public method | ZDO_REMOVE_LINK_KEY | Constructor
Public method | ZDO_REMOVE_LINK_KEY (UInt64) | Constructor

See Also

ZDO_REMOVE_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY Constructor ()

ZDO_REMOVE_LINK_KEY Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_REMOVE_LINK_KEY()
C++
public:
ZDO_REMOVE_LINK_KEY() sealed
J#
public ZDO_REMOVE_LINK_KEY()
JScript
public function ZDO_REMOVE_LINK_KEY()

See Also

ZDO_REMOVE_LINK_KEY Class
TI.ZPI2 Namespace
ZDO_REMOVE_LINK_KEY Constructor Overload List


ZDO_REMOVE_LINK_KEY Constructor (UInt64)

ZDO_REMOVE_LINK_KEY Constructor (UInt64)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64 _
)
C#
public ZDO_REMOVE_LINK_KEY(
ulong
)
C++
public:
ZDO_REMOVE_LINK_KEY(
unsigned __int64
) sealed
J#
public ZDO_REMOVE_LINK_KEY(
ulong
)
JScript
public function ZDO_REMOVE_LINK_KEY(
: UInt64
)

See Also

ZDO_REMOVE_LINK_KEY Class
TI.ZPI2 Namespace
ZDO_REMOVE_LINK_KEY Constructor Overload List


Fields

ZDO_REMOVE_LINK_KEY Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEaddr | Specifies the IEEE address of the device.
Top

See Also

ZDO_REMOVE_LINK_KEY Class
TI.ZPI2 Namespace


IEEEaddr Field

ZDO_REMOVE_LINK_KEY.IEEEaddr Field
[image]

Specifies the IEEE address of the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEaddr As UInt64
C#
public ulong IEEEaddr;
C++
public:
unsigned __int64 IEEEaddr sealed ;
J#
public ulong IEEEaddr
JScript
public IEEEaddr : UInt64;

See Also

ZDO_REMOVE_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY_SRSP Class

ZDO_REMOVE_LINK_KEY_SRSP Class
See Also Example Members
[image]

Response for ZDO_REMOVE_LINK_KEY

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_REMOVE_LINK_KEY_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_REMOVE_LINK_KEY_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_REMOVE_LINK_KEY_SRSP : IRESPONSE, IZDO
J#
public class ZDO_REMOVE_LINK_KEY_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_REMOVE_LINK_KEY_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_REMOVE_LINK_KEY_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_REMOVE_LINK_KEY_SRSP Members
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY_SRSP Members

ZDO_REMOVE_LINK_KEY_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_REMOVE_LINK_KEY

The following tables list the members exposed by ZDO_REMOVE_LINK_KEY_SRSP.

Public Constructors

Name | Description
ZDO_REMOVE_LINK_KEY_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_REMOVE_LINK_KEY_SRSP | Overloaded.
Top

See Also

ZDO_REMOVE_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY_SRSP Constructor

ZDO_REMOVE_LINK_KEY_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_REMOVE_LINK_KEY_SRSP | Constructor
Public method | ZDO_REMOVE_LINK_KEY_SRSP (ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS) |

See Also

ZDO_REMOVE_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY_SRSP Constructor ()

ZDO_REMOVE_LINK_KEY_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_REMOVE_LINK_KEY_SRSP()
C++
public:
ZDO_REMOVE_LINK_KEY_SRSP() sealed
J#
public ZDO_REMOVE_LINK_KEY_SRSP()
JScript
public function ZDO_REMOVE_LINK_KEY_SRSP()

See Also

ZDO_REMOVE_LINK_KEY_SRSP Class
TI.ZPI2 Namespace
ZDO_REMOVE_LINK_KEY_SRSP Constructor Overload List


ZDO_REMOVE_LINK_KEY_SRSP Constructor (ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS)

ZDO_REMOVE_LINK_KEY_SRSP Constructor (ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS _
)
C#
public ZDO_REMOVE_LINK_KEY_SRSP(
ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS
)
C++
public:
ZDO_REMOVE_LINK_KEY_SRSP(
ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS
) sealed
J#
public ZDO_REMOVE_LINK_KEY_SRSP(
ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS
)
JScript
public function ZDO_REMOVE_LINK_KEY_SRSP(
: ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS
)

See Also

ZDO_REMOVE_LINK_KEY_SRSP Class
TI.ZPI2 Namespace
ZDO_REMOVE_LINK_KEY_SRSP Constructor Overload List


Fields

ZDO_REMOVE_LINK_KEY_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_REMOVE_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_REMOVE_LINK_KEY_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS
C#
public ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS Status;
C++
public:
ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS;

See Also

ZDO_REMOVE_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS Enumeration

ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS : char
J#
public enum ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS byte
JScript
public enum ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ Class

ZDO_SERVER_DISC_REQ Class
See Also Example Members
[image]

The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SERVER_DISC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_SERVER_DISC_REQ : IREQUEST, IZDO
C++
ref class ZDO_SERVER_DISC_REQ : IREQUEST, IZDO
J#
public class ZDO_SERVER_DISC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_SERVER_DISC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SERVER_DISC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SERVER_DISC_REQ Members
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ Members

ZDO_SERVER_DISC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

The command is used for local device to discover the location of a particular system server or servers as indicated by the ServerMask parameter. The destination addressing on this request is 'broadcast to all RxOnWhenIdle devices'.

The following tables list the members exposed by ZDO_SERVER_DISC_REQ.

Public Constructors

Name | Description
ZDO_SERVER_DISC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ServerMask | Server Mask is a two byte field with bit settings signifying the system server capabililties of the device.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SERVER_DISC_REQ | Overloaded.
Top

See Also

ZDO_SERVER_DISC_REQ Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ Constructor

ZDO_SERVER_DISC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_SERVER_DISC_REQ | Constructor
Public method | ZDO_SERVER_DISC_REQ (UInt16) | Constructor

See Also

ZDO_SERVER_DISC_REQ Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ Constructor ()

ZDO_SERVER_DISC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SERVER_DISC_REQ()
C++
public:
ZDO_SERVER_DISC_REQ() sealed
J#
public ZDO_SERVER_DISC_REQ()
JScript
public function ZDO_SERVER_DISC_REQ()

See Also

ZDO_SERVER_DISC_REQ Class
TI.ZPI2 Namespace
ZDO_SERVER_DISC_REQ Constructor Overload List


ZDO_SERVER_DISC_REQ Constructor (UInt16)

ZDO_SERVER_DISC_REQ Constructor (UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16 _
)
C#
public ZDO_SERVER_DISC_REQ(
ushort
)
C++
public:
ZDO_SERVER_DISC_REQ(
unsigned short
) sealed
J#
public ZDO_SERVER_DISC_REQ(
ushort
)
JScript
public function ZDO_SERVER_DISC_REQ(
: UInt16
)

See Also

ZDO_SERVER_DISC_REQ Class
TI.ZPI2 Namespace
ZDO_SERVER_DISC_REQ Constructor Overload List


Fields

ZDO_SERVER_DISC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | ServerMask | Server Mask is a two byte field with bit settings signifying the system server capabililties of the device.
Top

See Also

ZDO_SERVER_DISC_REQ Class
TI.ZPI2 Namespace


ServerMask Field

ZDO_SERVER_DISC_REQ.ServerMask Field
[image]

Server Mask is a two byte field with bit settings signifying the system server capabililties of the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ServerMask As UInt16
C#
public ushort ServerMask;
C++
public:
unsigned short ServerMask sealed ;
J#
public ushort ServerMask
JScript
public ServerMask : UInt16;

See Also

ZDO_SERVER_DISC_REQ Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ_SRSP Class

ZDO_SERVER_DISC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_SERVER_DISC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SERVER_DISC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_SERVER_DISC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_SERVER_DISC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_SERVER_DISC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_SERVER_DISC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SERVER_DISC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SERVER_DISC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ_SRSP Members

ZDO_SERVER_DISC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_SERVER_DISC_REQ

The following tables list the members exposed by ZDO_SERVER_DISC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_SERVER_DISC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SERVER_DISC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_SERVER_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ_SRSP Constructor

ZDO_SERVER_DISC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_SERVER_DISC_REQ_SRSP | Constructor
Public method | ZDO_SERVER_DISC_REQ_SRSP (ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS) |

See Also

ZDO_SERVER_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ_SRSP Constructor ()

ZDO_SERVER_DISC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SERVER_DISC_REQ_SRSP()
C++
public:
ZDO_SERVER_DISC_REQ_SRSP() sealed
J#
public ZDO_SERVER_DISC_REQ_SRSP()
JScript
public function ZDO_SERVER_DISC_REQ_SRSP()

See Also

ZDO_SERVER_DISC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_SERVER_DISC_REQ_SRSP Constructor Overload List


ZDO_SERVER_DISC_REQ_SRSP Constructor (ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS)

ZDO_SERVER_DISC_REQ_SRSP Constructor (ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS _
)
C#
public ZDO_SERVER_DISC_REQ_SRSP(
ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS
)
C++
public:
ZDO_SERVER_DISC_REQ_SRSP(
ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS
) sealed
J#
public ZDO_SERVER_DISC_REQ_SRSP(
ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS
)
JScript
public function ZDO_SERVER_DISC_REQ_SRSP(
: ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS
)

See Also

ZDO_SERVER_DISC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_SERVER_DISC_REQ_SRSP Constructor Overload List


Fields

ZDO_SERVER_DISC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_SERVER_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_SERVER_DISC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS
C#
public ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS Status;
C++
public:
ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS;

See Also

ZDO_SERVER_DISC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS Enumeration

ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS : char
J#
public enum ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS byte
JScript
public enum ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_SERVER_DISC_RSP Class

ZDO_SERVER_DISC_RSP Class
See Also Example Members
[image]

This callback message is

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SERVER_DISC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_SERVER_DISC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_SERVER_DISC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_SERVER_DISC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_SERVER_DISC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SERVER_DISC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SERVER_DISC_RSP Members
TI.ZPI2 Namespace


ZDO_SERVER_DISC_RSP Members

ZDO_SERVER_DISC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is

The following tables list the members exposed by ZDO_SERVER_DISC_RSP.

Public Constructors

Name | Description
ZDO_SERVER_DISC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ServerMask | each bit signifies one system server capability of the node
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SERVER_DISC_RSP | Overloaded.
Top

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_RSP Constructor

ZDO_SERVER_DISC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_SERVER_DISC_RSP | Constructor
Public method | ZDO_SERVER_DISC_RSP (UInt16, ZDO_SERVER_DISC_RSP.ZDO_STATUS, ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY) |

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_RSP Constructor ()

ZDO_SERVER_DISC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SERVER_DISC_RSP()
C++
public:
ZDO_SERVER_DISC_RSP() sealed
J#
public ZDO_SERVER_DISC_RSP()
JScript
public function ZDO_SERVER_DISC_RSP()

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace
ZDO_SERVER_DISC_RSP Constructor Overload List


ZDO_SERVER_DISC_RSP Constructor (UInt16, ZDO_SERVER_DISC_RSP.ZDO_STATUS, ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY)

ZDO_SERVER_DISC_RSP Constructor (UInt16, ZDO_SERVER_DISC_RSP.ZDO_STATUS, ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_SERVER_DISC_RSP.ZDO_STATUS, _
ByVal As ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY _
)
C#
public ZDO_SERVER_DISC_RSP(
ushort ,
ZDO_SERVER_DISC_RSP.ZDO_STATUS ,
ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY
)
C++
public:
ZDO_SERVER_DISC_RSP(
unsigned short ,
ZDO_SERVER_DISC_RSP.ZDO_STATUS ,
ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY
) sealed
J#
public ZDO_SERVER_DISC_RSP(
ushort ,
ZDO_SERVER_DISC_RSP.ZDO_STATUS ,
ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY
)
JScript
public function ZDO_SERVER_DISC_RSP(
: UInt16,
: ZDO_SERVER_DISC_RSP.ZDO_STATUS,
: ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY
)

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace
ZDO_SERVER_DISC_RSP Constructor Overload List


Fields

ZDO_SERVER_DISC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | ServerMask | each bit signifies one system server capability of the node
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace


ServerMask Field

ZDO_SERVER_DISC_RSP.ServerMask Field
[image]

each bit signifies one system server capability of the node

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ServerMask As ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY
C#
public ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY ServerMask;
C++
public:
ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY ServerMask sealed ;
J#
public ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY ServerMask
JScript
public ServerMask : ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY;

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_SERVER_DISC_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_SERVER_DISC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SERVER_DISC_RSP.ZDO_STATUS
C#
public ZDO_SERVER_DISC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_SERVER_DISC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_SERVER_DISC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_SERVER_DISC_RSP.ZDO_STATUS;

See Also

ZDO_SERVER_DISC_RSP Class
TI.ZPI2 Namespace


ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY Enumeration

ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY Enumeration
[image]

Capabilities bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY As
C#
[FlagsAttribute]
public enum ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY : ushort
C++
[FlagsAttribute]
public enum class ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY : unsigned short
J#
/** @attribute FlagsAttribute() */
public enum ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY ushort
JScript
public enum ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY :

Members

Member Name | Description | Value
NONE | Capabilities bitfield | 0
PRIM_TRUST_CENTER | Capabilities bitfield | 1
BACKUP_TRUST_CENTER | Capabilities bitfield | 2
PRIM_BIND_TABLE_CACHE | Capabilities bitfield | 4
BAK_BIND_TABLE_CACHE | Capabilities bitfield | 8
PRIM_DISC_CACHE | Capabilities bitfield | 22
BAK_DISC_CACHE | Capabilities bitfield | 50

See Also

TI.ZPI2 Namespace


ZDO_SERVER_DISC_RSP.ZDO_STATUS Enumeration

ZDO_SERVER_DISC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SERVER_DISC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_SERVER_DISC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_SERVER_DISC_RSP.ZDO_STATUS : char
J#
public enum ZDO_SERVER_DISC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_SERVER_DISC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_SET_LINK_KEY Class

ZDO_SET_LINK_KEY Class
See Also Example Members
[image]

This Command sets the application or trust center link key for a given device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SET_LINK_KEY
Implements IREQUEST, IZDO
C#
public class ZDO_SET_LINK_KEY : IREQUEST, IZDO
C++
ref class ZDO_SET_LINK_KEY : IREQUEST, IZDO
J#
public class ZDO_SET_LINK_KEY implements IREQUEST, IZDO
JScript
public class ZDO_SET_LINK_KEY extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SET_LINK_KEY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SET_LINK_KEY Members
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY Members

ZDO_SET_LINK_KEY Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This Command sets the application or trust center link key for a given device.

The following tables list the members exposed by ZDO_SET_LINK_KEY.

Public Constructors

Name | Description
ZDO_SET_LINK_KEY | Overloaded.
Top

Public Fields

 | Name | Description
Public field | IEEEaddr | 64 bit IEEE address of the device.
Public field | LinkKeyData | 128 bit link key data of the device.
Public field | ShortAddr | Specifies the short address of the device.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SET_LINK_KEY | Overloaded.
Top

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY Constructor

ZDO_SET_LINK_KEY Constructor

Overload List

 | Name | Description
Public method | ZDO_SET_LINK_KEY | Constructor
Public method | ZDO_SET_LINK_KEY (UInt16, UInt64, Byte) | Constructor

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY Constructor ()

ZDO_SET_LINK_KEY Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SET_LINK_KEY()
C++
public:
ZDO_SET_LINK_KEY() sealed
J#
public ZDO_SET_LINK_KEY()
JScript
public function ZDO_SET_LINK_KEY()

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace
ZDO_SET_LINK_KEY Constructor Overload List


ZDO_SET_LINK_KEY Constructor (UInt16, UInt64, Byte[])

ZDO_SET_LINK_KEY Constructor (UInt16, UInt64, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte() _
)
C#
public ZDO_SET_LINK_KEY(
ushort ,
ulong ,
byte[]
)
C++
public:
ZDO_SET_LINK_KEY(
unsigned short ,
unsigned __int64 ,
array<char>^
) sealed
J#
public ZDO_SET_LINK_KEY(
ushort ,
ulong ,
byte[]
)
JScript
public function ZDO_SET_LINK_KEY(
: UInt16,
: UInt64,
: Byte[]
)

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace
ZDO_SET_LINK_KEY Constructor Overload List


Fields

ZDO_SET_LINK_KEY Fields
[image]

Public Fields

 | Name | Description
Public field | IEEEaddr | 64 bit IEEE address of the device.
Public field | LinkKeyData | 128 bit link key data of the device.
Public field | ShortAddr | Specifies the short address of the device.
Top

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace


IEEEaddr Field

ZDO_SET_LINK_KEY.IEEEaddr Field
[image]

64 bit IEEE address of the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public IEEEaddr As UInt64
C#
public ulong IEEEaddr;
C++
public:
unsigned __int64 IEEEaddr sealed ;
J#
public ulong IEEEaddr
JScript
public IEEEaddr : UInt64;

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace


LinkKeyData Field

ZDO_SET_LINK_KEY.LinkKeyData Field
[image]

128 bit link key data of the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkKeyData As Byte()
C#
public byte[] LinkKeyData;
C++
public:
array<char>^ LinkKeyData sealed ;
J#
public byte[] LinkKeyData
JScript
public LinkKeyData : Byte[];

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace


ShortAddr Field

ZDO_SET_LINK_KEY.ShortAddr Field
[image]

Specifies the short address of the device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ShortAddr As UInt16
C#
public ushort ShortAddr;
C++
public:
unsigned short ShortAddr sealed ;
J#
public ushort ShortAddr
JScript
public ShortAddr : UInt16;

See Also

ZDO_SET_LINK_KEY Class
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY_SRSP Class

ZDO_SET_LINK_KEY_SRSP Class
See Also Example Members
[image]

Response for ZDO_SET_LINK_KEY

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SET_LINK_KEY_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_SET_LINK_KEY_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_SET_LINK_KEY_SRSP : IRESPONSE, IZDO
J#
public class ZDO_SET_LINK_KEY_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_SET_LINK_KEY_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SET_LINK_KEY_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SET_LINK_KEY_SRSP Members
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY_SRSP Members

ZDO_SET_LINK_KEY_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_SET_LINK_KEY

The following tables list the members exposed by ZDO_SET_LINK_KEY_SRSP.

Public Constructors

Name | Description
ZDO_SET_LINK_KEY_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SET_LINK_KEY_SRSP | Overloaded.
Top

See Also

ZDO_SET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY_SRSP Constructor

ZDO_SET_LINK_KEY_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_SET_LINK_KEY_SRSP | Constructor
Public method | ZDO_SET_LINK_KEY_SRSP (ZDO_SET_LINK_KEY_SRSP.CMD_STATUS) |

See Also

ZDO_SET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY_SRSP Constructor ()

ZDO_SET_LINK_KEY_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SET_LINK_KEY_SRSP()
C++
public:
ZDO_SET_LINK_KEY_SRSP() sealed
J#
public ZDO_SET_LINK_KEY_SRSP()
JScript
public function ZDO_SET_LINK_KEY_SRSP()

See Also

ZDO_SET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace
ZDO_SET_LINK_KEY_SRSP Constructor Overload List


ZDO_SET_LINK_KEY_SRSP Constructor (ZDO_SET_LINK_KEY_SRSP.CMD_STATUS)

ZDO_SET_LINK_KEY_SRSP Constructor (ZDO_SET_LINK_KEY_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_SET_LINK_KEY_SRSP.CMD_STATUS _
)
C#
public ZDO_SET_LINK_KEY_SRSP(
ZDO_SET_LINK_KEY_SRSP.CMD_STATUS
)
C++
public:
ZDO_SET_LINK_KEY_SRSP(
ZDO_SET_LINK_KEY_SRSP.CMD_STATUS
) sealed
J#
public ZDO_SET_LINK_KEY_SRSP(
ZDO_SET_LINK_KEY_SRSP.CMD_STATUS
)
JScript
public function ZDO_SET_LINK_KEY_SRSP(
: ZDO_SET_LINK_KEY_SRSP.CMD_STATUS
)

See Also

ZDO_SET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace
ZDO_SET_LINK_KEY_SRSP Constructor Overload List


Fields

ZDO_SET_LINK_KEY_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_SET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_SET_LINK_KEY_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SET_LINK_KEY_SRSP.CMD_STATUS
C#
public ZDO_SET_LINK_KEY_SRSP.CMD_STATUS Status;
C++
public:
ZDO_SET_LINK_KEY_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_SET_LINK_KEY_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_SET_LINK_KEY_SRSP.CMD_STATUS;

See Also

ZDO_SET_LINK_KEY_SRSP Class
TI.ZPI2 Namespace


ZDO_SET_LINK_KEY_SRSP.CMD_STATUS Enumeration

ZDO_SET_LINK_KEY_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SET_LINK_KEY_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_SET_LINK_KEY_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_SET_LINK_KEY_SRSP.CMD_STATUS : char
J#
public enum ZDO_SET_LINK_KEY_SRSP.CMD_STATUS byte
JScript
public enum ZDO_SET_LINK_KEY_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ Class

ZDO_SIMPLE_DESC_REQ Class
See Also Example Members
[image]

This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SIMPLE_DESC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_SIMPLE_DESC_REQ : IREQUEST, IZDO
C++
ref class ZDO_SIMPLE_DESC_REQ : IREQUEST, IZDO
J#
public class ZDO_SIMPLE_DESC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_SIMPLE_DESC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SIMPLE_DESC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SIMPLE_DESC_REQ Members
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ Members

ZDO_SIMPLE_DESC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to inquire as to the Simple Descriptor of the destination device's Endpoint

The following tables list the members exposed by ZDO_SIMPLE_DESC_REQ.

Public Constructors

Name | Description
ZDO_SIMPLE_DESC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | End point
Public field | NWKAddrOfInterest | NWK address for the request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SIMPLE_DESC_REQ | Overloaded.
Top

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ Constructor

ZDO_SIMPLE_DESC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_SIMPLE_DESC_REQ | Constructor
Public method | ZDO_SIMPLE_DESC_REQ (UInt16, UInt16, Byte) | Constructor

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ Constructor ()

ZDO_SIMPLE_DESC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SIMPLE_DESC_REQ()
C++
public:
ZDO_SIMPLE_DESC_REQ() sealed
J#
public ZDO_SIMPLE_DESC_REQ()
JScript
public function ZDO_SIMPLE_DESC_REQ()

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_SIMPLE_DESC_REQ Constructor Overload List


ZDO_SIMPLE_DESC_REQ Constructor (UInt16, UInt16, Byte)

ZDO_SIMPLE_DESC_REQ Constructor (UInt16, UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZDO_SIMPLE_DESC_REQ(
ushort ,
ushort ,
byte
)
C++
public:
ZDO_SIMPLE_DESC_REQ(
unsigned short ,
unsigned short ,
char
) sealed
J#
public ZDO_SIMPLE_DESC_REQ(
ushort ,
ushort ,
byte
)
JScript
public function ZDO_SIMPLE_DESC_REQ(
: UInt16,
: UInt16,
: Byte
)

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_SIMPLE_DESC_REQ Constructor Overload List


Fields

ZDO_SIMPLE_DESC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | Endpoint | End point
Public field | NWKAddrOfInterest | NWK address for the request
Top

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_SIMPLE_DESC_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace


Endpoint Field

ZDO_SIMPLE_DESC_REQ.Endpoint Field
[image]

End point

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_SIMPLE_DESC_REQ.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_SIMPLE_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ_SRSP Class

ZDO_SIMPLE_DESC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_SIMPLEDESCRIPTOR_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SIMPLE_DESC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_SIMPLE_DESC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_SIMPLE_DESC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_SIMPLE_DESC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_SIMPLE_DESC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SIMPLE_DESC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SIMPLE_DESC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ_SRSP Members

ZDO_SIMPLE_DESC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_SIMPLEDESCRIPTOR_REQUEST

The following tables list the members exposed by ZDO_SIMPLE_DESC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_SIMPLE_DESC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SIMPLE_DESC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_SIMPLE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ_SRSP Constructor

ZDO_SIMPLE_DESC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_SIMPLE_DESC_REQ_SRSP | Constructor
Public method | ZDO_SIMPLE_DESC_REQ_SRSP (ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS) |

See Also

ZDO_SIMPLE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ_SRSP Constructor ()

ZDO_SIMPLE_DESC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SIMPLE_DESC_REQ_SRSP()
C++
public:
ZDO_SIMPLE_DESC_REQ_SRSP() sealed
J#
public ZDO_SIMPLE_DESC_REQ_SRSP()
JScript
public function ZDO_SIMPLE_DESC_REQ_SRSP()

See Also

ZDO_SIMPLE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_SIMPLE_DESC_REQ_SRSP Constructor Overload List


ZDO_SIMPLE_DESC_REQ_SRSP Constructor (ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS)

ZDO_SIMPLE_DESC_REQ_SRSP Constructor (ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_SIMPLE_DESC_REQ_SRSP(
ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_SIMPLE_DESC_REQ_SRSP(
ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_SIMPLE_DESC_REQ_SRSP(
ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_SIMPLE_DESC_REQ_SRSP(
: ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS
)

See Also

ZDO_SIMPLE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_SIMPLE_DESC_REQ_SRSP Constructor Overload List


Fields

ZDO_SIMPLE_DESC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_SIMPLE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_SIMPLE_DESC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS
C#
public ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS;

See Also

ZDO_SIMPLE_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS Enumeration

ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_RSP Class

ZDO_SIMPLE_DESC_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO Simple Descriptor Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SIMPLE_DESC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_SIMPLE_DESC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_SIMPLE_DESC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_SIMPLE_DESC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_SIMPLE_DESC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SIMPLE_DESC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SIMPLE_DESC_RSP Members
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_RSP Members

ZDO_SIMPLE_DESC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO Simple Descriptor Request.

The following tables list the members exposed by ZDO_SIMPLE_DESC_RSP.

Public Constructors

Name | Description
ZDO_SIMPLE_DESC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceID | The Device Description ID for this endpoint.
Public field | DeviceVersion | Flags indicating app version
Public field | Endpoint | End point
Public field | InClusterList | List of input cluster IDs supported
Public field | Len | Length of simple descriptor
Public field | NumInClusters | The number of input clusters in the AppInClusterList
Public field | NumOutClusters | The number of output clusters in the AppOutClusterList
Public field | NwkAddr | Device's short address that this response describes.
Public field | OutClusterList | List of output cluster IDs supported
Public field | ProfileID | The profile ID for this endpoint.
Public field | SrcAddr | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SIMPLE_DESC_RSP | Overloaded.
Top

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_RSP Constructor

ZDO_SIMPLE_DESC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_SIMPLE_DESC_RSP | Constructor
Public method | ZDO_SIMPLE_DESC_RSP (UInt16, ZDO_SIMPLE_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte, UInt16, UInt16, ZDO_SIMPLE_DESC_RSP.APP_DEV_VER, Byte, UInt16, Byte, UInt16) |

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_RSP Constructor ()

ZDO_SIMPLE_DESC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SIMPLE_DESC_RSP()
C++
public:
ZDO_SIMPLE_DESC_RSP() sealed
J#
public ZDO_SIMPLE_DESC_RSP()
JScript
public function ZDO_SIMPLE_DESC_RSP()

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_SIMPLE_DESC_RSP Constructor Overload List


ZDO_SIMPLE_DESC_RSP Constructor (UInt16, ZDO_SIMPLE_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte, UInt16, UInt16, ZDO_SIMPLE_DESC_RSP.APP_DEV_VER, Byte, UInt16[], Byte, UInt16[])

ZDO_SIMPLE_DESC_RSP Constructor (UInt16, ZDO_SIMPLE_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte, UInt16, UInt16, ZDO_SIMPLE_DESC_RSP.APP_DEV_VER, Byte, UInt16[], Byte, UInt16[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_SIMPLE_DESC_RSP.ZDO_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As ZDO_SIMPLE_DESC_RSP.APP_DEV_VER, _
ByVal As Byte, _
ByVal As UInt16(), _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_SIMPLE_DESC_RSP(
ushort ,
ZDO_SIMPLE_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte ,
ushort ,
ushort ,
ZDO_SIMPLE_DESC_RSP.APP_DEV_VER ,
byte ,
ushort[] ,
byte ,
ushort[]
)
C++
public:
ZDO_SIMPLE_DESC_RSP(
unsigned short ,
ZDO_SIMPLE_DESC_RSP.ZDO_STATUS ,
unsigned short ,
char ,
char ,
unsigned short ,
unsigned short ,
ZDO_SIMPLE_DESC_RSP.APP_DEV_VER ,
char ,
array<unsigned short>^ ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_SIMPLE_DESC_RSP(
ushort ,
ZDO_SIMPLE_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte ,
ushort ,
ushort ,
ZDO_SIMPLE_DESC_RSP.APP_DEV_VER ,
byte ,
ushort[] ,
byte ,
ushort[]
)
JScript
public function ZDO_SIMPLE_DESC_RSP(
: UInt16,
: ZDO_SIMPLE_DESC_RSP.ZDO_STATUS,
: UInt16,
: Byte,
: Byte,
: UInt16,
: UInt16,
: ZDO_SIMPLE_DESC_RSP.APP_DEV_VER,
: Byte,
: UInt16[],
: Byte,
: UInt16[]
)

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_SIMPLE_DESC_RSP Constructor Overload List


Fields

ZDO_SIMPLE_DESC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceID | The Device Description ID for this endpoint.
Public field | DeviceVersion | Flags indicating app version
Public field | Endpoint | End point
Public field | InClusterList | List of input cluster IDs supported
Public field | Len | Length of simple descriptor
Public field | NumInClusters | The number of input clusters in the AppInClusterList
Public field | NumOutClusters | The number of output clusters in the AppOutClusterList
Public field | NwkAddr | Device's short address that this response describes.
Public field | OutClusterList | List of output cluster IDs supported
Public field | ProfileID | The profile ID for this endpoint.
Public field | SrcAddr | the message's source network address.
Public field | Status | this field indicates either SUCCESS or FAILURE.
Top

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


DeviceID Field

ZDO_SIMPLE_DESC_RSP.DeviceID Field
[image]

The Device Description ID for this endpoint.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceID As UInt16
C#
public ushort DeviceID;
C++
public:
unsigned short DeviceID sealed ;
J#
public ushort DeviceID
JScript
public DeviceID : UInt16;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


DeviceVersion Field

ZDO_SIMPLE_DESC_RSP.DeviceVersion Field
[image]

Flags indicating app version

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceVersion As ZDO_SIMPLE_DESC_RSP.APP_DEV_VER
C#
public ZDO_SIMPLE_DESC_RSP.APP_DEV_VER DeviceVersion;
C++
public:
ZDO_SIMPLE_DESC_RSP.APP_DEV_VER DeviceVersion sealed ;
J#
public ZDO_SIMPLE_DESC_RSP.APP_DEV_VER DeviceVersion
JScript
public DeviceVersion : ZDO_SIMPLE_DESC_RSP.APP_DEV_VER;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


Endpoint Field

ZDO_SIMPLE_DESC_RSP.Endpoint Field
[image]

End point

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Endpoint As Byte
C#
public byte Endpoint;
C++
public:
char Endpoint sealed ;
J#
public byte Endpoint
JScript
public Endpoint : Byte;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


InClusterList Field

ZDO_SIMPLE_DESC_RSP.InClusterList Field
[image]

List of input cluster IDs supported

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public InClusterList As UInt16()
C#
public ushort[] InClusterList;
C++
public:
array<unsigned short>^ InClusterList sealed ;
J#
public ushort[] InClusterList
JScript
public InClusterList : UInt16[];

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


Len Field

ZDO_SIMPLE_DESC_RSP.Len Field
[image]

Length of simple descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


NumInClusters Field

ZDO_SIMPLE_DESC_RSP.NumInClusters Field
[image]

The number of input clusters in the AppInClusterList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumInClusters As Byte
C#
public byte NumInClusters;
C++
public:
char NumInClusters sealed ;
J#
public byte NumInClusters
JScript
public NumInClusters : Byte;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


NumOutClusters Field

ZDO_SIMPLE_DESC_RSP.NumOutClusters Field
[image]

The number of output clusters in the AppOutClusterList

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NumOutClusters As Byte
C#
public byte NumOutClusters;
C++
public:
char NumOutClusters sealed ;
J#
public byte NumOutClusters
JScript
public NumOutClusters : Byte;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_SIMPLE_DESC_RSP.NwkAddr Field
[image]

Device's short address that this response describes.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


OutClusterList Field

ZDO_SIMPLE_DESC_RSP.OutClusterList Field
[image]

List of output cluster IDs supported

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public OutClusterList As UInt16()
C#
public ushort[] OutClusterList;
C++
public:
array<unsigned short>^ OutClusterList sealed ;
J#
public ushort[] OutClusterList
JScript
public OutClusterList : UInt16[];

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


ProfileID Field

ZDO_SIMPLE_DESC_RSP.ProfileID Field
[image]

The profile ID for this endpoint.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ProfileID As UInt16
C#
public ushort ProfileID;
C++
public:
unsigned short ProfileID sealed ;
J#
public ushort ProfileID
JScript
public ProfileID : UInt16;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_SIMPLE_DESC_RSP.SrcAddr Field
[image]

the message's source network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_SIMPLE_DESC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_SIMPLE_DESC_RSP.ZDO_STATUS
C#
public ZDO_SIMPLE_DESC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_SIMPLE_DESC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_SIMPLE_DESC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_SIMPLE_DESC_RSP.ZDO_STATUS;

See Also

ZDO_SIMPLE_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_RSP.APP_DEV_VER Enumeration

ZDO_SIMPLE_DESC_RSP.APP_DEV_VER Enumeration
[image]

App dev ver

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLE_DESC_RSP.APP_DEV_VER As Byte
C#
public enum ZDO_SIMPLE_DESC_RSP.APP_DEV_VER : byte
C++
public enum class ZDO_SIMPLE_DESC_RSP.APP_DEV_VER : char
J#
public enum ZDO_SIMPLE_DESC_RSP.APP_DEV_VER byte
JScript
public enum ZDO_SIMPLE_DESC_RSP.APP_DEV_VER :

Members

Member Name | Description
VER_100 | App dev ver

See Also

TI.ZPI2 Namespace


ZDO_SIMPLE_DESC_RSP.ZDO_STATUS Enumeration

ZDO_SIMPLE_DESC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_SIMPLE_DESC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_SIMPLE_DESC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_SIMPLE_DESC_RSP.ZDO_STATUS : char
J#
public enum ZDO_SIMPLE_DESC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_SIMPLE_DESC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_SRC_RTG_IND Class

ZDO_SRC_RTG_IND Class
See Also Example Members
[image]

This message is an indication to inform host device the receipt of a source route to a given device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_SRC_RTG_IND
Implements IRESPONSE, IZDO
C#
public class ZDO_SRC_RTG_IND : IRESPONSE, IZDO
C++
ref class ZDO_SRC_RTG_IND : IRESPONSE, IZDO
J#
public class ZDO_SRC_RTG_IND implements IRESPONSE, IZDO
JScript
public class ZDO_SRC_RTG_IND extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_SRC_RTG_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_SRC_RTG_IND Members
TI.ZPI2 Namespace


ZDO_SRC_RTG_IND Members

ZDO_SRC_RTG_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is an indication to inform host device the receipt of a source route to a given device.

The following tables list the members exposed by ZDO_SRC_RTG_IND.

Public Constructors

Name | Description
ZDO_SRC_RTG_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination of the source route
Public field | Relay | The number of devices in the relay list for source routing
Public field | Relay | List of relay devices on the source routing path. For each device, it contains 2 bytes short address for each device.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_SRC_RTG_IND | Overloaded.
Top

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace


ZDO_SRC_RTG_IND Constructor

ZDO_SRC_RTG_IND Constructor

Overload List

 | Name | Description
Public method | ZDO_SRC_RTG_IND | Constructor
Public method | ZDO_SRC_RTG_IND (UInt16, Byte, UInt16) | Constructor

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace


ZDO_SRC_RTG_IND Constructor ()

ZDO_SRC_RTG_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_SRC_RTG_IND()
C++
public:
ZDO_SRC_RTG_IND() sealed
J#
public ZDO_SRC_RTG_IND()
JScript
public function ZDO_SRC_RTG_IND()

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace
ZDO_SRC_RTG_IND Constructor Overload List


ZDO_SRC_RTG_IND Constructor (UInt16, Byte, UInt16[])

ZDO_SRC_RTG_IND Constructor (UInt16, Byte, UInt16[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16() _
)
C#
public ZDO_SRC_RTG_IND(
ushort ,
byte ,
ushort[]
)
C++
public:
ZDO_SRC_RTG_IND(
unsigned short ,
char ,
array<unsigned short>^
) sealed
J#
public ZDO_SRC_RTG_IND(
ushort ,
byte ,
ushort[]
)
JScript
public function ZDO_SRC_RTG_IND(
: UInt16,
: Byte,
: UInt16[]
)

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace
ZDO_SRC_RTG_IND Constructor Overload List


Fields

ZDO_SRC_RTG_IND Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination of the source route
Public field | Relay | The number of devices in the relay list for source routing
Public field | Relay | List of relay devices on the source routing path. For each device, it contains 2 bytes short address for each device.
Top

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_SRC_RTG_IND.DstAddr Field
[image]

Destination of the source route

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP Class

ZDO_STARTUP_FROM_APP Class
See Also Example Members
[image]

In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_STARTUP_FROM_APP
Implements IREQUEST, IZDO
C#
public class ZDO_STARTUP_FROM_APP : IREQUEST, IZDO
C++
ref class ZDO_STARTUP_FROM_APP : IREQUEST, IZDO
J#
public class ZDO_STARTUP_FROM_APP implements IREQUEST, IZDO
JScript
public class ZDO_STARTUP_FROM_APP extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_STARTUP_FROM_APP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_STARTUP_FROM_APP Members
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP Members

ZDO_STARTUP_FROM_APP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

In the case where compiler flag HOLD_AUTO_START is defined by default, device will start from HOLD state. Issuing this command will trigger the device to leave HOLD state to form or join a network.

The following tables list the members exposed by ZDO_STARTUP_FROM_APP.

Public Constructors

Name | Description
ZDO_STARTUP_FROM_APP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Mode | Mode
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_STARTUP_FROM_APP | Overloaded.
Top

See Also

ZDO_STARTUP_FROM_APP Class
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP Constructor

ZDO_STARTUP_FROM_APP Constructor

Overload List

 | Name | Description
Public method | ZDO_STARTUP_FROM_APP | Constructor
Public method | ZDO_STARTUP_FROM_APP (Byte) | Constructor

See Also

ZDO_STARTUP_FROM_APP Class
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP Constructor ()

ZDO_STARTUP_FROM_APP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_STARTUP_FROM_APP()
C++
public:
ZDO_STARTUP_FROM_APP() sealed
J#
public ZDO_STARTUP_FROM_APP()
JScript
public function ZDO_STARTUP_FROM_APP()

See Also

ZDO_STARTUP_FROM_APP Class
TI.ZPI2 Namespace
ZDO_STARTUP_FROM_APP Constructor Overload List


ZDO_STARTUP_FROM_APP Constructor (Byte)

ZDO_STARTUP_FROM_APP Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZDO_STARTUP_FROM_APP(
byte
)
C++
public:
ZDO_STARTUP_FROM_APP(
char
) sealed
J#
public ZDO_STARTUP_FROM_APP(
byte
)
JScript
public function ZDO_STARTUP_FROM_APP(
: Byte
)

See Also

ZDO_STARTUP_FROM_APP Class
TI.ZPI2 Namespace
ZDO_STARTUP_FROM_APP Constructor Overload List


Fields

ZDO_STARTUP_FROM_APP Fields
[image]

Public Fields

 | Name | Description
Public field | Mode | Mode
Top

See Also

ZDO_STARTUP_FROM_APP Class
TI.ZPI2 Namespace


Mode Field

ZDO_STARTUP_FROM_APP.Mode Field
[image]

Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As Byte
C#
public byte Mode;
C++
public:
char Mode sealed ;
J#
public byte Mode
JScript
public Mode : Byte;

See Also

ZDO_STARTUP_FROM_APP Class
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP_SRSP Class

ZDO_STARTUP_FROM_APP_SRSP Class
See Also Example Members
[image]

Response for ZDO_STARTUP_FROM_APP

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_STARTUP_FROM_APP_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_STARTUP_FROM_APP_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_STARTUP_FROM_APP_SRSP : IRESPONSE, IZDO
J#
public class ZDO_STARTUP_FROM_APP_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_STARTUP_FROM_APP_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_STARTUP_FROM_APP_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_STARTUP_FROM_APP_SRSP Members
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP_SRSP Members

ZDO_STARTUP_FROM_APP_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_STARTUP_FROM_APP

The following tables list the members exposed by ZDO_STARTUP_FROM_APP_SRSP.

Public Constructors

Name | Description
ZDO_STARTUP_FROM_APP_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_STARTUP_FROM_APP_SRSP | Overloaded.
Top

See Also

ZDO_STARTUP_FROM_APP_SRSP Class
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP_SRSP Constructor

ZDO_STARTUP_FROM_APP_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_STARTUP_FROM_APP_SRSP | Constructor
Public method | ZDO_STARTUP_FROM_APP_SRSP (ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS) |

See Also

ZDO_STARTUP_FROM_APP_SRSP Class
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP_SRSP Constructor ()

ZDO_STARTUP_FROM_APP_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_STARTUP_FROM_APP_SRSP()
C++
public:
ZDO_STARTUP_FROM_APP_SRSP() sealed
J#
public ZDO_STARTUP_FROM_APP_SRSP()
JScript
public function ZDO_STARTUP_FROM_APP_SRSP()

See Also

ZDO_STARTUP_FROM_APP_SRSP Class
TI.ZPI2 Namespace
ZDO_STARTUP_FROM_APP_SRSP Constructor Overload List


ZDO_STARTUP_FROM_APP_SRSP Constructor (ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS)

ZDO_STARTUP_FROM_APP_SRSP Constructor (ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS _
)
C#
public ZDO_STARTUP_FROM_APP_SRSP(
ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS
)
C++
public:
ZDO_STARTUP_FROM_APP_SRSP(
ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS
) sealed
J#
public ZDO_STARTUP_FROM_APP_SRSP(
ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS
)
JScript
public function ZDO_STARTUP_FROM_APP_SRSP(
: ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS
)

See Also

ZDO_STARTUP_FROM_APP_SRSP Class
TI.ZPI2 Namespace
ZDO_STARTUP_FROM_APP_SRSP Constructor Overload List


Fields

ZDO_STARTUP_FROM_APP_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_STARTUP_FROM_APP_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_STARTUP_FROM_APP_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS
C#
public ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS Status;
C++
public:
ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS;

See Also

ZDO_STARTUP_FROM_APP_SRSP Class
TI.ZPI2 Namespace


ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS Enumeration

ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS : char
J#
public enum ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS byte
JScript
public enum ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_STATE_CHANGE_IND Class

ZDO_STATE_CHANGE_IND Class
See Also Example Members
[image]

ZDO state change indication.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_STATE_CHANGE_IND
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_STATE_CHANGE_IND : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_STATE_CHANGE_IND : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_STATE_CHANGE_IND implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_STATE_CHANGE_IND extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_STATE_CHANGE_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_STATE_CHANGE_IND Members
TI.ZPI2 Namespace


ZDO_STATE_CHANGE_IND Members

ZDO_STATE_CHANGE_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

ZDO state change indication.

The following tables list the members exposed by ZDO_STATE_CHANGE_IND.

Public Constructors

Name | Description
ZDO_STATE_CHANGE_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | State | State
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_STATE_CHANGE_IND | Overloaded.
Top

See Also

ZDO_STATE_CHANGE_IND Class
TI.ZPI2 Namespace


ZDO_STATE_CHANGE_IND Constructor

ZDO_STATE_CHANGE_IND Constructor

Overload List

 | Name | Description
Public method | ZDO_STATE_CHANGE_IND | Constructor
Public method | ZDO_STATE_CHANGE_IND (ZDO_STATE_CHANGE_IND.CMD_STATUS) |

See Also

ZDO_STATE_CHANGE_IND Class
TI.ZPI2 Namespace


ZDO_STATE_CHANGE_IND Constructor ()

ZDO_STATE_CHANGE_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_STATE_CHANGE_IND()
C++
public:
ZDO_STATE_CHANGE_IND() sealed
J#
public ZDO_STATE_CHANGE_IND()
JScript
public function ZDO_STATE_CHANGE_IND()

See Also

ZDO_STATE_CHANGE_IND Class
TI.ZPI2 Namespace
ZDO_STATE_CHANGE_IND Constructor Overload List


ZDO_STATE_CHANGE_IND Constructor (ZDO_STATE_CHANGE_IND.CMD_STATUS)

ZDO_STATE_CHANGE_IND Constructor (ZDO_STATE_CHANGE_IND.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_STATE_CHANGE_IND.CMD_STATUS _
)
C#
public ZDO_STATE_CHANGE_IND(
ZDO_STATE_CHANGE_IND.CMD_STATUS
)
C++
public:
ZDO_STATE_CHANGE_IND(
ZDO_STATE_CHANGE_IND.CMD_STATUS
) sealed
J#
public ZDO_STATE_CHANGE_IND(
ZDO_STATE_CHANGE_IND.CMD_STATUS
)
JScript
public function ZDO_STATE_CHANGE_IND(
: ZDO_STATE_CHANGE_IND.CMD_STATUS
)

See Also

ZDO_STATE_CHANGE_IND Class
TI.ZPI2 Namespace
ZDO_STATE_CHANGE_IND Constructor Overload List


Fields

ZDO_STATE_CHANGE_IND Fields
[image]

Public Fields

 | Name | Description
Public field | State | State
Top

See Also

ZDO_STATE_CHANGE_IND Class
TI.ZPI2 Namespace


State Field

ZDO_STATE_CHANGE_IND.State Field
[image]

State

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public State As ZDO_STATE_CHANGE_IND.CMD_STATUS
C#
public ZDO_STATE_CHANGE_IND.CMD_STATUS State;
C++
public:
ZDO_STATE_CHANGE_IND.CMD_STATUS State sealed ;
J#
public ZDO_STATE_CHANGE_IND.CMD_STATUS State
JScript
public State : ZDO_STATE_CHANGE_IND.CMD_STATUS;

See Also

ZDO_STATE_CHANGE_IND Class
TI.ZPI2 Namespace


ZDO_STATE_CHANGE_IND.CMD_STATUS Enumeration

ZDO_STATE_CHANGE_IND.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_STATE_CHANGE_IND.CMD_STATUS As Byte
C#
public enum ZDO_STATE_CHANGE_IND.CMD_STATUS : byte
C++
public enum class ZDO_STATE_CHANGE_IND.CMD_STATUS : char
J#
public enum ZDO_STATE_CHANGE_IND.CMD_STATUS byte
JScript
public enum ZDO_STATE_CHANGE_IND.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZDO_STATUS_ERROR_RSP Class

ZDO_STATUS_ERROR_RSP Class
See Also Example Members
[image]

This message is the default message for error status.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_STATUS_ERROR_RSP
Implements IRESPONSE, IZDO
C#
public class ZDO_STATUS_ERROR_RSP : IRESPONSE, IZDO
C++
ref class ZDO_STATUS_ERROR_RSP : IRESPONSE, IZDO
J#
public class ZDO_STATUS_ERROR_RSP implements IRESPONSE, IZDO
JScript
public class ZDO_STATUS_ERROR_RSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_STATUS_ERROR_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_STATUS_ERROR_RSP Members
TI.ZPI2 Namespace


ZDO_STATUS_ERROR_RSP Members

ZDO_STATUS_ERROR_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This message is the default message for error status.

The following tables list the members exposed by ZDO_STATUS_ERROR_RSP.

Public Constructors

Name | Description
ZDO_STATUS_ERROR_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | This field indicates either SUCCESS or ZDO Error.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_STATUS_ERROR_RSP | Overloaded.
Top

See Also

ZDO_STATUS_ERROR_RSP Class
TI.ZPI2 Namespace


ZDO_STATUS_ERROR_RSP Constructor

ZDO_STATUS_ERROR_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_STATUS_ERROR_RSP | Constructor
Public method | ZDO_STATUS_ERROR_RSP (UInt16, ZDO_STATUS_ERROR_RSP.ZDO_STATUS) |

See Also

ZDO_STATUS_ERROR_RSP Class
TI.ZPI2 Namespace


ZDO_STATUS_ERROR_RSP Constructor ()

ZDO_STATUS_ERROR_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_STATUS_ERROR_RSP()
C++
public:
ZDO_STATUS_ERROR_RSP() sealed
J#
public ZDO_STATUS_ERROR_RSP()
JScript
public function ZDO_STATUS_ERROR_RSP()

See Also

ZDO_STATUS_ERROR_RSP Class
TI.ZPI2 Namespace
ZDO_STATUS_ERROR_RSP Constructor Overload List


ZDO_STATUS_ERROR_RSP Constructor (UInt16, ZDO_STATUS_ERROR_RSP.ZDO_STATUS)

ZDO_STATUS_ERROR_RSP Constructor (UInt16, ZDO_STATUS_ERROR_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_STATUS_ERROR_RSP.ZDO_STATUS _
)
C#
public ZDO_STATUS_ERROR_RSP(
ushort ,
ZDO_STATUS_ERROR_RSP.ZDO_STATUS
)
C++
public:
ZDO_STATUS_ERROR_RSP(
unsigned short ,
ZDO_STATUS_ERROR_RSP.ZDO_STATUS
) sealed
J#
public ZDO_STATUS_ERROR_RSP(
ushort ,
ZDO_STATUS_ERROR_RSP.ZDO_STATUS
)
JScript
public function ZDO_STATUS_ERROR_RSP(
: UInt16,
: ZDO_STATUS_ERROR_RSP.ZDO_STATUS
)

See Also

ZDO_STATUS_ERROR_RSP Class
TI.ZPI2 Namespace
ZDO_STATUS_ERROR_RSP Constructor Overload List


Fields

ZDO_STATUS_ERROR_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | Source address of the message
Public field | Status | This field indicates either SUCCESS or ZDO Error.
Top

See Also

ZDO_STATUS_ERROR_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_STATUS_ERROR_RSP.SrcAddr Field
[image]

Source address of the message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_STATUS_ERROR_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_STATUS_ERROR_RSP.Status Field
[image]

This field indicates either SUCCESS or ZDO Error.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_STATUS_ERROR_RSP.ZDO_STATUS
C#
public ZDO_STATUS_ERROR_RSP.ZDO_STATUS Status;
C++
public:
ZDO_STATUS_ERROR_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_STATUS_ERROR_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_STATUS_ERROR_RSP.ZDO_STATUS;

See Also

ZDO_STATUS_ERROR_RSP Class
TI.ZPI2 Namespace


ZDO_STATUS_ERROR_RSP.ZDO_STATUS Enumeration

ZDO_STATUS_ERROR_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_STATUS_ERROR_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_STATUS_ERROR_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_STATUS_ERROR_RSP.ZDO_STATUS : char
J#
public enum ZDO_STATUS_ERROR_RSP.ZDO_STATUS byte
JScript
public enum ZDO_STATUS_ERROR_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_UNBIND_REQ Class

ZDO_UNBIND_REQ Class
See Also Example Members
[image]

This command is generated to request an UnBind

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_UNBIND_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_UNBIND_REQ : IREQUEST, IZDO
C++
ref class ZDO_UNBIND_REQ : IREQUEST, IZDO
J#
public class ZDO_UNBIND_REQ implements IREQUEST, IZDO
JScript
public class ZDO_UNBIND_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_UNBIND_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_UNBIND_REQ Members
TI.ZPI2 Namespace


ZDO_UNBIND_REQ Members

ZDO_UNBIND_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request an UnBind

The following tables list the members exposed by ZDO_UNBIND_REQ.

Public Constructors

Name | Description
ZDO_UNBIND_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | DstAddress | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | DstEndpoint | Binding destination endpoint. See Table 1 for formatting
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_UNBIND_REQ | Overloaded.
Top

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


ZDO_UNBIND_REQ Constructor

ZDO_UNBIND_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_UNBIND_REQ | Constructor
Public method | ZDO_UNBIND_REQ (UInt16, UInt64, Byte, UInt16, ZDO_UNBIND_REQ.ADDRESS_MODE, Byte, Byte) |

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


ZDO_UNBIND_REQ Constructor ()

ZDO_UNBIND_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_UNBIND_REQ()
C++
public:
ZDO_UNBIND_REQ() sealed
J#
public ZDO_UNBIND_REQ()
JScript
public function ZDO_UNBIND_REQ()

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace
ZDO_UNBIND_REQ Constructor Overload List


ZDO_UNBIND_REQ Constructor (UInt16, UInt64, Byte, UInt16, ZDO_UNBIND_REQ.ADDRESS_MODE, Byte[], Byte)

ZDO_UNBIND_REQ Constructor (UInt16, UInt64, Byte, UInt16, ZDO_UNBIND_REQ.ADDRESS_MODE, Byte[], Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As ZDO_UNBIND_REQ.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As Byte _
)
C#
public ZDO_UNBIND_REQ(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_UNBIND_REQ.ADDRESS_MODE ,
byte[] ,
byte
)
C++
public:
ZDO_UNBIND_REQ(
unsigned short ,
unsigned __int64 ,
char ,
unsigned short ,
ZDO_UNBIND_REQ.ADDRESS_MODE ,
array<char>^ ,
char
) sealed
J#
public ZDO_UNBIND_REQ(
ushort ,
ulong ,
byte ,
ushort ,
ZDO_UNBIND_REQ.ADDRESS_MODE ,
byte[] ,
byte
)
JScript
public function ZDO_UNBIND_REQ(
: UInt16,
: UInt64,
: Byte,
: UInt16,
: ZDO_UNBIND_REQ.ADDRESS_MODE,
: Byte[],
: Byte
)

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace
ZDO_UNBIND_REQ Constructor Overload List


Fields

ZDO_UNBIND_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | ClusterID | Cluster ID to match in messages
Public field | DstAddr | destination address, where this message is going
Public field | DstAddress | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | DstEndpoint | Binding destination endpoint. See Table 1 for formatting
Public field | SrcAddress | 64 bit Binding source address
Public field | SrcEndpoint | Binding source endpoint
Top

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


ClusterID Field

ZDO_UNBIND_REQ.ClusterID Field
[image]

Cluster ID to match in messages

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ClusterID As UInt16
C#
public ushort ClusterID;
C++
public:
unsigned short ClusterID sealed ;
J#
public ushort ClusterID
JScript
public ClusterID : UInt16;

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_UNBIND_REQ.DstAddr Field
[image]

destination address, where this message is going

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


DstAddress Field

ZDO_UNBIND_REQ.DstAddress Field
[image]

The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddress As Byte()
C#
public byte[] DstAddress;
C++
public:
array<char>^ DstAddress sealed ;
J#
public byte[] DstAddress
JScript
public DstAddress : Byte[];

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


DstAddrMode Field

ZDO_UNBIND_REQ.DstAddrMode Field
[image]

The destination address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As ZDO_UNBIND_REQ.ADDRESS_MODE
C#
public ZDO_UNBIND_REQ.ADDRESS_MODE DstAddrMode;
C++
public:
ZDO_UNBIND_REQ.ADDRESS_MODE DstAddrMode sealed ;
J#
public ZDO_UNBIND_REQ.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : ZDO_UNBIND_REQ.ADDRESS_MODE;

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


DstEndpoint Field

ZDO_UNBIND_REQ.DstEndpoint Field
[image]

Binding destination endpoint. See Table 1 for formatting

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstEndpoint As Byte
C#
public byte DstEndpoint;
C++
public:
char DstEndpoint sealed ;
J#
public byte DstEndpoint
JScript
public DstEndpoint : Byte;

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


SrcAddress Field

ZDO_UNBIND_REQ.SrcAddress Field
[image]

64 bit Binding source address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddress As UInt64
C#
public ulong SrcAddress;
C++
public:
unsigned __int64 SrcAddress sealed ;
J#
public ulong SrcAddress
JScript
public SrcAddress : UInt64;

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


SrcEndpoint Field

ZDO_UNBIND_REQ.SrcEndpoint Field
[image]

Binding source endpoint

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcEndpoint As Byte
C#
public byte SrcEndpoint;
C++
public:
char SrcEndpoint sealed ;
J#
public byte SrcEndpoint
JScript
public SrcEndpoint : Byte;

See Also

ZDO_UNBIND_REQ Class
TI.ZPI2 Namespace


ZDO_UNBIND_REQ.ADDRESS_MODE Enumeration

ZDO_UNBIND_REQ.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_UNBIND_REQ.ADDRESS_MODE As Byte
C#
public enum ZDO_UNBIND_REQ.ADDRESS_MODE : byte
C++
public enum class ZDO_UNBIND_REQ.ADDRESS_MODE : char
J#
public enum ZDO_UNBIND_REQ.ADDRESS_MODE byte
JScript
public enum ZDO_UNBIND_REQ.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZDO_UNBIND_REQ_SRSP Class

ZDO_UNBIND_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_UNBIND_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_UNBIND_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_UNBIND_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_UNBIND_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_UNBIND_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_UNBIND_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_UNBIND_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_UNBIND_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_UNBIND_REQ_SRSP Members

ZDO_UNBIND_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_UNBIND_REQ

The following tables list the members exposed by ZDO_UNBIND_REQ_SRSP.

Public Constructors

Name | Description
ZDO_UNBIND_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_UNBIND_REQ_SRSP | Overloaded.
Top

See Also

ZDO_UNBIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_UNBIND_REQ_SRSP Constructor

ZDO_UNBIND_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_UNBIND_REQ_SRSP | Constructor
Public method | ZDO_UNBIND_REQ_SRSP (ZDO_UNBIND_REQ_SRSP.AF_STATUS) |

See Also

ZDO_UNBIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_UNBIND_REQ_SRSP Constructor ()

ZDO_UNBIND_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_UNBIND_REQ_SRSP()
C++
public:
ZDO_UNBIND_REQ_SRSP() sealed
J#
public ZDO_UNBIND_REQ_SRSP()
JScript
public function ZDO_UNBIND_REQ_SRSP()

See Also

ZDO_UNBIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_UNBIND_REQ_SRSP Constructor Overload List


ZDO_UNBIND_REQ_SRSP Constructor (ZDO_UNBIND_REQ_SRSP.AF_STATUS)

ZDO_UNBIND_REQ_SRSP Constructor (ZDO_UNBIND_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_UNBIND_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_UNBIND_REQ_SRSP(
ZDO_UNBIND_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_UNBIND_REQ_SRSP(
ZDO_UNBIND_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_UNBIND_REQ_SRSP(
ZDO_UNBIND_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_UNBIND_REQ_SRSP(
: ZDO_UNBIND_REQ_SRSP.AF_STATUS
)

See Also

ZDO_UNBIND_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_UNBIND_REQ_SRSP Constructor Overload List


Fields

ZDO_UNBIND_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_UNBIND_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_UNBIND_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_UNBIND_REQ_SRSP.AF_STATUS
C#
public ZDO_UNBIND_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_UNBIND_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_UNBIND_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_UNBIND_REQ_SRSP.AF_STATUS;

See Also

ZDO_UNBIND_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_UNBIND_REQ_SRSP.AF_STATUS Enumeration

ZDO_UNBIND_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_UNBIND_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_UNBIND_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_UNBIND_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_UNBIND_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_UNBIND_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_UNBIND_RSP Class

ZDO_UNBIND_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO UnBind Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_UNBIND_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_UNBIND_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_UNBIND_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_UNBIND_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_UNBIND_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_UNBIND_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_UNBIND_RSP Members
TI.ZPI2 Namespace


ZDO_UNBIND_RSP Members

ZDO_UNBIND_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO UnBind Request

The following tables list the members exposed by ZDO_UNBIND_RSP.

Public Constructors

Name | Description
ZDO_UNBIND_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_UNBIND_RSP | Overloaded.
Top

See Also

ZDO_UNBIND_RSP Class
TI.ZPI2 Namespace


ZDO_UNBIND_RSP Constructor

ZDO_UNBIND_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_UNBIND_RSP | Constructor
Public method | ZDO_UNBIND_RSP (UInt16, ZDO_UNBIND_RSP.ZDO_STATUS) |

See Also

ZDO_UNBIND_RSP Class
TI.ZPI2 Namespace


ZDO_UNBIND_RSP Constructor ()

ZDO_UNBIND_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_UNBIND_RSP()
C++
public:
ZDO_UNBIND_RSP() sealed
J#
public ZDO_UNBIND_RSP()
JScript
public function ZDO_UNBIND_RSP()

See Also

ZDO_UNBIND_RSP Class
TI.ZPI2 Namespace
ZDO_UNBIND_RSP Constructor Overload List


ZDO_UNBIND_RSP Constructor (UInt16, ZDO_UNBIND_RSP.ZDO_STATUS)

ZDO_UNBIND_RSP Constructor (UInt16, ZDO_UNBIND_RSP.ZDO_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_UNBIND_RSP.ZDO_STATUS _
)
C#
public ZDO_UNBIND_RSP(
ushort ,
ZDO_UNBIND_RSP.ZDO_STATUS
)
C++
public:
ZDO_UNBIND_RSP(
unsigned short ,
ZDO_UNBIND_RSP.ZDO_STATUS
) sealed
J#
public ZDO_UNBIND_RSP(
ushort ,
ZDO_UNBIND_RSP.ZDO_STATUS
)
JScript
public function ZDO_UNBIND_RSP(
: UInt16,
: ZDO_UNBIND_RSP.ZDO_STATUS
)

See Also

ZDO_UNBIND_RSP Class
TI.ZPI2 Namespace
ZDO_UNBIND_RSP Constructor Overload List


Fields

ZDO_UNBIND_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_UNBIND_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_UNBIND_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_UNBIND_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_UNBIND_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_UNBIND_RSP.ZDO_STATUS
C#
public ZDO_UNBIND_RSP.ZDO_STATUS Status;
C++
public:
ZDO_UNBIND_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_UNBIND_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_UNBIND_RSP.ZDO_STATUS;

See Also

ZDO_UNBIND_RSP Class
TI.ZPI2 Namespace


ZDO_UNBIND_RSP.ZDO_STATUS Enumeration

ZDO_UNBIND_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_UNBIND_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_UNBIND_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_UNBIND_RSP.ZDO_STATUS : char
J#
public enum ZDO_UNBIND_RSP.ZDO_STATUS byte
JScript
public enum ZDO_UNBIND_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_USER_DESC_CONF Class

ZDO_USER_DESC_CONF Class
See Also Example Members
[image]

This callback message is in response to the ZDO User Descriptor Set Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USER_DESC_CONF
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_USER_DESC_CONF : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_USER_DESC_CONF : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_USER_DESC_CONF implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_USER_DESC_CONF extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_USER_DESC_CONF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USER_DESC_CONF Members
TI.ZPI2 Namespace


ZDO_USER_DESC_CONF Members

ZDO_USER_DESC_CONF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO User Descriptor Set Request.

The following tables list the members exposed by ZDO_USER_DESC_CONF.

Public Constructors

Name | Description
ZDO_USER_DESC_CONF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USER_DESC_CONF | Overloaded.
Top

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace


ZDO_USER_DESC_CONF Constructor

ZDO_USER_DESC_CONF Constructor

Overload List

 | Name | Description
Public method | ZDO_USER_DESC_CONF | Constructor
Public method | ZDO_USER_DESC_CONF (UInt16, ZDO_USER_DESC_CONF.ZDO_STATUS, UInt16) |

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace


ZDO_USER_DESC_CONF Constructor ()

ZDO_USER_DESC_CONF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USER_DESC_CONF()
C++
public:
ZDO_USER_DESC_CONF() sealed
J#
public ZDO_USER_DESC_CONF()
JScript
public function ZDO_USER_DESC_CONF()

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace
ZDO_USER_DESC_CONF Constructor Overload List


ZDO_USER_DESC_CONF Constructor (UInt16, ZDO_USER_DESC_CONF.ZDO_STATUS, UInt16)

ZDO_USER_DESC_CONF Constructor (UInt16, ZDO_USER_DESC_CONF.ZDO_STATUS, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_USER_DESC_CONF.ZDO_STATUS, _
ByVal As UInt16 _
)
C#
public ZDO_USER_DESC_CONF(
ushort ,
ZDO_USER_DESC_CONF.ZDO_STATUS ,
ushort
)
C++
public:
ZDO_USER_DESC_CONF(
unsigned short ,
ZDO_USER_DESC_CONF.ZDO_STATUS ,
unsigned short
) sealed
J#
public ZDO_USER_DESC_CONF(
ushort ,
ZDO_USER_DESC_CONF.ZDO_STATUS ,
ushort
)
JScript
public function ZDO_USER_DESC_CONF(
: UInt16,
: ZDO_USER_DESC_CONF.ZDO_STATUS,
: UInt16
)

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace
ZDO_USER_DESC_CONF Constructor Overload List


Fields

ZDO_USER_DESC_CONF Fields
[image]

Public Fields

 | Name | Description
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Top

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_USER_DESC_CONF.NwkAddr Field
[image]

Device's short address that this response describes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_USER_DESC_CONF.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace


Status Field

ZDO_USER_DESC_CONF.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USER_DESC_CONF.ZDO_STATUS
C#
public ZDO_USER_DESC_CONF.ZDO_STATUS Status;
C++
public:
ZDO_USER_DESC_CONF.ZDO_STATUS Status sealed ;
J#
public ZDO_USER_DESC_CONF.ZDO_STATUS Status
JScript
public Status : ZDO_USER_DESC_CONF.ZDO_STATUS;

See Also

ZDO_USER_DESC_CONF Class
TI.ZPI2 Namespace


ZDO_USER_DESC_CONF.ZDO_STATUS Enumeration

ZDO_USER_DESC_CONF.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USER_DESC_CONF.ZDO_STATUS As Byte
C#
public enum ZDO_USER_DESC_CONF.ZDO_STATUS : byte
C++
public enum class ZDO_USER_DESC_CONF.ZDO_STATUS : char
J#
public enum ZDO_USER_DESC_CONF.ZDO_STATUS byte
JScript
public enum ZDO_USER_DESC_CONF.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_USER_DESC_REQ Class

ZDO_USER_DESC_REQ Class
See Also Example Members
[image]

This command is generated to request for the destination device's user descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USER_DESC_REQ
Implements IREQUEST, IZDO
C#
public class ZDO_USER_DESC_REQ : IREQUEST, IZDO
C++
ref class ZDO_USER_DESC_REQ : IREQUEST, IZDO
J#
public class ZDO_USER_DESC_REQ implements IREQUEST, IZDO
JScript
public class ZDO_USER_DESC_REQ extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_USER_DESC_REQ

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USER_DESC_REQ Members
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ Members

ZDO_USER_DESC_REQ Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request for the destination device's user descriptor

The following tables list the members exposed by ZDO_USER_DESC_REQ.

Public Constructors

Name | Description
ZDO_USER_DESC_REQ | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USER_DESC_REQ | Overloaded.
Top

See Also

ZDO_USER_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ Constructor

ZDO_USER_DESC_REQ Constructor

Overload List

 | Name | Description
Public method | ZDO_USER_DESC_REQ | Constructor
Public method | ZDO_USER_DESC_REQ (UInt16, UInt16) | Constructor

See Also

ZDO_USER_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ Constructor ()

ZDO_USER_DESC_REQ Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USER_DESC_REQ()
C++
public:
ZDO_USER_DESC_REQ() sealed
J#
public ZDO_USER_DESC_REQ()
JScript
public function ZDO_USER_DESC_REQ()

See Also

ZDO_USER_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_USER_DESC_REQ Constructor Overload List


ZDO_USER_DESC_REQ Constructor (UInt16, UInt16)

ZDO_USER_DESC_REQ Constructor (UInt16, UInt16)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16 _
)
C#
public ZDO_USER_DESC_REQ(
ushort ,
ushort
)
C++
public:
ZDO_USER_DESC_REQ(
unsigned short ,
unsigned short
) sealed
J#
public ZDO_USER_DESC_REQ(
ushort ,
ushort
)
JScript
public function ZDO_USER_DESC_REQ(
: UInt16,
: UInt16
)

See Also

ZDO_USER_DESC_REQ Class
TI.ZPI2 Namespace
ZDO_USER_DESC_REQ Constructor Overload List


Fields

ZDO_USER_DESC_REQ Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | destination address
Public field | NWKAddrOfInterest | NWK address for the request
Top

See Also

ZDO_USER_DESC_REQ Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_USER_DESC_REQ.DstAddr Field
[image]

destination address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_USER_DESC_REQ Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_USER_DESC_REQ.NWKAddrOfInterest Field
[image]

NWK address for the request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_USER_DESC_REQ Class
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ_SRSP Class

ZDO_USER_DESC_REQ_SRSP Class
See Also Example Members
[image]

Response for ZDO_USER_DESC_REQ

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USER_DESC_REQ_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_USER_DESC_REQ_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_USER_DESC_REQ_SRSP : IRESPONSE, IZDO
J#
public class ZDO_USER_DESC_REQ_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_USER_DESC_REQ_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_USER_DESC_REQ_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USER_DESC_REQ_SRSP Members
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ_SRSP Members

ZDO_USER_DESC_REQ_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_USER_DESC_REQ

The following tables list the members exposed by ZDO_USER_DESC_REQ_SRSP.

Public Constructors

Name | Description
ZDO_USER_DESC_REQ_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USER_DESC_REQ_SRSP | Overloaded.
Top

See Also

ZDO_USER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ_SRSP Constructor

ZDO_USER_DESC_REQ_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_USER_DESC_REQ_SRSP | Constructor
Public method | ZDO_USER_DESC_REQ_SRSP (ZDO_USER_DESC_REQ_SRSP.AF_STATUS) |

See Also

ZDO_USER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ_SRSP Constructor ()

ZDO_USER_DESC_REQ_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USER_DESC_REQ_SRSP()
C++
public:
ZDO_USER_DESC_REQ_SRSP() sealed
J#
public ZDO_USER_DESC_REQ_SRSP()
JScript
public function ZDO_USER_DESC_REQ_SRSP()

See Also

ZDO_USER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_USER_DESC_REQ_SRSP Constructor Overload List


ZDO_USER_DESC_REQ_SRSP Constructor (ZDO_USER_DESC_REQ_SRSP.AF_STATUS)

ZDO_USER_DESC_REQ_SRSP Constructor (ZDO_USER_DESC_REQ_SRSP.AF_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_USER_DESC_REQ_SRSP.AF_STATUS _
)
C#
public ZDO_USER_DESC_REQ_SRSP(
ZDO_USER_DESC_REQ_SRSP.AF_STATUS
)
C++
public:
ZDO_USER_DESC_REQ_SRSP(
ZDO_USER_DESC_REQ_SRSP.AF_STATUS
) sealed
J#
public ZDO_USER_DESC_REQ_SRSP(
ZDO_USER_DESC_REQ_SRSP.AF_STATUS
)
JScript
public function ZDO_USER_DESC_REQ_SRSP(
: ZDO_USER_DESC_REQ_SRSP.AF_STATUS
)

See Also

ZDO_USER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace
ZDO_USER_DESC_REQ_SRSP Constructor Overload List


Fields

ZDO_USER_DESC_REQ_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_USER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_USER_DESC_REQ_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USER_DESC_REQ_SRSP.AF_STATUS
C#
public ZDO_USER_DESC_REQ_SRSP.AF_STATUS Status;
C++
public:
ZDO_USER_DESC_REQ_SRSP.AF_STATUS Status sealed ;
J#
public ZDO_USER_DESC_REQ_SRSP.AF_STATUS Status
JScript
public Status : ZDO_USER_DESC_REQ_SRSP.AF_STATUS;

See Also

ZDO_USER_DESC_REQ_SRSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_REQ_SRSP.AF_STATUS Enumeration

ZDO_USER_DESC_REQ_SRSP.AF_STATUS Enumeration
[image]

Status code for AF responses

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USER_DESC_REQ_SRSP.AF_STATUS As Byte
C#
public enum ZDO_USER_DESC_REQ_SRSP.AF_STATUS : byte
C++
public enum class ZDO_USER_DESC_REQ_SRSP.AF_STATUS : char
J#
public enum ZDO_USER_DESC_REQ_SRSP.AF_STATUS byte
JScript
public enum ZDO_USER_DESC_REQ_SRSP.AF_STATUS :

Members

Member Name | Description
afStatus_SUCCESS | Status code for AF responses
afStatus_FAILED | Status code for AF responses
afStatus_INVALID_PARAMETER | Status code for AF responses
afStatus_MEM_FAIL | Status code for AF responses
afStatus_NO_ROUTE | Status code for AF responses

See Also

TI.ZPI2 Namespace


ZDO_USER_DESC_RSP Class

ZDO_USER_DESC_RSP Class
See Also Example Members
[image]

This callback message is in response to the ZDO User Description Request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USER_DESC_RSP
Implements IRESPONSE_CALLBACK, IZDO
C#
public class ZDO_USER_DESC_RSP : IRESPONSE_CALLBACK, IZDO
C++
ref class ZDO_USER_DESC_RSP : IRESPONSE_CALLBACK, IZDO
J#
public class ZDO_USER_DESC_RSP implements IRESPONSE_CALLBACK, IZDO
JScript
public class ZDO_USER_DESC_RSP extends IRESPONSE_CALLBACK, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_USER_DESC_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USER_DESC_RSP Members
TI.ZPI2 Namespace


ZDO_USER_DESC_RSP Members

ZDO_USER_DESC_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This callback message is in response to the ZDO User Description Request.

The following tables list the members exposed by ZDO_USER_DESC_RSP.

Public Constructors

Name | Description
ZDO_USER_DESC_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Public field | UserDescriptor | Array of bytes contains user descriptor.
Public field | UserLength | Length of the user descriptor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USER_DESC_RSP | Overloaded.
Top

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_RSP Constructor

ZDO_USER_DESC_RSP Constructor

Overload List

 | Name | Description
Public method | ZDO_USER_DESC_RSP | Constructor
Public method | ZDO_USER_DESC_RSP (UInt16, ZDO_USER_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte) |

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_RSP Constructor ()

ZDO_USER_DESC_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USER_DESC_RSP()
C++
public:
ZDO_USER_DESC_RSP() sealed
J#
public ZDO_USER_DESC_RSP()
JScript
public function ZDO_USER_DESC_RSP()

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_USER_DESC_RSP Constructor Overload List


ZDO_USER_DESC_RSP Constructor (UInt16, ZDO_USER_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte[])

ZDO_USER_DESC_RSP Constructor (UInt16, ZDO_USER_DESC_RSP.ZDO_STATUS, UInt16, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As ZDO_USER_DESC_RSP.ZDO_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_USER_DESC_RSP(
ushort ,
ZDO_USER_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_USER_DESC_RSP(
unsigned short ,
ZDO_USER_DESC_RSP.ZDO_STATUS ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_USER_DESC_RSP(
ushort ,
ZDO_USER_DESC_RSP.ZDO_STATUS ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_USER_DESC_RSP(
: UInt16,
: ZDO_USER_DESC_RSP.ZDO_STATUS,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace
ZDO_USER_DESC_RSP Constructor Overload List


Fields

ZDO_USER_DESC_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | NwkAddr | Device's short address that this response describes
Public field | SrcAddr | the message's source network address
Public field | Status | this field indicates either SUCCESS or FAILURE
Public field | UserDescriptor | Array of bytes contains user descriptor.
Public field | UserLength | Length of the user descriptor
Top

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


NwkAddr Field

ZDO_USER_DESC_RSP.NwkAddr Field
[image]

Device's short address that this response describes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddr As UInt16
C#
public ushort NwkAddr;
C++
public:
unsigned short NwkAddr sealed ;
J#
public ushort NwkAddr
JScript
public NwkAddr : UInt16;

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


SrcAddr Field

ZDO_USER_DESC_RSP.SrcAddr Field
[image]

the message's source network address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As UInt16
C#
public ushort SrcAddr;
C++
public:
unsigned short SrcAddr sealed ;
J#
public ushort SrcAddr
JScript
public SrcAddr : UInt16;

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


Status Field

ZDO_USER_DESC_RSP.Status Field
[image]

this field indicates either SUCCESS or FAILURE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USER_DESC_RSP.ZDO_STATUS
C#
public ZDO_USER_DESC_RSP.ZDO_STATUS Status;
C++
public:
ZDO_USER_DESC_RSP.ZDO_STATUS Status sealed ;
J#
public ZDO_USER_DESC_RSP.ZDO_STATUS Status
JScript
public Status : ZDO_USER_DESC_RSP.ZDO_STATUS;

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


UserDescriptor Field

ZDO_USER_DESC_RSP.UserDescriptor Field
[image]

Array of bytes contains user descriptor.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UserDescriptor As Byte()
C#
public byte[] UserDescriptor;
C++
public:
array<char>^ UserDescriptor sealed ;
J#
public byte[] UserDescriptor
JScript
public UserDescriptor : Byte[];

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


UserLength Field

ZDO_USER_DESC_RSP.UserLength Field
[image]

Length of the user descriptor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UserLength As Byte
C#
public byte UserLength;
C++
public:
char UserLength sealed ;
J#
public byte UserLength
JScript
public UserLength : Byte;

See Also

ZDO_USER_DESC_RSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_RSP.ZDO_STATUS Enumeration

ZDO_USER_DESC_RSP.ZDO_STATUS Enumeration
[image]

ZDO status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USER_DESC_RSP.ZDO_STATUS As Byte
C#
public enum ZDO_USER_DESC_RSP.ZDO_STATUS : byte
C++
public enum class ZDO_USER_DESC_RSP.ZDO_STATUS : char
J#
public enum ZDO_USER_DESC_RSP.ZDO_STATUS byte
JScript
public enum ZDO_USER_DESC_RSP.ZDO_STATUS :

Members

Member Name | Description
ZDP_SUCCESS | ZDO status
ZDP_INVALID_REQTYPE | ZDO status
ZDP_DEVICE_NOT_FOUND | ZDO status
ZDP_INVALID_EP | ZDO status
ZDP_NOT_ACTIVE | ZDO status
ZDP_NOT_SUPPORTED | ZDO status
ZDP_TIMEOUT | ZDO status
ZDP_NO_MATCH | ZDO status
ZDP_TABLE_FULL | ZDO status
ZDP_NO_ENTRY | ZDO status

See Also

TI.ZPI2 Namespace


ZDO_USER_DESC_SET Class

ZDO_USER_DESC_SET Class
See Also Example Members
[image]

This command is generated to request a User Descriptor Set Request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USER_DESC_SET
Implements IREQUEST, IZDO
C#
public class ZDO_USER_DESC_SET : IREQUEST, IZDO
C++
ref class ZDO_USER_DESC_SET : IREQUEST, IZDO
J#
public class ZDO_USER_DESC_SET implements IREQUEST, IZDO
JScript
public class ZDO_USER_DESC_SET extends IREQUEST, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_USER_DESC_SET

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USER_DESC_SET Members
TI.ZPI2 Namespace


ZDO_USER_DESC_SET Members

ZDO_USER_DESC_SET Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is generated to request a User Descriptor Set Request

The following tables list the members exposed by ZDO_USER_DESC_SET.

Public Constructors

Name | Description
ZDO_USER_DESC_SET | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | Len | Length, in bytes, of the user descriptor.
Public field | NWKAddrOfInterest | NWK address for the request.
Public field | UserDescriptor | User descriptor array
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USER_DESC_SET | Overloaded.
Top

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace


ZDO_USER_DESC_SET Constructor

ZDO_USER_DESC_SET Constructor

Overload List

 | Name | Description
Public method | ZDO_USER_DESC_SET | Constructor
Public method | ZDO_USER_DESC_SET (UInt16, UInt16, Byte, Byte) | Constructor

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace


ZDO_USER_DESC_SET Constructor ()

ZDO_USER_DESC_SET Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USER_DESC_SET()
C++
public:
ZDO_USER_DESC_SET() sealed
J#
public ZDO_USER_DESC_SET()
JScript
public function ZDO_USER_DESC_SET()

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace
ZDO_USER_DESC_SET Constructor Overload List


ZDO_USER_DESC_SET Constructor (UInt16, UInt16, Byte, Byte[])

ZDO_USER_DESC_SET Constructor (UInt16, UInt16, Byte, Byte[])
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZDO_USER_DESC_SET(
ushort ,
ushort ,
byte ,
byte[]
)
C++
public:
ZDO_USER_DESC_SET(
unsigned short ,
unsigned short ,
char ,
array<char>^
) sealed
J#
public ZDO_USER_DESC_SET(
ushort ,
ushort ,
byte ,
byte[]
)
JScript
public function ZDO_USER_DESC_SET(
: UInt16,
: UInt16,
: Byte,
: Byte[]
)

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace
ZDO_USER_DESC_SET Constructor Overload List


Fields

ZDO_USER_DESC_SET Fields
[image]

Public Fields

 | Name | Description
Public field | DstAddr | Destination network address.
Public field | Len | Length, in bytes, of the user descriptor.
Public field | NWKAddrOfInterest | NWK address for the request.
Public field | UserDescriptor | User descriptor array
Top

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace


DstAddr Field

ZDO_USER_DESC_SET.DstAddr Field
[image]

Destination network address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As UInt16
C#
public ushort DstAddr;
C++
public:
unsigned short DstAddr sealed ;
J#
public ushort DstAddr
JScript
public DstAddr : UInt16;

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace


Len Field

ZDO_USER_DESC_SET.Len Field
[image]

Length, in bytes, of the user descriptor.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Len As Byte
C#
public byte Len;
C++
public:
char Len sealed ;
J#
public byte Len
JScript
public Len : Byte;

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace


NWKAddrOfInterest Field

ZDO_USER_DESC_SET.NWKAddrOfInterest Field
[image]

NWK address for the request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NWKAddrOfInterest As UInt16
C#
public ushort NWKAddrOfInterest;
C++
public:
unsigned short NWKAddrOfInterest sealed ;
J#
public ushort NWKAddrOfInterest
JScript
public NWKAddrOfInterest : UInt16;

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace


UserDescriptor Field

ZDO_USER_DESC_SET.UserDescriptor Field
[image]

User descriptor array

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UserDescriptor As Byte()
C#
public byte[] UserDescriptor;
C++
public:
array<char>^ UserDescriptor sealed ;
J#
public byte[] UserDescriptor
JScript
public UserDescriptor : Byte[];

See Also

ZDO_USER_DESC_SET Class
TI.ZPI2 Namespace


ZDO_USER_DESC_SET_SRSP Class

ZDO_USER_DESC_SET_SRSP Class
See Also Example Members
[image]

Response for ZDO_USER_DESC_SET

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZDO_USER_DESC_SET_SRSP
Implements IRESPONSE, IZDO
C#
public class ZDO_USER_DESC_SET_SRSP : IRESPONSE, IZDO
C++
ref class ZDO_USER_DESC_SET_SRSP : IRESPONSE, IZDO
J#
public class ZDO_USER_DESC_SET_SRSP implements IRESPONSE, IZDO
JScript
public class ZDO_USER_DESC_SET_SRSP extends IRESPONSE, IZDO

Inheritance Hierarchy

System.Object
TI.ZPI2.ZDO_USER_DESC_SET_SRSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZDO_USER_DESC_SET_SRSP Members
TI.ZPI2 Namespace


ZDO_USER_DESC_SET_SRSP Members

ZDO_USER_DESC_SET_SRSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZDO_USER_DESC_SET

The following tables list the members exposed by ZDO_USER_DESC_SET_SRSP.

Public Constructors

Name | Description
ZDO_USER_DESC_SET_SRSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZDO_USER_DESC_SET_SRSP | Overloaded.
Top

See Also

ZDO_USER_DESC_SET_SRSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_SET_SRSP Constructor

ZDO_USER_DESC_SET_SRSP Constructor

Overload List

 | Name | Description
Public method | ZDO_USER_DESC_SET_SRSP | Constructor
Public method | ZDO_USER_DESC_SET_SRSP (ZDO_USER_DESC_SET_SRSP.CMD_STATUS) |

See Also

ZDO_USER_DESC_SET_SRSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_SET_SRSP Constructor ()

ZDO_USER_DESC_SET_SRSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZDO_USER_DESC_SET_SRSP()
C++
public:
ZDO_USER_DESC_SET_SRSP() sealed
J#
public ZDO_USER_DESC_SET_SRSP()
JScript
public function ZDO_USER_DESC_SET_SRSP()

See Also

ZDO_USER_DESC_SET_SRSP Class
TI.ZPI2 Namespace
ZDO_USER_DESC_SET_SRSP Constructor Overload List


ZDO_USER_DESC_SET_SRSP Constructor (ZDO_USER_DESC_SET_SRSP.CMD_STATUS)

ZDO_USER_DESC_SET_SRSP Constructor (ZDO_USER_DESC_SET_SRSP.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZDO_USER_DESC_SET_SRSP.CMD_STATUS _
)
C#
public ZDO_USER_DESC_SET_SRSP(
ZDO_USER_DESC_SET_SRSP.CMD_STATUS
)
C++
public:
ZDO_USER_DESC_SET_SRSP(
ZDO_USER_DESC_SET_SRSP.CMD_STATUS
) sealed
J#
public ZDO_USER_DESC_SET_SRSP(
ZDO_USER_DESC_SET_SRSP.CMD_STATUS
)
JScript
public function ZDO_USER_DESC_SET_SRSP(
: ZDO_USER_DESC_SET_SRSP.CMD_STATUS
)

See Also

ZDO_USER_DESC_SET_SRSP Class
TI.ZPI2 Namespace
ZDO_USER_DESC_SET_SRSP Constructor Overload List


Fields

ZDO_USER_DESC_SET_SRSP Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZDO_USER_DESC_SET_SRSP Class
TI.ZPI2 Namespace


Status Field

ZDO_USER_DESC_SET_SRSP.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZDO_USER_DESC_SET_SRSP.CMD_STATUS
C#
public ZDO_USER_DESC_SET_SRSP.CMD_STATUS Status;
C++
public:
ZDO_USER_DESC_SET_SRSP.CMD_STATUS Status sealed ;
J#
public ZDO_USER_DESC_SET_SRSP.CMD_STATUS Status
JScript
public Status : ZDO_USER_DESC_SET_SRSP.CMD_STATUS;

See Also

ZDO_USER_DESC_SET_SRSP Class
TI.ZPI2 Namespace


ZDO_USER_DESC_SET_SRSP.CMD_STATUS Enumeration

ZDO_USER_DESC_SET_SRSP.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZDO_USER_DESC_SET_SRSP.CMD_STATUS As Byte
C#
public enum ZDO_USER_DESC_SET_SRSP.CMD_STATUS : byte
C++
public enum class ZDO_USER_DESC_SET_SRSP.CMD_STATUS : char
J#
public enum ZDO_USER_DESC_SET_SRSP.CMD_STATUS byte
JScript
public enum ZDO_USER_DESC_SET_SRSP.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZLL_TOUCH_LINK_INDICATION Class

ZLL_TOUCH_LINK_INDICATION Class
See Also Example Members
[image]

ZLL Touch Link Indication

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZLL_TOUCH_LINK_INDICATION
Implements IINDICATION, IAPP
C#
public class ZLL_TOUCH_LINK_INDICATION : IINDICATION, IAPP
C++
ref class ZLL_TOUCH_LINK_INDICATION : IINDICATION, IAPP
J#
public class ZLL_TOUCH_LINK_INDICATION implements IINDICATION, IAPP
JScript
public class ZLL_TOUCH_LINK_INDICATION extends IINDICATION, IAPP

Inheritance Hierarchy

System.Object
TI.ZPI2.ZLL_TOUCH_LINK_INDICATION

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZLL_TOUCH_LINK_INDICATION Members
TI.ZPI2 Namespace


ZLL_TOUCH_LINK_INDICATION Members

ZLL_TOUCH_LINK_INDICATION Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

ZLL Touch Link Indication

The following tables list the members exposed by ZLL_TOUCH_LINK_INDICATION.

Public Constructors

Name | Description
ZLL_TOUCH_LINK_INDICATION | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceID | Device ID of the linked target
Public field | DeviceVersion | Device Version of the linked target
Public field | EndPoint | EndPoint of the linked target
Public field | NwkAddress | Network address of the linked target
Public field | ProfileID | Profile ID of the linked target
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZLL_TOUCH_LINK_INDICATION | Overloaded.
Top

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


ZLL_TOUCH_LINK_INDICATION Constructor

ZLL_TOUCH_LINK_INDICATION Constructor

Overload List

 | Name | Description
Public method | ZLL_TOUCH_LINK_INDICATION | Constructor
Public method | ZLL_TOUCH_LINK_INDICATION (UInt16, Byte, UInt16, UInt16, Byte) | Constructor

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


ZLL_TOUCH_LINK_INDICATION Constructor ()

ZLL_TOUCH_LINK_INDICATION Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZLL_TOUCH_LINK_INDICATION()
C++
public:
ZLL_TOUCH_LINK_INDICATION() sealed
J#
public ZLL_TOUCH_LINK_INDICATION()
JScript
public function ZLL_TOUCH_LINK_INDICATION()

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace
ZLL_TOUCH_LINK_INDICATION Constructor Overload List


ZLL_TOUCH_LINK_INDICATION Constructor (UInt16, Byte, UInt16, UInt16, Byte)

ZLL_TOUCH_LINK_INDICATION Constructor (UInt16, Byte, UInt16, UInt16, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte _
)
C#
public ZLL_TOUCH_LINK_INDICATION(
ushort ,
byte ,
ushort ,
ushort ,
byte
)
C++
public:
ZLL_TOUCH_LINK_INDICATION(
unsigned short ,
char ,
unsigned short ,
unsigned short ,
char
) sealed
J#
public ZLL_TOUCH_LINK_INDICATION(
ushort ,
byte ,
ushort ,
ushort ,
byte
)
JScript
public function ZLL_TOUCH_LINK_INDICATION(
: UInt16,
: Byte,
: UInt16,
: UInt16,
: Byte
)

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace
ZLL_TOUCH_LINK_INDICATION Constructor Overload List


Fields

ZLL_TOUCH_LINK_INDICATION Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceID | Device ID of the linked target
Public field | DeviceVersion | Device Version of the linked target
Public field | EndPoint | EndPoint of the linked target
Public field | NwkAddress | Network address of the linked target
Public field | ProfileID | Profile ID of the linked target
Top

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


DeviceID Field

ZLL_TOUCH_LINK_INDICATION.DeviceID Field
[image]

Device ID of the linked target

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceID As UInt16
C#
public ushort DeviceID;
C++
public:
unsigned short DeviceID sealed ;
J#
public ushort DeviceID
JScript
public DeviceID : UInt16;

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


DeviceVersion Field

ZLL_TOUCH_LINK_INDICATION.DeviceVersion Field
[image]

Device Version of the linked target

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceVersion As Byte
C#
public byte DeviceVersion;
C++
public:
char DeviceVersion sealed ;
J#
public byte DeviceVersion
JScript
public DeviceVersion : Byte;

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


EndPoint Field

ZLL_TOUCH_LINK_INDICATION.EndPoint Field
[image]

EndPoint of the linked target

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public EndPoint As Byte
C#
public byte EndPoint;
C++
public:
char EndPoint sealed ;
J#
public byte EndPoint
JScript
public EndPoint : Byte;

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


NwkAddress Field

ZLL_TOUCH_LINK_INDICATION.NwkAddress Field
[image]

Network address of the linked target

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkAddress As UInt16
C#
public ushort NwkAddress;
C++
public:
unsigned short NwkAddress sealed ;
J#
public ushort NwkAddress
JScript
public NwkAddress : UInt16;

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


ProfileID Field

ZLL_TOUCH_LINK_INDICATION.ProfileID Field
[image]

Profile ID of the linked target

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ProfileID As UInt16
C#
public ushort ProfileID;
C++
public:
unsigned short ProfileID sealed ;
J#
public ushort ProfileID
JScript
public ProfileID : UInt16;

See Also

ZLL_TOUCH_LINK_INDICATION Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_CNF Class

ZMAC_ASSOCIATE_CNF Class
See Also Example Members
[image]

This sends a associat confirm command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ASSOCIATE_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_ASSOCIATE_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_ASSOCIATE_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_ASSOCIATE_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ASSOCIATE_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_CNF Members
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_CNF Members

ZMAC_ASSOCIATE_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This sends a associat confirm command

The following tables list the members exposed by ZMAC_ASSOCIATE_CNF.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceShortAddress | Short Address of the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_CNF | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_CNF Constructor

ZMAC_ASSOCIATE_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_CNF | Constructor
Public method | ZMAC_ASSOCIATE_CNF (ZMAC_ASSOCIATE_CNF.CMD_STATUS, UInt16, Byte, ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL, ZMAC_ASSOCIATE_CNF.KEY_ID_MODE, Byte) |

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_CNF Constructor ()

ZMAC_ASSOCIATE_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_CNF()
C++
public:
ZMAC_ASSOCIATE_CNF() sealed
J#
public ZMAC_ASSOCIATE_CNF()
JScript
public function ZMAC_ASSOCIATE_CNF()

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_CNF Constructor Overload List


ZMAC_ASSOCIATE_CNF Constructor (ZMAC_ASSOCIATE_CNF.CMD_STATUS, UInt16, Byte[], ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL, ZMAC_ASSOCIATE_CNF.KEY_ID_MODE, Byte)

ZMAC_ASSOCIATE_CNF Constructor (ZMAC_ASSOCIATE_CNF.CMD_STATUS, UInt16, Byte[], ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL, ZMAC_ASSOCIATE_CNF.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ASSOCIATE_CNF.CMD_STATUS, _
ByVal As UInt16, _
ByVal As Byte(), _
ByVal As ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL, _
ByVal As ZMAC_ASSOCIATE_CNF.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ASSOCIATE_CNF(
ZMAC_ASSOCIATE_CNF.CMD_STATUS ,
ushort ,
byte[] ,
ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_CNF.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ASSOCIATE_CNF(
ZMAC_ASSOCIATE_CNF.CMD_STATUS ,
unsigned short ,
array<char>^ ,
ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_CNF.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ASSOCIATE_CNF(
ZMAC_ASSOCIATE_CNF.CMD_STATUS ,
ushort ,
byte[] ,
ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_CNF.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ASSOCIATE_CNF(
: ZMAC_ASSOCIATE_CNF.CMD_STATUS,
: UInt16,
: Byte[],
: ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL,
: ZMAC_ASSOCIATE_CNF.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_CNF Constructor Overload List


Fields

ZMAC_ASSOCIATE_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceShortAddress | Short Address of the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


DeviceShortAddress Field

ZMAC_ASSOCIATE_CNF.DeviceShortAddress Field
[image]

Short Address of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceShortAddress As UInt16
C#
public ushort DeviceShortAddress;
C++
public:
unsigned short DeviceShortAddress sealed ;
J#
public ushort DeviceShortAddress
JScript
public DeviceShortAddress : UInt16;

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_ASSOCIATE_CNF.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ASSOCIATE_CNF.KEY_ID_MODE
C#
public ZMAC_ASSOCIATE_CNF.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ASSOCIATE_CNF.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ASSOCIATE_CNF.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ASSOCIATE_CNF.KEY_ID_MODE;

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_ASSOCIATE_CNF.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_ASSOCIATE_CNF.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_ASSOCIATE_CNF.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL
C#
public ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL;

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_ASSOCIATE_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ASSOCIATE_CNF.CMD_STATUS
C#
public ZMAC_ASSOCIATE_CNF.CMD_STATUS Status;
C++
public:
ZMAC_ASSOCIATE_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_ASSOCIATE_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_ASSOCIATE_CNF.CMD_STATUS;

See Also

ZMAC_ASSOCIATE_CNF Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_CNF.CMD_STATUS Enumeration

ZMAC_ASSOCIATE_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_ASSOCIATE_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_ASSOCIATE_CNF.CMD_STATUS : char
J#
public enum ZMAC_ASSOCIATE_CNF.CMD_STATUS byte
JScript
public enum ZMAC_ASSOCIATE_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_CNF.KEY_ID_MODE Enumeration

ZMAC_ASSOCIATE_CNF.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_CNF.KEY_ID_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_CNF.KEY_ID_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_CNF.KEY_ID_MODE : char
J#
public enum ZMAC_ASSOCIATE_CNF.KEY_ID_MODE byte
JScript
public enum ZMAC_ASSOCIATE_CNF.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL Enumeration

ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL : char
J#
public enum ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL byte
JScript
public enum ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_IND Class

ZMAC_ASSOCIATE_IND Class
See Also Example Members
[image]

This command is used to send (on behalf of the next higher layer) an association indication message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_IND
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ASSOCIATE_IND : IRESPONSE, IZMAC
C++
ref class ZMAC_ASSOCIATE_IND : IRESPONSE, IZMAC
J#
public class ZMAC_ASSOCIATE_IND implements IRESPONSE, IZMAC
JScript
public class ZMAC_ASSOCIATE_IND extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ASSOCIATE_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_IND Members
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_IND Members

ZMAC_ASSOCIATE_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send (on behalf of the next higher layer) an association indication message

The following tables list the members exposed by ZMAC_ASSOCIATE_IND.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Capabilities | Capabilities of the device
Public field | DeviceExtendedAddress | Extended Address of the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_IND | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_IND Constructor

ZMAC_ASSOCIATE_IND Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_IND | Constructor
Public method | ZMAC_ASSOCIATE_IND (Byte, Byte, Byte, ZMAC_ASSOCIATE_IND.SECURITY_LEVEL, ZMAC_ASSOCIATE_IND.KEY_ID_MODE, Byte) |

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_IND Constructor ()

ZMAC_ASSOCIATE_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_IND()
C++
public:
ZMAC_ASSOCIATE_IND() sealed
J#
public ZMAC_ASSOCIATE_IND()
JScript
public function ZMAC_ASSOCIATE_IND()

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_IND Constructor Overload List


ZMAC_ASSOCIATE_IND Constructor (Byte[], Byte, Byte[], ZMAC_ASSOCIATE_IND.SECURITY_LEVEL, ZMAC_ASSOCIATE_IND.KEY_ID_MODE, Byte)

ZMAC_ASSOCIATE_IND Constructor (Byte[], Byte, Byte[], ZMAC_ASSOCIATE_IND.SECURITY_LEVEL, ZMAC_ASSOCIATE_IND.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_ASSOCIATE_IND.SECURITY_LEVEL, _
ByVal As ZMAC_ASSOCIATE_IND.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ASSOCIATE_IND(
byte[] ,
byte ,
byte[] ,
ZMAC_ASSOCIATE_IND.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_IND.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ASSOCIATE_IND(
array<char>^ ,
char ,
array<char>^ ,
ZMAC_ASSOCIATE_IND.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_IND.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ASSOCIATE_IND(
byte[] ,
byte ,
byte[] ,
ZMAC_ASSOCIATE_IND.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_IND.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ASSOCIATE_IND(
: Byte[],
: Byte,
: Byte[],
: ZMAC_ASSOCIATE_IND.SECURITY_LEVEL,
: ZMAC_ASSOCIATE_IND.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_IND Constructor Overload List


Fields

ZMAC_ASSOCIATE_IND Fields
[image]

Public Fields

 | Name | Description
Public field | Capabilities | Capabilities of the device
Public field | DeviceExtendedAddress | Extended Address of the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


Capabilities Field

ZMAC_ASSOCIATE_IND.Capabilities Field
[image]

Capabilities of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Capabilities As Byte
C#
public byte Capabilities;
C++
public:
char Capabilities sealed ;
J#
public byte Capabilities
JScript
public Capabilities : Byte;

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


DeviceExtendedAddress Field

ZMAC_ASSOCIATE_IND.DeviceExtendedAddress Field
[image]

Extended Address of the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceExtendedAddress As Byte()
C#
public byte[] DeviceExtendedAddress;
C++
public:
array<char>^ DeviceExtendedAddress sealed ;
J#
public byte[] DeviceExtendedAddress
JScript
public DeviceExtendedAddress : Byte[];

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_ASSOCIATE_IND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ASSOCIATE_IND.KEY_ID_MODE
C#
public ZMAC_ASSOCIATE_IND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ASSOCIATE_IND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ASSOCIATE_IND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ASSOCIATE_IND.KEY_ID_MODE;

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_ASSOCIATE_IND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_ASSOCIATE_IND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_ASSOCIATE_IND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ASSOCIATE_IND.SECURITY_LEVEL
C#
public ZMAC_ASSOCIATE_IND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ASSOCIATE_IND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ASSOCIATE_IND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ASSOCIATE_IND.SECURITY_LEVEL;

See Also

ZMAC_ASSOCIATE_IND Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_IND.KEY_ID_MODE Enumeration

ZMAC_ASSOCIATE_IND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_IND.KEY_ID_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_IND.KEY_ID_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_IND.KEY_ID_MODE : char
J#
public enum ZMAC_ASSOCIATE_IND.KEY_ID_MODE byte
JScript
public enum ZMAC_ASSOCIATE_IND.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_IND.SECURITY_LEVEL Enumeration

ZMAC_ASSOCIATE_IND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_IND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ASSOCIATE_IND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ASSOCIATE_IND.SECURITY_LEVEL : char
J#
public enum ZMAC_ASSOCIATE_IND.SECURITY_LEVEL byte
JScript
public enum ZMAC_ASSOCIATE_IND.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_REQUEST Class

ZMAC_ASSOCIATE_REQUEST Class
See Also Example Members
[image]

This command is used to request (on behalf of the next higher layer) an association with a coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_ASSOCIATE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_ASSOCIATE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_ASSOCIATE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_ASSOCIATE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ASSOCIATE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_REQUEST Members
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_REQUEST Members

ZMAC_ASSOCIATE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request (on behalf of the next higher layer) an association with a coordinator

The following tables list the members exposed by ZMAC_ASSOCIATE_REQUEST.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CapabilityInformation | Bit map which specifies the operational capabilities of the device (use eCAPABILITIES_BITFIELD)
Public field | ChannelPage | The channel page that the device will associate
Public field | CoordAddress | Address of the Coordinator
Public field | CoordAddressMode | Specifies the format of the coordinator device address
Public field | CoordPanID | PAN ID of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | The channel that the device will associate
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_REQUEST | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_REQUEST Constructor

ZMAC_ASSOCIATE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_REQUEST | Constructor
Public method | ZMAC_ASSOCIATE_REQUEST (Byte, Byte, ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte, Byte, ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_REQUEST Constructor ()

ZMAC_ASSOCIATE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_REQUEST()
C++
public:
ZMAC_ASSOCIATE_REQUEST() sealed
J#
public ZMAC_ASSOCIATE_REQUEST()
JScript
public function ZMAC_ASSOCIATE_REQUEST()

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_REQUEST Constructor Overload List


ZMAC_ASSOCIATE_REQUEST Constructor (Byte, Byte, ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte, Byte[], ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, Byte)

ZMAC_ASSOCIATE_REQUEST Constructor (Byte, Byte, ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte, Byte[], ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ASSOCIATE_REQUEST(
byte ,
byte ,
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
byte ,
byte[] ,
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ASSOCIATE_REQUEST(
char ,
char ,
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
char ,
array<char>^ ,
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ASSOCIATE_REQUEST(
byte ,
byte ,
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
byte ,
byte[] ,
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ASSOCIATE_REQUEST(
: Byte,
: Byte,
: ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: Byte,
: Byte[],
: ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL,
: ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_REQUEST Constructor Overload List


Fields

ZMAC_ASSOCIATE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CapabilityInformation | Bit map which specifies the operational capabilities of the device (use eCAPABILITIES_BITFIELD)
Public field | ChannelPage | The channel page that the device will associate
Public field | CoordAddress | Address of the Coordinator
Public field | CoordAddressMode | Specifies the format of the coordinator device address
Public field | CoordPanID | PAN ID of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | The channel that the device will associate
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


CapabilityInformation Field

ZMAC_ASSOCIATE_REQUEST.CapabilityInformation Field
[image]

Bit map which specifies the operational capabilities of the device (use eCAPABILITIES_BITFIELD)

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CapabilityInformation As Byte
C#
public byte CapabilityInformation;
C++
public:
char CapabilityInformation sealed ;
J#
public byte CapabilityInformation
JScript
public CapabilityInformation : Byte;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


ChannelPage Field

ZMAC_ASSOCIATE_REQUEST.ChannelPage Field
[image]

The channel page that the device will associate

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


CoordAddress Field

ZMAC_ASSOCIATE_REQUEST.CoordAddress Field
[image]

Address of the Coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddress As UInt64
C#
public ulong CoordAddress;
C++
public:
unsigned __int64 CoordAddress sealed ;
J#
public ulong CoordAddress
JScript
public CoordAddress : UInt64;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


CoordAddressMode Field

ZMAC_ASSOCIATE_REQUEST.CoordAddressMode Field
[image]

Specifies the format of the coordinator device address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddressMode As ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE
C#
public ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE CoordAddressMode;
C++
public:
ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE CoordAddressMode sealed ;
J#
public ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE CoordAddressMode
JScript
public CoordAddressMode : ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


CoordPanID Field

ZMAC_ASSOCIATE_REQUEST.CoordPanID Field
[image]

PAN ID of the coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordPanID As UInt16
C#
public ushort CoordPanID;
C++
public:
unsigned short CoordPanID sealed ;
J#
public ushort CoordPanID
JScript
public CoordPanID : UInt16;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_ASSOCIATE_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE
C#
public ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_ASSOCIATE_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_ASSOCIATE_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


LogicalChannel Field

ZMAC_ASSOCIATE_REQUEST.LogicalChannel Field
[image]

The channel that the device will associate

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_ASSOCIATE_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL
C#
public ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_ASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE Enumeration

ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE Enumeration

ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RESPONSE Class

ZMAC_ASSOCIATE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_ASSOCIATE_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ASSOCIATE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_ASSOCIATE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_ASSOCIATE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_ASSOCIATE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ASSOCIATE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RESPONSE Members

ZMAC_ASSOCIATE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_ASSOCIATE_REQUEST

The following tables list the members exposed by ZMAC_ASSOCIATE_RESPONSE.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_RESPONSE | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RESPONSE Constructor

ZMAC_ASSOCIATE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_RESPONSE | Constructor
Public method | ZMAC_ASSOCIATE_RESPONSE (ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RESPONSE Constructor ()

ZMAC_ASSOCIATE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_RESPONSE()
C++
public:
ZMAC_ASSOCIATE_RESPONSE() sealed
J#
public ZMAC_ASSOCIATE_RESPONSE()
JScript
public function ZMAC_ASSOCIATE_RESPONSE()

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_RESPONSE Constructor Overload List


ZMAC_ASSOCIATE_RESPONSE Constructor (ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS)

ZMAC_ASSOCIATE_RESPONSE Constructor (ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_ASSOCIATE_RESPONSE(
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_ASSOCIATE_RESPONSE(
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_ASSOCIATE_RESPONSE(
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_ASSOCIATE_RESPONSE(
: ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_RESPONSE Constructor Overload List


Fields

ZMAC_ASSOCIATE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_ASSOCIATE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
C#
public ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS;

See Also

ZMAC_ASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Enumeration

ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP Class

ZMAC_ASSOCIATE_RSP Class
See Also Example Members
[image]

This command is sent by the host to response to the ASSOCIATE_IND

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_RSP
Implements IREQUEST, IZMAC
C#
public class ZMAC_ASSOCIATE_RSP : IREQUEST, IZMAC
C++
ref class ZMAC_ASSOCIATE_RSP : IREQUEST, IZMAC
J#
public class ZMAC_ASSOCIATE_RSP implements IREQUEST, IZMAC
JScript
public class ZMAC_ASSOCIATE_RSP extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ASSOCIATE_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_RSP Members
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP Members

ZMAC_ASSOCIATE_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is sent by the host to response to the ASSOCIATE_IND

The following tables list the members exposed by ZMAC_ASSOCIATE_RSP.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssocShortAddress | Short address of the associated device
Public field | AssocStatus | Status of the association
Public field | ExtAddr | Extended Address of the device requesting association
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_RSP | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP Constructor

ZMAC_ASSOCIATE_RSP Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_RSP | Constructor
Public method | ZMAC_ASSOCIATE_RSP (Byte, UInt16, ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS, Byte, ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL, ZMAC_ASSOCIATE_RSP.KEY_ID_MODE, Byte) |

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP Constructor ()

ZMAC_ASSOCIATE_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_RSP()
C++
public:
ZMAC_ASSOCIATE_RSP() sealed
J#
public ZMAC_ASSOCIATE_RSP()
JScript
public function ZMAC_ASSOCIATE_RSP()

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_RSP Constructor Overload List


ZMAC_ASSOCIATE_RSP Constructor (Byte[], UInt16, ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS, Byte[], ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL, ZMAC_ASSOCIATE_RSP.KEY_ID_MODE, Byte)

ZMAC_ASSOCIATE_RSP Constructor (Byte[], UInt16, ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS, Byte[], ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL, ZMAC_ASSOCIATE_RSP.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte(), _
ByVal As UInt16, _
ByVal As ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS, _
ByVal As Byte(), _
ByVal As ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL, _
ByVal As ZMAC_ASSOCIATE_RSP.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ASSOCIATE_RSP(
byte[] ,
ushort ,
ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS ,
byte[] ,
ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_RSP.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ASSOCIATE_RSP(
array<char>^ ,
unsigned short ,
ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS ,
array<char>^ ,
ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_RSP.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ASSOCIATE_RSP(
byte[] ,
ushort ,
ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS ,
byte[] ,
ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL ,
ZMAC_ASSOCIATE_RSP.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ASSOCIATE_RSP(
: Byte[],
: UInt16,
: ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS,
: Byte[],
: ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL,
: ZMAC_ASSOCIATE_RSP.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_RSP Constructor Overload List


Fields

ZMAC_ASSOCIATE_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | AssocShortAddress | Short address of the associated device
Public field | AssocStatus | Status of the association
Public field | ExtAddr | Extended Address of the device requesting association
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


AssocShortAddress Field

ZMAC_ASSOCIATE_RSP.AssocShortAddress Field
[image]

Short address of the associated device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocShortAddress As UInt16
C#
public ushort AssocShortAddress;
C++
public:
unsigned short AssocShortAddress sealed ;
J#
public ushort AssocShortAddress
JScript
public AssocShortAddress : UInt16;

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


AssocStatus Field

ZMAC_ASSOCIATE_RSP.AssocStatus Field
[image]

Status of the association

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocStatus As ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS
C#
public ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS AssocStatus;
C++
public:
ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS AssocStatus sealed ;
J#
public ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS AssocStatus
JScript
public AssocStatus : ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS;

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


ExtAddr Field

ZMAC_ASSOCIATE_RSP.ExtAddr Field
[image]

Extended Address of the device requesting association

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As Byte()
C#
public byte[] ExtAddr;
C++
public:
array<char>^ ExtAddr sealed ;
J#
public byte[] ExtAddr
JScript
public ExtAddr : Byte[];

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_ASSOCIATE_RSP.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ASSOCIATE_RSP.KEY_ID_MODE
C#
public ZMAC_ASSOCIATE_RSP.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ASSOCIATE_RSP.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ASSOCIATE_RSP.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ASSOCIATE_RSP.KEY_ID_MODE;

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_ASSOCIATE_RSP.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_ASSOCIATE_RSP.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_ASSOCIATE_RSP.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL
C#
public ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL;

See Also

ZMAC_ASSOCIATE_RSP Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS Enumeration

ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS Enumeration
[image]

Address types used in AutoPend

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS As Byte
C#
public enum ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS : byte
C++
public enum class ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS : char
J#
public enum ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS byte
JScript
public enum ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS :

Members

Member Name | Description
0x00 (SUCCESSFUL_ASSOCIATION) | Address types used in AutoPend
0x01 (PAN_AT_CAPACITY) | Address types used in AutoPend
0x02 (PAN_ACCESS_DENIED) | Address types used in AutoPend

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP.KEY_ID_MODE Enumeration

ZMAC_ASSOCIATE_RSP.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RSP.KEY_ID_MODE As Byte
C#
public enum ZMAC_ASSOCIATE_RSP.KEY_ID_MODE : byte
C++
public enum class ZMAC_ASSOCIATE_RSP.KEY_ID_MODE : char
J#
public enum ZMAC_ASSOCIATE_RSP.KEY_ID_MODE byte
JScript
public enum ZMAC_ASSOCIATE_RSP.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL Enumeration

ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL : char
J#
public enum ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL byte
JScript
public enum ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP_RESPONSE Class

ZMAC_ASSOCIATE_RSP_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_ASSOCIATE_RSP

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ASSOCIATE_RSP_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ASSOCIATE_RSP_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_ASSOCIATE_RSP_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_ASSOCIATE_RSP_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_ASSOCIATE_RSP_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ASSOCIATE_RSP_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ASSOCIATE_RSP_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP_RESPONSE Members

ZMAC_ASSOCIATE_RSP_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_ASSOCIATE_RSP

The following tables list the members exposed by ZMAC_ASSOCIATE_RSP_RESPONSE.

Public Constructors

Name | Description
ZMAC_ASSOCIATE_RSP_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ASSOCIATE_RSP_RESPONSE | Overloaded.
Top

See Also

ZMAC_ASSOCIATE_RSP_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP_RESPONSE Constructor

ZMAC_ASSOCIATE_RSP_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_ASSOCIATE_RSP_RESPONSE | Constructor
Public method | ZMAC_ASSOCIATE_RSP_RESPONSE (ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS) |

See Also

ZMAC_ASSOCIATE_RSP_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP_RESPONSE Constructor ()

ZMAC_ASSOCIATE_RSP_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ASSOCIATE_RSP_RESPONSE()
C++
public:
ZMAC_ASSOCIATE_RSP_RESPONSE() sealed
J#
public ZMAC_ASSOCIATE_RSP_RESPONSE()
JScript
public function ZMAC_ASSOCIATE_RSP_RESPONSE()

See Also

ZMAC_ASSOCIATE_RSP_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_RSP_RESPONSE Constructor Overload List


ZMAC_ASSOCIATE_RSP_RESPONSE Constructor (ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS)

ZMAC_ASSOCIATE_RSP_RESPONSE Constructor (ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_ASSOCIATE_RSP_RESPONSE(
ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_ASSOCIATE_RSP_RESPONSE(
ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_ASSOCIATE_RSP_RESPONSE(
ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_ASSOCIATE_RSP_RESPONSE(
: ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS
)

See Also

ZMAC_ASSOCIATE_RSP_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ASSOCIATE_RSP_RESPONSE Constructor Overload List


Fields

ZMAC_ASSOCIATE_RSP_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_ASSOCIATE_RSP_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_ASSOCIATE_RSP_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS
C#
public ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS;

See Also

ZMAC_ASSOCIATE_RSP_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS Enumeration

ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_BEACON_NOTIFY_IND Class

ZMAC_BEACON_NOTIFY_IND Class
See Also Example Members
[image]

Beacon Notify Indication

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_BEACON_NOTIFY_IND
Implements IRESPONSE, IZMAC
C#
public class ZMAC_BEACON_NOTIFY_IND : IRESPONSE, IZMAC
C++
ref class ZMAC_BEACON_NOTIFY_IND : IRESPONSE, IZMAC
J#
public class ZMAC_BEACON_NOTIFY_IND implements IRESPONSE, IZMAC
JScript
public class ZMAC_BEACON_NOTIFY_IND extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_BEACON_NOTIFY_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_BEACON_NOTIFY_IND Members
TI.ZPI2 Namespace


ZMAC_BEACON_NOTIFY_IND Members

ZMAC_BEACON_NOTIFY_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Beacon Notify Indication

The following tables list the members exposed by ZMAC_BEACON_NOTIFY_IND.

Public Constructors

Name | Description
ZMAC_BEACON_NOTIFY_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AddressList | Address List
Public field | BSN | BSN
Public field | CoordinatorAddressMode | Address mode of the coordincator
Public field | CoordinatorExtendedAddress | Coordinator Extended Address
Public field | GTSPermit | GTS Permit
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | Link Quality
Public field | LogicalChannel | Logical Channel
Public field | NSDU | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | PanID | Pan ID
Public field | PendingAddrSpec | Pending Address Specification
Public field | SDULength | Data Length
Public field | SecurityFailure | Security Failure
Public field | SecurityLevel | Security Level of this data frame
Public field | SuperframeSpec | Superframe specification
Public field | Timestamp | Timestamp
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_BEACON_NOTIFY_IND | Overloaded.
Top

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


ZMAC_BEACON_NOTIFY_IND Constructor

ZMAC_BEACON_NOTIFY_IND Constructor

Overload List

 | Name | Description
Public method | ZMAC_BEACON_NOTIFY_IND | Constructor
Public method | ZMAC_BEACON_NOTIFY_IND (Byte, UInt32, Byte, UInt64, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL, ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE, Byte, Byte, Byte, Byte, Byte) |

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


ZMAC_BEACON_NOTIFY_IND Constructor ()

ZMAC_BEACON_NOTIFY_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_BEACON_NOTIFY_IND()
C++
public:
ZMAC_BEACON_NOTIFY_IND() sealed
J#
public ZMAC_BEACON_NOTIFY_IND()
JScript
public function ZMAC_BEACON_NOTIFY_IND()

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace
ZMAC_BEACON_NOTIFY_IND Constructor Overload List


ZMAC_BEACON_NOTIFY_IND Constructor (Byte, UInt32, Byte, UInt64, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL, ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE, Byte, Byte, Byte[], Byte, Byte[])

ZMAC_BEACON_NOTIFY_IND Constructor (Byte, UInt32, Byte, UInt64, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL, ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE, Byte, Byte, Byte[], Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL, _
ByVal As ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZMAC_BEACON_NOTIFY_IND(
byte ,
uint ,
byte ,
ulong ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL ,
ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE ,
byte ,
byte ,
byte[] ,
byte ,
byte[]
)
C++
public:
ZMAC_BEACON_NOTIFY_IND(
char ,
unsigned int ,
char ,
unsigned __int64 ,
unsigned short ,
unsigned short ,
char ,
char ,
char ,
char ,
array<char>^ ,
ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL ,
ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE ,
char ,
char ,
array<char>^ ,
char ,
array<char>^
) sealed
J#
public ZMAC_BEACON_NOTIFY_IND(
byte ,
uint ,
byte ,
ulong ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL ,
ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE ,
byte ,
byte ,
byte[] ,
byte ,
byte[]
)
JScript
public function ZMAC_BEACON_NOTIFY_IND(
: Byte,
: UInt32,
: Byte,
: UInt64,
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[],
: ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL,
: ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[],
: Byte,
: Byte[]
)

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace
ZMAC_BEACON_NOTIFY_IND Constructor Overload List


Fields

ZMAC_BEACON_NOTIFY_IND Fields
[image]

Public Fields

 | Name | Description
Public field | AddressList | Address List
Public field | BSN | BSN
Public field | CoordinatorAddressMode | Address mode of the coordincator
Public field | CoordinatorExtendedAddress | Coordinator Extended Address
Public field | GTSPermit | GTS Permit
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | Link Quality
Public field | LogicalChannel | Logical Channel
Public field | NSDU | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | PanID | Pan ID
Public field | PendingAddrSpec | Pending Address Specification
Public field | SDULength | Data Length
Public field | SecurityFailure | Security Failure
Public field | SecurityLevel | Security Level of this data frame
Public field | SuperframeSpec | Superframe specification
Public field | Timestamp | Timestamp
Top

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


AddressList Field

ZMAC_BEACON_NOTIFY_IND.AddressList Field
[image]

Address List

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AddressList As Byte()
C#
public byte[] AddressList;
C++
public:
array<char>^ AddressList sealed ;
J#
public byte[] AddressList
JScript
public AddressList : Byte[];

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


BSN Field

ZMAC_BEACON_NOTIFY_IND.BSN Field
[image]

BSN

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BSN As Byte
C#
public byte BSN;
C++
public:
char BSN sealed ;
J#
public byte BSN
JScript
public BSN : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


CoordinatorAddressMode Field

ZMAC_BEACON_NOTIFY_IND.CoordinatorAddressMode Field
[image]

Address mode of the coordincator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordinatorAddressMode As Byte
C#
public byte CoordinatorAddressMode;
C++
public:
char CoordinatorAddressMode sealed ;
J#
public byte CoordinatorAddressMode
JScript
public CoordinatorAddressMode : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


CoordinatorExtendedAddress Field

ZMAC_BEACON_NOTIFY_IND.CoordinatorExtendedAddress Field
[image]

Coordinator Extended Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordinatorExtendedAddress As UInt64
C#
public ulong CoordinatorExtendedAddress;
C++
public:
unsigned __int64 CoordinatorExtendedAddress sealed ;
J#
public ulong CoordinatorExtendedAddress
JScript
public CoordinatorExtendedAddress : UInt64;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


GTSPermit Field

ZMAC_BEACON_NOTIFY_IND.GTSPermit Field
[image]

GTS Permit

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public GTSPermit As Byte
C#
public byte GTSPermit;
C++
public:
char GTSPermit sealed ;
J#
public byte GTSPermit
JScript
public GTSPermit : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_BEACON_NOTIFY_IND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE
C#
public ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_BEACON_NOTIFY_IND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_BEACON_NOTIFY_IND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


LinkQuality Field

ZMAC_BEACON_NOTIFY_IND.LinkQuality Field
[image]

Link Quality

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


LogicalChannel Field

ZMAC_BEACON_NOTIFY_IND.LogicalChannel Field
[image]

Logical Channel

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


NSDU Field

ZMAC_BEACON_NOTIFY_IND.NSDU Field
[image]

Dynamic array, actual network data packet which is of size indicated by NSDULength

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NSDU As Byte()
C#
public byte[] NSDU;
C++
public:
array<char>^ NSDU sealed ;
J#
public byte[] NSDU
JScript
public NSDU : Byte[];

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


PanID Field

ZMAC_BEACON_NOTIFY_IND.PanID Field
[image]

Pan ID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


PendingAddrSpec Field

ZMAC_BEACON_NOTIFY_IND.PendingAddrSpec Field
[image]

Pending Address Specification

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PendingAddrSpec As Byte
C#
public byte PendingAddrSpec;
C++
public:
char PendingAddrSpec sealed ;
J#
public byte PendingAddrSpec
JScript
public PendingAddrSpec : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


SDULength Field

ZMAC_BEACON_NOTIFY_IND.SDULength Field
[image]

Data Length

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SDULength As Byte
C#
public byte SDULength;
C++
public:
char SDULength sealed ;
J#
public byte SDULength
JScript
public SDULength : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


SecurityFailure Field

ZMAC_BEACON_NOTIFY_IND.SecurityFailure Field
[image]

Security Failure

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityFailure As Byte
C#
public byte SecurityFailure;
C++
public:
char SecurityFailure sealed ;
J#
public byte SecurityFailure
JScript
public SecurityFailure : Byte;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_BEACON_NOTIFY_IND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL
C#
public ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


SuperframeSpec Field

ZMAC_BEACON_NOTIFY_IND.SuperframeSpec Field
[image]

Superframe specification

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperframeSpec As UInt16
C#
public ushort SuperframeSpec;
C++
public:
unsigned short SuperframeSpec sealed ;
J#
public ushort SuperframeSpec
JScript
public SuperframeSpec : UInt16;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


Timestamp Field

ZMAC_BEACON_NOTIFY_IND.Timestamp Field
[image]

Timestamp

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp As UInt32
C#
public uint Timestamp;
C++
public:
unsigned int Timestamp sealed ;
J#
public uint Timestamp
JScript
public Timestamp : UInt32;

See Also

ZMAC_BEACON_NOTIFY_IND Class
TI.ZPI2 Namespace


ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE Enumeration

ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE As Byte
C#
public enum ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE : byte
C++
public enum class ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE : char
J#
public enum ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE byte
JScript
public enum ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL Enumeration

ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL : char
J#
public enum ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL byte
JScript
public enum ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND Class

ZMAC_COMM_STATUS_IND Class
See Also Example Members
[image]

Communcation status indication

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_COMM_STATUS_IND
Implements IRESPONSE, IZMAC
C#
public class ZMAC_COMM_STATUS_IND : IRESPONSE, IZMAC
C++
ref class ZMAC_COMM_STATUS_IND : IRESPONSE, IZMAC
J#
public class ZMAC_COMM_STATUS_IND implements IRESPONSE, IZMAC
JScript
public class ZMAC_COMM_STATUS_IND extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_COMM_STATUS_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_COMM_STATUS_IND Members
TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND Members

ZMAC_COMM_STATUS_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Communcation status indication

The following tables list the members exposed by ZMAC_COMM_STATUS_IND.

Public Constructors

Name | Description
ZMAC_COMM_STATUS_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DevicePanID | Device PanID
Public field | DstAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | Destination Address Mode
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Reason | Reason
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddr | The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SrcAddrMode | Source Address Mode
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_COMM_STATUS_IND | Overloaded.
Top

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND Constructor

ZMAC_COMM_STATUS_IND Constructor

Overload List

 | Name | Description
Public method | ZMAC_COMM_STATUS_IND | Constructor
Public method | ZMAC_COMM_STATUS_IND (ZMAC_COMM_STATUS_IND.CMD_STATUS, ZMAC_COMM_STATUS_IND.ADDRESS_MODE, Byte, ZMAC_COMM_STATUS_IND.ADDRESS_MODE, Byte, UInt16, Byte, Byte, ZMAC_COMM_STATUS_IND.SECURITY_LEVEL, ZMAC_COMM_STATUS_IND.KEY_ID_MODE, Byte) |

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND Constructor ()

ZMAC_COMM_STATUS_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_COMM_STATUS_IND()
C++
public:
ZMAC_COMM_STATUS_IND() sealed
J#
public ZMAC_COMM_STATUS_IND()
JScript
public function ZMAC_COMM_STATUS_IND()

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace
ZMAC_COMM_STATUS_IND Constructor Overload List


ZMAC_COMM_STATUS_IND Constructor (ZMAC_COMM_STATUS_IND.CMD_STATUS, ZMAC_COMM_STATUS_IND.ADDRESS_MODE, Byte[], ZMAC_COMM_STATUS_IND.ADDRESS_MODE, Byte[], UInt16, Byte, Byte[], ZMAC_COMM_STATUS_IND.SECURITY_LEVEL, ZMAC_COMM_STATUS_IND.KEY_ID_MODE, Byte)

ZMAC_COMM_STATUS_IND Constructor (ZMAC_COMM_STATUS_IND.CMD_STATUS, ZMAC_COMM_STATUS_IND.ADDRESS_MODE, Byte[], ZMAC_COMM_STATUS_IND.ADDRESS_MODE, Byte[], UInt16, Byte, Byte[], ZMAC_COMM_STATUS_IND.SECURITY_LEVEL, ZMAC_COMM_STATUS_IND.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_COMM_STATUS_IND.CMD_STATUS, _
ByVal As ZMAC_COMM_STATUS_IND.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As ZMAC_COMM_STATUS_IND.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_COMM_STATUS_IND.SECURITY_LEVEL, _
ByVal As ZMAC_COMM_STATUS_IND.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_COMM_STATUS_IND(
ZMAC_COMM_STATUS_IND.CMD_STATUS ,
ZMAC_COMM_STATUS_IND.ADDRESS_MODE ,
byte[] ,
ZMAC_COMM_STATUS_IND.ADDRESS_MODE ,
byte[] ,
ushort ,
byte ,
byte[] ,
ZMAC_COMM_STATUS_IND.SECURITY_LEVEL ,
ZMAC_COMM_STATUS_IND.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_COMM_STATUS_IND(
ZMAC_COMM_STATUS_IND.CMD_STATUS ,
ZMAC_COMM_STATUS_IND.ADDRESS_MODE ,
array<char>^ ,
ZMAC_COMM_STATUS_IND.ADDRESS_MODE ,
array<char>^ ,
unsigned short ,
char ,
array<char>^ ,
ZMAC_COMM_STATUS_IND.SECURITY_LEVEL ,
ZMAC_COMM_STATUS_IND.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_COMM_STATUS_IND(
ZMAC_COMM_STATUS_IND.CMD_STATUS ,
ZMAC_COMM_STATUS_IND.ADDRESS_MODE ,
byte[] ,
ZMAC_COMM_STATUS_IND.ADDRESS_MODE ,
byte[] ,
ushort ,
byte ,
byte[] ,
ZMAC_COMM_STATUS_IND.SECURITY_LEVEL ,
ZMAC_COMM_STATUS_IND.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_COMM_STATUS_IND(
: ZMAC_COMM_STATUS_IND.CMD_STATUS,
: ZMAC_COMM_STATUS_IND.ADDRESS_MODE,
: Byte[],
: ZMAC_COMM_STATUS_IND.ADDRESS_MODE,
: Byte[],
: UInt16,
: Byte,
: Byte[],
: ZMAC_COMM_STATUS_IND.SECURITY_LEVEL,
: ZMAC_COMM_STATUS_IND.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace
ZMAC_COMM_STATUS_IND Constructor Overload List


Fields

ZMAC_COMM_STATUS_IND Fields
[image]

Public Fields

 | Name | Description
Public field | DevicePanID | Device PanID
Public field | DstAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | Destination Address Mode
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Reason | Reason
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddr | The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SrcAddrMode | Source Address Mode
Public field | Status | Status
Top

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


DevicePanID Field

ZMAC_COMM_STATUS_IND.DevicePanID Field
[image]

Device PanID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DevicePanID As UInt16
C#
public ushort DevicePanID;
C++
public:
unsigned short DevicePanID sealed ;
J#
public ushort DevicePanID
JScript
public DevicePanID : UInt16;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


DstAddr Field

ZMAC_COMM_STATUS_IND.DstAddr Field
[image]

The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As Byte()
C#
public byte[] DstAddr;
C++
public:
array<char>^ DstAddr sealed ;
J#
public byte[] DstAddr
JScript
public DstAddr : Byte[];

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


DstAddrMode Field

ZMAC_COMM_STATUS_IND.DstAddrMode Field
[image]

Destination Address Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As ZMAC_COMM_STATUS_IND.ADDRESS_MODE
C#
public ZMAC_COMM_STATUS_IND.ADDRESS_MODE DstAddrMode;
C++
public:
ZMAC_COMM_STATUS_IND.ADDRESS_MODE DstAddrMode sealed ;
J#
public ZMAC_COMM_STATUS_IND.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : ZMAC_COMM_STATUS_IND.ADDRESS_MODE;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_COMM_STATUS_IND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_COMM_STATUS_IND.KEY_ID_MODE
C#
public ZMAC_COMM_STATUS_IND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_COMM_STATUS_IND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_COMM_STATUS_IND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_COMM_STATUS_IND.KEY_ID_MODE;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_COMM_STATUS_IND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_COMM_STATUS_IND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


Reason Field

ZMAC_COMM_STATUS_IND.Reason Field
[image]

Reason

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Reason As Byte
C#
public byte Reason;
C++
public:
char Reason sealed ;
J#
public byte Reason
JScript
public Reason : Byte;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_COMM_STATUS_IND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_COMM_STATUS_IND.SECURITY_LEVEL
C#
public ZMAC_COMM_STATUS_IND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_COMM_STATUS_IND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_COMM_STATUS_IND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_COMM_STATUS_IND.SECURITY_LEVEL;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


SrcAddr Field

ZMAC_COMM_STATUS_IND.SrcAddr Field
[image]

The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As Byte()
C#
public byte[] SrcAddr;
C++
public:
array<char>^ SrcAddr sealed ;
J#
public byte[] SrcAddr
JScript
public SrcAddr : Byte[];

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


SrcAddrMode Field

ZMAC_COMM_STATUS_IND.SrcAddrMode Field
[image]

Source Address Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddrMode As ZMAC_COMM_STATUS_IND.ADDRESS_MODE
C#
public ZMAC_COMM_STATUS_IND.ADDRESS_MODE SrcAddrMode;
C++
public:
ZMAC_COMM_STATUS_IND.ADDRESS_MODE SrcAddrMode sealed ;
J#
public ZMAC_COMM_STATUS_IND.ADDRESS_MODE SrcAddrMode
JScript
public SrcAddrMode : ZMAC_COMM_STATUS_IND.ADDRESS_MODE;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


Status Field

ZMAC_COMM_STATUS_IND.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_COMM_STATUS_IND.CMD_STATUS
C#
public ZMAC_COMM_STATUS_IND.CMD_STATUS Status;
C++
public:
ZMAC_COMM_STATUS_IND.CMD_STATUS Status sealed ;
J#
public ZMAC_COMM_STATUS_IND.CMD_STATUS Status
JScript
public Status : ZMAC_COMM_STATUS_IND.CMD_STATUS;

See Also

ZMAC_COMM_STATUS_IND Class
TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND.ADDRESS_MODE Enumeration

ZMAC_COMM_STATUS_IND.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_COMM_STATUS_IND.ADDRESS_MODE As Byte
C#
public enum ZMAC_COMM_STATUS_IND.ADDRESS_MODE : byte
C++
public enum class ZMAC_COMM_STATUS_IND.ADDRESS_MODE : char
J#
public enum ZMAC_COMM_STATUS_IND.ADDRESS_MODE byte
JScript
public enum ZMAC_COMM_STATUS_IND.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND.CMD_STATUS Enumeration

ZMAC_COMM_STATUS_IND.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_COMM_STATUS_IND.CMD_STATUS As Byte
C#
public enum ZMAC_COMM_STATUS_IND.CMD_STATUS : byte
C++
public enum class ZMAC_COMM_STATUS_IND.CMD_STATUS : char
J#
public enum ZMAC_COMM_STATUS_IND.CMD_STATUS byte
JScript
public enum ZMAC_COMM_STATUS_IND.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND.KEY_ID_MODE Enumeration

ZMAC_COMM_STATUS_IND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_COMM_STATUS_IND.KEY_ID_MODE As Byte
C#
public enum ZMAC_COMM_STATUS_IND.KEY_ID_MODE : byte
C++
public enum class ZMAC_COMM_STATUS_IND.KEY_ID_MODE : char
J#
public enum ZMAC_COMM_STATUS_IND.KEY_ID_MODE byte
JScript
public enum ZMAC_COMM_STATUS_IND.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_COMM_STATUS_IND.SECURITY_LEVEL Enumeration

ZMAC_COMM_STATUS_IND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_COMM_STATUS_IND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_COMM_STATUS_IND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_COMM_STATUS_IND.SECURITY_LEVEL : char
J#
public enum ZMAC_COMM_STATUS_IND.SECURITY_LEVEL byte
JScript
public enum ZMAC_COMM_STATUS_IND.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_DATA_CNF Class

ZMAC_DATA_CNF Class
See Also Example Members
[image]

Data Request Confirmation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DATA_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DATA_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_DATA_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_DATA_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_DATA_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DATA_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DATA_CNF Members
TI.ZPI2 Namespace


ZMAC_DATA_CNF Members

ZMAC_DATA_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Data Request Confirmation

The following tables list the members exposed by ZMAC_DATA_CNF.

Public Constructors

Name | Description
ZMAC_DATA_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Handle | Handle
Public field | Status | Status
Public field | Timestamp | Timestamp
Public field | Timestamp2 | Timestamp 2
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DATA_CNF | Overloaded.
Top

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace


ZMAC_DATA_CNF Constructor

ZMAC_DATA_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_DATA_CNF | Constructor
Public method | ZMAC_DATA_CNF (ZMAC_DATA_CNF.CMD_STATUS, Byte, UInt32, UInt16) |

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace


ZMAC_DATA_CNF Constructor ()

ZMAC_DATA_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DATA_CNF()
C++
public:
ZMAC_DATA_CNF() sealed
J#
public ZMAC_DATA_CNF()
JScript
public function ZMAC_DATA_CNF()

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace
ZMAC_DATA_CNF Constructor Overload List


ZMAC_DATA_CNF Constructor (ZMAC_DATA_CNF.CMD_STATUS, Byte, UInt32, UInt16)

ZMAC_DATA_CNF Constructor (ZMAC_DATA_CNF.CMD_STATUS, Byte, UInt32, UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DATA_CNF.CMD_STATUS, _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As UInt16 _
)
C#
public ZMAC_DATA_CNF(
ZMAC_DATA_CNF.CMD_STATUS ,
byte ,
uint ,
ushort
)
C++
public:
ZMAC_DATA_CNF(
ZMAC_DATA_CNF.CMD_STATUS ,
char ,
unsigned int ,
unsigned short
) sealed
J#
public ZMAC_DATA_CNF(
ZMAC_DATA_CNF.CMD_STATUS ,
byte ,
uint ,
ushort
)
JScript
public function ZMAC_DATA_CNF(
: ZMAC_DATA_CNF.CMD_STATUS,
: Byte,
: UInt32,
: UInt16
)

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace
ZMAC_DATA_CNF Constructor Overload List


Fields

ZMAC_DATA_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Handle | Handle
Public field | Status | Status
Public field | Timestamp | Timestamp
Public field | Timestamp2 | Timestamp 2
Top

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace


Handle Field

ZMAC_DATA_CNF.Handle Field
[image]

Handle

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_DATA_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_DATA_CNF.CMD_STATUS
C#
public ZMAC_DATA_CNF.CMD_STATUS Status;
C++
public:
ZMAC_DATA_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_DATA_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_DATA_CNF.CMD_STATUS;

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace


Timestamp Field

ZMAC_DATA_CNF.Timestamp Field
[image]

Timestamp

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp As UInt32
C#
public uint Timestamp;
C++
public:
unsigned int Timestamp sealed ;
J#
public uint Timestamp
JScript
public Timestamp : UInt32;

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace


Timestamp2 Field

ZMAC_DATA_CNF.Timestamp2 Field
[image]

Timestamp 2

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp2 As UInt16
C#
public ushort Timestamp2;
C++
public:
unsigned short Timestamp2 sealed ;
J#
public ushort Timestamp2
JScript
public Timestamp2 : UInt16;

See Also

ZMAC_DATA_CNF Class
TI.ZPI2 Namespace


ZMAC_DATA_CNF.CMD_STATUS Enumeration

ZMAC_DATA_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_DATA_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_DATA_CNF.CMD_STATUS : char
J#
public enum ZMAC_DATA_CNF.CMD_STATUS byte
JScript
public enum ZMAC_DATA_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_DATA_IND Class

ZMAC_DATA_IND Class
See Also Example Members
[image]

Data Indication

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DATA_IND
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DATA_IND : IRESPONSE, IZMAC
C++
ref class ZMAC_DATA_IND : IRESPONSE, IZMAC
J#
public class ZMAC_DATA_IND implements IRESPONSE, IZMAC
JScript
public class ZMAC_DATA_IND extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DATA_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DATA_IND Members
TI.ZPI2 Namespace


ZMAC_DATA_IND Members

ZMAC_DATA_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Data Indication

The following tables list the members exposed by ZMAC_DATA_IND.

Public Constructors

Name | Description
ZMAC_DATA_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Correlation | Correlation or LQI
Public field | Data | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | DSN | DSN
Public field | DstAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | DstPanID | Destination PanID
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Length | Length
Public field | LinkQuality | Link Quality
Public field | RSSI | RSSI
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddr | The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SrcAddrMode | The source address mode according to afAddrMode_t.
Public field | SrcPanID | Source PanID
Public field | Timestamp | Timestamp
Public field | Timestamp2 | Timestamp 2
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DATA_IND | Overloaded.
Top

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


ZMAC_DATA_IND Constructor

ZMAC_DATA_IND Constructor

Overload List

 | Name | Description
Public method | ZMAC_DATA_IND | Constructor
Public method | ZMAC_DATA_IND (ZMAC_DATA_IND.ADDRESS_MODE, Byte, ZMAC_DATA_IND.ADDRESS_MODE, Byte, UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte, ZMAC_DATA_IND.SECURITY_LEVEL, ZMAC_DATA_IND.KEY_ID_MODE, Byte, Byte, Byte) |

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


ZMAC_DATA_IND Constructor ()

ZMAC_DATA_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DATA_IND()
C++
public:
ZMAC_DATA_IND() sealed
J#
public ZMAC_DATA_IND()
JScript
public function ZMAC_DATA_IND()

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace
ZMAC_DATA_IND Constructor Overload List


ZMAC_DATA_IND Constructor (ZMAC_DATA_IND.ADDRESS_MODE, Byte[], ZMAC_DATA_IND.ADDRESS_MODE, Byte[], UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], ZMAC_DATA_IND.SECURITY_LEVEL, ZMAC_DATA_IND.KEY_ID_MODE, Byte, Byte, Byte[])

ZMAC_DATA_IND Constructor (ZMAC_DATA_IND.ADDRESS_MODE, Byte[], ZMAC_DATA_IND.ADDRESS_MODE, Byte[], UInt32, UInt16, UInt16, UInt16, Byte, Byte, Byte, Byte, Byte[], ZMAC_DATA_IND.SECURITY_LEVEL, ZMAC_DATA_IND.KEY_ID_MODE, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DATA_IND.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As ZMAC_DATA_IND.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As UInt32, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_DATA_IND.SECURITY_LEVEL, _
ByVal As ZMAC_DATA_IND.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZMAC_DATA_IND(
ZMAC_DATA_IND.ADDRESS_MODE ,
byte[] ,
ZMAC_DATA_IND.ADDRESS_MODE ,
byte[] ,
uint ,
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_DATA_IND.SECURITY_LEVEL ,
ZMAC_DATA_IND.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
C++
public:
ZMAC_DATA_IND(
ZMAC_DATA_IND.ADDRESS_MODE ,
array<char>^ ,
ZMAC_DATA_IND.ADDRESS_MODE ,
array<char>^ ,
unsigned int ,
unsigned short ,
unsigned short ,
unsigned short ,
char ,
char ,
char ,
char ,
array<char>^ ,
ZMAC_DATA_IND.SECURITY_LEVEL ,
ZMAC_DATA_IND.KEY_ID_MODE ,
char ,
char ,
array<char>^
) sealed
J#
public ZMAC_DATA_IND(
ZMAC_DATA_IND.ADDRESS_MODE ,
byte[] ,
ZMAC_DATA_IND.ADDRESS_MODE ,
byte[] ,
uint ,
ushort ,
ushort ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_DATA_IND.SECURITY_LEVEL ,
ZMAC_DATA_IND.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
JScript
public function ZMAC_DATA_IND(
: ZMAC_DATA_IND.ADDRESS_MODE,
: Byte[],
: ZMAC_DATA_IND.ADDRESS_MODE,
: Byte[],
: UInt32,
: UInt16,
: UInt16,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[],
: ZMAC_DATA_IND.SECURITY_LEVEL,
: ZMAC_DATA_IND.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[]
)

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace
ZMAC_DATA_IND Constructor Overload List


Fields

ZMAC_DATA_IND Fields
[image]

Public Fields

 | Name | Description
Public field | Correlation | Correlation or LQI
Public field | Data | Dynamic array, actual network data packet which is of size indicated by NSDULength
Public field | DSN | DSN
Public field | DstAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DstAddrMode | The destination address mode according to afAddrMode_t.
Public field | DstPanID | Destination PanID
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | Length | Length
Public field | LinkQuality | Link Quality
Public field | RSSI | RSSI
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddr | The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | SrcAddrMode | The source address mode according to afAddrMode_t.
Public field | SrcPanID | Source PanID
Public field | Timestamp | Timestamp
Public field | Timestamp2 | Timestamp 2
Top

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


Correlation Field

ZMAC_DATA_IND.Correlation Field
[image]

Correlation or LQI

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Correlation As Byte
C#
public byte Correlation;
C++
public:
char Correlation sealed ;
J#
public byte Correlation
JScript
public Correlation : Byte;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


Data Field

ZMAC_DATA_IND.Data Field
[image]

Dynamic array, actual network data packet which is of size indicated by NSDULength

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


DSN Field

ZMAC_DATA_IND.DSN Field
[image]

DSN

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DSN As Byte
C#
public byte DSN;
C++
public:
char DSN sealed ;
J#
public byte DSN
JScript
public DSN : Byte;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


DstAddr Field

ZMAC_DATA_IND.DstAddr Field
[image]

The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddr As Byte()
C#
public byte[] DstAddr;
C++
public:
array<char>^ DstAddr sealed ;
J#
public byte[] DstAddr
JScript
public DstAddr : Byte[];

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


DstAddrMode Field

ZMAC_DATA_IND.DstAddrMode Field
[image]

The destination address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstAddrMode As ZMAC_DATA_IND.ADDRESS_MODE
C#
public ZMAC_DATA_IND.ADDRESS_MODE DstAddrMode;
C++
public:
ZMAC_DATA_IND.ADDRESS_MODE DstAddrMode sealed ;
J#
public ZMAC_DATA_IND.ADDRESS_MODE DstAddrMode
JScript
public DstAddrMode : ZMAC_DATA_IND.ADDRESS_MODE;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


DstPanID Field

ZMAC_DATA_IND.DstPanID Field
[image]

Destination PanID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DstPanID As UInt16
C#
public ushort DstPanID;
C++
public:
unsigned short DstPanID sealed ;
J#
public ushort DstPanID
JScript
public DstPanID : UInt16;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_DATA_IND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_DATA_IND.KEY_ID_MODE
C#
public ZMAC_DATA_IND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_DATA_IND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_DATA_IND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_DATA_IND.KEY_ID_MODE;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_DATA_IND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_DATA_IND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


Length Field

ZMAC_DATA_IND.Length Field
[image]

Length

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Length As Byte
C#
public byte Length;
C++
public:
char Length sealed ;
J#
public byte Length
JScript
public Length : Byte;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


LinkQuality Field

ZMAC_DATA_IND.LinkQuality Field
[image]

Link Quality

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


RSSI Field

ZMAC_DATA_IND.RSSI Field
[image]

RSSI

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RSSI As Byte
C#
public byte RSSI;
C++
public:
char RSSI sealed ;
J#
public byte RSSI
JScript
public RSSI : Byte;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_DATA_IND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_DATA_IND.SECURITY_LEVEL
C#
public ZMAC_DATA_IND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_DATA_IND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_DATA_IND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_DATA_IND.SECURITY_LEVEL;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


SrcAddr Field

ZMAC_DATA_IND.SrcAddr Field
[image]

The source address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddr As Byte()
C#
public byte[] SrcAddr;
C++
public:
array<char>^ SrcAddr sealed ;
J#
public byte[] SrcAddr
JScript
public SrcAddr : Byte[];

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


SrcAddrMode Field

ZMAC_DATA_IND.SrcAddrMode Field
[image]

The source address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddrMode As ZMAC_DATA_IND.ADDRESS_MODE
C#
public ZMAC_DATA_IND.ADDRESS_MODE SrcAddrMode;
C++
public:
ZMAC_DATA_IND.ADDRESS_MODE SrcAddrMode sealed ;
J#
public ZMAC_DATA_IND.ADDRESS_MODE SrcAddrMode
JScript
public SrcAddrMode : ZMAC_DATA_IND.ADDRESS_MODE;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


SrcPanID Field

ZMAC_DATA_IND.SrcPanID Field
[image]

Source PanID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcPanID As UInt16
C#
public ushort SrcPanID;
C++
public:
unsigned short SrcPanID sealed ;
J#
public ushort SrcPanID
JScript
public SrcPanID : UInt16;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


Timestamp Field

ZMAC_DATA_IND.Timestamp Field
[image]

Timestamp

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp As UInt32
C#
public uint Timestamp;
C++
public:
unsigned int Timestamp sealed ;
J#
public uint Timestamp
JScript
public Timestamp : UInt32;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


Timestamp2 Field

ZMAC_DATA_IND.Timestamp2 Field
[image]

Timestamp 2

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Timestamp2 As UInt16
C#
public ushort Timestamp2;
C++
public:
unsigned short Timestamp2 sealed ;
J#
public ushort Timestamp2
JScript
public Timestamp2 : UInt16;

See Also

ZMAC_DATA_IND Class
TI.ZPI2 Namespace


ZMAC_DATA_IND.ADDRESS_MODE Enumeration

ZMAC_DATA_IND.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_IND.ADDRESS_MODE As Byte
C#
public enum ZMAC_DATA_IND.ADDRESS_MODE : byte
C++
public enum class ZMAC_DATA_IND.ADDRESS_MODE : char
J#
public enum ZMAC_DATA_IND.ADDRESS_MODE byte
JScript
public enum ZMAC_DATA_IND.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZMAC_DATA_IND.KEY_ID_MODE Enumeration

ZMAC_DATA_IND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_IND.KEY_ID_MODE As Byte
C#
public enum ZMAC_DATA_IND.KEY_ID_MODE : byte
C++
public enum class ZMAC_DATA_IND.KEY_ID_MODE : char
J#
public enum ZMAC_DATA_IND.KEY_ID_MODE byte
JScript
public enum ZMAC_DATA_IND.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_DATA_IND.SECURITY_LEVEL Enumeration

ZMAC_DATA_IND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_IND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_DATA_IND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_DATA_IND.SECURITY_LEVEL : char
J#
public enum ZMAC_DATA_IND.SECURITY_LEVEL byte
JScript
public enum ZMAC_DATA_IND.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_DATA_REQUEST Class

ZMAC_DATA_REQUEST Class
See Also Example Members
[image]

This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DATA_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_DATA_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_DATA_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_DATA_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_DATA_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DATA_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DATA_REQUEST Members
TI.ZPI2 Namespace


ZMAC_DATA_REQUEST Members

ZMAC_DATA_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send (on behalf of the next higher layer) MAC Data Frame packet.

The following tables list the members exposed by ZMAC_DATA_REQUEST.

Public Constructors

Name | Description
ZMAC_DATA_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DestAddress | Address of the destination.
Public field | DestAddressMode | Specifies the format of the destination address.
Public field | DestPanID | PAN ID of the destination.
Public field | Handle | Handle of the packet.
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Channel that data frame will be transmitted
Public field | MSDU | Dynamic array, requires memory allocation. Actual data
Public field | MSDULength | Length of the data
Public field | Power | Power level that data frame will be transmitted
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddressMode | Specifies the format of the source address.
Public field | TxOption | Transmitting options
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DATA_REQUEST | Overloaded.
Top

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


ZMAC_DATA_REQUEST Constructor

ZMAC_DATA_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_DATA_REQUEST | Constructor
Public method | ZMAC_DATA_REQUEST (ZMAC_DATA_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DATA_REQUEST.ADDRESS_MODE, Byte, ZMAC_DATA_REQUEST.TX_OPT, Byte, Byte, Byte, ZMAC_DATA_REQUEST.SECURITY_LEVEL, ZMAC_DATA_REQUEST.KEY_ID_MODE, Byte, Byte, Byte) |

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


ZMAC_DATA_REQUEST Constructor ()

ZMAC_DATA_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DATA_REQUEST()
C++
public:
ZMAC_DATA_REQUEST() sealed
J#
public ZMAC_DATA_REQUEST()
JScript
public function ZMAC_DATA_REQUEST()

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace
ZMAC_DATA_REQUEST Constructor Overload List


ZMAC_DATA_REQUEST Constructor (ZMAC_DATA_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DATA_REQUEST.ADDRESS_MODE, Byte, ZMAC_DATA_REQUEST.TX_OPT, Byte, Byte, Byte[], ZMAC_DATA_REQUEST.SECURITY_LEVEL, ZMAC_DATA_REQUEST.KEY_ID_MODE, Byte, Byte, Byte[])

ZMAC_DATA_REQUEST Constructor (ZMAC_DATA_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DATA_REQUEST.ADDRESS_MODE, Byte, ZMAC_DATA_REQUEST.TX_OPT, Byte, Byte, Byte[], ZMAC_DATA_REQUEST.SECURITY_LEVEL, ZMAC_DATA_REQUEST.KEY_ID_MODE, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DATA_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As ZMAC_DATA_REQUEST.ADDRESS_MODE, _
ByVal As Byte, _
ByVal As ZMAC_DATA_REQUEST.TX_OPT, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_DATA_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_DATA_REQUEST.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZMAC_DATA_REQUEST(
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
byte ,
ZMAC_DATA_REQUEST.TX_OPT ,
byte ,
byte ,
byte[] ,
ZMAC_DATA_REQUEST.SECURITY_LEVEL ,
ZMAC_DATA_REQUEST.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
C++
public:
ZMAC_DATA_REQUEST(
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
char ,
ZMAC_DATA_REQUEST.TX_OPT ,
char ,
char ,
array<char>^ ,
ZMAC_DATA_REQUEST.SECURITY_LEVEL ,
ZMAC_DATA_REQUEST.KEY_ID_MODE ,
char ,
char ,
array<char>^
) sealed
J#
public ZMAC_DATA_REQUEST(
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DATA_REQUEST.ADDRESS_MODE ,
byte ,
ZMAC_DATA_REQUEST.TX_OPT ,
byte ,
byte ,
byte[] ,
ZMAC_DATA_REQUEST.SECURITY_LEVEL ,
ZMAC_DATA_REQUEST.KEY_ID_MODE ,
byte ,
byte ,
byte[]
)
JScript
public function ZMAC_DATA_REQUEST(
: ZMAC_DATA_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: ZMAC_DATA_REQUEST.ADDRESS_MODE,
: Byte,
: ZMAC_DATA_REQUEST.TX_OPT,
: Byte,
: Byte,
: Byte[],
: ZMAC_DATA_REQUEST.SECURITY_LEVEL,
: ZMAC_DATA_REQUEST.KEY_ID_MODE,
: Byte,
: Byte,
: Byte[]
)

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace
ZMAC_DATA_REQUEST Constructor Overload List


Fields

ZMAC_DATA_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DestAddress | Address of the destination.
Public field | DestAddressMode | Specifies the format of the destination address.
Public field | DestPanID | PAN ID of the destination.
Public field | Handle | Handle of the packet.
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Channel that data frame will be transmitted
Public field | MSDU | Dynamic array, requires memory allocation. Actual data
Public field | MSDULength | Length of the data
Public field | Power | Power level that data frame will be transmitted
Public field | SecurityLevel | Security Level of this data frame
Public field | SrcAddressMode | Specifies the format of the source address.
Public field | TxOption | Transmitting options
Top

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


DestAddress Field

ZMAC_DATA_REQUEST.DestAddress Field
[image]

Address of the destination.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddress As UInt64
C#
public ulong DestAddress;
C++
public:
unsigned __int64 DestAddress sealed ;
J#
public ulong DestAddress
JScript
public DestAddress : UInt64;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


DestAddressMode Field

ZMAC_DATA_REQUEST.DestAddressMode Field
[image]

Specifies the format of the destination address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestAddressMode As ZMAC_DATA_REQUEST.ADDRESS_MODE
C#
public ZMAC_DATA_REQUEST.ADDRESS_MODE DestAddressMode;
C++
public:
ZMAC_DATA_REQUEST.ADDRESS_MODE DestAddressMode sealed ;
J#
public ZMAC_DATA_REQUEST.ADDRESS_MODE DestAddressMode
JScript
public DestAddressMode : ZMAC_DATA_REQUEST.ADDRESS_MODE;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


DestPanID Field

ZMAC_DATA_REQUEST.DestPanID Field
[image]

PAN ID of the destination.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DestPanID As UInt16
C#
public ushort DestPanID;
C++
public:
unsigned short DestPanID sealed ;
J#
public ushort DestPanID
JScript
public DestPanID : UInt16;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


Handle Field

ZMAC_DATA_REQUEST.Handle Field
[image]

Handle of the packet.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_DATA_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_DATA_REQUEST.KEY_ID_MODE
C#
public ZMAC_DATA_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_DATA_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_DATA_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_DATA_REQUEST.KEY_ID_MODE;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_DATA_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_DATA_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


LogicalChannel Field

ZMAC_DATA_REQUEST.LogicalChannel Field
[image]

Channel that data frame will be transmitted

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


MSDU Field

ZMAC_DATA_REQUEST.MSDU Field
[image]

Dynamic array, requires memory allocation. Actual data

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDU As Byte()
C#
public byte[] MSDU;
C++
public:
array<char>^ MSDU sealed ;
J#
public byte[] MSDU
JScript
public MSDU : Byte[];

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


MSDULength Field

ZMAC_DATA_REQUEST.MSDULength Field
[image]

Length of the data

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MSDULength As Byte
C#
public byte MSDULength;
C++
public:
char MSDULength sealed ;
J#
public byte MSDULength
JScript
public MSDULength : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


Power Field

ZMAC_DATA_REQUEST.Power Field
[image]

Power level that data frame will be transmitted

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Power As Byte
C#
public byte Power;
C++
public:
char Power sealed ;
J#
public byte Power
JScript
public Power : Byte;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_DATA_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_DATA_REQUEST.SECURITY_LEVEL
C#
public ZMAC_DATA_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_DATA_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_DATA_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_DATA_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


SrcAddressMode Field

ZMAC_DATA_REQUEST.SrcAddressMode Field
[image]

Specifies the format of the source address.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SrcAddressMode As ZMAC_DATA_REQUEST.ADDRESS_MODE
C#
public ZMAC_DATA_REQUEST.ADDRESS_MODE SrcAddressMode;
C++
public:
ZMAC_DATA_REQUEST.ADDRESS_MODE SrcAddressMode sealed ;
J#
public ZMAC_DATA_REQUEST.ADDRESS_MODE SrcAddressMode
JScript
public SrcAddressMode : ZMAC_DATA_REQUEST.ADDRESS_MODE;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


TxOption Field

ZMAC_DATA_REQUEST.TxOption Field
[image]

Transmitting options

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxOption As ZMAC_DATA_REQUEST.TX_OPT
C#
public ZMAC_DATA_REQUEST.TX_OPT TxOption;
C++
public:
ZMAC_DATA_REQUEST.TX_OPT TxOption sealed ;
J#
public ZMAC_DATA_REQUEST.TX_OPT TxOption
JScript
public TxOption : ZMAC_DATA_REQUEST.TX_OPT;

See Also

ZMAC_DATA_REQUEST Class
TI.ZPI2 Namespace


ZMAC_DATA_REQUEST.ADDRESS_MODE Enumeration

ZMAC_DATA_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_DATA_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_DATA_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_DATA_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_DATA_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZMAC_DATA_REQUEST.KEY_ID_MODE Enumeration

ZMAC_DATA_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_DATA_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_DATA_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_DATA_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_DATA_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_DATA_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_DATA_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_DATA_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_DATA_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_DATA_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_DATA_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_DATA_REQUEST.TX_OPT Enumeration

ZMAC_DATA_REQUEST.TX_OPT Enumeration
[image]

Transmission options bitfield

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_REQUEST.TX_OPT As Byte
C#
public enum ZMAC_DATA_REQUEST.TX_OPT : byte
C++
public enum class ZMAC_DATA_REQUEST.TX_OPT : char
J#
public enum ZMAC_DATA_REQUEST.TX_OPT byte
JScript
public enum ZMAC_DATA_REQUEST.TX_OPT :

Members

Member Name | Description
0x00 (UNDEFINED) | Transmission options bitfield
0x01 (ACK_TRANS) | Transmission options bitfield
0x02 (GTS_TRANS) | Transmission options bitfield
0x04 (IND_TRANS) | Transmission options bitfield
0x08 (SEC_ENABLED_TRANS) | Transmission options bitfield
0x10 (NO_RE_TRANS) | Transmission options bitfield
0x20 (NO_CONFIRM_TRANS) | Transmission options bitfield
0x40 (USE_PIB_VALUE) | Transmission options bitfield

See Also

TI.ZPI2 Namespace


ZMAC_DATA_RESPONSE Class

ZMAC_DATA_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_DATA_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DATA_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DATA_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_DATA_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_DATA_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_DATA_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DATA_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DATA_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_DATA_RESPONSE Members

ZMAC_DATA_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_DATA_REQUEST

The following tables list the members exposed by ZMAC_DATA_RESPONSE.

Public Constructors

Name | Description
ZMAC_DATA_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DATA_RESPONSE | Overloaded.
Top

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_DATA_RESPONSE Constructor

ZMAC_DATA_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_DATA_RESPONSE | Constructor
Public method | ZMAC_DATA_RESPONSE (ZMAC_DATA_RESPONSE.CMD_STATUS) |

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_DATA_RESPONSE Constructor ()

ZMAC_DATA_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DATA_RESPONSE()
C++
public:
ZMAC_DATA_RESPONSE() sealed
J#
public ZMAC_DATA_RESPONSE()
JScript
public function ZMAC_DATA_RESPONSE()

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_DATA_RESPONSE Constructor Overload List


ZMAC_DATA_RESPONSE Constructor (ZMAC_DATA_RESPONSE.CMD_STATUS)

ZMAC_DATA_RESPONSE Constructor (ZMAC_DATA_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DATA_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_DATA_RESPONSE(
ZMAC_DATA_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_DATA_RESPONSE(
ZMAC_DATA_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_DATA_RESPONSE(
ZMAC_DATA_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_DATA_RESPONSE(
: ZMAC_DATA_RESPONSE.CMD_STATUS
)

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_DATA_RESPONSE Constructor Overload List


Fields

ZMAC_DATA_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_DATA_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_DATA_RESPONSE.CMD_STATUS
C#
public ZMAC_DATA_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_DATA_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_DATA_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_DATA_RESPONSE.CMD_STATUS;

See Also

ZMAC_DATA_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_DATA_RESPONSE.CMD_STATUS Enumeration

ZMAC_DATA_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DATA_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_DATA_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_DATA_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_DATA_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_DATA_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_CNF Class

ZMAC_DISASSOCIATE_CNF Class
See Also Example Members
[image]

Disassociate Indication

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DISASSOCIATE_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DISASSOCIATE_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_DISASSOCIATE_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_DISASSOCIATE_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_DISASSOCIATE_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DISASSOCIATE_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DISASSOCIATE_CNF Members
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_CNF Members

ZMAC_DISASSOCIATE_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Disassociate Indication

The following tables list the members exposed by ZMAC_DISASSOCIATE_CNF.

Public Constructors

Name | Description
ZMAC_DISASSOCIATE_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DeviceAddrMode | The destination address mode according to afAddrMode_t.
Public field | DevicePanID | Device PanID
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DISASSOCIATE_CNF | Overloaded.
Top

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_CNF Constructor

ZMAC_DISASSOCIATE_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_DISASSOCIATE_CNF | Constructor
Public method | ZMAC_DISASSOCIATE_CNF (ZMAC_DISASSOCIATE_CNF.CMD_STATUS, ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE, Byte, UInt16) |

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_CNF Constructor ()

ZMAC_DISASSOCIATE_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DISASSOCIATE_CNF()
C++
public:
ZMAC_DISASSOCIATE_CNF() sealed
J#
public ZMAC_DISASSOCIATE_CNF()
JScript
public function ZMAC_DISASSOCIATE_CNF()

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_CNF Constructor Overload List


ZMAC_DISASSOCIATE_CNF Constructor (ZMAC_DISASSOCIATE_CNF.CMD_STATUS, ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE, Byte[], UInt16)

ZMAC_DISASSOCIATE_CNF Constructor (ZMAC_DISASSOCIATE_CNF.CMD_STATUS, ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE, Byte[], UInt16)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DISASSOCIATE_CNF.CMD_STATUS, _
ByVal As ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE, _
ByVal As Byte(), _
ByVal As UInt16 _
)
C#
public ZMAC_DISASSOCIATE_CNF(
ZMAC_DISASSOCIATE_CNF.CMD_STATUS ,
ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE ,
byte[] ,
ushort
)
C++
public:
ZMAC_DISASSOCIATE_CNF(
ZMAC_DISASSOCIATE_CNF.CMD_STATUS ,
ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE ,
array<char>^ ,
unsigned short
) sealed
J#
public ZMAC_DISASSOCIATE_CNF(
ZMAC_DISASSOCIATE_CNF.CMD_STATUS ,
ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE ,
byte[] ,
ushort
)
JScript
public function ZMAC_DISASSOCIATE_CNF(
: ZMAC_DISASSOCIATE_CNF.CMD_STATUS,
: ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE,
: Byte[],
: UInt16
)

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_CNF Constructor Overload List


Fields

ZMAC_DISASSOCIATE_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddr | The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.
Public field | DeviceAddrMode | The destination address mode according to afAddrMode_t.
Public field | DevicePanID | Device PanID
Public field | Status | Status
Top

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace


DeviceAddr Field

ZMAC_DISASSOCIATE_CNF.DeviceAddr Field
[image]

The destination address depending on the afAddrMode_t: a UInt16 or UInt64, LSB to MSB.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddr As Byte()
C#
public byte[] DeviceAddr;
C++
public:
array<char>^ DeviceAddr sealed ;
J#
public byte[] DeviceAddr
JScript
public DeviceAddr : Byte[];

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace


DeviceAddrMode Field

ZMAC_DISASSOCIATE_CNF.DeviceAddrMode Field
[image]

The destination address mode according to afAddrMode_t.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddrMode As ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE
C#
public ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE DeviceAddrMode;
C++
public:
ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE DeviceAddrMode sealed ;
J#
public ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE DeviceAddrMode
JScript
public DeviceAddrMode : ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE;

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace


DevicePanID Field

ZMAC_DISASSOCIATE_CNF.DevicePanID Field
[image]

Device PanID

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DevicePanID As UInt16
C#
public ushort DevicePanID;
C++
public:
unsigned short DevicePanID sealed ;
J#
public ushort DevicePanID
JScript
public DevicePanID : UInt16;

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_DISASSOCIATE_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_DISASSOCIATE_CNF.CMD_STATUS
C#
public ZMAC_DISASSOCIATE_CNF.CMD_STATUS Status;
C++
public:
ZMAC_DISASSOCIATE_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_DISASSOCIATE_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_DISASSOCIATE_CNF.CMD_STATUS;

See Also

ZMAC_DISASSOCIATE_CNF Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE Enumeration

ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE As Byte
C#
public enum ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE : byte
C++
public enum class ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE : char
J#
public enum ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE byte
JScript
public enum ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_CNF.CMD_STATUS Enumeration

ZMAC_DISASSOCIATE_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_DISASSOCIATE_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_DISASSOCIATE_CNF.CMD_STATUS : char
J#
public enum ZMAC_DISASSOCIATE_CNF.CMD_STATUS byte
JScript
public enum ZMAC_DISASSOCIATE_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_IND Class

ZMAC_DISASSOCIATE_IND Class
See Also Example Members
[image]

Disassociate Indication

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DISASSOCIATE_IND
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DISASSOCIATE_IND : IRESPONSE, IZMAC
C++
ref class ZMAC_DISASSOCIATE_IND : IRESPONSE, IZMAC
J#
public class ZMAC_DISASSOCIATE_IND implements IRESPONSE, IZMAC
JScript
public class ZMAC_DISASSOCIATE_IND extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DISASSOCIATE_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DISASSOCIATE_IND Members
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_IND Members

ZMAC_DISASSOCIATE_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Disassociate Indication

The following tables list the members exposed by ZMAC_DISASSOCIATE_IND.

Public Constructors

Name | Description
ZMAC_DISASSOCIATE_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DisassociateReason | Disassociate Reason
Public field | ExtendedAddress | Extended Address
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DISASSOCIATE_IND | Overloaded.
Top

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_IND Constructor

ZMAC_DISASSOCIATE_IND Constructor

Overload List

 | Name | Description
Public method | ZMAC_DISASSOCIATE_IND | Constructor
Public method | ZMAC_DISASSOCIATE_IND (UInt64, Byte, Byte, ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL, ZMAC_DISASSOCIATE_IND.KEY_ID_MODE, Byte) |

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_IND Constructor ()

ZMAC_DISASSOCIATE_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DISASSOCIATE_IND()
C++
public:
ZMAC_DISASSOCIATE_IND() sealed
J#
public ZMAC_DISASSOCIATE_IND()
JScript
public function ZMAC_DISASSOCIATE_IND()

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_IND Constructor Overload List


ZMAC_DISASSOCIATE_IND Constructor (UInt64, Byte, Byte[], ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL, ZMAC_DISASSOCIATE_IND.KEY_ID_MODE, Byte)

ZMAC_DISASSOCIATE_IND Constructor (UInt64, Byte, Byte[], ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL, ZMAC_DISASSOCIATE_IND.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL, _
ByVal As ZMAC_DISASSOCIATE_IND.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_DISASSOCIATE_IND(
ulong ,
byte ,
byte[] ,
ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_IND.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_DISASSOCIATE_IND(
unsigned __int64 ,
char ,
array<char>^ ,
ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_IND.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_DISASSOCIATE_IND(
ulong ,
byte ,
byte[] ,
ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_IND.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_DISASSOCIATE_IND(
: UInt64,
: Byte,
: Byte[],
: ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL,
: ZMAC_DISASSOCIATE_IND.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_IND Constructor Overload List


Fields

ZMAC_DISASSOCIATE_IND Fields
[image]

Public Fields

 | Name | Description
Public field | DisassociateReason | Disassociate Reason
Public field | ExtendedAddress | Extended Address
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


DisassociateReason Field

ZMAC_DISASSOCIATE_IND.DisassociateReason Field
[image]

Disassociate Reason

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DisassociateReason As Byte
C#
public byte DisassociateReason;
C++
public:
char DisassociateReason sealed ;
J#
public byte DisassociateReason
JScript
public DisassociateReason : Byte;

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


ExtendedAddress Field

ZMAC_DISASSOCIATE_IND.ExtendedAddress Field
[image]

Extended Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedAddress As UInt64
C#
public ulong ExtendedAddress;
C++
public:
unsigned __int64 ExtendedAddress sealed ;
J#
public ulong ExtendedAddress
JScript
public ExtendedAddress : UInt64;

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_DISASSOCIATE_IND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_DISASSOCIATE_IND.KEY_ID_MODE
C#
public ZMAC_DISASSOCIATE_IND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_DISASSOCIATE_IND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_DISASSOCIATE_IND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_DISASSOCIATE_IND.KEY_ID_MODE;

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_DISASSOCIATE_IND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_DISASSOCIATE_IND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_DISASSOCIATE_IND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL
C#
public ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL;

See Also

ZMAC_DISASSOCIATE_IND Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_IND.KEY_ID_MODE Enumeration

ZMAC_DISASSOCIATE_IND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_IND.KEY_ID_MODE As Byte
C#
public enum ZMAC_DISASSOCIATE_IND.KEY_ID_MODE : byte
C++
public enum class ZMAC_DISASSOCIATE_IND.KEY_ID_MODE : char
J#
public enum ZMAC_DISASSOCIATE_IND.KEY_ID_MODE byte
JScript
public enum ZMAC_DISASSOCIATE_IND.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL Enumeration

ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL : char
J#
public enum ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL byte
JScript
public enum ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST Class

ZMAC_DISASSOCIATE_REQUEST Class
See Also Example Members
[image]

This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DISASSOCIATE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_DISASSOCIATE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_DISASSOCIATE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_DISASSOCIATE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_DISASSOCIATE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DISASSOCIATE_REQUEST Members
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST Members

ZMAC_DISASSOCIATE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request (on behalf of the next higher layer) a disassociation of the device from the coordinator.

The following tables list the members exposed by ZMAC_DISASSOCIATE_REQUEST.

Public Constructors

Name | Description
ZMAC_DISASSOCIATE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | DeviceAddress | Device Address
Public field | DeviceAddressMode | Specifies the format of the device address
Public field | DevicePanID | Network PAN ID of device
Public field | DisassociateReason | Reason of disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | TxIndirect | Tx indirect
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DISASSOCIATE_REQUEST | Overloaded.
Top

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST Constructor

ZMAC_DISASSOCIATE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_DISASSOCIATE_REQUEST | Constructor
Public method | ZMAC_DISASSOCIATE_REQUEST (ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, Byte, Byte, ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST Constructor ()

ZMAC_DISASSOCIATE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DISASSOCIATE_REQUEST()
C++
public:
ZMAC_DISASSOCIATE_REQUEST() sealed
J#
public ZMAC_DISASSOCIATE_REQUEST()
JScript
public function ZMAC_DISASSOCIATE_REQUEST()

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_REQUEST Constructor Overload List


ZMAC_DISASSOCIATE_REQUEST Constructor (ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, Byte, Byte[], ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, Byte)

ZMAC_DISASSOCIATE_REQUEST Constructor (ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, UInt64, UInt16, ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, Byte, Byte[], ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_DISASSOCIATE_REQUEST(
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON ,
byte ,
byte[] ,
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_DISASSOCIATE_REQUEST(
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON ,
char ,
array<char>^ ,
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_DISASSOCIATE_REQUEST(
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON ,
byte ,
byte[] ,
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL ,
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_DISASSOCIATE_REQUEST(
: ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON,
: Byte,
: Byte[],
: ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL,
: ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_REQUEST Constructor Overload List


Fields

ZMAC_DISASSOCIATE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | DeviceAddress | Device Address
Public field | DeviceAddressMode | Specifies the format of the device address
Public field | DevicePanID | Network PAN ID of device
Public field | DisassociateReason | Reason of disassociation
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Public field | TxIndirect | Tx indirect
Top

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


DeviceAddress Field

ZMAC_DISASSOCIATE_REQUEST.DeviceAddress Field
[image]

Device Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddress As UInt64
C#
public ulong DeviceAddress;
C++
public:
unsigned __int64 DeviceAddress sealed ;
J#
public ulong DeviceAddress
JScript
public DeviceAddress : UInt64;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


DeviceAddressMode Field

ZMAC_DISASSOCIATE_REQUEST.DeviceAddressMode Field
[image]

Specifies the format of the device address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DeviceAddressMode As ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE
C#
public ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE DeviceAddressMode;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE DeviceAddressMode sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE DeviceAddressMode
JScript
public DeviceAddressMode : ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


DevicePanID Field

ZMAC_DISASSOCIATE_REQUEST.DevicePanID Field
[image]

Network PAN ID of device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DevicePanID As UInt16
C#
public ushort DevicePanID;
C++
public:
unsigned short DevicePanID sealed ;
J#
public ushort DevicePanID
JScript
public DevicePanID : UInt16;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


DisassociateReason Field

ZMAC_DISASSOCIATE_REQUEST.DisassociateReason Field
[image]

Reason of disassociation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public DisassociateReason As ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON
C#
public ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON DisassociateReason;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON DisassociateReason sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON DisassociateReason
JScript
public DisassociateReason : ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_DISASSOCIATE_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE
C#
public ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_DISASSOCIATE_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_DISASSOCIATE_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_DISASSOCIATE_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL
C#
public ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


TxIndirect Field

ZMAC_DISASSOCIATE_REQUEST.TxIndirect Field
[image]

Tx indirect

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TxIndirect As Byte
C#
public byte TxIndirect;
C++
public:
char TxIndirect sealed ;
J#
public byte TxIndirect
JScript
public TxIndirect : Byte;

See Also

ZMAC_DISASSOCIATE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE Enumeration

ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON Enumeration

ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON Enumeration
[image]

Valid disassociation reason codes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON :

Members

Member Name | Description
0x00 (RESERVED) | Valid disassociation reason codes
0x01 (COOR_WISHES_DEV_LEAVE) | Valid disassociation reason codes
0x02 (DEV_WISHES_LEAVE) | Valid disassociation reason codes

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE Enumeration

ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_RESPONSE Class

ZMAC_DISASSOCIATE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_DISASSOCIATE_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_DISASSOCIATE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_DISASSOCIATE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_DISASSOCIATE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_DISASSOCIATE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_DISASSOCIATE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_DISASSOCIATE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_DISASSOCIATE_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_RESPONSE Members

ZMAC_DISASSOCIATE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_DISASSOCIATE_REQUEST

The following tables list the members exposed by ZMAC_DISASSOCIATE_RESPONSE.

Public Constructors

Name | Description
ZMAC_DISASSOCIATE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_DISASSOCIATE_RESPONSE | Overloaded.
Top

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_RESPONSE Constructor

ZMAC_DISASSOCIATE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_DISASSOCIATE_RESPONSE | Constructor
Public method | ZMAC_DISASSOCIATE_RESPONSE (ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_RESPONSE Constructor ()

ZMAC_DISASSOCIATE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_DISASSOCIATE_RESPONSE()
C++
public:
ZMAC_DISASSOCIATE_RESPONSE() sealed
J#
public ZMAC_DISASSOCIATE_RESPONSE()
JScript
public function ZMAC_DISASSOCIATE_RESPONSE()

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_RESPONSE Constructor Overload List


ZMAC_DISASSOCIATE_RESPONSE Constructor (ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS)

ZMAC_DISASSOCIATE_RESPONSE Constructor (ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_DISASSOCIATE_RESPONSE(
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_DISASSOCIATE_RESPONSE(
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_DISASSOCIATE_RESPONSE(
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_DISASSOCIATE_RESPONSE(
: ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_DISASSOCIATE_RESPONSE Constructor Overload List


Fields

ZMAC_DISASSOCIATE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_DISASSOCIATE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
C#
public ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS;

See Also

ZMAC_DISASSOCIATE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Enumeration

ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
See Also Example Members
[image]

This command is used to send a request to the device to send an enhanced beacon request.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Members
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Members

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a request to the device to send an enhanced beacon request.

The following tables list the members exposed by ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.

Public Constructors

Name | Description
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page that the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | Link quality to be sent in the payload as part of this request
Public field | MaxResults | Maximum number of PAN descriptor results
Public field | PercentFilter | Expected probability of device to respond back out of the devices which receive this message
Public field | PermitJoining | Selecting this would allow only those devices to respond who have permit joining turned on
Public field | ScanChannels | Channels to be scanned
Public field | ScanDuration | Duration of the scan
Public field | ScanType | Type of the scan
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST | Overloaded.
Top

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST | Constructor
Public method | ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST (ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE, Byte, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN, Byte, Byte) |

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor ()

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST()
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST() sealed
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST()
JScript
public function ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST()

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor Overload List


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor (ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte[], ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE, Byte, ZMAC_ENHANCED_ACTIVE_SCAN_RE

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor (ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte[], ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE, Byte, ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS, _
ByVal As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST(
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE ,
byte ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN ,
byte ,
byte
)
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST(
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE ,
char ,
char ,
char ,
array<char>^ ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE ,
char ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN ,
char ,
char
) sealed
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST(
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE ,
byte ,
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN ,
byte ,
byte
)
JScript
public function ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST(
: ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS,
: ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE,
: Byte,
: Byte,
: Byte,
: Byte[],
: ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL,
: ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE,
: Byte,
: ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN,
: Byte,
: Byte
)

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Constructor Overload List


Fields

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page that the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LinkQuality | Link quality to be sent in the payload as part of this request
Public field | MaxResults | Maximum number of PAN descriptor results
Public field | PercentFilter | Expected probability of device to respond back out of the devices which receive this message
Public field | PermitJoining | Selecting this would allow only those devices to respond who have permit joining turned on
Public field | ScanChannels | Channels to be scanned
Public field | ScanDuration | Duration of the scan
Public field | ScanType | Type of the scan
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


ChannelPage Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ChannelPage Field
[image]

The channel page that the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


LinkQuality Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.LinkQuality Field
[image]

Link quality to be sent in the payload as part of this request

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LinkQuality As Byte
C#
public byte LinkQuality;
C++
public:
char LinkQuality sealed ;
J#
public byte LinkQuality
JScript
public LinkQuality : Byte;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


MaxResults Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.MaxResults Field
[image]

Maximum number of PAN descriptor results

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MaxResults As Byte
C#
public byte MaxResults;
C++
public:
char MaxResults sealed ;
J#
public byte MaxResults
JScript
public MaxResults : Byte;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


PercentFilter Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.PercentFilter Field
[image]

Expected probability of device to respond back out of the devices which receive this message

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PercentFilter As Byte
C#
public byte PercentFilter;
C++
public:
char PercentFilter sealed ;
J#
public byte PercentFilter
JScript
public PercentFilter : Byte;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


PermitJoining Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.PermitJoining Field
[image]

Selecting this would allow only those devices to respond who have permit joining turned on

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PermitJoining As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN PermitJoining;
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN PermitJoining sealed ;
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN PermitJoining
JScript
public PermitJoining : ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


ScanChannels Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ScanChannels Field
[image]

Channels to be scanned

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


ScanDuration Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ScanDuration Field
[image]

Duration of the scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


ScanType Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ScanType Field
[image]

Type of the scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanType As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE ScanType;
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE ScanType sealed ;
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE ScanType
JScript
public ScanType : ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN Enumeration

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN As Byte
C#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN : byte
C++
public enum class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN : char
J#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN byte
JScript
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE Enumeration

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE Enumeration

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE Enumeration
[image]

Scan type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE As Byte
C#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE : byte
C++
public enum class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE : char
J#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE byte
JScript
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE :

Members

Member Name | Description
0x00 (ENERGY_DETECT) | Scan type
0x01 (ACTIVE) | Scan type
0x02 (PASSIVE) | Scan type
0x03 (ORPHAN) | Scan type
0x05 (ENHANCED) | Scan type

See Also

TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS Enumeration

ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS Enumeration
See Also Example
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Members

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST

The following tables list the members exposed by ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.

Public Constructors

Name | Description
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE | Overloaded.
Top

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE | Constructor
Public method | ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE (ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS) |

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor ()

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE()
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE() sealed
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE()
JScript
public function ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE()

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor Overload List


ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor (ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS)

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor (ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE(
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE(
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE(
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE(
: ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS
)

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Constructor Overload List


Fields

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS
C#
public ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS;

See Also

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS Enumeration

ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_GET_REQUEST Class

ZMAC_GET_REQUEST Class
See Also Example Members
[image]

This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_GET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_GET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_GET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_GET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_GET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_GET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_GET_REQUEST Members
TI.ZPI2 Namespace


ZMAC_GET_REQUEST Members

ZMAC_GET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to read (on behalf of the next higher layer) a MAC PIB attribute.

The following tables list the members exposed by ZMAC_GET_REQUEST.

Public Constructors

Name | Description
ZMAC_GET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_GET_REQUEST | Overloaded.
Top

See Also

ZMAC_GET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_GET_REQUEST Constructor

ZMAC_GET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_GET_REQUEST | Constructor
Public method | ZMAC_GET_REQUEST (ZMAC_GET_REQUEST.MAC_PID_ATTR) |

See Also

ZMAC_GET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_GET_REQUEST Constructor ()

ZMAC_GET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_GET_REQUEST()
C++
public:
ZMAC_GET_REQUEST() sealed
J#
public ZMAC_GET_REQUEST()
JScript
public function ZMAC_GET_REQUEST()

See Also

ZMAC_GET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_GET_REQUEST Constructor Overload List


ZMAC_GET_REQUEST Constructor (ZMAC_GET_REQUEST.MAC_PID_ATTR)

ZMAC_GET_REQUEST Constructor (ZMAC_GET_REQUEST.MAC_PID_ATTR)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_GET_REQUEST.MAC_PID_ATTR _
)
C#
public ZMAC_GET_REQUEST(
ZMAC_GET_REQUEST.MAC_PID_ATTR
)
C++
public:
ZMAC_GET_REQUEST(
ZMAC_GET_REQUEST.MAC_PID_ATTR
) sealed
J#
public ZMAC_GET_REQUEST(
ZMAC_GET_REQUEST.MAC_PID_ATTR
)
JScript
public function ZMAC_GET_REQUEST(
: ZMAC_GET_REQUEST.MAC_PID_ATTR
)

See Also

ZMAC_GET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_GET_REQUEST Constructor Overload List


Fields

ZMAC_GET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Top

See Also

ZMAC_GET_REQUEST Class
TI.ZPI2 Namespace


Attribute Field

ZMAC_GET_REQUEST.Attribute Field
[image]

Specifies the MAC PID Attributes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As ZMAC_GET_REQUEST.MAC_PID_ATTR
C#
public ZMAC_GET_REQUEST.MAC_PID_ATTR Attribute;
C++
public:
ZMAC_GET_REQUEST.MAC_PID_ATTR Attribute sealed ;
J#
public ZMAC_GET_REQUEST.MAC_PID_ATTR Attribute
JScript
public Attribute : ZMAC_GET_REQUEST.MAC_PID_ATTR;

See Also

ZMAC_GET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_GET_REQUEST.MAC_PID_ATTR Enumeration

ZMAC_GET_REQUEST.MAC_PID_ATTR Enumeration
[image]

MAC PID Attribute

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_GET_REQUEST.MAC_PID_ATTR As Byte
C#
public enum ZMAC_GET_REQUEST.MAC_PID_ATTR : byte
C++
public enum class ZMAC_GET_REQUEST.MAC_PID_ATTR : char
J#
public enum ZMAC_GET_REQUEST.MAC_PID_ATTR byte
JScript
public enum ZMAC_GET_REQUEST.MAC_PID_ATTR :

Members

Member Name | Description
0x00 (NOT_SPECIFIED) | MAC PID Attribute
0x40 (ZMAC_ACK_WAIT_DURATION) | MAC PID Attribute
0x41 (ZMAC_ASSOCIATION_PERMIT) | MAC PID Attribute
0x42 (ZMAC_AUTO_REQUEST) | MAC PID Attribute
0x43 (ZMAC_BATT_LIFE_EXT) | MAC PID Attribute
0x44 (ZMAC_BATT_LEFT_EXT_PERIODS) | MAC PID Attribute
0x45 (ZMAC_BEACON_MSDU) | MAC PID Attribute
0x46 (ZMAC_BEACON_MSDU_LENGTH) | MAC PID Attribute
0x47 (ZMAC_BEACON_ORDER) | MAC PID Attribute
0x48 (ZMAC_BEACON_TX_TIME) | MAC PID Attribute
0x49 (ZMAC_BSN) | MAC PID Attribute
0x4A (ZMAC_COORD_EXTENDED_ADDRESS) | MAC PID Attribute
0x4B (ZMAC_COORD_SHORT_ADDRESS) | MAC PID Attribute
0x4C (ZMAC_DSN) | MAC PID Attribute
0x4D (ZMAC_GTS_PERMIT) | MAC PID Attribute
0x4E (ZMAC_MAX_CSMA_BACKOFFS) | MAC PID Attribute
0x4F (ZMAC_MIN_BE) | MAC PID Attribute
0x50 (ZMAC_PANID) | MAC PID Attribute
0x51 (ZMAC_PROMISCUOUS_MODE) | MAC PID Attribute
0x52 (ZMAC_RX_ON_IDLE) | MAC PID Attribute
0x53 (ZMAC_SHORT_ADDRESS) | MAC PID Attribute
0x54 (ZMAC_SUPERFRAME_ORDER) | MAC PID Attribute
0x55 (ZMAC_TRANSACTION_PERSISTENCE_TIME) | MAC PID Attribute
0x56 (ZMAC_ASSOCIATED_PAN_COORD) | MAC PID Attribute
0x57 (ZMAC_MAX_BE) | MAC PID Attribute
0x58 (ZMAC_FRAME_TOTAL_WAIT_TIME) | MAC PID Attribute
0x59 (ZMAC_MAX_FRAME_RETRIES) | MAC PID Attribute
0x5A (ZMAC_RESPONSE_WAIT_TIME - (0x5A) | MAC PID Attribute
0x5B (ZMAC_SYNC_SYMBOL_OFFSET) | MAC PID Attribute
0x5C (ZMAC_TIMESTAMP_SUPPORTED) | MAC PID Attribute
0x5D (ZMAC_SECURITY_ENABLED) | MAC PID Attribute
0xE0 (ZMAC_PHY_TRANSMIT_POWER) | MAC PID Attribute
0xE1 (ZMAC_LOGICAL_CHANNEL) | MAC PID Attribute
0xE2 (ZMAC_EXTENDED_ADDRESS) | MAC PID Attribute
0xE3 (ZMAC_ALT_BE) | MAC PID Attribute
0xE4 (ZMAC_DEVICE_BEACON_ORDER) | MAC PID Attribute
0xE5 (ZMAC_PHY_TRANSMIT_POWER_SIGNED) | MAC PID Attribute

See Also

TI.ZPI2 Namespace


ZMAC_GET_RESPONSE Class

ZMAC_GET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_GET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_GET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_GET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_GET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_GET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_GET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_GET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_GET_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_GET_RESPONSE Members

ZMAC_GET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_GET_REQUEST

The following tables list the members exposed by ZMAC_GET_RESPONSE.

Public Constructors

Name | Description
ZMAC_GET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Public field | Value | Array, contains the data read from the target.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_GET_RESPONSE | Overloaded.
Top

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_GET_RESPONSE Constructor

ZMAC_GET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_GET_RESPONSE | Constructor
Public method | ZMAC_GET_RESPONSE (ZMAC_GET_RESPONSE.CMD_STATUS, Byte) |

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_GET_RESPONSE Constructor ()

ZMAC_GET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_GET_RESPONSE()
C++
public:
ZMAC_GET_RESPONSE() sealed
J#
public ZMAC_GET_RESPONSE()
JScript
public function ZMAC_GET_RESPONSE()

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_GET_RESPONSE Constructor Overload List


ZMAC_GET_RESPONSE Constructor (ZMAC_GET_RESPONSE.CMD_STATUS, Byte[])

ZMAC_GET_RESPONSE Constructor (ZMAC_GET_RESPONSE.CMD_STATUS, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_GET_RESPONSE.CMD_STATUS, _
ByVal As Byte() _
)
C#
public ZMAC_GET_RESPONSE(
ZMAC_GET_RESPONSE.CMD_STATUS ,
byte[]
)
C++
public:
ZMAC_GET_RESPONSE(
ZMAC_GET_RESPONSE.CMD_STATUS ,
array<char>^
) sealed
J#
public ZMAC_GET_RESPONSE(
ZMAC_GET_RESPONSE.CMD_STATUS ,
byte[]
)
JScript
public function ZMAC_GET_RESPONSE(
: ZMAC_GET_RESPONSE.CMD_STATUS,
: Byte[]
)

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_GET_RESPONSE Constructor Overload List


Fields

ZMAC_GET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Public field | Value | Array, contains the data read from the target.
Top

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_GET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_GET_RESPONSE.CMD_STATUS
C#
public ZMAC_GET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_GET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_GET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_GET_RESPONSE.CMD_STATUS;

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI2 Namespace


Value Field

ZMAC_GET_RESPONSE.Value Field
[image]

Array, contains the data read from the target.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZMAC_GET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_GET_RESPONSE.CMD_STATUS Enumeration

ZMAC_GET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_GET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_GET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_GET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_GET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_GET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_INIT_REQUEST Class

ZMAC_INIT_REQUEST Class
See Also Example Members
[image]

This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_INIT_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_INIT_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_INIT_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_INIT_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_INIT_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_INIT_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_INIT_REQUEST Members
TI.ZPI2 Namespace


ZMAC_INIT_REQUEST Members

ZMAC_INIT_REQUEST Members
See Also Example Constructors Methods
[image]

This command is used to initialize the ZMAC on the current device (on behalf of the next higher layer).

The following tables list the members exposed by ZMAC_INIT_REQUEST.

Public Constructors

 | Name | Description
Public method | ZMAC_INIT_REQUEST | Constructor
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ZMAC_INIT_REQUEST Class
TI.ZPI2 Namespace


ZMAC_INIT_REQUEST Constructor

ZMAC_INIT_REQUEST Constructor
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_INIT_REQUEST()
C++
public:
ZMAC_INIT_REQUEST() sealed
J#
public ZMAC_INIT_REQUEST()
JScript
public function ZMAC_INIT_REQUEST()

See Also

ZMAC_INIT_REQUEST Class
TI.ZPI2 Namespace


ZMAC_INIT_RESPONSE Class

ZMAC_INIT_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_INIT_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_INIT_RESPONSE
Implements IRESPONSE
C#
public class ZMAC_INIT_RESPONSE : IRESPONSE
C++
ref class ZMAC_INIT_RESPONSE : IRESPONSE
J#
public class ZMAC_INIT_RESPONSE implements IRESPONSE
JScript
public class ZMAC_INIT_RESPONSE extends IRESPONSE

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_INIT_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_INIT_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_INIT_RESPONSE Members

ZMAC_INIT_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_INIT_REQUEST

The following tables list the members exposed by ZMAC_INIT_RESPONSE.

Public Constructors

Name | Description
ZMAC_INIT_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_INIT_RESPONSE | Overloaded.
Top

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_INIT_RESPONSE Constructor

ZMAC_INIT_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_INIT_RESPONSE | Constructor
Public method | ZMAC_INIT_RESPONSE (ZMAC_INIT_RESPONSE.CMD_STATUS) |

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_INIT_RESPONSE Constructor ()

ZMAC_INIT_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_INIT_RESPONSE()
C++
public:
ZMAC_INIT_RESPONSE() sealed
J#
public ZMAC_INIT_RESPONSE()
JScript
public function ZMAC_INIT_RESPONSE()

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_INIT_RESPONSE Constructor Overload List


ZMAC_INIT_RESPONSE Constructor (ZMAC_INIT_RESPONSE.CMD_STATUS)

ZMAC_INIT_RESPONSE Constructor (ZMAC_INIT_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_INIT_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_INIT_RESPONSE(
ZMAC_INIT_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_INIT_RESPONSE(
ZMAC_INIT_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_INIT_RESPONSE(
ZMAC_INIT_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_INIT_RESPONSE(
: ZMAC_INIT_RESPONSE.CMD_STATUS
)

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_INIT_RESPONSE Constructor Overload List


Fields

ZMAC_INIT_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_INIT_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_INIT_RESPONSE.CMD_STATUS
C#
public ZMAC_INIT_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_INIT_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_INIT_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_INIT_RESPONSE.CMD_STATUS;

See Also

ZMAC_INIT_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_INIT_RESPONSE.CMD_STATUS Enumeration

ZMAC_INIT_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_INIT_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_INIT_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_INIT_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_INIT_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_INIT_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_ORPHAN_IND Class

ZMAC_ORPHAN_IND Class
See Also Example Members
[image]

Orphan Indication

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ORPHAN_IND
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ORPHAN_IND : IRESPONSE, IZMAC
C++
ref class ZMAC_ORPHAN_IND : IRESPONSE, IZMAC
J#
public class ZMAC_ORPHAN_IND implements IRESPONSE, IZMAC
JScript
public class ZMAC_ORPHAN_IND extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ORPHAN_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ORPHAN_IND Members
TI.ZPI2 Namespace


ZMAC_ORPHAN_IND Members

ZMAC_ORPHAN_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Orphan Indication

The following tables list the members exposed by ZMAC_ORPHAN_IND.

Public Constructors

Name | Description
ZMAC_ORPHAN_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ExtendedAddr | Extended Address of the orphan
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ORPHAN_IND | Overloaded.
Top

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_IND Constructor

ZMAC_ORPHAN_IND Constructor

Overload List

 | Name | Description
Public method | ZMAC_ORPHAN_IND | Constructor
Public method | ZMAC_ORPHAN_IND (UInt64, Byte, ZMAC_ORPHAN_IND.SECURITY_LEVEL, ZMAC_ORPHAN_IND.KEY_ID_MODE, Byte) |

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_IND Constructor ()

ZMAC_ORPHAN_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ORPHAN_IND()
C++
public:
ZMAC_ORPHAN_IND() sealed
J#
public ZMAC_ORPHAN_IND()
JScript
public function ZMAC_ORPHAN_IND()

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace
ZMAC_ORPHAN_IND Constructor Overload List


ZMAC_ORPHAN_IND Constructor (UInt64, Byte[], ZMAC_ORPHAN_IND.SECURITY_LEVEL, ZMAC_ORPHAN_IND.KEY_ID_MODE, Byte)

ZMAC_ORPHAN_IND Constructor (UInt64, Byte[], ZMAC_ORPHAN_IND.SECURITY_LEVEL, ZMAC_ORPHAN_IND.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As Byte(), _
ByVal As ZMAC_ORPHAN_IND.SECURITY_LEVEL, _
ByVal As ZMAC_ORPHAN_IND.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ORPHAN_IND(
ulong ,
byte[] ,
ZMAC_ORPHAN_IND.SECURITY_LEVEL ,
ZMAC_ORPHAN_IND.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ORPHAN_IND(
unsigned __int64 ,
array<char>^ ,
ZMAC_ORPHAN_IND.SECURITY_LEVEL ,
ZMAC_ORPHAN_IND.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ORPHAN_IND(
ulong ,
byte[] ,
ZMAC_ORPHAN_IND.SECURITY_LEVEL ,
ZMAC_ORPHAN_IND.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ORPHAN_IND(
: UInt64,
: Byte[],
: ZMAC_ORPHAN_IND.SECURITY_LEVEL,
: ZMAC_ORPHAN_IND.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace
ZMAC_ORPHAN_IND Constructor Overload List


Fields

ZMAC_ORPHAN_IND Fields
[image]

Public Fields

 | Name | Description
Public field | ExtendedAddr | Extended Address of the orphan
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


ExtendedAddr Field

ZMAC_ORPHAN_IND.ExtendedAddr Field
[image]

Extended Address of the orphan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtendedAddr As UInt64
C#
public ulong ExtendedAddr;
C++
public:
unsigned __int64 ExtendedAddr sealed ;
J#
public ulong ExtendedAddr
JScript
public ExtendedAddr : UInt64;

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_ORPHAN_IND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ORPHAN_IND.KEY_ID_MODE
C#
public ZMAC_ORPHAN_IND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ORPHAN_IND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ORPHAN_IND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ORPHAN_IND.KEY_ID_MODE;

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_ORPHAN_IND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_ORPHAN_IND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_ORPHAN_IND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ORPHAN_IND.SECURITY_LEVEL
C#
public ZMAC_ORPHAN_IND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ORPHAN_IND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ORPHAN_IND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ORPHAN_IND.SECURITY_LEVEL;

See Also

ZMAC_ORPHAN_IND Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_IND.KEY_ID_MODE Enumeration

ZMAC_ORPHAN_IND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_IND.KEY_ID_MODE As Byte
C#
public enum ZMAC_ORPHAN_IND.KEY_ID_MODE : byte
C++
public enum class ZMAC_ORPHAN_IND.KEY_ID_MODE : char
J#
public enum ZMAC_ORPHAN_IND.KEY_ID_MODE byte
JScript
public enum ZMAC_ORPHAN_IND.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_ORPHAN_IND.SECURITY_LEVEL Enumeration

ZMAC_ORPHAN_IND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_IND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ORPHAN_IND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ORPHAN_IND.SECURITY_LEVEL : char
J#
public enum ZMAC_ORPHAN_IND.SECURITY_LEVEL byte
JScript
public enum ZMAC_ORPHAN_IND.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP Class

ZMAC_ORPHAN_RSP Class
See Also Example Members
[image]

This command is sent by the host to response to the ORPHAN_IND

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ORPHAN_RSP
Implements IREQUEST, IZMAC
C#
public class ZMAC_ORPHAN_RSP : IREQUEST, IZMAC
C++
ref class ZMAC_ORPHAN_RSP : IREQUEST, IZMAC
J#
public class ZMAC_ORPHAN_RSP implements IREQUEST, IZMAC
JScript
public class ZMAC_ORPHAN_RSP extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ORPHAN_RSP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ORPHAN_RSP Members
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP Members

ZMAC_ORPHAN_RSP Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is sent by the host to response to the ORPHAN_IND

The following tables list the members exposed by ZMAC_ORPHAN_RSP.

Public Constructors

Name | Description
ZMAC_ORPHAN_RSP | Overloaded.
Top

Public Fields

 | Name | Description
Public field | AssociatedMember | TRUE if the orphan is a associated member
Public field | AssocShortAddress | Short address of the orphan device
Public field | ExtAddr | Extended Address of the device sending the orphan notification
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ORPHAN_RSP | Overloaded.
Top

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP Constructor

ZMAC_ORPHAN_RSP Constructor

Overload List

 | Name | Description
Public method | ZMAC_ORPHAN_RSP | Constructor
Public method | ZMAC_ORPHAN_RSP (UInt64, UInt16, ZMAC_ORPHAN_RSP.BOOLEAN, Byte, ZMAC_ORPHAN_RSP.SECURITY_LEVEL, ZMAC_ORPHAN_RSP.KEY_ID_MODE, Byte) |

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP Constructor ()

ZMAC_ORPHAN_RSP Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ORPHAN_RSP()
C++
public:
ZMAC_ORPHAN_RSP() sealed
J#
public ZMAC_ORPHAN_RSP()
JScript
public function ZMAC_ORPHAN_RSP()

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace
ZMAC_ORPHAN_RSP Constructor Overload List


ZMAC_ORPHAN_RSP Constructor (UInt64, UInt16, ZMAC_ORPHAN_RSP.BOOLEAN, Byte[], ZMAC_ORPHAN_RSP.SECURITY_LEVEL, ZMAC_ORPHAN_RSP.KEY_ID_MODE, Byte)

ZMAC_ORPHAN_RSP Constructor (UInt64, UInt16, ZMAC_ORPHAN_RSP.BOOLEAN, Byte[], ZMAC_ORPHAN_RSP.SECURITY_LEVEL, ZMAC_ORPHAN_RSP.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As ZMAC_ORPHAN_RSP.BOOLEAN, _
ByVal As Byte(), _
ByVal As ZMAC_ORPHAN_RSP.SECURITY_LEVEL, _
ByVal As ZMAC_ORPHAN_RSP.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_ORPHAN_RSP(
ulong ,
ushort ,
ZMAC_ORPHAN_RSP.BOOLEAN ,
byte[] ,
ZMAC_ORPHAN_RSP.SECURITY_LEVEL ,
ZMAC_ORPHAN_RSP.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_ORPHAN_RSP(
unsigned __int64 ,
unsigned short ,
ZMAC_ORPHAN_RSP.BOOLEAN ,
array<char>^ ,
ZMAC_ORPHAN_RSP.SECURITY_LEVEL ,
ZMAC_ORPHAN_RSP.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_ORPHAN_RSP(
ulong ,
ushort ,
ZMAC_ORPHAN_RSP.BOOLEAN ,
byte[] ,
ZMAC_ORPHAN_RSP.SECURITY_LEVEL ,
ZMAC_ORPHAN_RSP.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_ORPHAN_RSP(
: UInt64,
: UInt16,
: ZMAC_ORPHAN_RSP.BOOLEAN,
: Byte[],
: ZMAC_ORPHAN_RSP.SECURITY_LEVEL,
: ZMAC_ORPHAN_RSP.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace
ZMAC_ORPHAN_RSP Constructor Overload List


Fields

ZMAC_ORPHAN_RSP Fields
[image]

Public Fields

 | Name | Description
Public field | AssociatedMember | TRUE if the orphan is a associated member
Public field | AssocShortAddress | Short address of the orphan device
Public field | ExtAddr | Extended Address of the device sending the orphan notification
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


AssociatedMember Field

ZMAC_ORPHAN_RSP.AssociatedMember Field
[image]

TRUE if the orphan is a associated member

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssociatedMember As ZMAC_ORPHAN_RSP.BOOLEAN
C#
public ZMAC_ORPHAN_RSP.BOOLEAN AssociatedMember;
C++
public:
ZMAC_ORPHAN_RSP.BOOLEAN AssociatedMember sealed ;
J#
public ZMAC_ORPHAN_RSP.BOOLEAN AssociatedMember
JScript
public AssociatedMember : ZMAC_ORPHAN_RSP.BOOLEAN;

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


AssocShortAddress Field

ZMAC_ORPHAN_RSP.AssocShortAddress Field
[image]

Short address of the orphan device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AssocShortAddress As UInt16
C#
public ushort AssocShortAddress;
C++
public:
unsigned short AssocShortAddress sealed ;
J#
public ushort AssocShortAddress
JScript
public AssocShortAddress : UInt16;

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


ExtAddr Field

ZMAC_ORPHAN_RSP.ExtAddr Field
[image]

Extended Address of the device sending the orphan notification

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ExtAddr As UInt64
C#
public ulong ExtAddr;
C++
public:
unsigned __int64 ExtAddr sealed ;
J#
public ulong ExtAddr
JScript
public ExtAddr : UInt64;

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_ORPHAN_RSP.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_ORPHAN_RSP.KEY_ID_MODE
C#
public ZMAC_ORPHAN_RSP.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_ORPHAN_RSP.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_ORPHAN_RSP.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_ORPHAN_RSP.KEY_ID_MODE;

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_ORPHAN_RSP.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_ORPHAN_RSP.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_ORPHAN_RSP.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_ORPHAN_RSP.SECURITY_LEVEL
C#
public ZMAC_ORPHAN_RSP.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_ORPHAN_RSP.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_ORPHAN_RSP.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_ORPHAN_RSP.SECURITY_LEVEL;

See Also

ZMAC_ORPHAN_RSP Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP.BOOLEAN Enumeration

ZMAC_ORPHAN_RSP.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_RSP.BOOLEAN As Byte
C#
public enum ZMAC_ORPHAN_RSP.BOOLEAN : byte
C++
public enum class ZMAC_ORPHAN_RSP.BOOLEAN : char
J#
public enum ZMAC_ORPHAN_RSP.BOOLEAN byte
JScript
public enum ZMAC_ORPHAN_RSP.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP.KEY_ID_MODE Enumeration

ZMAC_ORPHAN_RSP.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_RSP.KEY_ID_MODE As Byte
C#
public enum ZMAC_ORPHAN_RSP.KEY_ID_MODE : byte
C++
public enum class ZMAC_ORPHAN_RSP.KEY_ID_MODE : char
J#
public enum ZMAC_ORPHAN_RSP.KEY_ID_MODE byte
JScript
public enum ZMAC_ORPHAN_RSP.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP.SECURITY_LEVEL Enumeration

ZMAC_ORPHAN_RSP.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_RSP.SECURITY_LEVEL As Byte
C#
public enum ZMAC_ORPHAN_RSP.SECURITY_LEVEL : byte
C++
public enum class ZMAC_ORPHAN_RSP.SECURITY_LEVEL : char
J#
public enum ZMAC_ORPHAN_RSP.SECURITY_LEVEL byte
JScript
public enum ZMAC_ORPHAN_RSP.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP_RESPONSE Class

ZMAC_ORPHAN_RSP_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_ORPHAN_RSP

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_ORPHAN_RSP_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_ORPHAN_RSP_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_ORPHAN_RSP_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_ORPHAN_RSP_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_ORPHAN_RSP_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_ORPHAN_RSP_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_ORPHAN_RSP_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP_RESPONSE Members

ZMAC_ORPHAN_RSP_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_ORPHAN_RSP

The following tables list the members exposed by ZMAC_ORPHAN_RSP_RESPONSE.

Public Constructors

Name | Description
ZMAC_ORPHAN_RSP_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_ORPHAN_RSP_RESPONSE | Overloaded.
Top

See Also

ZMAC_ORPHAN_RSP_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP_RESPONSE Constructor

ZMAC_ORPHAN_RSP_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_ORPHAN_RSP_RESPONSE | Constructor
Public method | ZMAC_ORPHAN_RSP_RESPONSE (ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS) |

See Also

ZMAC_ORPHAN_RSP_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP_RESPONSE Constructor ()

ZMAC_ORPHAN_RSP_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_ORPHAN_RSP_RESPONSE()
C++
public:
ZMAC_ORPHAN_RSP_RESPONSE() sealed
J#
public ZMAC_ORPHAN_RSP_RESPONSE()
JScript
public function ZMAC_ORPHAN_RSP_RESPONSE()

See Also

ZMAC_ORPHAN_RSP_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ORPHAN_RSP_RESPONSE Constructor Overload List


ZMAC_ORPHAN_RSP_RESPONSE Constructor (ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS)

ZMAC_ORPHAN_RSP_RESPONSE Constructor (ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_ORPHAN_RSP_RESPONSE(
ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_ORPHAN_RSP_RESPONSE(
ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_ORPHAN_RSP_RESPONSE(
ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_ORPHAN_RSP_RESPONSE(
: ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS
)

See Also

ZMAC_ORPHAN_RSP_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_ORPHAN_RSP_RESPONSE Constructor Overload List


Fields

ZMAC_ORPHAN_RSP_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_ORPHAN_RSP_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_ORPHAN_RSP_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS
C#
public ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS;

See Also

ZMAC_ORPHAN_RSP_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS Enumeration

ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_POLL_CNF Class

ZMAC_POLL_CNF Class
See Also Example Members
[image]

Mac Poll Confirmation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_POLL_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_POLL_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_POLL_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_POLL_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_POLL_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_POLL_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_POLL_CNF Members
TI.ZPI2 Namespace


ZMAC_POLL_CNF Members

ZMAC_POLL_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Mac Poll Confirmation

The following tables list the members exposed by ZMAC_POLL_CNF.

Public Constructors

Name | Description
ZMAC_POLL_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_POLL_CNF | Overloaded.
Top

See Also

ZMAC_POLL_CNF Class
TI.ZPI2 Namespace


ZMAC_POLL_CNF Constructor

ZMAC_POLL_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_POLL_CNF | Constructor
Public method | ZMAC_POLL_CNF (ZMAC_POLL_CNF.CMD_STATUS) |

See Also

ZMAC_POLL_CNF Class
TI.ZPI2 Namespace


ZMAC_POLL_CNF Constructor ()

ZMAC_POLL_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_POLL_CNF()
C++
public:
ZMAC_POLL_CNF() sealed
J#
public ZMAC_POLL_CNF()
JScript
public function ZMAC_POLL_CNF()

See Also

ZMAC_POLL_CNF Class
TI.ZPI2 Namespace
ZMAC_POLL_CNF Constructor Overload List


ZMAC_POLL_CNF Constructor (ZMAC_POLL_CNF.CMD_STATUS)

ZMAC_POLL_CNF Constructor (ZMAC_POLL_CNF.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_POLL_CNF.CMD_STATUS _
)
C#
public ZMAC_POLL_CNF(
ZMAC_POLL_CNF.CMD_STATUS
)
C++
public:
ZMAC_POLL_CNF(
ZMAC_POLL_CNF.CMD_STATUS
) sealed
J#
public ZMAC_POLL_CNF(
ZMAC_POLL_CNF.CMD_STATUS
)
JScript
public function ZMAC_POLL_CNF(
: ZMAC_POLL_CNF.CMD_STATUS
)

See Also

ZMAC_POLL_CNF Class
TI.ZPI2 Namespace
ZMAC_POLL_CNF Constructor Overload List


Fields

ZMAC_POLL_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_POLL_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_POLL_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_POLL_CNF.CMD_STATUS
C#
public ZMAC_POLL_CNF.CMD_STATUS Status;
C++
public:
ZMAC_POLL_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_POLL_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_POLL_CNF.CMD_STATUS;

See Also

ZMAC_POLL_CNF Class
TI.ZPI2 Namespace


ZMAC_POLL_CNF.CMD_STATUS Enumeration

ZMAC_POLL_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_POLL_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_POLL_CNF.CMD_STATUS : char
J#
public enum ZMAC_POLL_CNF.CMD_STATUS byte
JScript
public enum ZMAC_POLL_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_POLL_REQUEST Class

ZMAC_POLL_REQUEST Class
See Also Example Members
[image]

This command is used to send a MAC data request poll

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_POLL_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_POLL_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_POLL_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_POLL_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_POLL_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_POLL_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_POLL_REQUEST Members
TI.ZPI2 Namespace


ZMAC_POLL_REQUEST Members

ZMAC_POLL_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a MAC data request poll

The following tables list the members exposed by ZMAC_POLL_REQUEST.

Public Constructors

Name | Description
ZMAC_POLL_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | CoordAddress | Coordinator Address
Public field | CoordAddressMode | Specified the format of the coordinator address
Public field | CoordPanID | PAN Id of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_POLL_REQUEST | Overloaded.
Top

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


ZMAC_POLL_REQUEST Constructor

ZMAC_POLL_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_POLL_REQUEST | Constructor
Public method | ZMAC_POLL_REQUEST (ZMAC_POLL_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte, ZMAC_POLL_REQUEST.SECURITY_LEVEL, ZMAC_POLL_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


ZMAC_POLL_REQUEST Constructor ()

ZMAC_POLL_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_POLL_REQUEST()
C++
public:
ZMAC_POLL_REQUEST() sealed
J#
public ZMAC_POLL_REQUEST()
JScript
public function ZMAC_POLL_REQUEST()

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace
ZMAC_POLL_REQUEST Constructor Overload List


ZMAC_POLL_REQUEST Constructor (ZMAC_POLL_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte[], ZMAC_POLL_REQUEST.SECURITY_LEVEL, ZMAC_POLL_REQUEST.KEY_ID_MODE, Byte)

ZMAC_POLL_REQUEST Constructor (ZMAC_POLL_REQUEST.ADDRESS_MODE, UInt64, UInt16, Byte[], ZMAC_POLL_REQUEST.SECURITY_LEVEL, ZMAC_POLL_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_POLL_REQUEST.ADDRESS_MODE, _
ByVal As UInt64, _
ByVal As UInt16, _
ByVal As Byte(), _
ByVal As ZMAC_POLL_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_POLL_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_POLL_REQUEST(
ZMAC_POLL_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
byte[] ,
ZMAC_POLL_REQUEST.SECURITY_LEVEL ,
ZMAC_POLL_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_POLL_REQUEST(
ZMAC_POLL_REQUEST.ADDRESS_MODE ,
unsigned __int64 ,
unsigned short ,
array<char>^ ,
ZMAC_POLL_REQUEST.SECURITY_LEVEL ,
ZMAC_POLL_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_POLL_REQUEST(
ZMAC_POLL_REQUEST.ADDRESS_MODE ,
ulong ,
ushort ,
byte[] ,
ZMAC_POLL_REQUEST.SECURITY_LEVEL ,
ZMAC_POLL_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_POLL_REQUEST(
: ZMAC_POLL_REQUEST.ADDRESS_MODE,
: UInt64,
: UInt16,
: Byte[],
: ZMAC_POLL_REQUEST.SECURITY_LEVEL,
: ZMAC_POLL_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace
ZMAC_POLL_REQUEST Constructor Overload List


Fields

ZMAC_POLL_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | CoordAddress | Coordinator Address
Public field | CoordAddressMode | Specified the format of the coordinator address
Public field | CoordPanID | PAN Id of the coordinator
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


CoordAddress Field

ZMAC_POLL_REQUEST.CoordAddress Field
[image]

Coordinator Address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddress As UInt64
C#
public ulong CoordAddress;
C++
public:
unsigned __int64 CoordAddress sealed ;
J#
public ulong CoordAddress
JScript
public CoordAddress : UInt64;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


CoordAddressMode Field

ZMAC_POLL_REQUEST.CoordAddressMode Field
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordAddressMode As ZMAC_POLL_REQUEST.ADDRESS_MODE
C#
public ZMAC_POLL_REQUEST.ADDRESS_MODE CoordAddressMode;
C++
public:
ZMAC_POLL_REQUEST.ADDRESS_MODE CoordAddressMode sealed ;
J#
public ZMAC_POLL_REQUEST.ADDRESS_MODE CoordAddressMode
JScript
public CoordAddressMode : ZMAC_POLL_REQUEST.ADDRESS_MODE;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


CoordPanID Field

ZMAC_POLL_REQUEST.CoordPanID Field
[image]

PAN Id of the coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordPanID As UInt16
C#
public ushort CoordPanID;
C++
public:
unsigned short CoordPanID sealed ;
J#
public ushort CoordPanID
JScript
public CoordPanID : UInt16;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_POLL_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_POLL_REQUEST.KEY_ID_MODE
C#
public ZMAC_POLL_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_POLL_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_POLL_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_POLL_REQUEST.KEY_ID_MODE;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_POLL_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_POLL_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_POLL_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_POLL_REQUEST.SECURITY_LEVEL
C#
public ZMAC_POLL_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_POLL_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_POLL_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_POLL_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_POLL_REQUEST Class
TI.ZPI2 Namespace


ZMAC_POLL_REQUEST.ADDRESS_MODE Enumeration

ZMAC_POLL_REQUEST.ADDRESS_MODE Enumeration
[image]

Specified the format of the coordinator address

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_REQUEST.ADDRESS_MODE As Byte
C#
public enum ZMAC_POLL_REQUEST.ADDRESS_MODE : byte
C++
public enum class ZMAC_POLL_REQUEST.ADDRESS_MODE : char
J#
public enum ZMAC_POLL_REQUEST.ADDRESS_MODE byte
JScript
public enum ZMAC_POLL_REQUEST.ADDRESS_MODE :

Members

Member Name | Description
0x00 (ADDRESS_NOT_PRESENT) | Specified the format of the coordinator address
0x01 (GROUP_ADDRESS) | Specified the format of the coordinator address
0x02 (ADDRESS_16_BIT) | Specified the format of the coordinator address
0x03 (ADDRESS_64_BIT) | Specified the format of the coordinator address
0x0F (BROADCAST) | Specified the format of the coordinator address

See Also

TI.ZPI2 Namespace


ZMAC_POLL_REQUEST.KEY_ID_MODE Enumeration

ZMAC_POLL_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_POLL_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_POLL_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_POLL_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_POLL_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_POLL_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_POLL_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_POLL_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_POLL_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_POLL_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_POLL_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_POLL_RESPONSE Class

ZMAC_POLL_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_POLL_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_POLL_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_POLL_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_POLL_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_POLL_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_POLL_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_POLL_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_POLL_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_POLL_RESPONSE Members

ZMAC_POLL_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_POLL_REQUEST

The following tables list the members exposed by ZMAC_POLL_RESPONSE.

Public Constructors

Name | Description
ZMAC_POLL_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_POLL_RESPONSE | Overloaded.
Top

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_POLL_RESPONSE Constructor

ZMAC_POLL_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_POLL_RESPONSE | Constructor
Public method | ZMAC_POLL_RESPONSE (ZMAC_POLL_RESPONSE.CMD_STATUS) |

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_POLL_RESPONSE Constructor ()

ZMAC_POLL_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_POLL_RESPONSE()
C++
public:
ZMAC_POLL_RESPONSE() sealed
J#
public ZMAC_POLL_RESPONSE()
JScript
public function ZMAC_POLL_RESPONSE()

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_POLL_RESPONSE Constructor Overload List


ZMAC_POLL_RESPONSE Constructor (ZMAC_POLL_RESPONSE.CMD_STATUS)

ZMAC_POLL_RESPONSE Constructor (ZMAC_POLL_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_POLL_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_POLL_RESPONSE(
ZMAC_POLL_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_POLL_RESPONSE(
ZMAC_POLL_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_POLL_RESPONSE(
ZMAC_POLL_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_POLL_RESPONSE(
: ZMAC_POLL_RESPONSE.CMD_STATUS
)

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_POLL_RESPONSE Constructor Overload List


Fields

ZMAC_POLL_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_POLL_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_POLL_RESPONSE.CMD_STATUS
C#
public ZMAC_POLL_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_POLL_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_POLL_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_POLL_RESPONSE.CMD_STATUS;

See Also

ZMAC_POLL_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_POLL_RESPONSE.CMD_STATUS Enumeration

ZMAC_POLL_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_POLL_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_POLL_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_POLL_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_POLL_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_POLL_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_PURGE_CNF Class

ZMAC_PURGE_CNF Class
See Also Example Members
[image]

Mac RX enable Confirmation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_PURGE_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_PURGE_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_PURGE_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_PURGE_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_PURGE_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_PURGE_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_PURGE_CNF Members
TI.ZPI2 Namespace


ZMAC_PURGE_CNF Members

ZMAC_PURGE_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Mac RX enable Confirmation

The following tables list the members exposed by ZMAC_PURGE_CNF.

Public Constructors

Name | Description
ZMAC_PURGE_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Handle | Handle
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_PURGE_CNF | Overloaded.
Top

See Also

ZMAC_PURGE_CNF Class
TI.ZPI2 Namespace


ZMAC_PURGE_CNF Constructor

ZMAC_PURGE_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_PURGE_CNF | Constructor
Public method | ZMAC_PURGE_CNF (ZMAC_PURGE_CNF.CMD_STATUS, Byte) |

See Also

ZMAC_PURGE_CNF Class
TI.ZPI2 Namespace


ZMAC_PURGE_CNF Constructor ()

ZMAC_PURGE_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_PURGE_CNF()
C++
public:
ZMAC_PURGE_CNF() sealed
J#
public ZMAC_PURGE_CNF()
JScript
public function ZMAC_PURGE_CNF()

See Also

ZMAC_PURGE_CNF Class
TI.ZPI2 Namespace
ZMAC_PURGE_CNF Constructor Overload List


ZMAC_PURGE_CNF Constructor (ZMAC_PURGE_CNF.CMD_STATUS, Byte)

ZMAC_PURGE_CNF Constructor (ZMAC_PURGE_CNF.CMD_STATUS, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_PURGE_CNF.CMD_STATUS, _
ByVal As Byte _
)
C#
public ZMAC_PURGE_CNF(
ZMAC_PURGE_CNF.CMD_STATUS ,
byte
)
C++
public:
ZMAC_PURGE_CNF(
ZMAC_PURGE_CNF.CMD_STATUS ,
char
) sealed
J#
public ZMAC_PURGE_CNF(
ZMAC_PURGE_CNF.CMD_STATUS ,
byte
)
JScript
public function ZMAC_PURGE_CNF(
: ZMAC_PURGE_CNF.CMD_STATUS,
: Byte
)

See Also

ZMAC_PURGE_CNF Class
TI.ZPI2 Namespace
ZMAC_PURGE_CNF Constructor Overload List


Fields

ZMAC_PURGE_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Handle | Handle
Public field | Status | Status
Top

See Also

ZMAC_PURGE_CNF Class
TI.ZPI2 Namespace


Handle Field

ZMAC_PURGE_CNF.Handle Field
[image]

Handle

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Handle As Byte
C#
public byte Handle;
C++
public:
char Handle sealed ;
J#
public byte Handle
JScript
public Handle : Byte;

See Also

ZMAC_PURGE_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_PURGE_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_PURGE_CNF.CMD_STATUS
C#
public ZMAC_PURGE_CNF.CMD_STATUS Status;
C++
public:
ZMAC_PURGE_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_PURGE_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_PURGE_CNF.CMD_STATUS;

See Also

ZMAC_PURGE_CNF Class
TI.ZPI2 Namespace


ZMAC_PURGE_CNF.CMD_STATUS Enumeration

ZMAC_PURGE_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_PURGE_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_PURGE_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_PURGE_CNF.CMD_STATUS : char
J#
public enum ZMAC_PURGE_CNF.CMD_STATUS byte
JScript
public enum ZMAC_PURGE_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_PURGE_REQUEST Class

ZMAC_PURGE_REQUEST Class
See Also Example Members
[image]

This command is used to send a request to the device to purge a data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_PURGE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_PURGE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_PURGE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_PURGE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_PURGE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_PURGE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_PURGE_REQUEST Members
TI.ZPI2 Namespace


ZMAC_PURGE_REQUEST Members

ZMAC_PURGE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a request to the device to purge a data frame

The following tables list the members exposed by ZMAC_PURGE_REQUEST.

Public Constructors

Name | Description
ZMAC_PURGE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | MsduHandle | Msdu Handle
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_PURGE_REQUEST | Overloaded.
Top

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_PURGE_REQUEST Constructor

ZMAC_PURGE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_PURGE_REQUEST | Constructor
Public method | ZMAC_PURGE_REQUEST (Byte) | Constructor

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_PURGE_REQUEST Constructor ()

ZMAC_PURGE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_PURGE_REQUEST()
C++
public:
ZMAC_PURGE_REQUEST() sealed
J#
public ZMAC_PURGE_REQUEST()
JScript
public function ZMAC_PURGE_REQUEST()

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_PURGE_REQUEST Constructor Overload List


ZMAC_PURGE_REQUEST Constructor (Byte)

ZMAC_PURGE_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZMAC_PURGE_REQUEST(
byte
)
C++
public:
ZMAC_PURGE_REQUEST(
char
) sealed
J#
public ZMAC_PURGE_REQUEST(
byte
)
JScript
public function ZMAC_PURGE_REQUEST(
: Byte
)

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_PURGE_REQUEST Constructor Overload List


Fields

ZMAC_PURGE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | MsduHandle | Msdu Handle
Top

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI2 Namespace


MsduHandle Field

ZMAC_PURGE_REQUEST.MsduHandle Field
[image]

Msdu Handle

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MsduHandle As Byte
C#
public byte MsduHandle;
C++
public:
char MsduHandle sealed ;
J#
public byte MsduHandle
JScript
public MsduHandle : Byte;

See Also

ZMAC_PURGE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_PURGE_RESPONSE Class

ZMAC_PURGE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_PURGE_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_PURGE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_PURGE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_PURGE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_PURGE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_PURGE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_PURGE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_PURGE_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_PURGE_RESPONSE Members

ZMAC_PURGE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_PURGE_REQUEST

The following tables list the members exposed by ZMAC_PURGE_RESPONSE.

Public Constructors

Name | Description
ZMAC_PURGE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_PURGE_RESPONSE | Overloaded.
Top

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_PURGE_RESPONSE Constructor

ZMAC_PURGE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_PURGE_RESPONSE | Constructor
Public method | ZMAC_PURGE_RESPONSE (ZMAC_PURGE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_PURGE_RESPONSE Constructor ()

ZMAC_PURGE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_PURGE_RESPONSE()
C++
public:
ZMAC_PURGE_RESPONSE() sealed
J#
public ZMAC_PURGE_RESPONSE()
JScript
public function ZMAC_PURGE_RESPONSE()

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_PURGE_RESPONSE Constructor Overload List


ZMAC_PURGE_RESPONSE Constructor (ZMAC_PURGE_RESPONSE.CMD_STATUS)

ZMAC_PURGE_RESPONSE Constructor (ZMAC_PURGE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_PURGE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_PURGE_RESPONSE(
ZMAC_PURGE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_PURGE_RESPONSE(
ZMAC_PURGE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_PURGE_RESPONSE(
ZMAC_PURGE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_PURGE_RESPONSE(
: ZMAC_PURGE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_PURGE_RESPONSE Constructor Overload List


Fields

ZMAC_PURGE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_PURGE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_PURGE_RESPONSE.CMD_STATUS
C#
public ZMAC_PURGE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_PURGE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_PURGE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_PURGE_RESPONSE.CMD_STATUS;

See Also

ZMAC_PURGE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_PURGE_RESPONSE.CMD_STATUS Enumeration

ZMAC_PURGE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_PURGE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_PURGE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_PURGE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_PURGE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_PURGE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_RESET_REQUEST Class

ZMAC_RESET_REQUEST Class
See Also Example Members
[image]

This command is used to send a MAC Reset command to reset MAC state machine

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_RESET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_RESET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_RESET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_RESET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_RESET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_RESET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_RESET_REQUEST Members
TI.ZPI2 Namespace


ZMAC_RESET_REQUEST Members

ZMAC_RESET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a MAC Reset command to reset MAC state machine

The following tables list the members exposed by ZMAC_RESET_REQUEST.

Public Constructors

Name | Description
ZMAC_RESET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | SetDefault | Set Default
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_RESET_REQUEST | Overloaded.
Top

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_RESET_REQUEST Constructor

ZMAC_RESET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_RESET_REQUEST | Constructor
Public method | ZMAC_RESET_REQUEST (Byte) | Constructor

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_RESET_REQUEST Constructor ()

ZMAC_RESET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_RESET_REQUEST()
C++
public:
ZMAC_RESET_REQUEST() sealed
J#
public ZMAC_RESET_REQUEST()
JScript
public function ZMAC_RESET_REQUEST()

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_RESET_REQUEST Constructor Overload List


ZMAC_RESET_REQUEST Constructor (Byte)

ZMAC_RESET_REQUEST Constructor (Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte _
)
C#
public ZMAC_RESET_REQUEST(
byte
)
C++
public:
ZMAC_RESET_REQUEST(
char
) sealed
J#
public ZMAC_RESET_REQUEST(
byte
)
JScript
public function ZMAC_RESET_REQUEST(
: Byte
)

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_RESET_REQUEST Constructor Overload List


Fields

ZMAC_RESET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | SetDefault | Set Default
Top

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI2 Namespace


SetDefault Field

ZMAC_RESET_REQUEST.SetDefault Field
[image]

Set Default

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SetDefault As Byte
C#
public byte SetDefault;
C++
public:
char SetDefault sealed ;
J#
public byte SetDefault
JScript
public SetDefault : Byte;

See Also

ZMAC_RESET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_RESET_RESPONSE Class

ZMAC_RESET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_RESET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_RESET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_RESET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_RESET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_RESET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_RESET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_RESET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_RESET_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_RESET_RESPONSE Members

ZMAC_RESET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_RESET_REQUEST

The following tables list the members exposed by ZMAC_RESET_RESPONSE.

Public Constructors

Name | Description
ZMAC_RESET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_RESET_RESPONSE | Overloaded.
Top

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_RESET_RESPONSE Constructor

ZMAC_RESET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_RESET_RESPONSE | Constructor
Public method | ZMAC_RESET_RESPONSE (ZMAC_RESET_RESPONSE.CMD_STATUS) |

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_RESET_RESPONSE Constructor ()

ZMAC_RESET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_RESET_RESPONSE()
C++
public:
ZMAC_RESET_RESPONSE() sealed
J#
public ZMAC_RESET_RESPONSE()
JScript
public function ZMAC_RESET_RESPONSE()

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_RESET_RESPONSE Constructor Overload List


ZMAC_RESET_RESPONSE Constructor (ZMAC_RESET_RESPONSE.CMD_STATUS)

ZMAC_RESET_RESPONSE Constructor (ZMAC_RESET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_RESET_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_RESET_RESPONSE(
ZMAC_RESET_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_RESET_RESPONSE(
ZMAC_RESET_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_RESET_RESPONSE(
ZMAC_RESET_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_RESET_RESPONSE(
: ZMAC_RESET_RESPONSE.CMD_STATUS
)

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_RESET_RESPONSE Constructor Overload List


Fields

ZMAC_RESET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_RESET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_RESET_RESPONSE.CMD_STATUS
C#
public ZMAC_RESET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_RESET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_RESET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_RESET_RESPONSE.CMD_STATUS;

See Also

ZMAC_RESET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_RESET_RESPONSE.CMD_STATUS Enumeration

ZMAC_RESET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_RESET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_RESET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_RESET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_RESET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_RESET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_RX_ENABLE_CNF Class

ZMAC_RX_ENABLE_CNF Class
See Also Example Members
[image]

Mac RX enable Confirmation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_RX_ENABLE_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_RX_ENABLE_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_RX_ENABLE_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_RX_ENABLE_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_RX_ENABLE_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_RX_ENABLE_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_RX_ENABLE_CNF Members
TI.ZPI2 Namespace


ZMAC_RX_ENABLE_CNF Members

ZMAC_RX_ENABLE_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Mac RX enable Confirmation

The following tables list the members exposed by ZMAC_RX_ENABLE_CNF.

Public Constructors

Name | Description
ZMAC_RX_ENABLE_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_RX_ENABLE_CNF | Overloaded.
Top

See Also

ZMAC_RX_ENABLE_CNF Class
TI.ZPI2 Namespace


ZMAC_RX_ENABLE_CNF Constructor

ZMAC_RX_ENABLE_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_RX_ENABLE_CNF | Constructor
Public method | ZMAC_RX_ENABLE_CNF (ZMAC_RX_ENABLE_CNF.CMD_STATUS) |

See Also

ZMAC_RX_ENABLE_CNF Class
TI.ZPI2 Namespace


ZMAC_RX_ENABLE_CNF Constructor ()

ZMAC_RX_ENABLE_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_RX_ENABLE_CNF()
C++
public:
ZMAC_RX_ENABLE_CNF() sealed
J#
public ZMAC_RX_ENABLE_CNF()
JScript
public function ZMAC_RX_ENABLE_CNF()

See Also

ZMAC_RX_ENABLE_CNF Class
TI.ZPI2 Namespace
ZMAC_RX_ENABLE_CNF Constructor Overload List


ZMAC_RX_ENABLE_CNF Constructor (ZMAC_RX_ENABLE_CNF.CMD_STATUS)

ZMAC_RX_ENABLE_CNF Constructor (ZMAC_RX_ENABLE_CNF.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_RX_ENABLE_CNF.CMD_STATUS _
)
C#
public ZMAC_RX_ENABLE_CNF(
ZMAC_RX_ENABLE_CNF.CMD_STATUS
)
C++
public:
ZMAC_RX_ENABLE_CNF(
ZMAC_RX_ENABLE_CNF.CMD_STATUS
) sealed
J#
public ZMAC_RX_ENABLE_CNF(
ZMAC_RX_ENABLE_CNF.CMD_STATUS
)
JScript
public function ZMAC_RX_ENABLE_CNF(
: ZMAC_RX_ENABLE_CNF.CMD_STATUS
)

See Also

ZMAC_RX_ENABLE_CNF Class
TI.ZPI2 Namespace
ZMAC_RX_ENABLE_CNF Constructor Overload List


Fields

ZMAC_RX_ENABLE_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_RX_ENABLE_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_RX_ENABLE_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_RX_ENABLE_CNF.CMD_STATUS
C#
public ZMAC_RX_ENABLE_CNF.CMD_STATUS Status;
C++
public:
ZMAC_RX_ENABLE_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_RX_ENABLE_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_RX_ENABLE_CNF.CMD_STATUS;

See Also

ZMAC_RX_ENABLE_CNF Class
TI.ZPI2 Namespace


ZMAC_RX_ENABLE_CNF.CMD_STATUS Enumeration

ZMAC_RX_ENABLE_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_RX_ENABLE_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_RX_ENABLE_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_RX_ENABLE_CNF.CMD_STATUS : char
J#
public enum ZMAC_RX_ENABLE_CNF.CMD_STATUS byte
JScript
public enum ZMAC_RX_ENABLE_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SCAN_CNF Class

ZMAC_SCAN_CNF Class
See Also Example Members
[image]

Scan Confirmation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SCAN_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SCAN_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_SCAN_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_SCAN_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_SCAN_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SCAN_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SCAN_CNF Members
TI.ZPI2 Namespace


ZMAC_SCAN_CNF Members

ZMAC_SCAN_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Scan Confirmation

The following tables list the members exposed by ZMAC_SCAN_CNF.

Public Constructors

Name | Description
ZMAC_SCAN_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | Channel Page
Public field | ED | ED max Enegry
Public field | ResultList | Dynamic array holds the result list
Public field | ResultListCount | Result List Count
Public field | ResultListMaxLength | Max Length of the result list
Public field | ScanType | Scan Type
Public field | Status | Status
Public field | UnscannedChannelList | Unscanned Channel List
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SCAN_CNF | Overloaded.
Top

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ZMAC_SCAN_CNF Constructor

ZMAC_SCAN_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_SCAN_CNF | Constructor
Public method | ZMAC_SCAN_CNF (ZMAC_SCAN_CNF.CMD_STATUS, Byte, ZMAC_SCAN_CNF.SCAN_TYPE, Byte, UInt32, Byte, Byte, Byte) |

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ZMAC_SCAN_CNF Constructor ()

ZMAC_SCAN_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SCAN_CNF()
C++
public:
ZMAC_SCAN_CNF() sealed
J#
public ZMAC_SCAN_CNF()
JScript
public function ZMAC_SCAN_CNF()

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace
ZMAC_SCAN_CNF Constructor Overload List


ZMAC_SCAN_CNF Constructor (ZMAC_SCAN_CNF.CMD_STATUS, Byte, ZMAC_SCAN_CNF.SCAN_TYPE, Byte, UInt32, Byte, Byte, Byte[])

ZMAC_SCAN_CNF Constructor (ZMAC_SCAN_CNF.CMD_STATUS, Byte, ZMAC_SCAN_CNF.SCAN_TYPE, Byte, UInt32, Byte, Byte, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SCAN_CNF.CMD_STATUS, _
ByVal As Byte, _
ByVal As ZMAC_SCAN_CNF.SCAN_TYPE, _
ByVal As Byte, _
ByVal As UInt32, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte() _
)
C#
public ZMAC_SCAN_CNF(
ZMAC_SCAN_CNF.CMD_STATUS ,
byte ,
ZMAC_SCAN_CNF.SCAN_TYPE ,
byte ,
uint ,
byte ,
byte ,
byte[]
)
C++
public:
ZMAC_SCAN_CNF(
ZMAC_SCAN_CNF.CMD_STATUS ,
char ,
ZMAC_SCAN_CNF.SCAN_TYPE ,
char ,
unsigned int ,
char ,
char ,
array<char>^
) sealed
J#
public ZMAC_SCAN_CNF(
ZMAC_SCAN_CNF.CMD_STATUS ,
byte ,
ZMAC_SCAN_CNF.SCAN_TYPE ,
byte ,
uint ,
byte ,
byte ,
byte[]
)
JScript
public function ZMAC_SCAN_CNF(
: ZMAC_SCAN_CNF.CMD_STATUS,
: Byte,
: ZMAC_SCAN_CNF.SCAN_TYPE,
: Byte,
: UInt32,
: Byte,
: Byte,
: Byte[]
)

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace
ZMAC_SCAN_CNF Constructor Overload List


Fields

ZMAC_SCAN_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | Channel Page
Public field | ED | ED max Enegry
Public field | ResultList | Dynamic array holds the result list
Public field | ResultListCount | Result List Count
Public field | ResultListMaxLength | Max Length of the result list
Public field | ScanType | Scan Type
Public field | Status | Status
Public field | UnscannedChannelList | Unscanned Channel List
Top

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ChannelPage Field

ZMAC_SCAN_CNF.ChannelPage Field
[image]

Channel Page

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ED Field

ZMAC_SCAN_CNF.ED Field
[image]

ED max Enegry

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ED As Byte
C#
public byte ED;
C++
public:
char ED sealed ;
J#
public byte ED
JScript
public ED : Byte;

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ResultList Field

ZMAC_SCAN_CNF.ResultList Field
[image]

Dynamic array holds the result list

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ResultList As Byte()
C#
public byte[] ResultList;
C++
public:
array<char>^ ResultList sealed ;
J#
public byte[] ResultList
JScript
public ResultList : Byte[];

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ResultListCount Field

ZMAC_SCAN_CNF.ResultListCount Field
[image]

Result List Count

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ResultListCount As Byte
C#
public byte ResultListCount;
C++
public:
char ResultListCount sealed ;
J#
public byte ResultListCount
JScript
public ResultListCount : Byte;

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ResultListMaxLength Field

ZMAC_SCAN_CNF.ResultListMaxLength Field
[image]

Max Length of the result list

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ResultListMaxLength As Byte
C#
public byte ResultListMaxLength;
C++
public:
char ResultListMaxLength sealed ;
J#
public byte ResultListMaxLength
JScript
public ResultListMaxLength : Byte;

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ScanType Field

ZMAC_SCAN_CNF.ScanType Field
[image]

Scan Type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanType As ZMAC_SCAN_CNF.SCAN_TYPE
C#
public ZMAC_SCAN_CNF.SCAN_TYPE ScanType;
C++
public:
ZMAC_SCAN_CNF.SCAN_TYPE ScanType sealed ;
J#
public ZMAC_SCAN_CNF.SCAN_TYPE ScanType
JScript
public ScanType : ZMAC_SCAN_CNF.SCAN_TYPE;

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_SCAN_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SCAN_CNF.CMD_STATUS
C#
public ZMAC_SCAN_CNF.CMD_STATUS Status;
C++
public:
ZMAC_SCAN_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_SCAN_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_SCAN_CNF.CMD_STATUS;

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


UnscannedChannelList Field

ZMAC_SCAN_CNF.UnscannedChannelList Field
[image]

Unscanned Channel List

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public UnscannedChannelList As UInt32
C#
public uint UnscannedChannelList;
C++
public:
unsigned int UnscannedChannelList sealed ;
J#
public uint UnscannedChannelList
JScript
public UnscannedChannelList : UInt32;

See Also

ZMAC_SCAN_CNF Class
TI.ZPI2 Namespace


ZMAC_SCAN_CNF.CMD_STATUS Enumeration

ZMAC_SCAN_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_SCAN_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_SCAN_CNF.CMD_STATUS : char
J#
public enum ZMAC_SCAN_CNF.CMD_STATUS byte
JScript
public enum ZMAC_SCAN_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SCAN_CNF.SCAN_TYPE Enumeration

ZMAC_SCAN_CNF.SCAN_TYPE Enumeration
[image]

Scan type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_CNF.SCAN_TYPE As Byte
C#
public enum ZMAC_SCAN_CNF.SCAN_TYPE : byte
C++
public enum class ZMAC_SCAN_CNF.SCAN_TYPE : char
J#
public enum ZMAC_SCAN_CNF.SCAN_TYPE byte
JScript
public enum ZMAC_SCAN_CNF.SCAN_TYPE :

Members

Member Name | Description
0x00 (ENERGY_DETECT) | Scan type
0x01 (ACTIVE) | Scan type
0x02 (PASSIVE) | Scan type
0x03 (ORPHAN) | Scan type
0x05 (ENHANCED) | Scan type

See Also

TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST Class

ZMAC_SCAN_REQUEST Class
See Also Example Members
[image]

This command is used to send a request to the device to perform a network scan.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SCAN_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SCAN_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SCAN_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SCAN_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SCAN_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SCAN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SCAN_REQUEST Members
TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST Members

ZMAC_SCAN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a request to the device to perform a network scan.

The following tables list the members exposed by ZMAC_SCAN_REQUEST.

Public Constructors

Name | Description
ZMAC_SCAN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page that the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | MaxResults | Maximum number of PAN descriptor results
Public field | ScanChannels | Channels to be scanned
Public field | ScanDuration | Duration of the scan
Public field | ScanType | Type of the scan
Public field | SecurityLevel | Security Level of this data frame
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SCAN_REQUEST | Overloaded.
Top

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST Constructor

ZMAC_SCAN_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SCAN_REQUEST | Constructor
Public method | ZMAC_SCAN_REQUEST (ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte, ZMAC_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_SCAN_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST Constructor ()

ZMAC_SCAN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SCAN_REQUEST()
C++
public:
ZMAC_SCAN_REQUEST() sealed
J#
public ZMAC_SCAN_REQUEST()
JScript
public function ZMAC_SCAN_REQUEST()

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SCAN_REQUEST Constructor Overload List


ZMAC_SCAN_REQUEST Constructor (ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte[], ZMAC_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_SCAN_REQUEST.KEY_ID_MODE, Byte)

ZMAC_SCAN_REQUEST Constructor (ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, ZMAC_SCAN_REQUEST.SCAN_TYPE, Byte, Byte, Byte, Byte[], ZMAC_SCAN_REQUEST.SECURITY_LEVEL, ZMAC_SCAN_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS, _
ByVal As ZMAC_SCAN_REQUEST.SCAN_TYPE, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_SCAN_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_SCAN_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_SCAN_REQUEST(
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_SCAN_REQUEST.SCAN_TYPE ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_SCAN_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_SCAN_REQUEST(
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_SCAN_REQUEST.SCAN_TYPE ,
char ,
char ,
char ,
array<char>^ ,
ZMAC_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_SCAN_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_SCAN_REQUEST(
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ,
ZMAC_SCAN_REQUEST.SCAN_TYPE ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_SCAN_REQUEST.SECURITY_LEVEL ,
ZMAC_SCAN_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_SCAN_REQUEST(
: ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS,
: ZMAC_SCAN_REQUEST.SCAN_TYPE,
: Byte,
: Byte,
: Byte,
: Byte[],
: ZMAC_SCAN_REQUEST.SECURITY_LEVEL,
: ZMAC_SCAN_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SCAN_REQUEST Constructor Overload List


Fields

ZMAC_SCAN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page that the device
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | MaxResults | Maximum number of PAN descriptor results
Public field | ScanChannels | Channels to be scanned
Public field | ScanDuration | Duration of the scan
Public field | ScanType | Type of the scan
Public field | SecurityLevel | Security Level of this data frame
Top

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


ChannelPage Field

ZMAC_SCAN_REQUEST.ChannelPage Field
[image]

The channel page that the device

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_SCAN_REQUEST.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_SCAN_REQUEST.KEY_ID_MODE
C#
public ZMAC_SCAN_REQUEST.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_SCAN_REQUEST.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_SCAN_REQUEST.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_SCAN_REQUEST.KEY_ID_MODE;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_SCAN_REQUEST.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_SCAN_REQUEST.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


MaxResults Field

ZMAC_SCAN_REQUEST.MaxResults Field
[image]

Maximum number of PAN descriptor results

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public MaxResults As Byte
C#
public byte MaxResults;
C++
public:
char MaxResults sealed ;
J#
public byte MaxResults
JScript
public MaxResults : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


ScanChannels Field

ZMAC_SCAN_REQUEST.ScanChannels Field
[image]

Channels to be scanned

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanChannels As ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS
C#
public ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels;
C++
public:
ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels sealed ;
J#
public ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS ScanChannels
JScript
public ScanChannels : ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


ScanDuration Field

ZMAC_SCAN_REQUEST.ScanDuration Field
[image]

Duration of the scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanDuration As Byte
C#
public byte ScanDuration;
C++
public:
char ScanDuration sealed ;
J#
public byte ScanDuration
JScript
public ScanDuration : Byte;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


ScanType Field

ZMAC_SCAN_REQUEST.ScanType Field
[image]

Type of the scan

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ScanType As ZMAC_SCAN_REQUEST.SCAN_TYPE
C#
public ZMAC_SCAN_REQUEST.SCAN_TYPE ScanType;
C++
public:
ZMAC_SCAN_REQUEST.SCAN_TYPE ScanType sealed ;
J#
public ZMAC_SCAN_REQUEST.SCAN_TYPE ScanType
JScript
public ScanType : ZMAC_SCAN_REQUEST.SCAN_TYPE;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_SCAN_REQUEST.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_SCAN_REQUEST.SECURITY_LEVEL
C#
public ZMAC_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_SCAN_REQUEST.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_SCAN_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_SCAN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST.KEY_ID_MODE Enumeration

ZMAC_SCAN_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_SCAN_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_SCAN_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_SCAN_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_SCAN_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST.SCAN_TYPE Enumeration

ZMAC_SCAN_REQUEST.SCAN_TYPE Enumeration
[image]

Scan type

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_REQUEST.SCAN_TYPE As Byte
C#
public enum ZMAC_SCAN_REQUEST.SCAN_TYPE : byte
C++
public enum class ZMAC_SCAN_REQUEST.SCAN_TYPE : char
J#
public enum ZMAC_SCAN_REQUEST.SCAN_TYPE byte
JScript
public enum ZMAC_SCAN_REQUEST.SCAN_TYPE :

Members

Member Name | Description
0x00 (ENERGY_DETECT) | Scan type
0x01 (ACTIVE) | Scan type
0x02 (PASSIVE) | Scan type
0x03 (ORPHAN) | Scan type
0x05 (ENHANCED) | Scan type

See Also

TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_SCAN_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_SCAN_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_SCAN_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS Enumeration

ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS Enumeration
[image]

Channels bitfield

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS As
C#
[FlagsAttribute]
public enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS : uint
C++
[FlagsAttribute]
public enum class ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS : unsigned int
J#
/** @attribute FlagsAttribute() */
public enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS uint
JScript
public enum ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS :

Members

Member Name | Description | Value
NONE | Channels bitfield | 0
ALL_CHANNELS | Channels bitfield | 134215680
CHNL_0x00000800 | Channels bitfield | 2048
CHNL_0x00001000 | Channels bitfield | 4096
CHNL_0x00002000 | Channels bitfield | 8192
CHNL_0x00004000 | Channels bitfield | 16384
CHNL_0x00008000 | Channels bitfield | 32768
CHNL_0x00010000 | Channels bitfield | 65536
CHNL_0x00020000 | Channels bitfield | 131072
CHNL_0x00040000 | Channels bitfield | 262144
CHNL_0x00080000 | Channels bitfield | 524288
CHNL_0x00100000 | Channels bitfield | 1048576
CHNL_0x00200000 | Channels bitfield | 2097152
CHNL_0x00400000 | Channels bitfield | 4194304
CHNL_0x00800000 | Channels bitfield | 8388608
CHNL_0x01000000 | Channels bitfield | 16777216
CHNL_0x02000000 | Channels bitfield | 33554432
CHNL_0x04000000 | Channels bitfield | 67108864

See Also

TI.ZPI2 Namespace


ZMAC_SCAN_RESPONSE Class

ZMAC_SCAN_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SCAN_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SCAN_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SCAN_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SCAN_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SCAN_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SCAN_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SCAN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SCAN_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_SCAN_RESPONSE Members

ZMAC_SCAN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SCAN_REQUEST

The following tables list the members exposed by ZMAC_SCAN_RESPONSE.

Public Constructors

Name | Description
ZMAC_SCAN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SCAN_RESPONSE | Overloaded.
Top

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SCAN_RESPONSE Constructor

ZMAC_SCAN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SCAN_RESPONSE | Constructor
Public method | ZMAC_SCAN_RESPONSE (ZMAC_SCAN_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SCAN_RESPONSE Constructor ()

ZMAC_SCAN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SCAN_RESPONSE()
C++
public:
ZMAC_SCAN_RESPONSE() sealed
J#
public ZMAC_SCAN_RESPONSE()
JScript
public function ZMAC_SCAN_RESPONSE()

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SCAN_RESPONSE Constructor Overload List


ZMAC_SCAN_RESPONSE Constructor (ZMAC_SCAN_RESPONSE.CMD_STATUS)

ZMAC_SCAN_RESPONSE Constructor (ZMAC_SCAN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SCAN_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SCAN_RESPONSE(
ZMAC_SCAN_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SCAN_RESPONSE(
ZMAC_SCAN_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SCAN_RESPONSE(
ZMAC_SCAN_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SCAN_RESPONSE(
: ZMAC_SCAN_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SCAN_RESPONSE Constructor Overload List


Fields

ZMAC_SCAN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_SCAN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SCAN_RESPONSE.CMD_STATUS
C#
public ZMAC_SCAN_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SCAN_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SCAN_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SCAN_RESPONSE.CMD_STATUS;

See Also

ZMAC_SCAN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SCAN_RESPONSE.CMD_STATUS Enumeration

ZMAC_SCAN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SCAN_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SCAN_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SCAN_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SCAN_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SCAN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SECURITY_GET_REQUEST Class

ZMAC_SECURITY_GET_REQUEST Class
See Also Example Members
[image]

This command is used to read (on behalf of the next higher layer) a MAC Security PIB attribute.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SECURITY_GET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SECURITY_GET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SECURITY_GET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SECURITY_GET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SECURITY_GET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SECURITY_GET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SECURITY_GET_REQUEST Members
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_REQUEST Members

ZMAC_SECURITY_GET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to read (on behalf of the next higher layer) a MAC Security PIB attribute.

The following tables list the members exposed by ZMAC_SECURITY_GET_REQUEST.

Public Constructors

Name | Description
ZMAC_SECURITY_GET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC Security PID Attributes
Public field | Index | Specifies the MAC Security PID Index 1
Public field | Index | Specifies the MAC Security PID Index 2
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SECURITY_GET_REQUEST | Overloaded.
Top

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_REQUEST Constructor

ZMAC_SECURITY_GET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SECURITY_GET_REQUEST | Constructor
Public method | ZMAC_SECURITY_GET_REQUEST (ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR, Byte, Byte) |

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_REQUEST Constructor ()

ZMAC_SECURITY_GET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SECURITY_GET_REQUEST()
C++
public:
ZMAC_SECURITY_GET_REQUEST() sealed
J#
public ZMAC_SECURITY_GET_REQUEST()
JScript
public function ZMAC_SECURITY_GET_REQUEST()

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SECURITY_GET_REQUEST Constructor Overload List


ZMAC_SECURITY_GET_REQUEST Constructor (ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR, Byte, Byte)

ZMAC_SECURITY_GET_REQUEST Constructor (ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR, Byte, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZMAC_SECURITY_GET_REQUEST(
ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR ,
byte ,
byte
)
C++
public:
ZMAC_SECURITY_GET_REQUEST(
ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR ,
char ,
char
) sealed
J#
public ZMAC_SECURITY_GET_REQUEST(
ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR ,
byte ,
byte
)
JScript
public function ZMAC_SECURITY_GET_REQUEST(
: ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR,
: Byte,
: Byte
)

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SECURITY_GET_REQUEST Constructor Overload List


Fields

ZMAC_SECURITY_GET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC Security PID Attributes
Public field | Index | Specifies the MAC Security PID Index 1
Public field | Index | Specifies the MAC Security PID Index 2
Top

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace


Attribute Field

ZMAC_SECURITY_GET_REQUEST.Attribute Field
[image]

Specifies the MAC Security PID Attributes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR
C#
public ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR Attribute;
C++
public:
ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR Attribute sealed ;
J#
public ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR Attribute
JScript
public Attribute : ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR;

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR Enumeration

ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR Enumeration
[image]

MAC Security PID Attribute

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR As Byte
C#
public enum ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR : byte
C++
public enum class ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR : char
J#
public enum ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR byte
JScript
public enum ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR :

Members

Member Name | Description
0x00 (NOT_SPECIFIED) | MAC Security PID Attribute
0x71 (ZMAC_KEY_TABLE) | MAC Security PID Attribute
0x72 (ZMAC_KEY_TABLE_ENTRIES) | MAC Security PID Attribute
0x73 (ZMAC_DEVICE_TABLE) | MAC Security PID Attribute
0x74 (ZMAC_DEVICE_TABLE_ENTRIES) | MAC Security PID Attribute
0x75 (ZMAC_SECURITY_LEVEL_TABLE) | MAC Security PID Attribute
0x76 (ZMAC_SECURITY_LEVEL_TABLE_ENTRIES) | MAC Security PID Attribute
0x77 (ZMAC_FRAME_COUNTER) | MAC Security PID Attribute
0x78 (ZMAC_AUTO_REQUEST_SECURITY_LEVEL) | MAC Security PID Attribute
0x79 (ZMAC_AUTO_REQUEST_KEY_ID_MODE) | MAC Security PID Attribute
0x7A (ZMAC_AUTO_REQUEST_KEY_SOURCE) | MAC Security PID Attribute
0x7B (ZMAC_AUTO_REQUEST_KEY_INDEX) | MAC Security PID Attribute
0x7C (ZMAC_DEFAULT_KEY_SOURCE) | MAC Security PID Attribute
0x7D (ZMAC_PAN_COORD_EXTENDED_ADDRESS) | MAC Security PID Attribute
0x7E (ZMAC_PAN_COORD_SHORT_ADDRESS) | MAC Security PID Attribute
0xD0 (ZMAC_KEY_ID_LOOKUP_ENTRY) | MAC Security PID Attribute
0xD1 (ZMAC_KEY_DEVICE_ENTRY) | MAC Security PID Attribute
0xD2 (ZMAC_KEY_USAGE_ENTRY) | MAC Security PID Attribute
0xD3 (ZMAC_KEY_ENTRY) | MAC Security PID Attribute
0xD4 (ZMAC_DEVICE_ENTRY) | MAC Security PID Attribute
0xD5 (ZMAC_SECURITY_LEVEL_ENTRY) | MAC Security PID Attribute

See Also

TI.ZPI2 Namespace


ZMAC_SECURITY_GET_RESPONSE Class

ZMAC_SECURITY_GET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SECURITY_GET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SECURITY_GET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SECURITY_GET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SECURITY_GET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SECURITY_GET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SECURITY_GET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SECURITY_GET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SECURITY_GET_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_RESPONSE Members

ZMAC_SECURITY_GET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SECURITY_GET_REQUEST

The following tables list the members exposed by ZMAC_SECURITY_GET_RESPONSE.

Public Constructors

Name | Description
ZMAC_SECURITY_GET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Public field | Value | Array, contains the data read from the target.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SECURITY_GET_RESPONSE | Overloaded.
Top

See Also

ZMAC_SECURITY_GET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_RESPONSE Constructor

ZMAC_SECURITY_GET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SECURITY_GET_RESPONSE | Constructor
Public method | ZMAC_SECURITY_GET_RESPONSE (ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS, Byte) |

See Also

ZMAC_SECURITY_GET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_RESPONSE Constructor ()

ZMAC_SECURITY_GET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SECURITY_GET_RESPONSE()
C++
public:
ZMAC_SECURITY_GET_RESPONSE() sealed
J#
public ZMAC_SECURITY_GET_RESPONSE()
JScript
public function ZMAC_SECURITY_GET_RESPONSE()

See Also

ZMAC_SECURITY_GET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SECURITY_GET_RESPONSE Constructor Overload List


ZMAC_SECURITY_GET_RESPONSE Constructor (ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS, Byte[])

ZMAC_SECURITY_GET_RESPONSE Constructor (ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS, _
ByVal As Byte() _
)
C#
public ZMAC_SECURITY_GET_RESPONSE(
ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS ,
byte[]
)
C++
public:
ZMAC_SECURITY_GET_RESPONSE(
ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS ,
array<char>^
) sealed
J#
public ZMAC_SECURITY_GET_RESPONSE(
ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS ,
byte[]
)
JScript
public function ZMAC_SECURITY_GET_RESPONSE(
: ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS,
: Byte[]
)

See Also

ZMAC_SECURITY_GET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SECURITY_GET_RESPONSE Constructor Overload List


Fields

ZMAC_SECURITY_GET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Public field | Value | Array, contains the data read from the target.
Top

See Also

ZMAC_SECURITY_GET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_SECURITY_GET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS
C#
public ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS;

See Also

ZMAC_SECURITY_GET_RESPONSE Class
TI.ZPI2 Namespace


Value Field

ZMAC_SECURITY_GET_RESPONSE.Value Field
[image]

Array, contains the data read from the target.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Value As Byte()
C#
public byte[] Value;
C++
public:
array<char>^ Value sealed ;
J#
public byte[] Value
JScript
public Value : Byte[];

See Also

ZMAC_SECURITY_GET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS Enumeration

ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SECURITY_SET_REQUEST Class

ZMAC_SECURITY_SET_REQUEST Class
See Also Example Members
[image]

This command is used to request the device to write a MAC Security PIB value.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SECURITY_SET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SECURITY_SET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SECURITY_SET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SECURITY_SET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SECURITY_SET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SECURITY_SET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SECURITY_SET_REQUEST Members
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_REQUEST Members

ZMAC_SECURITY_SET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request the device to write a MAC Security PIB value.

The following tables list the members exposed by ZMAC_SECURITY_SET_REQUEST.

Public Constructors

Name | Description
ZMAC_SECURITY_SET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC Security PID Attributes
Public field | AttributeValue | 1-26 bytes value of the attribute
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SECURITY_SET_REQUEST | Overloaded.
Top

See Also

ZMAC_SECURITY_SET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_REQUEST Constructor

ZMAC_SECURITY_SET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SECURITY_SET_REQUEST | Constructor
Public method | ZMAC_SECURITY_SET_REQUEST (ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR, Byte) |

See Also

ZMAC_SECURITY_SET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_REQUEST Constructor ()

ZMAC_SECURITY_SET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SECURITY_SET_REQUEST()
C++
public:
ZMAC_SECURITY_SET_REQUEST() sealed
J#
public ZMAC_SECURITY_SET_REQUEST()
JScript
public function ZMAC_SECURITY_SET_REQUEST()

See Also

ZMAC_SECURITY_SET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SECURITY_SET_REQUEST Constructor Overload List


ZMAC_SECURITY_SET_REQUEST Constructor (ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR, Byte[])

ZMAC_SECURITY_SET_REQUEST Constructor (ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR, _
ByVal As Byte() _
)
C#
public ZMAC_SECURITY_SET_REQUEST(
ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR ,
byte[]
)
C++
public:
ZMAC_SECURITY_SET_REQUEST(
ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR ,
array<char>^
) sealed
J#
public ZMAC_SECURITY_SET_REQUEST(
ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR ,
byte[]
)
JScript
public function ZMAC_SECURITY_SET_REQUEST(
: ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR,
: Byte[]
)

See Also

ZMAC_SECURITY_SET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SECURITY_SET_REQUEST Constructor Overload List


Fields

ZMAC_SECURITY_SET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC Security PID Attributes
Public field | AttributeValue | 1-26 bytes value of the attribute
Top

See Also

ZMAC_SECURITY_SET_REQUEST Class
TI.ZPI2 Namespace


Attribute Field

ZMAC_SECURITY_SET_REQUEST.Attribute Field
[image]

Specifies the MAC Security PID Attributes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR
C#
public ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR Attribute;
C++
public:
ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR Attribute sealed ;
J#
public ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR Attribute
JScript
public Attribute : ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR;

See Also

ZMAC_SECURITY_SET_REQUEST Class
TI.ZPI2 Namespace


AttributeValue Field

ZMAC_SECURITY_SET_REQUEST.AttributeValue Field
[image]

1-26 bytes value of the attribute

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AttributeValue As Byte()
C#
public byte[] AttributeValue;
C++
public:
array<char>^ AttributeValue sealed ;
J#
public byte[] AttributeValue
JScript
public AttributeValue : Byte[];

See Also

ZMAC_SECURITY_SET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR Enumeration

ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR Enumeration
[image]

MAC Security PID Attribute

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR As Byte
C#
public enum ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR : byte
C++
public enum class ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR : char
J#
public enum ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR byte
JScript
public enum ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR :

Members

Member Name | Description
0x00 (NOT_SPECIFIED) | MAC Security PID Attribute
0x71 (ZMAC_KEY_TABLE) | MAC Security PID Attribute
0x72 (ZMAC_KEY_TABLE_ENTRIES) | MAC Security PID Attribute
0x73 (ZMAC_DEVICE_TABLE) | MAC Security PID Attribute
0x74 (ZMAC_DEVICE_TABLE_ENTRIES) | MAC Security PID Attribute
0x75 (ZMAC_SECURITY_LEVEL_TABLE) | MAC Security PID Attribute
0x76 (ZMAC_SECURITY_LEVEL_TABLE_ENTRIES) | MAC Security PID Attribute
0x77 (ZMAC_FRAME_COUNTER) | MAC Security PID Attribute
0x78 (ZMAC_AUTO_REQUEST_SECURITY_LEVEL) | MAC Security PID Attribute
0x79 (ZMAC_AUTO_REQUEST_KEY_ID_MODE) | MAC Security PID Attribute
0x7A (ZMAC_AUTO_REQUEST_KEY_SOURCE) | MAC Security PID Attribute
0x7B (ZMAC_AUTO_REQUEST_KEY_INDEX) | MAC Security PID Attribute
0x7C (ZMAC_DEFAULT_KEY_SOURCE) | MAC Security PID Attribute
0x7D (ZMAC_PAN_COORD_EXTENDED_ADDRESS) | MAC Security PID Attribute
0x7E (ZMAC_PAN_COORD_SHORT_ADDRESS) | MAC Security PID Attribute
0xD0 (ZMAC_KEY_ID_LOOKUP_ENTRY) | MAC Security PID Attribute
0xD1 (ZMAC_KEY_DEVICE_ENTRY) | MAC Security PID Attribute
0xD2 (ZMAC_KEY_USAGE_ENTRY) | MAC Security PID Attribute
0xD3 (ZMAC_KEY_ENTRY) | MAC Security PID Attribute
0xD4 (ZMAC_DEVICE_ENTRY) | MAC Security PID Attribute
0xD5 (ZMAC_SECURITY_LEVEL_ENTRY) | MAC Security PID Attribute

See Also

TI.ZPI2 Namespace


ZMAC_SECURITY_SET_RESPONSE Class

ZMAC_SECURITY_SET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SECURITY_SET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SECURITY_SET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SECURITY_SET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SECURITY_SET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SECURITY_SET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SECURITY_SET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SECURITY_SET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SECURITY_SET_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_RESPONSE Members

ZMAC_SECURITY_SET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SECURITY_SET_REQUEST

The following tables list the members exposed by ZMAC_SECURITY_SET_RESPONSE.

Public Constructors

Name | Description
ZMAC_SECURITY_SET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SECURITY_SET_RESPONSE | Overloaded.
Top

See Also

ZMAC_SECURITY_SET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_RESPONSE Constructor

ZMAC_SECURITY_SET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SECURITY_SET_RESPONSE | Constructor
Public method | ZMAC_SECURITY_SET_RESPONSE (ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SECURITY_SET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_RESPONSE Constructor ()

ZMAC_SECURITY_SET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SECURITY_SET_RESPONSE()
C++
public:
ZMAC_SECURITY_SET_RESPONSE() sealed
J#
public ZMAC_SECURITY_SET_RESPONSE()
JScript
public function ZMAC_SECURITY_SET_RESPONSE()

See Also

ZMAC_SECURITY_SET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SECURITY_SET_RESPONSE Constructor Overload List


ZMAC_SECURITY_SET_RESPONSE Constructor (ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS)

ZMAC_SECURITY_SET_RESPONSE Constructor (ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SECURITY_SET_RESPONSE(
ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SECURITY_SET_RESPONSE(
ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SECURITY_SET_RESPONSE(
ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SECURITY_SET_RESPONSE(
: ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SECURITY_SET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SECURITY_SET_RESPONSE Constructor Overload List


Fields

ZMAC_SECURITY_SET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SECURITY_SET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_SECURITY_SET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS
C#
public ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS;

See Also

ZMAC_SECURITY_SET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS Enumeration

ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SET_REQUEST Class

ZMAC_SET_REQUEST Class
See Also Example Members
[image]

This command is used to request the device to write a MAC PIB value.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SET_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SET_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SET_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SET_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SET_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SET_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SET_REQUEST Members
TI.ZPI2 Namespace


ZMAC_SET_REQUEST Members

ZMAC_SET_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request the device to write a MAC PIB value.

The following tables list the members exposed by ZMAC_SET_REQUEST.

Public Constructors

Name | Description
ZMAC_SET_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Public field | AttributeValue | 1-16 bytes value of the attribute
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SET_REQUEST | Overloaded.
Top

See Also

ZMAC_SET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SET_REQUEST Constructor

ZMAC_SET_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SET_REQUEST | Constructor
Public method | ZMAC_SET_REQUEST (ZMAC_SET_REQUEST.MAC_PID_ATTR, Byte) |

See Also

ZMAC_SET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SET_REQUEST Constructor ()

ZMAC_SET_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SET_REQUEST()
C++
public:
ZMAC_SET_REQUEST() sealed
J#
public ZMAC_SET_REQUEST()
JScript
public function ZMAC_SET_REQUEST()

See Also

ZMAC_SET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SET_REQUEST Constructor Overload List


ZMAC_SET_REQUEST Constructor (ZMAC_SET_REQUEST.MAC_PID_ATTR, Byte[])

ZMAC_SET_REQUEST Constructor (ZMAC_SET_REQUEST.MAC_PID_ATTR, Byte[])
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SET_REQUEST.MAC_PID_ATTR, _
ByVal As Byte() _
)
C#
public ZMAC_SET_REQUEST(
ZMAC_SET_REQUEST.MAC_PID_ATTR ,
byte[]
)
C++
public:
ZMAC_SET_REQUEST(
ZMAC_SET_REQUEST.MAC_PID_ATTR ,
array<char>^
) sealed
J#
public ZMAC_SET_REQUEST(
ZMAC_SET_REQUEST.MAC_PID_ATTR ,
byte[]
)
JScript
public function ZMAC_SET_REQUEST(
: ZMAC_SET_REQUEST.MAC_PID_ATTR,
: Byte[]
)

See Also

ZMAC_SET_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SET_REQUEST Constructor Overload List


Fields

ZMAC_SET_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Attribute | Specifies the MAC PID Attributes
Public field | AttributeValue | 1-16 bytes value of the attribute
Top

See Also

ZMAC_SET_REQUEST Class
TI.ZPI2 Namespace


Attribute Field

ZMAC_SET_REQUEST.Attribute Field
[image]

Specifies the MAC PID Attributes

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Attribute As ZMAC_SET_REQUEST.MAC_PID_ATTR
C#
public ZMAC_SET_REQUEST.MAC_PID_ATTR Attribute;
C++
public:
ZMAC_SET_REQUEST.MAC_PID_ATTR Attribute sealed ;
J#
public ZMAC_SET_REQUEST.MAC_PID_ATTR Attribute
JScript
public Attribute : ZMAC_SET_REQUEST.MAC_PID_ATTR;

See Also

ZMAC_SET_REQUEST Class
TI.ZPI2 Namespace


AttributeValue Field

ZMAC_SET_REQUEST.AttributeValue Field
[image]

1-16 bytes value of the attribute

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public AttributeValue As Byte()
C#
public byte[] AttributeValue;
C++
public:
array<char>^ AttributeValue sealed ;
J#
public byte[] AttributeValue
JScript
public AttributeValue : Byte[];

See Also

ZMAC_SET_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SET_REQUEST.MAC_PID_ATTR Enumeration

ZMAC_SET_REQUEST.MAC_PID_ATTR Enumeration
[image]

MAC PID Attribute

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SET_REQUEST.MAC_PID_ATTR As Byte
C#
public enum ZMAC_SET_REQUEST.MAC_PID_ATTR : byte
C++
public enum class ZMAC_SET_REQUEST.MAC_PID_ATTR : char
J#
public enum ZMAC_SET_REQUEST.MAC_PID_ATTR byte
JScript
public enum ZMAC_SET_REQUEST.MAC_PID_ATTR :

Members

Member Name | Description
0x00 (NOT_SPECIFIED) | MAC PID Attribute
0x40 (ZMAC_ACK_WAIT_DURATION) | MAC PID Attribute
0x41 (ZMAC_ASSOCIATION_PERMIT) | MAC PID Attribute
0x42 (ZMAC_AUTO_REQUEST) | MAC PID Attribute
0x43 (ZMAC_BATT_LIFE_EXT) | MAC PID Attribute
0x44 (ZMAC_BATT_LEFT_EXT_PERIODS) | MAC PID Attribute
0x45 (ZMAC_BEACON_MSDU) | MAC PID Attribute
0x46 (ZMAC_BEACON_MSDU_LENGTH) | MAC PID Attribute
0x47 (ZMAC_BEACON_ORDER) | MAC PID Attribute
0x48 (ZMAC_BEACON_TX_TIME) | MAC PID Attribute
0x49 (ZMAC_BSN) | MAC PID Attribute
0x4A (ZMAC_COORD_EXTENDED_ADDRESS) | MAC PID Attribute
0x4B (ZMAC_COORD_SHORT_ADDRESS) | MAC PID Attribute
0x4C (ZMAC_DSN) | MAC PID Attribute
0x4D (ZMAC_GTS_PERMIT) | MAC PID Attribute
0x4E (ZMAC_MAX_CSMA_BACKOFFS) | MAC PID Attribute
0x4F (ZMAC_MIN_BE) | MAC PID Attribute
0x50 (ZMAC_PANID) | MAC PID Attribute
0x51 (ZMAC_PROMISCUOUS_MODE) | MAC PID Attribute
0x52 (ZMAC_RX_ON_IDLE) | MAC PID Attribute
0x53 (ZMAC_SHORT_ADDRESS) | MAC PID Attribute
0x54 (ZMAC_SUPERFRAME_ORDER) | MAC PID Attribute
0x55 (ZMAC_TRANSACTION_PERSISTENCE_TIME) | MAC PID Attribute
0x56 (ZMAC_ASSOCIATED_PAN_COORD) | MAC PID Attribute
0x57 (ZMAC_MAX_BE) | MAC PID Attribute
0x58 (ZMAC_FRAME_TOTAL_WAIT_TIME) | MAC PID Attribute
0x59 (ZMAC_MAX_FRAME_RETRIES) | MAC PID Attribute
0x5A (ZMAC_RESPONSE_WAIT_TIME - (0x5A) | MAC PID Attribute
0x5B (ZMAC_SYNC_SYMBOL_OFFSET) | MAC PID Attribute
0x5C (ZMAC_TIMESTAMP_SUPPORTED) | MAC PID Attribute
0x5D (ZMAC_SECURITY_ENABLED) | MAC PID Attribute
0xE0 (ZMAC_PHY_TRANSMIT_POWER) | MAC PID Attribute
0xE1 (ZMAC_LOGICAL_CHANNEL) | MAC PID Attribute
0xE2 (ZMAC_EXTENDED_ADDRESS) | MAC PID Attribute
0xE3 (ZMAC_ALT_BE) | MAC PID Attribute
0xE4 (ZMAC_DEVICE_BEACON_ORDER) | MAC PID Attribute
0xE5 (ZMAC_PHY_TRANSMIT_POWER_SIGNED) | MAC PID Attribute

See Also

TI.ZPI2 Namespace


ZMAC_SET_RESPONSE Class

ZMAC_SET_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SET_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SET_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SET_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SET_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SET_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SET_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SET_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SET_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_SET_RESPONSE Members

ZMAC_SET_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SET_REQUEST

The following tables list the members exposed by ZMAC_SET_RESPONSE.

Public Constructors

Name | Description
ZMAC_SET_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SET_RESPONSE | Overloaded.
Top

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SET_RESPONSE Constructor

ZMAC_SET_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SET_RESPONSE | Constructor
Public method | ZMAC_SET_RESPONSE (ZMAC_SET_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SET_RESPONSE Constructor ()

ZMAC_SET_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SET_RESPONSE()
C++
public:
ZMAC_SET_RESPONSE() sealed
J#
public ZMAC_SET_RESPONSE()
JScript
public function ZMAC_SET_RESPONSE()

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SET_RESPONSE Constructor Overload List


ZMAC_SET_RESPONSE Constructor (ZMAC_SET_RESPONSE.CMD_STATUS)

ZMAC_SET_RESPONSE Constructor (ZMAC_SET_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SET_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SET_RESPONSE(
ZMAC_SET_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SET_RESPONSE(
ZMAC_SET_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SET_RESPONSE(
ZMAC_SET_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SET_RESPONSE(
: ZMAC_SET_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SET_RESPONSE Constructor Overload List


Fields

ZMAC_SET_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_SET_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SET_RESPONSE.CMD_STATUS
C#
public ZMAC_SET_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SET_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SET_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SET_RESPONSE.CMD_STATUS;

See Also

ZMAC_SET_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SET_RESPONSE.CMD_STATUS Enumeration

ZMAC_SET_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SET_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SET_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SET_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SET_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SET_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_REQUEST Class

ZMAC_SET_RX_GAIN_REQUEST Class
See Also Example Members
[image]

This command is used to send a request to the device to set Rx gain

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SET_RX_GAIN_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SET_RX_GAIN_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SET_RX_GAIN_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SET_RX_GAIN_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SET_RX_GAIN_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SET_RX_GAIN_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SET_RX_GAIN_REQUEST Members
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_REQUEST Members

ZMAC_SET_RX_GAIN_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to send a request to the device to set Rx gain

The following tables list the members exposed by ZMAC_SET_RX_GAIN_REQUEST.

Public Constructors

Name | Description
ZMAC_SET_RX_GAIN_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Mode | PA/PNA mode
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SET_RX_GAIN_REQUEST | Overloaded.
Top

See Also

ZMAC_SET_RX_GAIN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_REQUEST Constructor

ZMAC_SET_RX_GAIN_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SET_RX_GAIN_REQUEST | Constructor
Public method | ZMAC_SET_RX_GAIN_REQUEST (ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN) |

See Also

ZMAC_SET_RX_GAIN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_REQUEST Constructor ()

ZMAC_SET_RX_GAIN_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SET_RX_GAIN_REQUEST()
C++
public:
ZMAC_SET_RX_GAIN_REQUEST() sealed
J#
public ZMAC_SET_RX_GAIN_REQUEST()
JScript
public function ZMAC_SET_RX_GAIN_REQUEST()

See Also

ZMAC_SET_RX_GAIN_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SET_RX_GAIN_REQUEST Constructor Overload List


ZMAC_SET_RX_GAIN_REQUEST Constructor (ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN)

ZMAC_SET_RX_GAIN_REQUEST Constructor (ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN _
)
C#
public ZMAC_SET_RX_GAIN_REQUEST(
ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN
)
C++
public:
ZMAC_SET_RX_GAIN_REQUEST(
ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN
) sealed
J#
public ZMAC_SET_RX_GAIN_REQUEST(
ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN
)
JScript
public function ZMAC_SET_RX_GAIN_REQUEST(
: ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN
)

See Also

ZMAC_SET_RX_GAIN_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SET_RX_GAIN_REQUEST Constructor Overload List


Fields

ZMAC_SET_RX_GAIN_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | Mode | PA/PNA mode
Top

See Also

ZMAC_SET_RX_GAIN_REQUEST Class
TI.ZPI2 Namespace


Mode Field

ZMAC_SET_RX_GAIN_REQUEST.Mode Field
[image]

PA/PNA mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Mode As ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN
C#
public ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN Mode;
C++
public:
ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN Mode sealed ;
J#
public ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN Mode
JScript
public Mode : ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN;

See Also

ZMAC_SET_RX_GAIN_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN Enumeration

ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN Enumeration
[image]

True or False flag

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN As Byte
C#
public enum ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN : byte
C++
public enum class ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN : char
J#
public enum ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN byte
JScript
public enum ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN :

Members

Member Name | Description
FALSE | True or False flag
TRUE | True or False flag

See Also

TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_RESPONSE Class

ZMAC_SET_RX_GAIN_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SET_RX_GAIN_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SET_RX_GAIN_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SET_RX_GAIN_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SET_RX_GAIN_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SET_RX_GAIN_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SET_RX_GAIN_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SET_RX_GAIN_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SET_RX_GAIN_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_RESPONSE Members

ZMAC_SET_RX_GAIN_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SET_RX_GAIN_REQUEST

The following tables list the members exposed by ZMAC_SET_RX_GAIN_RESPONSE.

Public Constructors

Name | Description
ZMAC_SET_RX_GAIN_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SET_RX_GAIN_RESPONSE | Overloaded.
Top

See Also

ZMAC_SET_RX_GAIN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_RESPONSE Constructor

ZMAC_SET_RX_GAIN_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SET_RX_GAIN_RESPONSE | Constructor
Public method | ZMAC_SET_RX_GAIN_RESPONSE (ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SET_RX_GAIN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_RESPONSE Constructor ()

ZMAC_SET_RX_GAIN_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SET_RX_GAIN_RESPONSE()
C++
public:
ZMAC_SET_RX_GAIN_RESPONSE() sealed
J#
public ZMAC_SET_RX_GAIN_RESPONSE()
JScript
public function ZMAC_SET_RX_GAIN_RESPONSE()

See Also

ZMAC_SET_RX_GAIN_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SET_RX_GAIN_RESPONSE Constructor Overload List


ZMAC_SET_RX_GAIN_RESPONSE Constructor (ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS)

ZMAC_SET_RX_GAIN_RESPONSE Constructor (ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SET_RX_GAIN_RESPONSE(
ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SET_RX_GAIN_RESPONSE(
ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SET_RX_GAIN_RESPONSE(
ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SET_RX_GAIN_RESPONSE(
: ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SET_RX_GAIN_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SET_RX_GAIN_RESPONSE Constructor Overload List


Fields

ZMAC_SET_RX_GAIN_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SET_RX_GAIN_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_SET_RX_GAIN_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS
C#
public ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS;

See Also

ZMAC_SET_RX_GAIN_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS Enumeration

ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_START_CNF Class

ZMAC_START_CNF Class
See Also Example Members
[image]

Mac Start Confirmation

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_START_CNF
Implements IRESPONSE, IZMAC
C#
public class ZMAC_START_CNF : IRESPONSE, IZMAC
C++
ref class ZMAC_START_CNF : IRESPONSE, IZMAC
J#
public class ZMAC_START_CNF implements IRESPONSE, IZMAC
JScript
public class ZMAC_START_CNF extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_START_CNF

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_START_CNF Members
TI.ZPI2 Namespace


ZMAC_START_CNF Members

ZMAC_START_CNF Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Mac Start Confirmation

The following tables list the members exposed by ZMAC_START_CNF.

Public Constructors

Name | Description
ZMAC_START_CNF | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_START_CNF | Overloaded.
Top

See Also

ZMAC_START_CNF Class
TI.ZPI2 Namespace


ZMAC_START_CNF Constructor

ZMAC_START_CNF Constructor

Overload List

 | Name | Description
Public method | ZMAC_START_CNF | Constructor
Public method | ZMAC_START_CNF (ZMAC_START_CNF.CMD_STATUS) |

See Also

ZMAC_START_CNF Class
TI.ZPI2 Namespace


ZMAC_START_CNF Constructor ()

ZMAC_START_CNF Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_START_CNF()
C++
public:
ZMAC_START_CNF() sealed
J#
public ZMAC_START_CNF()
JScript
public function ZMAC_START_CNF()

See Also

ZMAC_START_CNF Class
TI.ZPI2 Namespace
ZMAC_START_CNF Constructor Overload List


ZMAC_START_CNF Constructor (ZMAC_START_CNF.CMD_STATUS)

ZMAC_START_CNF Constructor (ZMAC_START_CNF.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_START_CNF.CMD_STATUS _
)
C#
public ZMAC_START_CNF(
ZMAC_START_CNF.CMD_STATUS
)
C++
public:
ZMAC_START_CNF(
ZMAC_START_CNF.CMD_STATUS
) sealed
J#
public ZMAC_START_CNF(
ZMAC_START_CNF.CMD_STATUS
)
JScript
public function ZMAC_START_CNF(
: ZMAC_START_CNF.CMD_STATUS
)

See Also

ZMAC_START_CNF Class
TI.ZPI2 Namespace
ZMAC_START_CNF Constructor Overload List


Fields

ZMAC_START_CNF Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_START_CNF Class
TI.ZPI2 Namespace


Status Field

ZMAC_START_CNF.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_START_CNF.CMD_STATUS
C#
public ZMAC_START_CNF.CMD_STATUS Status;
C++
public:
ZMAC_START_CNF.CMD_STATUS Status sealed ;
J#
public ZMAC_START_CNF.CMD_STATUS Status
JScript
public Status : ZMAC_START_CNF.CMD_STATUS;

See Also

ZMAC_START_CNF Class
TI.ZPI2 Namespace


ZMAC_START_CNF.CMD_STATUS Enumeration

ZMAC_START_CNF.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_START_CNF.CMD_STATUS As Byte
C#
public enum ZMAC_START_CNF.CMD_STATUS : byte
C++
public enum class ZMAC_START_CNF.CMD_STATUS : char
J#
public enum ZMAC_START_CNF.CMD_STATUS byte
JScript
public enum ZMAC_START_CNF.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_START_REQUEST Class

ZMAC_START_REQUEST Class
See Also Example Members
[image]

This command is used to request the MAC to transmit beacons and become a coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_START_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_START_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_START_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_START_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_START_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_START_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_START_REQUEST Members
TI.ZPI2 Namespace


ZMAC_START_REQUEST Members

ZMAC_START_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request the MAC to transmit beacons and become a coordinator

The following tables list the members exposed by ZMAC_START_REQUEST.

Public Constructors

Name | Description
ZMAC_START_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | BatteryLifeExt | If this value is TRUE, the receiver is disabled after MAC_BATT_LIFE_EXT_PERIODS full backoff periods following the interframe spacing period of the beacon frame
Public field | BeaconKeyIdMode | Key Id Mode of this data frame
Public field | BeaconKeyIndex | Key Index of this data frame
Public field | BeaconKeySource | Key Source of this data frame
Public field | BeaconOrder | The exponent used to calculate the beacon interval
Public field | BeaconSecurityLevel | Security Level of this data frame
Public field | ChannelPage | The channel page to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | CoordRealignment | Coord Realignment
Public field | LogicalChannel | The logical channel to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | PanCoordinator | Set to TRUE to start a network as PAN coordinator
Public field | PanID | The PAN ID to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | RealignKeyIdMode | Key Id Mode of this data frame
Public field | RealignKeyIndex | Key Index of this data frame
Public field | RealignKeySource | Key Source of this data frame
Public field | RealignSecurityLevel | Security Level of this data frame
Public field | StartTime | The time to begin transmitting beacons relative to the received beacon
Public field | SuperFrameOrder | The exponent used to calculate the superframe duration
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_START_REQUEST | Overloaded.
Top

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


ZMAC_START_REQUEST Constructor

ZMAC_START_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_START_REQUEST | Constructor
Public method | ZMAC_START_REQUEST (UInt32, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte, ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte, Byte, ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte) |

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


ZMAC_START_REQUEST Constructor ()

ZMAC_START_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_START_REQUEST()
C++
public:
ZMAC_START_REQUEST() sealed
J#
public ZMAC_START_REQUEST()
JScript
public function ZMAC_START_REQUEST()

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace
ZMAC_START_REQUEST Constructor Overload List


ZMAC_START_REQUEST Constructor (UInt32, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte)

ZMAC_START_REQUEST Constructor (UInt32, UInt16, Byte, Byte, Byte, Byte, Byte, Byte, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte, Byte[], ZMAC_START_REQUEST.SECURITY_LEVEL, ZMAC_START_REQUEST.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As UInt32, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_START_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_START_REQUEST.KEY_ID_MODE, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_START_REQUEST.SECURITY_LEVEL, _
ByVal As ZMAC_START_REQUEST.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_START_REQUEST(
uint ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_START_REQUEST(
unsigned int ,
unsigned short ,
char ,
char ,
char ,
char ,
char ,
char ,
char ,
array<char>^ ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
char ,
array<char>^ ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_START_REQUEST(
uint ,
ushort ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte ,
byte[] ,
ZMAC_START_REQUEST.SECURITY_LEVEL ,
ZMAC_START_REQUEST.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_START_REQUEST(
: UInt32,
: UInt16,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte,
: Byte[],
: ZMAC_START_REQUEST.SECURITY_LEVEL,
: ZMAC_START_REQUEST.KEY_ID_MODE,
: Byte,
: Byte[],
: ZMAC_START_REQUEST.SECURITY_LEVEL,
: ZMAC_START_REQUEST.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace
ZMAC_START_REQUEST Constructor Overload List


Fields

ZMAC_START_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | BatteryLifeExt | If this value is TRUE, the receiver is disabled after MAC_BATT_LIFE_EXT_PERIODS full backoff periods following the interframe spacing period of the beacon frame
Public field | BeaconKeyIdMode | Key Id Mode of this data frame
Public field | BeaconKeyIndex | Key Index of this data frame
Public field | BeaconKeySource | Key Source of this data frame
Public field | BeaconOrder | The exponent used to calculate the beacon interval
Public field | BeaconSecurityLevel | Security Level of this data frame
Public field | ChannelPage | The channel page to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | CoordRealignment | Coord Realignment
Public field | LogicalChannel | The logical channel to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | PanCoordinator | Set to TRUE to start a network as PAN coordinator
Public field | PanID | The PAN ID to use. This parameter is ignored if Pan Coordinator is FALSE
Public field | RealignKeyIdMode | Key Id Mode of this data frame
Public field | RealignKeyIndex | Key Index of this data frame
Public field | RealignKeySource | Key Source of this data frame
Public field | RealignSecurityLevel | Security Level of this data frame
Public field | StartTime | The time to begin transmitting beacons relative to the received beacon
Public field | SuperFrameOrder | The exponent used to calculate the superframe duration
Top

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


BatteryLifeExt Field

ZMAC_START_REQUEST.BatteryLifeExt Field
[image]

If this value is TRUE, the receiver is disabled after MAC_BATT_LIFE_EXT_PERIODS full backoff periods following the interframe spacing period of the beacon frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BatteryLifeExt As Byte
C#
public byte BatteryLifeExt;
C++
public:
char BatteryLifeExt sealed ;
J#
public byte BatteryLifeExt
JScript
public BatteryLifeExt : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


BeaconKeyIdMode Field

ZMAC_START_REQUEST.BeaconKeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconKeyIdMode As ZMAC_START_REQUEST.KEY_ID_MODE
C#
public ZMAC_START_REQUEST.KEY_ID_MODE BeaconKeyIdMode;
C++
public:
ZMAC_START_REQUEST.KEY_ID_MODE BeaconKeyIdMode sealed ;
J#
public ZMAC_START_REQUEST.KEY_ID_MODE BeaconKeyIdMode
JScript
public BeaconKeyIdMode : ZMAC_START_REQUEST.KEY_ID_MODE;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


BeaconKeyIndex Field

ZMAC_START_REQUEST.BeaconKeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconKeyIndex As Byte
C#
public byte BeaconKeyIndex;
C++
public:
char BeaconKeyIndex sealed ;
J#
public byte BeaconKeyIndex
JScript
public BeaconKeyIndex : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


BeaconKeySource Field

ZMAC_START_REQUEST.BeaconKeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconKeySource As Byte()
C#
public byte[] BeaconKeySource;
C++
public:
array<char>^ BeaconKeySource sealed ;
J#
public byte[] BeaconKeySource
JScript
public BeaconKeySource : Byte[];

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


BeaconOrder Field

ZMAC_START_REQUEST.BeaconOrder Field
[image]

The exponent used to calculate the beacon interval

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconOrder As Byte
C#
public byte BeaconOrder;
C++
public:
char BeaconOrder sealed ;
J#
public byte BeaconOrder
JScript
public BeaconOrder : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


BeaconSecurityLevel Field

ZMAC_START_REQUEST.BeaconSecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public BeaconSecurityLevel As ZMAC_START_REQUEST.SECURITY_LEVEL
C#
public ZMAC_START_REQUEST.SECURITY_LEVEL BeaconSecurityLevel;
C++
public:
ZMAC_START_REQUEST.SECURITY_LEVEL BeaconSecurityLevel sealed ;
J#
public ZMAC_START_REQUEST.SECURITY_LEVEL BeaconSecurityLevel
JScript
public BeaconSecurityLevel : ZMAC_START_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


ChannelPage Field

ZMAC_START_REQUEST.ChannelPage Field
[image]

The channel page to use. This parameter is ignored if Pan Coordinator is FALSE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


CoordRealignment Field

ZMAC_START_REQUEST.CoordRealignment Field
[image]

Coord Realignment

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public CoordRealignment As Byte
C#
public byte CoordRealignment;
C++
public:
char CoordRealignment sealed ;
J#
public byte CoordRealignment
JScript
public CoordRealignment : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


LogicalChannel Field

ZMAC_START_REQUEST.LogicalChannel Field
[image]

The logical channel to use. This parameter is ignored if Pan Coordinator is FALSE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


PanCoordinator Field

ZMAC_START_REQUEST.PanCoordinator Field
[image]

Set to TRUE to start a network as PAN coordinator

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanCoordinator As Byte
C#
public byte PanCoordinator;
C++
public:
char PanCoordinator sealed ;
J#
public byte PanCoordinator
JScript
public PanCoordinator : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


PanID Field

ZMAC_START_REQUEST.PanID Field
[image]

The PAN ID to use. This parameter is ignored if Pan Coordinator is FALSE

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanID As UInt16
C#
public ushort PanID;
C++
public:
unsigned short PanID sealed ;
J#
public ushort PanID
JScript
public PanID : UInt16;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


RealignKeyIdMode Field

ZMAC_START_REQUEST.RealignKeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignKeyIdMode As ZMAC_START_REQUEST.KEY_ID_MODE
C#
public ZMAC_START_REQUEST.KEY_ID_MODE RealignKeyIdMode;
C++
public:
ZMAC_START_REQUEST.KEY_ID_MODE RealignKeyIdMode sealed ;
J#
public ZMAC_START_REQUEST.KEY_ID_MODE RealignKeyIdMode
JScript
public RealignKeyIdMode : ZMAC_START_REQUEST.KEY_ID_MODE;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


RealignKeyIndex Field

ZMAC_START_REQUEST.RealignKeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignKeyIndex As Byte
C#
public byte RealignKeyIndex;
C++
public:
char RealignKeyIndex sealed ;
J#
public byte RealignKeyIndex
JScript
public RealignKeyIndex : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


RealignKeySource Field

ZMAC_START_REQUEST.RealignKeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignKeySource As Byte()
C#
public byte[] RealignKeySource;
C++
public:
array<char>^ RealignKeySource sealed ;
J#
public byte[] RealignKeySource
JScript
public RealignKeySource : Byte[];

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


RealignSecurityLevel Field

ZMAC_START_REQUEST.RealignSecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public RealignSecurityLevel As ZMAC_START_REQUEST.SECURITY_LEVEL
C#
public ZMAC_START_REQUEST.SECURITY_LEVEL RealignSecurityLevel;
C++
public:
ZMAC_START_REQUEST.SECURITY_LEVEL RealignSecurityLevel sealed ;
J#
public ZMAC_START_REQUEST.SECURITY_LEVEL RealignSecurityLevel
JScript
public RealignSecurityLevel : ZMAC_START_REQUEST.SECURITY_LEVEL;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


StartTime Field

ZMAC_START_REQUEST.StartTime Field
[image]

The time to begin transmitting beacons relative to the received beacon

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public StartTime As UInt32
C#
public uint StartTime;
C++
public:
unsigned int StartTime sealed ;
J#
public uint StartTime
JScript
public StartTime : UInt32;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


SuperFrameOrder Field

ZMAC_START_REQUEST.SuperFrameOrder Field
[image]

The exponent used to calculate the superframe duration

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SuperFrameOrder As Byte
C#
public byte SuperFrameOrder;
C++
public:
char SuperFrameOrder sealed ;
J#
public byte SuperFrameOrder
JScript
public SuperFrameOrder : Byte;

See Also

ZMAC_START_REQUEST Class
TI.ZPI2 Namespace


ZMAC_START_REQUEST.KEY_ID_MODE Enumeration

ZMAC_START_REQUEST.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_START_REQUEST.KEY_ID_MODE As Byte
C#
public enum ZMAC_START_REQUEST.KEY_ID_MODE : byte
C++
public enum class ZMAC_START_REQUEST.KEY_ID_MODE : char
J#
public enum ZMAC_START_REQUEST.KEY_ID_MODE byte
JScript
public enum ZMAC_START_REQUEST.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_START_REQUEST.SECURITY_LEVEL Enumeration

ZMAC_START_REQUEST.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_START_REQUEST.SECURITY_LEVEL As Byte
C#
public enum ZMAC_START_REQUEST.SECURITY_LEVEL : byte
C++
public enum class ZMAC_START_REQUEST.SECURITY_LEVEL : char
J#
public enum ZMAC_START_REQUEST.SECURITY_LEVEL byte
JScript
public enum ZMAC_START_REQUEST.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_START_RESPONSE Class

ZMAC_START_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_START_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_START_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_START_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_START_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_START_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_START_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_START_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_START_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_START_RESPONSE Members

ZMAC_START_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_START_REQUEST

The following tables list the members exposed by ZMAC_START_RESPONSE.

Public Constructors

Name | Description
ZMAC_START_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_START_RESPONSE | Overloaded.
Top

See Also

ZMAC_START_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_START_RESPONSE Constructor

ZMAC_START_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_START_RESPONSE | Constructor
Public method | ZMAC_START_RESPONSE (ZMAC_START_RESPONSE.CMD_STATUS) |

See Also

ZMAC_START_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_START_RESPONSE Constructor ()

ZMAC_START_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_START_RESPONSE()
C++
public:
ZMAC_START_RESPONSE() sealed
J#
public ZMAC_START_RESPONSE()
JScript
public function ZMAC_START_RESPONSE()

See Also

ZMAC_START_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_START_RESPONSE Constructor Overload List


ZMAC_START_RESPONSE Constructor (ZMAC_START_RESPONSE.CMD_STATUS)

ZMAC_START_RESPONSE Constructor (ZMAC_START_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_START_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_START_RESPONSE(
ZMAC_START_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_START_RESPONSE(
ZMAC_START_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_START_RESPONSE(
ZMAC_START_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_START_RESPONSE(
: ZMAC_START_RESPONSE.CMD_STATUS
)

See Also

ZMAC_START_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_START_RESPONSE Constructor Overload List


Fields

ZMAC_START_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_START_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_START_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_START_RESPONSE.CMD_STATUS
C#
public ZMAC_START_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_START_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_START_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_START_RESPONSE.CMD_STATUS;

See Also

ZMAC_START_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_START_RESPONSE.CMD_STATUS Enumeration

ZMAC_START_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_START_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_START_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_START_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_START_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_START_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SYNC_LOSS_IND Class

ZMAC_SYNC_LOSS_IND Class
See Also Example Members
[image]

Indication for sync loss

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SYNC_LOSS_IND
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SYNC_LOSS_IND : IRESPONSE, IZMAC
C++
ref class ZMAC_SYNC_LOSS_IND : IRESPONSE, IZMAC
J#
public class ZMAC_SYNC_LOSS_IND implements IRESPONSE, IZMAC
JScript
public class ZMAC_SYNC_LOSS_IND extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SYNC_LOSS_IND

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SYNC_LOSS_IND Members
TI.ZPI2 Namespace


ZMAC_SYNC_LOSS_IND Members

ZMAC_SYNC_LOSS_IND Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Indication for sync loss

The following tables list the members exposed by ZMAC_SYNC_LOSS_IND.

Public Constructors

Name | Description
ZMAC_SYNC_LOSS_IND | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | Channel Page
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Logical Channel
Public field | PanId | PanId
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SYNC_LOSS_IND | Overloaded.
Top

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


ZMAC_SYNC_LOSS_IND Constructor

ZMAC_SYNC_LOSS_IND Constructor

Overload List

 | Name | Description
Public method | ZMAC_SYNC_LOSS_IND | Constructor
Public method | ZMAC_SYNC_LOSS_IND (ZMAC_SYNC_LOSS_IND.CMD_STATUS, UInt16, Byte, Byte, Byte, ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL, ZMAC_SYNC_LOSS_IND.KEY_ID_MODE, Byte) |

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


ZMAC_SYNC_LOSS_IND Constructor ()

ZMAC_SYNC_LOSS_IND Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SYNC_LOSS_IND()
C++
public:
ZMAC_SYNC_LOSS_IND() sealed
J#
public ZMAC_SYNC_LOSS_IND()
JScript
public function ZMAC_SYNC_LOSS_IND()

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace
ZMAC_SYNC_LOSS_IND Constructor Overload List


ZMAC_SYNC_LOSS_IND Constructor (ZMAC_SYNC_LOSS_IND.CMD_STATUS, UInt16, Byte, Byte, Byte[], ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL, ZMAC_SYNC_LOSS_IND.KEY_ID_MODE, Byte)

ZMAC_SYNC_LOSS_IND Constructor (ZMAC_SYNC_LOSS_IND.CMD_STATUS, UInt16, Byte, Byte, Byte[], ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL, ZMAC_SYNC_LOSS_IND.KEY_ID_MODE, Byte)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SYNC_LOSS_IND.CMD_STATUS, _
ByVal As UInt16, _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte(), _
ByVal As ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL, _
ByVal As ZMAC_SYNC_LOSS_IND.KEY_ID_MODE, _
ByVal As Byte _
)
C#
public ZMAC_SYNC_LOSS_IND(
ZMAC_SYNC_LOSS_IND.CMD_STATUS ,
ushort ,
byte ,
byte ,
byte[] ,
ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL ,
ZMAC_SYNC_LOSS_IND.KEY_ID_MODE ,
byte
)
C++
public:
ZMAC_SYNC_LOSS_IND(
ZMAC_SYNC_LOSS_IND.CMD_STATUS ,
unsigned short ,
char ,
char ,
array<char>^ ,
ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL ,
ZMAC_SYNC_LOSS_IND.KEY_ID_MODE ,
char
) sealed
J#
public ZMAC_SYNC_LOSS_IND(
ZMAC_SYNC_LOSS_IND.CMD_STATUS ,
ushort ,
byte ,
byte ,
byte[] ,
ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL ,
ZMAC_SYNC_LOSS_IND.KEY_ID_MODE ,
byte
)
JScript
public function ZMAC_SYNC_LOSS_IND(
: ZMAC_SYNC_LOSS_IND.CMD_STATUS,
: UInt16,
: Byte,
: Byte,
: Byte[],
: ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL,
: ZMAC_SYNC_LOSS_IND.KEY_ID_MODE,
: Byte
)

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace
ZMAC_SYNC_LOSS_IND Constructor Overload List


Fields

ZMAC_SYNC_LOSS_IND Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | Channel Page
Public field | KeyIdMode | Key Id Mode of this data frame
Public field | KeyIndex | Key Index of this data frame
Public field | KeySource | Key Source of this data frame
Public field | LogicalChannel | Logical Channel
Public field | PanId | PanId
Public field | SecurityLevel | Security Level of this data frame
Public field | Status | Status
Top

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


ChannelPage Field

ZMAC_SYNC_LOSS_IND.ChannelPage Field
[image]

Channel Page

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


KeyIdMode Field

ZMAC_SYNC_LOSS_IND.KeyIdMode Field
[image]

Key Id Mode of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIdMode As ZMAC_SYNC_LOSS_IND.KEY_ID_MODE
C#
public ZMAC_SYNC_LOSS_IND.KEY_ID_MODE KeyIdMode;
C++
public:
ZMAC_SYNC_LOSS_IND.KEY_ID_MODE KeyIdMode sealed ;
J#
public ZMAC_SYNC_LOSS_IND.KEY_ID_MODE KeyIdMode
JScript
public KeyIdMode : ZMAC_SYNC_LOSS_IND.KEY_ID_MODE;

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


KeyIndex Field

ZMAC_SYNC_LOSS_IND.KeyIndex Field
[image]

Key Index of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeyIndex As Byte
C#
public byte KeyIndex;
C++
public:
char KeyIndex sealed ;
J#
public byte KeyIndex
JScript
public KeyIndex : Byte;

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


KeySource Field

ZMAC_SYNC_LOSS_IND.KeySource Field
[image]

Key Source of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public KeySource As Byte()
C#
public byte[] KeySource;
C++
public:
array<char>^ KeySource sealed ;
J#
public byte[] KeySource
JScript
public KeySource : Byte[];

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


LogicalChannel Field

ZMAC_SYNC_LOSS_IND.LogicalChannel Field
[image]

Logical Channel

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


PanId Field

ZMAC_SYNC_LOSS_IND.PanId Field
[image]

PanId

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public PanId As UInt16
C#
public ushort PanId;
C++
public:
unsigned short PanId sealed ;
J#
public ushort PanId
JScript
public PanId : UInt16;

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


SecurityLevel Field

ZMAC_SYNC_LOSS_IND.SecurityLevel Field
[image]

Security Level of this data frame

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public SecurityLevel As ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL
C#
public ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL SecurityLevel;
C++
public:
ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL SecurityLevel sealed ;
J#
public ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL SecurityLevel
JScript
public SecurityLevel : ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL;

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


Status Field

ZMAC_SYNC_LOSS_IND.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SYNC_LOSS_IND.CMD_STATUS
C#
public ZMAC_SYNC_LOSS_IND.CMD_STATUS Status;
C++
public:
ZMAC_SYNC_LOSS_IND.CMD_STATUS Status sealed ;
J#
public ZMAC_SYNC_LOSS_IND.CMD_STATUS Status
JScript
public Status : ZMAC_SYNC_LOSS_IND.CMD_STATUS;

See Also

ZMAC_SYNC_LOSS_IND Class
TI.ZPI2 Namespace


ZMAC_SYNC_LOSS_IND.CMD_STATUS Enumeration

ZMAC_SYNC_LOSS_IND.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SYNC_LOSS_IND.CMD_STATUS As Byte
C#
public enum ZMAC_SYNC_LOSS_IND.CMD_STATUS : byte
C++
public enum class ZMAC_SYNC_LOSS_IND.CMD_STATUS : char
J#
public enum ZMAC_SYNC_LOSS_IND.CMD_STATUS byte
JScript
public enum ZMAC_SYNC_LOSS_IND.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


ZMAC_SYNC_LOSS_IND.KEY_ID_MODE Enumeration

ZMAC_SYNC_LOSS_IND.KEY_ID_MODE Enumeration
[image]

Key Id Mode

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SYNC_LOSS_IND.KEY_ID_MODE As Byte
C#
public enum ZMAC_SYNC_LOSS_IND.KEY_ID_MODE : byte
C++
public enum class ZMAC_SYNC_LOSS_IND.KEY_ID_MODE : char
J#
public enum ZMAC_SYNC_LOSS_IND.KEY_ID_MODE byte
JScript
public enum ZMAC_SYNC_LOSS_IND.KEY_ID_MODE :

Members

Member Name | Description
0x00 (NOT_USED) | Key Id Mode
0x01 (KEY_1BYTE_INDEX) | Key Id Mode
0x02) (KEY_4BYTE_INDEX) | Key Id Mode
0x03 (KEY_8BYTE_INDEX) | Key Id Mode

See Also

TI.ZPI2 Namespace


ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL Enumeration

ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL Enumeration
[image]

Security Level

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL As Byte
C#
public enum ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL : byte
C++
public enum class ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL : char
J#
public enum ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL byte
JScript
public enum ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL :

Members

Member Name | Description
0x00 (NO_SECURITY) | Security Level
0x01 (MIC_32_AUTH) | Security Level
0x02 (MIC_64_AUTH) | Security Level
0x03 (MIC_128_AUTH) | Security Level
0x04 (AES_ENCRYPTION) | Security Level
0x05 (AES_ENCRYPTION_MIC_32) | Security Level
0x06 (AES_ENCRYPTION_MIC_64) | Security Level
0x07 (AES_ENCRYPTION_MIC_128) | Security Level

See Also

TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_REQUEST Class

ZMAC_SYNCHRONIZE_REQUEST Class
See Also Example Members
[image]

This command is used to request synchronization to the current network beacon

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SYNCHRONIZE_REQUEST
Implements IREQUEST, IZMAC
C#
public class ZMAC_SYNCHRONIZE_REQUEST : IREQUEST, IZMAC
C++
ref class ZMAC_SYNCHRONIZE_REQUEST : IREQUEST, IZMAC
J#
public class ZMAC_SYNCHRONIZE_REQUEST implements IREQUEST, IZMAC
JScript
public class ZMAC_SYNCHRONIZE_REQUEST extends IREQUEST, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SYNCHRONIZE_REQUEST

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SYNCHRONIZE_REQUEST Members
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_REQUEST Members

ZMAC_SYNCHRONIZE_REQUEST Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

This command is used to request synchronization to the current network beacon

The following tables list the members exposed by ZMAC_SYNCHRONIZE_REQUEST.

Public Constructors

Name | Description
ZMAC_SYNCHRONIZE_REQUEST | Overloaded.
Top

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page to use
Public field | LogicalChannel | The logical channel to use
Public field | TrackBeacon | Set to TRUE to continue tracking beacons after synchronizing with the first beacon. Set to FALSE to only synchronize with the first beacon
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SYNCHRONIZE_REQUEST | Overloaded.
Top

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_REQUEST Constructor

ZMAC_SYNCHRONIZE_REQUEST Constructor

Overload List

 | Name | Description
Public method | ZMAC_SYNCHRONIZE_REQUEST | Constructor
Public method | ZMAC_SYNCHRONIZE_REQUEST (Byte, Byte, Byte) | Constructor

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_REQUEST Constructor ()

ZMAC_SYNCHRONIZE_REQUEST Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SYNCHRONIZE_REQUEST()
C++
public:
ZMAC_SYNCHRONIZE_REQUEST() sealed
J#
public ZMAC_SYNCHRONIZE_REQUEST()
JScript
public function ZMAC_SYNCHRONIZE_REQUEST()

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SYNCHRONIZE_REQUEST Constructor Overload List


ZMAC_SYNCHRONIZE_REQUEST Constructor (Byte, Byte, Byte)

ZMAC_SYNCHRONIZE_REQUEST Constructor (Byte, Byte, Byte)
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As Byte, _
ByVal As Byte, _
ByVal As Byte _
)
C#
public ZMAC_SYNCHRONIZE_REQUEST(
byte ,
byte ,
byte
)
C++
public:
ZMAC_SYNCHRONIZE_REQUEST(
char ,
char ,
char
) sealed
J#
public ZMAC_SYNCHRONIZE_REQUEST(
byte ,
byte ,
byte
)
JScript
public function ZMAC_SYNCHRONIZE_REQUEST(
: Byte,
: Byte,
: Byte
)

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace
ZMAC_SYNCHRONIZE_REQUEST Constructor Overload List


Fields

ZMAC_SYNCHRONIZE_REQUEST Fields
[image]

Public Fields

 | Name | Description
Public field | ChannelPage | The channel page to use
Public field | LogicalChannel | The logical channel to use
Public field | TrackBeacon | Set to TRUE to continue tracking beacons after synchronizing with the first beacon. Set to FALSE to only synchronize with the first beacon
Top

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace


ChannelPage Field

ZMAC_SYNCHRONIZE_REQUEST.ChannelPage Field
[image]

The channel page to use

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public ChannelPage As Byte
C#
public byte ChannelPage;
C++
public:
char ChannelPage sealed ;
J#
public byte ChannelPage
JScript
public ChannelPage : Byte;

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace


LogicalChannel Field

ZMAC_SYNCHRONIZE_REQUEST.LogicalChannel Field
[image]

The logical channel to use

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public LogicalChannel As Byte
C#
public byte LogicalChannel;
C++
public:
char LogicalChannel sealed ;
J#
public byte LogicalChannel
JScript
public LogicalChannel : Byte;

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace


TrackBeacon Field

ZMAC_SYNCHRONIZE_REQUEST.TrackBeacon Field
[image]

Set to TRUE to continue tracking beacons after synchronizing with the first beacon. Set to FALSE to only synchronize with the first beacon

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public TrackBeacon As Byte
C#
public byte TrackBeacon;
C++
public:
char TrackBeacon sealed ;
J#
public byte TrackBeacon
JScript
public TrackBeacon : Byte;

See Also

ZMAC_SYNCHRONIZE_REQUEST Class
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Class

ZMAC_SYNCHRONIZE_RESPONSE Class
See Also Example Members
[image]

Response for ZMAC_SYNCHRONIZE_REQUEST

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZMAC_SYNCHRONIZE_RESPONSE
Implements IRESPONSE, IZMAC
C#
public class ZMAC_SYNCHRONIZE_RESPONSE : IRESPONSE, IZMAC
C++
ref class ZMAC_SYNCHRONIZE_RESPONSE : IRESPONSE, IZMAC
J#
public class ZMAC_SYNCHRONIZE_RESPONSE implements IRESPONSE, IZMAC
JScript
public class ZMAC_SYNCHRONIZE_RESPONSE extends IRESPONSE, IZMAC

Inheritance Hierarchy

System.Object
TI.ZPI2.ZMAC_SYNCHRONIZE_RESPONSE

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZMAC_SYNCHRONIZE_RESPONSE Members
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Members

ZMAC_SYNCHRONIZE_RESPONSE Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Response for ZMAC_SYNCHRONIZE_REQUEST

The following tables list the members exposed by ZMAC_SYNCHRONIZE_RESPONSE.

Public Constructors

Name | Description
ZMAC_SYNCHRONIZE_RESPONSE | Overloaded.
Top

Public Fields

 | Name | Description
Public field | Status | Status
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ZMAC_SYNCHRONIZE_RESPONSE | Overloaded.
Top

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Constructor

ZMAC_SYNCHRONIZE_RESPONSE Constructor

Overload List

 | Name | Description
Public method | ZMAC_SYNCHRONIZE_RESPONSE | Constructor
Public method | ZMAC_SYNCHRONIZE_RESPONSE (ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS) |

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_RESPONSE Constructor ()

ZMAC_SYNCHRONIZE_RESPONSE Constructor ()
See Also Example
[image]

Constructor

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZMAC_SYNCHRONIZE_RESPONSE()
C++
public:
ZMAC_SYNCHRONIZE_RESPONSE() sealed
J#
public ZMAC_SYNCHRONIZE_RESPONSE()
JScript
public function ZMAC_SYNCHRONIZE_RESPONSE()

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SYNCHRONIZE_RESPONSE Constructor Overload List


ZMAC_SYNCHRONIZE_RESPONSE Constructor (ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS)

ZMAC_SYNCHRONIZE_RESPONSE Constructor (ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS)
See Also Example
[image]

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal As ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS _
)
C#
public ZMAC_SYNCHRONIZE_RESPONSE(
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
)
C++
public:
ZMAC_SYNCHRONIZE_RESPONSE(
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
) sealed
J#
public ZMAC_SYNCHRONIZE_RESPONSE(
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
)
JScript
public function ZMAC_SYNCHRONIZE_RESPONSE(
: ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
)

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI2 Namespace
ZMAC_SYNCHRONIZE_RESPONSE Constructor Overload List


Fields

ZMAC_SYNCHRONIZE_RESPONSE Fields
[image]

Public Fields

 | Name | Description
Public field | Status | Status
Top

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI2 Namespace


Status Field

ZMAC_SYNCHRONIZE_RESPONSE.Status Field
[image]

Status

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Status As ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
C#
public ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Status;
C++
public:
ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Status sealed ;
J#
public ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Status
JScript
public Status : ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS;

See Also

ZMAC_SYNCHRONIZE_RESPONSE Class
TI.ZPI2 Namespace


ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Enumeration

ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS Enumeration
[image]

Status of command

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS As Byte
C#
public enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS : byte
C++
public enum class ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS : char
J#
public enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS byte
JScript
public enum ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS :

Members

Member Name | Description
SUCCESS | Status of command
FAIL | Status of command
INVALID_PARAMETER | Status of command
ZMEM_ERROR | Status of command
ZBUFFER_FULL | Status of command
ZUNSUPPORTED_MODE | Status of command
ZMAC_MEM_ERROR | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_BAD_STATE | Status of command
ZMAC_NO_RESOURCE | Status of command
ZMAC_ACK_PENDING | Status of command
ZMAC_NO_TIME | Status of command
ZMAC_TX_ABORTED | Status of command
ZAF_STATUS_SUCCESS | Status of command
ZAF_STATUS_FAILED | Status of command
ZAF_STATUS_INVALID_PARAMETER | Status of command
ZAF_STATUS_MEM_FAIL | Status of command
ZAF_STATUS_NO_ROUTE | Status of command
ZAPS_FAIL | Status of command
ZAPS_TABLE_FULL | Status of command
ZAPS_ILLEGAL_REQUEST | Status of command
ZAPS_INVALID_BINDING | Status of command
ZAPS_UNSUPPORTED_ATTRIB | Status of command
ZAPS_NOT_SUPPORTED | Status of command
ZAPS_NO_ACK | Status of command
ZSEC_NO_KEY | Status of command
ZSEC_OLD_FRM_COUNT | Status of command
ZSEC_MAX_FRM_COUNT | Status of command
ZSEC_CCM_FAIL | Status of command
ZNWK_INVALID_PARAM | Status of command
ZNWK_INVALID_REQUEST | Status of command
ZNWK_NOT_PERMITTED | Status of command
ZNWK_STARTUP_FAILURE | Status of command
ZNWK_ALREADY_PRESENT | Status of command
ZNWK_SYNC_FAILURE | Status of command
ZNWK_TABLE_FULL | Status of command
ZNWK_UNKNOWN_DEVICE | Status of command
ZNWK_UNSUPPORTED_ATTRIBUTE | Status of command
ZNWK_NO_NETWORKS | Status of command
ZNWK_LEAVE_UNCONFIRMED | Status of command
ZNWK_NO_ACK | Status of command
ZNWK_NO_ROUTE | Status of command
ZMAC_BEACON_LOSS | Status of command
ZMAC_CHANNEL_ACCESS_FAILURE | Status of command
ZMAC_DENIED | Status of command
ZMAC_DISABLE_TRX_FAILURE | Status of command
ZMAC_FAILED_SECURITY_CHECK | Status of command
ZMAC_FRAME_TOO_LONG | Status of command
ZMAC_INVALID_GTS | Status of command
ZMAC_INVALID_HANDLE | Status of command
ZMAC_INVALID_PARAMETER | Status of command
ZMAC_NO_ACK | Status of command
ZMAC_NO_BEACON | Status of command
ZMAC_NO_DATA | Status of command
ZMAC_NO_SHORT_ADDRESS | Status of command
ZMAC_OUT_OF_CAP | Status of command
ZMAC_PANID_CONFLICT | Status of command
ZMAC_REALIGNMENT | Status of command
ZMAC_TRANSACTION_EXPIRED | Status of command
ZMAC_TRANSACTION_OVERFLOW | Status of command
ZMAC_TX_ACTIVE | Status of command
ZMAC_UNAVAILABLE_KEY | Status of command
ZMAC_UNSUPPORTED_ATTRIBUTE | Status of command
ZMAC_UNSUPPORTED | Status of command
ZMAC_ON_TIME_TOO_LONG | Status of command
ZMAC_PAST_TIME | Status of command
ZMAC_TRACKING_OFF | Status of command
ZMAC_SCAN_IN_PROGRESS | Status of command

See Also

TI.ZPI2 Namespace


NwkManagerAddr Field

ZDO_MGMT_NWK_UPDATE_REQUEST.NwkManagerAddr Field
[image]

indicates the NWK address for the device with the Network Manager bit set in its Node Descriptor

Namespace: TI.ZPI1
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public NwkManagerAddr As UInt16
C#
public ushort NwkManagerAddr ;
C++
public:
unsigned short NwkManagerAddr sealed ;
J#
public ushort NwkManagerAddr
JScript
public NwkManagerAddr : UInt16;

See Also

ZDO_MGMT_NWK_UPDATE_REQUEST Class
TI.ZPI1 Namespace


Relay Count Field

ZDO_SRC_RTG_IND.Relay Count Field
[image]

The number of devices in the relay list for source routing

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Relay Count As Byte
C#
public byte Relay Count;
C++
public:
char Relay Count sealed ;
J#
public byte Relay Count
JScript
public Relay Count : Byte;

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace


Relay List Field

ZDO_SRC_RTG_IND.Relay List Field
[image]

List of relay devices on the source routing path. For each device, it contains 2 bytes short address for each device.

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Relay List As UInt16()
C#
public ushort[] Relay List;
C++
public:
array<unsigned short>^ Relay List sealed ;
J#
public ushort[] Relay List
JScript
public Relay List : UInt16[];

See Also

ZDO_SRC_RTG_IND Class
TI.ZPI2 Namespace


Index 1 Field

ZMAC_SECURITY_GET_REQUEST.Index 1 Field
[image]

Specifies the MAC Security PID Index 1

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index 1 As Byte
C#
public byte Index 1;
C++
public:
char Index 1 sealed ;
J#
public byte Index 1
JScript
public Index 1 : Byte;

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace


Index 2 Field

ZMAC_SECURITY_GET_REQUEST.Index 2 Field
[image]

Specifies the MAC Security PID Index 2

Namespace: TI.ZPI2
Assembly: TI.ZPI (in TI.ZPI.dll)

Syntax

Visual Basic (Declaration)
Public Index 2 As Byte
C#
public byte Index 2;
C++
public:
char Index 2 sealed ;
J#
public byte Index 2
JScript
public Index 2 : Byte;

See Also

ZMAC_SECURITY_GET_REQUEST Class
TI.ZPI2 Namespace


TI.ZPI1 Hierarchy

TI.ZPI1 Hierarchy
System.Object
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
TI.ZPI1.AF_INIT_RESPONSE.AF_STATUS
TI.ZPI1.AF_REGISTER_REQUEST.APP_FLAGS
TI.ZPI1.AF_REGISTER_REQUEST.LATENCY_TYPE
TI.ZPI1.AF_REGISTER_RESPONSE.AF_STATUS
TI.ZPI1.AF_SENDMSG_RESPONSE.AF_STATUS
TI.ZPI1.APSDE_DATA_CONFIRMATION.APSDE_STATUS
TI.ZPI1.APSDE_DATA_CONFIRMATION.BOOLEAN
TI.ZPI1.APSME_BIND_RESPONSE.NLME_STATUS
TI.ZPI1.MESSAGE_ID
TI.ZPI1.NLDE_DATA_CONFIRMATION.CMD_STATUS
TI.ZPI1.NLDE_DATA_RESPONSE.NLDE_STATUS
TI.ZPI1.NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
TI.ZPI1.NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_GET_REQUEST.NIB_ATTR
TI.ZPI1.NLME_GET_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_JOIN_CONFIRMATION.CMD_STATUS
TI.ZPI1.NLME_JOIN_INDICATION.CAPABILITY_INFO
TI.ZPI1.NLME_JOIN_REQUEST.CAPABILITY_INFO
TI.ZPI1.NLME_JOIN_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_LEAVE_CONFIRMATION.CMD_STATUS
TI.ZPI1.NLME_LEAVE_INDICATION.CMD_STATUS
TI.ZPI1.NLME_LEAVE_REQUEST.BOOLEAN
TI.ZPI1.NLME_LEAVE_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
TI.ZPI1.NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS
TI.ZPI1.NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
TI.ZPI1.NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS
TI.ZPI1.NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS
TI.ZPI1.NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_PERMITJOINING_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_RESET_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_SET_REQUEST.NIB_ATTR
TI.ZPI1.NLME_SET_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
TI.ZPI1.NLME_STARTROUTER_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_SYNC_INDICATION.CMD_STATUS
TI.ZPI1.NLME_SYNC_REQUEST.TRACK_BEACONS
TI.ZPI1.NLME_SYNC_RESPONSE.CMD_STATUS
TI.ZPI1.NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE
TI.ZPI1.NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL
TI.ZPI1.NWK_ASSOCIATE_INDICATION.CAPABILITIES
TI.ZPI1.NWK_ASSOCIATE_INDICATION.KEY_ID_MODE
TI.ZPI1.NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION.BOOLEAN
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL
TI.ZPI1.NWK_COMM_STATUS_INDICATION.ADDRESS_MODE
TI.ZPI1.NWK_COMM_STATUS_INDICATION.CMD_STATUS
TI.ZPI1.NWK_COMM_STATUS_INDICATION.KEY_ID_MODE
TI.ZPI1.NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL
TI.ZPI1.NWK_DATA_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_DATA_INDICATION.ADDRESS_MODE
TI.ZPI1.NWK_DATA_INDICATION.KEY_ID_MODE
TI.ZPI1.NWK_DATA_INDICATION.SECURITY_LEVEL
TI.ZPI1.NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE
TI.ZPI1.NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON
TI.ZPI1.NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE
TI.ZPI1.NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL
TI.ZPI1.NWK_ORPHAN_INDICATION.KEY_ID_MODE
TI.ZPI1.NWK_ORPHAN_INDICATION.SECURITY_LEVEL
TI.ZPI1.NWK_POLL_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_PURGE_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_SCAN_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_SCAN_CONFIRMATION.SCAN_TYPE
TI.ZPI1.NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS
TI.ZPI1.NWK_START_CONFIRMATION.CMD_STATUS
TI.ZPI1.NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE
TI.ZPI1.NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
TI.ZPI1.SYS_APP_MSG.LOC_REQ_MESSAGE_ID
TI.ZPI1.SYS_APP_MSG.OAD_REQ_MESSAGE_ID
TI.ZPI1.SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
TI.ZPI1.SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.APP_END_POINT
TI.ZPI1.SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
TI.ZPI1.SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS
TI.ZPI1.SYS_APP_MSG_RESPONSE.LOC_RSP_MESSAGE_ID
TI.ZPI1.SYS_APP_MSG_RESPONSE.OAD_RSP_MESSAGE_ID
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.ERROR_CODE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE.SUBS_ACTION
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_GET_DEVICE_INFO_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE
TI.ZPI1.SYS_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE
TI.ZPI1.SYS_GET_NV_INFO_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS
TI.ZPI1.SYS_GET_NV_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_KEY_EVENT.BOOLEAN
TI.ZPI1.SYS_KEY_EVENT.KEY_EVENT
TI.ZPI1.SYS_KEY_EVENT_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_LED_CONTROL.LED_MODE
TI.ZPI1.SYS_LED_CONTROL.LED_NUM
TI.ZPI1.SYS_LED_CONTROL_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_PING_RESPONSE.CAPABILITIES
TI.ZPI1.SYS_RAM_READ_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_RAM_WRITE_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_RESET.RESET_TYPE
TI.ZPI1.SYS_RESET_RESPONSE.RESET_TYPE
TI.ZPI1.SYS_SET_CHANNELS.ZIGBEE_CHANNELS
TI.ZPI1.SYS_SET_CHANNELS_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_SET_NV_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_SET_PANID_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
TI.ZPI1.SYS_SET_SECURITY_MODE_RESPONSE.CMD_STATUS
TI.ZPI1.USERTEST_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_ACTIVEENDPOINT_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_AUTOFINDDESTINATION_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_BIND_REQUEST.ADDRESS_MODE
TI.ZPI1.ZDO_BIND_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_BIND_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_BIND_RESPONSECB.BIND_RESPONSE_STATUS
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
TI.ZPI1.ZDO_END_DEVICE_ANNCE.SECURITY_SUITE
TI.ZPI1.ZDO_END_DEVICE_ANNCE_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_ENDDEVICEBIND_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSECB.ED_BIND_RESPONSE_STATUS
TI.ZPI1.ZDO_IEEEADDRESS_REQUEST.REQ_TYPE
TI.ZPI1.ZDO_IEEEADDRESS_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSECB.ADDRESS_MODE
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MATCHDESCRIPTOR_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_BIND_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_MGMT_BIND_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_REQUEST.CAPABILITY_INFO
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_LEAVE_REQUEST.BOOLEAN
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_LQI_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_MGMT_LQI_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_NOTIFYCB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_NOTIFYCB.ZIGBEE_CHANNELS
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_MGMT_NWKDISC_REQUEST.ZIGBEE_CHANNELS
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_MGMT_RTG_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_MGMT_RTG_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_NETWORK_START_RESPONSE.NETWORK_START_STATUS
TI.ZPI1.ZDO_NETWORKADDRESS_REQUEST.REQ_TYPE
TI.ZPI1.ZDO_NETWORKADDRESS_REQUEST.SECURITY_STATUS
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSECB.ADDRESS_MODE
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_NODEDESCRIPTOR_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB.CAPABILITY_INFO
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB.NODE_TYPE
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB.SERVER_CAPABILITY
TI.ZPI1.ZDO_POWERDESCRIPTOR_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_AVAIL_PWR_SRC
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSECB.NODE_CURR_PWR_MODE
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_DEV_VER
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSECB.APP_FLAGS
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSECB.SERVER_CAPABILITY
TI.ZPI1.ZDO_UNBIND_REQUEST.ADDRESS_MODE
TI.ZPI1.ZDO_UNBIND_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_UNBIND_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_UNBIND_RESPONSECB.UNBIND_RESPONSE_STATUS
TI.ZPI1.ZDO_USERDESCRIPTOR_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSE.AF_STATUS
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSECB.CMD_STATUS
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_REQUEST.SECURITY_SUITE
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSE.CMD_STATUS
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSECB.CMD_STATUS
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST.CAPABILITY_INFO
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND.CMD_STATUS
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND.KEY_ID_MODE
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND.SECURITY_LEVEL
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_DATA_REQUEST.ADDRESS_MODE
TI.ZPI1.ZMAC_DATA_REQUEST.KEY_ID_MODE
TI.ZPI1.ZMAC_DATA_REQUEST.SECURITY_LEVEL
TI.ZPI1.ZMAC_DATA_REQUEST.TX_OPT
TI.ZPI1.ZMAC_DATA_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL
TI.ZPI1.ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_GET_REQUEST.MAC_PID_ATTR
TI.ZPI1.ZMAC_GET_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_INIT_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_ORPHAN_RESPOND.KEY_ID_MODE
TI.ZPI1.ZMAC_ORPHAN_RESPOND.SECURITY_LEVEL
TI.ZPI1.ZMAC_ORPHAN_RESPOND_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_POLL_REQUEST.ADDRESS_MODE
TI.ZPI1.ZMAC_POLL_REQUEST.KEY_ID_MODE
TI.ZPI1.ZMAC_POLL_REQUEST.SECURITY_LEVEL
TI.ZPI1.ZMAC_POLL_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_PURGE_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_RESET_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_RX_ENABLE_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_SCAN_REQUEST.KEY_ID_MODE
TI.ZPI1.ZMAC_SCAN_REQUEST.SCAN_TYPE
TI.ZPI1.ZMAC_SCAN_REQUEST.SECURITY_LEVEL
TI.ZPI1.ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS
TI.ZPI1.ZMAC_SCAN_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_SET_REQUEST.MAC_PID_ATTR
TI.ZPI1.ZMAC_SET_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_START_REQUEST.KEY_ID_MODE
TI.ZPI1.ZMAC_START_REQUEST.SECURITY_LEVEL
TI.ZPI1.ZMAC_START_RESPONSE.CMD_STATUS
TI.ZPI1.ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
TI.ZPI1.NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_CONFIGURATION
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
TI.ZPI1.SYS_APP_MSG.BLIND_NODE_REQUEST
TI.ZPI1.SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION
TI.ZPI1.SYS_APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
TI.ZPI1.SYS_APP_MSG.REFERENCE_NODE_REQUEST
TI.ZPI1.SYS_APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
TI.ZPI1.SYS_APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
TI.ZPI1.SYS_APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
TI.ZPI1.SYS_APP_MSG.ZLMSGID_RESET_REQUEST
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_START_RESPONSE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
TI.ZPI1.SYS_APP_MSG.ZLMSGID_STATUSQ_REQUEST
TI.ZPI1.SYS_APP_MSG_RESPONSE.BLIND_NODE_CONFIGURATION
TI.ZPI1.SYS_APP_MSG_RESPONSE.BLIND_NODE_RESPONSE
TI.ZPI1.SYS_APP_MSG_RESPONSE.REFERENCE_NODE_CONFIGURATION
TI.ZPI1.SYS_APP_MSG_RESPONSE.REFERENCE_NODE_RESPONSE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CLIENT_CMD_RESPONSE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_CODE_ENABLE_RESPONSE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_BOARD_RESPONSE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_RESET_RESPONSE
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_SEND_DATA_REQUEST
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_START_REQUEST
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_SESSION_TERM_REQUEST
TI.ZPI1.SYS_APP_MSG_RESPONSE.ZLMSGID_STATUSQ_RESPONSE
TI.ZPI1.ZDO_MGMT_BIND_RESPONSECB.BindListItemClass
TI.ZPI1.ZDO_MGMT_LQI_RESPONSECB.NeighborLqiListItemClass
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSECB.NetworkListItemClass
TI.ZPI1.AF_INCOMINGDATA_INDICATION ---- TI.ZPI1.IAF, TI.ZPI1.IINDICATION
TI.ZPI1.AF_INIT_REQUEST ---- TI.ZPI1.IAF, TI.ZPI1.IREQUEST
TI.ZPI1.AF_INIT_RESPONSE ---- TI.ZPI1.IAF, TI.ZPI1.IRESPONSE
TI.ZPI1.AF_REGISTER_REQUEST ---- TI.ZPI1.IAF, TI.ZPI1.IREQUEST
TI.ZPI1.AF_REGISTER_RESPONSE ---- TI.ZPI1.IAF, TI.ZPI1.IRESPONSE
TI.ZPI1.AF_SENDMSG_CONFIRM ---- TI.ZPI1.IAF, TI.ZPI1.IREQUEST
TI.ZPI1.AF_SENDMSG_REQUEST ---- TI.ZPI1.IAF, TI.ZPI1.IREQUEST
TI.ZPI1.AF_SENDMSG_RESPONSE ---- TI.ZPI1.IAF, TI.ZPI1.IRESPONSE
TI.ZPI1.APSDE_DATA_CONFIRMATION ---- TI.ZPI1.IAPS, TI.ZPI1.ICONFIRMATION
TI.ZPI1.APSME_BIND_RESPONSE ---- TI.ZPI1.IAPS, TI.ZPI1.IRESPONSE
TI.ZPI1.IAF
TI.ZPI1.IAPS
TI.ZPI1.ICONFIRMATION
TI.ZPI1.IINDICATION
TI.ZPI1.INETWORK
TI.ZPI1.IREQUEST
TI.ZPI1.IRESPONSE
TI.ZPI1.IRESPONSE_CALLBACK
TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ISYSTEM
TI.ZPI1.IUSERTEST
TI.ZPI1.IZDO
TI.ZPI1.IZMAC
TI.ZPI1.NLDE_DATA_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NLDE_DATA_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NLDE_DATA_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLDE_DATA_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_DIRECTJOIN_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_DIRECTJOIN_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_GET_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_GET_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_JOIN_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_JOIN_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_JOIN_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_JOIN_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_LEAVE_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_LEAVE_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_LEAVE_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_LEAVE_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_NETWORK_FORMATION_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_NETWORK_FORMATION_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_NETWORK_FORMATION_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_NETWORKDISCOVERY_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_NETWORKDISCOVERY_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_NETWORKDISCOVERY_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_ORPHANJOIN_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_ORPHANJOIN_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_PERMITJOINING_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_PERMITJOINING_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_RESET_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_RESET_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_ROUTEDISCOVERY_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_ROUTEDISCOVERY_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_SET_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_SET_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_STARTROUTER_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_STARTROUTER_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_STARTROUTER_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NLME_SYNC_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NLME_SYNC_REQUEST ---- TI.ZPI1.INETWORK, TI.ZPI1.IREQUEST
TI.ZPI1.NLME_SYNC_RESPONSE ---- TI.ZPI1.INETWORK, TI.ZPI1.IRESPONSE
TI.ZPI1.NWK_ASSOCIATE_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_ASSOCIATE_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_BEACON_NOTIFY_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_COMM_STATUS_INDICATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_DATA_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_DATA_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_DISASSOCIATE_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_DISASSOCIATE_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_ORPHAN_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_POLL_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_PURGE_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_RX_ENABLE_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_SCAN_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_START_CONFIRMATION ---- TI.ZPI1.ICONFIRMATION, TI.ZPI1.INETWORK
TI.ZPI1.NWK_SYNCHRONIZATION_LOSS_INDICATION ---- TI.ZPI1.IINDICATION, TI.ZPI1.INETWORK
TI.ZPI1.SYS_APP_MSG ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_APP_MSG_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_CALLBACK_SUBSCRIBE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_DEVICE_INFO ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_DEVICE_INFO_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_EXTENDED_ADDRESS_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_NV ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_NV_INFO ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_NV_INFO_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_NV_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_TIME_ALIVE ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_GET_TIME_ALIVE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_KEY_EVENT ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_KEY_EVENT_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_LED_CONTROL ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_LED_CONTROL_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_PING ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_PING_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_RAM_READ ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_RAM_READ_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_RAM_WRITE ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_RAM_WRITE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_RESET ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_RESET_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_CHANNELS ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_CHANNELS_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_DEBUG_THRESHOLD_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_EXTENDED_ADDRESS_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_NV ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_NV_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_PANID ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_PANID_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_PRECONFIG_KEY ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_PRECONFIG_KEY_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_SECURITY_LEVEL ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_SECURITY_LEVEL_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_SECURITY_MODE ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_SET_SECURITY_MODE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_STRING_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_VERSION ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISYSTEM
TI.ZPI1.SYS_VERSION_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISYSTEM
TI.ZPI1.USERTEST_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IUSERTEST
TI.ZPI1.USERTEST_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IUSERTEST
TI.ZPI1.ZB_ALLOW_BIND ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_ALLOW_BIND_CNF ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_ALLOW_BIND_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_BIND_CNF ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_BIND_DEVICE ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_BIND_DEVICE_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_FIND_DEV ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_FIND_DEV_CNF ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_FIND_DEV_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_GET_DEV_INFO ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_GET_DEV_INFO_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_PERMIT_JOIN ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_PERMIT_JOIN_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_RCV_DATA_IND ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_READ_CFG ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_READ_CFG_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_SEND_DATA ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_SEND_DATA_CNF ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_SEND_DATA_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_START_CNF ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_START_REQ ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_START_REQ_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_SYS_RESET ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_WRITE_CFG ---- TI.ZPI1.IREQUEST, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZB_WRITE_CFG_RSP ---- TI.ZPI1.IRESPONSE, TI.ZPI1.ISIMPLEAPI
TI.ZPI1.ZDO_ACTIVEENDPOINT_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_ACTIVEENDPOINT_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_AUTOAPPENDENDDEVICEBIND_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_AUTOFINDDESTINATION_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_AUTOFINDDESTINATION_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_BIND_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_BIND_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_BIND_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_COMPLEXDESCRIPTOR_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_END_DEVICE_ANNCE ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_END_DEVICE_ANNCE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_ENDDEVICEBIND_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_ENDDEVICEBIND_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_IEEEADDRESS_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_IEEEADDRESS_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MATCHDESCRIPTOR_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MATCHDESCRIPTOR_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_BIND_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_BIND_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_BIND_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_DIRECT_JOIN_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_LEAVE_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_LEAVE_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_LQI_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_LQI_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_LQI_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_NOTIFYCB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_NWK_UPDATE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_NWKDISC_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_NWKDISC_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_PERMIT_JOIN_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_RTG_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_RTG_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_MGMT_RTG_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NETWORK_START_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NETWORK_START_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NETWORKADDRESS_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NETWORKADDRESS_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NODEDESCRIPTOR_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_NODEDESCRIPTOR_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_POWERDESCRIPTOR_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_POWERDESCRIPTOR_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_SIMPLEDESCRIPTOR_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_SYSTEM_SERVER_DISC_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_UNBIND_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_UNBIND_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_UNBIND_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_USERDESCRIPTOR_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_USERDESCRIPTOR_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZDO
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZDO
TI.ZPI1.ZDO_USERDESCRIPTOR_SET_RESPONSECB ---- TI.ZPI1.IRESPONSE_CALLBACK, TI.ZPI1.IZDO
TI.ZPI1.ZMAC_ASSOCIATE_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_ASSOCIATE_RESPOND_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_ASSOCIATE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_DATA_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_DATA_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_DISASSOCIATE_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_DISASSOCIATE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_GET_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_GET_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_INIT_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_INIT_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_ORPHAN_RESPOND ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_ORPHAN_RESPOND_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_POLL_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_POLL_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_PURGE_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_PURGE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_RESET_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_RESET_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_RX_ENABLE_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_RX_ENABLE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_SCAN_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_SCAN_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_SET_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_SET_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_START_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_START_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_SYNCHRONIZE_REQUEST ---- TI.ZPI1.IREQUEST, TI.ZPI1.IZMAC
TI.ZPI1.ZMAC_SYNCHRONIZE_RESPONSE ---- TI.ZPI1.IRESPONSE, TI.ZPI1.IZMAC

See Also

TI.ZPI1 Namespace


TI.ZPI2 Hierarchy

TI.ZPI2 Hierarchy
System.Object
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
TI.ZPI2.AF_APSF_CONFIG_SET_SRSP.AF_STATUS
TI.ZPI2.AF_DATA_CONFIRM.AF_STATUS
TI.ZPI2.AF_DATA_REQUEST_EXT.ADDRESS_MODE
TI.ZPI2.AF_DATA_REQUEST_EXT_SRSP.AF_STATUS
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG_SRSP.AF_STATUS
TI.ZPI2.AF_DATA_REQUEST_SRSP.AF_STATUS
TI.ZPI2.AF_DATA_RETRIEVE_SRSP.AF_STATUS
TI.ZPI2.AF_DATA_STORE_SRSP.AF_STATUS
TI.ZPI2.AF_INCOMING_MSG_EXT.ADDRESS_MODE
TI.ZPI2.AF_INTER_PAN_CTL_SRSP.CMD_STATUS
TI.ZPI2.AF_REGISTER.LATENCY_TYPE
TI.ZPI2.AF_REGISTER_SRSP.AF_STATUS
TI.ZPI2.APP_MSG.BLIND_NODE_CONFIGURATION.APP_END_POINT
TI.ZPI2.APP_MSG.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
TI.ZPI2.APP_MSG.LOC_REQ_MESSAGE_ID
TI.ZPI2.APP_MSG.OAD_REQ_MESSAGE_ID
TI.ZPI2.APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST.APP_END_POINT
TI.ZPI2.APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_MSG.ZLMSGID_SEND_DATA_RESPONSE.SEND_DATA_ERROR_CODE
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_START_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_START_RESPONSE.SESSION_START_ERROR_CODE
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE.SESSION_TERM_ERROR_CODE
TI.ZPI2.APP_MSG_RESPONSE.CMD_STATUS
TI.ZPI2.APP_MSG_RSP.BLIND_NODE_CONFIGURATION.APP_END_POINT
TI.ZPI2.APP_MSG_RSP.BLIND_NODE_CONFIGURATION.BLIND_NODE_MODE
TI.ZPI2.APP_MSG_RSP.BLIND_NODE_RESPONSE.BLIND_NODE_STATUS
TI.ZPI2.APP_MSG_RSP.LOC_RSP_MESSAGE_ID
TI.ZPI2.APP_MSG_RSP.OAD_RSP_MESSAGE_ID
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.CLIENT_CMD_ERROR_CODE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.CODE_ENABLE_ERROR_CODE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.ERROR_CODE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.ERROR_CODE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.ERROR_CODE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE.OAD_DEVICE_STATE
TI.ZPI2.APP_USER_TEST_RESPONSE.CMD_STATUS
TI.ZPI2.APSDE_DATA_CONFIRMATION.APSDE_STATUS
TI.ZPI2.APSDE_DATA_CONFIRMATION.BOOLEAN
TI.ZPI2.APSME_BIND_RESPONSE.NLME_STATUS
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD.DEBUG_THRESHOLD
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD_RESPONSE.CMD_STATUS
TI.ZPI2.MESSAGE_ID
TI.ZPI2.NLDE_DATA_CONFIRMATION.CMD_STATUS
TI.ZPI2.NLDE_DATA_RESPONSE.NLDE_STATUS
TI.ZPI2.NLME_DIRECTJOIN_REQUEST.CAPABILITY_INFO
TI.ZPI2.NLME_DIRECTJOIN_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_GET_REQUEST.NIB_ATTR
TI.ZPI2.NLME_GET_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_JOIN_CONFIRMATION.CMD_STATUS
TI.ZPI2.NLME_JOIN_INDICATION.CAPABILITY_INFO
TI.ZPI2.NLME_JOIN_REQUEST.CAPABILITY_INFO
TI.ZPI2.NLME_JOIN_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_LEAVE_CONFIRMATION.CMD_STATUS
TI.ZPI2.NLME_LEAVE_INDICATION.CMD_STATUS
TI.ZPI2.NLME_LEAVE_REQUEST.BOOLEAN
TI.ZPI2.NLME_LEAVE_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_NETWORK_FORMATION_CONFIRMATION.CMD_STATUS
TI.ZPI2.NLME_NETWORK_FORMATION_REQUEST.ZIGBEE_CHANNELS
TI.ZPI2.NLME_NETWORK_FORMATION_RESPONSE.NLME_STATUS
TI.ZPI2.NLME_NETWORKDISCOVERY_REQUEST.ZIGBEE_CHANNELS
TI.ZPI2.NLME_NETWORKDISCOVERY_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_ORPHANJOIN_REQUEST.ZIGBEE_CHANNELS
TI.ZPI2.NLME_ORPHANJOIN_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_PERMITJOINING_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_POLL_CONFIRMATION.CMD_STATUS
TI.ZPI2.NLME_RESET_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_ROUTEDISCOVERY_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_SET_REQUEST.NIB_ATTR
TI.ZPI2.NLME_SET_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_STARTROUTER_CONFIRMATION.CMD_STATUS
TI.ZPI2.NLME_STARTROUTER_RESPONSE.CMD_STATUS
TI.ZPI2.NLME_SYNC_INDICATION.CMD_STATUS
TI.ZPI2.NWK_ASSOCIATE_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_ASSOCIATE_CONFIRMATION.KEY_ID_MODE
TI.ZPI2.NWK_ASSOCIATE_CONFIRMATION.SECURITY_LEVEL
TI.ZPI2.NWK_ASSOCIATE_INDICATION.CAPABILITIES
TI.ZPI2.NWK_ASSOCIATE_INDICATION.KEY_ID_MODE
TI.ZPI2.NWK_ASSOCIATE_INDICATION.SECURITY_LEVEL
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION.ADDRESS_MODE
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION.BOOLEAN
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION.KEY_ID_MODE
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION.SECURITY_LEVEL
TI.ZPI2.NWK_COMM_STATUS_INDICATION.ADDRESS_MODE
TI.ZPI2.NWK_COMM_STATUS_INDICATION.CMD_STATUS
TI.ZPI2.NWK_COMM_STATUS_INDICATION.KEY_ID_MODE
TI.ZPI2.NWK_COMM_STATUS_INDICATION.SECURITY_LEVEL
TI.ZPI2.NWK_DATA_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_DATA_INDICATION.ADDRESS_MODE
TI.ZPI2.NWK_DATA_INDICATION.KEY_ID_MODE
TI.ZPI2.NWK_DATA_INDICATION.SECURITY_LEVEL
TI.ZPI2.NWK_DISASSOCIATE_CONFIRMATION.ADDRESS_MODE
TI.ZPI2.NWK_DISASSOCIATE_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_DISASSOCIATE_INDICATION.DISASSOC_REASON
TI.ZPI2.NWK_DISASSOCIATE_INDICATION.KEY_ID_MODE
TI.ZPI2.NWK_DISASSOCIATE_INDICATION.SECURITY_LEVEL
TI.ZPI2.NWK_ORPHAN_INDICATION.KEY_ID_MODE
TI.ZPI2.NWK_ORPHAN_INDICATION.SECURITY_LEVEL
TI.ZPI2.NWK_POLL_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_PURGE_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_RX_ENABLE_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_SCAN_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_SCAN_CONFIRMATION.SCAN_TYPE
TI.ZPI2.NWK_SCAN_CONFIRMATION.ZIGBEE_CHANNELS
TI.ZPI2.NWK_START_CONFIRMATION.CMD_STATUS
TI.ZPI2.NWK_SYNCHRONIZATION_LOSS_INDICATION.KEY_ID_MODE
TI.ZPI2.NWK_SYNCHRONIZATION_LOSS_INDICATION.SECURITY_LEVEL
TI.ZPI2.SYS_OSAL_NV_DELETE_SRSP.CMD_STATUS
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT_SRSP.CMD_STATUS
TI.ZPI2.SYS_OSAL_NV_READ_SRSP.CMD_STATUS
TI.ZPI2.SYS_OSAL_NV_WRITE_SRSP.CMD_STATUS
TI.ZPI2.SYS_OSAL_START_TIMER_SRSP.CMD_STATUS
TI.ZPI2.SYS_OSAL_STOP_TIMER_SRSP.CMD_STATUS
TI.ZPI2.SYS_PING_RESPONSE.CAPABILITIES
TI.ZPI2.SYS_RESET.RESET_TYPE
TI.ZPI2.SYS_RPC_ERROR.RPC_ERROR_STATUS
TI.ZPI2.SYS_SET_TIME_SRSP.CMD_STATUS
TI.ZPI2.SYS_STACK_TUNE_SRSP.CMD_STATUS
TI.ZPI2.USERTEST_REQUEST.USERTEST_COMMAND
TI.ZPI2.USERTEST_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD_SRSP.CMD_STATUS
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE.SUBS_ACTION
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_DATA_REQ.BOOLEAN
TI.ZPI2.UTIL_DATA_REQ_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_GET_DEVICE_INFO_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_STATE
TI.ZPI2.UTIL_GET_DEVICE_INFO_RESPONSE.DEVICE_TYPE
TI.ZPI2.UTIL_GET_NV_INFO_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_GET_NV_INFO_RESPONSE.ZIGBEE_CHANNELS
TI.ZPI2.UTIL_KEY_EVENT.BOOLEAN
TI.ZPI2.UTIL_KEY_EVENT.KEY_EVENT
TI.ZPI2.UTIL_KEY_EVENT_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_LED_CONTROL.LED_MODE
TI.ZPI2.UTIL_LED_CONTROL.LED_NUM
TI.ZPI2.UTIL_LED_CONTROL_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SET_CHANNELS.ZIGBEE_CHANNELS
TI.ZPI2.UTIL_SET_CHANNELS_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SET_PANID_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SET_PRECONFIG_KEY_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SET_SECURITY_LEVEL_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING.BOOLEAN
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY.ADDRESS_MODE
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.BOOLEAN
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR.ADDRESS_MODE
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY.ADDRESS_MODE
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SRC_MATCH_ENABLE.AUTOPEND_ADDRESS_TYPE
TI.ZPI2.UTIL_SRC_MATCH_ENABLE_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_SRNG_GEN_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST.ADDRESS_MODE
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE.CMD_STATUS
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN_RESPONSE.CMD_STATUS
TI.ZPI2.ZB_APP_REGISTER_RSP.AF_STATUS
TI.ZPI2.ZB_BIND_CONFIRM.CMD_STATUS
TI.ZPI2.ZB_BIND_DEVICE.BIND_ACTION_TYPE
TI.ZPI2.ZB_GET_DEVICE_INFO.DEV_INFO_TYPE
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST_RSP.CMD_STATUS
TI.ZPI2.ZB_READ_CONFIGURATION_RSP.CMD_STATUS
TI.ZPI2.ZB_SEND_DATA_CONFIRM.CMD_STATUS
TI.ZPI2.ZB_SEND_DATA_REQUEST.TXOPTIONS_TYPE
TI.ZPI2.ZB_START_CONFIRM.CMD_STATUS
TI.ZPI2.ZB_WRITE_CONFIGURATION_RSP.CMD_STATUS
TI.ZPI2.ZDO_ACTIVE_EP_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_ACTIVE_EP_RSP.ZDO_STATUS
TI.ZPI2.ZDO_BIND_REQ.ADDRESS_MODE
TI.ZPI2.ZDO_BIND_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_BIND_RSP.ZDO_STATUS
TI.ZPI2.ZDO_COMPLEX_DESC_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_COMPLEX_DESC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_END_DEVICE_ANNCE.CAPABILITY_INFO
TI.ZPI2.ZDO_END_DEVICE_ANNCE_SRSP.CMD_STATUS
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_END_DEVICE_BIND_RSP.ZDO_STATUS
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_RSP.ZDO_STATUS
TI.ZPI2.ZDO_GET_LINK_KEY_SRSP.CMD_STATUS
TI.ZPI2.ZDO_IEEE_ADDR_REQ.REQ_TYPE
TI.ZPI2.ZDO_IEEE_ADDR_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_IEEE_ADDR_RSP.ZDO_STATUS
TI.ZPI2.ZDO_JOIN_CNF.CMD_STATUS
TI.ZPI2.ZDO_JOIN_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_MATCH_DESC_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_MATCH_DESC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MGMT_BIND_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_MGMT_BIND_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ.CAPABILITY_INFO
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MGMT_LEAVE_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_MGMT_LEAVE_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MGMT_LQI_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_MGMT_LQI_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ.ZIGBEE_CHANNELS
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_MGMT_NWK_DISC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_REQUEST.ADDRESS_MODE
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_REQUEST.ZIGBEE_CHANNELS
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_RESPONSE.CMD_STATUS
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MGMT_RTG_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_MGMT_RTG_RSP.ZDO_STATUS
TI.ZPI2.ZDO_MSG_CB_REGISTER_RESPONSE.CMD_STATUS
TI.ZPI2.ZDO_MSG_CB_REMOVE_RESPONSE.CMD_STATUS
TI.ZPI2.ZDO_NODE_DESC_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_NODE_DESC_RSP.CAPABILITY_INFO
TI.ZPI2.ZDO_NODE_DESC_RSP.SERVER_CAPABILITY
TI.ZPI2.ZDO_NODE_DESC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_NWK_ADDR_REQ.REQ_TYPE
TI.ZPI2.ZDO_NWK_ADDR_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_NWK_ADDR_RSP.ZDO_STATUS
TI.ZPI2.ZDO_NWK_DISCOVERY_CNF.CMD_STATUS
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ.ZIGBEE_CHANNELS
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_POWER_DESC_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_POWER_DESC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_REMOVE_LINK_KEY_SRSP.CMD_STATUS
TI.ZPI2.ZDO_SERVER_DISC_REQ_SRSP.CMD_STATUS
TI.ZPI2.ZDO_SERVER_DISC_RSP.SERVER_CAPABILITY
TI.ZPI2.ZDO_SERVER_DISC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_SET_LINK_KEY_SRSP.CMD_STATUS
TI.ZPI2.ZDO_SIMPLE_DESC_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_SIMPLE_DESC_RSP.APP_DEV_VER
TI.ZPI2.ZDO_SIMPLE_DESC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_STARTUP_FROM_APP_SRSP.CMD_STATUS
TI.ZPI2.ZDO_STATE_CHANGE_IND.CMD_STATUS
TI.ZPI2.ZDO_STATUS_ERROR_RSP.ZDO_STATUS
TI.ZPI2.ZDO_UNBIND_REQ.ADDRESS_MODE
TI.ZPI2.ZDO_UNBIND_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_UNBIND_RSP.ZDO_STATUS
TI.ZPI2.ZDO_USER_DESC_CONF.ZDO_STATUS
TI.ZPI2.ZDO_USER_DESC_REQ_SRSP.AF_STATUS
TI.ZPI2.ZDO_USER_DESC_RSP.ZDO_STATUS
TI.ZPI2.ZDO_USER_DESC_SET_SRSP.CMD_STATUS
TI.ZPI2.ZMAC_ASSOCIATE_CNF.CMD_STATUS
TI.ZPI2.ZMAC_ASSOCIATE_CNF.KEY_ID_MODE
TI.ZPI2.ZMAC_ASSOCIATE_CNF.SECURITY_LEVEL
TI.ZPI2.ZMAC_ASSOCIATE_IND.KEY_ID_MODE
TI.ZPI2.ZMAC_ASSOCIATE_IND.SECURITY_LEVEL
TI.ZPI2.ZMAC_ASSOCIATE_REQUEST.ADDRESS_MODE
TI.ZPI2.ZMAC_ASSOCIATE_REQUEST.KEY_ID_MODE
TI.ZPI2.ZMAC_ASSOCIATE_REQUEST.SECURITY_LEVEL
TI.ZPI2.ZMAC_ASSOCIATE_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_ASSOCIATE_RSP.ASSOCIATION_STATUS
TI.ZPI2.ZMAC_ASSOCIATE_RSP.KEY_ID_MODE
TI.ZPI2.ZMAC_ASSOCIATE_RSP.SECURITY_LEVEL
TI.ZPI2.ZMAC_ASSOCIATE_RSP_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_BEACON_NOTIFY_IND.KEY_ID_MODE
TI.ZPI2.ZMAC_BEACON_NOTIFY_IND.SECURITY_LEVEL
TI.ZPI2.ZMAC_COMM_STATUS_IND.ADDRESS_MODE
TI.ZPI2.ZMAC_COMM_STATUS_IND.CMD_STATUS
TI.ZPI2.ZMAC_COMM_STATUS_IND.KEY_ID_MODE
TI.ZPI2.ZMAC_COMM_STATUS_IND.SECURITY_LEVEL
TI.ZPI2.ZMAC_DATA_CNF.CMD_STATUS
TI.ZPI2.ZMAC_DATA_IND.ADDRESS_MODE
TI.ZPI2.ZMAC_DATA_IND.KEY_ID_MODE
TI.ZPI2.ZMAC_DATA_IND.SECURITY_LEVEL
TI.ZPI2.ZMAC_DATA_REQUEST.ADDRESS_MODE
TI.ZPI2.ZMAC_DATA_REQUEST.KEY_ID_MODE
TI.ZPI2.ZMAC_DATA_REQUEST.SECURITY_LEVEL
TI.ZPI2.ZMAC_DATA_REQUEST.TX_OPT
TI.ZPI2.ZMAC_DATA_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_DISASSOCIATE_CNF.ADDRESS_MODE
TI.ZPI2.ZMAC_DISASSOCIATE_CNF.CMD_STATUS
TI.ZPI2.ZMAC_DISASSOCIATE_IND.KEY_ID_MODE
TI.ZPI2.ZMAC_DISASSOCIATE_IND.SECURITY_LEVEL
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST.ADDRESS_MODE
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST.DISASSOC_REASON
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST.KEY_ID_MODE
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST.SECURITY_LEVEL
TI.ZPI2.ZMAC_DISASSOCIATE_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.BOOLEAN
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.KEY_ID_MODE
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SCAN_TYPE
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.SECURITY_LEVEL
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST.ZIGBEE_CHANNELS
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_GET_REQUEST.MAC_PID_ATTR
TI.ZPI2.ZMAC_GET_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_INIT_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_ORPHAN_IND.KEY_ID_MODE
TI.ZPI2.ZMAC_ORPHAN_IND.SECURITY_LEVEL
TI.ZPI2.ZMAC_ORPHAN_RSP.BOOLEAN
TI.ZPI2.ZMAC_ORPHAN_RSP.KEY_ID_MODE
TI.ZPI2.ZMAC_ORPHAN_RSP.SECURITY_LEVEL
TI.ZPI2.ZMAC_ORPHAN_RSP_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_POLL_CNF.CMD_STATUS
TI.ZPI2.ZMAC_POLL_REQUEST.ADDRESS_MODE
TI.ZPI2.ZMAC_POLL_REQUEST.KEY_ID_MODE
TI.ZPI2.ZMAC_POLL_REQUEST.SECURITY_LEVEL
TI.ZPI2.ZMAC_POLL_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_PURGE_CNF.CMD_STATUS
TI.ZPI2.ZMAC_PURGE_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_RESET_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_RX_ENABLE_CNF.CMD_STATUS
TI.ZPI2.ZMAC_SCAN_CNF.CMD_STATUS
TI.ZPI2.ZMAC_SCAN_CNF.SCAN_TYPE
TI.ZPI2.ZMAC_SCAN_REQUEST.KEY_ID_MODE
TI.ZPI2.ZMAC_SCAN_REQUEST.SCAN_TYPE
TI.ZPI2.ZMAC_SCAN_REQUEST.SECURITY_LEVEL
TI.ZPI2.ZMAC_SCAN_REQUEST.ZIGBEE_CHANNELS
TI.ZPI2.ZMAC_SCAN_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_SECURITY_GET_REQUEST.MAC_SECURITY_PID_ATTR
TI.ZPI2.ZMAC_SECURITY_GET_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_SECURITY_SET_REQUEST.MAC_SECURITY_PID_ATTR
TI.ZPI2.ZMAC_SECURITY_SET_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_SET_REQUEST.MAC_PID_ATTR
TI.ZPI2.ZMAC_SET_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_SET_RX_GAIN_REQUEST.BOOLEAN
TI.ZPI2.ZMAC_SET_RX_GAIN_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_START_CNF.CMD_STATUS
TI.ZPI2.ZMAC_START_REQUEST.KEY_ID_MODE
TI.ZPI2.ZMAC_START_REQUEST.SECURITY_LEVEL
TI.ZPI2.ZMAC_START_RESPONSE.CMD_STATUS
TI.ZPI2.ZMAC_SYNC_LOSS_IND.CMD_STATUS
TI.ZPI2.ZMAC_SYNC_LOSS_IND.KEY_ID_MODE
TI.ZPI2.ZMAC_SYNC_LOSS_IND.SECURITY_LEVEL
TI.ZPI2.ZMAC_SYNCHRONIZE_RESPONSE.CMD_STATUS
TI.ZPI2.APP_MSG.BLIND_NODE_CONFIGURATION
TI.ZPI2.APP_MSG.BLIND_NODE_CONFIGURATION_REQUEST
TI.ZPI2.APP_MSG.BLIND_NODE_REQUEST
TI.ZPI2.APP_MSG.REFERENCE_NODE_CONFIGURATION
TI.ZPI2.APP_MSG.REFERENCE_NODE_CONFIGURATION_REQUEST
TI.ZPI2.APP_MSG.REFERENCE_NODE_REQUEST
TI.ZPI2.APP_MSG.ZLMSGID_CLIENT_CMD_REQUEST
TI.ZPI2.APP_MSG.ZLMSGID_CODE_ENABLE_REQUEST
TI.ZPI2.APP_MSG.ZLMSGID_RESET_BOARD_REQUEST
TI.ZPI2.APP_MSG.ZLMSGID_RESET_REQUEST
TI.ZPI2.APP_MSG.ZLMSGID_SEND_DATA_RESPONSE
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_START_RESPONSE
TI.ZPI2.APP_MSG.ZLMSGID_SESSION_TERM_RESPONSE
TI.ZPI2.APP_MSG.ZLMSGID_STATUSQ_REQUEST
TI.ZPI2.APP_MSG_RSP.BLIND_NODE_CONFIGURATION
TI.ZPI2.APP_MSG_RSP.BLIND_NODE_RESPONSE
TI.ZPI2.APP_MSG_RSP.REFERENCE_NODE_CONFIGURATION
TI.ZPI2.APP_MSG_RSP.REFERENCE_NODE_RESPONSE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CLIENT_CMD_RESPONSE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_CODE_ENABLE_RESPONSE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_BOARD_RESPONSE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_RESET_RESPONSE
TI.ZPI2.APP_MSG_RSP.ZLMSGID_SEND_DATA_REQUEST
TI.ZPI2.APP_MSG_RSP.ZLMSGID_SESSION_START_REQUEST
TI.ZPI2.APP_MSG_RSP.ZLMSGID_SESSION_TERM_REQUEST
TI.ZPI2.APP_MSG_RSP.ZLMSGID_STATUSQ_RESPONSE
TI.ZPI2.NLME_NETWORKDISCOVERY_CONFIRMATION.PanInfoItemClass
TI.ZPI2.ZDO_BEACON_NOTIFY_IND.BeaconListItemClass
TI.ZPI2.ZDO_MGMT_BIND_RSP.BindListItemClass
TI.ZPI2.ZDO_MGMT_LQI_RSP.NeighborLqiListItemClass
TI.ZPI2.ZDO_MGMT_NWK_DISC_RSP.NetworkListItemClass
TI.ZPI2.ZDO_MGMT_RTG_RSP.RoutingTableListClass
TI.ZPI2.AF_APSF_CONFIG_SET ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_APSF_CONFIG_SET_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.AF_DATA_CONFIRM ---- TI.ZPI2.IAF, TI.ZPI2.ICONFIRMATION
TI.ZPI2.AF_DATA_REQUEST ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_DATA_REQUEST_EXT ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_DATA_REQUEST_EXT_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_DATA_REQUEST_SRC_RTG_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.AF_DATA_REQUEST_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.AF_DATA_RETRIEVE ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_DATA_RETRIEVE_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.AF_DATA_STORE ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_DATA_STORE_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.AF_INCOMING_MSG ---- TI.ZPI2.IAF, TI.ZPI2.IINDICATION
TI.ZPI2.AF_INCOMING_MSG_EXT ---- TI.ZPI2.IAF, TI.ZPI2.IINDICATION
TI.ZPI2.AF_INTER_PAN_CTL ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_INTER_PAN_CTL_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.AF_REGISTER ---- TI.ZPI2.IAF, TI.ZPI2.IREQUEST
TI.ZPI2.AF_REGISTER_SRSP ---- TI.ZPI2.IAF, TI.ZPI2.IRESPONSE
TI.ZPI2.APP_MSG ---- TI.ZPI2.IAPP, TI.ZPI2.IREQUEST
TI.ZPI2.APP_MSG_RESPONSE ---- TI.ZPI2.IAPP, TI.ZPI2.IRESPONSE
TI.ZPI2.APP_MSG_RSP ---- TI.ZPI2.IAPP, TI.ZPI2.IRESPONSE
TI.ZPI2.APP_USER_TEST ---- TI.ZPI2.IAPP, TI.ZPI2.IREQUEST
TI.ZPI2.APP_USER_TEST_RESPONSE ---- TI.ZPI2.IAPP, TI.ZPI2.IRESPONSE
TI.ZPI2.APSDE_DATA_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION
TI.ZPI2.APSME_BIND_RESPONSE ---- TI.ZPI2.IRESPONSE
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD ---- TI.ZPI2.IDEBUG, TI.ZPI2.IREQUEST
TI.ZPI2.DEBUG_SET_DEBUG_THRESHOLD_RESPONSE ---- TI.ZPI2.IDEBUG, TI.ZPI2.IRESPONSE
TI.ZPI2.DEBUG_STRING ---- TI.ZPI2.IDEBUG, TI.ZPI2.IRESPONSE
TI.ZPI2.IAF
TI.ZPI2.IAPP
TI.ZPI2.ICONFIRMATION
TI.ZPI2.IDEBUG
TI.ZPI2.IINDICATION
TI.ZPI2.INETWORK
TI.ZPI2.IREQUEST
TI.ZPI2.IRESPONSE
TI.ZPI2.IRESPONSE_CALLBACK
TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ISYSTEM
TI.ZPI2.IUTIL
TI.ZPI2.IZDO
TI.ZPI2.IZMAC
TI.ZPI2.MT_UTIL_SYNC_REQ ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.MT_UTIL_ZCL_KEY_ESTABLISH_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.MT_ZDO_MSG_CB_INCOMING ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.NLDE_DATA_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NLDE_DATA_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NLDE_DATA_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLDE_DATA_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLDE_NWK_INIT ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_DIRECTJOIN_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_DIRECTJOIN_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_GET_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_GET_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_JOIN_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_JOIN_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_JOIN_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_JOIN_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_LEAVE_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_LEAVE_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_LEAVE_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_LEAVE_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_NETWORK_FORMATION_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_NETWORK_FORMATION_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_NETWORK_FORMATION_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_NETWORKDISCOVERY_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_NETWORKDISCOVERY_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_NETWORKDISCOVERY_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_ORPHANJOIN_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_ORPHANJOIN_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_PERMITJOINING_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_PERMITJOINING_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_POLL_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_RESET_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_RESET_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_ROUTEDISCOVERY_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_ROUTEDISCOVERY_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_SET_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_SET_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_STARTROUTER_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NLME_STARTROUTER_REQUEST ---- TI.ZPI2.INETWORK, TI.ZPI2.IREQUEST
TI.ZPI2.NLME_STARTROUTER_RESPONSE ---- TI.ZPI2.INETWORK, TI.ZPI2.IRESPONSE
TI.ZPI2.NLME_SYNC_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_ASSOCIATE_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_ASSOCIATE_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_BEACON_NOTIFY_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_COMM_STATUS_INDICATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_DATA_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_DATA_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_DISASSOCIATE_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_DISASSOCIATE_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_ORPHAN_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_POLL_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_PURGE_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_RX_ENABLE_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_SCAN_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_START_CONFIRMATION ---- TI.ZPI2.ICONFIRMATION, TI.ZPI2.INETWORK
TI.ZPI2.NWK_SYNCHRONIZATION_LOSS_INDICATION ---- TI.ZPI2.IINDICATION, TI.ZPI2.INETWORK
TI.ZPI2.SYS_ADC_READ ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_ADC_READ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_GET_TIME ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_GET_TIME_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_GPIO ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_GPIO_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_DELETE ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_DELETE_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_ITEM_INIT_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_LENGTH ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_LENGTH_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_READ ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_READ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_WRITE ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_NV_WRITE_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_START_TIMER ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_START_TIMER_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_STOP_TIMER ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_STOP_TIMER_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_OSAL_TIMER_EXPIRED_IND ---- TI.ZPI2.IINDICATION, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_PING ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_PING_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_RANDOM ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_RANDOM_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_RESET ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_RESET_RESPONSE ---- TI.ZPI2.IINDICATION, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_RPC_ERROR ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_SET_TIME ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_SET_TIME_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_SET_TX_POWER ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_SET_TX_POWER_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_STACK_TUNE ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_STACK_TUNE_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_VERSION ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISYSTEM
TI.ZPI2.SYS_VERSION_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISYSTEM
TI.ZPI2.USERTEST_REQUEST ---- TI.ZPI2.IREQUEST
TI.ZPI2.USERTEST_RESPONSE ---- TI.ZPI2.IRESPONSE
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ADDRMGR_EXT_ADDR_LOOKUP_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ADDRMGR_NWK_ADDR_LOOKUP_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_APSME_LINK_KEY_DATA_GET_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_APSME_LINK_KEY_NV_ID_GET_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_APSME_REQUEST_KEY_CMD_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ASSOC_COUNT ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ASSOC_COUNT_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ASSOC_FIND_DEVICE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ASSOC_GET_WITH_ADDRESS_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_CALLBACK_SUBSCRIBE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_DATA_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_DATA_REQ_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_GET_DEVICE_INFO ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_GET_DEVICE_INFO_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_GET_NV_INFO ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_GET_NV_INFO_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_GET_TIME_ALIVE ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_GET_TIME_ALIVE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_KEY_EVENT ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_KEY_EVENT_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_LED_CONTROL ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_LED_CONTROL_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_LOOPBACK_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_CHANNELS ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_CHANNELS_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_PANID ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_PANID_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_PRECONFIG_KEY ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_PRECONFIG_KEY_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_SECURITY_LEVEL ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SET_SECURITY_LEVEL_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_ACK_ALL_PENDING_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_ADD_ENTRY_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_CHECK_ALL_PENDING_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_CHECK_SRC_ADDR_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_DELETE_ENTRY_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_ENABLE ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRC_MATCH_ENABLE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRNG_GEN ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_SRNG_GEN_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_TEST_LOOPBACK ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ZCL_KEY_EST_INIT_EST_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN ---- TI.ZPI2.IREQUEST, TI.ZPI2.IUTIL
TI.ZPI2.UTIL_ZCL_KEY_EST_SIGN_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IUTIL
TI.ZPI2.ZB_ALLOW_BIND ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_ALLOW_BIND_CONFIRM ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_ALLOW_BIND_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_APP_REGISTER_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_APP_REGISTER_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_BIND_CONFIRM ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_BIND_DEVICE ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_BIND_DEVICE_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_FIND_DEVICE_CONFIRM ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_FIND_DEVICE_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_FIND_DEVICE_REQUEST_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_GET_DEVICE_INFO ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_GET_DEVICE_INFO_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_PERMIT_JOINING_REQUEST_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_READ_CONFIGURATION ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_READ_CONFIGURATION_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_RECEIVE_DATA_INDICATION ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_SEND_DATA_CONFIRM ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_SEND_DATA_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_SEND_DATA_REQUEST_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_START_CONFIRM ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_START_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_START_REQUEST_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_SYSTEM_RESET ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_WRITE_CONFIGURATION ---- TI.ZPI2.IREQUEST, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZB_WRITE_CONFIGURATION_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.ISIMPLEAPI
TI.ZPI2.ZDO_ACTIVE_EP_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_ACTIVE_EP_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_ACTIVE_EP_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_AUTO_FIND_DESTINATION ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_BEACON_NOTIFY_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_BIND_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_BIND_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_BIND_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_COMPLEX_DESC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_COMPLEX_DESC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_COMPLEX_DESC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_ANNCE ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_ANNCE_IND ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_ANNCE_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_BIND_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_BIND_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_END_DEVICE_TIMEOUT_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_GET_LINK_KEY ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_GET_LINK_KEY_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_IEEE_ADDR_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_IEEE_ADDR_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_IEEE_ADDR_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_JOIN_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_JOIN_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_JOIN_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_LEAVE_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MATCH_DESC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MATCH_DESC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MATCH_DESC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MATCH_DESC_RSP_SENT ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_BIND_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_BIND_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_BIND_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_DIRECT_JOIN_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_LEAVE_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_LEAVE_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_LEAVE_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_LQI_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_LQI_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_LQI_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_NWK_DISC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_NWK_DISC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_NWK_UPDATE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_PERMIT_JOIN_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_RTG_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_RTG_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MGMT_RTG_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MSG_CB_REGISTER ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MSG_CB_REGISTER_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MSG_CB_REMOVE ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_MSG_CB_REMOVE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NODE_DESC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NODE_DESC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NODE_DESC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NWK_ADDR_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NWK_ADDR_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NWK_ADDR_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NWK_DISCOVERY_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_NWK_DISCOVERY_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_POWER_DESC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_POWER_DESC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_POWER_DESC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_REMOVE_LINK_KEY ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_REMOVE_LINK_KEY_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SERVER_DISC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SERVER_DISC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SERVER_DISC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SET_LINK_KEY ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SET_LINK_KEY_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SIMPLE_DESC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SIMPLE_DESC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SIMPLE_DESC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_SRC_RTG_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_STARTUP_FROM_APP ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_STARTUP_FROM_APP_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_STATE_CHANGE_IND ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_STATUS_ERROR_RSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_UNBIND_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_UNBIND_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_UNBIND_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_USER_DESC_CONF ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_USER_DESC_REQ ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_USER_DESC_REQ_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZDO_USER_DESC_RSP ---- TI.ZPI2.IRESPONSE_CALLBACK, TI.ZPI2.IZDO
TI.ZPI2.ZDO_USER_DESC_SET ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZDO
TI.ZPI2.ZDO_USER_DESC_SET_SRSP ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZDO
TI.ZPI2.ZLL_TOUCH_LINK_INDICATION ---- TI.ZPI2.IAPP, TI.ZPI2.IINDICATION
TI.ZPI2.ZMAC_ASSOCIATE_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ASSOCIATE_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ASSOCIATE_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ASSOCIATE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ASSOCIATE_RSP ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ASSOCIATE_RSP_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_BEACON_NOTIFY_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_COMM_STATUS_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DATA_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DATA_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DATA_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DATA_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DISASSOCIATE_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DISASSOCIATE_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DISASSOCIATE_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_DISASSOCIATE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ENHANCED_ACTIVE_SCAN_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_GET_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_GET_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_INIT_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_INIT_RESPONSE ---- TI.ZPI2.IRESPONSE
TI.ZPI2.ZMAC_ORPHAN_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ORPHAN_RSP ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_ORPHAN_RSP_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_POLL_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_POLL_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_POLL_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_PURGE_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_PURGE_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_PURGE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_RESET_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_RESET_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_RX_ENABLE_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SCAN_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SCAN_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SCAN_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SECURITY_GET_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SECURITY_GET_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SECURITY_SET_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SECURITY_SET_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SET_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SET_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SET_RX_GAIN_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SET_RX_GAIN_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_START_CNF ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_START_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_START_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SYNC_LOSS_IND ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SYNCHRONIZE_REQUEST ---- TI.ZPI2.IREQUEST, TI.ZPI2.IZMAC
TI.ZPI2.ZMAC_SYNCHRONIZE_RESPONSE ---- TI.ZPI2.IRESPONSE, TI.ZPI2.IZMAC

See Also

TI.ZPI2 Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace